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What's New in VRED Products 2019.3 
These are the new features, improvements, and known issues found in VRED 2019.3 products: 

New Features and Enhancements 

• Substance materials are now supported in VRED 

 

• Alias Switch Materials are now supported in VRED 
• Varjo HMD is now supported in VRED 



• 3D speech communication has been integrated into the Collaboration module 
• Transparent Cutouts are now supported 

 

• The range of photometric parameters match that of the non-photometric mode 
• An optional parameter was added to findNode to restrict its search to a given sub-tree 
• Automatic detection of the active StarVR SDK was added 
• The environment variable VRED_SERVICE_PAGE was added to set up the cluster service 

web interface 

Fixed Issues 

• Rendering: Images appear as expected when rendering animations in .hdr format 
• Rendering: Exported PSB files can be opened in Photoshop 
• Rendering: IES lights in Photometric parameter mode provide the expected rendered 

result. 
• Rendering: Luminance and illuminance rendering occur as expected when photometric 

parameters are off 
• Rendering: Activating Use Light Profile without an IES light profile loaded works as 

expected 
• Rendering: The correct intensities are supplied when Export to TIFF/PSD in HDR is 

enabled with Photometric Parameters 
• Rendering: Rendering HDR environments with very high dynamic ranges now provides 

the expected results 
• Rendering: When using 16-bit bump maps, materials reflections no longer display 

banding artefacts 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Collaboration_About_the_Collaboration_Module_html


• Measurements: Unwanted wireframe object no longer appear when using point to 
object measurements 

• Navigation: When setting a new pivot point with active collision detection, Trackball 
navigation is smooth 

• Cluster: Improved navigation responsiveness when waking up the RT Cluster from 
Antialiasing 

• Cluster: Fixed background color with Export Alpha Channel and Premultiply Alpha 
activated 

• Cluster: Added the environment variable VRED_SERVICE_PAGE to enable/disable the 
web interface provided by the cluster service (http://localhost:8889) 

Environment Variable Function 
VRED_SERVICE_PAGE=0 Disables the Service page 
VRED_SERVICE_PAGE=1 Makes only the version number and 

status visible on the Service page 
VRED_SERVICE_PAGE=2 Makes the interactive Service page 

visible. This is the default 

• Scripting: HTML script injection in VRED web interface 
• Scripting: HTML script injection in VRED cluster service web interface 
• FileIO: Constant Radius Blend surfaces appear as expected during conversion of a CATIA 

file 
• FileIO: Fixed parsing of PLMXML files leading to lower memory consumption 
• Raytracing: Environment light source intensity acts as expected when photometric 

parameters are active 
• Raytracing: Using a spectrum in RGB raytracing mode provides the correct area light 

color 
• Raytracing: Artefacts no longer appear on object edges when using the illuminance 

tonemapper 
• Raytracing: IES Profiles for spherical lights are supported in raytracing 
• Raytracing: Transparency appears as expected for raytraced see-through colors 
• General: Variant sets are no longer missing after closing the Data collection and use 

dialog 
• Collision Detection: Box colliders rotate as expected 
• Scripting: Reopen a Catia Product file using load() without issues 
• UI: Opaque Distance and Transparent Distance tooltips have been corrected 
• UI: The correct tooltips appear for avatar fading distance settings 
• UI: After undoing a deleted camera, the camera reappears in the Scene Graph 
• OpenGL: Parallax Mapping artefacts have been fixed (Bump Type Bump Mapping with 

Parallax Intensity > 0) 
• KOR/JPN/CHS: The unlocalized string Quick Actions is displayed when right-click the 

mouse at the top menu area in the Material Editor 
• Geometry Editor: Fixed crash when using Calculate Normals in Raytracing for geos with 

anisotropic or displaced material 



Known Issues and Workarounds 

• Substance Material Output Size Issue - The Unlock/Lock state of the preference, Default 
Output Size, doesn't match that of the substance parameter, Output Size. 

• Collaboration Session Issue - Workstations with both VRED Pro and Design installed 
cannot be the host of a collaboration session. 

• Workaround: 
 

1. Only install either VREDPro or VRED Design on the PC. 
2. Adjust the firewall rule. 
3. Manually call VREDClusterService -e -c once. 



User Interface 



About the Standard and Simple User Interfaces 
VRED has two user interfaces: 

• A standard user interface that includes all VRED functionality. 
• A simple user interface that includes a smaller, basic set of functionalities for casual 

users who are not familiar with visualization tools. 

VRED Professional Standard UI 

 

1 Menu Bar includes all main functions for creating and editing VRED content. You can access 
available VRED modules and enable basic file actions, like saving and opening. 

2 Icon Bar provides shortcuts to access common features for saving a scene, toggling raytracing 
mode, or switching between simple and standard UI. 

3 Scene Graph lists all nodes in the scene. 

4 Viewport displays the whole scene. You can change the view, as well as select and modify 
objects directly. 

5 Quick Access Bar provides easy, fast access to main functions, such as the Material Editor, 
Clip Maker, and Variants. 



6 Status Bar provides information about memory usage. You can change the up vector, near 
and far clip planes, and field-of-view. It also integrates the Terminal. 

7 Object properties (available in Simple UI mode) offers quick access to common properties for 
the selected object, such as position, pre-calculated shadows, and normal settings, which affect 
shading within the OpenGL Render Window. 

VRED Professional Simple UI 

 

1 Menu Bar includes all main functions for creating and editing VRED content. You can access 
available VRED modules and enable basic file actions, like saving and opening. 

2 Icon Bar provides shortcuts to access common features for saving a scene, toggling raytracing 
mode, or switching between simple and standard UI. 

3 Scene Graph lists all nodes in the scene. 

4 Viewport displays the whole scene. You can change the view, as well as select and modify 
objects directly. 

5 Quick Access Bar provides easy, fast access to main functions, such as the Material Editor, 
Clip Maker, and Variants. 

6 Status Bar provides information about memory usage. You can change the up vector, near 
and far clip planes, and field-of-view. It also integrates the Terminal. 



Switching Interfaces 
In VRED, switch interfaces from the standard to simple is easy. At the far right you will see the 
Simple UI button. Click it to switch from the standard interface to the simple one. 

 

When Simple UI is selected: 

• The Simple UI button is highlighted orange. 
• The Quick Access Bar will only have buttons for common modules and settings only. 

 

• All modules and dialog boxes are simplified. 
• The scene module is selected by default. 

 



About the VRED Toolbar 
There are two toolbars in the main VRED Window, the main toolbar and Quick Access Bar. 

The VRED Toolbar 

Below the menu bar is the VRED main toolbar. The main toolbar is composed of an assortment 
of smaller toolbar. These can be dragged into various locations along the top of the VRED 
application window. 

 

To customize the toolbar further, use the View > Toolbars menu options. When you select View 
> Toolbars and uncheck options in this menu, they are removed from the main toolbar. To add 
them back, place checks beside their names in the View > Toolbars menu. 

 

 

The UI mode you are in, standard or simple, will also determine the tools you see. Standard UI 
mode contains all the icons; however, the size of your window determines whether all are 

visible or not. Whenever you see , this means there are hidden icons in this group. If working 
with a narrow screen, either open the window to full size or grab and reposition the icon 
groupings, as shown above. View > Toolbars is only available in standard UI mode. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_User_Interface_About_the_Quick_Access_Bar_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=About-the-Standard-and-Simple#vred-professional-simple-ui


• File - Contains the following options: 

o  New - Creates a new scene file with four camera views and a default 
environment. The existing scene is destroyed. 

o Open - Opens only VRED files, such as .vpb, .vpe, and .vpf. The existing 
scene is destroyed. To load other file types into VRED, use File > Import or File > 
Import Scene Data. 

o Import - Loads supported files types into the current scene, merging the 
geometry with the scene. Adding a VRED scene opens a dialog box for choosing 
whether to merge variants, touch sensors, sequences, or environments. 

o Save - Saves the current scene. 
 

• Render Options - Contains the following options: 
 

o Antialias - Activates stillframe antialiasing in the Viewport. Keep mouse 
button pressed for further options: 
 

 Enable Downscale Antialiasing (configuration settings from the 
downscale button are used for calculation) 

 Enable Raytraced Antialiasing 
 

o  Raytracing - Turns on raytracing in the Viewport. 
o Downscale - Controls the calculation of the raytracing and therefore the 

quality of the raytracing inside the Viewport. Keep the mouse button pressed for 
further options: Off, Low, Medium, and High. 

o Region - Holds the R key and drag in the Viewport to generate a region. Only 
this region is updated within the Viewport when antialiasing and raytracing are 
activated. 

o  Isolate - Hides everything except the selected object. 
o Backplate - Uses a background image in the Viewport. Keep the mouse 

button pressed for further options: 
 

 Create Backplate - Selects a backplate image. 
 Delete Backplate - Deletes the backplate from the Viewport. 

 

o Wireframe - Applies a wireframe to all selected objects. 
o Boundings - Shows or hides a bounding box for the selected object. The 

bounding box is an orange cube that frames the selection. 
o   Headlight - Enables or disables the headlight in the scene. 
o  Statistics - Opens a window displaying information, such as Frames per 

Second (FPS), Triangles drawn displayed, and more. 



• View - Contains the following options: 
 

o  Fullscreen - Enables fullscreen mode. Keep the mouse button pressed for 
an option to enable multi-display fullscreen. Press Esc to deactivate it. 

o  Presentation - If enabled, only the hotkeys from the variants module are 
available. 

o Show all - Zooms out so all objects inside the Scene Graph are visible inside 
the Viewport. 

o Zoom To - Zooms to the objects selected in the Scene Graph. 
o Grid - Shows or hides a grid for measurements that can help to identify 

geometry proportions. Keep the mouse button pressed for further options: 
 

 xy/xz/yz - Changes the orientation of the grid. 
 Show Labels - Shows or hides the measurement values within the grid. 
 Settings - Opens a dialog box to adjust grid size and subdivision. 

 

o  Ruler - Shows or hides a ruler on the floor to help with estimating 
distances. 

o Show Manipulator - Enables a transformation and rotation manipulator for 
positioning the grid within the scene. Shift-click to position the ruler on a 
geometry point. 

o Show Grid - Shows a grid with the ruler. 
o Fix Axes - If disabled (default), the ruler scale markings and the grid adapt to the 

distance of the camera and the ruler origin. If Fix Axes is activated, the scale and 
grid remain static during camera movement. 

o Transform - Shows a transform manipulator in the Render Window to 
reposition the selected geometry. Keep the mouse button pressed for further 
options: 

o Local Mode - If enabled, the translation manipulator is oriented by the local 
coordinate system of the object. 

o Use Fixed Steps - Enables only full numerical transformation/rotation/scales. 
During manipulation, the relative translation/rotation/scale values snap to a 
multiple of the step size defined in the Preferences Transform. 

o Size - Shows a control for changing the size of the transformation tool. 
o Translation, Rotation, or Scale Manipulator - Shows these specific manipulators. 
o Universal Manipulator - Do any type of manipulation. 
o Pivot Transform Manipulator - Repositions the pivot point of the selected 

object. 
 
 
 



• Interaction - Contains the following options: 
 

o  Selection - Sets what can be selected. Choose from Component, Object, 
Group, By Material, or Adjacency. If Adjacency is selected, use the Adjacency 
Settings to select the method used, Picked Normal or Neighbor Normal, and set 
the angle. 

o  Texturing - Toggles the ability to change the texture mapping settings on a 
selected object. Can be used for UV mapping, planar, triplanar, and tire 
projection. When Texturing Mode is activated, Shift-click in the Render Window 
to open the appropriate texture manipulator to select the texture. 

o Planar Projection Manipulator - Changes the visibility of the planar projection 
plane when using a decal image. Adjust Opacity from 0 (not visible) to 1 (fully 
visible). 

o Cylinder Opacity - Used for tires. 
 

• Synchronization - Contains the following two options: 
 

o  Connect 
o  Cluster 

 
• Mode - Contains the Simple UI option: 

 

o  Simple UI - Toggles between the standard full UI and a simplified subset of 
the UI. 



About the Quick Access Bar 
The Quick Access Bar is just below the Viewport. As mentioned above, it has two states, 
standard and simple UI. A different set of icons is displayed, depending on the which state you 
are in. 

Standard UI mode 

These are the icons you will see when in Standard UI mode. 

• Graph - Opens the Scene Graph. 

• Transform - Opens the Transform module. 

• Materials - Opens the Material Editor. 

• Cameras - Opens the Camera Editor. 

• Clips - Opens the Clip Maker. 

• Curves - Opens the Curve Editor. 

• VSets - Opens the Variant Sets module. 

• Render - Opens the Render Settings. 

Simple UI mode 

These are the icons you will see when in Simple UI mode. 

•  Assets - Opens the Asset Manager, which contains tabs for loading geometry, 
materials, and environments. 

• Scene - Opens the Scene module, which contains tabs for the Scene Graph, 
Materials, Environments, Camera, Lights, and Settings. Some of these tabs will also have 
their own Properties section. 

• Animation - Opens the Clip Maker. 

• Variants - Opens the Variant Sets module. 

• Render - Opens the Render Image module. 

http://help.autodesk.com/cloudhelp/2019/ENU/VRED/files/User-Interface/Switching-Interfaces.htmlGUID-0B9EE0D3-3760-4204-AF09-B5B07D82C200


About the Status Bar 
The Status Bar is found at the bottom of the VRED application window. It provides information 
about memory usage. Change the up vector, as well as near and far clipping planes and the field 
of view. 

 

1. Info: Size of the scene, id, and resolution of the current Viewport. 
2. Terminal: Quick access button to enter the terminal module and field that shows the 

last entry in the terminal window. 
3. Connector: Quick access button to open the Connector module. 
4. Units: Defines the mapping of the scene units to a physical unit of length. Values are 

mm, cm, and m. 
5. Up: Sets the axis of the up vector. Values are: Z and Y. 
6. NCP: Defines the distance of the near clip plane. 
7. FCP: Defines the distance of the far clip plane. 
8. FOV: Sets the field of view in degree. 
9. ICV: Saves the current view as the initial camera view. 



Working with Modules in the Application 
Window 
How to close, dock and undock a module, and prevent a module from docking when you move 
it. 

Modules are the windows that appear when you select one of the options, such as Graph or 
VSets, in the Quick Access Bar. Modules can float outside of the VRED application window (the 
area that surrounds the Viewport) or be docked within the it. Modules can also be undocked. If 
finished with a module, close it. 

See how to dock and undock a module and prevent a module from docking when you move it, 
and close one when done with it. 

What are Modules 

Modules are the windows that appear when you select options from some of the menus or the 
Quick Access Bar, such as Graph or VSets. They tend to contain things like an Icon Bar at the 
bottom, menus, a tree view, and parameters. 

For docking and undocking, use the interface elements are found in the upper right corner. 

 



How to Dock and Undock a Module 

 

Do either of the following: 

• At the top right of a module, click the arrow button  to dock it. 
• Drag the title bar of the module to the Viewport's outer edge. The Viewport adjusts to 

make room for the module. When the mouse button is released, the module is docked. 

To undock a module, drag the title bar away from the Viewport's edge or click . 

How to Prevent a Module from Docking When Moving it 

At the top right of a module, click the orange D button  to deselect docking. The button 

color changes to gray . This will prevent it from docking, while moving the module. 

How to Close a Module 

To close a module, at the top right of a module, click . 



Customizing Controls and Display 
Customizing controls and your display is possible using an assortment of tools. 

How to Adjust the VRED Display 

In the Menu Bar, select View > Display, then a display setting that is appropriate for the device 
you are using: 

NOTE If the View option is not displayed, at the far right of the Icon Bar, turn off Simple UI. 

• Powerwall Settings - Opens the Powerwall Settings Editor. 
 

o Width and Height - Sets the dimensions of the projection window. 
o Distance - Sets the distance between the projection window and viewer. 
o Enable Powerwall Mode - Activates Powerwall rendering. 

 
• Standard Display - Encodes the rendered image to be displayed on a standard display. 
• SIM2 HDR - Encodes the rendered image to be displayed on an HDR display. 
• Sony 10bit - Encodes the rendered output image with 10-bit color depth. 
• Oculus Rift - Generates output images optimized for Oculus Rift devices. 
• OpenVR HMD - Enables head mounted VR devices to connect to VRED via the OpenVR. 

How to Split the View 

Splits the Viewport into perspective, front, side, and top views. 

• In the Menu Bar, select Window > Show Split View. 

NOTE If the View option is not displayed, at the far right of the Icon Bar, turn off Simple UI. 

How to Return to a Single Display 

To return to a single display view, in the Menu Bar, click Window > Show Single View to display 
single view. The last active window, indicated by a white border, will become the single view. 

NOTE For a shortcut to toggle between split view and single view, use Ctrl + Space Bar. 

 



How to Show or Hide Toolbars 

Select which toolbars are visible in the main VRED window. Show or hide tools. 

In the Menu Bar, select View > Toolbars, then select one or more options. 

• When checked, the tools in that toolbar appear in the main VRED toolbar. 

 

• When unchecked, the tools in that toolbar will be removed from the main VRED toolbar. 

 

NOTE If the View option is not displayed, at the far right of the Icon Bar, turn off Simple UI. 

How to Identify Stereo Output Channels 

In the Menu Bar, select View > Stereo Identification. A letter appears in the Viewport. 

 

NOTE If the View option is not 
displayed, at the far right of the 
Icon Bar, turn off Simple UI. 

 



How to Show Scene Elements and Controls 

In the Menu Bar, from the View menu, select the appropriate option. 

• Show A Sides, Show B Sides, Show A and B Sides - Faces in 3D data can be defined as an 
A or B side. Use these options to select which faces to show. More options are available 
in the Scene Graph View menu. 

• Show Cameras - Shows or hides all cameras. 
• Show Lights - Shows or hides all lights. 
• Show Camera Pivot - The point that the camera rotates around is displayed within the 

Viewport during camera rotation. 
• Show Annotations - Shows annotations (notes) that were created under Interaction > 

Annotation. 

NOTE If the Annotation window is open, another way to turn an annotation on or off is 
by clicking . 

• Show Clipping - Shows the clipping plane created under Interaction > Clipping. 
• Show Grid - Shows the scene grid in the Viewport. This provides a grid (axis) on the floor 

that helps with estimating distances. 
• Show Measurement - Shows measurements created under Interaction > Measurement. 
• Show Ruler - Shows the ruler in the scene. 
• Show Manipulator - Shows the transform manipulator. 
• Show Routes - Opens a new window and displays all VRML animation routes in the 

scene. 
• Show Shortcuts - Opens a new window and displays all available VRED shortcuts. 

How to Show or Hide Selected Content 

To show or hide everything that is 
currently selected, in the Menu 
Bar, select Visualization > Isolate 
View Selected. This adds an 
Isolate View (name of the 
selected node) label to the 
Viewport. Visibility of 
environments and backplates is 
not affected. In previous versions 
of VRED, this feature was 
available by dragging a node from 
the Scene Graph into the 
Viewport. 



How to Show a Simulation of a Scene 

In the Menu Bar, select Visualization > Simulate. This starts the simulation loop to control 
animations, interactive scripts, viewpoint interpolations, and other functions. 



Files and Data 



Adding Files to Scene 
Learn how to load files into VRED. 

When adding files to scene, you need to take into consideration the file type. VRED supports an 
assortment of file formats and types. Before adding files to VRED, consult the section below. 

Support File Formats and Types 

Many types of files can be imported and added to VRED scenes. Try other VRED scenes, XML or 
Python files, and files created by other applications, such as 3ds Max. When importing, if there 
is an issue with the import, you can abort it at any time during the process. 

Here is a list of supported file formats and types: 

• CAD: .apf, .asm, .catpart, .catproduct, .cgr, .dlv, .dlv3, .dlv4, .dwg, .dwf, .dxf, .exp, .g, 
.iam, .iges, .igs, .ipt, .jt, .mdl, .model, .neu, .prt, .session, .sldasm, .sldprt, .step, .stp, 
.wire 

• Cosmo Binary: Cosmo3D/Optimizer Geometry .csb, Deltagen Geometry .rtx, Deltagen 
Animations .wrl, Deltagen Variants .xml 

• PLM XML: Imports product structure files with .plmxml file format. 

Maya Files 

Maya .ma and .mb files can be added to a scene; however, not everything in the scene may be 
supported. A lot of Maya data that cannot be loaded into VRED. Therefore, .ma and .mb files 
should be avoided. We recommend you use FBX (the recommended exchange format between 
Maya and VRED), as it is superior to .ma and .mb. 

If you still are hoping to load .mb files into VRED, here's a list of what is supported. All other 
things, such as animation, rigging, and skinning, will be lost. 

Where in VRED What comes through 

Scene Graph Node Names, Transformations, Rotations, Scaling 

Lights Directional Lights, Point Lights, Spot Lights, Area Light 

Materials 
Material Names, Diffuse Color, Glossy/Specular Color, Incandescent 
Color, Transparency 



Alias Files 

When importing Alias files, first unify all the surface normals to face the camera in Alias. Set 
Visual normals, rather than Geometric normals, to avoid disturbing the history of the model. 

CAD Files 

When working with CAD files, import multiple files in one shot. In the Import File(s) dialog, you 
will see the imported CAD files listed. 

 

Showcase Files 

Showcase files are not supported in VRED 2018 and beyond. You can open a Showcase file in a 
version of VRED before 2018, save the file as a .vpb, then open in VRED 2018 or later. 

How to Add a File to a Scene 

1. Optional: Select a node in the Scene Graph below where you want to add the file or 
animation. 

2. In the Menu Bar, select File > Import. 
3. Select one or more files to add them to the scene and click Open. 
4. Click Import. 

The file or files are added to the Scene Graph as child nodes of the selected node. 



 

If no node was selected in the Scene Graph, the objects are added as children of the 
root node. 

 

All objects of an added file are grouped in a group node. Imported files are marked 
green in the Scene Graph. 

 



How to Add an Animation to a Scene 

You can add VRML animations to a scene, provided they include the objects being animated. 

1. In the Menu Bar, select File > Import Scene Data > VRML Animation. 
2. Select an animation to add to the scene. 
3. Click Open. 

How to Import Information to a Scene 

You can import various file types and meta information to a scene. 

1. In the Menu Bar, select File > Import Scene Data. 
2. Select the type of information you want to import, then click Open: 

 
o CSB Animation/Variants - Imports .csb animation or variant files into the current 

scene. 
o Render Jobs - Imports jobs from the Render module into the current scene. (XML 

Render Queue Description .xml) 
o Rendering Meta Data - Imports images rendered with VRED (.png, .jpg, .tiff, .exr) 

containing scene settings, embedded as meta data in the Rendering Meta Data. 
These settings are applied to the loaded scene. 

o Sequences - Imports arrangements from the Sequencer module into the current 
scene (XML Sequencer Description .xml). A sequence setup for the Sequencer 
module can be added to the scene. 

o Variants - Imports variants from the Variant Sets module into the current scene 
(XML Variant Description .xml). A variant setup for the Variants and VariantSets 
module can be added to the scene. 



About the Import Files Dialog 
Use File > Import to access Import Files and Edit > Preferences > FileIO to change its 
preferences. 

Select File > Import, then one or more files to access the Import Files dialog. Use Import Files 
(formerly Import Options) to set parameters of imported files for tessellation and scene 
location. Only options specific to the file format appear. Get file type, size, current import state, 
and file conversion process information. 

The Import Files Dialog 

Import Files consists of two areas, the Import File List on the left and the File Type Parameters 
on the right. Drag and drop files into the Import File List or add them using the Add button. 
Select a file from the list, then click File Type and select the file type associated with your 
selection. This loads import parameters for that specific file type. 

 



Import File List 

Once the Import Files dialog opens, the files for import appear on the left. Drag and drop more 
files and folders into the list. Check the State column to see if they have been added, are 
pending or loading, have been successful, or failed. 

 

Use the right-click menu to add or remove files from the imported file list. Use other right-click 
options to show a file location in an explorer window or view the import logs. 

 



File Type Parameters 

When you select a file in the Import File List, parameters appear to the right; however, to load 
parameters for your selections, select File Type, then the selected file's file type. This loads the 
correct import parameters specific to that file type. 

 

Enable and set the parameters you want. Use the Shared CAD Options > Mode option to batch 
convert CAD to OSB without loading files into VRED and ATF to import native Rhino .3dm files. 
Features like surfaces, meshes, curves, etc. are supported. 

Once you click Import, you can check the state of files during import. In the State column, check 
the status of the importing. Messages like importing, converted, merged, and stitched appear 
to indicate the current ATF (Autodesk Translation Framework) conversion state. Since logfiles 
tracks several ATF tasks, during import, these need more time. 

Shared CAD Options 

• Mode - Sets what to do with CAD files. Batch convert them to OSB without loading them 
into VRED. 
 

o Import - Imports the file into the scene; however, any conversion data is 
removed. 

o Import & Keep Files - Import the file into the scene and keeps the conversion 
data in the specified File Output folder. 

o Convert - Converts only the files, then stores the data in the specified File Output 
folder. Nothing is imported into the VRED scene. 
 

• Max Parallel Processes - Chooses the number of imports VRED can perform 
simultaneously. Define the maximum number of parallel file conversion processes, 
based on your machine's the number of CPU cores. Depending on the type of data, 
there are times when more processes are faster; however, these extra processes use 
more memory. 



• File Output Path - Sets the output path for the shared CAD options. Click the icon to 
browse to the output location. 

Import Options 

• Surface - Sets the type of surface data imported into the scene. 
 

o Import none- Excludes all surface data from import. 
o Import visible - Imports only visible surface data. 
o Import all - Imports all visible and invisible (hidden) surface data. 

 
• Meshes - Sets the type of mesh data imported into the scene. 

 
o Import none - Excludes all mesh data from import. 
o Import visible - Imports only visible mesh data. 
o Import all - Imports all visible and invisible (hidden) mesh data. 

 
• Curves and Polygon Lines - Sets the type of curve and polygon line data imported into 

the scene. 
 

o Import none - Excludes all curve and polygon line data from import. 
o Import visible - Imports only visible curve and polygon line data. 
o Import all- Imports all visible and invisible (hidden) curve and polygon line data. 

Tessellation 

• Tessellation Quality - Defines preset values for Chord Deviation, Normal Tolerance, and 
Max Chord Length. 
 

o Coarse - (1.0–30.0 - 400.0) 
o Low - (0.15–20.0 - 300.0) 
o Medium - (0.075–10.0 - 200.0) 
o High - (0.0375–7.5 - 100.0) 
o Custom - Custom quality values. 

 
• Chord Deviation - Shows the tolerance of the distance from the NURBS surface to the 

tessellated surface in mm. Lower values result in more accurate polygon models, but 
also increase the number of triangles. 

• Normal Tolerance - Displays the normal tolerance of adjacent triangles in degrees. 
Lower values result in more accurate polygon models, but also increase the number of 
triangles. 

• Max Chord Length - Displays the maximum length of a triangle edge in mm. Lower 
values result in more accurate polygon models, but also increase the number of 
triangles. 



• Enable Stitching - Enables stitching of adjacent edges. 
• Stitching Tolerance - Displays the tolerance in mm that controls when adjacent edges 

are stitched together. 

Advanced Options 

• Keep Surface Data - Keeps NURBS data after tessellation, rather than deleting it. Allows 
for re-tessellation later or for direct NURBS rendering. However, more memory is used. 

• Unify Surface Normals - Ensures all surface normals point in the same direction. Only 
available when Import File(s) > Import Options > Surfaces is set to either Import visible 
or Import all. 

• Merge Geometries - Merges the geometries to create one single (stitched) mesh, since 
a single shell can have many NURBS surfaces. If not checked, the result is one mesh per 
surface. 

• Create Groups for Layers - Organizes items originally organized in layers, for example, in 
Autodesk Alias, into groups; otherwise, the objects are placed under the same parent 
node. 

• Remove Empty Groups - Removes group nodes without children. 
• Unshare Nodes - Converts shared node instances are into independent nodes. When 

selected, more memory is consumed. 
• Flush Transformations - Resets the transformations of each node. Transformation 

values are flushed to the vertices. If, for example, a node has been moved 100 mm in 
the X direction, flushing the transformations leaves the node where it is, but changes 
the X value from 100 to 0. 

File Specific Options 

• Import Associative Meshes - Imports data associated with your meshes, rather than 
excluding it. 

• Import Invisible Instances - Imports invisible (hidden) instance data, rather than 
excluding it. 

• Import Referenced Files - Toggles the import of all part files and sub-assemblies 
referenced by the assembly file on or off. When disabled, only the structural 
information, not geometry will appear in the Scene Graph. All sub-assemblies will be 
imported, but the part files will be represented by a group node. To avoid loading a very 
large external data set, deselect this option. 

Global Scene Options 

• Apply Materials from Asset Manager - Replaces imported materials with similar 
materials from the Asset Manager. Click the icon to the right to access the Asset 
Manager. 

• Center in Origin - Places imported geometry in the center of the VRED environment. 
• Put onto the Ground - Places imported geometry on the ground plane. 



• Import Animations - Imports animations contained within the file. 

Project Merge Options 

Select the elements to import or merge. 

• Import Variants - Imports variant data, rather than excluding it. 
• Import Touch Sensors - Imports touch sensors, rather than excluding them. 
• Import Sequences - Imports sequences, rather than excluding them. 
• Import Animations - Imports animations, rather than excluding them. 
• Import Clips - Imports clips, rather than excluding them. 
• Import Annotations - Imports annotations, rather than excluding them. 
• Merge Materials - Compares the materials of both scenes and eliminates duplicates. 
• Environments - When merging environments, there are four options: 

 
o Use From Scene - Uses the existing environments from the current scene 

remain. Environments from the imported file are only added if they directly 
reference a material in the common tab of the Material Editor. Added materials, 
using the default environment switch from file, use the existing scene 
environment default switch. 

o Use From File - Adds environments from the file and removes environments 
from the existing scene (unless the existing environments directly reference a 
material in the common tab of the Material Editor.) Otherwise, all materials use 
the new environments. 

o Add From File - Adds the environments switch (from the file) as a new switch to 
the scene and maintains the default switch. All materials keep their environment 
assignment. 

NOTE This may result in duplicate environments and switches. 

o Merge - Adds the child environments of the default environment switch to the 
existing default environment switch. Duplicates are excluded. When merging 
projects, viewpoints are preserved. 

Alias 

Use the Alias import options to specify whether to include or exclude items from the imported 
file. 

• Import Template Geometries - This feature is only for Alias wire files. Imports all 
template geometry, rather than excluding it. 

• Import Cameras - This feature is only for Alias wire files. Imports all cameras, rather 
than excluding them. 



• Import Lights - This feature is only for Alias wire files. Imports all lights, rather than 
excluding them. 

• Import Variants - This feature is only for Alias wire files. Imports all variants, rather than 
excluding them. 

• Max Parallel Import Tasks - Sets the maximum number of import tasks. Changing this 
value increases memory usage. 



Optimizing, Saving, and Publishing a Scene 
Before saving, exporting, and publishing a scene, why not optimize your scene. Optimizing a 
scene speeds up rendering and lowers memory use. 

How to Optimize a Scene 

Imported FBX files are automatically scene optimized. 

NOTE We highly recommend against loading .ma and .mb file into VRED. Instead, we suggest 
the use of .fbx. 

1. In the Menu Bar, select File > Optimize Scene. 

 

2. Click Optimize Options and select one of these optimization options: 
 

o Optimize Geometries: Optimizes the structure of the geometry. 
o Optimize/Share Geometries: Optimizes the structure of the geometry and tries 

to share duplicate geometries. 
o Merge/Optimize/Share Geometries: Optimizes by changing the Scene Graph 

structure. This has a significant impact on the geometry. 
3. Click OK. 

For more advanced optimization options, in the Menu Bar, select Scene > Optimize to open the 
Optimize dialog. 



How to Save a Scene 

From the File menu, select the appropriate saving option, then click Save. 

• Save or Save As: Saves as you would from other applications, using the supported VRED 
file formats: 
 

o VRED Essentials Project Binary - .vpe 
o VRED Project Binary - .vpb 
o VRED Project File - .vpf 

 
• Save Selected: Saves the current selection to a supported VRED file format. 
• Save Package: Saves the project with textures stored in a subfolder, instead of inline. 

How to Publish a Scene 

From the File menu, select the appropriate saving option, then click Save. 

1. In the Menu Bar, select File > Publish. 
2. Locate and select a file. 
3. Click Save. 

How to Export Information from a Scene 

Export various types of information from a scene, such as geometry, images, sequencer 
batches, and variants. 

1. In the Menu Bar, select File > Export. 
2. Select the type of information you want to export, then click Save. 

 
o Scene - Exports the whole scene. These are the supported export formats: 

 
 VRML Geometry - .vrml .wrl 
 Wavefront Geometry - .obj 
 VRED Essentials Project Binary - .vpe 
 FBX Scene - .fbx 
 Maya® ASCII - .ma 
 Maya® Binary - .mb 
 Maya® Scene - .ma .mb .wire 
 FHS Geometry - .fhs 
 PovRay - .pov 
 OpenSG ASCII Geometry - .osg 
 OpenSG Binary Geometry - .osb 



 ProENGINEER Render Geometry - .slp 
 Python Script - .py 
 StereoLithography Geometry - .stl .stla .stlb 
 VRED Project Binary - .vpb 
 VRED Project File - .vpf 

 
o Selected - Exports the current selection into one of the supported formats. 
o Switched Geometry - Exports switched geometry data (*.osb). 
o CubeImages - Exports the scene to a set of cube images. The export is based 

around a center point you create, such as with a standard primitive (which you 
hide using the Scene Graph). CubeImages render settings can be set in Edit > 
Preferences > Export. 

o Render Jobs - Exports jobs from the Render module to the current scene (XML 
Render Queue Description .xml). 

o Snapshot - Exports a snapshot of the Viewport to the snapshot folder specified 
in Preferences. 

o Sequences - Places all sequences set in the Sequencer module into a separate 
xml file. 

o Variants - Places all variants and variants sets into a separate xml file. 

 



VR and VR Setup 



VR Requirements 
See a list of the VR requirements and supported devices. 

If you meet the VRED system requirements, your machine could be all set for VR. However, 
please check the Video Card/GPU Requirements section below, as the requirements that are 
called out there are to aid with a comfortable VR experience. 

Since your safety, as well as your comfort, is important to us, please look over the VR Safety 
section. Another important link, if collaborating with multiple participants using HMDs in the 
same real-world location, is Setting up a VR Room. 

VR Safety 

Always follow the health and safety (including any regulatory information) and operating 
directions from the device manufacturer. To help prevent injury only use VRED VR with the 
health and safety guidance and operating directions included with your device enabled: Oculus 
Guardian and Vive Chaperone. 

Stop use if you experience any discomfort or health reactions. 

For customers utilizing the same tracked space for more than one (1) VR participants in 
collaboration sessions, the virtual room (VR Room) in Autodesk software, as well as the VR 
device's roomscale tracked space, must be correctly setup, to enable area precision and syncing 
of tracking to display safety mechanisms. These safety mechanisms (currently unavailable in 
Raytracing) provide guidance to help prevent collisions between participants operating inside 
the same roomscale tracked space. Participants in collaboration sessions should maintain 
general awareness of other participants and always use care (i.e., avoid rapid or unexpected 
movements). Collaboration sessions should only be run while under the supervision of another 
person who is able to warn of hazards during a session. 

Video Card/GPU Requirements 

High performance is critical to a pleasant VR experience and is essential to reduce any 
discomfort. It is important to use an NVIDIA or AMD VR ready graphics card, with the amount of 
graphics power increased to meet your content demands. 

 

 

https://knowledge.autodesk.com/support/vred-products/troubleshooting/caas/sfdcarticles/sfdcarticles/System-requirements-for-Autodesk-VRED-products.html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Collaboration_Setting_Up_a_VR_Room_html


Supported VR Devices 

VRED supports the VR devices listed below. 

• Oculus Rift and Touch Controllers* 
• HTC Vive and HTC Vive Controllers* 
• StarVR and HTC Vive Controllers 
• VRHero/VRgineers XTAL and HTC Vive Controllers 
• WinMR Controllers 

* VRED currently only supports the use of HTC Vive or Oculus Rift (via OpenVR) when in a VR 
room during a collaboration session. See Tracking System Precision for more details. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Setting-Up-a-VR-Room#tracking-system-precision


Using Controllers 
Get information on using controllers in a VRED collaboration session. Since not all controllers 
have buttons in the same location, when in VR, there is a controller mode with displayed 
tooltips. Use the tooltips to locate tools. 

NOTE For entering a collaboration session, two controllers are required. 

For a list of supported VR devices, see VR Requirements. 

What Tools Do the Controllers Have? 

For the location of these tools, please refer to these images: 

HTC Vive, StarVR, and VRHero/VRgineers XTAL 
 

 

1. Tools Menu 
2. Teleport 
3. Tooltips 
4. Pointer 

 

 

 

Oculus Rift 
 

 

1. Tools Menu 
2. Teleport 
3. Tooltips 
4. Pointer 

 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VR-Requirements#supported-vr-devices


WinMR 

 

1. Tools Menu 
2. Teleport 
3. Tooltips 
4. Pointer 

 

 

 Tools Menu - Press this button to display the Tools Menu or hide it. See Tools Menu for 
more information. 

 Teleport - Use to teleport yourself to assorted places in a scene by touching the controller 
pad to cast a teleport arc, then pressing the pad to teleport. Teleport to various locations in the 
scene, into a car, or onto a car. See Teleporting for more information. 

 Tooltips - Press this button to turn the displayed controller tooltips on or off. 

 Pointer - Press this to activate a beam and use it to point and indicate areas of interest. 

Custom Controls 

Use the following Python functions to switch the mapped interaction of the trigger and 
touchpad/thumbstick. 

In vrImmersiveInteractionService, use setControlMode(ControlMode) 

For ControlMode, you can use TriggerPointer or ButtonPointer. 

For example, for the Vive controller, if you wanted the touchpad/thumbstick to be mapped to 
the pointer and the trigger to be teleport, you would use: 

setControlMode(ButtonPointer) and setControlMode(TriggerTeleport). 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VR_and_VR_Setup_Tools_Menu_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VR_and_VR_Setup_Teleporting_html


Using the HTC Vive with VRED 
The HTC Vive hardware uses the OpenVR HMD mode, which uses SteamVR. For an explanation 
of the coordinate systems, see the Activating OpenVR HMD section below. 

 

 

 

1. Tools Menu 
2. Teleport 
3. Tooltips 
4. Pointer 

 

 

 

Using the OpenVR HMD Mode 

IMPORTANT You must install the SteamVR software. If you haven't installed it, go to 
https://store.steampowered.com/steamvr and click Install Steam. Once installed, click the VR 
button, at the top of the screen, to install SteamVR. 

How to Activate OpenVR 

Do the following to activate OpenVR: 

1. Load a scene. 
2. Select View > Display > OpenVR HMD. If SteamVR is not running yet, wait a moment, as 

it will start automatically. 

Eye Separation 

Use the hardware slider on the Vive headset to set the distance between your eyes. This value 
can be overwritten in VRED by selecting Visualization > Stereo > Stereo Settings > Eye 
Separation. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#how-to-activate-openvr
https://store.steampowered.com/steamvr


Controllers and Vive Trackers 

When a Vive controller is detected, a hand is rendered at its tracked pose. See Hands in VR. 
When a Vive tracker is detected, a simple static geometric representation is rendered at its 
tracked pose. 

Use a Python script to add behavior to controllers and trackers, for example, to react to button 
clicks or movement of the tracked device. 

See example file OpenVRExample.vpb and https://knowledge.autodesk.com/support/vred-
products/learn-explore/caas/simplecontent/content/adding-interaction-for-vr.html 

How to Start the VR Experience at a Certain Point in a Scene 

If you need to start the VR experience at a certain point in your scene, such as 1 meter in front 
of an object, do the following: 

1. Create a viewpoint (Scene > Camera Editor, right-click and select Create > Viewpoint) on 
the floor of the scene, where you want to stand in VR. 

NOTE See Viewpoints for how to create this viewpoint. 

2. Activate OpenVR (see above). 
3. Activate the pre-defined viewpoint. 

For more of a detailed explanation on the coordinate systems, see the next section, 
Camera. 

Tracking Origin Type 

The only difference between the Room Scale and Seated mode is the assumed tracking origin. 
Tracking values are reported relative to this origin. 

• Room Scale (Default) - The Room Scale assumed tracking origin is in the center of the 
play area on the floor. Tracking values are relative to that central position. The play area 
is configured in SteamVR. 
 

• Seated - The Seated tracking origin is at the user's head. Tracking values are relative to a 
Seated Zero Pose (the preferred sitting position), which the user has setup. This mode is 
probably only suitable for scenarios where you don't need actual correspondence 
between the real and virtual world. 

NOTE To enable with the Seated mode using Python commands, see Seated Mode. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VR_and_VR_Setup_Hands_in_VR_html
https://knowledge.autodesk.com/support/vred-products/learn-explore/caas/simplecontent/content/adding-interaction-for-vr.html
https://knowledge.autodesk.com/support/vred-products/learn-explore/caas/simplecontent/content/adding-interaction-for-vr.html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#viewpoints
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#how-to-activate-openvr
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VR_and_VR_Setup_Using_Python_for_VR_Python_for_HTC_Vive_html


Camera 

The VRED default scene setup is Z-up. In Open VR mode, VRED uses Room Scale tracking per 
default. In the following, we assume the scene is set to Z-up and you are using the Room Scale 
tracking mode. 

 

Camera Transformation and Tracking Space 

The transformation (translation and rotation) of the VRED active camera defines the 
origin/location of the tracking space of a scene and how it is oriented. 

• The camera position represents the preferred standing point (~center) in the play area 
on the floor. The default camera position in VR is (0, 0, 0). 

• The camera's Z-value position represents the floor height. The default camera height in 
VR is 0. 

• The camera viewing direction represents the preferred forward-facing direction. The 
default camera orientation in VR is positive Y-axis in VRED's world coordinate system. 

The preferred forward-facing direction is the direction in which the user prefers to look 
in the real world, while wearing the HMD (head-mounted display). It is setup in 
SteamVR, when installing the tracking system. 

• The camera up-vector should always be set to (0, 0, 1). This is the Z-axis in VRED's world 
coordinate system. 

The VRED SteamVR tracking values for the HMD are applied on top of the camera 
transformation. 

Each time the OpenVR HMD mode is activated, the active camera in the VRED scene is set to 
world position (0, 0, 0) and looks along the positive Y-axis. After deactivating OpenVR again, the 
camera is reset to its previous position/orientation. 

In these images, you will see a simple example setup from the outside: 

• This image shows how the VRED camera sits on the floor in the origin (without HMD 
tracking values), and where the camera is located when the tracking values are applied 
(shown in orange): 



 

• In this image, the VRED camera has been moved -1000 units along the X axis. Therefore, 
the camera with tracking applied is also moved 1000 units: 

 



Why Not to Use a Mouse to Navigate 

Navigating with a mouse in the Render Window changes the transformation of the active 
camera. It is possible to transform the active camera while VR is running, but this could result in 
the camera no longer sitting at floor level or being rotated incorrectly. This is why navigation 
with a mouse, while in VR, is not recommended. 

Floor Level and Initial Position (Room Scale Mode) 

In Room Scale mode, a camera's Z-translation value defines the floor level. This means the Z-
value in the scene corresponds to the physical floor in the tracked space. Therefore, if the floor 
in your scene is NOT at Z = 0, adjust the camera's Z-value, accordingly. 

NOTE Alternatively, you can leave the camera at (0, 0, 0) and use the Python function 
setOpenVRTrackingOrigin(Pnt3f(x,y,z)). 

Example: Floor Level for Automotive_Genesis.vpb 

In the scene below, the scene origin (0, 0, 0) is at the center of the front axle, so the floor level 
is not set at Z = 0, but Z = -337. 

 

 

 



• Finding the Z-value of the Ground Plane - To find the Z-value of the ground plane, select 
the ShadowPlane node in the Scene Graph, right-click and select Information... from the 
menu. In the Node Information dialog, look at the 3rd value of Bounding box center, 
which is the world Z-value (the ground plane). 

 

If this method does not work for the specific geometry in your scene, create a 
temporary point to point measurement, using the Measurement module. 

How to Create a Point to Point Measurement 

1. From the menu bar, select Interaction > Measurement. 
2. Right-click within the top section of the Measurement module and select Add Point to 

Point Measurement. 
3. Shift-pick two points along the floor, then in the Properties section, look at the Z-value 

for one of the picked points. 

How to Set Floor Level by Changing Camera Translation 

To set the floor level by changing camera translation, you will need to activate OpenVR. This 
automatically sets the camera translation to (0, 0, 0). From there, use one of several methods 
to get the camera set to floor level and change the translation. 

1. Activate OpenVR. 
2. Change the camera translation to (0, 0, -337). You can do this in the Camera Editor 

(Scene > Camera Editor). 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#how-to-activate-openvr


3. If your camera node is transformed by any parent transformation node in the Scene 
Graph, use the Transform Editor. In its Translation section, change Coordinate System to 
World to ensure the translation is using world coordinates. 

4. After setting the correct camera position, create a new viewpoint. 

TIP To use these values in the future, store them in a viewpoint, which can be activated 
once you are in OpenVR. Activate the viewpoint either with the Camera Editor or 
Python. For the Python function to activate the viewpoint, see Shortcuts for Activating 
OpenVR and the Viewpoint. 

Viewpoints 

Viewpoints are created within the Camera Editor and are the stored parameters for a camera. 
When you transform a camera, it defines the location of the scene's tracking space and how it is 
oriented. This means for VR, you cannot re-use existing viewpoint setups in normal Desktop 
Viewing mode, but must create special VR viewpoints. 

How to Create a Viewpoint 

When setting up the transformation for a viewpoint, it is easier to view an actual camera with a 
secondary camera from the outside (View > Show Cameras). Once this is done, move the 
displayed camera to the desired position, using the Transform manipulator in the scene. 

 

To create a viewpoint from the "floor" camera, first activate the "floor" camera, create the 
viewpoint, then activate the other camera again to setup the next viewpoint in a similar 
fashion. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Python-for-HTC-Vive#shortcuts-for-activating-openvr-and-the-viewpoint
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Python-for-HTC-Vive#shortcuts-for-activating-openvr-and-the-viewpoint


NOTE You need to activate the camera before creating the viewpoint because a new viewpoint 
is always created from the active camera's transformations. 

• Translation - The camera translation must be on the floor. 
• Rotation - The camera viewing direction is the preferred forward-facing direction and 

the up-vector must be 0, 0, 1 (VRED world z-axis). To check it, select Scene > Camera 
Editor > Advanced tab > From/At/Up. 

• Activation - For instant teleportation, activate the viewpoint without animation. The 
viewpoint animation in VRED has an acceleration at the beginning and end, which is 
likely to cause discomfort in VR. Therefore, deactivate animation in the Camera Editor 
settings by selecting Scene > Camera Editor > Camera Settings > Animation. 

Vive: How to Check Tracking Calibration 

To check whether the calibration of your Vive is correct, so the measurements in the virtual 
scene correspond 1:1 to the real world, do the following: 

1. Create a 1x1 meter box in VRED. 
2. In VR, place the controllers so the Menu button is perfectly on the edge of the box. 
3. Measure the distance between these buttons in the real world. If this does not match, 

you probably need to recalibrate your Vive setup. 



Using the Oculus Rift with VRED 
The Oculus Rift hardware can be used with either of these VR display modes, which can be 
found at View > Display: 

• Oculus Rift, which uses the Oculus Rift SDK directly. 
• OpenVR HMD, which goes through SteamVR. 

 

 

1. Tools Menu 
2. Teleport 
3. Tooltips 
4. Pointer 

 

Since the following information is the same for the HTC Vive, see the links below: 

• Floor Level and Initial Position (Room Scale Mode) 
• How to Set Floor Level by Changing Camera Translation 
• Viewpoints and Creating a Viewpoint 

Using the Oculus Rift Mode 

IMPORTANT Before continuing, you will need a NVIDIA Quadro graphics card or better. Next, 
the Oculus software must be installed, and Oculus hardware set up. 

How to Activate the Oculus Rift 

Once you have followed the instructions above, do the following to activate the Oculus Rift: 

1. Load a scene into VRED. 
2. From the menu bar, select View > Display > Oculus Rift to activate the device. 

Eye Separation 

Use the hardware slider on the Oculus headset to set the distance between your eyes. This 
value can be overwritten in VRED by selecting Visualization > Stereo > Stereo Settings > Eye 
Separation. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#floor-level-and-initial-position--room-scale-mode-
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#how-to-set-floor-level-by-changing-camera-translation
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#viewpoints


Controllers 

When a controller is detected, a hand is rendered at its tracked pose. See Hands in VR for more 
information. You can use the Python function vrOculusTouchController for Oculus Rift 
controllers. Load the example file (File > Open Examples > OculusTouchExample.vpb), then 
select Edit > Script Editor to see an example of this in use. 

How to Start the VR Experience at a Certain Point in a Scene 

If you need to start the VR experience at a certain point in your scene, such as 1 meter in front 
of an object, do the following: 

1. Create a viewpoint (Scene > Camera Editor, right-click and select Create > Viewpoint) on 
the floor of the scene, where you want to stand in VR. 

NOTE See Viewpoints for how to create this viewpoint. 

2. Activate Oculus Rift. 
3. Activate the pre-defined viewpoint. 

For more of a detailed explanation on the coordinate systems, see the next section, 
Camera. 

Tracking Origin Type 

The default tracking type for the Oculus Rift is Seated mode, which is eye level. To change the 
tracking origin type to Room Scale, use a Python function found in Python for Oculus Rift. 

For information on Tracking values, see the Oculus Developer documentation. 

For navigation, viewpoints, and matching virtual and real-world floor level, you will need to use 
some Python functions. See Enabling Standing Mode. 

Camera Transformation and Tracking Space 

Camera placement is the first thing you should set. The transformation (translation and 
rotation) of the VRED active camera defines the origin/location of the scene's tracking space 
and how it is oriented. Ideally, you should start with the scene set to Z-up. Next, you need to 
determine whether the camera is positioned at eye level/Seated mode (the default) or floor 
level/Standing mode. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VR_and_VR_Setup_Hands_in_VR_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#viewpoints
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-Oculus-Rift-with-VRED#how-to-activate-the-oculus-rift
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Python-for-Oculus-Rift#how-to-set-floor-level-in-oculus-rift-mode
https://developer.oculus.com/documentation/pcsdk/latest/concepts/dg-sensor/#dg_sensor
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Python-for-Oculus-Rift#how-to-enable-standing-mode-in-oculus-rift-mode--oculus-rift-s-floor-level-


Seated mode (Oculus Rift's Eye Level) 

By default, VRED's Oculus Rift mode starts up in Seated mode and reports tracking values 
relative to any calibrated default headset pose. For example, sitting at the desk with the 
headset on. 

The VRED camera should be positioned approximately where the user's eyes will be in the 
scene, since this is not automatically done in VRED. After activating Oculus Rift display mode, 
the position and orientation of the current active camera is the same as it was in Desktop 
mode, which is likely not suitable for VR. 

There are always two things that will impact the final view in the headset: 

• HMD calibration (setup of tracking space) 
• VRED camera position and orientation 

Headset (HMD) calibration 

For example, the headset was on the desk pointing in one direction when turned on. Now, on 
your head, your eye level has changed and so has the direction you are looking. 

NOTE To recalibrate the tracking origin, use the Python function 
resetOculusRiftOrientation() in VRED. In Seated mode, resetOculusRiftOrientation() 
resets the tracking origin to where the headset currently is. It also sets the preferred looking 
direction to where the headset is currently looking (yaw angle). 

VRED Camera 

Should be positioned approximately where the user's eyes will be in the scene, since this is not 
automatically done in VRED. The camera up-vector should always set to 0, 0, 1 (Z-axis in VRED's 
world coordinate system). 

Standing mode (Oculus Rift's Floor Level) 

Standing mode is also known as Room Scale. It reports tracking values relative to a position on 
the floor that was set up during the initial calibration. Standing mode is defined as follows: 

• The VRED camera should be positioned approximately at floor level in the scene. If the 
VRED camera is looking at the front of a car, you will look at the front of the car in VR, 
when you are looking with your headset toward the sensors. This is the preferred 
forward-facing direction (looking towards the sensors). 

There are always two things that will impact the final view in the headset: 



o VRED camera position and orientation 
o HMD calibration (setup of tracking space) 

NOTE The calibration tracking origin can be changed by using the Python function 
resetOculusRiftOrientation() in VRED. In Standing mode, 
resetOculusRiftOrientation() sets the tracking origin to the position on the floor 
below the headset. It also sets the preferred looking direction to where the headset is 
currently looking (yaw angle). 

• The camera up-vector must always be set to 0, 0, 1 (Z-axis in VRED's world coordinate 
system). 

Using the OpenVR HMD Mode 

IMPORTANT You must install the SteamVR software. If you haven't installed it, go to 
https://store.steampowered.com/steamvr and click Install Steam. Once installed, click the VR 
button at the top of the screen to install SteamVR. 

Since the following information is the same for the HTC Vive, see the links below: 

• Tracking Origin Type 
• Camera Transformation and Tracking Space 
• How to Start the VR Experience at a Certain Point in a Scene 

How to Activate OpenVR 

Do the following to activate OpenVR: 

1. Load a scene. 
2. To activate, select View > Display > OpenVR HMD. If SteamVR is not running yet, wait a 

moment, as it will start automatically. 

Why NOT to Use a Mouse to Navigate 

Navigating with a mouse in the Viewport changes the transformation of the active camera. It is 
possible to transform the active camera while VR is running, but this could result in the camera 
no longer sitting at floor level or being rotated incorrectly. This is why navigation with a mouse, 
while in VR, is not recommended. 

https://store.steampowered.com/steamvr
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#tracking-origin-type
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#camera-transformation-and-tracking-space
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#how-to-start-the-vr-experience-at-a-certain-point-in-a-scene


Using the StarVR 
The StarVR hardware uses the StarVR HMD mode, which goes through SteamVR. 

NOTE Though the StarVR HMD can be used with the Collaboration module, it is not supported 
for the VR Room feature. 
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Using the StarVR HMD Mode 

IMPORTANT Before continuing, you will need a NVIDIA Quadro graphics card or better. Next, 
the StarVR software must be installed and StarVR hardware set up. 

How to Activate the StarVR 

Once you have followed the instructions above, do the following to activate the StarVR: 

1. Load a scene into VRED. 
2. From the menu bar, select View > Display > StarVR HMD to activate the device. 

Controllers 

The StarVR uses HTC Vive Controllers. 

How to Start the VR Experience at a Certain Point in a Scene 

If you need to start the VR experience at a certain point in your scene, such as 1 meter in front 
of an object, do the following: 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Collaboration_About_the_Collaboration_Module_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Setting-Up-a-VR-Room#tracking-system-precision


1. Create a viewpoint (Scene > Camera Editor, right-click and select Create > Viewpoint) on 
the floor of the scene, where you want to stand in VR. 

NOTE See Viewpoints for how to create this viewpoint. 

2. Activate StarVR. 
3. Activate the pre-defined viewpoint. 

For more of a detailed explanation on the coordinate systems, see the next section, 
Camera. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#viewpoints
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-StarVR#how-to-activate-the-starvr


Using the WinMR 
The Windows Mixed Reality (WinMR) hardware uses the OpenVR HMD mode, which goes 
through SteamVR. 

NOTE Though the WinMR HMD can be used with the Collaboration module, based on test 
results, we feel using the WinMR HMD should be avoided for VR room scenarios. 
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Using the OpenVR HMD Mode 

IMPORTANT You must install the SteamVR software. If you haven't installed it, go to 
https://store.steampowered.com/steamvr and click Install Steam. Once installed, click the VR 
button, at the top of the screen, to install SteamVR. 

How to Activate OpenVR 

Do the following to activate OpenVR: 

1. Load a scene. 
2. Select View > Display > OpenVR HMD. If SteamVR is not running yet, wait a moment, as 

it will start automatically. 

Controllers 

The WinMR uses the WinMR controllers. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Collaboration_About_the_Collaboration_Module_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Setting-Up-a-VR-Room#tracking-system-precision
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Setting-Up-a-VR-Room#tracking-system-precision
https://store.steampowered.com/steamvr


How to Start the VR Experience at a Certain Point in a Scene 

If you need to start the VR experience at a certain point in your scene, such as 1 meter in front 
of an object, do the following: 

1. Create a viewpoint (Scene > Camera Editor, right-click and select Create > Viewpoint) on 
the floor of the scene, where you want to stand in VR. 

NOTE See Viewpoints for how to create this viewpoint. 

2. Activate OpenVR. 
3. Activate the pre-defined viewpoint. 

For more of a detailed explanation on the coordinate systems, see the next section, 
Camera. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#viewpoints
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-WinMR#how-to-activate-openvr


Using the Varjo 
The Varjo hardware uses the Varjo HMD mode, which goes through SteamVR. 
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Using the Varjo HMD Mode 

IMPORTANT Before continuing, you will need a NVIDIA Quadro graphics card or better. Next, 
the Varjo software must be installed and Varjo hardware set up. 

How to Activate the Varjo 

Once you have followed the instructions above, do the following to activate the Varjo: 

1. Load a scene into VRED. 
2. From the menu bar, select View > Display > Varjo HMD to activate the device. 

Controllers 

The Varjo uses HTC Vive Controllers. 

How to Start the VR Experience at a Certain Point in a Scene 

If you need to start the VR experience at a certain point in your scene, such as 1 meter in front 
of an object, do the following: 

1. Create a viewpoint (Scene > Camera Editor, right-click and select Create > Viewpoint) on 
the floor of the scene, where you want to stand in VR. 



NOTE See Viewpoints for how to create this viewpoint. 

2. Activate Varjo. 
3. Activate the pre-defined viewpoint. 

For more of a detailed explanation on the coordinate systems, see the next section, 
Camera. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#viewpoints


Using the VRHero/VRgineers XTAL 
The VRHero/VRgineers XTAL hardware uses the VRHero/XTAL HMD mode, which goes through 
SteamVR. 

NOTE Though the VRHero and VRgineers XTAL HMDs can be used with the Collaboration 
module, they are not supported for the VR Room feature. 
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Using the VRHero/XTAL HMD Mode 

IMPORTANT Before continuing, you will need a NVIDIA Quadro graphics card or better. Next, 
the VRHero/XTAL software must be installed and VRHero/XTAL hardware set up. 

How to Activate the VRHero/XTAL 

Once you have followed the instructions above, do the following to activate the VRHero/XTAL: 

1. Load a scene into VRED. 
2. From the menu bar, select View > Display > VRHero/XTAL HMD. 

Controllers 

The VRHero and VRgineers XTAL use HTC Vive Controllers. 

How to Start the VR Experience at a Certain Point in a Scene 

If you need to start the VR experience at a certain point in your scene, such as 1 meter in front 
of an object, do the following: 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Collaboration_About_the_Collaboration_Module_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Collaboration_About_the_Collaboration_Module_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Setting-Up-a-VR-Room#tracking-system-precision


1. Create a viewpoint (Scene > Camera Editor, right-click and select Create > Viewpoint) on 
the floor of the scene, where you want to stand in VR. 

NOTE See Viewpoints for how to create this viewpoint. 

2. Activate VRHero/XTAL. 
3. Activate the pre-defined viewpoint. 

For more of a detailed explanation on the coordinate systems, see the next section, 
Camera. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#viewpoints
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-VRHero-VRgineers-XTAL#how-to-activate-the-vrhero-xtal


Using the VRED Presenter for VR 

How to set up your HMD in VRED Presenter 

VRED Presenter has no GUI, such as menus, so how do you activate your HMD (head mounted 
display) and display your scene in virtual reality? To do this requires some scripting. 

NOTE For further information on other ways to use the VRED Presenter, click here. 

You will need to activate an HMD, such as an HTC Vive or Oculus Rift. There are two ways to do 
this: 

• Use a special command line parameter: 

For HTC Vive: 

-postpython "setDisplayMode(VR\_DISPLAY\_OPEN_VR)" 

NOTE This does the same as selecting View > Display > OpenVR HMD in VRED 
Professional or VRED Design (since 2019). 

For Oculus Rift: 

-postpython "setDisplayMode(VR\_DISPLAY\_OCULUS_RIFT)" 

NOTE This does the same as selecting View > Display > Oculus Rift in VRED Professional 
or VRED Design (since 2019). 

• Use an embedded script. The person who created the scene would save the scene with 
a special Python function in the .vpb file. See the following section for more 
information. 

Using a Special Command Line Parameter 

Use a special command line parameter to prepare a scene to open in VRED Presenter and 
activate an HMD to view the scene in VR. The advantage of the -postpython command line 
option is you don't need to modify the existing .vpb file. You can use it with any existing .vpb 
file. 

Enter the following in the command line: 

VREDPresenter.exe c:/vred/scene.vpb -postpython 
"setDisplayMode(VR_DISPLAY_OPEN_VR)" 

https://www.autodesk.com/products/vred/features/server-presenter


NOTE This does the same as selecting View > Display > OpenVR HMD in VRED Professional or 
VRED Design (since 2019). 

VREDPresenter.exe c:/vred/scene.vpb -postpython 
"setDisplayMode(VR_DISPLAY_OCULUS_RIFT)" 

NOTE This does the same as selecting View > Display > Oculus Rift in VRED Professional or VRED 
Design (since 2019). 

Using an Embedded Script 

The embedded script makes doing complex things much easier than script coding via the 
command line. Often for VR presentations, there is already a script in the file for the 
controllers, since that is the only way to connect custom functionality to the controller buttons. 

Use the Script Editor (Edit > Script Editor) for entering the embedded script. By default, the 
editor is empty. When you enter a Python function in it, it is saved within the .vpb file. When 
the .vpb file is loaded, the script is executed. See To Create, Edit, and Use Scripts for more 
information on using scripts. 

NOTE The automatic execution of the script can be disabled in the Preferences (Edit > 
Preferences > FileIO > OSB/VPB > Execute Embedded Script). 

How to Embed a Script 

This section is for someone using VRED Professional. They will embed a script into their scene. 

NOTE The automatic execution of the script can be disabled in the Preferences (Edit > 
Preferences > FileIO > OSB/VPB > Execute Embedded Script). 

1. With the scene open, select Edit > Script Editor to open the Script Editor. 
2. Enter the following script to create shortcuts for turning VR on and off. 

def enableVR(): 
   setDisplayMode(VR_DISPLAY_OPEN_VR) 
def disableVR(): 
   setDisplayMode(VR_DISPLAY_STANDARD) 
 
keyV = vrKey(Key_V) 
keyV.connect(enableVR) 
keyS = vrKey(Key_S) 

keyS.connect(disableVR) 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Scene_Interaction_Working_with_Scripts_html


 

3. Save the .vpb file. Now, when anyone opens this file, they can press the V key to enable 
VR and the S key to return to standard desktop mode. 

How to Use an Embedded Script 

Anyone opening a .vpb file containing an embedded script can press the key defined in the 
script to enable and disable things. 

NOTE In VRED Presenter, there is no Script Editor or way to see if there is an embedded script 
within the file. This means that the creator of the file will need to inform you of any shortcuts 
they've added. 

1. Drag the .vpb file into VRED Presenter. 
2. Use the shortcuts. As stated in the example code, press the V key to enable VR and the S 

key to return to standard desktop mode. 



Using Python for VR 
The VRED Python functions to use for VR 

NOTE For Python functions specific to your HMD, see Python for HTC Vive or Python for Oculus 
Rift. 

For a comprehensive list of Python functions and descriptions, select Help > Python 
Documentation. Here is a list of some VR-specific Python functions: 

- vrOculusTouchController.vrOculusTouchController 
- vrOpenVR.vrOpenVRController 
- vrOpenVR.vrOpenVRFrameTimings 
- getOpenVRFrameTimings 
- getOpenVRTrackingOrigin 
- getOpenVRTrackingOriginType 
- resetOculusRiftOrientation 
- resetOpenVRHMDPose 
- setNodeInteractableInVR 
- setOculusRiftHmdCaps 
- setOculusRiftTracking 
- setOculusRiftTrackingOrigin 
- setOculusRiftTrackingOriginType 
- setOpenVRControllerTracking 
- setOpenVRHMDForceInterleavedReprojection 
- setOpenVRHMDMirrorTextureView 
- setOpenVRHMDTracking 
- setOpenVRHMDUseHiddenAreaMesh 
- setOpenVRTracking 
- setOpenVRTrackingOrigin 
- setOpenVRTrackingOriginType 
- setOpenVRControllerTracking 
- setNodeInteractableInVR 
- setOculusRiftHmdCaps 
- setOculusRiftTracking 
- setOculusRiftTrackingOrigin 
- setOculusRiftTrackingOriginType 
- showOculusRiftPerformanceHUD 
- vrOpenVR 
- vrOculusTouchController 
- getOculusRiftTrackingOrigin 
- getOculusRiftTrackingOriginType 

http://help.autodesk.com/cloudhelp/2019/ENU/VRED/files/VR-and-VR-Setup/Using-Python-for-VR/Python-for-HTC-Vive.htmlGUID-80268C6F-ED58-435B-88A3-2FB8B26AF407
http://help.autodesk.com/cloudhelp/2019/ENU/VRED/files/VR-and-VR-Setup/Using-Python-for-VR/Python-for-Oculus-Rift.htmlGUID-240E67DF-929F-4E08-AEF5-E897E3D2E738
http://help.autodesk.com/cloudhelp/2019/ENU/VRED/files/VR-and-VR-Setup/Using-Python-for-VR/Python-for-Oculus-Rift.htmlGUID-240E67DF-929F-4E08-AEF5-E897E3D2E738


Python for HTC Vive 

Get Python functions specific to use of the HTC Vive with VRED 

With the HTC Vive there is only one display mode option, OpenVR HMD. 

Floor Level and Initial Position (Standing/Room Scale Mode) 

In Standing or Room Scale mode, a camera's Z-translation value defines the floor level. This 
means the Z-value in the scene corresponds to the physical floor in the tracked space. 

Since how to set the camera in VRED, such that the virtual floor in the scene and the real floor 
match, is the same for the HTC Vive, see How to Set Floor Level by Changing Camera 
Translation. 

Another possibility is to use the Python function setOpenVRTrackingOrigin(Pnt3f(x,y,z)) 
to adjust tracking values, if the floor in your scene is NOT at Z = 0. 

In this image, the tracking values are modified with the setOpenVRTrackingOrigin Python 
function: 

 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#how-to-set-floor-level-by-changing-camera-translation
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#how-to-set-floor-level-by-changing-camera-translation


How to Set Floor Level 

If you want to set the floor level using a Python function, here's an example: 

1. Load the Automotive_Genesis example (File > Open Examples, find 
Automotive_Genesis, and click Open). 

2. In the Terminal dialog (View > Terminal), enter 
setOpenVRTrackingOrigin(Pnt3f(0.0, 337.0, 0.0)). 

3. Press the Enter key. 
4. Activate OpenVR. 

The Python function setOpenVRTrackingOrigin specifies an offset vector. This is subtracted 
from OpenVR's positional tracking values. This function can be executed before OpenVR is 
activated or while OpenVR is running. Note that the function expects the position to be in a 
special coordinate system. 

If the tracking origin in the VRED scene should be at pos = (x\_scene, y\_scene, z_scene), 
call the Python function setOpenVRTrackingOrigin(Pnt3f(-x\_scene, -z\_scene, 
y_scene)). 

Shortcuts for Activating OpenVR and the Viewpoint 

Activate the viewpoint after enabling the OpenVR HMD display mode. Paste the following 
Python function into the Terminal to create a shortcut that will activate OpenVR or Script Editor 
and set a viewpoint named VR\_initial\_view. For information on how to setup viewpoints 
for VR, see Viewpoints. 

def activateOpenVR(): 
    setDisplayMode(VR_DISPLAY_OPEN_VR) 
    jumpViewPoint('VR_initial_view') 
 
keyA = vrKey(Key_A) 
keyA.connect(activateOpenVR) 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-HTC-Vive-with-VRED#viewpoints


 

Now, whenever you press the A key, VRED will go into OpenVR mode and activate the 
viewpoint. 

NOTE Scripts executed in the Terminal are not saved in the scene file. To save this scripted 
shortcut in your scene for future use, enter the Python code into the Script Editor. The script 
will be saved within the vpb file, next time you save the scene. 

How to Find the Current HMD Position 

If you want to query the current absolute position of the tracked HMD in the VRED scene, use: 

matrix = getActiveCameraNode().getWorldTransform() 

The position is: 

x=matrix[3], y=matrix[7], z=matrix[11] 

The function, getWorldTransform(), includes the tracking transformation when used with the 
active camera node. 

Seated Mode 

You can enable Seated mode, using the following Python function, with mode 0 = seated and 
mode 1 = standing/room scale: 

setOpenVRTrackingOriginType(0) 

NOTE Default mode is room scale. 



When enabling the seated tracking origin type, the tracking origin is no longer the center of the 
play area, but at the head position of the player. That means, the VRED camera should be 
positioned where the head of the user should be in the VR scene. 

A certain pose, defined by the user during setup, is assumed as the default head pose or Seated 
Zero Pose. Tracking values are delivered relative to that pose. The Seated Zero Pose can be 
reset while OpenVR is running in VRED, using the Python function resetOpenVRHMDPose(). 

IMPORTANT VRED resets the zero pose each time OpenVR mode is enabled. 

Here are the steps for setting up Seated mode with OpenVR. The correct order is very is 
important! 

1. Activate OpenVR. 
2. Open the Terminal, enter setOpenVRTrackingOriginType(0) to activate Seated mode. 
3. (Optional) To reset Seated Zero Pose, enter resetOpenVRHMDPose() in the Terminal. It 

is already reset upon activation of OpenVR; however, if the user did not wear the HMD 
in the correct position at that time, resetting is necessary. 

4. Position the camera in scene where the head of the user should be, for example, by 
activating a suitable viewpoint in the Camera Editor. 



Python for Oculus Rift 

Get Python functions specific to use of the Oculus Rift with VRED 

You can use either the Oculus Rift or OpenVR HMD display mode with the Oculus Rift. For 
Oculus Rift Mode, see the information below. 

Oculus Rift Mode 

The information below covers only the Oculus Rift display mode. For OpenVR, see Python for 
HTC Vive. 

Standing Mode 

If you are using the Oculus Rift HMD with the OpenVR HMD display mode, Standing mode is the 
default, so it won't need to be enabled. However, if you selected the Oculus Rift display mode, 
it is NOT the default, so you will need to enable Standing mode. 

How to Enable Standing Mode in Oculus Rift Mode (Oculus Rift's Floor Level) 

When the Oculus Rift is activated, it starts up with you in Seated mode. To enable Standing 
mode, which is recommended for room-scale scenarios and when the user stands, do the 
following: 

1. Ensure Oculus Rift mode is activated (View > Display > Oculus Rift). 
2. In the menu bar, select View > Terminal, then paste this Python function 

setOculusRiftTrackingOriginType(1). 
3. Put the headset back on, stand, and notice how the viewpoint has changed. 
4. Activate a camera viewpoint that puts the camera on the floor of the scene at a location 

where you want to be. 

With Python, activate a viewpoint with jumpViewPoint('Floor'), if your viewpoint is 
named Floor. 

Alternatively, directly set the transformation of the active camera with setFromAtUp. 
The default values for from, at, and up can be set like this: setFromAtUp(-1, 0.0, 
0.0, 0.0, 0.0, 1.0, 0.0, 0.0, 0.0, 1.0) 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VR_and_VR_Setup_Using_Python_for_VR_Python_for_HTC_Vive_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VR_and_VR_Setup_Using_Python_for_VR_Python_for_HTC_Vive_html


Tracking Origin Type in Oculus Rift Mode 

The default tracking type for the Oculus Rift is Seated mode, which is eye level. In Seated mode, 
the VRED camera should be positioned where the head of the user should be in the VR scene. 
This can be changed to Room Scale with a Python function. 

• To set the tracking system origin at eye level (Seated mode), the tracking origin type 
must be set to 0 in VRED. Use setOculusRiftTrackingOriginType(0). 

CAUTION This resets the tracking origin to the current HMD pose (position and yaw 
orientation). 

Use resetOculusRiftOrientation() to reset the view, while wearing the headset in 
your preferred position. 

• To set the tracking system origin at floor height (Standing mode/Room Scale), use 
setOculusRiftTrackingOriginType(1). 

CAUTION This resets the tracking origin to the position on the floor below the HMD and 
changes the yaw orientation component of the tracking origin to the current yaw of the 
HMD. 

In Standing mode, you can also use resetOculusRiftOrientation() to recalibrate the 
tracking origin. 

For information on Tracking values, see the Oculus Developer documentation. 

How to Move in the Scene or Set Position 

To move to a desired position in the scene, we recommend setting the active camera 
translation (see Camera Transformation). Alternatively, use the Python function 
setOculusRiftTrackingOrigin(...). 

When changing the camera translation, leave the tracking origin at (0, 0, 0). This makes it easier 
to setup and no conversion of values is needed. You can do this through the UI, with Python, or 
with viewpoints. The preferred viewing direction (yaw) can also be defined this way. 

How to Set Floor Level in Oculus Rift Mode 

In Oculus Rift mode, you can adjust the tracking values using setOculusRiftTrackingOrigin. 
This works the same as the equivalent OpenVR function. 

https://developer.oculus.com/documentation/pcsdk/latest/concepts/dg-sensor/#dg_sensor
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-the-Oculus-Rift-with-VRED#camera-transformation-and-tracking-space


NOTE For setting floor level in OpenVR mode, see How to Set Floor Level from Python for HTC 
Vive. 

NOTE In OpenVR mode, since the following information is the same for the HTC Vive, see the 
links below: 

• Seated Mode 
• How to Find the Current HMD Position 
• Shortcuts for Activating OpenVR and the Viewpoint 

Shortcuts for Activating Oculus Rift Mode and a Viewpoint 

Paste the following Python function into the Terminal to create a shortcut that will activate 
Oculus Rift and set the viewpoint. 

def activateOculus(): 
 
    setDisplayMode(VR_DISPLAY_OCULUS_RIFT) 
 
    jumpViewPoint('VR_initial_view') 
 
 
 
keyA = vrKey(Key_A) 
 
keyA.connect(activateOculus) 

Now, whenever you press the A key, it will activate Oculus mode and set the viewpoint. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Python-for-HTC-Vive#how-to-set-floor-level
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Python-for-HTC-Vive#seated-mode
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Python-for-HTC-Vive#how-to-find-the-current-hmd-position
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Python-for-HTC-Vive#seated-mode


Hands in VR 
Hands have been added to VRED to introduce gestures in VR. They provide a more immersive 
experience for VIVE and Oculus users by delivering a more natural feel when interacting in a 3D 
scene. The X-Ray material was added to further improve the experience. See X-Ray Material for 
more information. 

 

VRED comes with one set of standard hands, which support joints/bones with pre-skinned 
vertices for hand representation. This makes for a smoother transition between hand poses. 
Gestures are driven by an HMD-specific controller setup. 

When activating the Oculus Rift or OpenVR mode, one hand appears per tracked controller. You 
can use it to interact with WebEngines and touch sensors in the scene. Only the index finger 
can be used for interaction. When the finger touches interactable geometry, a left mouse 
press/move/release is emulated for WebEngines and touch sensors on that geometry. 

When using a script with vrOpenVRController, the hands will disappear automatically. You 
can enable them again with controller.setVisualizationMode(Visualization_Hand). 

For example scenes with touch sensors and WebEngines to interact with: 

• When working in OpenVR and in Oculus Rift mode: 
o VR-hands-touchsensor.vpb - Touch the car shape with the index finger to toggle 

the material (touch sensor on car shape). 
o VR-hands-touchsensor-2.vpb - Touch the car shape with the index finger to 

show 3 spheres, which can be touched to change the material (touch sensors on 
car shape and on spheres). 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Truelight_Materials_Reference_X_Ray_html


o VR-hands-webengine.vpb - Touch the calculator buttons with the index finger. 
The calculator material is connected to a web engine. Touching the web engine 
geometry with the index finger triggers a mouse events on the web site. 
 

• When working in OpenVR: 
 

o VR-hands-webengine-buttonVibration-openvr.vpb - It is the same as VR-hands-
webengine.vpb , however, there is controller vibration triggered by the website. 
The calculator web engine has javascript code that sends a 
requestVibration() python command to the VRED WebInterface, when a 
button on the web site is hit. This triggers haptic feedback (vibrations) on the 
connected controller device. 

How to Make Nodes Interactable 

Nodes in the scene are not interactable, by default. All nodes you want to interact with need to 
be made "interactable" with the Python command setNodeInteractableInVR(node, True). 
Please view the Python documentation (Help > Python Documentation) for more details. Enter 
the command in the Script Editor, press Run. The setNodeInteractableInVR command is not 
persistent and needs to be executed every time you load a scene. We recommend you save the 
scene with the script, so the nodes are interactable the next time you open the scene. 

VR Hand Gestures 

You can move fingers and do hand gestures by pressing and touching buttons on the HTC VIVE 
or Oculus Touch Controllers. 

Use the following gestures: 

• Forefinger to point and touch objects 
• Thump's up/down to communicate if something is good or bad 
• Open hand for waving 
• Pinch and pick up objects 
• Clenched Fist 

Customization for VR Hands 

Use Python scripting and HTML5 to create custom setups. You can find script files in the VRED 
Examples folder (C:\\ProgramData\\Autodesk\\VREDPro-11.0\\Examples). 

 

 



Here are some of the added scripts: 

• To enable haptic feedback (controller vibration) when a hand touches an interactable 
node. 
 

o VR-hands-vibrate-openvr.py - For OpenVR mode 
o VR-hands-vibrate-oculus.py - For Oculus Rift mode 

 
• To change hand color / hit point color 

 
o VR-hands-color-openvr.py 
o VR-hands-color-oculus.py 

 
• To interact from a distance (instead of directly touching something) by just pointing with 

the index finger at nodes in the scene. A sphere appears at the hit point. When 
activating the "Pointing" pose (Grip button pressed, Index trigger button not pressed), 
touch sensors and web engines can be executed. 
 

o VR-hands-pointing-openvr.vpb - For OpenVR mode 



Teleporting 
For HMD users, learn how to teleport inside models, onto them, and around them. 

What is Teleporting 

Teleporting is only available for HMD users and is what they use to get around a scene in VR. 
Cast a teleport arc, position the telepad, then press the controller and instantly travel there. 

Use the Teleport Ground option in the Tools Menu to set whether you teleport onto the ground 
plane or geometry. When you want to jump into the driver's seat or walk around the scene, 
ensure On Ground Plane is enabled. Enable On Geometry to teleport onto the sunroof of a car 
and look inside. 

To set the teleport ground mode, either onto the ground plane or geometry, when a scene is 
first opened and your teleporting range, see Virtual Reality Preferences. 

 

How to Teleport 

When casting the teleport arc, the first thing to be aware of is its color. Red indicates you 
cannot teleport. Green means you can. Once the arc is green, look at the arrows. They indicate 
the direction you will be facing. 

1. Touch the controller pad to cast a teleport arc. 
2. As you roll your wrists, the arrow in the scene updates, showing the direction you will 

be facing once you teleport. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Virtual-Reality-Preferences#teleport


 

3. Press the controller pad to teleport. 

How to Set Teleport Orientation with Python 

Use the following Python functions for whether you use relative or absolute teleport 
orientation: 

• Relative - The teleport direction is always facing straight, no matter the rotation of your 
controllers when you activate the teleport arc. 

vrImmersiveInteractionService.setRelativeTeleportOrientation(True) 

• Absolute - The teleport direction will be a fixed rotation to look straight ahead. 
However, wrist rotation will change the direction of your view. To rotate your view, 
rotate your wrist, once you have started teleporting. 

vrImmersiveInteractionService.setRelativeTeleportOrientation(False) 
 

How do I Teleport into a Vehicle? 

Use the Teleport Ground option to set whether you can teleport onto geometry or into and 
around it. 

• To teleport into a vehicle or around it, in the Tools Menu, deactivate Teleport Ground. 
• To teleport onto a vehicle, in the Tools Menu, activate Teleport Ground. 



Tools Menu 
Use the VRED Tools Menu to access tools when wearing an HMD. 

About the Tools Menu 

For participants in VR, click the Tools 
Menu controller button to display 
the Tools Menu (also called the VR 
Menu). It houses an assortment of 
desktop tools, making them 
accessible while in VR. 

NOTE For collaboration session 
participants not wearing an HMD, all 
tools accessed through the Tools 
Menu are accessible in the VRED 
desktop UI. 

 

The panel contains the following options: 

• Variant Sets - Opens the Variant Sets (VSets) panel to access all variant sets created for 
the scene. Any variant sets set in a scene are automatically loaded into the Variant Sets 
panel of the Tools Menu. 

• Viewpoints - Opens the Viewpoints panel to access all viewpoints created for the scene. 
Any viewpoints set in a scene are automatically loaded into the Viewpoints panel of the 
Tools Menu. 

• Controller/Hand - Switches between displaying the controllers or hands. To do this 
another way, see How to Switch Between Hands and Controllers. 

To set the displayed default, see Default Visualization in Virtual Reality Preferences. 

• Hand Poses Only - Toggles between using the pointer or hand gestures for 
communication. When enabled, you can point, give a thumbs up or down, make a fist, 
punch, or open your hand. It also disables all tools mapped to these button, with the 
exception of the Tools Menu button. Use hand poses to interact with touch sensors and 
communicate with others, while in a session. 

• Teleport Ground - Sets the teleporting ground mode to either On Geometry or On 
Ground Plane. When Teleport Ground is enabled, teleport around the scene or into 
spaces, such as inside a car. When disabled, teleport onto geometry in the scene. To set 
a teleporting Ground Mode preference, see Virtual Reality Preferences. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Interacting-Within-a#how-to-switch-between-hands-and-controllers
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Virtual-Reality-Preferences#general
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Virtual-Reality-Preferences#teleport


 

• Calibrate Ground - Provides a way to set where the ground plane is. When working with 
a model not created at the origin, participants will need to calibrate the ground to 
match that of the model. 

 

• Share Pointer - (Only available for VR Room participants) Changes whether other 
participants see or do not see your pointer. The default state is for it to be seen by 
others, enabled. For you, your pointer will be visible, whether this option is activated or 
not. 

Since the pointer is meant to draw participants' attention to things during a 
collaboration session, when activating touch sensors or WebEngines, disable Share 
Pointer. Enable Share Pointer again when you need to get the others' attention. 

How to Access Tools 

To access any of these tools, either tap with your virtual hand or use the pointer. For how to 
use these tools, see the following: 

• How to Switch Between Hands and Controllers 
• What if I'm Left-handed? 
• Using Hand Poses 
• How to Use the Pointer 
• How to Calibrate the Ground Level 

To exit a panel and return to the previous one, press the X in the top right. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Interacting-Within-a#how-to-switch-between-hands-and-controllers
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Interacting-Within-a#what-if-i-m-left-handed-
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Interacting-Within-a#using-hand-poses
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Interacting-Within-a#how-to-use-the-pointer
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Interacting-Within-a#how-to-calibrate-the-ground-level


Can I Add Functionality to the Tools Menu? 

Use Python add functionality to the Tools Menu, such as web content and access to VRED 
modules. 

1. To see sample Python functions for adding functionality, select File > Open Example > vr 
> customMenuButton.py and click Open. 

2. Select Edit > Script Editor to open the editor and take a look at the code. 

 

3. Select Help > Python Documentation to refer to the Python documentation for details 
on these functions. 



VRED Basics 



Selecting Objects in the Viewport 
The following table provides instructions for selecting and deselecting objects: 

To: Do this: 

Select an object Shift-click the object 

Deselect an object Shift+right-click the object 

Select objects fully enclosed in the 
selection frame 

Shift-drag with the left mouse button from left to 
right 

Select objects fully and partially 
enclosed in the selection frame 

Shift-drag with the left mouse button from right to 
left 

Deselect objects in the selection frame Shift-drag with the right mouse button 

Add an object to a selection Shift+Ctrl-click the object 

Remove an object from a selection 
Shift+Ctrl-right-click the object or on an empty space 

to clear the selection 

Select Specific Elements of an Object 

Shift+middle-click the object, then select the option you want: 

• Component - Selects individual surface patches inside a shell, geometries (meshes, lines, 
points), and light sources. 

• Object - Selects shells, surfaces that are not in a shell, geometries (meshes, lines, 
points), and light sources. 

• Group - Selects the next parent of an object. 
• Sceneplate - Selects frontplates and backplates. 
• By Material - Selects all objects with the same material. 
• Adjacency - Selects adjacent components. 
• Adjacent Settings - If the Adjacency Settings are set to Picked Normal, all 

components/geometries that are neighboring to the selected geometry and are within 
the specified angle to the picked normal are selected. If the Adjacency Settings are set 
to Neighbor Normal, all components/geometries that are neighboring the selected 
geometry and are within the specified angle to its neighbor are selected. This function is 
the same as the Geometry Editor's Adjacency Selection. 



• Select Parent - Selects a parent node of the currently selected object from this sub 
menu. 

• Select Object Behind - Selects an object behind the currently selected object from this 
sub menu. 

• Selectable - Toggles the Selectable state of the currently selected object or its parent. 

How to Change Selection Behavior 

1. In the Menu Bar, click Edit > Selection. 
2. Choose a selection behavior: 

 
o Make Normals Consistent - When flipping normals using Alt-click, the vertex and 

face normals of each selected object will be made consistent, that is, pointed in 
the same direction. 

o Use Depth Selection - Enables you to select all objects within the selection 
frame, whether they are behind another object or not. 

o Select Components - Enables you to select individual surface patches inside a 
shell, geometries (meshes, lines, points), and light sources. Choose option from 
the list. 



Transforming Objects in the Viewport 
Transforming object in the Viewport can be done different ways. Use the Transform 
manipulator when eyeballing it is fine. Enter values when precision is required. 

How to Use the Transform Manipulator 

This section explains how to move, scale, and rotate objects using only the Transform 
manipulator. To move, scale, and rotate objects with precision, see the next section for how to 
enter transform values. 

1. Shift-click or Shift-click and drag to select objects to transform. 
2. Select View > Show Manipulator to display the transform manipulators. 
3. Use these keyboard shortcuts to select which manipulator is displayed. 

Translate: Shift+W   

 

Rotate: Shift+E          

 

Scale: Shift+R            

 



How to Transform Objects by Entering Values 

1. Shift-click or Shift-click and drag to select objects to transform. 
2. In the Quick Access Bar at the bottom, click  (the Transform icon). The Transform 

module opens. 

 

3. Enter transform values. These values are applied to all selected objects. When 
transforming multiple objects at once, the Transform module always shows the 
transformation properties of the last selected object and the Transform manipulator is 
connected to the last selected object. 

NOTE Yellow filled input boxes indicate different transformation values for the selected 
objects. For example, one of the selected objects might have an X rotation of 7, while 
another has an X rotation of 45. In this case, the X rotation input box would be yellow. 

 



How to Transform Multiple Objects at the Same Time 

When transforming multiple objects, the last selected object displays the Transform 
manipulator. The transformation properties of the last selected object are displayed in the 
Transform module. Yellow input boxes indicate the transformation values are different for the 
selected objects. 

1. Select multiple objects, either by Shift-clicking and dragging within the Viewport or by 
Shift-dragging within the Scene Editor. 

2. For precise transformations, follow the instructions in How to Transform Objects By 
Entering Values. Otherwise, following the instructions in How to Use the Transform 
Manipulator. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Transforming-Objects-in-the#how-to-transform-objects-by-entering-values
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Transforming-Objects-in-the#how-to-transform-objects-by-entering-values
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Transforming-Objects-in-the#how-to-use-the-transform-manipulator
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Transforming-Objects-in-the#how-to-use-the-transform-manipulator


Adding Files to Scene 

Learn how to load files into VRED 

When adding files to scene, you need to take into consideration the file type. VRED supports an 
assortment of file formats and types. Before adding files to VRED, consult the section below. 

Support File Formats and Types 

Many types of files can be imported and added to VRED scenes. Try other VRED scenes, XML or 
Python files, and files created by other applications, such as 3ds Max. When importing, if there 
is an issue with the import, you can abort it at any time during the process. 

Here is a list of supported file formats and types: 

• CAD: .apf, .asm, .catpart, .catproduct, .cgr, .dlv, .dlv3, .dlv4, .dwg, .dwf, .dxf, .exp, .g, 
.iam, .iges, .igs, .ipt, .jt, .mdl, .model, .neu, .prt, .session, .sldasm, .sldprt, .step, .stp, 
.wire 

• Cosmo Binary: Cosmo3D/Optimizer Geometry .csb, Deltagen Geometry .rtx, Deltagen 
Animations .wrl, Deltagen Variants .xml 

• PLM XML: Imports product structure files with .plmxml file format. 

Maya Files 

Maya .ma and .mb files can be added to a scene; however, not everything in the scene may be 
supported. A lot of Maya data that cannot be loaded into VRED. Therefore, .ma and .mb files 
should be avoided. We recommend you use FBX (the recommended exchange format between 
Maya and VRED), as it is superior to .ma and .mb. 

If you still are hoping to load .mb files into VRED, here's a list of what is supported. All other 
things, such as animation, rigging, and skinning, will be lost. 

Where in VRED What comes through 

Scene Graph Node Names 

Transformations, Rotations, 
Scaling  

Lights 
Directional Lights, Point Lights, Spot Lights, and Area 

Lights 



Where in VRED What comes through 

Materials Material Names 

Diffuse Color Glossy/Specular Color 

Incandescent Color Transparency 

 

Alias Files 

When importing Alias files, first unify all the surface normals to face the camera in Alias. Set 
Visual normals, rather than Geometric normals, to avoid disturbing the history of the model. 

CAD Files 

When working with CAD files, import multiple files in one shot. In the Import File(s) dialog, you 
will see the imported CAD files listed. 

 

Showcase Files 

Showcase files are not supported in VRED 2018 and beyond. You can open a Showcase file in a 
version of VRED before 2018, save the file as a .vpb, then open in VRED 2018 or later. 



How to Add a File to a Scene 

1. Optional: Select a node in the Scene Graph below where you want to add the file or 
animation. 

2. In the Menu Bar, select File > Import. 
3. Select one or more files to add them to the scene and click Open. 
4. Click Import. 

The file or files are added to the Scene Graph as child nodes of the selected node. 

 

If no node was selected in the Scene Graph, the objects are added as children of the 
root node. 

 

All objects of an added file are grouped in a group node. Imported files are marked 
green in the Scene Graph. 

 



How to Add an Animation to a Scene 

You can add VRML animations to a scene, provided they include the objects being animated. 

1. In the Menu Bar, select File > Import Scene Data > VRML Animation. 
2. Select an animation to add to the scene. 
3. Click Open. 

How to Import Information to a Scene 

You can import various file types and meta information to a scene. 

1. In the Menu Bar, select File > Import Scene Data. 
2. Select the type of information you want to import, then click Open: 

 
o CSB Animation/Variants - Imports .csb animation or variant files into the current 

scene. 
o Render Jobs - Imports jobs from the Render module into the current scene. (XML 

Render Queue Description .xml) 
o Rendering Meta Data - Imports images rendered with VRED (.png, .jpg, .tiff, .exr) 

containing scene settings, embedded as meta data in the Rendering Meta Data. 
These settings are applied to the loaded scene. 

o Sequences - Imports arrangements from the Sequencer module into the current 
scene (XML Sequencer Description .xml). A sequence setup for the Sequencer 
module can be added to the scene. 

o Variants - Imports variants from the Variant Sets module into the current scene 
(XML Variant Description .xml). A variant setup for the Variants and VariantSets 
module can be added to the scene. 



Working with Joints and Meshes 
FBX files containing skeletons, joints, and skinned meshes can be imported into VRED. There are 
a few limitations: 

• Only meshes and the Linear Blend skinning method (Maya: Classic Linear) are 
supported. 

• A single mesh vertex can be influenced by a maximum of 4 joints. If a vertex is 
influenced by more, the 4 most influential joints are chosen, and their weights 
normalized. 

• At most, 1024 joints for AMD and NVIDIA GPUs and 256 joints for Intel GPUs can 
influence a mesh. 

• Unshare is only partially supported. We don't recommend unsharing multiple clones of 
the same mesh at the same time. 

• Only skin data from polygon meshes can be imported. NURBS skinned geometry is not 
supported. 

Why Use FBX Files 

FBX is the recommended exchange format between Maya and VRED, as it is superior to .ma and 
.mb. When using .ma and .mb files, not everything in the scene may be supported, so a lot of 
Maya data that cannot be loaded into VRED. Therefore, .ma and .mb files should be avoided 
and FBX files used. 

How to Import Joints and Skinned Meshes 

When importing a skinned mesh, joint hierarchy is shown in the Scene Graph. Only individual 
joints can be modified and animated. 

1. In the Menu Bar, select File > Import, locate a file with joints and/or meshes, and click 
Open. 

2. In Import File(s), disable Center in Origin and Put onto the Ground. These compute and 
apply a translation for the imported node, affecting the mesh, which can lead to 
misalignment of the skeleton and mesh. 

3. Enable any other import options and click Import. 

Which Operations Skip Skinned Meshes 

The following operations skip skinned meshes: 

• Merge Geometry 
• Normal/Tangent/Binormal Recalculation 



• Decore 
• Subdivisions 
• Light Baking Subdivisions 
• Split/Unsplit Geometry 
• Octree calculation 
• Flush transformations (also skipped on Joint nodes) 

How to View Joints 

To turn joint visibility on in the Viewport, select View > Show Joints. 

 

To view joint hierarchy, open the Scene Graph by selecting Scene > Scene Graph. Joint nodes 

are represented by . 

 



How to Use Duplicate/Cut/Paste/Delete with Joints and Meshes 

• If you Duplicating/Cut/Paste only a mesh, the skinning information will be detached. 
• If you Duplicating/Cut/Paste a mesh and joint, the hierarchy will adjust the duplicate's 

joint references in the skinning information, so it refers to the joint hierarchy duplicate. 
• If you only Delete or Cut the joint hierarchy, this permanently removes the mesh's 

skinning information. 

How to Transform Skinned Meshes 

To move a skinned mesh to a certain position in the scene, move the skeleton. Since the mesh 
is bound to the skeleton, it will automatically move with the skeleton. If you transform joint 
nodes, the mesh will become deformed, resulting in the mesh and joints becoming misaligned. 
This is why the transformation of the mesh must NOT be changed. So, if you wanted to move 
the entire mesh to a different position, as mentioned above, select the skeleton at the root 
joint node, then move it. 

NOTE When transforming geometry with a skinned mesh, if both are selected, the geometry is 
transformed twice. Why this happens is because the transform is being applied once to the 
group (geometry and rig) and again to the geometry directly. 



Using Undo and Redo in VRED 
You can undo and redo actions in VRED, as you would in most applications, using Edit > Undo 
(Ctrl+Z) and Edit > Redo (Ctrl+Y). VRED also includes some features for managing Undo actions. 

How to Clear an Undo Stack 

This removes stored Undo actions to clear memory for other tasks. 

In the Menu Bar, select Edit > Clear Memory Stack. 

How to View the Undo/Redo History 

This displays a brief history of actions in VRED. 

In the Menu Bar, select View > Undo/Redo History. 

How to View and Empty the Trash 

The Trash container contains items deleted from your scene. These can be restored, using 
Undo. However, you can delete these items from the Trash to clear memory for other 
processes. Once an item is deleted, even using Undo cannot restored it to the scene. 

To view and empty the trash: 

• To view the contents of the trash, in the Menu Bar, select View > Trash. 
• To empty the trash, in the Menu Bar, select View > Trash then right-click inside the 

Trash dialog box and select Clear. 

 



About Shared Views 
Shared views are online visual representations of the view of 
your model or design uploaded from an Autodesk product. By 
default, these shared views expire after 30 days. You can 
upload a shared view free of any intellectual property. 

When you create a shared view, a pop-up window appears 
with a link to the shared view in the Autodesk Viewer. This 
makes it easy for you to send the link to others. They can 
review and post comments directly in the Autodesk Viewer. 
No Autodesk product is required. 

Why use shared views 

Do you want to collaborate on a visual representation of your 
model or design online? If so, Shared View is your tool. For 
example, you create a shared view to request approval from 

a client. Maybe your field sales team needs easy access for an on-site presentation. Using the 
link you provide (generated with Shared View), anyone can view and comment on the content 
without having an Autodesk product installed. When anyone comments on the shared view, 
you receive an email. View and reply to comments, manage your shared view, directly from 
your Autodesk product. 

About the Shared Views list 

As the owner, you use the Shared Views list with the 
Autodesk Viewer to quickly access your shared views, start 
new comment threads, and reply to comments. The Shared 
Views list also provides management options, such as 
extending the expiration date and deleting a shared view. 

Shared Data 

Do you need LMV files for visualization? Upload VRED files to 
a cloud server that converts them into LMV files. Now, the 
model can be opened in a cloud-based LMV. 

NOTE Directional lights and switches aren't supported. 

https://viewer.autodesk.com/
https://viewer.autodesk.com/
http://help.autodesk.com/cloudhelp/2019/ENU/VRED/files/Files-and-Data/About-Shared-Views/Working-with-Shared-Views.HTML


Working with Shared Views 
Shared views are online visual representations of the view of your model or design for others to 
view and comment on. 

Working with shared views can include creating shared views for sharing content, as well as 
disabling shared views to ensure private content is not shared. 

If it is your first time using Share View, follow the steps below. If you have used it before, jump 
to step 4 and follow the steps. 

How to Create Shared Views 

1. With your scene loaded in VRED, from the menu bar, select File > Share View. The 
Shared Views dialog appears. 

 

2. Click the Sign into your Autodesk account link. This opens the Autodesk Sign In dialog. 

 



3. Enter your Autodesk account credentials and click Sign In. The Shared Views dialog 
changes. 

 

4. Click New Shared View. The Create New Design Share dialog appears. 

 

5. Click the ShareViewFile field, enter a file name, then click Publish. Once the publishing 
process starts, the Upload Progress dialog appears. When it is finished, an Upload 
Finished dialog appears. 

 

 

6. Click one of these two buttons: Get Share Link or View in Browser. 



How to Get a Share Link 

A new shared view appears at the top of the Shared Views list. 

 

An email containing a link to the shared view is created. 

How to View in a Browser 

Click the View in Browser button to launch the Autodesk Viewer to interact with the 
shared view. 

NOTE Another way to access these options is by clicking ... , then select Copy link or 
View in browser. A short link will appear in the dialog that appears that can be copied 
when you click the OK button. 

  



Disabling Shared Views 

Use the following system environment variable ( VRED_DISABLE_SHARED_VIEWS ) to 
remove the menu option Share View from the File menu. 

Why Disable Shared Views 

Some companies worry about the accidental uploading of models to the ADSK cloud. By 
disabling this option, it is impossible to do this. 

How to Disable Shared Views on Windows 

1. Access your Control Panel. 
2. In the search field at the top of the window and to the right, type: environment variable 
3. On the new page, click the link for editing the system environment variables. This opens 

the Advanced tab of the System Properties window. 
4. Click the Environment Variables button. 
5. In the System variables section, click the New button to open the New System Variable 

window. 
6. Enter the name of the variable ( VRED2019\_SCRIPT\_PLUGIN 

VRED\_DISABLE\_SHARED_VIEWS ), followed by the value (C). 
7. When finished, click OK. 

How to Disable Shared Views on Mac 

1. Open a terminal window. 
2. Type the following command: export <variable name>=<value> 

export=VRED\_DISABLE\_SHARED_VIEWS=C 



Enabling and Disabling Outbound 
Communication 
Some companies are concerned their proprietary and confidential files could accidentally be 
sent outside of the company. The following two batch files were added to enable and disable 
dark site mode and enable or disable outbound communication. 

How to Enable Outbound Communication 

Enable outbound communication so you can share views of your content with people outside of 
your organization. 

1. From the Windows Start Menu, scroll to the Autodesk VREDPro <version number> 
folder and click it. 

2. Select Enable Outbound Communication. 

 

 



How to Disable Outbound Communication 

Disable outbound communication so you can protect your content from accidentally being sent 
to people outside of your organization. 

1. From the Windows Start Menu, scroll to the Autodesk VREDPro <version number> 
folder and click it. 

2. Select Disable Outbound Communication. 

 



Using Python in VRED 
Though VRED has all sorts of tools for working with your files, there is so much more you can do 
once you start scripting in Python. Customize VRED to your liking using logic written in Python. 
Make something to work differently or add custom operations, menus, or options with the help 
of Python. 

There is an assortment of Python examples provided with VRED to help you understand how 
Python works. In the Menu Bar, select Help > Python Documentation to access the Python 
documentation. 

In 2019, we added HTML 5 integration. Using HTML5, you can create overlays and more, then 
use Python to talk with VRED and execute the action. 

HTML5 

Use the Python docs (Help > Python Documentation) to find the Python command you want, 
such as a create, edit, or toggle command. Let's start with a small tutorial to walk you through 
an example of how you might use HTML5 with Python in VRED. 

In this example, we will add code to HTML5 and Java Script files to add a button to a pre-
existing interface that will create a cone when clicked. The changes we will do will affect the 
Plane node, found under the Perspective node. The files needed for this can be found here. 
Save the files to C:\\ProgramData\\Autodesk\\VREDPro-11.0\\Examples\\script. 

The Python Command 

We will get the Python command (createCone) from here: Help > Python Documentation. 
Search the list along the left for createCone. Click the createCone link for an explanation of 
the command and information about its parameters. 

createCone ( height , radius , sides , create\_side , create\_bottom , red , 
green , blue ) 

How to Load the VRED File 

Open VRED and select File > Open, then browse C:\\ProgramData\\Autodesk\\VREDPro-
11.0\\Examples\\script, select fullscreenmenu, and click Open. 

http://download.autodesk.com/US/VRED/2019/VRED_PYTHON_SCRIPT.ZIP


How to Add Code to index.HTML 

We want to add a button, labeled Cone, to the existing HTML5 code. When you click this 
button, it will create a cone. All the information about the cone, such as its size, color, and 
placement will all be defined in your script.js file. 

1. Open a text editor (I used Notepad for this), then open index.HTML 
(C:\\ProgramData\\Autodesk\\VREDPro-11.0\\Examples\\script\. 

NOTE If you don't see any files, change the type of file from Text Documents (*.txt) to 
All Files. 

2. Add this line just above </div>: 

<button class="button" onclick="createCone()">Cone</button> 

3. Save your changes. 

How to Add the Cone Code to script.js 

In the Python documentation, we are given this: createCone ( height , radius , sides , 
create\_side , create\_bottom , red , green , blue ). We need to enter values for 
each of these parameters. 

1. In the text editor, open script.js (C:\\ProgramData\\Autodesk\\VREDPro-
11.0\\Examples\\script\). 

NOTE If you don't see any files, change the type of file from Text Documents (*.txt) to 
All Files. 

2. Scroll to the bottom and place your cursor after };, 
3. Press your Enter key 3 time to add empty lines after it. 
4. Paste the following Python code from the Python documentation at the bottom of the 

file. 

function createCone() { 

sendPython("createCone( height , radius , sides , create\_side , 
create\_bottom , red , green , blue );"); 

}; 

5. Set following values: 
o For height = 1000 
o For radius = 150 



o For sides = 30 
o For create_side, since it is a type bool, it needs a true or false = true 
o For create_bottom, since it is a type bool, it needs a true or false = false 
o For red = 0.5 
o For green = 0.3 
o For blue = 0.4 

Your final code will look like this: 

function createCone() { 

sendPython("createCone(1000, 150, 30, true, false, 0.5, 0.3, 0.4);"); 

}; 

6. Save your changes and close the editor. 

How to Enable the Web Server 

When using HTML5 and Python, you need to enable the Web Server to see your work. 

1. Select Edit > Preferences > WebInterface. 
2. Check Enable Web Server. A dialog appears. 
3. Click Enable. 
4. Click Apply and OK. 

How to Reload the HTML5 Changes 

Since changes were made to the HTML5 file, you will need to reload it into the WebEngine. 

1. Select Scene > Media Editor to open the Media Editor. 
2. Select WebEngine. 
3. In the parameters to the right, click (Redo the Web Page). The new button should 

appear in your scene. 
4. Close the editor. 

How to Test Things 

If you want to test the function to see if it works, in VRED, there are two ways: 

Open the Scene Graph, then at the bottom of the window, click  (Terminal) to open it. In the 
root: field, enter: 

createCone(1000,150,30,true,false,0.5,0.3,0.4); 



A Geometry node should appear in the Scene Graph. This lets you know it worked. Select the 
node and press your Delete key to remove it. 

In VRED, click the new Cone button. If it works, in the Scene Graph, a new Geometry node 
appears. 



Mathematical Expressions in Numerical Inputs 
In any VRED function that allows numerical input, you can use a mathematical expression in 
addition to numeric values. 

• Valid operators are: +, -, *, /, and ( ). 
• Relative operators, that change the current value, are: +=, -=, *=, and /=. 

Here is an example of using valid and relative operators: To divide a current value of 10 by 2, 
enter as 10/2 or /=2. The equal sign represents the current value. 

If the expression is not valid, the input field has a yellow border. Once a valid expression is 
entered, the input field has the normal orange border when the mouse is hovered over it. 



Preferences 



Editing Preferences 
Use the VRED Preferences to customize your experience. Click an option listed under Module to 
load those preferences into the panel to the right. For information on a particular preference, 
see the other help preference topics. 

1. In the Menu Bar, click Edit > Preferences. 

 

2. Select the category you want to set preferences for on the left side of the dialog box. 
3. Make your changes. 

 
o OK: Closes the Preferences window, applies changes to the scene, and saves 

changes. 
o Cancel: Closes the Preferences window and does not save changes. 
o Apply: Leaves Preferences window open, applies the changes to the scene 

immediately, but does not save changes. 
 

4. Optional: To restore the default settings for the selected category, click Load Default. 
5. Optional: To restore default settings for all preferences, click Load All Defaults. 



Annotation Preferences 
Preferences affect annotations created after settings are applied. Pre-existing annotations and 
opened .vpb files are not affected by preference settings. Preference settings are used on 
annotation XML files, created before VRED 2018.2, that do not contain individual annotation 
properties. 

In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select 
Annotation. 

Properties 

• Use Node Visibility - Uses the visible state of the node the annotation is associated 
with. If the node is invisible, so is the annotation. 

• Font Color - Color of the text in the annotation. 
• Line Color - Color of the line and box of the annotation. 
• Background Color - Color inside the box of the annotation. 
• Background Transparency - Transparency of the background color. 

Size 

• Size - Adjust the size of the entire annotation. 
• Dynamic Scaling - Vary the size of labels, based on their depth within the viewport; for 

example, the label of an object that appears closer in the viewport has a bigger label 
than an object farther back. There are three scaling options: 
 

o Near - Labels are smaller; appropriate when working close to the screen. 
o Far - Labels are larger; appropriate when working further away from the 

computer screen, for example when sharing a presentation with others. 
o Off - Labels are larger and all the same size. 



Animation Preferences 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select 
Animation. 

Base 

• Time - Set the number of frames rendered per second of animation. 
• Keep Keys at Current Frames - When selected, all keyframes remain in their global 

position, even when changing the global time. As a result, those curves are modified. 
When deactivated, keys may map to a different frame when the global time value is 
changed. 

• Verify Clip Structure - When selected, unreferenced animation blocks and empty clips 
are removed when importing a VRED file. 

• Don't show Create Curve Dialog - When selected, the Create Curve dialog no longer 
appears. 

Playback 

• Playback Speed - Set the number of frames processed per second. 
• Playback Range - Select whether the full or detailed range is played. 
• Evaluation Context - Define which curves are calculated. When set to Scene, all active 

curves and blocks are examined. When set to Curve Editor, only the curves currently 
displayed in the Curve Editor are examined. 

• Loop - Toggle playback looping. For continuous looping of playback, toggle this on. 

Timeline 

• Full Range Start - Start frame for the complete timeline. 
• Full Range End - End frame for the complete timeline. 
• Detailed Range Start - Start frame for the current part of the timeline. 
• Detailed Range End - End frame for the current part of the timeline. 



Asset Manager Preferences 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select Asset 
Manager. 

• Search Paths - Use the four tabs to display paths where VRED can reference assets 
(complete scenes), geometry, materials, and environments. Use the buttons on the 
bottom to add, change, or remove paths from the lists. 

• General - Select the file format in which preview images will be generated. If you are 
working with sensitive content and want to generate images that can only be read by 
VRED, select VIF. 

• Material Assets - This section contains the following options: 
 

o Generate Automotive Material Files: Choose whether to create Automotive 
Material files or not. 

o Incandescence Adjustment: Set whether the incandescence of your materials is 
adjustable or not. 



Camera Preferences 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select Camera 
Preferences. 

Base 

• Field of View - Set the standard preset for the Field of View (FOV) in degrees. 

Stereo 

• Eye Separation - Set the distance in millimeters between the left eye and right eye in 
stereoscopic view. 

• Zero Parallax Distance - Set the focus point in millimeters in stereoscopic view. 

Powerwall 

• Projection Width - Physical projection width in millimeters. 
• Projection Height - Physical projection height in millimeters. 
• Projection Distance - Distance between projection plane and observer in millimeters. 



Cluster Client Preferences 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select Cluster. 

Base 

Default Config File - Set the root of the configuration file (XML) for cluster setup. The default 
file and other sample files are found in the cluster subfolder of the VRED installation folder. 

License check out 

Consumption based - A consumption-based licenses cost depends on usage time. 

• Off: Consumption-based licenses are not used. 
• On: Consumption-based licenses are used. 
• Combined: Normal cluster licenses are used first. If enough cluster licenses are not 

available, more consumption-based licenses are used. 

Check out all licenses from master - When cluster nodes do not have network access to the 
license server, the number of required licenses is checked out from the host where VREDPro is 
running. 



Collaboration Preferences 
Learn about the collaboration preferences and how to set your profile and session address, as 
well as change avatar proximity fading. 

NOTE There are two sets of preferences, Collaboration and Virtual Reality, that affect your 
experience in VR. See Virtual Reality Preferences for information on general VR and StarVR 
preferences. 

Use these preferences to set Collaboration module preferences, such as your name, room, and 
color, so these fields are automatically filled in whenever you enter a session. 

 

My Profile 

Click within each field and enter your information to setup your profile. 

• Name - Enter the name displayed in the Participant List and above your avatar. By 
default, your PC login is used. 

• Room - (Only for participants using HMDs) Enter the name of the VR room you are in. 
This let VRED know where you are in the same real-world space to avoid collisions. 

NOTE  For HMD users, all PCs in the same real-world space MUST set the same Room 
name. This tells VRED to enable safety mechanisms for these PCs to help avoid real-
world collisions. See this section for how to set up a room. 

• Color - Select a color from the drop-down menu to set your color in the Participant List 
and for your desktop or VR avatar. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Preferences_Virtual_Reality_Preferences_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Setting-Up-a-VR-Room#understanding-the-safety-twin
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Collaboration_Setting_Up_a_VR_Room_html


Session 

Enter information for setting up a collaboration session. 

Address - Click within the Address field and enter the IP address for the session or PC name for 
the server hosting the session. If you have a permanent server used for VRED collaboration 
sessions, add it here. 

IMPORTANT  This server must be running the cluster service to host the session and must be 
reachable on the network by all participants.  

Avatar Proximity Fading 

Set the distance at which other participants' avatar opacity starts to fade, becoming more 
transparent. When there are many HMD participants crowding around an area, the Avatar 
Proximity Fading settings fade out the avatars, so your view is unobstructed. 

Python Functions for Avatar Proximity Fading 

As participants get closer, the opacity of their avatar fades, becoming more transparent. These 
parameters set the threshold for distance at which your avatar begins to fade (Avatar Proximity 
Fading). 

• Opaque Distance - Set the distance of when your avatar's opaqueness starts to fade, 
using either the sliders or by entering numeric values. The default distance before your 
avatar starts to fade is 1000 mm (1 m). 

NOTE  You can also use these Python functions to define the distance for when the 
regular avatar is shown and when it fades out: 

 
```vrSessionService.setAvatarProximityTransparentDistance(value) 

• Transparent Distance - Set the distance of when your avatar's transparency stops 
fading, using either the sliders or by entering numeric values. The default distance when 
your avatar stops fading is 400 mm (0.4 m). 

NOTE  You can also use these Python functions to change the Transparent Distance of 
when the safety twin stops fading: 

 
```vrSessionService::setAvatarSafetyTransparentDistance(maxDistance) 

Here is how these work: 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Setting-Up-a-VR-Room#understanding-the-safety-twin


• If the distance is < minDistance, the safety twin is visible. 
• If the distance is > maxDistance, the safety twin is hidden. 
• If the distance is between minDistance and maxDistance, the safety twin is faded in. 

How to Set Collaboration Preferences 

1. Select Edit > Preferences > Collaboration to set your profile and session information. 
2. Click within each field and enter information to setup your profile. 
3. When finished, click OK. 



Color Management Preferences 
Set paths to custom color profile files (.icc) for color mapping. In some cases, profile files are 
available from third-party manufacturers; for example, for monitors. 

In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select Color 
Management. 



Copy and Paste Preferences 
• Paste Options - In the Menu Bar, click Edit > Preferences, then on the left side of the 

dialog box, select Copy and Paste. 
• Paste Touch Sensors - Pastes all touch sensors from the copied nodes and their 

subtrees. Before doing this, check whether you want this before continuing. 
• Paste Animation Curves - Pastes all animation curves from the copied nodes and their 

subtrees. Before doing this, check whether you want this before continuing. 
• Merge Materials - Merges all materials with the scene's material pool. Before doing this, 

check whether materials from the copied nodes and their corresponding subtrees 
should be merged with the scene's material pool or not. All materials are compared with 
the pool materials. If all properties of a material are equal with one in the pool, 
including its environment, it is not added as an additional material. Instead the material 
from the pool is used. If a material has no counterpart in the pool, it is added. If this is 
unchecked, all materials are added to the pool, which may result in copies of materials. 

• Environments - Merge with Scene: Merges the environments with the environments in 
the scene, using the same strategy as merge materials. 
 

o Use Scene Default - Discards all environments and sets the default environment 
of the scene to all materials. 

Note: If this option is selected, the material comparison assumes the default 
environment as the environment set for the copied materials. 

o Add Copy to Scene - Adds a copy of the environment to the material pool. If the 
environment is a switch, all environments of the switch are copied, as well. This 
option is only available when materials are not merged, so the Merge Materials 
option must be toggled off. 
 

• Show Dialog - When checked, the dialog will not reappear and the copy paste will apply 
the last given settings. 



Devices Preferences 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select Devices. 

Space Mouse 

• Enable 3D Mouse - Use to enable the 3D mouse, provided you have installed the 
appropriate drivers. 

• View Mode - Select to either control the camera or manipulate an object. 
• Rotation Pivot - Move around the camera, the selected object, or the focus distance. 
• Enable Two-Axis Mode - On/Off 
• Helicopter Mode - Define the height and tilt. 
• Height - Define the Helicopter Mode height in millimeters. 
• Use Fixed Height - On/Off 

Joystick 

• Use Joystick - Activate the use of a joystick for navigation. 
• Id - Enter the device ID. 

Sample settings for a Logitech RumblePad 2 

These are suggested Logitech RumblePad 2 settings to use with Autodesk VRED. 

• Left joystick - Trackball-like navigation. Rotates around the at-point. 
• Left joystick + L1 - Rotates the camera. 
• Left joystick + L2 - Pans the camera. 
• Right joystick - Zooms. 
• Button 1 - Shows the whole scene. 
• Button 2 - Shows the Initial Camera View (ICV). 



Export Preferences 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select Export. 

Cube Image 

• Resolution - Select a render resolution for cube images. 
• Supersampling - Select a supersampling quality for cube image rendering. Higher values 

may impact performance. 
• Type - Set the type of cube image rendering: 

 
o Separate Images (six planar images) 

 

o Vertical Cross rendering      

 

o Horizontal Cross rendering  

 

o Spherical Map rendering      



FileIO Preferences 
Sets the global File I/O settings in VRED. 

In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select FileIO. 

Base 

• Verify Geometry - During import, checks the structure of the geometry is suitable for 
rendering. 

• Optimize Geometry - Rebuilds geometry optimized for the VRED Scene Graph. 
• Temporary Path - Displays a temporary path for the files. Use the icon to the right to 

browse to a different location. 

Import Dialog 

• Show Dialog - Opens a preferences dialog when you try to import a supported file 
format. When disabled, the defined preferences are used. 

• Center to Origin - Places the imported objects in the origin of the scene. 
• Place Objects on the Ground - Places objects on the ground. 
• Adjust Object Size - Resizes objects on import, enabling you to work with fitting scales. 

This can be useful for a file whose scaling is incorrect, or whose units are not being 
imported properly. An incorrect scaling may directly impact many settings, such as 
flakes. Choose between objects that relate in scale to the type of objects in your scene; 
for example, cell phone (small), big car (moderate), house (large). 

Texture Compression 

• Mode - Determines how to or whether to compress textures on import. Select one of 
the following options: 
 

o None - No compression at any time. 
o Auto - Compression if texture size exceeds graphics board memory limit. 
o Always - Compression for all loaded textures. 

 
• Video Memory Limit - Set the video memory limit, in Megabytes, to use for texture 

compression. 

Texture Search Paths 

Use this tab to add paths where VRED can search for textures. 



Base CAD Preferences 

Base 

• Keep Surface Data - Keep NURBS data after tessellation instead of deleting it. This is 
useful for re-tessellation later, or for direct NURBS rendering, but uses more memory. 

• Merge Geometries - A single shell can have many NURBS surfaces. Merge the 
geometries to give you one single (stitched) mesh; otherwise you have one mesh per 
surface. 

• Create Groups for Layers - Items that are originally organized in layers (for example, in 
Autodesk Alias) are organized into groups. Otherwise, the objects are all placed under 
the same parent node. 

• Remove Empty Groups - Remove empty (unnecessary) groups. 
• Unshare Nodes - Shared node instances, used to save system memory, are removed so 

that nodes exist independently. 
• Flush Transformations - Transformation data is stored within objects themselves rather 

than in higher-level group nodes. In other words, if you have a hierarchy of 
transformation parent nodes of a geometry node, all of them are baked into one single 
matrix within the geometry; the original information is lost. You would want to avoid 
this, for example, for animating wheels on a moving car. 

• Import Curves - Includes curves when importing a file. Otherwise, they are excluded. 
• Chord Deviation - The maximum deviation between the NURBS surface and the 

tessellated surface. A low value results in a more accurate polygon model but also 
increases the number of triangles. 

• Normal Tolerance - The Normal Tolerance is the allowed normal deviation between the 
normals on the ends of a tessellated edge. 

• Max Chord Length - The maximum edge length of the generated polygons. Long 
polygon edges might not be smoothly shaded in the render view; use this setting to 
avoid this condition. 

• Enable Stitching - Enables stitching of adjacent edges. 
• Stitching Tolerance - Sets the tolerance where two adjacent edges are considered to be 

touching and where they should be stitched together. 

Advanced 

For advanced options, see Import Options Dialog Box. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Files_and_Data_About_the_Import_Files_Dialog_html


FBX Preferences 
FBX transfers files from one file format to another. 

Export Settings 

• Version - Select a version of FBX for export. 
• Format - Select Binary or ASCII. 
• Export Vertex Colors - Exports VRED's ambient Occlusion calculation as vertex colors. 

This results in unmerged triangle vertices. 



JT Preferences 

Legacy Loader 

• Use Legacy JT Loader - Bypass the Autodesk loader settings of VRED and instead use the 
legacy JT file sharing protocol. 

• Use Active Layerfilter - Use layer filters and disable inactive Nodes. 
• Breps Handling - Manage objects with exact boundary representation surfaces. Use the 

options to load and tessellate all Breps, or load the Breps of your choosing without 
tessellating. 



Maya Preferences 

Base 

• Maya Directory - Enter the Maya installation path. 

Loader 

• Force Grayscale Shadow Texture - Convert all shadow textures from RGB to grayscale 
textures. 

• Use Local Material Library - Use the local instead of external material library. 
• Units - Set the units to be used for imported data. 

Writer 

• Units - Set the units to be used for exported data. 



OSB/VPB Preferences 
OSB and VPB are the standard binary file formats of VRED. Use OSB to exchange geometrical 
nodes on export. VPB can contain all available VRED node types; use it in the Save or Save As 
dialog boxes. 

Loader 

• Checksum Test - The Checksum Test makes sure that the file was successfully read after 
loading into VRED. The Checksum Test causes longer file loading times. 

• Calculate missing variant set previews - Generate missing preview images for 
VariantSets. 

• Execute Embedded Script - Scripts that have been saved within the VPB are executed 
when the file is loaded. 

Writer 

• File Compression - VRED files can be saved with file compression to reduce size. Define 
compression quality with these options. 
 

o Off - No compression; results in larger files but short saving and loading times. 
o Fast - Moderate compression; results in smaller files and moderate save and load 

times. 
o Best - High compression; files need less space, but saving and loading is longest 

with this option. 
 

• Write Compatible (<6.0) Format - Save VPB/OSB files to be compatible with VRED 
versions that precede 6.0. 

• Validate Written File - Validate all written data; may increase write time. 
• Use Inline Textures - Include all scene textures in the file. 
• Texture Compression 

 
o None - No compression, textures are unchanged. 
o Lossless - Compresses all textures without loss of data. 
o Lossy - Provides greater compression (smaller file sizes), but with some loss of 

quality. 
 

• Quality - For lossy compression only; higher quality corresponds to less compression, 
and lower quality corresponds to higher compression. 



Incremental Save 

• Enable Incremental Save - Store incremental versions of the file. The number of 
versions is defined in Number of Increments. 

• Number of Increments - The number of backups saved by the incremental save 
function. 



Rhino Preferences 

Base 

• Merge Geometry - A single shell can have many NURBS surfaces. Merge the geometries 
to give you one single (stitched) mesh; otherwise you will have one mesh per surface. 

• Import NURBS - Select whether or not to import NURBS (Non-Uniform Rational B-
Splines) data; you might deselect this if you prefer to work with polygons only. 

• Import NURBS - Select whether or not to import NURBS (Non-Uniform Rational B-
Splines) data; you might deselect this if you prefer to work with polygons only. 



STL Preferences 

Writer 

• STL Export Format - Select a format in which to write STL files: 
o Ascii - File is legible in the editor, but reading and writing is slower and requires 

more disk space. 
o Binary - File is illegible in the editor, but reading and writing is faster and uses 

less disk space. 



WRL Preferences 

Loader 

• Optimization (Auto, Catia, Pro Engineer) - Optimize loading time for files. Complex data 
structures such as Catia and Pro Engineer’s VRML files can impact load performance. 
These optimizations enable you to display these files much faster than usual. Select 
Auto to apply automatic optimizations regardless of the file origin. 

Writer 

• Inline Textures - Include all textures in the file instead of referencing them externally. 



Final Render Pass Preferences 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select 
FinalRenderPass. 

Base 

• Default Config File - Sets the default configuration file to use for the final render pass. 
Click the icon to the right to browse to a different location. 



Help Preferences 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select Help. 

• Help Location - Specify whether VRED uses online Autodesk Knowledge Network help or 
installed offline help. 

If Installed Help is selected, enter the location, either a file system path or a URL. For 
example: 

/CDROM/html 
file:///c:/Docs/VRED/Help 
http://webserver/docs/VRED/help 

You must set this option to open the help from the Help menu. 

• Popup Help - Display short text hints that appear in the interface when the mouse 
cursor hovers over a tool icon for longer than 1 second (Simple Toolclips) or longer text 
hints (Toolclips). 



Import Preferences 
Define CAD data and tessellation settings for import. 

In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select Import. 



Optimizer Preferences 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select Import > 
Optimizer. 

Advanced 

• Optimizer Rendering Compatibility Mode - Tries to render the imported geometry in 
accordance with the Optimizer renderer (disabled state sorting). 

• Remove Vertex Colors - Removes the vertex color information of the geometry nodes. 
• Merge Shape Geometries - Tries to merge all geometry children of a shape node. 
• Shadow Conversion - Provides the following options for shadow conversion: 

 
o Remove Shadow 
o 2 Geometries / 2 Materials 
o 1 Geometry / 1 MultiPassMaterial 
o 1 Geometry / 1 MultiTextureMaterial 
o 1 Geometry / 1 MergeMaterial 



Tessellation Preferences 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select Import > 
Tessellation. 

Tessellation Quality 

• Tolerance - Sets the maximum triangle aberration for tessellation from the b-splines. 
When you add further tessellation tolerances, an LOD (Level of Detail) node is generated 
for each imported file. The tolerance values define the tessellation aberration for each 
child of an LOD node. The number of children is defined by the number of tolerance 
values. 

• Offset Factor - Sets the offset when adding new tolerance values. 

Tessellation Topology 

• Topology - Offers three different options to tessellate geometries. 
 

o Create New - Rebuilds new geometry, based on the imported b-splines. 
o Reuse Ex... (If Any) - Refines the existing geometry, according to the tessellation 

settings. The new tessellation is based on the currently set tessellation in the 
imported data, if it exists. 

o No Topology - Does not tessellate geometries. 
 

• Tolerance - Aberration of the tessellated geometries from the b-splines. 
• Check Orientation - Makes sure that normals of seamless patches are pointing in the 

same direction. 



MainWindow Preferences 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select 
MainWindow. 

Base 

• Show FPS in Status Bar - Show the current frame rate in the lower left corner of the 
Render View. 

• Show Rendering Log Messages in Terminal - Shows all log messages in the Terminal 
window during rendering. 

• Show Tool button Text - Shows hint text for buttons. 
• Window Opacity - Sets the opacity for all module windows. 
• Disable Docking - Toggles docking capability for VRED module windows. 

User Language 

• User Language - Sets a language displayed in the interface. 

Issue: For MAC 10.13.x users, once VRED 2019 is installed, the UI defaults to English, not the 
language you expect. 

Solution: In VRED, select Edit > Preferences > MainWindow, then under User Language, set the 
language you want. Click Apply, then OK. Restart VRED. 



Navigator Preferences 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select 
Navigator. 

Base 

Navigation Mode 

Sets how the camera can rotate. 

• Trackball - All camera rotation axes are unlocked. The camera rotates freely in all 
directions. 

• Two Axis - The camera has only two free rotation axes, while the third, the roll axis, is 
locked. 

• Fly - Suitable for space mouse navigation. The camera pivot is fixed to the camera's 
center. The camera can be placed and orientated freely in 3D space. 

• Orientation - The camera keeps its position in space. All that changes is the orientation 
of the camera. This is similar to turning your head to look in another direction. 

• Auto Center - In Two Axis and Trackball modes, places the rotational pivot at the center 
of the object at the center of the Render View. 

• Pivot based panning - Bases the panning speed on the distance to the pivot, instead of 
using the click position. 

• Panning Speed - Adjusts the panning speed. Enter a value or use the scroll wheel. This 
option is available once Pivot Based Panning is selected or when Speed Mode is set to 
Linear. 

• Speed Mode - Contains the following options: 
 

o Unconstrained - Resembles the old VRED behavior, which slows navigation when 
getting close to the navigational pivot. 

o Limited - Constrains the dolly speed to a minimum value, giving a more natural 
feel. 

o Linear - Uses a constant speed for dolly operation. 
 

• Dolly Speed - Adjusts the Dolly speed. Enter a value or use the scroll wheel. 
• Dolly Axis - Contains the following options: 

 
o Vertical Only - Dolly by holding the RMB and move the mouse vertically. 
o Horizontal Only - Dolly by holding the RMB and move the mouse horizontally. 
o Horizontal and Vertical - Dolly by holding the RMB and move the mouse 

vertically or horizontally. 



• Invert Dolly Axis - Inverts the Y-axis for the dolly operations. The X-axis remains 
unchanged. 

• Invert Wheel Dolly - Inverts dolly direction when using the scroll wheel. 
• Dolly to Pivot - Sets the dolly operation towards the pivot, instead of the screen center. 

Animate camera change - Animates changes in view; for example, after double right-clicking in 
the Render View to set the rotation pivot. 

• Duration - Sets the time used to animate a camera change. 
• Orbit Mode - Isolates rotation or translation navigation to the vertical or horizontal axis. 
• Orbit Detection Area - Sets the area to detect mouse operation to enable orbit mode. 
• Orbit Detection Time - Sets the time to detect mouse operation to enable orbit mode. 

Friendship Bridge 

• Interaction Mode - Offers the ability to change the look and feel of navigating and 
selecting within the Render View. You can choose between VRED, Alias, or Maya. VRED 
is the default. 



OpenPDM Preferences 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select 
OpenPDM. 

Base 

• Unit Scale Factor - Scales the incoming values from OpenPDM to match VRED units. 

NOTE To set the unit scale, use the python function: setUnitScale() 

NOTE To get the unit scale, use getUnitScale(). 

• Enable debug mode - Enables enhanced logging in the VRED terminal. 
• Debug Output Folder - Displays the folder where debug files are saved. Click the icon to 

the right to change the location. 

Connection 

• Server - Displays the OpenPDM server address. 
• Port - Displays the server port. 
• Webdav User - Displays the user name for accessing the OpenPDM Webdav, once you 

have entered it. 
• Webdav Password - Stores the Webdav user password, once you have entered it. 

Project 

• Components Strategy - Sets whether you update or revise changes when saving a 
project. 

• Referencing Strategy - Sets where to reference from, the root or only leaves. 
• Update Interval - Sets the time interval for update checks. 



Plugins Preferences 
Loads all checked plugins on startup. Deselect any plugins you do not want to load. 

In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select Plugins. 



Raytracing Cluster Preferences 
• Default Config File - This configuration file is loaded on startup. 
• Consumption Based License Check Out - Use a special license for consumption-based 

billing. 
• Check Out All Licenses From Master - If the cluster nodes are not able to connect a 

license server, licenses for all nodes can be checked out from the master. 



Render Options Preferences - Visualization 
Advanced tab 
In the Menu Bar, select Edit > Preferences, then on the left side of the dialog box, select Render 
Options, then the Visualization Advanced tab. 

Advanced Rendering 

• Disable Main Thread Sleep - Prevents the computer from sending the main thread to 
sleep. 

• Use 10-Bit RGB - Offers better image quality, provided your graphics card supports it. 
• Cache Geometry - Uses extra main memory (RAM) to try and improve performance. 
• Force GLFinish - Forces a full sync point for the GPUs, after a buffer swap, when 

rendering is slow, due to background buffers in the GPU driver. 
• Single Pass Stereo - Improves performance by rendering a pair of stereo images in a 

single render pass. 
• Occlusion Culling - Disables the rendering of invisible objects. This can improve 

performance in complex scenes. 

Realtime Antialiasing Presets 

Uses these setting for the Render Options > Visualization > Render Window > Antialiasing 
Quality options. Customize settings for all realtime Antialiasing Quality presets from Low to 
Ultra High. 

• Multisampling - Samples ranges from 1x to 16x. If a platform does not support a 
sampling level, it is silently clamped. 

• Enable Pixelfilter - Enables a triangle pixel filter to use with multisampling. Staircase 
artifacts caused by standard GPU Box filtering are removed. 

• Enable Supersampling - Creates a render buffer with 2x the size and is downscaled with 
a triangle filter. When combined with 16x multisampling, 256 samples are taken. 

• Raytracing - Displays the number of samples, from 1 to 16, used in the raytracer for 
realtime antialiasing. 

Background 

Sets the background colors of the Render View. The background can be a gradient, with various 
colors set at specified positions. Use the Add, Delete, and Choose Color buttons to make your 
list. Define each color using RGB values and with positions ranging from 0 to 1 (bottom to top). 



SLI 

• SLI Mode - Select the SLI mode to distribute rendering across two GPUs. 
 

o Alternate Frame - Sets one GPU to renders all the odd frames and the other the 
even frames. 

o Multicast Stereo - Renders the scene from two different viewpoints, distributing 
the workload across two GPUs. If you use VRED Design and an OpenVR HMD or 
Oculus Rift, use this setting. 



Render Settings Preferences - General Settings 
tab 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select Render 
Settings. 

Antialiasing 

• Use Image Samples - Sets the number of samples taken during still frame antialiasing. 
Higher values produce a cleaner result, while lower values reduce the render time. A 
value of 256 is a good starting point, but may be too low for interior scenes with full 
global illumination. Use this option when wanting to only render a set number of 
frames. For example, if you want 256 frames rendered, you would set Use Image 
Samples to 256. 

• Use Time - Uses time, instead of image samples, to set the maximum time it takes to 
render all still anti-aliased frames. More time produces higher quality images, but uses 
more of your CPU. Less time reduces the quality of the image, but has less impact on 
your CPU. Use this option when wanting to render all frames in a specify amount of 
time. 

• Adaptive Sampling - Enables the raytracer to skip regions that are already smooth and 
focus on regions that are still noisy. 
 

o Preview, Low, and Medium Quality - Uses these for lower quality, but faster 
rendering times. 

o High Quality, Ultra High Quality, and Highest Quality - Uses these for better 
quality, but slower rendering times. Highest Quality disables adaptive 
antialiasing and samples each pixel with the number of image samples specified. 
This setting may use processing power on regions that are already smooth. 
 

• Use Clamping Value - Activates clamping of bright pixels to eliminate white spots after 
antialiasing. The value sets the maximum value for a white pixel. Activating clamping 
and reducing the value, reduces the maximum resulting image color range. 

Pixel Filter 

A pixel filter weighs the image samples taken per pixel and therefore controls the antialiasing 
quality of the rendering. High image filter sizes may result in blurry image results. 

• Filter - Uses your preferred filtering method from the list. See Render Settings under 
Pixel Filter. 

• Size - Defines the number of neighboring pixels in width and height used for filtering. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=The-Render-Settings-Dialog


Features 

• Monitor Luminance (cd/m²) - Sets the luminance value of the preferred display. When 
using photometric parameters, the actual monitor luminance is necessary to reproduce 
the rendering results with realistic photometric values on the display device. 

• Enable Photometric Parameters - Enables photometric parameters for newly generated 
scenes, not to the current scene. For a description of photometric consistent rendering, 
see Render Settings. 

• Enable Spectral Raytracing - Enables the optimization of all light colors when rendering 
an image. In addition to the simulation of more reliable colors of materials, wavelength-
based spectral rendering enables the user to illustrate realistic dispersion effects. See 
Render Settings. 

• Illuminant - Sets the light spectrum considered to be white. Usually this should be D65 
to match daylight. The other option, Equal Energy, uses an equal energy spectrum as 
white. An equal energy spectrum has an equal value for all wavelengths. 

• Optimize for Many Light Sources - Optimizes light calculation by reducing the quality 
slightly, in scenes with many light sources. This increases the rendering performance. 
See Render Settings. 

• Enable NURBS Raytracing - Enables NURBS to be raytraced when working with 
polygons. 

• BRDF Behaviour - Uses the BRDF value that is appropriate for your scene. For 
compatibility reasons, you can choose between VRED version 6.0 and older, or newer 
versions of VRED. See Render Settings. 

Sim2 HDR 

• Luminance Mapping - Sets the luminance mapping for the Sim2 HDR display when 
photometric parameters are enabled. A value of 1 maps a luminance value of 1 cd/m² in 
the rendering to a value of 1 cd/m² on the Sim2 HDR display. 

Sound 

• Play sound after finishing a rendering - Plays a sound to let you know when your render 
is complete. This is useful if rendering is taking place in the background and you are 
working in other applications. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=The-Render-Settings-Dialog
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=The-Render-Settings-Dialog
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=The-Render-Settings-Dialog
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=The-Render-Settings-Dialog


Render Settings Preferences - Ray Tracing Quality 
tab 

Illumination Mode 

Set the default lighting mode for interactive and still frame antialiasing of materials. 

• CPU Rasterization - Does not compute direct reflection, refraction, or any other 
sophisticated visual effect. 

• Precomputed Illumination - Comparable to VRED OpenGL rendering mode, this uses 
precomputed ambient occlusion and indirect illumination for rendering and calculates 
specular reflections and refractions and correct shadows from light sources. 

• Precomputed + Shadows - Uses precomputed image-based lighting and indirect 
illumination, but does not use precomputed ambient occlusion values. Instead, it 
calculates shadows based on the active environment. 

• Precomputed + IBL - Uses precomputed indirect illumination and samples the 
environment. 

• Full Global Illumination - Does not use any precomputed values, however, it accurately 
samples the global lighting distribution in a physically-based approach. Some features 
like Photon Mapping require the render mode to be set to Full Global Illumination. 

Photon Tracing 

Calculate the global illumination in a scene. The default VRED method, full global illumination, 
provides high-quality results, but may require longer calculation times. Photon Tracing can 
reduce the time required to render a clean image, especially indoor scenes. 

The most common photon tracing mode used is Indirect Only. Caustics + Indirect mode 
calculates indirect illumination and caustics, due to specular materials in a scene. 

• Trace Depth - Sets the number of reflections taken into account during raytracing, when 
calculating the color of a photon or ray. 

• Interactive and Still Frame Count - These two photon count values specify the number 
of photons being sent into the scene for each image sample. Specifying a photon count 
of 100 photons, while setting the image samples to 256, results in 25,600 photons sent 
into the scene for a frame. More photons result in smoother results. 

• Photon Radius - Specifies the radius around a scene’s hit-point used by the raytracer to 
find photons. A larger radius allows the raytracer to find more photons, but may result 
in slower lookup times. 

• Interactive and Still Frame Final Gather Quality - There are two ways to use the photon 
map. The first uses caustic photons. It gathers photons around a hitpoint to calculate 



the incoming illumination. This gives fast interactive performance and calculates all light 
paths in a scene; however, it might require a high photon count to get a clean image. 
The second way is to use final gathering. In final gathering, a one-bounce indirect 
illumination is performed before evaluating the photon maps. This function is the 
default photon-tracing approach in VRED, since it generates high-quality images quickly. 
Setting the final gather quality to Off enables the first approach, while setting it to any 
other value uses the second approach. 

• Final Gather Radius - Sets the lookup radius used to find the nearest final gather point 
during raytracing. Using a smaller radius increases performance, but requires more 
photons to avoid dark regions. 

• Final Gather Refresh - If Final Gather Quality is set to 1 or higher, the update frequency 
of the photon map can be set. By default, photon maps are updated for each image 
sample, sending many photons into the scene. If Final Gather Quality is set to Off, it is 
often enough to update the photon map only once per frame and use it for each image 
sample to reduce the render times. 
 

o On Each Sample: Updates the photon map for each image sample. This is the 
default setting, since it also works for scenes with animated objects that may 
otherwise cause flickering. 

o On Scene Change: Updates the photon map once per frame, unless motion blur 
is activated. Since caustics require many photons, the caustic map will still be 
updated for each sample, while the indirect illumination photon map can only 
update once. This setting often results in the best rendering performance, but 
requires a much higher photon count to receive artifact-free results. This is 
particularly true when rendering scenes with animated objects, where the result 
may flicker in regions with a low photon count. Because of this, this mode should 
only be used for scenes with static geometry and materials. 
 

• Use Final Gather for Glossy Reflections - Stops glossy reflections from being evaluated 
by path tracing and uses the final gather map, instead. This feature reduces the render 
time, but results in less accurate reflections. 

Quality and Depth Sliders 

• IBL Sampling Quality - Specifies the number of rays used to sample the environment 
map. More rays give higher quality, but require more time. 

• Reflection/Refraction Sampling Quality - The same principle as IBL Sampling Quality 
applies; set the number of rays used for sampling. 

• Trace Depth - Defines how many interactions (such as reflect and refract) a ray has 
before it terminates. Higher numbers mean higher quality. 



Photon Tracing Notes and Tips 

Photon tracing is useful in interior scenes. In exterior scenes, most light illuminates the scene 
directly, so the VRED default mode of full global illumination is likely to offer better 
performance. 

The number of photons emitted is not the same as the number of photons stored. If a photon 
misses the scene, it is not stored. A photon bouncing several times in a scene might be stored 
more than once. To keep the number of emitted photons as low as possible, place any light 
emitters in a way that most photons hit the scene. 

When using final gathering, scenes may suffer from light leaks, if the photon radius is too large. 
Light leaks result mainly from bad geometry in architectural scenes. An example would be the 
interior of a room illuminated through a window, with the walls being modeled as simple 
planes. Any geometry near the wall would get light from outside the room, since there is no 
actual wall thickness. The solution would be to model the outer walls, as well. Reducing the 
lookup radius may also fix the problem, but may require shooting more photons into the scene. 

Final gathering may also show problems in scenes with strong indirections, where the scene is 
primarily illuminated by light, resulting from reflections off a wall. In these situations, disabling 
final gathering may give you a cleaner result. 



Render Settings Preferences - Advanced tab 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select Render 
Settings. 

Cluster 

Enable cluster mode and enter hostnames to be used to render the scene. The default is 
localhost. 

Snapshot 

Enter a path for where snapshots will be stored. Click the icon to the right to browse to a 
location. 

Signature 

Create a signature to be added to each video or image you produce. The signature format is: 

filename -date -time -comment 

• Add Signature - Adds a signature to each video or image, when enabled. 

Use the remaining controls to format your signature and customize what information gets 
included. 

Position x/y sets the distance of the signature from the lower left corner of the output. 

Color sets the color of the signature text. Use the slider to select the color. 

1 Add Filename adds the filename to the 
signature, when enabled. 

2 Add Date adds the date to the signature, 
when enabled. 

3 Add Time adds a timestamp to the 
signature, when enabled. 

4 Comment adds a comment to the 
signature, when enabled. 



Script Preferences 
Enter scripts or script commands using the Script Editor. They are executed on each startup. For 
further information, please refer to the VRED Python Documentation found in Help > Python 
Documentation. 

In the Menu Bar, select Edit > Preferences, then on the left side of the dialog box, select Script. 



Selection Preferences 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select 
Selection. 

Base 

• Bounding Box Visualization Size - Defines a minimal bounding box size for objects of 
size 0. 

• LOD Selection - Automatically selects all the other children of a distance LOD (Level of 
Detail) node, if the geometry is a child of a distance LOD node and you are selecting a 
geometry node in the Render Window. 

• Auto Scroll to Selected Node - Initiates an automatic scroll in the Scene Graph view to 
the selected node, when selecting a geometry node in the Render Window. 

• Select 100% Transparent Objects - Enables the selection of objects that have 100% 
transparent material from the Render Window. This feature only works in OpenGL. 

Wireframe 

• Enable Wireframe - Draws a wireframe of all selected objects. 
• Always in Front (OpenGL Only) - Draws the wireframe on top of all objects, even if 

other objects cover the selected object. 
• Wireframe Color - Sets the wireframe color. 

Selection Modes 

• Show Preselection Highlight - Displays the bounding box of an object in the preselection 
color before selection. 

• Preselection Color - Sets the wireframe color. 



Substance Preferences 
Make changes to the preferred settings of Substance materials and save them for future use. 

Setting Render Engine Settings 

Determine how Substance textures are rendered. Select one of the following: 

• GPU - This tends to be the preferred setting, as it performs better, is faster, and can 
handle large textures. GPU can compute up to 8K Substance textures. 

• CPU - Use CPU to lower hardware resources when multitasking or rendering. The 
tradeoff is performance. Large textures can be rendered, but it will be slow. 

• Automatic - The Allegorithmic Substance Manager chooses the best option for the 
render engine. 

• In the Menu Bar, select Edit > Preferences > Substance. 
• Select an option from the Render Engine dropdown. Choose from GPU, CPU, and 

Automatic. 

Setting the Default Output Size 

This determines the default output size when loading a Substance archive and resetting a 
graph. 

If using presets, see Applying a Preset in Working with Substances to understand how output 
size is affected. 

Keep in mind, the larger the size, the more resources required for rendering. 

1. In the Menu Bar, select Edit > Preferences > Substance. 
2. Click the arrow next to Default Output Size and set a value. 

NOTE To set different output sizes for width and height, click the Lock to unlock the 
proportions. 



Transform Preferences 
Enter step sizes and Transform editor settings. 

In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select 
Transform. 

Transform Step Size 

Enter step sizes for transform, rotation, and scale. 

Transform Editor 

Choose the transform variant display settings for the transform dialog. 

• Off 
• Transform Variant Window 
• Transform Variant Window & Variant Options 
• Share 



VRPN Tracking Preferences 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select VRPN 
Tracking. 

• Default Config File - Specifies the default configuration file for a VRPN tracking server. 
This will be used in the VRPN Tracking dialog box, if you right-click the Server box and 
select Use Default Config File. 

• Load Configuration From Project - Makes it possible for the current configuration to be 
overwritten with the one from a loaded project. 

• Clear Session On New Scene - Clears the current configuration for a new scene. 
• Auto Start/Stop Internal VRPN Servers - Automatically starts or stops internal VRPN 

servers when enabling or disabling tracking. 



Virtual Reality Preferences 
Find out about the Virtual Reality preferences for customizing settings for general VR, teleport, 
and StarVR use. 

Edit > Preferences > Virtual Reality 

Use the Virtual Reality preferences to customize settings for general VR, teleport, and StarVR 
use. Once everything is set, click Apply. 

 

General (tab) 

Use these parameters to customize any HMD. 

General 

• Default Visualization - Sets whether the initial session starts with VR hands or 
controllers displayed. 

• Show Tooltips - Toggles the visibility of the controller tooltips on or off. By default, this 
option is toggled on. 



• Create Collision Objects - Toggles the creation of collision objects for all touch sensors 
and WebEngines in the scene on or off. Without them, you cannot interact with touch 
sensors and WebEngines when using VR Hands. 

Teleport 

Use these parameters to customize your teleporting mode and range. 

• Ground Mode - Sets the default mode when teleporting. Either teleport onto models or 
into and around them. 

Important: To teleport into a vehicle or anywhere on the ground plane, select On 
Ground Plane. When On Geometry is selected, you can teleport onto geometry, but not 
into it. 

• Range - Sets the limit for how far you can teleport within the scene. 

StarVR (tab) 

Use these parameters to customize your StarVR settings. 

Rendering 

• Foveated Rendering - Toggles Foveated Rendering on or off. When enabled, eye-
tracked areas are rendering in high resolution and peripheral areas in low resolution. 

• Foveated FOV factor - Only available when Foveated Rendering is enabled. Defines the 
percentage of the whole field-of-view per eye used for the high-resolution area. For 
example, is the FOV factor is 0.35 = 35% of whole eye FOV used for eye tracked Render 
Window. 

• Foveated Resolution Scale - Only available when Foveated Rendering is enabled. Sets 
the resolution scale factor for high-resolution, foveated, areas. 

• Non-Foveated Resolution Scale - Only available when Foveated Rendering is enabled. 
Sets the resolution scale for low-resolution, full FOV, non-tracked, areas. Should be 
lower than 1.0. 

• Non-Foveated Rendering - Toggles Non-Foveated Rendering on or off. When enabled, 
eye-tracked and peripheral areas will be rendered at the same resolution. 

• Front View Resolution Scale - Only available when Non-Foveated Rendering is enabled. 
Sets the resolution scale for front Render Windows in non-foveated rendering mode. 

• Side View Resolution Scale - Only available when Non-Foveated Rendering is enabled. 
Sets the resolution scale for side Render Windows in non-foveated rendering mode. 

• Single Texture per Eye - Only available when Non-Foveated Rendering is enabled. 
Toggles the use of only one texture per eye in non-foveated rendering mode, instead of 
the two textures, front and side. 



WebInterface Preferences 
Activate the VRED Professional internal Web Server and turn on debug mode, if necessary. 
Activating the Web Server allows the execution of remote Python commands. A local firewall is 
recommended. 

In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select 
WebInterface. 

Base 

• Enable Web Server - Makes it possible for the execution of remote Python commands. 
When selected, the following options become available. 

• Port - Displays the server port. 
• SSL Port - Displays the secure server port. 
• Enable Debug Mode - Enables enhanced logging in the VRED terminal. 
• Allow request from localhost only - Denies access to all other hosts, except localhost. 
• Allowed hosts - Makes it possible for the host names to be entered. 



Render Options Preferences - Visualization tab 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select Render 
Options. 

Render Window 

Use the resolution controls at the top of this window to set your preferred render resolution. If 
you do not set a resolution, the render window will adapt to the size of the main VRED window. 

• Use Fixed Resolution - Locks the Render View to a fixed pixel resolution. 
• Pixel Resolution - Sets the width and height of the Fixed Pixel resolution. 
• Enable Downscale - Enables downscaling to help less powerful computers render more 

interactively, according to individual scene complexities and when moving the camera. 
Available only in raytracing. 

• Downscale Quality - Contains the following options: 
 

o Low - Uses every second pixel for the calculation. 
o Medium - Uses every fourth pixel for the calculation. 
o High - Uses every eighth pixel for the calculation. 

 
• Antialiasing Quality - Contains the following options: 

 
o Off - The original resolution is displayed. 
o Low, Medium, High, and Ultra High - Quality levels are configured in 

Visualization Advanced > Realtime Antialiasing Presets. 

For example - With Multisampling set to 2 Samples, two times the original 
resolution displays. If Enable Supersampling is selected, rendering occurs twice 
in the x and y (effectively four times). With Multisampling at 2 and 
Supersampling selected, the quality is eight times the original resolution. 

• Enable Postprocess Antialiasing - Attempts to smooth the hard edges of the image, 
based on filtering. Results are lower quality, but you get higher performance. 

• Disable Realtime Antialiasing on Camera movement - Disables realtime antialiasing 
during camera movement and re-enables it when camera movement stops. 

• Enable Still-Frame Antialiasing - Activates still-frame antialiasing rendering for OpenGL 
and raytracing render mode. Still frame antialiasing progressively renders the still image 
over time. 

• Still Frame AA After - Sets the duration to wait for user input before automatically 
beginning antialiasing. 

• Interactive Material Preview - Activates interactive material preview, while dragging 
and dropping a material onto an object in the Render View. 



• Show Auxiliary Nodes During Antialiasing - Keeps all auxiliary visualizations, like 
clipping or manipulators, visible during antialiasing. 

• Limit Near and Far Clipping Plane - Objects closer to the camera than the near clipping 
plane and farther than the far clipping plane are not drawn anymore. Sets the distances 
using the Near Clipping Plane and Far Clipping Plane controls. 

• Near Clipping Plane - Sets the distance between the near clipping plane and camera 
position. Objects between the camera position and this near plane are not drawn. 

• Far Clipping Plane - Sets the distance between the far clipping plane and camera 
position. Objects beyond this far plane will not be drawn. 

• Show Camera Visualizations - Displays a representation of the camera in the Render 
View. 

• Show Light Visualizations - Displays a representation of the light in the Render View. 

Lighting 

• Headlight Behaviour - Sets the default state of the headlight for new scenes. Select 
Auto to leave the headlight turned on until the first Truelight Shader is used. Select 
Ignore to retain the headlight state. 

• Use Point Headlight - Uses a point light as headlight, instead of a directional light. 

Navigation Help 

• Show Coordinate System - Shows a miniature (global) coordinate system in the lower 
right corner of the Render View. 

• Show Navigation Cube - Shows a cube in the upper right corner of the Render View, 
whose corners, edges, and faces are shortcuts to align the camera. 

• Use Z-Up Coordinate System - Sets the z-axis as the up-axis. 

Progress Cursor 

Adjust the progress cursor displayed during stillframe antialiasing. 

• Size - Sets the size of the cursor. 
• Show Progress - Displays the progress of the antialiasing with the render progress 

cursor. 
• Static position - Displays the progress at a static position in the render windows and not 

with the moving cursor. 



Render Settings Preferences - Image tab 
In the Menu Bar, click Edit > Preferences, then on the left side of the dialog box, select Render 
Settings. 

Image 

• Resolution - Sets the resolution width and height in pixels for images rendered to disk. 
Use the drop-down list to select from standard resolutions. 

• DPI (Dots Per Inch) - Defines the image resolution in dots per inch. 
• Size - Displays the physical image size in millimeters and calculates it using the 

resolution and DPI values. 

Advanced 

• Supersampling - Enable the increase of antialiasing quality. This may impact 
performance. 

• Stereo Mode - Options include Mono, Stereo, 5 Eye Stereo (five images), and 9 Eye 
Stereo (nine images). 

• Compression Quality - Sets the compression quality of an image by percentage. This 
only applies to image formats that support compression, such as JPG. For no 
compression, enter -1. 

• Export Options - Select the Export options you want: 
•  

o Export Image with Alpha Channel - Renders the alpha channel into the resulting 
image, if the file type supports it. You can select the alpha channel color 
separately. 

o Show Rendered Image After Saving - Opens a separate window, showing the 
rendered image. 

o Single Image Viewer Window - Shows only one image per window. 
o Ignore Aspect Ratio - Squashes or stretches the rendered image and ignores the 

aspect ratio. 
o Export to formats such as TIFF/PSD (32 bits per channel), EXR (16-Bit Float), and 

Multi Layer EXR/PSD. 

Animation 

Use these controls to set the start frame, stop frame, and frame rate for your animation. You 
can export a series of images or an AVI movie. 



Geometry 



About the Geometry Editor 
Scene > Geometry Editor 

The Geometry Editor contains functions for modifying scene geometry. Use it to adjust/flip 
normals and re-tessellate NURBS surfaces. 

 

Normals 

These parameters affect the normals of the selected geometry. 

Normal Calculations 

• Crease Angle - Determines the hardness of the shading between geometry edges. A 
lower value gives a harder look to the edges. While values around the default of 35 
degrees give a smoother appearance. 

• Calculate Normals - Starts to recalculate the normal orientation for the selected objects. 
• Length - Normalizes the normal vector lengths in the geometry to a value of one. 



• Normal Consistency - Removes the inconsistencies with surface normals that can occur 
when importing geometry; some normals point inside and others outside (the 
Vertex/Face Normal Rendering Mode helps to identify affected objects). This option sets 
all normals so they are pointing on the same side of the surface geometry. 

• Flip Normals - Enables you to flip all types of normals. 
 

o Face/Surface - Switches the direction of the face or surface normals of the 
selected geometry. 

o Vertex - Switches the direction of the vertex normals of the selected geometry. 
o Face and Vertex - Switches the direction of both the face and vertex normals of 

the selected geometry. 
 

• Mirrored Flip Normals - Allows the flipping of the normals for instanced geometry, such 
as a mirrored surface. The Flip Mirrored button flips the normals for the instanced 
object, while the Flip Non-Mirrored button flips the normals for the original object. 

Adjacency Selection 

Selects the triangles of the geometry that have neighboring vertex normals less than the given 
Crease Angle value. This function, along with the Separate Objects function, can be useful when 
selecting portions of an object to separate it. 

• Crease Angle - Defines the angle used for identifying neighboring vertex normals. 
• Select - Starts the identification and selection process. 

Separate Objects 

Separates geometry into discrete objects, when the angle between the vertex normals is larger 
than the value specified by the Separation Angle. 

• Separation Angle - Defines the angle used for separation. 
• Separate - Starts the separating process. 

Tangents/Binormal 

Calculates the tangents and binormals of the given UV texture coordinates. 

• Source - Shows the texture coordinates that should be used to calculate the tangents & 
binormals 

• Tangent - Shows the texture coordinate slot that the tangent values are saved in. 
• Binormal - Shows the texture coordinate slot that the binormal values are saved in. 
• Calculate - Executes the calculation using the selected values from Source, Tangent, and 

Binormal. 



Geometry 

These parameters affect the selected geometry. 

Tessellation 

Provides the functionality for re-tessellation of surface (NURBS) data in the scene. 

• Tessellation Quality - Displays different presets to help you choose reasonable settings, 
if you are a casual user. 

Tessellation 
Quality 

Coarse Low Medium High 

Chord 
Deviation 

1.00 0.15 0.075 0.0375 

Normal 
Tolerance 

30.00 20.00 10.00 7.50 

Max Chord 
Length 

400.00 300.00 200.00 100.00 

Enable 
Stitching 

Yes Yes Yes Yes 

Stitching 
Tolerance 

0.10 0.10 0.10 0.10 

• Chord Deviation - Describes the maximum deviation between the NURBS surface and 
the tessellated surface. A low value results in more accurate polygon model but it also 
increases the number of triangles. 

• Normal Tolerance - The normal tolerance is the allowed normal deviation between the 
normals on the ends of a tessellated edge. 

• Max Chord Length - Defines the maximum edge length of the generated polygons. Long 
polygon edges are not shaded smooth within the Render Window. This setting is helpful 
to avoid such faceted effects. 

• Enable Stitching - Rebuilds existing topology and makes edges of selected shells align to 
each other, when enabled on tessellation. It avoids ragged edges on tessellated 
representation within the Stitching Tolerance. 

• Stitching Tolerance - Sets the tolerance where two adjacent edges are considered to be 
touching and should be stitched together. 

• Convert to Convex - Converts concave polygon primitives into convex polygons, which 
are polygons with interior angles more than 180 degrees. Concave polygons may cause 
problems during rendering. 



Decore 

Removes redundant geometry that is inside other geometry, like screws and mountings inside a 
door covering. A virtual camera flies around the selected object, takes screen shots, and 
removes any non-visible geometry. 

• Quality Resolution - Defines the resolution of the images taken. A higher resolution 
gives more precise results. 

• Quality Steps - Defines the number of images taken during the analysis. A higher value 
gives more accurate results. 

• Correct Wrong Normals - Flips polygon normals pointing away from the camera, if they 
are encountered during the analysis. 

• Removal - When geometry is determined to be inside another and non-visible, then one 
of these options are available: 
 

o Disabled - Removes nothing. 
o Object Level - Removes hidden objects. 
o Polygon Level - Removes hidden polygons. 



Working with Geometry 
You can create the following types of geometry. 

Line 

The connection of two points. Every point has X, Y, and Z coordinates for its positioning in 3D 
space. The representation of a line object in the Render Window depends on the active render 
engine. In OpenGL mode, a line is represented as a line. In Raytracing mode, it is represented as 
a tube capped with half spheres on both ends. The Line Tube Radius material setting controls 
the radius of the representation. 

Plane 

A flat quadratic face often used to place object shadows onto the ground below. It has X and Y 
dimensions and it requires input for the number of sub-divisions for both axes. 

Box 

A quadratic, three-dimensional room, also known as a cube. It has X, Y, and Z dimensions and 
requires input for the number of subdivisions for each axis. 

Cylinder 

An object that has two circular ends, with the same radius, parallel to each other. A cover 
wrapped around the distance between, or height, builds the outer skin of the primitive. 
Increasing the number of sides gives a less faceted look to the object. 

Cone 

Similar to a cylinder; has a circular base, with a top that converged to a single point. Faces for 
bottom or side are only created when related check boxes are selected upon creation. 

Sphere 

A three-dimensional primitive in the form of a ball. Every point on the surface has the same 
distance to the center point. This distance can be adjusted within the dialog box, using the 
radius value. The values for latitude and longitude resolution result in the number of horizontal 
and vertical subdivisions. 



Torus 

An object shaped like a donut. It has a circular profile limited by the inner and outer radius. The 
surface is created by rotating the profile around the perpendicular axis in the center of the 
object. The ring's value controls the number of subdivisions along the axis of rotation. The 
side's value controls the quantity of horizontal subdivisions. 

Dome 

A dome, or hemisphere, has a flat circular surface at the bottom and a half sphere covering it. 
The border edge to the bottom surface is chamfered. The Base Radius value controls the 
dimension of the half sphere, Ground Radius controls chamfer creation. Latres defines the 
number of perpendicular subdivisions, Longres defines the number of subdivisions around the 
perpendicular axis. 

Find out how to create and edit geometry, as well as illuminate objects. Also, learn about 
cloning and mirroring lights and how you can use this in VRED. 

How to Create and Edit Geometry 

1. In the Menu Bar, click Scene > Create Geometry. 
2. Select the object type you want to create. 
3. Enter values appropriate for the object, such as XYZ coordinates, length, width, height, 

radius, and so on. 
4. In the Menu Bar, click Scene > Geometry Editor. 
5. Use the Normals and Geometry tabs to make changes to your geometry. 



Materials 
 



Working with Materials 
Use the Material Editor to create materials and convert them from one file type to another. 

How to Create Materials 

If you need a material for OpenGL, see the section to follow. 

1. In the Menu Bar, click Scene > Material Editor. 
2. Click Create/Convert > Create Material. 

 

3. Select the material type you want. This create that material. 

NOTE Another way to create a material is to right-click in the Material Tree View, click 
Create Material, and select a material from the list. 

 



How to Create OpenGL Materials 

Create a material that will work in OpenGL. 

1. In the Menu Bar, click Scene > Material Editor. 
2. Click Create/Convert > Create OpenGL Material. 
3. Select the type you want. This creates an OpenGL material. 

How to Convert Materials 

Convert one kind of material to another. 

1. In the Menu Bar, click Scene > Material Editor. 
2. Select a material in the Materials Preview Pane. 
3. Click Create/Convert > Convert. 
4. Select the type of material to convert to. This converts the material. 

How to Toggle an Interactive Material Preview 

In the Menu Bar, select Visualization > Interactive Material Preview. When enabled, dragging a 
material (without dropping it) over an object provides a preview of how the object would look 
with the material applied. 

How to Preview and Apply a Material 

Ensure Interactive Material Preview is enabled. 

1. In the Menu Bar, click Scene > Material Editor. 
2. Drag (without dropping) a material from the Material Editor over any object in the 

scene. This provides a preview of what the object will look like with the chosen material. 
3. Do one of the following: 

 
o If you decide you do not like the material choice, without releasing the mouse, 

drag it back to the Material Editor and no change is made. 
o If you decide you like the material choice, release the mouse. 

How to Edit a Material 

Use the material parameters to make changes to a material. 

1. In the Menu Bar, click Scene > Material Editor. 
2. Select a material from the Material Preview Pane. 



 

3. In the pane to the right, use the parameters to make changes to the material color, 
texture, incandescence, transparency, displacement, raytracing, and more. 



About the Material Editor 
Scene > Material Editor 

Use the Material Editor to create, modify, and group materials within VRED. For information on 
specific materials, see the Materials section. 

The Material Editor is comprised of the following: 

 

1 Menu Bar 
2 Materials Section 
(Selector) 
3 Search Bar and 
Filter 
4 Materials Tree 
View 
5 Tags Section 
(Selector)/Tree View 
6 Groups/Tags Pane 
7 Materials Preview 
Pane 
8 Attributes Pane 
9 Icon Bar 

 Menu Bar 

File 

Contains options for loading and saving materials, loading 
animation to the Materials Editor, rendering preview images, 
and viewing statistics. 

 
 

• Load Materials - Loads a previously saved material from a file. 
• Save Materials(s) - Saves the selected materials to a file. 
• Load Animation To Materials - Applies a saved material animation to the selected 

material nodes. 
 



• Render Preview Images - Renders the preview images of all materials, depending on the 
used mode, either in OpenGL or Raytracing. The previews are usually created when 
needed, which can result in delays while scrolling through the preview list. Creating all 
previews explicitly takes a bit of time and avoids delays. 

• Statistics - Shows some important statistics about the materials used within the scene, 
such as the number of materials and textures and amount of memory used by the 
materials. 

Edit 

Contains options for copying, pasting, merging, referencing, optimizing, removing, 
locking/unlocking, and compressing and decompressing. 

• Copy - Copies the selected material to the clipboard. 
• Paste - Pastes a material saved on the clipboard into the material tree. 
• Duplicate - Creates a unique copy of the selected material. 
• Delete - Deletes the selected material. 
• Merge Duplicate Materials - Deletes copies of a material and only uses one, when two 

materials of the same type and settings are available. This also updates any material 
references on objects, so they use this one material. 

• Remove Unused Materials - Removes materials not referenced by an object from the 
material tree. 

• Reference Unused Materials - Creates a reference to any unused materials, so that they 
are not erased by commands such as Remove Unused Materials. 

• Optimize Materials - Optimizes materials to improve render performance. 
• Optimize Textures - Optimizes textures to improve memory performance. 
• Remove All Groups - Removes all material group nodes and places the materials in the 

top level of the material tree. 
• Scroll to Selected - Scrolls to the selected material. This is useful when working with 

large lists of materials. 
• Lock/Unlock - Prevents or allows the material to be modified. 
• Compress/Uncompress Textures - Compresses or decompresses textures to save 

memory or improve speed. 

Create/Convert 

Contains options for creating and converting materials, groups, switches, and environments. 

• Create Material - Creates a Truelight Material. Select materials from its list. See the 
Materials section for a full listing of available materials and options within VRED. 

• Create Environment - Creates an environment map material. Select environments from 
its list. 

• Create OpenGL Material - Creates a OpenGl material. Select OpenGL materials from its 
list. 



• Create Group - Creates a new empty material group node. 
• Create Group from Selection - Creates a material group node filled with the selected 

materials. 
• Create Switch from Selection - Creates a material switch filled with the selected 

materials. 
• Convert - Converts the selected material of one type into another. 

Scene 

Contains options for dealing with selecting things within a scene. 

• Select Nodes - Selects the geometry nodes assigned to the currently selected materials. 
• Add Nodes to Selection - Extends the selection in the Scene Graph to include nodes 

with the currently selected material. 
• Apply Selection Nodes - Applies the currently selected material to the selected 

geometry nodes in the Scene Graph. 

 Groups/Tags Pane 

Shows the logical sorting and listing of the currently created materials. This is comprised of the 
Materials/Tags Selector, Search Bar and Filter, Material Tree, and Tag Tree. 

Window 

Contains the Groups/Tags, Preview, Attributes options for changing the appearance of the 
Material Editor. When an option is checked, that component is added to the editor. When 
unchecked, it is removed. 

All Components 

 



Groups/Tags Disabled 

 

 Materials Section/  Tags Section (Selector) 

 

Sets whether a section will be Materials or Tags. Click the selector to pick which view is shown 
in which section. By default, one shows Materials and the other, Tags. 

 Search Bar & Filter 

 

Conducts searches or filters for materials and tags. These can be searched for by name, using 
the Search Bar, or by material type, using the filter icon to the right of the search input box. The 
icon turns orange when a filter is active. 



 Materials Tree View 

 

Lists all the materials and groupings within the scene. 

 Tags Tree View 

 

Lists all tags found in the scene materials. By clicking a tag, the preview is filtered by materials 
with the selected tag. Tags can be defined in the general section, next to the material in the 
Attributes window or by dropping the material on a tag. Dropping a material group on a tab 
assigns the tag to the entire group. 

 Materials Preview Pane 

 

Shows a visual listing of the materials, depending on the selection. Click 
something in the Materials Tree. When a material group is selected, only 
the materials in that group is shown. If no material groups are selected, 
then the entire listing of scene materials is shown. 

Slider - Changes the size of the previews. At the bottom of the Materials 
Preview Pane, drag the slider to increase or decrease the size of the 
previews. 



 Attributes Pane 

Shows all available settings for the currently 
selected material, along with a preview of the 
material. Any tags associated with the material are 
listed to the right of the preview. A complete listing 
of material attributes and their functions are found 
below the preview. 

 

 

 

 

Context Menu 

Contains quick shortcuts to commonly used Material Editor functions. 

Right-click in the Materials Section & Material Preview Pane 

• Create Material 
• Create Environment 
• Create OpenGL Material 
• Edit 
• Convert 
• Load/Save Materials… 
• Create Group 
• Create Group from Selection 
• Create Switch from Selection 
• Select Nodes 
• Add Nodes to Selection 
• Apply to Selected Nodes 
• Apply Environment to Selected Nodes (only 
available when Environments is selected) 
• Apply Environment to All Materials (only 
available when Environments is selected) 

 

 



Right-click in the Tags Section 

• New Tag 
• Add to Selected Materials 
• Remove Tag from Material 
• Remove Tag 
• Remove All Tags 

 Icon Bar 

 

Contains visual shortcuts for commonly used commands in the Material Editor. The order of the 
icons is: 

• Create - Creates a material. 
• Duplicate - Duplicates the currently selected material. 
• Create Group - Creates a group the from selected material(s). 
• Select all nodes - Selects all nodes with the currently selected material applied. 
• Apply - Applies the selected material to all currently selected nodes. 
• Remove - Removes all unused materials. 
• Delete - Deletes the currently selected material. 

Keyboard Shortcuts 

There are several hotkeys available for the Material Editor: 

• Select Nodes  
• Add Nodes to Selection  
• Apply to Selected Nodes  
• Create Group  
• Create Group from Selection  
• Scroll to Selected  
• Copy  
• Paste  
• Rename  
• Delete <Del> 
• Remove Unused Materials  
• Optimize Materials  
• Optimize Textures  
• Lock  
• Unlock 



About the Substance Attributes 

 

The Substance Attributes 

The top part of the Substance Attributes displays a Material Preview and the following 
additional information: 

• Substance Name - Provides the name and location of the Substance. 

•  Load - Opens the Load Substance Archive dialog for locating a Substance. By default, 
it opens to the last opened directory. 

•  Reload - Reloads the Substance archive file. 

IMPORTANT Any previous changes made to the material are lost, including presets. 

• Id - Identifies the listed presets with a numeric value. 
• Presets - Displays the name of the listed Substance presets. 

o Double-click LMB to apply the preset. 
o Double-click MMB to apply the preset AND set the default output size. 



Substance Parameters 

This next section houses parameters. Most substances will have Substance Package, Texture 
Settings, Bump, Displacement, Raytracing, and Common parameter categories, along with their 
own unique categories of parameters. 

Supported Texture Channels 

Here is a list of the supported Substance output channels: 

• Base Color (Required) 
• Roughness (Required) 
• Metallic (Required) 
• Normal (Optional) - VRED expects the normal texture to be generated in DirectX normal 

format (i.e., +X = right and +Y = down). 
• Height (Optional) 
• Emissive (Optional) 
• Opacity (Optional) 
• Specular Level (Optional) 
• Ambient Occlusion (Optional) 
• Anisotropy Level and Anisotropy Angle (Optional) - VRED uses the anisotropy angle for 

a clockwise rotation. 

Here is a list of Texture Channels that are not easily found in VRED: 

• Normal is found in Bump (Bump Intensity). Tangent-space Normal mapping is used. 
Bump Intensity is set to 1.0 by default to enable normals. When Bump Intensity is set to 
0.0, Normal mapping is disabled. 

• Height is found in Displacement. By default, Displacement mapping is disabled 
(Displacement Height is set to 0). To displace the geometry, based on the content of the 
height texture, set Displacement Height to a value greater than 0. The Displacement 
Offset defines the texture values used to extrude (values larger than Offset) or indent 
(values smaller than Offset) the geometry. 

• Height is also found in Bump (Parallax Intensity + Bump Type). Instead of using 
Displacement mapping, a method called Parallax Mapping is used to create the 
impression of a displaced surface. 

Parallax mapping is faster than real displacement mapping; however, it does not 
generate the correct silhouettes and might display artifacts. By default, Parallax 
Mapping is disabled (Parallax Intensity is set to 0.0). Bump Type controls use the Parallax 
Mapping method. For example, the Bump Type, Bump Mapping, enables standard 
Parallax Mapping and Displacement Mapping enables Parallax Occlusion Mapping. 



• Emissive is found in Incandescence. If a material has an emissive texture, the 
Incandescence Intensity will be set to 1.0 by default. 

• Opacity is found in Transparency. The Use Cutout option will be enabled by default. 

Substance Package Parameters 

The following list is comprised of parameters we feel are notable: 

• Graph - Specifies the graph used by the Substance. Each graph can change the look and 
makeup of a Substance. Click the drop-down and select a graph. 
 

o Reset - Resets the current selected graph to its default parameters. However, 
any VRED material setting changes made to Texture Settings, Bump, 
Incandescence, Displacement, Transparency, Raytracing, or Common will 
remain. See Resetting a Graph in Working with Substances. 
 

• Output Size - Sets the rendering output resolution for each Substance material. For a 
Substance that contains multiple materials, you can set some materials to a lower 
resolution, and others to a higher one. Doing this, enables you to control memory usage 
and reduce rendering time. 

• Random Seed - Randomizes the texture patterns within the Substance, based on the 
numeric value entered. 

 

For the first image, Random Seed = 0. For the second, it is 30. Notice the difference in 
the texture pattern. 

Texture Settings 

• Mapping Type - Sets how the Substance is mapped onto your geometry. Choose from 
UV, Planar, and Triplanar. Use this in combination with other Texture Settings such as 
Repeat Mode UV, and Texture Size to adjust your Substance to the geometry. 



Substances in VRED 
Material Editor > Create/Convert > Create Material > Substance 

What is a Substance 

A Substance is created with Substance Designer and can be loaded into VRED through the 
Material Editor. When a Substance is loaded into VRED, it is converted into VRED readable 
texture images, which are used for rendering. The file format for it is .sbsar. 

A Substance contains one or more graphs with texture outputs. These textures are generated 
by the Substance Render Engine. We use the texture maps to render the material in VRED. 
Besides the original Substance graphs, the generated textures are stored within the VRED 
material. Therefore, if you use a large texture resolution (Output Size), the file size of your VRED 
scene will also increase. 

If a Substance isn't quite to your liking, tweak it. Change its parameters and create presets. 
Keep in mind, though a Substance can be tweaked, and presets created and exported, there is 
no way to create an actual Substance in VRED. To create one, use the Allegorithmic Substance 
Designer. 

For a more in-depth look at what substances are, see Allegorithmic's website. 

Metal/Roughness Workflow 

VRED supports the Substance metal/roughness default workflow; however, at present, we do 
not support the specular/glossiness workflow. For information on the metal/roughness 
workflow, see this short description from the Allegorithmic forum or this longer one from 
Substance Academy. 

NOTE If one of these textures (Base Color, Roughness, Metallic) is missing, the Substance 
metal/roughness result will be incorrect. 

Loading a Substance 

Substances (.sbsar files) need to be brought into VRED to use them. If you already have some, 
access them through the Material Editor. If not, visit these Allegorithmic links to download and 
buy substances.: 

• Community share site 
• Allegorithmic's share site 

 

https://www.allegorithmic.com/
https://forum.allegorithmic.com/index.php?topic=3243.0#msg14976
https://academy.allegorithmic.com/courses/the-pbr-guide-part-2
https://share.allegorithmic.com/
https://source.allegorithmic.com/assets


• From the Quick Access Bar, tap Materials to open the Materials Editor. 

 

• Select Create/Convert > Create Material > Substance to load a Substance. 
• Click  and locate a Substance on your machine. 
• Select a Substance. 
• Click OK to load your selection into the Material Editor. 

 

TIP Whenever you open the Load Substance Archive dialog, it opens to the last opened 
directory. 
 
 
 
 
 
 



Applying a Substance to Geometry 

With your scene loaded, click-drag the Substance from the Material Editor onto the geometry in 
the Viewport. 

 

To assign a different Substance, in the Material Editor, drag and drop a different Substance 
onto your geometry. The material will automatically update on the geometry. 

Reloading a Substance 

When changes have been made to a Substance, using Substance Designer, you can grab the 

updated version by clicking  Reload. 

Creating a Presets 

When creating a preset, you can make changes to the parameters before creating it or after it. 
If you do it after, use Recapture Preset. 

In the Presets area, right-click and select Create Preset or use the Insert hotkey. A new preset is 
added to the list. 

Recapturing a Preset 

If you tweak a preset and you want to recapture it with these changes, right-click the preset 
and select Recapture Preset. 
 
 



Applying a Preset 

When you apply a preset, it changes the appearance of the Substance. 

If you apply a preset with double-click LMB (left mouse button) or with the context menu, the 
output size will be contained in the preset. However, if you apply it with double-click MMB, the 
output size will be overwritten by the specified value from the preferences. 

In the Presets area, with a preset selected, do either of the following: 

• right-click and select Apply Selected Preset. 
• double-click the preset. 

Renaming a Preset 

1. In the Presets area, with a preset selected, right-click and select Rename or use the Ctrl 
+ R hotkey. The preset name is highlighted. 

2. Enter a new name and press Enter to set the name. 

Importing a Preset 

When a Substance archive file is loaded into VRED, if there are presets with the same name, in 
the same directory, they are automatically loaded with the Substance archive file. 

What if you have a project where a preset was created for everyone to use and it wasn't in the 
Substance directory? Use Import Preset File, then Apply Selected Preset to add this to the 
Substance. 

1. In the Presets area of the Substance, right-click and select Import Preset File. 
2. In the Load Substance Presets dialog, locate a preset. 
3. Click Open. The preset appears in the Preset list. 

Exporting a Preset 

Have you created a preset for your team to use? If so, use Export Preset File to share it with 
them. They can then import and apply the preset. 

1. In the Presets area, with a preset selected, right-click and select Export Preset File. 
2. In the Export Substance Presets dialog, locate the directory where you would like the 

preset saved. 
3. Click Save. 



Deleting a Presets 

If you created a preset that is no longer needed, use Delete Presets or the Delete key to delete 
it. 

In the Presets area, with a preset selected, right-click and select Delete Presets. The selected 
preset is removed from the Preset list. 

Tweaking a Substance 

Substance parameter names are not changed upon import and appear as is in VRED. The 
Substance Material Designer set default values to all material properties. This is stored in 
Substance archive files. We read these values and attach all default values as fields in the 
created VRED material. We can use these defaults to reset the material to the original state. 
See the section, Resetting a Graph, that follows. 

Changing Substance Resolution 

Set the resolution of the current Substance material in the Material Editor. For example, one 
Substance material needs a lower resolution, but another Substance material needs a higher 
one. Using Change Substance resolution, you can do this. 

Keep in mind, lowering the resolution reduces memory usage, but also image quality. Increasing 
the resolution improving image quality, but also increases memory usage. 

1. In the Material Editor, with a Substance selected, open the Substance Package section. 

 

2. Click the arrow next to Output Size to access values. Sets the resolution of the rendered 
Substance. The larger the value, the higher the image quality and more memory 
required. The Viewport updates to show the change. 



Resetting a Graph 

When a Substance has been tweaked, you can reset its default values by using , found next 
to Graph. It resets the current selected graph. Changes made to some of the parameters within 
the materials are not reset. See Substance Package Parameters in About the Substance 
Attributes. 

Raytracing Substances 

Substances can be raytraced. This section contains options for setting the material ID and line 
tube radius and enable or disabling use of the local environment and ignoring the photon map, 
as well as options for overriding the illumination mode, IBL sampling quality, reflection and 
refraction, and trace depth. 

For additional information on raytracing, see The Render Setting Module. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=GUID-B01B9ECB-4A29-4341-9C67-F166A9956044


To Choose a Color 
When you click a color field for an option in the Material Editor, such as Warm Color or Diffuse, 
this opens the Choose a Color dialog. Use it to set the color for that option (Color tab) or access 
the spectral data (Spectrum tab). 

Color (tab) 

Use these options to set a color for the option in the Material Editor. 

Set the Current Color 

Along the left are two color fields. The top displays the current color and bottom the output 
color. Use the Current color field to set the new color for the option in the Material Editor. The 
Output Color field displays the previously set color for the option in the Material Editor. Below 
these are the RGB, HSV, and Lab color values for the current color. 

1. Click the Current color field. 
2. Do any of the following: 

 
o Use the slider at the bottom of the dialog, along with the indicator in the Color 

Palette to select a color. 
o Use the Pipette to grab color from sources outside the dialog. 
o Use the Color sliders or numeric input fields to the far right to set RGB, HSV, or 

Lab color values. 
 

3. Do one or more of the following: 
 

o To store the colors you create, click the Store Color button. 
o To use sRGB colors, instead of RGB, check to enable Use sRGB Colors. 
o To use the selected color for the Material Editor option, click Accept. 

Spectrum (tab) 

To enable spectral input data for a color channel, enable the Spectrum option. The plot area 
displays the spectral distribution, depending on the settings to the right. 

Along the left are two color fields. The top displays the current color and bottom the output 
color. Use the Current color field to set the new color for the option in the Material Editor. The 
Output Color field displays the previously set color for the option in the Material Editor. Below 
these are the RGB, HSV, and Lab color values for the current color. 



Spectrum 

This section has two tabs, Basic and Analytic. 

Basic 

• File - Allows loading and saving a spectral distribution to a file, based on the settings in 
this window. 

• Red/Green/Blue - Allows computing spectral data from RGB input values. 
• Scale - Rescales the photometric value of a spectrum by changing the value V of a 

spectrum, while keeping the hue H and saturation S constant. 

Analytic 

Use the Add or Set buttons, once the analytic options are set. 

• Function - Sets the method for smoothing. 
• Peak Wavelength - Sets the maximum wavelength applied. 
• Peak Intensity - Sets the maximum intensity applied. 
• FWHM - Compares the quality of images obtained under different observing conditions. 
• Temperature - Controls the generation of the CIE D spectral curve. Use the default 

value, 6504 K, to generate a spectral curve of standard daylight. Use this to define the 
spectrum of a light source in VRED. 

• Add - Generates a spectral curve with the current parameters, set with the other 
attributes, and adds it to the current spectrum. 

• Set - Generates a spectral curve using the current parameters, set with the other 
attributes, and sets it as the current spectrum. 

Edit Sample Distribution 

Allows setting the number and distribution of spectral samples in the spectral domain. 

NOTE Changing the sample distribution will only take effect after confirming by clicking Apply. 

• Presets - Provides a collection of predefined settings suitable for most use cases. 
Sampling spectra between 380 nm and 730 nm is widely considered sufficient to capture 
the perception of light by human observers. 

• Allow Non-Uniform Sample Distribution - Allows editing the sample wave lengths of the 
spectral samples individually. 

• Start - Sets the wavelength of the first spectral sample of the distribution. 
• Delta - Sets the distance between the samples to be created. 
• Number - Sets the number of samples to be created. 
• Apply - Confirms the Edit Sample Distribution settings and applies them. 



Textures 
 



Editing Textures 
Use the Texture Editor to position textures on objects within the scene. 

How to Edit Textures 

1. In the Menu Bar, click Scene > Texture Editor. 
2. From the Icon Bar, select Graph to open the Scene Graph. 
3. Click the object with the texture you want to edit. 

Textures and the material's assigned attributes are listed in the Texture list at the top of 
the Texture Editor. VRED, by default, uses the UV coordinates of any imported object, if 
they are available. 

 

4. Select Edit Texture Projection, so you can make changes to the texture. 
5. Make your changes in the Texture Editor dialog box. 



About the Texture Editor 
Scene > Texture Editor 

Use the Texture Editor to view and edit textures for a selected object. See a list of all textures 
assigned to the selected object. 

NOTE Another way to access the Texture Editor is to right-click the empty space next to the 
Quick Access Bar and select it from the list. 

The Texture Editor 

The Texture Editor lists the textures in the top portion of the editor. Below this are three 
sections. When Edit Texture Projection is checked, the properties sections are editable. 

 

Texture List 

The Texture List is at the top of the Texture Editor. It contains all the texture file names and 
dimensions (width and height in pixels) of the material assigned to selected object. The selected 
texture is displayed to the right. 

 



Edit Texture Projection 

Enable Edit Texture Projection to modify texture placement on an object. Place Texture 3D and 
Place Texture 2D options become accessible. Disable it once finished editing. 

• Mode - Select a projection mode. Choose Planar or Cylindrical. 
• Apply Projection - Applies the selected projection mode to the texture mapping 

channels of the related material. 
• Show Support Geometry - Shows or hides the texture geometry, such as the 

manipulation widgets, within the Render Window. 
• Instant Mapping - Enables or disables the updating of the texture placement in the 

Render Window in real time. 
• Visibility - Determines the transparency of the projection plane. 
• Distance - Determines the distance between the surface and projection plane. 

Place Texture 3D 

Place Texture 3D is helpful for the placement of a texture plane in 3D space. 

• Projection Center - Sets where the center of the projection plane is placed. Use the 
Object Center button to use the center of the object. Use the Pick button and Shift+RMB 
to position the plane in the Render Window. 

• Center (X,Y,Z) coordinates - Enables more accurate placement of the texture projection, 
using numerical input for the X,Y, and Z texture coordinates. 

• Rotate - Determines the degree of rotation for the texture, rotated away from the 
projection plane orientation. 

Place Texture 2D 

Place Texture 2D is helpful in exactly placing a texture on the projection plane. 

• Keep Aspect Ratio - Maintains the original aspect ratio of the texture, without 
stretching it to fit. 

• Scale Mode - Determines the method used to scale the texture to the projection plane. 
 

o Fit Scale and Center 
o Fit Scale Only 

 
• Repeat - Determines how many times the texture repeats in the X and Y directions. 
• Offset - Defines how far the texture is shifted from the projection center position on the 

X- or Y-axis. 
• Rotation - Defines the angle the texture is rotated away from the projection plane 

orientation. 



Using Dragged Textures 
Drag and drop images onto geometry, as a material texture or decal. With an HDR image, assign 
it to an environment. 

How to Create a Material Texture 

1. Drag an image file onto an object in the Render Window. This opens the Texture Drag & 
Drop dialog. 

 

2. In the Texture Drag & Drop dialog, select material attributes for the new image texture. 

NOTE If you select Add Decal, the material attributes will be disabled. 

3. With Add Decal not selected, from the drop-down list and choose Edit Material or Edit 
Object Only. 

NOTE Both options are only available when using the dropped image as a material 
texture and if the material is NOT assigned to multiple objects. 

How to Create a Decal 

1. Drag an image file onto an object in the Render Window. 
2. In the Texture Drag and Drop dialog, select Add Decal. 



 

3. From the drop-down list, select Add to Object or Add to Material. 

NOTE Add to Object is only available if the material is assigned to multiple objects. 

A Plastic material, named Decal, with a planar projection of the diffuse texture and a 
multipass material are created. If a multipass material is already assigned to the 
geometry, this multipass material is used. VRED switches automatically to Texturing 
Mode. A manipulator appears on the image to resize and position the decal. 

4. Hold the Shift key and drag the manipulator to rotate, scale, or translate the texture. 
Dragging the blue scale control adjusts the depth limit of the texture. The default Z 
value of the projection size is two hundred. Having a value other than zero, ensures the 
decal only appears on one side of the object. 

5. Press T or ESC to exit the manipulator. 

How to Create an HDR Image 

1. Drag an HDR or accepted environment format image into the Render Window. The HDR 
Drag and Drop dialog appears. 

2. Click Yes to add the environment as new or replace the active environment. 



About the Texture Drag and Drop 
This dialog appears whenever you drag and drop a texture onto an object. 

Use the Texture Drag and Drop dialog to determine how to apply the newly dragged and 
dropped texture. Drag an image onto geometry in the Render Window to launch the Texture 
Drag & Drop dialog. 

The Texture Drag and Drop 

The Texture Drag and Drop dialog displays the texture image and name, then lists options for 
how to apply it, along with a drop-down with options that change. Click the arrow to expose 
more options. 

 

• Diffuse - Loads the selected image as a texture in the Diffuse attribute of the material. 
• Glossy - Loads the selected image as a texture in the Glossy attribute of the material. 
• Roughness - Loads the selected image as a texture in the Roughness attribute of the 

material. 
• Bump - Loads the selected image as a texture in the Bump attribute of the material. 



• Incandescence - Loads the selected image as a texture in the Incandescence attribute of 
the material. 

• Transparency - Loads the selected image as a texture in the Transparency attribute of 
the material. 

• Subsurface Scattering - Loads the selected image as a texture in the Subsurface 
Scattering attribute of the material. 

• Displacement - Loads the selected image as a texture in the Displacement attribute of 
the material. 

• Add Decal - Creates a plastic material with planar projection and a multipass material. If 
a multipass material is already assigned to the geometry, this multipass material is used. 
VRED will automatically switch to the Texturing Mode. A manipulator appears on the 
image to resize and position the decal. Press T or ESC to exit the manipulator. 

 

• Use Alpha Channel - (Default setting) Assigns the dropped texture as a diffuse texture 
for the new plastic material created for the decal. The alpha channel is used for the 
transparency of the texture. 

• Use as Opacity Map - Assigns the dropped texture as a transparency texture for the new 
plastic material. This create a plain white plastic with transparent cut outs. 

• Edit Material - Modifies the material for the object the image has been dropped onto. 
Other objects using that material also have that texture. 

NOTE Edit Material is only available when using the dropped image as a material 
texture. 

• Edit Object Only - Assigns a new material with a texture to the object the image was 
dropped onto. Other objects with that material are not changed. 

NOTE Edit Object Only is only available when using the dropped image as a material 
texture and if the material is assigned to multiple objects. 

• Add to Object - Assigns a new material to the object the image was dropped onto. A 
new multipass material is created from the current object material and from a new 
decal material. The new multipass material is assigned to the object. Other objects are 



not affected. If the object material is already a multipass material, another layer is 
added to it. 

NOTE Add to Object is only available when using the dropped image as a decal and if the 
material is assigned to multiple objects. 

• Add to Material - Modifies the material of the object the image was dropped onto. 
Other objects with that material also have the decal. If the object material is not a 
multipass, VRED creates a new multipass material from the target material and from the 
new decal material. The multipass is assigned to all objects that use the target material. 

NOTE Add to Material is only available when using the dropped image as a decal. 



Cameras 



About the Camera Editor 
Scene > Camera Editor 

Use the Camera Editor to create and manipulate cameras in VRED. See a list of all cameras 
within a scene. The Camera Editor makes all camera-related property settings accessible. In 
addition to the simple UI camera settings, more advanced attributes are available, such as exact 
camera lens characteristics and custom projections, and camera properties. 

NOTE Another way to access the Camera Editor is to right-click the empty space next to the 
Quick Access Bar and select it from the list. 

The Camera Editor 

The Camera Editor has a left and right side. The left houses the Menu Bar, Tree View and Search 
field. The right contains three tabs, Camera Settings, Image Processing, and Advanced. Along 
the bottom of the editor is the Icon Bar. 

 

1. Menu Bar 

2. Search Field 

3. Camera Tree View 

4. Context Menu 

5. Camera Parameters 

6. Icon Bar 

 

 

 

Menu Bar 

The menu bar contains two menus, File and View. Use these options for saving, loading, and 
viewing. 



File 

This menu is found along the top of the Camera Editor, just above Search. 

• Save Selected - Writes selected data to disc. Save Selected supports saving a camera 
and viewpoints. The .osb file format supports saving a camera with camera tracks and 
viewpoints. XML only supports saving the selected camera or viewpoint. 

• Load - Reads stored data from disc. The loaded data is added as new cameras or 
viewpoints. 

• Load Settings from Rendering - Loads settings from a rendered image (.jpg, .png, .tiff, 
.exr) that includes meta data and applies it to the selected camera or viewpoint. 

View 

This menu is found next to File, along the top of the Camera Editor, just above Search. 

• Render Viewpoint Previews - Renders previews for the viewpoints of the active camera. 

Search Field 

Searches the Cameras Tree View to find whatever you are looking for. 

Cameras Tree View 

The Cameras Tree on the left, lists all scene-contained cameras, camera tracks, and viewpoints. 
Cameras can be grouped. Double-clicking a camera activates and connects it to the Render 
Window. 

Context Menu 

Right-click within the Camera Tree to access the context menu. 

• Create - Provides the following creation options: 
 

o Camera - Creates a camera with a perspective view. Perspective View is similar 
to the view of human eyes. Objects further away seem smaller than objects right 
in front. 

o Camera and Aim - Creates a separate node for the camera and aim. Each node is 
selectable and can be moved in the Render Window. 

o Camera, Aim and Up - Creates a separate node for the camera, aim, and up. 
Each node is selectable and can be moved in the Render Window. 

o Orthographic Camera - Creates a camera with an orthographic view. 



o Viewpoint - Creates a bookmark for the viewpoint, capturing the position and 
orientation of the camera(s). A camera track, which stores the viewpoints, is 
created below the camera. 

 

o Group - Creates an empty group. Drag and drop cameras into the group. 
o Track - Enables you to use the camera animation within the Clip Maker. To do so, 

create an animation block inside the Curve Editor. Drag the camera block into 
the Clip Maker to use it. 
 

• Edit - Provides the following editing options: 
 

o Rename - Renames the selected camera, view point, track, or group. 
o Duplicate - Duplicates the selected camera, view point, track, or group. 
o Delete - Deletes the selected camera, view point, track, or group. 
o Copy Attributes - Copies all the attributes of the selected camera to the 

clipboard. 
o Paste Attributes (sub menu) - Provides the following pasting options: 

 
 All - Pastes all attributes. 
 Viewing - Pastes only the camera view attributes. 
 Camera Attributes - Pastes the general camera attributes. 
 Tonemapping - Pastes only the camera tone mapping attributes. 
 Color Correction - Pastes only the camera color correction attributes. 



 Glow - Pastes only the camera glow attributes. 
 Glare - Pastes only the camera glare attributes. 
 Blending - Pastes only the camera blending attributes. 

 
o Mirror X, Mirror Y, and Mirror Z - Pastes only the X, Y, or Z mirror reflection of 

the camera. 
o Set to Current View - Updates selected viewpoint with the current position and 

orientation. 
o Reset View - Resets the view to its initial settings. 

 
• Activate - Activates the selected camera and connects it to the Render Window. 
• Select Node - Selects camera node in the Scene Graph. 
• Select Aim Node - Selects camera aim node in the Scene Graph. 
• Select Up-Vector Node - Selects camera up-vector node in the Scene Graph. 
• Save Selected - Saves the selected camera to an .osb file. 
• Load - Loads cameras and settings from an .osb/.vpe/.vpb file. 
• Load Settings from Rendering - Loads settings from a rendered image (.jpg/.png/.tiff) 

including the meta data. 

Camera Parameters 

This section of the Camera Editor has three tabs. All parameters for camera settings are listed in 
the first tab. Image processing parameters are in the second and advanced settings are in the 
third. Select a camera to load its parameters. 

Camera Settings 

Use these parameters to modify the camera's settings. 

• General - Provides the following general options: 
 

o Wireframe - Renders the selected camera view in wireframe mode. 
o Projection Mode - Sets up the projection mode of the projection matrix for the 

selected camera. 
o Perspective - Renders the current scene in perspective projection view. This 

mode is the most natural way of image reception. 
o Orthographic - Renders the current scene in parallel projection view. 
o Spherical Map, Peters Map, Vertical Cross, Horizontal Cross - Renders the 

current scene with a 360° environment projection. To use one of these modes, 
create a Perspective Camera, activate it, and choose the desired projection 
mode. These projection modes only take effect when raytracing is activated. 

o Omnidirectional Stereo - Creates two 360° rendered views for VR application. 
This projection mode only take effect when raytracing is activated. 



o Custom Matrix - Activates the projection matrix in the Advanced tab. 
o Field of View Mode - Defines whether the angular Field of View is horizontal or 

vertical. 
o Field of View - Sets the field of view angle of the camera, measured in degrees. 

You can switch between horizontally and vertically defined FOV, using Lens 
Attributes > Field of View Mode. The Field of View parameter is directly 
connected to the focal length parameter. 

o Stereo Layout - Sets the layout for the two eyes. 
o Eye Separation - Sets the eye separation. 
o Polar Merge Angle - Sets the starting angle for reducing eye separation to 0, to 

avoid artifacts at the poles. A value of 0 degrees will start the reduction 
immediately. A value of 90 degrees turns merging off completely. 
 

• Viewing - Provides the following viewing options: 
 

o Translation - Translates the camera, using these X, Y, and Z options. 
o Rotation - Rotates the camera, using these X, Y, and Z axes options. 

 
• Lens Attributes - Provides the following lens attribute options: 

 
o Dolly Zoom - Works in conjunction with Field of View and Focal Length changes 

and only affects the current focused object within the Render Window (double 
right-click on the object's surface). The effect changes the focal length and the 
field of view in combination with moving the camera, making the observer feel 
like the focused object is always in the center of interest and everything around 
it moves. 

o Focal Length - Sets the focal length, measured in millimeters, which affects the 
camera's zoom. The focal length is directly related to the field of view. 

o Focus Distance - Sets the focus distance in millimeters. 
o Sensor Presets - Contains preset camera lens settings based on common camera 

lenses. 
 

 1/3.2" (iPhone 5) (4.536 w, 3.416 h) 
 Standard 8mm film frame 
 1/3" (iPhone 6) (4.800 w, 3.600 h) 
 1/2.5" (Sony DSC-T5) (5.760 w, 4.290 h) 
 1/2.3" (Gopro Hero 3) (6.160 w, 4.620 h) 
 1/1.8" (Nokia N8) (7.176 w, 5.319 h) 
 1/1.7" (Canon G10) (7.600 w, 5.700 h) 
 2/3" (Fuji X-S1) (8.800 w, 6.600 h) 
 Standard 16mm film frame 
 1" (Nikon CX) (12.800 w, 9.600 h) 
 Four Thirds (4/3”) (18.000 w, 13.500h) 
 1.5" (Canon G1) 



 APS-C (Nikon DX) 
 Standard 35mm film frame (36.000 w, 24.000h) 
 35mm full frame (Canon EF, Nikon FX) 
 Standard 65mm film frame 
 IMAX film frame 
 1/3.6” (4.000 w, 3.000 h) 
 1/2.7” (5.371 w, 4.035 h) 
 1/2” (6.400 w, 4.800 h) 
 1.8” (23.700 w, 15.700h) 

 
o Sensor Size - Sets the sensor width and height in millimeters. 
o Principal Point Offset - Provides the following offset options: 

 
 X-Offset - Sets the X offset of the image plane. It does not affect the 

translation of the camera. 
 Y-Offset - Sets the Y offset of the image plane. It does not affect the 

translation of the camera. 
 Roll - Rotates the image plane, not the camera. 

 
o Enable Depth of Field - Activates or deactivates the depth of field function. With 

Enable Depth of Field activated, you have access to the F-Stop settings in the 
Lens Attributes. 

o F-Stop Presets - Contains a selection of commonly used camera F-Stops (f/1, 
f/1.4, f/2, f/2.8, f/4, f/5.6, f/8, f/11, f/16, f/22, f/32, f/45, f/64, f/90, f/128) 

o F-Stop - Defines a custom F-Stop as f over the input value (f/x). 
o Enable Motion Blur - Activates or deactivates motion blur. When activated, you 

have access to the shutter settings in the Lens Attributes. 
o Shutter Presets - Contains a selection of commonly used shutter speeds (1/1000, 

1/500, 1/250, 1/125, 1/62, 1/30, 1/15, 1/8, 1/4, 1/2, 1”, 2”, 4”, 8”, 16”, 32”, 64”) 

NOTE Enable Motion Blur must be activated to use this option. 

o Shutter Speed - Defines a custom shutter speed in 1 over the input value (1/x). 

NOTE Enable Motion Blur must be activated to use this option. 

• Clipping - Provides the following clipping options: 
 

o Near Plane - Sets the distance between the near clip plane and camera, 
measured in scene units. Millimeters are the default. All objects closer to the 
camera than the near clipping plane are not rendered. 

o Far Plane - Sets the distance between the far clip plane and camera, measured in 
scene units. Millimeters are the default. All objects further away from the 
camera than the far clipping plane are not rendered. 



o Calculate - Calculates near and far plane values based on the object's boundings, 
and their distances to the camera, in the current scene. 
 

• Animation - Provides the following animation options: 
 

o Viewpoint Transition - Turns on/off the camera change animation. Camera 
parameters are smoothly interpolated when switching to a viewpoint with this 
option activated. 

o Duration - Sets the duration of the camera flight to the viewpoint. 
o Evaluate Navigation Mode - Restricts the camera transformation to valid poses 

in the current navigation mode. This applies to both custom created animations 
of the Curve Editor and Camera Track. When unselected, a camera may take all 
poses during animation and on viewpoint activation, regardless of active 
navigation mode. This feature is selected, by default, for converted cameras. 

o Distance - Sets the distance between the camera and center of interest. 
o Height - Sets the height relative to the center of interest and distance. 
o Angle - Defines the vertical angle relative to the focus point. 
o Get From View - Gets the respective camera settings from the current viewport 

settings. 
o Animation - Creates an animation that rotates the camera 360° 

counterclockwise around the perpendicular axis of the focused object. Double 
right-click an object to center the camera on that point and locate the center of 
the turntable. You can also use Zoom To to make the center of the turntable the 
same as the selected object. Aim cameras will use the rotation pivot of the aim 
node as the pivot of the turntable. Replay the animation by clicking the Play 
button. The duration of the 360° rotation can be set in the field next to the Play 
button. 

NOTE The shorter the duration, the faster the animation rotates. 

o Direction - Sets the rotation direction of the turntable. Choose from Clockwise or 
Counter-clockwise. 

o Loop - Continues playing the animation until you stop it. 
 

• Visualization - Provides the following visualization options: 
 

o Display Camera - Shows or hides the camera. 
o Display Aims - Shows or hides the aim geometry for the selected item. 
o Scale - Displays the scale of the camera representation. 

 



Image Processing 

All camera image processing parameters are found in this tab. 

• Tonemapping - Makes it possible to map the high dynamic range rendering for display 
onto an output device with lower dynamic range. 
 

o Tonemapper - Selects an algorithm to adjust the appearance of a 32-bit render. 
o Reinhard Luminance - Uses the tone mapping methods, based on Erik Reinhard’s 

methods. The tone mapping takes place, based on the luminance values of a 
pixel. The pixel color information is retained. 

o Reinhard RGB - Uses the tone mapping methods, based on Erik Reinhard’s 
methods. The tone mapping takes place separately for each channel of an RGB 
pixel. Bright pixels are desaturated, as with a digital camera sensor. 

o Logarithmic Luminance - Uses a logarithmic mapping, based on the luminance 
values. This mapping corresponds approximately to the human perception. The 
color information remains unchanged. 

o Logarithmic RGB - Uses a logarithmic mapping that affects each channel of an 
RGB pixel separately. Bright pixels are desaturated. 

o Filmic - Uses an s-curve mapping that reproduces the behavior of a photographic 
film. RGB channels are mapped separately. Two parameters control the shape of 
the s-curve: 
 

 Shoulder Strength - Controls the gradient in the area of bright pixels. 
 Toe Strength - Controls the gradient in the area of the dark pixels. 

 
o Physical Camera - Enables the option to work with physical values like F-stop, 

Shutter Speed, and ISO to control the tonemapping of the image. Additionally, 
presets of response camera curves can be loaded and edited to adjust the 
appearance of the rendering. These values affect the amount of motion blur and 
depth of field. Also, a focal length change affects the exposure of the rendering. 

o F-Stop - Sets the ratio of the focal length to the aperture. 
o Shutter Speed - Defines a custom shutter speed in 1 over the input value (1/x). 
o ISO - Determines the sensitivity of the image sensor; the lower the number, the 

less sensitive the camera is to light. 
o Sensor Response - Provides the following options: 

 
 Custom Response Curve - Allows the use of a custom sensor response 

curve for RGB or Luminance. 
 

 Response Curve Editor Size - Sets the response curve editor size 
to small, medium, or large. 

 Response Curve Mode - Sets the response curve mode to use 
luminance, red, green, or RGB. 



 Response Curve - Allows a custom response curve, from or to a 
file, to be loaded or saved. 
 

 ACES 1.0 - Uses sensor response behavior, as defined in the Academy 
Color Encoding System, so there will be a filmic color shift. For example, 
red glowing objects shift to yellow. 

 ACES 0.7 - Uses sensor response behavior, as defined in the Academy 
Color Encoding System, so there will be a digital look, where red glowing 
objects shift to white. 
 

o Luminance - Shows the luminance values in the scene. Luminance is the light 
reflected from a surface, so this is what a human eye would see. 

o Illuminance - Shows the illuminance arriving at a surface. 
 

• Exposure - Sets the scaling factor for the luminance of the image. 
• White Point - Sets the luminance value, which is mapped to the value 1 (that is, the 

maximum luminance of the display device). 
• Colorspace - Sets the colorspace used when rendering your images. 

 
o sRGB - Uses the standard RGB color space for vibrant saturated consistently 

displayed colors. 
o ACES - Helps reproduce the color shifts that occur when filming a bright light. For 

example, think of a taillight where red gets shifted to yellow or a bright sky that 
gets slightly desaturated. 
 

• Blending - VRED provides different modes of blending. By default, this will be off. 
 

o Off - No blending. 
o Vignette - Renders a vignette on top of the rendering. A vignette darkens the 

corners of an image. 
o Amount - Sets the opacity of the vignette. The amount can be used to control 

the darkness of the vignette. 
o Radius - Sets the radius of the vignette. 
o Roundness - Sets the shape of the vignette. A roundness of 0 indicates the 

ellipse fits the render resolution. 
o Feather - Defines the blurriness of the vignette. 
o Image - Multiplies a texture on top of the rendering. Can be used for texture 

overlays. 
o Amount - Sets the opacity of the image. 
o Left and Right Eye Blend Map - Allows the use of blending textures at pixel level. 

At a final pass, the input image is multiplied with the rendering. In stereo mode, 
it is possible to define different images for left and right eye. 

 



• Color Correction 
 

o White Balance - Defines the white balance value that affects the image in the 
post-processing procedure. 

o Hue-Shift - Defines the hue-shift value. 
o Contrast - Sets the overall contrast. 
o Brightness - Sets the overall brightness. 
o Saturation - Sets the color saturation. 
o Apply To Backplates - Applies the camera color correction and the camera's 

white balance to the backplate. Otherwise it is only applied to the rendered 
geometry. 

o Apply To Frontplates - Applies the camera color correction and the camera's 
white balance to the frontplate. Otherwise it is only applied to the rendered 
geometry. 
 

• Glow 
 

o Enable - Enables/disables glow. When enabled, Threshold, Size, and Intensity are 
activated. 

o Threshold - Determines the threshold of the brightness of a pixel where the glow 
effect sets in. 

o Size - The glow size determines the size of the glow surrounding an object. 
o Intensity - The glow intensity determines the brightness of the glow. 

 
• Glare 

 
o Enable - Enables/disables glare. 
o Threshold - Determines the threshold of the brightness of a pixel for where the 

glare effect sets in. 
o Size - Determines the size of the glare. 
o Intensity - Determines the brightness of the glare. 
o Rotation - Sets the rotation of streaks in a specified angle. 
o Streaks - Determines the maximum count of streaks. Higher values appear like 

stars. 
 

• Fog 
 

o Distance fog - Defines the characteristics of fog as it gets farther away. As it 
travels further into the scene, objects become less visible and the fog gets 
thicker, just like in real life. So, if you want your object to stand out against your 
background, this is an elegant way to achieve this. 

o Color - Determines the color of the fog. Use the slider or enter the RGB value for 
the color of your Distance fog. The color you set is blended with the lit material 
color and factors in the Falloff value you've set. 



o Falloff - Describes how the fog changes in density as you travel deeper into a 
scene. There are two options: 
 

 Linear - Creates fog that slowly thickens as you move deeper into the 
scene and away from the camera, ultimately creating less fog than 
Realistic. 

 Realistic - Creates life-like fog that quickly thickens (exponentially) as you 
move deeper into the scene and away from the camera. 
 

o Distance - Sets how near or far the camera is from the beginning of the fog. 
o Density - Determines the thickness of the fog, based on the selected Falloff 

option and distance. When set to a high value, objects in the scene quickly blend 
into the background, getting obstructed by the fog. 

o Noise Intensity - Creates noise in the fog density. The density of the fog appears 
to be different in different places, not uniform. Use it to roughly approximate 
clouds or similar phenomena. 

o Noise Size - Determines the size of the irregularities in the fog, made by the 
noise function or texture. When Noise Intensity is greater than zero, you can 
change their size. Use the three sliders to scale the size of the irregularities in 
one or all three directions (X, Y, and Z). If you want uniform scaling, tick the 
Uniform Scaling check box. 

o Noise Offset - Changes the position of the irregularities in the fog, made by the 
noise function or texture, when Noise Intensity is greater than zero. 

o Uniform Scaling - Determines whether noise functions/textures are all scaled 
uniformly or at different rates when Noise Size is set. 

o Height fog - Helps you simulate effects like ground fog or fog at the top of high 
buildings. Like Distance fog, Height fog depends how far away things are and 
where they are inside the fog. 
 
Things that are closer are move visible. As things get further away, the fog gets 
thicker. 

When things are inside the fog, you won't notice a difference between Distance 
fog and Height Fog. Where you will notice a difference is where parts of objects 
can be outside the fog, unobscured, while others won't be and are obstructed. 

o Color - Determines the color of the fog. Use the slider or enter the RGB value for 
the color of your Distance fog. The color you set is blended with the lit material 
color and factors in the Falloff value you've set. 

o Falloff - Describes how the fog changes in density as you travel deeper into a 
scene. There are two options: 

o Linear - Creates fog that slowly thickens as you move deeper into the scene and 
away from the camera, ultimately creating less fog than Realistic. 



o Realistic - Creates life-like fog that quickly thickens (exponentially) as you move 
deeper into the scene and away from the camera. 

o Density - Determines the thickness of the fog, based on the selected Falloff 
option and distance. When set to a high value, objects in the scene quickly blend 
into the background, getting obstructed by the fog. 

o Min Max - Min defines at what height from the ground the fog begins. Max 
defines at what height from the ground the fog ends. To see Height fog, the Max 
value must be greater than Min. 

o Noise Intensity - Creates noise in the fog density. The density of the fog appears 
to be different in different places, not uniform. Use it to roughly approximate 
clouds or similar phenomena. 

o Noise Size - Determines the size of the irregularities in the fog, made by the 
noise function or texture. When Noise Intensity is greater than zero, you can 
change their size. Use the three sliders to scale the size of the irregularities in 
one or all three directions (X, Y, and Z). If you want uniform scaling, tick the 
Uniform Scaling check box. 

o Uniform Scaling - Determines whether noise functions/textures are all scaled 
uniformly or at different rates when Noise Size is set. 

o Blend Range - Normally, fog density is constant, resulting in unpleasant sharp 
transitions between foggy and non-foggy areas. Use the Blend Range slider to 
gradually change fog density as you get higher into the fog. At the beginning, the 
fog gradually builds, until it's reached maximum density, then gradually fades 
away. The fog disappears when Blend Range is set to 1. 

Advanced 

Advanced camera properties, such as projection, distortion map, and collision detection are 
found in this tab. 

• Projection - Provides the following options: 
 

o Skew Factor - Defines how much VRED skews the view. 
o Orthographic Size - Adapts the size of an orthographic camera. 
o Use Manual Frustum - Activates or deactivates the custom frustum settings. 
o Sides (L, R, B, T) - Defines the camera projection through a frustum, based on the 

sides Left, Right, Bottom, and Top. 
o Use Manual Projection Matrix - Overrides the Projection Mode of camera and 

activates Projection Matrix. 
o Projection Matrix - Create a custom projection matrix. When enabled, in Camera 

Settings > General, Projection Mode is automatically changed to Custom Matrix. 
o Apply - Updates the Render Window to the values entered. 

 

 



• Distortion Map 
 

o Enable - Activates or deactivates the distortion map. 
o Left and Right Eye Distortion Map - Allows the use of a distortion texture at pixel 

level. The texture describes the course of the normalized XY-image coordinates. 
The input texture is an EXR-image. The red channel describes the course of the X-
image coordinate. The green channel describes the course of the Y-image 
coordinate. The origin (0,0) is at the bottom left corner. 
 

• Collision Detection 

Supports the operator on presentations to prevent camera intersections with objects. 

o Use Collision Detection - Enables/disables a feature that recognized when the 
camera collides with objects. 

o Slide - Enables the camera to glide over the surface. when a collision occurs. 
o Distance - Defines the distance between the camera and an object in mm, when 

the camera detects a collision. 
o Nodes - Adds the current selection from the Scene Graph to the list of objects 

considered on collision detection, when Add Node is used. Remove Node deletes 
the selected entry/object from the list. 

o Triangle Based / Bounding Box Based - Determines the selection algorithm 
(Triangle or Bounding Box) used for collision detection. 

o Build Scene - Creates the scene, by using the pre-calculation of the above 
settings. Any change to the settings require re-calculating the scene. 
 

• From/At/Up 
 

o From - Sets the 3D coordinates for the camera position. 
o At - Sets the coordinates for the center of interest. 
o Up - Sets the coordinates for the up vector to define which direction is up in the 

scene. 
o Apply - Updates the transformation of the selected camera to the entered 

values. 
 

• Camera Track Animated and Track - Either of these sections, Camera Track Animated or 
Track, and their options are only visible when a Track is selected in the Camera Tree. If 
the selected Track is animated, then the Camera Track Animated section appears, along 
with others, including Track. If the Track is not animated, only the Track section appears. 



 

 

Viewpoints and settings for animation interpolation are stored within the Track section. 
Every camera has its own track. Double-click a track to collapse or expand it. 

Click Capture to create a viewpoint. The current position and orientation of the active 
camera are stored. If no camera track exists at the point of viewpoint creation, it is 
generated automatically. Each thumbnail image represents a different viewpoint. 

To create more viewpoints, use the Capture button, which attaches the capture to the 
current track. You can also use +, from the Icon Bar, to create a track. 

To rename a camera track or viewpoint, click its name and enter a new value. 



Click a viewpoint to go to it. Drag the thumbnails to rearrange the existing viewpoints. 
Right-click on a viewpoint to open its context menu to adjust animation settings and 
create a shortcut key for the viewpoint. 

• Context menu from viewpoints 
 

o Recapture - Overwrites the viewpoint with the current position and orientation 
from the Render Window’s camera. Another way to recapture a viewpoint is to 
use . 

o Delete - Removes the current viewpoint from the Camera Editor. Another way to 
delete a viewpoint is to use . 

o Animation Properties - Opens the Animation Properties dialog to set the 
animation behavior of the camera when a viewpoint is selected. 

o Name - Enables you to rename the viewpoint. 
o Fade-In Time - Sets when the fade starts for the current viewpoint, fading it from 

a complete black screen to the colored image. A value from 0.00 disables the 
feature. 

o Animation Duration - Sets how long the camera is animated, moving from its 
current position to the viewpoint position. A duration value of 0.00 seconds gives 
a hard cut. The viewpoint duration doesn’t affect the track duration. 

o Pause Time - Time the animation waits before the camera moves to the 
viewpoint position. 

o Overwrite track settings - Makes the viewpoint use its own animation settings, 
created in this Animation Properties dialog, when enabled. These settings only 
influence the final animation. When disabled, the viewpoint uses the Global 
Camera Track animation settings. 

o Hotkey - Defines a hotkey for the current viewpoint. 
 

• Buttons beside the viewpoint thumbnails - These buttons are hidden on lower zoom 
levels. 
 

o  Delete - Removes the viewpoint from the Camera Editor. 
o  Recapture - Overwrites the viewpoint with the current position and 

orientation from the Render Window’s camera. 
 

• Buttons beside the track title 
 

o  Play - Plays (and stops on replay) the current camera track within the Render 
Window. 

o  Delete - Removes the track and its related viewpoints from the Camera 
Editor. 



o  Camera Track Settings - Opens the Camera Track Settings dialog to set 
replay behavior for the camera track. 

o Name - Enables you to rename the camera track. 
o Fade-In Time - Defines the time used for the moment of fading. On replay, a 

viewpoint will start with fading from a complete black screen to the colored 
image. A value from 0.00 disables feature. 

o Animation Duration - Sets how long it takes for the camera to move from one 
viewpoint to another. A duration value of 0.00 corresponds to a hard cut, 
meaning there is no animation between different viewpoints. 
 

• Pause Time - Defines how long the animation waits after it arrives at a viewpoint before 
it goes on to the next. 

• Slider - At the bottom of the Camera Track, is a slider. Use it to zooms in and out of the 
preview thumbnails. 

 

 



 Icon Bar 

Use the icons in this toolbar to create, duplicate, or delete a camera, viewpoint, track, or group, 
as well as toggle different camera and viewpoint attributes. 

How to Create a Camera 

Select Create. This creates a camera, camera and aim, camera, aim, and up, orthographic 
camera, viewpoint, track, or group. 

How to Duplicate a Camera 

Select Duplicate. This creates a copy of the current selected camera, viewpoint, track, or group. 

How to Delete a Camera 

Select Delete. This deletes the current selected camera, viewpoint, track, or group. 

How to Toggle the Depth of Field 

Select Toggle DOF. This toggles depth of field for the selected camera or viewpoint. 

How to Toggle Motion Blur 

Select Toggle MB. This toggles Motion Blur for the selected camera or viewpoint. 

How to Toggle a Glow 

Select Toggle Glow. This toggles the glow effect for the selected camera or viewpoint. 



Working with a Camera 
In VRED, using cameras includes creating, viewing, and editing them. Sometimes, you might 
even mirror a camera. 

Using Cameras 

Let's start with creating a camera. Once created, you might not see anything, so the next step is 
to make it visible. After that, you can transform and edit it. The following sections will explore 
each of these and more. 

How to Create a Camera 

Since there are a few camera choices, let's select the type of camera you want to create. 

1. In the Menu Bar, click Scene > Create Camera. 
2. Select the type of camera you want to create. 

 
o Camera - Creates a camera with a perspective view, which is similar to the view 

of human eyes. Through a perspective view, objects further away seem smaller 
than objects right in front. Original parallel lines appear centric to a single point a 
long distance off. This view is the default for file output (see Render Settings). 

o Camera and Aim - Creates a separate node for the camera and the aim. Each 
node is selectable and can be transformed in the Render Window. The aim node 
controls where the camera points. The aim point is the rotational pivot of the 
aim node. Navigation modes, such as Fly and Orientation, do not align with aim 
cameras and are disabled. Navigation has certain influences on the aim node. 
While panning, the aim moves with the camera. Dollying toward the pivot keeps 
the aim in position, except when the camera moves over the aim, then it moves 
forward with it. 

o Camera, Aim and Up - Creates a separate node for the camera, aim, and up. 
Each node is selectable and can be transformed in the Render Window. The 
camera calculates its orientation from the aim and up nodes. The camera points 
to the aim node and its top is oriented towards the up node. The up vector of 
the camera is determined by the pivot of the up node. Two-Axis navigation 
reverts to Trackball mode for an Aim and Up camera. 

o Orthographic Camera - Creates a camera with an orthographic view, which is a 
view where all objects have the same size irrespective of distance. Each object’s 
actual height and width is shown and parallel lines remain parallel. 

NOTE To see a representation of the camera in the viewport, you will need to 
make it visible. See the section that follows. 

http://help-staging.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=The-Render-Settings-Dialog


How to Display a Camera 

Once you've created a camera, the next step is to make it visible because once it's displayed, 
you can move it into position. You can show or hide all representations of cameras. When a 
camera node is selected in the Scene Graph, a highlighted representation appears in the 
Viewport. 

• When a camera is not selected, it appears white. 

 

• When you hover over it, it takes on the Preselection Color preference color. 
• When selected, it takes on the Wireframe Color preference color. 

 

 



NOTE To change either the Preselection Color or the Wireframe Color, in the Menu Bar, 
select Edit > Preferences > Selection. 

In the Menu Bar, click View > Show Cameras. 

This option is saved in the VRED project file. When importing scenes from previous 
versions, it is disabled by default. Active camera representations of the current Viewport 
are not drawn, and orthographic default cameras are turned off by default. Cameras do 
not have bounding box representation. 

How to Edit a Camera 

There are two ways to edit a camera. To manipulate a camera with normal scene navigation, 
use the Transform tool. For exact placement, use the Camera Editor. 

How to Place a Camera Using the Camera Editor 

1. In the Menu Bar, click Scene > Camera Editor. 
2. On the left side of the Camera Editor, select the camera you want to edit. 
3. Make changes to the camera. 

NOTE Cameras are also selectable and can be translated and rotated with the transform 
tool. 

How to Place a Camera Using the Transform Tool 

1. In the Menu Bar, click Transform. 

2. In the Scene Graph (click ), select the camera you want to edit. 
3. Shift-click and drag the Transform manipulator to position the camera. 

How to Mirror a Camera 

You can mirror any type of camera to display the same viewing angle from the opposite side of 
a scene. 

1. In the Camera Editor, right-click the camera to open the context menu. 
2. Select Edit > Mirror X, Y, or Z. 

Mirroring a camera does not affect animations or camera tracks. 



Working with Fog 
Add fog for atmospheric effect and to make your model the center of attention. 

Cameras in VRED support classic fog effects as part of image processing. The fog is only visible 
when there's geometry. It's not volumetric, so there's no fog between objects. Create either 
distance or height fog. Use Fog for atmospheric effects to help someone better understand the 
distance and scale of objects. Make your model the center of attention, by fading objects in the 
distance. In the Camera Editor, along the left, select a camera angle, then to the right and along 
the top, select the Image Processing tab and click Fog to expose its parameters. 

Several parameters were added, such as Noise Offset, so you can change the position of 
irregularities in the fog. 

How to Create Fog 

1. In the Quick Access Bar along the bottom of your screen, click Cameras to access the 
Camera Editor and the Fog UI. 

 

2. Click one of the camera nodes, then the Image Processing tab to the right. 
3. Click Fog to access its parameters. 

VRED creates two types of fog, Distance and Height. 

 

NOTE Fog is computed before any other post-processing effect. 



How to Copy and Paste 

As with other camera attributes, Fog attributes can be copied and pasted between cameras or 
viewpoints. 

How to Animate Fog Attributes 

Fog attributes can be animated in the Curve Editor. See How to Create Keyframe Animation for 
more information. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Creating-a-Keyframe-Animation


Sceneplates 



About Sceneplates 

What are Sceneplates? 

Sceneplates are a set of planes bound to the viewpoint. They consist of frontplates (previously 
known as Overlays) and backplates. 

What is a Frontplate 

A frontplate is an element (plane) that exists in front of your product. It could be an image, text, 
or HMI/HTML web content. Use its transition effects to fade in and out of the frontplate text 
and/or images. 

Use frontplates for simple things like watermarks, trademarks, product text, and company 
logos. For something a bit more complex, create an interactive overlaid component, such as 
menus, for changing elements of your product, like color, textures, materials, orientation, even 
some of the geometry. 

 

For example, there's a customer who wants to see the latest model of a car, but customized to 
their specifications. Instead of the basic model, they want the sports package, in a different 
color, with a different paint finish and the luxury upholstery. With VRED, you can create a 
frontplate with the functionality to change these attributes, so the customer can take a virtual 
tour of their customized vehicle. 



What is a Backplate 

A backplate is an element (plane) that exists behind the product in your scene. Use a static 
image or sequence of images for your backplate to place your product in a different location or 
change the time of day. 

What can you do with Sceneplates 

You can do the following with sceneplates: 

• Can add one or more sceneplates in a scene. 
• Move, scale, and/or rotate one or more frontplates and backplates, using the toolbar's 

Transform tool and its options. You can manipulate multiple sceneplates at once. 
• Select one frontplate/backplate or multiples, using the Sceneplate section option, under 

Selection. Use Shift-drag for rectangular selection, Shift-click for individual, and 
Shift+Ctrl-click for multiple selection. See To Select Objects in Render Window for 
selection shortcuts. 

• Animate frontplates and backplates, using Curves, by setting keys on properties in the 
Sceneplate Editor. Animate sceneplate transparency to fade in and out of frontplates or 
backplates. 

NOTE You cannot animated frontplate text itself (no changing it from saying "dog" to 
"cat"), but you can animation the position, color, transparency, and background 
transparency of the text. 

Sceneplate Editor 

The Sceneplate Editor is where you create frontplates, backplates, groups, and switches. 
Options for setting properties, size, and position, as well as making color correction are all 
found here. 

Menus 

Along the top of the Sceneplate Editor are three menus: 

File 

Contains the following options: 

• Load - Opens a browser for locating and loading an OpenSG Binary Geometry (*.osb) 
sceneplate file. 

• Save - Saves all items in the Sceneplate Editor tree list as Open SG Binary Geometry 
(*.osb) files. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Selecting-%20Objects-in-the


• Save Selected - Saves the item or items selected in the Sceneplate Editor tree list as 
Open SG Binary Geometry (*.osb) files. 

Edit 

Contains options for editing content within the Sceneplate Editor tree. Rename, copy, paste, 
cut, and delete content. Create a duplicate of the selected content or paste the attributes of 
one sceneplate onto another or group of others. Lock sceneplates so changes cannot be made 
or unlock them to make changes. Reorder tree items. Select all, deselect all, or even invert a 
selection. 

Create 

Contains options for creating frontplates, backplates, groups, and switches. To create a group 
with only the selected tree items, choose Create Group from Selected. To create a switch with 
only the selected tree items, choose Create Switch from Selected. 

NOTE Right-clicking within the tree view also gives you access to these options. 

Search 

To locate something within the Sceneplate Editor tree, use the search field, located under the 
menus. Click the field, then start typing the search term, the tree view will adjust to show only 
entries that match the search. Remove all content from the search field to see all the tree 
items. 

Tree 

Contains your frontplates and backplates, groups, and switches. Click to select a tree entry and 
show its properties in the panel to the right. When something is checked, it is visible. When 
unchecked, it is hidden. Right-click to access a menu with options for creating frontplates, 
backplates, groups, and switches, editing the selected entry, load sceneplates, select, deselect, 
and reposition tree entries, and view information about the selected entry. 

Properties, Size and Position, and Color Correction 

Provides options for setting and customizing sceneplate properties, size, position, and color 
correction. Enter a name, the type of sceneplate, image or text used. Control the transparency 
and set the repeat mode. Determine the position, offset, rotation, and size of the sceneplate. If 
any color correction is required, change the white balance, shift the hue, and tweak the 
contrast, brightness, and saturation. 



Setting Per-view Options 

Set different visibility options for each view. From the toolbar, select Window > New Render 
Window, to create more views. Click to select a view, then to any of the following: 

• Right-click-hold Sceneplates and add a check to make the sceneplate visible in the 
selected view. 

• Right-click-hold Sceneplates and remove a check to hide the selected sceneplate(s). 
• Click Sceneplates. When highlighted, checked sceneplates are visible for the selected 

view. When not highlighted, all sceneplates in the selected view are hidden. 

Setting an Image Sequence 

Use an animated image sequence for a sceneplate. In the Sceneplate Editor, under Content 
Type, select Image, then click the folder icon and load an image sequence image. Check Use 
Image Sequence. It will ask if it should create animation. 

NOTE If there is already animation on the image number, you are not asked about creating 
animation. Where did it come from? It is probably due to using key all when animating 
something else, such as a front plate. 

Sceneplates with transparent images 

Sceneplates with transparent elements use an additional alpha channel for storing the 
transparency data. There are two ways this alpha channel can be interpreted: 

• Straight Alpha - This alpha channel only contains transparency information and is widely 
used and simple. An issue arises, however, when using it in textures. A visible halo may 
be introduced around semi-transparent pixels, if no special precautions are taken. 

• Pre-multiplied Alpha - This alpha channel contains transparency information and 
multiplies it into the other color channels. This makes it good for compositing and for 
textures; however, it is not widely supported. 

Sceneplates support both image types. As most image files do not indicate which alpha 
representation is use, the Sceneplate Editor has a check box for manually setting the correct 
type. By default, it is set to Straight Alpha. If a sceneplate shows erroneous pixels in transparent 
regions or dark borders around opaque areas, the type is set incorrectly. 

Using Web-engines with Frontplates 

Use web-engines as content for frontplates. After, you can use the color correction tools to 
change the white balance, brightness, contrast, hue shift, and/or saturation. 



Frontplate Pick-throughs 

If you have a transparent plate with buttons, the transparent areas can be picked through. 
When you need to select the content, you can simply click through the frontplate. This means 
you don't need to hide the frontplate, make your selection, then turn visibility back on. Also, 
when using color correction, if the frontplate is selected, only it will be affected, even though 
you can interact with the content behind the plate. 

Renderpasses 

In the Renderpasses section, under Image Processing, you can select Frontplates and 
Backplates. This renders all the views, providing a backplate pass and frontplate pass, any 
empty views, and the full view. If you have four views, there will be four renders. 

If you disable the backplates, you can see the backplate pass, the frontplate pass, etc. 



Creating and Managing Backplates 
Use backplates to provide different locations for your product. 

How to Create a Backplate 

1. In the Menu Bar, select Scene > Sceneplate Editor. 
2. Right-click in the left side of the Sceneplate Editor and select Create Backplate. 
3. Under Properties, in the Name field, enter a name for the backplate and for Repeat 

Mode, select how the backplate is applied to the scene. 
 

o Repeat - Tiles the image. 

 

o Mirror - Mirrors the content it at the ends. 

 



o Decal - Centers the image and fills the rest of the scene black. 

 

o Clamp - Stretches the pixels along the border of the image to the edges of the 
scene. 

 

o For selecting the backplate image, click the folder icon and select the image you 
want; if at any point the image is updated, click  Restore to load the latest 
version. 
 

4. Under Size and Position, adjust any necessary values. 

For absolute scale, pixels are used. For relative scale, percentage is used. 



How to Create a Backplate Switch 

1. Right-click in the left side of the Sceneplate Editor and select Create Switch. 
2. Drag and drop backplates from the list onto the switch. 
3. Select which backplate in the switch should be displayed by adding a check. 

NOTE When a child of a switch is checked, making it visible, the others are automatically 
unchecked and hidden. 

How to Use Multiple Backplates 

With sceneplates, you can have multiple backplates, create a switch for them, then use variant 
sets to switch between them. This is an example of how you can use multiple backplates. 

PART ONE - Creating Backplates and Viewpoints 

1. Use File > Import to load a model of your product into VRED. 
2. Add a backplate. 

NOTE To transform the backplate, use the UI elements in the Sceneplate Editor or the 
Transform manipulator. 

3. Use your mouse buttons to move the camera and position your product. 
 

o LMB (Left Mouse Button) for rotation 
o MMB (Middle Mouse Button) for lateral movement 
o RMB (Right Mouse Button) for forward and back 

 
4. Click the Cameras icon to open the Camera Editor. 
5. Select the Perspective camera, right-click and select Create > Viewpoint to create a 

viewpoint. 
6. Add a second backplate, then uncheck the previous backplate to makes only the new 

backplate visible. 
7. Use your mouse buttons to move the camera and position your product. 
8. In the Camera Editor, right-click the Track and select Create > Viewpoint. 

Before continuing, let's check the viewpoints. Double-click the first viewpoint. Look at the 
placement of the product. Double-click the second viewpoint, notice how the placement of the 
product has changed. We will fix the placement in PART FOUR - Setting a Camera View for a 
VSet. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Sceneplates_Creating_and_Managing_Backplates_html


PART TWO - Creating a Switch 

1. In the Sceneplate Editor, select both backplates. 
2. Right-click a backplate and select Create Switch from Selected from the menu. This 

groups the backplates under a switch called Grouped_Nodes. 

NOTE If you don't see the Create Switch from Selected option, move your cursor over 
the backplates and right-click. 

PART THREE - Creating a Variant Set (VSet) 

1. Click the VSets icon. 
2. In the Variant Sets panel to the left, right-click and select New Set. 
3. In the Sceneplate Editor, select the Grouped_Nodes switch and drag it into the VSets' 

Sceneplate tab. 

NOTE If you can't drop it into the VSets' Sceneplate tab, select New Variant 1 and try 
again. 

4. In the Variant Sets Sceneplate tab, below State, click !None, then click it again to access 
a drop-down menu and select a backplate from the list. 

5. To check it is correct, in the Variant Sets list, double-click New Variant 1. If the product 
isn't placed in the correct backplate, select the other backplate from the list. 

Repeat steps 2 - 4, but select New Variant 2 and the other backplate, to create another variant 
set. 

PART FOUR - Setting a Camera View for a VSet 

The second variant set created above does not use the correct viewpoint (camera view). To test 
this, double-click New Variant 2. Notice that the product is positioned incorrectly. In this 
section, we will correct this by linking the correct viewpoint to the VSet. 

1. In Variant Sets, with New Variant 2 selected, click the View tab. 
2. In the Camera Editor, double-click the viewpoints to find the one with the correct 

product placement. 
3. Drag the correct viewpoint onto the Variant Sets' Viewpoints section. 
4. Select New Variant 1. If you double-click it, you will see the product placement is 

incorrect. 
5. To fix this, in the Camera Editor, select the other viewpoint, then drag it onto New 

Variant 1's Viewpoints section. 

To check that the variant sets are correctly linked, double-click New Variant 1, then New 
Variant 2. 



How to Manage Backplates in the Sceneplate Editor 

In the Sceneplate Editor, do the following: 

• To duplicate a selection of backplates, right-click the selection and do either of the 
following: 
 

o Right-click in the left side and select Edit > Duplicate. 
o Click  (the Duplicate icon) at the bottom of the editor. 

 
• To change the order in which backplates appear in the scene, drag and drop them within 

the list to rearrange them. 
• To group a selection of backplates together, right-click the selection and select Create 

Group. 
• To show or hide backplates, check or uncheck them in the Sceneplate Editor list. 



Creating and Managing Frontplates 
Use frontplates (formerly known as overlays) to create car variants, to specify the product life 
cycle state, or to add watermarks, trademarks, or legal information. For meetings, overlay 
images, such as your company logo, and text, like dates, for presentations. 

How to Create a Frontplate 

1. In the Menu Bar, select Scene > Sceneplate Editor. 
2. Right-click in the left side of the Sceneplate Editor and select Create Frontplate. 
3. Under Properties, in the Name field, enter a name for the frontplate and for Content 

Type, select whether it will be text, web, or an image. 
 

o For a text frontplate, enter the text you want and properties, such as font, color, 
and transparency. 

o For an image frontplate, click the folder icon and select the image you want; if at 
any point the image is updated, click  Restore to load the latest version. 
 

4. Under Size and Position, adjust any necessary values. 

For absolute scale, pixels are used. For relative scale, percentage is used. 

How to Create a Frontplate Switch 

1. Right-click in the left side of the Sceneplate Editor and select Create Switch. 
2. Drag and drop frontplates from the list onto the switch. 
3. Select which frontplate in the switch should be displayed by adding a check. 

NOTE When a child of a switch is checked, making it visible, the others are automatically 
unchecked and hidden. 

How to Manage Frontplates in the Sceneplate Editor 

To duplicate a selection of frontplates, right-click the selection and do either of the following: 

• Right-click in the left side and select Edit > Duplicate. 
• Click  (the Duplicate icon) at the bottom of the editor. 

 
 



 
To make changes after this, do any of the following: 

• To change the order in which frontplates appear in the scene, drag and drop them 
within the list to rearrange them. 

• To group a selection of frontplates together, right-click the selection and select Create 
Group. 

• To show or hide frontplates, check or uncheck them in the Sceneplate Editor list. 



Lights 



About Lights 
Learn about delta and area lights, such as directional, point, spot, spherical, disk, and 
rectangular. Also, read about IES Profiles, Ray Files, and light nodes. 

You can create the following types of lights in VRED: 

• Delta and area lights, which include directional, point, spot, spherical, disk, or 
rectangular lights. 

• IES Profiles and Ray Files (VRED Professional only). 

Delta and Area Lights 

These are the delta and area lights found in VRED: 

Directional Light 

Light rays from directional light sources are parallel like sunlight. 
A directional light represents a distant light source and has no 
position only a direction that affects how the scene is 
illuminated. Directional lights always create hard shadows. 

 

Point Light 

Point light rays start at a single point and emit radially. In 
Raytracing mode, the point light generates a hard shadow. In 
OpenGL, a point light has a shadow. 

 

 

Spot Light 

Spot light rays follow a beam cone. They start at a single point 
and spot in a circular area on the object. It is often used to 
emphasize an object or surface. 

 



Spherical Light 

Spherical light rays beam like from a glowing ball and generate 
diffuse light and soft shadows. It is an indirect lighting and more 
atmospheric than a point light. In OpenGL, a spherical light has 
a shadow. 

 

Disk Light or Rectangular Light 

The disk or rectangular light rays are created from a light source, appearing as if from a 
dropped ceiling, either from a circle (disk) or from a square (rectangular). 

  Disk Light 

  Rectangular Light 

IES Profiles and Ray Files (VRED Professional only) 

Ray Light 

Ray light files contain the simulated spatial and angular distribution, as well as photometric or 
spectral information of emitted light from a complex light source. 

The shadows generated by more than one light source on an object, add up where they 
overlap. Similar to new geometry, the newly created light source appears at (0,0,0), by default, 
whether or not an object is selected. Location, size, angle, and so on, can be modified by using 
the Transform Manipulator. 



 

VRED can read ray files in the following formats: 

• plain ASCII format 
• LucidShape's ASCII and binary formats 
• spectral LucidShape ray file format 
• Osram's ASCII format 

The basic method is to use photon mapping, which is easy to set up and accurately recreates 
the illumination stored in the ray file. However, since ray files are just a bunch of photons, they 
cannot be seen in specular reflections/refractions. Glossy reflections are also problematic, since 
you need a lot of rays for them to be noise free. 

For the second method, you need the geometry the 
photons in the ray file originating from. If you have the 
geometry, you can turn it into a light source (in the 
material's Incandescence channel: select Evaluate Ray 
Lights). Whenever a ray hits the light geometry, a view-
dependent lookup into the ray file is performed. With this 
approach, you do not need to use photon mapping. You 
can "look directly into" the light source and see the light in 
the specular reflections/refractions. Although you will get 
a noise-free image easier, it maybe not be as accurate. 

VRED Professional only, Raytracing only, needs photon mapping or surface with ray light 
evaluation 

IES Profiles 

These light types support IES profile in Raytracing and 
OpenGL mode: Point light and Spot light. 

These light types support IES profile in Raytracing mode: 
Disk light, Rectangular light, and Spherical light. 

The correct way to use an IES Profile is to load it into a 
point light. Use other types to achieve certain effects. 

Point Light with IES Profile (VRED Professional only, Raytracing or OpenGL) 



Light nodes in the Scene Graph 

In VRED 2016 and previous versions, in the Scene Graph, there were two nodes for each light 
source. One node stored its transformation, in contrast to the second, which stored properties, 
such as color. Define which objects could be locally lit by the light source using the location of 
that second node in the Scene Graph hierarchy 

Since VRED 2017, there is one node per light source in the Scene Graph, which stores both the 
transformation and other properties of the light, such as color. Since the position of that node 
in the Scene Graph is not relevant when it comes to local lighting, use Light Link Sets in the Light 
Editor to define local lighting of objects. 



Working with Lights 
Find out how to create and edit lights, as well as illuminate objects. Also, learn about cloning 
and mirroring lights and how you can use this in VRED. 

How to Create a Light 

Once you know the type of light you want to create, follow the instructions below. To learn 
about the different lights in VRED, see About Lights. 

1. In the Menu Bar, click Scene > Create Light. 
2. Select the type of light you want to create: 

o Delta and area lights, which include directional, point, spot, spherical, disk, or 
rectangular lights. 

o IES Profiles and Ray Files (VRED Professional only). 

How to Edit a Light 

To edit lights, use the Light Editor. To learn about the different parameters, see About the Light 
Editor. 

1. In the Menu Bar, click Scene > Light Editor. 
2. On the left side of the Light Editor, select the light you want to edit. 
3. Make the changes you want to the light. 

How to Illuminate Objects 

By default, a light source illuminates all objects in the scene. 

1. To illuminate only some objects, in the Light Editor, select the light. 
2. Select Local Lighting for that light and define which objects it should illuminate. If using 

VRED 2017 or newer, do this with Light Link Sets. For previous versions, use the Scene 
Graph. 

NOTE If you enable Local Lighting for a light without adding the light to a light link set, 
nothing in the scene will be illuminated. 

http://help.autodesk.com/cloudhelp/2019/ENU/VRED/files/Lights/About-Lights.HTML


How to Clone and Mirror Lights 

In VRED 2016 and earlier version, cloning lights was not possible in a usable way because all 
clones of a light source referred to the same transform beacon node and therefore were at the 
same position. 

With the new light concept in VRED 2017, you can clone and mirror lights without problems 
because they derive their position directly from the hierarchy above. 

In the Light Editor, cloned lights are only listed once. Cloned light names are underlined. Its 
tooltip shows how many instances of that light are in the Scene Graph. Double-click a light to 
select all instances in the Scene Graph. 



About the Light Editor 
Scene > Light Editor 

Use the Light Editor to create and manipulate light sources in VRED. See a list of all light sources 
within a scene. For an empty scene, Headlight is the default light source. It is automatically 
disabled when a new light source is added. The headlight can be re-enabled in the Light Editor 
or using the Headlight button in the Icon Bar. 

NOTE Another way to access the Light Editor is to right-click the empty space next to the Quick 
Access Bar and select it from the list. 

The Light Editor 

The Light Editor has a left and right side. The left houses the Light Sources Tree and Search field. 
The right contains two tabs, Light settings and Image Processing. Along the bottom of the editor 
is the Icon Bar. 

 

Search Field 

Use the Search field, found just above the Light Sources Tree, to find lights by name. It has live-
search capabilities. 



Light Sources Tree View 

The tree is on the left and displays all scene-contained light sources. After selecting a light from 
the list, parameters, such as name, color, and intensity, appear on the right. 

Context Menu 

Right-click within the left side of the Light Editor to access these options: 

Create 

• Directional Light - Light rays from directional light sources are parallel, like sunlight. A 
directional light represents a distant light source and has no position, only a direction 
that affects how the scene is illuminated. Directional lights always create hard shadows. 

• Point Light - Point light rays start at a single point, radially emits light. In Raytracing 
mode, the point light generates a hard shadow. In OpenGL, a point light shows no 
shadow. 

• Spot Light - Spot light rays follow a beam cone. They start at a single point and spot in a 
circular area in the direction it is oriented. An area around the hotspot, defined by the 
penumbra property setting, is where the light falls off to darkness. It is often used to 
emphasize an object or a surface. 

• Spherical Light - Spherical give off light rays as if from a glowing ball. A spherical light 
generates diffuse light and soft shadows. It provides indirect lighting and is more 
atmospheric and natural than a point light. 

• Disk or Rectangular Light - Light rays from disk and rectangular light sources appear as if 
from a hole in the ceiling. The light appears in the shape of a circle (disk) or square 
(rectangular). 

• Ray Light - Ray light files contain the simulated spatial and angular distribution and 
photometric or spectral information of emitted light from a complex light source. 

• Group (Ctrl+G) - Creates a group node for creating a tree structure within the Light 
Editor tree, independent of the Scene Graph tree. Groups help to keep scene-contained 
light clearly arranged. 

Edit 

• Rename (Ctrl+R) - Enables you to rename the selected light or group. 
• Duplicate (Ctrl+D) - Creates an independent copy of the selected light. 
• Delete (Del) - Removes the selected light or group. 
• Copy Lens Flare - Copies the lens flare from the selected light. 
• Paste Lens Flare - Pastes a copied lens flare on the selected light or group. 

 
 



• Inline Image Sequences - Packages inline image sequences within the .vpb file. 
• Group Selection (Ctrl+Shift+G) - Creates a group node where the selected lights are and 

pastes them as its children. 

Convert to 

Changes the selected light into another type of light. 

Switch On/Off 

Enables or disables the light. 

Toggle (Ctrl+T) 

Toggles the light on or off, depending on its previous state. 

Select Nodes (Ctrl+N) 

Selects the current node in the Scene Graph. 

Select All (Ctrl+A) 

Selects all the nodes in the Light Sources Tree. 

Deselect All (Ctrl+Shift+A) 

Deselects all nodes in the Light Sources Tree. 

Invert Selection (Ctrl+I) 

Inverts the current selection in the light list. Selects all deselected lights and deselects all 
currently selected lights. 

Save Selected Lights 

Saves the selected lights and preferences to an .osb file. 

Load Lights 

Loads previously saved lights from an .osb/.vpe/.vpb file. 

Validate 

Updates and validates all lights in the Scene Graph. 



Light Parameters 

This section of the Light Editor has two tabs. All parameters for light settings are listed in the 
first tab. Image processing parameters are in the second. Select a light to load its parameters, 
which will vary depending on the light selected. 

Light Settings 

Use these parameters to modify the light's settings. 

Name 

Displays the name for the selected light. 

Type 

Displays the type of the currently selected light. The type of light can be changed here. 

Local Lighting 

Enables the light to illuminate only certain objects in the scene. See Light Link Sets, for a 
description on how to set up which objects should be illuminated. 

Illuminate Scene 

Toggles the illumination of object on and off. If you only need the light source to cast a lens 
flare, without adding light to the scene, you would uncheck this option. If Light Link Sets are 
defined for the light source, the light source should illuminate them, if switched on. 

Intensity 

Displays the relative strength or intensity of a light, where a higher value gives off more light. 

Diffuse 

Sets the lighting color of a diffuse reflection (characteristic for light reflected from a dull, non-
shiny surface). A diffuse color attribute specifies the color of the light diffusely reflected by the 
objects to which it is assigned. 

Glossy 

Sets the lighting color of a glossy reflection. A glossy color attribute specifies the color of the 
light reflected by the objects to which it is assigned. 

http://help.autodesk.com/cloudhelp/2019/ENU/VRED/files/Lights/Working-with-Lights.HTML


Use Texture 

Loads an image texture the light source projects into the scene. Not available for directional 
and ray lights. 

Repeat Mode UV 

Sets the repeat mode of the texture. Only accessible when Use Texture is enabled. There are 
four modes: 

• Repeat - Repeats the texture in all directions. 
• Mirrored - Repeats and mirrors the texture on the x-and y-axis with every repetition. 
• Decal - Sets the texture not to repeat. 
• Clamp - Repeats only the last pixel of the texture. 

Repeat UV 

Sets the number of repetitions for the UVs. Only accessible when Use Texture is enabled. 

Offset UV 

Sets the offset for the UVs. Only accessible when Use Texture is enabled. 

Rotate 

Rotates the UVs. Only accessible when Use Texture is enabled. 

Use Temperature 

Uses the temperature value to determine the light's color values. 

• Temperature - Simulates the light's color by using a Temperature value. 

Attenuation 

Sets the falloff of the light intensity. Three values are available: 

• None - Keeps the intensity of the light constant, in relation to the distance of the light 
source. 

• Linear - Decreases light intensity linearly, in relation to the distance of the light source. 
• Realistic - Decreases light intensity quadratically, in relation to the distance of the light 

source to an illuminated object. 



Cone Angle 

Sets the light beam’s angle from one edge to the other, measured in degrees. 

Penumbra Angle 

Controls the light edge’s falloff in degrees. This feature can be a positive or negative value. 

Material Shadow Intensity 

Sets how dark or intense the material shadows cast are and their color. 

Ground Shadow Intensity 

Sets how dark or intense the ground shadows cast are and their color. 

Map Filter Radius 

Sets the radius used for filtering the shadow map lookup in OpenGL. 

Map Resolution 

Sets the quality of OpenGL shadow maps. Higher values increase the quality. 

Illuminate Shadow Material 

Illuminates the shadow material. The shadow material needs to have its reflection mode set to 
Diffuse Only, Glossy Only, or Diffuse + Glossy for this option to work correctly. 

Cast Shadow on Shadow Material 

Only available for Raytracing. Allows lights to cast shadows on shadow materials. 

Importance Multiplier 

A value higher than 1 increases the probability that the light source emits photons at the 
photon mapping. Great for rather dark light sources in an interior, if the incident light comes 
from outside Environments. 

Light Profile 
Use Light Profile 

Enables a light profile from an imported file to be used. 



IES Profile 

Defines where the light profile is located. Clip the Browse icon to the right to locate the .ies file. 

Set Profile Shape 

Uses the shape information from the .ies file for the selected light. 

Profile Info 

Displays information for the selected light, such as lumens per lamp, number of lamps, candela 
multiplier, etc. 

Visualization 
Display Light 

Shows or hides the selected light source representations in the Render Window. 

Scale 

Scales the light source representation to better fit the Render Window. 

Transform 
Position 

• Get from Camera - Sets the light’s position and direction to the current camera’s 
position and direction. 

• Apply to Camera - Sets the camera’s position and direction to the values of the 
currently selected light source. 

• Get from Node(s) - Positions the light by using the node’s transformation properties. 

Image Processing 

Not all lights will have image processing parameters. Point and Spot will, since lens flares can 
only be enabled for them. 

Lens Flare 

Use presets or create custom lens flares. Use the Lens Flare parameters for making global 
changes to all lens flares. Right-click in a blank area to access a context menu. 

Lens flare is an effect attached to a light (Point or Spot) and affect image processing. It is 
available in OpenGL and raytracing render modes and added as a post process. Use the Lens 



Flare parameters to globally adjust color, size, intensity, radius, and angular intensity. For 
control of individual Lens flare elements, such as shape and color, use the Custom preset. 

Since lens flares can be created only for point and spot lights, select one to access the Image 
Processing Lens Flare parameters. 

• To set parameters on individual elements, you'll need to create the elements, then set 
them. See the section to follow. 

• To reposition a lens flare, select the light source, then from the menu bar, use the 
Transform tool. 

Enable 

Enables or disables the lens flare applied to the selected light. 

Lens Flare Presets 

Contains a list of the following assorted lens flare presets, which can be easily applied to your 
scene. The selected preset is applied to the selected point or spot light. 

• Head Lamp Blue Steel 
• Head Lamp Ring Burst 
• Tail Lamp Ruby Red 
• Tail Lamp Radical Red 
• Sun Warm 
• Sun Cool 
• Street Lamp 

It is also possible to start from scratch by selecting Custom to create your own lens flares. Use 
the other presets' attributes as a base for your custom lens flare. Doing this will not override 
the preset. Elements can be created for your custom lens flare. See the Ghost Line section of 
Elements that follows for more information. 

Use Light Properties 

Always uses the Intensity of the light settings. This only affects the color and applies to the 
selected light source's lens flares. When disabled, the color set in the Image Processing tab's 
Color option is used globally. 

Color 

Changes the color of all lens flares. The color selected is multiplied with any element color 
already assigned. 



NOTE If Use Light Properties is enabled, the color set here is ignored and the light color is used. 

NOTE Since this color is multiplied with element color assignments, there may be instances 
where a lens flare disappears, due to the multiply operation. If this occurs, try changing the 
color of the individual lens flares (instead of using this option) or change the color of this 
option. 

If there are no element assigned colors, this color is assigned to all lens flares. 

Size 

Changes the size of all lens flares. 

Intensity (Lens Flares) 

Changes the brightness of all lens flares. 

Radius 

Changes how dispersed the flare is for all lens flares. The radius represents the virtual size of 
the light sources, since the lights do not have geometry. A larger radius requires a larger object 
to completely occlude the effect. Shrinking of the lens flare will start when the radius around 
the light source starts to get occluded by an object. That occlusion also decreases the intensity 
of the ghosts. As the radius increases, the intensity of the light decreases. As the radius 
decreases, the flare becomes more intense and defined. 

Angular Intensity 

Changes the brightness of the flare, as the angle changes. As the light source is rotated toward 
the viewer, becoming perpendicular to the view, its intensity increases. It is like how intense a 
sunset gets as it reaches the horizon, just before setting. Another example would be turning a 
flashlight's beam toward you. From your point of view, as the light aligns with your view, it 
becomes more intense, to the point of blinding. 

Context Menu 

Right-click in a blank area to access a context menu, select Create Element, then an element 
from the list. Once an element is created, options appear for renaming, duplicating, and editing 
it. 



 

Icon Bar 

Use the icons in this toolbar to create, duplicate, delete, or toggle a light on or off. 

How to Create a New Light 

Select Create New Light. This opens a menu for selecting and creating the type of light or 
making a light group. 

How to Duplicate a Selected Light 

Select Duplicate Selected Light. This creates a duplicate of the selected light and places it below 
the original in the Scene Graph and Light Sources Tree. 

How to Delete a Selected Light 

Select Delete Selected Light. This deletes the selected light. 

How to Toggle a Light On and Off 

Select Toggle Light. This turns the light cast by the selected light on or off. 



Working with Light Link Sets 
Light link holds sets of lights and sets of nodes from the Scene Graph. You can find Lights and 
Light Link Sets listed on the left side of the Light Editor (Scene > Light Editor). 

 

If a light is in a light link set and has Local Lighting selected, it only illuminates all nodes (the 
geometries in their subtrees) in the light link set, nothing else in the scene. 

Without Light Link Sets 

 

With Light Link Sets 

 



A light can appear in multiple light link sets. It illuminates all the nodes of the light link sets it is 
in. 

 

A node can live in multiple light link sets. Objects in the subgraph of the node are different. 
They are illuminated by all the lights in all the sets they are in. All non-local lights illuminate the 
objects. 

How to Create an Empty Light Link Set 

In the Light Editor, right-click in the Light Link Sets view and choose Create Light Link Set from 
the context menu. 

 

When you tap the box to the left the new empty light link set, two entries are added to the 
view: Lights and Scene Nodes. 

 



How to Add Nodes to a Light Link Set 

• Drag and drop light nodes from the Scene Graph onto Lights, and nodes that should be 
locally lit onto Scene Nodes. 

• Drag and drop lights from the Lights list in the Light Editor to a Light Link Set, as long as 
the light is not cloned (a cloned light is underlined in the list). 

• For convenience, you can drag and drop the nodes from the Scene Graph directly onto 
the Light Link Set item, and the dropped nodes are added to Lights or Scene Nodes set, 
according to their type. 

 

NOTE You can also add light nodes into the Scene Nodes set, if you want the objects in the 
subgraph of the light node to be locally lit by the lights in the Lights set. 

How to Select Nodes in a Light Link Set 

In the Light Editor, when you select a light in the Light Link Sets view, you also select the 
corresponding light in the Lights list. 

Double-click a light or node in the Light Link Sets view. This selects the corresponding node in 
the Scene Graph. This is the same function as right-clicking the node and choosing Select Nodes 
from the context menu. 



About Lens Flares and Elements 
Everything you need for lens flares is found in the Image Processing tab of the Light Editor. Lens 
flares are composed of one or more elements. To create an element, right-click and select one. 

 

Lens Flare Element 

Choose from the following lens flare elements when creating lens flares in VRED: 

 Glow 

 Creates a glowing shape. 

 

 Starburst 

Creates a sun-like effect, made up of multiple streaks. Use it for things such as street 
lamps at night, objects with stationary lights, or a light source that's partially 
obscured by an object, like a tree or building's edge. 

 



 Streak 

Creates a streaking effect, like what you get when using an anamorphic lens. 

 

 Ring 

Creates a ring-like element for the light source. 

 

 Ghost Line 

Opens the Ghost Line Editor for adding elements that move with the light source. 

Element Parameters 

When an element, such as Glow or Starburst, is selected, additional parameters appear below 
it. Keep in mind, some parameters are element-specific. When this is the case, it will be noted. 

 

Shape 

Use to change the shape of the following elements: 

• For a Ghost Line or Glow, change their current shape to a circle, triangle, square, 
pentagon, hexagon, heptagon, octagon, nonagon, decagon, or custom loaded texture, 
using the option selected from the Shape list. 

• For a Starburst, change its current shape to a fan, spike, blade, or texture. 



Glow Shape Example 

In the following example, this lens flare is a combination of many elements, 2 glows, 1 ring,  
2 starburst, and 5 ghosts in a Ghost Line. The shape used for the glow was a Circle. 

 

The shape used for this glow was Triangle. 

 

The shape used for this glow was Octagon. 

 



Starburst Shape Example 

In the following example, this lens flare is a combination of many elements, 2 glows, 1 ring,  
2 starburst, and 5 ghosts in a Ghost Line. The shape used for this starburst was Spike. 

 

The shape used for this starburst was Fan. 

 

The shape used for this starburst was Blade. 

 



Create an element 

Once you create an element, it appears in the empty space below the global parameters, the 
Element List. All elements are listed by name and can also be identified by their icon, such as 
this one for ghost elements . To view only certain elements in the Render Window, click the 
check box in front of elements to remove the check and turn off visibility. 

1. Right-click within the empty area below the global lens flare parameters, the Element 
List. 

 

2. Select Create Element, then select an element from the list. The selected element 
appears in the Render Window and in the Element List. 

3. Use the parameters to customize the selected element. Each element contains at least 
one unique parameter. 

Shape (Glow) 

Changes the shape of a glow from its current shape to a circle, triangle, square, pentagon, 
hexagon, heptagon, octagon, nonagon, decagon, or custom loaded texture, using the option 
selected from the Shape list. 

Shape (Starburst) 

Changes the shape of the starburst to a fan, spike, blade, or a custom loaded texture, using the 
option selected from the Shape list. 



Color 

Use to change the color of the lens flare. If the light already has an assigned color, this color will 
be mixed with it. Click Accept. 

Number 

Use to set how many arms a Ring or Starburst element has. 

Starburst Number Example 

This starburst has Number set to 4. 

 

This starburst has Number set to 17. 

 

Ring Number Example 

Use Number to divide a ring into segments. Zero creates a solid ring. Values of one 
or greater divide it into segments. 

  



 

When used in combination with the other parameters, you can create endless effects. 

 

Offset 

Use to offset the streak(s) from the center of the light source. Negative values will move the 
streak to the left and below the light. Positive will move it to the right and above the light. 

In the following example, this lens flare is a combination of many elements, 3 glows, 1 ring, 3 
streaks, 2 starburst, and a ghost. The streak has an offset of 0.00 and 0.00. 

 

One streak was offset -0.25 and 0.00, moving the streak to the left of the light source. 

 



The same streak was then offset +0.25 and 0.00, moving the streak to the right of the light 
source. 

 

The same streak was then offset 0.00 and -0.25, moving the streak below the light source. 

 

That same streak was then offset 0.00 and +0.25, moving the streak above the light source. 

 



Chromatic Aberration 

Use Chromatic Aberration with the Ring element to distort the colors of the ring and create a 
rainbow-like effect. The R, G, and B values are spatial values, meaning that a negative value 
moves that color spectrum inside of the ring and a positive moves the color outside the ring. As 
you change the color, it takes that color away from the other parts of the ring, creating a multi-
ringed effect. 

Ring Chromatic Aberration Example 

In the example below, the R value is positive, which 
pushes the red away from the center. The B value is 
negative, which pulls the blue toward the center. 
As you travel away from the center, the amount of 
blue is reduced, and the red is increase, creating 
the other bands of color. 

 

Ghost Line Chromatic Aberration Example 

Use Chromatic Aberration with the Ring element to distort the colors of the light. The R, G, and 
B values are spatial values, meaning that a negative value moves that color spectrum further 
away from the light source. A positive value moves the color closer to the light source. As you 
change the color, it moves that color further away from or closer to the light source. 

In the example below, the B value is set to a negative value, resulting in the blue moving in a 
direction away from the light. 

 



Thickness 

Controls the thickness of the rays of light. For some elements, an additional parameter, Streak 
Thickness, can be used to further influence Thickness. 

Ring Thickness Example 

In the example below, the ring expanding outward from the center. When set to 0, if Streak 
Thickness is also set to 0, then the ring is barely visible. As the value approaches 1, it expands, 
becoming thicker. 

 

Streak Thickness 

Controls the thickness of the segments created using Number. 

 

Edge Intensity 

Makes the edge color of the Ghost Line element more or less intense. Changing it to 0 will make 
the edge disappear. 

 



Edge Thickness 

Controls the thickness of the edges of the Ghost Line element. When Edge Intensity is high, it is 
much easier to see the difference. 

 

Ghost Line Editor 

Select a Ghost Line element to load the Ghost Line Editor. Use it for adding elements that move 
with the light source. Create, place, and edit ghost elements. 

Hover below the horizontal lines. Your cursor to change to a +. When you click, a ghost element 
is created. To move the ghost element closer to the light source, drag it toward the center line. 
To move it away from the light source, drag it away from the center line. 

 

1 Represents the position of the light source. 

2 A ghost element that appears before the light source. This means it will appear in front of the 
light in the Viewport. 

3 Other ghost elements that appear after the light source. This means they will appear behind 
the light in the Viewport. 

From within the Render Window, use the Transform tool to reposition things. 

 

 



Working with Lens Flares 
Scene > Light Editor > Image Processing 

Find out how to use lens flares. Use the Image Processing tab of the Light Editor to add lens 
flares, tweak preset flares, or create one from scratch. When finished, save them. 

How to Use Lens Flares 

Use lens flares found in the Lens Flare Presets dropdown menu. Tweak these presets or create 
custom ones. When finished, save them for reuse. If you select a preset lens flare, followed by 
the Lens Flare Preset Custom option, you can see how the preset was constructed. Notice how 
it combines elements, such as glows, rings, streaks, starbursts, and even ghost lines. Select an 
element to see how its attributes were set. When creating your own lens flare, use what you've 
observed to combine elements and experiment. 

How to Add a Lens Flare 

Use the presets to add a lens flare to a light. 

1. Select Scene > Light Editor, then from the Icon Bar, click + and select either Point Lights 
or Spot Light. 

2. Click Lens Flare Preset and select a preset. 
3. Right-click and select Create Element, followed by one of the elements. 
4. Use the Transform tool to move it into position. 

How to Customize a Preset 

Make changes to a preset lens flare to make it your own. 

1. Follow the instructions in How to Add a Lens Flare. 
2. Change some of the parameters under Lens Flare to customize your flare. 

How to Create Custom Lens Flares (Elements and Element Attributes) 

Create custom lens flares from scratch or by adding to and tweaking existing lens flares. 

1. Select Scene > Light Editor, then from the Icon Bar, click + and select either Point Lights 
or Spot Light. 

2. Once the Custom Lens Flare Preset is selected, right-click in an empty place in the Image 
Processing tab and select Create Element, followed by one of the following elements: 
Glow, Starburst, Streak, Ring, or Ghost Line. 



3. Select the created element and change any of the advanced lens flare parameters listed 
below it. 

How to Save Lens Flares 

The custom lens flares you create can be saved to be reused or shared. You will need your 
Scene Graph and Asset Manager to do this. 

1. In the Menu Bar, select Scene > Asset Manager to open the Asset Manager. 
2. Select Scene > Scene Graph to open your Scene Graph. 
3. In the Scene Graph, select the light with the lens flare and drag it into the Asset 

Manager onto the folder connected to your local machine or network. 
4. A warning will appear letting you know the light does not have a valid Asset Root node. 

Click Yes. 

The light appears in the Asset Manager in a section below the folders. 

5. Though a thumbnail preview appears next to light, select the light, then right-click and 
select Rename to give it an identifiable name. 

 



Enabling Ambient Occlusion 
Do you want to simulate a soft global illumination by computing shadows, resulting from light 
coming from all directions? If so, use Ambient Occlusion and make shadows similar to shadows 
cast from an overcast sky and feature darkens cracks, creases, corners, and points of contact. 

It is a specific, not physically accurate, rendering trick that samples a hemisphere around each 
point on the face, sees what proportion of a hemisphere is occluded by other geometry, and 
shades the pixel accordingly. It has nothing to do with light, but is, instead, a trick that looks 
appealing and increases the realism of geometry. 

In real life, surfaces close together (like small cracks) are darker, due to dirt, shadows, and so 
on. Ambient Occlusion approximates this. It does not simulate light bouncing off or through 
objects, but works even if there are no lights in the scene. 

How to Enable Ambient Occlusion 

1. In the Menu Bar, click Scene > Bake Light and Shadows. 

NOTE If Bake Light and Shadows is not listed, in the Menu Bar, turn off Simple UI. 

2. Adjust settings in the Bake Light and Shadows module. 
3. Click a calculation option: 

 
o Calculate All - Calculates the ambient occlusion for all visible and selected nodes 

and their child nodes. 
o Calculate Missing - Calculates the ambient occlusion for nodes that weren't 

included in the last ambient occlusion pass. Save time by not having to search for 
all missing visible and selected nodes and their child nodes. 

These are pre-processing calculation that take place during data preparation. It bakes the 
results on the geometry's vertices. The smoothness of the Ambient Occlusion depends on the 
detail level of the geometry. Therefore, VRED offers several ways to increase the quality on low-
level geometries, like subdividing triangles, and pre-defined quality presets. 



The Bake Light and Shadows Dialog Box 
Scene > Bake Light and Shadows 

Use the Bake Light and Shadows module to set parameters for direct and indirect illumination, 
subdividing polygon mesh, and calculating ambient occlusion. 

 

NOTE Another way to access the Bake Light and Shadows module is to right-click the empty 
space next to the Quick Access Bar and select it from the list. 

About the Bake Light and Shadows Module 

The Bake Light and Shadows module has a menu bar, sections for settings an assortment of 
parameters, and a display that calculates all light and shadows and missing ones. 

Settings Menu 

Click the Settings menu to access the following options: 

• Save Current - Saves the current lights and shadows. 
• Load from Node - Loads the lights and shadows from the selected node. 
• Load Settings and Delete Settings - Loads the light and shadow settings. Select the 

setting to be loaded. Choose from Default, Car Low Quality, Car Medium Quality, Car 
High Quality, Car Highest Quality, Groundplane Low Quality, and Groundplane High 
Quality. 



• Delete Settings - Deletes the light and shadow settings. Select the setting to be deleted. 
Choose from Default, Car Low Quality, Car Medium Quality, Car High Quality, Car 
Highest Quality, Groundplane Low Quality, and Groundplane High Quality. 

Direct Illumination 

Enables an extra calculation of direct light bounces, which increases the quality of the result. 

• Ambient Occlusion - This default setting, creates the common Ambient Occlusion 
shadow texture. This is independent of light direction and takes the mutual occlusion of 
visible geometry objects into account. Shadows are calculated based on distance. The 
ambient occlusion is computed in real-time, including during navigation and running 
animations. Therefore, it supports interactivity, but decreases performance. 

• Shadows - Creates an Ambient Occlusion shadow texture that takes all shadows of 
active lights from the scene and HDR into account. 

• Light and Shadows - Stores shadows and light information for each vertex. It replaces 
the HDR lighting after baking. The use of this kind of texture increases real-time 
performance immensely for static scenes. Later changes to geometry objects, for 
example, through transformation, do not influence the displayed shadows. 

• Shadow Quality - Defines the direct shadow quality of the ambient occlusion. Six 
presets are available: 
 

o Preview Quality - 8×8 hemisphere samples (per vertex) 
o Low Quality - 16×16 hemisphere samples 
o Medium Quality - 32×32 hemisphere samples 
o High Quality - 48×48 hemisphere samples 
o Highest Quality - 64×64 hemisphere samples 
o Ultra High Quality - 128×128 hemisphere samples 

 
• Minimum Distance - Sets the minimum distance of objects to be considered for the 

Ambient Occlusion calculation. This value defines black areas, where full occlusion takes 
place. 

• Maximum Distance - Sets the maximum distance of objects to be considered for the 
Ambient Occlusion calculation. This value defines white areas, where no occlusion takes 
place. This value can also be seen as the maximum expansion of the virtual hemisphere. 

• Clear All - Deletes the Ambient Occlusion calculation of the whole scene. 
• Clear Active - Deletes the Ambient Occlusion on selected geometry. All numeric values 

use millimeters as their units. 

IMPORTANT The total calculation time depends on the complexity of the scene and 
chosen Shadow Quality Preset. 



Indirect Illumination 

Enables an extra calculation of indirect light bounces, which increases the quality of the result. 

• Enable - Enables/disables the indirect illumination mode. 
• Quality - Sets the quality of indirection. The higher the values, the better the results. 
•  

o Preview Quality - 8×8 samples 
o Low Quality - 16×16 samples 
o Medium Quality - 24×24 samples 
o High Quality - 32×32 samples 
o Highest Quality - 48×48 samples 

 
• Indirections - The number of indirections defines the number of calculated light 

bounces. The default value is one, so only one light bounce is calculated. 

IMPORTANT Higher values induce better quality, but increase calculation time. 

• Enable Color Bleeding - Enables the transfer of color between near-by objects, caused 
by the colored reflection of the indirect illumination option. Color bleeding causes a 
white wall close to a red wall to appear pink because it receives red light from the red 
wall. 

• Override Material Color - Overrides the material color of the occlusion. 
• Color - Deletes the Indirect Illumination on the selected geometry. 
• Clear All - Deletes the Indirect Illumination calculation of the whole scene. 
• Clear Active - Deletes the Indirect Illumination on the selected geometry. 

Subdivision 

Subdivides the existing polygon mesh into smaller triangles to calculate the ambient occlusion 
more precisely. Turn this option on to avoid ragged edges on shadow illustrations. This feature 
is helpful when NURBS data for re-tessellation is not available, but a refined mesh is required. 
Subdividing generates more complex objects. Use it only when required. Subdivide Geometry 
(from the Scene Graph's Edit context menu) provides more settings to control this process. 

• Enable - Enables/disables the subdivision mode. 
• Quality - Causes geometries to be refined during the Ambient Occlusion calculation 

process, when the subdivision check box is checked. Extra vertices are inserted into the 
meshes. It is possible to get smoother results on the geometry. Three presets are 
available: 
 

o Low Quality - Subdivides up to two times, if the difference in intensities between 
the vertices of an edge is above the intensity threshold. 



o Medium Quality - Subdivides up to two times, if the difference in intensities 
between the vertices of an edge, or the edge midpoint of the triangle edge, is 
above the intensity threshold. 

o High Quality - Subdivides up to four times, if the difference in intensities 
between the vertices of an edge, or the edge midpoint, is above the intensity 
threshold. 
 

• Minimum edge length - Defines the threshold of the subdivision. If the length of an 
edge between two vertices is below the defined value, it is not subdivided, and no 
added vertices are added. 

• Intensity threshold - Sets the threshold of intensity values of two vertices, to force a 
subdivision of the triangle edge. 

CAUTION Enabling this feature increases calculation time and the polygon count of the 
scene. 

Calculate All 

Calculates the ambient occlusion for all visible and selected nodes and their child nodes. 

Calculate Missing 

Calculates the ambient occlusion for all missing visible and selected nodes and their child 
nodes. Use this to select all nodes without ambient occlusion automatically, instead of having 
to search for and select them one at a time. 

 



Variants 



Creating Variants 
Variants are key for product design reviews (PRDs). Core members from design, management, 
and engineering can get together to review a 3D product, such as their latest car. Using VRED 
variants/VSets, you can configure your car and its parts, so it is easy to switch through them 
during the review. 

Since a car can have many different versions, such as standard, sports, convertible, etc., as well 
as a variety of options, such as sports body pack, 100s of paint and interior material 
combinations, lights, etc., variants and VSets provide a straightforward way to step through 
these, in a packaged way. 

NOTE Go one step further and create an HTML5 frontplate that links this functionality and 
allows your participants to change things to see what they want. See Using Python in VRED for 
how to do this. 

How to Create a Variant 

1. In the Menu Bar, select Scene > Scene Graph to open the Scene Graph. 
2. Select Scene > Variants to open the Variants module. 
3. In the Variants module, click the tab corresponding to the type of variant you want to 

create: Geometry Variants, Material Variants, or Light Variants. 

NOTE This doesn't apply to Transform Variants and Sceneplate Variants, which will be 
discussed in other sections. 

4. Drag a node or switch node from the Scene Graph into the list view (left side) of the 
Variants module. The node name appears in the list view and its potential states and 
hotkey (if you create one) are displayed on the right. 

How to Set a Hotkey 

1. To set a hotkey for a variant, from the list view (left side) of the Variants module, select 
a node or switch node. 

2. In the section to the right, click the space to the right of the state to access its Hotkey 
drop-downs. 

3. After entering the hotkey values, tap the blank space below it to set the hotkey. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Using-Python-in-VRED


 

4. To enable a state, double-click the state. The currently enabled state is indicated by bold 
lettering; the default state is highlighted. 

NOTE To test your hotkey, click the Render Window, then use your hotkey. 

How to Create a Transform Variant 

Transform variants are used to add multiple transforms as variants to Scene Graph nodes. All 
nodes currently supporting transforms allow transform variants to be created (Groups, Lights, 
Shells, Surfaces, Meshes, and Lines). For example, a steering wheel can be set to varying 
positions. Instead of having a geometry variant for each position, you can now have one 
geometry with multiple transform variants. Using a transform variant reduces scene size, Scene 
Graph nodes, and memory usage. 

1. In the Menu Bar, click Edit > Preferences > Transform. 
2. Select the Scene Graph node to add transform variants. 
3. In the Quick Access Bar, select Transform to open the Transform module. 
4. Just below the title in the Transform module, select Window > Transform Variants. 

 



 

NOTE To always show Transform Variants in the Transform module, in Preferences > 
Transform > Transform Editor, set Transform Variant Settings to Transform Variant 
Window. 

5. In the Transform module, right-click the node and select Create or + in the Quick Icon 
Bar. The first variant is created from the current state of the geometry. 

 

6. Adjust the geometry with any of the tools in the Basic tab. For example, Translation and 
Rotation. Right-click on the node and create a second variant. 

7. Double-click a variant to display it in the Render Window. 

How to Create a Variant Set 

Use variant sets (VSets) to define multiple states for different properties at same time. In many 
cases, a variant alone is not enough for managing complex models. For example, many different 
switch nodes are needed to represent a specific version of the loaded model. Variant Sets 
provides more functionality for activating many states, simultaneously. For configurators, 
logical connections can be generated. 

1. In the Menu Bar, click Scene > Scene Graph to open the Scene Graph. 
2. In the Menu Bar, click Scene > Variant Sets to open the Variant Sets module. 
3. In the Variant Sets module, right-click in the left side and select New Set. 
4. Click the name of the new set to rename it. 
5. In the Variant Sets module, click the tab corresponding to the type variant you want to 

create: Geometry, Material, or Light. 



NOTE The other types of variants will be discussed in other sections. 

6. Drag a node or switch node from the Scene Graph under the appropriate tab of the 
Variant Sets module. 

The node name is added to the tab, with supported states listed in a drop-down box. 

7. To enable a state, select it from the drop-down box. 

Optional: Create a hotkey for the variant set in the General tab. 

In addition to hotkeys and the Variant Sets module, you can use VRED python scripting to 
switch between Variant Sets. Use the function selectVariantSet(name), where name is the 
name of the variant set. 

How to Show or Hide Geometry in Variant Sets 

Use this feature to show or hide Scene Graph nodes. This can be useful, for example, when 
using dissections in your scene. 

1. In the Variant Sets module, select a variant set. 
2. Go to the Show/Hide tab. You may need to repeatedly tap the last arrow to the right to 

access it. 
3. Drag nodes from the Scene Graph into the Show/Hide tab. 
4. Right-click in the list of variant sets. 
5. Select Show Geometry or Hide Geometry from the context menu. 



About Variants 
Scene > Variants 

Use the Variants module to set up variants to help with product design reviews (PRDs). 

Variants 

The Variants module has tabs along the top. Each tab has two sections. The left section lists 
variants and the right section displays the node name, state, and assigned hotkeys. This is 
where you can set hotkeys to quickly access your variants. Along the bottom is the Icon Bar. 

 

Are These All the Tabs 

Depending on the size of the window, not all tabs may be visible. To access other tabs, either 
expand the Variants module or click the arrows along the top. 

 



Geometry Variants (tab) 

Allows multiple geometries to exist in the same scene with only one shown at a time. 

Actions 

• !All - Shows all geometry in the variant list. 
• !Next - Shows the next geometry in the variant list. 
• !Next(Loop) - Shows the next geometry in the variant. When the end of the list is 

reached, the next selected is the first item in the list. 
• !None - Hides all geometry in the variant list. 
• !Previous - Shows the previous geometry in the variant list. 
• !Previous(Loop) - Shows the previous geometry in the variant. When the beginning of 

the list is reached, the next item selected is the last item in the list. 

Context Menu 

• Create All - Adds all Scene Graph-contained geometry switches to the list of geometry 
variants. 

• Rename (Ctrl + R) - Renames the selected geometry variant. 
• Delete (Del) - Deletes the selected geometry variant. 
• Clear - Deletes the entire variant list. 
• Show Geometry - Shows the geometry in the Render Window. 
• Hide Geometry - Hides the geometry in the Render Window. 
• Show Connected Variant Sets - Selects the variant sets that use this variant. 
• Select Switch Nodes - Selects the switch nodes in the Scene Graph. 
• Select Nodes (Ctrl + N) - Selects the nodes in the Scene Graph that apply to the selected 

geometry variant. 

Transform Variants (tab) 

Allows multiple orientations of the same geometries to exist in the same scene with only one 
shown at a time. 

Actions (Transform Variants) 

• !Next - Shows the next transformation in the variant list. 
• !Next(Loop) - Shows the next transformation in the variant. When the end of the list is 

reached, the next selected is the first item in the list. 
• !Previous - Shows the previous transformation in the variant list. 
• !Previous(Loop) - Shows the previous transformation in the variant. When the beginning 

of the list is reached, the next selected is the last item in the list. 
• Variant1 - Shows transformation in the first variant. Any additional variants in the 

transform are listed and displayed by double-clicking. 



Context Menu (Transform Variants) 

• Create All - Adds all Scene Graph-contained transformation switches to the list of 
transformation variants. 

• Rename (Ctrl + R) - Renames the selected transformation variant. 
• Delete (Del) - Deletes the selected transformation variant. 
• Clear - Clears the entire variant list. 
• Select Nodes (Ctrl + N) - Selects the nodes in the Scene Graph that apply to the selected 

transform variant. 
• Show Connected Variant Sets - Selects the variant sets that use this variant. 

Material Variants (tab) 

Allows objects to have multiple materials assigned. You can switch between the states quickly. 

Actions (Material Variants) 

• !Next - Shows the next geometry in the variant list. 
• !Next(Loop) - Shows the next geometry in the variant. When the end of the list is 

reached, the next selected becomes the first item in the list. 
• !Previous - Shows the previous geometry in the variant list. 
• Previous (loop) - Shows the previous geometry in the variant. When the beginning of 

the list is reached, the next selected becomes the last item in the list. 

Context Menu (Material Variants) 

• Create All - Adds all Scene Graph-contained material switches to the list of material 
variants. 

• Rename (Ctrl + R) - Renames the selected material variant. 
• Delete (Del) - Deletes the selected material variant. 
• Clear - Deletes the entire variant list. 
• Show Geometry - Shows the geometry in the Render Window. 
• Hide Geometry - Hides the geometry from the Render Window. 
• Show Connected Variant Sets - Selects the variant sets that use this variant. 

Light Variants (tab) 

Enables you to quickly change between multiple lighting scenes. 

Actions (Light Variants) 

• !Disable - Disables the lights in the variant. 
• !Enable - Enables the lights in the variant. 
• !Toggle - Switches the state from Enabled to Disabled. 



Context Menu (Light Variants) 

• Create All - Adds all Scene Graph-contained light switches to the list of light variants. 
• Rename (Ctrl + R) - Renames the selected light variant. 
• Delete (Del) - Deletes the selected light variant. 
• Clear - Deletes the entire variant list. 
• Show Connected Variant Sets - Selects the variant sets that use this variant. 

Sceneplate Variants (tab) 
Actions (Sceneplate Variants) 

• Create All - Automatically creates new variants of the current type. 
• Rename - Renames the node in the Scene Graph related to the selected variant. 
• Delete - Deletes the currently selected variant. 
• Clear - Clears the currently selected variant. 
• Show Connected Variant Sets - Selects the variant sets that use this variant. 

Context Menu (Sceneplate Variants) 

• Create All - Adds all Scene Graph-contained sceneplate switches to the list of sceneplate 
variants. 

• Rename (Ctrl + R) - Renames the selected sceneplate variant. 
• Delete (Del) - Deletes the selected sceneplate variant. 
• Clear - Deletes the entire variant list. 
• Show Connected Variant Sets - Selects the variant sets that use this variant. 

Icon Bar 

• Create - Automatically creates new variants of the current type. 
• Select Node - Selects the node in the Scene Graph related to the selected variant. 
• Delete - Deletes the currently selected variant. 



About Variant Sets 
Scene > Variant Sets 

Use the Variant Sets module to create and modify variant sets, as well as add hotkeys. 

Variant Sets 

The Variant Sets module has a section listing your variant sets on the left, tabs on the right, and 
an Icon Bar at the bottom. 

Variant Sets List 

Contains entries of already-defined variant sets and is found on the left. The context menu can 
be used to create new sets, as well as to perform other actions on its nodes. The tabs can be 
used to switch between the various types. Options are available for variant sets. 

Context Menu 

• New Set - Creates a variant set. 
• New Group - Creates groups to organize all variant sets that behave like folders. Variant 

sets can be dragged into any group or removed from a group by dragging it on its parent 
folder. It is not possible to recursively store folders within folders. 

• Close Groups - Collapses the list of groups in the Variant Sets dialog box. 
• Select - Selects and applies the current variant sets. 
• Select Defaults - Reverts to the previously applied variant sets. 
• Duplicate - Creates a copy of the selected variant sets. 
• Rename - Enables the renaming of the selected variant sets. 
• Delete - Deletes the selected variant sets. 
• Clear - Removes all Variant Sets and groups. 
• Optimize Sets - Optimizes and deletes all missing connections within the variant sets. 
• Remove Empty Sets - Removes all links (parts) of the variant sets not assigned to 

anything in the current scene. 
• Create Preview - Renders a preview and automatically assigns an icon to the selected 

variant set. 
• Show/Hide Geometry - Shows or hides nodes dragged from the Scene Graph into the 

Show/Hide tab. 
• Show Connected Variants - Selects the variants used in the variant set. 
• Dissection Mode - Creates screenshots only of specific parts of the loaded model. When 

entering the Dissection Mode, all geometry is disabled, making your screen empty, at 
first. Then, you can gradually enable the geometry, either using Show from the Scene 
Graph or some predefined Show/Hide-lists from the variant set module. 



When the desired geometry is visible, you can create a screenshot, using the 
corresponding button, either in the variant set module or VRED toolbar. When leaving 
the Dissection Mode, the previous state of all nodes and switches are restored in the 
context menu. 

• Verify All - Loads a csv file with embedded logics. 
• Verify Maya - Verifies imported Maya variants. 

Global States 

There is a collection of states, not user-defined. These are relatively self-explanatory. For 
example, the “!Next” state changes to the next state within that variant when the hotkey is 
pressed. Some states are not available in all contexts. 

• !All - Shows all objects in the switch list. (Only usable in combination with a Geometry 
Switch). 

• !None - Hides all objects in the switch list. (Only available in combination with a 
Geometry Switch). 

• !Next / !Next (Loop) - Activates the next object in the switch list and stops when the last 
object is reached. !Next (Loop) is similar to !Next, however, it returns to the beginning 
of the list after the last object is selected. 

• !Previous / !Previous (Loop) - Operates in the same principle as the !Next/!Next (Loop) 
options, just in reverse. 

• !Enable / !Disable / !Toggle - Enables or disables the variant set-contained lights in the 
scene. !Toggle switches the related variant to the opposite state. 

General (tab) 

Provides the location where hotkeys for variant sets can be defined. 

• Hotkey - Where hotkeys for switching between variant sets can be defined. The first box 
is for a modifier key, such as Alt or Ctrl, while the second is for selecting an 
alphanumeric character for the shortcut. The second field is required to assign the 
hotkey (for example, a letter or sign). 

• Comment - Adds a custom comment to each variant set. 
• Screenshot (Go button) - Creates a quick rendering of the Render Window, using the 

currently selected variant set and render settings. VRED asks for a location and format 
to save the image, which is an 800x600 bitmap image, by default. 

Geometry (tab) 

Creates or modifies the geometry variants. To create a geometry variant, drag a geometry node 
or group node to the right section in the Geometry tab. 



Transform (tab) 

Creates or modifies the transform variants. To add a transform variant to the variant set, drag a 
node with transform variants to the right section in the Transform tab. You can also drag a 
variant from the Transform dialog or from the Variants dialog to that section. 

Material (tab) 

Creates or modifies the material variants. To create a material variant, drag a material node to 
the right section in the Material tab. 

Light (tab) 

Creates or modifies the light variants. To create a light variant set, drag a light variant to the 
right section in the Light tab. Instructions for creating a light variant can be found in the Variant 
section. 

View (tab) 

Creates or modifies the Viewport variants. Viewport variants can be set within the View tab. 
Drag a previously created view into the Camera Editor to the right side of the View tab. 
Instructions for creating a Viewport can be found in the Camera Editor section. 

Sceneplate (tab) 

Creates or modifies the sceneplate (frontplates and backplates) variants. To create a new 
sceneplate variant set, a sceneplate can be dragged from the Sceneplate Editor to the right side 
of the Sceneplate tab. If this variant set is selected, the sceneplate will be set to active. If 
another variant set is activated, the new sceneplate will be set to active. It is possible to add 
multiple sceneplates to one variant set. It is also possible to add one sceneplate to multiple 
variant sets. 

Animation (tab) 

Creates or modifies the animation variants. To create an animation variant set, drag an 
animation from the Clip Maker (Clips icon) to the right side of the Animation tab. 

 

 

 



Analyzer (tab) 

Lets you enable, disable, or modify clipping planes within a variant set. 

• Clipping Plane - Contains the following options: 
 

o Enable / Disable Clipping - Enables or disables the clipping plane. 
o Only Clipping Values - Enables you to adopt value changes, but not its state 

(enabled/disabled). 
o Get Current Position - Adopts the position and orientation of the clipping plane 

selected within the Clipping module on feature execution. 
 

• Clipping Plane Position - Provides the coordinate position of the clipping plane. 
• Clipping Plane Normal - Affects the orientation of the clipping plane, in radians, about 

the X, Y, and Z axis. 
• Invert Direction - Toggles which side of the clipping plane is cut. 
• Hide scene - Hides the whole scene. Shows only the contours of the clipped objects on 

the clipping plane. 
• Show Clipping Plane - Toggles the visibility of the clipping plane. 
• Show Grid - Toggles the visibility of the clipping plane’s grid. 
• Show Contour - Toggles the outline of the objects cut by the clipping plane. 

Script (tab) 

For advanced users, each variant set can contain a Python script, executed automatically, each 
time the variant set is activated, whether through the Variant Set module, a hotkey, or another 
script. 

Values (tab) 

Add generic key/value pairs to any variant set, if the exported XML data should be processed 
personally (see Import and Export). The list of keys is on the left and values belonging to those 
keys are on the right. The currently selected key can be changed. Use the context menu to 
create or delete keys. VRED does not process this data in any way; it is only available in the 
exported Variants XML data. 

Show/Hide (tab) 

Shows or hides a list of Scene Graph nodes, based on whether Show Geometry or Hide 
Geometry was selected in the Variant Set context menu. This is especially useful for making 
screenshots of isolated parts of the model that belong to a specific variant set. Nodes can 
simply be added by dragging them from the Scene Graph into the list. They can be removed by 
using the context menu in the nodes list. Primarily, the Show/Hide tab is used in the Dissection 
Mode. 



Bottom Icon Bar 

There are shortcut icons at the bottom of the window for creating a new variant, duplicating 
the currently selected variant, and deleting the currently selected variant. 

 



Media 



About the Media Editor 
Scene > Media Editor 

The Media Editor can create multiple WebEngines inside VRED and for streaming interactive 
web content, loading local HTML5 files, and writing HTML5 content directly in the editor. 

What is a WebEngine 

A WebEngine is an element that adds an interactive website or html content to a VRED scene. 
The content streams into a material texture channel in real-time and uses the properties of the 
material for display. When working with the combination of HTML5 and Python scripts, this is 
the key to adding that functionality to a VRED scene. 

The Media Editor 

The Media Editor has a Search field along the top, List View to the left, WebEngine properties to 
the right, and an Icon Bar along the bottom. 

 

Search Filed 

Helps to find WebEngines by name. 

WebEngine List View 

Lists all WebEngines and is found on the left side of the Media Editor. Select a WebEngine from 
the list to load its editable parameters into the right. Multiple WebEngines can be selected in 



the list view, using Ctrl-left mouse. To select a range of WebEngines, use Shift-left mouse. All 
items between the current item and the clicked item are selected or unselected. 

WebEngine 

Contains editable parameters for the selected WebEngine in the list view. 

• Name - Displays the WebEngine name. 
• Width - Defines the width of the interactive content. 
• Height - Defines the height of the interactive content. 
• Url - Displays the entered URL. 

•  Browse - Loads local HTML file. 

•  HTML Editor - Enter and edit HTML5 code. 

•  Reload - Reloads the URL. 

•  Delete - Deletes the URL. 
• Material - Lets you add the material from the object being used. 
• Texture - Defines which texture channel of the material is used for the image created by 

the WebEngine. Select Diffuse, Incandescence, or Diffuse + Incandescence. Diffuse 
reflects the environment and has an alpha channel. Incandescence does not reflect the 
environment, but does emit light in raytracing, when Use as Light Source is activated. 
Diffuse + Incandescence creates an incandescence material, using the Diffuse Texture 
Alpha Channel to mask the background of an HTML5 page, for example. 

• Click Through - Sets the alpha click-through threshold. If the alpha value in HTML under 
the mouse is smaller than this threshold, it clicks through and navigates the scene. 

Icon Bar 

The Icon Bar contains visual shortcuts for commonly used Media Editor commands. 

• Create - Creates a WebEngine to display interactive content in a VRED scene. 
• Duplicate - Duplicates the currently selected WebEngine. 
• Select Nodes - Selects all geometry nodes within the currently selected WebEngine. 
• Delete - Deletes the selected WebEngine. 
• Render - Sets the global switch for enabling or disabling the rendering of WebEngines. 

 



Adding Interactive Website or HTML Content to a 
Scene 
Create a WebEngine to add an interactive website or HTML content to a VRED scene. The 
content streams into a material texture channel in real-time and uses the properties of the 
material for display. 

How to Create a WebEngine 

1. In the Menu Bar, select Scene > Media Editor to open the Media Editor. 
2. Select the + icon in the bottom Icon Bar, then WebEngine to create a WebEngine. 
3. Double-click the WebEngine and name it. 
4. Set the Width and Height: 

 
o If using HTML content in the URL, enter the known width and height from the 

code. 
o If using a website in the URL, adjust the width and height when the website is 

displayed on an object. 
 

5. Add a URL for the content: 
 

o To add a website, enter it in the URL field (for example, www.Autodesk.com). 
o To add a local HTML file, use the Browse icon. HTML can contain audio and 

video. The HTML file can refer to audio and video files that are embedded. 
Supported media formats are WebM (.webm), OGG (.ogg/.ogv), and WAV (.wav). 
 

6. From the Material Editor, drag the assigned material for the WebEngine onto the 
Material field. 

7. Set the texture type: 
 

o Diffuse: 

The environment is reflected in this texture. 

1. In the Material Editor Properties, under Material, set the Diffuse Color to 
white. 

2. In the Material Editor Properties, under Diffuse Texture, check Use 
Texture, then set Mapping Type to UV. Rotate the Diffuse Texture as 
needed. 
 

 

http://www.autodesk.com)/


o Incandescence: 

In raytracing, the material emits light into the scene when Use as Light Source is 
activated. 

1. In the Material Editor Properties, under Material, set the Diffuse Color to 
black. 

2. In the Material Editor Properties, under Incandescence, set Intensity to 
1.00 and the color to white. 

3. Set Mapping Type to UV. Rotate the Incandescence Texture as needed. 
 

o Diffuse + Incandescence: 

This texture is used when the properties of incandescence and an alpha channel, 
that is only available in Diffuse, are needed. 

This HTML example code sets the background of a webpage transparent (alpha): 

<style> 
body{ 
background-color: rgba(0, 0, 0, 0); 
} 
</style> 

1. In the Material Editor Properties, under Material, set the Diffuse Color to 
white. 

2. In the Material Editor Properties, under Diffuse Texture, check Use Alpha. 
3. In the Material Editor Properties, under Incandescence, set Intensity to 

1.00 and the color to white. 
4. In either Diffuse Texture or Incandescence, set Mapping Type to UV. 

Rotate the Texture as needed. 

VRED to HTML5 Communication 

There is a two-way communication and interaction between VRED and HTML5. Here is an 
example of VRED to HTML5. 

Executing the Variant Set (Home\_Button) with an associated Python function 
(sendToWebEngine), triggers a specific WebEngine (Webengine\_A) and sends an HTML event 
(VRED\_HOME\_Btn) to the web page. The web page must have an Event Listener to receive 
the message. 

 

 



The following is an example of HTML code to receive a message: 

<script> 
document.addEventListener("VRED\_HOME\_Btn", Icon_HomeClick); 
</script> 
 

 

HTML5 to VRED Communication 

An img element and a URL can be used to send Python commands from the webpage to VRED, 
using the webserver. For example, src = "http://localhost:8888?..... The webserver 
must be enabled in the preferences.  

The HTML code for setting the Switch Material to 0:  

<script>  

function r(){  

var i = document.createElement("img");  

i.src = 
"http://localhost:8888/python?value=setSwitchMaterialChoice('SwitchColo
r', 0)";  

};  

</script>  

The HTML code for triggering a VariantSet named Icon_Anim:  

<script>  

Icon_Click = function(event) {  

var i = document.createElement("img");  



i.src = 
"http://localhost:8888/variants?value=selectVariantSet('Icon_Anim')";  

};  

</script>  



Assets 



Working with the Asset Manager 
Scene > Asset Manager 

Use the Asset Manager to manage items like scenes, environments, and materials across 
multiple projects. Each tab contains the assets and location of those assets for that category. 
Global assets stored anywhere in the network can be accessed as from a local folder. This 
supports standardization throughout several projects or even across multiple departments 
within the company. 

 

Use the Asset Manager section in Preferences to set up asset paths either for complete assets 
or for scenes, materials, and environments, individually. 

For more details, see Asset Manager Module - Simple UI. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Simple_UI_Asset_Manager_Module_Simple_UI_html


UVs 



Editing UVs 
NOTE  Please pay attention to the following: 

• The UV Editor works only with NURBs data tessellated in VRED. Any other mesh or 
previously tessellated data will not work. 

• If the geometry is re-tessellated, its UV coordinates are not preserved, and changes to 
the UVs need to be redone. 

• Ensure your materials have a Mapping Type set to UV. To check, in the Material Editor, 
select the material, then in the Diffuse Texture section, check Mapping Type. If set to 
Planar or Triplanar, you will not see the result on the geometry. 

How to Display UVs in the UV Editor 

1. In the Menu Bar, select Scene > UV Editor. 

2. In the UV Editor, under Selection Mode, choose  (Select Objects). 

In Select Objects mode, only nodes in the scene can be selected in the Scene Graph and 
nothing can be selected in the UV Editor view. 

3. In the Scene Graph, select geometry nodes. The UVs for the selected nodes are 
displayed in the UV Editor. 

Alternatively, select the nodes in the Scene Graph, then select Scene > UV Editor to open the 
UV Editor with the UVs for the selected nodes displayed. 

How to Navigate the View in the UV Editor 

• To pan, hold down the middle mouse button and drag. 
• To zoom, hold down the right mouse button and drag. 
• To refocus the view, press the F key on your keyboard. 

 
o If no island/edge/vertex is selected, the view zooms to display all UV coordinates 

of the selected geometries. 
o If some islands/edges/vertices are selected, the view focuses only on the UV 

coordinates of the selection. 

How to Select Islands of Selected Geometry Nodes 

1. In the UV Editor, Shift+middle-click in the view, then choose Islands from the context 
menu to set the Selection Mode. 



TIP Another way to do this is to click  (the Islands icon). 

(A UV island is a sub-part of the mesh where every vertex is directly or indirectly 
connected to every other vertex in the same island.) 

2. Use the standard VRED object selection methods to select components Selecting 
Objects in the Viewport. 

TIP To select only those components on the front-most surfaces, or alternatively, to 
select all components in the selection frame, whether they are behind another surface 
or not, in the Menu Bar, toggle Edit > Selection > Use Depth Selection either on or off. 

When you select an island, its corresponding sub-mesh is highlighted white in the UV 
Editor. 

The UV islands are drawn in the Render Window, if  (Wireframe) is enabled in the 
Icon Bar. This adds a wireframe overlay over the solid shading of the selected nodes. 
When combined with the UV Editor, the selected islands are highlighted white, while 
the rest of the wireframe is orange. 

 

To see the borders, in the UV Editor, under Visualize, select Show Borders. 

 

http://help-staging.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VRED_Basics_Selecting_Objects_in_the_html
http://help-staging.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VRED_Basics_Selecting_Objects_in_the_html


How to Select Edges of Selected Geometry Nodes 

1. In the UV Editor, Shift+middle-click the view and choose Select Edges as the Selection 
Mode. 

TIP Another way to activate edge selection is to select  from Selection Mode. 

2. Use the standard VRED object selection methods to select the components Selecting 
Objects in the Viewport. 

TIP To select only those components on the front-most surfaces, or alternatively to 
select all components in the selection frame, whether they are behind another surface 
or not, in the Menu Bar, toggle Edit > Selection > Use Depth Selection either on or off. 

In the UV Editor, hold the Shift or Shift+Ctrl keys and hover the cursor over an edge to 
highlight it. The edge highlights red, if that edge has not been selected, and yellow, if it 
has. 

 

Selected edges are highlighted green in the UV Editor. 

The UV edges are drawn in the Render Window, if   (Wireframe) is enabled in the 
Icon Bar. 

 

http://help-staging.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VRED_Basics_Selecting_Objects_in_the_html
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To select a chain of edges: 

1. In the UV Editor, under Selection Mode, click Start Picking. 
2. Define the edge selection path by picking at least two points. 

 

3. When point picking is finished, click End Picking. 

The shortest path connecting each way point, in the order it was picked, is 
selected and added to the current edge selection. 

 

If any way point is located on a different UV island, a path that connects all way 
points cannot be constructed. 

 



 

Adding a way point on the border between two islands may guide the path to go 
across the border. 

 

 

NOTE If there is any physical gap between two islands, it is impossible for a path 
to go across it. 

TIP Turn on Show Border when constructing a path. 

How to Select Vertices of Selected Geometry Nodes 

1. In the UV Editor, Shift+middle-click on the view and choose Select Vertices as the 
Selection Mode. 

TIP Another way to activate vertices selection is to select  from Selection Mode. 



2. Use the standard VRED object selection methods to select the components Selecting 
Objects in the Viewport. 

TIP To select only those components on the front-most surfaces, or alternatively to 
select all components in the selection frame, whether they are behind another surface 
or not, in the Menu Bar, toggle Edit > Selection > Use Depth Selection either on or off. 

In Selection Mode, check Show All Vertices to display all vertices in magenta in the UV 
Editor. 

The vertices are drawn in the Render Window, if   (Wireframe) is enabled in the Icon 
Bar. 

Hold the Shift or Shift+Ctrl keys and hover the cursor over a vertex to highlight it. The 
vertex highlights red, if it has not been selected, or yellow, if it has. 

Selected vertices are highlighted green. 

 

How to Cut and Sew Edges of a UV Mesh 

Cut Edges 

Cuts are important to the unfolding process. They allow the UV textures to unfold with as little 
distortion as possible. When unfolded, the UV mesh should lay flat without overlapping. 

1. In the UV Editor, select (Select Edges) and select two or more edges. 

TIP To highlight the borders, in the Visualize section, check Show Borders. 

2. In the Selection Mode section, click Cut Edges. 

The mesh is cut along the selected edges. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VRED_Basics_Selecting_Objects_in_the_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VRED_Basics_Selecting_Objects_in_the_html


 

The edges become new borders after the cut. 

 

NOTE Cutting border edges has no effect. 

Sew Edges 

There are two ways to sew edges: sew along borders or sew neighboring islands. 

How to Sew Along Borders 

1. In the UV Editor, select  (Select Edges) and select two or more border edges to sew 
together. 

TIP Check Only Select Borders when selecting borders using rectangle selection. 

 



2. In the Selection Mode section, click Sew Edges. 

If sewing is successful, a border edge becomes a normal edge. 

The UV coordinates of vertices on both sides of a border are averaged and used as the 
new coordinates for the sewn vertices. 

 

How to Sew Neighboring Islands 

This method has the same effect as selecting corresponding border edges and sewing them 
using Sew Edges. However, this method may be more efficient, in some cases. 

1. In the UV Editor, click (the Islands icon) and select one or more islands to sew 
together. 

 

2. In the Selection Mode section, click Sew Islands. 

VRED attempts to sew neighboring islands together. 



 

If the island has an internal border, which means the other side of the border belongs to 
the same island, it is also sewn. This may not be the desired behavior and can be 
changed by selecting the option Only Borders Between Islands, next to Sew Islands. 
When this option is selected, only borders between different islands can be sewn. 

 

NOTE  Please note the following: 

• Sewing along non-border edges has no effect. 
• To sew the border, the physical locations, normal vectors, and other per-vertex 

attributes of vertices on both sides of a border must be the same. For example, a 
physical gap cannot be sewn by the Sew tools. 

• Only islands belonging to the same triangle mesh or shell can be sewn together. 

How to Unfold a UV Mesh 

UV coordinates can be created by unfolding a surface in 3D space onto a 2D plane. Each UV 
island is an isolated and detachable piece, so it is the basic unit to perform unfolding. 

The quality of unfolding depends on how easily each island can unwrap onto a plane. A 
relatively planar surface is usually easy to unfold and produces a good result. On the other 
hand, a surface wrapped with a lot of tension is tricky to unfold and usually incurs a lot of 
distortion. Experience and effort may be needed to cut and sew the surfaces before unfolding 
to achieve a satisfactory result. 



How to Unfold All Geometries 

1. Select the geometries to unfold. 

 

2. In the UV Editor, under Unfold, click Unfold All. 

VRED attempts to pack the UV islands belonging to the same geometry into the unit UV 
space after unfolding. 

 

How to Unfold Selected Islands 

1. In the UV Editor, choose  (the Islands icon) and select one or more islands to unfold. 

 



2. In the Selection Mode section, click Unfold Islands. 

The new UV coordinates for the selected islands are scaled roughly as large as before 
unfolding and placed in their original position. 

 

The Iterations field in the Unfold section provides the maximum computation allowed to 
perform the unfolding. It affects both Unfold All and Unfold Islands. The time spent on 
unfolding may be reduced by having less iterations, but the result may be worse. 

How to Manipulate UVs 

Use the options in the Manipulate section of the UV Editor to manipulate coordinates of 
selected islands/edges/vertices. 

How to Flip UVs in U or V Direction 

To flip the UV coordinates of selected islands/edges/vertices in either the U or V direction, 
under Manipulate, click Flip in U Direction or Flip in V Direction. 



How to Translate UVs 

To translate the UV coordinates of selected 
islands/edges/vertices: 

1. Hold the Shift+W keys to toggle the display 
of the Translation manipulator. The 
manipulator displays at the centroid position 
of the selection. 
2. Continue to hold the Shift key and hover 
over the manipulator to select one or both 
translation axes and highlight the 
corresponding arrow in yellow. 
3. Still holding the Shift key, drag to translate 
the selection. 

How to Rotate UVs 

To rotate the UV coordinates of selected islands/edges/vertices: 

1. Hold the Shift+E keys to toggle the display of the rotation manipulator. The manipulator 
displays at the rotation pivot position of the selection. 

2. Continue to hold the Shift key and hover over the manipulator to select the rotation tool 
and highlight the manipulator in yellow. 

3. Still holding the Shift key, drag to rotate the selection. 

 

4. To move the position of the rotation pivot, hold the Shift+Q key to display a manipulator 
with two blue arrows. Drag to reposition the pivot. 



 

How to Scale UVs 

To scale the UV coordinates of selected islands/edges/vertices: 

1. Hold the Shift+R keys to toggle the display of the scaling manipulator. The manipulator 
displays at the scale pivot position of the selection. 

2. Continue to hold the Shift key and hover over the manipulator to select a scaling axis 
and highlight it in yellow, if the cursor is near that axis, or select both axes, if the cursor 
is near the square at the top right. 

3. Still holding the Shift key, drag to scale the selection. 

 

4. To move the position of the scale pivot, hold the Shift+Q key to display a manipulator 
with two pale yellow arrows. Drag these arrows to reposition the pivot. 



 

How to Modify Multiple UVs at Once Using Lattice Deformation 

Modify the layout of multiple UVs at once, using a 2D lattice deformer. 

How to Create a Lattice 

• Select the islands/edges/vertices you want to manipulate, and in the UV Editor, under 
Manipulate, select Use UV Lattice. A lattice that is large enough to cover all the selected 
vertices is created. 

or 

• To start a new lattice, hold the Shift key and drag a rectangle in the UV Editor. 

 

To toggle the automatic fitting of the rectangle you dragged to the bounding rectangle 
of the selected vertices, select Use Bounding Rectangle. 



 

Left: Off, Right: On 

Circles represent the control points of the lattice. They are distributed evenly in rows and 
columns. You can select control points and the lines connecting them. Select and deselect them 
the same way you select islands/edges/vertices. 

Selected control points are yellow. If the two points that connect a line are both selected, then 
that line is also yellow. 

 

How to Deform UV Coordinates 

Select lattice control points and drag. 

 



Columns and Rows specify how many control points each row and column of the lattice has. 
The more columns and rows there are, the more local the influence of moving a control point. 

 

• Falloff 1.0 - Falloff specifies how much influence the deformation should bring to the 
original UV coordinates. It is a value between 0.0 and 1.0. If 1.0 is used, UV coordinates 
are fully influenced by the deformation. If 0.0 is used, UV coordinates are not affected 
by the deformation at all. 1.0 was used in the previous example and 0.0 is used in the 
following example. 

 

• Falloff 0.0 

Best Practices 

If a complex surface geometry comes in as a normal triangle mesh, which is one large piece, UV 
islands need to be created, by cutting the surface, so each can be unfolded. If the unfolding 
result looks strange or unbalanced, more cuts are likely needed in the surface. 

A shell node, which may contain a number of NURBS components, is considered as one 
geometry node and the UV coordinates of neighbor NURBS surfaces may be sewn together. If 
each NURBS surface is small and relatively planar, sewing UV islands of NURBS surfaces to form 
larger islands and then unfolding may be a more efficient way to work. 



Sometimes the triangle mesh is completely split. This can be detected by enabling border 
visualization. Every edge will be drawn blue. If unfolding is done on such geometry, a result like 
this will be returned. 

 

 



About the UV Editor 
Learn about the UV Editor 

Scene > UV Editor 

The UV Editor works only with NURBs data tessellated in VRED. If the geometry is re-
tessellated, its UV coordinates are not preserved, and changes to the UVs will need to be 
redone. 

When applying a material with a structured pattern to a surface, there can be a blend zone 
where the front and top projections overlap. Fix this using UV mapping in VRED, since NURBS 
surfaces brought over from other applications tend to have no UV mapping. 

Use the UV Editor to stretch out each patch to fit the coordinates. Unfold to break it into 
individual surfaces. This makes each surface an island. By sewing these islands together, the 
seams between them are welding together. When the sewn islands are unfolded, the issue with 
the blend zones is corrected. 

Use other options to move the texture around to line up the seam of a texture. Scale and rotate 
the texture, so it fits the surface better. 

How this all comes together is when you return to the Material Editor. When the same 
geometry is selected, under Diffuse Texture, change the Mapping Type to UV. 



The UV Editor 

The UV Editor displays the UVs of 
selected geometry to the left and 
assorted options to the right. 

 

 

 

 

 

 

 

 

Selection Mode 

• Select Objects - Nodes in the scene can be selected in the Render Window. Nothing can 
be selected in the UV Editor view. 

• Select Islands - UV islands of selected geometry nodes can be selected. If an island is 
selected, its corresponding sub-mesh is highlighted white. 
 

o Only Borders between Islands - Only attempts to join borders between different 
islands (does not attempt to join internal borders). 

o Sew Islands - Attempts to join neighboring islands. 
o Unfold Islands - Unfolds selected islands. The new UV coordinates for the 

selected islands are scaled to be approximately as large as the originals and 
placed in the original locations. 
 

• Select Edges - Edges of selected geometry nodes can be selected. Holding the Shift or 
Shift+Ctrl keys and hovering the cursor over an unselected edge highlights it red, over a 
selected edge, highlights it yellow. Selected edges are green. 
 

o Only Select Borders - Filters the non-border edges from the new edge selection. 
o Cut Edges - Cuts the mesh along the selected edges. 
o Sew Edges - Joins two borders together, making the border edges a normal edge. 



o Start/End Picking - For selecting a path of edges, click Start Picking, then select 
at least two points. When picking is complete, click End Picking to pick the 
shortest path connecting each way point in the order it was picked and add it to 
the current edge selection. 
 

• Select Vertices - Vertices of selected geometry nodes can be selected. 
 

o Show All Vertices - All vertices display in magenta. 

Unfold 

• Unfold All - Unfolds all currently selected geometry. After unfolding, it attempts to fit all 
the UV islands belonging to the same geometry into the UV unit space. 

• Iterations - The number of times the unfold calculations are performed. The time spent 
may be reduced with fewer iterations, but the unfolding result may be worse. The 
higher the value, the more relaxed or smooth the unwrapping becomes. 

Manipulate 

• Apply World Scale - Scales the UV coordinates according to the average triangle area in 
scene units. To achieve real world scaling of textures, select Apply World Scale. Real 
world scaling means to display a texture on an object where UV islands correspond to 
the size of the object parts in the scene in such a way that the texture appears with a 
specified width and height on the object in the scene, such as 200 mm x 100 mm. 

• Flip in U Direction - Flips the UV coordinates of selected vertices/edges/islands in the U 
direction. 

• Flip in V Direction - Flips the UV coordinates of selected vertices/edges/islands in the V 
direction. 

• Use UV Lattice - Enables the 2D UV lattice deformer for modifying the layout of multiple 
UVs, all at once. 

• Columns/Rows - The number of columns/rows of the current lattice manipulator. 
• Falloff - The lattice manipulator's level of influence or falloff value. 
• Use Bounding Rectangle - When selected, the current lattice manipulator cannot 

extend past the outer edge or boundary of the target geometry. 

Visualize 

• Show Grid - Displays the grid in the UV Editor view. 
• Show Texture - Displays any textures used by the materials of the selected nodes. 

 
o If there is one texture, it is scaled to fit into the unit UV space. 
o If there are multiple textures used by the materials, only one of them displays in 

the UV Editor. 



• Show Checkerboard - Overwrites the existing object material with Checkerboard in the 
Render Window and UV Editor. You can input values for the height and width of the 
checker pattern. The colors and detail of the Checkerboard make it easier to identify 
distortions, map direction, check details, and display repeats. Select Show Texture to 
return to the original material. 

• Show Manipulator - Displays the selected manipulator - Translate, Rotate, Scale, Rotate 
Pivot, Scale Pivot. 

If no island/edge/vertex is selected, the manipulator does not display, even if this option 
is selected. 

• Show Borders - Displays borders on UV islands. 



Optimize 



About Optimize 
Scene > Optimize 

Opens the module that provides further operations, such as geometrical optimizations, sharing, 
and so on. Its default activates a recommended selection that could increase render 
performance, clear deselects all selected modules, and optimize executes selected optimization 
commands. All operations are applied recursively. Multi-selection is supported on execution. 
Undo for these types of actions is not available. 

The Optimize Module 

The Optimize module contains an assortment of options, grouped into five categories, 
Reduction, Filter, Flush/Unflush, Share, and Optimizations. 

 

Reduction 

• 16-bit Lengths, 16-bit Indices - Changes the lengths and indices of a geometry to a 16-
bit data type. 

Filter 

• Remove Point - Deletes all point objects within the selection. 
• Remove Lines - Deletes all line objects within the selection. 



• Remove LODs (Keep Best Quality) - Deletes all LODs nodes within the selection. Child 
instances with the highest mesh resolution are kept and replace the LOD nodes. 

• Remove LODs (Keep Lowest Quality) - Deletes all LODs nodes within selection. Child 
instances with lowest number of polygons are kept and replace the LOD nodes. 

• Remove Switches - Removes all switch nodes within the selection. The last child 
instance is kept and replaces the switch node. 

• Remove Vertex Normals - Deletes all existing vertex normals from the selection. 
• Remove Vertex Color #1 and #2 - When imported objects contain two different RGB 

values for each vertex point (edge point of polygons), these two values are known as the 
vertex color. This feature removes the existing vertex color information from the shape 
nodes. 

• Remove Texture Coordinates #1 - #7 - Deletes existing texture coordinates from the 
related channel. The first channel is without a number and is used for UV texture 
mapping in VRED materials. There are 5 additional channels (#1, #2, #3, #4 and #6), 
which can be used for other purposes, such as custom shaders. Channel #5 is for baked 
direct illumination. Channel #7 is for baked indirect illumination and baked ambient 
occlusion. 

• Remove Material Group Nodes with No Children - Deletes all unassigned materials 
within the Materials module. 

• Remove Empty Group Nodes - Deletes group nodes that contain no child nodes. 
• Remove Empty Geometry Nodes - Incorrect usage on external geometry editors could 

generate shape nodes that contain no polygons. These types of shape nodes imported 
to VRED could decrease runtime stability. This feature deletes such shape nodes. 

• Remove Empty Shell Nodes - Automatically removes empty shell nodes in a scene. 
• Remove Identity Transforms - Deletes identity transform nodes within the selection. 
• Remove Transform Variants - Deletes all transform variants within the selection. If not 

enabled, when also flushing transformations, nodes with a transform variant will be 
omitted from flushing. 

• Remove Invalid Texture Coordinates - Imported objects could contain invalid texture 
coordinates. This feature helps to delete that type of information. 

• Remove Degenerated Polygons - Removes shape nodes that cannot be drawn from the 
render engine. 

• Remove Animations - Deletes existing animation from selection. 
• Remove FileInfo - Removes the information from a file. 
• Remove B-Side Nodes - B-Side nodes are comparable to the No Show feature in CAD 

software. Execution removes shapes and components set as B-Side. 

Flush/Unflush 

Object transformation could be realized in two different ways within the Scene Graph. Either 
the transformation is stored within the object itself (flushed) or the related information is 
stored within group nodes on a higher hierarchy level above (unflushed). Nodes that contain 

transformations have a symbol of an axis in front of their icon . Several transformations on 



distinct levels are accumulated. Nodes containing transform variants and their parent nodes 
will remain unaffected by the Flush Transformation functions. To flush these nodes, enable 
Filter - Remove Transform Variants. 

• Flush Transformation Nodes (Adjust Face Normals) - Moves transform information 
from transform nodes to the geometry nodes on the lowest level. Face normals are 
recalculated upon execution. 

• Flush Transformation Translation - Moves the translation-related transform 
information of the selected sub-tree to the geometry nodes on the lowest level. 

• Flush Transformation Rotation - Moves the rotation-related transform information of 
the selected sub-tree to the geometry nodes on the lowest level. 

• Flush Transformation Scales - Moves the scale-related transform information of the 
selected sub-tree to the geometry nodes on the lowest level. 

• Flush Selected Transformations - Flushes transform information from selected node. 
• Flush Transformation Nodes -Moves the transform information of the selected sub-tree 

to the geometry nodes on the lowest level. 
• Flush Material Group Nodes - Material assignment in VRED can be done by assignment 

to the object itself or to a material group node on a higher hierarchy level. Execution 
moves unflushed material definitions from the material group node of the object. 

• Unflush Material Group Nodes - Creates a material group node above each geometrical 
node within the selection and moves the material definition there. 

• Flush Texgens - Converts TexGenChunk information to texture coordinates within the 
object on the level below. 

• Flush Textransformations - Converts TextureTransformChunk information to texture 
coordinates within the object on the level below. 

Share 

Sharing improves OpenGL render and raytracing performance because required objects are not 
present several times within the system memory. Shared instances are indicated by an 
underlined node description inside the scene tree. Any change on a shared object affects the 
cloned instance and vice versa. 

• Geometries - Looks for identical objects (identical polygon meshes) within the selection 
and references all occurrences. 

• GeometryProperties - References all occurrences of duplicated geometry properties. 
• Materials - References all occurrences of duplicated materials. 
• Textures - References all occurrences of duplicated textures. 
• BlendChunks - References all occurrences of duplicated Blend Chunks. 

Optimization 

• Triangulate - Converts all types of polygon meshes into triangles. Faces with four and 
more edges are split into the appropriate number of triangles. 



• TriangulateReIndex - Indices of vertices must be defined in a counterclockwise order 
upon creation. Following this rule increases runtime stability and render performance. 
This option converts all types of polygon meshes into triangles and applies the 
regeneration of all vertex indices. 

• Octree - This type of tree structure provides constant branches within the scene tree. 
Every node contains either eight nodes or none. Execution restructures the scene tree in 
that way. 

• Merge Materials - Merges identical materials into one. 
• Merge Geometry Nodes - Merges geometrical nodes into one contiguous object. 

Regarding objects are unshared, identical material are assigned, and all objects that 
should be combined are located within same group node. 

• Cleanup Group Nodes - CAD-generated data can contain deep branches on their created 
trees. A group node can contain a group node that contains a group node, and so on. At 
the end, there is one shape node in a nested arrangement of group nodes. This option 
automatically deletes these types of nested groups without removing the shape nodes 
itself. Group nodes that contain two or less shapes are considered upon execution. 

• Unify Vertices - Every triangulated polygon has three vertices; one at every edge. 
Polygons located directly beside one another should share as many vertices as possible 
to increase render performance. This option looks for identical, but not shared vertices, 
and combines them. 

• Optimize Indices - Tries to improve vertex cache efficiency by reordering triangle 
indices. 

• Sort Indices - Sorts indices from selection. 



Scene Graph 



Working with the Scene Graph 
The Scene Graph shows all the nodes of a scene, organized in a tree structure. Imported files 
are highlighted in green. The root node is at the top of the structure and is a parent to all other 
nodes in the scene. The root node is a group node and cannot be deleted, renamed, or 
otherwise edited.  

 

How to Display the Scene Graph 

There are two ways to display the Scene Graph:  

• From the Menu Bar, click Scene > Scene Graph.  

• In the Quick Access Bar, click Graph .  

How to Dock and Undock the Scene Graph 

In the Scene Graph, click the docking icon  in the top right to dock and undock it.  

 

How to Rename a Node 

In the Scene Graph, click the node and enter a new name.  



 

How to Move a Node 

In the Scene Graph, drag a node to a new location.  

How to Open a Node in the Viewport 

1. Drag a node from the Scene Graph into the Viewport to see the node and its respective 
objects.  

2. To restore the whole scene, drag the Root node into the Viewport.  

How to Find All Parent Nodes 

When you select a node in the Scene Graph, all its parent nodes turn light blue.  

 



How to Display Scene Graph in Split View 

The dotted line at the bottom of the Scene Graph is a splitting tool. Drag it to show a second 
view of the Scene Graph. You can drag and drop items between views. Use its drop-down menu 
to change one view to Scene Tags.  

 

How to Search the Scene Graph 

Use the Search box at the top of the Scene Graph to find nodes. Regular expressions are 
supported.  

 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=GUID-325FB521-33A8-4A0E-8ED5-223867C1778E


How to Access Other Scene Graph Functions 

Do either of the following:  

• Use the toolbar at the bottom of the Scene Graph for quick asset to other functions, 
such as creating, copying, and grouping items.  

 

• Use the Scene Graph Menu Bar to edit and create items, and to work with the Scene 
Graph view.  

 

How to Create a Node 

In the toolbar at the bottom of the Scene Graph, click to create a node. Generally, the 
node will be inserted below the currently selected node. Choose from the following options: 

• Create Geometry - Creates lines, planes, boxes, cylinders, cones, spheres, tori, and 
domes. 

• Create Light - Creates directional, point, spot, spherical, disk, rectangular, and ray lights. 
• Create Camera - Creates cameras, cameras and aims, cameras with aims and ups, and 

orthographic cameras. 
• Group - Creates a Group node in the tree below where your cursor was. Try the 

keyboard shortcut Ctrl+G. 
• Shell - Creates a Shell node. 
• Matrix Transform - Creates a Matrix Transform node. 
• MaterialGroup - Creates a MaterialGroup node. 
• Environment - Creates a Environment node. 
• Switch - Creates a Switch node. 
• StereoSwitch - Creates a StereoSwitch node. 
• HostSwitch - Creates a HostSwitch node. 
• Billboard - Creates a Billboard node. 
• ClipPlane - Creates a ClipPlane node. 
• DistanceLOD - Creates a DistanceLOD node. 
• Sound - Creates a Sound node. 
• SoundObstructor - Creates a SoundObstructor node. 
• Custom... - Creates a custom node. Select the type from the Create custom node dialog 

that appears. 



How to Duplicate a Node 

In the toolbar at the bottom of the Scene Graph, with one or more nodes selected, click  to 
duplicate a node or nodes. Generally, the node will be inserted somewhere below the currently 
selected node. 

How to Group a Selection of Nodes 

In the toolbar at the bottom of the Scene Graph, with nodes selected, click to create a group 
and add the selected nodes to it. 

How to Copy Transformations 

In the toolbar at the bottom of the Scene Graph, with a node selected, click  to copy all 
transformation information from the selected node to the clipboard. A transformation contains 
information on the position and orientation of an object within 3D space. It also provides 

information on the position and orientation of the object's coordination system. Use  Paste 
Transformation, then select an option, to apply the copied transformation information to 
something. 

How to Paste Transformations 

In the toolbar at the bottom of the Scene Graph, with one or more nodes selected, click  to 
paste copied transformation information onto the selected node or nodes. All transformation 
information, that is, translation, rotation, scale, and pivot are pasted. If you want to select one 
attribute to paste, used Edit > Paste Transformation to access paste options for 
transformations. Paste the pivot to apply the location and orientation from the object's local 
coordinate system. 

How to Delete a Node 

In the toolbar at the bottom of the Scene Graph, with one or more nodes selected, click to 
delete the selected node or nodes. 

About the Scene Graph Context Menu 

Right-click within the Tree View to access the following options: 

• Create - Provides a list of things to create, such as assorted types of geometry, lights, 
cameras, as well as groups, shells, matrix transforms, material groups, environments, 
etc. 



• Edit - Provides a list of things to edit, such as assorted types of surfaces, geometry, 
animation, as well as options for renaming, removing select nodes, etc. 

• Asset - Provides a submenu for editing the usage of external file references. These files 
are imported into the Scene Graph and are present within its structure. 
 

o Modify - Allows to make changes to the selected object. The object's icon 
changes to  (modified asset). 

o Save in Asset Manager - Saves the selected asset within the Asset Manager. 
o Select all Occurrences - Selects all incidents of the chosen asset in the Scene 

Graph. 
o Find in Asset Manager - Selects the related asset within the Asset Manager. 
o Reload from Asset Manager - Updates the selected asset from the Asset 

Manager. 
o Remove Reference - Removes the reference connection to the Asset Manager. 

The asset itself is deleted, using this action. 
 

• Convert To - Changes the selected node into what you have selected, such as a group, 
matrix transform, material group, switch, etc. 

• Reload - Provides a way to reload external files referenced by the selected node, replace 
the external file referenced by the selected node with a new file, or show the reload log. 
Choose whether to keep the current materials or use them. VRED creates a new node to 
replace the one being reloaded. This is because VRED uses a naming scheme for nodes 
within the hierarchy of the loaded file. If some materials cannot be restored, a message 
is displayed listing them, and the list is saved to the reload log. (The log is available for 
the last reload action only.) 

• Hide - Hides the selected node. 
• Show/Hide - Toggles the selected node on or off. 
• Show Last Hidden - Shows the last hidden node. This is great for quickly locating and 

turning on a node when working with a large and complex model. 
• Hide Subtree - Hides the selected node and its subtree. 
• Show Subtree - Shows the selected node and its subtree. 
• Hide All - Hides everything in the Tree View, but has no effect on the Viewport. 
• Show/Hide All - Shows and hides everything in the Tree View. Use it to view your nodes 

after using Hide All. 
• Set To A Side - Sets the selected nodes as A sides, so they are visible in the Viewport. 
• Set To B Side - Sets the selected unneeded shapes and components as B sides, to hide 

them in the Viewport and avoid re-loading these files. 
• Isolate View Selected - Shows only the selected node in the Viewport. To see your 

entire model, select the top node of our model, then Isolate View Selected. 



 

• View In New Renderwindow - Opens a new Viewport (Render Window), displaying the 
selected rendered node. 

• Zoom To - Zooms the Viewport into the selected node's geometry. 

 

• Show Components - Shows the individual patches for objects (only Surfaces and Shells). 
• Selectable - Toggles the selection mode of a node and its children on or off. If nodes are 

deselectable, they cannot be modified in the Viewport. Mouse interaction with the 
deselectable node is not possible, such as applying a material by drag and drop or 
flipping normals. However, the touch sensors can still be used, such as annotations and 
measurements with the deselectable nodes. The object’s icon changes from 
(selectable) to  (deselectable). To deselect things, use Deselect All. 

• Select All - Selects all parent nodes in the Scene Graph, excluding the root node. (Ctrl+A) 
• Deselect All - Deselects all nodes in the Scene Graph. (Ctrl+Shift+A) 
• Select Subtree - Selects the current node and its child nodes in the Scene Graph. 
• Select Parent - Selects the parent node for the selected node in the Scene Graph. 
• Select All Clones - Selects all clone nodes of the select node in the Scene Graph. 
• Select All Transformable Clones - Selects all transformable clone nodes of the selected 

node in the Scene Graph. 
• Select All In Same Level - Selects all nodes that are at the same level in the tree. For 

example, you want to select all 3rd generated child nodes. If you have a large project, 
this would be time consuming. However, if you select one, then use Select All In Same 
Level, all are selected immediately. 



• Invert Selection - Switches from what is selected to everything else. In the tree, the 
inversely selected nodes will highlight blue. In the Viewport, if Boundings is active, the 
select geometry will change. (Ctrl+I) 

• Invert Selection in Group - Switches the selection from the things selected in the group 
to what wasn't selected. (Ctrl+Shift+I) 

• Grow Component Selection - (Surfaces/Shells only) Expands the currently selected 
nodes to include neighboring patches. (>). 

• Shrink Component Selection - (Surfaces/Shells only) Deselects patches that have 
unselected neighbor patches. This is the inverse of Grow Component Selection. (<). 

• Find - Opens the Find pop-up window. Any objects matching the criteria are selected. 
(Ctrl+F) 

• Scroll to Selected - Scrolls through the Scene Graph to the selected node. (Ctrl+Shift+F) 
• Information - Opens Node Information, which displays an assortment of details 

regarding the selected node. Click OK or the X to close it. 



Scene Graph File Menu 
Scene > Scene Graph > File 

The Scene Graph File menu contains these features: 

• Add File - Imports geometry into the scene. When adding a VRED scene, the Import 
Options dialog appears. Decide whether variants, touch sensors, sequences, or 
environments should be merged and more. 

• Save Selected - Saves the currently selected nodes to a new VRED scene. To save to 
non-VRED file types, in the Menu Bar, select File > Export. 

• Reload - Contains the following options: 
 

o Reload File and Reload All Files - Reloads the external files referenced by the 
selected node. Choose whether to keep the current materials or use the ones in 
the files. VRED creates a new node to replace the one being reloaded. This is 
because VRED uses a naming scheme for nodes within the hierarchy of the 
loaded file. If some materials cannot be restored, a message is displayed listing 
them, and the list is saved to the reload log. (The log is available only for the last 
reload.) 

o Replace File - Replace the external file referenced by the selected node with a 
new file. 

o Show Reload Log - Displays the Reload Log only for the last reload. 
 

• Assets - Provides a submenu for editing the usage of external file references. These files 
are imported into the Scene Graph and are present within its structure. 

• Modify - Makes it possible to change the selected object. The object's icon changes 
from asset to  (modified asset). 
 

o Save in Asset Manager - Saves the selected asset within the Asset Manager. 
o Select all Occurrences - Selects all incidents of the chosen asset in the Scene 

Graph. 
o Find in Asset Manager - Selects the related asset within the Asset Manager. 
o Reload from Asset Manager - Updates the selected asset from the Asset 

Manager. 
o Remove Reference - Removes the reference connection to the Asset Manager. 

The asset itself is deleted, using this action. 



Scene Graph Edit Menu 

Surfaces 

Once you have one or more surfaces selected, the following features are found in the Scene 
Graph under Edit > Surfaces. 

• Tessellate Surfaces - VRED uses ray tracing to display NURBS data, without any 
preparation. In OpenGL mode, VRED tessellates objects to generate a polygonal 
representation. This involves changing the complexity or number of polygons of an 
object, at any time. NURBS coexist with polygons on nodes within the Scene Graph. You 
can re-tessellate without having to reload the files. A polygonal representation will 
never be as precise as source NURBS data, so more polygons will have to be generated 
when a higher precision is required. 

The Tessellate Surfaces dialog box contains these settings. 

o Tessellation Quality - Uses the selected preset to determine the approximate 
tessellation quality. The other option values, such as Chord Deviation, Normal 
Tolerance, etc. automatically adjust, based on the selected quality. 

o Chord Deviation - Sets the maximum deviation between the NURBS surface and 
tessellated surface. A low value results in a more accurate polygon model, but 
increases the number of triangles. 

o Normal Tolerance - Determines the allowed normal deviation between the 
normals on the endings of a tessellated edge. 

o Max Chord Length - Sets the maximum edge length of the generated polygons. 
Long polygon edges will not be smoothly shaded within the Render Window. This 
setting is helpful to avoid this. 

o Enable Stitching - Avoids the ragged edges of a tessellated representation within 
the Stitching Tolerance. When a surface is tessellated, this process re-builds 
existing topology and aligns the edges of selected shells to each other. Stitching 
is required to smooth the edges. 

o Stitching Tolerance - Sets the tolerance where two adjacent edges are 
considered to be touching and should be stitched together. 
 

• Create Shell From Selection - Combines the selected NURBS components into one 
contiguous NURBS shell. 

• Convert to Mesh - Deletes NURBS information stored with the tessellated object. This 
reduces memory requirements for the scene, but re-tessellation of that object will no 
longer be possible. 



Geometry 

The following features are found in the Scene Graph under Edit > Geometry. 

• Merge Geometry - Merges polygonal objects with the same material into one 
contiguous object. Can also be used on group nodes. Will also work when NURBS data 
exists with the polygonal representation. If nothing is selected, this applies to all items 
in the Scene Graph. (Ctrl+Shift+M) 

• Split Geometry - Splits the selected object into meshes. In the dialogue box that opens, 
enter the maximum number of triangles each resulting mesh can have. For example, if 
there is an object with 1000 polygons and it should be divided into fragments with a 
maximum amount of 100 polygons each, the splitting will yield 10 objects. This cannot 
be undone. 

• Split Geometry into Primitives - Converts the object into a group node with the same 
name. The group node contains single triangles for each polygon of the source object. 
(Ctrl+T) 

• Unsplit Geometries with One Triangle - Merges triangles into one object. To combine a 
number of polygons this way, they should be grouped, and this feature used on the 
group node. Material from the first node below the parent group is applied to the 
merged object. (Ctrl+Shift+T) 

• Subdivide Geometry - Subdivides an existing polygon mesh into smaller triangles. This 
feature is helpful when NURBS data for re-tessellation is not available, but a refined 
mesh is required. For example, ambient occlusion calculation requires a fine mesh 
resolution to avoid ragged edges on shadows. 

In the Subdivide Geometry dialog, select a Subdivision Mode. 

o Standard - Subdivides each polygon until the edge lengths fall below the value 
entered in the Max Edge Length box. 

o Phong Interpolation - Subdivides each polygon into a specific number of 
triangles, depending on the value selected in the Iterations box. 

Iterations Triangles/Polygons 
1 4 
2 16 
3 64 
4 256 

 

 



Animation 

The following features are found in the Scene Graph under Edit > Animation. 

• Load Animation to Nodes - Applies a saved transformation animation to the selected 
nodes. 

• Load Animation to Materials - Applies a saved material animation to the selected 
nodes. 

• Create Turntable Animation - Creates a turntable to rotate the selected object around 
the perpendicular axis. Adjust settings in the dialog, including: 
 

o Interpolation - Determines object velocity during animation playback. Linear 
results in a constant rotation of the object, while Ease In or Ease Out reduces 
velocity during the beginning or end of the animation. 

o Rotation Pivot(s) - Click Set To Center to set the rotation pivot to the center of 
the selected object's bounding box. 
 

• Copy Animations - Copies the animation from a selected animated object. 
• Paste Animations - Pastes an animation to the selected node. 
• Paste Clone Animations - Pastes an animation to the selected node as a reference. This 

means any change to the animation affects the cloned instance. The reverse is true, as 
well. 

Copy and Paste 

Nodes in the Scene Graph can be copied and pasted within the Scene Graph. You can also copy 
and paste nodes from one instance of VRED to another. With two or more sessions of VRED 
open, copy nodes from one Scene Graph, select a node in another Scene Graph and paste. The 
Paste dialog opens with options. 

NOTE Variant Sets and Environment nodes are not supported with copy and paste between 
instances of VRED. 

Paste and Clone 

Aside from standard delete, copy, and paste functions, VRED includes these clipboard options in 
the Scene Graph Edit menu. When components are dragged and dropped or pasted in the 
Scene Graph, shells are created. 

• Paste > Paste Clone - Pastes nodes currently stored in the clipboard as a group node of 
clones in the Scene Graph. The clones are also known as referenced objects. Referenced 
objects are underlined. (Ctrl+Shift+V) 



• Paste > Paste with Transformation - Pastes nodes currently stored in the clipboard to 
the same location as the originally copied nodes. 

• Paste > Paste Clone with Transformation - Pastes nodes currently stored in the 
clipboard as a group node of clones in the Scene Graph, and in the same location as the 
originally copied nodes. The clones are also known as referenced objects. Referenced 
objects are underlined. 

• Clone - Combines the Edit menu commands, Copy and Paste Clone, into a single action. 
The use of one of the mirror commands creates a referenced and mirrored instance of 
the source object or structure. Referenced nodes are underlined within the Scene 
Graph. Cloned groups are transformable by default. 

NOTE Edit > Preferences > Scene Graph > Transformable Clone Root is activated by 
default. 

o Clone - Creates a cloned instance of the source selection at the same position in 
3D. When the Transformable Clone Root is activated, the selected node and its 
duplicate are synchronized. All children of both nodes are clones of each other. 
Adding, removing, and reordering children does the same on the children of the 
synchronized node. The two synchronized nodes can be independently 
transformed, animated, and named. Only Groups (Transform3Ds) can be 
synchronized. That means, cloning with the option enabled is only possible on 
Transform3D nodes. (Ctrl+Shift+D) 

o Clone Mirror X, Y, or Z - Creates a cloned instance of the source selection 
mirrored on the related axis. When the Transformable Clone Root is activated, 
the subtree of the selected node is cloned, and the roots of both subtrees 
(source and result) are synchronized with each other, as with Clone. The cloned 
subtree is added as a child to a Mirror Transform node. 
 

• Duplicate - Acts the same as Clone, except the new objects are independent, rather 
than referenced. Additional flush options for axis mirroring, flush the transformations 
from the sub-tree into the object nodes. (Ctrl+D) 
 

o Duplicate - Creates an independent instance of the source selection at the same 
position in 3D. All clone connections are preserved within the duplicate. (Ctrl+D) 

o Duplicate and Keep Clones - Creates an independent instance of the source 
selection at the same position in 3D. All clone connections are preserved to 
other parts of the Scene Graph. 

o Duplicate Without Clones - Creates an independent instance of the source 
selection at the same position in 3D. All clone connections are disrupted within 
the duplicate. 

o Duplicate Mirror X/Y/Z - Creates an independent instance of the source 
selection, mirrored across the selected axis. 

o Duplicate Mirror X/Y/Z Flush - Creates an independent instance of the source 
selection, mirrored across the selected axis. This command also flushes the 



transformations from the subtree into the object nodes. 
 

• Unshare - Removes a referenced connection. Changes made to one object no longer 
affect its former reference. Internal clones are preserved. 
 

o Unshare - Disrupts all clone connections from nodes in the selected subtree to 
other parts of the Scene Graph. 

o Unshare Selected Node - Disrupts only the clone connection of the selected 
node. 

o Unshare Subtree - Disrupts all clone connections in the selected subtree. 
 

• Copy Transformation - Copies all transformation information from the selected node to 
the clipboard. A transformation contains information on the position and orientation of 
an object within 3D space. It also provides information on the position and orientation 
of the object's coordination system. 

• Paste Transformation - Accesses paste options for transformations. Paste all 
transformation information, such as translation, rotation, scale, and pivot, or select one 
attribute to paste. Paste the pivot to apply the location and orientation from the 
object’s local coordinate system. Use Paste As Variant to paste a copy of a 
transformation as a variant on a selected node. 

Copy/Paste Transform Variants 

• Copy Transform Variants - Copies all transform variants of a selected node. 
• Paste Transform Variants - Pastes all copied transform variants to a selected node. 

Lock/Unlock 

Nodes can be locked, so they and their children cannot be modified anymore. A locked node is 
indicated in the Scene Graph by its icon . In the Render Window, when a selected node is 
locked, the bounding box, wireframe, and transformation handle are gray. 

 

 



Group 

Use these options in the Edit menu to group objects. 

• Group by Material - Groups objects by their applied materials into new nodes. 

IMPORTANT This rearranges the Scene Graph structure. 

• Group Selection - Moves selected objects into a new node. (Ctrl+Shift+G) 

Show Optimize Module 

Opens the Optimize Module to optimize the scene and increase rendering performance. All 
optimization processes are applied to the selected nodes and their children. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=About-Optimize


Scene Graph Create Menu 
All functions in the Create menu of the Scene Graph add more nodes to the scene. Generated 
nodes are added as children to the currently selected node. If no node is selected, the new 
node is a child of the Root node. The geometry, lights, and camera options in the Create menu 
are the same as in the Scene menu of VRED. All other options in the Scene Graph Create menu 
are described here. 

• Group - Creates a group node to which you can add objects. This is useful when wanting 
to move, scale, or rotate multiple objects as a unit. This does not affect the graphical 
representation within the Render Window. (Ctrl+G) 

• Shell - Creates a shell node. Edit the shell node with Scene > Node Editor. 
• Matrix Transform - Creates an empty matrix transformation node in the Scene Graph, 

called “Transform.” This node holds independent translation and transformation 
information. Use it to reuse positions and transformations of an object and apply them 
to another structure. 

• MaterialGroup - Creates an empty node in the Scene Graph, named “MaterialGroup”. 
When a material is assigned to this node, objects under this node will use the 
MaterialGroup’s material. The original material of the object will not be deleted. 

• Environment - Creates an environment group node, so you can organize your 
environment geometries. An environment group node provides a textured surrounding 
with a shadow plane on its ground. Its texture affects the representation of all scene-
related materials. 

• Switch - Creates a Switch node with only one child visible at a time. The child to be set 
visible can be selected under Scene > Node Editor. Switches can also be controlled in the 
Variants and the Variant Set Module. 

• StereoSwitch - Creates a StereoSwitch node, which can draw the first two children 
independently of each other. While the first child is drawn on the left eye channel, the 
second child is drawn on the right. To activate the StereoSwitch, select a preferred 
stereo render mode. 

• HostSwitch - Creates a HostSwitch node. HostSwitch children can be rendered on any 
dedicated host computer. Enter the name of the host computer under Scene > Node 
Editor > hostname. 

• Billboard - Creates a Billboard node that aligns its children to the camera. 
• ClipPlane - Creates a ClipPlane node. This node has a border behind which its child 

objects are not shown. 
• DistanceLOD - Creates a DistanceLOD nodes that helps you set up different children to 

be rendered, depending on the distance between the object and camera. Usually, this is 
used to reduce the geometry's level of detail when the camera is far from an object and 
increase the detail when the camera is close, by switching between different 
geometries. This keeps the frame rate high. To setup which child should be drawn for 
which distance range, click Scene > Node Editor and edit the range property. If the 
DistanceLOD node has N children, specify the N-1 range values (comma separated 



floating point values are accepted). Each value constitutes a distance threshold between 
two adjacent ranges corresponding to a specific level of detail. 

• Sound - Creates a Sound node to embed sound into a scene. Enter the path of the sound 
file under Scene > Node Editor > soundFile. 

• SoundObstructor - Creates a SoundObstructor node, which mutes a sound file when the 
corresponding Sound node is covered by the SoundObstructor in the Render Window. 

• Custom - Creates custom nodes. Enter the custom node type. 



Scene Graph View Menu 
The View menu in the Scene Graph enables you to show and hide various parts of the scene in 
the Render Windows. It also includes the following features. 

• Set to A/B Side - Helps you define unneeded shapes and components as B-sides to avoid 
reloading these files. 

B-sides are the interiors and engineering sides of things. These are the surfaces you 
don't see in a typical render. If you are doing a technical preview, then these are handy. 
This option is quite useful when you don't know whether you need this geometry of not 
for the future. Setting things to B-side provides more flexibility when working and keeps 
this geometry as temporary. B-side elements are not visible, by default, within the 
Render Window. 

In the Scene Graph, B-side nodes are identifiable by their darker blue icon. 

 

Once the file is loaded into VRED, you can use Set to A Side and Set to B Side to select 
which objects to show. 

When exporting a file, you will be asked whether you want the B-side content to be 
exported, as well. 

• Isolate View Selected - Opens the selected object or node in the Render Window. 
• View in New Render Window - Opens a floating Render Window, displaying the 

selected object. 
• Zoom to - Shows a centered view of the selected object. 
• Show Components - Shows the individual patches for objects (only Surfaces and Shells). 
• Show Internal Nodes - Shows internal Scene Graph nodes, such as LightTransform 

nodes. 
• Information - Opens Node Information, which displays an assortment of details 

regarding the selected node. Click OK or the X to close it. 



Scene Graph Select Menu 
The Select menu in the Scene Graph enables you to select and deselect a variety of different 
things. 

• Selectable - Toggles the selection mode of a node and its children on or off. If nodes are 
deselectable, they cannot be modified in the Render Window. Mouse interaction with 
the deselectable node is not possible, such as applying a material by drag and drop or 
flipping normals. However, the touch sensors can still be used, such as annotations and 
measurements with the deselectable nodes. The object’s icon changes from 
(selectable) to  (deselectable). 

• Select All - Selects all parent nodes in the Scene Graph, excluding the root node. (Ctrl+A) 
• Deselect All - Deselects all nodes in the Scene Graph. (Ctrl+Shift+A) 
• Select Subtree - Selects the current node and its child nodes in the Scene Graph. 
• Select Parent - Selects the parent node for the selected node in the Scene Graph. 
• Select All Clones - Selects all clone nodes of the select node in the Scene Graph. 
• Select All Transformable Clones - Selects all transformable clone nodes of the selected 

node in the Scene Graph. 
• Select All In Same Level - Selects all nodes that are at the same level (hierarchy) in the 

tree. For example, you want to select all 3rd generated child nodes. If you have a large 
project, this would be time consuming. However, if you select one, then use Select All In 
Same Level, all are selected immediately. 

• Invert Selection - Switches from what is selected to everything else. In the tree, the 
inversely selected nodes will highlight blue. In the Render Window, if Boundings is 
active, the select geometry will change. (Ctrl+I) 

Use Invert Selection when getting a file ready for rendering. It helps you isolate 
geometry for reducing tessellation of unseen surfaces or removing surfaces (patches) 
that aren't needed. Select all the pieces that will be rendered, then in the Scene Graph, 
select Select > Invert Selection. This selects all the geometry you don't want. At this 
point you can hide or delete this geometry. 

Tip - After inverting the selection, you may want to use B-side to set them as so. 

• Invert Selection in Group - Switches the selection from the things selected in the group 
to what wasn't selected. (Ctrl+Shift+I) 

• Grow Component Select - (Surfaces/Shells only) Expands the currently selected nodes 
to include neighboring patches. (>) 

• Shrink Component Selection - (Surfaces/Shells only) Deselects patches that have 
unselected neighbor patches. This is the inverse of Grow Component Selection. (<) 

• Find - Opens the Find pop-up window. Any objects matching the criteria are selected. 
(Ctrl+F) 

• Scroll to Selected - Scrolls through the Scene Graph to the selected node. (Ctrl+Shift+F) 



Scene Graph Scene Tags 
Scene tags filter content and allow you to quickly isolate it in the Render Window. You can 
associate scene tags with nodes in the Scene Graph. 

Show Scene Tags 

There are two ways to show scene tags: 

• Below the Scene Graph menus, select the Scene Graph drop-down, then Scene Tags. 
• Drag the dotted white line up from the bottom of the Scene Graph to display two Scene 

Graphs. From one of the Scene Graph drop-downs, choose Scene Tags. 

To Add Scene Tags to Nodes 

Add scene tags to help organize and filter content when working in the Render Window. 

1. Display two Scene Graphs and change one to Scene Tags. 
2. Right-click in Scene Tags and select New Tag. 
3. (Optional) Right-click the tag and select Rename to change its name. 
4. Drag nodes from the Scene Graph onto the desired tag. Tap the plus in front of the tag 

to expand it and see its associated nodes. A tag can also be dragged onto a node in the 
Scene Graph to add the node to the tag. 

To Isolate a Scene Tag 

Display only the nodes associated with the selected scene tag in the Render Window. 

1. Right-click on a tag and select Isolate View Selected. The nodes and name of the tag are 
displayed in the Render Window. 

2. To restore your model in the Render Window, in the Scene Graph, select the root node, 
then right-click and select Isolate View Selected. 



Viewing and Editing Node Information 
The Node Editor provides 
information about any node in a 
scene. You can view detailed 
information about selected 
nodes, change values, and attach 
custom attributes to nodes. 

For example, use the Node Editor 
to set up the ranges for a 
DistanceLOD. Which child should 
be drawn for which distance 
range, set the parameters of the 
range property, and so on. 

Accessing the Node Editor 

1. In the Menu Bar, click Scene > Scene Graph. 
2. In the Scene Graph, select the node you want to work with. 
3. In the Menu Bar, click Scene > Node Editor. 

Editing in the Node Editor 

With the Node Editor open, click the field to the right of an option, then enter another value. 

 

 



Animation 



About the Curve Editor 
Animation > Curve Editor 

Use the Curve Editor to select animatable parameters (channels) for selected geometry. Use 
the timeline and animation tools for setting keyframes and editing animation curves. 

The Curve Editor 

The Curve Editor has a menu and search bar, library tree view, fields for entering frames and 
settings, curve grid, channel box that lists animatable channels, timeline, and Icon Bar. 

From the Menu Bar, select Animation > Curve Editor. 

Menu Bar 

 Search Bar 

 Library 

 Framing Values 

 Curves Grid 

 Channel Box 

 Icon Bar 

 

Menu Bar 

This section explains what each option in the Curve Editor menus does. 

Edit 

• Save - Opens the Save Animation dialog to save the animation on the selected node as 
an OpenSG Binary Geometry (.osb) file. 

• Rename - Renames the selected node. 
• Delete - Deletes the selected node. 
• Copy - Copies the selected animation block. 
• Cut - Cuts the selected animation block. 



• Paste - Pastes an animation block to the selected object as a reference. 
• Paste Clone - Pastes an animation block to the selected object in a non-referenced way. 
• Clone - Creates a referenced copy of the selected animation block and pastes it directly 

below the source block. 
• Duplicate - Creates a copy of the selected animation block, but unlike Clone, the new 

animation block is independent, rather than referenced. 
• Unshare - Removes referenced connections to a node. 
• Group Selection - Groups selected objects into a group node, with the primarily selected 

objects as children of that node. 
• Select Node - Selects the node corresponding to the selected object in the Curve Editor 

Library. 
• Information - Displays attributes of the selected node, such as the number of vertices. 

View 

• Frame - Frames the animation curves for the selected Library node in the grid, making 
them visible. To frame a specific area, use the Frame and Value options and enter 
numeric values in each. 

• Lock Objects/Unlock Objects - Locks or unlocks attributes of the selected object. 

Curve 

• Pre-Infinity Mode and Post-Infinity Mode - Pre-Infinity Mode defines the behavior 
before the first keyframe has been reached, while Post-Infinity Mode defines the 
behavior after the last keyframe has been reached. Both modes share the same options: 
 

o Constant - Runs the curve one time. Continues the curve constant with the last 
keyframe of the curve. 

o Loop: Loops the curve endlessly. 
o Loop with Offset - Loops the curve, but with the beginning of the new curve 

using the last keyframe of the old. 
o Oscillate - Runs the curve forward and backward alternately in an endless mode. 
o Linear - Continues the curve linearly in the direction of the last keyframe 

handle's direction (Tangent). 
 

• Key All Channels - Creates a key at the current frame for all object attributes listed in 
the Curve Editor's Channel Box. (Ctrl+K) 

• Key All Selected Channel Types - Enables the selection of several objects and the editing 
of channels from those objects at the same time. 

• Key Selected Channels - Adds a keyframe at the current frame for the selected channels 
to the timeline. The key also appears in the grid. 

• Create Block - Creates a block, which is a container that stores animations. The 
animations can be accessed and edited, at any time. Blocks can be used in the Clip 
Editor to arrange more complex animations. Objects may have an unlimited number of 



blocks. The length of each block runs from the first to last keyframe position. When a 
block is selected, the keyed animation curves are drawn. (Ctrl+Shift+K) 

• Snap to Grid - Offers two options: 

o Time: Snaps to the X-axis. For a shortcut, try in the Icon Bar. 

o Value: Snaps to the Y-axis. For a shortcut, try in the Icon Bar. 

Tangents 

Tangents describe the entry and exit of a key's curve segments. Apply these options to the 
shape of curve segments around the selected keys. 

• Constant - Keeps the curve value constant until the next key value, creating a non-
interpolated and flat connection between the points. Select a keyframe in the grid, then 
Constant. 

• Linear - Applies a linear interpolation between the key points. A linear in and out 
tangent results in a straight line between the points. Select a keyframe in the grid, then 
Linear. 

• Flat - Sets the handles in a horizontal position with a slope of 0 degrees. Select a 
keyframe in the grid, then Flat. 

• Hermite - Creates a smooth animation curve between the keys that precede and follow 
the selected key. The tangents of the curve are collinear (both with the same angle), so 
the animation curve smoothly enters and exits the key. Select a keyframe in the grid, 
then Hermite. 

• Following - Keeps the tangent handles of the key’s point in the direction of the next key. 
In and out tangents are collinear. Select a keyframe in the grid, then Following. 

• Break - Breaks the in-and-out tangent link, allowing each handle to be changed 
independently. Select a keyframe in the grid, then Break. 

Search Bar 

Conducts a search, using the entered string, of the nodes in the Library. If nothing is found, 
clear the Search Bar to view the nodes in the Library. 

!Library  

Houses the animated nodes in a tree structure. Right-click within the Library to access a context 
menu of editing option. To invert the list, click the triangle to the right of Library. 

Motion Blur 

Right-click a node and select Motion Blur to enable or disable this effect on rendering. 



Framing Values 

Displays the current frame and value for the selected keyframe. Use these fields to make 
manual adjustments to a keyframe. 

Curves Grid 

Displays animation curves plotted along the X- and Y-axis. 

• To edit a curve, click a keyframe, then use tools in the Edit menu or Icon Bar. Change the 
tangents, add more keyframes, and create animation blocks. 

• To view a curve, select a node or channel, then use View > Frame to frame it. 

Keyboard and mouse shortcuts for navigating the Grid 
Action Shortcut 

Zoom Right-click 

Pan Middle-click 

Focus Double right-click 

Multiselection Ctrl+Shift-click 

Deselect Ctrl+Shift+right-click 

Move Shift-click 

Zoom horizontal X+right-click 

Zoom vertical Y+right-click 

Center F 

Channel Box 

Displays the channels for the selected Library node. When a node from the Library is selected, it 
and its channels populate the Channel Box. 

• To edit the value of a channel, double-click the channel's value, then enter a numeric 
value. 



• To loads animation curve into the grid, selecting one or more channels. Don't forget to 

use  to frame the curve(s). 

Icon Bar 

The icons in the Curve Editor make it quick to change tangents, key channels, and snap to the 
grid. 

 Key All Channels - Adds a keyframe for all channels to the timeline. The key also appears in 
the grid. 

 Key Selected Channels - Adds a keyframe at the current frame for the selected channels to 
the timeline. The key also appears in the grid. 

 Create Animation Block - Creates a block from the animation curves of the selected Curve 
Editor item, so the animation can be used in the Clip Maker. The animations can be accessed 
and edited, at any time. 

Use blocks to arrange more complex animations. Objects can have an unlimited number of 
blocks. The length of each block runs from the first to last keyframe position. When a block is 
selected, the keyed animation curves are drawn. 

 Frame - Frames the animation curves for the selected Library node in the grid, making 
them visible. 

 Constant Tangents - Keeps the curve value constant until the next key value, creating a non-
interpolated and flat connection between the points. 

 Linear Tangents - Applies a linear interpolation between the key points. A linear in and out 
tangent results in a straight line between the points. 

 Flat Tangents - Sets the handles in a horizontal position with a slope of 0 degrees. 

 Hermite Tangents - Creates a smooth animation curve between the keys that precede and 
follow the selected key. The tangents of the curve are collinear (both with the same angle), so 
the animation curve smoothly enters and exits the key. 

 Following Tangents - Keeps the tangent handles of the key's point in the direction of the 
next key. In and out tangents are collinear. 



 Break Tangents - Breaks the in-and-out tangent link, allowing each handle to be changed 
independently. 

 Horizontal Grid Snapping - Snaps the selected keyframe to points in time along the grid (X-
axis). 

 Vertical Grid Snapping - Snaps the selected keyframe to values along the grid (Y-axis). 



Creating a Keyframe Animation 
Follow these instructions for creating keyframe animation: 

1. In the Menu Bar, select Animation > Timeline. 
2. Select Scene > Scene Graph. 
3. In the Scene Graph, select the geometry you want to animate. 
4. Go to frame zero on the timeline. 
5. On the right side of the timeline, click  (Keyframe). 

This saves the current transformation values for frame zero. A red line appears at frame 
zero indicating a keyframe has been created. 

6. Tap elsewhere within the timeline to navigate to a later frame and move the object 
within your scene. 

7. Click  (Keyframe) again to create a keyframe with the new transformation values. 

Now when you play the animation, the position of the object will be interpolated 
between the two keyframes. 

 

8. Optional: Drag another object, such as a shadow plane, under the animated object in 
the Scene Graph. 

This sets the dragged object as a child of the animated object, so it will move with the 
object. 



Managing VRML Animations 
VRML animations are imported into VRED. You can play them using a mouse shortcut menu, 
keyboard shortcuts, or Python scripts. Animations initiated by clicking an object within the 
Render Window can be associated with touch sensors. 

How to Show a List of VRML Animations 

 

1. In the Menu Bar, select Animation > VRML Animation. 

The VRML Animation module lists all VRML animations imported to VRED. 

2. Right-click an animation in the list to see shortcuts for playing, pausing, and deleting the 
animation, and so on. 

Use the VRML Animation module to change properties of VRML animations, such as shortcuts, 
cycle interval, and so on. 

How to Change VRML Animation Properties 

1. In the VRML Animation module, select an animation to edit. 
2. Enter a comment under Properties to describe the animation. 
3. Under Hotkeys, enter shortcuts to play and pause the animation. 
4. Under Animation, set the cycle interval in seconds. 
5. Under Animation, drag the Keyframe slider to scrub through the animation. A value of 0 

represents the beginning of the animation; a value of 1 represents the end. 
6. Right-click an animation and choose Select Nodes to select all the nodes affected by the 

animation. 

 



Working with the Curve Editor 
Animation > Curve Editor 

Use the Curve Editor to create and edit animations. The animation curve of an object indicates 
when and where it should be within the scene’s coordinate system. Use it to control curvature 
and acceleration during animation. 

NOTE Open the Timeline (Animation > Timeline) to help when animating. 

How to Create an Animation Curve 

1. In the Menu Bar, select Scene > Scene Graph and select an object. 
2. Select Animation > Curve Editor. 

When a node is selected in the Library to the left, its animated channels are listed to the 
right. 

 

3. Drag the vertical line in the Curve Editor to select the moment when you want the 
object to reach a certain position. 

If it helps, open the Timeline (Animation > Timeline) for more accurate frame 
navigation. 

4. Select an object or a channel. 
5. Select  Key All Channels or  Key Selected Channels to set a key for the selected 

channels. 

TIP Press F to scale and center curves to fit the view. 



6. Drag the vertical slider (or Timeline slider) to select a different frame, then re-key the 
selected properties for that frame. 

Curves are generated with a smooth transition between the two frames where keys 
were set. 

How to Edit an Animation Curve 

1. In the Curve Editor, click the node you want to change. 
2. Drag the key to change its frame position or drag the yellow curve handles to edit the 

curvature (tangent) between two keys. 

 

How to Create Animation Blocks for the Clip Maker 

Animation curves cannot be dragged directly into the Clip Maker. Animation curves must be 
convert into a block element, then these block elements can be used in the Clip Maker. 

NOTE To quickly animate an object moving from one place to another, as well as its material, 
try the Clip Maker Wizard. 

1. Once something has been animated, if the Curve Editor isn't open, click (the Curves 
icon) in the Quick Access toolbar to open it. 

2. In the Curve Editor, select an element from the Library, then click (Create an 
animation block element). This adds a block element to the Curve Editor Library. 

 



How to Add a Block to a Clip 

1. Click (the Clips icon) in the Quick Access toolbar to open the Clip Maker. 
2. Click  and select Clip to create a clip. 

 

3. From the Curve Editor, drag the block onto the new clip in the Clip Maker to add the 
block to a clip. Expand the clip to see the block. A clip appears in the Clip Maker timeline 
to the right. 

 



Working with the Clip Maker 
Animation > Clip Maker 

Use the Clip Maker to create and manage animation sequences. The left side contains a list of 
all clips in the scene. Select a clip from the list to see a timeline view to the right. 

 

Clips 

Clips contain multiple animations. An example of a clip would be an animation of a door handle, 
the lock, and door open/close. Since you don't want these to play at the same time, you can 
move your clips in time, stretching or squashing them to slow or speed up the animation. 
However, before doing this, the curves (animation curves) must be convert into block elements. 
This is done in the Curve Editor. 

How to Create a Clip with the Wizard 

The Wizard button is located under the main menu of the Clip Maker. Use it to create an 
animated clip. 

1. Select an object or material and click Wizard. The Animation Wizard opens. 
2. Select whether you want to animate an object, material, or both at once, and click Next. 
3. Enter a name for the animation and set the start and duration times. 
4. Select an interpolation mode; Ease In and Ease Out reduce the velocity at the beginning 

and end of the animation. 
5. Click Capture Start to capture the initial state of the animation. A thumbnail image 

displays its current state. 



6. Move the geometry or change the material, then click Capture End. 
7. Click Preview to play the animation in the Render Window. 
8. Click Reset Preview to return the animation to its initial state. 
9. Click Finish. 

How to Add Variants and Other Items 

In addition to clips, you can add animations, camera tracks, viewpoints, variants, and sequences 
to the Clip Maker. Only existing variants can be added; see Variants. 

In the Clip Maker, click  and from its menu, select Variant Set. 

NOTE If there are no created variant sets, selecting this option will do nothing. 

This opens the Add Variant Set dialog, where you choose the Variant Sets from the drop-down 
menu and the Frame, then click OK. The variant set appears in the timeline of the Clip Maker 
and looks like this. 

 

To create other items, such as viewpoints or sequences, click , select the type of item to 
create, and follow the instructions. 

How to Manage Clips in the List 

• To activate or deactivate a clip, click the check box to its left. 
• To lock or unlock a clip against changes, click the check box to its right. 

 

How to Edit a Clip 

There are a couple ways to edit a clip, such as using the clip parameters or by interacting 
directly with the clip in the timeline. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Variants_About_Variants_html


How to Edit Clip Parameters 

1. From the list on the left side of the Clip Maker, select a clip. 
2. Use the controls at the top of the timeline to adjust the start time, duration, and 

number of play cycles. 

How to Edit a Clip in the Timeline 

Do any of the following in the Clip Maker timeline: 

• Drag a clip to a new position either in time (left or right) or to a new track (up or down). 
• Drag the white end and stretch your clip to slow the playback of the animation, by 

having the same action playing for longer. 
• Drag the white end and squish the clip to speed the animation up, having the action play 

for a shorter amount of time. 

How to Manage Clips in the Clip Maker Timeline 

The Clip Maker timeline includes several tracks for arranging clips. Each block represents one 
animation sequence. 

 

• To move clips, click-drag them within the timeline. 
• To change the start point, end point, or duration of a clip, drag the handles at the 

beginning or end of a clip. 

• To snap clips by one-second units when modifying their start or end points, click 
Horizontal Grid Snapping. 

• To remove empty clips and animation blocks no longer referenced in the scene, click  
Remove all unused blocks and empty clips. 

• To zoom in and out of the timeline, scroll with the mouse wheel. 



• To display a clip in the timeline, click it in the Clips List. However, you may not see it if it 
is out of the displayed time range. Tap F to fix this. 

• To display in the timeline the full range of a set of clips, select their parent item and click 
 Frame Objects in View or select View > Frame. 



Using the Timeline 
Animation > Timeline 

Use the timeline to create and play animations. The time format is set to frames, by default. 

 

How to Use the Timeline 

• To change the time format of the timeline, right-click Frames (4) and from the menu, 
select frames, seconds, or both. 

• To scroll through the animation, tap and drag through the timeline. 
• To go to a specific frame, enter the frame number in the Frame Number box (5) beside 

the timeline. 
• To change the range of frames displayed, drag the slider (1) above the timeline. You can 

also enter values in the boxes on either side of the slider. 
• To play, pause, and stop playback and to navigate to the start, end, or next keyframe, 

use the Playback Controls (6). 
• To store the transformation values for the current frame, set a keyframe (2). 
• To show only animations that are currently loaded in the Curve Editor, click  Toggle 

Curve Editor Animations (3). 
• To customize how the Timeline works, click  Preferences. 



About the Timeline 
Animation > Timeline 

 

1. Sets the slider to the end frame. 

2. Sets the slider to the next keyframe. A keyframe represents a saved state of attributes at a 
specific time. Keyframes are the basis for non-linear animations in VRED. 

3. Plays the animation. 

4. Stops the animation. 

5. Plays the animation backwards. 

6. Moves the slider to the previous keyframe. 

7. Moves the slider to the starting frame. 

8. Displays the current frame number. Click it to enter a frame number. 

9. Visually represents of the animation frames. 

10. Sets the starting frame of the full timeline range. 

11. Sets the starting frame of a specific playback range. 

12. Sets a specific playback range. 

13. Sets the end value for a specific playback range. 

14. Sets the end frame of the full timeline range. 

15. Sets a keyframe for the selected object and all its animated attributes. This has the same 
effect as Key All Channels in the Curve Editor. 



16. Toggles activation of the local evaluation of the shown curves in the Curve Editor, instead of 
all active animation in the scene. 

17. Closes the Timeline. 

18. Opens the Preferences Animation tab. 



Collaboration 



Collaboration 
Find safety information and requirements for setting up a VRED collaboration session. 

VRED provides an out-of-the-box collaboration solution for both desktop and VR users alike. 
Use it for showing work to a group in VR. Participants can join a collaboration session from their 
desktop or using HMDs. To see what is needed for a collaboration session, see What's Needed 
for a Collaboration Session. 

IMPORTANT The Collaboration tool is only available in Autodesk VRED 2019.2 Design and 
Professional. The VRED Cluster Service is required and acts as an exchange server to 
synchronize the participants and scene changes. 

Workstations with both VRED Pro and Design installed cannot be the host of a collaboration 
session. Here is a workaround for this issue: 

1. Only install either VREDPro or VRED Design on the PC. 
2. Adjust the firewall rule. 
3. Manually call VREDClusterService -e -c once. 

What's Needed for a Collaboration Session 

When participating in a collaboration session, there are things to consider, such as whether you 
will participate from your desktop or through VR. Let's look at what you will need: 

Connections Requirements 

• Network connection - To access the collaboration session and VRED file. 
• Internet connection - To send/receive invites. 

Hardware Requirements 

• VRED system requirements - To guarantee your machine meets the VRED 
requirements, as well as the additional VR specific requirements. This ensures that your 
graphics card and GPU meet the demands of the content. 

• VR Devices - See Supported VR Devices. 

NOTE At present, only the HTC Vive and Oculus support the Collaboration tool's VR 
Room configurations. All other devices should only be used for testing purposes. See 
Correctly Setting Up the Tracking System for more information. 

• Audio - To minimize outside noise and potential disruptions, we recommend a noise-
cancelling mic and headphones. 

https://knowledge.autodesk.com/support/vred-products/troubleshooting/caas/sfdcarticles/sfdcarticles/System-requirements-for-Autodesk-VRED-products.html
https://knowledge.autodesk.com/support/vred-products/troubleshooting/caas/sfdcarticles/sfdcarticles/System-requirements-for-Autodesk-VRED-products.html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VR_and_VR_Setup_VR_Requirements_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VR-Requirements#supported-vr-devices
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Setting-Up-a-VR-Room#correctly-setting-up-the-tracking-system


Software Requirements 

The VRED collaboration session is designed to work side-by-side with your current, audio 
conferencing, email, and calendar apps. These are needed, as they are not included as part of 
VRED. 

• Matching version of VRED - To participate, all participants must use the same version of 
VRED. This is defined by the first session participant. 

• Calendar application - To send/receive meeting invites. 
• Email application - To send/receive invites. 
• Audio application - To communicate with others. The session leader will set this up 

using a service, such as Zoom, Skype, or Mumble. 

Collaborative Sessions 

You will find information on what desktop and VR participants should expect and require, how 
scenes work in a collaboration session, and room calibration. 

Collaboration Participants 

There are two kinds of collaboration session participants: 

Desktop Participants 

Desktop participants have full control over a scene. They can switch 
Variants Sets, trigger animations, and transform parts of the scene, as 
well as navigate within it. In a session, desktop participants appear as a 
tablet. 

 

VR Participants 

VR participants have full control over the scene. They can switch 
Variants Sets and trigger animations within the scene and navigate via 
the teleporter. In a session, VR participants appear as a robotic 
humanoid. 

Please refer to VR Room Setup to ensure everything is set up correctly 
for the best and safest experience. 

 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Interacting-Within-a-1#how-to-access-variant-sets
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Interacting-Within-a-1#how-to-access-variant-sets
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VR_and_VR_Setup_Teleporting_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Collaboration_Setting_Up_a_VR_Room_html


How Scenes Work in Collaboration 

Since things work a bit differently in a collaboration session, it is important to understand how 
scenes work. 

Participants can trigger things like Variant Sets and animation. When this happens, VRED 
uploads only these actions to participants, not the entire scene. It only syncs the changed 
information. This is why we stress that all participants use the same scene file during the 
collaboration session. This guarantees everyone sees the same thing. Participants not using the 
same scene will experience issues with information syncing, resulting in errors and not seeing 
changes. 

There are limitations to the information synced. Though Variant Sets, animations, and 
transformations are synced, new geometry added to the scene is not. However, if participants 
upload the scene after changes have been made, even newly created geometry, variants, 
variant sets, and animation are synced. 

Where to Go from Here 

Though there is nothing that needs to be done before starting a VRED collaboration sessions, 
here are some suggestions: 

• Customize your Collaboration and Virtual Reality preferences 
• Review VR room setup if working with multiple people in the same real-world space 
• Check out the functionality in the Collaboration module 
• Set up a collaboration session 
• For VR users, learn about your controller, how to get around in your scene, and how to 

access tools 
• Add custom controls to the Tools Menu 
• Review safety information and requirements 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Preferences_Collaboration_Preferences_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Preferences_Virtual_Reality_Preferences_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Collaboration_Setting_Up_a_VR_Room_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Collaboration_About_the_Collaboration_Module_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Collaboration_Setting_Up_a_Collaboration_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VR_and_VR_Setup_Using_Controllers_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VR_and_VR_Setup_Teleporting_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VR_and_VR_Setup_Tools_Menu_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VR_and_VR_Setup_Tools_Menu_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=Tools-Menu#can-i-add-functionality-to-the-tools-menu-
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VR_and_VR_Setup_Tools_Menu_html
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Setting Up a VR Room 
Suggestions for how to best set up a VR room for VRED. 

When using VR, the VR room setup must be done correctly, as it is critical for your enjoyment 
and safety. We will go through the requirements, understanding the Room feature and safety 
twins, tracking system recommendations, and finish off with sound. 

VR Room Requirements 

When using VRED for your VR experience, we require the following: 

• The use of multiple HTC Vives or Oculus (via OpenVR) (see Correctly Setting Up the 
Tracking System for more information) 

• A correctly calibrated and aligned room configuration for every VR PC in the room 
• The correct VRED room names entered in the Collaboration module 

NOTE We also recommend you review the VR Requirements. 

Setting the Room Parameter 

The Room parameter, found in the Collaboration module, is used to let VRED know which VR 
participants are in the same real-world space. The room name for these participants must 
match exactly, this includes capitalization, spaces, and any punctuations. VRED takes the Room 
parameter, syncs and represents the participants within the tracked space, and uses this 
information for their safety twin. 

TIP To set a default room location, see Collaboration Preferences. 

Correctly Setting Up the Tracking System 

There are a number of things, such as device tracking precision and calibration, along with the 
syncing calibration of all devices inside the VR room and number of people inside the tracking 
area, that heavily influence tracking system accuracy during a VR experience. Let's take a look 
at these. 

Room-scale Calibration 

Since the precision of the room-scale calibration affects the accuracy of the experience, room-
scale tracking must be setup correctly and match each of the HMD PCs. Calibration errors could 
result in avatars and safety twins appearing in the wrong location, general confusion, and risk of 
collision. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VR-Requirements#vr-safety
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Tracking System Precision 

Since VR devices have their own unique tracking system, these tracking systems can differ in 
precision. We have gotten the best precision with Vive and Oculus (via OpenVR). We have 
found that when using other systems, the safety twin accuracy was unreliable. Therefore, at the 
moment, based on the test results below, we feel these should be avoided for VR room 
scenarios. 

Device 
High Precision 

Alignment Error  
<20 cm 

Medium Precision 
Alignment Error  

<40 cm 

Low Precision 
Alignment Error  

<200 cm 

HTC Vive X   

Oculus Rift (via OpenVR) X   

Oculus Rift   X 

Windows Mixed Reality 
(via OpenVR)  X  

NOTE Currently, we have no test results for StarVR or VRHero/VRgineers XTAL in VR room 
setups. 

Tracking System Interference 

Tracking system interference can occur whenever many participants are within the same 
tracked area. This can result in controller and VR hand interference, as well as avatars visually 
snapping or drifting during a session. 

Using the Same Type of Device 

The VR Room parameter only supports rooms using the same VR devices. This is because with 
different VR devices, you get different tracking systems, which are a problem. So, if VR Room A 
is using 3 Oculus Rifts and VR Room B is using a Vive and Vive Pro, each room will be successful. 
However, if VR Room C has a mix of devices, such as an Oculus and a Vive, the VR Room feature 
will fail. 

Dealing with Sound 

When VR room participants connect with remote participants, issues can arise with sound. 
Therefore, for HMD participants, we recommend noise-canceling headphones. They prevent 
hearing real-world voices over those in the session. You will be able to communicate with 



others and not be distracted by outside noise. Any sound distortion caused by voices coming 
from multiple places will be avoided, as well as any lag in audio. 

Understanding the Safety Twin 

When multiple participants are in the same real-world space, without some type 
of safety mechanism in place, collisions can occur. In VRED, we added the safety 
twin to provide a visual cue to keep you safe and help avoid collisions. 

Safety twins are the aqua grid mesh avatars that aligns with the actual avatar as 
participants enter the room. 

 

They represent the participants' location in the real-world VR room. As participants move away 
from one another, the safety twins fade, until they disappear. 

 

NOTE Only VR participants within the same VR room can see the safety twins. They are hidden 
from other participants. 

When teleporting to a new location, your actual avatar moves to the virtual location and the 
safety twin remains at its physical location. In the following example, the participant teleported 
a very short distance. 

 



IMPORTANT Since the safety twin is not displayed when raytracing, we do NOT recommend 
using Raytracing when in a session with VR participants in the same real-world space. 

Safety twin positions are representative, not exactly accurate. Since accuracy greatly relies on a 
correct tracking system setup, we have added a tracking systems section, to help with this. 

Adding a Custom Avatar 

Here are some guidelines for adding a custom avatar into your VRED collaboration session: 

Avatar Body Part Names 

Here are the filenames for the avatar body parts. 

Part Filename 

Head Head.osb 

Torso Torso.osb 

Billboard Billboard.osb 

Left hand L_hand_baked.osb 

Right hand R_hand_baked.osb 

Tablet Tablet.osb 

These files are loaded from C:\\ProgramData\\Autodesk\\VREDPro-
nn.nn\\Data\\Internal\\VR\\Avatar to create avatars and safety twins. 

In general, the structure of the original VRED shipped OSB files must be kept, as some nodes 
must not be deleted nor renamed. 

In the following we list the guidelines for materials and geometry. 

Guidelines for Materials 

At the start of a VR session, each participant is automatically assigned a color. This color can be 
changed, during the session, with the Collaboration module's Color option. This color is applied 
to avatar parts with the colored\_part\_mtl material. 



 

NOTE The colored\_part\_mtl material type must be plastic or reflective plastic and applies 
to all .osb parts, with the exception of Billboard.osb. 

Guidelines for Geometry 

NOTE Do NOT change the following node names. 

Part Node Names to Keep Note 

Hand R_HandOpen L_HandOpen 

This is the default hand pose (or gesture) for the 
avatar's hand. It is used when no controller buttons 
are pressed. It is also the only pose for the safety 
twin. This is one of the poses underneath 
gesture_switch. 

Hand 
R_hand_transformation 
L_hand_transformation 

Each of these has two transformation variants: 
Oculus and OpenVR VRED. These set the OpenVR 
variant (i.e., the 2nd one) when loading the hand. 

Hand gesture_switch 

Switch node containing these poses: picking, 
pointing, thumb-up, fist, and open hand. This must 
be named R_HandOpen for the right hand and 
L_HandOpen for the left. 

The Torso 

Note that the default torso file shipped with VRED 2019.2 has a translation of Y = -275. This 
positions the torso in a plausible way below the head. 

 

The Hands 

The default avatar hand design shipped with VRED 2019.2 mimics that of normal hands. 



Note that for avatar hands: 

• no environment variable is considered 
• no skinning is applied 
• no hit visualization is built nor needed 

Summary 

VRED assumes these avatar properties: 

Avatar height: 1.75 m 

Part Filename 
Material for the 

Unique Color 
Orientation Note 

Head Head.osb Colored_part_mtl Looks toward-Z. 
Use Plastic or Reflective 
Plastic for the colored 
parts. 

Torso Torso.osb colored_part-mtl 
Looks toward -Z. 
Translated by (0,-

275,0)wrt. the head. 

Use Plastic or Reflective 
Plastic for the colored 
parts. 

Billboard Billboard.osb n/a 
Looks toward -Z. 

Centered in the origin. 

Must be made of Plastic 
material. The color 
stripe at the top is 
rendered as a 2D 
rectangle. 

Left 
hand 

L_hand_baked.osb colored_part_mtl 
The origin is in the base 

of the wrist. 

Must have these nodes: 
L_hand_transformation, 
gesture_switch, 
L_HandOpen. 

Right 
hand 

R_hand_baked.osb colored_part_mtl 
The origin is in the base 

of the wrist. 

Must have these nodes: 
R_hand_transformation, 
gesture_switch, 
R_HandOpen. 

Tablet Tablet.osb colored_part_mtl 

Must have these nodes: 
R_hand_transformation, 

gesture_switch, 
R_HandOpen. 

 



About the Collaboration Module 
Learn about the 
settings and things 
displayed in the 
Collaboration 
module. 

Interaction > 
Collaboration 

 

 

 

 

The Collaboration module has two sides, along with an Icon Bar and Menu Bar. The left displays 
the names of all session participants, along with the model of VRED used, and room location. 
The right displays options for profile information, creating, joining, leaving, and ending a 
session, and model management. 

NOTE Use the Collaboration preferences to set these ahead of time. 

Menu Bar 

The Collaboration module contains one menu, the File menu. Use it to load, view, or save a 
session. 

File Menu 

Find options for creating, loading, and saving sessions. 

• New - Use to create a session. 
• Load Session - Use to load a previously saved collaboration config (.vrs) file. 
• Save Session - Use to save the current session as a collaboration config (.vrs) file. 
• Save Session As - Use to assign a different name to the current session and save it as a 

collaboration config (.vrs) file. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Preferences_Collaboration_Preferences_html


Participant Information 

This pane lists all participants who have joined the session. It also indicates whether they have 
loaded the model. If a room location is supplied, it is also listed here, indicating the VR room(s) 
used in the session. 

 

• Participants - Participants who have joined a session are listed by name and color. To 
modify these settings, see Collaboration preferences. 

• Model - When a participant joins a session and has loaded a model, its information 
appears next to their name. If  is displayed, the wrong model is loaded and you need 
to update your model. 

IMPORTANT All participants must load the same file to ensure everyone sees the same 
thing during the session. 

• Room - Displays the name of the real-world VR room. To have the room name 
automatically filled in, see Collaboration preferences. 

Session Information 

This pane contains three sections dealing with profile, session, and model management 
information. 

 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Preferences_Collaboration_Preferences_html
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My Profile 

Enter information for setting up your profile. 

NOTE Use the Collaboration preferences to set these ahead of time. 

• Name - Enter the name displayed in the Participant List and above your avatar. By 
default, your PC login is used. 

• Room - (Only for participants using HMDs) Enter the name of the VR room you are in. 
This let VRED know where you are in the same real-world space to avoid collisions. 

NOTE For HMD users, all PCs in the same real-world space MUST set the same Room 
name. This tells VRED to enable safety mechanisms for these PCs to help avoid 
collisions. See this section for how to set up a room. 

• Color - Select a color from the drop-down menu. This will be used in the Participant List 
and for your desktop or VR 3D avatar. 

 

Session 

Enter information for setting up a collaboration session. 

• Address - Enter an IP address or PC name for the server hosting the session. Use the 
Collaboration preferences to set this ahead of time. 

IMPORTANT This machine needs to be on the same network as the Cluster Service 
server to host. Ensure all participants can reach this server. 

For invitees, if you have received a session address, paste it here to join a session. 

o Secure - Opens the Create Secure Session ID dialog for entering a server IP and 
optional password to protect the session. 

o Delete - Deletes the address currently displayed. 
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• Invitation - Select an invitation option from the drop-down menu to choose the type of 
session invitation sent to participants. 

 

o Calendar - Opens a meeting in your default Windows calendar application with a 
VRED session file attachment. 

o Email - Opens an email in your default Windows email application with a VRED 
session file attachment. 

o Text - Opens a text dialog. Click Copy to Clipboard, then paste the content into a 
text app, such as Slack. 
 

• Invite - Click create an invitation for this collaboration session. For meeting and email 
invitation, a VRED session file is attached. See Setting Up a Collaboration Session for 
instructions of replacing the ORGANIZER-TO-ADD content. 

• Join - Click to join a collaboration session. 

NOTE To join a session, you must have the same version of VRED as the session leader. 
The first participant to enter a session defines the VRED version for the session. 

NOTE If your version of VRED doesn't match, you can leave the session, update your 
version, then return to the session or if all participants are in agreement, start a new 
session. See End for all for more information. 

• Leave - Click to leave the session. The session will continue until all participants have left 
the session. 

As a participant, you might select this when running a version of VRED different from 
the session leaders. If you update your version, do NOT uninstall your current version. 

• End for all - Click when the session needs to be cancelled for everyone. 

You might select this if most participants aren't using the same version of VRED as the 
session leader. The first participant to start the new session sets the version of VRED 
used. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Collaboration_Setting_Up_a_Collaboration_html


Model Management 

Join a session, then use Model Management to push the session scene to participants. Use 
these tools to help send and upload scenes to all participants. 

IMPORTANT  Since large files can take a while for participants to download and this action 
cannot be undone, we recommend you ask participants, in the invite, to leave enough time 
before the meeting to download the file. 

• Send - Click and select one of the following options: 
 

o Current Scene to All - Send the opened scene to all participants. 
o Shared Network Scene to All - Send the path of a scene on the network drive to 

all participants. Ensure they can access the network. 
 

• Upload - Upload the session scene from the session leader. If a participant joins a 
session after this upload has been initiated, they are asked if they want to download the 
scene. If they agree, they receive the download. 

Audio 

Join a session, then use the Audio parameters to control sound within a Collaboration session. 

• Enable - Enable or disable sound within a session. When enabled, others audio 
parameters are accessible. 

• Speaker - Control the volume level of the speaker. 
• Microphone - Control the volume level of the microphone. 
• 3D Audio - Enable or disable the use of spatial audio. When someone speaks, the sound 

will come from the position of participant in the virtual world. 

Disabling Audio for a Collaboration Session 

To disable the audio for a session, set the environment variable 
VRED_COLLABORATION_NO_AUDIO. This feature disables it in the session. 

Icon Bar 

The Icon Bar at the bottom of the module contains the following tools: 

 Join/Leave - Click to quickly join or leave a session. 



 Spectator Mode - For desktop users, tap to see the viewpoint of the selected participant. 
While in this state, you cannot navigate within the view, as you are seeing the content through 
the eye of the other user. Tap the icon again to return to your view and take control. 

 Pointer - For desktop users, tap to enable or disable the Share Pointer to interact with VR 
participants within the scene. It is visible to all participants. 

• Press Shift to change your cursor to a cross-hair to mark where your laser will hit. 
• Shift-click for the cross-hair cursor and to fire your laser. 



Setting Up a Collaboration Session 
Learn how to set up a collaboration session and what is needed for it in VRED. 

Interaction > Collaboration 

As the session leader, in the invite template, there are areas marked as ORGANIZE-TO-ADD. You 
will need this information to fill these values in. 

• VRED session address - Provide the IP address for the session or PC name. 
• Audio - Provide a link to the audio for the meeting. 
• Model location - Provide a location on the network for the model that all participants 

can access. We recommend you add the file size to help users estimate how long it will 
take to load the file. 

• Version number - Indicate which version of VRED will be used for the session. When 
possible, provide a link to the version that all participants can access, since users need 
to run the same version to access the session. We also recommend you add the file size 
to help users estimate how long it will take to load the file. 

• Password - States whether a password is required or not. 

TIP For collaboration session beginners, we recommend you send this link for How to join a 
session. 

How to Set Up a Session 

1. In VRED, open the scene you want to use for the collaboration session. 
2. In the Menu Bar, select Interaction > Collaboration. 
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3. In the Collaboration module, set the fields in the My Profile and Session sections. 

TIP Set up your Collaboration preferences to automatically populate the My Profile and 
Address fields. 

NOTE If you encounter a Session Server connection error, ensure Address is set to your 
IP address or PC name and that cluster services are activated (Windows Start menu > 
Autodesk VREDPro 2019.2 > Activate Cluster Service). 

4. Click Join. This adds you to the Participants List and starts a session. 
5. Under Session, select one of the following options from the Invitation drop-down. 

 

o Calendar - Opens a meeting in your default Windows calendar application with a 
VRED session file attachment. 

o Email - Opens an email in your default Windows email application with a VRED 
session file attachment. 

o Text - Opens a text dialog. Click Copy to Clipboard, then paste the content into a 
text app, such as Slack. 
 

6. Click Invite to generate a meeting request or email with a VRED session file attachment. 
7. In the invitation, add participants and links for the audio, model location, and VRED 

build, then send it. 

What does Model Management do? 

Once you joined a session, use Model Management to push the session scene to participants. 
Since large files can take a while for participants to download and this action cannot be undone, 
we recommend you ask participants, in the invite, to leave enough time before the meeting to 
download the file. 

How to Send a Scene 

1. Select an option in from the Send drop-down menu. 
 

o To send the current scene, select Current Scene to All. 

o To send a scene on the network, select Shared Network Scene to All, click , 
then locate the scene. 

2. Click Upload and OK. This sends the scene or file path to the other participants. 

http://help.autodesk.com/cloudhelp/2019/ENU/VRED/files/Preferences/Collaboration-Preferences.HTML


Joining a Collaboration Session 
Learn how to join a VRED collaboration session, load a scene, and what might be needed to 
join. 

Before joining a collaboration session, we recommend you have the correct version of VRED 
installed and have saved your scene. It is also good practice to download the scene ahead of 
time, since large scenes can take a while, depending on your connection. But to start, you need 
an invite. 

About a Collaboration Invite 

When someone has invited you to a collaboration session, you will receive notice. It could be an 
email, text, or meeting request. Email and meeting invites may include a VRED-Collaboration 
.vrs attachment. 

NOTE If the file is blocked and no longer attached, copy the 
Session Address and paste it into the Collaboration module's 
Address field. 
 

Here is an example of a meeting request. 

 



At the top of the invite is the name of the session leader. Below that, you will find the following: 

• Join VRED Session - Displays the session IP or PC name. 
• Join Audio - Provides a link to the audio for this meeting. 
• Model Location - Provides a link to the VRED scene (.vpb file). 

NOTE We recommend you load the model before the start of the collaboration session, 
as it can take a while, depending on the size of the file and other factors. 

• VRED Version - Displays the VRED version needed for this session. 
• Password - States whether a password is required or not. 

What is Needed to Join a Session 

Before beginning a collaboration session, let's look at what you need. 

• Windows machine 
• Internet connection 
• Access to the model/scene file 
• VRED installed 

An HMD is recommended, but not required. VRED has a desktop mode, where you can see, 
move around, and interact with things in the scene. You can even see what another participant 
using an HMD sees. For more information, see Spectator Mode. 

What if I'm Running a Different Version of VRED 

If you have a different version, VRED will notify you. Here is what you can do: 

• Click the End for all button and quit the session for everyone. Only do this if most 
participants aren't using the same version of VRED and there is agreement among all the 
participants. 

• Install the required session version. 

IMPORTANT If working with a production setting, if you need to load a different version 
of VRED for a session, do NOT uninstall your current project version. 

• Click the Leave button and exit the session. 

 

http://help.autodesk.com/cloudhelp/2019/ENU/VRED/files/Collaboration/About-the-Collaboration-Module.HTML#icon-bar


How to Join a Session 

Once you have the correct version of VRED running, do the following: 

1. In the invite, click the Join Audio link to connect to the audio portion of the session. 
2. If you received an email or meeting invite and there was a VRED-Collaboration.vrs 

attachment, click to open it and launch VRED. 

NOTE If the file is blocked and no longer attached, copy the Session Address and paste it 
into the Collaboration module's Address field. 

 

3. In the Collaboration dialog that appears, if you haven't set up your preferences, enter 
the My Profile fields. 

4. In the Session section, click Join to join the collaboration session. Your name will appear 
to the left in the Participants list. 

How do I Load the Session Scene? 

The session leader can provide a link to the session scene in the invite, as well as push it to all 
participants for download, during a session. 

How to Load a Scene from an Invite 

An invitation can have either a link to the scene file or a server location. 

• If there is a link, click it. If it doesn't automatically load in VRED, save it, then select File > 
Open, locate the file, and click Open. 

• If there is a server location, navigate to the file, then drag and drop it into the Render 
Window. 

How to Accept a Pushed Scene 

If a scene has been pushed during a collaboration session, VRED prompts you to do one of the 
following: 

• Click OK to destroy (not save) your current loaded scene and replace it with the session 
scene. 

http://help.autodesk.com/cloudhelp/2019/ENU/VRED/files/Preferences/Collaboration-Preferences.HTML#how-to-set-collaboration-preferences


• Click Cancel to join the session and not replace the scene. This will result in having the 
wrong scene loaded. In the Collaboration module, under Model,  will appear next to 
your name. However, now you can save your scene, exit the session, rejoin it, and load 
the pushed scene. 

NOTE During download, you can abort the downloading process. 

 

With your name listed in the Participants list, audio connected, and correct the scene and 
version of VRED loaded, you are now ready to begin the collaboration session. 

If you want to join the collaboration session in VR, in the menu bar, select View > Display and 
select your HMD from the list. For more information, see Using Controllers. 

http://help.autodesk.com/cloudhelp/2019/ENU/VRED/files/VR-and-VR-Setup/Using-Controllers.HTML


Interacting Within a Collaboration Session for 
Desktop Users 
Learn what can be done in a VRED collaboration session. 

There are two kinds of collaboration session participants, desktop and HMD users. This article 
covers the instructions for how to do things as a desktop user. For HMD users, see Interacting 
Within a Collaboration Session for HMD Users. 

How to Get Around in a Scene 

Use the same methods you always do for navigating around a scene when in a collaboration 
session. 

How to Use the Pointer 

1. Click  to activate the pointer. 
 

o To change your cursor to a cross-hair to line up your laser, press Shift. 
o To line it up and fire, Shift-click and hold. 

 
2. Press  again to deactivate the pointer. 

How to Change the Viewpoint 

If viewpoints are set up for a scene, they are accessible through the Simple UI's Scene module. 

NOTE When you change the viewpoint, it only affects you. 

1. In the main toolbar, click Simple UI, then select Scene > Camera to access the viewpoints 
in the Scene module's Camera tab. 

http://help.autodesk.com/cloudhelp/2019/ENU/VRED/files/Collaboration/Interacting-Within-a.HTML
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2. Click a viewpoint to change your view. 

How to Access Variant Sets 

If variant sets (VSets) are set up for a scene, they are accessible through the Simple UI's Variant 
Sets module. 

1. In the main toolbar, click Simple UI to access the Variant Sets (VSets) module. 

 

2. Click a variant set to change something in the scene. 



How to See Through Another Participant's Eyes 

To see what another participant is seeing, click  to activate it, then select a participant from 
the Participants List in the Collaboration module. 

NOTE While in Spectator mode, you cannot change the viewpoint. To regain control, deactivate 

. 

How to Leave and Rejoin a Session 

In the Collaboration module, click  to leave a session. Click it again to rejoin the session. If 
the scene has been updated, you will be notified. 



Interacting Within a Collaboration Session for 
HMD Users 
There are two kinds of collaboration session participants, desktop and HMD users. This article 
covers the instructions for how to do things as an HMD user. For desktop users, see Interacting 
Within a Collaboration Session for Desktop Users. 

How to Get Around in a Scene 

Use Teleport to get around in a scene. Click the following links for: 

How to teleport 

• How to teleport inside a vehicle 
• How to change direction 
• How to change the teleport range 
• How to calibrate the ground level 

How to Switch Between Hands and Controllers 

There are two ways to switch between displaying hands and controllers. With both, to return to 
the other state, repeat the action. 

• Click the Controller/Hand button from the Tools Menu. 
• Align the top of the controllers, bringing them together. 

 

NOTE When using the controllers, tooltips appear to show which functions are controlled by 
which control. 
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What if I'm Left-handed 

The controllers are mapped in such a way that both left- and right-handed users can use them. 

The controller used to open the Tools Menu automatically becomes the non-dominant hand 
controller. Therefore, if you are left-handed, you want to open the Tools Menu with the 
controller in your right hand. 

Using Hand Poses 

Hand poses are used to communicate visually. Click the Hand Poses Only button to enable it. 
Now you can make a thumbs up, thumbs down, pointing, open hand, or a fist (closed hand) to 
indicate liking, agreeing, etc. See VR Hand Gestures for more information. 

How to Use the Pointer 

Line up your hand or controller with the content you want to draw attention to and squeeze 
the trigger to fire your laser pointer. 

Pointer Display 

1. Press Tools Menu on your controller. 
2. In the Tools Menu, do the following: 

o For other participants to see your pointer and draw their attention to something, 
enable Share Pointer. 

o When engaging with touch sensors and not wanting to draw attention, disable 
Share Pointer. This way, the pointer is only visible to you. 

How to Return to the Pointer 

To return to using the pointer after hand poses, deactivate Hand Poses Only. 

How to Calibrate the Ground Level 
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1. In the Tools Menu, enable Teleport Ground. 
2. Press Calibrate Ground. A green plane appears to represent the new ground plane. 

 

3. Move the green plane to where the ground place should be. 
4. Pull the trigger to select that spot and reset the ground plane. 

 

How to Change the Viewpoint 

If viewpoints are set up for a scene, they are accessible through the Tools Menu. 

NOTE When you change the viewpoint, it only affects you. 

How to Access Variant Sets 

If variant sets (VSets) are set up for a scene, they are accessible through the Variant Sets option 
in the Tools Menu. 

1. Use the Tools Menu on your controller to access the Tools Menu home page. 

 



2. Click Variant Sets to open the Variant Sets panel. 
3. Click a variant set to change something in the scene. 

 

How the Safety Twin Works 

When multiple participants are in the same real-world space, without some type of safety 
mechanism in place, collisions can occur. In VRED, we added the safety twin to provide a visual 
cue to keep you safe and help avoid collisions. 

When a blue grid mesh appears (the safety twin), that indicated another participant is nearby. 

 

As they move closer, the mesh of the safety twin begins to fade, becoming increasingly 
transparent. 



 

If the safety twin becomes completely transparent, that participant is dangerously close. 

 

How to Leave and Rejoin a Session 

There is no button in VR to leave a session. If you take off your headset, in the Collaboration 

module, click  to leave the session. Click it again to rejoin the session, then put on your 
headset. If the scene has been updated, you will be notified. 



Scene Interaction 



Connecting VRED Instances 
VRED instances can be synchronized for navigation, including on independent computers. You 
can load the same scene on all instances and control the navigation on all connected client 
machines with one instance. Besides navigation, python commands are synchronized, and you 
can optionally synchronize variants, the camera, field of view, and transformations. 

About the Connector 

The Connector contains a Settings 
menu for saving settings. It also 
has two sections. The Connect To 
section contains options for 
setting the server and port, as 
well as buttons for connecting to 
and disconnecting the server. The 
Server section contains options 
for setting the port and turning 
on frame sync, as well as buttons 
to start and stop the server. 
Within the Server section is the 
Synchronize Options. Use them to 
synchronize variants, the camera, 
field of view, and 
transformations. 

 

 

How to Connect to Another VRED Instance 

1. Select Interaction > Connector. 
2. In the Connect To section, enter the server IP and port number of the instance you want 

to connect to.  
If the instance is on the local machine, enter localhost as the Server IP. 

3. Click Connect. 
If you have connection problems, ensure there is no firewall present and the server and 
IP are correct. 

4. When finished, click Disconnect to close the connection. 



How to Take Control of a Connection 

When your VRED instance is being controlled from another instance, you can take over the 
connection. 

1. Select Interaction > Connector. 
2. Under Connect To, click Take Over Control. 

This requests control of the current session. A dialog on the controlling machine asks to 
grant control. 

3. When finished, click Disconnect to close the connection. 

How to Host a Connection 

You can set up your VRED instance, so others can connect to it. You control the connection; for 
example, to demonstrate a scene. 

1. Make a note of your computer's IP address. 
2. Select Interaction > Connector. 
3. Under Server, ender a port number to use. 
4. Optional: Select Frame Sync to synchronize the Render Window refresh rate for all 

conference participants. 

The frame rate of the slowest connected computer will be used. 

5. Under Synchronize Options, select which elements of your scene you want to 
synchronize with viewers. 

For remote connections, you may want to synchronize everything and have viewers see 
what you are seeing. For local, side-by-side connections, you might not want to 
synchronize everything. This makes it possible to compare alternative versions of a 
scene. For example, you might choose not to synchronize variants, so the main display 
shows them, while the adjacent display does not. 

6. Click Start. 
7. Provide your IP and port numbers to anyone who wants to connect to your instance. 
8. When finished, click Stop to close the connection. 



Using Annotations 
Interaction > Annotation 

Place text annotations (or notes) into the scene. Annotations are saved within a VRED-project 
file or they can be saved as an XML file for further processing in other applications. Most tasks 
related to annotations are done using the Annotation module. 

About the Annotation Module 

The Annotation module has a Search field, List View, Description, Properties, and Size and 
Position sections, and Icon Bar. 

 

How to Create an Annotation 

To create an annotation: 

1. In the Annotation module, click Create . 
2. Shift-click to select a location in the scene for the annotation. 
3. Enter the annotation text in the Description section. Use the search field to find 

annotations by this name. 



4. Under Properties, adjust the font, line, and background color, as well as background 
transparency. 
 

o Name identifies an annotation when using Python. 
o Node identifies the Scene Graph node associated with the annotation. When 

selecting the position of an annotation, the selected geometry becomes the 
associated Scene Graph node. Another node can be dragged from the Scene 
Graph onto the Node field to assign it to the annotation. 

o Use Node Visibility uses the visible state of the node associated with the 
annotation. If the node is invisible, so is the annotation. If the annotation has no 
node association, Use Node Visibility has no effect. 
 

5. Under Size and Position, adjust the position and size of the annotation. 

Dynamic Scaling enables size variation of labels, based on their depth within the Render 
Window; for example, the label of an object that appears closer in the Render Window 
has a bigger label than an object that is farther back. There are three scaling options: 

o Near labels are smaller; appropriate when working close to the screen. 
o Far labels are larger; appropriate when working further away from the computer 

screen; for example, when sharing a presentation with others. 
o Off labels are larger, with all labels the same size. 

Both the Size and Dynamic Scaling controls affect size. Use them in combination to find 
an agreeable size. 

How to Change the Position of an Annotation 

To change the position of an annotation: 

1. Select an annotation from the List View. 
2. Click Reposition . 
3. Shift-click to select a location in the scene for the annotation. 

How to Remove Annotations 

To remove an annotation: 

1. Select an annotation from the List View. 

2. Click Delete . 

 



To remove all or a range of annotations: 

1. Select the first annotation in the List View, then Shift-click the last. Also try Ctrl-click to 
select specific annotations. 

2. Click Delete. 

How to Zoom into an Annotation 

1. In the List View, right-click an annotation you want to zoom into. 
2. Select Zoom To from the context menu. 

How to Save or Load a List of Annotations 

Save the current list of annotations to an XML file, so they can be loaded into the scene later. 

1. Right-click in the List View. 
2. Select Save Annotations to save them to an XML file or Load Annotations to load them 

into the scene. 

How to Show or Hide Annotations 

Click Show Annotations  to view of all annotations. Click the check box next to any 
annotation in the List View to hide its display. 

How to Duplicate Annotations 

Click Duplicate  to duplicate all highlighted annotations. 

How to Select Nodes 

Click Select Nodes  to select nodes in the Scene Graph associated with selected 
annotations. 

NOTE In .vpb files created before VRED 2018.2, annotations names are created from the 
associated node. When there are multiple nodes with the same name, the first found 
occurrence is used; for example, Sphere, Sphere1, Sphere2. 



Using the Clipping Plane 
Interaction > Clipping 

Use the clipping plane to hide parts of the scene on one side of a plane. This is useful for 
construction evaluation purposes. 

About the Clipping Module 

The Clipping module contains three 
sections, Clipping Plane for making 
changes to the positioning of the 
clipping plane, Visualization for 
changing the look of the clipping plane, 
and Genuine Clipping for setting a 
clipping plane path. 

 

 

 

 

 

 

 

 

 

 

 

 



How to Enable the Clipping Plane 

1. Select Interaction > Clipping to open the Clipping module. 
2. Select Enable Clipping. 

How to Position the Clipping Plane 

1. In the Clipping module, click Pick, then Shift-click the point in the scene where you want 
the clipping plane. 

2. Adjust the position of the plane by doing any of the following: 
 

o Use the Position X/Y/Z controls. Either enter numbers directly into the fields or 
drag the Position X/Y/Z scrollbars . 

o Click Center to move the clipping plane into the center of the screen. 
o Click Align to align the clipping plane parallel to the current active camera. 
o Click Toggle X, Y, or Z to position the plane along an axis. 
o Use the Direction X/Y/Z controls to adjust the plane's direction. Either enter 

numbers directly into the fields or drag the Direction X/Y/Z scrollbars . 
o Enable Invert Direction to invert the direction of the plane, making the opposite 

side of the scene visible. 
o Click Align to align the clipping plane parallel to the current active camera. 
o Hold down Shift and drag the manipulator handles to adjust the position, using a 

mouse. 

How to Change Clipping Plane Appearance 

From the Clipping module, use the controls under Visualization to change how the clipping 
plane looks. 

• Show Clipping Plane - Enable to show the plane or disable to hide it. 
• Plane Color - Set the color of the clipping plane. You can keep the grid visible, while 

hiding the plane. 
• Show Grid - Enable to show the grid or disable to hide it. 
• Grid Color - Set the color of the grid. You can keep the clipping plane visible, while 

hiding the grid. 
• Show Contour - Enable to show the line around the part of the object clipped by the 

plane or disable to hide it. 
• Contour Width - Set the thickness of the contour line. 
• Clone Contour - Click Clone, then Shift-click the contour line to clone it. Once the 

clipping plane is translated, the clone will be visible. 



How to Hide Everything in the Scene Except the Clipping Plane 

Select Hide Scene. 

How to Align the Camera Parallel to the Clipping Plane 

In the Clipping module, under Visualization, enable Show Clipping Plane. This is the inverse of 
Align, which positions the plane relative to the camera. 

How to Create Geometry from the Clipping Contour 

In the Clipping module, under Visualization, click Clone. This creates a geometry node from the 
clipping contour. This node, named Clipping Contour, appears in the Scene Graph. 

How to Set a Clipping Plane Path (Genuine Clipping) 

You can set the clipping plane to move along a predefined path. A path can either be a line 
geometry contained in the original model or a continuous part of the clipping plane itself. 

1. In the Clipping module, under Genuine Clipping, click Pick. 
2. Shift-click and select a line geometry in the scene, including any displayed clipping 

contour. 
3. Adjust speed with the Speed controls. 
4. Move the clipping plane along the path, using the mouse wheel, while holding down 

Shift. 

When you reposition the clipping plane, the path is discarded. 



About the Measurement Module 
Interaction > Measurement 

Use the Measurement module to access a collection of different distance measurement tools. It 
also provides a ruler that can be enabled with the corresponding icon in the Icon Bar. While the 
ruler is enabled, Shift-click in the scene to position it. 

The Measurement Module 

The Measurement module has three sections. The Measurement List View displays the type of 
measurement and name for that measurement. Properties contains properties for the selected 
measurement. Visualization contains some general options, which affect all measurements, 
such as the active color scheme or hiding all measurements in the Render Window. 

 

Measurement List View Context Menu 

Right-click within the Measurement List View (upper section) to add assorted types of 
measurement, such as point to point or line to object. Also do this to load, save, zoom in, or 
remove measurements. See Creating Measurements for instructions. 

• Add Point to Point Measurement - After Shift-clicking to select the first and second 
point, the distance is calculated between the explicitly selected points. After creation, 
the points can be readjusted under Properties. 
 

• Add Point to Object Measurement - After Shift-clicking to select the first point and 
object, the distance is calculated between the point and object. After creation, the 
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position can be readjusted, and another object node selected under Properties. 
 

• Add Object to Object Measurement - The minimal distance between the selected 
objects is calculated. After creation, the hierarchy level used for calculation can be 
selected under Properties. 
 

• Add Line to Object Measurement - 
Use line-to-object measurement for 
judging gaps when the original model 
already contains line geometry. For 
creating a line-to-object 
measurement, the first object must 
be line geometry, while the second 
may be any other geometry. The 
measurement then creates sample 
points along the line. For each point, 
the minimum distance to the second 
object is calculated. The result is 
displayed in the Render Window, 
using a special visualization for all 
distances. The distances are 
displayed as lines, both in the 3D 
scene and in a 2D diagram in the lower left corner of the Render Window. Hovering with 
the mouse over the diagram highlights a particular distance in the 3D view and shows its 
exact value on top of the diagram. 
 

• Add Circle Measurement - By selecting three points, it's possible to calculate the radius, 
diameter, and circumference, for example, of a cylinder. 

 



• Add Gap Measurement - The most complex measurement is gap measurement. It is a 
useful substitute for line-to-object measurement, in case no appropriate line geometry 
is available. The gap measurement is calculated along the line segment between two 
selected points on two distinct objects. The viewer tries to find multiple minimum 
distances between the two objects, where each distance calculation is restricted to 
being on a plane perpendicular to the line segment. The result is displayed in the Render 
Window, using a special visualization of all distances for line-to-object measurements. 

NOTE The measurements start and end on objects, identifying these objects by their 
name. Ensure your measured objects have a unique name within the Scene Graph when 
saving and loading measurements. 

• Remove Measurement - Removes the selected measurement. 
• Update Measurement - Recalculates the measurement when, for example, an object is 

moved. 
• Zoom in - Zooms to a specific measurement. 
• Load Measurements - Loads measurements into an .xml file. 
• Save Measurements - Saves all measurements to an .xml file. 
• Remove All - Deletes all measurements in the Measurement module. 

Properties 

Shows different properties, depending on the selected measurement. 

• Point to Point - Contains the following options: 
 

o 3D Distance: Shows the distance between two points. 
o 2D Distance: Shows the distance between the two points for each axis. 
o First position: Shows the coordinates of the first selected position. You can 

select a new position using the Pick button. 
o Second position: Shows the coordinates of the second selected position. You can 

select a new position using the Pick button. 
 

• Point to Object - Contains the following options: 
 

o 3D Distance: Shows the minimum distance between the point and object. 
o 2D Distance: Shows the distance between the point and object for each axis. 
o Position: Shows the coordinates of the first selected position. You can select a 

new position using the Pick button. 
o Node: Shows the selected node. 

 

 



• Object to Object - Contains the following options: 
 

o 3D Distance: Shows the minimum distance between the objects. 
o 2D Distance: Shows the distance between the objects for each axis. 
o First Node: Shows the first selected node. 
o Second Node: Shows the second selected node. 

 
• Line to Object - Contains the following options: 

 
o Line: Shows the selected line. 
o Object: Shows the selected node. 
o Avg. Dist.: Calculates the average distance. 
o Min. Dist.: Shows the minimum distance. 
o Max. Dist.: Shows the maximum distance. 

 
• Circle - Contains the following options: 

 
o Rad./Dia./Circumf: Shows the data for radius, diameter, and circumference. 
o First Position: Shows the location of first selected point. 
o Second Position: Shows the location of second selected point. 
o Third Position: Shows the location of third selected point. 

 
• Gap - Contains the following options: 

 
o First Object: Shows the first selected node. 
o Second Object: Shows the second selected node. 
o Avg. Dist.: Calculates the average distance. 
o Min. Dist.: Shows the minimum distance. 
o Max. Dist.: Shows the maximum distance. 

Visualization 

Use these general options to affect all measurements. 

• Show Measurements - Enables/disables all measurements in the scene. 
• Color Scheme - Defines the display color of the measurements. Available colors are: 

Orange, Red, Green, Blue. 
• Measurement Precision - Sets the decimal measurement precision. 



Working with Measurements 
Add measurements to your scene. 

Interaction > Measurement 

How to Create Measurements 

Use the Measurement module to measure the distance between points, points and objects, 
objects, and more. 

 

1. Click Interaction > Measurement. 
2. Right-click in the Measurement List View (upper section) and select one of the types of 

measurement. 
3. Follow the on-screen Render Window prompts, as you Shift-click to select your 

measurement points. For example, "Select first Point," means Shift-click the first point 
of measurement. The point and its values are displayed in the Properties section of the 
Measurement module. Some types of points can be modified; these have a Pick button 
beside them. 

 

 

 



How to Remove One or All Measurements 

Remove one or all measurements. 

1. Click Interaction > Measurement. 
2. Right-click in the Measurement List View (upper section) and one of the following: 

 
o Remove Measurement - Removes only the selected measurement from the 

scene. 
o Remove All - Removes all measurements from the scene. 

How to Update Measurements 

Update measurements when things have changed within a scene. 

1. Click Interaction > Measurement. 
2. Right-click in the Measurement List View (upper section) and select Update 

Measurements. 

How to Zoom into a Measurement 

Zoom into the scene to see a measurement. 

1. Click Interaction > Measurement. 
2. In the Measurement List View (upper section), select the measurement to zoom in on. 
3. Right-click in the Measurement List View and select Zoom In. 

How to Save Measurements 

Save your measurements to a scene for future use. 

1. Click Interaction > Measurement. 
2. Right-click in the Measurement List View (upper section) and select Save 

Measurements. 

How to Load Measurements 

Load saved measurements back into a scene. 

1. Click Interaction > Measurement. 
2. Right-click in the Measurement List View (upper section) and select Load 

Measurements. 



How to Edit Measurements 

Make changes to the position of points and objects. 

1. To edit measurements, select one from the Measurement List View. 
2. In the Properties section, click a field to edit it. 

For some fields, click the drop-down and select an option. To change the position of a 
point, click Pick, then Shift-click a new point within the scene. These values cannot be 
manually change in the Position field. 

How to Show/Hide On-screen Measurements 

To show on-screen measurements, in the Measurement module, scroll to the Visualization 
section, and ensure Show Measurements is checked. 

To hide on-screen measurements, uncheck Show Measurements. 

How to Change the Color Scheme 

To change the colors used for the displayed measurements, scroll to the Visualization section, 
then select a color from the Color Scheme drop-down. 

How to Set Measurement Precision 

To set the precision of measurements, scroll to the Visualization section, and in the 
Measurement Precision field, set the number of decimal places. If set to 4, measurements will 
be accurate to four decimal places, such as 12.0251. 



About the Sequencer 
Interaction > Sequencer 

Use the Sequencer to set up command sequences. The sequences are executed in a batch 
process from top to bottom. You can initiate execution or set up other actions in the 
application. All entries are case-sensitive. 

The Sequencer 

The Sequencer contains a List View that lists 
all sequences and values associated with 
them. It also contains a timeline and an Icon 
Bar at the bottom. 

 

 

 

 

 

Context Menu 

• Create Sequence - Creates a sequence in which actions can be queued. 
• Create Action - Actions are function sets, which can be used to activate and edit settings 

in VRED. 
• Duplicate - Duplicates the selected sequence or action. 
• Select All - Selects all sequences and actions. 
• Rename - Renames the selected sequence or sets the selected action parameter value. 

Actions cannot be renamed, but you can enter a comment for each action. 
• Delete - Deletes the selected sequence or action. 
• Active - Toggles the active state of the selected sequences and actions. Activated 

actions and sequences can be executed. 
• Move Up - Shifts the selected sequences or actions one step up in the process queue. 
• Move Down - Shifts the selected sequences or actions one step down in the process 

queue. 
• Run - Executes selected sequences and actions. Inactive actions are not executed. 
• Run All - Executes all sequences that have an active state. 



Slider 

Use the slider at the bottom of the module to expand or collapse all sequences and actions at 
once. 

Actions 

• setEnvironmentVariable - Sets an environment variable. 
 

o name - Sets the variable’s name. 
o value - Sets the variable’s value, in this case the path to the project. Double-click 

to change it. 
 

• enableSimulation - Sets the simulation state. The simulation state defines whether 
animation can be executed or not. Value is Boolean. 
 

o state - true/false 
 

• updateRender - Enforces a rendering refresh. Boolean value: 
 

o force - true/false 
 

• selectCamera - Selects a camera. 
 

o name - here the name of the selected camera is set 
 

• showInitialView- Activates the InitialView position. 
• jumpViewPoint - Sets the camera to a Viewpoint’s position. This function immediately 

jumps to the viewpoint (no interpolation). Viewpoints can be set in the Camera Module. 
 

o name - Sets the Viewpoint’s name 
 

• setActiveSnapshotMovieRenderPasses - Activates or deactivates render passes for 
image rendering. All parameters are Boolean: 
 

o beauty_pass - true/false 
o diffuse_ibl_pass - true/false 
o diffuse_light_pass - true/false 
o glossy_ibl_pass: true/false 
o glossy_light_pass - true/false 
o specular_ibl_pass - true/false 
o specular_light_pass - true/false. (This parameter is deprecated. The specular 

light pass no longer exists, therefore the parameter is ignored.) 



o translucency_pass - true/false 
o incandescence_pass - true/false 
o diffuse_indirect_pass - true/false 
o glossy_indirect_pass - true/false 
o occlusion_pass - true/false 
o normal_pass - true/false 
o depth_pass - true/false 
o material_id_pass - true/false 

 
• resetActiveSnapshotMovieRenderPasses - Deactivates rendering the image with 

render-passes. 
• setCombinedChannelsRenderPasses - All parameters are Boolean: 

 
o beauty_pass - true/false 
o diffuse_ibl_pass - true/false 
o diffuse_light_pass - true/false 
o glossy_ibl_pass - true/false 
o glossy_light_pass - true/false 
o specular_ibl_pass - true/false 
o translucency_pass - true/false 
o incandescence_pass - true/false 
o diffuse_indirect_pass - true/false 
o glossy_indirect_pass - true/false 
o transparency_pass - true/false 
o background_pass - true/false 

 
• setMaterialChannelsRenderPasses - All parameters are Boolean: 

 
o diffuse_material_pass - true/false 
o glossy_material_pass - true/false 
o specular_material_pass - true/false 
o translucency_material_pass - true/false 
o transparency_material_pass - true/false 
o background_material_pass - true/false 
o incandescence_pass - true/false 

 
• setIlluminationChannelRenderPasses - All parameters are Boolean: 

 
o diffuse_ibl_pass - true/false 
o glossy_ibl_pass - true/false 
o translucency_ibl_pass - true/false 
o diffuse_light_pass - true/false 
o glossy_light_pass - true/false 
o translucency_light_pass - true/false 



o diffuse_indirect_pass - true/false 
o glossy_indirect_pass - true/false 
o specular_indirect_pass - true/false 
o translucency_indirect_pass - true/false 

 
• setAuxiliaryChannelRenderPasses - All parameters are Boolean: 

 
o occlusion_pass - true/false 
o normal_pass - true/false 
o depth_pass - true/false 
o material_id_pass - true/false 
o mask_pass - true/false 
o position_pass - true/false 
o view_vector_pass - true/false 

 
• setSnapshotICCProfile - Sets the ICC profile to be used for the rendered image. 

 
o profileID - One of the following IDs can be set: 

 
 0 uses the current settings from the render settings module 
 1 uses sRGB encoding 
 2 uses Adobe RGB 98 encoding 
 3 uses the specified Monitor ICC Profile 

 
• setSnapshotEmbedMetaData - Sets which metadata is embedded in the rendered 

image. All parameters are Boolean. 
 

o embedRenderSettings - Sets whether to embed image, animation, render 
passes, and raytracing settings. true/false 

o embedCameraSettings - Sets whether to embed the settings of the active 
camera. true/false 

o embedNodeVisibilties - Sets whether to embed the visibility state of each node 
in the Scene Graph. true/false 

o embedSwitchNodeStates - Sets whether to embed the state of each switch node 
in the Scene Graph. true/false 

o embedSwitchMaterialStates - Sets whether to embed the state of each valid 
switch material in the scene. true/false 
 

• createSnapshot - Renders a single image. 
 

o filename - Sets the target folder and the image filename. 
o width - Sets the image width resolution in pixel. 
o height - Sets the image height resolution in pixels. 
o supersampling - Sets the sampling quality. 



 0 disables supersampling. 
 1 uses ¼ of the set image samples. 
 2 uses ½ of the set image samples. 
 3 uses the set image samples. 

 
o alpha - Sets the state of alpha rendering. 

 
 true - renders alpha channel. The resulting image has a transparent 

background including correct alpha values for transparent materials. 
 false - does not render alpha channel. 

 
o background RED/GREEN/BLUE: Sets the alpha color, defining the red, green, and 

blue component of the background color. 
o dpi - Sets the dots per inch resolution embedded in the rendered image. 
o overwrite - Allows you to overwrite an existing file with the same name. 

true/false 
o showImage - Opens the image file after rendering is completed: true/false 
o alpha premultiply - Multiplies the alpha and the color channel in the resulting 

image. true/false 
o tonemap hdr - Applies tone mapping to the high dynamic image rendering. As a 

result, the 32-bit renderings look the same in the compositing tool as set in 
VRED. However, the values of the image are compressed by the chosen tone 
mapper to values from 0 through 1. In doing so, the dynamic range is lost. 
Therefore, effects like glow are hard to calculate in the compositing tool 
afterwards. 
 

• createMovie - Settings for exporting a movie. 
 

o filename - Sets the target folder and the movie filename. 
o width - Sets the movie width resolution in pixel. 
o height - Sets the movie height resolution in pixels. 
o fps - Sets the frames to be rendered per each movie second. 
o startFrame - Sets the movie's start frame. 
o stopFrame - Sets the movie's end frame. 
o supersampling - Sets the sampling quality. 

 
 0 disables supersampling. 
 1 uses ¼ of the set image samples. 
 2 uses ½ of the set image samples. 
 3 uses the set image samples. 

 

 



o alpha - Sets the state of alpha rendering. 
 

 true - renders alpha channel. 
 false - does not render alpha channel. 

 
o background RED/GREEN/BLUE - Sets the alpha color, defining the red, green, 

and blue component of the background color. 
o overwrite - Allows you to overwrite an existing file with the same name. 

true/false 
o alpha premultiply - Multiplies the alpha and the color channel in the resulting 

image. true/false 
o frame step - Defines the frame offset for the rendering of image sequences. 

Example: Step 3 renders only every third frame (0, 3, 6, 9, ...) 
o tonemap hdr - Applies tone mapping to the high dynamic image rendering. As a 

result, the 32-bit renderings look the same in the compositing tool as set in 
VRED. However, the values of the image are compressed by the chosen tone 
mapper to values from 0 through 1. In doing so, the dynamic range is lost. 
Therefore, effects like glow are hard to calculate in the compositing tool 
afterwards. true/false 
 

• createCubeImages - Exports an environment image. 
 

o node_name - The name of the node that is used for the camera position is 
specified. 

o type - Defines the type as which the cube image is created. Images are rendered 
and processed based on the chosen type: 
 

 0 separate images 
 1 vertical cross 
 2 horizontal cross 
 3 spherical map 

 
o resolution - Sets the quadratic resolution in pixels. 
o supersampling - Defines the level of anti-aliasing. 
o filename - Filename of the images. 

 
• setSwitchMaterialChoice - Changes the choice of a switch material. 

 
o name - Sets the Switch Material’s name. 
o choice - Sets the Switch Material’s choice. 

 

 



• setMaterialImage - Helps to change a material’s textures. 
 

o materialName - Sets the name of the material whose texture should be set. 
o fieldName - Defines the field name of the texture slot to be set. 
o imageFilename - Sets the path to the image. 

 
• setBackplate - Activates/deactivates a backplate. 

 
o state - true/false 

 
• createBackplate - Creates a backplate from the file provided. 

 
o filename - Sets the backplate name to be created. 

 
• deleteBackplate - Deletes the backplate. 
• selectVariantSet - Activates a Variant Set. The variant set activates all states of its 

defined node and material variants. 
 

o name - Sets the Variant Set’s name to be activated. 
 

• startAnimation - Starts an animation node in the Animation Module. 
 

o name - Sets the animation name to be started. 
 

• stopAnimation - Stops an animation node in the Animation Module. 
 

o name - Sets the animation name to be stopped. 
 

• pauseAnimation - Pauses an animation node in the Animation Module. 
 

o name - Sets the animation name to pause. 
 

• continueAnimation - Continues an animation node in the Animation Module. 
 

o name - Sets the animation name to continue. 
 

• resetAnimation - Resets an animation node in the Animation Module. 
 

o name - Sets the animation name to be reset. 
 

• startSAnimation - Starts an animation node in the SAnimation Module. 
• startReverseSAnimation - Reverse an animation node in the SAnimation Module. 

 
o name - Sets the animation name to be reversed. 



• playCAnimation - Starts an animation clip. 
 

o name - Sets the animation clip’s name to be executed. 
o startFrame - Sets the start frame of the animation. 
o endFrame - Sets the end frame of the animation. 

 
• pauseCAnimation - Pauses an animation clip. 

 
o name - Sets the animation clip’s name to be paused. 
o value - true/false 

 
• resetCAnimation - Resets an animation clip. 

 
o name - Sets the animation clip’s name to be reset. 

 
• resetCAnimation - Resets an animation clip. 

 
o animation - the name of the animation clip to be rendered 
o filename - Sets the target folder and the image filename. 
o width - Sets the image width resolution in pixel. 
o height - Sets the image height resolution in pixels. 
o fps - Sets the frames to be rendered per each movie second. 
o startFrame - Sets the movie’s start frame. 
o stopFrame - Sets the movie’s end frame. 
o supersampling - Sets the sampling quality. 

 
 0 disables supersampling. 
 1 uses ¼ of the set image samples. 
 2 uses ½ of the set image samples. 
 3 uses the set image samples. 

 
o alpha - Sets the state of alpha rendering. 

 
 true - renders alpha channel. 
 false - does not render alpha channel. 

 
o alpha RED/GREEN/BLUE: Sets the alpha color, defining the red, green, and blue 

component of the background color. 
o overwrite - Allows you to overwrite an existing file with the same name. 

true/false 
o alpha premultiply - Multiplies the alpha and the color channel in the resulting 

image. true/false 
o frame step - Defines the frame offset for the rendering of image sequences. 

Example: Step 3 renders only every third frame (0, 3, 6, 9, ...) 



o tonemap hdr - Applies tone mapping to the high dynamic image rendering. As a 
result, the 32-bit renderings look the same in the compositing tool as set in 
VRED. However, the values of the image are compressed by the chosen tone 
mapper to values from 0 through 1. In doing so, the dynamic range is lost. 
Therefore, effects like glow are hard to calculate in the compositing tool 
afterwards. true/false 
 

• setVRMLViewpointsEnable - Activates or deactivates VRML Viewpoints. VRML 
Viewpoints are camera animations imported through a VRML file from third-party 
software. 
 

o state - true/false 
 

• setVRMLCurrentViewpoint - Sets the VRML Viewpoint to be activated. 
 

o name - Sets the VRML viewpoint name to activate. 
 

• resetRenderLayers - Resets all Render Layer settings. 
• ActivateRenderLayer - Activates a Render Layer. 

 
o name - Sets the VRML viewpoint name to activate. 

 
• setStillDOF - Activates or deactivates depth of field rendering. 

 
o state - true/false 
o radius - Sets the DOF blur amount 
o focal distance - Sets the focus distance in millimeters 
o  

• setRenderQuality - Sets the image render quality and image render mode. Available 
modes are: 
 

o VR_QUALITY_ANALYTIC_HIGH 
o VR_QUALITY_ANALYTIC_LOW 
o VR_QUALITY_REALISTIC_HIGH 
o VR_QUALITY_REALISTIC_LOW 
o VR_QUALITY_RAYTRACING 

 
• setRaytracingImageSamples - Sets the number of anti-aliasing samples for Raytracing 

rendering. 
 

o samples - The total number of image samples for Raytracing rendering. 
 

 



• setRaytracingAAAdaptiveSamples - Sets the minimum number of adaptive samples for 
ray tracing rendering. This function is deprecated. 
 

o samples - Sets the minimum number of samples for Raytracing rendering. 
 

• setRaytracingAAThresholdQuality - Sets the Raytracing anti-aliasing threshold quality. 
 

o level - values from 0 to 4 are allowed 
 

• setRaytracingAAImageFilter - Sets the image filter algorithm for Raytracing rendering. 
 

o filterid: 
 

 0 Box 
 1 Triangle 
 2 Gaussian 
 3 Mitchell Netravali 
 4 Lanczos 
 5 BSpline 
 6 Catmull Rom 
 7 Sharp Triangle 
 8 Sharp Gauss 
 9 Sharp BSpline 

For more information on the different filter types, see ~Pixel Filter. 

• loadCluster - Loads a cluster configuration. 
 

o filename - The name and path of the XML-file with the cluster 
 

• startCluster - Starts a cluster. 
• stopCluster - Stops a cluster. 
• computeMissingAmbientOcclusion - Calculates the ambient occlusion for all visible and 

selected nodes and their child nodes that do not have valid ambient occlusion values 
assigned yet. 
 

o quality - The quality level (value from 0 to 5) for the ambient occlusion 
calculation. 

o minDistance - The minimum distance of objects to be taken into account for the 
ambient occlusion calculation. 

o maxDistance - The maximum distance of objects to be taken into account or the 
ambient occlusion calculation. 

o indirectIllumination - Turns indirect illumination on or off. (Boolean true/false) 
o colorBleeding - Turns color bleeding on or off. (Boolean true/false) 



o gatherQuality - The quality level (value from 0 to 4) for the indirect illumination 
gathering passes. 

o numIndirections - The number of bounces (gathering passes) for the indirect 
illumination. 

o subdivide - Turns geometry subdivision on or off. (Boolean true/false) 
o minEdgeLength - Sets the minimum length an edge can have after subdivision. 
o intensityThreshold - Sets the intensity threshold for a subdivision. 
o overrideMaterialColor - Turns material color override on or off. 
o materialColorR - Red component of the material override color. 
o materialColorG - Green component of the material override color. 
o materialColorB - Blue component of the material override color. 
o  

• Button Icon Bar - Icon Bar at the bottom of the module allows easy access to often 
required commands: 
 

o Create - Creates a sequence. 
o Duplicate - Duplicates the currently selected sequence or action. 
o Delete - Deletes the currently selected sequence or action. 
o Move Up - Shifts the currently selected sequence or action one step up in the 

process queue. 
o Move Down - Shifts the currently selected sequence or action one step down in 

the process queue. 
o Run - Executes the currently selected sequences and actions. 
o Run All - Executes all sequences that are checked have an active state. 



Creating and Running Command Sequences 
Interaction > Sequencer 

How to Create Command Sequences 

Once you have created a command sequence, other sequences can be added as needed. 

1. Select Interaction > Sequencer. 
2. Right-click inside the Sequencer module and select Create Sequence. 
3. Right-click the new sequence, select Create Action, then the action you want from the 

context menu. 
4. Repeat step 3 to add other actions to the sequence. 

How to Disable an Action Inside a Sequence 

To disable an action inside a sequence, deselect the check box beside the action. 

 

How to Use the Icon Bar Controls 

1. Select Interaction > Sequencer. 
2. Use the controls in the Icon Bar to delete, duplicate, or change the order of sequences. 

 



How to Run Command Sequences 

To run one sequence, including all its enabled actions: 

1. In the Sequencer module, right-click the sequence you want to run. 
2. Select Run. 

 

To run multiple sequences: 

1. In the Sequencer module, select the check boxes beside the sequences you want to run. 
2. Right-click inside the module and select Run All. 



Creating a Touch Sensor 
Interaction > Touch Sensor 

What are Touch Sensors 

Touch sensors are defined areas on an object within a scene that are clickable. Clicking them 
triggers animated events. Variant sets are used to create these events. 

For example, clicking a car door could play an animation of the door opening and clicking a car 
bumper could result in the car moving forward or back. 

 

Touch sensors are a great way to get people interacting with a model. They can also show how 
a door opens, not only the angle, but speed and smoothness of the action. When in VR, touch 
sensors help participants feel more immersed in the experience. This interaction with the 
model and its component can go a long way to help share your vision and deliver the 
experience a customer will have. 

How to Create a Touch Sensor 

1. Select Interaction > Touch Sensor to open the Touch Sensor module. 
2. Select Scene > Scene Graph. 
3. From the Scene Graph, drag an object node into the Touch Sensor module. 
4. Select Scene > Variant Sets. 
5. Drag a variant set onto the object node in the Touch Sensor module. 

This creates a touch sensor node with the object as its activator. Clicking the object will 
activate the variant set. 

TIP To select nodes in the Scene Graph that are in the Touch Sensor module, right-click in the 
Touch Sensor module and select Select Nodes. 



How to Delete a Touch Sensor 

In the Touch Sensor, select a Sensor Nodes Variants from the List View, and click . 



VRPN Tracking - Setting Up a Tracking 
Configuration 
The following is an example of how to create a configuration for a projection with headtracking 
(glasses body) and flystick navigation. 

Assume that A.R.T. room calibration was done with the Powerwall setting. This implies that the 
tracking coordinate system is right-handed and Y-up oriented. Its origin is on the ground and 
there is a front wall projection of size 3x2 metres, which is orthogonal to the ground. No VRPN 
server is running. 

1. In VRED, select Interaction > VRPN Tracking to open the VRPN Tracking module. 
2. In the VRPN Tracking module, select Edit > Add server to create a VRPN server named 

localhost. 
3. With the localhost server selected, load the configuration file vrpn-art.cfg from the 

VRED folder data\\vrpn. 
4. Click Start to start the server. The Status changes to Running. 
5. With the localhost server selected, select Edit > Add device. 
6. Name the new device DTrack to correspond to the name in the configuration file. 
7. With the DTrack device selected, change the coordinate system to Y-Up. 

This is because the room was calibrated with the Powerwall setting. You do not need to 
swap any axis. 

8. Set the Y-value of the Projection Origin to 1000. 

This is half the diameter of the front wall. Assume the projection is set up symmetrically. 

9. Select the device and click Edit > Add body to add a new body to the device. 

(It may be necessary to change the sensor identifier.) 

10. Name the new body Glasses. 
11. Change the target type of the body to Head Projection. 
12. If the tracker sensor for the glasses was calibrated with zero in marker, you can add a 

translation offset to move the reference point in the middle of the glasses. 
13. Select the device again and click Edit > Add flystick. 

(It may be necessary to change the sensor identifier.) A button and two analogs are 
automatically created. They are needed for the different navigation modes. 

14. Change the navigation mode to one of the following: 



o Scene Move - Uses the predefined button of the flystick to activate the 
movement. 

o Point Fly - Uses the two analogs for fly-to navigation. 
 

15. Optional: Select Diagnostics > Connection test to test the configuration. 
16. Click Enable/Disable Tracking in the lower toolbar to toggle tracking. 

 



VRPN Tracking - About the Tracking Module 
Interaction > VRPN Tracking 

Connect an external tracking system to VRED to receive data from various tracking systems via 
VRPN (Virtual-Reality Peripheral Network). VRPN is an open source standard library for 
accessing many different tracking systems. Use VRPN to set up power-wall and cave projections 
with head-tracking, object tracking, interactive navigation with flysticks, and so on. Add servers, 
devices, and their children; types of children you can add include: 

• Body - The only sensor that has a position and orientation in space and can be 
calibrated or connected to a node. Connecting a body to a node is an important task 
that updates a transform nodes matrix with the values coming from the corresponding 
sensor. 

• Flystick - A type of body with a predefined button and analogs. 
• Button - A trigger with a unique identifier and target. Does not need calibration. 
• Analog - A pointing device, such as a joystick. Each movement axis must be mapped by 

adding an analog sensor. 

Dialog Box Layout 

Navigate between servers, devices, and their children (bodies, flysticks, and so on) on the left 
side of the dialog box. View and edit properties of the selected items on the right side of the 
dialog box. 

Menu Bar 

These commands are available from the menu bar; most of them can also be found in the 
context menu or the buttons at the bottom of the VRPN Tracking dialog box. 

• File - Create, load, or save tracking configurations using New, Load, and Save. 
• Edit > Add... - Create new objects, such as a server or a flystick. 
• Edit > Freeze - Block the execution of incoming VRPN data while tracking is active. 
• Edit > Reset Camera - Clear head projection and HMD values and restore the original 

camera. 
• Diagnostics - Access Connection Test to open a dialog box to test the current 

configuration. 

VRPN Server Settings 

Select a server on the left side of the dialog box to see its settings on the right in the Server 
dialog box. 



If the server is not already running, you must specify a configuration file for it and start it. 

• Config File - Enter the path to a config file (*.cfg) for a VRPN server. Sample 
configuration files are included in the VRED installation folder. Right-click to use the 
default configuration file specified in Preferences. 

• Status - Shows the current server status. 
• Start/Stop - Manually start or stop the server. 

Device Settings 

Select a device on the left side of the dialog box to see its settings on the right in the Device 
dialog box. 

• Unit Scale - Tracking values are normally transferred in meters. Unit Scale converts this 
to the VRED standard of millimeters. The default value is 1000. If the tracking system is 
not sending its values in meters, you should adjust this value. 

• Coordinate System - There are three predefined tracking coordinate systems: 
 

o X-Up - X pointing up, Y left and Z front. 
o Y-Up - X pointing right, Y up and Z front 
o Z-Up - X pointing right, Y back and Z up 

 
• Swap Axis - Swap axes to match various coordinate systems. 
• Projection Origin - Specifies the position of the projection in global tracking coordinates. 

This is mainly used for head projections. 
• Rotation Offset - Use to add an extra rotation. 

Body Settings 

For every device, you can define one or more tracker bodies. A body represents a sensor in the 
tracking system. You can enter a numerical identifier for a body in the Sensor ID column of the 
list view. 

• Target Type - Defines how tracking values are used in VRED. 
 

o Custom Node - Values are transferred to the node specified in the Target Node 
box. 

o Head Projection - Values are transferred to the camera for power-wall and cave 
projections. 

o HMD - Values are transferred to the camera for head mounted displays. 
o Cart - Values are transferred to the camera for cart displays. 

 



• Camera - When the target type is set to HMD, a camera can be specified. This option is 
stored in the tracking system by name. 

• Translation Offset - Add an extra translation in local body coordinates. 
• Rotation Offset - Add an extra rotation. 
• Cart Transform Mode - When the target type is set to Cart, this specifies the source 

where the cart will get its values from. Possible sources: 
 

o Custom - Translation and rotation values are gathered from the Cart Translation 
and Cart Rotation fields. 

o Node - Transform values are gathered from a node in the Scene Graph; the name 
of the node is specified in the Cart Node field. 

o Viewpoint - Transform values are calculated using a viewpoint, whose name is 
specified in the Viewpoint field. 
 

• Cart Node - When Cart Transform Mode is set to Node, this specifies the name of the 
node to use. If the node does not exist, the value is ignored. 

• Viewpoint - When Cart Transform Mode is set to Viewpoint, this specifies the name of 
the viewpoint which is used to calculate the transformation. If the viewpoint does not 
exist, the value is ignored. 

• Relative to Camera - Offset relative to the camera position. 
• Ignore Device Offsets - Ignore offset values from the device for final position and 

orientation calculations. 

Flystick Settings 

A flystick is a type of body with a predefined button and analogs. It acts as a navigation device 
and is used to change your position and orientation within the virtual scene. There are two 
different modes: Scene Move and Point Fly. You can also define buttons and analogs and 
connect them to VRED functions using python scripts. 

• Mode - Set the interaction mode for the flystick: 
o None 
o Scene Move - Move the scene with the flystick. You must press the related 

button to activate this mode. 
o Point Fly - Move the user to pointed direction when the analog stick is pushed. 

 
• Speed - Adjust the speed for movements in point fly mode. 
• Translation Offset - Add an extra translation in local body coordinates. 
• Rotation Offset - Add an extra rotation. 
• Relative to Camera - Offset relative to the camera position. 
• Ignore Device Offsets - Offset values from the device are ignored for final position and 

orientation calculations. 
• Show Position - Highlight the flystick position with an orange cube. 



Advanced Settings 

Create a matrix for modifying incoming tracking values of devices, bodies, and flysticks. This 
supersedes all other settings. Click Edit to modify the matrix manually. For bodies and flysticks, 
click Calibrate to modify the matrix automatically. 

• Use Custom Calibration - Enable the Calibrate and Edit buttons. 
• Calibrate - Automatically calibrate the matrix for bodies and flysticks, using the current 

position of the sensor as a reference. 
• Edit - Open the Matrix Editor. The calibration matrix is a measurement mapping of the 

real space to the virtual space. 
• Clear Translation - Clear any translation (offset) in the matrix. 
• Lock Rotation 90° - Lock the rotation angle in 90° steps. 

Troubleshooting 

• Nothing Happens When Tracking Is Enabled - Select one of the following options: 
 

o Is a VRPN server running on the specified host? If not, you can start one under 
VRPN server settings. 

o Is the tracking system sending its data to the correct host (where the VRPN 
server is running)? 

o Is the device name correct? It must match the one in the VRPN configuration. 
o Is the sensor identifier correct and is the sensor in tracking range? 

 
• VRPN Server Is Not Starting - Check that the VREDClusterService process is running. 



About the Transform Module 
Interaction > Transform 

Use the Transform module to transform selected objects in two ways. The first is interactively 
with the transform manipulator in the toolbar. The second is by entering the transformation 
values into the Transform module. 

Move geometry, resize it, rotate it, and redefine its pivot. When transforming multiple objects 
at once, the Transform module always shows the transformation properties of the last selected 
object. The transform manipulator is connected to the last selected object. 

A yellow background in the respective input field highlights transformation values that differ 
among the selected objects. When entering a certain value, it is applied to all selected objects. 
With the wheel control next to the input field, you can increase or decrease the respective 
values of all selected objects at once. 

You can also create Transform Variants to display a single set of geometry in multiple 
orientations. Using a Transform Variant reduces file size, root structure, and memory usage. 

The toggle button for enabling/disabling the Transform Module is on the left side of the quick 
access bar. 

The Transform Module 

The Transform Module contains a Window menu for opening the Transform Variants Window, 
two tabs, Basic and Advanced, and an Icon Bar. 

Window Menu 

Toggles the Transform Variants Window in the Transform module. To always show the 
Transform Variants Window in the Transform module, select Edit > Preferences > Transform > 
Transform Editor, then select either Transform Variants Window or Transform Variants Window 
& Variant Options. 

Transform Variants 

With transform variants, display a single set of geometry in multiple orientations and locations 
within the scene. Using a transform variant, instead of multiple duplicated geometries, reduces 
file size, root structure, and memory usage. Transform variants use the Basic tab values of the 
Transform module. Transform variants work on most nodes available in the Scene Graph. 



Options 

Select the Options slider to display check boxes to enable/disable any basic transform functions 
for the variant. For example, disabling the rotation in a transform variant means the rotation is 
not applied to the node when the variant is activated. You can change the options for individual 
or all variants. When a change is made to an option, this notification icon  appears on the 
affected variant. It is displayed even if the options are toggled off. The check boxes are also 
displayed in the Basic tab next to each function. Variant options are recommended only for 
advanced transform variant use and are not required in most situations. 

Context Menu 

Right-click the node or variants for a context menu. Use the options for create, rename, delete, 
and duplicate variants, copy and paste transformations, and copy and paste transformation 
variants. 

Use these other options to: 

• Activate - Displays the selected variant by pushing the variant information to the Scene 
Graph node. 

• Move Up - Moves the variant up in the Transform Variants Window. 
• Move Down - Moves the variant down in the Transform Variants Window. 

See Scene Graph Edit Menu for the additional definitions. 

Basic (tab) 

The functions in the transformation tool help with exact placement of objects within a scene. 
All numerical input fields have a wheel beside them. Click-drag it to the left or right increase or 
decrease values. 

• Translation - Moves the selected objects along the coordinate system axis. 
 

o Coordinate System - Defines whether the translation values are presented based 
on world or object space. In world space, the translation defines the object’s 
global position within the world. In object space, the translation defines the 
object’s offset from its origin. 

Example - Translate a parent node by (0, 0, 10) (TX TY TZ) in world space. If you 
translate the child node by (0, 0, 5) in local space, its translation values in world 
space is (0, 0, 15). 

o Translate X/Y/Z - The distance the object is moved along the respective axis. 

http://help-staging.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Scene_Graph_Scene_Graph_Edit_Menu_html


o Move to Camera - Translates the selected object to the position of the current 
active camera. 

o Move to Origin - Translates the selected object to the world coordinate system’s 
origin. 
 

• Rotation - Rotates the object around the rotation pivot. There are two methods of 
rotating objects using this tool. The first method is to manually select the rotation values 
and order with Rotate X/Y/Z and Rotation Order. The second method is to either pick or 
define an axis to rotate the object about and use the Rotate dial to rotate the object 
around this axis. 
 

o Rotate X/Y/Z - Rotates the object on the X-, Y-, or Z-axis. 
o Rotation Order - Euler rotations are not clear. The rotation order defines the 

order in which the rotations around all axes are realized. 
o Rotate Axis X/Y/Z - Changes the position and orientation of the rotation axis the 

objects rotate around. 
o Rotate - Rotates the selected object around the before-specified rotation axis. 

This axis can be visually shown in the Render Window with the Show Axis check-
box. 

o Pick Axis Mode - Enables the selection of the rotation axis by interactively 
selecting points within the Render Window. With two points the axis is directly 
defined in 3D space. With the three point method, a triangle in 3D is defined 
with the normal vector as the rotation axis. 
 

• Scaling - Contains the following options: 
 

o Scale X/Y/Z - Scales the object on X-, Y-, or Z-axis. 
o Uniform Scaling - Connects X-, Y-, and Z-axis and keys the same value to all of 

them. Disable this option to scale an object in only one direction or unequally in 
different directions. 
 

• Rotation Pivot - The rotation pivot is the point in 3D around which an object is rotated 
when using the rotate tool. 
 

o Coordinate System - Sets the coordinate system, Object or World, used as a 
reference on rotations. 

o Position X/Y/Z - Translates the rotation pivot point on the X-, Y-, or Z-axis. 
o Move To Object Center - Moves the rotation pivot point to the center of the 

object’s bounding box. 
o Move To World Center - Moves the rotation pivot point to the center of the 

world’s coordination system. 
o Alignment - Sets the coordinate system, Orientation or Direction Vector, used as 

a reference on rotations. 
o Orientation X/Y/Z - Rotates the rotation pivot point on the X-, Y-, or Z-axis. 



o Direction Vector X/Y/Z - Locates the second point of a vector with X-, Y-, and Z 
values. The first point is the pivot point of the object. 

o Pick - Picks two or three points to define an axis. 
o Axis - Sets X, Y, or Z as the axis defined by two or three points. 
o Show Axis - Displays the axis set in Pick and Axis. 

 
• Scaling Pivot - The scaling pivot is the point in 3D from which an object is scaled, when 

using the Scale tool. 
 

o Coordinate System - Sets the coordinate system, Object or World, used as a 
reference on scaling. 

o Position X/Y/Z - Translates the scaling pivot along the X-, Y-, or Z-axis. 
o Move to Object Center - Moves the scaling pivot point to the center of the 

object’s bounding box. 
o Move to World Center - Moves the scaling pivot point to the center of the world 

coordination system. 

Advanced (tab) 

The functions in this tab deal with the bounding box, shearing, and pivot translations. All 
numerical input fields have a wheel beside them. Click-drag it to the left or right increase or 
decrease values. 

• Bounding Box - Contains the following options: 
 

o Bounding Box Center - Retrieves the coordinates (X,Y,Z) of the bounding box 
center from the selected object. 

o Create Bounding Box Center Transform - Creates a transform node with the 
transformation of the selected bounding box center. The generated node is at 
the top level of the Scene Graph. 

o Create Bounding Box Center Inverse Transform - Creates a transform node with 
inverse transformation of the selected bounding box center. 
 

• Shearing - Shearing deforms the object by tilting the selected bounding box plane. 
 

o Shear XY - Shears the object on the X- and Y-axis. 
o Shear XZ - Shears the object on the X- and Z-axis. 
o Shear YZ - Shears the object on the Y- and Z-axis. 

 
• Pivot Translations - Contains the following options: 

 
o Rotation Pivot Translation - Preserves the existing rotate transformations when 

moving the pivot. Used to prevent an object from moving when the object's 
pivot point is not at the origin and the pivot is moved. 



o Scaling Pivot Translation - Preserves the existing scale transformations when 
moving the pivot. Used to prevent an object from moving when the object's 
pivot point is not at the origin and a non-unit scale is applied to the object. 
 

• Transform: Quick Icons - Contains the following options: 
 

o Create a new transform variant - Creates a transform variant of the selected 
node. 

o Duplicate selected variants - Creates a duplicate of the selected variants. 
o Delete selected variants - Deletes the selected variants. 
o Position rotate pivot in object center - Sets the rotate pivot to the center of the 

selected object. 
o Position scale pivot in object center - Sets the scale pivot to the center of the 

selected object. 
o Move the object to camera position - Moves the selected object to the current 

camera position. 
o Move the object to origin - Moves the selected object to the center of the world 

coordination system. 
o Put object on ground - Translates the selected objects along the Z-axis in such a 

way as to have the bottom face of the object’s bounding box at the same level as 
the ground plane. 

 



Working with Scripts 
VRED Professional supports custom Python modules (script plugins). Use the Script Editor for 
creating and editing scripts and script plugins and the Terminal to view messages and 
commands. For more information on Python scripts, please check Help > Python 
Documentation. 

Here's what you can expect from the Script Editor: 

• Dark theme 
• Fira Code font to make the coding experience better 
• Highlighted syntax 
• Ligatures support, so multiple characters appear to combine into a single character: 

"!=", ">=", "==>", "www" 
• Autocomplete for VRED python commands 
• Ctrl+F search functionality 
• Find and Replace functionality 
• Ctrl+G GoTo Line functionality 

How to Create and Edit Scripts 

Use the Script Editor for creating and editing scripts. 

• In the Menu Bar, select Edit > Script Editor. 

How to Run a Script 

Use either the main VRED window or Script Editor to run a script. 

• From the main VRED window, in the Menu Bar, select Edit > Run Script to run the script 
currently in the Script Editor. 

• From the Script Editor, click Run. 

How to View Messages and Run Python Commands 

Use the Terminal window to view errors and warnings, as well as run Python commands. 

• To open the Terminal, in the Menu Bar, select View > Terminal. 
• To save the output to a file, right-click inside the Terminal and select Save output. 



About the Scripted Custom Python Modules (Script Plugins) 

VRED Professional supports custom Python modules (script plugins). Once your script plugins 
have been copied to a specific location (see How to Create a Scripts Menu Option), they are 
automatically loaded during the next VRED start-up. You will find all your script plugins listed in 
the newly created Scripts menu. 

We've provided an example module with VRED (see Load an Example Script), so you can test 
this out and create a Scripts menu option. 

How to Create a Scripts Menu Option 

The first thing you'll need to do is create a Scripts menu. Unless you've loaded other plugins 
into VRED, this will be missing from your menu bar. Do the following to add a Scripts menu to 
your menu bar: 

Windows (Create a Scripts Menu Option) 

1. In a browser window, navigate to: 

C:\\Users\\<user>\\Documents\\Autodesk\ 

2. Right-click and select New > Folder. 
3. Name the folder VRED-11.0. 
4. In the VRED-11.0 folder, right-click, and select New > Folder. 
5. Name the folder ScriptPlugins. 

Mac (Create a Scripts Menu Option) 

1. In a Finder window, from the column to the left, select Documents, then the Autodesk 
folder in the space to the right. 

2. From the menu bar, select New > New Folder. 
3. Name the folder VRED-11.0. 
4. From the menu bar, select New > New Folder. This creates a folder within the folder 

VRED-11.0. 
5. Name the folder ScriptPlugins. 

IMPORTANT  The Scripts menu option won't appear in the menu bar until you've loaded scripts 
into your ScriptPlugins folder and restarted VRED. See Load an Example Script. 

How to Load an Example Script 

To load the example script, which will appear in your Scripts menu, do the following: 



Windows (Load an Example Script) 

1. Once you've created a ScriptPlugins folder, in a browser, navigate to: 

C:\\ProgramData\\Autodesk\\VREDPro-
<internalVersion>\\Examples\\plugins 

2. Copy the SimpleExample folder and paste it into the ScriptPlugins folder: 

C:\\Users\\<user>\\Documents\\Autodesk\\VRED-11.0\\ScriptPlugins\ 

3. Save your work, then close and restart VRED. The Scripts menu is now displayed in 
the menu bar. When you select it, you'll see the example, called SimpleExample, 
listed. 

Mac (Load an Example Script) 

1. Once you've created a ScriptPlugins folder, in a Finder window, navigate to: 

/Users/Shared/Autodesk/VRED-
<internalVersion>/examples/plugins/SimpleExample 

2. Copy the SimpleExample folder and paste it into the ScriptPlugins folder: 

C:/Users/<user>/Documents/Autodesk/VRED-11.0/ScriptPlugins/ 

3. Save your work, then close and restart VRED. The Scripts menu is now displayed in 
the menu bar. When you select it, you'll see the example, called SimpleExample, 
listed. 

How to Use Environment Variables to Define a Path 

For another way to create the Scripts menu and add the script plugins, try setting an 
environment variable. 

There are two kinds of environment variables, one that's version-dependent and one that's not. 
You can only define one version-dependent environment variable with an absolute path per 
VRED version. There is no limitation like this for non-dependent ones. 

How to Set an Environment Variable on Windows 

1. Access your Control Panel. 
2. In the search field at the top of the window and to the right, type: 

environment variable 



3. On the new page, click the link for editing the system environment variables. This opens 
the Advanced tab of the System Properties window. 

4. Click the Environment Variables button. 
5. In the System variables section, click the New button to open the New System Variable 

window. 
6. Enter the name of the variable (VRED2019\_SCRIPT\_PLUGINS), followed by the value 

(C). 
7. When finished, click OK. 

How to Set an Environment Variable on Mac 

1. Open a terminal window. 
2. Type the following command: 

export <variable name>=<value> 

export= VRED2018\_2\_SCRIPT_PLUGINS=C 

How to Use Non-dependent Variables 

Use VRED\_SCRIPT\_PLUGINS to define where VRED looks for script plugins. This will add the 
variable to: 

/Autodesk/VRED-<internalVersion>/ScriptPlugins 

If you enter:  

VRED\_SCRIPT\_PLUGINS=C: 

you set the search path for script plugins to:  

C:/Autodesk/VRED-<internalVersion>/ScriptPlugins 

How to Use Version-dependent Variables 

To use a version-dependent variable, you need to properly identify the version you're targeting. 
When you run VRED, the version is displayed in the title bar. If you see 2019, in the variable, 
you would change this to 2019. 

For example, for version 2018.2, the variable name would be VRED2018\_2\_SCRIPT\_PLUGINS 
and for 2019, it would be VRED2019\_SCRIPT_PLUGINS. 



Rendering 



Adjusting Render Settings and Modes 

How to Enable Raytracing 

1. Select Visualization > Toggle Raytracing. 

When raytracing is on, the indicator  is enabled in the Toggle Raytracing menu item 
and on the main toolbar. 

2. Select Visualization > Raytracing Downscale, then select a level of downscaling to speed 
up interaction time, as necessary. 

How to Enable Rendering 

1. Select Visualization > Rendering to toggle Rendering on and off. 

When rendering is on, the indicator  is enabled beside the Rendering menu item and 
on the main toolbar. 

2. Optional - From the Visualization menu, select a rendering type. 

How to Adjust Stereo Settings 

Select Visualization > Stereo, then select a stereo option. 

How to Use Sceneplates 

To add sceneplates (frontplates and backplates) to the scene, see the sections that follow. 

To toggle the display of all sceneplates on or off, click Visualization > Sceneplates and 
uncheck/check Toggle Sceneplates. 

How to Use Frontplates 

To add a frontplate to the scene: 

1. Select Visualization > Sceneplates > Frontplates. 
2. Select an image file to use as the frontplate. 
3. To toggle the frontplate display, click Visualization > Sceneplates and uncheck/check 

Frontplates. 



 

To delete a frontplate from a scene: 

1. Select Scene > Sceneplate Editor. 
2. In the Sceneplate Editor, tap the frontplate you want to delete to select it. 

3. At the bottom of the Sceneplate Editor, click . 

How to Use Backplates 

To add a backplate to the scene: 

1. Select Visualization > Sceneplates > Backplates. 
2. Select an image file to use as the backplate. 
3. To toggle the backplate display, click Visualization > Sceneplates and uncheck/check 

Backplates. 

To delete a backplate from a scene: 

1. Select Scene > Sceneplate Editor. 
2. In the Sceneplate Editor, tap the backplate you want to delete to select it. 

3. At the bottom of the Sceneplate Editor, click . 

How to Use Realtime Antialiasing 

Antialiasing is a smoothing calculation that builds up the look of surfaces, materials, and 
textures. Use anti-aliasing options to give surfaces a more realistic appearance, but be aware 
that frame rate might be affected. 

Select Visualization > Realtime Antialiasing, then select one of the available options; in 
Raytracing mode, different levels of samples per pixel are applied. 

• Off - No antialiasing is used 
• Low - Four samples per pixel 
• Medium - Eight samples per pixel 
• High - 16 samples per pixel 
• Ultra High - 32 samples per pixel 

How to Adjust Advanced OpenGL Settings 

Select Visualization > Advanced OpenGL Settings and choose from the available options. 



Render Options in the Visualization Menu 
These rendering options are available from the VRED Visualization menu. 

• Realistic Rendering - In raytracing mode, a selection of different render passes are 
provided for interactive display. To view composed rendering, choose Beauty Rendering. 

• Renderpasses Rendering - Allows you to interactively evaluate specific render passes in 
the viewport. This feature works in raytracing only. You can view the following: 

Combined Channels 

• Diffuse IBL 
• Diffuse Light 
• Diffuse Indirect 
• Glossy IBL 
• Glossy Light 
• Glossy Indirect 
• Specular Reflection 
• Incandescence 
• Translucency 
• Transparency Color 
• Background Color 

Material Channels 

• Diffuse Color 
• Glossy Color 
• Specular Color 
• Incandescence 
• Translucency Color 
• Transparency Color 
• Background Color 

Illumination Channels 

• Diffuse IBL Illumination 
• Diffuse Light Illumination 
• Diffuse Indirect Illumination 
• Glossy IBL Illumination 
• Glossy Light Illumination 
• Glossy Indirect Illumination 
• Translucency IBL Illumination 



• Translucency Light Illumination 
• Translucency Indirect Illumination 
• Specular Indirect Illumination 

Image Processing 

• Fog 
• Lens Flare 

Auxiliary Channels 

• Occlusion 
• Mask 
• Depth 
• Material ID 
• Normal 
• Position 
• View 
• Vertex/Face Normal Rendering - Gives visual feedback about the orientation of vertex 

and face normals. See To Work with Normals. 
• Ambient Occlusion Rendering - Enables pre-calculated ambient occlusion. 
• Indirect Illumination Rendering - Shows pre-calculated indirect illumination, or with 

photon mapping and final gathering enabled. Shows the final gather points. 
• Surface Analysis Rendering - Analyzes the quality of a surface. Options of this rendering 

mode are defined in the Surface Analysis module. 
• Analytic Rendering - Uses a basic shading quality, without distracting reflections. It only 

uses standard light sources and ignores IBL lighting. 
• Non Photorealistic Rendering - NPR rendering is an OpenGL render mode, for rendering 

schematic images. NPR shading supports outline rendering. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Rendering_Working_with_Normals_html


Stereo Options in the Visualization Menu 
Find these options under Visualization > Stereo. 

• Disabled - Disables stereo mode by default. 
• Double Buffered - Activates double-buffered rendering in OpenGL mode for a shutter 

stereo mode, when supported by the graphics board. 
• Horizontal Interlaced - Activates horizontal interlaced stereo rendering. This function 

produces an image with alternating lines for left and right eye. Televisions also use this 
function. 

• Vertical Interlaced - Activates vertical interlaced stereo rendering. 
• Left/Right Split - Splits the Render Window into two render areas. The left half of the 

Render Window draws the left eye’s field of view of stereo rendering. The bottom half 
draws the right eye's field of view. 

• Left/Right Split (Half) - Sets a half resolution mode for stereo television. 
• Top/Bottom Split - Splits the Render Window into two render areas. The top half of the 

Render Window draws the left eye’s field of view of stereo rendering. The bottom half 
draws the right eye’s field of view. 

• Red/Cyan - Activates red/cyan anaglyph stereo mode, which can be used with cheap 
glasses. 

• Blue/Yellow - Activates blue/yellow stereo rendering mode. The same as red/cyan with 
differently colored glasses. 

• Green/Magenta - Activates the green/magenta stereo rendering mode. 
• Left Eye - Activates only the left eye’s stereo rendering view. 
• Right Eye - Activates only the right eye’s stereo rendering view. 
• Stereo Settings - Opens the Stereo Settings dialog for setting stereo settings. 

 
o Eye Separation - Sets the viewer’s left and right eye distance in millimeters. 
o Zero Parallax Distance - Sets the viewer’s focus distance. This distance is the 

distance to a plane where the images for both eyes match. For example, if you 
are 1.50 m in front of a powerwall, the value is 1500mm. 

o Disable Stereo - Disables stereo rendering. 
o Auto - Calculates the eye distance depending on the view distance. 



Advanced OpenGL Settings in the Visualization 
Menu 
Find these options under Visualization > Advanced OpenGL Settings. 

• Wireframe - The wireframe button toggles wireframe rendering to On or Off. All 
currently selected objects are drawn in set render mode and a wireframe mode. The 
wireframe color can be set in - Edit > Preferences > Render Options > Wireframe. 

• Two-Sided Lighting - Enables/disables two-sided lighting. Use it to toggle the 
illumination of polygon backsides globally. 

• Realtime Shadow - Activates/deactivates real time shadows. Only available in OpenGL 
mode. 

• Ambient Occlusion Shadows - Activates ambient occlusion calculation. 
• Screen Space Ambient Occlusion Settings - Opens the Screen Space Ambient Occlusion 

Settings dialog for enabling SSAO and defining the following options: 
 

o Radius - The radius of the virtual hemisphere outside which occlusion is ignored. 
o Intensity - The darkness of the occlusion. The higher the value, the darker the 

shadows. 
o Blur Amount - The amount of blur to apply to the occlusion. 

SSAO provides an efficient, realtime approximation of the baked ambient 
occlusion (AO). Although SSAO will never be as good as precomputed AO, or 
even baked lighting and shadows, SSAO is good for quick previews. 

• Geometry Light Sources - Treats self-illuminated geometries as light source. Only in 
OpenGL render mode. Only active if Realtime Shadow is selected. 

• Backface Culling - Activates/deactivates backface culling. Backface culling renders only 
the faces with normals pointing toward the camera. 

• Occlusion Culling - Renders visible geometries only; the render engine excludes 
polygons/patches hidden by other objects on rendering. 

• Depth Only Pass - Renders the scene once, using only the depth values. It can be used 
for optimization with complex shaders. 



Working with Normals 
Visualization > Vertex/Face Normal Rendering 

How to Identify Normal Orientations 

Face and vertex normals can point toward or away from the camera. They might both point the 
same way ("consistent") or opposite ways ("inconsistent"). Use Vertex/Face Normal Rendering 
mode to identify the orientations that exist in your scene. 

Orientations are identified by color: 

• Green - Face and vertex normals are consistent and point toward the camera. 
• Blue - Face and vertex normals are consistent and point away from the camera. 
• Gold - Face and vertex normals are inconsistent. The face normals point away from the 

camera, while the vertex normals point toward the camera. 
• Magenta - Face and vertex normals are inconsistent. The face normals point toward the 

camera, while the vertex normals point away from the camera. 

How to Flip Normals 

Use the following mouse shortcuts to turn (flip) the normals of a selected object inward or 
outward. 

Mouse Action Result 

ALT-left button Flip whole shell 

ALT-middle button Flip selected patches only 

ALT-right button Flip connected patches 

How to Make Normals Consistent 

1. Select Edit > Selection > Make Normals Consistent. 
2. Use the appropriate mouse shortcut to flip the normals. When you do this, the normals 

are turned in the same direction. 



Rendering with Clusters 
Rendering > Cluster 

Use cluster rendering to speed up the rendering time by sharing the rendering process between 
multiple computers. Internally, the Scene Graph is transferred over the network to each 
computer, and then split into tiles for rendering. The result is sent back to the master, where 
the final image is composed. 

To configure a cluster, you must know the IP address or name of each host you intend to 
cluster. Each host must have a cluster service or version of VRED Professional installed. 

To avoid checking out unneeded render node licenses, you can disable individual hosts from the 
cluster service. 

Master and rendering nodes are connected through a network. The configuration is presented 
as a tree view with the global options, network options, and options for each rendering node. 

How to Configure a Cluster 

1. Choose Rendering > Cluster to open the Cluster module. 

 

2. In the left panel, select Options and choose Edit > Add network. 
3. Do any of the following: 

 
o To add rendering nodes individually, choose Edit > Add compute node and 

provide the Name under Compute node in the right panel. 
o To add many nodes at once, choose Edit > Cluster config to open the Cluster 

config dialog box. 



In the Configuration text box, add the configuration. A wide range of formats is 
recognized, including the connection string from the Cluster module in previous VRED 
releases. 

PC1 PC2 PC3 PC4 

PC1, PC2, PC3, PC4 

PC1 - PC4 

Master1 {PC1 PC2 PC3} 

Master1[forwards=PC1|PC2|PC3] 

Master1 {C1PC01 - C1PC50} Master2 {C2PC00 - C2PC50}  

You can also read the configuration from an externally generated file. For example, a 
startup script could generate a file that contains the names of all usable cluster nodes. If 
the Read configuration from file field contains a valid file name, then the configuration 
is read each time the Start button is clicked. 

NOTE  If the cluster nodes are in a local network that is not accessible from the host 
where VRED is running, then you must configure an intermediate node. This node must 
be connected to the same network as the host where VRED is running and through a 
second network card to the cluster network. In this setup, you must configure two 
networks. The first one is the network that connects VRED with the gateway note. The 
second is the network that connects the cluster nodes. 

 

4. Set cluster, network, and render node options in the right panel of the dialog. 
 

o To display cluster options, select Options in the left panel. 
o To display network options, select the Network node in the left panel. 
o To display render node options, select the node in the left panel. 



How to Import Legacy Cluster Configurations 

Since VRED 2016 SR1, the raytracing cluster configuration, and since VRED 2017, the display 
cluster configuration has changed. You can import the old configuration and convert it to the 
new format. 

In the Cluster dialog box, choose File > Import Legacy. 

How to Use the Same Cluster Node Multiple Times 

You can connect to the same cluster node from multiple instances of VRED. However, this can 
cause problems, as the available resources must be shared between multiple 
VREDClusterServer instances. 

For example, one problem could be bad performance, due to unpredictable load balancing 
results, or CPU usage by the other VREDClusterServer instance. When a second user tries to 
connect to the same cluster node, the following message appears: 

There is already a VREDClusterServer running on one or more of the requested cluster nodes. Do 
you really want to start clustering and risk performance problems? 

Another problem is the available memory. If large models are used, then it could be impossible 
to load multiple models into the memory of the cluster node. VRED tries to estimate how much 
memory is required. If the requested memory is not available, the following message appears: 

There is already a VREDClusterServer running on one or more of the requested cluster nodes and 
there is likely not enough free memory. Do you really want to start clustering and risk server 
instability? 

If VRED is forced to start the cluster server, then unpredictable crashes could happen on the 
server. 

Disable a host from cluster service 

You can disable individual hosts from cluster rendering. The disabled host does not check out a 
render node license. 

1. In the Menu Bar, choose Rendering > Render Settings to open the Render Settings dialog 
box. 

2. In the Render Settings dialog box, scroll down to the Cluster section, select Enable 
Cluster, and enter the host names. 

3. Add \[RT=0\] after a host to disable it. 



Set up a display cluster 

In a display cluster setup, the scene can be viewed on a number of hosts connected over a 
network. For a fully functional display cluster setup, the following information must be 
configured: 

• Network setup - All display nodes and optionally additional nodes for raytracing 
speedup must be configured in the Cluster dialog box. 

• Projection setup - You must define what should be visible on remote displays. For 
example, displays can be arranged as a tiled wall or as a cave. 

• Display setup - You must define which part of the projection should be visible on which 
display. The exact location of the viewport can be defined. Passive or active settings are 
selectable. 

• In the Menu Bar, choose Rendering > Cluster to open the Cluster dialog box. 
• Set up display nodes and any additional nodes for raytracing. 
• Click Display Setup to open the Display configuration dialog box. 
• Set up projections. 

Multiple projection types are supported. You can define projections for tiles walls, 
caves, or arbitrary projection planes. You can define multiple projection types for 
multiple displays. For example, VRED can handle a tiled display parallel to a cave 
projection. 

Projection types, like Tiled Wall or Cave, generate child projections for each single 
display. Child projections are read-only. If the generated projections must be changed to 
fit the real-world situations, right-click on them and choose Convert to planes to convert 
them to plane projections. Then, you can edit each plane individually. 

• Set up displays. 

If the projection is defined, then each projection must be mapped to a window on one 
of the cluster nodes. All windows belonging to the same display are grouped together 
into a display node. 

Displays, Windows, and Viewports can be copied and pasted, using the right-click menu. 
This simplifies the definition if, for example, the whole display is composed of similar 
windows. 

Enable hardware sync 

VRED supports swap sync between multiple cluster nodes. Sync hardware, like the NVidia 
Quadro Sync, must be installed, properly configured, and connected. If all these preconditions 
are available, then the Hardware Sync property of the display properties can be enabled. All the 
connected displays should do the buffer swap synchronized. 



Network Requirements 

The network hardware is the limiting factor for the maximum reachable frame rate and the 
speed with which the Scene Graph can be distributed to the rendering nodes in a cluster. We 
have measured frame rates and data transfer rates on a 32-node cluster with different network 
configurations. We used a very simple scene with CPU rasterization to generate the images to 
ensure the rendering speed is not CPU bound. All measurements were taken in a dedicated 
network without other traffic and well configured network components. 

The data transfer rate is always limited by the slowest network link in the cluster. Infiniband can 
in theory transfer up to 30GBit/s, but the 10GBit link from the master makes it impossible to 
reach this speed. Currently, we have no experience with large clusters connected by 10GB 
Ethernet. The 10GB>Infiniband configuration has been tested with up to 300 nodes. 

Network Uncompressed (MB/s) Medium (MB/s) High (MB/s) 

10GB->Infiniband 990 1100 910 

10GB->1GB 110 215 280 

1GB 110 215 280 

In contrast to the transfer rate of the Scene Graph, the frame rate is, in some cases, not limited 
by the slowest connection. If the rendering nodes are connected to a 1GBit Switch with a 
10GBit uplink to the master, then 10 renderings nodes can, in sum, utilize the whole 10GBit 
uplink. As for large clusters, the influence of network latency becomes more important. 
Infiniband should be the preferred cluster network. 

Resolution Network 
Uncompressed 

(fps) 
Lossless 

(fps) 
Medium Lossy 

(fps) 
High Lossy 

(fps) 

1024x768 
10GB-

>Infiniband 
250 220 300 250 

 10GB->1GB 250 220 300 250 

 1GB 50 100 145 220 

1920x1080 
10GB-

>Infiniband 
130 120 200 130 

 10GB->1GB 130 120 200 130 



Resolution Network 
Uncompressed 

(fps) 
Lossless 

(fps) 
Medium Lossy 

(fps) 
High Lossy 

(fps) 

 1GB 20 40 50 130 

4096x2160 
10GB-

>Infiniband 
40 40 55 40 

 10GB->1GB 40 40 55 40 

 1GB 5 10 15 40 

8192x4320 
10GB-

>Infiniband 
10 12 14 13 

 10GB->1GB 10 12 14 13 

 1GB 1 2 3 10 

We have tested Mellanox and QLogic/Intel Infiniband cards. For 10 GB Ethernet, we used an 
Intel X540-T1 network card. 

VRED will try to use as much bandwidth as possible. This can cause problems with other users 
on the same network. Otherwise, that is, large file transfers on the same network will slow 
down the rendering. If possible, try to use dedicated network infrastructure for the cluster. 

Start the cluster service 

For cluster rendering, a rendering server must be started on the rendering node. To be able to 
automate this process, VREDClusterService is used. This program starts and stops cluster 
servers on demand. 

By default, the service listens on port 8889 for incoming connections. Only one service can be 
started for a single port at a time. If there should be multiple services started, then each service 
must use a different port. Use the -p option to specify the port. 

For testing, VREDClusterService can be started manually. Adding the options -e -c will produce 
some debug information on the console. 

On Windows, the VRED installer will add a system service "VRED Cluster Daemon". This service 
is responsible for starting VREDClusterService on system startup. You can check this by selecting 
"view local services" from the Windows Control Panel. The path should point to the correct 
installation, startup type should be "automatic", and service status should be "started". 



On Linux, the service must be started by adding bin/vredClusterService to the init system or by 
running bin/clusterService manually. 

1. Click Start Cluster at the bottom of the dialog box. 

This starts the VREDClusterService in Windows. This service will process the rendering, 
instead of VRED itself. 

2. In the Main Menu, select Rendering > Render Settings and enter a path to which to save 
the rendering. 

3. In the Render Settings dialog box, click Render. 

The Cluster Snapshot dialog box opens. It shows you a preview of the rendering and its 
progress. 

4. At any point during the rendering process, select Update Preview in the Cluster 
Snapshot dialog box to update the preview image. 

5. You can click Cancel & Save at any point to abort the rendering and save its current state 
to a file, or wait until the rendering is finished and click Save. 

Disable a host from the cluster service 

You can disable single hosts from the cluster service. The excluded hosts do not check out a 
render node license. 

1. In the Main Menu, choose Rendering > Render Settings to open the Render Settings 
dialog box. 

2. In the Render Settings dialog box, scroll to the Cluster section and select Enable Cluster. 
3. Enter the host names and add \[RT=0\] after the hosts to disable. 

VRED Cluster on Linux 

Extracting the Linux installation 

The Linux VREDCluster installer is shipped as a self-extracting binary. The filename of the 
package contains the version number and a build date. To be able to extract the content to the 
current directory, run the installer as a shell command. 

sh VREDCluster-2016-SP4-8.04-Linux64-Build20150930.sh 

This creates the directory VREDCluster-8.04, containing all the files required for cluster 
rendering. Each cluster node must have read permission to this directory. It can be installed 
individually on each node or on a shared network drive. 



To be able to connect a cluster node, the cluster service must be started. This can be done by 
calling the following command manually or by adding the script to the Linux startup process. 

 

Automatically start VRED Cluster Service on Linux startup 
 
On Linux, there are a many ways for starting a program on system startup. There are slightly 
different ways for each Linux distribution. One possible solution is to add the start command to 
/etc/rc.local. This script is executed on startup and on each runlevel change. 
 
If the installation files are, for example, stored in /opt/VREDCluster-8.04, then rc.local 
should be edited as follows: 
 
#!/bin/sh -e 
 
killall -9 VREDClusterService 
 
/opt/VREDCluster-8.04/bin/clusterService & 
 
exit 0 

If you do not want to run the service as root, you could start the service, for example, as 
vreduser. 

#!/bin/sh -e 

killall -9 VREDClusterService 

su - vreduser '/opt/VREDCluster-8.04/bin/clusterService &' 

exit 0 

 
Another option to start the VRED service on system startup is to add an init script to 
/etc/init.d. Copy the init script from the installation directory bin/vredClusterService to 
/etc/init.d. Then, you must activate the script for different run levels. 
 
On Redhat or CentOS Linux use: chkconfig vredClusterService on 

On Ubuntu use update-rc.d vredClusterService defaults 

Connecting a license Server 

The address of the license server must be stored either in a config file in your home directory 
.flexlmrc or can be set as an environment variable ADSKFLEX\_LICENSE\_FILE. If the server 
is named mylicenseserver: 

~/ .flexlmrc should contain: ADSKFLEX\_LICENSE\_FILE=@ mylicenseserver 



or add to your login script: export ADSKFLEX\_LICENSE\_FILE=@ mylicenseserver 

Make sure to setup the environment for the user that starts the cluster service. 

Accessing log information 

Log files will be written to the directory /tmp/clusterServer/log. Log files should be viewed 
with a web browser. For trouble shooting, it could be helpful to start the cluster service in 
console mode. Stop a running cluster service and start bin/clusterService -e -c manually. 
Now, all debug and error messages are written to the console. 

Useful commands 

Check, if the service is running: ps -C VREDClusterService 

Stopping the cluster service: killall -9 VREDClusterService 

Stopping a cluster server: killall -9 VREDClusterServer 

Fully nonblocking networks/blocking networks 

A fully nonblocking network allows all connected nodes to communicate with each other with 
the full link speed. For a 16-port GB switch, this means that the switch is able to handle the 
traffic of 16 ports reading and writing in parallel. This requires an internal bandwidth of 32 
GBit/s. VRED will work best with nonblocking networks. For example, the transfer of the Scene 
Graph is done by sending packages from node to node, like a pipeline. This is much faster than 
sending the whole scene directly to each node. 

If possible, do not use network hubs. A hub sends incoming packages to all connected nodes. 
This will result in a very slow Scene Graph transfer. 

On large clusters, it could be very expensive to use fully nonblocking networks. If the cluster 
nodes are connected to multiple switches, then a satisfactory performance could be reached by 
simply sorting the rendering nodes by the switches they are connected to. 

For example, if you have a cluster with 256 nodes, these nodes are connected to 4 switches. 
The worst configuration would be: 

Node001 Node177 Node002 Node200 Node090 ... 

A better result could be achieved with a sorted list: 

Node001 - Node256 



If this configuration causes any performance problems, you could try to model your network 
topology into the configuration: 

Node001 { Node002 - Node064 } 

Node065 { Node066 - Node128 } 

Node129 { Node130 - Node192 } 

Node193 { Node194 - Node256 } 

 

With this configuration, the amount of data that is transferred between the switches is 
efficiently reduced. 

Troubleshooting 

 
Unable to connect a rendering node 
 

• Use ping hostname to check if the node is reachable. 
• Try to use the IP-Address instead of the host name. 
• The port 8889 must be allowed through the firewall. 
• VREDClusterService must be started on the rendering node. Try to connect over a web 

browser with [http://hostname:8889](http://hostname:8889). 

 
Unable to use Infiniband to connect cluster servers 
 

• Communication over Infiniband without an IP layer is only supported on Linux. 
• The Infiniband network must be configured properly. Use ibstat to check your network 

state or use ib\_write\_bw to check the communication between two nodes. 
• Check ulimit -l. The amount of locked memory should be set to unlimited. 
• Check ulimit -n. The number of open files should be set to unlimited or to a large 

value. 
• If it's not possible to run VREDClusterServer over Infiniband, in most cases, IP over 

Infiniband can be used with very little performance loss. 

 

Occasional hangings by an otherwise high frame rates 
 

• Maybe the network is used by other applications. 
• Try to change network speed to Auto. 
• Try to reduce image compression or set image compression to Off. 



The frame rate is not as high as expected 
 

• If the CPU usage is high, rendering speed is limited by the CPUs. Frame rates can be 
increased by reducing the image quality. 

• If the CPU usage is low and the network utilization is high, then enabling compression 
could provide higher frame rates. 

• Small screen areas with very complex material properties can lead to a very bad load 
balancing between the rendering nodes. The result is a low CPU usage and a low 
network usage. The only option, in this case, is to locate these hot spots and reduce the 
material quality. 

 
Why is the network utilization less than 100%? 
 

• If the rendering speed is limited by the CPU, then network utilization will always be less 
than 100%. Providing a faster network will, in this case, not provide a higher frame rate. 

• Try to use tools like iperf to check the achievable network throughput. On 10 GB 
Ethernet, VRED uses multiple channels to speedup communication. This could be 
simulated with iperf -P4. Check the throughput in both directions. 

• Network speed is limited by the used network cards, and by the network switches and 
hubs. If the network is used by many people, then the throughput can vary strongly 
from time to time. 

• Tests have shown that it is very difficult to utilize 100% of a 10 GB Ethernet card on 
Windows. Without optimization, you can expect 50%. You can try to use measurement 
tools and adjust performance parameters for your network card. If the rendering speed 
is really limited by your network, then you should set image compression to "lossless" or 
higher. 

• For Intel 10GB X540-T1 Ethernet cards, the following options could increase the network 
throughput on Windows: 

 
o Receive Side Scaling Queues: Default = 2, changed to 4 
o Performance Options / Receive Buffers: Default = 512, changed to 2048 
o Performance Options / Transmit Buffers: Default = 512, changed to 2048 

• Sometimes installing the network card into another PCI slot can increase the network 
throughput. 

• On Linux, you could increase the parameters net.ipv4.tcp_rmem, 
net.ipv4.tcp_wmem, net.ipv4.tcp_mem in /etc/sysctl.conf. 



Why is the CPU utilization less than 100%? 

• If the rendering speed is limited by the network, CPU utilization will not reach 100%. 
• To distribute the work between multiple rendering nodes, the screen is split into tiles. 

Each node then renders a number of these tiles. In most cases, it is not possible to 
assign each node the same amount of work. Depending on the scene, this can lead to a 
low CPU utilization. 

Mellanox Infiniband with Windows 

• With the Mellanox MLNX\_VPI\_WinOF infiniband driver for Windows, it is possible to 
use TCP over Infiniband to connect cluster nodes. Use the following network settings: 
 

o Network: selected 
o Network type: Ethernet 
o Network speed: 40 GB 
o Encryped: Not selected 

 
• It is not possible to connect to a Linux network if Linux is configured to use Connected 

Mode. Make sure the MTU on all connected nodes is equal. 



The Cluster Dialog Box 
Rendering > Cluster 

Menu 

• File - Contains the following file options: 
 

o New - Creates a new set of presets for clustering. 
o Load - Loads the presets for clustering from an .xml-file. 
o Import Legacy - Loads the presets for clustering from a legacy .xml file. 
o Save - Saves the current definitions into a cluster configuration file (.vhpc). 
o Save As - Saves the current definitions into a cluster configuration file (.vhpc). 

 
• Edit - Contains the following editing options: 

 
o Cluster Config - Opens the Cluster Config dialog box, where you can add multiple 

render nodes at once. 
 

 Read Configuration From File - Select a configuration file containing the 
names of all usable cluster nodes. The file could be externally generated. 
For example, a startup script could generate a file that contains the 
names of all usable cluster nodes. The configuration file in this field is 
read each time the Start button is clicked. 
 

• Configuration - Add the configuration. A wide range of formats is recognized, including 
the connection string from the Cluster module in previous VRED releases. 

PC1 PC2 PC3 PC4 

PC1, PC2, PC3, PC4 

PC1 - PC4 

Master1 {PC1 PC2 PC3} 

Master1[forwards=PC1|PC2|PC3] 

Master1 {C1PC01 - C1PC50} Master2 {C2PC00 - C2PC50}  

o Add Compute Node - Adds a rendering node to the cluster. 
o Remove Compute Node - Removes a rendering node from the cluster. 
o Add Network - Adds a network to the cluster. 
o Remove Network - Removes a network from the cluster. 



Cluster Options 

• Data Compression - Compression method used to transfer the scene graph from VRED 
to the cluster nodes. 
 

o Off - No compression. 
o Medium - Fast but low compression ratio. 
o High - Slow but higher compression ratio. 

 
• Image Compression - Compression method used to transfer the rendered images from 

the cluster nodes to VRED. 
 

o Off - No compression. 
o Low (lossless) - Low compression without loss of quality. 
o Medium (lossy) - Fixed compression ratio of 1/3 and fast. 
o High (lossy) - Slow but high compression ratio. 

 
• Start/Stop Action - This option can be used to prevent excessive rendering times on 

cluster stop or cluster crash. 
 

o Do nothing - No action is performed on cluster start or cluster stop. 
o Downscale Off/On - Switch downscale Off on cluster start and back to On when 

the cluster stops. 
o Raytracing On/Off - Enable raytracing during cluster rendering and use OpenSG 

rendering when the cluster stops. 
o Rendering On/Off - Rendering is switched off, when the cluster is not running. 

 
• Still Supersampling - If the CPU use during still antialiasing is poor, then by increasing 

the image size the use could go up. With a supersampling of 2x2, 4 pixels are rendered 
by the cluster and later combined to a single pixel. To get the same rendering quality, 
the number of image samples should be reduced by a factor of 4. (9 with 3x3, 16 with 
4x4) 

Advanced 

• Homogeneous cluster - If not selected, the load balancer measures the performance of 
the render nodes when the cluster connection starts. If selected, the load balancer 
assumes that the render nodes perform the same as each other and does not measure 
their performance. Select this option if all render nodes use the same hardware to avoid 
unnecessary and possibly inaccurate measurements. 

• Parallel Frames - On clusters with many nodes (>100) and low-resolution rendering, use 
this option to increase the frame rate. If there are 500 nodes and Parallel Frames is set 



to 2, then 250 nodes are rendering one image while 250 are rendering the next image. 
This increases the latency and should only be used on high frame rates. 

• Frame Buffers - VRED is able to render a new image while the last images are still 
transferred over the network. Slow internet connections increasing the number of 
frame buffers could increase the frame rate. 

Network Options 

• Description - For documentation only. 
• Enabled - If not selected, all the nodes connected to this network will not be used 

during cluster rendering. 
• Encrypted - The whole communication in the network is encrypted. For each session a 

new key is used. The communication is safe against listening and recording network 
sessions. If you expect attacks to your network infrastructure and elaborate "man in the 
middle" attacks, you should consider using other mechanisms like encryption hardware 
or encryptions that are secured by signed certificates. 

The following algorithms are used for encryption: 

o Key negotiation - Unified Diffie-Hellman, Ephemeral Unified Model Scheme 
(X9.63) or Static Unified Model (NIST). 1024 Bit 

o Transport layer security - AES128 Bit. 
 

• Network Type - Contains the following network type options: 
 

o Ethernet - Standard network connection 
o Infiniband - On linux the ibverbs interface is used to communicate with 

infiniband network cards. In some situations, this can be faster than using IPoIB. 
To be able to use Infiniband, the nodes must also be reachable over Ethernet. 
 

• Network Speed - VRED uses this option to optimize the communication. In most cases, 
select Auto. With 10GBit Ethernet you can get a higher throughput by selecting 10 
Gigabit. If you have a 10GBit link to a 1GBit switch, then select 10G Uplink to 1G. 

• Service Port - This is the TCP socket port where the VREDClusterService is listening for 
incoming connections. Communication over this port must not be blocked by a firewall. 
8889 is the default port. To start VREDClusterService on another port, use the -p option. 

Compute Node 

• Name - IP address or host name of the compute node. 
• Enabled - If not selected, this node is not used for cluster rendering. 
• Use for Raytracing - If not selected, this node is not used for raytracing and no 

raytracing license is required. 



Display Setup 

Opens the Display Configuration dialog box, where you can set up a cluster to project (for 
example, on Powerwall or Cave). 

Icon Bar 

• Start Cluster - Starts the Cluster. 
• Stop Cluster - Stops the Cluster. 



The Display Configuration Dialog Box 

Projections 

Convert to Planes 

Projection Options 

• Name - This name is used to assign projections to windows. 
• Type - Contains the following type options: 

 
o Wall (No head tracking) - Select this type for a tiled wall. In a tiled wall 

projection setup a projection is composed with multiple projectors or multiple 
displays. Each projector or display projects a tile of the whole image. Tiles are 
arranged in rows and columns. Rows are counted from bottom to top and 
columns are counted from left to right. Tiles can overlap each other, and the 
overlapping edges can be blended. If stereo display has an offset between the 
left and the right eye, then the offset from the left to the right eye must be 
provided. 

Row 2, Col 1  Row 2, Col 2  

Row 1, Col 1  Row 1, Col 2  

There are two similar tiled projections supported. The first one does not support 
head tracking. For this setup the exact geometry of the display must not be 
provided. So, if head tracking is not required, this setup should be used. 

o Power Wall - For a tiled display with head tracking support. The projection plane 
must be defined in mm. The center of the tracking system must be calibrated to 
lie in the center of the projection wall. 

o Cave - For a cave-like projection. A cave consists of multiple orthogonal 
projections. It is defined as a cube. Each side of the cube can be defined as a 
projection plane. Consider a person standing in the middle of the cave cube, 
then the projection planes are named relative to this person as front, back, left, 
right, bottom and top. If the walls of the cave are not aligned to a cube, for 
example the floor projection is shorter than the left or right wall, then multiple 
cave projections can be used or some sides of the cave can be defined as 
projection planes. 



o Plane - A projection plane is the most flexible projection type. It is possible to 
define any rectangular area in 3D space as a projection area. The plane is defined 
by 3 points in space. 

o Tile - Contains the following tile options: 

Wall Parameters 

• Distance - The zero-parallax distance. 

Tile Parameters 

• Tile - For Tile projection type only. 
• Tile Layout - Number of vertical rows and horizontal columns. 
• Tile Overlap [pixel] - Number of pixel for horizontal and vertical tile overlap. 
• Right Eye Offset [pixel] - For Wall and Tile projection types only. If left and right eye 

projections are not congruent, then you can give the offset as the distance from the left 
to the right eye in pixels. 

• Edge Blending - Blends overlapping regions. 

Power Wall Parameters 

• Projection Area [mm] - Width and height of the projection in mm. 
• Distance - Distance from the origin of the tracker to the projection plane 

Cave Parameters 

• Cave Size [mm] - The size of the cave cube in mm. 
• Cave Center [mm] - Distance from the origin of the tracker to the cave center. 
• Cave Walls - Select the walls to use. 

Plane Parameters 

• Projection Plane - 3 corner points of the projection plane must be defined in counter 
clock order. 

Display Options 

If the projection is defined, then each projection must be mapped to a window on one of the 
cluster nodes. All windows that belong to the same display are grouped together into a display 
node. 

• Eye Separation [mm] - Defines the distance between left and right eyes in millimeters. 



• Camera - You can set different cameras to each display. Mapping is done by camera 
name, so it can be stored in the display cluster configuration file. If the camera cannot 
be found, the active camera from the master is used. 

• User - You can specify the tracking user for the projection. With this option, you can 
drive two different caves with independent head tracking for the same scene. The 
option can be found in the display settings of the cluster module or in the body options 
of the tracking module for target type Head Projection. 

• Hardware Sync - If the graphics driver supports buffer swap syncs, then select this 
option to synchronize the buffer swaps. To synchronize buffer swaps between multiple 
cluster nodes, a special sync hardware and sync network is required, for example 
Quadro Sync from NVidia. 

Window Options 

• Render Node - The name of a compute node that should be used as graphics output. 
• Screen - If multiple displays are connected, then the screen number is used to select one 

of the displays. 
• Full Screen - The whole screen area is used. 
• Geometry - If Full Screen is not selected, the geometry parameters are used to define an 

area on the screen where the window should be visible. 

Viewport Options 

A viewport defines an area on a window where the scene should be visible. Each viewport is 
responsible to view one projection. 

• Projection - Select the projection that should be visible on this viewport. 
• Stereo - Stereo parameter: 

 
o Disabled 
o Left 
o Right 
o Double Buffered 
o Horizontal Interlaced 
o Vertical Interlaced 
o Left/Right Split 
o Top/Bottom Split 
o Red/Cyan 
o Blue/Yellow 

For definitions of these stereo modes, see Stereo Options in the Visualization Menu. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Rendering_Stereo_Options_in_the_html


• Position - Defines the position of the viewport in the window. Select Custom to define 
the exact position in pixels. Viewport positions, Lower left and Upper right, can be 
defined in pixel values >1 or relative to the window [0-1]. 

• Flip - The displayed image can be mirrored horizontally or vertically. 



To Use Render Layers 
Use Render Layers to define how single geometries should be rendered and displayed. This 
feature is only available in Raytracing mode. The procedure described here uses a car and its 
accompanying geometries as an example. 

1. Ensure raytracing is enabled (Visualization > Toggle Raytracing). 
2. Select Rendering > Render Layer. 
3. Right-click within the Render Layer dialog box and select Create Layer. 
4. Double-click the new render layer to rename it; for example, "Car." 
5. Select Scene > Scenegraph. 
6. Drag geometry from the Scene Graph onto the new layer; for example, in this case, you 

could drag the geometry of the car onto the Car layer you created. 
7. Follow the same steps to create another layer named "Wheels" containing geometry for 

the wheels. 
8. Double-click inside the columns of the Render Layer dialog box to disable or enable 

different levels of visibility for the geometry in each layer. 

For example, you could turn PrimaryVisibility off for the car, and the geometry of the car 
will not be visible, but its other effects will be, such as shadows. 

9. Click  (Activate Layer) to see the results of your selections. 



The Render Layer Dialog Box 
Rendering > Render Layer 

Use the Render Layer Module to define how single geometries should be rendered and 
displayed. This feature is only available in Raytracing mode. Once a layer is created, you can 
assign geometries to it by dragging nodes from the Scene Graph. To see to layer attribute 
changes, activate the layer from the context menu or by using the icon in the tool bar. 

NOTE The order in which Render Layers are activated is important. If in doubt, reset, then 
activate the Render Layers in the correct order. 

For each Render Layer, the attributes can be activated (On) and deactivated (Off) by double-
clicking the entry. To enable/disable several attributes from different nodes at the same time, 
right-click the layer and select Apply Attributes to Selected from the context menu. 

The following attributes are available: 

• Visible - Sets the attributes for Color and Alpha Channel. Not selecting this attribute 
excludes the objects from the rendering. 

• Visible In Alpha - Affects attributes for the Alpha Channel. Not selecting this attribute 
excludes the related objects from the rendered alpha channel (for example, to produce 
cutouts). 

• Primary Visibility - Sets the attribute for the Color Channel. Not selecting this attribute 
results in a color channel where the related objects are not contained; however, they 
still cast shadows and can be seen within reflections. 

• Visible In Reflections - Sets the attributes for reflection. Not selecting this attribute 
disables object's visibility within reflections. 

• Visible In Refractions - Sets the attribute for refractions. Not selecting this attribute 
disables object's visibility within refractions. 

• Cast Shadows - Sets the attribute for casting shadows. Not selecting this attribute 
prevents the objects from casting shadows. 

• Receive Shadows - Sets the attribute for receiving shadows. Not selecting this attribute 
prevents the objects from receiving shadows. 

• Double Sided - Results in rendering both sides (front face/back face) of the related 
objects. When the attribute is not selected, only the front faces are rendered. 

• Visible For Photons - When not selected, photon algorithms ignore the objects within 
this layer. 

• Cast Shadows On Shadow Material - Sets the attribute for casting shadows on shadow 
material. Not selecting this attribute prevents the objects from casting shadows on 
shadow materials. 

• Use Override Material - Double-click within the UseOverrideMaterial column to toggle 
the Override Material on and off. 



• Override Material - Drag any material to the Override Material column to add it as an 
override material. 

Context Menu 

• Create Layer - Creates an empty Render Layer. 
• Rename - Renames the selected Render Layer. 
• Delete - Deletes the selected Render Layer. 
• Duplicate Layer - Duplicates the selected Render Layer. 
• Move Up - Moves the selected Render Layer up in the stack. 
• Move Down - Moves the selected Render Layer down in the stack. 
• Apply Attributes to Selected - Adopts checked/unchecked attributes to all selected 

Render Layers. 
• Add Selected Nodes - Adds selected objects from the Scene Graph to selected Render 

Layer. 
• Select Nodes - Selects all nodes contained in the Render Layer within the Scene Graph. 
• Cleanup - Removes non-existing objects from Render Layers. 
• Activate Layer - Activates the Render Layer and adopts settings within the Render View. 
• Reset Layer - Deactivates all Render Layers. 

Icon Bar 

• Creates a new Layer - Creates a new empty Render Layer. 
• Duplicates the current selected Layer - Duplicates the current selected Render Layer 

(with all the nodes and attributes). 
• Select the notes - Selects the corresponding notes from the Render Layer within the 

Scene Graph. 
• Deletes the currently selected note or Layer - Deletes the currently selected note or 

layer. 
• Deactivates all Layers - Deactivates all layers inside the Render Layer module. 
• Activates the Layer - Activates the current selected Render Layer. 



To Manage Cluster Rendering 
The VRED Cluster Manager organizes the shared use of a central cluster by multiple users. It 
provides you the ability to book certain time slots and resources for cluster raytracing on a one-
time or periodic basis. Resources are booked for a user and each user must be registered, by an 
administrator, to use the system. You can see your reservations and the remaining available 
resources. Administrators manage all reservations and may stop sessions as necessary. A 
central server must be selected to work as the management server. The VREDClusterService 
does not require a license, but must be installed on the PC in use. Administrators can upload 
cluster configurations. The VRED Cluster Module should be used to create these configurations. 

Open the Cluster Manager 

Click Rendering > Cluster Manager. 

If the management PC has been configured, you can log in with the cluster manager. A user 
name and password are required. 

Initialize the management PC 

If the cluster service is installed on the management PC, each PC in the network can be used as 
a management node. When you log in for the first time, a dialog informs you that the cluster 
manager is initializing with the given user as an administrator. 

• Login with your user name and password. 

You can also execute the initialization from the command line. The command 
VREDNodePoolService -i, resets the database and asks for the name and password of an 
administrator. 

All settings and booked sessions are stored in a database file. The location of this file depends 
on the operating system. 

• Windows, if VREDClusterService is running as windows service: 

C:\\Windows\\System32\\config\\systemprofile\\AppData\\Roaming\\VREDClu
sterManager\\nodePool.db 

• Windows: 
C:\\users\\USER\\AppData\\Roaming\\VREDClusterManager\\nodePool.db 

• Linux: ~USER/.VREDClusterManager/nodePool.db 



You can control the location of these files with the environment variable 
VRED\_CLUSTERMANAGER\_PATH. For a running system, you can view the info page to see the 
location of the database file. 

User Management 

If the cluster service is running at the first login, users should start registering with the system. 
The most convenient way to use the system is to use the windows login names and register the 
users without a password. In this case, users are automatically logged in. If circumstances 
required the use of passwords, a login screen is displayed when the Cluster Manager module is 
opened. 

Configuration Management 

If users are added, one or more clusters must be configured. Create a cluster configuration with 
the cluster module. This configuration should include all available resources. 

You can use localhost in configurations. Compute nodes named localhost, 127.0.0.1, or 
::1 is ignored during scheduling. 

If configurations contain display cluster definitions, then all display nodes must be available to 
start the configuration. If not all display nodes are available, the resource overview shows 0% 
available resources. 

Resource Overview 

The resource overview shows available resources for an entire week. Available resources are 
shown as percentages and the actual number of available compute nodes. If all resources are 
available, the time slot is green. If no resources are available, the slot is red. If multiple clusters 
are available, the available resources can be shown for each cluster configuration. 

To Book One-Time Resources 

To reserve nodes, select a time from the resource dialog and select Book nodes from the 
context menu. The booking editor is displayed. 

To Book Periodic Resources 

To reserve nodes on a repeating basis, select the Type Periodic in the Bookings tab. Select a 
Start and End date for the rendering. Select Add Time Range to choose days and times for 
rendering to occur and save. 



Starting a Cluster Session 

Sessions that have been successfully booked can be started by selecting the booking, then the 
Start button. If the start time has already been reached, the cluster session starts immediately. 
If the start time has not been reached, a countdown is displayed until the session begins. 

Ending a Cluster Session 

The administrator determines what happens at the end of a session. A warning dialog can be 
shown before the end, the session can end automatically, or a dialog box can be shown that the 
session has ended. 

There are different ways to stop a running session. You can stop running sessions by selecting 
the stop button in the Cluster Manager module or by selecting Stop in the cluster module. If a 
session was started on the local PC, an orange arrow is shown. If the session was started on 
another PC in the network, a blue arrow is shown. With this method, you can stop your session 
from any PC in the network. Administrators can use this function to stop sessions started by 
other users. If an administrator stops a session from other users, the session is marked as 
aborted. 

Cluster Queues 

The cluster manager can be used to do offline rendering. If a job queue is configured, the 
current scene and settings can be sent to the cluster manager for batch processing. Once a job 
is created, the current VREDPro instance is no longer part of the rendering process and can be 
closed or used for other work. Jobs in a cluster queue are processed in order of creation. 

Configuring cluster queues 

A cluster queue is a special configuration. A queue master must be defined. A VREDPro instance 
is started to process render jobs on the computer in use. A cluster configuration can be loaded 
to increase the render speed. Nodes involved in the render process must be booked by an 
administrator. 

Local cluster queues 

Using a local host allows you to do background rendering. If the queue master is localhost and 
you are logged into a cluster manager on localhost, rendering is done on the same PC with no 
additional VREDPro licenses required. For local rendering queues, no booking is required. 



Adding jobs to a cluster queue 

Cluster render jobs can be created from the render settings, the render queue or from the 
Cluster Manager. 

Downloading results 

When a render job that you own has finished, you can download the result images by clicking 
the Disk symbol. After downloading, the job is removed. Job projects and the resulting images 
are encrypted and stored on the cluster manager PC and only accessible by the owner. An 
administrator can remove jobs, but can't download the results. 

Aborting or deleting jobs 

Deleting a job removes all results. Deleting a job that is running cancels the process. An 
administrator can delete all jobs; however, you can only delete jobs that you own. 

For problems with the cluster manager, see Cluster Manager Troubleshooting. 

http://help-staging.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Rendering_Cluster_Manager_Troubleshooting_html


The Cluster Manager Dialog Box 
Rendering > Cluster Manager 

The Cluster Manager organizes the shared use of a central cluster by multiple users. It provides 
you the ability to book certain time slots and resources for cluster raytracing. 

Login 

If the cluster service is installed on the PC in use, you can login with admin as the user name 
and password. Once logged in, you can change your user name and password in the Users tab. 
Using your system user name and password is recommended. 

• Server - Enter a server name for the cluster. If one is not known, contact your cluster 
administrator. 

• User Name - Enter your User name or admin. 
• Password - Enter your password or admin. 

Cluster Manager 

Bookings 

• Configuration - All available clusters are listed for selection. 
• Type - Select One-Time or Periodic to book nodes repeatedly for specific days and times. 
• Date range - You can select a date from the calendar or, to select a range of dates, hold 

Shift and select an end date. Only available when type is one-time. 
• Start Date - Start date of the booking series. Only available when type is periodic. 
• End Date - Last date of the booking series. Only available when type is periodic. 
• Day - Day of the week. Only available when type is periodic. 
• From - The start time of the cluster reservation. 
• To - The end time of the cluster reservation. 
• Number of nodes - The number of compute nodes to reserve. The administrator can 

restrict the maximum number of nodes. 
• Description - You can add additional comments. 

Resources 

• Configuration - Select the configuration to allocate resources for. 
• Date - Select a date to display a full week of resources. 



Users 

• Login name - User name. 
• Password - Administrators and users can change or remove passwords. 
• User type - Contains the following user type options: 

o Standard User - Allows reservation and use of resources. 
o Administrator - Allows management of resources, users, and configurations. 

Configurations 

• Type - Use Online cluster for online rendering or Job queue for offline rendering. 
• Name - The name of the configuration. This name is used for reservations or resource 

overviews. 
• Node Limit - The maximum number of nodes a user is able to reserve. If unlimited, all 

resources can be reserved. 
• Show warning - Defines when a user sees a warning dialog announcing the end of a 

session. 
• Stop session - Defines when a session is ended. 
• Queue Master - Offline rendering is performed on this computer. A VREDClusterService 

must be installed on this computer. 
• Description - Comments that can be attached to the configuration. 

Jobs 

• Add render - Add a render job with the current render settings. 
• Add queue - Add a render job with all active entries in the render queue. 
• Add sequences - Add a render job for all active sequences in the sequencer module. 
• Remove - Remove all selected jobs. An administrator can remove jobs that you do not 

own. 
• Abort - Stops a render job and leaves the rendered frames on the server. Starting the 

render job again deletes the existing frames and starts the render from the beginning. 
To continue the render at the point it was aborted, a new job must be created with a 
start point of where the render was stopped. 

• Start - Start processing. 
• Stop - Stop processing after current job is finished. Do not start new jobs. 



Cluster Manager Troubleshooting 
Here are some areas to look at when troubleshooting the Cluster Manager. 

Inconsistent frame rate 

The cluster manager updates its views periodically. During updates, there may be a drop in the 
frame rate. Close the cluster manager to stop updates and restore the frame rate. 

Unable to connect to a server 

• Use a ping command, from a windows command shell, to see if the server is reachable. 
• Determine if the VREDClusterService is running on your machine. 
• Check your firewall settings. The cluster manager uses port 8889. 
• Try to stop the VREDClusterService and start it from a windows command shell. Go to 

the bin/WIN64 folder of the VRED installation and call VREDClusterService -e -c. 
Check the console for error messages. 

Unable to render on a cluster queue 

• Check that there are render nodes booked for the cluster queue. 
• Check that you have an extra VREDPro license for the queue master PC. 
• Check that the queue is not paused. 



The Render Settings Module 
Rendering > Render Settings 

The Render Settings dialog contains a context menu and four tabs, File Output, General 
Settings, Raytracing Quality, and Display Output. 

Quality Settings Presets 

Click Quality Settings Presets to display a context menu for saving, loading, and deleting all 
settings entered in Render Settings. 

File Output (tab) 

Image 

• View - Provides a list of views from all cameras, viewpoints, predefined camera track 
animations, or variants (if the camera was active upon its creation). Select a view to be 
used for image calculation. If a track is chosen, all contained viewpoints are rendered 
automatically. 

• Filename - Sets the image file name and path where the rendered image file is stored. 
• Use Time Stamp - Appends a time stamp to the filename. 
• Image Size Presets - Offers a drop-down menu of presets for all the usual resolutions, 

such as PAL, NTSC, HD 720, HD 1080, and 4K. 
• Image Size - Enables you to enter a custom resolution when a preset image size has not 

been selected. If a preset from above is used, the corresponding amount of pixels for 
horizontal and vertical resolution are automatically filled in. 

• Printing Size - Sets width and height of the resulting print in centimeters. 
• Resolution - Sets the printing resolution in dots per inch. 
• Region Render - Restricts rendering to the rectangular region specified by the following 

coordinates: 
 

o Use Current Render Window Region - Sets the upper left and lower right corner, 
according to the rectangle selected in the Render Window. If the button is 
activated, upper left and lower right corners are updated automatically including 
any change of the region. 

o Upper Left Corner - Defines the X and Y coordinate for the upper left corner of 
the region frame. 

o Lower Right Corner - Defines the X and Y coordinate for the lower right corner of 
the region frame. 
 



• Render Mode - Sets the illumination mode applied for rendering the image to a file. The 
following render modes are available: 
 

o CPU Rasterization - This mode does not compute direct reflections, nor does it 
compute refraction or any other sophisticated visual effects. 

o Precomputed Illumination - This mode is comparable to VRED OpenGL rendering 
mode. It uses pre-computed Ambient Occlusion and indirect illumination for 
rendering and calculates specular reflections and refractions and correct 
shadows from light sources. 

o Precomputed+Shadows - This mode uses pre-computed image-based lighting 
and indirect illumination, without using pre-computed Ambient Occlusion values. 
Instead, it calculates shadows based on the active environment. 

o Precomputed+IBL - This mode uses pre-computed indirect illumination and 
samples the environment. 

o Full Global Illumination - This mode doesn’t use any pre-computed values. It 
accurately samples everything, using a physically-based approach. Other 
features, like Photon Mapping, require the render mode to be set to Full Global 
Illumination. 

IMPORTANT This value automatically changes the Still Frame illumination mode in the 
Raytracing Quality tab. 

• Render Quality - Sets the number of image samples used for rendering or use one of the 
following presets: 
 

o Draft 
o Preview 
o Production 
o Production Interior 

IMPORTANT This value automatically changes the Use Image Samples value from the 
Antialiasing section of the General Settings tab. 

• Supersampling - Activates/deactivates supersampling for the rendering. The default 
setting is On. 

• Background Color - Sets the background color when rendering a file in Raytracing 
render mode. 

• Tonemap HDR - Applies tone mapping to the high dynamic image rendering. As a result, 
a 32-bit rendering looks the same in the compositing tool as set in VRED. However, the 
values of the image are compressed by the chosen tone mapper to values from 0 
through 1. In doing so, the dynamic range is lost. Therefore, effects like glow are hard to 
calculate in the compositing tool afterwards. 



• Export Alpha Channel - Activates alpha channel rendering. If the file type supports alpha 
channels, the alpha channel is embedded into the resulting image. The background color 
is seen through transparent objects. 

• Premultiply Alpha - Renders the alpha channel pre-multiplied. This option is only 
available when Export Alpha Channel is enabled. 

• ICC Profile - VRED supports the storage of ICC color profiles within the project data to 
ensure color management consistency during the entire workflow and between devices. 
Storing ICC color profiles guarantees the colors visible on the workstation are the same 
as on any other computer. The default setting is Current Settings. 

Meta Data 

This feature embeds certain scene settings in the rendered output. Later, you can import the 
rendering (its metadata) into VRED, using File > Import Scene Data > Rendering Meta Data. The 
settings saved within the image upon creation are applied to the currently loaded scene, for 
example, the camera settings adopt. 

NOTE This option is only available for JPG, PNG, TIFF, and EXR files. 

• All - Embeds all the following metadata. 
• Render Settings - Embeds the current render settings as metadata to the rendered 

image, for example, image resolution, image samples, pixel filter, and Raytracing quality 
settings. 

• Camera - Embeds the settings of the currently active camera as metadata. 
• Scene Graph - Contains the following options: 

 
o Node Visibilities - Embeds the visibility states of all Scene Graph nodes as 

metadata. 
o Switch Node States - Embeds all switch node choice states as metadata. 

 
• Materials - Contains the following options: 

 
o Switch Material States - Embeds all switch material choice states as metadata. 

Saving and restoring node visibilities and switch node states relies on a consistent node 
naming scheme within the Scene Graph hierarchy. The same applies to switch materials 
within the materials hierarchy, within the Material Editor’s list view. As the metadata 
does not contain information on nodes/materials that are added or renamed since the 
rendering, their states remain unchanged when importing the rendering metadata. Also, 
if there are inconsistencies, some states may not be reconstructed. All nodes and 
materials, whose state could not be reconstructed, will be displayed in the Import 
Results dialog after the import has finished. 



• Consistency of visibility states - In the metadata, you can identify a node by its node 
path, which is a concatenation of the names of its ancestors and itself. If all nodes with 
the same node path have the same visibility, the node path is considered consistent and 
it is stored with this visibility on metadata export. If nodes with the same node path 
have different visibilities, this node path is considered to be inconsistent and it is not 
considered during export. The visibility state of those inconsistent nodes cannot be 
reconstructed on import and remains unchanged. 

To ensure all visibilities are exported and reconstructable upon import, either ensure all 
nodes with the same path have the same visibility, or create an unambiguous node path 
by renaming the respective nodes. 

• Consistency of switch states - In the metadata, the state of a switch node/material is 
defined by the name of the node/material selected by the choice (called choice name in 
the following). The choice is consistent, if the choice names of all switches with the 
same node/material path are identical. 

To ensure all switch states are exported and reconstructable upon import, either ensure 
all switches with the same path have the same choice, or rename the respective 
switches. 

When importing switch states, if the switch has several children called choice name, a 
state of a switch in the scene cannot be restored. In this case, the switch is displayed in 
the Import Results dialog with its proposed choice name. 

The scene-contained switches should not have multiple choices with the same name. 

Renderpasses 

• Export Renderpasses - Activates rendering with render passes. All activated 
renderpasses are rendered and saved at a time. 

Combined Channels (tab) 

• Color Channels - Contains the following options: 
 

o Beauty 
o Diffuse IBL 
o Diffuse Light 
o Diffuse Indirect 
o Incandescence 
o Background Color 
o Fog 
o Specular Reflection 



o Glossy IBL 
o Glossy Light 
o Glossy Indirect 
o Translucency 
o Transparency Color 

 
• Auxiliary Channels - Contains the following options: 

 
o Occlusion 
o Mask 
o Material ID 
o Depth 
o Normal 
o Position 
o View Vector 

Separated Channel (tab) 

• Material Channels - Contains the following options: 
 

o Diffuse Color 
o Glossy Color 
o Specular Color 
o Incandescence 
o Translucency Color 
o Transparency Color 
o Background Color 

 
• Illumination Channels 

 
o IBL Diffuse 
o Lights Diffuse 
o Indirect Diffuse 
o IBL Glossy 
o Lights Glossy 
o Indirect Glossy 
o IBL Translucency 
o Light Translucency 
o Indirect Specular 

NOTE To reconstruct the beauty pass image, using the other renderpasses, it is 
necessary to render to EXR/HDR/Floating Point TIFF image format, without Tonemap 
HDR activated. Because Tonemapping changes the linearity of values, render with 
Tonemapping after the renderpasses are combined to the final image. To reconstruct 



the beauty pass, layer the Diffuse IBL/Light/Indirect, Glossy IBL/Light /Indirect, Specular 
Reflection, Translucency, and Incandescence Passes, using a linear add operation in your 
compositing tool. 

Animation 

• Render Animation - Makes animation-related settings accessible, when activated. It 
provides the possibility to render an animation clip or only a part of it. 

• Type - Sets the type of animation. Choose from Clip and Timeline. 
• Animation Clip - This option is only accessible when no camera track animation or 

variant is selected within the above Image section's View drop-down. A predefined clip 
can be selected here. 

• Format - Determines the file output for the rendered animation. Choose from: 
 

o Image - Generates a picture for every frame. 
o Movie - Provides the output within a single AVI movie file. Video file 

compression settings (Frames per Second) are available in a later step, after 
initializing the render process. 
 

• Use Clip Range - Enables the rendering of the whole clip. To render only a sequence 
from the selected clip, deselect it and define the first and last image of the sequence in 
Start Frame/Stop Frame. Frame Step (only available when the Images format is selected) 
helps when not every frame of an animation sequence should be generated. With a 
Frame Step setting of 3, for example, VRED renders every third image of the sequence. 
The default value, 1, generates one image per frame. 

• Frames per Second - Defines the frame rate for the output movie. This option is 
available when the Movie format is selected. 

Cluster 

The creation of pictures can be distributed to other computers connected to the network 
(cluster). 

• Enable Cluster - Enables the cluster. 
• Hostnames - Defines the clustering slaves. Hostnames and IPs can be used to access the 

slaves. 

General Settings (tab) 

In the General Settings tab, you can enter global parameters for antialiasing, the pixel filter, and 
other options. 



Antialiasing 

Computer screens are made of small pixels, which is why illustrations of round objects or 
curved surfaces appear faceted at their edges. Antialiasing is a technique that makes the edges 
from rendered objects less pixelated. 

The Antialiasing settings control the number of samples taken during stillframe antialiasing. 
These are the primary controls that influence the quality of the rendered image. 

• Use Image Samples - Sets the number of samples taken during stillframe antialiasing. 
Higher values produce a cleaner result, while lower values reduce the render time. A 
value of 128 is a recommended starting point, in general, but may be too low for 
interior scenes with full global illumination. 

• Use Time - Sets the maximum duration for creating a single image. 
• Use Infinity Rendering in Viewport - Sets the calculation of the image samples as 

endless. If this box is not checked, there are as many image samples calculated as set in 
Use Image Samples (for example, 256 images) or as the calculation takes until the preset 
time is reached. 

• Start Update Render With - Sets the number of samples at which the antialiasing render 
update starts. A value of 16 typically prevents grainy-looking progress samples from 
displaying. The render continues to calculate in the background. 

• Adaptive Sampling - Allows the raytracer to skip regions that are already smooth and 
focus the processing power on regions that are still noisy. The various quality settings 
control a threshold for a region to be considered as smooth. Setting the control to 
Highest Quality disables adaptive antialiasing and always samples each pixel with the 
number of image samples specified. While this gives the highest render quality, it may 
waste processing power and time on regions that are already smooth. 
 

o Preview Quality - Sets the sampling quality to a low level, resulting in preview 
render quality and short render times. 

o Low Quality - Sets the sampling quality to low level, resulting in average render 
quality and short render times. 

o Medium Quality - Sets the sampling quality to medium level, resulting in good 
render quality and medium render times. 

o High Quality - Sets the sampling quality to high-quality level. 
o Ultra High Quality - Sets sampling quality to a production quality level. 
o Highest Quality - Sets the sampling quality to the maximum available quality 

level. 
 

• Use Clamping - Activates clamping of bright pixels to eliminate white spots after 
antialiasing. The value sets the maximum value for a white pixel. 

IMPORTANT Activating clamping and reducing the value reduces the maximum resulting 
image color range. 



• Denoiser - Provides options for reducing noise for raytracing on anti-aliased images. The 
denoise filter should also work with clusters. 
 

o Off - No denoising is applied. 
o CPU - Statistic-based denoising is applied and enables the Denoise Filter 

Threshhold parameter. 
o Deep Learning Stillframe - Deep-learning-based denoising is applied during 

stillframe rendering. 
o Deep Learning Always - Deep-learning-based denoising is applied during 

interactive and stillframe rendering. 
 

• Denoise Filter Threshold - Sets the threshold filter value for the level of noise reduction. 
It is only enabled when the Denoise CPU option is selected. The parameter can be set to 
values between 0 and 3. It controls the aggressiveness of the filter. The larger the value 
is, the more noise is removed and, simultaneously, more blurring artifacts may be 
introduced. Once set, click the Filter and Save Now button. 

Limitations to the Denoiser 

There are a few limitations to the Denoiser. 

o It only works on Maxwell generation and up NVIDIA GPUs. 
o Performance depends highly on the GPU used. 
o Only sharp pixel filter variants work. Other pixel filters cause noise that isn't 

detected by the denoiser. 
o Denoising in Display Cluster mode may cause seams between segments, since 

the whole image is required for it to work. 
o Can consume a lot of memory. For example, a 4K image, about 2-3 GB of GPU 

memory is required. Memory requirements can exceed that of your GPU For 
high resolution rendering. 

o Deep-learning denoising is only applied to all individual renderpasses. This can 
cause slight differences between the denoised beauty image and combined 
denoised images. 
 

• Filter and Save Now - Filters the current image in the viewport, using the threshold 
value specified. The filtered image is saved at the location specified in Render Settings > 
File Output (tab) > Image (section) > Filename and has the same format, as well. Its 
name is based on the filename specified there, with a suffix and the unfiltered original 
image is saved next to it. 

Pixel Filter 

A pixel filter weights the image samples taken per pixel and therefore, controls the antialiasing 
quality of the rendering. High image filter sizes may result in blurry images. 



• Filter - Contains the following filter options: 

Box - The box filter is the simplest pixel filter. It weights each image sample equally. A 
size of 0.5 should be used for this pixel filter. 

Triangle - The triangle filter linearly distributes the samples between the various pixels. 
It gives decent results and is therefore, the default pixel filter in VRED. It should be used 
with a size of 1.0 independent of screen resolution. 

Gaussian - The Gaussian filter uses a Gaussian function to weight the samples. Samples 
near the center of a pixel receive a larger weight compared to samples further away 
from the pixel center. It gives slightly better results compared to the triangle filter in 
some situations. A size of 1.0–1.2 is recommended. 

Mitchell Netravali - The Mitchell Netravali filter prevents blurring that may occur when 
using box, triangle, Gaussian, or bspline filter by sharpening the image. It gives the 
highest-quality result, but may have ringing on hard contrast edges. A size of 2.2 is 
recommended. 

Lanczos - The Lanczos filter is a sync-based filter that does an optimal reconstruction of 
the image. It delivers sharp high-quality results, but may have ringing. A size of 2.5 is 
recommended. 

Bspline - The bspline filter uses a bspline function to weight the samples. It gives results 
comparable to Gaussian filtering, but suffers less from blurring. A value of 1.3–1.5 is 
recommended. 

Catmull Rom - The Catmull Rom filter creates sharp images, but may have ringing, just 
like the Lanczos and Mitchell Netravalli filter. A size of 2.5 is recommended. 

Sharp Triangle - In this triangle filter variant, one sample affects only 1 pixel. This way, 
the first impression of the image looks sharper and the image noise is high frequency. 

Sharp Gauss - In this Gauss filter variant, one sample affects only 1 pixel. This way the 
first impression of the image looks sharper and the image noise is high frequency. 

Sharp BSpline - In this BSpline filter variant, one sample affects only 1 pixel. This way the 
first impression of the image looks sharper and the image noise is high frequency. 

• Size - Defines the number of neighboring pixels taken into account for sampling. 

Options 

Certain rendering features can be enabled or disabled globally. 



• Enable Photometric Parameters - Activates the photometrically consistent rendering 
pipeline to generate images containing realistic and reliable luminance information. The 
process chain includes photometric input values for light sources, environment maps, 
materials, cameras, clamping threshold, and the display luminance. Spectral data for 
light sources and incandescence are photometrically consistent and physically 
implausible parameters are removed from the user interface. This mode provides the 
means to reproduce the rendering, results in realistic luminance information on the 
display. Therefore, it is necessary to set up the display luminance parameter to match 
the current display, preferably using measured data. Also, adjust the clamping threshold 
and tone mapping parameters of the cameras, accordingly. 

• Enable Spectral Raytracing - Activates the spectral rendering pipeline for raytracing. The 
lighting simulation calculation uses spectral distributions for all the colors, instead of 
conventional tri-stimulus RGB values. The spectral information for the color channels of 
materials and light sources can be provided and edited by opening the respective color 
dialogs. See Choose a Color. 

• Illuminant - Sets the light spectrum considered to be white. Usually this value should be 
D65 to match daylight. 
 

o Equal Energy - Uses an equal energy spectrum as white. An equal energy 
spectrum has an equal value for all wavelengths. 

o D65 - Uses a D65 daylight spectrum as white. 
 

• Optimize for Many Light Sources - Allows the renderer to optimize the light calculation 
by slightly reducing the quality, which significantly increases the rendering performance. 
While the quality loss is not recognizable in most situations, some scenes may suffer 
from heavy noise, when this feature is selected. In such scenes, it can be necessary to 
disable the optimization to get a clean render result. In scenes with many light or 
geometry light sources, rendering may slow down. 

• Enable NURBS Raytracing - Enables VRED to render NURBS data without prior 
tessellation. 

• Cost Visualization - Analyzes where the most time is spent, while tracing an image. 

 

• RDF Behaviour - The new BRDF model is better at conserving energy. The weighting of 
the diffuse/glossy/specular layers should consider the glossy/specular colors, in addition 



to the fresnel reflectivity. The result does not show dark edges when a glossy color turns 
to black. Instead, it displays a purely diffuse material. This provides better fine-tuning of 
the specular reflections. For compatibility reasons, the old BRDF model can still be 
chosen from the list. Version 2014 and above does consider the glossy color to weight 
the diffuse color and avoid darkened edges. 
 

o Ver. 2014 and above 
o Ver. 6.0x and below 

 
• Number of CPU Cores - Sets the number of CPU cores used for raytracing. Sometimes, 

limit the number cores VRED uses is required, so some processing power is left for other 
applications. This setting is a runtime-only setting and does not influence cluster 
machines. 

Raytracing Quality (tab) 

In the Raytracing Quality tab, parameters for illumination, photon tracing, various sampling 
qualities, trace depth, and materials can be set globally. 

Illumination Mode 

• Interactive/Still Frame- Enables the choice of different illumination modes for 
interactive and still frame rendering in raytracing. It allows working in a precomputed 
mode for fast interaction with the scene and automatic switching to full global 
illumination for still frame rendering. Five modes are available: 
 

o CPU Rasterization - This mode does not compute direct reflection, refraction, or 
any other sophisticated visual effect. 

o Precomputed Illumination - This mode is comparable with the VRED OpenGL 
rendering mode. It uses precomputed Ambient Occlusion and indirect 
illumination for rendering and calculates specular reflections and refractions and 
correct shadows from light sources. 

o Precomputed+Shadows - This mode uses precomputed image-based lighting 
and indirect illumination, but doesn’t use precomputed Ambient Occlusion 
values. Instead, it calculates shadows based on the active environment. 

o Precomputed+IBL - This mode uses precomputed indirect illumination and 
samples the environment. 

o Full Global Illumination - This mode doesn’t use precomputed values, but 
accurately samples everything in a physically-based approach. Other features, 
like Photon Mapping, require the render mode to be set to Full Global 
Illumination. 



Photon Tracing 

Photon Tracing provides an approach to calculate the global illumination of a scene. The default 
full global illumination mode in VRED provides high-quality results, but may require longer 
calculation times. Photon Tracing can reduce the time required to render a clean image by a 
larger margin, especially in indoor scenarios, such as car interiors or architectural indoor 
scenes. 

• Mode - VRED provides different photon mapping modes. 
 

o Off - Disables Photon Tracing and uses the default full global illumination 
algorithm in VRED. 

o Indirect Only - Uses Photon Tracing to calculate the indirect illumination in a 
scene. This is the most common mode. 

o Caustics + Indirect - Uses Photon Tracing to calculate indirect illumination and 
caustics due to specular materials in a scene. 
 

• Trace Depth - Sets the trace depth of the photon tracer. 
• Interactive Count/Still Frame Count - Specifies the number of photons sent into the 

scene for each image sample. Specifying a photon count of 100,000 photons, while 
having set the image samples set to 256, results in 25,600,000 photons send into the 
scene for a frame. The higher the number of sent photons, the less pixelated the output 
is. 

• Use Automatic Photon Radius - Uses a pre-process to lookup the 16 closest photons for 
each photon in the scene and calculates two times the average lookup radius. This 
feature works for most situations. 

• Photon Radius - Specifies the radius around a hitpoint used by the raytracer to look for 
photons. A larger radius allows the raytracer to find more photons, but may result in 
slower lookup times. 

• Interactive Final Gather/Still Frame Final Gather - There are two ways to use the 
photon map. The first approach is always used for caustic photons. It gathers photons 
around a hitpoint to calculate the incoming illumination. This approach gives fast 
interactive performance and can calculate all light paths in a scene, but it may require a 
high photon count to get a clean image. The other approach is to use final gathering. In 
final gathering, a one bounce indirect illumination is performed before evaluating the 
Photon Maps. This is the default Photon Tracing approach in VRED since it generates 
high-quality images in a short time. Setting the final gather quality to Off enables the 
first approach while setting it to any other value uses the second approach. 

• Final Gather Radius - Sets the lookup radius used to find the nearest final gather point 
during Raytracing. Using a smaller radius increases performance, but requires more 
photons to avoid dark regions. 



NOTE To evaluate the final gather points, use the Indirect Illumination Rendering with 
photon mapping and final gathering turned on. For a good quality result, the final gather 
points should have few black regions where no photons are stored. 

• Final Gather Refresh - Setting the Final Gather Quality (Interactive Final Gather/Still 
Frame Final Gather values) to 1 or higher, the update frequency of the Photon Map may 
be set. By default, the Photon Maps are updated for each image sample, sending many 
photons into the scene. If Final Gather Quality is set to Off, it is often sufficient to 
update the Photon Map only once per frame and use it for each image sample to reduce 
the render times. 
 

o On Each Sample - Updates the Photon Map for each image sample. This is the 
default setting, since it also works for scenes with animated objects that may 
otherwise cause flickering. 

o On Scene Change - The Photon Map is updated once per frame, unless Motion 
Blur is activated. Since caustics require many photons, the Caustic Map is still 
updated for each sample, while the indirect illumination Photon Map is only 
updated once. This setting often results in the best rendering performance, but 
requires a much higher photon count to receive artefact-free results, particularly 
when rendering scenes with animated objects. The result may flicker in regions 
with a low photon count. This is why this mode should only be used for scenes 
with static geometry and materials. 
 

• Use Final Gather for Glossy Reflections - When activated, glossy reflections are 
evaluated by the final gather map, rather than path tracing. This reduces the render 
time, but results in less accurate reflections. 

IBL Sampling Quality 

• Interactive - Sets the interactive IBL sampling quality. 
• Still Frame - Sets the still frame IBL sampling quality. 

Reflection/Refraction Sampling Quality Settings 

• Interactive - Sets the interactive sampling quality of reflections and refractions. 
• Still Frame - Sets the still frame sampling quality of reflections and refractions. 

Trace Depth 

• Interactive - Sets the interactive amount of reflection and refraction each ray may 
encounter. 



• Still Frame - Sets the still frame amount of reflection and refraction each ray may 
encounter. 

Material Overrides 

Each material can bring its own settings for material properties, illumination mode, IBL 
sampling quality, reflection/refraction quality, and trace depth. For each material, different 
overrides can be set separately in the Material Editor's Raytracing Settings. 

Predetermined, all overrides are globally activated. That means, you can use different render 
settings for each material. This can be deactivated here, so the special material settings are 
ignored. 

• Allow Material Overrides - Overrides the global allow material setting for interactive or 
still frame rendering. 

• Illumination Mode Override - Overrides the global set illumination modes for 
interactive or still frame rendering. 

• IBL Sampling Quality Override - Overrides the global IBL Sampling quality for sampling 
the environment map. 

• Reflection/Refraction Quality Override - Overrides the global sampling quality for 
reflections/refractions. 

• Trace Depth Override - Overrides the global set trace depth modes for interactive or 
still-frame rendering. 

Display Output (tab) 

In the Display Output tab, several parameters can be defined globally for color, histogram, and 
visual support. 

Color 

• Monitor Luminance (cd/m²) - Set up the luminance value of the preferred display. 
When using photometric parameters, the actual monitor luminance is necessary to 
reproduce the rendering results with realistic photometric values on the display device. 
This setting is only available when the checkbox Enable Photometric Parameters is 
active under General Settings > Options. 

• Monitor Colorspace - Contains the following colorspace options: 
 

o Simple Gamma 
o sRGB IEC 61966-21 
o A.RGB 98 
o Monitor ICC Profile 



Histogram 

Shows the relative color distribution of the rendered image. This tool is useful to detect overly 
bright areas of light. Different modes are available. It can use logarithmic and linear display 
scales. 

• Show Histogram - Enables each color distribution to be viewed separately. 
• Red - Shows histogram of red image channel. 
• Green - Shows histogram of green image channel. 
• Blue - Shows histogram of blue image channel. 
• Logarithmic Scale - Uses a logarithmic scale for the histogram values. 
• Grayscale - Shows the luminance histogram of the rendered image. 

Visual Support 

• Show Snapshot Frame - Draws a yellow frame into Render View, indicating the target 
image to be rendered. After activation, all the following settings are available. 

• Show Region Render Frame - Draws a green frame into the Render View dependent on 
the values of the region start XY and region end XY input fields. 

• Show Rule of Thirds Guide - Draws orange guide lines into Render View, allowing to use 
the rule of thirds. 

• Show Inner Frame - Draws an orange frame in the Render View, indicating the area 
where text or graphics show neatly. 

• Unit - Defines the distance unit of the inner frame by percent or in pixels. 
• Left - Right - Sets the distance of the left and right side. 
• Top - Bottom - Sets the distance of the top and bottom side 

Start Image Calculation 

• Send to Cluster Queue - Renders to the Cluster Queue; however, you must be logged 
into the Cluster Manager before sending anything to the Cluster Queue. See To Manage 
Cluster Rendering. 

• Add to Render Queue - Creates a job from the current camera view and adopts last 
settings from the render module, after submitting the Render Queue Window opens. 

• Render - Creates the image or movie with current settings. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Rendering_To_Manage_Cluster_Rendering_html
http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Rendering_To_Manage_Cluster_Rendering_html


Render Queue 
Rendering > Render Queue 

From the menu bar, select Rendering > Render Queue or when in the Simple UI mode, select 
Render > Render Queue to open the Render Queue module. 

Before using the Render Queue, you will need to set off a render. When in the Simple UI mode, 
select Render > Render Image or when not, select Rendering > Render Settings, then in the 
Display Output tab, enter the setting you need. Click the Add to Render Queue button to start 
image calculations. Enter a name for the rendered image, select where the renders will be 
saved, then click Save. This opens the Render Queue and adds an entry displaying the state, file 
name, render mode, quality, image size, and path. 

The Render Queue 

Every line within that queue represents a job that must be calculated. 

 

Visibility flags assigned to an object by a render layer are captured when something is added to 
the Render Queue. 

NOTE  Use this Python command activateRenderLayerState(string name) to activate 
every stored render layer state with the passed key-name. 

• State - Uses the checkbox to control job consideration on rendering. A preview image 
helps to identify the jobs within the queue. 

• Name - Shows the name chosen on file browse dialog box. 
• Animation - Indicates the type of job. Checkbox is selected on animations. 
• RT - Indicates the type of renderer. When enabled it uses Raytracing and Open GL when 

disabled. 



• Render Mode - Creates the output, based on the setting from the Scene module's 
Settings tab. It uses the selected image render mode that was configured there. 

• Render Quality/Image Size - Shows the settings set during job creation. 
• File Path - Shows image name and full path. 

Context menu 

Right-mouse click in the list to access this context menu. 

• Set - Sets the current camera (render view) to the job initial position. 
• Recapture - Captures the current camera view and overwrites settings from selected 

job. 
• Rename - Enables the renaming of the job name within the render queue. 
• Delete - Removes the selected render job. 
• Active - Controls job consideration on rendering, when enabled. 
• Move Up/Move Down - Rearranges jobs inside the queue. Calculation performs jobs 

from top to bottom. 
• Run - Starts rendering the selected job immediately. 
• Run All - Processes all jobs. Behave like the Render All button. 

Start image calculation 

• Add to Render Queue - Creates a job from current camera view and adopts the last 
settings from the Render Image module. 

• Render - Processes all jobs. 

Why use the Render Queue? 

Use the Render Queue to create cluster render jobs and send them to the Cluster Queue. 



To Analyze Surfaces 
Examine the continuity of various types of virtual lines like isophotes that are displayed on the 
objects in the scene, detect discontinuities on surfaces, and analyze polygonal as and NURBS 
data. This topic describes working with the Isophotes and Reflection Lines modes. 

Activate Surface Analysis 

1. Select Rendering > Surface Analysis to open the Surface Analysis dialog box. 
2. Select Activate Surface Analysis. 

Adjust Settings in Isophotes Mode 

In Isophotes mode, a virtual light source provides defuse illumination to the object geometry. 
All points sharing the same brightness value are connected with a line. 

Surface Analysis Off Surface Analysis On - Isophotes Mode 

 
 

1. From the Analysis Mode box of the Surface Analysis dialog box, select Isophotes. 
2. To orient light direction along an axis, select X, Y, or Z beside Set to Axis (under Define 

Light Source). 
3. Select Show Light Direction to show the light direction manipulator. 
4. To define light direction using the surface normals on your geometry, click Pick Surface 

Normals, then Shift-drag the manipulator in the scene. 
5. To align the light along the camera vector, click Use Camera View Vector. 
6. Under Lines / Stripes, adjust the type, amount, and color of the lines. 



Adjust Settings in Reflection Lines Mode 

In Reflection Lines mode, lines on a virtual plane are reflected onto the surface of the 
geometry. 

Surface Analysis On - Isophotes Mode 
 

Surface Analysis On - Reflection Lines Mode 
(Parallel Linear Lines) 

 
 

1. From the Analysis Mode box of the Surface Analysis dialog box, select Reflection Lines. 
2. Select Parallel Linear Lines on a Plane. 
3. Change the value of Lines Spacing to increase the size of the plane. 
4. Alternatively, select Longitudinal Lines on a Sphere under Analysis mode. 

This creates a sphere with lines reflected on the geometry. 

5. Adjust light direction as you would in Isophotes mode. 



The Surface Analysis Dialog Box 
Rendering » Surface Analysis 

The Surface Analysis module lets you analyze the quality of a surface. You can examine the 
continuity of different types of virtual lines like isophotes that are displayed on the objects in 
the scene. Discontinuities on surfaces can be detected. You can use the module for analyzing 
polygonal as well as NURBS data. 

Analysis Mode 

• Activate Surface Analysis - Enables/disables the Surface Analysis rendering mode. You 
can also activate this rendering mode by selecting it in the Visualization Menu. 

• Analysis Mode - Selects the analysis mode. 
 

o Isophotes - With isophotes, it is possible to determine whether a surface is 
continuous in position, tangency, or curvature. Isophotes are lines which mark 
spots of same brightness on the surface. The surface is assumed to be perfectly 
diffuse reflecting. It is lit from both sides by a directional light emitting parallel 
light beams. You can set the direction of the light source. Isophote lines are 
view-independent meaning that the lines do not change when moving the 
camera (except when using the option Use Camera View Vector). 

o Highlight Lines - Highlight lines mark spots on a surface whose extended surface 
normals intersect light lines. Highlight lines are view-independent as well. 

o Reflection Lines - Reflection lines are reflections of light lines. This analysis mode 
is view-dependent. 

Both Highlight Lines and Reflection Lines need light lines to be defined as a 
virtual light source. You can choose between two different basic shapes on which 
the light lines appear: 

o Longitudinal Lines on a Sphere - The lines are meridians on a sphere (lines from 
pole to pole) which encloses the scene and is of infinite size. You can set the axis 
of the sphere. 

o Parallel Linear Lines on a Plane - The lines are parallel straights on a plane. You 
can set their position and rotation. 
 

• Curvature (NURBS Only) - VRED offers a curvature Shader to evaluate degree and 
tension of NURBS surfaces. This enables a 100% accurate evaluation of surfaces without 
any tessellation artifacts. The Curvature Shader currently works only in combination 
with NURBS data and NURBS Raytracing mode. 



NOTE  This requires NURBS Raytracing enabled within the Preferences (Render Settings 
> General Settings > Features). 

Define Light Source 

Depending on the chosen Analysis Mode the GUI changes in frame Define Light Source. 

For Isophotes 

• Show Light Direction - Shows an arrow in the render view for the picked direction. Use 
the rotation manipulator to rotate the arrow (does change the direction) and the 
translation manipulator to move it (does not change the direction). 

NOTE  The translation does not change the direction of the light and therefore has no 
influence on the isophotes. 

• Direction - Offers the opportunity to enter values manually. 

Important: The entered values are automatically normalized if the direction manipulator 
is enabled with Show Light Direction. To enter X,Y,Z manually without normalization, 
disable the manipulator.  

• Normalize - Normalizes the manually entered direction vector to length 1. 
• Set to Axis - Sets the direction to X (1, 0, 0), Y (0, 1, 0), or Z (0, 0, 1). 
• Pick Surface Normal - This button enables a tool to select surface normal as light 

direction. SHIFT + LMB allows you to select a normal of an object. Click the button again 
to disable the tool. 

• Use Camera View Vector - To reproduce the Discontinuity Rendering Mode from 
previous VRED versions select Isophotes as Analysis Mode and enable Use Camera View 
Vector. This updates the direction depending on the camera orientation. 

For Highlight / Reflection Lines with Longitudinal Lines on a Sphere 

• Show Plane with Light Lines - Shows the light lines together with a transparent 
representation of the plane in the render view and a transformation handle for 
translating and rotating the plane. 

• Light Plane Origin - Sets the origin of the plane. 
• Light Plane Rotation - Sets the rotation of the plane. 
• Lines Spacing - Defines the distance between the lines on the plane. 
• Limited Lines Length - By default, all lines are infinitely long. If Limited Lines Length is 

activated, you can define the length of the lines using the slider. 



• Pick Surface Normal - This button enables a tool to select surface normal as plane 
normal. SHIFT + LMB allows you to select a normal of an object. Click the button again to 
disable the tool. 

Lines/Stripes 

The following settings allow you to define the visual appearance of the lines on the surfaces. 

• Type - Defines the style that is used to display the analysis lines on the object surfaces. 
 

o Thin Lines - Uses thin sharp lines. 
o Stripes - Uses stripes that can be modified in their sharpness and thickness. 
o Zebra - Uses a classical zebra pattern. 

 
• Count - Defines the number of lines. 
• Color - Defines the color of the lines. 

Surface 

These settings allow you to define the visual appearance of the surfaces. 

• Lighting - Sets the lighting situation for the surfaces. For Isophotes, the defined 
directional light lights the surfaces. For Highlight/Reflection Lines, a headlight lights the 
surfaces. 
 

o Ambient - The surfaces display single-colored. The Base Color defines the color. 
o Diffuse - The surfaces are assumed to be diffuse. Set the diffuse reflection color 

with Base Color. 
o Phong - The surfaces are lit with the phong lighting model. You can set the 

diffuse reflection color with Base Color, the glossy reflection color with Glossy 
Color, and the roughness. 

o NURBS UV - Show the parameterization of NURBs surfaces. Triangle meshes are 
displayed in Ambient mode. 

Curvature 

• Type - Surfaces can be analyzed with different evaluation types. Surface mistakes can 
quickly be made visible. The Curvature Evaluation type setting specifies which circles are 
used for the calculation. 
 

o Mean - Average the two principle curvatures on each point of the surface. 
o Princ. Max/Min - The maximum/minimum curvature values (the curvature of the 

steepest/flattest curves that pass through each point). Good for comparing 
surfaces. 



o Gaussian - The product of two principal curvatures. 
 

• Color Scale - It is a scalar that scales radius values to colors. This option is not available 
when Min. Radius Limit or Max. Radius Limit is turned on. 

• Min. Radius Limit - Surface regions having a radius less than the Min. Radius Limit value 
are indicated by one color, and surface regions having a radius greater than the Min. 
Radius Limit value are indicated by a different color. Available only for the Princ. Max 
evaluation type. 

• Max. Radius Limit - Surface regions having a radius larger than the Max. Radius Limit 
value are indicated by one color, and surface regions having a radius less than the Max. 
Radius Limit value are indicated by a different color. Available only for the Princ. Min 
evaluation type. 

• Radius Ramp - Enables/disables the color bar on the right side of the viewport that 
shows how different curvature radius of the current evaluation type are mapped to 
different colors (red, green, blue, and purple). The unit of the radius value is the same as 
the unit of the scene. 

NOTE  NURBs raytracing within the Rendering > Render Settings > General Settings > 
Options and Activate Surface Analysis within the Rendering > Surface Analysis > Analysis 
Mode should be activated. Viewed in Raytracing mode. 



Simple UI 



Scene Module Scene Graph Tab – Simple UI 
The Simple UI includes the Scene module, which contains all scene elements, like geometry, 
materials, environments, cameras, lights, and render settings on different tabs at the top of the 
window. 

 

1 Tabs 

2 Search Field 

3 Scene Tree 

4 Properties element with tabs 

5 Scene module slider 

6 Properties element with tabs 

7 Width adjustment 

8 Second Scene Tree (meta tags) 

9 Window splitting adjustment 

Use the vertical dotted line (7) to resize window width. 
Use the dotted line over the Properties window (9) to 
resize the windows splitting size. Use a second dotted 
line over the Icon Bar and slider (8) to open a second 
Scene Graph. These features are helpful for arranging 
scene objects within large scene trees. 

 
 

If NURBS data within the scene there is the possibility to show/edit scene tags. Above the 
middle window and above the search field a drop- Down field (10) appears to choose which 
window should show tags and/ or scene tree. 



 

Search field 

The search field provides live-search capabilities for Scene Graph objects. Search is helpful for 
quickly identifying known components in complex scenes without browsing the Scene Graph 
structure. The search field is located below the module tabs. Only single search terms are 
supported. 



 

Paste your search term from clipboard to avoid live check on search. 

Scene Graph tree 

All scene relevant objects that have been set up or imported are present and accessible within 
the scene tree. The usage is familiar to file browsers - a plus in front of a node indicates that 
something is located below. Either a click onto the plus or a double click with left mouse button 
onto the node toggles the extension of the hierarchy up to the next level. The slider located 
underneath enables a fast way to extend substructure of selection or multi-selection. 

When the check box in front of a node is selected the object is visible in render view. Objects 
not selected are grayed. 

Click selects an item; right-click opens the context menu. Clicking a selected item enables 
renaming. 

Multi-selection of nodes could be done in two ways by Scene Graph interaction: 

• Ctrl-click to add objects to the selection. 
• Shift-click to select a range of objects. 

Context menu within Scene Graph module 

The minimized context menu from simple UI continues the thread of simplification. Common 
usual features like create or edit are directly available, uncommon features are stripped off to 
keep it clear. A switch back to the standard UI brings them back whenever required. Right 
mouse click inside the scene tree opens the context menu. 

Clicking the top of the context menu (dotted line) releases it to an independent window. This 
works also on sub menus. 



Create (sub menu) 

The create sub menu provides functionality to generate and add nodes to the scene. Newly 
created nodes appear under the group node selected on creation. If a node without grouping 
characteristics is selected on creation, then the node appears besides the selection. If nothing is 
selected on creation, then the root group node is used as parent node. 

Create geometry 

Scene Graph icons for line and polygonal shapes (active and inactive) 

 

VRED supports creation of the following geometric standard primitives. The layout of numerical 
input dialog box depends on the use case. 

All object creation except Line feature results in triangulated polygonal shapes nodes. 

• Line - A line is the connection of two points. Every point has X, Y, and Z coordinates for 
it's positioning in 3D space. The representation of a line object in render view depends 
on the active render engine. This means that in OpenGL mode a line is represented as a 
line, but in Raytracing mode it is represented as a tube capped with half spheres on both 
ends. The radius of the representation in that case is controlled by the material setting 
Line Tube Radius, accessible within the standard UI. 

 

• Plane - A plane is a flat quadratic face often used to place object shadows onto the 
ground below. It has X and Y dimensions and it requires input for the number of sub- 
Divisions for both axes. 

 

• Box - A box describes a quadratic, 3D room also known as cube. It has X, Y, and Z 
dimensions and it requires input for the number of sub- Divisions for all axes. 



 

• Cylinder - A cylinder is an object that has two circular ends with same radius parallel to 
each other. A cover wrapped around the distance between (height) builds the outer skin 
of the primitive. Increasing the number of sides makes the object look less faceted. 
Faces for top, bottom or side are only created when related check boxes are selected on 
creation. 

 

• Cone - A cone is similar to a cylinder. It has also a circular base at the bottom, but its top 
end is a single point instead of a circular face. Faces for bottom or side are only created 
when related check boxes are selected on creation. 

 

• Sphere - Sphere is the distinguishing name for a 3D primitive in the form of a ball. Every 
point on the surface has the same distance to the center point. This distance is adjusted 
within the dialog box by the radius value. The values for latitude and longitude 
resolution results in amount of horizontal and vertical sub- Divisions. 

 

• Torus - A torus is an object that's shape equals a donut. A section cut would show a 
circular profile limited by the inner and outer radius. Imagine on creation that the 



profile is rotated around the perpendicular axis in the center of the object. The value for 
rings controls the number of subdivisions along that rotation, sides controls the number 
of horizontal sub- Divisions. 

 

• Dome - A dome has a flat circular surface at the bottom and a half sphere on the top, 
also known as hemisphere. The border edge to the bottom surface is chamfered. The 
Base Radius value on creation dialog box controls the dimension of the half sphere, 
Ground Radius controls chamfer creation. Setting for Latres results in number of 
perpendicularly sub- Divisions, Longres controls number of sub- Divisions around the 
perpendicular axis. 

 

Create light 

VRED supports creation of the following light sources as nodes. 

• Directional light - Directional light rays are parallel, like sun light. Directional light 
generates a clean-cut shadow. If the light source is set near an object, it creates a clear, 
hard shadow. Rather further away, the shadow becomes softer. 

 

• Point light - Point light rays start at a single point and emit radially. Point light generates 
rather diffuse shadows. 

 

 



• Spot light - Spot light rays follow a beam cone. They start at a single point and spot in a 
circled area on the object. It is often used to emphasize an object or surface. 

 

• Spherical light - Spherical light rays beam like from a glowing ball. Spherical light 
generates diffuse light and soft shadows. It is an indirect lighting and more atmospheric 
than point light. 

 

• Disk light and Rectangular light - The disk or rectangular light rays are created a light 
source appearing like from a dropped ceiling - either like from a circle (disk) or from a 
square (rectangular) 

 

• Ray light - Ray Files contain the simulated spatial and angular distribution as well as 
photometric or spectral information of emitted light from a complex light source. 

 

Create camera 

VRED supports creation of the following cameras. 

• Perspective camera - Setting this node creates a camera with a perspective view.  
 
Perspective View - A view similar to the view of human eyes -Objects further away seem 
smaller than objects right in front. Original parallel lines appear centric to a single point 
a long distance off. This view is the default for file output (s.a. Render Settings) 

 

• Orthographic camera - Setting this node creates a camera with an orthographic view.  
 
 
 
 



Orthographic View - A view where all objects have the same size irrespective of 
distance. Each object's actual height and width is shown, and parallel lines remain 
parallel. 

 

• Viewpoint - This function creates a new fixed point of view from the actual distance and 
angle to a scene or object. 

 

Create functional Scene Graph nodes 

• Group (Ctrl + G) - A group node helps you structure everything scene related that is 
present within the tree. Grouping of nodes has no influence on the graphical 
representation within the render view. 

 

• Clone - A clone node duplicates and references all child nodes of the node that is 
dropped onto it. All nodes contained at that moment are considered. Referenced means 
that any change on that objects (for example, transforming, assigning material) also 
affect the duplicated instance and vice versa. Referenced nodes are underlined within 
the Scene Graph. 

The shadows generated by more than one light source on an object add up where they 
overlap. Similar to a new geometry, the newly created light source is at (0,0,0) by 
default, no matter whether an object is selected or not. Location, size, angle, and so on, 
can be modified by using the Transform Manipulator 

 

• Environment - An Environment node provides a textured surrounding with shadow 
plane on its ground. Its texture affects the representation of all scene-related materials. 
The creation dialog box asks for this texture. It generates the dome and shadow plane 
automatically. 



 

• Switch - A switch node groups different child nodes and it switches the visibility of them 
within the render view. Only one of the child nodes is visible at the same time. When a 
check box is selected, the visibility check boxes of all other child nodes are unselected 
automatically. 

 

Edit (sub menu) 

Geometrical object properties, transformations, and animations are accessible and 
customizable within the edit sub menu. Place the mouse pointer above an editable node on 
opening the context menu. All following instructions are affecting that node. 

Edit surfaces 

VRED's trueNURBS concept provides the usage of CAD NURBS data directly within the scene. 
Features for editing geometrical properties of NURBS objects or their polygonal representation 
are available here. 

• Tessellate Surfaces - CAD generated construction data is mathematically precise; exact 
defined by a technique called Bézier curves. VRED's directNURBS Raytracing mode can 
represent NURBS data without any preparation. 

OpenGL mode requires generating a polygonal representation before. This process is 
called tessellation. It enables changing the complexity/amount of polygons of an object 
at any time. NURBS data coexists besides polygonal data (same node object within 
Scene Graph); this enables re-tessellation without reloading the files before. 

A polygonal representation is never as precise as the source NURBS data. The higher the 
precision the more polygons are generated. 

o Tessellation Settings – Get Settings From Node - Reads the settings that were 
used last time this object was tessellated. 

o Tessellation Quality - Different presets help casual users choose reasonable 
settings. 



 

Tessellation Quality  Coarse  Low  Medium  High  

Chord deviation  1.00  0.15  0.075  0.037  

Normal tolerance  30.00  20.00  10.00  7.5  

Max chord length  400.00  300.00  200.00  100.0  

Enable stitching  yes  yes  yes  yes  

Stitching tolerance  0.10  0.10  0.10  0.1  

o Chord Deviation - Describes the maximum deviation between the NURBS surface 
and the tessellated surface. A low value results in more accurate polygon model 
but it also increases the number of triangles. 

o Normal Tolerance - The normal tolerance is the allowed normal deviation 
between the normals on the ends of a tessellated edge 

o Max Chord Length - Defines the maximum edge length of the generated 
polygons. Long polygon edges are not shaded smooth within the render view; 
this setting is helpful to avoid such faceted effects. 

o Enable Stitching - This feature enabled on tessellation rebuilds existing topology 
- it makes edges of selected shells align to each other. It avoids ragged edges on 
tessellated representation within the Stitching Tolerance. 
 

• Create Shell From Selection - Combines selected NURBS components to one contiguous 
NURBS shell. The noncontiguous condition is furthermore accessible at any time 
through the standard UI of VRED. 

• Convert To Mesh - Deletes the NURBS information that is stored beside the tessellated 
object. Due to this, memory consumption of the scene is reduced but re-tessellation of 
that object is not possible anymore. 

NOTE Undo for this action is not available. 



Edit geometry 

Features for editing geometrical properties of polygonal objects are available here. This is 
useful for splitting or merging objects 

• Merge Geometry (Ctrl + Shift + M) - Merges polygonal objects with same material to 
one contiguous object. Group objects that should be combined this way and use feature 
on group node. This works also when NURBS data exists besides the polygonal 
representation. 

NOTE Undo for this action is not available. 

• Split Geometry - Splits selected polygonal object into fragments. The dialog box asks for 
a value that determines the maximum number of triangles a split object should contain. 
For example, you have an object with 1000 polygons and you split it into fragments with 
a maximum amount about 100 polygons you will get 10 objects. 

NOTE Undo for this action is not available. 

• Split Into Primitives (Ctrl + T) - Execution converts object to a group node that is named 
like the object before. The group node contains single triangles for every polygon of the 
source object. 

NOTE Undo for this action is not available. 

o Unsplit Geometry with One Triangle (Ctrl + Shift + T) - Merges single triangles to 
one object. Group polygons that should be combined this way and use feature 
on group node. Material from the first node below the parent group is applied to 
the merged object. 

NOTE Undo for this action is not available. 

o Subdivide Geometry - Subdivides existing polygon mesh into smaller triangles. 
Ambient occlusion calculation for example requires a fine mesh resolution for 
shadowed areas to avoid ragged edges on shadow illustration. This feature is 
helpful when NURBS data for re-tessellation is not available, but a refined mesh 
is required. 

Two different subdivide methods are present: 

 Standard - Each polygon is subdivided until each edge length is below the 
maximum edge length threshold entered on creation. 



 Phong Interpolation - Each polygon is subdivided into a specific number 
of triangles depending on the selected iteration value selected on 
creation (see table). 

Iteration  Triangles/Polygon  

1 4 

2 16 

3 64 

4 256 

NOTE Undo for this action is not available. 

Edit animation 

This menu contains a feature to create turntable animations quickly. Furthermore, it provides 
commands to handle already created animations for duplication or cloning purposes. 

• Load Animation To Nodes - An already created and saved transformation animation 
could be loaded and assigned to the selected node. 

• Load Animations To Materials - An already created and saved material animation could 
be loaded and assigned to the selected node. 

• Create Turntable Animation - This dialog box supports the user on creation of turntable 
animations. The object is rotated 360° around the perpendicular axis. These kinds of 
animations are for example, used for product presentation within virtual showrooms. 

 

o Name - Declares the name that is used for the representation of the animation 
sequence within the Curve Editor. 

o Duration - Threshold defines the length of the animation in seconds. 



o Interpolation - Determines object velocity on animation playback. Linear results 
in a constant rotation of the object; Ease In/Out reduces velocity on beginning 
or/and at the end of the animation. 

o Behavior - Play Once replays animation one time; Loop replays animation 
looped; Oscillate plays the animation forwards and backward. 

o Direction - Affects the replay direction; could be set to Clockwise or 
Counterclockwise. 

o Rotation Pivot - Set to Center moves the rotation center of the object to the 
center of its bounding box. This is helpful if the animated object had custom 
pivot point settings that affect inside motion on object rotation.  

o Preview - Replays the animation one time for preview purposes related to the 
settings above. 
 

• Copy Animations - The animation can be copied to the clipboard by selecting an already 
animated object and executing this command. 

• Paste Animation - Pastes animation from clipboard to the selected node. 
• Paste Clone Animation - Pastes animation from clipboard to the selected node in a 

referenced way. This means that any change on animation affects the cloned instance 
and vice versa. 

Edit asset 

The asset management module supports the user on the usage of external file references. 
These files are imported to the Scene Graph and present within its structure. Sub menu 
provides commands to edit such references. 

• Save in Asset Manager - Saves selection within the asset manager. 
• Find in Asset Manager - Select related asset within the asset manager. 
• Reload from Asset Manager… - Updates the selected asset from the asset manager. 
• Remove Reference - Removes the reference connection to the asset manager. The asset 

itself is not deleted this way. 

Edit menu commands 

• Rename (Ctrl + R) - Renames selected node; same behavior as clicking selection. 
• Delete (Del) - Deletes selected nodes. 
• Copy (Ctrl + C) - Copies selected nodes and structure to clipboard. 
• Cut (Ctrl + X) - Cuts selection and stores it to clipboard. 
• Paste (Ctrl + V) - Pastes clipboard contained nodes to an independent instance within 

the Scene Graph. 
• Paste Clone (Ctrl + Shift + V) - Pastes clipboard contained nodes to an automatically 

created group node in a referenced way. Referenced nodes are underlined within the 
Scene Graph. 



• Clone - Groups the edit menu commands copy and paste clone to a single action. Take 
one of the mirror commands to create a references and mirrored instance from source 
object or structure. 
 

o Clone (Ctrl + Shift + D) - Creates a cloned instance of the source selection at 
same position in 3D. 

o Clone Mirror X/Y/Z - Creates a cloned instance of the source selection mirrored 
on related axis.  
 

• Duplicate - Groups the edit menu commands copy and paste to a single action. The 
duplicated instance here are not referenced to source object and structure. 
 

o Duplicate (Ctrl + D) - Creates an independent instance of the source selection at 
same position in 3D. 

o Duplicate Mirror X/Y/Z - Creates an independent instance of the source 
selection mirrored on related axis. 

o Duplicate Mirror X/Y/Z Flush - Creates an independent instance of the source 
selection mirrored on related axis. This command flushes also the 
transformation from sub tree to the object nodes. 
 

• Unshare - Removes the reference connection between source and cloned instance. 
Referenced nodes are underlined within the Scene Graph. A later change on them 
doesn't affect the other instance anymore. 

• Copy Transformation - A transformation contains information about the position and 
the orientation of an object within 3D space. It also provides information about the 
position and orientation of the objects coordination system. This command copies all 
this information from the selected node to clipboard. 

• Paste Transformation - Adopts transformations from clipboard to a selection. 
 

o Paste All - This command adopts all types of transformation information 
(translation, rotation, scale, pivot) from clipboard. 

o Paste Translation - Pastes translation threshold from clipboard to selected node. 
o Paste Rotation - Adopts rotation from clipboard. 
o Paste Scale - Adopts scale settings from clipboard. 
o Paste Pivot - Adopts location and orientation for the objects local coordination 

system from clipboard. 
 

• Group selection - Creates a group node and moves all selected nodes into it. 

Show optimize module 

Opens the module that provides further operations for example, geometrical optimizations, 
sharing, and so on. Default activates a recommended selection that could increase render 
performance; Clear deselects all selected modules; Optimize executes selected optimization 



commands. All operations are applied recursively. Multi-selection is supported on execution. 
Undo for all these types of actions is not available. 

• Reduction - 16-bit Lengths, 16-bit indices -Changes the lengths and/or indices from 
selection to a 16-bit data type. 

• Filter - Contains the following options: 
 

o Remove Point - Deletes all point objects within 
selection. 
o Remove Lines - Deletes all line objects within 
selection. 
o Remove LODs (Keep Best Quality) - Deletes all 
LOD's nodes within selection; command execution 
keeps child instance with highest mesh resolution and 
replaces the LOD node with it. 
o Remove LODs (Keep Lowest Quality) - Deletes all 
LOD's nodes within selection; command execution 
keeps child instance with lowest number of polygons 
and replaces the LOD node with it. 
o Remove Switches - Removes all switch nodes 
within selection; command execution keeps last child 
instance and replaces the switch node with it. 
o Remove Vertex Normals - Deletes all existing 
vertex normals from selection. 
o Remove Vertex Colors #1 and #2 - Imported 
objects could contain in maximum two different RGB 
values for every vertex point (edge point of polygons) - 
this technique is called vertex color. The feature 
removes existing vertex color information from shape 
nodes. 
o Remove Texture Coordinates #1 - #8 - Deletes 
existing texture coordinates from related channel. 
Channel #1 - #6 are relaying to UVW mapped texture 
coordinates; channel #7 and #8 are containing ambient 
occlusion calculated shadow information. 
o Remove Material Group Nodes with no children - 
Deletes all materials within Materials module that 
have not been assigned to an object. 
o Remove Empty Group Nodes - Deletes group 
nodes that contain no child nodes. 
o Remove Empty Geometry Nodes - Incorrect usage 
on external geometry editors could generate shape 
nodes that contain no polygons. These types of shape 



nodes imported to VRED could decrease runtime stability. This feature deletes 
such shape nodes. 

o Remove Identity Transforms - Deletes identity transform nodes within selection. 
o Remove Invalid Texture Coordinates - Imported objects could contain invalid 

texture coordinates. This feature helps delete this information. 
o Remove Degenerated Polygons - Removes shape nodes that cannot be drawn 

from the render engine. 
o Remove Animations - Deletes existing animation from selection. 
o Remove FileInfo - Removes the information from a file 
o Remove B-Side Nodes - B-Sides definition is comparable with no show feature 

from CAD software. Execution removes shapes and components that have been 
set as a B-Side. 
 

• Flush / Unflush - Object transformation could be realized in two ways within the Scene 
Graph. Either the transformation is stored within the object itself (flushed) or the 
related information is stored within group nodes on a higher hierarchy level above 
(unflushed). Nodes that contain transformations got a symbol of an axis in front of its 
icon. Several transformations in different levels are accumulated. 
 

o Flush Transformation Nodes (Adjust Face Normals) - Moves transform 
information from transform nodes to the geometry nodes on lowest level. 
Recalculates face normals additionally on execution. 

o Flush Transformation Translation - Moves translation-related transform 
information of selected sub- Tree to the geometry nodes on lowest level. 

o Flush Transformation Rotation - Moves rotation-related transform information 
of selected sub- Tree to the geometry nodes on lowest level. 

o Flush Transformation Scales - Moves scale related transform information of 
selected sub- Tree to the geometry nodes on lowest level. 

o Flush Selected Transformation - Flushes transform information from selected 
node. 

o Flush Transformation Nodes - Moves transform information of the selected sub- 
Tree to the geometry nodes on lowest level. 

o Flush Material Group Nodes - Material assignment in VRED can also be done by 
assignment to the object itself or to a material group node on a higher hierarchy 
level. Execution moves unflushed material definition from material group node 
the object. 

o Unflush Material Group Nodes - Creates a material group node above each 
geometrical node within selection and moves material definition there. 

o Flush Texgens - Converts TexGenChunk information to texture coordinates 
within the object on the level below. 

o Flush Textransformations - Converts TextureTransformChunk information to 
texture coordinates within the object on the level below. 
 



• Share - Sharing improves OpenGL render and Raytracing performance because required 
objects are not present several times within system memory. Shared instances are 
indicated by an underlined node description inside the scene tree. Any change on a 
shared object affects the cloned instance and vice versa. 
 

o Geometries - Looks for identical objects (identical polygon mesh) within 
selection and references all occurrences. 

o GeometryProperties - References all occurrences of duplicated geometry 
properties. 

o Materials - References all occurrences of duplicated materials. 
o Textures - References all occurrences of duplicated textures. 
o BlendChunks - References all occurrences of duplicated Blend Chunks. 

 
• Optimizations - Contains the following options: 

 
o Triangulate - Converts all types of polygon meshes into triangles. Faces with four 

and more edges are split into the appropriate number of triangles. 
o TriangulateReIndex - Indices of vertices must be defined in a counterclockwise 

order on creation. Following this rule increases runtime stability and render 
performance. Feature execution also converts all polygon meshes into triangles 
and it applies the regeneration of all vertex indices. 

o Octree - Is a tree structure that provides constant branches within the scene tree 
- every node had to contain eight or no child nodes. Execution restructures scene 
tree in that way. 

o Merge Materials - Merges identical materials to one. 
o Merge Geometry Nodes - Merges geometrical nodes to one contiguous object. 

Regarding objects are unshared, identical material are assigned, and all objects 
that should be combined are located within same group node. 

o Cleanup Group nodes - CAD generated data contains sometimes deep branches 
on their created trees. A group node contains a group node that contains a 
group node, and so on; at the end there is one shape node in a nested 
arrangement of group nodes. Feature helps to delete these nested groups 
automatically without removing the shape nodes itself. Group nodes that 
contain two or less shapes are considered on execution. 

o Unify Vertices - Every triangulated polygon got three vertices; one in every edge. 
Polygons located directly beside to each other should share as many vertices as 
possible to increase render performance. Command looks for identical, not 
shared vertices and combines them. 

o Create Fans / Create Stitches - Connects triangles to fans and stitches. 
o Optimize Indices - Tries to improve vertex cache efficiency by reordering indices. 
o Sort Indices - Sorts indices from selection. 



Convert to (sub menu) 

Contains commands to convert a group node into a switch node (Switch) and vice versa 
(Group). 

Reload (sub menu) 

Asset management module supports the user on the usage of external file references. These 
files are imported to the Scene Graph and present within its structure. Any change on an 
external file reference will be present within the scene after reloading affected file. Sub menu 
provides features to reload such file references. 

Other Scene Graph context menu commands (besides sub menus) 

• Hide/Show - Hides/shows selection within render view. An unselected box in front of a 
node and an uncolored icon indicates that the nodes are hidden. (Hotkeys Ctrl + H / Ctrl 
+ J) 

• Hide All/Show All - Hides/shows all scene objects within render view. (Hotkeys Ctrl + 
Shift + H / Ctrl Shift + J) 

• Isolate View Selected - Hides/shows everything unselected. The visibility of 
Environments is not affected. This feature was known from previous releases by 
dragging a node from Scene Graph into render view - both works. (Hotkey I) 

• Zoom To - Moves the Camera to a position that fits the bounding box dimensions from 
selection into the field of view. (Hotkey F) 

• Select All - Selects all nodes contained within Scene Graph exclude root node. (Ctrl + A) 
• Deselect all - Deselects everything. (Ctrl + Shift + A) 
• Invert Selection - Selects all unselected nodes and vice versa. (Ctrl + I) 

Icon Bar and slider within Scene Graph module 

Often required commands are accessible by an icon located directly below the scene tree. 

 

• Create - Opens sub menu that contains all node types that could be generated within 
VRED -Create Geometry, Create Light, Create Camera, Group, Clone, Environment, 
Switch. 

• Duplicate - Creates an independent instance from selection (Hotkey Ctrl +D). 
• Group selection - Creates a group node and moves all selected nodes into it (Hotkey Ctrl 

+ Shift + G). 
• Copy Transformation - Copies all transform information (translation, rotation, scale, 

pivot) from the selected node to system clipboard. 



• Paste Transformation - Pastes all transform information from system clipboard to 
transform properties of the selected node. 

• Delete - Deletes selected nodes and its child nodes (Hotkey Del). 
• Slider - Extends or folds substructure of selection or multi-selection on its usage. 

Object properties 

Object properties like position, pre-calculated shadows, and normal settings (affects shading 
within OpenGL render view) are available at tabs on the bottom of the Scene Graph module. 

Transformation 

A transformation contains information about the position and the orientation of an object 
within 3D space. It provides also information about the position and orientation of the objects 
coordination system. 

 

• Translate X/Y/Z - Moves selection depending on threshold and unit setting (mm, cm, 
m). Move to Camera moves the selection to the same position in 3D space where the 
camera is located; Move to Origin moves the selection to the position of its pivot point; 
Put on Ground makes selection move to environment floor height. 

• Rotate X/Y/Z - Rotates selection in on related axis about threshold in degrees. The 
Center Pivot button on the right moves objects local rotation axis to the center of its 
bounding box. 

• Scale X/Y/Z - Scales selection on related axis depending on threshold and unit setting. 
Enabling check box for Uniform Scaling restricts execution to set new value also on 
other related axes. The Center Pivot button on the right moves objects local scale pivot 
to the center of its bounding box. 



Occlusion 

Ambient occlusion calculation - is also known as soft global illumination. It generates shadows 
on gaps and corners; this makes scene illustration become more realistic within OpenGL render 
mode. 

 

The scene is illuminated on calculation by the HDR file from the environment node; it works 
without any other light source within the scene. All objects that are hidden in the moment of 
calculation are darkened. 

The Ambient Occlusion calculation is a pre-process and takes place during data preparation. 
Calculated Ambient Occlusion results are baked on the geometry's vertices - stored within 
texture coordinates #7 and #8. 

The smoothness of the calculated shadow depends on the polygon mesh resolution. Therefore, 
VRED offers several ways to increase the quality on low quality models, like subdividing, and 
predefined quality presets. 

 



• Preset - Presets are containing all shadow calculation-related settings within one 
setting. The drop- Down menu provides quick access to all available calculation presets 
that were saved from the Ambient Occlusion module within standard UI. 

• Shadow Quality - Ambient Occlusion is a specific not-physically-accurate rendering trick. 
It basically samples a hemisphere around each point on the face, sees what proportion 
of a hemisphere is occluded by other geometry and shades the pixel accordingly. 
 

o Preview Quality - 8×8 hemisphere samples (per vertex) 
o Low Quality - 16×16 hemisphere samples 
o Medium Quality - 32×32 hemisphere samples 
o High Quality - 48×48 hemisphere samples 
o Highest Quality - 64×64 hemisphere samples 
o Ultra High Quality - 128×128 hemisphere samples 

 
• Minimum Distance - Defines the minimum distance (mm) between objects that to 

should be taken into account for the calculation of Ambient Occlusion shadows. This 
value defines total black areas where full occlusion takes place. 

• Maximum Distance - Defines the maximum distance (mm) between objects that to 
should be taken into account for the calculation of Ambient Occlusion shadows. This 
value defines areas where no occlusion takes place. 

• Enable Subdivisions - Subdivides existing polygon mesh into smaller triangles. This 
option should be turned on to avoid ragged edges on shadow illustration. This feature is 
helpful when NURBS data for re-tessellation is not available, but a refined mesh is 
required. Subdividing generates more complex objects - it should only be used when 
required. Subdivide Geometry (edit menu from context menu of Scene Graph) provides 
more settings to control this process. 

IMPORTANT Only shadows for selected objects are calculated on execution. All visible 
objects in the scene are taken into account on calculation! 

Geometry 

The Geometry Editor from simple UI contains commands to turn polygon normals, vertex 
normals, and operations that affect the shaded illustration of the object within the OpenGL 
render mode. 



 

• Flip Normals - Polygons got a font-face and a back-face; the face normal is located 
centered and in right angle to the font-face. For Ambient occlusion calculation it is 
required to have polygons turned to the right direction. Otherwise calculation provides 
undesirable darkening effects where normals are turned. Every polygons vertex also has 
a normal that affects shading. Face/Surface turns all face normals of selection into the 
other direction. Face and Vertex turns both kinds of normals from selection. Vertex 
affects only normals from polygons vertices. 

Vertex/Face Normal Rendering mode available on settings tab of scene module from 
simple UI gives visual feedback about the orientation and it enables the adjustment of 
objects that contain inconsistent normals. 

• Crease Angle - Threshold defines an angle that is considered on shading illustration; all 
object edges that got a lower angle to the face beside are drawn smooth. Object edges 
with a higher angle than threshold display faceted. A value of 45 degrees let objects 
appear smooth. 

• Separation Angle - Defines the angle between the vertex normals. Needed in case of 
merged objects for example. 

B-sides 

On 3D data preparation, sometimes it is not clear if the part of an object is required for the 
scene or if it is hidden by another object. To avoid reloading the file, define regarding shapes 
and components as B-Sides. These elements are not visible within the render view; the scene 
tree icons are illustrated slightly darker than the standard icons. 

 

Scene Graph icons for B-Side line and polygonal shapes (active and inactive) 



Scene Module Material Tab - Simple UI 
The Material module from the simple UI reduces dialog boxes to the minimum of applicable 
settings. It helps inexperienced users to create and assign materials simply and quickly. 

Extended drag and drop operations and the preview feature on material assignment saves time 
on scene setup. 

 

Search field 

This search field provides live-search capabilities within the materials module. Entering one 
character hides all materials beginning with other characters. It is on top of the materials 
module - below the module tabs. Only single search terms are supported. 



 

Material preview list 

Every scene- Related material is represented by an icon within the material preview list. 
Switches, layered, and multipass materials have another smaller icon on lower left corner of the 
icon. 

Click selects a material; right- Click opens the context menu. Clicking a selected material 
enables renaming. 

Assign materials by dragging them to objects in the render view. In addition, common features 
like for example, replacing all occurrences of a material is contained by now. 

• Left mouse button - Replaces the material on a single object. 
• Middle mouse button - Replaces the material on all objects that are to be replaced by 

the material assigned. 
• Right mouse button - Converts the material to a material switch or multipass material. A 

pop-up menu lets you choose the desired type. Both materials (before assigned and 
dragged) are present within the newly created material. 

Preview on material assignment is a feature that gives visual feedback before the material is 
dropped onto an object. This avoids miss-assignment on dragging. 

Context Menu 

The context menu provides commands to create, change, or convert materials or its properties. 
Once the setup is done, the load and save feature enables the reuse within other scenes. 
Selection and assignment complete the scope of operation here. 



Create (sub menu) 

 

VRED provides lots of different material node types that support you creating every type of 
material you can imagine. The properties dialog box settings for the different node types are 
depending on its use case; they are at the bottom of the module. 

The creation of photorealistic materials requires sometimes the ability to use custom graphic 
files for its definition - these graphic files are called textures. Textures can be assigned within 
the most material types, directly below the material property settings. All usual 2D file formats 
are supported. 

Using textures implies a mechanism that tells the render engine about the position, orientation 
and scale of an image. All this information is generated automatically in the background on 
texture assignment within simple UI. Features to change these kinds of settings are accessible 
from standard UI. 

• Name - A material naming scheme with clear identifiers enables the live-search to find 
materials within complex scenes or libraries quickly. 

• Type - Change the material node type using the drop-down menu on top of the 
properties dialog box. All adoptable property settings are adopted automatically. 

VRED Material types and its properties 
Phong 

Phong shading is a historical technique that describes the way a surface reflects light. It 
generates diffuse reflections from rough surfaces and specular reflections from shiny surfaces - 
based on the fact that shiny surfaces have small intense specular highlights, while dull surfaces 
have large highlights that fall off more gradually. 

 



• Diffuse Color - This attribute defines the base color, the main characteristic of the 
material. The slider enables changing the brightness; click the color field on the right to 
open the color chooser. Assigning a texture to the diffuse color, projects it onto the 
surface. The look representation is a combination of the defined color and the assigned 
texture. 

• Glossy Color - Sets the material's color for surfaces glossy reflections. The slider enables 
changing the brightness; click the color field on the right to open the color chooser. 
Assigning a texture to the glossy channel defines areas in which different gloss 
intensities appear with help of a texture. The glossy color depends finally on both - the 
defined color and the possibly assigned texture file. 

• Roughness - The roughness parameter controls light refractions on top of the surface. 
The higher the value, the rougher is the microscopic structure on top of the surface and 
the more diffuse are the reflections. 

• Bump - Bump mapping enables the creation of structure to the materials surface. The 
Bump slider controls the height of that effect. A higher value results in more depth 
structure. If a texture is assigned to the bump map channel, it is used as a pattern figure 
on surface illustration. If no texture is assigned, a default noise map is used instead; 
Structure size affects then scale. 

Plastic 

Plastic is suitable to simulate shiny or glossy surfaces from objects that are made of synthetic 
materials. 

 

• Diffuse Color - This attribute defines the base color, the main characteristic of the 
material. The slider enables changing the brightness; click the color field on the right to 
open the color chooser. Assigning a texture to the diffuse color, projects it onto the 
surface. The look representation is a combination of the defined color and the assigned 
texture. 

• Glossy Color - Sets the material's color for surfaces glossy reflections. The slider enables 
changing the brightness; click the color field on the right to open the color chooser. 
Assigning a texture to the glossy channel defines areas in which different gloss 
intensities appear with help of a texture. The glossy color depends finally on both - the 
defined color and the possibly assigned texture file. 



• Roughness - The roughness parameter controls light refractions on top of the surface. 
The higher the value, the rougher the microscopic structure on top of the surface and 
the more diffuse the reflections. 

• Reflectivity - Controls the intensity of reflection on the surface. The higher the value the 
more the influence from environment and objects around. 

• Bump - Bump mapping enables the creation of structure to the materials surface. The 
Bump slider controls the height of that effect. A higher value results in more depth 
structure. If a texture is assigned to the bump map channel, it is used as a pattern figure 
on surface illustration. If no texture is assigned, a default noise map is used instead; 
Structure size affects then scale. 

Triplanar 

In difference to all other materials that could have textures assigned, the Triplanar node type 
enables you to have a custom mapping on different object sides within one material definition. 
Features to adjust these settings are accessible from standard UI. This type is recommended to 
create for example, leather, fabric, and diffuse plastic materials. 

 

• Diffuse Color - This attribute defines the base color, the main characteristic of the 
material. The slider enables changing the brightness; click the color field on the right to 
open the color chooser. Assigning a texture to the diffuse color, projects it onto the 
surface. The look representation is a combination of the defined color and the assigned 
texture. 

• Glossy Color - Sets the material's color for surfaces glossy reflections. The slider enables 
changing the brightness; click the color field on the right to open the color chooser. 
Assigning a texture to the glossy channel defines areas in which different gloss 
intensities appear with help of a texture. The glossy color depends finally on both - the 
defined color and the possibly assigned texture file. 

• Roughness - The roughness parameter controls light refractions on top of the surface. 
The higher the value, the rougher the microscopic structure on top of the surface and 
the more diffuse the reflections. 

• Reflectivity - Controls the intensity of reflection on the surface. The higher the value the 
more the influence from environment and objects around. 

• Bump - Bump mapping enables the creation of structure to the materials surface. The 
Bump slider controls the height of that effect. A higher value results in more depth 
structure. If a texture is assigned to the bump map channel, it is used as a pattern figure 



on surface illustration. If no texture is assigned, a default noise map is used instead; 
Structure size affects then scale. 

Reflective Plastic 

Reflective Plastic is also suitable to simulate shiny or glossy surfaces from objects that are made 
of synthetic materials. It adds the ability to have a mirror image reflection of everything around 
on its surface. 

 

• Diffuse Color - This attribute defines the base color, the main characteristic of the 
material. The slider enables changing the brightness; click the color field on the right to 
open the color chooser. Assigning a texture to the diffuse color, projects it onto the 
surface. The look representation is a combination of the defined color and the assigned 
texture. 

• Glossy Color - Sets the material's color for surfaces glossy reflections. The slider enables 
changing the brightness; click the color field on the right to open the color chooser. 
Assigning a texture to the glossy channel defines areas in which different gloss 
intensities appear with help of a texture. The glossy color depends finally on both - the 
defined color and the possibly assigned texture file. 

• Roughness - The roughness parameter controls light refractions on top of the surface. 
The higher the value, the rougher the microscopic structure on top of the surface and 
the more diffuse the reflections. 

• Reflectivity - Controls the intensity of reflection on the surface. The higher the value the 
more the influence from environment and objects around. 

• Bump - Bump mapping enables the creation of structure to the materials surface. The 
Bump slider controls the height of that effect. A higher value results in more depth 
structure. If a texture is assigned to the bump map channel, it is used as a pattern figure 
on surface illustration. If no texture is assigned, a default noise map is used instead; 
Structure size affects then scale. 

Reflective Triplanar 

This node type provides the triplanar mapping feature in combination with mirror reflections 
from everything around on its surface. 



 

• Diffuse Color - This attribute defines the base color, the main characteristic of the 
material. The slider enables changing the brightness; click the color field on the right to 
open the color chooser. Assigning a texture to the diffuse color, projects it onto the 
surface. The look representation is a combination of the defined color and the assigned 
texture. 

• Glossy Color - Sets the material's color for surfaces glossy reflections. The slider enables 
changing the brightness; click the color field on the right to open the color chooser. 
Assigning a texture to the glossy channel defines areas in which different gloss 
intensities appear with help of a texture. The glossy color depends finally on both - the 
defined color and the possibly assigned texture file. 

• Roughness - The roughness parameter controls light refractions on top of the surface. 
The higher the value, the rougher the microscopic structure on top of the surface and 
the more diffuse the reflections. 

• Reflectivity - Controls the intensity of reflection on the surface. The higher the value the 
more the influence from environment and objects around. 

• Bump - Bump mapping enables the creation of structure to the materials surface. The 
Bump slider controls the height of that effect. A higher value results in more depth 
structure. If a texture is assigned to the bump map channel, it is used as a pattern figure 
on surface illustration. If no texture is assigned, a default noise map is used instead; 
Structure size affects then scale. 

Chrome 

The Chrome material node type should be used for all kinds of chromic and metallic materials. 
When more control about scale and orientation of the surface structure is required, it is 
recommended to use brushed metal instead. Many metal type presets are available within the 
properties dialog box. 

 



• Metal Type - High reflective chrome material, aluminum, amorphous carbon, silver, 
gold, cobalt, copper, chromium, lithium, mercury, nickel, potassium, platinum, iridium, 
silicon, amorphous silicon, sodium, rhodium, tungsten, vanadium, andiron. 

• Reflection Color - The higher the brightness the higher the reflection on the surface. 
Black means no reflection; white gives full reflection. Click the color field on the right to 
open the color chooser; when the chrome reflection is colored, reflected objects are 
also colored. 

• Roughness - The roughness parameter controls light refractions on top of the surface. 
The higher the value, the rougher the microscopic structure on top of the surface and 
the more blurred are the reflections. 

Brushed Metal 

The brushed metal material node type can simulate any type of metal; it gives full control about 
the scale and orientation of the surface structure. Many metal type presets are available within 
the properties dialog box. 

 

• Metal Type - Custom reflectivity, aluminum, amorphous carbon, silver, gold, cobalt, 
copper, chromium, lithium, mercury, nickel, potassium, platinum, iridium, silicon, 
amorphous silicon, sodium, rhodium, tungsten, vanadium, and iron. 

• Glossy Color - The higher the brightness the higher the reflection on the surface. Black 
means no reflection; white gives full reflection. Click the color field on the right to open 
the color chooser; when the chrome reflection is colored, reflected objects are also 
colored. 

• Brush Mapping - This Property setting belongs to the brush orientation; planar, radial, 
and triplanar options are available to generate the desired surface structure. 

• Roughness U/V - The roughness parameter controls light refractions on top of the 
surface. The higher the value, the rougher the microscopic structure on top of the 
surface and the more blurred are the reflections. Different values for horizontal and 
vertical roughness provide every type of refraction behavior that is known from metallic 
surfaces. 

• Size U/V - Affects scale and direction of the surface structure when no texture is 
assigned to the bump map channel. 

• Bump - Bump mapping enables the creation of structure to the materials surface. The 
Bump slider controls the height of that effect. A higher value results in more depth 
structure. If a texture is assigned to the bump map channel, it is used as a pattern figure 



on surface illustration. If no texture is assigned, the structure results from property 
setting Size U and Size V. 

Unicolor Carpaint 

Generates a single-colored car lacquer material with customizable coating effect on the top of 
the surface. 

 

• Base Color - This attribute defines the basic color, the main characteristic of the 
material. The slider enables changing the brightness; click the color field on the right to 
open the color chooser. 

• Clear Coat Color - Changing the brightness relays to the reflection intensity of the clear 
coat effect. It possibly adds a color to the glossy effect of the coated surface. 

Metallic Carpaint 

A metallic carpaint material got additionally small particles made of metal (flakes) on top of its 
lacquer layer. Those particles increase the brightness within the angle of incidence. Color and 
size of flakes is customizable. 

 

• Base Color - This attribute defines the basic color, the main characteristic of the 
material. The slider enables changing the brightness; click the color field on the right to 
open the color chooser. 

• Flake Color - The setting defines the color of the metallic particles on top of the lacquer 
layer. 

• Clear Coat Color - Changing the brightness relays to the reflection intensity of the clear 
coat effect. It possibly adds a color to the glossy effect of the coated surface. The check 
box enables you to deactivate the coating effect. 



• Roughness - The roughness parameter controls light refractions on top of the surface. 
The higher the value, the rougher the microscopic structure on top of the surface and 
the more diffuse the reflections. 

• Reflectivity - Controls the intensity of reflection on the surface. The higher the value the 
more the influence from environment and objects around. 

• Flake Size - Belongs to the size of the metallic particles on top of the lacquer layer. 

Flipflop Carpaint 

This type of carpaint material provides two layers of flakes on top of the base color. Its 
appearance depends extremely on the viewing angle between surface and observer. The effect 
is commonly known from show cars and toy cars. 

 

• Base Color - This attribute defines the basic color. The slider enables changing the 
brightness; click the color field on the right to open the color chooser. 

• Flake One Color - The setting defines the color of the metallic particles on top of the 
lacquer layer. 

• Flake Two Color - The setting defines the color of the metallic particles on the second 
layer of flakes. 

• Clear Coat Color - Changing the brightness relays to the reflection intensity of the clear 
coat effect. It possibly adds a color to the glossy effect of the coated surface. 

• Roughness - The roughness parameter controls light refractions on top of the surface. 
The higher the value, the rougher the microscopic structure on top of the surface and 
the more diffuse the reflections. 

• Reflectivity - Controls the intensity of reflection on the surface. The higher the value the 
more the influence from environment and objects around. 

• Flake Size - Belongs to the size of the metallic particles on top of the lacquer layer. 

Glass 

Glass material is used for all kinds of transparent materials for example, glass, acrylic glass, 
diamond. It provides furthermore the ability to simulate liquids. Presets help on quick setup. 

• Medium - Presets for all kinds of transparent materials and liquids. 
• Transparency - Changes the level of transparency. A click onto the color field on the 

right opens the color chooser; it enables changing the base color of the glass material. 



• Specular Color - Sets the material's color for surfaces glossy reflections. The slider 
enables changing the brightness; click the color field on the right to open the color 
chooser. 

• Reflectivity - Controls the intensity of reflection on the surface. The higher the value the 
more the influence from environment and objects around. 

• Roughness - The roughness parameter controls light refractions on top of the surface. 
The higher the value, the rougher the microscopic structure on top of the surface and 
the more diffuse the reflections. 

Carbon / Carbon 2D 

Carbon is a fiber material with typical pattern and coating on the top. It is often used to 
decrease the weight of sport vehicles to the minimum. 

Carbon is a triplanar shader; Carbon 2D is used in case of planar projections. 

 

• Diffuse Color - This attribute defines the base color of the material. The slider enables 
changing the brightness; click the color field on the right to open the color chooser. 

• Glossy Color - Sets the material's color for surfaces glossy reflections. The slider enables 
changing the brightness; click the color field on the right to open the color chooser. 

• Clear Coat Color - Changing the brightness relays to the reflection intensity of the clear 
coat effect. It possibly adds a color to the glossy effect of the coated surface. The check 
box enables you to deactivate the coating effect. 

• Roughness - The roughness parameter controls light refractions on top of the surface. 
The higher the value, the rougher the microscopic structure on top of the surface and 
the more diffuse the reflections. 

• Reflectivity - Controls the intensity of reflection on the surface. The higher the value the 
more the influence from environment and objects around. 

• Pattern - All typical patterns are included within VRED. 
• Pattern Size - Scales applied pattern. 

Tire 

Tire material supports different textures for rim and profile within one node. Rubber shading 
rounds off whole thing. 



 

• Diffuse Color - This attribute defines the base color. The slider enables changing the 
brightness; click the color field on the right to open the color chooser. 

• Glossy Color - Sets the material's color for surfaces glossy reflections. The slider enables 
changing the brightness; click the color field on the right to open the color chooser. 

• Roughness - The roughness parameter controls light refractions on top of the surface. 
The higher the value, the rougher the microscopic structure on top of the surface and 
the more diffuse the reflections. 

• Reflectivity - Controls the intensity of reflection on the surface. The higher the value the 
more the influence from environment and objects around. 

• Bump - Bump mapping enables the creation of structure to the materials surface. The 
Bump slider controls the height of that effect. A higher value results in more depth 
structure. 

• Textures - Markings textures relating to rim; profile belongs to the pattern of the 
running surface. 

Velvet 

The velvet material mimics the reflection behavior of velvet by darkening the regions of an 
object where the surface points almost directly to the viewer and brightening its edges up 
(where the surface is viewed at grazing angles). 

 

• Diffuse Color - This attribute defines the base color. The slider enables changing the 
brightness; click the color field on the right to open the color chooser. 

• Glossy Color - Sets the material's color for surfaces reflections. The slider enables 
changing the brightness of the reflections; click the color field on the right to open the 
color chooser. 

• Darkening - Controls the intensity of the diffuse component. The default value is 1.0; 
everything greater than 1 darkens the material, a value less than 1 lightens it up. 



Woven Cloth 

Woven cloth material contains presets for all usual types of fabric. The properties dialogue 
enables casual users on setting up customized cloth material without using an external image-
processing tool for example, Photoshop. 

 

• Cloth Preset - Various fabric presets are shipped with VRED. 
• Diffuse Color - This attribute defines the base color of the material. The slider enables 

changing the brightness; click the color field on the right to open the color chooser. 
• Yarn Colors - Enables you to customize the color of the yarns. The sliders changing the 

brightness; click the color field on the right to open the related color chooser. 
• Darkening - Controls the intensity of the diffuse component. The default value is 1.0; 

everything greater than 1 darkens the material, a value less than 1 lightens it up. 
• Texture Mode - If the object already contains an UV mapping, UV coordinates are used. 

Triplanar generates mapping new from scratch. 
• Pattern Size - Adjusts the scale of the fabric pattern. 

Line Chrome 

The Line Chrome Material is a special variant of the chrome materials for line geometries. This 
material does not work on triangle based or NURBS geometry. 

 

• Reflection Color - The Specular Reflection color. 
• Use Roughness - Turns the material to be glossy instead of specular. 
• Line Width - The width of the line geometry. 



Measured 

VRED supports the usage of measured materials. Those kinds of materials contain inter alia 
surface reflection information that considers reflection behavior from different viewing angles - 
it ensures a photo realistic illustration within the render view. 

 

• Measurement - Loads the BTF measurement file. 
• Exposure - Controls the representation intensity of the measured material. A threshold 

about 1.0 gives the optimal result. 

Measured Carpaint 

This material type aligns to the measured material. It additionally enables adjusting the 
refraction index of the scanned material within its properties. 

 

• Measurement - Loads BTF measurement. 
• Exposure - Controls the representation intensity of the measured material. A threshold 

about 1.0 gives the optimal result. 
• Fresnel IOR - Controls the refraction index of the clear coat layer. When loading a BTF 

measurement it is initialized to the measured refraction index. 

Office Color Science (OCS) Material 

The Office Color Science (OCS) Material allows you to load BRDF files exported from CI- 
Navigator. The CI-Navigator is a software system by Office Color Science Co., Ltd. that calculates 
metallic and pearlescent paint formulations from measurements of given target paint samples. 
The BRDFs of those measurements and simulations can be exported by CI-Navigator in a VRED 
compatible BRDF file format (*.pbrdf). 



 

• OCS BRDF - Loads a BRDF file. 
• Exposure - Controls the representation intensity of the measured material. A threshold 

about 1.0 gives the optimal result. 
• Clearcoat - Disables coating when checked. 

Shadow 

Shadow material is transparent by default. It is only shaded where pre-calculated ambient 
occlusion shadows take place. 

 

• Occlusion intensity - Controls the intensity of shadowed areas. 
• Occlusion Color - Sets the color for ambient occlusion shadows. 
• Shadow Color - Sets the color for shadows from light sources (like point lights). 

Multi Pass 

MultiPass materials can display multiple materials in different layers on top of each other. It 
enables you to setup dirt, promotion labels, and other types of complex materials. 

 

It can be created in two ways; the first uses drag and drop assignment within the render view. 
Right- Click opens a dialog box that lets you select Add as Multi Pass. Both materials (before 



assigned and dragged) are present within the newly created material as different layers. The 
second creation method is the related create context menu entry. The node is created and all 
materials that should be present within the layers are also assignable by dragging but this must 
be done within the material library itself. 

Changing the drawing order of layers could be done within the material editor from standard 
UI. 

Layered 

A layered material allows you to stack multiple materials on top of each other. Unlike the 
multipass material, the order of traversal is determined by the normal of the geometry. This 
allows it to use the layered material as a two-sided material. 

 

Additionally, glass materials are handled in a special way. If two glass materials are added to 
the layered material the index of refraction of these glass materials are adjusted in a way that 
allows to use them in glass-on-glass contact situations. If you add more than two glass 
materials, only the index of refraction of the first and last glass material is considered, all other 
glass materials get an Index of Refraction of 1.0 and act as a color filter if material density is 
turned off. 

Changing the drawing order of layers could be done within the material editor from standard 
UI. 

NOTE Layered materials do not support render passes. 

Switch 

A switch material can contain several materials but only one of them is visible at the same time. 
The creation is done on the same ways already known from the creation of multipass or layered 
materials. Either on dragging within the render view - Create Switch Material must be selected 
or by dragging within the material library. If several material variants should be assigned on 
creation, have them selected and execute the context menu command Create Switch from 
Selection. 



If a switch material is selected the all material variants are present within the Switch Choice 
section below the library. Click a child material to open its properties. Double- Click a child 
material to activate it. 

Light Portal 

A light portal is a guide for photons coming from the environment. The bounding box around all 
light portals in the scene is used as a target for photon emission from an environment. This 
allows you to limit the photons to certain areas of the scene instead of shooting many more 
photons. 

During still frame antialiasing all light portal materials are set to invisible in raytracing mode. 

• Visibility - Sets the opacity of the material. This is useful for placing the light portal. 

Edit (sub menu) 

The edit sub menu provides features to replicate materials or to adopt its settings to other 
existing materials. 

• Copy - Copies the selected material to the system clipboard. 
• Paste - Pastes the clipboard contained material into the library. 
• Paste Attributes - Pastes all settings from clipboard contained material to the selected. 
• Duplicate - Creates an independent copy of the selected material. 
• Delete - Removes the selected material from the library when it's not in use. 
• Lock/Unlock - Avoids any change on the material. Property settings from locked 

materials are not accessible within the properties dialog box until the material has been 
unlocked again. The Name of locked materials is illustrated with italic style. 

Asset (sub menu) 

Asset management module supports the user on the usage of external file references. These 
files are imported in a referenced way to the material module. Any change on an external file 
reference will be present within the scene after reloading affected file. Sub menu provides 
features to reload such file references. 

• Unlock to Edit - Unlocks the referenced material to change settings 
• Find in Asset Manager - Selects the corresponding folder within the file browse tree 

inside materials tab from the asset manager. 
• Reload from Asset Manager - Reloads related material and adopts updates when 

changes are made to it. Material can be chosen from appearing window 
• Remove Reference - Removes all references from material and makes it unique. An 

asset manager link is no longer available. 



Convert (sub menu) 

There are different classes of materials supported within VRED. Truelight materials provide a 
photorealistic representation; this type of material is required for ambient occlusion 
calculation. Geometry that has been newly imported to VRED contains standard OpenGL Phong 
material that doesn't support ambient occlusion calculation. The convert sub menu helps either 
to convert a type of Truelight material into another type of Truelight material or it helps to 
convert standard OpenGL Phong materials into Truelight Phong materials. 

• To Truelight Material - Has the same behavior than using the Type drop-down menu 
within the materials properties. It converts the selected Truelight material into another 
type of Truelight material; all adoptable property settings are adopted automatically. 

• All to Phong Truelight Material - Converts all scene contained standard OpenGL Phong 
materials into Truelight Phong materials. 

Other material context menu commands (besides sub menus) 

• Load / Save Material(s) - Enables the reuse of materials within other VRED projects. 
Save is available when materials have been selected before; the dialog box asks for a 
folder within the file system that is used to store before selected materials in OSB file 
format. Every material is selected as a single OSB file. Use Load to import a saved 
material into the library. 

• Create Switch from Selection - Creates a switch material node and applies selected 
materials to it. 

• Select Nodes (Hotkey Ctrl + N) - Selects all geometrical objects that have the selected 
material assigned. 

• Add Nodes to Selection (Hotkey Ctrl + Shift + N) - Adds all objects that have the 
selected material assigned to the current selection of geometrical objects. 

• Apply to Selected Nodes (Hotkey Ctrl + M) - Applies selected material to the selected 
objects. 

Icon Bar and slider within material module 

Often required commands are accessible by an icon located directly below the material library. 

 

• Create - Opens sub menu that contains all material node types VRED can create. 
• Duplicate - Creates an independent copy of the selected material. 
• Select Nodes - Selects all geometrical objects that have the selected material assigned. 
• Apply to Selected Nodes - Applies selected material to the selected objects. 
• Remove unused - Deletes all materials from the library that are not applied to any 

object. 



• Delete - Removes the selected material from the library when it's not in use. 
• Slider - Scales the material preview representations inside the library. 

Material properties 

Object property settings and texture assignment takes place here. 



Scene Module Environments Tab – Simple UI 
An Environment is used for the surrounding of the scene. It contains a textured geometrical 
object that is used for lighting the scene and avoids presenting an endless 3D space to the 
observer. A shadow plane on its ground stores pre-calculated ambient occlusion data and is 
also able to illustrate shadows on the floor when Raytracing mode is activated. 

 



Search field 

The search field provides live-search capabilities within the environment module. Entering one 
character hides all environments beginning with other characters. It is on top of the module - 
below the module tabs. Only single search terms are supported. 

 

Environment preview list 

Every environment that is contained within the project file got its representation within the 
environment library. 

Left mouse button selects an environment; right button opens the context menu. Single left 
mouse button on a selected environment enables renaming. Double left mouse button sets the 
selected environment material to be used as current. 

Context menu 

The context menu provides commands to create, edit, or convert environments. 

Create (sub menu) 

VRED provides two kinds of environment nodes. One gets it representation and lighting 
behavior from a texture file and the other one simulates the position of the sun depending on 
world time and location. 

• Environment - An environment node provides a textured surrounding with shadow 
plane on its ground. Its texture affects the representation of all scene-related materials. 
The creation dialog box asks for this texture. It generates the dome and shadow plane 
automatically. 
 

o Environment - A click onto the folder icon on the right opens the file browse 
dialog box enables assigning a texture. When a texture is assigned the path and 
filename are present in the field on the left. 



o Environment Geometry - Selects the geometrical form for the current 
environment. Dome, sphere and cube shapes are available as presets; custom 
enables you to load an external geometry file. 

o Visible - Controls the visibility of the environment within the render view. A 
hidden environment but activated environment furthermore influences all scene 
contained objects regarding its look and appearance. 

o Shadow Plane - Enables or disables the shadow plane on the ground. 
o Exposure - Enables you to control the influence about lighting and reflection 

from the environment node to any object within the scene. A threshold from 1.0 
interprets the texture exactly like it is; a value below/above darkens/lightens all 
objects. 
 

• Skylight - A skylight environment provides physical correct simulated lighting depending 
on world time and location. 
 

o Location - Adopts the clicked map position for the sunlight simulation. An orange 
point on top of the map indicates selection. Another possibility to define this 
location using the text field directly below the map. It requires a city name on 
live-search supported input. A yellow point on the map previews occurrence. 
Confirming input converts the yellow point to orange when the simulation has 
adopted the new location. 

o Time / Date - Sets time and date of the simulation. Today changes the date to 
today; now changes day and time to now. 

o Sky Model - Provides two different sky models - Realistic and Artistic. The artistic 
sky model produces more reddish and colorful skies; especially for 
sunrise/sunsets. 

o Exposure - Enables the control of the lighting and reflection influence from the 
environment node on any object within the scene. A threshold of 1.0 interprets 
the texture exactly like it is; a value below/above darkens/lightens all objects. 

o Sky Turbidity - Sets the amount of particulate in the sky. The lower the value, 
the clearer blue the sky. Increased values add dust to the sky. 

o Sun Scale - Creates sunlight-generated shadows with hard edges near objects 
that casts them. The farther the distance from the object, the softer are the 
shadow's edges. Reducing Sun Scale extends the shadow's distance creates 
harder edges. 

o Ground color - Changes the brightness at ground level. Click the color field to the 
right to open the Color Chooser and define a custom color. 

Edit (sub menu) 

The edit sub menu provides features to duplicate or delete an environment material. 

• Duplicate - Creates an independent copy of the selected material. 
• Delete - Removes the selected material from the library when it's not in use. 



Other material context menu commands (besides sub menus) 

• Convert to Environment/Skylight - This entry depends on the type of environment 
material selected upon opening the context menu. If a skylight is selected, you can 
convert it to an environment and vice versa. 

• Select Environment node - Selects the corresponding environment shape with a related 
material assigned. 

• Set - Sets the selected environment material as the current. 

Icon Bar and slider within Environment module 

Often required commands are accessible by an icon located directly below the material library. 

 

• Create - Opens a sub menu that provides for creating either an environment or skylight 
material. 

• Duplicate - Creates an independent copy of the selected material. 
• Select Environment Node - Selects the corresponding environment shape with a related 

material assigned. 
• Delete - Removes the selected material from the library when not in use. 
• Slider - Scales the material preview representations inside the library. 

Environments properties 

All environment property settings take place here. Detailed descriptions are available within the 
previous create section. 

 



Scene Module Camera Tab – Simple UI 
While in Simple UI mode, in the Quick Access Bar, click Scene, then click the Camera tab. Use 
this tab to makes all camera-related property settings accessible and supports the creation of 
viewpoints and track animations. To keep the Simple UI mode of the Camera Editor clean, 
advanced features, like lens attributes and clipping, are accessible only in the Standard UI 
mode. 

Camera drop-down menu 

All settings affect the camera selected within the Camera drop-down. All scene-contained 
perspective cameras are available here. 

 



Camera Tracks / Capture 

Viewpoints and settings for the animation 
interpolation in between are stored in the Track 
section. Every camera has its own track. Double-
click the track name bar to collapse or expand it. 

To create a viewpoint, click Capture. The current 
position and orientation of the active camera are 
stored within it. If no camera track exists when 
the viewpoint is created, it is generated 
automatically. A thumbnail image helps to 
differentiate viewpoints, at a glance. 

To create additional viewpoints within a track, use 
the track's Capture button. To create another 
track and add a viewpoint to it, click the Capture 
button below the camera track(s). 

To rename a camera track or viewpoint, click its name to edit the field. 

To make the current camera adopt its position and orientation from the viewpoint, click a 
viewpoint. Drag to rearrange existing viewpoints. 

Context menu from viewpoints 

Right-click a viewpoint to open its context menu. 

• Recapture - Overwrites the viewpoint with the current position and orientation from 
Render Window's camera. Use the icon to the right of the viewpoint thumbnail for quick 
access. 

• Delete - Removes the current viewpoint from the Camera tab. Use the icon to the right 
of the viewpoint thumbnail for quick access. 

• Animation Properties - Opens a dialog for setting the camera's animation behaviors, 
when a viewpoint is selected. 

 



o Name - Enables the renaming of the viewpoint. 
o Fade-In Time - Sets the start time for the playback to fade from a complete black 

screen to the colored image. The threshold defines the time that is used for the 
moment of fading. A value from 0.00 disables feature. 

o Duration - Controls the time the camera animation uses to move from its current 
position to the one stored within the viewpoint. A duration value of 0.00 seconds 
gives a hard cut. The viewpoint duration doesn't affect the track duration. 

o Pause Time - Determines how long before the camera to move to the related 
viewpoint. 

o Overwrite track settings - Adapts adjusted settings from viewpoint to the 
animation track properties, once OK is pressed. 

Buttons next to the thumbnails 

These buttons are only visible at maximum zoom. 

• Delete - Removes the viewpoint from the Camera tab. 
• Recapture - Overwrites the viewpoint with the current position and 
orientation from the Render Window's camera. 

Buttons next to the Track title 

• Play - Toggles playback of the current camera track on and 
off within the Render Window. 

• Delete - Removes the complete track and its related 
viewpoints from Camera tab. 

• Animation Properties - Opens a dialog for setting the camera's animation behaviors, 
when a viewpoint is selected. 

 

o Name - Enables the renaming of the viewpoint. 
o Fade-In Time - Sets the start time for the playback to fade from a complete black 

screen to the colored image. The threshold defines the time that is used for the 
moment of fading. A value from 0.00 disables feature. 



o Duration - Controls the time the camera animation uses to move from its current 
position to the one stored within the viewpoint. A duration value of 0.00 seconds 
gives a hard cut. The viewpoint duration doesn't affect the track duration. 

o Pause Time - Determines how long before the camera to move to the related 
viewpoint. 

• Overwrite track settings - Adapts adjusted settings from viewpoint to the animation 
track properties, once OK is pressed. 

Slider 

Use the slider at the bottom of the Camera Track window to zoom in and out of the thumbnails. 

Properties 

The Properties section at the bottom of the tab makes all customizable settings from the 
related viewpoint accessible. 

• Name - Enables the renaming of the 
current camera. 

• Dolly Zoom - Changes the focal length 
and the field of view, in combination 
with moving the camera. This makes 
the observer feel that the focused 
object stays still in the center of 
interest and everything around it 
moves. When the check box is enabled, 
Field of View and Focal Length can act 
independent of one another. This 
option only affects the current focused 
object within the Render Window 
(double-right-click on the object's 
surface). 

• Field of View - Sets the camera's angle 
of view and is measured in degrees. The 
field of view angle is directly 
interrelated with the focal length. 

• Focal Length - Affects zooming. It sets 
the focal length, measured in 
millimeters. The focal length is directly 
interrelated with the field of view. 

• Roll - Adjusts the camera rotation angle 
(in degrees) about its line of sight. 



• Depth of Field - Simulates blurring of everything in front or behind the focused object. It 
requires defining the focal aperture (F-Stop) used for the calculation. 

• Motion Blur - Creates the streaking that appears do to the rapid movement of an object 
or prolonged exposure. The shutter setting controls the strength of the effect. 

• Exposure - Affects the illumination behavior from the environment texture on the usage 
of the related camera. A threshold from 1.0 interprets the HDR environment texture 
exactly like it's given within its environmental property settings. A value below/above 
darkens/lightens the illustration from that camera. 

• Whitepoint - Defines the tone above everything that should be shown as white. 
• Whitebalance - Adjusts the color temperature of the image. It is measured in Kelvin. 

6500 Kelvin is used as standard for video productions. 
• Hue-Shift - Shifts all colors uniformly towards a color shade. 
• Saturation - Sets the intensity of the color values. 
• Contrast - Separates the light and dark color values further from each other. 
• Brightness - Increases or decreases lightness for the scene. 

Turntable animation 

Creates an animation that rotates the camera 360° counterclockwise around the perpendicular 
axis of the focused object. Playback starts when Play is pressed. The duration of the 360° 
rotation can be set in the field next to the Play button. 

 

When Loop is checked, the animation continues until you stop it. Reverse plays animation in a 
clockwise rotation. 



Scene Module Lights Tab – Simple UI 
The Lights tab in the Scene module, lists all scene-contained light sources, enables light 
creation, and makes property settings accessible. It uses group nodes and a tree structure like 
the Scene Graph, but independent of it. 

NOTE To access it, you must be in Simple UI mode. Once in Simple UI mode, if the Scene 
module isn't already open, in the Quick Access Bar, click the Scene icon. 

 

One of the light sources is generated by default and can't be created afterwards—the 
headlight. Its orientation aligns to the active camera view, like an on-camera light source. The 
light source type can be chosen within its properties dialog box. 



Use the transformation manipulator, accessible by selecting the Transform icon in the Icon Bar, 
to transform and rotate the light source. Use your mouse within the Render Window to do this. 

 

To change the orientation or position of a light numerically, in Simple UI mode, in the Quick 
Access Bar, select Scene, then the Scene Graph tab, in the Properties, and select the 
Transformation tab. 

Search field 

Provides live-search capabilities within the Scene module's Lights tab. Entering one character 
hides all light sources beginning with other characters. Search is at the top, just below the tabs. 
Only single search terms are supported. 

 

Scene lights 

Navigation within the Light Editor is equal to the Scene module's Lights tab. If there is a group 
node you want expanded, click the plus (+) in front of it or double-click it. Once open, you can 
drag and rearrange the nodes. To switch a light on or off, use the check box in front of the 
node. 

Click to select a light source. Right-click to open the context menu. Click a selected light source 
to enables renaming. Double-click to select the corresponding node within the Scene Graph. 

 



Context menu 

Provides commands to create, edit, save, or load light sources. Right-click to open it. 

Create (sub menu) 

Provides several kinds of light sources for lighting a scene. Advanced settings, like realtime 
shadow intensity and its map resolution, are available within the Lights Editor in the standard 
UI. You can rename and change the type of light source in the Properties section of the Lights 
tab. 

• Directional Light - Light rays from directional light sources are parallel like sunlight. A 
directional light generates a clean-cut shadow. If the light source is located near an 
object, it creates a clear shadow with hard edges. If it is further away, the shadow edges 
become softer. 

 
o Intensity - Changes the light 
intensity; higher values result in 
brighter lighting. 
o Diffuse - Uses the diffuse color to 
define the color of light shown on 
illuminated objects' diffuse surface 
reflection. 
o Specular - Uses the specular color 
for the light that appears on shiny 
surfaces. 

 
• Point Light - Point light rays start at a single point and emit radially. Point light generates 

rather diffuse shadows. In OpenGL, a point light has a shadow. 
 

o Intensity - Changes the light 
intensity; higher values result in 
brighter lighting. 
o Diffuse - Uses the diffuse color to 
define the color of light shown on 
illuminated objects diffuse surface 
reflection. 
o Specular - Uses the specular color 
for the light that appears on shiny 
surfaces. 
o Position > Get from Camera - Moves 
the light source to the position of the 
active camera. 



 
 

• Spot Light - Spot light rays follow a beam cone. They start at a single point and spot in a 
circular area to its oriented direction. An area around the hotspot, defined by the 
penumbra property setting, is where the light falls off to dark. The spot light is often 
used to emphasize an object or a surface. 
 

o Intensity - Changes the light 
intensity; higher values result in brighter 
lighting. 
o Diffuse - Uses the diffuse color to 
define the color of light shown on 
illuminated objects diffuse surface 
reflection. 
o Specular - Uses the specular color 
for the light that appears on shiny 
surfaces. 
o Cone / Penumbra Angle - Uses the 
cone angle to control the size of the 
spot. The penumbra angle is the falloff 
area added around the spot. 
o Position > Get from Camera - Moves 
the light source to the position of the 
active camera. 
 

 
• Spherical Light - Spherical light rays beam like from a glowing ball. A spherical light 

generates diffuse light and soft shadows. It provides a type of indirect lighting and it is 
more atmospheric than a point light. In OpenGL, a spherical light has a shadow. 



 

o Intensity - Changes the light 
intensity; higher values result in brighter 
lighting. 
o Diffuse - Uses the diffuse color to 
define the color of light shown on 
illuminated objects diffuse surface 
reflection. 
o Specular - Uses the specular color 
for the light that appears on shiny 
surfaces. 
o Position > Get from Camera - Moves 
the light source to the position of the 
active camera. 
 
 
• Disk Light / Rectangular Light - Light 

rays from disk and rectangular light sources appear like dropped from ceiling - either in 
the shape of circle (disk) or square (rectangular). 

 

o Intensity - Changes the light 
intensity; higher values result in brighter 
lighting. 
o Diffuse - Uses the diffuse color to 
define the color of light shown on 
illuminated objects diffuse surface 
reflection. 
o Specular - Uses the specular color 
for the light that appears on shiny 
surfaces. 
o Position > Get from Camera - Moves 
the light source to the position of the 
active camera. 
 
 
 

 
• Group - Enables you to create a tree structure within the Lights tab independent from 

the Scene Graph. It helps you to keep scene-contained light sources clearly arranged. 



Edit (sub menu) 

Provides features to rename, duplicate, delete, or group selected light sources. 

• Rename - Changes the name of the light source. 
• Duplicate - Creates an independent copy of the selected light source. 
• Delete - Removes the selected light source from the scene. 
• Inline Image Sequences - Packages loaded image sequences within the .vpb file. If the 

.vpb is moved to another computer, the image sequence does not need to be moved 
separately. Inline Image Sequence is available for use with materials, lights, and 
environments. 

• Group selection - Creates a group node and adds all the selected lights in the Light tab 
within it. This is a fast way to create groups. 

Convert to (sub menu) 

Provides features to change the type of light. Another way to do this is through the Properties 
section of the Lights tab. 

Other light source context menu commands (besides sub menus) 

• Switch On / Switch Off / Toggle - Switches a light on or off. 
• Select Nodes - Selects the corresponding light within the Scene Graph. 
• Select All / Deselect All / Invert Selection - Selects everything, nothing, or inverts the 

selection. 
• Save Selected Lights / Load Lights - Enables the reuse of light setups from other scenes. 
• Validate - Validates all lights and updates all light within the Scene Graph. 

Icon Bar in the Lights tab 

Provides icons for often required commands. Find these directly below the tree of light. 

1 Create - Opens a sub menu for creating any 
light. 

2 Duplicate - Creates an independent copy of the 
selected light source. 

3 Delete - Removes the selected light source from 
the scene. 

4 Toggle - Switches the selected light source on or 
off. 



Properties 

All light properties are here. Detailed descriptions are available within the Create section above. 



Scene Module Settings Tab – Simple UI 
While in Simple UI mode, in the Quick Access Bar, click Scene, then click the Settings tab. Use 
this tab to set the resolution for rendering your project. 

• Resolution - Changes the resolution of the Render Window. If a preset, such as VGA, 
PAL, HD720, or HD1080, is selected from the drop-down menu to the right, the 
resolutions are automatically loaded. Use Custom Resolution for customized size 
requirements. If Dynamic Resolution is set, the final size is dependent on the window 
size in VRED, all docked modules, and their dimensions. 

 

• Antialiasing 

 

Antialiasing off (left) and Antialiasing on (right) 

Computer screens are made of small square pixels. This is why an illustration of round 
objects or curved surfaces appears faceted at its edges. Antialiasing makes the edges of 
rendered objects less pixelated. 



Use the check box to toggle antialiasing on or off, like the button in the Icon Bar. After 
its activation, the calculation starts once the camera position has not changed for more 
than a second. (This is the Preferences > Render Options > Render Window > Still Frame 
AA default setting.) The progress is shown in a clockwise growing circle around the 
mouse pointer. If the circle is complete and closed, the calculation is finished. 

• Raytracing 

 

Raytracing is a module that generates physically correct illustrations. This means that all 
light sources are sending rays to any point within its area of influence and the image 
generator considers reflections and refraction of every ray on its calculation. 

Use the check box to toggle raytracing on or off, like 
the button in the Icon Bar. Fewer rays are sent from 
the light sources on camera movement to enable 
smooth navigation within the Render Window. 
Enabling (Still Frame) Antialiasing affects not only the 
smoothing of the illustration's edges, it increases the 
number of rays and reflections considered during 
image calculation. The more allotted to time 
calculation, the less noise within the image. 

 

 

When Raytracing is selected, the following options appear: 

 

o Downscale - Reduces the preview quality on interactive work, enabling 
smoother navigation within complex scenes. Different level presets, Low, 
Medium, and High, help with feature usage. 

o Interactive Render Mode / Image Render Mode - Helps when working in a pre-
computed mode for fast interaction. You can switch to full global illumination on 
still frame rendering. There are different settings for interactive rendering and 
still frame. Select from these VRED illumination modes: 



 CPU Rasterization - Provides a raytracing mode generally comparable to 
the standard OpenGL rendering mode. This mode can be applied when an 
appropriate graphics card is not available. 

 Precomputed Illumination - Adds pre-calculated ambient occlusion 
shadows to the rendering, comparable to the standard OpenGL rendering 
mode. 

 Precomputed + Shadows - Uses image-based lighting and indirect 
illumination from pre-calculation and combines this with realtime 
shadows. 

 Precomputed + IBL - Uses pre-calculated indirect illumination, in 
combination with image-based lighting from the current environment 
and shadows calculated in real time. 

 Full Global Illumination - Provides image-based lighting, full indirect 
illumination, and shadows, with everything generated in real time. 
 

• Bounding Box - Displays an orange quadric wireframe object to frame a selection. Use 
the check box to toggle its visibility within the Render Window on or off, like the button 
in the Icon Bar. 

• Wireframe - Shows the polygonal mesh of the selected objects highlighted in orange 
color. The mesh is shown in addition to the shaded illustration. Other objects can hide it 
until Edit > Preferences > Selection > Wireframe > Always in Front is disabled. Use the 
check box to toggle its visibility within the Render Window on or off, like the button in 
the Icon Bar. 

• Grid / Ruler - Displays a grid /axis on the floor to help estimate distances. Use the check 
box to toggle its visibility within the Render Window on or off, like the button in the Icon 
Bar. 

Render mode 

VRED supports different render modes to help with scene setup and data preparation. 

• Realistic Rendering - Provides a colored and textured illustration within OpenGL or 
Raytracing. It enables everything required to generate photorealistic output. 

• Vertex/Face Normal Rendering - Provides visual feedback for the orientation of vertex 
and face normals, as well as the capability to easily align inconsistent normal 
orientations. 

Four colors are used to indicate different normal orientation: 

o Green - Face and vertex normals are consistent and point towards the camera. 
o Blue - Face and vertex normals are consistent and point away from the camera. 
o Gold - Face and vertex normals are inconsistent. Face normals point away from 

the camera; vertex normals point towards the camera. 



o Magenta - Face and vertex normals are inconsistent. Face normals point towards 
the camera; vertex normals point away from the camera. 

The best way to turn face or vertex normal orientation when the whole shape is 
affected is to use the Standard UI Geometry Editor (Scene > Geometry Editor). 

Inconsistent normals within one shape require pressing the Alt key in combination with 
the right-mouse button on the affected area. This aligns the orientation of face/vertex 
normals with the orientation of the faces and vertices around it. If all normals are 
consistent, upon operation, it enables you to turn them completely. 

• Ambient Occlusion Rendering - Creates a grayscale rendering, in which the pre-
calculated ambient occlusion data is shown exclusively. This is useful when evaluating 
precomputed shadows. 

• Surface Analysis Rendering - Helps when evaluating surfaces. You can examine the 
continuity of various types of virtual lines projected onto the object's surfaces. This 
makes it easy to detect discontinuities. This also supports polygonal, as well as NURBS 
data. 

The Surface Analysis window opens automatically when activated. 

For a detailed description of the Surface Analysis settings, see the Surface Analysis video 
tutorial. 

http://help-staging.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_VRED_Tutorials_Engineering_Surface_Analysis_html


Asset Manager Module - Simple UI 
When in Simple UI mode, the Asset Manager button can be found in the Quick Access Bar. 

NOTE You can also right-click on the Quick Access Bar to display a list and select the Asset 
Manager from it. 

The Asset Manager helps you manage items like scenes, environments, and materials beyond a 
single project. Several global assets stored anywhere on the network can be accessed, like from 
a local folder. It supports standardization throughout several projects or even across multiple 
departments within the company. 

On the other hand, you can have an individual asset locally stored, as well. When the module is 
activated the first time, a path to the user's local folder is already specified. As a result, you can 
start establishing a library immediately. 

Use the Asset Manager section in VRED's preferences dialog box to set up asset paths, either 
for complete assets or for scenes, materials, and environments, individually. 

All items within the Asset Manager module are externally-referenced files from preset libraries. 
These items are called assets. A geometry asset contains geometry; material and environment 
assets contain their type of content. After import from the Asset Manager, the geometry asset 
appears in the Scene Graph, as a node or a sub structure. When an object is referenced to the 
Asset Manager, its icon switches to an inverted green shape icon . The material and 
environment representation from referenced assets gets an additional green indication in the 
lower left corner . 

Preferences from such indicated assets are locked after creation. A Modify button located 
below the module's Icon Bar unlocks the asset and makes it editable. Click Save to apply the 
new settings to the references within the Asset Manager. 

A Material Asset saves the information of its applied environment. If this Material Asset is 
added to a scene and if the applied environment is available in the scene, the environment will 
be applied to this material. If not, the Default Environment Switch will be used, instead. This 
also works for old (prior 2015) assets because the information has always been saved, but not 
yet loaded. 

When a geometry asset is applied to the Scene Graph, the node and all its children are initially 
locked. The “Asset Root”, the node marked with the green icon, is editable after the geometry 
asset has been dragged into the scene (for example, renamable, transformable). This root node 
is a node that has a reference to the Asset Manager and draws its children from the Asset 
Manager. The asset root’s children are locked, and it is not possible to add, delete, or move 
them, as long as the asset is not unlocked for modifications (icon switches). If the user adds an 



old asset (prior 2015) to the scene, which consists only of a single leaf node, an appropriate 
root node will be added automatically above the loaded node. These “old” geometry asset 
nodes are marked as modified because versions prior to VRED 2016 did not have node locking 
in the Scene Graph. 

If one geometry asset is added multiple times, it will be treated as a clone. The child nodes of 
the asset root will be shared. The asset roots will be synchronized with each other. 
Nevertheless, it can be renamed or transformed individually. 

Any external change on a referenced asset will be adapted to the scene, after reloading the 
affected asset. The context menu within the Scene Graph provides features to reload such 
references. 

If one geometry asset is added multiple times and one is reloaded, only this one will be 
reloaded. The asset root node will not be changed. It will remain in position and name. Only its 
children will be updated/replaced by the ones loaded from the Asset Manager. 

Tabs 

At the top of the Asset Manager module window, there are three tabs. Switch easily between 
managing assets for scenes, materials, and environments. Every tab has the same structure -tab 
name, file search, library folder tree, list of components, and a zoom slider (except the scenes 
tab). 

Search field 

The live search considers the current tab. Once a folder is selected within the library folder tree, 
it is searched. An entered search string hides all assets that don't contain the string. 

Library directory tree 

All asset paths, as configured in the Preferences, appear here. Select a folder to either import or 
store an asset from there. 

Context menu from library directory tree 

Right-click the folder structure in the upper part of the module to open a context menu that is 
the same in every tab. 

• Create Folder - Adds a new folder or subfolder into the selected library. This is a tab-
specific functionality. The new folder is created automatically in the Materials, Scenes, 
or Environments subfolder of the selected library. If the subfolder does not exist, it is 
created. 



• Rename - Changes the name of the selected subfolder. 
• Delete - Removes the selected folder and all contained files. 
• Reload Directory - Reloads the content or structure of the selected subfolder. 
• Reload all directories - Reloads content from all Asset Manager paths. 
• Update Assets in Scene - Updates all assets (geometry, materials, and environments) 

contained within the scene. 
• Import - Imports external files into the selected folder. One of the shortcut icons at the 

bottom of the module makes the same feature quickly accessible. 
• Open in Explorer - Opens the selected folder within Windows Explorer. 
• Apply Material To Scene by Name (folder context menu) - Replaces materials in the 

scene with material assets of the same name from the selected folder in the Asset 
Manager. 

If there are no matching material names, nothing happens. 

For example, there is a material named Red Plastic in the scene, and a Red Plastic also 
inside the selected material assets folder. The material Red Plastic in the scene will be 
replaced by the Red Plastic material from the Asset Manager. 

List of components 

Contains thumbnails and detail information about the modify date, name, tags, and so on. 

Click to select an asset; right-click to open the context menu. Drag to get components from the 
Asset Manager to the related Simple UI module. 

Context menu from library directory tree for the tabs 

Right-clicking one of the listed items at the lower part of the Asset Manager module opens a 
context menu that is slightly different per tab. 

• Add to Scene - Adds the selected asset as a node, directly below the current scene root. 
Drag to add it to a custom location within the Scene Graph. 

• Rename - Enables you to change the name of a subfolder. 

Add to Scene and Rename can only be found in the context menu for Scenes or 
Environments. 

• Apply to Selected Node - Uses the selected material on the previously marked node in 
the Scene Graph. 

• Apply to Scene by Name (item context menu) - Replaces materials in the scene with the 
same name with the selected material assets. 



Only the materials tab provides the features Apply to Selected Node and Apply to Scene 
by Name. 

• Delete - Removes the selected item directly from library. 

NOTE Undo is not available for this action. 

• Select Directory - Selects the corresponding folder of the asset's location in the upper 
folder tree. 

• Open in Explorer - Opens the selected folder within Windows Explorer. 

Icon Bar from Asset module 

At the bottom of the module window are three buttons -Import, Reload, and Check for new 
versions. 

• Import - Opens the file browse dialog to import a new asset. 
• Reload Directory - Adapts any changes to the external asset library, once you have 

clicked. 

NOTE The following Python functions were added for Reload Directory in the Asset 
Manager: 

o reloadAllAssetDirectories() 
o reloadAssetDirectory(path) 

 
• Update Assets in Scene - Updates all assets contained within the scene. 
• Slider - Scales thumbnails. 



Animation Module - Simple UI 
Use the Animation module to help manage and create animation sequences within VRED. In the 
Quick Access Bar, click the Animation button opens the Animation module, which is the Clip 
Maker, consisting of two fundamental areas. The left side displays a list view of all scene 
contained clips; when a clip is selected from the list, the right updates, showing a block within 
the timeline. 

1 Wizard 

2 Animation 
Parameters 

3 List View 

4 Timeline View 

5 Icon Bar 

 
Use the animation wizard at the top left to help create object and material animations easily. 

Wizard 

The animation wizard provides help in three different modes. 

• Object 
• Material 
• Object and Material 

Before clicking Next, select the node that should be animated within the Scene Graph and/or 
Material Editor. If nothing is selected, a warning appears. 

Once the Animation Wizard window is open, click the name field to rename the animation. 
Below that, is the start time, duration, and interpolation mode for the current animation. 

• Start Time - Sets the moment the animation starts on replay within the Clip Maker. 
• Duration - Controls the total length of the animation. 
• Interpolation Mode - Determines velocity on animation playback. Linear results in a 

constant animation; Ease In/Ease Out/Ease In Ease Out reduces velocity on beginning 
or/and at the end of the animation. 



The initial state of the animation is captured, creating a thumbnail, when Capture Start is 
clicked. The generated thumbnails help to differentiate the different states, at a glance. After 
either moving the geometry or changing the material, click Capture End to store the final state 
of the animation. 

The Preview button enables replaying the animation within the Render Window. Reset Preview 
sets the animation to the initial state. 

Select Open Clip Manager When Finished to automatically open the Clip Maker on completion. 

Animation parameters 

Above the timeline are the following numeric input fields: 

• Start - Adjusts the animation start time. 
• Duration - Sets the length of the animation. 
• Cycles - Sets how often to repeat playing the animation. 

These settings are adopted on duplicated clips. 

List View 

The List View is on the left and lists all animation clips, including camera animations. 

• To activate/deactivate a clip, click the check box in front of the clip. 
• To select and show a clip within the timeline, click the clip in the list. 
• To rename a clip, double-click it. 
• To rearrange clips, drag then within the list. 
• To lock settings against any change, select the check box to the right of the clip name. 

Context menu (List View) 

This right-click context menu provides the following options: 

• Play - Plays the animation. 
• Reset - Sets animated objects to their initial state. 
• New Clip - Creates a sub clip below the selected existing clip. If no clip is selected, upon 

execution, the new clip appears at the top level. 
• Copy - Copies the selected clip to the clipboard. 
• Paste - Pastes copied clips into the desired location. 
• Duplicate - Creates an independent copy of the clip. 
• Duplicate Flipped - Creates an independent copy of the clip, but reverses the animation. 



• Delete - Removes the selected clip. 
• Rename - Enables the renaming of the clip. 
• Information - Provides further clip information. 

Timeline View 

Use the Timeline View to arrange clip, using its several tracks. Every block represents one 
animation sequence. In the timeline, drag them to rearranged them. Areas at the beginning and 
end of every block enable you to shift the related moment within the timeline. Use the mouse 
wheel to zoom in and out of the timeline. 

Context menu (Timeline View) 

This right-click context menu provides the following options: 

• Play - Plays the animation. 
• Reset - Sets animated objects to their initial state. 
• Active - Enables the playback of animation clips, when enabled. 
• Lock - Locks the animation's settings and that moment against any change, when 

enabled. 
• Flipped - Reverses the related clip during playback. 
• Motion Blur - Motion blurs or enables streaking of an object, due to rapid movement or 

prolonged exposure. This feature is enabled, by default. 
• Duplicate - Generates an independent copy of the selected clip. It pastes the new clip 

into the track located below the track containing the source clip. This populates the 
numerical input fields at the top, with the animation start and duration. 

• Duplicate Flipped - Generates an independent copy of the selected clip, but reverses 
the animation during playback. 

• Delete - Removes the related clip from the module. 
• Show Source - Shows associated animation curves in the Curve Editor. 
• Info - Provides further clip information. 

Icon Bar 

In the lower left corner are four buttons for quick access to the following: 

• Create - Opens a menu for creating a clip, animation, or variant. The creation and 
functionality of a variant is described here. The use of a variant inside the Clip Maker 
enables switch to another state of a variant in an appropriate moment within the 
timeline. Only pre-configured variants from the Variant Sets module are selectable on 
creation. 

http://help-staging.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Simple_UI_Variant_Sets_Module_Simple_UI_html


• Frame objects in view - Shows all animations for the selected clip within the Timeline 
View. 

• Delete - Removes the selected clip from the Clip Maker. 



Variant Sets Module - Simple UI 
This module makes different variants of such things as an object's material, its position and 
orientation, lights, environments, and viewpoint and makes them accessible with one click. 

In the Quick Access Bar, click Variants to open the Variant Sets module. Within the module, to 
create a variant, click Capture (4). This opens the Capture Variant Set dialog for selecting what 
will be stored inside the variant and creating a variant set. 

 

 

1 Variant Set Groups 

2 Delete 

3 Variant Thumbnail Icons 

4 Capture 

5 Format Resize 

 

 

 

Variant Set Groups - Variants can be grouped to organize things. Once a variant set is 
created, a group is added to the Variant Sets module. A thumbnail image appears to distinguish 
variants from one another at a glance. Use the slider (5) on the bottom to zoom in or out of the 
thumbnails. Click a group title to show or hide its content. Drag variants to rearrange them 
within a group. 

Delete - Removes the current variant group and the variants in it from the module. 

Variant Thumbnail Icons - These buttons are only visible at maximum zoom. 

• Delete - Removes the current variant from its related variant group. 



• Recapture and overwrite current set - Opens the Capture Variant Set dialog, updates 
variant-contained information with any changes, and may update the thumbnail. 

The Variant Thumbnail Context Menu 

The variant thumbnail context menu provides commands for working with variants. 

• Recapture - Opens the Capture Variant Set dialog, updates variant-contained 
information with any changes, and may update the thumbnail. 

• Delete - Removes the current variant from the group. 
• Update Preview - Updates the thumbnail image. 
• Select Nodes - Selects all geometrical nodes within the Scene Graph relating to the 

variant. 
• Variant Set Properties - Opens a sub menu that for assigning a hotkey to the related 

variant. 

After re-capturing a variant set, you must reset its hotkey. 



Render Image Module - Simple UI 
The Render Image module makes all usual setting to create images or movies available. It is 
accessible from the quick access bar. 

After its activation it comes up with the following window. 

Image Output 

• View - Establishes the view used for image calculation. All viewpoints, pre-defined 
camera track animations, or variants (if camera was active on its creation) can be 
selected from the drop-down menu. If a track is chosen, all contained viewpoints are 
rendered automatically. 

• Image Size Presets - The drop-down menu offers presets for industry standard 
resolutions, such as PAL, NTSC, HD 720, HD 1080, and 4K. for unique image sizes, used 
the Custom option and enter the size in Image Size. 

• Image Size - Automatically fills in the corresponding number of pixel for horizontal and 
vertical resolution, if a preset was set in Image Size Presets. If Custom was selected, use 
numerical input to set the image size. 

• Export Alpha Channel - Enables the export of additional information regarding 
transparent areas within the image for use in post-production processes. This requires 
the target file format to support alpha channels. 

• Render Animation - Makes animation-related settings accessible; it provides the 
possibility to render an animation clip or only part of it. 
 

o Animation Clip - Enables you to select a clip. This option is only accessible when 
something other than a camera track animation or variant is selected in the 
above View option. 

o Format- Selection - Generates the following: 
 Image generates a picture for every frame. 
 Movie provides the output within a single AVI movie file. Video file 

compression settings are available in a later step, after initializing the 
render process. 
 

o Use Clip Range - Enables the rendering of the whole clip, when checked. To 
render only a sequence on the selected clip, it must be deselected; in that case, 
the first and last image of the sequence must be defined (Start Frame/Stop 
Frame). Frame Step helps when not every frame of an animation sequence 
should be generated. For example, a Frame Step setting of 3 causes VRED to 
render every third image of the sequence. The default of 1 generates one image 
per frame. 

o Frames per Second - Sets the frame rate for the output movie. 



Image Render Quality 

In this section, the image quality is set using time or samples. 

• Time - Sets the maximum duration for creating a single image. 
• Samples - Sets the number of samples taken for the calculation of an image. Higher 

values produce a cleaner result, while lower values reduce the render time. 

Starting Image Calculation 

After configuration is done, the calculation could be either added to the render queue or 
started immediately by pressing the Render button. Each option opens the file browser to 
choose the destination folder and file format. 

Render Queue 

Every line within that queue represents a job that must be calculated. 

• State - Uses the check box to control job consideration on rendering. A preview image 
helps to identify the jobs within the queue. 

• Name - Shows the name chosen on file browse dialog box. 
• Animation - Indicates the type of job. Checkbox is selected on animations. 
• RT - Indicates the type of renderer. When enabled it uses Raytracing and Open GL when 

disabled. 
• Render Mode - Creates the output, based on the setting from the Scene module's 

Settings tab. It uses the selected image render mode that was configured there. 
• Render Quality/Image Size - Shows the settings set during job creation. 
• File Path - Shows image name and full path. 

Context menu 

Right-mouse click in the list to access this context menu. 

• Set - Sets the current camera (render view) to the job initial position. 
• Recapture - Captures the current camera view and overwrites settings from selected 

job. 
• Rename - Enables the renaming of the job name within the render queue. 
• Delete - Removes the selected render job. 
• Active - Controls job consideration on rendering, when enabled. 
• Move Up/Down - Rearranges jobs inside the queue. Calculation performs jobs from top 

to bottom. 
• Run - Starts rendering the selected job immediately. 
• Run All - Processes all jobs. Behave like the Render All button. 



Start image calculation 

• Add to Render Queue - Creates a job from current camera view and adopts the last 
settings from the Render Image module. 

• Render - Processes all jobs. 



Truelight Materials Reference 



General Truelight Material Settings 
Many Truelight materials used in VRED share properties. 

Incandescence 

The effect of the object itself giving off light. Incandescence is useful in various cases where an 
object needs to be lit without the use of a full light object in the scene. Settings are available for 
the object to affect the lighting of only itself or the surrounding scene. 

• Intensity - The strength of the effect (Range -0-1000). 
• Color - The color of the light rays. 
• Use Texture - Enables the use of a texture to control the intensity of the effect 

according to the texture values. 
• Link texture Settings - If this option is selected for multiple texture slots of a material, 

their texture mapping settings are linked together. When changing, for example, the 
Repeat UV of a linked texture, it is changed for all linked textures at once. When 
selecting this option for a texture while other textures of that material already have the 
link option selected, the texture settings are set to the settings of the already linked 
textures. 

Depending on the type of material, the setting options can vary. For common materials 
light Plastic and Phong, there are now three mapping types selectable for the using 
textures: 

• Mapping Type - Sets the mapping type of the texture. There are three modes which can 
be selected. 

• Repeat Mode UV - Sets the repeat mode of the texture. There are four modes: 
 

o Repeat - Repeats the texture in all directions. 
o Mirror - Repeats and mirrors the texture on the x- And y- Axis with every 

repetition. 
o Decal - The texture is not repeated. 
o Clamp - Repeats only the last pixel of the texture. 

For UV Mapping Type 

• Repeat UV - Sets the number of repetitions for the UVs. 
• Offset UV - Sets the offset for the UVs. 
• Rotate - Rotates the UVs. 



For Planar Mapping Type 

• Projection Center - Coordinates (x, y, z) of the projection center can be set here. 
• Projection Orientation - Offers the possibility to incline the projection plane. 
• Projection Size - Sets the size of the projection. Textures default to infinite projection 

depth and cover the entire object. You can restrict the texture to one side of the object 
by limiting the range of the projection. Changing the Z value of the projection size from 
zero (infinite) to another value achieves the restriction. 

• Keep Aspect Ratio - If selected, the size corresponding to the original aspect ratio of the 
texture is automatically adjusted. 

• Rotate - Sets the projection plane’s rotation on the X/Y/Z- Axis. 
• Manipulate - Adjusts the texture on the selected object. Hold the Shift key and drag on 

the manipulator to rotate, scale, or translate the texture. Dragging the blue scale control 
adjusts the depth limit of the texture. 

• Fit Size - Adjusts the size of the projection plane to the selected object. 
• Object Center - Adjusts the projection center to the center of the selected object. 

For Triplanar Mapping Type 

• Texture Size X, Y - Defines the textures size on the X-/Y- Axis. 
• X Repeat UV, Y/UV, Z/UV - Set the repetition value of the U and V- Axis for each 

projection direction. 
• X Offset UV, Y/UV, Z/UV - Set the offset value of the U and V- Axis for each projection 

direction. 
• X/Y/Z Rotate - Sets the projection orientation. 
• Manipulate - Applies the texture to the selected surface. 
• Anisotropy - Sets the texture filter quality for the image texture. Value 1 is lowest 

quality. Value 16 is highest quality. 
• Evaluate Ray Lights (Raytracing Only) - Enables evaluation of ray lights on the surface. 

This is used to be able to look into a ray file light and to make it visible in reflections and 
refractions. The origins of the rays should be on the surface to be evaluated. 

• Use as Light Source (Raytracing Only) - Uses the material as a light source for other 
materials in the scene while raytracing. 

• Illuminate Shadow Material - Allows the incandescence light shadow materials. Set the 
Reflection Mode of the shadow material to Diffuse, Glossy, or Diffuse + Glossy. 

• Cast Shadow on Shadow Material - Allows other objects to cast shadows on the shadow 
material due to the material's incandescence illumination. 

• Shadow Intensity - Sets the intensity of shadows cast by the geometry light. 
• Importance Multiplier - If Use As Light Source is selected, objects with this material 

function as geometric light sources. A value higher than one increases the probability 
that the light source emits photons at the photon mapping. This is useful for dark light 
sources in an interior if incident light comes from outside Environments. 



• Interactive/Still Frame Quality - Controls the illumination and sets the light sampling 
quality during interactive/still frame rendering. 

Transparency Settings 

Define the shader’s opacity. 

• See Through - Renders the shader transparent. 
• Invert Texture - Inverts the texture. 

The Texture, Repeat, Offset, Rotate, and Anisotropy settings are described in the General 
Truelight Material Settings - Incandescence section. 

Subsurface Scattering 

Translucency and subsurface scattering are two different methods for calculating light passing 
through the back of an object into the observer's eye. While translucency requires far less 
calculation power, subsurface scattering offers more possibilities and greater flexibility. 

• Scattering Mode Translucency - There are two modes when operating with 
translucency, depending on what objects to project: 
 

o Thin Walled Translucency - Suitable for one- Sided objects. It requires more 
calculation time than the solid translucency mode, but when in doubt, use this 
mode. 

o Solid Translucency - Used for solid objects only. Otherwise unpredictable 
problems can occur when this mode is used on one-sided objects. 
 

• Color - Determines the color of the scattering/translucent light. 
• Roughness - Defines the amount of diffusion that is applied to translucent light. 
• Scattering Mode Subsurface Scattering - Incoming light on the averted side of an object 

is refracted in all directions. With this mode, it is possible to simulate the behavior of 
wax or other translucent materials. There are two modes available: 
 

o Single Scattering - Allows light to bounce once inside a material before it is 
reflected to the outside. This mode is less accurate but requires less calculation 
time than multiple scattering. 

o Multiple Scattering - Allows light to bounce several times inside a material 
before it is reflected to the outside. This mode is more accurate but requires 
more calculation time than single scattering. 
 

• Attenuation - The distance that the light travels inside the medium is depending on the 
attenuation value. The higher the value, the more light is absorbed inside the medium. 



• Asymmetry - This value describes the directional characteristic of incoming light, and its 
weighted behavior. The value -1 defines that light is distributed to the averted side 
along the incoming light path. The value 1 defines that light is distributed along the 
incoming light path. The value 0 describes a homogeneous distribution of light inside 
the medium. 

• Select Medium - Offers a wide selection of refraction indices based on materials existing 
in reality. The selected medium affects the index of Refraction automatically. 

• Index of Refraction - The refraction index defines the optical density, and therefore the 
way light is refracted when passing differently dense materials. 

The Texture, Repeat, Offset, Rotate, and Anisotropy settings are described in the General 
Truelight Material Settings - Incandescence section. 

Displacement 

Displacement maps are detailed maps, which are interpreted as height information. Floating 
point displacement maps may encode displacements in both positive and negative directions 
using real world values. Using displacement maps you can create highly detailed structures 
from simple geometry by using a plain image. Each point on the geometry is displaced along the 
interpolated vertex normals using the height information of the map, resulting in a realistic 
silhouette, producing correct shadows, and reflections. Accuracy is limited by the resolution of 
the texture image and memory requirements are low. To avoid cracks in the displaced surfaces 
the vertex normals should be smooth and consistent. Using a higher tessellated base mesh can 
improve performance. 

• Displacement Height - Defines the scaling factor of values for the displacement. 
• Displacement Offset - Defines the offset of the displacement. Allows you to set the 

value of the zero plane in the texture. Values below the zero plane displace inside the 
geometry and values above the zero plane displace outside the geometry. 

• Use Accurate Silhouettes in OpenGL - This feature allows you to calculate the 
displacement in OpenGL like in raytracing mode. Selecting it may drastically reduce the 
performance. 

• Use Texture - Loads an image texture for the diffuse color channel. Uses the image as 
pattern on the surfaces. 

• Link texture Settings - If this option is selected for multiple texture slots of a material, 
their texture mapping settings are linked together. When changing, for example, the 
Repeat UV of the linked texture, it is changed for all linked textures at once. When 
selecting this option for a texture while other textures of that material already have the 
link option selected, the texture settings are set to the settings of the already linked 
textures. 

• Mapping Type - Select the type of mapping, either Planar, or UV. 
• Repeat Mode UV - Sets the repeat mode of the texture. There are four modes: 

 



o Repeat - Repeats the texture in all directions. 
o Mirror - Repeats and mirrors the texture on the x- and y-axis with every 

repetition. 
o Decal - The texture is not repeated. 
o Clamp - Repeats only the last pixel of the texture. 

 
• For Mapping Type UV - You can set the following parameters: 

 
o Repeat UV - Sets the number of repetitions for the UVs. 
o Offset UV - Sets the offset for the UVs. 
o Rotate - Rotates the UVs. 

 
• For Mapping Type Planar - You can set the following parameters: 

 
o Projection Center - Coordinates (x, y, z) of the projection plane’s center can be 

set here. 
o Projection Orientation - Offers the possibility to incline the projection plane. 
o Projection Size - Sets the size of the projection. 
o Keep Aspect Ratio (Checkbox) - If checked, the size corresponding to the original 

aspect ratio of the texture, is automatically adjusted. 
o Rotate - Sets the projection plane’s rotation on the X/Y/Z-axis. 
o Manipulate - Applies the texture to the selected surface. 
o Fit Size - Adjusts the size of the projection plane to the selected object. 
o Object Center - Adjusts the projection center to the center of the selected 

object. 

Raytracing 

These settings take effect in Raytracing rendering mode only. 

• Material ID - Sets the ID of the material in a range of [0, 31]. 
• Line Tube Radius - Defines the radius of the tube when the shader is applied to a line 

geometry. 
• Use Local Environment - If selected, diffuse and glossy reflections are calculated from 

the environment that is assigned to this material in all illumination modes. Specular 
reflections are determined by the environment that is present in the scene. 

• Ignore Photon Map - Selecting this option does not include the light values of a photon 
map when calculating the illumination of a pixel. 

• Override Illumination Mode - If selected, the setting overrides the global set 
illumination modes for interactive or still frame rendering. 
 

o Interactive/Still Frame - Sets the render quality mode and render quality level 
during Render View interaction/still frame rendering. 



 CPU Rasterization - This mode does not compute direct reflection, nor 
does it compute refraction or any other sophisticated visual effect. 

 Precomputed Illumination - This mode is comparable to VRED OpenGL 
rendering mode. It uses precomputed Ambient Occlusion and indirect 
illumination for rendering and calculates specular reflections, refractions, 
and correct shadows from light sources. 

 Precomputed + Shadows - This mode uses precomputed image-based 
lighting and indirect illumination but doesn’t use precomputed Ambient 
Occlusion values. Instead it calculates shadows based on the active 
environment. 

 Precomputed + IBL - This mode uses precomputed indirect illumination 
and samples the environment. 

 Full Global Illumination - The Full Global Illumination Mode doesn’t use 
any precomputed values but accurately samples everything in a physically 
based approach. Other features like Photon Mapping require the render 
mode to be set to Full Global Illumination. 
 

• Override IBL Sampling Quality - If selected, the setting overrides the global IBL Sampling 
quality for sampling the environment map. 
 

o Interactive/Still Frame - Sets the IBL sampling quality during interactive/still-
frame rendering. 
 

• Override Reflection/Refraction Sampling Quality - If enabled, the setting overrides the 
global sampling quality for reflections/refractions. 
 

o Interactive/Still Frame - Sets the reflection/refraction sampling quality during 
interactive/still-frame rendering. 
 

• Override Trace Depth - If selected, the setting overrides the global set illumination 
modes for interactive or still-frame rendering. 
 

o Interactive/Still Frame - Sets the Trace Depth during interactive/still frame 
rendering. 

Common 

The common settings define material settings that are present in all BRDF materials. 

• Occlusion Color - Sets the shader’s pre-calculated ambient occlusion color. 
• Occlusion Intensity - Sets the shader’s pre-calculated ambient occlusion intensity 
• Compress Textures (OpenGL) - Compresses all used textures to save disk space and 

helps to reduce memory requirements in large scenes. 



• Sort Key (OpenGL) - Enables materials to be sorted into groups based on the key that 
controls the order of the drawing transparent surfaces. 

• Environment - Right-click opens a context menu to select the HDR-Image to be used as 
light source. 

• Lighting Mode - Defines the light model to be used for the shader. There are five 
different lighting models. 
 

o IBL + Indirect + Direct Lights - The shader is affected by the HDR-Image, by the 
pre-calculated or interactive Global Illumination rendering and by the direct light 
sources placed in the scene. 

o IBL + Indirect - The shader is affected by the HDR-Image and by the pre-
calculated or interactive Global Illumination rendering. 

o IBL + Direct Lights - The shader is affected by the HDR-Image and the direct light 
sources placed in the scene. 

o IBL - Only the HDR-Image affects the shader. 
o Direct Lights - Only direct light sources placed in the scene affect the shader. 



Brushed Metal 

 

The brushed metal material type simulates any type of metal; it gives full control over the scale 
and orientation of the surface structure. Metal type presets are available within the properties 
dialog. 

For this material, there is no choice between UV and Planar Mapping. The texture mapping is as 
follows -For Diffuse, Glossy, Bump, and Roughness it depends on the brush mapping 
orientation. UV-mapping is used for radial and planar brush mapping, triplanar mapping is used 
for triplanar brush mapping orientation. UV-mapping is always used for Incandescence, 
Transparency, and Displacement textures. 

Brushed Metal Material 

• Diffuse Color - Sets the shader’s diffuse reflection color. This color is the color the 
shader adopts when the light reflection of the surface is spread in many directions. 

• Glossy Color - The higher the brightness the higher the reflection on the surface. Black 
means no reflection; white gives full reflection. Click the color field on the right to open 
the color chooser; when the glossy reflection is colored, reflected objects are also 
colored. 

• Roughness UV - The roughness parameter controls light reflection on top of the surface. 
The higher the value the rougher the microscopic structure on top of the surface and 
the more blurred are the reflections. Different values for horizontal and vertical 
roughness provide every type of refraction behavior that is commonly known from 
metallic surfaces. 

• Metal Type - Various metal types are available -Custom Reflectivity, Aluminum, 
Amorphous Carbon, Silver, Gold, Cobalt, Copper, Chromium, Lithium, Mercury, Nickel, 
Potassium, Platinum, Iridium, Silicon, Amorphous Silicon, Sodium, Rhodium, Tungsten, 
Vanadium, and Iron. 

• Reflectivity - Sets the Brushed Metal’s reflective intensity. 



Clearcoat 

Sets the clearcoat color. The clear coat is a transparent, reflective paint layer on the base metal 
layer. 

• Clearcoat Type - The Fresnel Term describes the intensity of a reflection based on the 
viewing angle. Its intensity at normal incidence is set by the material’s reflectivity. 
 

o Off - Turns off the clearcoat. 
o Fast - Uses a fast but less accurate approximation to the Fresnel Term. 
o Accurate - Uses a physically accurate evaluation of the Fresnel Term. 

 
• Clearcoat color - Sets the clearcoat color. 
• Reflectivity - Sets the clearcoat reflective intensity. 

Brush Orientation 

• Brush Mapping - Allows you to choose between a range of possible brush orientations, 
for example, metal brushed in one direction or metal with radial brushes. For example, 
Brush Mapping Radial XY simulates radial brushes within the xy-plane. The projection 
planes are defined relative to the object coordinate system of the object the material is 
assigned to. 

• Brush Mapping Planar - Contains the following options: 
 

o Brush Mappings - Planar XY, Planar XZ, Planar YZ. 
o Size U/V - Defines the brush’s size on the U/V-axis. 
o Orientation X/Y/Z - Sets the projection plane's orientation. 

 
• Brush Mapping Radial - Contains the following options: 

 
o Brush Mappings - Radial XY, Radial XZ, Radial YZ. 
o Size U/V - Defines the brush’s size on the U/V-axis. 

 
• Radial Mapping - Contains the following options: 

 
o Center X/Y/Z - Sets the projection plane’s center of the radial brushes. 
o Get Center - Returns the Center X, Y, and Z transformations to Zero. 
o Orientation X/Y/Z - Sets the projection plane's orientation. 

 
• Brush Mapping Triplanar - Contains the following options: 

o Size U/V - Defines the brush’s size on the U/V-axis. 
o Orientation X/Y/Z - Sets the projection plane's orientation. 
o Rotate X/Y/Z - Sets the projection plane’s rotation on the X/Y/Z-axis. 



Diffuse Texture 

For further information on the Texture settings, refer to the Phong reflection model - Diffuse 
Texture section. 

Glossy Texture 

For further information on the Texture settings, refer to the Phong reflection model - Glossy 
Texture section. 

Roughness Texture 

For Brushed Metal, red and green color channels are used for u and v roughness. For 
information on the other settings in Roughness Texture, refer to the Phong reflection model. 

• Minimum Roughness U - Sets the minimum roughness for U which is determined by the 
red color channel of the roughness texture. 

• Maximum Roughness U - Sets the maximum roughness for U which is determined by 
the red color channel of the roughness texture. 

• Minimum Roughness V - Sets the minimum roughness for V which is determined by the 
green color channel of the roughness texture. 

• Maximum Roughness V - Sets the maximum roughness for V which is determined by the 
green color channel of the roughness texture. 

Bump Texture 

For further information on the Texture settings, refer to the Phong reflection model - Bump 
Texture section. 

For further information on the Incandescence, Transparency, Subsurface Scattering, 
Displacement, and Raytracing settings, refer to the General Truelight Material Settings section. 



Carbon/Carbon 2D 

 

Carbon fiber, found in light weight sports vehicles, is a woven fiber-pattern material type with a 
clearcoat layer. Four preset pattern types are available and are customizable within the Carbon 
Pattern properties. 

Carbon is a triplanar shader; Carbon 2D uses the UV layout of an object. 

Triplanar Carbon Material/Carbon Material 

• Diffuse Color - Sets the shader’s diffuse reflection color. The shader adopts this color 
when the light reflection of the surface is spread in many directions. 

• Glossy Color - The higher the brightness the higher the reflection on the surface. Black 
means no reflection; white gives full reflection. Click the color field on the right to open 
the color chooser; when the glossy reflection is colored, reflected objects are also 
colored. 

• Roughness - The roughness parameter controls light reflections on top of the surface. 
The higher the value the rougher the microscopic structure on top of the surface and 
the more blurred are the reflections. 

Clearcoat Settings 

Sets the clearcoat color. The clearcoat is a transparent, highly reflective paint layer on the base 
metal layer. 

• Clearcoat Type - The Fresnel Term describes the intensity of a reflection based on the 
viewing angle. Its intensity at normal incidence is set by the material’s reflectivity. 
 

o Off - Turns off the clear coat. 
o Fast - Uses a fast but less accurate approximation to the Fresnel Term. 
o Accurate - Uses a physically accurate evaluation of the Fresnel Term. 



• Clearcoat Color - Sets the clearcoat color. 
• Reflectivity - Sets the clearcoat reflective intensity. 

Carbon Pattern 

• Pattern type - There are several different pattern types, according to the carbon 
structures typically sewn. 
 

o 2 X 2 
o 3 X 1 Staircase 
o 3 X 1 Interleave 
o 5 X 1 

 
• Pattern Size - Sets the carbon structure size. 
• Pattern Intensity - Sets the fissure depth intensity. 
• Rotate X,Y,Z - Sets the pattern direction on x, y, and z projection direction. Respectively, 

for Carbon 2D the slider Rotate adjusts the pattern's rotation value. 

Bump Texture 

• Use Structure - Activates a procedural bump structure. 
• Bump Intensity - Sets the bump intensity interpretation of the bump image texture. 
• Structure Size - Sets the structure size when the procedural bump structure is activated. 

For further information on the Incandescence, Transparency, Displacement, Raytracing, and 
Common settings, refer to the General Truelight Material Settings section. 



Chrome 

 

Use the Chrome material type for all kinds of chromic and metallic materials. When more 
control about scale and orientation of the surface structure is required, use brushed metal 
instead. Metal type presets are available within the properties dialog box. 

Chrome Material Settings 

• Reflection Color - Sets the chrome reflection color. When the chrome reflection is 
colored, reflected objects are also colored. 

• Smear - Sets the reflection’s blur amount. Only supported in OpenGL rendering mode. 
• Contrast - Sets the reflection’s contrast level. 
• Saturation - Sets the reflection’s saturation level. 
• Type - Various metal types are available. Highly Reflective, Aluminum, Amorphous 

Carbon, Silver, Gold, Cobalt, Copper, Chromium, Lithium, Mercury, Nickel, Potassium, 
Platinum, Iridium, Silicon, Amorphous Silicon, Sodium, Rhodium, Tungsten, Vanadium, 
and Iron. 

• Use Roughness - Activates roughness value. 
• Roughness - Sets the roughness of the material. The higher the roughness value, the 

blurrier the reflection is. 

Roughness Texture 

For further information on the Texture settings, refer to the Phong reflection model - 
Roughness Texture section. 



Bump Texture 

For further information on the Texture settings, refer to the Phong reflection model - Bump 
Texture section. 

For further information on the Incandescence, Transparency, Displacement, Raytracing, and 
Common settings, refer to the General Truelight Material Settings section. 



Custom 
To create a custom material, enter the class name of the desired material. Find the class name 
in the Node Editor. 



Flipflop 

 

Flipflop car paint material provides two layers of flakes on top of the base coat color. Its 
appearance depends heavily on the viewing angle between surface and observer. The effect is 
seen with paint on show and model cars. 

Flipflop Carpaint Material Settings 

• Base Color - This attribute defines the basic color, the main characteristic of the 
material. Use the slider to change the brightness. Click the color field on the right to 
open the color chooser. 

Flakes 

Describes the metallic flake’s behavior, which is embedded in metallic paints. They have a 
strong specular light reflection and are layered on top of the base shading color. 

• Flake Color 1 - Sets the metallic shiny flake’s first color. It gets stronger and more 
brilliant the further the normal orientation points away from the camera. 

• Flake Color 2 - Sets the metallic shiny flake’s second color. It gets stronger and more 
brilliant the further the normal orientation points towards the camera. 

• Blending - Defines the mixture ratio of two colors. Drag the slider to the left to increase 
the intensity of color one. Drag the slider to the right to increase the intensity of color 
two. 

• Roughness - Defines the amount of diffuse reflection and its complement specular 
reflection. The higher the roughness value, the more diffuse reflections are rendered. 

• Flake Size - Sets the flake’s size. 
• Flake Intensity - Sets the flakes contrast value of each flakes normal direction. 



Clearcoat 

The clearcoat is a transparent, reflective paint layer on the base paint layer. 

• Clearcoat Type - This type describes the intensity of a reflection based on the viewing 
angle. Its intensity at normal incidence is set by the material's reflectivity. 
 

o Off - Turns off the clearcoat. 
o Fast - Uses a fast but less accurate approximation to the Fresnel Term to create 

the clearcoat layer. 
o Accurate - Uses a physically accurate evaluation of the Fresnel Term to create 

the clearcoat layer. 
 

• Clearcoat color - Sets the pigment color in the layer. 
• Reflectivity - Sets the clearcoat reflective intensity. 
• Use Orange Peel - Applies a bump structure to the layer. 

 
o Orange Peel Frequency - Sets the bump structure’s noise frequency. 
o Orange Peel Intensity - Sets the bump structure’s intensity. 

For further information on the Incandescence, Transparency, Displacement, Raytracing, and 
Common settings, refer to the General Truelight Material Settings section. 



Glass 

 

Glass material can be used for all kinds of transparent materials like glass, acrylic, and diamond 
among others. It is also an ideal material for liquids such as water. Within the glass material 
properties, many indices of refraction presets are available for the accurate representation of 
these materials within the scene. 

Glass Material 

• Exterior Transparency - Sets the shader’s transparency color. The exterior transparency 
acts like a color filter for the light coming from behind the surface. A darker color blocks 
more light and makes the surface more opaque. In OpenGL mode, the exterior 
transparency sets the color of the glass when the surface normal is facing towards the 
viewer. Raytracing ignores this attribute. 

• Interior Transparency - Sets the shader’s transparency. The interior transparency acts 
the same as the exterior transparency. It filters the light coming from behind the 
surface. A darker color blocks more light making the surface more opaque. In OpenGL 
mode, the interior transparency sets the color of the glass. This happens when the 
surface normal is facing away from the viewer, the exterior transparency sets the color, 
and the normal is facing towards the viewer. Raytracing ignores this attribute. 

• Reflection Color - Sets the shader’s color for reflections. 
• Select Medium - Offers a wide selection of refraction indices based on materials existing 

in reality. The selected medium affects the Index of Refraction automatically. 
• Index of Refraction - Sets the material’s refraction index. Only supported in Raytracing 

rendering mode. 
• Simulated Thickness - Sets the materials simulated thickness. 
• Use Dispersion - Simulates how different wavelengths of light are refracted, resulting in 

dispersion effects. Use Dispersion only works with spectral raytracing. 
• Use Reflectivity - Controls the intensity of reflection on the surface. The higher the 

value the more the influence from environment and objects around. 



• Fresnel Term Quality - The Fresnel Term describes the intensity of a reflection based on 
the viewing angle. Its intensity at normal incidence sets the material’s reflectivity. 
 

o Fast - Uses a fast but less accurate approximation to the Fresnel Term. 
o Accurate - Uses a physically accurate evaluation of the Fresnel Term. 

 
• Solid Shadows (Cast Photon Caustics) - When selected, the Glass casts a solid (black) 

shadow (if a render mode is selected that can calculate caustic effects due to 
refractions). Otherwise the color of the shadow is calculated solely on the Glass’s color. 

• Use Roughness - If selected, the Glass is handled as frosted glass with glossy reflections 
and refractions. 

• Use Material Density - If selected, rays traveling through the glass gets attenuated 
based on the distance it travels inside the glass. 

Texture 

Texture settings define how a texture is placed on the surface and how the planar projection is 
blended at the edges. 

• Texture Mode - Defines how a texture is placed on the surface, whether it uses UV 
Coordinates or Triplanar projection. By using UV coordinates there are no other 
parameters to be set. Using the Triplanar Texture Mode, the following options are 
available: 

• Edge Blend - Sets the range for overlapping areas of the planar projection. 
• Texture Size X, Y - Defines the textures size on the X/Y-axis. 
• Uniform Repeat - Synchronizes the repetition value for all projection axes. 
• X Repeat UV, Y/UV, Z/UV - Set the repetition value of the U and V-axis for each 

projection direction. 
• X Offset UV, Y/UV, Z/UV - Set the offset value of the U and V-axis for each projection 

direction. 
• X,Y,Z Rotate - Sets the projection orientation. 

Exterior Transparency Texture 

Can be used to load a texture to the exterior surface. 

• Use Texture - Loads an image texture for the exterior transparency channel. Using a 
grayscale image is recommended, for color images the red channel is used. 

Further settings are identical with the Diffuse Texture settings and are described in the Phong 
reflection model - Diffuse Texture section. 



Roughness Texture 

For further information on the Texture settings, refer to the Phong reflection model - 
Roughness Texture section. 

Bump Texture 

For further information on the Texture settings, refer to the Phong reflection model - Bump 
Texture section. 

For further information on the Incandescence, Transparency, Displacement, Raytracing, and 
Common settings, refer to the General Truelight Material Settings section. 



Layered Material 

 

A layered material allows you to stack multiple materials on top of each other. Unlike the 
multipass material, the order of traversal is determined by the normal of the geometry. This 
allows it to use the layered material as a two-sided material. 

Additionally, glass materials are handled in a special way. If two glass materials are added to 
the layered material the index of refraction of these glass materials are adjusted in a way that 
allows to use them in glass-on-glass contact situations. If you add more than two glass 
materials, only the index of refraction of the first and last glass material is considered, all other 
glass materials get an Index of Refraction of 1.0 and act as a color filter if material density is 
turned off. 

Changing the drawing order of layers could be done within the material editor from standard 
UI. 

NOTE Layered materials do not support render passes. 



Light Portal 
A light portal is a guide for photons coming from the environment. The bounding box around all 
light portals in the scene is used as a target for photon emission from an environment, allowing 
you to limit the photons to certain areas of the scene instead of shooting many more photons. 

During still frame anti-aliasing all light portal materials are set to invisible in raytracing mode. In 
combination with Raytracing, this material only works in Full Global Illumination Mode. By 
default, objects with a portal Light Material do not affect the rendering in any other way. 

Visibility - Sets the opacity of the material. Usually a visibility of 0 is recommended. 



Line Chrome 

 

The Line Chrome Material is a special variant of the chrome materials for line geometries. This 
material does not work on triangle based or NURBS geometry. 

Line Chrome Material 

• Reflection Color - Sets the specular reflection color. 
• Use roughness - Makes the material glossy instead of specular. 
• Line Width - Sets the thickness of the lines drawn. 

For further information on the Transparency, Displacement, Raytracing, and Common settings, 
refer to the General Truelight Material Settings section. 



Metallic Carpaint 

 

A metallic car paint material has small particles made of metal, or flakes, on top of its lacquer 
layer. These particles increase the brightness within the angle of incidence, causing a light 
textured look. The color and size of the flakes is customizable. 

The basic structure of this kind of paint consists of a mix of three or four different layers. 

The base layer is a solid diffuse colored layer at the bottom to give a constant colored basis, 
independent from the actual material it is applied to. Usually, grey is used for this layer. 

The second layer is the Primary Flake Layer. It contains both colored diffuse pigment particles 
that give the basic color impression and randomly distributed flakes. 

The third layer is the Secondary Flake Layer. Its attributes are identical to the attributes of the 
Primary Flake Layer. 

The last layer is the Clearcoat Layer, which is a specular layer. It can also have colored pigments 
in it. 

Metallic Carpaint Material 

• Paint Types - This attribute sets the type of carpaint to simulate. It can be chosen 
between three types: 
 

o Artistic - A simplified approach will be used on modelling carpaint. This paint 
material will consist of three layers (Base, Primary Flake and Clearcoat Layer) 

o 2-Coat - A more realistic approach will be used on modelling carpaint. This paint 
material will consist of three layers (Base, Primary Flake and Clearcoat Layer). 



o 3-Coat - A more realistic approach will be used on modelling carpaint. This paint 
material will consist of four layers including two flake layers on top of each other 
(Base, Primary Flake, Secondary Flake and Clearcoat Layer). 
 

• Base Color - This attribute defines the basic color, the main characteristic of the 
material. Use the slider to change the brightness. Click the color field on the right to 
open the color chooser. 

Primary Flake Layer 

Set the behavior of the pigment particles and flakes. 

• Pigment Color - Sets the pigment’s color. That gives the basic color impression of this 
layer. 

• Pigment Concentration - The density of pigments can be set here. This controls, how 
many particles are present in the layer. 

• Flake Color - Defines the color of the metallic particles on top of the lacquer layer. It 
gets stronger and more brilliant the further the normal orientation points away from the 
camera. 

• Use Flip Flop - Select to use flakes with a Flip Flop behavior. If this box is selected, two 
more attributes become available: 
 

o Flip Flop Flake Color - Sets the metallic shiny flake’s second color. It gets 
stronger and more brilliant the further the normal orientation points towards 
the camera. 

o Flip Flop Blend - Defines the mixture ratio of the two flake colors. If the slider is 
dragged to the right, the intensity of the basic Flake color will be increased. If the 
slider is dragged to the left, the intensity of the Flip Flop Flake Color will be 
increased. 
 

• Flake Roughness - Defines the amount of diffuse reflection and its complement specular 
reflection. The higher the roughness value, the more diffuse reflections are rendered. 

• Flake Reflectivity - Sets the flake’s reflective intensity. 
• Flake Size - Sets the flake’s size. 
• Flake Perturbation - The randomness of the flake’s orientation. 
• Flake Density - The concentration of the flakes can be set here. This controls, how many 

flakes are present in the layer. If the density is set to 0, no flakes are present, and the 
paint represents a unicolor paint. 

Secondary Flake Layer 

When the paint type is set to 3-Coat, the attribute panel for the Secondary Flake Layer appears. 



The pigment color influences the colors of the layer beneath because it is applied on top of the 
Primary Flake Layer. 

The attributes are identical to the attributes of the Primary Flake Layer. 

Clearcoat 

The clearcoat is a transparent, reflective paint layer on the base paint layer. 

• Clearcoat Type - This type describes the intensity of a reflection based on the viewing 
angle. Its intensity at normal incidence is set by the material's reflectivity. 
 

o Off - Turns off the clearcoat. 
o Fast - Uses a fast but less accurate approximation to the Fresnel Term to create 

the clearcoat layer. 
o Accurate - Uses a physically accurate evaluation of the Fresnel Term to create 

the clearcoat layer. 
 

• Clearcoat color - Sets the pigment color in the layer. 
• Refraction Index - Sets the material's refraction index. 
• Thickness - Sets the thickness of the clearcoat layer. 
• Density - The concentration of the layer’s particles. 
• Use Orange Peel - Applies a bump structure to the layer. 

 
o Orange Peel Frequency - Sets the bump structure’s noise frequency. 
o Orange Peel Intensity - Sets the bump structure’s intensity. 

For further information on the Incandescence, Transparency, Displacement, Raytracing, and 
Common settings, refer to the General Truelight Material Settings section. 



Multi Pass 

 

Multi Pass materials display multiple materials in different layers on top of each other. Use 
them to set up dirt, promotion labels, and other types of complex materials. 

A bin shader is created, which can layer TrueLight materials. The first material in the list is the 
first rendered. The following shaders are rendered according to their position in the list from 
top to bottom. 

Create Multi Pass material layers in two ways: 

• Drag with the right mouse button to assign within the render view, then right-click and 
select Add as Multi Pass. Both materials, before assigned and the dragged one, are 
present within the created Multi Pass material as different layers. 

• Use the Multi Pass create context menu entry. Assign materials that should be present 
within the layers by dragging within the Multi Pass material attribute window. 

To change the drawing order of layers, drag them. Alternatively, use the Move Up and Move 
Down commands on the Multi Pass material attribute window context menu. 



Office Color Science (OCS) Material 

 

The Office Color Science (OCS) Material loads BRDF files exported from CI-Navigator. The CI-
Navigator is a software system by Office Color Science Co., Ltd. that calculates metallic and 
pearlescent paint formulations from measurements of given target paint samples. CI-Navigator 
exports the BRDFs of those measurements and simulations in a VRED compatible BRDF file 
format (*.pbrdf). 

Office Color Science Material Settings 

• OCS BRDF - Loads a BRDF file. 
• Automatic Reload - Checks whether CI-Navigator has updated the BRDF file. This is the 

case when the BRDF export from CI-Navigator overwrites the file. VRED detects this 
modification and reloads the file automatically. Only one OCS Material can be 
monitored at the same time. 

• Exposure - Controls the representation intensity of the measured material. A threshold 
about 1.0 gives the optimal result. 

Clearcoat 

• Clearcoat color - Sets the clearcoat color. 
• Fresnel Term Quality - The Fresnel Term describes the intensity of a reflection based on 

the viewing angle. The clearcoat reflectivity or fresnel IOR parameter controls its 
intensity at normal incidence, depending on the chosen Fresnel Term Quality mode. 
 

o Off - Turns off the clear coat. 
o Fast - Uses a fast but less accurate approximation to the Fresnel Term. 
o Accurate - Uses a physically accurate evaluation of the Fresnel Term that is 

controlled by setting the reflectivity parameter. 
o Reflectivity - Controls the intensity of reflection. 



o Use Fresnel IOR - Uses a physically accurate evaluation of the Fresnel Term that 
is controlled by setting the refraction index of the clearcoat layer. 

For further information on the Incandescence, Transparency, Raytracing, and Common settings, 
refer to the General Truelight Material Settings section. 



Phong 

 

Phong reflection model is an historical technique that describes the way a surface reflects light. 
It generates diffuse reflections from rough surfaces and glossy reflections from shiny surfaces - 
based on the fact that shiny surfaces have small intense glossy highlights, while dull surfaces 
have large highlights that fall off more gradually. 

Phong Material 

• Diffuse Color - This attribute defines the base color and the main characteristic of the 
material. Use the slider to change the brightness. Click the color field on the right to 
open the color chooser. Assigning a texture to the diffuse color projects it onto the 
surface. The appearance is a combination of the defined color and the assigned texture. 

• Glossy Color - Sets the material’s color for surfaces glossy reflections. Use the slider to 
change the brightness. Click the color field on the right to open the color chooser. 
Assigning a texture to the glossy channel defines areas in which different gloss 
intensities appear with the help of a texture. The glossy color depends finally on both - 
the defined color and the possibly assigned texture file. 

• Roughness - The roughness parameter controls light reflections on top of the surface. 
The higher the value the rougher the microscopic structure on top of the surface and 
the more diffuse are the reflections. 

• Diffuse Backscattering - Defines the roughness of the material’s diffuse component. A 
value of 0.0 means smooth (Lambertian surface), a value of 1.0 means rough (for 
example, concrete). 

Diffuse Texture 

When the use of a previously saved texture is checked, the following parameters can be 
configured: 



• Use Texture - Loads an image texture for the diffuse color channel. Uses the image as 
pattern on the surfaces. 

• Use Image Sequence - Select when an image sequence is loaded in the Use Texture box. 
An animation for the sequence is created in the Curve Editor. Go to Animation > 
Timeline. Click play to view the animated image sequence on the material. 

NOTE For a group of images to be considered an image sequence, there must be at least 
two images with the same name with an increasing numeric value. The required naming 
format is name, number, and extension. For example, image000.png image001.png. 

• Frame Offset - Sets an offset to the image number when an image sequence is loaded in 
the Use Texture box and when Use Image Sequence is selected. 

• Inline Image Sequence - When selected, loaded image sequences are packaged within 
the .vpb file. If the .vpb is moved to another computer, the image sequence does not 
need to be moved separately. 

• Use Alpha - If the image texture has an alpha channel embedded, it is used. 
• Link texture Settings - If this option is selected for multiple texture slots of a material, 

their texture mapping settings are linked together. When changing, for example, the 
Repeat UV of a linked texture, it is changed for all linked textures at once. When 
selecting this option for a texture while other textures of that material already have the 
link option selected, the texture settings are set to the settings of the already linked 
textures. 

• Mapping Type - Type of mapping can be selected. It can either be Planar, UV, or 
Triplanar. 

• Use Texture Size - Select to defined texture size in millimeters instead of repeat values 
for texture mapping. Only available when Mapping Type is set to UV. Use Texture Size 
only works on objects with UVs set to real world scale. If the UVs have not been scaled, 
go to the UV Editor and use Apply World Scale. 

• Texture Size - Enter the width and height of the texture in millimeters. Only available 
with mapping type UV and Use Texture Size selected or with mapping type triplanar. 

• Repeat Mode UV - Sets the repeat mode of the texture. There are four modes, which 
can be set: 
 

o Repeat - Repeats the texture in all directions. 
o Mirror - Repeats and mirrors the texture on the x-and y-axis with every 

repetition. 
o Decal - The texture is not repeated. 
o Clamp - Repeats only the last pixel of the texture is repeated. 

For Mapping Type UV you can set the following parameters: 

o Repeat UV - Sets the number of repetitions for the UVs. 
o Offset UV - Sets the offset for the UVs. 
o Rotate - Rotates the UVs. 



For Mapping Type Planar you can set the following parameters: 

o Projection Center - Coordinates (x, y, z) of the projection center can be set here. 
o Projection Orientation - Offers the possibility to incline the projection plane. 
o Projection Size - Sets the size of the projection. 
o Keep Aspect Ratio (Checkbox) - If selected, the size, corresponding to the 

original aspect ratio of the texture, is automatically adjusted. 
o Rotate - Sets the projection plane’s rotation on the X/Y/Z-axis. 
o Manipulate - Applies the texture to the selected surface. 
o Fit Size - Adjusts the size of the projection plane to the selected object. 
o Object Center - Adjusts the projection center to the center of the selected 

object. 

For Mapping Type Triplanar you can set the following parameters: 

o Edge Blend - Sets the range for overlapping areas of the planar projection. 
o X Repeat UV, Y/UV, Z/UV - Set the repetition value of the U and V-axis for each 

projection direction. 
o X Offset UV, Y/UV, Z/UV - Set the offset value of the U and V-axis for each 

projection direction. 
o X/Y/Z Rotate - Sets the projection orientation. 

 
• Anisotropy - Sets the texture filter quality for the image texture. One is lowest quality, 

16 is highest quality. 
• Input Gamma - Sets the texture image gamma correction. 
• Use ICC Profile - If selected, the texture’s colors are interpreted based on an embedded 

color profile if present. If a color profile is missing, it is assumed that the colors are 
stored in sRGB. 

Glossy Texture 

When the use of a previously saved texture is checked, the following parameters can be 
configured: 

• Use Texture - Loads an image texture for the glossy color channel. Uses the image as a 
pattern on the surfaces. 

For further information on the common settings, refer to the Phong Diffuse Texture section. 

Roughness Texture 

Use a roughness texture for varying roughness values on the surfaces. If a previously saved 
roughness texture is selected, the simple roughness slider loses its function. Instead, you can 



define how the texture values are mapped to roughness values using a minimum and a 
maximum roughness value. The following parameters can be configured: 

• Use Texture - Load an image texture for the roughness channel. Using a grayscale image 
is recommended, for color images the red channel is used. 

• Minimum Roughness - Defines the roughness value to which a texture value of 0 is 
mapped. 

• Maximum Roughness - Defines the roughness value to which a texture value of one is 
mapped. 

For further information on the common settings, refer to the Phong Diffuse Texture section. 

Bump Texture 

Bump mapping enables the creation of structure to the materials surface. 

• Use Structure - Uses a default noise map. 
• Use Texture - Loads an image texture for the bump channel. Uses the loaded image as a 

pattern on the surfaces. 
• Parallax Intensity - Sets the parallax shift interpretation of the bump image texture. 
• Bump Intensity - Sets the bump intensity interpretation of the bump image texture. 
• Structure Size - Sets the structure size when the procedural bump structure is activated. 
• Bump Type - Sets the bump type. The bump mapping can be drawn as bump map or as 

pixel displacement map without self-shadowing. 

For further information on the common settings, refer to the Phong Diffuse Texture section. 

For further information on the Incandescence, Transparency, Subsurface Scattering, 
Displacement, Raytracing, and Common settings, refer to the General Truelight Material 
Settings section. 



Plastic 

 

Plastic is suitable for simulating shiny or glossy surfaces from objects that are made of synthetic 
materials. 

Plastic Material 

• Diffuse Color - Defines the base color, the main characteristic of the material. Use the 
slider to change the brightness. Click the color field on the right to open the color 
chooser. Assigning a texture to the diffuse color projects it onto the surface. The 
appearance is a combination of the defined color and the assigned texture. 

• Glossy Color - Sets the material’s color for surfaces glossy reflections. Use the slider to 
change the brightness. Click the color field on the right to open the color chooser. 
Assigning a texture to the glossy channel defines areas in which different gloss 
intensities appear with the help of a texture. The glossy color depends on both the 
defined color and the assigned texture file. 

• Roughness - The roughness parameter controls light reflections on top of the surface. 
The higher the value the rougher the microscopic structure on top of the surface and 
the more diffuse are the reflections. 

• Reflectivity - Controls the intensity of reflection on the surface. The higher the value the 
more the influence from environment and objects around. 

Diffuse Texture 

For further information on the Texture settings, refer to the Phong material Diffuse Texture 
section. 



Glossy Texture 

For further information on the Texture settings, refer to the Phong material Glossy Texture 
section. 

Roughness Texture 

For further information on the Texture settings, refer to the Phong material Roughness Texture 
section. 

Bump Texture 

For further information on the Texture settings, refer to the Phong material Bump Texture 
section. 

For further information on the Incandescence, Transparency, Subsurface Scattering, 
Displacement, and Raytracing settings, refer to the General Truelight Material Settings section. 



Reflective Plastic 

 

Reflective Plastic is suitable to simulate shiny or glossy surfaces from objects that are made of 
synthetic materials. It adds the ability to have a mirror image reflection of everything around on 
its surface. 

Reflective Plastic Material 

• Diffuse Color - This attribute defines the base color, the main characteristic of the 
material. Use the slider to change the brightness. Click the color field on the right to 
open the color chooser. Assigning a texture to the diffuse color projects it onto the 
surface. The appearance is a combination of the defined color and the assigned texture. 

• Specular Color - Sets the material’s color for surfaces specular reflections. Use the slider 
to change the brightness. Click the color field on the right to open the color chooser. 
Assigning a texture to the specular channel defines areas in which different specular 
intensities appear with the help of a texture. The specular color depends finally on both 
the defined color and the assigned texture file. 

• Reflectivity - Sets the specular reflection intensity when the surface normal is directly 
facing the viewer. The intensity of the reflection increases based on the Fresnel term 
when the angle between the viewer and the surface normal increases. 

• Fresnel Term Quality - The Fresnel Term describes the intensity of a reflection based on 
the viewing angle. The material reflectivity sets its intensity at normal incidence. 
 

o Fast - Uses a fast but less accurate approximation to the Fresnel Term. 
o Accurate - Uses a physically accurate evaluation of the Fresnel Term. 



Diffuse Texture 

For further information on the Texture settings, refer to the Phong material Diffuse Texture 
section. 

Specular Texture 

The specular texture settings are identical to the settings for the diffuse texture. The only 
difference is that the texture is loaded into the specular channel. For further information on the 
Texture settings, refer to the Phong material Diffuse Texture section. 

Bump Texture 

For further information on the Texture settings, refer to the Phong material Bump Texture 
section. 

For further information on the Incandescence, Transparency, Subsurface Scattering, 
Displacement, Raytracing, and Common settings, refer to the General Truelight Material 
Settings section. 



Shadow 

 

The Shadow material is a transparent material by default. It is shaded only in areas of pre-
calculated ambient occlusion shadows, shadows calculated by linear lights sources, or global 
illumination light sources. It is also capable of receiving diffuse and glossy reflections to 
simulate wet or mirroring surfaces. 

Shadow Material Settings 

• Occlusion Color - Sets the color of the pre-calculated ambient occlusion or environment 
shadows. 

• Occlusion Intensity - Controls the intensity of shadowed areas. 
• Shadow Color - Sets the color for shadows from light sources (like point lights). 
• Opacity Mode Settings - Contains the following options: 

 
o Transparent - Renders the Shadow transparent by default. 
o Solid - Renders the Shadow white by default. 

 
• Sort Key - Sets the render priority of the Shadow. Only supported in OpenGL mode. 

Reflection 

• Reflection Mode - Offers three different reflection modes: 
 

o Diffuse only - Shows only the diffuse reflections. 
o Glossy only - Shows only the glossy reflections. 
o Diffuse + Glossy - Shows the diffuse and glossy reflections. 

 
• Diffuse Color - Sets the shader diffuse reflection color, the color the shader takes on 

when the light reflection of the surface is spread in many directions. 
• Glossy Color - Sets the shader’s color for glossy reflections. 
• Reflectivity - Sets the material reflectivity intensity. 



• Roughness - The roughness parameter defines the amount of diffuse reflection and its 
complement specular reflection. The higher the roughness value, the more diffuse 
reflections are rendered 

For further information on Raytracing settings, refer to the General Truelight Material Settings 
section. 



Switch 
A switch material can contain several materials but only one of them is visible at the same time. 
Create switch materials the same way you create MultiPass or layered materials -either drag 
within the render view with select Create Switch Material selected or drag within the material 
preview list. To assign several material variants on creation, select them and then select Create 
Switch from Selection from the context menu. 

If a switch material is selected, all the material variants are present within the Switch Choice 
section below the material preview list. Click a child material to open its properties. Double-
click a child material to activate it. 



Tire 

 

Tire material supports several surfaces and structures for rim and profile within a single texture. 
The tire material texture settings allow the accurate placement and wrapping of textures to fit a 
tire shaped object. 

Tire Material 

• Diffuse Color - This attribute defines the base color, the main characteristic of the 
material. Use the slider to change the brightness. Click the color field on the right to 
open the color chooser. Assigning a texture to the diffuse color projects it onto the 
surface. The appearance is a combination of the defined color and the assigned texture. 

• Glossy Color - Sets the material’s color for surfaces glossy reflections. Use the slider to 
change the brightness. Click the color field on the right to open the color chooser. 
Assigning a texture to the glossy channel defines areas in which different gloss 
intensities appear with help of a texture. The glossy color depends finally on both the 
defined color and the assigned texture file. 

• Roughness - The roughness parameter controls light reflections on top of the surface. 
The higher the value the rougher the microscopic structure on top of the surface and 
the more diffuse are the reflections. 

• Reflectivity - Controls the intensity of reflection on the surface. The higher the value the 
more the influence from environment and objects around. 

Texture Settings 

• Get Values from Object - Attempts to guess the correct Rotation Axis, Center, Markings 
Scale, and Profile Repeat V from the object's boundings. 

• Rotation Axis - Select the rotation axis. 



• Center X/Y/Z - Sets the brush projection center. To center the projection pivot 
automatically, select an object and click Get Values From Object. The selected object 
center is used as projection pivot. 

• Repeat Profile U/V - Sets the U and V repetition of the profile texture. 
• Scale Markings - Sets the texture scale value for the marking texture. 
• Blend Position - Sets the marking and profile texture blend position. 
• Anisotropy - Sets the texture filter quality for the image texture. Value 1 is lowest 

quality. Value 16 is highest quality. 

Diffuse Texture 

• Use Marking - Loads an image texture to be applied to the tire sides for the diffuse color 
channel. The image is used as a pattern on the surface sides. 

• Use Profile - Loads an image texture to be applied as the tire profile for the diffuse color 
channel. The image is used as a pattern on the surface middle. 

• Input Gamma - Sets the texture image gamma correction. 
• Use ICC Profile - If selected, the texture colors are interpreted based on an embedded 

color profile if present. If a color profile is missing, it is assumed that the colors are 
stored in sRGB. 

Glossy Texture 

• Use Marking - Loads an image texture to be applied to the tire sides for the glossy 
channel. The image is used as a glossy pattern on the surface sides. 

• Use Profile - Loads an image texture which is applied as the tire profile for the glossy 
channel. The image is used as a pattern on the surface middle. 

• Input Gamma - Sets the texture image gamma correction. 
• Use ICC Profile - If selected, the texture colors are interpreted based on an embedded 

color profile if present. If a color profile is missing, it is assumed that the colors are 
stored in sRGB. 

Bump Texture 

• Use Marking - Loads an image texture to be applied to the tire sides for the bump 
structure. The image is used as a bump pattern on the surface sides. 

• Use Profile - Loads an image texture which is applied as the tire profile for the bump 
structure. The image is used as a pattern on the surface´s middle. 

• Bump Intensity - Sets the bump intensity interpretation of the bump image texture. 
• Parallax Intensity - Sets the parallax shift interpretation of the bump image texture. 

For further information on the Incandescence, Transparency, Displacement, Raytracing, and 
Common settings, refer to the General Truelight Material Settings section. 



Unicolor Paint 

 

This material generates a single-colored car lacquer material with customizable coating effect 
on the top of the surface. 

Unicolor Carpaint Material 

• Base Color - This attribute defines the basic color, the main characteristic of the 
material. Use the slider to change the brightness. Click the color field on the right to 
open the color chooser. 

Clearcoat 

The clearcoat is a transparent, reflective paint layer on the base paint layer. 

• Clearcoat color - Sets the clearcoat color. 
• Reflectivity - Sets the clearcoat reflective intensity. 
• Fresnel Term Quality - The Fresnel Term describes the intensity of a reflection based on 

the viewing angle. The material's reflectivity sets its intensity at normal incidence. 
 

o Fast - Uses a fast, but less accurate approximation to the Fresnel Term. 
o Accurate - Uses a physically accurate evaluation of the Fresnel Term. 

 
• Use Orange Peel - Activates a noisy bump structure in the shader. 

 
o Orange Peel Frequency - Sets the bump structure’s noise frequency. 
o Orange Peel Intensity - Sets the bump structure’s intensity. 



For further information on the Incandescence, Transparency, Subsurface Scattering, 
Displacement, Raytracing, and Common settings, refer to the General Truelight Material 
Settings section. 



Velvet 

 

The Velvet material imitates the behavior of a velvet or satin-like material by darkening the 
regions of an object where the surface points almost directly to the viewer and brightening at 
its edges. 

Velvet Material 

• Diffuse Color - This attribute defines the base color, the main characteristic of the 
material. Use the slider to change the brightness. Click the color field on the right to 
open the color chooser. Assigning a texture to the diffuse color projects it onto the 
surface. The appearance is a combination of the defined color and the assigned texture. 

• Glossy Color - Sets the material’s color for surfaces glossy reflections. Use the slider to 
change the brightness. Click the color field on the right to open the color chooser. 
Assigning a texture to the glossy channel defines areas in which different gloss 
intensities appear with the help of a texture. The glossy color depends finally on both 
the defined color and the assigned texture file. 

• Darkening - Controls the appearance of the diffuse component. The default darkening 
value of 1.0 corresponds to a perfectly diffuse surface. Higher values than 1.0 darken 
the material, lower values brighten it up. 

• Falloff - Controls the glossy component, which is depending on the viewing angle and 
affecting the edges of the objects. 

Texture 

• Texture Mode - Defines how a texture is placed on the surface, whether it uses UV 
Coordinates or Triplanar projection. By using UV coordinates, there are no other 
parameters to be set. Using the Triplanar Texture Mode, the following options are 
available: 
 



o Edge blend - Sets the range for overlapping areas of the planar projection. 
o Texture Size X, Y - Defines the textures size on the X-/Y-axis. 
o Synchronizes the repetition value for all projection axes. 
o X Repeat UV, Y/UV, Z/UV - Set the repetition value of the U and V-axis for each 

projection direction. 
o X Offset UV, Y/UV, Z/UV - Set the offset value of the U and V-axis for each 

projection direction. 
o X/Y/Z Rotate - Sets the projection orientation. 

Diffuse Texture 

For further information on the Texture settings, refer to the Phong material Diffuse Texture 
section. 

Glossy Texture 

For further information on the Texture settings, refer to the Phong material Glossy Texture 
section. 

Bump Texture 

For further information on the Texture settings, refer to the Phong material Bump Texture 
section. 

For further information on the Incandescence, Transparency, Subsurface Scattering, 
Displacement, Raytracing, and Common settings refer to the General Truelight Material 
Settings section. 



Woven Cloth 

 

The Woven cloth material contains presets for many common types of fabrics and allows the 
creation of a customized cloth material without using an external texture. Customized cloth 
patterns can also be used by importing a texture. 

Woven Cloth Material 

• Diffuse Color - Sets the shader’s diffuse reflection color. The shader adopts this color 
when the light reflection of the surface is spread in many directions. 

• Darkening - Controls the appearance of the diffuse component. The default darkening 
value of 1.0 corresponds with a perfectly diffuse surface. Higher values than 1.0 darken 
the material, lower values brighten it up. 

• Warp/Weft Yarn Color - Sets the color of the vertical (warp) and horizontal (weft) yarn. 
Use the sliders to change the brightness. Click the color field on the right to open the 
related color chooser. It is best practice to use similar colors for warp and weft yarn. 

• Cloth Presets - Choose from various handpicked material presets. These presets are also 
available in the VRED Example Assets in the Asset Manager. The parameters change 
automatically when a cloth preset is selected. 

• Weaving Pattern - The weaving pattern defines how the yarn is woven to cloth. 
• Yarn Type - Defines the glossiness of the yarn. 

 
o Staple Yarn - Simulates yarn that is made up of many tiny threads. Use this type 

for rough types of clothes such as denim. 
o Filament Yarn - Simulates yarn that is made up of one single untwisted, virtual 

yarn. Use this type for shiny types of clothes such as silk. 
 

• Yarn Twist Angle - The yarn twist angle determines the glossiness of the yarn and 
depends on the choice made in the yarn type. 



• Highlight Width - Defines the width of the glossy highlight on the yarn segments. 
• Exposure - Defines the brightness of the glossy component. 
• Noise Intensity - Sets a natural noise effect for matt surfaces (staple yarn is 

recommended). 
• Moiré Removal - The higher the value, the more effective the moiré pattern is being 

softened. If too high, any structure is softened, and surface information might get lost. 
• Advanced Yarn Settings - Allows you to define the curvature for weft and warp yarn. 

Procedural Weaving Texture 

The procedural BTF is highly dependent on how the weaving pattern is mapped onto the 
object’s surface. The texture mapping controls size and direction of the yarn and therefore its 
reflection behavior. 

• Texture Mode - Sets the texture projection mode, either UV Coordinates or the 
Triplanar Mode. 

When the Texture Mode is set to UV Coordinates, UV information for the texture 
projection is used. You can set the following parameters: 

o Pattern Repeat - When the texture mode is set to UV Coordinates, Pattern 
Repeat defines the number of repetitions of the texture along the UVs. 

o Pattern Rotate - When the texture mode is set to UV Coordinates, Pattern 
Rotate defines rotation angle of the texture along the UVs. 

When the Texture Mode is set to Triplanar, the triplanar projection mode is activated, 
regardless of any UV information. You can set the following parameters: 

o Texture Size X/Y - When set to triplanar projection mode, this value allows you 
to scale the weaving pattern in mm. 

o Uniform Repeat - Fills the same value into all X/Y/Z Repeat fields. 
o X/Y/Z Repeat UV - Allows you to change the repetition rate for all projection 

axes. 
o X/Y/Z Rotate - Allows you to change the rotation angle for all projection axes. 

Diffuse Texture 

For further information on the Texture settings, refer to the Phong material Diffuse Texture 
section. 



Yarn Texture 

• Use Texture - Loads an image texture for the yarn. The image is used as a pattern on the 
surfaces. 

The yarn textures settings are identical with the settings for the diffuse texture. For 
further information on the Texture settings, refer to the Phong material Diffuse Texture 
section. 

Bump Texture 

For further information on the Texture settings, refer to the Phong material Bump Texture 
section. 

For further information on the Incandescence, Transparency, Subsurface Scattering, 
Displacement, Raytracing, and Common settings, refer to the General Truelight Material 
Settings section. 



X-Ray 
The X-Ray material was created as a material for hands in a VR environment, in particular, for 
Oculus users. However, use it whenever you want to assign a transparent or semi-transparent 
material to an object, like for a technical illustration. 

IMPORTANT  If an X-Ray material is in a layered material, the effect is not visible in OpenGL 
mode. It is visible, however, in Raytracing mode. In the images below, the first is an example in 
OpenGL mode. The second is in Raytracing mode.  

 

In the Menu Bar, select Scene > Material Editor, then in the editor, select Create/Convert > 
Create Material > X-Ray. 

X-Ray Material 

Base Color 

Defines the base color of the material. Click the color field on the right to access Choose a Color 
dialog and select a color. 

Single-sided 

Toggles the visibility of backfaces. By default, this attribute is enabled, so only one side of the 
object is rendered. When enabled, it is important for normals to be correctly oriented. Single-
sided can also be switched off in the Material options. 



Cast Shadows 

Casts a shadow, when enabled. In OpenGL, the shadow is based on non-transparent object 
forms. In Raytracing, transparency is considered. 

Fresnel Transparency 

The three Fresnel Transparency attributes help define the transparency of the object. When 
Bias is increased, the surface of your object becomes opaquer. When Scale is increased, the 
edges of your object become opaquer, as it takes into account the normal falloff. When Power 
is increased, it defines the intensity of the outline created with Scale. 

Fresnel Color 

The Color attribute defines the color of opaque surfaces and outlines. It is added on top of any 
base color that was set separately. Use it to change the color or brighten the outline. The other 
Fresnel Color attributes are the same as the Fresnel Transparency attributes, since they 
customize the falloff based on surface normals and the viewing direction. They will influence 
the strength of the hue, applying more or less color to opaque surfaces and outlines. 

Transparency 

This is based on the viewing angle. The surface is rendered ore opaquely when viewed from a 
gazing view. The surface is rendered more transparent, when it is facing the view. 

See Through 

Set how easily you can see through the texture. 

Use Texture 

Click the box after the title to enable Use Texture and expose options for modifying the texture. 
Set how the texture will be mapped and the type of mapping it will use, whether to use the 
original texture size or not, how often the texture repeats and/or if it offset, whether it's 
rotated, and is there any anisotropy. 

• Click the folder icon and select the texture you want; if at any point the texture is 
updated, click  Restore to load the latest version. 

• Click  to save the texture to a different location. 

• Click  to delete the texture. 



Raytracing 

Set the Material ID and Line Tube Radius when raytracing the texture. 

Common 

Set occlusion color and intensity, sort key, and environment. 



X-Rite Measured 
VRED supports the use of measured materials. Measured materials contain internal surface 
reflection information that considers reflection behavior from different viewing angles ensuring 
a photo-realistic illustration within the render view. 

The X-Rite Measured is a wrapper material for several measured materials which are sorted by 
Id. 

A measurement file can be loaded from the file browser. VRED supports files in AXF, CPA, and 
BTF format. 

NOTE VRED X-Rite AxF materials include GGX BRDF model support. This provides the latest 
state-of-the-art micro-facet BRDF technology to accurately capture and reproduce surface 
reflection behavior. It also allows for high-fidelity simulation of material reflections at both 
peek and shallow viewing angles. 

To add a new material to the list, use copy and paste. Material specific attributes can be 
changed when the material is selected in the list. 



OpenGL Materials Reference 



About OpenGL Materials - Chunk Material 
Create/Convert > Create OpenGL Material > Chunk Material 

In the Material Editor, when Chunk Material is selected, it creates a chunk material 
node. The chunk material node is an empty material bin node, which can be 
customized by adding extra chunk attributes. 

How to Create OpenGL Materials 

Create a material that will work in OpenGL. 

1. In the Menu Bar, click Scene > Material Editor. 
2. Click Create/Convert > Create OpenGL Material. 
3. Select the type you want. This creates an OpenGL material. 

What is a GLSL Shader 

A GLSL Shader is a chunk used when programming your own material. To do this, use OpenGL 
Shading language or GLSL for short. When you create a GLSL shader chunk, it is created with an 
already functioning example, SHLChunk, which renders the complete object orange. 

 

• VP = Vertex Program 
• FP = Fragment Program 
• GP = Geometry Program 

How to Create a Chunk 

When you create a chunk OpenGL material, it is just an empty container for chunks. Use Create 
Chunk to fill it with a GLSL shader, texture, cube texture, blend, depth test, or polygon. 

1. In the Material Editor, select a ChunkMaterial and right-click. 



 

2. Select Create OpenGL Material > Create Chunk, then select either GLSL Shader, Texture, 
Cube Texture, Blend, Depth Test, or Polygon. 

3. In the List View, expand the ChunkMaterial node, then select a chunk to access its 
parameters for editing. 

 



Environments 



Skylight 

 

A skylight environment provides physical correct simulated lighting depending on world time 
and location. Skylights are procedurally generated Sphere Environment materials. 

Preview Image Skylight 

The Skylight provides an interactive preview image that allows you to quickly change the sun 
position. The yellow curve within the preview image depicts the sun path from sunrise to 
sunset at the currently set date and location. You can set the sun position represented by a 
circle by clicking the sun path. The preview image includes labels of the four cardinal directions 
(N = North, E = East, S = South, W = West). If the current location is on the northern 
hemisphere, South is the centered direction; for locations in the southern hemisphere, North is 
the centered direction. 

Skylight Material 

Resolution 

Sets the resolution of the procedural environment texture. A higher-quality yields higher 
generation time for the environment but might be necessary in precomputed illumination 
mode with animated sun: Interactive, Medium, High Quality. 

• Is Visible - Sets the light source to on by default. 
• Flip Inside Out - Flips the normals of the object this material is assigned to. 
• Show Compass - Displays a compass in the render window for the currently selected 

skylight material. The compass is positioned at the environment’s center and oriented 
according to the environment rotation (see Transformation). 

• Emit Caustics - Activates/deactivates Emit Caustics. Allows the HDR to emit caustics. 
Only supported in FullGI illumination mode with caustics. 

• Use as Lightsource - Uses the HDR as light source. Only supported in FullGI illumination 
mode. 



Shadows and Illumination 

• Shadow Lightsources - Sets the number of explicit light sources. There are 256 light 
sources available. 

• Use Lightsources Only - When selected, only the shadow lightsources used for the 
environment are used for illumination. At least one lightsource must be entered in the 
Shadow Lightsources option for results. In the Raytracing Settings tab, set Illumination 
to Full Sphere to get illumination from the floor. 

• Material Shadow Intensity - Sets the shadow intensity of the generated lightsources on 
brdf based materials. 

• Ground Shadow Intensity - Sets the shadow intensity of the generated lightsources on 
the shadow material. 

• Map Filter Radius - Sets the radius used for filtering the shadow map lookup in OpenGL. 
• Map Resolution - Sets the quality of OpenGL shadow maps. Higher values increase the 

quality. 

Sky and Sun 

• Sky Model - Choose between two different sky models: Realistic and Artistic. The artistic 
sky model produces more reddish and colorful skies, especially for sunrise/sunsets. 

• Exposure - Sets the HDR-Image’s exposure level. The higher the exposure level, the 
longer the series of shutter cycles, which are used to calculate the image’s light 
intensity. 

• Sky Turbidity - Controls the amount of haze in the atmosphere. Low values correspond 
to a clear sky. The default value of 3.0 is a clear sky in a temperate climate. The 
maximum value of 10.0 yields a hazy sky. 

• Sun Scale - Controls the size of the sun. The default value 1.0 corresponds to the actual 
size of the sun, seen from the earth. The sun is drawn as a filled circle within the sky 
environment. Increase the sun scale to get softer shadows with raytracing. 

• Sun Visible in Specular Reflections - Defines whether the sun of this skylight material is 
visible in all specular reflections in the scene, for example, on clear coat. 

• Use Mirrored Sky as Ground - The mirrored upper hemisphere (sky without sun) is used 
as lower hemisphere (ground). 

• Ground Color - Sets the color for the single-colored ground in the lower hemisphere if 
Use Mirrored Sky as Ground is not selected.  

NOTE When using the Realistic sky model, the ground color serves as a ground albedo 
which influences the tint of the sky. 



Date and Time 

• Date - The date determines the sun path. The sun position is computed from Local Time, 
Date, and Location. The Today button sets the date to the current operation system 
date. 

• Local Time - Controls the sun position at the current date. The sun position is computed 
from Local Time, Date, and Location. The Now button sets the date to the current 
operation system local time. 

Location 

• Longitude/Latitude - Sets the location to these geographic coordinates in decimal 
degrees. 

• Time Zone - The time zone is expressed as time difference to UTC (Coordinated 
Universal Time). It is automatically estimated from the given geographic coordinates. 

• DST - Enables/disables daylight saving time. Specify whether there is daylight saving 
time at the current location on the current date because this information is not 
retrieved automatically. 

• Closest City - The City (Country) information names the city that is closest to the given 
geographic coordinates. The current time zone is this city’s time zone. 

• Location Search - Retrieve longitude/latitude data from a database of over 22,000 cities. 
You may also enter a country name and choose a city from the popup list. 

Color Correction 

• Whitebalance - Sets the white balancing color temperature, where lower values create 
cooler (bluish) colors and higher values create warmer (yellowish) colors. 

• Hue-Shift - Shifts all colors in the HDR-Image uniformly through the hue color range. 
• Contrast - Separates the light and dark color values further from each other. 
• Brightness - Raises the color value of the whole HDR-Image. 
• Saturation - Sets the HDR-Image’s saturation. 
• Reflected Saturation - Sets the HDR-Image’s saturation for reflections of the HDR-Image 

in any surface. 

Transformation 

The source of spherical projection of the Skylight can be set using transformation parameters. 

• Environment Size - Sets the radius of the projection sphere. The projection sphere must 
enclose all objects using a material having this Skylight as environment shader assigned. 
All objects that are outside the projection sphere using a Truelight Material with this 
Skylight as input channel, are rendered properly. 



• Center - Defines the projection sphere’s center position. 
• Get from Object - Sets the projection sphere’s center. To center the projection pivot 

automatically, select an object and press Get Center. The selected objects center is used 
as projection spheres pivot. 

• Rotate X, Y, Z - Sets the Skylight orientation. 
• Scale X, Y, Z - Sets the Skylight’s size. With the scale value, the image projection can be 

stretched and squashed on any axis. 

Raytracing Settings 

These settings take effect in Raytracing Mode only. 

• Is Visible in Reflections - Sets the visibility. 
• Use as Lightsource - Uses the HDR as light source. Only supported in FullGI illumination 

mode. 
• Use Accurate Geometry - When selected, uses the accurate geometry. This option is 

unselected by default. If unselected, all diffuse and glossy reflection calculations are 
based on the virtual sphere of the environment. Selecting this option, the real 
environment geometry is used for more accurate diffuse and glossy illumination in 
Precomputed+IBL and Full Global Illumination Mode. (At the cost of a 20–25% 
performance hit compared to default finite sphere environment.) 

NOTE This option is only supported for diffuse and glossy environment reflections. 

• Emit Caustics - Activates / deactivates Emit Caustics. Allows the HDR to emit caustics. 
Only supported in FullGI illumination mode with caustics. 

• Material ID - Sets the id of the material. 
• Illumination - Offers the following options: 

 
o Upper Hemisphere - Emits light only from the top half of the sphere. 
o Full Sphere - Emits light from the whole sphere. 

 
• Override IBL Sampling Quality - If selected, the setting overrides the global IBL Sampling 

quality for sampling the environment map. 
 

o Interactive Quality - Sets the IBL sampling quality during interactive rendering. 
o Still Frame Quality - Sets the IBL sampling quality during Still Frame rendering. 



Sphere Environment 

 

Environments add realistic reflections and light sources to the scene. Use Sphere Environments 
in Truelight Material. They deliver precomputed Image-Based Lighting (IBL) for the Truelight 
Material they are assigned to. The lighting of a Truelight Material can be adjusted with the 
settings of the Sphere Environment. Each Sphere Environment can be assigned as an input node 
of each Truelight Material in the Material Editor (see General Truelight Material Settings » 
Common » Environment). The Sphere Environment is a single-sided shader in OpenGL 
rendering mode. 

The Sphere environment gets its representation and lighting behavior from a texture file. 

Environment Material 

• Environment - Loads the HDR image to be used as light source. The HDR image is used 
as an environment, which is reflected on reflective surfaces in OpenGL rendering. In 
raytraced rendering, the 3D space is reflected in the surfaces. LDR (.png and .jpg) can 
also be loaded. 

• Use Image Sequence - Select when an image sequence is loaded in the Use Texture box. 
An animation for the sequence is created in the Curve Editor. Go to Animation > 
Timeline. Click play to view the animated image sequence on the material. 

NOTE For definition of an image sequence, refer to the Phong material Diffuse Texture 
section. 

• Frame Offset - Sets an offset to the image number, when an image sequence is loaded 
in the Use Texture box and when Use Image Sequence is selected. 



• Inline Image Sequence - When selected, loaded image sequences are packaged within 
the .vpb file. If the .vpb is moved to another computer, the image sequence does not 
need to be moved separately. 

• Environment Geometry - Selects the geometrical form for the current environment. 
 

o Custom - Loads an external geometry file. 
o Dome 
o Sphere 
o Cube 

 
• Is Visible - Sets the light source to on by default. Controls the visibility of the 

environment within the render view. A hidden environment but activated environment 
furthermore influences all scene contained objects regarding its look and appearance. 

• Flip Inside Out - Flips the normals of the Environment Sphere. 
• Shadow Plane Visible - Enables or disables the shadow plane on the ground. 

Shadows and Illumination 

• Shadow Lightsources - Sets the number of explicit light sources. There are 256 light 
sources available. 

• Use Lightsources Only - When selected, only the shadow lightsources used for the 
environment are used for illumination. At least one lightsource must be entered in the 
Shadow Lightsources option for results. In the Raytracing Settings tab, set Illumination 
to Full Sphere to get illumination from the floor. 

• Material Shadow Intensity - Sets the shadow intensity of the generated lightsources on 
BRDF-based materials. 

• Ground Shadow Intensity - Sets the shadow intensity of the generated lightsources on 
the shadow material. 

• Map Filter Radius - Sets the radius used for filtering the shadow map lookup in OpenGL. 
• Map Resolution - Sets the quality of OpenGL shadow maps. Higher values increase the 

quality. 

HDR Light Studio 

The HDR image of a Sphere Environment can be interactively created using HDR Light Studio by 
Lightmap LTD. This part of the GUI is visible, if a demo or full version of HDR Light Studio 
detects VRED on startup. 

• Edit & Load Settings - Opens HDR Light Studio and tries to load a project saved for this 
material. If no project has been previously saved for this material, you start with a blank 
canvas. The current HDR image is replaced. All changes made on the HDR Light Studio 
canvas are immediately applied to the HDR image of the connected VRED Sphere 
Environment. 



• Save Settings - Internally saves the HDR Light Studio project for the Sphere Environment 
currently being edited. 

• LightPaint - This feature is available since HDR Light Studio version 4.0. Integration of 
LightPaint within VRED allows you to directly click the VRED render window to position 
your light sources in the HDR image. For example, the current light source reflects in 
that position. Refer to the HDR Light Studio manual for detailed information on the 
different painting modes. Choosing one of the three painting modes activates the Paint 
tool in the VRED render window. Hold SHIFT and click within the scene to place the 
selected light source in the HDR Light Studio canvas. Hold SHIFT and right-click within 
the scene to select a light source. The active painting mode is used to determine the 
light node in the HDR map. 

Color Correction 

• Exposure - Sets the HDR-Image’s exposure level. The higher the exposure level, the 
longer the series of shutter cycles which are used to calculate the image’s light intensity. 

• Whitebalance - Sets the camera's white balancing color temperature. Lower values 
balance the camera to a lower color temperature and therefore create cooler (bluish) 
colors. A higher value balances the camera to a higher color temperature and produces 
a warmer (yellowish) color. 

• Hue-Shift - Shifts all colors in the HDR-Image uniformly through the hue color range. 
• Contrast - Separates the light and dark color values further from each other. 
• Brightness - Raises the color value of the whole HDR-Image. 
• Saturation - Sets the HDR-Image’s saturation. 
• Reflected Saturation - Sets the HDR-Image’s saturation when the HDR-Image reflects in 

any surface. 

Transformation 

The source of spherical projection of the Sphere Environment Material can be set with 
transformation parameters. 

• Environment Size - Sets the radius of the Sphere Environment Material’s projection 
sphere. The projection sphere must enclose all objects using a material having this 
Sphere Environment Material as environment shader assigned. All objects that are 
outside the projection sphere using a Truelight Material with this Sphere Environment 
Material as input channel, are not rendered properly. 

• Center X, Y, Z - Defines the projection sphere’s center position. 
• Get from Object - Sets the projection sphere’s center. To center the projection pivot 

automatically, select an object and press Get Center. The selected object center is now 
used as projection spheres pivot. 
 
 



• Rotate X, Y, Z - Sets the Sphere Environment Material’s orientation. 
• Scale X, Y, Z - Sets the Sphere Environment Material’s size. With the scale value, the 

image projection can be stretched and squashed on any axis. 

Raytracing Settings 

These settings take effect in Raytracing Mode only. 

• Is Visible in Reflections - Sets the visibility. 
• Use as Lightsource - Uses the HDR ALS light source. Only supported in FullGI illumination 

mode. 
• Use Accurate Geometry - When selected, uses the accurate geometry. This option is 

unselected by default. If unselected, all diffuse and glossy reflection calculations are 
based on the virtual sphere of the environment. Selecting this option, the real 
environment geometry is used for more accurate diffuse and glossy illumination in 
Precomputed+IBL and Full Global Illumination Mode. (At the cost of a 20–25% 
performance hit compared to default finite sphere environment.) 

NOTE This option is only supported for diffuse and glossy environment reflections. 

• Emit Caustics - Activates/deactivates Emit Caustics. Allows the HDR to emit caustics. 
Only supported in FullGI illumination mode with caustics. 

• Material ID - Sets the id of the material. 
• Illumination - Offers the following options: 

 
o Upper Hemisphere - Emits light only from the top half of the sphere. 
o Full Sphere - Emits light from the whole sphere. 

 
• Override IBL Sampling Quality - If enabled, the setting overrides the global IBL Sampling 

quality for sampling the environment map. 
 

o Interactive Quality - Sets the IBL sampling quality during interactive rendering. 
o Still Frame Quality - Sets the IBL sampling quality during Still Frame rendering. 



Using the Environment Switch 
By default, VRED provides two environment switches. One is in the Material Editor and the 
other in the Scene Graph. Both have an icon with an orange star , which indicates a switch. 
These switches are connected and have the same number of children. 

What makes them different is: 

• The one in the Material Editor is a default environment switch material and uses a bin 
shader. It is set as the local environment for newly created TrueLight materials. Use it to 
manage and switch between environments in your scene. If you load the example file 
Automotive_Genesis (select File > Open Examples ... > Automotive_Genesis), you will 
see quite a few switches in the Material Editor's Materials Tree. 

• The one in the Scene Graph is a default environment switch node. It contains the 
geometry for displaying the environment and a shadow plane. Its children are 
environment nodes. Use it to add different shaped geometries to change the shape of 
the environment onto which a switch material is projected. If you load the example file 
Automotive_Genesis (select File > Open Examples ... > Automotive_Genesis), when you 
open the environments, you will see different geometry shapes. 

Use switches, whether they are environment or something else to change things quickly. Use an 
environment switch to instantly set your model in a new location or to see how it will look in 
different lighting conditions. One minute, it's a dark garage. The next, it's the seaside in the 
middle of the day or Times Square at dusk. If you have clients wondering what a car would look 
like painted some other color, switch to the metallic blue fire or OCS Red Candy. Different 
interior colors or fabrics? Switch them quickly and easily, on-the-fly. 

How to Activate an Environment 

Load the example file Automotive_Genesis (select File > Open Examples ... > 
Automotive_Genesis) and change the environment to activate another pre-loaded one. 

1. In the Scene Graph or Material Editor, expand the Environments switch. 
2. Place a check next to one of its child environments to activate it. 

How to Reorder Environments 

Environments can be reordered by dragging and dropping them in the Scene Graph or Material 
Editor. When changing the order of the children in one switch, the same is done automatically 
in the linked switch. 



How to Create an Environment 

Newly created environments are automatically added to the default environment switch. A 
dome geometry is used for a newly created environment. You can change this shape 
afterwards. 

An environment must first be created in VRED before a switch can be created. In the Material 
Editor, right-click an environment in the Materials List and select Create Environment > Sphere 
Environment or Skylight. 

How to Delete an Environment 

The default environment material and geometry switch cannot be deleted. However, their 
children can be. If a child is deleted, the child in both the default environment switch material 
and geometry switch are deleted. 

In either the Scene Graph or Material Editor, select the child to be deleted, then click from its 
Quick Access Bar to delete the child environment. 

How to Locate and Load an Environment Switch 

There are a couple ways to load an environment switch. The easiest is to drop an environment 
material onto the default switch in the Material Editor. When you do this, a corresponding 
environment geometry is created and added to the switch in the Scene Graph. To locate an 
environment switch, do the following: 

1. In the Menu Bar, click Scene > Material Editor to open the Material Editor dialog box. 
2. Select Environments in the Materials List. 

This is the Environment switch. 

3. Expand the Environment switch. 

By default, it contains a Studio environment. 

4. To load other environments into the switch, in the Menu Bar, select Scene > Asset 
Manager > Environments. 

5. Open one of the folders, select and drag one or more environment previews from the 
Asset Manager onto the Environments switch in the Material Editor's Materials Tree. 



How to Change the Environment 

Once you have located and loaded the Environment switch with an assortment of locations, it's 
change from the default environment to something else. 

1. In the Material Editor's Materials Tree, under the Environment switch, check the 
environment you want to use in the scene. 

Its name and properties are shown loaded into the right side of the Material Editor 
dialog box (Attributes Pane). 

2. If needed, adjust the properties of the environment. 
3. To add another environment to the switch, right-click in the Materials List, select Create 

Environment, the type of environment (Sphere Environment or Skylight), and an 
environment. 

The new environment is added to the Materials List and also automatically added to the 
Environment switch. 

NOTE For more complex scenes, you can add more environment switches; right-click in 
the Materials List and select Create Environment > Environment Switch. 



Autodesk VRED App 



Starting the VRED App 
With the Autodesk VRED App, a network-connected device can become a remote control. Use it 
to navigate your VRED scene and switch between variant sets. 

Autodesk VRED App interacts with any Autodesk VRED Pro instance, as long as the mobile 
device or machine is connected to the same network. If you are in the office and both the 
machine running VRED and your device are logged into the same network, things are good to 
go. However, if you are experiencing any issues, refer to Troubleshooting. 

Troubleshooting 

If you experience issues with connecting to VRED, double-check to ensure the preferences are 
set up correctly. Next, check for typos and ensure only one instance of VRED is running. If the 
issue persists, it could be your firewall. We recommend you contact your system administrator. 

How to Start the VRED App 

Your device or machine must be able to reach the PC VRED is running on. If using localhost, the 
browser must be running on the same machine as VRED. 

1. Open a VRED scene. 
2. Select Edit > Preferences > WebInterface and ensure Enable Web Server is activated. 

Note the port number. The default is 8888. 

3. Click OK. 
4. Open a web browser on your device. 
5. Enter YourIP:8888. 
6. Use the interface to navigate to VREDApp. 

NOTE Another way of doing this is to enter the following in the address bar: 
http://YourIP:8888/apps/VREDApp/index.html 

For example, http://10.123.123.123:8888/apps/VREDApp/index.html 

7. Click Start to start the VRED App. 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=About-the-Autodesk-VRED-App#add-new-connections


About the Autodesk VRED App 
To open the Autodesk VRED App, see Starting the VRED App. 

Use the Autodesk VRED App to interact with any Autodesk VRED Pro instance over the network, 
from any mobile device. Use it to navigate to your VRED scene and switch between variant sets 
with your device. 

About the VRED App 

The VRED App consists of a few 
things. Along the top to the right is 
Options. Along the bottom are two 
tabs, Navigation and Variants. The 
area in the center changes, 
depending on your selection. 

 

 

 

 

 

About Options 

Click Options, along the top of the 
VRED App, to access the VRED App 
Options page. It contains two 
sections, Options-Tools and 
Connections. Click back to return to 
the previous page. 

 

http://help-staging.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Autodesk_VRED_App_Starting_the_VRED_App_html


Toggle Full Screen Mode 

Displays the VRED scene either at full screen or browser window size on the computer running 
the scene. 

Variants Layout 

Controls the layout of the Variants page. Use it to switch from the list to block layout view. 

 

NOTE To return to the Navigation page, click the Navigation tab at the bottom. 



Variants Preview 

Enables or disables the preview images for the variants sets. 

 

 

 

 

 

 

Add New Connections 

Creates connections to VRED instances. These connections are added and listed below 
Connections. 

How to Add Connections 

Use the Connections section at the bottom of the page to create connections to VRED 
instances. 

1. On the Options page, click Add new connection and enter the IP address and port 
number of the computer on which the VRED scene is running. 

 

2. Click Set. If the IP or Port are incorrect, a message will appear to let you know. 

NOTE To edit and delete connections, use the Connection Editor. Another way to delete 
a connection is to click  next to a connection listed under Connections. 



How to Switch Between Connections 

If you have multiple connections, use the check boxes in front of them to switch between your 
connections. 

 

Navigation mode 

The Navigation page has two groups of buttons, one controlling display, the other navigation. 
Use the display controls to change how our model looks or to return to the original view. Use 
the navigation controls to manipulate your model. Click-drag within the Navigation page to 
rotate or zoom into the model in the desktop version. 

 



The button along the top left do the following: 

•  - Enables and disables antialiasing. 

•  - Switches between OpenGL and Raytracing Render mode. 

•  - Restores the initial view. 

The button along the top right set the navigation mode for the scene. Select one of the 
following, the left-click and drag. 

•  (Rotate) - (On by default) rotates the scene. 

•  (Zoom) - Moves closer to and further away from the object. 

•  (Pan) - Moves laterally in the scene. 

Variants mode 

The Variants page has a Load button along the top left, access to the Options and Navigation 
pages, and a Search bar for filtering variants. 

 

In this mode, all variant sets that have been created in the scene are available. 

How to Load Variants 

At the top left, click Load to load all existing variants in the scene. Once they are loaded, they 
are available from a drop-down list. 

• To change how they are displayed, see Variants Layout above. 
• To turn on or off the variant set previews, see Variants Preview above. 



   

From the menu bar at the bottom of your screen, you can switch between Navigation 
and VariantSets interaction mode. 

 

The default mode is Navigation. To navigate within your scene, drag with one finger in 
the navigation area. You can set options from the top menu bar. For more information, 
see About the VRED App. 

 

 

 

 

http://help.autodesk.com/view/VREDPRODUCTS/2019/ENU/?guid=VRED_Autodesk_VRED_App_About_the_Autodesk_VRED_App_html
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