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トランスレータ機能の基
礎知識

Maya トランスレータ
Maya にプラグインフォーマットで提供されているトランスレータ（IGES、FBX、
DXF、Alias wire、OpenFlight など）の他に、Maya は Autodesk DirectConnect
プラグインによって幅広いトランスレータフォーマットをサポートしています。

詳細については、Maya ヘルプ メニューにある Autodesk DirectConnect ヘルプ
オプションを参照してください。

特定の Maya トランスレータプラグインのアップデートが提供されることがあり
ます。詳細については、Autodesk の Maya サポートページを参照してください。

1

1



2



FBX ファイルトランス
レータ

FBX ファイルトランスレータ
Autodesk® FBX® トランスレータプラグインを使用すると、Autodesk® Maya®

で最新バージョンの FBX ファイルの読み込みと書き込みが可能になります。FBX
により、すべてのタイプのデータを、現在のほとんどの 3D オーサリングソフト
ウェアで使用可能な 1 つのファイルフォーマットにパッケージすることができま
す。FBX があれば、どのサポート対象アプリケーションでデータが作成されたか、
または変換方法などについて心配する必要がなくなります。FBX はソフトウェア
ベンダやコンピュータプラットフォームを問わず、ほとんどの 3D ソフトウェア
間の交換ハブの役割を果たします。

これにより、Maya、Autodesk® MotionBuilder®、Autodesk® 3ds Max®、
Autodesk® Mudbox® の間で、データ全体の動作を維持しつつ、複雑なデータの
交換が可能になるので、単一のパイプラインにこれらすべての製品を統合するこ
とがより容易になります。たとえば FBX を使って、Maya と MotionBuilder の間
でアニメーションデータやキャラクタリグの交換、または Maya と MotionBuilder
および 3ds Max の最新バージョンとの間でポイントデータの交換が行えます。

FBX プラグインは Maya とともに自動的にインストールされ、スタートアップ時
にデフォルトでロードされます。このプラグインをアンロードしている場合は、
次の手順によりロードできます。

1 ウィンドウ > 設定/プリファレンス > プラグインマネージャ（Window >
Settings/Preferences > Plug-in Manager）を選択します。

2 fbxmaya.mll のロード（Load）ボタンをチェックします。

2
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注:

すべての FBX 対応製品でシームレスに操作できるようにするために、FBX プラ
グインの開発が進行中です。Maya 機能のサポートがますます強化され、改善を
続けています。

このため、Autodesk のウェブサイト（www.autodesk.co.jp/fbx）から、またはイ
ンポート（Import）またはエクスポート（Export）ウィンドウの FBX オプショ
ンにあるWeb 更新（web update ）のチェックボタンをクリックして、FBX プ
ラグインの最新バージンをダウンロードしてください。無償でダウンロードで
きる Maya FBX プラグイン

FBX プラグインのマニュアル

Maya とインストールされている FBX のバージョンの詳細については、Maya
のメインメニューからヘルプ > Autodesk FBX ヘルプ（Help > Autodesk FBX
Help）を選択します。

Maya と FBX 間でのインポートまたはエクスポート

.fbxファイルのインポートまたはエクスポート方法の詳細については、Autodesk
FBX ヘルプの「Maya から FBX ファイルへのエクスポート」と「FBX ファイル
の Maya へのインポート」を参照してください。

FBX の制限事項

Maya との間でファイルをインポート、エクスポートする場合、以下のような制
限が考えられます。制限事項の最新情報については、Autodesk FBX ヘルプと、
最新バージョンでサポートされている全新機能のリストを参照してください。

FBX Mel スクリプトコマンド

FBX Mel コマンドのリストを以下に示します。これらのコマンドが実行する処
理の詳細については、Maya FBX プラグインドキュメントを参照してください。

FBXExport -f

FBXExportAnimationOnly -v

FBXExportApplyConstantKeyReducer -v

FBXExportAxisConversionMethod

Add FBX_Root node
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FBXExportBakeComplexAnimation -v

FBXExportBakeComplexEnd -v

FBXExportBakeComplexStart -v

FBXExportBakeComplexStep -v

FBXExportCacheFile –v

FBXExportCameras -v

FBXExportCharacter -v

FBXExportColladaFrameRate

FBXExportColladaSingleMatrix

FBXExportColladaTriangulate

FBXExportConstraints -v

FBXExportConvert2Tif –v

FBXExportDxfTriangulate

FBXExportDxfDeformation

FBXExportEdgeSmoothing –v

FBXExportEmbeddedTextures -v

FBXExportFileVersion

FBXExportHardEdges -v

FBXExportInAscii -v

FBXExportLights -v

FBXExportQuaternion -v

FBXExportQuickSelectSetAsCache –q

FBXExportQuickSelectSetAsCache –v

FBXExportScaleFactor

FBXExportShapes -v

FBXExportSkins -v

FBXExportUpAxis

FBXImport -f [filename] -t

FBXImportAxisConversionEnable –v
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FBXImportCacheFile –v

FBXImportCameras -v

FBXImportCharacter -v

FBXImportConstraints -v

FBXImportConvertDeformingNullsToJoint -v

FBXImportDxfWeldVertice

FBXImportDxfReferenceNode

FBXImportDxfObjectDerivation

FBXImportEdgeSmoothing –v

FBXImportFillTimeline

FBXImportHardEdges -v

FBXImportLights -v

FBXImportMergeBackNullPivots -v

FBXImportMergeAnimationLayers -v

FBXImportMode -v

FBXImportOverrideNormalsLock -v

FBXImportProtectDrivenKeys -v

FBXImportQuaternion -v

FBXImportResamplingRateSource -v

FBXImportScaleFactorEnable

FBXImportScaleFactor

FBXImportSetMayaFrameRate -v

FBXImportSetLockedAttribute -v

FBXImportShapes -v

FBXImportSkins -v

FBXImportUpAxis

FBXConvertUnitString

FBXGetTakeComment

FBXGetTakeCount
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FBXGetTakeIndex

FBXGetTakeLocalTimeSpan

FBXGetTakeName

FBXGetTakeReferenceTimeSpan

FBXLoadExportPresetFile -f

FBXLoadImportPresetFile -f

FBXRead -f

FBXResetImport

FBXResetExport

FBXResamplingRate -v
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IGES トランスレータプラ
グイン

IGES トランスレータプラグイン
IGES トランスレータプラグインの概要

IGES ファイルトランスレータプラグインは Maya の機能を拡張し、IGES フォー
マットのファイルに慣れているカスタマに必要な機能を提供します。このデータ
トランスレータを使用すると、既存の IGES ファイルを Maya に読み込むことも、
ファイルを Maya から IGES フォーマットにエクスポートすることもできます。

IGES トランスレータをインストールする

このトランスレータは Maya と同時にインストールされます。

IGES ファイルをインポート/エクスポートする

IGES ファイル トランスレータをロードするには

1 Maya を開いてウィンドウ > 設定/プリファレンス > プラグインマネージャ
（Window > Settings/Preferences > Plug-in Manager）を選択します。

2 IGES ファイルトランスレータのロード（loaded）ボタンをチェックします。

IGES ファイルをインポートするには

■ ファイル > インポート（File > Import）を選択して、ファイルブラウザの選
択肢から、開く IGES ファイルを選択します。

3
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IGES ファイルをエクスポートするには

■ ファイル > すべてエクスポート（File > Export All）（またはファイル > 選
択項目のエクスポート（File > Export Selection））を選択し、ファイル タ
イプ（File Type）のプルダウンリストから IGESExport を選択します。

IGES インポートオプション

以下のオプションにアクセスするには、IGES トランスレータプラグインをロー
ドし、ファイル タイプ（File Type）のプルダウンメニューを IGES に変更する
必要があります。

デフォルト トリム カーブ（Default Trim Curves） パラメータ空間（Parameter
Space）トリミング（サーフェスのパラメータ空間で定義されたカーブ）または
ワールド空間（World Space）トリミング（モデルのワールド空間で定義された
カーブ）を選択します。デフォルトでは、パラメータ空間トリミングを使用しま
す。

IGES トリム フラグ（IGES Trim Flag）: IGES では、トリムサーフェスはワール
ド空間またはパラメータ空間のいずれかを優先するトリミング方法として指定す
ることができます。このオプションを選択することにより、Maya はそのファイ
ルで優先される方法を使用します。

スケール係数（Scale Factor） インポートされたすべてのジオメトリを共通の係
数でスケールします。これによって、非常に大きなシーンの表示が簡単にできる
ようになります。

注: IGES ファイルには、しばしば非常に大きなジオメトリが含まれています。
このジオメトリを正しく表示するために、スケール係数を使用してスケールダ
ウンすることができます。または表示ウィンドウで、ビュー > すべてをフレー
ムに収める（View > Frame All）を選択して選択項目をフレーム内に収めるか、
また、ジオメトリが表示されない場合はカメラ後部のクリッピングプレーンに
収まっていません。ビュー > カメラ アトリビュート エディタ（View > Camera
Attribute Editor）を選択し、ジオメトリが可視となるように「ファークリップ
プレーン（Far Clip Plane）」を十分に大きな値に設定します。

レベル マッピング（Level Mapping） IGES ファイルからレイヤがインポートさ
れるかどうかを制御します。デフォルトでは、必ずレイヤをインポートします。
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IGES エクスポートオプション

以下のオプションにアクセスするには、IGES トランスレータプラグインをロー
ドし、ファイル タイプ（File Type）のプルダウンメニューを IGES に変更する
必要があります。

スケール係数（Scale Factor） IGES ファイルでジオメトリがエクスポートに合
わせてスケールされるように係数を指定します（デフォルト: 1.0000）。

既知の問題点
■ シーンに IGES で作成したジオメトリがある場合、プラグインをアンロード

することはできません。すべてのデータを削除してプラグインをアンロード
してください。

■ 500 Series（BREP）エンティティはサポートされていません。

IGES エンティティサポート
Maya でサポートされる IGES エンティティ

IGES エンティティ形式タイプ

circular arc（円弧）0100

composite curve（複合カー
ブ）

0102

conic arc（円錐弧）0-3104

copious data（大量のデー
タ）

1106

copious data（大量のデー
タ）

2106

copious data（大量のデー
タ）

11106

copious data（大量のデー
タ）

12106
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closed area（閉じた領域）63106

plane（プレーン）0*108*

plane（プレーン）1108

line（ライン）0110

parametric curve（パラメ
トリック カーブ）

0112

parametric surface（パラメ
トリック サーフェス）

0114

ruled surface（線織面）0-1118

surface of revolution（回転
面）

0120

tabulated cylinder（円筒）0122

TRANSFORMATION

MATRIX（変換行列）
0124

rational b-spline curve（有
理 B スプライン カーブ）

0-5126

rational b-spline surface

（有理 B スプライン サー
フェス）

0-9128

offset curve（オフセット
カーブ）

0130

offset surface（オフセット
サーフェス）

0140

boundary entity（境界エン
ティティ）

0141
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curve on surface（カーブ
オンサーフェス）

0142

bounded surface（境界サー
フェス）

0143

trimmed surface（トリム
サーフェス）

0144

subfigure definition（サブ
フィギュアの定義）

0308

associativity instance（結合
インスタンス）

7,9402

property - definition levels

（プロパティ: 定義レベ
ル）

1406

singular subfigure instance

（単一のサブフィギュアイ
ンスタンス）

0408

name（名前）15406
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StudioImport プラグイン
およびトランスレータ

StudioImport
StudioImport は Alias® Studio® Wire ファイル（以前の Alias Wire ファイル）用
のトランスレータです。

注: Alias® StudioTools® バージョン 10 以降（Autodesk AliasStudio）では、旧来
の Wire ファイルとは異なるファイルフォーマットを使用しています。このファ
イルフォーマットでは従来の Wire ファイルと同等のすべての機能が含まれてい
るため、このフォーマットによって、StudioTools での日常業務に変更が生じるこ
とはまずありません。また、このファイルフォーマットは、StudioTools バージョ
ン 10 以降のどのリリースとも互換性がありますので、将来のリリースでバージョ
ン 10 のファイルに変換する必要はありません。

StudioImport ファイル トランスレータをロードするには

1 Maya を起動してウィンドウ > 設定/プリファレンス > プラグインマネージャ
（Window > Settings/Preferences > Plug-in Manager）を選択します。

2 StudioImport プラグインのロード（loaded）チェックボックスをクリック
します。

Studio Wire ファイルを開くには

■ ファイル > シーンを開く（File > Open Scene）を選択して、ファイルブラウ
ザの選択肢から、開く Studio Wire ファイルを選択します。

4
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StudioImport の変換について

StudioImport の変換に関して、次の事項が確認されています。

■ Studio SID データは、StudioImport プラグインではサポートされていませ
ん。

■ ペイントデータは、Maya には一切トランスレートされません。SID のシェ
イプは Maya サーフェスとしてトランスレートされません。

■ ポリゴンセットのテクスチャ座標は、Maya へのトランスレート時に失われ
ます。

■ エリアライトとリニアライトは、正しく変換されません。

■ 自由度カメラ設定は、変換すると違う値に変更されます。

■ カラーテクスチャチャンネルのあるライトでライトフォグをレンダリング
（またはレイトレース）するときに、フォグはテクスチャを受け取ります
が、Studio では受け取りません。カラーテクスチャチャンネルのあるライ
トを含む Studio ファイルをインポートすると、デフォルトのサンプリング
レートが 1 のため、結果がかなり異なることがあります。20 から 30 のサン
プリングレートを使用してください。

■ Ortho カメラは StudioImport では完全にはサポートされていません。カメ
ラを含む（Include cameras）を false に変更してインポートするか、または
インポート後に Ortho カメラの変換を手動で調整します。

■ StudioImport からのインポート後、Maya のレンダリングに屈折ジッタは含
まれません。

■ 最も単純な環境フォグのみが正しく変換されます。

■ Studio のシェルを使うと、ライトのリンク機能とレンダリングで問題を引き
起こすことがあります。Maya に wire ファイルをインポートする前に、Studio
でステッチを解除してください。
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エクスポートプラグイン

MayaToAlias エクスポートプラグイン
MayaToAlias は Windows® 32 ビット用の Maya プラグインです。このプラグイ
ンは OpenMaya API を使用して Maya からシーン情報を取得し、OpenModel を
使い以下のいずれかのファイルにエクスポートします。このときのフォーマット
は、エクスポートファイルフォーマットで選択したものが適用されます。

■ Wire ファイル（バージョン 9.7.3）

■ IGES ファイル

MayaToAlias を使用して、Maya から Wire ファイルにエクスポートできるオブ
ジェクト

■ トランスフォームノード

■ 階層

■ インスタンスオブジェクト

■ NURBS カーブ

■ NURBS サーフェス

■ トリムサーフェス

■ メッシュ

■ カメラ

5
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MayaToAlias を使用して Maya から IGES フォーマットにエクスポートできる
オブジェクト

■ トランスフォームノード

■ インスタンスオブジェクト（IGES ではコピーされたオブジェクトになりま
す）

■ NURBS カーブ

■ NURBS サーフェス

■ トリムサーフェス

■ メッシュ

MayaToAlias プラグインをロードするには

1 Maya を開いてウィンドウ > 設定/プリファレンス > プラグインマネージャ
（Window > Settings/Preferences > Plug-in Manager）を選択します。

2 MayaToAlias プラグインのロード（loaded）チェックボックスをクリック
します。

これで、通常のエクスポートメカニズムで、Maya のコンテンツを Wire
または IGES のいずれかのフォーマットにエクスポートすることができま
す。

Maya ファイルを FBX、IGES にエクスポートするには

1 ファイル > すべてエクスポート（File > Export All）またはファイル > 選択
項目のエクスポート（File > Export Selection）を選択します。

2 ファイル名とファイルタイプを選択してすべてエクスポート（Export All）
または選択項目のエクスポート（Export Selection）をクリックします。

FBX と IGESexport は ファイル タイプ（File Type）プルダウンメニュー
のオプションです。

トラブルシューティング
■ この形式の MayatoAlias を使用しているときに、"Creating surface fails -

node [nodename]" というエラーメッセージが表示された場合、これは、
Studio Tools と Maya では有効な NURBS サーフェスに対する要件が異なる
ためです。Maya における有効な NURBS サーフェスが Studio Tools でも有
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効であるとは限りません。したがってサーフェスは作成されません。通常、
NURBS の編集 > サーフェスの開閉（Edit NURBS > Open/Close Surfaces）
を選択して U 方向または V 方向の周期的な開示を変更すると、この問題は
解決されます（オプションボックスを開いて、サーフェス（Surface）の方
向が正しく設定されていることを確認してください）。

■ Maya メッシュを wire ファイルにエクスポートするときに、そのメッシュに
穴のあるフェースが含まれている場合は、最初にそのフェースを三角化する
必要があります。

Wavefront（OBJ）エクスポートプラグイン
objExport プラグインを使用すると、Maya のポリゴンデータを Wavefront の
OBJ ASCII ファイルフォーマットにエクスポートすることができます。objExport
では次のような変換がサポートされています。

■ Maya テクスチャ座標と頂点法線の情報

■ Maya のレンダリング可能なセット情報をマテリアル名に

■ Maya のコンポーネントセット情報をグループに

OBJ フォーマットへのエクスポートの詳細については、『基本ツール』を参照し
てください。

注: objExportでは、OBJ フォーマットのカーブ、サーフェス、スムージンググ
ループ、ポイントグループマテリアルはエクスポートされません。また、NURBS
もサポートしません。NURBS サーフェスを含むシーンについては、MayaToAlias
プラグインを使用してください。

注: Autodesk は objExport プラグインのソースコードを、Maya Developer's
Toolkit の一部として提供しています。Maya Developer's Toolkit が正しくイン
ストールされていれば、.../files/devkit/plug-ins/objExport.cpp にソースコー
ドがあります。

objExport プラグインをロードするには

1 Maya を開いてウィンドウ > 設定/プリファレンス > プラグインマネージャ
（Window > Settings/Preferences > Plug-in Manager）を選択します。
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2 objExport プラグインのロード（loaded）チェックボックスをクリックし
ます。

ファイルを OBJ フォーマットでエクスポートするには

1 ファイル > すべてエクスポート（File > Export All）またはファイル > 選択
項目のエクスポート（File > Export Selection）を選択します。

2 ファイルタイプとしてOBJexport を選択してから、エクスポート（Export）
をクリックします。

RenderMan（RIB）エクスポートプラグイン
ribExport プラグインでは、ファイル > すべてエクスポート（File > Export All）
のオプションメニューに新しいファイルフォーマット RIBexport が追加されま
す。これにより、Maya で作成したシーンを RIB（Pixar® RenderMan®）フォー
マットでエクスポートできます。

注: ribExport プラグインでは、エクスポート方式としてすべてエクスポート
（Export All）だけがサポートされます。RIB ファイルをインポートすることは
できません。

注: このプラグインは、32 ビット Windows および 64 ビット Linux でのみサ
ポートされています。

ribExport はアンビエントライトやディレクショナルライト、ポイントライト、
スポットライトもサポートしています。単純な非テクスチャシェーダもサポー
トされていますが、シェーダカラーだけがエクスポートされ、他のすべての
シェーディングアトリビュートは無視されます。Phong や Blinn シェーダは
「plastic」として、Lambert シェーダは「matte」としてエクスポートされま
す。フェース単位のシェーディンググループはサポートされていません。オブ
ジェクトまたはオブジェクトインスタンスに割り当てられているシェーディン
ググループのみがエクスポートされます。

Maya のシーンを RIB にエクスポートする際には、# 文字が Renderman イメー
ジ名における特殊文字であるということに注意してください。RenderMan のイ
メージ名に#という文字を実際に使用したい場合は、## を使用する必要がありま
す（フォーマットに関する詳細については、RenderMan のユーザマニュアル
を参照してください）。
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ribExport プラグインで作成されたイメージ名には、レンダー可能なカメラの
imageName アトリビュートのコンテンツも含まれます。RenderMan の特殊な
フォーマット文字（# など）をイメージ名の中で使用したい場合は、その文字を
imageName アトリビュートの値に埋め込んでください。

注: Autodesk は、ribExport プラグインのソースコードを Maya Developer's
Toolkit の一部として提供しています。Toolkit をインストールしている
と、.../files/devkit/plug-ins/ribExport.cpp にソースコードがあります。

ribExport プラグインをロードするには

1 Maya を開いてウィンドウ > 設定/プリファレンス > プラグインマネージャ
（Window > Settings/Preferences > Plug-in Manager）を選択します。

2 ribExport プラグインのロード（loaded）チェックボックスをクリックし
ます。

ファイルを RIB フォーマットでエクスポートするには

1 ファイル > すべてエクスポート（File > Export All）を選択します。

2 ファイルの種類（Files of type）フィールドでファイルタイプとして
RIBexport を選択し、すべてエクスポート（Export All）をクリックしま
す。

RIBexport オプション
Single File Output はい（Yes）を選択すると、すべてのフレームが 1 つの .rib

ファイルに書き出されます。いいえ（No）を選択すると、すべてのフレームが
別々の .ribファイルに書き出されます。

Extension Padding Single File Output オプションがいいえの場合、このオプ
ションは RIB ファイルの拡張子を 0 でパディングするよう指定します。

Geometry Motion Blur ジオメトリモーションブラー情報を RIB ファイルに書
き込むかどうかを指定します。

Pixel Samples 1 ピクセルあたりのサンプル数を指定します。指定した値は X 軸
および Y 軸の両方向で使用されます。
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Maya OpenFlight のイン
ポート/エクスポート

OpenFlight の概要
OpenFlight® ファイルトランスレータプラグインは Maya の機能を拡張し、ビ
ジュアルシミュレーション業界で必要とされている機能を提供します。これは、
既存の OpenFlight データベースを Maya に読み込むデータトランスレータを提
供することで実現されています。OpenFlight Exporter には、OpenFlight データ
ベースインポータが付属しています。Maya に不足している機能が、Maya のモ
デリング環境で作成および編集できる、新しいノードタイプの形で追加されてい
ます。

OpenFlight は Maya と同時にインストールされます。

OpenFlight ファイルをインポート/エクスポート
する

OpenFlight ファイル トランスレータをロードするには

1 Maya を開いてウィンドウ > 設定/プリファレンス > プラグインマネージャ
（Window > Settings/Preferences > Plug-in Manager）を選択します。

2 Open/Flight プラグイン、fltTranslatorのロード（loaded）チェックボック
スをクリックします。

6
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OpenFlight は 3D ファイルフォーマットです。ファイルのインポータ/エクス
ポータは OpenMaya プラグインです。Maya にインポートできる Beads は、エ
クスポートもできます（詳細については、サポートされている OpenFlight Beads
(38 ページ) を参照）。

エクスポートされたファイルには、インポートされたデータのサブセットが含ま
れます。外部ファイルまたはテクスチャのリファレンスは、カレントディレク
トリのリファレンスファイルを指します。エクスポートしたファイルをオリジ
ナルのファイルリファレンスへのアクセスが許されない場所に移動する必要が
ある場合、このリファレンスファイルをターゲットの OpenFlight ファイルと
同じディレクトリにコピーするとリファレンスを正しく読み込むことができま
す。

OpenFlight ファイルを開くには

■ ファイル > シーンを開く（File > Open Scene）を選択して、ファイルブラ
ウザの選択肢から、開く OpenFlight ファイルを選択します。

OpenFlight ファイルをエクスポートするには

■ ファイル > すべてエクスポート（File > Export All）（またはファイル > 選
択項目のエクスポート（File > Export Selection））を選択し、ファイル タ
イプ（File Type）プルダウンリストから OpenFlight を選択します。

バージョンの互換性

バージョン 14.2 から 15.7 までを読み込む（インポートする）ことができます
が、エクスポートできるのは 15.7 のファイルのみです。

ユーザインタフェース
OpenFlightメニュー

OpenFlight プラグインがインストールされている場合、メインウィンドウに
OpenFlight メニューが追加されます。このメニューには次のメニュー項目が含
まれます。

■ OpenFlight > ライトポイントの作成（OpenFlight > Create Light Points）
(25 ページ)

24 | 第 6 章 Maya OpenFlight のインポート/エクスポート



■ OpenFlight > ライトオンカーブの作成（OpenFlight > Create Lights on
Curve） (26 ページ)

■ OpenFlight > ライトポイントカラーの編集（OpenFlight > Edit Light Point
Colors） (26 ページ)

■ OpenFlight > ライトポイント法線の編集（OpenFlight > Edit Light Point
Normals） (27 ページ)

OpenFlight > ライト ポイントの作成
（OpenFlight > Create Light Points）

fltLightPoints コマンドを起動してシーンに新しいライトポイントのセットを作
成します。

OpenFlight > ライト ポイントの作成（OpenFlight > Create Light

Points）
ライト ポイント数（Number of Light Points） ライトポイントの数を設定しま
す。

ライト ポイント間の距離（Distance Between Light Points） ライトポイント
間の距離を設定します。

ライト タイプ（Light type） 全方向（Omnidirectional）、一方向
（Unidirectional）、双方向（Bidirectional）のいずれかを選択します。

ライト法線（Light Normal） ライトタイプが一方向（Unidirectional）または
双方向（Bidirectional）の場合のみ使用可能です。ライトの法線を設定します。

ライト カラー（Light Color） ライトのカラーを設定します。

注: ライトのカラーはシェーディングモードでのみ表示されます。カラーを表示
するには、スムース シェーディング（Smooth Shading）をオンにします。
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OpenFlight > ライト オンカーブの作成
（OpenFlight > Create Lights on Curve）

fltLightsOnCurve スクリプトを起動して、選択されたカーブに沿ったライトポ
イントを作成します。

OpenFlight > ライト オンカーブの作成（OpenFlight > Create Lights

on Curve）
ライト ポイント数（Number of Light Points） ライトポイントの数を設定しま
す。

ライト タイプ（Light type） 全方向（Omnidirectional）、一方向
（Unidirectional）、双方向（Bidirectional）のいずれかを選択します。

ライト カラー（Light Color） ライトのカラーを設定します。

注: ライトのカラーはシェーディングモードでのみ表示されます。カラーを表示
するには、スムース シェーディング（Smooth Shading）をオンにします。

OpenFlight > ライト ポイント カラーの編集
（OpenFlight > Edit Light Point Colors）

選択されたライトポイントのカラーを変更するのに使用されます。

選択したライト ポイントのカラーを変更するには

1 変更するライトポイントを選択します。

2 OpenFlightメニューから、ライト ポイント カラーの編集（Edit Light Point
Colors）を選択します。

ライト ポイント カラー エディタ（Light Point Color Editor）が表示され
ます。

3 カラースライダで、選択したライトポイントに適用するカラーを選びま
す。

4 適用（Apply）（または適用して閉じる（Apply and Close））ボタンをク
リックして、選択されたライトポイントにカラーを適用します。
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このダイアログボックスは、オブジェクトモードで選択したライトポイントに
対しても、コンポーネントモードで選択したライトポイントに対しても動作し
ます。

OpenFlight > ライト ポイント法線の編集
（OpenFlight > Edit Light Point Normals）

任意の選択されたライトポイントの法線を変更することができます。

任意の選択されたライト ポイントの法線を変更するには

1 変更するライトポイントを選択します。

2 OpenFlight メニューから、ライト ポイント法線の編集（Edit Light Point
Normals）を選択します。

ライト ポイント法線エディタ（Light Point Normal Editor）が表示されま
す。

3 ライトポイントに適用する新しい法線の値を入力します。

4 適用（Apply）（または適用して閉じる（Apply and Close））ボタンをク
リックして、選択されたライトポイントに法線を適用します。

このダイアログボックスは、オブジェクトモードで選択したライトポイントに
対しても、コンポーネントモードで選択したライトポイントに対しても動作し
ます。

OpenFlight ワークフローで考慮すべき点
Maya で OpenFlight ファイルを扱う場合、ワークフローに関して次の事項を考
慮しておく必要があります。

ファイルのインポート時

OpenFlight モデルは Z アップ軸を上向きにして構築されます。ファイル > シー
ンを開く（File > Open Scene）を使用してモデルを Maya に読み込む場合、
Maya のデフォルトの方向が再配置されて Z 軸がアップベクトルになります（通
常 Maya では、Y 軸がアップベクトル）。
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ファイル > インポート（File > Import）を使用して Maya にファイルを読み込
む場合、方向はインポートによって左右されます。インポートされたデータを正
しい方向に向ける必要があります。

ファイルのエクスポート時

ここでは、Maya から OpenFlight ファイルをエクスポートする際の制限につい
ていくつか挙げます。

■ モデルは常に RGB モードでエクスポートされます。

■ 単位は常にメートルです。

■ アニメーションはすべてエクスポートできません。

■ カメラもすべてエクスポートできません。

■ エクスポータは、1 つのフェースにつき 1 つのテクスチャマップのみをサ
ポートしています。レイヤ化されたテクスチャは、最初のテクスチャだけが
エクスポートされます。

■ 2D や 3D のプロシージャテクスチャはエクスポートされません。

■ Maya のレンダリングパラメータには、OpenFlight では同等のパラメータ
がないものが多くあります。

■ Degree of Freedom Beads は、Maya の Group/Transform ノードで Limits
が設定されている場合のみ作成されます。

■ 外部参照のノードのトランスフォームは OpenFlight フォーマットには保存
されません。カレントシーンから参照されているファイルをトランスフォー
ムするには、参照ファイルの DAG ノードのルートオブジェクトをグループ
化して、トランスフォームをすべてそのグループノードに適用する必要があ
ります。

モデルのシェーディング時

フラットシェーディング

OpenFlight オブジェクトにはフラットシェーディングのフラグがあります。こ
れは、オブジェクトをフラットシェーディングで描画するか、Gouraud（スムー
ス）シェーディングで描画するかを指定します。このフラグは、Maya のポリゴ
ンのスムース シェーディング（Smooth Shading）アトリビュートにコネクト
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されるようになりました（アトリビュート エディタ（Attribute Editor）のシェ
イプ（Shape）ノードのレンダリング詳細（Render Stats）セクション参照）。

OpenFlight は、フェースレベルとオブジェクトレベルの両方でフラットシェー
ディングフラグをサポートしますが、Maya では、オブジェクトレベルのフラ
グのみをサポートします。このため、Maya にインポートするオブジェクトのフ
ラットシェーディングフラグは、オブジェクトとそのすべてのフェースで必ず
等しい値に設定する必要があります。

照明

OpenFlight オブジェクトの照明フラグは、オブジェクトを近くのライトで照ら
すか、自己照明のみを適用するかを指定します。

自己照明オブジェクトをインポートすると、該当する Maya オブジェクトの次
のアトリビュートがオフになります: シャドウの投影（Casts Shadows）、シャ
ドウの受像（Receive Shadows）、反射に現れる（Visible in Reflections）、屈
折に現れる（Visible in Refractions）。インポートされたオブジェクトが自己照
明オブジェクトではない場合、これらのアトリビュートはすべてオンになりま
す。

Maya オブジェクトを OpenFlight にエクスポートすると、Maya オブジェクト
のシャドウの受像（Receive Shadows）アトリビュートがオフになっている場合
に限り、自己照明フラグが設定されます。

スイッチノードの使用時

Maya では OpenFlight スイッチノードがサポートされています。スイッチノー
ドでは、グループのトランスフォーム（Transform）ノードに適用される表示マ
スク配列が許されます。表示マスクでは、子ノードが 1 ビットで表示されます
（カレントの実装でサポートされているのは、32 個までの子ノードです）。

スイッチノードがグループトランスフォームノードに適用され、ハイパーグラ
フ（Hypergraph）を通して見たり、選択したりできるヘルパー（Helper）ノー
ドとして実装されています。現在選択されているマスクは、スイッチノードに
関連するアトリビュート エディタ（Attribute Editor）を通して修正できます。

スイッチノードは、スイッチノード付きの OpenFlight データベースが Maya
に読み込まれるときに自動的に作成されます。また、このノードは、Maya モデ
リング環境内で fltSwitch コマンドを使用して作成することもできます。
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スイッチノードのアトリビュート

フラグデフォルトタイプロング ネーム
（ショート ネー
ム）

R0Tint32outputVis（out）

RWSK0Tint32curMask（in）

RWS0Tint32maskWidth

（mkw）

RWS0Tint32numMasks（nmk）

ARWS0Tint32masks（mks）

fltSwitchコマンド
書式 FltSwitch [flags]

戻り値 [string[]]（作成時のオブジェクト名またはノード名）

説明 このコマンドは、Maya でスイッチノードの作成、編集、または照会を行
う際に使用されます。

フラグ -p（c）親グループのトランスフォームノード

-cm（eq）カレントのスイッチノードマスクの設定または照会

-n（ceq）扱うノードの名前

-am（e）選択されているオブジェクトに応じたマスクの追加

-em（e）選択されているオブジェクトに応じたアクティブなマスクの編集

-dm（e）カレントマスクの削除
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例
// Create a Switch node

fltSwitch -n sw1;

// After some geometry has been added under sw1, masks maybe

created by selecting the geometry to be visible under the switch

for the mask and and then using the fltSwitch command as follows.

fltSwitch -e -am -n sw1;

// Setting the current mask to the desired switch will enable that

mask.

fltSwitch -e -cm 0 -n sw1;

ライトポイント（Light Point）を使用する場合

Maya では OpenFlight ライトポイント（Light Point）がサポートされていま
す。ライトポイントを使用して、レンダープロパティのないライトの配列を作
成することができます。

この光源は、OpenFlight ファイルにインポートおよびエクスポートすることが
できます。ただし、次の制限があります。

インポート
■ モデリングライトはサポートされません。

■ OpenFlight 無限ライト（OpenFlight Infinite Light）は、ディレクショナル
ライトとして Maya にインポートされます。

■ OpenFlight ローカルライト（OpenFlight Local Light）は、アンビエント
ライトとして Maya にインポートされます。

■ OpenFlight スポットライト（OpenFlight Spot Light）は、スポットライ
トとして Maya にインポートされます。

エクスポート
■ ディレクショナルライトは無限ライトとしてエクスポートされます。

■ アンビエントライトはローカルライトとしてエクスポートされます。

■ スポットライトはスポットライトとしてエクスポートされます。

■ OpenFlight でサポートされていないライトのタイプ（エリアライト、ポイ
ントライト）は、無限ライトとしてエクスポートされます。

■ モデリングライトはサポートされません。

OpenFlight ワークフローで考慮すべき点 | 31



注:

■ 1 つの光源ごとに 1 つのライトパレットが作成されます。

■ ライトパレットの方向は常に Yaw = 0、Pitch = 0 になります。

ライトポイントは Maya のシェイプとして実装されます。ライトポイントは、
ライトポイント付き OpenFlight データベースが Maya に読み込まれる際に自
動的に作成されます。または、OpenFlight のメニューコマンドや MEL コマン
ド fltLightPoints を使って Maya で作成することもできます。

LightPointShape にはそれぞれ、任意の数のライトポイントを含めることがで
きます。LightPointShape を選択してそのアトリビュート エディタ（Attribute
Editor）を開くと、ライトポイントアトリビュートがすべて使用可能な状態に
なります。このアトリビュートには、Maya では可視となるエフェクトがなくて
も編集、保存、エクスポートはできるものがたくさんあります。

ライトポイントアトリビュート

フラグデフォルトタイプロング ネーム
（ショート ネー
ム）

RWS0double3LightPointsMin

（lpmn）

RWS0double3LightPointsMax

（lpmx）

RWS0Tint16SurfaceMaterialCode

（smc）

RWS0Tint16FeatureId（fid）

RWS0Tint32BackColor（bc）

RWS0enumDisplayMode

（dm）

RWS0floatIntensity（ity）
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RWS0floatBackIntensity

（bit）

RWS0floatMinimumDefocus

（mndf）

RWS0floatMaximumDefocus

（mxdf）

RWS0Tint32FadingMode（fm）

RWS0Tint32FogPunchMode

（fpm）

RWS0Tint32DirectionalMode

（drm）

RWS0Tint32RangeMode（rm）

RWS0floatMinimumPixelSize

（mnps）

RWS0floatMaximumPixelSize

（mxps）

RWS0floatActualSize（aps）

RWS0floatTransparentFalloffPixelSize

（tfps）

RWS0floatTransparentFalloffExponent

（tfe）

RWS0floatTransparentFalloffScalar

（tfs）

RWS0floatTransparentFalloffClamp

（tfc）

RWS0floatFogScalar（fs）
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RWS0floatSizeDifferenceThreshold

（sdt）

RWS0enumDirectionalType

（drt）

RWS0floatHorizontalLobeAngle

（hla）

RWS0floatVerticalLobeAngle

（vla）

RWS0floatDirectionalFallofExponent

（dfe）

RWS0floatDirectionalAmbientIntensity

（dai）

RWS0floatAnimationPeriod

（ap）

RWS0floatAnimationPhaseDelay

（apd）

RWS0floatAnimationEnabledPeriod

（aep）

RWS0floatSignificance（sig）

RWS0Tint32Calligraphic（call）

RWS0Tint32Flags（flgs）

RWS0floatXanimRotateAxis

（xra）

RWS0floatYanimRotateAxis

（yra）

RWS0floatZanimRotateAxis

（zra）
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ARWS0Double3LightColors（lc）

ARWS0Double3LightNormals（ln）

RW00x58000014InputLightPoints

（ilp）

RS00x58000014OutputLightPoints

（olp）

ARS00x58000014WorldLightPoints

（wlp）

RWS00x58000014CachedLightPoints

（clp）

RWSKfalseBooleanDisplayNormals

（dn）

RWSKfalseBooleanDisplayLobe（dl）

ライトポイントの機能が拡張されて、表示されるライトポイントシェイプのア
トリビュートがいくつか増えました。

■ ライトの方向性 > タイプ（Light Directionality > Type）

■ ライトの方向性 > 前面の強度（Light Directionality > Front Intensity）

■ ライトの方向性 > アンビエント強度（Light Directionality > Ambient
Intensity）

■ ライトの方向性 > バック強度（Light Directionality > Back Intensity）

■ ローブ角度 > 水平（Lobe Angle > Horizontal）

■ ローブ角度 > 垂直（Lobe Angle > Vertical）

■ ローブ角度 > ロール（Lobe Angle > Roll）

■ 表示 > 法線（Display > Normals）

■ 表示 > ローブ（Display > Lobe）
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表示 > 法線（Display > Normals）と表示 > ローブ（Display > Lobe）には共に
Creator に該当するオプションがありません。これらは、Maya 内でシーンを作
成するときに、法線の可視性とライトポイントのローブを制御する場合に使用
します。全方向ライトのローブを表示することはできません。

現在のところ、実際に設定されている値に関係なく、背景のカラーは赤でのみ表
示されます。ただしこのデフォルトカラーは、背景およびアンビエント強度に
反応します。これにより、さらに高度なシミュレーションを行うことができま
す。

fltLightPointsコマンド
書式 fltLightPoints [flags]

戻り値 [string[]]（オブジェクト名またはノード名）

説明 このコマンドは、Maya でライトポイントを作成するときに使用します。

フラグ -d（c）ライトポイント間の距離

-c（c）作成すライトポイント数

-n（c）作成するノードの名前

-p（c）親グループのトランスフォームノード

-nt（c）これが指定されている場合、親のトランスフォームノードは作成され
ません。この場合、親も –p フラグで指定する必要があります。

-clr（ce）作成されたすべてのライトポイントに適用される RGB のカラー値。
それぞれの値は 0.0 から 1.0 の範囲になるはずです。編集モードでは、ライト
ポイントが選択されていなければ、-n を使ってライトポイントシェイプの名前
を指定する必要があります。

-nml（ce）作成されたすべてのライトポイントに適用される法線。編集モード
では、ライトポイントが選択されていなければ、-n を使ってライトポイント
シェイプの名前を指定する必要があります。

-dt（ce）タイプは、"OMNIDIRECTIONAL"、"UNIDIRECTIONAL"、または
"BIDIRECTIONAL" のいずれかでなければなりません。デフォルトでは、ライト
ポイントは全方向（OMNIDIRECTIONAL）になります。

-dnml（ce）は、法線の表示の有効/無効を切り替えます（true/false）。
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例
// Create 3 light points spaced 0.5 UI units apart

fltLightPoints –c 3 –d 0.5/

/ this creates a light point string with 5 light points and visible

normals

fltLightPoints -c 5 -dnml true;

// this makes the normals of the selected light points string

invisible and

// changes the light type to be Unidirectional.

fltLightPoints -e -dnml false -dt UNIDIRECTIONAL;

fltLightsOnCurveスクリプト
書式 fltLightsOnCurve [arguments]

戻り値 なし（None）

説明 このスクリプトは、既存のカーブを使用し、配置のガイドとして現在選択
されているカーブを使って、指定された数のライトポイントを作成します。ラ
イトポイントはこのカーブに沿って均等な間隔で配置されます。

注: このカーブは構築専用であり、このスクリプトで変更されます。

このスクリプトを使用するには

1 カーブを作成してライトポイントを配置する際のガイドとして使用します。

2 カーブを選択してこのスクリプトを実行します。

例
// Create 3 Red Light Points equally spaced along the selected

curve

fltLightsOnCurve 3 1.0 0.0 0.0;

引数 Arg1 作成するライトポイントの数を指定する整数

Arg2 ライトポイントに割り当てられたカラーの赤（Red）コンポーネントを指
定する浮動小数点（0.0～ 1.0）

Arg3 ライトポイントに割り当てられたカラーの緑（Green）コンポーネントを
指定する浮動小数点（0.0～ 1.0）

Arg4 ライトポイントに割り当てられたカラーの青（Blue）コンポーネントを指
定する浮動小数点（0.0～ 1.0）
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DOF（Degree Of Freedom）ノード

Maya のトランスフォームノードはすべて DOF ノードを表すことができます。
DOF ノードにはそれぞれ使用できる情報に制限があり、デフォルトではそれぞ
れ独自の座標空間で動作します。

Maya トランスフォーム ノードから DOF を作成するには

■ アトリビュート エディタ（Attribute Editor）でグループのトランスフォー
ムノードの制限を設定します。

LOD（Level Of Detail）ノード

Maya の LOD ノードの動作は、OpenFlight の LOD ノードとは若干異なってい
ます。OpenFlight の LOD ノードの動作をシミュレーションするには、LOD
ノードで制御される単一のグループのトランスフォームノードに、OpenFlight
LOD ノードの子をすべてグループ化します。Maya の switch in/switch out 要
件にあわせて制御さした LOD ノードの前や後に、null のトランスフォームノー
ドを挿入することもできます。

注: このノードを削除すると、LOD が正しく動作しなくなります。

また、Maya の LOD は特定のカメラに関連付けられています。OpenFlight ファ
イルをインポートする際に、fltLOD という名前のカメラが作成されます。LOD
の動作を有効にするには、このカメラを使用する必要があります。Maya で新し
い LOD ノードが作成されると、同様に LOD カメラに関連付けられます。

サポートされている OpenFlight Beads
次の表に、OpenFlight と Maya の比較を示します。

Maya の場合/コメントOpenFlight Beads

コントロール レコード

インスタンス ジオメトリInstance Definition

インスタンス グループ ノードInstance Reference

DAG で前の親に移動します。POP
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カレントの親の下に子を作成します。PUSH

サポートされていないコントロール レコード

Extension

詳細については、PUSH Subface を参照。POP Surface

Maya では、同平面サーフェスの階層をサ
ポートすることはできません。代わりに、

PUSH Subface

作成する次のフェースを法線方向に 1 mm

オフセットします。

MultiGen 用に予約。Pop Attribute

MultiGen 用に予約。Push Attribute

プライマリ レコード

Maya トランスフォームを使って DOF を
表します。詳細については、OpenFlight

Degree-of-Freedom Record

ワークフローで考慮すべき点 (27 ページ)
を参照してください。

別の OpenFlight データベースへのファイ
ル リファレンス

EXTERNAL REFERENCE

フェースのシェイプ（Shape）ノードで
す。Maya では、フェースはポリゴン メッ
シュの一部です。

FACE

グループのトランスフォームノードです。GROUP

OpenFlight ファイルのヘッダ レコードで
す。方向、視界などを設定します。適切
な方向や UI の単位などを設定します。

HEADER

LOD グループ ノードです。Level-of-Detail

ライトです。Light Source
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OpenFlight トランスレータに関連付けら
れた特殊なノード タイプです。詳細につ

Light Point

いては、ライト ポイント（Light Point）
を使用する場合 (31 ページ)を参照してく
ださい。

トランスフォーム ノードです。OBJECT

OpenFlight トランスレータに関連付けら
れた特殊なノード タイプです。詳細につ

SWITCH

いては、「ワークフローで考慮すべき点」
の「スイッチ ノード」を参照してくださ
い。

サポートされていないプライマリ レコード

Z 軸に関する情報なしでデータベースの
モデリングができます。

Binary Separating Plane

B-spline、Cardinal（Catmull-Rom、
Bezier）

Curve

Continuously Adaptive Terrain Skin。信頼
性が高くリアルタイムで表示される三角
メッシュです。

CAT

Clip Region

ユーザ定義のノード情報。Extension Node

ポリゴン メッシュ（ポリゴン メッシュ
は、あまりサポートされていません。最

MESH

初のリリースでは使用できないこともあ
ります）。

LOD ノードと協調し、カメラからの距離
に応じてジオメトリを変形します。

Morph Vertex List

Road Segment
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Road Construction

Road Path

サウンド エミッタ位置Sound

Text

補助レコード

ノードではありませんが、頂点リストの
単純な延長です。レコード サイズは 64K

までに制限されます。

Continuation

以前読み込まれた 7 文字を超えるノード
に適用されるノード名。Maya のノード名

LONG ID

には特に制限がないため、名前はノード
に直接適用されます。

カレントのトランスフォーム ノードの複
数インスタンスです。

REPLICATE

カレントのトランスフォーム ノードに適
用されるトランスフォーム マトリックス
です。

TRANSFORMATION MATRIX

サポートされていない補助レコード

Bounding Volume

CAT Data Header

CAT Data Key

CAT Data Face

サード パーティによるサポート。Extension Attribute

Local Vertex Pool

MESH PRIMITIVE

サポートされている OpenFlight Beads | 41



頂点あたり 8 テクスチャまでサポートさ
れます（初期のリリースでは不可）。

MultiTexture

（グリッドの仰角データを含むファイル
へのポインタ）

Road Zone

頂点リストに沿ったテクスチャ レイヤ情
報を含んでいます。

UV List

（ライト ポイント フェースのみで使用）Vector

パレット レコード

カラー エントリの集合体です。Maya で
はカラー パレットは使用されません。頂

Color Palette

点にはそれぞれ該当する RGB カラーが保
持されています。

Maya では、ライトは DAG ノード エント
リです。

LIGHT PALETTE

Maya ではマテリアルはシェーダになりま
す。詳細については、TEXTURE PALETTE

を参照してください。

MATERIAL PALETTE

Maya では、テクスチャはシェーダに適用
されます。シェーダには、このテクスチャ

TEXTURE PALETTE

を使用するすべてのノードが接続される、
関連付けられたシェーディング グループ
があります。

Maya ではカメラとして実装されます（詳
細については、既知の問題点 (43 ページ)
を参照してください）。

Eyepoint and Trackplane Palette

Light Source Palette

Maya では、頂点はポリゴン メッシュの
一部です。

VERTEX PALETTE
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詳細については、VERTEX PALETTE を参照
してください。

VERTEX LIST

頂点データが後に続きます。Vertex Palette Header

ポリゴン メッシュの頂点データです。Vertex with Color

ポリゴン メッシュの頂点データです。Vertex with Color and Normal

ポリゴン メッシュの頂点データです。Vertex with Color, Normal and UV

ポリゴン メッシュの頂点データです。Vertex with Normal and UV

サポートされていないパレット レコード

Key Table

Linkage Palette

Maya には 1 つのライン スタイルしかあ
りません。

Line Style Palette

Name Table

Sound Palette

Texture Mapping

既知の問題点
次に、OpenFlight バージョン 1.1 時点での既知の問題を挙げます。

■ 一方向、または双方向ライトの Maya における表示カラーを変更することは
できません。このカラーは常にデフォルトの赤になります。将来的には、カ
ラーを RGB のディスプレイカラーにマップする機能を導入することが検討
されています。

■ スイッチノードと LOD をサポートする UI ベースのツールがありません。

■ サポートされているエクスポートタイプは、OpenFlight 15.7 のみです。
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■ OpenFlight ジオメトリはカラーチャンネルに割り当てられたテクスチャの
みを適用します。

■ 複数の光源はエクスポートすることができません。現在、単一の環境光のみ
が常にエクスポートされます。

■ Maya はカメラに視点をマップしようとしますが、マッピングが正しく表示
されない場合があります。視点は Maya からはエクスポートされません。

■ Track Planes はサポートされていません。

■ Maya で自由度座標を固定するには、シーンを OpenFlight ファイルとして
エクスポートして再び読み込むしか方法はありません。

■ グループノードでのアーティキュレーションはサポートされていません。

■ OpenFlight の LOD をさらに自在に扱うには、Maya の LOD を拡張する必
要があります。

■ 移動したライトポイントでトランスフォームのフリーズ（Freeze
Transformations）を実行すると、4.0.3 より古いバージョンの Maya はク
ラッシュしてしまいます。この問題は、Maya 4.0.3 以降に更新することによ
り解決できます。

■ ファイルテクスチャは、Maya シェーダのカラーアトリビュートにのみ適用
されます。ほかのアトリビュートに適用されるテクスチャは無視されます。

■ インポート時には、フェースの法線は無視されます。Maya は、頂点の順序
に基づいて法線を再生成します。ただし、エッジの設定は保持されます。
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