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サブディビジョンサー
フェスの概要

サブディビジョンサーフェスの概要
サブディビジョンサーフェスとは、Maya のモデリングで使用可能な特有のサー
フェスタイプで、ポリゴンおよび NURBS サーフェスタイプの特性を持ち合わせ
ています。

NURBS サーフェスのように、サブディビジョンサーフェスではスムースな有機体
の形状を生成し、比較的少数の CV で形成できます。

サブディビジョンサーフェスはさらにポリゴンサーフェスのように、特定の領域
を押し出して必要に応じてサーフェスにディテールを作成できます。これはサブ
ディビジョンサーフェスの異なるコンポーネント LOD を操作することで可能に
なります。必要なに応じて、LOD 間を何度となく切り替えることができます。

単一のサブディビジョンサーフェスには、異なる領域で異なる LOD（Level Of
Detail、制御点の密度）を持たせることができます。つまり、複雑なシェイプを持
つ領域には多くの制御点を持たせて細かいディテールを加え、また単純な、また
は平坦な領域は制御点の数を少なくすることができます。

1
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サブディビジョンサーフェスを使用してモデリングを行うと、人間の手などの
複雑なオブジェクトを簡単に作成することができます。NURBS とポリゴンモデ
リングの機能の最良な部分を統合します。

既存の NURBS やポリゴンサーフェスタイプをサブディビジョンサーフェスに
変換することができ、またその逆も可能です。

サブディビジョンサーフェスの動作

サブディビジョンサーフェスの名前は、「より細かなディテールの領域に分割
する」特徴に由来しています。ベースメッシュから始めて、その領域でより細
かな制御が可能な各サブディビジョンを使用して、領域をより細かなディテール
へと分割していきます。

サブディビジョンサーフェスのシェイプを変更するには、階層のそれぞれのレ
ベルで制御点を変更します。ベースメッシュ（「レベル 0」メッシュ）では、
サーフェス全体の大部分の領域のシェイプを変更できます。分割されたレベルで
は、サーフェスの特定の領域で、より細かな制御が可能となります。

サブディビジョンサーフェスの利点
■ サブディビジョンサーフェスでは、ポリゴンと比べてより高レベルなシェイ

プの制御が可能です。

■ モデルの複雑な領域では、複雑なジオメトリだけを使用することができます。

■ 折り目（折り目、鋭角なエッジ）や任意のトポロジ（四面体の用紙に限らず）
が可能です。

■ サブディビジョンサーフェスには連続性があるので、NURBS サーフェスを
アニメートするときに継ぎ目で発生するような問題の多くを排除できます。
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■ サブディビジョンサーフェスをスケルトンに粗いレベルでバインドし、エ
フェクトはより細かいレベルへスムースに移行します。

サブディビジョンサーフェスモデリングの概要
サブディビジョンサーフェスの使用経験がない場合、以下のワークフローの説
明が役に立ちます。

1 構築したいモデルの基本的なシェイプに近い、大まかなポリゴンメッシュ
を作成します。最初は最小限のポリゴンを使って構築するようにします。

このモデルによって、ベーストポロジおよびサブディビジョンサーフェス
変換時のサブディビジョンサーフェスの制御点が定義されます。サブディ
ビジョンサーフェスは、エッジに折り目を付けたり、洗練を行ったりする
場合にとても便利です。簡単に、ポリゴンメッシュにこれらの起伏をつけ
ることができます。

2 オブジェクトを選択してボタン 2 を押し、粗ポリゴンモデルがどのように
サブディビジョンサーフェスに変換されるか試してみてみましょう。

また、確認のためにサブディビジョンサーフェスを変換し、また元のポリ
ゴンモデルに戻すことができます。

3 ポリゴンメッシュをサブディビジョンサーフェスに変換した後、頂点の押
し込みと引き出しを行うことでサブディビジョンサーフェスのシェイプを
洗練します。

4 メッシュの特定の領域で、より詳細な制御が必要な場合は、標準モード
（Standard Mode）で新しいサブディビジョンレベルを作成します。

5 鋭角なエッジをサーフェスの領域に適用する場合、完全な、または部分的
な折り目を適用できます。

6 サーフェスのトポロジを変更する必要がある場合は、ポリゴン プロキシ
モード（Polygon Proxy Mode）に切り替えます（たとえば、フェースを分
割するなど）。ポリゴン プロキシ モード での作業時は、ポリゴンツール
を使用してサブディビジョンサーフェスを編集できます。

関連項目
■ 標準モードとポリゴンプロキシモード (4 ページ)
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■ サブディビジョンサーフェスコンポーネントに変換ツールを使用する (30
ページ)

■ 新しいサブディビジョンレベルを作成する (17 ページ)

■ サブディビジョンレベル間の切り替え (19 ページ)

■ サブディビジョンサーフェスの折り目を適用または削除する (21 ページ)

■ ポリゴンツールを使用してサブディビジョンサーフェスを修正する(23ペー
ジ)

■ サブディビジョンサーフェス編集時のインタラクティブなパフォーマンスを
上げる (30 ページ)

標準 モードとポリゴン プロキシ モード
サブディビジョンサーフェスは、2 つのモードで編集できます。

■ 標準モード

■ ポリゴン プロキシ モード

サブディビジョンサーフェスで効率的に作業するには、両方のモードを使用し
て作業する必要があります。マーキングメニューを使用して、両モード間を容
易に切り替えることができます。

標準モード（Standard mode）

標準モードでは、サブディビジョンサーフェスが一般的な形式で表示されます。
標準モードでは、ディテールを増やしたい領域のコンポーネント数を増やしたり
（領域を洗練する）、既存の洗練レベルを表示することができます。洗練したコ
ンポーネントを操作（移動、回転、スケール）し、そのサーフェスにキーフレー
ムを設定することができます。また、エッジと頂点に折り目を作成することも可
能です。

標準モードでは、選択したサーフェスの領域を洗練する場合、洗練したコンポー
ネントは異なるレベルに隔離されます。最初にサブディビジョンサーフェスを
作成すると、それはデフォルトではレベル 0 と呼ばれる 1 番目のレベルに表示
されます。レベル 0 はもっとも粗いレベルでベース メッシュとも呼ばれます。
レベル 1 以上の番号はより細かいレベルで、メッシュにより細かなディテール
を追加することができます。
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複雑なサブディビジョンサーフェスを表示する場合、インタラクティブなパ
フォーマンスはポリゴンプロキシモードより標準モードの方が優れています。
インタラクティブなパフォーマンスをさらに向上するためのヒントは、サブディ
ビジョンサーフェス編集時のインタラクティブなパフォーマンスを上げる (30
ページ)を参照してください。

標準モードとポリゴンプロキシモードの切り替えは、モデリングのいかなる段
階でも可能です。標準モードに切り替えると、Maya は、ポリゴンプロキシモー
ドで作成した押し出し、デフォメーション、またはその他のコンストラクション
ヒストリを削除します。

標準モードでは、サブディビジョンサーフェスの洗練の階層レベルを切り替え
ることができるため、階層モードとも呼ばれます。

ポリゴン プロキシ モード（Polygon proxy mode）

ポリゴンプロキシモードでは、サブディビジョンサーフェスのベースメッシュ
（レベル 0）に一致するポリゴンメッシュを、サブディビジョンサーフェスの
周辺に作成します。このポリゴンメッシュはテンポラリで、サーフェスの編集
に使用されます。つまり、標準モードに切り替えると、ポリゴンオブジェクト
は削除されます。

ポリゴン プロキシ モードでは、ポリゴンツールや機能を使用してサブディビ
ジョンサーフェスのベースメッシュ（レベル 0）を修正することができます。
たとえば、標準モードで作成したモデルのフェースの押し出しや削除を実行した
い場合は、ポリゴン プロキシ モードに切り替え、ポリゴンメッシュ上のフェー
スを押し出しまたは削除して（これによってベースメッシュに作用します）、
標準モードに戻ります。標準モードで行なった編集は、影響を受けるフェースが
オーバーラップしない場合は、そのまま維持されます。
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ポリゴンプロキシモードへの切り替えは、モデリングのどの段階でも可能です。
ただし、標準モードでデフォーマを使用したり、その他のコンストラクション
ヒストリを作成したりした場合は、コンストラクションヒストリを削除するま
で、ポリゴン プロキシ モードに切り替えることはできません。編集 > 種類ごと
に削除 > ヒストリ（Edit > Delete by Type > History）でオブジェクトのコンス
トラクションヒストリを削除し、ポリゴン プロキシ モード（Polygon Proxy
mode）に切り替えます。

注:

■ サブディビジョンサーフェスで作成したキャラクタをスキニングする場合、
スキニングの前にサブディビジョンサーフェスが標準モードに設定されてい
ることを確認してください。ポリゴンプロキシモードでスキニングすると、
予期せぬ動作を引き起こす場合があります。

関連項目
■ 新しいサブディビジョンレベルを作成する (17 ページ)

■ サブディビジョンレベル間の切り替え (19 ページ)

■ サブディビジョンサーフェス編集時のインタラクティブなパフォーマンスを
上げる (30 ページ)
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サブディビジョンサー
フェス変換

サブディビジョンサーフェスに変換するために
ポリゴンサーフェスを準備する

サブディビジョンサーフェスを開始する共通の方法は、ポリゴンを使ってシェイ
プの単純な「ラフスケッチ」を作成し、それをサブディビジョンサーフェスの
ベースメッシュに変換するというものです。ポリゴンメッシュを作成するとき
は、以下の点に注意してください。

ポリゴンメッシュをサブディビジョンサーフェスに変換する準備ができていると
きは、NURBS またはポリゴンメッシュをサブディビジョンサーフェスに変換す
る (11 ページ)を参照してください。

できるだけ少ないフェース数から開始する

密なサブディビジョンベースメッシュには制御点が多いため、パフォーマンスが
低下してしまいます。

既存のメッシュを変換する場合は、メッシュ > 削除（Mesh > Reduce）を使用し
てメッシュのフェースの個数を減らします。

四角ポリゴン（クワッド）を使用する

サブディビジョンサーフェスでは、最高で 256 辺のポリゴンを処理できますが、
最良の結果が得られるのは四角ポリゴンを使用した場合です。

2
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サブディビジョンサーフェスをモデリングするときは、四角形以外のフェース、
および隣接するフェースが 4 面未満または 4 面より多い頂点をなるべく使用し
ないでください。

オリジナルサーフェス上のフェースまたはパッチが四角形でない場合は、異常
な頂点（隣接するフェースが 4 面未満または 4 面より多い頂点）がサブディビ
ジョンサーフェスのレベル 0 で作成されます。これはサブディビジョンサー
フェスのパラメータ配置に影響し、サーフェスがでこぼこになる場合もあります
（モデルに比較して四角形が大きいほど、この問題の影響は小さくなります）。

ポリゴンメッシュの頂点とエッジをサブディビジョンサーフェスに配置
する

モデルのどこに頂点とエッジを配置するか計画すると、サブディビジョンサー
フェスをモデリングしたりジョイントにバインドしたときに、希望どおりの結果
が得られるようになります。

たとえば完全な、または部分的な折り目を作成したい場所には、エッジが必要で
す。ポリゴンサーフェスおよび NURBS サーフェスのように、頭部モデルの目
と口はエッジで円状に囲まれている必要があります。

変換しないポリゴンに注意する

次の種類のポリゴンサーフェスからサブディビジョンサーフェスを作成するこ
とはできません。

■ 不均一トポロジ
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メッシュ > クリーンアップ（Mesh > Cleanup）を使用して、非多様体ジオ
メトリを修正します。

■ ラミナトポロジ（複数の頂点または 1 つあるいは複数のエッジが共有された
フェースが相互に重なりあっている）
メッシュ > クリーンアップ（Mesh > Cleanup）を使用して、ラミナジオメ
トリを修正します。

■ 自由なポイントや浮遊エッジ

■ 2 つのエッジを結ぶ内部の複数の頂点

■ 一貫性のない法線
一貫性のない法線を修正する場合、法線 > 方向の一致（Normals > Conform）
を使用する方法があります。

関連項目
■ サブディビジョンサーフェスに変換するために NURBS サーフェスを準備す

る (9 ページ)

■ NURBS またはポリゴンメッシュをサブディビジョンサーフェスに変換する
(11 ページ)

サブディビジョンサーフェスに変換するために
NURBS サーフェスを準備する

NURBS サーフェスをサブディビジョンサーフェスに変換する準備ができている
ときは、NURBS またはポリゴンメッシュをサブディビジョンサーフェスに変
換する (11 ページ)を参照してください。
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NURBS プロパティの中には変換できないものもあります。

次の種類の NURBS サーフェスからサブディビジョンサーフェスを作成する場
合は、予期せぬ結果を得ることがあります。

■ 3 次以外の次数は変換されません。

■ 有理ジオメトリ（ウェイト付けした CV）は変換されません。

■ NURBS サーフェス上のトリムされた領域は変換されません。

■ サブディビジョンサーフェスに変換された NURBS 球体は、極に不正なサー
フェス法線ができます。シェーディングモードで表示すると、変換された半
球には法線が不正に計算されていることを示す黒いポイントがあります。

最初にポリゴンメッシュに変換することを検討する

NURBS から作成されたサブディビジョンベースメッシュはおそらく非常に密
であり、また NURBS モデルは通常、個別に変換してからアタッチしなければな
らない異なるサーフェスで作成されています。

最初に修正 > 変換 > NURBS をポリゴンに（Modify > Convert > NURBS to
Polygons）を使用すると、サブディビジョンサーフェスを変換する前に、ポリ
ゴンメッシュを減らしてアタッチできます。

修正 > 変換 > NURBS をポリゴンに（Modify > Convert > NURBS to Polygons）

から次のオプションを使用し、NURBS サーフェスをサブディビジョンベー
スメッシュとしての使用に適したポリゴンメッシュに変換します。

■ タイプ（Type）を四角（Quads）に設定します。

■ テッセレーション方法（Tessellation Method）が一般（General）であるこ
とを確認します。

■ U タイプ（U Type）と V タイプ（V Type）を 3D でのサーフェス単位のア
イソパラム数（Per Surf # of IsoParams in 3D）に設定します。

■ U の数（Number U）と V の数（Number V）のボックスに、サーフェスの
シェイプにほぼ近い数値のうち、最も小さい値があることを確認します。

複数の NURBS サーフェスを変換した場合は、メッシュ > 結合（Mesh >
Combine）を使用して単一のポリゴンメッシュにマージします。次にメッシュ
の編集 > マージ（Edit Mesh > Merge）またはメッシュの編集 > エッジのマージ
ツール（Edit Mesh > Merge Edge Tool）を使用して、内部境界エッジをマージ
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します。境界エッジをはっきりと表示するには、ディスプレイ > ポリゴン
（Display > Polygons） > カスタムポリゴン表示（Custom Polygon Display

） を選択して、境界エッジ（Border Edges）をオンにします。

関連項目
■ サブディビジョンサーフェスに変換するためにポリゴンサーフェスを準備

する (7 ページ)

■ NURBS またはポリゴンメッシュをサブディビジョンサーフェスに変換する
(11 ページ)

NURBS またはポリゴンメッシュをサブディビ
ジョンサーフェスに変換する

修正 > 変換 > NURBS をサブディビジョンに（Modify > Convert > NURBS to
Subdiv）

修正 > 変換 > ポリゴンをサブディビジョンに（Modify > Convert > Polygons
to Subdiv）

Alt キー + Shift キー + ～

変換時のトラブルシューティング
1 ポリゴンメッシュが変換されない、または使用に耐えないサブディビジョ

ンサーフェスになってしまう場合、サブディビジョンサーフェスに変換す
るためにポリゴン サーフェスを準備する (7 ページ)を参照してください。

2 NURBS メッシュが変換されない、または使用に耐えないサブディビジョン
サーフェスになってしまう場合、次を参照してください。
■ サブディビジョンサーフェスに変換するために NURBS サーフェスを準

備する (9 ページ)

■ サブディビジョンサーフェスをポリゴンに変換する (12 ページ)

■ サブディビジョンサーフェスを NURBS サーフェスに変換する (15ペー
ジ)
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■ 修正 > 変換 > NURBS をサブディビジョンに、ポリゴンをサブディビ
ジョンに（Modify > Convert > NURBS to Subdiv、Polygons to
Subdiv）

サブディビジョンサーフェスをポリゴンに変換
する

プロジェクトを終えるまでサブディビジョンサーフェスを使うこともできます
が、モデリングを終えたらポリゴンに変換しなくてはならないことがあります。
たとえば、ゲーム用のキャラクタを作成する場合、ゲームエンジンはポリゴン
のモデルを必要とします。

サブディビジョンサーフェスをポリゴンに変換するには、2 通りの方法があり
ます。

■ テッセレーションを行うとサブディビジョンサーフェスの外形に対応するポ
リゴンサーフェスが作成されます。

■ 頂点を抽出するとサブディビジョンサーフェスの（外形ではなく）制御頂点
に対応する単純で密度の低いポリゴンが作成されます。

元のサブディビジョン サーフェスの近似に変換するには

1 サブディビジョンサーフェスを選択して、修正 > 変換 > サブディビジョン

をポリゴンに（Modify > Convert > Subdiv to Polygons） を選択しま
す。
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2 頂点（Vertices）がオンではないことを確認します。

3 変換（Convert）をクリックします。

テッセレーションしたサブディビジョンサーフェスに折り目がある場合は、折
り目部分で作成されたポリゴンエッジは自動的に鋭いエッジになりません。

たとえば、オリジナルと同じシェイプを持つ、別のサブディビジョンサーフェ
スに変換できるポリゴンメッシュを作成できます。

頂点を一致させてサブディビジョン サーフェスの概形に変換する

1 サブディビジョンサーフェスを選択して、修正 > 変換 > サブディビジョン

をポリゴンに（Modify > Convert > Subdiv to Polygons） を選択しま
す。

2 頂点（Vertices）をクリックし、頂点をどのレベルから使用するかを選択し
ます。

3 変換（Convert）をクリックします。
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注:

■ サブディビジョンをポリゴンに（Subdiv to Polygons）は、サブディビジョ
ンサーフェスのレベル 0 の UV のみを、変換されたポリゴンサーフェスに
渡します。

関連項目
■ NURBS またはポリゴンメッシュをサブディビジョンサーフェスに変換する

(11 ページ)

■ サブディビジョンサーフェスを NURBS サーフェスに変換する (15 ページ)

■ 修正 > 変換 > サブディビジョンをポリゴンに（Modify > Convert > Subdiv
to Polygons）
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サブディビジョンサーフェスを NURBS サーフェ
スに変換する

修正 > 変換 > サブディビジョンを NURBS に（Modify > Convert > Subdiv to
NURBS）

Alt キー + ‘

サブディビジョンサーフェスに対応した NURBS サーフェスが作成されてグルー
プ化されます。

得られた NURBS サーフェスのグループを操作するには
■ NURBS の編集 > ステッチ > グローバルステッチ（Edit NURBS > Stitch >

Global Stitch）を使用します。
スティッチではパッチを 1 つのサーフェスとして変形させますが、そのパッ
チは、マテリアルを割り当てるときには、別のサーフェスとみなされます。
ステッチ（Stitch）サブメニューのその他のステッチ操作も使用できます。

■ NURBS の編集 > サーフェスのアタッチ（Edit NURBS > Attach Surfaces）を
使用します。
アタッチでは新規の連続サーフェスを作成し、マテリアルを割り当てるとき
に 1 つのサーフェスとみなされます。一度に 1 つのパッチで、反復してサー
フェスのアタッチ（Attach Surface）を適用する必要があります。パッチを
アタッチする順序は、サーフェスに適用するあらゆるテクスチャの配置に影
響するので注意してください。

注:

■ サブディビジョンを NURBS に（Subdiv to NURBS）の変換操作では、サブ
ディビジョンサーフェスの UV は変換されません。

■ シェーダがサブディビジョンサーフェスに割り当てられ、サブディビジョン
を NURBS に操作が適用されている場合、シェーダは作成されたサーフェス
へ転送されません。

関連項目
■ NURBS またはポリゴンメッシュをサブディビジョンサーフェスに変換する

(11 ページ)

■ サブディビジョンサーフェスをポリゴンに変換する (12 ページ)
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■ 修正 > 変換 > サブディビジョンを NURBS に（Modify > Convert > Subdiv
to NURBS）
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サブディビジョンサー
フェスの編集

新しいサブディビジョンレベルを作成する
サブディビジョンサーフェスでは、同じサーフェスの異なる領域に対して、異な
る LOD（Level of Detail）を設定できます。領域で使用可能な制御点（および
LOD の制限）の数を増やすことを領域の洗練と言います。

LOD は 13 のレベル（0 ～ 12）に洗練できますが、粗いレベルの頂点を使用して
希望のシェイプができなかった場合にだけ、細かいレベルへ階層を 1 つ上げてみ
てください。レベル 3 およびそれより細かいレベルで編集を行うと複雑になり、
パフォーマンスが低下します。

サブディビジョン サーフェスの領域を洗練するには

1 よりディテールを増やしたいコンポーネントを 1 つ以上選択します。

3
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2 サブディビジョンサーフェス > 選択したコンポーネントの洗練（Subdiv
Surfaces > Refine Selected Components）を選択します。

1 つ上のディテール階層レベルがサブディビジョンサーフェスに追加され
ます。選択したコンポーネントの洗練（Refine Selected Components）を
選択するたびに、新しいレベルが追加されます。

領域を拡大すると、隣り合う領域の洗練レベルをスプレッドすることができま
す。次の例では、中心の頂点が選択され、拡大されています。

洗練した領域を拡大するには

1 ディテールを増やしたい領域のコンポーネントを 1 つまたは複数選択しま
す。

2 サブディビジョンサーフェス > 選択したコンポーネントの拡大（Subdiv
Surfaces > Expand Selected Components）を選択して、隣接する領域も同
じレベルに洗練します。

選択したコンポーネントの洗練時のトラブルシューティング

サブディビジョン サーフェスの洗練を元に戻したい

 ➤ サブディビジョンサーフェスの洗練を元に戻すことはできません。ただし、
サブディビジョンサーフェス > トポロジのクリーニング（Subdiv Surfaces
> Clean Topology）を使用すると、作成してから編集されていない洗練済
みコンポーネントであれば削除できます。

関連項目
■ サブディビジョンレベル間の切り替え (19 ページ)
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■ ポリゴンツールを使用してサブディビジョンサーフェスを修正する(23ペー
ジ)

■ サブディビジョンサーフェスのレベルの数を減らす (31 ページ)

サブディビジョンレベル間の切り替え
サブディビジョンサーフェスの洗練レベルを切り替える方法はいくつかありま
す。

手順結果

サブディビジョン サーフェスを右マウス
ボタンで押して表示レベル（Display

サブディビジョン コンポーネントを編集
できるよう、特定のレベルを表示します。

Level）を選択し、編集するレベルを選択
します。
または
サブディビジョン サーフェス（シェイプ
ノード）のアトリビュート エディタ
（Attribute Editor）でサブディビジョン
コンポーネント表示（Subdiv Component

Display）セクションを開き、レベル
（Level）アトリビュートを設定します。

サブディビジョン サーフェスを右マウス
ボタンで押し、より詳細に表示（Display

Finer）を選択します。

現在よりも次に細かな（番号の大きい）
レベルを表示します。

または
サブディビジョン サーフェス > コンポー
ネントの表示レベル > より詳細に（Subdiv
Surfaces > Component Display Level >

Finer）を選択します。
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手順結果

または
キーボードの Page Up キーを押します。

サブディビジョン サーフェスを右マウス
ボタンで押し、選択項目の洗練（Refine

Selected）を選択します。

次の細かなレベルを編集し、既存の細か
なレベルがない場合はサーフェスを 1 レ
ベル上げます。

または
サブディビジョン サーフェスのコンポー
ネントを選択し、Ctrl + 下矢印キーを押し
ます。
または
サブディビジョン サーフェス > 選択した
コンポーネントの洗練（Subdiv Surfaces

> Refine Selected Components）を選択し
ます。

サブディビジョン サーフェスを右マウス
ボタンで押し、より粗く表示（Display

Coarser）を選択します。

現在よりも次に粗い（番号の小さい）レ
ベルを表示します。

または
サブディビジョン サーフェス > コンポー
ネントの表示レベル > より粗く（Subdiv
Surfaces > Component Display Level >

Coarser）を選択します。
または
キーボードの Page Down キーを押しま
す。

サブディビジョン サーフェスを右マウス
ボタンで押し、より粗いレベルの選択
（Select Coarser）を選択します。

サブディビジョン レベル階層で 1 レベル
上の関連するサブディビジョン コンポー
ネントを選択して、次に粗いレベルを編
集します。 または

サブディビジョン サーフェス > 粗いレベ
ルのコンポーネントの選択（Subdiv

Surfaces > Select Coarser Components）
を選択します。
または
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手順結果

サブディビジョン サーフェスのコンポー
ネントを選択し、Ctrl + 上矢印キーを押し
ます。

関連項目
■ 新しいサブディビジョンレベルを作成する (17 ページ)

サブディビジョンサーフェスの折り目を適用ま
たは削除する

選択したエッジまたは頂点に、折り目を完全にまたは部分的にを適用して、サブ
ディビジョンサーフェスのシェイプを修正できます。

完全な折り目とは、選択したエッジに作成されたハードエッジまたは鋭角なエッ
ジ、あるいは選択した頂点で作成された鋭いポイントです。折り目を作成する
と、サーフェスが選択したエッジや頂点のすぐ近く、またはその位置に移動しま
す。

部分的な折り目では、選択したエッジや頂点の近くにサーフェスが移動します
が、ちょうどその位置に移動することはありません。部分的な折り目は、キャラ
クタの唇の端など、よりソフトなエッジエフェクトが必要な場合に便利です。
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折り目が作成されたエッジは破線として表示されるので、どのエッジに対して折
り目が実行されたかを識別するのに便利です。

手順結果

折り目を入れるエッジまたは頂点を選択
して、サブディビジョン サーフェス >

完全な折り目を作成します。

エッジ/頂点に完全な折り目をつける
（Subdiv Surfaces > Full Crease

Edge/Vertex）を選択します。
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手順結果

折り目を入れるエッジまたは頂点を選択
して、サブディビジョン サーフェス >

部分的な折り目を作成します。

エッジ/頂点に部分的に折り目をつける
（Subdiv Surfaces > Partial Crease

Edge/Vertex）を選択します。

折り目のあるエッジまたは頂点を選択し
て、サブディビジョン サーフェス > エッ

折り目を削除します。

ジ/頂点の折り目を解除（Subdiv Surfaces

> Uncrease Edge/Vertex）を選択します。

関連項目
■ ポリゴンツールを使用してサブディビジョンサーフェスを修正する(23ペー

ジ)

ポリゴンツールを使用してサブディビジョン
サーフェスを修正する

サブディビジョンサーフェスを通常のサブディビジョンモード（標準モード
（Standard Mode））で操作するだけでなく、代替物（プロキシメッシュ）を
作成して編集することでサブディビジョンサーフェスをポリゴンメッシュであ
るかのように修正する（「ポリゴンプロキシモード（Polygon Proxy Mode）」）
ことができます。

サブディビジョンサーフェスをポリゴンプロキシモードで操作する場合、Maya
にある数多くのポリゴン編集ツールを使用して、サブディビジョンサーフェス
を修正および編集することができます。サーフェスの操作中に 2 つの表示モー
ドを自由に切り替えることができます。
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手順結果

サブディビジョン サーフェス > ポリゴン
プロキシ モード（Subdiv Surfaces >

Polygon Proxy Mode）を選択します。

ポリゴンプロキシモードに切り替えます。

ポリゴン メッシュ プロキシが現在のサブ
ディビジョン レベルから作成されます。
ポリゴン ツールを使用してプロキシを編
集します。

サブディビジョン サーフェス > 標準モー
ド（Subdiv Surfaces > Standard Mode）
を選択します。

標準モードに切り替えます。

加えた変更がサブディビジョン サーフェ
スへのプロキシに適用されます。

注:

■ ポリゴンメッシュにはシェーディングが無いので、作成されるサブディビ
ジョンサーフェスで確認することができます。

■ ブーリアン（Boolean）、ベベル（Bevel）、削減（Reduce）の操作では、
標準モードの編集を維持しません。

■ 一部のポリゴン操作（結合など）によって、サブディビジョンサーフェスに
関連のないポリゴンサーフェスが新たに作成されます。得られたポリゴン
サーフェスから新しいサブディビジョンサーフェスを作成する必要がありま
す。

■ ポリゴン操作を行うと、標準モードで行った編集が修正される場合がありま
す。たとえば、ポリゴンプロキシモードでフェースを分割すると、元の標
準モードで行った編集内容はそれぞれ新しいフェースにコピーされます。修
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正した領域から、遠いレベルの編集内容や折り目（折り目）は影響を受けま
せん。

■ 標準モードでコンポーネントを編集した領域のトポロジを変更することは避
けてください（フェースの分割など）。サーフェスに予期せぬ変形結果が生
じる可能性があります。これが編集内容の問題となるのはレベル 0 のコン
ポーネントではなく、より細かなレベルでだけとなります。

ポリゴン プロキシ モードでのトラブルシューティング

ポリゴン プロキシ モードに切り替えられない

 ➤ 標準モードでデフォーマを使用したり、ヒストリを持つ UV をマッピング
したり、あるいはその他のコンストラクションヒストリを作成したりした
場合は、ポリゴン プロキシ モードに切り替えることはできません。

まずオブジェクトのコンストラクションヒストリを削除し（編集 > 種類ごとに
削除 > ヒストリ（Edit > Delete by Type > History））、次にポリゴン プロキシ
モード（Polygon Proxy mode）に切り替えます。

ソフト修正を使用してサブディビジョンサー
フェスを修正する

次の各ページを参照してください。

■ 『デフォーマ』マニュアルの「ソフト修正とは」

■ 『デフォーマ』マニュアルの「ソフト修正ツール（Soft Modification Tool）
の使用」

■ デフォーマの作成 > ソフト修正（Create Deformers > Soft Modification）
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サブディビジョンサーフェスの編集した頂点を
表示する

特定のサブディビジョンサーフェスに対して表示モードを設定し、編集された
頂点のみを表示することができます。これにより、以前に編集した領域にさらな
る洗練や修正作業を簡単に実行できます。

編集した頂点のみが表示されるようにサブディビジョン コンポーネント表示を
設定するには

1 サブディビジョンサーフェスを選択して、頂点が表示されるように設定さ
れていることを確認します。

2 サブディビジョンサーフェスに初期的な洗練や変更を行います。

3 サブディビジョンサーフェス > コンポーネントの表示フィルタ > 編集済み
（Subdiv Surfaces > Component Display Filter > Edits）を選択します。

サブディビジョンサーフェス頂点の表示が、編集された頂点のみを表示す
るように更新されます。

4 再度すべての頂点を表示するには、サブディビジョンサーフェスを選択し
てサブディビジョンサーフェス > コンポーネントの表示フィルタ > すべて
（Subdiv Surfaces > Component Display Filter > All）を選択します。

関連項目
■ 新しいサブディビジョンレベルを作成する (17 ページ)

■ サブディビジョンレベル間の切り替え (19 ページ)

■ ポリゴンツールを使用してサブディビジョンサーフェスを修正する(23ペー
ジ)

サブディビジョンコンポーネントの選択項目を
変換する

既存のサブディビジョンコンポーネントの選択項目を別のコンポーネントタイ
プに変換できます。これにより、既存の選択項目を選択解除して別のコンポーネ
ントタイプを選択する手間が省けます。
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たとえば、ポリゴンプロキシメッシュのエッジを選択した場合、この選択項目
を、エッジにコネクトされるフェースに変換して、ポリゴン編集機能でフェース
を編集することができます。

この選択項目をフェース、エッジ、頂点、および UV に変換できます。さらに選
択項目を拡張して、その周囲のコンポーネントを追加で選択することもできま
す。

既存のサブディビジョン コンポーネントの選択項目を別のコンポーネント タイ
プに変換するには

1 サブディビジョンサーフェスの、1 つまたは複数のサブディビジョンコン
ポーネントが選択されていることを確認してください。

2 次のいずれかを実行します。
■ サーフェスのエッジ上で Ctrl キーを押しながら右クリックして、表示

されるマーキングメニューから変換したいコンポーネントタイプを選
択します。

■ Maya メニューからサブディビジョン サーフェス > 選択項目を <任意の
コンポーネント タイプ> に変換（Subdiv Surfaces > Convert Selection
to <component type>）を選択して変換したいコンポーネントタイプ
を選択します。

関連項目
■ サブディビジョンサーフェス > 選択項目をフェースに変換（Subdiv Surfaces

> Convert Selection to Faces） (65 ページ)

■ サブディビジョンサーフェス > 選択項目をエッジに変換（Subdiv Surfaces
> Convert Selection to Edges） (65 ページ)

■ サブディビジョンサーフェス > 選択項目を頂点に変換（Subdiv Surfaces >
Convert Selection to Vertices） (65 ページ)

■ サブディビジョンサーフェス > 選択項目を UV に変換（Subdiv Surfaces >
Convert Selection to UVs） (66 ページ)

■ サブディビジョンサーフェス > 選択したコンポーネントの拡大（Subdiv
Surfaces > Expand Selected Components） (67 ページ)
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サブディビジョンサーフェスをアタッチする
各サーフェスのベースメッシュ（レベル 0）のポリゴンエッジが同じ数の場合
にだけ、サーフェスのエッジがアタッチされます。サーフェスのエッジ数が異な
る場合、オブジェクトはグループ化されますが、サーフェスの頂点とエッジは
マージされません。

アタッチを行うと、選択したサーフェスにウェイトを割り当てているデフォーマ
が破壊されます。

アタッチするサブディビジョン サーフェスを準備するには

 ➤ アタッチする 2 つのサーフェスについて、ベースメッシュ（レベル 0）と
同数のポリゴンエッジがあることを確認します。エッジ数が異なる場合は、
サーフェスはグループ化されますが、マージはされません。

ポリゴンプロキシモードでポリゴンのスプリット ツール（Split Polygon
Tool）またはエッジ/頂点の削除（Delete Edge/Vertex）を使用して、エッ
ジの作成や削除をします。

■ 標準モードになっていない場合は、標準モードに切り替えます（サブディビ
ジョンサーフェス > 標準モード（Subdiv Surfaces > Standard Mode））。
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■ ミラーコピーしたサーフェスをマージする場合は、ミラーコピーのヒスト
リを削除します。

■ サブディビジョンサーフェス > アタッチ（Subdiv Surfaces > Attach）では、
一貫して配向法線のサーフェスが要求されます。
アタッチするいずれかのサーフェスに間違った方向を向いた法線がある場合、
編集 > 複製（Edit > Duplicate）を選択してサブディビジョンサーフェス >
ミラー（Subdiv Surfaces > Mirror）で逆方向にミラーしてから、ミラーした
オブジェクト上で修正 > トランスフォームのフリーズ（Modify > Freeze
Transformations）を実行します。

サブディビジョン サーフェスをアタッチするには

1 アタッチするサーフェスを選択します。

2 サブディビジョンサーフェス > アタッチ（Subdiv Surfaces > Attach）を選
択します。

注:

■ 各サーフェスのベースメッシュ（レベル 0）のポリゴンエッジが同じ数の場
合にだけ、サーフェスのエッジがアタッチされます。
サーフェスのエッジ数が異なる場合、オブジェクトはグループ化されますが、
サーフェスの頂点とエッジはマージされません。

■ アタッチを行うと、選択したサーフェスにウェイトを割り当てているデフォー
マが破壊されます。

関連項目
■ サブディビジョンサーフェス > アタッチ（Subdiv Surfaces > Attach） (60

ページ)
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サブディビジョンサーフェスコンポーネントに
変換ツールを使用する

サブディビジョンサーフェスコンポーネントをトランスフォームする場合は、
次のヒントに注意してください。

■ 各頂点で 1 つずつ修正 > トランスフォームツール > 法線移動ツール（Modify
> Transformation Tools > Move Normal Tool）を適用します。サブディビ
ジョンサーフェスで隣り合う頂点には、共通の UV 方向がないことがありま
す。

■ できれば、粗い（番号が小さい）方では、スケールを大きくし、細かいレベ
ルではスケールを小さくしてください。

■ 頂点を並べるには、サーフェスに接するようにしながら、カメラプレーンで
エッジを回転させます。

■ 標準モードで行った頂点の編集内容（変換）を削除するには、その頂点を選
択し、Delete キーを押します。この操作によって、頂点は元の位置に戻りま
す（実際に削除されるわけではありません）。

サブディビジョンサーフェス編集時のインタラ
クティブなパフォーマンスを上げる

サブディビジョンサーフェスの操作時にインタラクティブなパフォーマンスを
上げるためには、次のヒントに注意してください。

■ ポリゴンプロキシモード（Polygon Proxy Mode）よりも標準モード
（Standard Mode）でコンポーネントを編集します。

■ ベースメッシュは（レベル 0）シンプルにしておきます。より細かいレベル
を作成してディテールをすべて追加します。

■ パフォーマンスを向上させるためにポリゴンプロキシモードでモデリング
する場合は、UV の作成をオフに設定します（サブディビジョン上に UV な
し（No UVs on Subd）オプション。

■ 多くの制御点を同時に編集する場合、ディペンデンシー グラフの評価
（Dependency Graph Evaluation）設定（ウィンドウ > 設定/プリファレン
ス > パフォーマンス設定（Window > Settings/Preferences > Performance
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Settings））を設定することにより、サーフェスの更新時期を制御すること
ができます。マウスをドラッグしたとき、マウスを放したとき、または表示
される更新ボタンを押したときに描画がリフレッシュされるように設定する
ことができます。詳細については、「ウィンドウ > 設定/プリファレンス >
パフォーマンス設定（Window > Settings/Preferences > Performance
Settings）」を参照してください。

■ 作成されてから編集されていないコンポーネントを削除するときは、トポロ
ジのクリーニング（Clean Topology）操作を使用してください。詳細につい
ては、サブディビジョンサーフェスから未使用の頂点を削除する (32 ペー
ジ)を参照してください。

■ スケルトンをモデルにバインドするときは、レベル 0 または 1 などの粗いレ
ベルでバインドします。詳細については、サブディビジョンサーフェスをス
ケルトンにバインドする (47 ページ)を参照してください。

関連項目
■ 新しいサブディビジョンレベルを作成する (17 ページ)

■ サブディビジョンサーフェスのレベルの数を減らす (31 ページ)

■ サブディビジョンサーフェスから未使用の頂点を削除する (32 ページ)

サブディビジョンサーフェスをクリーンアップ
する

サブディビジョンサーフェスのレベルの数を減らす
階層のコラプス（Collapse Hierarchy）機能を使用して、サブディビジョンサー
フェスのレベル数を削減することができます。階層のコラプス（Collapse
Hierarchy）はサーフェスの元のシェイプを保持しますが、結果としてサブディ
ビジョンの編集内容を細かいレベルから粗いレベルへ移行し、粗いレベルの密度
が上がります。

たとえば、メッシュの編集 > ポリゴンのスプリットツール（Edit Mesh > Split
Polygon Tool）を使用して、より細かなレベルにあるフェースのトポロジを変
更することができます。このようなトポロジ変更は、メッシュのベースレベル

| 31



（レベル 0）のみで実行できます。メッシュのレベル 0 でより細かな LOD が表
示されるように階層をコラプスすると、ポリゴンプロキシモードに切り替えて、
ベースレベルでの編集を実行できます。

サブディビジョン レベルをコラプスするには

1 サブディビジョンサーフェスを選択します。

2 サブディビジョンサーフェス > 階層のコラプス（Subdiv Surfaces > Collapse

Hierarchy） を選択します。

3 レベル数（Number of levels）の値を下げます。

たとえばレベルを 2 つ下げる場合、それまでのレベル 2 の頂点はレベル 0
の頂点に、レベル 3 の頂点はレベル 1 の頂点になります。

4 コラプス（Collapse）をクリックします。

関連項目
■ 新しいサブディビジョンレベルを作成する (17 ページ)

■ サブディビジョンサーフェスから未使用の頂点を削除する (32 ページ)

■ サブディビジョンサーフェス > 階層のコラプス（Subdiv Surfaces > Collapse
Hierarchy） (62 ページ)

サブディビジョンサーフェスから未使用の頂点を削
除する

トポロジのクリーニング（Clean Topology）を使用して、作成されたものの、
使用されていない頂点をサブディビジョンサーフェスから削除できます。余計
な未使用の頂点を削除すると、ファイルサイズが小さくなり、インタラクティ
ブなパフォーマンスが向上する効果があります。

たとえば、サブディビジョンサーフェスの領域を洗練したときに作成された頂
点のうち、一部のみを移動した場合、トランスフォームしていない頂点をトポロ
ジのクリーニングで削除できます。

サブディビジョン サーフェスで未使用の頂点を自動的に削減するには

1 未使用のため、削除したい頂点があるサーフェスを選択します。
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2 サブディビジョンサーフェス > トポロジのクリーニング（Subdiv Surfaces
> Clean Topology）を選択します。

サブディビジョンメッシュからすべての未使用頂点が削除されます。

注:

トポロジのクリーニング（Clean Topology）によって頂点が削除されるのは、
次の 3 つの条件がすべて満たされる場合に限ります。

■ 頂点の位置に対して編集が行われていない。つまり、フェースを移動した場
合、コネクトしている頂点は削除されません。

■ 頂点にコネクトされた UV に対してマッピングまたは編集が行われていな
い。つまり、頂点にテクスチャデータが適用された場合、頂点は削除されま
せん。

■ 頂点またはエッジに折り目が適用されていない

これらの条件を満たしていても、サーフェストのトポロジで必要であるという理
由からトポロジのクリーニングによって削除できない頂点があることもありま
す。

■ ブレンド シェイプ（Blend Shape）またはその他のデフォメーション作成後
にサブディビジョンサーフェス > トポロジのクリーニング（Subdiv Surfaces
> Clean Topology）を使用すると、サーフェス上に UV のない領域ができる
ことがあります。こうした領域ができるのは、コンストラクションヒストリ
にトポロジのクリーニングノードが存在している間にデフォーマにウェイト
を設定すると、頂点が作成されるためです。
デフォーマの作成後にトポロジのクリーニングを使用するのは避けてくださ
い。また、デフォーマ作成の妨げにならないよう、トポロジのクリーニング
を使用した後はヒストリを削除してください。
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関連項目
■ サブディビジョンサーフェスのレベルの数を減らす (31 ページ)

■ サブディビジョンサーフェス編集時のインタラクティブなパフォーマンスを
上げる (30 ページ)
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UV のマッピングと編集

サブディビジョンサーフェスの UV マッピング
UV は、2 次元のテクスチャ座標で、ポリゴンおよびサブディビジョンサーフェ
スメッシュの頂点コンポーネント情報とともに存在します。UV は、サーフェス
メッシュの 2 次元テクスチャ座標システムを定義し、サーフェス上のイメージテ
クスチャマップを配置しやすくするために存在します。UV は、テクスチャマッ
プ上のどのポイント（ピクセル）がメッシュ上のどのポイント（頂点）に対応す
るかを制御するマーカポイントとして機能します。UV テクスチャ座標のないポ
リゴンまたはサブディビジョンサーフェスに適用されるテクスチャは、レンダー
されません。

UV マッピングは、UV テクスチャ エディタ（UV Texture Editor ）に表示すると
きにテクスチャとして使用するビットマップイメージ上でサーフェスメッシュの
平面化（2 次元）表現を作成、編集、配置するプロセスです。UV マッピングプ
ロセスによって、イメージと、三次元サーフェスメッシュにマッピングされると
きにテクスチャとして表示される状態との相関関係がわかります。

Maya はデフォルトでは多数のプリミティブタイプに UV を作成しますが、ほと
んどの場合に UV を再配列する必要があります。これは通常、デフォルトの配置
は、作成したモデルに続けて編集を行うと、これにマッチしないためです。さら
に UV テクスチャ座標の位置は、サーフェスメッシュを編集するときに自動的に
更新されません。

ほとんどのケースでは、UV のマッピングと配置は、モデリングの完了後、モデル
にテクスチャを割り当てる前に行います。

4
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注: UV マッピングはポリゴンおよびサブディビジョンサーフェスの作成および
形状変更時に必ずしも必要ありません。テクスチャをポリゴンに適用する場合の
み、UV テクスチャ座標に注意する必要があります。

サブディビジョンサーフェスは、UV テクスチャ座標を持つという点でポリゴン
サーフェスに似ています。ただしサブディビジョンサーフェスには、ポリゴン
の機能とは別の、独自のマッピング機能と編集機能があります（ポリゴン機能で
UV をマッピングすることもできます。詳細については、UV をポリゴンプロキ
シモードで編集する (36 ページ)を参照してください）。

サブディビジョンサーフェスには、平面マッピング（Planar Mapping）と自動
マッピング（Automatic Mapping）の 2 つの UV マッピング機能があります。
これらの項目は、サブディビジョン サーフェス > テクスチャ（Subdiv Surfaces
> Texture）メニューにあります。これらは、UV の作成（Create UVs）メニュー
の平面マッピング（Planar Mapping）と自動マッピング（Automatic Mapping）
の機能と同等です。ただし、1 つの重要な違いは、サブディビジョン サーフェ
ス（Subdiv Surfaces）では 1 つの UV セットだけを使用するのに対して、ポリ
ゴンでは複数の UV セットを使用できるという点です。

最適に機能する UV マッピング配置をモデルに作成するには、適切な UV マッ
ピング配置が見つかるまで必要に応じて何回かマッピングを行います。

関連項目
■ UV マッピングの基礎知識

■ UV マッピングのヒント

■ UV テクスチャエディタの概要

■ UV をサブディビジョンサーフェスにマッピングする (38 ページ)

■ サブディビジョンサーフェス UV を編集する (41 ページ)

UV をポリゴンプロキシモードで編集する
ポリゴン プロキシ モード（Polygon Proxy Mode）または標準モード（Standard
Mode）のどちらでも UV の作成と編集を選択できます。

ポリゴン プロキシ モードを使用すれば、より多くの UV 編集機能を使用できま
す。ただし、UV はベースメッシュフェースに適用されるので、テクスチャが
ツイストして表示されることがあります。特に、ベースメッシュよりも著しく
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レベルが上の領域の場合です。標準モード（デフォルト）で UV を編集すれば、
テクスチャの見栄えが最適になります。

ポリゴン プロキシ モード から UV を使用するには

1 ポリゴンプロキシモードに切り替えます（サブディビジョンサーフェスを
右クリックして、ポリゴン（Polygon）を選択します）。

2 アトリビューションエディタ（Attribute Editor）を開いて、polyToSubdiv
タブをクリックします。

3 UV 処理（UV treatment）アトリビュートを次のように設定します。
■ UV（UVs）セクションの UV を標準モードで使用する場合はサブディ

ビジョン UV の維持（Keep Subd UVs）を選択します。

■ ポリゴンプロキシモードで編集中の UV を使用する場合は、ポリゴン
から UV を継承する（Inherit UVs from Poly）を選択します。UV はポ
リゴンプロキシモードを終了するとサーフェスにコピーが戻されます。

■ このサーフェスでまったく UV を使用しない場合は、サブディビジョン
上に UV なし（No UVs on Subd）を選択します。これにより、サーフェ
ス上の既存の UV が削除されます。

標準モードに切り替え、その後でポリゴン プロキシ モードに戻すと、UV 処理
アトリビュートはデフォルトでサブディビジョン UV の維持（Keep Subd UVs）
に戻ります。UV をもう一度ポリゴンプロキシモードで編集する場合は、UV
処理（UV Treatment）アトリビュートを再度変更する必要があります。

関連項目
■ ポリゴンツールを使用してサブディビジョンサーフェスを修正する(23ペー

ジ)

■ サブディビジョンサーフェス UV を編集する (41 ページ)
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UV をサブディビジョンサーフェスにマッピン
グする

マッピングするフェースを選択するには

 ➤ 標準モード（Standard Mode）で、サブディビジョンサーフェスのチャン
ネルボックスの表示レベル（Display Level）を選択します。

■ サブディビジョンレベル間の切り替え (19 ページ)
マッピングしたいフェースが含まれるレベルに切り替えます。たとえば、サー
フェス全体をマッピングする場合は、レベル 0 に切り替えて、サーフェス全
体に渡るフェースを選択することができます。

選択したレベルの選択したフェースが最も細かいレベルに変換され、それら
のフェースにマッピングが適用されます。

たとえば、レベル 0 のフェースがレベル 3 に変更される場合、マッピングは
レベル 3 のフェースに適用されます。より細かいレベルがない場合は、カレ
ントレベルの選択したフェースにマッピングが適用されます。

 ➤ サーフェスのフェースの全部または一部を選択します。

フェースが選択されていない場合、マッピングは行われません。ポリゴン
にマッピングするときとは異なり、自動的にはフェースコンポーネント
モードに変わりません。

平面マッピングでは、UV を単一方向に投影することによってサーフェスに UV
を割り当てます。UV は、投影がサーフェスと交差する位置に割り当てられま
す。

このマッピング方法では、UV シェルの量は少なく保たれます。ただし、サー
フェスの両面に UV が投影されるので、UV シェルが重複します。結果として、
UV レイアウト（Layout UVs）を使用して、オーバーラップする UV を分離す
る必要があるでしょう。

UV を平面マッピング（Planar Mapping）でマッピングするには

1 サブディビジョンサーフェス > テクスチャ > 平面マッピング（Subdiv

Surfaces > Texture > Planar Mapping） を選択します。
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2 オプションを設定します。ほとんどの場合、少なくともマッピング方向
（Mapping direction）を変更する必要があります。マッピング方向では、
マッピングプレーンの方向を制御します。

3 投影（Project）をクリックします。

重複を回避するため、自動マッピングでは、同時に複数のプレーンから内側に
UV を投影することによってサーフェスに UV を割り当てます。UV は、投影が
サーフェスと交差する位置に割り当てられます。

UV を自動マッピング（Automatic Mapping）でマッピングするには

1 サブディビジョンサーフェス > テクスチャ > 自動マッピング（Subdiv

Surfaces > Texture > Automatic Mapping） を選択します。

2 オプションを設定します。

3 投影（Project）をクリックします。

このマッピング方法によって UV の重複は回避されますが、UV の小さなシェル
が多数作成されます。そのため、小さな UV シェルを大きなシェルに結合する必
要があります（たとえば、指に対応するシェルを手のひらに対応するシェルに結
合する場合など）。

隣接するフェースの UV が論理的な方法で結合されているときは、モデルにテク
スチャを作成するのは簡単です。UV シェルを結合するには、UV の編集 > UV
のマージ（Edit UVs > Merge UVs）とUV の編集 > UV エッジの縫合（Edit UVs
> Sew UV Edges）を使用します。

投影プレーンのサイズを変更する、または回転するには

1 UV テクスチャ エディタ（UV Texture Editor）（ウィンドウ > UV テクス
チャエディタ（Window > UV Texture Editor））を開きます。

マッピングされた UV を UV テクスチャエディタで確認する必要がありま
す。

2 サーフェスに投影マニピュレータを使用して、次の操作を行います。

■ コーナーをドラッグしてプレーンのサイズを変更します。

■ 赤いラインをクリックして、トランスフォームマニピュレータツールを表
示し、プレーンを回転または反転させます。
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マニピュレータが表示されない場合は、チャンネル ボックスで subdPlanarProj
を選択します。

例

マニピュレータ

長い魚のモデルにマッピングする場合、UV シェルはスクエアにフィットするよ
うにデフォルトで引き伸ばされます（次の図を参照してください）。シェイプが
引き伸ばされると、モデル上のテクスチャも引き伸ばされて見えます。

これを回避するには、UV シェルが（長い魚のモデルのような）長方形になるま
で投影マニピュレータのサイズを変更します。

フェースを選択する

左の図では、レベル 0 のフェースが選択されマップされています。得られる UV
シェルは丸みがありますが、逆 T 字形のラインも表示されています。他のライ

40 |  UV のマッピングと編集



ンは、レベル 0 で選択したフェースに対応しています。これらのラインは、そ
のフェースが選択状態であるために表示されています。他の部分を選択すると、
表示されなくなります。

右の図では、レベル 2 のフェースが選択されマップされています。作成された
UV シェルはオレンジ色で表示されており（選択されている状態）、弧のような
シェイプをしています。セクションが欠けた、逆 T 字形の UV シェルも表示さ
れています。この UV シェルは、レベル 1 のフェースに対応します。しかしデ
フォルトの UV 配置（逆 T 字形）は実際にマップされていないため、表示され
たままです。つまり、レベル 2 のフェースだけがマップされたことになります。

関連項目
■ サブディビジョンサーフェス UV を編集する (41 ページ)

■ サブディビジョンサーフェス > テクスチャ > 平面マッピング（Subdiv
Surfaces > Texture > Planar Mapping） (51 ページ)

■ サブディビジョンサーフェス > テクスチャ > 自動マッピング（Subdiv
Surfaces > Texture > Automatic Mapping） (53 ページ)

サブディビジョンサーフェス UV を編集する
UV テクスチャ エディタ（UV Texture Editor）（ウィンドウ > UV テクスチャ
エディタ（Window > UV Texture Editor））では、ポリゴンとサブディビジョ
ンサーフェスとで別々のメニューが用意されています。サブディビジョンサー
フェスの UV を編集するときはサブディビジョンサーフェス（Subdivs）メニュー
の下のメニュー項目を使用します。

UV テクスチャ エディタのサブディビジョンサーフェスメニューの項目は、エ
ディタのポリゴン（Polygons）メニューの対応する項目と同じ動作をします。

次のメニュー項目以外は、すべてのメニュー項目を使用することができます。

■ ビュー > 内蔵されたフェースの表示（View > View Contained Faces）と
ビュー > コネクトされたフェースの表示（View > View Connected Faces）

手順結果

ディスプレイ > サブディビジョンサー
フェス（Display > Subdiv Surfaces）UV

UV 境界をテクスチャエディタでよりはっ
きりと表示します。

の境界（テクスチャ エディタ（Texture
Editor））を選択します。
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手順結果

UV テクスチャ エディタで、作成したい
新しい境界に沿ったエッジを選択し、サ

UV シェルを小さなシェルに分けます。

ブディビジョン サーフェス > UV エッジ
のカット（Subdivs > Cut UV Edges）を
選択します。

UV テクスチャエディタでそれぞれの UV
シェルの共通エッジを選択し、サブディ

それぞれの UV シェルを手動でアタッチ
します。

ビジョン サーフェス > 移動して UV エッ
ジの縫合（Subdivs > Move and Sew UV

Edges） を選択します。
ピース サイズの制限（Limit Piece Size）
をオフにして、適用（Apply）ボタンをク
リックします。

UV テクスチャエディタで、すべての UV
シェルのすべてのエッジを選択し、サブ

それぞれの UV シェルを自動的にアタッ
チします。

ディビジョン サーフェス > 移動して UV
エッジの縫合（Subdivs > Move and Sew

UV Edges） を選択します。
ピース サイズの制限をオンにし、フェー
ス数（Number of Faces）を UV シェル
が所有するフェースの最小数に設定しま
す。
たとえば、2 を設定すると、所有する
フェースが 2 つ以下のシェルだけが移動、
縫合されます。
適用（Apply）ボタンをクリックします。

UV テクスチャエディタでサブディビジョ
ン サーフェス > UV のスナップショット

テクスチャをペイントする UV レイアウ
トのイメージを作成します。

（Subdivs > UV Snapshot）を選択しま
す。オプションはポリゴン > UV のスナッ
プショット（Polygons > UV Snapshot）
と同じです。

ヒント: 移動して UV エッジの縫合（Move and Sew UV Edges）操作の実行
後、チャンネル ボックス（Channel Box）でヒストリノード
（subdMapSewMove）を選択し、必要な結果が得られるまでフェース数
（Number of Faces）を調整することができます。

42 |  UV のマッピングと編集



関連項目
■ サブディビジョンサーフェス > テクスチャ > UV レイアウト（Subdiv Surfaces

> Texture > Layout UVs） (56 ページ)
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サーフェスメッシュのス
カルプト

サブディビジョンサーフェスでジオメトリのス
カルプト ツールを使用する

ジオメトリのスカルプト ツール（Sculpt Geometry Tool）を使用すると、ブラシ
ストロークだけで NURBS、ポリゴンまたはサブディビジョンサーフェスを手動で
すばやくスカルプトすることができます。ジオメトリのスカルプト ツールを使っ
てサーフェスメッシュをペイントすれば、複数の CV（NURBS）または頂点（ポ
リゴンおよびサブディビジョンサーフェス）を押し込んだり引き出したりするだ
けで目的のシェイプを完成させることができます。

ジオメトリのスカルプト ツールは、Maya ® Artisan™ ツールに基づくものです。
詳細については、『アーティザン』マニュアルの「アーティザンブラシツールの
仕組み」と『ポリゴン モデリング』マニュアルにある下記の関連項目を参照して
ください。

関連項目
■ ジオメトリのスカルプトツールの概要

■ NURBS サーフェスまたはポリゴンサーフェスのメッシュをスカルプトする

■ サーフェスメッシュをスムースする

■ サーフェススカルプトを消去して前の状態に戻す

■ NURBS 上のアトリビュートマップに従ってスカルプトする

5
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■ NURBS 上の継ぎ目やサーフェスエッジに渡ってスカルプトする

■ スカルプトによる変更をキーフレーム化する
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サブディビジョンサー
フェスのヒント

サブディビジョンサーフェスをスケルトンにバ
インドする

パフォーマンスを最適化するには、スケルトンをサブディビジョンサーフェスの
粗いレベル（1 つのレベルにだけ）にバインドします。これにより、通常はデフォー
マとジョイントが移動するにつれてサーフェスが十分に変形します。デフォーマ
の補間によるサーフェスの変形はスムースなままで、ウェイトを割り当てる頂点
数が少なくなります。

細かいレベルで編集されたディテールは、サーフェスが変形するとき、スケルト
ンがバインドされた粗いレベルに従います。これによってしわや斑点などのスキ
ンのディテールがスムースにブレンドされます。たとえば、細かいレベルでモデ
リングされた指の最表層のしわは、指の関節を曲げると引き伸ばされます。

バインドする前に、次のことを行います。

■ サブディビジョンサーフェス上で行ったトランスフォームを固定し、サブディ
ビジョンサーフェスで行う非均一なスケーリングによって、バインド後に異常
な歪みが生じないようにします。

■ ヒストリを削除します。特に、既にバインドされたことのあるサブディビジョ
ンサーフェスの場合には注意してください。

■ 標準モードになっていることを確認します。
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サブディビジョンサーフェスにデフォーマを適
用する

オブジェクトとして選択したサブディビジョンサーフェスにデフォーマを適用
するときは、デフォーマをベース（レベル 0）の頂点に適用します。デフォーマ
を別のレベルに適用するには、そのレベルの頂点を選択してからデフォーマを適
用します。ブレンドシェイプはどのレベルの頂点にも割り当てることができま
す。

■ デフォーマを削除した後ポリゴン プロキシ モード（Polygon Proxy mode）
に切り替えられない場合は、ヒストリを削除するか、またはディペンデンシー
グラフで入力ジオメトリを検出して削除します。

■ 異なるレベルでサーフェスの同じ部分にデフォーマがある場合は注意してく
ださい。ペアレント化しない状態で、デフォーマのベースでトランスフォー
ムが二重に行われる可能性があります。

■ 同じデフォーマに異なるレベルの頂点がないようにします。たとえば、レベ
ル 1 で完全な折り目を作成し、ワイヤデフォーマをオブジェクトサーフェ
ス（レベル 0）近くに適用してからワイヤまたはその頂点を移動すると、ワ
イヤをレベル 1 の頂点に適用した場合とは効果が非常に異なります。

■ 変形の結果が適切でない場合は、バインドを解除してヒストリを削除し、1
階層細かいレベルで再度バインドします。

■ レベル 1 より上位の階層レベルでスケルトンをサブディビジョンサーフェス
にバインドした場合に、すべての頂点が移動されないことがあります。これ
は、そのレベルの頂点がすべて選択されていないか、またはバインドする前
に作成されたものでないためです。すべての頂点が選択されていることを確
認するには、レベル 0 または 1 に移動し、頂点をすべて選択してから必要な
レベルまで階層レベルを上げ、すべての頂点を選択します。

■ レベル 2 におけるデフォーマはレベル 1 でのデフォメーションにオーバーラ
イドさせることができます。たとえば、レベル 1 にウェイト付けしたクラス
タがあり、レベル 2 にブレンドシェイプがある場合、ブレンドシェイプの
ウェイトが 1 に設定されると、クラスタのデフォメーションが消えます。最
も細かいレベルまたはその他のデフォーマと同じレベルにブレンドシェイプ
を割り当ててみてください。また、デフォメーションの順序を変更してみる
こともできます。
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■ レベル 1 のデフォーマで、細かなレベルのデフォーマからサーフェスを移動
することができます（たとえば、レベル 2 のラティスの場合、レベル 2 と 3
のサーフェスの同じ部分にラティスがあると、レベル 3 のラティスの範囲か
らサーフェスが引き出されます）。

■ サブディビジョンサーフェスにデフォーマとスケルトンがあるときにポリゴ
ンプロキシモードに切り替えると、サーフェスのバインドが解除され、ウェ
イトがなくなります。

サブディビジョンサーフェス用にブレンドシェイプとクラスタデフォー
マを作成する

サブディビジョンサーフェスのブレンドシェイプを作成するには、オブジェク
トを選択するか、特定のレベルの頂点を選択します。オブジェクトを選択する場
合、サーフェスの全レベルのすべての頂点がブレンドされます。特定のレベルの
頂点を選択する場合は、それらの頂点だけがブレンドされます。

サブディビジョンサーフェスのクラスタを作成するには、クラスタに含める頂
点を完全に取り囲む行状の頂点が必要です。これらの余分な頂点は、クラスタそ
のものの中にあってはいけませんが、サーフェス上には存在している必要があり
ます。余分な行がないと、クラスタ内の頂点へウェイトを割り当てるときに問題
が生じます。

追加の列が存在しない場合は、その頂点を選択してサブディビジョンサーフェ
ス > 選択したコンポーネントの拡大（Subdiv Surfaces > Expand Selected
Components）を選択します。

サブディビジョンサーフェスのレンダリング
レンダーしたサーフェスの精度を洗練するには、サブディビジョンサーフェス
のアトリビュート エディタ（Attribute Editor）のテッセレーション
（Tessellation）セクションで設定を洗練します。また、サブディビジョンサー
フェスではディスプレイスメントマップも使用できます。

非常に細かいテッセレーションが行われたポリゴンを作成することもできます。
極端な例として、10 個の四角形でできたベースメッシュの均一（Uniform）
テッセレーションで、デプス（Depth）とサンプル数（Sample Count）を 10
に設定すると、約 10 億個の三角形が作成されます。
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フォーマット（Format）
次のテッセレーション方法のいずれかを選択します。

均一（Uniform） 均一テッセレーションを選択すると、サブディビジョンサー
フェスのベースメッシュの各フェース（レベル 0 のフェース）ごとに同数の
フェースがあるポリゴンが生成されます。

適応（Adaptive） 適応テッセレーションを選択すると、サブディビジョンサー
フェス上の最も細かいレベルの各フェースに同数のフェースがあるポリゴンが生
成されます。サブディビジョンサーフェスの領域を精緻化するほど、得られる
ポリゴンは、その同じ領域により多くのフェースを含みます。テッセレーション
を増やすには、サンプル数（Sample Count）を使用します。

デプス（Depth） 均一テッセレーションの場合だけは、レベルを設定し、テッ
セレーションに使用するフェース数を指定します。たとえば、デプスが 3 の場
合は、レベル 3 のフェース数がテッセレーションで使用されます。

サンプル数（Sample Count） 各フェースを分割する回数を指定します。この値
を大きくすると、ポリゴンサーフェスがスムースになります。
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サブディビジョンサー
フェスメニュー

サブディビジョン サーフェス（Subdiv
Surfaces）

サブディビジョンサーフェス > テクスチャ > 平面マッ
ピング（Subdiv Surfaces > Texture > Planar
Mapping）

UV を一定方向に投影して、サブディビジョンサーフェスにマッピングします。

関連項目
■ UV をサブディビジョンサーフェスにマッピングする (38 ページ)

サブディビジョン サーフェス > テクスチャ > 平面マッピング（Subdiv

Surfaces > Texture > Planar Mapping）

スマートフィット（Smart Fit）はデフォルトでオンに設定されており、投影マニ
ピュレータは自動的に配置されます。投影マニピュレータに正確な値を指定した
い場合は、スマート フィットをオフに設定し、投影のセンター（Projection
center）、投影の回転（Projection rotation）、投影の幅（Projection width）、
投影の高さ（Projection height）の各設定の値を変更することができます。
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最適プレーンに（Fit to Best Plane） オブジェクトの一部のフェースに UV を
マッピングしたい場合は、最適プレーンにをオンに設定します。投影マニピュ
レータは、選択したフェースに最も適した角度と回転にスナップされます。

バウンディング ボックスに（Fit to Bounding Box） このオプションは、オブ
ジェクトのすべてまたはほとんどのフェースに UV をマッピングする場合に最適
に機能します。投影マニピュレータは、オブジェクトのバウンディングボック
ス内にフィットするようにスナップされます。このオプションをオンにする場合
は、マッピング方向（Mapping direction）のいずれかのオプションを選択し
て、投影マニピュレータの方向を設定する必要があります。

マッピング方向（Mapping direction） 投影マニピュレータがオブジェクトのほ
とんどのフェースと同じ方向を向くように、軸を選択します。たとえば、グリッ
ド上に横たわっている亀のモデルではほとんどのフェースが Y 軸方向を向いて
いますが、グリッド上に立っている馬のモデルではほとんどのフェースが X 軸
または Z 軸方向を向いています。

モデルのフェースのほとんどが X、Y、Z 軸のいずれの方向も向いていない場合
は、カメラ（Camera）を選択できます。このオプションは、現在アクティブに
なっているビューに基づいて投影マニピュレータを配置します。

デフォーマ前に挿入（Insert Before Deformers） デフォーマ前に挿入オプショ
ンは、オブジェクトにデフォメーションが適用されている場合に関係します。こ
のオプションをオフに設定してデフォーマによる変形をアニメートすると、頂点
位置が変化してテクスチャの配置が影響を受けるため、テクスチャがジオメトリ
から「浮遊する」原因になります。

このオプションをオンに設定すると、テクスチャの配置がオブジェクトに適用さ
れた後で、デフォメーションが適用されるようになります。基本的に、テクス
チャ配置ディペンデンシーグラフノードは、デフォーマディペンデンシーグ
ラフノードの前に挿入されるため、変形が適用された後もテクスチャはジオメ
トリに「スティッキー」になります。

イメージのセンター（Image Center） この値は、投影される UV の中心を示し
ています。この値を変更すると、それに応じて中心が移動します。

イメージ回転（Image Rotation） この値を変更して、2D ウィンドウ内で UV
が回転する角度を変更します。スライダをドラッグするか、または値を直接入力
してイメージを回転させます。

イメージ スケール（Image Scale） この値は、2D マッピングの幅（U）や高さ
（V）を 2D の中心ポイントを基準にして設定します。
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イメージ比率の維持（Keep Image Ratio） このオプションをオンに設定してイ
メージの幅と高さの比率を維持し、イメージが歪められないようにします。この
オプションをオフに設定すると、UV テクスチャ エディタ（UV Texture Editor）
の 0 ～ 1 の座標がマッピングされた UV で埋められます。

スマートフィットをオフに設定すると、次のオプションが使用可能になります。
値を入力して、投影のセンター、投影の回転、投影の高さ、投影の幅を変更する
ことができます。テクスチャを投影した後は、チャンネル ボックスまたはアト
リビュート エディタ（Attribute Editor）からこれらの値を変更することができ
ます。また、対応するマニピュレータハンドルを使用して、マッピングをイン
タラクティブに洗練することもできます。

投影のセンター（Projection center） 投影のセンターは、テクスチャマッピン
グを投影するときの基準となる X、Y、Z 軸の原点を定義します。デフォルトで
は、選択したフェースの中心が X、Y、Z 軸の原点になります。

投影の回転（Projection rotation） X、Y、Z 軸を中心に 3D ビュー内で投影を
回転させる（後でテクスチャを回転させることになる）値を入力します。

投影の幅（Projection Width） 3D の投影軸に対して投影の幅（U）を調整しま
す。

投影の高さ（Projection Height） 3D の投影軸に対して投影の高さ（V）を調整
します。

サブディビジョンサーフェス > テクスチャ > 自動マッ
ピング（Subdiv Surfaces > Texture > Automatic
Mapping）

UV テクスチャ座標を、選択したサブディビジョンサーフェスに複数の角度から
同時に投影します。

関連項目
■ UV をサブディビジョンサーフェスにマッピングする (38 ページ)
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サブディビジョン サーフェス > テクスチャ > 自動マッピング（Subdiv

Surfaces > Texture > Automatic Mapping）
プレーン（Planes）: 投影元のプレーンの数を選択します。多数のプレーンを使
用するほど歪みの発生が少なくなり、多数の UV シェルが作成されます。4 面
体、5 面体、6 面体、8 面体、または 12 面体を基準にして投影マッピングを選
択することができます。

最適化（Optimize）
投影をどのように最適化するかを選択します。

より少ないゆがみ（Less Distortion） すべてのプレーンを均等に投影します。
この方法でどのようなフェースにも最適な投影を行うことができますが、最終的
にピースが増える場合もあります。対称形のモデルについて投影のピースが対称
となるようにしたい場合に、このオプションは特に便利です。

より少ないピース数（Fewer Pieces） 理想的な投影角度が得られるなくなるま
で、各プレーンの投影を続けます。この結果、ピースが拡大され、数が少なくな
ります。

シェル レイアウト（Shell layout）
テクスチャ空間内で、UV ピースを配置する位置を選択します。

U に沿って（Along U） ピースを U 軸に沿って配置します。

スクエアに（Into Square） 0 ～ 1 の UV テクスチャ空間内にピースを配置しま
す。

スケール モード（Scale Mode）
テクスチャ空間内で、どのように UV ピースをスケールするかを選択します。

なし（None） スケーリングは行いません。

均一（Uniform） 高さと幅の比率を変更しないで、0 ～ 1 のテクスチャ空間内
にフィットするようピースをスケールします。

スクエアに伸長（Stretch to Square） 0 ～ 1 のテクスチャ空間にフィットする
ようにピースをストレッチします。ピースが歪むこともあります。

シェルのスタッキング（Shell stacking）
UV シェルを UV テクスチャ エディタ（UV Texture Editor）に配置する時に、
お互いにどのような関係でスタックされるかを定義します。

バウンディング ボックス（Bounding Box） 各 UV シェルの周囲に長方形のバ
ウンディングボックスを作成し、バウンディングボックスの境界に基づいてシェ
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ルをスタックします。このオプションを設定すると、UV シェル間のスペースは
より広くなります。

シェイプ（Shape） 個々のシェルの境界に基づいて、UV シェルをスタックしま
す。このオプションを設定すると、UV シェルをより密接に配置して、使用可能
な任意のスペースに合わせることができます。

間隔のプリセット（Spacing Presets） ピースの周囲にバウンディングボックス
を配置し、バウンディングボックスどうしが接近するようにレイアウトします。
シェルが最終的にぴったり隣リ合わせに配置されると、異なるシェルにある 2
つの UV が同じピクセルを共有する可能性があり、3D ペイント ツール（3D
Paint Tool）でテクスチャをペイントする時に、オーバースキャンにより隣接す
るシェルにペイントがはみ出してしまうことがあります。

この状態を避けるには、このメニューから間隔のプリセットを選択して、バウン
ディングボックス間にピクセルが少なくとも 1 つあるようにします。テクスチャ
マッピングのサイズに対応するプリセットを選択します。サイズがわからない場
合は、小さめのマップを選択して、UV 空間で隣接するシェルの間隔を大きくし
ていくようにします（ピクセルで表されたマップが小さいほど、バウンディン
グボックス間の UV の間隔が大きくなります）。

カスタム（Custom）を選択し、マップのサイズに対するパーセンテージで間隔
の大きさを（パーセンテージ空間（Percentage Space）フィールドで）設定し
ます。

パーセンテージ空間（Percentage Space） 間隔のプリセット（Spacing Preset）
でカスタム（Custom）を選択した場合は、マップのサイズに対するパーセンテー
ジでバウンディングボックスの間隔の大きさを入力します。

注: 自動マッピング投影を実行すると、その投影に関する プレーン（Plane）、
最適化（Optimize）、レイアウト（Layout）、スケール（Scale）の各設定を
チャンネル ボックスで変更できるようになります。ただし、これらの設定変更
は、テクスチャのペイント後に行わないでください。UV が大幅に変更される場
合があります。
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サブディビジョン サーフェス > テクスチャ > UV レ
イアウト（Subdiv Surfaces > Texture > Layout UVs）

UV レイアウト（Layout UVs）機能は、UV がテクスチャ空間内でオーバーラッ
プしないように、自動的に UV を移動します。

UV ピースを分離しておくことは、絶対に必要というわけではありません。たと
えば、さまざまなフェースがテクスチャの同じ領域を使用するように、UV を
オーバーラップしたい場合などです。ただし、一般的には、利便性と明確さのた
めにピースを分離したままにしてください。

関連項目
■ サブディビジョンサーフェス UV を編集する (41 ページ)

サブディビジョン サーフェス > テクスチャ > UV レイアウト（Subdiv

Surfaces > Texture > Layout UVs）

ほとんどの状況では、デフォルト設定を使用すると最適な結果が得られます。

分離（Separate） 重複する UV ピースの切り離し方法を選択します。

オフ（Off）
重複するピースを切り離しません。スケール（Scale）オプションにだけ有効で
す。

フォールド部（Folds） 重複するピースのサーフェス法線が、反対方向を指して
いるピースのみを切り離します。この方法を使用すると作業が速くでき、特に大
きなモデルには有効ですが、重複する UV が残る場合があります。

インターセクトのみ（All Intersecting） UV が重複しているピースをすべて切
り離します。

裏返しをフリップ（Flip Reversed） このオプションをオンに設定して、法線が
反対方向を指しているピースを逆転させます。

ヒント: モデルが対称形の場合は（たとえば、人物の顔など）、テクスチャ空間
を保存することができます。そのためには、このオプションをオフに設定して
UV ピースを重ね、それらのピースが同じテクスチャ空間内にあるようにしま
す。
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レイアウト（Layout）
テクスチャ空間内で、UV ピースを配置する位置を選択します。

なし（None） ピースを切り取った後はピースをレイアウトしません。一部の
ピースが別のピースの上に重なる場合があります。

U に沿って（Along U） ピースを U 軸に沿って配置します。

スクエアに（Into Square） 0 ～ 1 のテクスチャ空間内にピースを配置します。

スケール（Scale）
テクスチャ空間内で、どのように UV ピースをスケールするかを選択します。

なし（None） スケーリングは行いません。

均一（Uniform） 高さと幅の比率を変更しないで、0 ～ 1 のテクスチャ空間内
にフィットするようピースをスケールします。

スクエアに伸長（Stretch to Square） 0 ～ 1 のテクスチャ空間にフィットする
ようにピースをストレッチします。ピースが歪むこともあります。

間隔のプリセット（Spacing Presets） ピースの周囲にバウンディングボックス
を配置し、バウンディングボックスどうしが接近するようにレイアウトします。
ピースが最終的にぴったり隣リ合わせに配置されると、異なるピースにある 2
つの UV が同じピクセルを共有できるので、テクスチャペインティングの際に、
隣り合うピースにオーバースキャンのため過剰にペイントされる可能性がありま
す。

この状態を避けるには、このメニューから間隔のプリセットを選択して、バウン
ディングボックス間にピクセルが少なくとも 1 つあるようにします。テクスチャ
マッピングのサイズに対応するプリセットを選択します。サイズがわからない場
合は、小さめのマップを選択して、UV 空間で隣り合うピースの間隔を大きくし
ていくようにします（ピクセルで表されたマップが小さいほど、バウンディング
ボックス間の UV の間隔が大きくなります）。

カスタム（Custom）を選択し、マップのサイズに対するパーセンテージで間隔
の大きさを（パーセンテージ空間（Percentage Space）フィールドで）設定し
ます。
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パーセンテージ空間（Percentage Space） 間隔のプリセットでカスタムを選択
した場合は、マップのサイズに対するパーセンテージでバウンディングボック
スの間隔の大きさを入力します。

サブディビジョンサーフェス > エッジ/頂点に完全な
折り目をつける（Subdiv Surfaces > Full Crease
Edge/Vertex）

エッジ/頂点に完全な折り目をつける（Subdiv Surfaces > Full Crease
Edge/Vertex）で、メッシュの選択した領域にエッジシェイプの起伏を適用し
て、サブディビジョンサーフェスの外観を修正します。

サーフェス上に鋭角なエッジやトランジションが必要な場合、折り目を適用する
と便利です。部分的な折り目を適用したり、サーフェス領域に付けた折り目を解
除したりすることもできます。完全な折り目を付けて生成された起伏は、部分的
な折り目よりもサーフェスの起伏が目立ちます。

関連項目
■ サブディビジョンサーフェスの折り目を適用または削除する (21 ページ)

サブディビジョンサーフェス > エッジ/頂点に部分的
に折り目をつける（Subdiv Surfaces > Partial Crease
Edge/Vertex）

エッジ/頂点に部分的に折り目をつける（Partial Crease Edge/Vertex）で、メッ
シュの選択した領域にエッジシェイプの起伏を適用して、サブディビジョンサー
フェスの外観を修正します。

サーフェス上に鋭角なエッジやトランジションが必要な場合、折り目を適用する
と便利です。完全な折り目を適用したり、サーフェス領域に付けた折り目を解除
したりすることもできます。部分的な折り目を付けて生成された起伏は、完全な
折り目よりもサーフェス上の起伏が目立ちません。
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関連項目
■ サブディビジョンサーフェスの折り目を適用または削除する (21 ページ)

サブディビジョンサーフェス > エッジ/頂点の折り目
を解除（Subdiv Surfaces > Uncrease Edge/Vertex）

エッジ/頂点の折り目を解除（Uncrease Edge/Vertex）は、部分的、または完全
な折り目の起伏を、サブディビジョンサーフェスの選択した領域から削除しま
す。

関連項目
■ サブディビジョンサーフェスの折り目を適用または削除する (21 ページ)

サブディビジョン サーフェス > ミラー（Subdiv
Surfaces > Mirror）

サーフェスをミラーコピーするときに基準とする軸をオンに設定し、ミラー
（Mirror）ボタンまたは適用（Apply）ボタンをクリックします。デフォルトで
は、サーフェスの複製とフリップは X 軸を基準にして行われます。

サーフェスをトランスフォームしてその変形を固定してから（修正 > トランス
フォームのフリーズ（Modify > Freeze Transformations）を選択）ミラーコ
ピーを行うと、サーフェスは選択した軸を基準にしてミラーコピーされます。
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サーフェスをミラーコピーした後にマージしようとする場合は、オリジナルサー
フェスを原点に対して並べ、トランスフォームを固定してからミラーコピーを実
行します。

サブディビジョン サーフェス > アタッチ（Subdiv
Surfaces > Attach）

2 つのサブディビジョンサーフェスをマージして新しいサブディビジョンサー
フェスを作成します。

関連項目
■ サブディビジョンサーフェスをアタッチする (28 ページ)

サブディビジョン サーフェス > アタッチ（Subdiv Surfaces > Attach）

UV もマージ（Merge UVs Also） アタッチするエッジが共有する UV をマージ
します。オフに設定すると、UV はマージされず、UV を別々に操作および編集
することができます。
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しきい値（Threshold） この値を超える距離にある頂点はアタッチされません。
この値は注意して設定してください。小さすぎると、どの頂点もアタッチされま
せん。大きすぎると、アタッチする必要のない頂点までアタッチされることがあ
ります。

オリジナルの維持（Keep Originals） アタッチしようとする元の各サーフェス
を Maya が維持するかどうかを制御します。

サブディビジョン サーフェス > トポロジのマッチン
グ（Subdiv Surfaces > Match Topology）

トポロジのマッチング（Match Topology）は、デフォーマの作成 > ブレンド
シェイプ（Create Deformers > Blend Shape）と連動して機能します。通常、ト
ポロジのマッチングはブレンド シェイプの作成操作によって自動的に実行され
るので、トポロジのマッチングを実行する必要はありません。

トポロジのマッチングは、異なるポーズのキャラクタの頭のコピーなど、複数の
サブディビジョンサーフェスをブレンドする準備をします。サブディビジョン
サーフェスをブレンドするには、各サーフェスについて全レベルに同数の頂点が
ある必要があります。トポロジのマッチングを実行すると、選択したすべてのオ
ブジェクトの頂点が一致するように必要に応じて頂点が追加されます。
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トポロジのマッチングはブレンド シェイプの作成操作によって自動的に実行さ
れるので、ユーザがトポロジのマッチングを実行する必要はありません。トポロ
ジのマッチングを実行するのは、ブレンドシェイプの作成操作を実行する前に
結果を確認したい場合だけにしてください。ただし、トポロジのマッチングを
ユーザが実行すると、シェイプをブレンドする際のシステムパフォーマンスは
低速になります。

トポロジのマッチングを実行する場合、まず複数のサーフェスを任意の順序で選
択します。サーフェスには、レベル 0 でのフェースと同じ数だけフェースが必
要です。レベルと同じ数は必要ではありません。

トポロジのマッチングは、頂点を追加するだけです。各サーフェスの頂点位置に
おける編集内容や折り目（折り目）を相互に一致させることはしません。

サブディビジョン サーフェス > トポロジのクリーニ
ング（Subdiv Surfaces > Clean Topology）

トポロジのクリーニング（Clean Topology）は、作成したものの、修正されて
いない頂点をサブディビジョンサーフェスから削除します。余計な未使用の頂
点を削除すると、ファイルサイズが小さくなり、インタラクティブなパフォー
マンスが向上する効果があります。

関連項目
■ サブディビジョンサーフェスから未使用の頂点を削除する (32 ページ)

サブディビジョン サーフェス > 階層のコラプス
（Subdiv Surfaces > Collapse Hierarchy）

レベル数（Number of levels）で下げるレベルの数を設定して、コラプス
（Collapse）ボタンまたは適用（Apply）ボタンをクリックします。たとえば、
2 を入力すると、レベル 2 の編集内容がレベル 0 の編集内容になります。

関連項目
■ サブディビジョンサーフェスのレベルの数を減らす (31 ページ)
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サブディビジョン サーフェス > 標準モード（Subdiv
Surfaces > Standard Mode）

標準モード（Standard Mode）は、サブディビジョンサーフェスを一般的な形
式で表示するサブディビジョンサーフェスの表示モードです。

サブディビジョンサーフェスを標準モードで操作する場合、次を実行できます。

■ 使用しているモードでディテールを増やす必要がある場合、サブディビジョ
ンサーフェスの選択した領域に洗練レベルを追加できます。
洗練レベルを追加すると、選択領域を細分割することによって、頂点がサー
フェスに追加されます。

■ 既存の洗練レベルを切り替えることができます。

■ 洗練したコンポーネントを操作（移動、回転、スケール）し、そのサーフェ
スにキーフレームを設定することができます。

■ マーキングメニューを使用して、モデリングのいかなる段階でも標準モード
とポリゴン プロキシ モード（Polygon Proxy mode）を切り替えられます。

関連項目
■ 標準モードとポリゴンプロキシモード (4 ページ)

■ サブディビジョンサーフェス > ポリゴンプロキシモード（Subdiv Surfaces
> Polygon Proxy Mode） (63 ページ)

サブディビジョン サーフェス > ポリゴン プロキシ
モード（Subdiv Surfaces > Polygon Proxy Mode）

ポリゴン プロキシ モード（Polygon Proxy mode）は、サブディビジョンサー
フェスのベースメッシュ（レベル 0）に対応するポリゴンメッシュを表示する
サブディビジョンサーフェスの表示モードです。

ポリゴン プロキシ モードでは、次を実行できます。

■ ポリゴンツールを使用して、サブディビジョンサーフェスを編集できます。
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■ マーキングメニューを使用して、モデリングのいかなる段階でもポリゴン
プロキシ モードと標準モード（Standard Mode）を切り替えられます。

関連項目
■ 標準モードとポリゴンプロキシモード (4 ページ)

■ サブディビジョンサーフェス > 標準モード（Subdiv Surfaces > Standard
Mode） (63 ページ)

サブディビジョン サーフェス > ジオメトリのスカル
プト ツール（Subdiv Surfaces > Sculpt Geometry
Tool）

NURBS、ポリゴン、およびサブディビジョンサーフェスをスカルプトするに
は、このツールを使用します。このツールは、Maya Artisan ツールに基づいて
います。詳細については、『アーティザン』マニュアルの「アーティザンブラ
シツールの仕組み」と、次の関連項目を参照してください。

ジオメトリのスカルプト ツール（Sculpt Geometry Tool）オプションについて
は、『ポリゴン モデリング』マニュアルの「メッシュ > ジオメトリのスカルプ
トツール（Mesh > Sculpt Geometry Tool）」を参照してください。

関連項目
■ ソフト選択の概要

■ NURBS サーフェスまたはポリゴンサーフェスのメッシュをスカルプトする

■ サーフェスメッシュをスムースする

■ サーフェススカルプトを消去して前の状態に戻す

■ NURBS 上のアトリビュートマップに従ってスカルプトする

■ NURBS 上の継ぎ目やサーフェスエッジに渡ってスカルプトする

■ スカルプトによる変更をキーフレーム化する
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サブディビジョン サーフェス > 選択項目をフェース
に変換（Subdiv Surfaces > Convert Selection to
Faces）

選択項目をフェースに変換（Convert Selection to Faces）により、現在のサブ
ディビジョンの選択項目を、現在のサブディビジョンレベルで選択されている
サブディビジョンコンポーネントにコネクトされる任意のフェースに変更しま
す。

ヒント: 選択項目の変換機能の多くは、サブディビジョンサーフェスコンポー
ネントを選択した状態で Ctrl + 右クリックすると表示される、状況に応じたサ
ブディビジョンサーフェスマーキングメニューから使用できます。

サブディビジョン サーフェス > 選択項目をエッジに
変換（Subdiv Surfaces > Convert Selection to
Edges）

選択項目をエッジに変換（Convert Selection to Edges）により、現在のサブ
ディビジョンの選択項目を、現在のサブディビジョンレベルで選択されている
サブディビジョンコンポーネントにコネクトされる任意のエッジに変更します。

ヒント: 選択項目の変換機能の多くは、サブディビジョンサーフェスコンポー
ネントを選択した状態で Ctrl + 右クリックすると表示される、状況に応じたサ
ブディビジョンサーフェスマーキングメニューから使用できます。

サブディビジョン サーフェス > 選択項目を頂点に変
換（Subdiv Surfaces > Convert Selection to
Vertices）

選択項目を頂点に変換（Convert Selection to Vertices）により、現在のサブディ
ビジョンの選択項目を、現在のサブディビジョンレベルで選択されているサブ
ディビジョンコンポーネントにコネクトされる任意の頂点に変更します。
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ヒント: 選択項目の変換機能の多くは、サブディビジョンサーフェスコンポー
ネントを選択した状態で Ctrl + 右クリックすると表示される、状況に応じたサ
ブディビジョンサーフェスマーキングメニューから使用できます。

サブディビジョン サーフェス > 選択項目を UV に変
換（Subdiv Surfaces > Convert Selection to UVs）

選択項目を UV に変換（Convert Selection to UVs）により、現在のサブディビ
ジョンの選択項目を、現在のサブディビジョンレベルで選択されているサブディ
ビジョンコンポーネントにコネクトされる任意の UV テクスチャ座標に変更し
ます。

ヒント: 選択項目の変換機能の多くは、サブディビジョンサーフェスコンポー
ネントを選択した状態で Ctrl + 右クリックすると表示される、状況に応じたサ
ブディビジョンサーフェスマーキングメニューから使用できます。

サブディビジョン サーフェス > 選択したコンポーネ
ントの洗練（Subdiv Surfaces > Refine Selected
Components）

次に細かいサブディビジョンサーフェスレベルが存在する場合、これを編集で
きます。より細かなサブディビジョンサーフェスレベルが存在しない場合は、
元々選択されたコンポーネントを基にサブディビジョンサーフェスに洗練レベ
ルを 1 つ追加する選択したコンポーネントの洗練（Refine Selected
Components）機能で、サブディビジョンサーフェスに追加可能な LOD が増加
されます。

たとえば、サブディビジョンサーフェスの 3 つのフェースを選択して選択した
コンポーネントの洗練を選択すると、サーフェス上にある選択された 3 つの
フェースに含まれる領域に、洗練レベルが 1 つ追加されます。つまり、サブディ
ビジョンサーフェス上のその領域にフェースが追加されます。

これによってサブディビジョンサーフェスの必要な領域に、いっそうきめ細か
い起伏やディテールを追加することができます。さらに細かいディテールが必要
な場合は、コンポーネントを選択した状態で再度選択したコンポーネントの洗練
を選択するだけで、選択領域にディテールがさらに追加されます。
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関連項目
■ 新しいサブディビジョンレベルを作成する (17 ページ)

サブディビジョンサーフェス > 粗いレベルのコンポー
ネントの選択（Subdiv Surfaces > Select Coarser
Components）

サブディビジョンレベル階層で 1 レベル上にある、関連するサブディビジョン
コンポーネントを選択して、サブディビジョンサーフェスの次に粗いレベルを
編集できるようになります。

関連項目
■ サブディビジョンレベル間の切り替え (19 ページ)

サブディビジョン サーフェス > 選択したコンポーネ
ントの拡大（Subdiv Surfaces > Expand Selected
Components）

洗練されたコンポーネントの選択項目に基づいて、特定の洗練レベルでサブディ
ビジョンの洗練領域を拡大します。

たとえば、選択したコンポーネントの洗練（Refine Selected Components）機
能を使用してディテールをサブディビジョンサーフェスの領域に追加して、LOD
を外側に追加する場合、洗練する領域の境界のコンポーネントを選択して選択し
たコンポーネントの拡大（Expand Selected Component）を選択し、洗練の領
域を拡大することができます。

関連項目
■ 新しいサブディビジョンレベルを作成する (17 ページ)
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サブディビジョン サーフェス > コンポーネントの表
示レベル > より詳細に（Subdiv Surfaces >
Component Display Level > Finer）

現在選択されているサブディビジョンサーフェスのコンポーネントの表示を変
更して、現在表示されているサブディビジョンレベルの次に細かい（番号が上
の）サブディビジョンレベルを表示します。

たとえば、現在表示されているサブディビジョンレベルが 1 の場合、コンポー
ネントの表示レベル > より詳細に（Component Display Level > Finer）を選択
するとサーフェスの表示が更新され、次に細かいサブディビジョンサーフェス
レベル（レベル 2）が表示されます。

関連項目
■ サブディビジョンレベル間の切り替え (19 ページ)

サブディビジョン サーフェス > コンポーネントの表
示レベル > より粗く（Subdiv Surfaces > Component
Display Level > Coarser）

現在選択されているサブディビジョンサーフェスのコンポーネントの表示を変
更して、現在表示されているサブディビジョンレベルの次に粗い（番号が下の）
サブディビジョンレベルが表示されます。

たとえば、現在表示されているサブディビジョンレベルが 2 の場合、コンポー
ネントの表示レベル > より粗く（Component Display Level > Coarser）を選択
するとサーフェスの表示が更新され、次に粗いサブディビジョンサーフェスレ
ベル（レベル 1）が表示されます。

関連項目
■ サブディビジョンレベル間の切り替え (19 ページ)
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サブディビジョン サーフェス > コンポーネントの表
示レベル > ベース（Subdiv Surfaces > Component
Display Level > Base）

現在選択されているサブディビジョンサーフェスのコンポーネントの表示を変
更して、現在表示されているサブディビジョンレベルから、最も粗い（レベル
0）サブディビジョンレベルで表示されます。

たとえば、現在表示されているサブディビジョンレベルが 2 のときに、コンポー
ネントの表示レベル > ベース（Component Display Level > Base）と選択する
とサーフェスの表示が更新され、最も粗いサブディビジョンサーフェスレベル
（レベル 0）が表示されます。

関連項目
■ サブディビジョンレベル間の切り替え (19 ページ)

サブディビジョン サーフェス > コンポーネントの表
示フィルタ > すべて（Subdiv Surfaces > Component
Display Filter > All）

選択したサブディビジョンサーフェスの表示を設定し、サブディビジョンメッ
シュ上のすべての頂点が表示されます。サブディビジョンサーフェスのサブディ
ビジョン コンポーネント表示（Subdiv Component Display）のフィルタ
（Filter）設定が以前に編集済み（Edits）に設定されていると、このモードによ
り表示がリセットされ、すべての頂点が表示されます。この機能は、オブジェク
トのシェイプノードのサブディビジョン コンポーネント表示（Subdiv
Component Display）のフィルタ（Filter）アトリビュートを制御します。

関連項目
■ サブディビジョンサーフェスの編集した頂点を表示する (26 ページ)
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サブディビジョン サーフェス > コンポーネントの表
示フィルタ > 編集済み（Subdiv Surfaces >
Component Display Filter > Edits）

サブディビジョンサーフェスの表示を設定し、サブディビジョンメッシュ上の
編集した頂点のみが表示されます。この表示モードにより、特定のサブディビ
ジョンレベルで修正した頂点の表示および選択が容易になります。この機能は、
オブジェクトのシェイプノードのサブディビジョンコンポーネント表示（Subdiv
Component Display）のフィルタ（Filter）アトリビュートを制御します。

関連項目
■ サブディビジョンサーフェスの編集した頂点を表示する (26 ページ)
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