Subdivision Surface Modeling
# Contents

## Chapter 1 Subdivision surfaces overview ................................. 1
- What are subdivision surfaces? ............................................. 1
- Subdivision surface modeling overview .................................. 2
- Standard mode and polygon proxy mode .................................. 3

## Chapter 2 Subdivision surface conversion ............................... 7
- Prepare a polygonal surface for conversion to a subdivision surface ........................................ 7
- Prepare a NURBS surface for conversion to a subdivision surface ..................................... 9
- Convert a NURBS or polygonal surface to a subdivision surface .................................... 10
- Convert a subdivision surface to polygons .................................. 11
- Convert a subdivision surface to a NURBS surface .................................. 14

## Chapter 3 Editing subdivision surfaces ................................. 15
- Create a new subdivision level .............................................. 15
- Switch between subdivision levels ......................................... 16
- Apply or remove a crease in a subdivision surface .......................... 18
- Use polygon tools to modify a subdivision surface .......................... 20
- Modify a subdivision surface using Soft Modification ........................ 21
- Display the edited vertices on a subdivision surface ........................ 22
- Convert a subdivision component selection ............................... 22
- Attach subdivision surfaces .................................................. 23
- Use transformation tools with subdivision surface components .......................... 25
Improve interactive performance when editing subdivision surfaces ................................................. 26
Cleaning up subdivision surfaces ................................................................................................. 26
Reduce the number of levels in a subdivision surface ................................................................. 26
Remove unused vertices from a subdivision surface ................................................................. 27

Chapter 4 Mapping and editing UVs ................................................................................................. 29
UV mapping for subdivision surfaces ............................................................................................ 29
Edit UVs in Polygon Proxy Mode ................................................................................................. 30
Map UVs onto a subdivision surface ............................................................................................ 31
Edit subdivision surface UVs ......................................................................................................... 34

Chapter 5 Sculpting surface meshes ............................................................................................... 37
Using the Sculpt Geometry Tool for subdivision surfaces ............................................................ 37

Chapter 6 Subdivision surfaces tips ................................................................................................. 39
Bind subdivision surfaces to skeletons ........................................................................................... 39
Apply a deformer to a subdivision surface ..................................................................................... 39
Render subdivision surfaces ........................................................................................................ 41

Chapter 7 Subdivision surfaces menus ............................................................................................. 43
Subdiv Surfaces ............................................................................................................................ 43
Subdiv Surfaces > Texture > Planar Mapping ................................................................................. 43
Subdiv Surfaces > Texture > Automatic Mapping ......................................................................... 45
Subdiv Surfaces > Texture > Layout UVs ......................................................................................... 46
Subdiv Surfaces > Full Crease Edge/Vertex .................................................................................... 48
Subdiv Surfaces > Partial Crease Edge/Vertex ................................................................................ 48
Subdiv Surfaces > Uncrease Edge/Vertex ......................................................................................... 49
Subdiv Surfaces > Mirror ................................................................................................................ 49
Subdiv Surfaces > Attach ................................................................................................................. 50
Subdiv Surfaces > Match Topology ................................................................................................ 51
Subdiv Surfaces > Clean Topology .................................................................................................. 52
Subdiv Surfaces > Collapse Hierarchy ............................................................................................. 52
Subdiv Surfaces > Standard Mode .................................................................................................. 52
Subdiv Surfaces > Polygon Proxy Mode .......................................................................................... 53
Subdiv Surfaces > Sculpt Geometry Tool ....................................................................................... 53
Subdiv Surfaces > Convert Selection to Faces ............................................................................... 54
Subdiv Surfaces > Convert Selection to Edges ............................................................................... 54
Subdiv Surfaces > Convert Selection to Vertices .......................................................................... 54
Subdiv Surfaces > Convert Selection to UVs ............................................................................... 54
Subdiv Surfaces > Refine Selected Components ........................................................................... 55
Subdiv Surfaces > Select Coarser Components ............................................................................ 55
Subdiv Surfaces > Expand Selected Components ......................................................................... 55
Subdiv Surfaces > Component Display Level > Finer .................................................................... 56
What are subdivision surfaces?

Subdivision surfaces are a unique surface type available for modeling in Maya that possess characteristics of both polygon and NURBS surface types.

Like NURBS surfaces, subdivision surfaces are capable of producing smooth organic forms and can be shaped using relatively few control vertices.

Like polygon surfaces, subdivision surfaces allow you to extrude specific areas and create detail in your surfaces when it is required. This is accomplished by having the ability to work at different component levels of detail on the subdivision surface. You can switch between the different levels of detail as often as necessary.

A single subdivision surface can have different levels of detail in different regions. That is, a region that has a complex shape can have more control points to allow finer detail, while a simple or flat region will have fewer control points.
Modeling with subdivision surfaces is an easy way to create intricate objects such as human hands. It combines the best features of NURBS and polygonal modeling.

You can convert existing NURBS and polygon surface types to subdivision surfaces and vice versa.

**How subdivision surfaces work**

Subdivision surfaces get their name from their characteristic “dividing into regions of greater detail”. You start with a base mesh and divide and subdivide regions into finer and finer detail, with each subdivision giving greater control in that area.

You reshape subdivision surfaces by modifying control points at the different levels of the hierarchy. The base mesh (or “level 0” mesh) allows you to reshape large areas of the overall surface. The subdivided levels allow finer control in specific regions of the surface.

**Advantages of subdivision surfaces**

- Subdivision surfaces allow higher level control over shape than polygons.
- They allow you to only use complex geometry in the complex regions of your model.
- They allow creases (sharp edges) and arbitrary topology (not just four-sided sheets).
- The continuity of subdivision surfaces eliminates many of the problems that can occur at seams when you animate NURBS surfaces.
- You can bind subdivision surfaces to skeletons at a coarse level and the effects will translate smoothly to the finer levels.

**Subdivision surface modeling overview**

If you have never used subdivision surfaces before, the following workflow description will help you get started:

1. Create a polygon mesh that roughly captures the basic shape of the model you want to build. Ensure you initially construct it with a minimum amount of polygons as much as possible.
   
   This model will determine the base topology and control points of the subdivision surface when you convert it to a subdivision surface.
Subdivision surfaces are very effective at creasing and refining edges so you don't need to put a lot of effort into capturing those types of features in the polygon mesh.

2 Select an object and press the 2 button to get an idea of how the rough polygon model will convert to a subdivision surface as you work on it. You can also convert to subdivision surface to check the conversion and then undo back to the polygon model.

3 After you convert the polygon mesh to a subdivision surface, adjust the shape of the subdivision surface by pushing and pulling vertices.

4 If you need more control in a particular region of the mesh, create a new subdivision level while working in Standard mode.

5 If you want to apply a sharp edge to a region of the surface you can apply either a full or partial crease.

6 Switch back to Polygon Proxy mode if you need to make topological changes to the surface (for example, splitting a face). You can use the polygon tools to edit the subdivision surface while working in Polygon Proxy mode.

Related topics

- Standard mode and polygon proxy mode on page 3
- Use transformation tools with subdivision surface components on page 25
- Create a new subdivision level on page 15
- Switch between subdivision levels on page 16
- Apply or remove a crease in a subdivision surface on page 18
- Use polygon tools to modify a subdivision surface on page 20
- Improve interactive performance when editing subdivision surfaces on page 26

**Standard mode and polygon proxy mode**

Subdivision surfaces can be edited in two modes:

- Standard mode
Polygon proxy mode

To work effectively with subdivision surfaces you must work using both modes. You can easily switch between each mode using the marking menu.

**Standard mode**

Standard mode displays the subdivision surface in its native form. In standard mode you can increase the number of components (refine regions) where you need more detail in your model as well as view any existing levels of refinement. You can manipulate refined components (move, rotate, or scale) and keyframe the surface. You can also crease edges and vertices.

In Standard mode, when you refine a selected region of the surface the refined components are segregated into different levels. When you first create a subdivision surface it is displayed at the first level by default, called Level 0. Level 0 is the coarsest level, also called the *base mesh*. Level 1 and higher numbers are finer levels, where you can add finer details to the mesh.

The interactive performance when viewing complex subdivision surfaces is always better when displaying a subdivision surface in standard mode than in polygon proxy mode. For tips on further improving the interactive performance, please refer to [Improve interactive performance when editing subdivision surfaces](#) on page 26.

You can switch between standard mode and polygon proxy mode at any stage of modeling. When you switch to standard mode, Maya deletes any extrude, deformation, or other construction history you’ve created while in polygon proxy mode.

Standard mode is also sometimes referred to as *hierarchy mode* because it lets you switch between the hierarchical levels of refinement on the subdivision surface.

**Polygon proxy mode**

Polygon Proxy mode creates a polygon mesh around the subdivision surface that corresponds to the base mesh (level 0) of the subdivision surface. This
polygon mesh is only temporary and is used for editing the surface; Maya deletes it when you switch back to Standard mode.

Polygon Proxy mode lets you use the polygon tools and features to modify the base mesh (level 0) of the subdivision surface. For example, if you create a model in Standard mode and then decide you need to extrude or delete a face, you can switch to the Polygon Proxy mode, extrude or delete the face on the polygon mesh (which in turn affects the base mesh), then return to Standard mode. The Standard mode edits are maintained, unless they overlap the affected face.

You can switch to Polygon Proxy mode at any stage of modeling. However, if you’ve used deformer or created other construction history while in Standard mode, you cannot switch to Polygon Proxy mode until you delete construction history. Delete construction history on the object with Edit > Delete by Type > History, and then switch to Polygon Proxy mode.

Notes

■ When skinning characters made from subdivision surfaces, be sure to set your subdivision surfaces to Standard mode before skinning. Skinning while in Polygon Proxy mode can lead to unexpected behavior.

Related topics

■ Create a new subdivision level on page 15
■ Switch between subdivision levels on page 16
■ Improve interactive performance when editing subdivision surfaces on page 26
Subdivision surface conversion

Prepare a polygonal surface for conversion to a subdivision surface

A common way to start a subdivision surface is to create a simple “rough sketch” of the shape with polygons and convert that to the base mesh of a subdivision surface. Keep the following in mind when you create a polygon mesh.

When you are ready to convert a polygon mesh to a subdivision surface, see Convert a NURBS or polygonal surface to a subdivision surface on page 10.

Start with as few faces as possible

A dense subdivision base mesh wastes control points and will reduce performance.

If you want to convert an existing mesh, try using Mesh > Reduce to reduce the number of faces in the mesh.

Use mostly 4-sided polygons (quads)

While subdivision surfaces can handle up to 256 sided polygons, you will get best results from using mostly 4-sided polygons.

When modeling subdivision surfaces, try to avoid faces with more or less than 4 sides, and vertices with more or less than 4 adjacent faces.

When a face or patch on the original surface is not 4-sided, an extraordinary vertex (a vertex with less than or more than 4 adjacent faces) is created at level 0 of the subdivision surface. This affects the parameterization of the subdivision surface.
surface and might make the surface bumpy (the bigger the quads relative to the model, the less this is a problem).

Put vertices and edges in the polygon mesh where you want them in the subdivision surface

If you can plan out where you want vertices and edges in the model, it will help you produce the results you want when modeling and binding the surface to joints.

For example, edges must be present where you want to create a partial or full crease, and as with polygonal and NURBS surfaces, edges should circle the eyes and mouth on the model of a head.

Watch out for polygons that will not convert

You cannot create subdivision surfaces from the following types of polygonal surfaces.

- Nonuniform topology.

Use Mesh > Cleanup to correct nonmanifold geometry.

- Lamina topology (faces are on top of each other sharing more than two vertices or more than one edge).
  Use Mesh > Cleanup to correct lamina geometry.

- Free points or floating edges.

- Interior vertices with two incident edges.
Inconsistent normals.
One way to correct inconsistent normals is to use Normals > Conform.

Related topics
- Prepare a NURBS surface for conversion to a subdivision surface on page 9
- Convert a NURBS or polygonal surface to a subdivision surface on page 10

Prepare a NURBS surface for conversion to a subdivision surface

When you are ready to convert a NURBS surface to a subdivision surface, see Convert a NURBS or polygonal surface to a subdivision surface on page 10.

Some NURBS properties do not convert
If you create subdivision surfaces from the following types of NURBS surfaces, you may get unexpected results.
- Degrees other than 3 (cubic) are not converted.
- Rational geometry (weighted CVs) is not converted.
- Trimmed regions on a NURBS surface are not converted.
- NURBS spheres converted to subdivision surfaces will have incorrect surface normals at the poles. When viewed in shaded mode the converted sphere will have dark points indicating that the normals are being computed incorrectly.

Consider converting to a polygon mesh first
A subdivision base mesh created from NURBS will probably be too dense, and NURBS models are typically made of different surfaces that must be converted individually and then attached.

By using Modify > Convert > NURBS to Polygons first, you can reduce and attach the polygon mesh before converting to a subdivision surface.
Use the following options with Modify > Convert > NURBS to Polygons > to convert NURBS surfaces to a polygon mesh suitable for use as a subdivision base mesh:

- Set Type to Quads.
- See Tesselation Method to General.
- Set U Type and V Type to Per Surf # of Isoparms in 3D.
- In the Number U and Number V boxes, try to find the lowest numbers that roughly approximate the shape of the surface.

If you converted multiple NURBS surfaces, use Mesh > Combine to merge them into a single polygon mesh. Then use Edit Mesh > Merge or Edit Mesh > Merge Edge Tool to merge internal border edges. To show border edges clearly, choose Display > Polygons > Custom Polygon Display > and turn on Border Edges.

Related topics
- Prepare a polygonal surface for conversion to a subdivision surface on page 7
- Convert a NURBS or polygonal surface to a subdivision surface on page 10

Convert a NURBS or polygonal surface to a subdivision surface

Modify > Convert > NURBS to Subdiv
Modify > Convert > Polygons to Subdiv
Alt + Shift + ~

Troubleshooting Convert
1 If the polygon mesh does not convert or results in a hard-to-use subdivision surface, see the Prepare a polygonal surface for conversion to a subdivision surface on page 7.
If the NURBS surface does not convert to a subdivision surface or results in a hard-to-use subdivision surface, see the following:

- Prepare a NURBS surface for conversion to a subdivision surface on page 9
- Convert a subdivision surface to polygons on page 11
- Convert a subdivision surface to a NURBS surface on page 14
- Modify > Convert > NURBS to Subdiv, Polygons to Subdiv

Convert a subdivision surface to polygons

Although you can use subdivision surfaces up to the completion of your project, you may need to convert them to polygons after you have finished modeling. For example, if you’re creating characters for a game, the game engine often requires the models to be polygons.

Maya offers two ways to convert subdivision surfaces to polygons:

- Tessellating creates a polygon surface that matches the contours of the subdivision surface.
- Extracting vertices creates a simpler, less dense polygon that matches the control vertices, not the contours, of the subdivision surface.

Subdivision surface at level 2.  

Tessellated surface. Polygon surface corresponds with subdivision surface.  

Extracted polygon at level 2. Vertices correspond with subdivision surface vertices.

To convert to a close approximation of your subdivision surface

1. Select the subdivision surface and choose Modify > Convert > Subdiv to Polygons > .

Convert a subdivision surface to polygons | 11
2 Make sure Vertices is not on.

3 Click Convert.

If the subdivision surface you tessellate has creases, the polygon edges that result at the creases are not automatically made hard.

You can create a polygon mesh that can be converted to another subdivision surface with the same shape as the original.

**Convert to a rough approximation of the subdivision surface by matching vertices**

1 Select the subdivision surface and choose Modify > Convert > Subdiv to Polygons.

2 Click Vertices and choose which level you want to use the vertices from.

3 Click Convert.
Notes

- The Subdiv to Polygons conversion only converts the UVs at Level 0 of the subdivision surface to the converted polygon surface.

Related topics

- Convert a NURBS or polygonal surface to a subdivision surface on page 10
- Convert a subdivision surface to a NURBS surface on page 14
- Modify > Convert > Subdiv to Polygons
Convert a subdivision surface to a NURBS surface

Modify > Convert > Subdiv to NURBS
Alt + ’

Maya creates NURBS surfaces corresponding to the subdivision surface and groups them.

To manipulate the resulting group of NURBS surfaces

■ Use Edit NURBS > Stitch > Global Stitch.
  Stitching makes the patches deform as one surface, but the patches are still regarded as separate surfaces when you assign materials. You can also use the other stitching operations under the Stitch submenu.

■ Use Edit NURBS > Attach Surfaces.
  Attaching creates a new continuous surface and is regarded as one surface when you assign materials. You must apply Attach Surface repeatedly, one patch at a time. Be aware that the order you attach patches affects the placement of any textures you might apply to the surface.

Notes

■ The Subdiv to NURBS conversion does not convert the UVs of the subdivision surface.

■ When a shader is assigned to a subdivision surface and the Subdiv to NURBS operation is applied, the shaders are not transferred to the resulting surface.

Related topics

■ Convert a NURBS or polygonal surface to a subdivision surface on page 10

■ Convert a subdivision surface to polygons on page 11

■ Modify > Convert > Subdiv to NURBS
Create a new subdivision level

Subdivision surfaces let you have different levels of detail in different regions of the same surface. Increasing the number of available control points (and the level of detail possible) in a region is called refining a region.

While you can refine to 13 (0 to 12) levels of detail, try to only go to a finer level when you cannot achieve the shape using coarser level vertices. Editing at levels 3 and higher increases the complexity and decreases performance.

To refine a region on a subdivision surface

1. Select one or more components where you want more detail.
2. Select Subdiv Surfaces > Refine Selected Components.
   
   A level of refinement is added to the subdivision surface. Each time you refine, a new level is added.
After refining an area, you can spread the level of refinement to adjacent areas. In the following example the center vertex is selected and expanded.

To expand a refined region

1. Select one or more components in the area you want more detail.
2. Select Subdiv Surfaces > Expand Selected Components to spread the level of refinement to adjacent areas.

Troubleshooting Refine Selected Components

I want to undo a refinement I made to a subdivision surface?

➤ You cannot undo a refinement to a subdivision surface. However, you can use Subdiv Surfaces > Clean Topology to remove refined components that you created but did not edit.

Related topics
- Switch between subdivision levels on page 16
- Use polygon tools to modify a subdivision surface on page 20
- Reduce the number of levels in a subdivision surface on page 26

Switch between subdivision levels

There are several ways to switch between the various levels of refinement on a subdivision surface.
<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Display a specific level so you can then edit the Subdiv components.| Press the right mouse button on the subdivision surface and choose Display Level, then the level you want to edit.  
or  
In the Attribute Editor for the subdivision surface (the shape node), open the Subdiv Component Display section and set the Level attribute. |
| Display the next finer (higher numbered) level from the current level.| Press the right mouse button on the subdivision surface and choose Display Finer.  
or  
Choose Subdiv Surfaces > Component Display Level > Finer.  
or  
Press Page Up on the keyboard. |
| Edit the next finer level, and refine the surface by one level if a finer level does not already exist. | Press the right mouse button on the subdivision surface and choose Refine Selected.  
or  
Select components on the subdivision surface and press Ctrl + Down.  
or  
Choose Subdiv Surfaces > Refine Selected Components. |
| Display the next coarser (lower numbered) level from the current level. | Press the right mouse button on the subdivision surface and choose Display Coarser.  
or  
Choose Subdiv Surfaces > Component Display Level > Coarser.  
or  
Press Page Down on the keyboard. |
To... | Do this
---|---
Edit the next coarser level, by selecting the related subdiv component one level higher in the subdiv level hierarchy. | Press the right mouse button on the subdivision surface and choose Select Coarser. or Choose Subdiv Surfaces > Select Coarser Components. or Select components on the subdivision surface and press Ctrl + Up.

Related topics
- Create a new subdivision level on page 15

**Apply or remove a crease in a subdivision surface**

You can modify the shape of a subdivision surface by applying a full or partial crease to selected edges or vertices.

A full crease is a hard or sharp edge created at the selected edges, or a sharp point created at the selected vertex. The surface moves very close or exactly to the edge or vertex to form the crease.

A partial crease moves the surface closer to the selected edges or vertices without ever reaching them. Partial creasing is useful when you want a softer edge effect, such as at the edge of a character’s lips.
Maya displays creased edges as dashed lines to help you identify which edges have been creased.

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a full crease.</td>
<td>Select the edge or vertices where you want the crease and choose <strong>Subdiv Surfaces &gt; Full Crease Edge/Vertex.</strong></td>
</tr>
<tr>
<td>Create a partial crease.</td>
<td>Select the edge or vertices where you want the crease and choose <strong>Subdiv Surfaces &gt; Partial Crease Edge/Vertex.</strong></td>
</tr>
</tbody>
</table>
To... | Do this
---|---
Remove a crease. | Select the edge or vertices with the crease and choose Subdiv Surfaces > Uncrease Edge/Vertex.

Related topics
- Use polygon tools to modify a subdivision surface on page 20

Use polygon tools to modify a subdivision surface

In addition to working on a subdivision surface when it is displayed in its normal subdivision mode (standard mode), Maya lets you modify a subdivision surface as if it were a polygon mesh by creating a substitute (proxy mesh) for you to edit (“polygon proxy mode”).

Working with a subdivision surface in polygon proxy mode lets you use the many polygon editing tools in Maya to modify and edit your subdivision surface. You can easily switch back and forth between the two display modes while you work on the surface.

To... | Do this
---|---
Switch to polygon proxy mode. | Choose Subdiv Surfaces > Polygon Proxy Mode. Maya creates polygonal mesh proxy from the current subdivision level. Use the polygon tools to edit the proxy.

Switch back to standard mode. | Choose Subdiv Surfaces > Standard Mode. Maya applies changes you made to the proxy to the subdivision surface.
Notes

- The proxy mesh has no shading so you can see the resulting subdivision surface.
- Boolean, Bevel, and Reduce operations will not maintain standard mode edits.
- Some polygonal operations (for example, Combine) create a new polygonal surface which has no subdivision surface associated with it. You will have to create a new subdivision surface from the resulting polygonal surface.
- Some polygonal operations modify your Standard mode edits. For example, when subdividing a face in polygon proxy mode, the original standard mode edits are copied onto each of the new faces. Edits and creases away from the modified area are not affected.
- Avoid changing the topology, such as subdividing a face, in areas where you’ve edited components in Standard mode. Doing this can alter the surface in unexpected ways. This is not a problem for edits to level 0 components, only at finer levels.

Troubleshooting polygon proxy mode

I can’t switch to polygon proxy mode?

➤ If you’ve used deformers, mapped UVs with history, or created other construction history while in Standard mode, you cannot switch to Polygon Proxy mode.

First delete construction history on the object (Edit > Delete by Type > History), then try switching to Polygon Proxy mode.

Modify a subdivision surface using Soft Modification

See the following:

- What is soft modification? in the Deformers guide
- Use the Soft Modification Tool in the Deformers guide
- Create Deformers > Soft Modification
Display the edited vertices on a subdivision surface

You can set the display mode for a particular subdivision surface so that it displays only the vertices that have been edited. This lets you more easily perform further refinements or modifications on those regions that have been previously edited.

To set the subdivision component display to show only edited vertices

1. Select the subdivision surface and ensure it is set to display vertices.
2. Perform any initial refinements or modifications to your subdivision surface.
   The display of vertices on the subdivision surface updates to display only the vertices that have been edited.
4. When you want to display all the vertices again, select the subdivision surface and then select Subdiv Surfaces > Component Display Filter > All.

Related topics

- Create a new subdivision level on page 15
- Switch between subdivision levels on page 16
- Use polygon tools to modify a subdivision surface on page 20

Convert a subdivision component selection

You can convert an existing selection of subdivision components to another component type. This saves you additional work in having to drop your existing selection and then selecting the other component type.

For example, if you have already selected some edges on a polygon proxy mesh, you can convert the selection to the faces associated with those edges so that you can then modify the faces with the polygon editing features.

You can convert the selection to faces, edges, vertices, and UVs. In addition you can expand a selection to select additional components that surround the existing selection.
To convert an existing subdivision component selection to another component type

1 Ensure one or more subdivision components are selected on your subdivision surface.

2 Do one of the following:
   - Press Ctrl and right click on an edge of the surface and select the component type you want to convert to from the marking menu that appears.
   - From the Maya menus, select Subdiv Surfaces > Convert Selection to <component type> and choose the component type that you wish to convert to.

Related topics
- Subdiv Surfaces > Convert Selection to Faces on page 54
- Subdiv Surfaces > Convert Selection to Edges on page 54
- Subdiv Surfaces > Convert Selection to Vertices on page 54
- Subdiv Surfaces > Convert Selection to UVs on page 54
- Subdiv Surfaces > Expand Selected Components on page 55

Attach subdivision surfaces

The edges of the surfaces will attach only if each surface has the same number of polygonal edges at the base mesh level (level 0). If the surface does not have the same number of edges, the objects are grouped, but the vertices and edges of the surfaces do not merge.
Attaching will destroy any deformer weighting on the selected surfaces.

**To prepare subdivision surfaces to be attached**

- Make sure the two surfaces you want to attach each have the same number of polygonal edges at the base mesh (level 0). If they do not have the same number of edges, the surfaces will be grouped, but will not merge. Use Split Polygon or Delete Edge on the polygon proxy to create or remove edges.

- Switch to Standard mode if you are not already in it (Subdiv Surfaces > Standard Mode).

- If you are merging mirrored surfaces, delete the history on the mirror copy.

- Subdiv Surfaces > Attach requires surfaces with consistently oriented normals.
  If one of the surfaces you wish to attach has its normals facing the wrong direction, Edit > Duplicate it, Subdiv Surfaces > Mirror it in the opposite direction, and then Modify > Freeze Transformations on the mirrored object.
To attach subdivision surfaces

1. Select the surfaces you want to attach.
2. Select Subdiv Surfaces > Attach.

Notes

- The edges of the surfaces will attach only if each surface has the same number of polygonal edges at the base mesh level (level 0). If the surface does not have the same number of edges, the objects are grouped, but the vertices and edges of the surfaces do not merge.

- Attaching will destroy any deformer weighting on the selected surfaces.

Related topics

- Subdiv Surfaces > Attach on page 50

Use transformation tools with subdivision surface components

Keep the following tips in mind when transforming subdivision surface components.

- Use the Modify > Transformation Tools > Move Normal Tool on individual vertices one at time. Adjacent vertices on a subdivision surface may not have common UV directions.

- For best results, make large scale changes at coarser (lower-numbered) levels and small-scale changes at finer levels.

- To line up vertices, rotate an edge in the camera plane while approximating it to be tangent to the surface.

- To remove standard mode edits (transformations) on a vertex, select the vertex and press the Delete key. This does not actually remove the vertex, but moves it back to its original position.
Improve interactive performance when editing subdivision surfaces

To improve interactive performance when working with subdivision surfaces, follow these tips:

■ Edit components in Standard mode rather than Polygon Proxy mode.
■ Keep the base mesh (level 0) simple. Add all detail by creating finer levels.
■ While modeling in Polygon Proxy mode, turn off the creation of UVs (No UVs on Subd option on the polyToSubdiv node) to improve performance.
■ If you’re editing a number of control points at once you can control when the surface updates by setting the Dependency Graph Evaluation settings (Window > Settings/Preferences > Performance Settings). You can set the draw refresh to occur as you drag the mouse, when you release the mouse, or when you press an update button that appears. For more information, see Window > Settings/Preferences > Performance Settings.
■ Use the Clean Topology operation to remove components that were created but not edited. See Remove unused vertices from a subdivision surface on page 27.
■ When binding a skeleton to a model, bind to a coarse level, such as level 0 or 1. See Bind subdivision surfaces to skeletons on page 39.

Related topics
■ Create a new subdivision level on page 15
■ Reduce the number of levels in a subdivision surface on page 26
■ Remove unused vertices from a subdivision surface on page 27

Cleaning up subdivision surfaces

Reduce the number of levels in a subdivision surface

You can reduce the number of levels in a subdivision surface using the Collapse Hierarchy feature. Collapse Hierarchy maintains the original shape of the
surface, but moves the subdivision edits from finer levels to coarser levels, making the coarser levels more dense as a result.

For example, you may want to make a topology change to a face that resides at a finer level using the Edit Mesh > Split Polygon Tool. Topology changes such as this can only be made at the base level (level 0) of a mesh, so collapsing the hierarchy so the finer levels of detail appear at level 0 on the mesh would allow you to switch to Polygon Proxy mode, and make the edit at the base level.

To collapse subdivision levels

1. Select the subdivision surface.
2. Choose Subdiv Surfaces > Collapse Hierarchy.
3. Set the number of levels to collapse.
   For example, if you collapse two levels, previous level 2 vertices become level 0 vertices, level 3 vertices become level 1 vertices, and so on.
4. Click Collapse.

Related topics
- Create a new subdivision level on page 15
- Remove unused vertices from a subdivision surface on page 27
- Subdiv Surfaces > Collapse Hierarchy on page 52

Remove unused vertices from a subdivision surface

You can use Clean Topology to remove any vertices that were created but not used in a subdivision surface. Removing the extra, unused vertices helps to reduce the file size and improve interactive performance.

For example, if have refined some regions of a subdivision surface, but moved only a few of the vertices created by the refinement, Clean Topology can remove the vertices you did not transform.

To automatically reduce unused vertices in a subdivision surface

1. Select the surface whose unused vertices you wish to remove.
2. Select Subdiv Surfaces > Clean Topology.
Any unused vertices are removed from the subdivision mesh.

Notes
Clean Topology only removes a vertex if it meets all three of the following requirements:

- No edits to the position of the vertex. That is, if a face has been moved the associated vertices will not be removed.
- No mapping or edits to the UV associated with a vertex. That is, if any texture data is applied to the vertex it will not be removed.
- No crease applied to the vertices or edges

There may be some vertices that Clean Topology cannot remove, even if they meet these requirements, because the vertices are required for surface topology.

- If you use Subdiv Surfaces > Clean Topology after creating a Blend Shape or other deformation, you might get areas on the surface that have no UVs. These areas are the result of vertices created when you weight the deformer while the Clean Topology node still exists in construction history. Avoid using Clean Topology after creating deformers. Also delete history after using Clean Topology so that it does not interfere with the creation of deformers.

Related topics
- Reduce the number of levels in a subdivision surface on page 26
- Improve interactive performance when editing subdivision surfaces on page 26
Mapping and editing UVs

UV mapping for subdivision surfaces

UVs are two-dimensional texture coordinates that reside with the vertex component information for polygonal and subdivision surface meshes. UVs exist to define a two-dimensional texture coordinate system for a surface mesh and to facilitate the placement of image texture maps on the surface. UVs act as marker points that control which points (pixels) on the texture map correspond to which points (vertices) on the mesh. Textures applied to polygon or subdivision surfaces without UV texture coordinates will not render.

UV mapping is a process whereby you create, edit, and otherwise arrange a flattened (two-dimensional) representation of the surface mesh over the bitmap image to be used as a texture as it appears in the UV Texture Editor. The UV mapping process results in a correlation between the image and how it appears as a texture when mapped onto the three-dimensional surface mesh.

Although Maya creates UVs by default for many primitive types, you’ll need to rearrange the UVs in most cases, because the default arrangement will usually not match any subsequent edits to the model you may make. In addition, the location of the UV texture coordinates do not automatically update when you edit a surface mesh.

In most cases, you map and arrange UVs after you have completed your modeling and before you assign textures to the model.

NOTE UV mapping is not necessary for creating and reshaping polygon and subdivision surfaces. You only need to be concerned about UV texture coordinates if you want to apply a texture to polygons.

Subdivision surfaces are similar to polygon surfaces in that they have UV texture coordinates. However, subdivision surfaces have their own mapping and editing
operations, separate from the polygon operations. (It's also possible to map UVs with the polygon operations; see Edit UVs in Polygon Proxy Mode on page 30.)

For subdivision surfaces, there are two UV mapping operations available: Planar Mapping and Automatic Mapping. These items are located in the Subdiv Surfaces > Texture menu. They are equivalent to the Planar Mapping and Automatic Mapping features in the Create UVs menu. However, one key difference is that the Subdiv Surfaces operations use only one UV set, whereas polygons can have multiple UV sets.

To create a UV mapping arrangement that works best for your model, you may need to map several times, until you find a mapping arrangement that is suitable.

Related topics
- Introduction to UV mapping
- UV mapping tips
- UV Texture Editor overview
- Map UVs onto a subdivision surface on page 31
- Edit subdivision surface UVs on page 34

Edit UVs in Polygon Proxy Mode

You can choose to create and edit UVs in either Polygon Proxy Mode or Standard Mode.

When you use Polygon Proxy Mode, you have more UV editing features available. However, because the UVs apply to the base mesh faces, textures might appear twisted, especially in areas that are significantly more refined than the base mesh. Editing UVs in Standard Mode (the default) ensures the best visual results for textures.

To use UVs from polygon proxy mode

1. Switch to Polygon Proxy Mode (right click the subdivision surface and choose Polygon).
2. Show the attribute editor and click the polyToSubdiv tab.
3 Set the UV treatment attribute:
  ■ To use the UVs from standard mode, choose Keep Subd UVs.
  ■ To use UVs you edit while in polygon proxy mode, choose Inherit UVs from Poly. The UVs will be copied back to the surface when you exit polygon proxy mode.
  ■ To not have UVs on this surface at all, choose No UVs on Subd. This removes any existing UVs on the surface.

The UV treatment attribute defaults back to Keep Subd UVs if you switch to Standard Mode and then switch back to Polygon Proxy Mode. If you want to edit UVs in polygon proxy mode again, you will need to change the UV treatment attribute again.

Related topics
  ■ Use polygon tools to modify a subdivision surface on page 20
  ■ Edit subdivision surface UVs on page 34

Map UVs onto a subdivision surface

To select faces for mapping
  ➤ In Standard Mode, select a Display Level for the subdivision surface.

  ■ Switch between subdivision levels on page 16
    Switch to a level that contains the faces you want to map. For example, if you want to map the entire surface, switch to level 0 so you can select faces across the entire surface.
    For whichever level you choose, Maya converts the faces you select down to the finest level and applies the mapping to those faces.
    For example, if a face at level 0 has refinements to level 3, the mapping is applied to level 3 faces. If there are no finer levels, the mapping is applied to faces you selected on the current level.

  ➤ Select some or all of the faces on the surface.
    If faces are not selected, no mapping occurs. Maya does not automatically change to the face component mode, as it does when you try to map polygons.
Planar Mapping assigns UVs to the surface by projecting them in a single direction. Where the projection intersects the surface, Maya assigns UVs. This mapping technique keeps the amount of UV shells low. However, it usually results in UV shells that overlap because the projected UVs strike both sides of the surface. As a result, you’ll probably need to separate the overlapping UVs using Layout UVs.

To map UVs with Planar Mapping

2. Set the options. In most cases, you’ll need to at least change the Mapping direction. Mapping direction controls the orientation of the mapping plane.
3. Click Project.

To avoid overlaps, Automatic Mapping assigns UVs to the surface by projecting them inward from multiple planes simultaneously. Where the projections intersect the surface, Maya assigns UVs.

To map UVs with Automatic Mapping

2. Set the options.
3. Click Project.

Although this mapping technique avoids overlapping UVs, it usually creates many small UV shells. As a result, you may want to combine the small UV shells into larger shells, for example, combining shells that correspond to fingers together with the shell corresponding to the palm.

It’s easier to create textures for the model when the UVs of adjacent faces are combined in a logical way. To combine UV shells, you use Edit UVs > Merge UVs and Edit UVs > Sew UV Edges.

To resize or rotate the projection plane

1. Open the UV Texture Editor (Window > UV Texture Editor).
   You should see the mapped UVs in the UV Texture Editor.
2 Use the projection manipulator on the surface:

- Drag the corners to resize the plane.
- Click the red lines to show a transform manipulator tool, then use it to rotate or flip the plane.

If the manipulator doesn’t appear, select subdPlanarProj in the Channel Box.

Examples

Manipulator

If you map a model of a long fish, the UV shell will be stretched by default to fit in a square (see the following illustration). The stretched shape could result in a texture that looks stretched on the model.

To avoid this problem, you can resize the projection manipulator until the UV shell becomes more oblong, like the long fish model.
Selecting faces

In the figure on the left, level 0 faces were selected to be mapped. The resulting UV shell is round, but there are also lines in the shape of an upside-down T. These other lines correspond to the faces that were selected on level 0. They appear only because those faces are still selected; select elsewhere and they no longer appear.

In the right figure, level 2 faces were selected to be mapped. The resulting UV shell is orange (meaning it’s selected) and is shaped like an arc. There is also a UV shell in the shape of an upside-down T, with a section missing. This UV shell corresponds to the level 1 faces. It still has the default UV arrangement (an upside-down T), because it was not actually mapped; only level 2 faces were mapped.

Related topics

- Edit subdivision surface UVs on page 34
- Subdiv Surfaces > Texture > Planar Mapping on page 43
- Subdiv Surfaces > Texture > Automatic Mapping on page 45

Edit subdivision surface UVs

In the UV Texture Editor (Window > UV Texture Editor), there are separate menus for polygons and subdivision surfaces. Use the menu items under the Subdivs menu when you edit UVs on subdivision surfaces.
The items in the UV Texture Editor’s Subdivs menu work the same as the corresponding items in the editor’s Polygons menu.

You can use all other menu items, except the following:

- **View > View Contained Faces and View > View Connected Faces**
  
<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show UV borders more clearly in the texture editor.</td>
<td>Select Display &gt; Subdiv Surfaces UV Borders (Texture Editor).</td>
</tr>
<tr>
<td>Separate a UV shell into smaller shells.</td>
<td>In the UV Texture Editor, select edges along the new border you want to create and choose Subdivs &gt; Cut UV Edges.</td>
</tr>
<tr>
<td>Attach separate UV shell manually.</td>
<td>In the UV Texture Editor, select the common edges of separate UV shells and choose Subdivs &gt; Move and Sew UV Edges &gt; . Turn off Limit Piece Size and click Apply.</td>
</tr>
<tr>
<td>Attach separate UV shells automatically.</td>
<td>In the UV Texture Editor, select all edges of all UV shells and choose Subdivs &gt; Move and Sew UV Edges &gt; . Turn on Limit Piece Size and set Number of Faces to the minimum number of faces a UV shell can have. For example, if you set 2, only shells with a number of faces equal to or less than 2 will be moved and sewn. Click Apply.</td>
</tr>
<tr>
<td>Create an image of the UV layout on which to paint a texture.</td>
<td>In the UV Texture Editor, select Subdivs &gt; UV Snapshot. The options are the same as for Polygons &gt; UV Snapshot.</td>
</tr>
</tbody>
</table>

**TIP** After performing a Move and Sew UV Edges operation, you can select the history node (subdMapSewMove) in the Channel Box and adjust the Number of Faces until you achieve the results you want.

**Related topics**

- **Subdiv Surfaces > Texture > Layout UVs** on page 46
Using the Sculpt Geometry Tool for subdivision surfaces

The Sculpt Geometry Tool lets you manually sculpt NURBS, polygons, or subdivision surfaces quickly with the stroke of a brush. You simply paint the surface mesh using the Sculpt Geometry Tool to push or pull CVs (NURBS) or vertices (polygons and subdivision surfaces) to achieve the shape you want.

The Sculpt Geometry tool is based on the Maya® Artisan™ tools. For more information, see How Artisan brush tools work in the Artisan guide and the related topics listed below which are found in the Polygon Modeling guide.

Related topics

- Sculpt Geometry Tool overview
- Sculpt a NURBS or polygon surface mesh
- Smooth a surface mesh
- Erase surface sculpting to an earlier state
- Sculpt according to an attribute map on NURBS
- Sculpt across seams and surface edges on NURBS
- Keyframe sculpting changes
Subdivision surfaces tips

Bind subdivision surfaces to skeletons

For optimal performance, bind subdivision surfaces at a coarser level, and only to one level. This usually results in adequate shape changes as the deformers and joints move, and gives you fewer vertices to weight while maintaining smooth interpolation.

The detail edits on finer levels tend to float or ride on the bound coarser level, which helps skin details such as wrinkles and spots blend smoothly. For example, as a finger joint bends, the wrinkles riding on top, modeled at a finer level, stretch out.

Before you bind:

- Freeze the transform on the subdivision surface to avoid unusual distortions after the bind caused by non-uniform scaling of the subdivision surface.

- Delete the history, especially if the subdivision surface has been bound before.

- Make sure you’re in Standard Mode.

Apply a deformer to a subdivision surface

When you apply a deformer to a subdivision surface selected as an object, the deformer applies to the base (level 0) vertices. To apply the deformer to a
different level, select the vertices at that level and then apply the deformer. You can assign blend shapes to vertices at any level.

- If you delete a deformer and cannot switch to Polygon Proxy mode, delete the history or find the input geometry in the dependency graph and delete it.

- Be careful if you have deformers on the same part of the surface at different levels. Without parenting, deformer bases can produce double transforms.

- Avoid having different levels of vertices in the same deformer. For example, if you create a full crease at level 1 and apply a wire close to the object surface (level 0), then move the wire or its vertices, the effect is very different than if you apply the wire to level 1 vertices.

- If the resulting deformation is undesirable, unbind, delete history, and rebind at a finer level.

- You may find that not all vertices are moved by a skeleton bound to a subdivision surface at a level finer than 1 because all vertices at the level were not selected or created before binding. To be sure all vertices are selected, go to level 0 or 1, select all vertices, then refine to the required level and select all.

- A deformer at level 2 can override the deformation done at level 1. For example, if you have a weighted cluster at level 1 and a blend shape at level 2, the cluster deformation will disappear when the blend shape weight is set to one. Try putting the blend shape at the finest level or on the same level as the other deformers. You can also try changing the order of the deformations.

- A deformer at level 1 can move the surface out of a deformer at a finer level (for example, lattices over the same parts of the surface at levels 2 and 3 and in the case of level 2 lattices, it pulls it out of the range of the lattice at level 3).

- Switching to Polygon Proxy mode when you have deformers and skeletons on the subdivision surface unbinds the surface and loses weighting.

**Creating blend shape and cluster deformers for subdivision surfaces**

To create a blend shape for subdivision surfaces, you can either select the object or select vertices on a given level. If you select the object, Maya blends all vertices at all levels of the surface. If you select vertices of a specific level, Maya blends only those vertices.
To create a cluster for subdivision surfaces, you need an extra row of vertices completely surrounding the vertices you want in the cluster. These extra vertices should not be in the cluster itself, but they must exist on the surface. Without the extra row, you will experience problems weighting the vertices in the cluster.

If the extra row does not exist, select the vertices and select Subdiv Surfaces > Expand Selected Components.

**Render subdivision surfaces**

You can fine-tune the quality of the rendered surface by adjusting the settings in the Tessellation section of the subdivision surface Attribute Editor. Subdivision surfaces also support displacement mapping.

You can potentially create very finely tessellated polygons. As an extreme example, a Uniform tessellation of a 10 quad base mesh, with Depth and Sample Count set to 10 will produce about a billion triangles.

Format
Select one of the tessellation methods.

**Uniform** Uniform tessellation produces a polygon with an equal number of faces for each of the subdivision surface's base mesh faces (faces at level 0).

**Adaptive** Adaptive tessellation produces a polygon with an equal number of faces for each of the finest level faces on the subdivision surface. The more refinement you've made to a region of the subdivision surface, the more faces the resulting polygon will have for that same region. Use Sample Count to increase the tessellation.

**Depth** For Uniform tessellation only, set the level to determine how many faces are to be used in the tessellation. For example, if Depth is 3, the number of faces at level 3 are used in the tessellation.

**Sample Count** Specify how many times each face should be divided. Increasing this value smooths the polygonal surface.
Subdivision surfaces menus

Subdiv Surfaces

Subdiv Surfaces > Texture > Planar Mapping

Maps UVs onto a subdivision surface by projecting along a direction.

Related topics
- Map UVs onto a subdivision surface on page 31

Subdiv Surfaces > Texture > Planar Mapping

By default, Smart Fit is turned on, which automatically positions the projection manipulator. If you prefer to specify exact values for the projection manipulator, you can turn off Smart Fit and change the values in the Projection Center, Rotation, Width, and Height settings instead.

Fit to Best Plane If you want to map UVs for a portion of the object's faces, you can turn on Fit to Best Plane and the projection manipulator snaps to an angle and rotation aimed directly at the selected faces.

Fit to Bounding Box This option works best when you are mapping UVs to all or most of an object's faces. It snaps the projection manipulator to fit within the object's bounding box. With this option on, you must choose one of the Mapping direction options to establish the orientation of the projection manipulator.

Mapping direction Choose an axis so that the projection manipulator is aimed at the majority of the object's faces. For example, a turtle model sitting on the
grid would have most of its faces pointing toward the Y axis, while a horse model standing on the grid would have most of its faces pointing toward the X or Z axis.

If most of the model's faces point somewhere that is not directly along the X, Y, or Z axis, you can choose Camera. This option positions the projection manipulator based on the current active view.

**Insert Before Deformers** The Insert Before Deformers option is relevant when the object has a deformation applied to it. If the option is turned off and the deformation is animated, the texture placement is affected by the change in vertex positions. This leads to “swimming” textures.

Turning this option on applies the texture placement to the object before the deformation is applied to it. Basically, the texture placement dependency graph node is inserted before the deformer dependency graph nodes and the texture “sticks” to the geometry even after the deformation.

**Image Center** This value represents the center of the projected UVs. Changing this value translates the center accordingly.

**Image Rotation** This value changes the angle at which UVs are rotated in the 2D window. Drag the slider or enter a value to rotate the image.

**Image Scale** This value represents the width (U) or the height (V) of the 2D map relative to the 2D center point.

**Keep Image Ratio** Turn this option on to retain the width to height ratio of the image so that the image does not distort. Turn it off so that the mapped UVs fill the 0 to 1 coordinates in the UV Texture Editor.

If Smart Fit is turned off, the following options become available. You can enter values to change the Projection Center, Rotation and Scale. After you project a texture, you can change these values from the Channel Box or the Attribute Editor, or use the corresponding manipulator handles to interactively adjust the map.

**Projection Center** The projection center defines the point of origin in the X, Y, or Z axis from where you can project a texture map. By default, this is the center of the selected faces in the X, Y, or Z axis.

**Projection Rotation** Type a value to rotate the projection in the 3D view around the X, Y, or Z axis which subsequently rotates the texture.

**Projection Width** Adjusts the width (U) of the projection relative to the 3D projection axis.

**Projection Height** Adjusts the height (V) of the projection relative to the 3D projection axis.
Subdiv Surfaces > Texture > Automatic Mapping

Projects UV texture coordinates onto the selected subdivision surface from multiple angles simultaneously.

Related topics
- Map UVs onto a subdivision surface on page 31

Subdiv Surfaces > Texture > Automatic Mapping > 🗑️

Planes: Select the number of planes you are projecting from. The more planes used, the less distortion occurs and the more UV shells created. You can choose a projection mapping based on shapes with 4, 5, 6, 8 or 12 planes.

Optimize: Select how you want the projection optimized.

Less Distortion: Projects all planes equally. While this method provides the best projection for any face, you may end up with more pieces. It is particularly useful if you have a symmetrical model and you want the pieces of the projection to be symmetrical.

Fewer pieces: Projects each plane until the projection encounters a projection angle that is not ideal. This can result in larger pieces, and fewer of them.

Shell Layout: Select where you want the UV pieces to lie in the texture space.

Along U: Positions the pieces along the U axis.

Into Square: Positions the pieces within the 0 to 1 UV texture space.

Scale mode: Select how you want the UV pieces scaled within the texture space.

None: Performs no scaling.

Uniform: Scales the pieces to fit the 0 to 1 texture space without changing the aspect ratio.

Stretch to Square: Stretches the pieces to fit the 0 to 1 texture space. The pieces may become distorted.

Shell stacking: Determines how the UV shells get stacked in relation to each other when laid out in the UV Texture Editor.
**Bounding Box** Creates a rectangular bounding box around each UV shell, then stacks the shells based on the borders of the bounding boxes. The UV shells will have more space between them when this option is set.

**Shape** Stacks the UV shells based on the boundaries of each individual shell. The UV shells can be more tightly arranged to fit into any available spaces when this option is set.

**Spacing Presets** Maya puts a bounding box around each piece and lays out the pieces so that the bounding boxes are very close together. If the shells end up positioned exactly next to each other, two UVs on different shells can share the same pixel and when painting a texture with the 3D Paint Tool, overscanning can cause the paint to spill onto the adjacent shell.

To avoid this situation, ensure that there is at least a pixel between the bounding boxes by selecting a spacing preset from this menu. Select a preset that corresponds to your texture map size. If you don’t know the size, select a smaller map, which will result in a larger spacing between adjacent shells in UV space. (The smaller your map in pixels, the bigger the UV spacing must be between bounding boxes.)

Select Custom to set the size of the space as a percentage of the map size (in the Percentage Space box).

**Percentage Space** If you select Custom beside Spacing Presets, enter the size of the space between bounding boxes as a percentage of the map size.

---

**NOTE** After performing an Automatic Mapping projection, you can modify the Planes, Optimize, Layout, and Scale settings for the projection in the Channel Box. However, do not modify these settings after painting a texture—the UVs may change drastically.

---

**Subdiv Surfaces > Texture > Layout UVs**

The Layout UVs action automatically moves UVs so they don’t overlap in texture space.

It is not absolutely necessary to keep UV pieces separate. For example, you may want to overlap UVs so different faces use the same region of a texture.
In general however you should keep pieces separate for convenience and clarity.

**Related topics**
- [Edit subdivision surface UVs](#) on page 34

**Subdiv Surfaces > Texture > Layout UVs**

The default settings give the best results in most situations.

**Separate** Select how you want to separate overlapping UV pieces.

- **Off**
  - Does not separate overlapping pieces. Only the Scale option has an effect.
- **Folds**
  - Separates only pieces where the surface normals of overlapping pieces point opposite directions. This method is faster, especially for larger models, however, you may be left with overlapping UVs.
- **All Intersecting**
  - Separates all pieces where the UVs overlap.
- **Flip Reversed**
  - Turn this option on to flip pieces that have normals pointing in opposite directions.

**TIP** If your model is symmetrical (for example, a character’s face), you can save texture space by turning this option off and superimposing the UV pieces so they occupy the same texture space.

**Layout**

Select where you want the UV pieces to lie in the texture space.

- **None**
  - Does not lay out pieces after they have been cut. Some pieces may lie on top of others.
- **Along U**
  - Positions the pieces along the U axis.
- **Into Square**
  - Positions the pieces within the 0 to 1 texture space.

**Scale**

Select how you want the UV pieces scaled within the texture space.

- **None**
  - Performs no scaling.
- **Uniform**
  - Scales the pieces to fit the 0 to 1 texture space without changing the aspect ratio.
- **Stretch to Square**
  - Stretches the pieces to fit the 0 to 1 texture space. The pieces may become distorted.
Spacing Presets  Maya puts a bounding box around each piece and lays out the pieces so that the bounding boxes are very close together. If the pieces end up positioned exactly next to each other, two UVs on different pieces can share the same pixel and when texture painting, overscanning can also cause the paint to spill onto the adjacent piece.

To avoid this situation, ensure that there is at least a pixel between the bounding boxes by selecting a spacing preset from this menu. Select a preset that corresponds to your texture map size. If you don’t know the size, select a smaller map, which will result in a larger spacing between adjacent pieces in UV space. (The smaller your map in pixels, the bigger the UV spacing must be between bounding boxes.) Select Custom to set the size of the space as a percentage of the map size (in the Percentage Space box).

Percentage Space  If you select Custom beside Spacing Presets, enter the size of the space between bounding boxes as a percentage of the map size.

Subdiv Surfaces › Full Crease Edge/Vertex

Full Crease Edge/Vertex modifies the appearance of a subdivision surface by applying an edge shaped feature along the selected region of the mesh.

Applying a crease is useful when you want a sharp edge or transition on a surface. You can also apply a partial crease, or uncrease previously creased regions of the surface. The feature produced by a full crease appears more pronounced on the surface than a partial crease.

Related topics

- Apply or remove a crease in a subdivision surface on page 18

Subdiv Surfaces › Partial Crease Edge/Vertex

Partial Crease Edge/Vertex modifies the appearance of a subdivision surface by applying an edge shaped feature along the selected region of the mesh.
Applying a crease is useful when you want a sharp edge or transition on a surface. You can also apply a full crease, or uncrease previously creased regions of the surface. The feature produced by a partial crease appears less pronounced on the surface than a full crease.

**Related topics**
- Apply or remove a crease in a subdivision surface on page 18

**Subdiv Surfaces > Uncrease Edge/Vertex**

Uncrease Edge/Vertex removes any previously applied full or partial crease features from the selected region of a subdivision surface.

**Related topics**
- Apply or remove a crease in a subdivision surface on page 18

**Subdiv Surfaces > Mirror**

Turn on the axes you want to mirror the surface along and click Mirror or Apply. By default, Maya duplicates and flips the surface along the X axis.

![Mirror Examples](image.png)

Original surface  |  Mirror X  |  Mirror Y  |  Mirror Z

If you transform the surface and then freeze the transformation (Modify > Freeze Transformation) before mirroring, the surfaces will mirror relative to the axis of choice.
If you intend to merge surfaces after mirroring them, line up the original surface to the origin, freeze the transform, then perform the mirror.

**Subdiv Surfaces > Attach**

Merges two subdivision surfaces to create a new subdivision surface.

**Related topics**
- Attach subdivision surfaces on page 23

**Subdiv Surfaces > Attach >**

**Merge UVs Also** Merges the UVs shared by the edges that you attach. If turned off, the UVs are not merged and can be manipulated and edited independent of each other.

**Threshold** Any vertices further apart than this distance will not be attached. Set this value carefully. If it's too small, no vertices will attach. If it's too large, the operation may attach vertices that you do not want attached.

**Keep Originals** Controls whether Maya keeps the original surfaces you are attaching.
Subdiv Surfaces > Match Topology

Match Topology works in conjunction with Create Deformers > Blend Shape. Ordinarily, you do not need to run Match Topology, because the Blend Shape operation does it automatically.

Match Topology prepares multiple subdivision surfaces to be blended, such as copies of a character’s head in different poses. In order to blend subdivision surfaces, the surfaces must have the same vertices at all levels. Match Topology adds vertices as needed to make the vertices match on all selected objects.

You do not need to do Match Topology yourself, because the Create Blend Shape operation does it automatically. Do it only if you want to see the results before the blend shape operation. Note, however, that doing Match Topology yourself will lead to slower system performance when you blend shapes.

If you do Match Topology, first select two or more surfaces in any order. The surfaces must have the same number of faces on level 0. They do not necessarily need to have the same number of levels.

Match Topology only adds vertices. It does not match the vertex position edits or creases from one surface to another.
Subdiv Surfaces > Clean Topology

Clean Topology is used to remove any vertices that were created but not modified in a subdivision surface. Removing the extra, unused vertices helps to reduce the file size and improve interactive performance.

Related topics
■ Remove unused vertices from a subdivision surface on page 27

Subdiv Surfaces > Collapse Hierarchy

Set the number of levels to collapse and click Collapse or Apply. For example, if you enter 2, level 2 edits become level 0 edits.

Related topics
■ Reduce the number of levels in a subdivision surface on page 26

Subdiv Surfaces > Standard Mode

Standard mode is a display mode for subdivision surfaces that displays a subdivision surface in its native form.

When working with a subdivision surface in Standard mode you can do the following:
■ Add levels of refinement to selected regions of the subdivision surface where you need more detail in your mode. Adding levels of refinement adds vertices to the surface by subdividing the selected region.
■ Switch between any existing levels of refinement.
■ Manipulate refined components (move, rotate, or scale) and keyframe the surface.
■ Switch between Standard mode and Polygon Proxy mode at any stage of modeling using the marking menu.

Related topics
■ Standard mode and polygon proxy mode on page 3
Subdiv Surfaces > Polygon Proxy Mode

Polygon Proxy mode is a display mode for subdivision surfaces that displays a polygon mesh that corresponds to the base mesh (level 0) for the subdivision surface.

In Polygon Proxy mode you can do the following:
- Edit the subdivision surface using the polygon tools.
- Switch between Polygon Proxy mode and Standard mode at any stage of modeling using the marking menu.

Related topics
- Standard mode and polygon proxy mode on page 3
- Subdiv Surfaces > Standard Mode on page 52

Subdiv Surfaces > Sculpt Geometry Tool

Use this tool to sculpt NURBS, polygons, and subdivision surfaces. This tool is based on the Maya Artisan tools. For more information, see How Artisan brush tools work in the Artisan guide and the related topics listed below.

For a description of the Sculpt Geometry Tool options see Mesh > Sculpt Geometry Tool in the Polygon Modeling guide.

Related topics
- Soft Selection overview
- Sculpt a NURBS or polygon surface mesh
- Smooth a surface mesh
- Erase surface sculpting to an earlier state
- Sculpt according to an attribute map on NURBS
- Sculpt across seams and surface edges on NURBS
- Keyframe sculpting changes
Subdiv Surfaces > Convert Selection to Faces

Convert Selection to Faces changes the current subdivision selection to any faces that are associated with the selected subdivision components at the current subdivision level.

**TIP** Many of the convert selection features are available from the context sensitive subdivision surface marking menu when you press Ctrl + right-click whenever a subdivision surface component is selected.

Subdiv Surfaces > Convert Selection to Edges

Convert Selection to Edges changes the current subdivision selection to any edges that are associated with the selected subdivision components at the current subdivision level.

**TIP** Many of the convert selection features are available from the context sensitive subdivision surface marking menu when you press Ctrl + right-click whenever a subdivision surface component is selected.

Subdiv Surfaces > Convert Selection to Vertices

Convert Selection to Vertices changes the current subdivision selection to any vertices that are associated with the selected subdivision components at the current subdivision level.

**TIP** Many of the convert selection features are available from the context sensitive subdivision surface marking menu when you press Ctrl + right-click whenever a subdivision surface component is selected.

Subdiv Surfaces > Convert Selection to UVs

Convert Selection to UVs changes the current subdivision selection to any UV texture coordinates that are associated with the selected subdivision components at the current subdivision level.

**TIP** Many of the convert selection features are available from the context sensitive subdivision surface marking menu when you press Ctrl + right-click whenever a subdivision surface component is selected.
**Subdiv Surfaces > Refine Selected Components**

Lets you edit the next finer subdivision surface level if it currently exists. If a finer subdivision surface level does not exist, the Refine Selected Components feature increases the level of detail possible for a subdivision surface by adding one level of refinement to the subdivision surface based on the components that were originally selected.

For example, if three faces are selected on a subdivision surface and you then select Refine Selected Components, a level of refinement is added to the regions contained within the three selected faces on the surface. That is, additional faces get added to that region on the subdivision surface.

This lets you add increasingly finer features and details to a subdivision surface in the regions that require it. If you require further detail, simply select Refine Selected Components again with the components still selected and additional detail will be added to the selected area.

**Related topics**

- Create a new subdivision level on page 15

**Subdiv Surfaces > Select Coarser Components**

Lets you edit the next coarser level of a subdivision surface, by selecting the related subdiv component one level higher in the subdiv level hierarchy.

**Related topics**

- Switch between subdivision levels on page 16

**Subdiv Surfaces > Expand Selected Components**

Enlarges the region of subdivision refinement at a particular refinement level based on the selection of refined components.

For example, if you have added detail to a region on a subdivision surface using the Refine Selected Components feature and want to increase the level of detail outwards, you can select the components on the border of the refined region and then select Expand Selected Component to enlarge the area of refinement.
Related topics
■ Create a new subdivision level on page 15

Subdiv Surfaces > Component Display Level > Finer

Changes the display of components for the currently selected subdivision surface so it displays the next finer (higher numbered) subdivision level from whatever subdivision level is currently displayed.

For example, if the current subdivision level being display is 1, and you select Component Display Level > Finer, the display of the surface updates to show the next finer subdivision surface level (level 2).

Related topics
■ Switch between subdivision levels on page 16

Subdiv Surfaces > Component Display Level > Coarser

Changes the display of components for the currently selected subdivision surface so it displays the next coarser (lower numbered) subdivision level from whatever subdivision level is currently displayed.

For example, if the current subdivision level being display is 2, and you select Component Display Level > Coarser, the display of the surface updates to show the next coarser subdivision surface level (level 1).

Related topics
■ Switch between subdivision levels on page 16

Subdiv Surfaces > Component Display Level > Base

Changes the display of components for the currently selected subdivision surface so it displays at the coarsest (level 0) subdivision level from whatever subdivision level is currently displayed.

For example, if the current subdivision level being display is 2, and you select Component Display Level > Base, the display of the surface updates to show the coarsest subdivision surface level (level 0).
Subdiv Surfaces > Component Display Filter > All

Sets the display for selected subdivision surfaces so that all vertices on the subdivision mesh are displayed. If the Subdiv Component Display Filter setting for the subdivision surface was previously set to Edits, this display mode resets the display so that all vertices are displayed. This feature controls the Subdiv Component Display Filter attribute on the object’s shape node.

Related topics

- Display the edited vertices on a subdivision surface on page 22

Subdiv Surfaces > Component Display Filter > Edits

Sets the display for subdivision surfaces so that only edited vertices on the subdivision mesh are displayed. This display mode lets you more easily view and select the vertices that have been modified at a particular subdivision level. This feature controls the Subdiv Component Display Filter attribute on the object’s shape node.

Related topics

- Display the edited vertices on a subdivision surface on page 22
Index

4-sided polygons (quads), using  7

A
Adaptive tessellation method
  when rendering  41
Attach (Subdiv Surfaces menu)  50
attach subdivision surfaces  23
automatic mapping  32
Automatic Mapping (Subdiv Surfaces >
  Texture)  45

B
base mesh  4
binding skeletons to subdivision
  surfaces  39
binding, tips  39
blend shape, creating  40

C
clean up subdivision surfaces  26
cluster deformers, creating  40
Collapse Hierarchy (Subdiv Surfaces
  menu)  52
collapse levels  27
combine subdivision surfaces  23
dashed lines representing creases  19
control points
  increase  15
crease
  add or remove  18
cylindrical mapping
    image center, changing  44
    image rotation angle, change  44

D
deformed lines representing creases  19
deroformer
  apply to a subdivision surface  39
deroformer dependency graph nodes
texture placement before
  deformation  44
Depth tessellation method
  when rendering  41

e
edges
  attaching  23
  create  18
dashed lines representing creases  19
  put in mesh  8
  edit
    UVs  34
    Edit NURBS menu
      Sculpt Surfaces Tool  53

F
faces
  select for mapping  31
  selecting  34
    use as few as possible  7
  Fit to Best Plane
    planar mapping option  43
  Fit to Bounding Box
    planar mapping option  43
  flip a surface  49
  Flip Reversed layout UVs option  47
  floating edges  8
  Format option  41
  free points  8
full crease, create 18

H
history, deleting 39

I
Image Center
cylindrical, spherical mapping option 44
Image Rotation
cylindrical, spherical mapping option 44
Image Scale
cylindrical, spherical mapping option 44
Inherit UVs from Poly 31
Insert Before Deformers
correct swimming textures 44
interactive performance, improve 26

K
Keep Image Ratio
Planar mapping option 44
Keep Subd UVs 31

L
lamina topology 8
Layout
layout UVs option 47
Layout UVs (Subdiv Surfaces > Texture) 46
levels
create new 15
defined 4
keeping the same when deforming 40
reduce number 26
switch 16

M
mapping
automatic 32
planar 32
Mapping direction
planar mapping option 43
Match Topology (Subdiv Surfaces menu) 51
mesh
put in vertices and edges 8
Mirror (Subdiv Surfaces menu) 49
modeling workflow 2
modes, about 4
Modify menu
Convert 43
moving a planar projection 44

N
nonmanifold topology 8
normals
inconsistent 9
NURBS
prepare surface for conversion 9

O
Optimize automatic mapping option 45
overlapping
avoiding 32

P
partial crease, create 18
Percentage Space
automatic mapping option 46
layout UVs option 48
performance
increase with reshaping 26
planar mapping 32
Planar Mapping (Subdiv Surfaces > Texture) 43
plane
for projecting UVs, resizing 32
projection, resize or rotate 32
Planes option 45
points
  sharp, create 18
polygon mesh
  converting to 9
  put in vertices and edges 8
polygon model
  checking how it will convert 3
polygon proxy mode
  about 4
  for polygon tools 20
  use UVs 30
polygons
  convert subdivision surface to 11
  non-convertible 8
  prepare 7
  sculpt tool 37
projection
  multiple planes, UV assigned by 32
  plane, resize and rotate 32
  snap to best plane 43
  snap to bounding box 43
  UV assigned by 32
Projection Center
  planar mapping option 44
Projection Height
  planar mapping option 44
Projection Rotation
  planar mapping option 44
Projection Width
  planar mapping option 44
proxy mode, polygon 4

Q
quads, using 7

R
refined region
  create 15
  expand 16
region
  add control points 15
rendering subdivision surfaces 41

S
Sample Count tessellation method
  when rendering 41
Scale
  layout UVs option 47
Scale mode
  automatic mapping option 45
Sculpt Polygons tool
  about 37
Sculpt Surfaces Tool
  options 53
  selecting
    faces 34
Separate layout UVs option 47
sharp point, create 18
Shell Layout
  automatic mapping option 45
Shell stacking
  automatic mapping option 45
skeletons, binding to subdivision surfaces 39
smooth proxy 3
Spacing Presets
  automatic mapping option 46
  layout UVs option 48
spherical mapping
  change image center 44
  change image rotation angle 44
  change image scale (width, height) 44
standard mode
  about 4
Subdiv Surfaces menu
  Attach 50
  Collapse Hierarchy 52
  Match Topology 51
  Mirror 49
  Texture 43
subdivision surface
  advantages of 2
  apply deformer to 39
  attach 23
  bind to skeletons 39
  clean up 26
  convert to polygons 11
creating blend shapes, cluster deformers for 40
duplicate and flip 49
edit UVs 34
levels of detail 15
map UVs to 31
mapping operations 30
modeling workflow 2
prepare for blending 51
prepare NURBS surface for 9
reduce number of levels 26
remove unused components 27
rendering 41
reshape 25
switch levels 16
tips for working with 39
UV projection 32
UV projection from multiple planes 32
swimming textures correct 44

T
tessellation methods for rendering 41
texture placement before deformation 44

swimming, correcting 44
twisted in polygon proxy mode 30
Texture (Subdiv Surfaces menu) 43
topology clean 27
match 51
transformation tools 25

U
Uniform tessellation method when rendering 41
UVs borders 35
edit 34
mapping 29
mapping, how to 31
treatment in polygon proxy mode 31

V
vertices adding with Match Topology 51
during deformation 40
put in mesh 8