
 
 



 
 

Autodesk NavisWorks 2009 Solutions 
This document details support provided by the current release of Autodesk 
NavisWorks 2009 solutions (including Autodesk NavisWorks Review, Autodesk 
NavisWorks Simulate and Autodesk NavisWorks Manage) for: 

• CAD file formats. 
• Laser scan formats. 
• CAD applications. 
• Scheduling software. 

 
NOTE: When referring to NavisWorks or Autodesk NavisWorks 2009 solutions in this 
document this does NOT include Autodesk NavisWorks Freedom 2009, which only 
reads NWD or 3D DWF files. 
 
Product release version: 2009.1 
 
 
Document version: 1.2 
July 2008 
 
 
 
 
 
 
 
 
 
 

© 2008 Autodesk, Inc.  All rights reserved.  Except as otherwise permitted by Autodesk, Inc., 
this publication, or parts thereof, may not be reproduced in any form, by any method, for any 
purpose. 

Autodesk, AutoCAD, Civil 3D, DWF, DWG, DXF, Inventor, Maya, NavisWorks, Revit, and 3ds Max are 
registered trademarks or trademarks of Autodesk, Inc., in the USA and other countries. All other 
brand names, product names, or trademarks belong to their respective holders. Autodesk reserves the 
right to alter product offerings and specifications at any time without notice, and is not responsible for 
typographical or graphical errors that may appear in this document.     

Disclaimer   

Certain information included in this publication is based on technical information provided by third 
parties.  THIS PUBLICATION AND THE INFORMATION CONTAINED HEREIN IS MADE AVAILABLE BY 
AUTODESK, INC. “AS IS.”  AUTODESK, INC. DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR 
IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR 
FITNESS FOR A PARTICULAR PURPOSE REGARDING THESE MATERIALS.  



 
 

Contents 
Supported CAD File Formats ........................................................................................................ 6 

Supported Laser Scan Formats .................................................................................................... 7 

Supported Applications ................................................................................................................. 8 

Autodesk ................................................................................................................................... 8 

AutoCAD R14 to 2009 ........................................................................................................... 8 

ADT 3.3 to 2007, AutoCAD Architecture 2008-2009 ............................................................. 8 

Building Systems, AutoCAD MEP 2008-2009 ....................................................................... 9 

Autodesk Inventor 5 to 11, 2009 ............................................................................................ 9 

AutoCAD Civil 3D 2008 ....................................................................................................... 10 

MDT 6 to 2008 ..................................................................................................................... 10 

Revit 4 to 7 ........................................................................................................................... 10 

Revit Building 8.1 to 9.1, Revit Architecture 2008-2009 ...................................................... 11 

Revit Structure 2 to 4, 2008-2009 ........................................................................................ 11 

Revit Systems, MEP 2008-2009 .......................................................................................... 11 

Autodesk 3ds Max 3 to 2009 ............................................................................................... 11 

Autodesk VIZ 3 to 2008 ....................................................................................................... 12 

Autodesk Maya .................................................................................................................... 12 

Bentley .................................................................................................................................... 13 

AutoPLANT .......................................................................................................................... 13 

MicroStation SE ................................................................................................................... 13 

MicroStation J ...................................................................................................................... 14 

MicroStation v8 to 8.5, XM (8.9) .......................................................................................... 14 

Triforma J ............................................................................................................................. 15 

Triforma v8 to 8.9 ................................................................................................................. 15 

Graphisoft ................................................................................................................................ 16 

ArchiCAD 6.5 to 7 ................................................................................................................ 16 

ArchiCAD 8 to 11 ................................................................................................................. 16 

Constructor 2005 to 2007 .................................................................................................... 16 

AceCad .................................................................................................................................... 16 

StruCad ................................................................................................................................ 16 

auto.des.sys ............................................................................................................................ 17 

form.z ................................................................................................................................... 17 

AEC ......................................................................................................................................... 17 

CADPIPE ............................................................................................................................. 17 

AVEVA .................................................................................................................................... 17 

PDMS .................................................................................................................................. 17 



 

CADopia .................................................................................................................................. 18 

IntelliCAD ............................................................................................................................. 18 

CEA Technology ..................................................................................................................... 18 

Plant-4D ............................................................................................................................... 18 

COADE, Inc. ............................................................................................................................ 18 

CADWorx Plant .................................................................................................................... 18 

CADWorx Pipe ..................................................................................................................... 18 

CADWorx Steel .................................................................................................................... 19 

COINS ..................................................................................................................................... 19 

BSLink ................................................................................................................................. 19 

Framing ................................................................................................................................ 19 

CSC ......................................................................................................................................... 20 

3D+ ...................................................................................................................................... 20 

Dassault Systemes .................................................................................................................. 20 

CATIA .................................................................................................................................. 20 

Google ..................................................................................................................................... 20 

SketchUp (upto v6) .............................................................................................................. 20 

Hannappel SOFTWARE GmbH .............................................................................................. 21 

elcoCAD R4 ......................................................................................................................... 21 

Intergraph ................................................................................................................................ 21 

PDS ..................................................................................................................................... 21 

Informatix ................................................................................................................................. 21 

MicroGDS ............................................................................................................................ 21 

ITandFactory ........................................................................................................................... 22 

CADISON ............................................................................................................................ 22 

TRICAD MS ......................................................................................................................... 22 

Kiwi Software GmbH ............................................................................................................... 23 

ProSteel 3D ......................................................................................................................... 23 

Kubotek USA ........................................................................................................................... 23 

CADKEY .............................................................................................................................. 23 

M.A.P. ...................................................................................................................................... 23 

CAD-Duct ............................................................................................................................. 23 

McNeel North America ............................................................................................................ 24 

Rhino ................................................................................................................................... 24 

Mensch und Maschine ............................................................................................................ 24 

RoCAD ................................................................................................................................. 24 

MultiSUITE .............................................................................................................................. 24 

MultiSTEEL .......................................................................................................................... 24 



 

Nemetschek ............................................................................................................................ 25 

Allplan .................................................................................................................................. 25 

PROCAD ................................................................................................................................. 25 

3DSMART ............................................................................................................................ 25 

PTC ......................................................................................................................................... 25 

Pro/ENGINEER ................................................................................................................... 25 

CADDS 5 ............................................................................................................................. 25 

QuickPen ................................................................................................................................. 26 

PipeDesigner 3D .................................................................................................................. 26 

DuctDesigner 3D ................................................................................................................. 26 

RAM International .................................................................................................................... 26 

CADstudio ............................................................................................................................ 26 

SolidWorks .............................................................................................................................. 27 

SolidWorks ........................................................................................................................... 27 

Tekla ........................................................................................................................................ 27 

Tekla Structures ................................................................................................................... 27 

Xsteel ................................................................................................................................... 27 

think3 ....................................................................................................................................... 27 

thinkdesign ........................................................................................................................... 27 

UGS ......................................................................................................................................... 28 

I-deas ................................................................................................................................... 28 

Solid Edge ........................................................................................................................... 28 

NX (Unigraphics) ................................................................................................................. 28 

FactoryCAD ......................................................................................................................... 28 

UHP Process Piping ................................................................................................................ 29 

FabPro Pipe ......................................................................................................................... 29 

x-plant .................................................................................................................................. 29 

Supported Scheduling Software ................................................................................................. 30 

Asta ......................................................................................................................................... 30 

PowerProject ....................................................................................................................... 30 

Microsoft .................................................................................................................................. 30 

Project 2000 to 2007 ............................................................................................................ 30 

Primavera ................................................................................................................................ 30 

ProjectPlanner (P3) ............................................................................................................. 30 

Primavera ................................................................................................................................ 30 

Primavera Engineering and Construction ............................................................................ 30 

Microsoft .................................................................................................................................. 30 

Microsoft Project Exchange Format ..................................................................................... 30 



Autodesk NavisWorks 2009 Solutions 

 
Supported CAD File Formats | 6 

 

Supported CAD File Formats 
NavisWorks has its own native file formats (.nwd, .nwf, .nwc), however Autodesk 
NavisWorks solutions can additionally read a combination of many popular 3D CAD 
formats. The following table lists the CAD file formats currently supported by Autodesk 
NavisWorks 2009 solutions. 

 Format Extension Format Extension 

NavisWorks .nwd .nwf .nwc IGES .igs .iges 

AutoCAD .dwg, .dxf Inventor .ipt .iam. ipj 

MicroStation         
(SE, J, V8 & XM) .dgn .prp .prw Informatix 

MicroGDS .man .cv7 

3D Studio .3ds .prj RVM .rvm 

ACIS SAT .sat SketchUp .skp 

DWF .dwf STEP .stp .step 

PDS Design Review .dri STL .stl 

IFC .ifc VRML .wrl .wrz 
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Supported Laser Scan Formats 
The following table lists the laser scan formats currently supported by Autodesk 
NavisWorks 2009 solutions. 

Format Extension 

ASCII Laser File .asc .txt 

Faro .fls .fws .iQscan .iQmod .iQwsp 

Leica .pts .ptx 

Riegl .3dd 

Trimble Native file NOT supported. 
Convert to ASCII laser file 

Z+F .zfc .zfs 



Autodesk NavisWorks 2009 Solutions 
 
 

 
Supported Applications | 8 

Supported Applications 
 

The following table is a non-exhaustive list of CAD applications and properties currently 
supported by Autodesk NavisWorks 2009 solutions, along with any additional 
information that may be necessary to review your project files in NavisWorks software. 

  Exporter Native 
Format 

Other 
Format Properties 

Autodesk  
AutoCAD R14 to 2009 

    

AutoCAD Details  

Other Formats DXF, 3DS 

• Models can be exported from AutoCAD software as either .nwc or .nwd format. 
• NavisWorks also supports the native AutoCAD .dwg file format, which can be read 

directly into NavisWorks. 
• 64-bit AutoCAD is supported by Exporter only. 
• Object properties, (such as Material Colors and Entity Handles) are also supported 

by NavisWorks and these can be viewed in the 'Properties' window. To open the 
Properties window, go to View > Control Bars > Properties.  

 

ADT 3.3 to 2007, AutoCAD Architecture 2008-2009 
    

AutoCAD Architecture Details  

Other Formats DXF, 3DS 

• In order to read an ADT 2007 or later .dwg file into NavisWorks, you will need to 
install the corresponding Object Enabler, regardless of whether you have the 
application installed. 

NOTE: This relates to all AutoCAD 2007/later-based products.  

• In order to read an ADT 3.3 to 2006 .dwg file into NavisWorks, you need the 
ADT2007 (or later) object enabler installed on the same machine. 

NOTE: When using an object enabler, ensure the corresponding loader version (year) is 
selected in Tools > Global Options > File Readers > DWG/DXF/SAT > DWG Loader 
Version. 

• From ADT/AutoCAD Architecture software you can export to .nwc or .nwd. 
• For versions pre-2007, the Exporter is the preferred route to NavisWorks. 
• NavisWorks supports ADT object properties and these can be viewed in the 

'Properties' window. To open the Properties window, go to View > Control Bars > 
Properties. Automatic Properties are also supported for AutoCAD Architecture.  

• Autodesk NavisWorks Simulate and Autodesk NavisWorks Manage software 
support ADT/AutoCAD Architecture textures.  

http://www.navisworks.com/support/formats�
http://www.navisworks.com/support/formats�
http://www.autodesk.com/aecobjecten�
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Building Systems, AutoCAD MEP 2008-2009 
    

AutoCAD MEP Details  

Other Formats DXF, 3DS 

• In order to read a Building Systems 2007 or AutoCAD MEP.dwg file into 
NavisWorks, you will need to install the corresponding Object Enabler, regardless of 
whether you have the application installed. 

NOTE: This relates to all AutoCAD 2007/later-based products.  

• In order to read an earlier version (pre-2007) Building Systems .dwg file into 
NavisWorks, you need the Building Systems 2007 (or later) object enabler installed 
on the same machine. 

NOTE: When using an object enabler, ensure the corresponding loader version (year) is 
selected in Tools > Global Options > File Readers > DWG/DXF/SAT > DWG Loader 
Version. 

• From Building Systems/AutoCAD MEP software you can export to .nwc or .nwd. 
• For versions pre-2007, the Exporter is the preferred route to NavisWorks. 
• NavisWorks supports Building Systems/AutoCAD MEP object properties and these 

can be viewed in the 'Properties' window. To open the Properties window, go to 
View > Control Bars > Properties.  

 

Autodesk Inventor 5 to 11, 2009   
  

  
Inventor Details  

Other Formats IGES, STEP 

• In order to read an Inventor software file into NavisWorks, you either need Inventor 
5 (or higher), Inventor Design Tracking 5 (or higher), or Inventor View installed on 
the same machine as NavisWorks (you’ll need to install either the same or later 
version relevant to the file you wish to read). Inventor View can be downloaded from 
support.autodesk.com.  

• If you are using an Inventor Project file, (*.ipj) you will need to set this as the Active 
Project in NavisWorks, prior to opening your assembly drawings (*.iam). You can set 
the Active Project either by opening your *.ipj file in NavisWorks, or by going to 
Tools > Global Options > File Formats > Inventor, then enter the full path and file 
name of your *.ipj file (e.g. C:\my Inventor projects\project 1.ipj). Once loaded, you 
can then Open the corresponding assembly drawing(s) as usual. 

 

 

 

http://www.navisworks.com/support/formats�
http://www.autodesk.com/aecobjecten�
http://www.navisworks.com/support/formats�
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AutoCAD Civil 3D 2008 
 

  
  

Civil 3D Details  

Other Formats DXF, 3DS 

• The Civil 3D native .dwg file can be read directly into NavisWorks, however you will 
need to install the Civil 3D Object Enabler (available to download from the Autodesk 
website).  

• You can export a file from Civil 3D software to .nwc or .nwd.  
• Object properties, (such as Material Colors and Entity Handles) are also supported 

by NavisWorks and these can be viewed in the 'Properties' window. To open the 
Properties window, go to View > Control Bars > Properties. 

 

MDT 6 to 2008 
 

  
  

MDT Details  

Other Formats DXF, 3DS, VRML 

• The MDT native .dwg file can be read directly into NavisWorks, however you will 
need to install the MDT Object Enabler (available to download from the Autodesk 
website).  

• You can export a file from MDT software to .nwc or .nwd.  
• For versions pre-2007, the Exporter is the preferred route to NavisWorks. 
• 64-bit AutoCAD Mechanical is supported by Exporter only. 
• Object properties, (such as Material Colors and Entity Handles) are also supported 

by NavisWorks and these can be viewed in the 'Properties' window. To open the 
Properties window, go to View > Control Bars > Properties. 

 

Revit 4 to 7     
  

Revit Details  

Other Formats DWG, DXF, DGN 

• Revit platform files can be viewed in NavisWorks if they have been saved as either 
a .dwg, .dxf, or .dgn file format.  

• If you use the .dwg Export out of Revit 6 and 7, then object properties such as 
Element ID, Type and Category are supported. 

 

 

 

 

http://www.navisworks.com/support/formats�
http://www.navisworks.com/support/formats�
http://www.navisworks.com/support/formats�
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Revit Building 8.1 to 9.1, Revit Architecture 2008-2009 
 

  
  

Revit Building Details  

Other Formats DWG, DXF, DGN 

• NavisWorks can export .nwc files directly from Revit Building/Revit Architecture 
software. 
You will need to install NavisWorks on the same machine as Revit Building/Revit 
Architecture.  

• Revit properties are supported. These can be viewed in the 'Properties' window. To 
open the Properties window, go to View > Control Bars > Properties.  

Revit Structure 2 to 4, 2008-2009 
 

  
  

Revit Structure Details  

Other Formats DWG, DXF, DGN 

• NavisWorks can export .nwc files directly from Revit Structure software. 
You will need to install NavisWorks on the same machine as Revit Structure.  

• Revit properties are supported. These can be viewed in the 'Properties' window. To 
open the Properties window, go to View > Control Bars > Properties. 

Revit Systems, MEP 2008-2009 
 

  
  

Revit MEP Details  

Other Formats DWG, DXF, DGN 

• NavisWorks can export .nwc files directly from Revit Systems/Revit MEP software. 
You will need to install NavisWorks on the same machine as Revit Systems/Revit 
MEP.  

• Revit properties are supported. These can be viewed in the 'Properties' window. To 
open the Properties window, go to View > Control Bars > Properties.  

Autodesk 3ds Max 3 to 2009 
 

  
 

  
3ds Max Details  

Other Formats DWG, DXF, 3DS, IGES 

• To view your 3ds Max model in NavisWorks, you will need to have 3ds Max 
software installed on the same machine. Then, simply export to .nwc for use in 
NavisWorks.  

• 64-bit 3ds Max is also supported via an Exporter. 
• NavisWorks does not support .max files, so you cannot read the native file format 

directly into NavisWorks. 

NOTE: NavisWorks Simulate and Manage both support the export of textures and materials 
from 3ds Max.  
 

http://www.navisworks.com/support/formats�
http://www.navisworks.com/support/formats�
http://www.navisworks.com/support/formats�
http://www.navisworks.com/support/formats�
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Autodesk VIZ 3 to 2008 
 

  
 

  
Viz Details  

Other Formats DWG, DXF, 3DS 

• To view your VIZ model in NavisWorks, you will need to have VIZ software installed 
on the same machine. Then, simply export to .nwc for use in NavisWorks.  

• NavisWorks does not support .max files, so you cannot read the native file format 
directly into NavisWorks.  

NOTE: Autodesk NavisWorks Simulate and Autodesk NavisWorks Manage both support the 
export of textures and materials from Autodesk 3ds Max. 
  

Autodesk Maya     
 

  
Maya Details  

Other Formats DXF, IGES, VRML 

• NavisWorks has file readers for .dxf, .igs .iges and .wrl .wrz.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.navisworks.com/support/formats�
http://www.navisworks.com/support/formats�
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Bentley  
AutoPLANT 

    

AutoPlant Details  

Other Formats DWG, DXF, 3DS 

• In order to read an AutoPLANT DWG file into NavisWorks, you will first need to 
install the AutoPLANT Object Enabler.  

NOTE: When using an object enabler, choose one of the same or later version as the 
authoring application, and then ensure the corresponding (NavisWorks) loader version 
(year) is selected in Tools > Global Options > File Readers > DWG/DXF/SAT > DWG 
Loader Version. 

• You can also export to .nwc or .nwd if you have NavisWorks installed on the same 
machine as AutoPLANT. 

NOTE: To ensure geometry is rendered correctly when reading a DWG file into 
NavisWorks, or exporting from AutoPLANT, ensure the render type is set to Shaded in 
Tools > Global Options > File Readers > DWG/DXF/SAT > Render Type. 

• Currently, object property information is unavailable. This is due to changes in 
AutoPLANT that prevent the Component ID from being obtained, which is required 
to address the AutoPLANT MDB file.  

 

MicroStation SE 
    

MicroStation SE Details  

Other Formats DWG, DXF, DGN, IGES, VRML 

• Models can be exported as NWC or NWD files from MicroStation SE if you have 
NavisWorks installed on the same machine.  

• NavisWorks supports the native MicroStation .dgn file format, which can be read 
directly into NavisWorks.  

• Object properties, such as colors and ambient, diffuse and shininess properties of 
materials from .pal and .mat palette and material files are supported.  

•  Autodesk NavisWorks Simulate and Autodesk NavisWorks Manage support 
MicroStation materials and textures. 

NOTE: For optimum file fidelity we recommend the NWC (or NWD) Exporter from within 
MicroStation whenever possible.  
 
 
 
 

http://www.navisworks.com/support/formats�
http://www.navisworks.com/support/formats�
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MicroStation J 
    

MicroStation J Details  

Other Formats DWG, DXF, DGN, IGES, STEP, VRML 

• Models can be exported as NWC or NWD files from MicroStation J if you have 
NavisWorks installed on the same machine.  

• NavisWorks supports the native MicroStation .dgn file format, which can be read 
directly into NavisWorks.  

• Object properties, such as colors and ambient, diffuse and shininess properties of 
materials from .pal and .mat palette and material files are supported.  

• Intergraph PDS object information can be read from .drv files and DMRS and 
database linkage and association ID's are also supported. These can be viewed in 
the Properties window. To open the Properties window, go to View > Control Bars 
> Properties.  

• Autodesk NavisWorks Simulate and Autodesk NavisWorks Manage support 
MicroStation materials and textures. 

NOTE: For optimum file fidelity we recommend the NWC (or NWD) Exporter from within 
MicroStation whenever possible.  
 
NOTE: For exporting numerous files from MicroStation we recommend using the Perl 
script installed with NavisWorks (by default in, C:\Program Files\Autodesk\NavisWorks 
[Review/Simulate/Manage] 2009\Tools).  

 

MicroStation v8 to 8.5, XM (8.9) 
    

MicroStation v8 Details  

Other Formats DWG, DXF, DGN, IGES, STEP, VRML 

• Models can be exported as NWC or NWD files from MicroStation V8 if you have 
NavisWorks installed on the same machine.   

• NavisWorks supports the native MicroStation V8 dgn file format, which can be read 
directly into NavisWorks. 

• Object properties, such as colors and ambient, diffuse and shininess properties of 
materials from .pal and .mat palette and material files are supported. 

• Autodesk NavisWorks Simulate and Autodesk NavisWorks Manage support 
MicroStation materials and textures. 

NOTE: For optimum file fidelity we recommend the NWC (or NWD) Exporter from within 
MicroStation whenever possible.  
 
NOTE: For exporting numerous files from MicroStation we recommend using the Perl 
script installed with NavisWorks (by default in, C:\Program Files\Autodesk\NavisWorks 
[Review/Simulate/Manage] 2009\Tools).  
 

 
 

http://www.navisworks.com/support/formats�
http://www.navisworks.com/support/formats�
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Triforma J 
    

Triforma J Details  

Other Formats DWG, DXF, DGN, IGES, STEP, VRML 

• Models can be exported as NWC or NWD files from TriForma J if you have 
NavisWorks installed on the same machine. 

• NavisWorks supports the native TriForma J .dgn file format, which can be read 
directly into NavisWorks.  

• Object properties, such as colors and ambient, diffuse and shininess properties of 
materials from .pal and .mat palette and material files are supported.  

• Family and Part information from TriForma and PDS object information can be read 
from .drv files and DMRS and database linkage and association ID's are also 
suported. These can be viewed in the Properties window. To open the Properties 
window, go to View > Control Bars > Properties.  

• Autodesk NavisWorks Simulate and Autodesk NavisWorks Manage support 
TriForma materials and textures.  

NOTE: For optimum file fidelity we recommend the NWC (or NWD) Exporter from within 
TriForma whenever possible.  
 
NOTE: For exporting numerous files from TriForma we recommend using the Perl script 
installed with NavisWorks (by default in, C C:\Program Files\Autodesk\NavisWorks 
[Review/Simulate/Manage] 2009\Tools).  

 
 

Triforma v8 to 8.9 
   

Triforma v8 Details  

Other Formats DWG, DXF, DGN, IGES, STEP, VRML 

• Models can be exported as NWC or NWD files from TriForma V8 if you have 
NavisWorks installed on the same machine.   

• NavisWorks supports the native TriForma V8 dgn file format, which can be read 
directly into NavisWorks. 

• Object properties, such as colors and ambient, diffuse and shininess properties of 
materials from .pal and .mat palette and material files are supported. 

• Autodesk NavisWorks Simulate and Autodesk NavisWorks Manage support 
TriForma materials and textures. 

NOTE: For optimum file fidelity we recommend the NWC (or NWD) Exporter from within 
TriForma whenever possible.  

NOTE: For exporting numerous files from TriForma we recommend using the Perl script 
installed with NavisWorks (by default in, C:\Program Files\Autodesk\NavisWorks 
[Review/Simulate/Manage] 2009\Tools). 

http://www.navisworks.com/support/formats�
http://www.navisworks.com/support/formats�
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Graphisoft  
ArchiCAD 6.5 to 7 

 

  
  

ArchiCAD 6.5 to 7 Details  

Other Formats DWG, DXF, DGN 

• ArchiCAD can export to the NavisWorks .nwc file format. NavisWorks does NOT 
have a direct reader for ArchiCAD files.  

• ArchiCAD can also save files as .dwg, .dxf and .dgn formats. These can be read 
directly by NavisWorks.  

• Object properties, such as GUIDS and Library Part Parameters can optionally be 
exported with the NavisWorks file.  

ArchiCAD 8 to 11 
 

  
  

ArchiCAD 8 to 11 Details  

Other Formats DWG, DXF, DGN, IFC 

• ArchiCAD can export to NavisWorks .nwc file format. NavisWorks does NOT have 
a direct reader for ArchiCAD files.  

• ArchiCAD can also save files as .dwg, .dxf, .dgn and .ifc formats. These can be 
read directly by NavisWorks.  

• Object properties, such as GUIDS and Library Part Parameters can optionally be 
exported with the NavisWorks file.  

Constructor 2005 to 2007 
 

  
  

Constructor Details  

Other Formats DWG, DXF, DGN 

• Constructor 2005 can export to the NavisWorks .nwc file format. NavisWorks does 
NOT have a direct reader for Constructor 2005 files.  

• Object properties, such as GUIDS and Library Part Parameters can optionally be 
exported with the NavisWorks file.  

 

AceCad  
StruCad     

 

  
StruCad Details  

Other Formats DXF 

• StruCad files can be viewed in NavisWorks, if they have been saved as .dxf format.  
• Object properties are not supported. 

http://www.navisworks.com/support/formats�
http://www.navisworks.com/support/formats�
http://www.navisworks.com/support/formats�
http://www.navisworks.com/support/formats�
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auto.des.sys  
form.z 

 

form.z Details  

Other Formats DWG, DXF, 3DS, IGES, STL, VRML 

• NavisWorks supports all of the above file formats, which form.z can export to.  

 

AEC  
CADPIPE 

    

CADPIPE Details  

Other Formats DWG, DXF, 3DS 

• To view CADPIPE object properties in NavisWorks, you may need to turn on the 
Convert Object Properties option. To do this, go to Tools > Global Options > File 
Readers > DWG/DXF/SAT then click on the Advanced button and select the 
CADPIPE option. Any CADPIPE properties can then be viewed in the 'Properties' 
window. To open the Properties window, go to View > Control Bars > Properties.  

• CADPIPE 'Industrial' and 'Commercial' cannot be used at the same time. 
If both are installed, then industrial is used. You can disable either or both by going 
to Tools > (Hold down the Shift Key and click) Global Options > Registry > Current 
User > CADPIPE. Change the version you require to one (1) and disable the other 
version by changing that value to zero (0). 

AVEVA  
PDMS   

  

PDMS Details  

Other Formats RVM 

• NavisWorks can read .rvm files exported from PDMS.  
• AVEVA Review .rvs files are also supported. These require the same filename as 

the .rvm file.  
• PDMS attribute files are supported, output using either the 'Dump Attributes' or 

'Datal' formats. These can be viewed in the 'Properties' window. To open the 
Properties window, go to View > Control Bars > Properties.  

 
 

 

 

http://www.navisworks.com/support/formats�
http://www.navisworks.com/support/formats�
http://www.navisworks.com/support/formats�
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CADopia  
IntelliCAD   

  

  
IntelliCAD Details  

Other Formats DWG, DXF 

• NavisWorks supports the native IntelliCAD .dwg file format, which can be read 
directly into NavisWorks.  

CEA Technology  
Plant-4D     

 

  
Plant-4D Details  

Other Formats DWG, DGN 

• NavisWorks has file readers for .dwg and .dgn files, both of which are supported by 
Plant-4D.  

COADE, Inc.  
CADWorx Plant 

    

CADWorx Plant Details  

Other Formats DWG, DXF, 3DS 

• Models can be exported from CADWorx as either .nwc or .nwd format, if you have 
NavisWorks installed on the same machine.  

• NavisWorks also provides support for .dwg files enabling native CADWorx models 
to be read directly into NavisWorks.  

• CADWorx object properties are also supported by NavisWorks and these can be 
viewed in the 'Properties' window. To open the Properties window, go to View > 
Control Bars > Properties.  

• CADWorx piping, steel, and equipment data is fully supported by NavisWorks.  

CADWorx Pipe 
    

CADWorx Pipe Details  

Other Formats DWG, DXF, 3DS 

• Models can be exported from CADWorx as either .nwc or .nwd format, if you have 
NavisWorks installed on the same machine. 

• NavisWorks also provides support for .dwg files enabling native CADWorx models 
to be read directly into NavisWorks.  

• CADWorx object properties are also supported by NavisWorks NavisWorks and 
these can be viewed in the 'Properties' window. To open the Properties window, go 
to View > Control Bars > Properties.  

• The legacy product, CADWorx Pipe, is fully supported by NavisWorks.  
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CADWorx Steel 
    

CADWorx Steel Details  

Other Formats DWG, DXF, 3DS 

• Models can be exported from CADWorx as either .nwc or .nwd format, if you have 
NavisWorks installed on the same machine. 

• NavisWorks also provides support for .dwg files enabling native CADWorx models 
to be read directly into NavisWorks.  

• CADWorx object properties are also supported by NavisWorks NavisWorks and 
these can be viewed in the 'Properties' window. To open the Properties window, go 
to View > Control Bars > Properties. 

• CADWorx Steel is fully supported by NavisWorks. 

 

COINS  
BSLink 

    

BSLink Details  

Other Formats DWG, DXF, 3DS 

• In order to read a BSLink file into NavisWorks, you either need BSLink installed on 
the same machine as NavisWorks, or AutoCAD installed complete with the BSLink 
object enabler.  

• If BSLink is installed, the object enabler is not necessary. With NavisWorks 
installed on the same machine, simply export to .nwc or .nwd.  

• In NavisWorks, object properties can be viewed in the 'BSLink' tab in the 
'Properties' window. To open the properties window, go to View > Control Bars > 
Properties.  

Framing 
    

Framing Details  

Other Formats DWG, DXF, 3DS 

• In order to read a Framing file into NavisWorks, you either need COINS Framing 
installed on the same machine as NavisWorks, or ADT installed complete with the 
Framing object enabler.  

• If COINS Framing is installed, the object enabler is not necessary. If NavisWorks is 
installed on the same machine, simply export to .nwc or .nwd.  

• In NavisWorks, object properties can be viewed in the Framing tab in the 
Properties window. To open the properties window, go to View > Control Bars > 
Properties.  
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CSC  
3D+ 

  

  
 

3D+ Details  

Other Formats DWG 

• 3D+ has a NavisWorks Exporter, enabling you to export a NavisWorks file out of 
3D+.  

• Also see the 3D+ website for information on their 3D+ NavisWorks Reader. This is 
a plug-in to NavisWorks, enabling you to read the native .3nwc file format in 
NavisWorks.  

• 3D+ object properties are supported by NavisWorks via either of the above routes.  

 
 
Dassault Systemes  
CATIA     

 

  
CATIA Details  

Other Formats DXF, IGES, STEP 

• NavisWorks has file readers for .dxf, .igs and .stp files, all of which can be exported 
from CATIA.  

• STEP is the preferred exchange format. 

 
 
Google  
SketchUp (upto v6) 

  

SketchUp Details  

Other Formats DWG, 3DS 

• SketchUp .skp files can can be read directly into NavisWorks.  
• Texture materials are supported in NavisWorks Simulate and Manage. 
• Grouping objects in SketchUp will make it easier to use the model in NavisWorks, 

for example applying Presenter materials, or attaching objects to TimeLiner tasks.  
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Hannappel SOFTWARE GmbH  
elcoCAD R4 

    

elcoCAD R4 Details  

Other Formats DWG, DXF, 3DS 

• Models can be exported from elcoCAD as either .nwc or .nwd format.  
• NavisWorks also supports the native elcoCAD .dwg file format, which can be read 

directly into NavisWorks.  
• Object properties are also supported by NavisWorks and these can be viewed in 

the 'Properties' window. To open the Properties window, go to View > Control Bars 
> Properties.  

Intergraph  
PDS 

    

PDS Details  

Other Formats DWG, DXF, DGN, IGES, STEP 

• Intergraph PDS will save the model geometry in a .dgn file and the property 
information in a .drv file. Both files are required by NavisWorks to read the model 
with object properties.  

• In NavisWorks, go to Tools > Global Options > DGN, scroll down and check the 
'Convert PDS Data' option. Ensure the .dgn and .drv files reside in the same 
directory. NavisWorks will then import the model, along with its properties.  

• PDS object properties can be viewed in the 'Properties' window. To open the 
Properties window, go to View > Control Bars > Properties.  

• If NavisWorks has been installed onto the same machine as Intergraph PDS, you 
will be able to export from PDS as a NavisWorks .nwc or .nwd file. 

 

Informatix  
MicroGDS   

 

    
MicroGDS Details  

Other Formats MAN 

• NavisWorks supports the native MicroGDS .man file format, which can be read 
directly into NavisWorks.  

• Colors and Materials from the file are supported. The .man File Reader options can 
be found in Tools > Global Options > File Readers > MAN.  
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ITandFactory  
CADISON 

    

CADISON Details  
CADISON Details 

Other Formats DXF, 3DS 

• NavisWorks can directly read CADISON .dwg files, utilizing the .dwg file reader.  
• In order to read a CADISON file into NavisWorks, you either need CADISON 

installed on the same machine as NavisWorks, or you will need to install the 
CADISON Object Enabler.  

• If CADISON is installed, the object enabler is not necessary.  

NOTE: When using an object enabler, ensure the corresponding loader version (year) is 
selected in Tools > Global Options > File Readers > DWG/DXF/SAT > DWG Loader 
Version. 

• With either CADISON or the Object Enabler installed, simply open the CADISON 
.dwg file in NavisWorks.  

• If CADISON is installed on the same machine as NavisWorks, then you can also 
export to .nwc or .nwd.  

• Exporting a NavisWorks file from CADISON also retains the models object 
properties that can be viewed in the 'Properties' window. To open the Properties 
window, go to View > Control Bars > Properties.  

 
TRICAD MS  

   
  

TRICAD Details  

Other Formats VRML 

• If TriCAD MS is installed on the same machine as NavisWorks, then you can also 
export to .nwc or .nwd.  

• Exporting a NavisWorks file from TRICAD MS also retains the models object 
properties that can be viewed in the 'Properties' window. To open the Properties 
window, go to View > Control Bars > Properties.  
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Kiwi Software GmbH  
ProSteel 3D 

   

  
ProSteel 3D Details  

Other Formats DWG, DXF, 3DS 

• This information relates to ProSteel 3D / ProStahl 3D / AutoPLANT Structural.  
• In order to read ProSteel files into NavisWorks, you either need ProSteel 3D 

installed on the same machine as NavisWorks, or AutoCAD/MDT/ADT installed 
complete with the relevant ProSteel 3D object enabler.  

• If ProSteel is installed, the object enabler is not necessary. Simply export to .nwd or 
.nwc.  

• Only basic AutoCAD properties are supported (such as Entity Handle and Material) 
and these can be viewed in the Properties window. This can be opened by going to 
View > Control Bars > Properties.  

Kubotek USA  
CADKEY     

 

  
CADKEY Details  

Other Formats DWG, DXF, IGES, STEP 

• NavisWorks has file readers for .dwg files and also .dxf, .igs and .stp files, all of which 
are supported by CADKEY. 

M.A.P.  
CAD-Duct 

    

CAD-Duct Details  

Other Formats DWG, DXF, 3DS 

• In order to read a CAD-Duct file into NavisWorks, you either need CAD-Duct 
installed on the same machine as NavisWorks, or have the CAD-Duct Object 
Enabler installed. The CAD-Duct Object Enabler can be downloaded from the 
CAD-Duct website, found under Support > Additional Files.  

NOTE: When using an object enabler, ensure the corresponding loader version (year) is 
selected in Tools > Global Options > File Readers > DWG/DXF/SAT > DWG Loader 
Version. 

• If CAD-Duct is installed, the Object Enabler is not necessary. Simply export to .nwd 
or .nwc.  

• In NavisWorks, object properties can be viewed in the 'CAD-Duct' tab in the 
'Properties' window. To open the Properties window, go to View > Control Bars > 
Properties.  
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McNeel North America  
Rhino     

 

  
Rhino Details  

Other Formats DWG, DXF, 3DS, IGES, STEP 

• To view your Rhino models in NavisWorks, you will have to export to one of the 
supported file formats (above). These can then be read directly into NavisWorks.  

 

Mensch und Maschine  
RoCAD 

    

RoCAD Details  

Other Formats DWG, DXF, 3DS 

• Models can be exported from RoCAD as either .nwc or .nwd.  
• NavisWorks also supports the .dwg file format, which can be read directly into 

NavisWorks.  
• If you do not have RoCAD installed on the same machine as NavisWorks, you will 

need to have AutoCAD installed, along with the RoCAD Object Enabler.  

NOTE: When using an object enabler, ensure the corresponding loader version (year) is 
selected in Tools > Global Options > File Readers > DWG/DXF/SAT > DWG Loader 
Version. 

• Object properties, (such as Material Colors and Entity Handles) are also supported 
by NavisWorks and these can be viewed in the 'Properties' window. To open the 
Properties window, go to View > Control Bars > Properties.  

 

MultiSUITE  
MultiSTEEL 

  

  
 

MultiSTEEL Details  

Other Formats DWG, DXF, 3DS 

• .dwg files from MultiSteel can be read directly into NavisWorks utilizing the .dwg file 
reader.  

• Models can also be exported from MultiSteel as either .nwc or .nwd.  
• MultiSteel object properties can be viewed in the 'Properties' window. To open the 

Properties window, go to View > Control Bars > Properties.  
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Nemetschek  
Allplan     

 

  
Allplan Details  

Other Formats DWG, DXF, DGN, IFC 

• All Plan files can be viewed in NavisWorks if they have been saved in one of the 
above formats.  

• Object properties are not supported.  

 

PROCAD  
3DSMART 

  

    
3DSMART Details  

Other Formats DWG, DXF, 3DS 

• With 3DSMART installed on the same machine as NavisWorks, you can read your 
DWG file directly into NavisWorks, utilizing the DWG file reader.  

• You can also export an .nwc or .nwd file directly from 3DSMART. 

  

PTC  
Pro/ENGINEER     

 

  
Pro/ENGINEER Details  

Other Formats IGES, STEP, VRML 

• You can read your Pro/ENGINEER models into NavisWorks via any of the above 
file formats.  

 

CADDS 5     
 

  
CADDS 5 Details  

Other Formats IGES, STEP 

• You can read CADDS 5 3D models into NavisWorks, by exporting either an IGES 
or STEP file from CADDS 5 and then utilize either the NavisWorks .igs, or .stp file 
readers.  
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QuickPen  
PipeDesigner 3D 

    

PipeDesigner 3D Details  

Other Formats DWG, DXF, 3DS 

• Models can be exported from PipeDesigner 3D as either .nwc or .nwd format.  
• NavisWorks also supports the native .dwg file format, which can be read directly 

into NavisWorks.  
• Object properties, (such as Material Colors and Entity Handles) are also supported 

by NavisWorks and these can be viewed in the 'Properties' window. To open the 
Properties window, go to View > Control Bars > Properties.  

 

DuctDesigner 3D 
    

DuctDesigner 3D Details  

Other Formats DWG, DXF, 3DS 

• Models can be exported from DuctDesigner 3D as either .nwc or .nwd format.  
• NavisWorks also supports the native .dwg file format, which can be read directly 

into NavisWorks.  
• Object properties, (such as Material Colors and Entity Handles) are also supported 

by NavisWorks and these can be viewed in the 'Properties' window. To open the 
Properties window, go to View > Control Bars > Properties.  

 

RAM International  
CADstudio 

    

CADstudio Details  

Other Formats DWG, DXF, 3DS 

• Models can be exported from CADstudio as either .nwc or .nwd format.  
• NavisWorks also supports the native CADstudio .dwg file format, which can be 

read directly into NavisWorks.  
• Object properties are also supported by NavisWorks and these can be viewed in 

the 'Properties' window. To open the Properties window, go to View > Control Bars 
> Properties. 
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SolidWorks  
SolidWorks 

 

SolidWorks Details  

Other Formats DWG, DXF, IGES, STEP, VRML 

• SolidWorks models can be exported to DWG, DXF, IGES, STEP or VRML format 
which can then be read into NavisWorks.  

 

Tekla  
Tekla Structures     

  

Tekla Structures Details  

Other Formats DGN, VRML 

• Tekla Structures can export to the .dgn file format, which can be read directly into 
NavisWorks.  

• Tekla Structures can additionally output to CIS/2. This may then be converted to 
VRML using the translator from the National Institute of Standards and Technology 
(see the NIST website for more information). The VRML file can then be read 
directly into NavisWorks.  

• Limited object properties are supported via the .dgn route.  

 

Xsteel     
  

Xsteel Details  

Other Formats DGN 

• Xsteel can export to the .dgn file format, which can be read directly into 
NavisWorks.  

• Limited object properties are supported via the .dgn route.  

 

think3  
thinkdesign     

 

  
thinkdesign Details  

Other Formats DWG, DXF, IGES, STEP 

• NavisWorks has file readers for .dwg/.dxf files and also .igs and .stp files.  
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UGS  
I-deas     

 

  
I-deas Details  

Other Formats DXF, IGES, STEP 

• NavisWorks has file readers for .dxf, .igs and .stp files.  

 

Solid Edge 
 

Solid Edge Details  

Other Formats IGES, STEP 

• Solid Edge can export to IGES and STEP files, which can be read directly into 
NavisWorks.  

 

NX (Unigraphics)     
 

  
NX Details  

Other Formats DXF, IGES, STEP 

• NavisWorks has file readers for .dxf, .igs and .stp files.  

 

FactoryCAD 
   

  
FactoryCAD Details  

Other Formats DWG, DXF, 3DS 

• In order to read a FactoryCAD file into NavisWorks, you either need FactoryCAD or 
the FactoryCAD object enabler installed on the same machine.  

NOTE: When using an object enabler, ensure the corresponding loader version (year) is 
selected in Tools > Global Options > File Readers > DWG/DXF/SAT > DWG Loader 
Version. 

• If FactoryCAD is installed, the object enabler is not necessary. Simply export to 
.nwc or .nwd. 
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UHP Process Piping  
FabPro Pipe 

   

  
FabPro-Pipe Details  

Other Formats DWG, DXF, 3DS 

• Models can be exported from FabPro Pipe as either .nwc or .nwd format.  
• NavisWorks also supports the native FabPro Pipe .dwg file format, which can be 

read directly into NavisWorks.  

 

x-plant  
x-plant 

   

  
x-plant Details  

Other Formats DWG, DXF, 3DS 

• Models can be exported from x-plant as either .nwc or .nwd format. 
 

• NavisWorks also supports the native x-plant .dwg file format, which can be read 
directly into NavisWorks. 
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Supported Scheduling Software 
 

The following table contains a list of the project scheduling software and formats 
supported by Autodesk NavisWorks Simulate 2009 and Autodesk NavisWorks 
Manage 2009. 

 

Developer Product File 
Format Notes 

Asta Powerproject  
8 to 10 .pp Requires Asta Powerproject to be installed on same 

machine, to make link. 

Microsoft Project  
2000 to 2007 .mpp Requires Microsoft Project to be installed on same 

machine, to make link. 

Primavera ProjectPlanner 
(P3) n/a 

Requires P3 to be installed on same machine. The 
file format is not read directly. Instead, TimeLiner logs 
into P3 and retrieves project information. 

Primavera 
Primavera 
Engineering and 
Construction 

n/a 

Requires Primavera v4.1, 5 or 6 Engineering and 
Construction to be installed on same machine, along 
with the Primavera SDK. TimeLiner connects to the 
Primavera database via an ODBC data source link. 

Microsoft Microsoft Project 
Exchange Format .mpx 

Does not require any project software to be installed. 
This is the common project exchange format which 
can be exported to from a number of scheduling 
packages. 

 


	Supported CAD File Formats
	Supported Laser Scan Formats
	Supported Applications
	Autodesk 
	AutoCAD R14 to 2009
	ADT 3.3 to 2007, AutoCAD Architecture 2008-2009
	Building Systems, AutoCAD MEP 2008-2009
	Autodesk Inventor 5 to 11, 2009
	AutoCAD Civil 3D 2008
	MDT 6 to 2008
	Revit 4 to 7
	Revit Building 8.1 to 9.1, Revit Architecture 2008-2009
	Revit Structure 2 to 4, 2008-2009
	Revit Systems, MEP 2008-2009
	Autodesk 3ds Max 3 to 2009
	Autodesk VIZ 3 to 2008
	Autodesk Maya

	Bentley 
	AutoPLANT
	MicroStation SE
	MicroStation J
	MicroStation v8 to 8.5, XM (8.9)
	Triforma J
	Triforma v8 to 8.9

	Graphisoft 
	ArchiCAD 6.5 to 7
	ArchiCAD 8 to 11
	Constructor 2005 to 2007

	AceCad 
	StruCad

	auto.des.sys 
	form.z

	AEC 
	CADPIPE

	AVEVA 
	PDMS

	CADopia 
	IntelliCAD

	CEA Technology 
	Plant-4D

	COADE, Inc. 
	CADWorx Plant
	CADWorx Pipe
	CADWorx Steel

	COINS 
	BSLink
	Framing

	CSC 
	3D+

	Dassault Systemes 
	CATIA

	Google 
	SketchUp (upto v6)

	Hannappel SOFTWARE GmbH 
	elcoCAD R4

	Intergraph 
	PDS

	Informatix 
	MicroGDS

	ITandFactory 
	CADISON
	TRICAD MS

	Kiwi Software GmbH 
	ProSteel 3D

	Kubotek USA 
	CADKEY

	M.A.P. 
	CAD-Duct

	McNeel North America 
	Rhino

	Mensch und Maschine 
	RoCAD

	MultiSUITE 
	MultiSTEEL

	Nemetschek 
	Allplan

	PROCAD 
	3DSMART

	PTC 
	Pro/ENGINEER
	CADDS 5

	QuickPen 
	PipeDesigner 3D
	DuctDesigner 3D

	RAM International 
	CADstudio

	SolidWorks 
	SolidWorks

	Tekla 
	Tekla Structures
	Xsteel

	think3 
	thinkdesign

	UGS 
	I-deas
	Solid Edge
	NX (Unigraphics)
	FactoryCAD

	UHP Process Piping 
	FabPro Pipe
	x-plant 


	Supported Scheduling Software
	Asta
	Powerproject 
	8 to 10

	Microsoft
	Project 
	2000 to 2007

	Primavera
	ProjectPlanner (P3)

	Primavera
	Primavera Engineering and Construction

	Microsoft
	Microsoft Project Exchange Format





