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Introducing Maya Muscle

Overview
Maya Muscle is a skin deformer that lets you rig characters with underlying
muscle objects to create realistic skin deformation. You can also use Muscle’s
independent Displacement, Force, Jiggle, Relax, Smooth, and Collision features
to create other deformation effects. Any NURBS surface in Maya can be converted
to include a Muscle Object shape node and be connected to the Maya Muscle
skin deformer.

For character rigging, you can build muscles based on the character’s skeleton
so that when the skeleton moves, the muscle objects squash and stretch and in
turn drive the surface of the character’s skin.

Muscles basically work as ‘influence objects’ but with special attributes that
precisely simulate the physical properties of muscle interacting with skin. Maya
Muscle lets you paint weights per-point to define exactly how the muscle
attributes (Sticky, Sliding, Relax, Jiggle) affect the skin.

This guide provides information on setting up your character rig to work with
Maya Muscle for skin deformation and on setting up other deformation effects.

Related topics

■ Creating Maya Muscles on page 5

■ Skin deformation on page 49

■ Point-caching on page 107

■ Collision on page 95
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Load Maya Muscle
Maya Muscle loads automatically. If you need to load Muscle manually, use
the following procedure.

To load Maya Muscle

1 Start Maya.

2 Select Window > Settings/Preferences > Plug-in Manager. The Plug-in
Manager opens.

3 Locate MayaMuscle and turn on Loaded. Maya loads the Muscle module
and adds the Muscle menu to the main menu set.

To load Muscle automatically every time you start Maya, turn on Auto
load.

4 Click Close.

You can access Maya Muscle features from the Muscle menu in the main menu
bar, or from the Muscle shelf.

Muscle workflow
There are a few options when you start using Maya Muscle to set up skin
deformations.

■ If you already use Maya skinClusters, you can convert your existing
skinClusters to use Maya Muscle (see Convert Maya skin to Maya Muscle
on page 63), or use Relative Sticky mode to use the Muscle deformer on
top of your skinClusters without transferring or recreating your rig (see
Relative Sticky deformation on page 52).

■ You can convert any NURBS surface in Maya to include a Muscle Object
shape node and connect it to the Maya Muscle skin deformer. See Manually
convert NURBS to Muscle Objects on page 16.

■ If you want to rig a character with Maya Muscle from scratch, you can
start by using Muscle to set up basic skin deformation between a skin mesh
and joint/bone objects.
While you can start by creating bones and muscles and weighting to them,
it is recommended that you do a more typical pass at rigging to
joints/bones/capsules first. This lets you focus on getting proper weighting
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and transitions all over your rig so that when you create and add weights
to muscles, you can transfer from each joint as needed.

This workflow is described in more detail in the steps below.

Step 1: Set up basic skin deformation for your rig

To set up a rig for basic skin deformation

1 Load a rig that includes a polygon skin mesh with some joints/bones.

2 Convert the joint/bone objects to capsules. See Convert Maya joints to
capsules on page 13.

3 Apply the Muscle deformer to your skin mesh. See Apply the Muscle
deformer on page 61.

4 Connect the bone/joint objects to the skin mesh. See Connect Muscle
Objects to a Muscle deformer on page 65.

5 Apply default weights for your rig. See Apply default weights on page 85.

NOTE Make sure your scene view is in a shaded mode.

6 Refine the default weighting by painting weights. See Paint Muscle weights
on page 86.

When you are finished, you have a basic skin setup with joints/bones,
and you can go on to create muscles.

Step 2: Set up muscle deformation for your rig

To set up a rig with muscle-skin deformation

1 Load a rig that has basic weights painted for the joint/bone/capsule objects
to the mesh. (See Step 1: Set up basic skin deformation for your rig on
page 3.)

2 Consider the types of muscle available (see Types of Muscle on page 6)
and create muscles.

■ To create muscles, see Create muscles with the Muscle Creator on
page 18.

■ To create simple muscles, see Create simple muscles with the Muscle
Builder on page 26.
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NOTE You can also create muscles by converting existing NURBS surfaces.
See Manually convert NURBS to Muscle Objects on page 16.

3 For muscles, set up the muscle poses for Squash & Stretch. See Set muscle
pose states on page 21.

4 Sculpt the muscles into the shapes you require.

■ For muscles, see Sculpt muscles on page 22.

■ For simple muscles, see Change the shape of simple muscles on page
28.

5 Connect the muscles to the Muscle skin deformer. See Connect Muscle
Objects to a Muscle deformer on page 65.

6 Apply default weights for the muscle. See Apply default weights on page
85.

7 Refine the weighting by painting muscle weights. See Paint Muscle weights
on page 86.

TIP While painting muscle weights, right-click the joint/bone objects in the
Influence list of the Muscle Paint window to enable the HOLD option. To
ensure the falloff from area to area on your rig remains similar, unlock one
bone and one muscle at a time, then add weight to that muscle. See Muscle
Paint window on page 149 for more information.

Step 3: Create a cache for faster playback

When you are finished with the muscle weighting, you can create a node or
file cache so that you can easily playback your animations and light/render
more quickly. See Create a cache on page 108.

NOTE You can also use the Maya Geometry Cache feature to create a cache. See
Geometry caching overview.
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Creating Muscles

Creating Maya Muscles
This guide explains the creation and set up of objects that work with the Maya®

Muscle skin deformer, showing you how to create capsules, convert joints to
capsules, and convert polygon meshes to bones. It also describes the process of
creating muscles.

Related topics

■ Muscle workflow on page 2

Muscle Objects
Capsules

Capsules are the Muscle primitive objects that you can connect to the Maya
Muscle skin deformer. They are basic Maya transform groups with a special
shape node underneath that is used to convert polygon or NURBS objects to
Muscle Objects that connect with skin.

Capsules are like Maya joints except that they have a shape and volume, which
allows them to be used for Sliding effects. When Sticky weighted to skin, capsules
deform the skin as they are moved, rotated, or scaled. This is similar to Maya
skinClusters. Sliding weights cause capsules to push out the skin geometry based
on their shape. Capsules can be non-uniformly scaled to get dynamic shapes.

You can create capsules from scratch or convert existing joints to capsules.

2
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Polygon bones

Before a polygon mesh can be used as a bone that deforms skin, it must have
a Muscle Object shape node added. The only advantage to using a polygon
mesh (instead of a capsule) as a bone object is that for Sliding effects the
deformer uses the real shape of the polygon mesh. Sticky weights for polygon
meshes are the same for capsules and bones, and are not based on surface
deformation.

Related topics

■ Create a capsule on page 10

■ Convert Maya joints to capsules on page 13

■ Convert polygonal meshes to bones on page 15

Types of Muscle
Any NURBS surface in Maya can be converted to have a Muscle Object shape
node and therefore can be connected to the Muscle deformer. In addition,
there are two tools that let you create two different types of muscles:

■ Muscles on page 6

■ Simple muscles on page 8

The main difference between the two muscle types is that simple muscles use
regular NURBS models with a special spline and spline deformer used to bend
them, while the new muscle is a parametric-style NURBS shape that has
deformation/posing ability.

Muscles

The Muscle Creator window lets you build a new, more powerful muscle with
rigging, shaping/sculpting, and deformation ability. These muscles include
two end points for each attach location so that you can more easily create
‘flat’ muscles and more easily orient your muscles. In addition, the Muscle
Creator window lets you grow muscles out to a surface. It is recommended
that you use these muscles for new rigs.

Some advantages of using this new muscle type include:

■ Adjustable resolution

■ Ability to mirror muscles after setup
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■ Easier rigging (you can parent the start and end locators and curves as
needed with no constraints)

■ Separate cross sections and attach points for each state of the muscle,
letting you create the shapes and poses you want for Squash, Stretch, and
Rest without custom muscle shaping

■ Ability to base pose states on rotation/translation, not just muscle length

■ More ‘correct’ deformation in that pulling or moving a control section at
one point on the muscle causes the surface to slide through the muscle
spline properly, instead of being localized as it is with a Muscle Spline
deformer

Advanced topics with the Muscle Creator

Muscles built with the Muscle Creator are designed to be simple and fast to
rig with, but also extensible for more advanced rigging. For example, a muscle
can be re-parented to a different part of the rig by re-parenting the muscle’s
attach locators and start/end curve. In addition, you can set the attach control
curves and leave them as is.

It is also possible to “rig” or adjust the attach curves. For example, you can
use Muscle KeepOut nodes to rig the muscle controls or attach nodes so that
they slide or collide with capsules or each other. (See Transform collisions
with KeepOut nodes on page 99.) Groups of muscles can also be deformed
with the Muscle Multi Collide deformer to provide muscle-muscle collision
before affecting skinning. (See Multi-Object Collision on page 99.)

Attach curves can also be re-parented, constrained or rigged in other ways.
Cross section curves can be deformed with blendshape targets to provide
animators with even more control over the shape of the muscle in various
situations.

Maya Muscle provides a high level of control for rigging muscles, but still
allows for even more customization using standard Maya articulation
techniques.

Muscle components

There are four main components that comprise the muscle:

■ Attach Points: Besides the two attach points for each end of the muscle,
each cross section/control has its own red ‘attach’ control along the length.
The red controls are the ‘rigging’ controls. You can parent these to the
objects you want the muscle to be attached to. By default, the Muscle
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Creator parents them half and half to the attach joints you select when
you create the muscle.
There are three attach points per control: one for the rest state, one for the
squash state, and one for the stretch state. This lets you adjust the length
or curve of the muscle so that it looks different in each state. Each of these
attach points is automatically driven by the Muscle Creator to go to a
default location. By adjusting the different states, you can simulate effects
like a muscle being pulled around a joint.

You can set/constrain the red ‘attach’ controls, but it is not necessary, as
they are usually auto-driven.

■ Cross Sections: The model is created by NURBS circle cross sections that
drive the shape. There are three sets: one for rest/default, one for squash,
and one for stretch.

■ Controls: Each cross section has a yellow control cube for control of the
muscle over time. You can think of these as ‘animator’ controls. These
controls move around automatically as children of the red ‘attach’ controls.
While it is not always necessary to animate the muscle spline with the
controls, each control has settings for the amount of jiggle on each part
of the muscle.

■ MuscleCreator node attributes: Most of the remaining controls are available
on the MuscleCreator node. This is where you can set the muscle resolution,
pose information, and other options. See cMuscleCreator node on page
161.

Simple muscles

The original Muscle Builder window lets you create basic Muscle Spline muscles.
In this documentation, these older Muscle Spline-based type muscles are
referred to as “simple muscles.”

Related topics

■ Create muscles with the Muscle Creator on page 18

■ Muscle Creator window on page 146

■ Muscle Builder window on page 139
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Other Muscle deformation
Any NURBS shape with a Muscle Object node can be used to skin with the
Muscle skin deformer. Typically, you use the Muscle Creator or Muscle Builder
windows to create and set up muscles, but you can also manually deform your
muscle with any regular Maya tool. In addition, you can set up any of Maya
Muscle's proprietary deformers on any object.

For example, even if you are not going to use muscles, you can apply a Muscle
Spline deformer onto any object, even a polygon mesh, to deform it with a
spline or Jiggle. You can also use the spline deformers to create a rig of joints
along a curve for things like spines or antennae.

Related topics

■ Create a Muscle Spline deformer on page 34

■ Create a Muscle Stretch deformer on page 43

Understand muscle Jiggle
This section explains the Jiggle settings on a muscle. The examples here are
also applicable to other muscle types, such as the Muscle Spline-based muscles.

If you select a control for the muscle, you see various attributes for Jiggle.
These are typically Jiggle, Cycle, and Rest attributes. In addition, Maya Muscle
provides more options including separate X, Y, Z values and Impact.

Jiggle A master multiplier for jiggle on the control. Setting it to 0 means there
is no jiggle. Raising the value makes the amount of jiggle that occurs as the
muscle moves stronger and more extreme.

JiggleX/Y/Z Multipliers on the Jiggle value. These values are relative to the
control space. Muscle Creator muscles always have controls such that the
Y-axis points down the length. In this case, the X and Z values strengthen or
dampen the amount of motion in the plane of the muscle, while the Y value
changes the amount of jiggle along its length. Since you do not want the
muscle to implode or slide too much along the length, this value defaults to
a smaller amount than the X and Z values.

Jiggle Impact Jiggle that occurs when the muscle undergoes a rapid change
from being stationary to moving, or from moving to stationary. Effectively,
when a big change in motion occurs, the Jiggle Impact attribute sets the
strength or amount of effect seen from that change. This motion is applied

Other Muscle deformation | 9



as a rotational movement around the axis of the muscle (a jiggle in the X-Z
plane only).

Jiggle Impact Start/Jiggle Impact Stop Set how much force is needed to
cause the impact motion to be applied. Typically, you want jiggle to occur
when a muscle stops moving, (for example when a large creature plants its
foot in a walk cycle), but not so much when it starts moving again. Because
of this, the Jiggle Impact Start value is a larger number, 1000, so it does not
trigger unless the force on the muscle changes at least 1000 units in one frame.
The default for Jiggle Impact Stop means the muscle force has to go from one
value to a value smaller by 0.001 units of force/movement for the impact
jiggle to trigger.

A good way to see the effect of Jiggle Impact is to set the normal X/Y/Z values
for jiggle to 0, then animate the muscle moving and stopping suddenly, then
play with the Jiggle Impact settings.

Cycle The number of frames it takes for the muscle to bounce back and forth.
For example a value of 12 means the muscle jiggles back and forth over 12
frames. Smaller values make the muscle oscillate faster, larger values make the
muscle appear to be heavier and slower.

Rest The number of frames the muscle takes to come to rest once forces on
it stop affecting it. Larger values make the muscle take longer to stop moving.

Create a capsule
To create a basic capsule object

 ➤ Select Muscle > Muscles/Bones > Make Capsule from the main menu bar.

A basic capsule is created. Since it is currently selected, it is highlighted
in green.
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You can also create a capsule with an End Locator. This locator automatically
drives the length of the capsule object. This can be useful when using capsules
for sliding when you need them to grow or expand like a muscle.

To create a capsule with an End Locator

1 From the main menu bar, select Muscle > Muscles/Bones > Make Capsule
with End Locator.

A capsule object is created with an end locator.

2 If you move the capsule or locator, the length of the capsule automatically
grows and aims to the locator. The rotation of the locator controls the
spin on the capsule. The translation of the locator lengthens the capsule.
Scaling the locator has no effect, although you can still scale the capsule.
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TIP If you create a capsule object without an end locator and you want to
add one, select the capsule object and select Muscle > Muscles/Bones > Add
End Locator to Capsule from the main menu bar.

Related topics

■ Capsules on page 5

Adjust capsule settings
You can adjust various capsule attributes on the Muscle Object node. Some
of these settings (such as Radius and Length) are specific to capsules, while
others (such as Strength and Fat) also appear on the Muscle Object shape node
for polygon bones and NURBS muscles. See cMuscleObject node on page 170
for descriptions of these settings.

You can access and alter muscle object settings in three places:

■ Channel Box: Select the object, then select the appropriate Muscle Object
shape in the SHAPES section of the Channel Box.

■ Attribute Editor: Select the object, open the Attribute Editor and select the
appropriate Muscle Object shape.

■ Muscle Parameters tab: Select Muscle > Simple Muscles > Set Muscle
Parameters.
The Muscle Builder window opens, displaying the Muscle Parameters tab.
This tab provides control over muscle deformers and settings, as well as
any capsule, bone, or muscle setting for its Muscle Object shape node
attributes.

Create polygon cylinders from capsules
Although capsules are not directly renderable, you can still show off or render
your capsules/joints using a conversion process to generate a simple polygon
cylinder from the capsules.

1 Select the capsule objects you want to create polygon representations for.

12 | Chapter 2   Creating Muscles



2 Select Muscle > Muscles/Bones > Generate Polygon Cylinders from
Capsules from the main menu bar.

New polygon cylinders with the same size and material color are created
and automatically parented under each capsule. These can now be
rendered.

Convert Maya joints to capsules
Any Maya joint can be converted to a capsule. This is useful since you do not
need to create a separate capsule object that would be parented to a joint.
Instead, the joint itself can get the Muscle Object shape and be directly
connected to the Muscle skin deformer.
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To convert joints to capsules

1 Create or load some joints in the Maya scene.

While it is not required, you want to align your joint axis such that one
of the local axes points cleanly down the length of the joint chain. The
default for Maya is X. You can use any free joint orient tool to align your
joints that way, or before creating joints, you can use the Joint Tool
settings and set the Orientation to yzx and the Second axis world
orientation to +y.

Regardless, you need to know which axis you are using for the axis down
the length of the joint.

2 Select the joint(s) you want to convert to capsules.

3 Select Muscle > Muscles/Bones > Convert Surface to Muscle/Bone from
the main menu bar.

4 In the window that appears, select the axis you are using down the length
of your joints.

The objects are converted to have capsule shapes. You can now colorize
and change other settings for the capsules. Their default length and radius
is set based on the initial joint locations.
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NOTE Due to a Maya limitation, Muscle Object parameters for converted
joints can only be set using the Channel Box and Muscle Parameters tab.
Using the Attribute Editor only works if you manually select the Muscle Object
shape node directly first.

Related topics

■ Capsules on page 5

Convert polygonal meshes to bones
The following shows a sample workflow for setting up a polygon bone:

1 Create or select a polygon object of your choice. (For example, select
Create > Polygon Primitives > Torus.)

2 Select Muscle > Muscles/Bones > Convert Surface to Muscle/Bone from
the main menu bar.

The object has a Muscle Object shape node added.

By default, Draw is set to off. If Draw is set to fat you can see the offset
from the polygon object that the sliding effect will have on the skin. The
image below shows a polygon torus with Draw set to fat with Highlight
set to off so that the Muscle Object shape draws as white.
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NOTE In the case of a polygon mesh object, the Muscle Object attributes
for radius, length, nSeg and nSides are not available since they are not needed.

Manually convert NURBS to Muscle Objects
You can make any NURBS surface connectable to the Muscle deformer by
converting it to have a Muscle Object shape node. You can deform the NURBS
surface however you want. Typically, this is done with one of Maya Muscle's
proprietary deformers, however you can also deform it with any other Maya
tools. This approach lets you convert existing NURBS-based muscle models,
or lets you deform the muscle with your own tools.

To convert a NURBS surface to a Muscle compatible surface

1 Select the NURBS surface you want to convert.

2 Select Muscle > Muscles/Bones > Convert Surface to Muscle/Bone from
the main menu bar.

The objects are converted to have a Muscle Object shape. This shape
provides basic settings to define how the muscle interacts with the skin
deformer, as well as basic drawing options.

Like capsules and bones, you can access the Muscle Object settings in the
Channel Box, Attribute Editor, or from the Muscle Builder window Muscle
Parameters tab.
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Set up muscle attach points
The Maya Muscle plug-in provides a way to easily generate locators stuck onto
the surface of NURBS or polygon mesh objects, even if they deform. This lets
you generate a regular object that is effectively always on the surface point of
the mesh as it moves. You can use these objects to parent muscle controls to,
or when specifying the Attach object in the Muscle Creator or Muscle Builder
windows.

To generate an attach point for a NURBS muscle or object

1 Right-click a NURBS object or muscle and select Surface Point from the
marking menu that appears. (For polygons, select Polygon Faces instead
of Surface Points.)

2 Select one or more surface points to use as the attach point(s). (For
polygons, select a polygon face, or two opposing edges.)

NOTE You can also select two opposing edges to manually select which
edges the attach locator uses. If you have selected two edges, you get one
attach locator between them. If you select four edges, you get two locators,
one for each pair in the order they were selected.

3 Select Muscle > Bonus Rigging > Surface Attach.

A Muscle Surf Attach node is created, and you have color-coded locators
for each surface point. These locators stay attached to the surface of the
NURBS object even if it deforms.
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4 You can adjust the u Loc and v Loc attributes in the Channel Box or
Attribute Editor to change the u/v location of the locator on the surface
of the object.

NOTE If your polygon attach locator appears to flip or move diagonally,
select the locator and set the Fix Poly Flip attribute to on in the Channel box.

Related topics

■ cMuscleSurfAttach node on page 186

Create muscles with the Muscle Creator
The following is a workflow overview of how you can build and work with
muscles using the Muscle Creator window.

1 Open the Muscle Creator window and create a muscle. See Open the
Muscle Creator window on page 19 and Create a muscle on page 19.

2 Set/store the muscle poses for Rest, Squash, and Stretch. See Set muscle
pose states on page 21.

To do this, switch to the Edit tab and bend the actual bones/joints that
the muscle is attached to into the Rest, Squash and Stretch states, then
click the Set Current State As buttons for each state.

3 Go back to the default state/bone positions. Adjust the start/end locations
for the muscle as well as the red cubes to set up the default spline curve
for the muscle in the rest state.

4 Go to the Squash state. In this case, you can again move the control,
except do not move the red square, but instead move its child: the Sq
curve. This curve controls the centerline spline when the muscle is in
squash.

5 Repeat using the related St curves for stretch.

NOTE You may want to disable Jiggle during these steps so that you do not
see any of the Jiggle effect.

The way to think about this is the muscle goes through some centerline.
That line is an implicit spline defined by the red boxes for Rest state, or
the Sq or St curves for the Squash and Stretch states. You need to tell the
muscle what state is what first, then fix or adjust those after storing the
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states. You must set all three states in order for state reading to work
correctly.

Adjust the cross sections for each state for actual shaping. This is similar
to custom muscle shaping, except it is all exposed and you have the exact
three states you want. You can also put blendShapes or rigging on the
cross section curves.

Related topics

■ Muscles on page 6

■ Muscle components on page 7

Open the Muscle Creator window
To launch the Muscle Creator window

 ➤ Select Muscle > Muscles/Bones > Muscle Creator from the main menu
bar.

The Muscle Creator window appears. The window has two main tabs,
Create and Edit.

Related topics

■ Create muscles with the Muscle Creator on page 18

■ Muscle Creator window on page 146

Create a muscle
The Muscle Creator window lets you build new NURBS muscles. You typically
need two objects to attach the muscle to, one for the start and one for the
end. Locator curves for each end are created so that you can set the width of
each side.

To create a new muscle

1 Select Muscle > Muscles/Bones > Muscle Creator from the main menu
bar to open the Muscle Creator window.
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2 In the Muscle Creator window, do the following:

■ In the Muscle Name field, enter a base name for the muscle (for
example “MusBiceps”).

■ Specify the number of controls and cross sections you want the muscle
to have, and the number of segments around.

NOTE These numbers cannot be changed once the muscle is created.

■ Select the start object and click the Attach Start  button, then

select the end object and click the Attach End  button to load
them into the window.

■ If you want to create a Muscle Object shape node, make sure the Create
cMuscle shape node option is on.

Typically, you want a Muscle Object shape node so that you can connect
the muscle to the Muscle deformer. If you decide to, you can turn off this
option, then convert the muscle to have a Muscle Object shape later.

3 Click Create Muscle.

A muscle is created. Depending on the orientation of your attach points,
the muscle may be twisted or need its end points adjusted.

Two curves that look like locators appear at each end. These start and
end points can be adjusted in the scene view to set the location of the
muscle. (See Muscle components on page 7 for information the muscle
that appears in the scene view.)

Once the muscle is created, you can switch to the Edit tab on page 147
for basic modeling and editing of the muscle.

Related topics

■ Muscles on page 6

■ Create muscles with the Muscle Creator on page 18

■ Muscle Creator window on page 146
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Delete a muscle
To delete a muscle created with the Muscle Creator window

1 Select a muscle created with the Muscle Creator window.

2 Select Muscle > Muscle Objects > Delete selected Muscle from the main
menu bar.

The muscle is deleted and any nodes and connections that are no longer
required are properly removed.

WARNING Once you have deleted a muscle, you cannot reuse the same
muscle name again. New muscles must be given a unique name.

NOTE To delete simple muscles created with the Muscle Builder window,
you cannot use the Delete selected Muscle menu item. In order to cleanly
delete simple muscles, you must manually delete all the associated objects
and connections.

Set muscle pose states
Built into muscles are three states: Rest, Squash and Stretch. You can set what
drives the muscle into these states, as well as what the center line curve looks
like for the muscle in each state.

It is a good idea to set up these pose states before sculpting your muscle. This
way you can be certain the poses you are sculpting are for the actual state you
are in.

To set the state of the muscle

1 Select Muscle > Muscles/Bones > Muscle Creator from the main menu
bar.

The Muscle Creator window opens.

2 Select the muscle if you have not already to load it into the window.

3 Click the Edit tab and in the Poses section, press the button for the state
you want to set.
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For example, you can go to the default/rest pose and click the Rest button,
then put the model into a squash state using the bones/joints and click the
Squash button, then do the same for the Stretch state.

It is important to set all three states for the muscle using these buttons before
tweaking the attach positions or model. Internally, the Muscle Creator stores
the relative change from the start attach object to the end attach object for
the muscle. (You can see that “group” nodes are created and parented to the
Start Parent curve that exists for the muscle.) This data includes information
on how the child bone is rotated and translated relative to the parent bone.
This information is then used to drive the different states on the muscle.

In addition, if you re-sculpt or adjust the two Attach Locators on each end of
the muscle to better position it, click Reset Width. This resets the new locator
distance to be the new default start/end widths for the muscle. This way, if
the autoWiden attribute is used, the cross sections scale properly.

Now that the pose state data is stored, you can set the center line positions
of the Attach controls. That is, you can adjust/move each of the Attach controls
to set how the muscle looks in each state. For example, for a knee, you can
adjust the attach states for a muscle so that when the knee is bent, the muscle
attaches stay outside the bones and the muscle appears to slide over the front
of the knee.

Sculpt muscles
After a muscle is created, you can edit the cross section curves to sculpt the
muscle into the shape you want. The Edit tab has a Sculpting section for this.

Muscle Creator muscles have three built-in cross section curve sets that you
can edit: one for the default rest position, one for the squash state, and another
for the stretch state. You can directly edit these curves in the scene view, or
using the Muscle Creator window.

IMPORTANT You need to edit the curve cross sections, not the muscle surface
itself. You generally do not want to manipulate the NURBS surface directly, since
that surface can be made more or less detailed using attributes on the Muscle
Creator node.

To sculpt with the Muscle Creator window

1 Select Muscle > Muscles/Bones > Muscle Creator from the main menu
bar.
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2 Click the Edit tab, then select any muscle or muscles that you created
with the Muscle Creator window.

3 In the Sculpting section of the Edit tab, select which axis of the cross
sections to edit.

The default is X-Z since they are flat cross sections. You can also edit the
Rest, Squash, or Stretch cross sections. For example, to make a muscle
more flat, turn X on and Z off, or vice-versa.

TIP The Sculpting part of the window can also work on selected points only.
If you select certain CVs on the cross section curves, the Sculpt slider affects
only those CVs.

4 Select which part of the muscle you want to affect using the Location
slider. (For detailed descriptions of the settings in the Muscle Creator
window’s Edit tab, see Muscle Creator window on page 146.)

5 Adjust the Sculpt slider to change the size of the muscle. As you drag,
you can see the shape being adjusted.

You can also select and edit the cross sections directly in the scene view.
Options at the bottom of the Edit tab let you select controls or cross sections
for the muscle(s) that have been chosen in the Muscle Creator window.

TIP Right-clicking each section lets you easily show or hide those items by setting
the Visibility attribute on the cMuscleCreator node for you.

TIP Right-clicking the Creator label above the selection lists lets you select just the
cMuscleCreator node to adjust its values in the Attribute Editor or Channel Box.

Related topics

■ Sculpting settings on page 147

Grow a muscle
One advantage of the Muscle Creator window is that you can use it to help
sculpt your muscle shapes by growing them. That is, you can select a muscle
and have its points “grow” outwards to the actual model surface. This can
speed up your muscle modeling time since you no longer need to manually
edit the shapes of the muscles.
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To grow a muscle

1 Select Muscle > Muscles/Bones > Muscle Creator from the main menu
bar.

2 Click the Edit tab.

3 If you have not already done so, select the muscle. This loads it into the
Muscle Creator window.

4 Select the surface you want to grow to, typically a skin mesh.

5 In the Grow section, click the Grow To Surface  button to load that
surface.

For reference, the window needs to know what joint or bones run down
the closest to the length of the muscle.

6 Select the main joint and click the Main Bone  button.

For example for a biceps muscle, you want to select the UpperArm and
Elbow joints respectively for the Main and Tip bones. The window
attempts to select the Main Bone Tip object automatically. If it is
unsuccessful, or if it does not find the correct bone, select the correct tip

bone and press the other  button to load that bone as the tip.

7 Set the options in the Grow settings area of the Edit tab. See Grow Settings
on page 147 for detailed descriptions of these options. For example, you
can use the Fat slider to set an offset to keep the grown points inside the
surface.

8 Click Grow Muscle. If nothing is selected, all three cross sections, Rest,
Squash, and Stretch are affected by the Grow Muscle button.

NOTE You can also select specific points on the cross section and make only
those points grow by clicking Grow Sel Points.

By default, the growing occurs outwards from the centerline defined by
the start/Main and end/Tip bones you selected. All points within the
Angle range specified in the Grow settings are grown.

Depending on the values you have set in the %Rest/Sq/St fields, the
muscle cross sections grow out to the surface you selected as the Grow
To Surface. If you have set the %Rest/Sq/St values higher than 100%, the
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muscle grows based on the shape of the selected Grow To Surface mesh,
but can grow past the selected mesh.

TIP If you want to start with a clean muscle shape for growing, you can click
Reset to Cyl to reset the muscle to a perfect cylinder shape.

It is important to note that growing muscles is effectively moving the
cross section points for the muscle. Since the muscle is a NURBS surface
and the points of the cross section do not lie exactly on the surface, there
may be offsets from the surface mesh even if the fat value is 0 and the
percentage is set to 100.

Mirror muscles
The Muscle Creator window lets you use naming conventions to mirror muscles
after they have been sculpted. The muscle for each “side” needs to be parented
to joints/nodes that follow a Left or Right naming convention (or something
similar, like Front, Back), and each muscle must have been created with that
naming style. For example, if your naming convention is to differentiate
between left and right using _L and _R, the first muscle you create should be
named something like Bicep_L or Bicep_R.

To mirror a muscle

1 Select Muscle > Muscles/Bones > Muscle Creator from the main menu
bar.

2 Click the Create tab and find the Mirror section.

3 Select the axis you want to mirror across.

4 Enter the naming conventions you want to Search/Replace for. (Right-click
the field to bring up some common cases).

5 Click Mirror Muscle from Selection.

Copy and paste Muscle Creator settings
Similar to mirroring, you can copy and paste settings from one muscle to
another.
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To copy and paste settings from one muscle to others

1 Select the source muscle to copy from, then select the other muscles to
paste to.

2 In the Muscle Creator window, click Copy First Selected Muscle, Paste to
Other Selected Muscles.

Create simple muscles with the Muscle Builder
As an alternative to manually converting NURBS surfaces, you can create
simple muscles using the Muscle Builder window. The following section gives
an example of how to create simple muscles with the Muscle Builder window.

To build a simple muscle

1 Create some joints in the Maya scene.

While it is not required, you should align your joint axis such that one
of the local axes cleanly points down the length of the joint chain. The
default for Maya is X. You can use any free joint orient tool to align your
joints that way, or before creating joints, you can use the Joint Tool
settings and set the Orientation to yzx and the Second axis world
orientation to +y.

Regardless, you need to know which axis you are using down the length
of the joint. The Muscle Builder window is set up to expect the Y-axis
down the chain, but it works with any setting. The image below shows
an example of joints properly aligned with Y down the length:

2 Select Muscle > Simple Muscles > Muscle Builder from the main menu
bar.

The Muscle Builder window appears with the Build tab open.
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3 In the Attach Obj 1 and Attach Obj 2 fields, enter the name of each joint
or attach object. You can do this by selecting a joint, then clicking the

 buttons to load the object into the field. Shown below, joint1 and
joint2 have been entered.

In addition, you can change the nSpans and nSegs to a desired value.
You can set these two values at any time, but you have to click
Build/Update again to refresh the surface. All other values can be tweaked
once the surface is built. See Muscle Builder window on page 139 for more
information on each option.

4 Click Build/Update, and a simple NURBS muscle is generated with the
values that you have specified.
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5 Adjust the settings to control where the simple muscle is placed, its overall
width, and falloff scaling. You can click Attach Obj 1 or Attach Obj 2 to
directly select and move the attach points of the simple muscle.

Now you can work with the cross section tools to change the shape of
the simple muscle.

Related topics

■ Muscle Builder window on page 139

■ Simple muscles on page 8

Change the shape of simple muscles
To change the shape of a simple muscle

1 Select the simple muscle, and in the Muscle Builder window, click the
Cross Section tab.
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2 Select one or more cross sections from the Cross Section list on the left.
Once it is selected, you can translate the cross section.

3 Click Edit Cross Section.

The points of the cross section curve are highlighted and you can move
or scale them.

4 Click EDITING when you are finished. While in Edit mode, you can select
one or more cross sections in the scene and edit them, or select other
cross sections independently with the Span slider.

Change the shape of simple muscles | 29



NOTE In addition to using the editor to change the simple muscle shape,
you can edit the cross section curves or the simple muscle surface directly in
any scene view.

5 When you are finished, click EDITING so that cross section Edit mode is
finished, and the label of the button returns to Edit Cross Section.
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When you are finished working with the cross sections, you can finish
the simple muscle building process with the Finalize tab. This tab lets
you convert the NURBS surface into a shape that is usable with the Muscle
skin deformer. Until a simple muscle is finalized, it is not connectable or
usable as a muscle, and does not have any muscle deformation applied.

Related topics

■ Muscle Builder window on page 139

Finalize a simple muscle
To finalize a muscle

1 Click the Finalize tab.

2 Select which Deformer you want to use.
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The deformers are described in more detail in the Other Muscle
deformation on page 9 section. Typically, you want to use the Muscle
Spline deformer, as it is more powerful and flexible. This deformer alters
the shape of a simple muscle with a custom spline curve, and any number
of controls.

If you select cMuscleSplineDeformer, you can define the number of
control points in the Num Controls field. You need at least two, one for
start and end, and typically three so there is one in the middle for jiggle.
If you want to have more controls and jiggle on the muscle you can
increase the number of controls.

3 (Optional) Use the Type drop-down list to select the shape of the simple
muscle control objects, such as a Cube or Circle control.

4 (Optional) If you are building a simple muscle that you want to mirror
onto the opposite side of the character, select the world axis to mirror
across, and the name Search/Replace to be done to find the appropriate
attachments and muscle naming. If you are doing mirroring, you must
enter a proper Search and Replace value, and the search string must appear
in the name of the simple muscle when the naming dialog appears.

TIP Right-click the Search field for mirroring to select from a number of preset
Search/Replace options.

5 When finished, click Convert to Muscle.

A window appears asking you to name the simple muscle, and warning
you that future cross section editing will be done. You can still edit the
shape after finalizing, but if you do so, you need to reset the base for the
muscle. See Reset base pose for selected Muscle Objects on page 69.
Typically, you should not remodel the muscle shape after it is built.

6 Enter a unique name for the simple muscle, such as MusBicep_L, and
click OK.
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NOTE Remember, if you use mirroring, the Search string must appear in the
name of the muscle. For example if you are using _L and _R naming
conventions, you might name a muscle "Bicep_L". If the Search string does
not appear in the name when mirroring, an error occurs and you must undo
the operation.

After a moment the simple muscle is rigged with the deformer you chose
and converted to a Muscle Object. The basic rigging creates a
"grpMUSCLES" null, and places a completed muscle rig inside of this
group for each muscle you make. The muscles are properly constrained
to the original joints.

After you have built a simple muscle, you can adjust the parameters.

Related topics

■ Muscle Builder window on page 139

Adjust simple muscle parameters
To change the simple muscle parameters

1 Click the Muscle Parameters tab in the Muscle Builder window, or select
Muscle > Simple Muscles > Set Muscle Parameters.

2 Select one or more simple muscles, and alter the settings.

If you change just one setting, all of the possible values are still set on
the selected muscles. The window automatically loads the current values
from the selected muscle, as well as sets the values to all selected muscles
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if the Realtime Update button is on. If the button is off, you can selectively
load and apply each section using the related buttons.

Related topics

■ Muscle Builder window on page 139

Create a Muscle Spline deformer
Part of the Muscle Spline deformer is a proprietary spline curve node. This
node provides a Hermite-type spline with true tangent length control. The
system can automatically create a spline and as many control points and
controls as you need. In addition, the spline node has built in Jiggle for each
control point. This tool can be used as a bonus rigging tool to place joints
along a curve with Jiggle for things like hair or antennae.

To create a Muscle Spline

1 Select Muscle > Bonus Rigging > Create Muscle Spline from the main
menu bar.

The Muscle Spline window appears, letting you select options for creating
your spline node.

2 In the Muscle Spline window, enter a unique name for the spline, and
set other options as you require. See Muscle Spline window on page 157
for detailed descriptions of each option.

3 Click Create Muscle Spline Rig.

Shown below is an example with five spline cube controls, and seven
driven joints on the spline curve.
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Related topics

■ Other Muscle deformation on page 9

■ Muscle Spline window on page 157

Set up a Muscle Spline deformer
The Muscle Spline deformer is a deformer node that lets you deform any object
based on a Muscle Spline. Since the deformation is based on the spline
information, much of the previous section is related. The deformer itself takes
connections/inputs from a Muscle Spline object as discussed earlier, and all
of the Jiggle is based on the spline jiggling. Since the object is deformed from
the spline curve, the geometry changes as the spline curve moves or changes.

The Muscle Spline deformer is the typical deformer used to get muscle control.
It has several main options including basic Squash and Stretch, and custom
muscle/geometry shaping based on spline length.

To apply a Muscle Spline deformer on any object

1 Select the object you want to apply the deformer to.

Typically, this is a NURBS surface so that the object can act as a muscle,
but it does not have to be. A basic NURBS object is used in the following
example.

2 Select Muscle > Simple Muscles > Apply Muscle Spline Deformer from
the main menu bar.

The Muscle Spline Deformer window appears with options for creating
the Muscle Spline deformer node. See Muscle Spline Deformer window
on page 158.

Set up a Muscle Spline deformer | 35



3 In the Muscle Spline Deformer window, do the following:

■ Enter a unique Name for the deformer and related items.

■ Enter the number of control points you want the spline to have.

■ Select the shape you want for the control points from the Type
drop-down menu.

■ Click Setup Muscle Spline Deformer.

4 When finished, you can close the Muscle Spline Deformer window.

The geometry is rigged. A Muscle Spline node is created, a Muscle Spline
deformer is applied to the surface, and all of the needed spline information
is connected into the deformer.

5 Move or animate the spline controls to deform the object based on the
spline curve.

Related topics

■ cMuscleSpline node on page 180

■ cMuscleSplineDeformer node on page 183
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■ Muscle Spline Deformer window on page 158

Reset Base Pose for Muscle Spline deformer

Once a Muscle Spline deformer is created, the control curve and controls are
automatically placed inside the surface. In some cases, you may want to adjust
the default location of the controls without affecting the surface. This lets you
set up exactly where and how the curve is shaped before deformation is applied.

To do this, you adjust the controls, then reset the base pose for the deformer.
This makes the current shape of the curve the default.

To reset the Base Pose for a Muscle Spline deformer

1 Select an object that has a Muscle Spline deformer on it.

2 Find the envelope attribute under the main shape in the Maya Channel
Box or Attribute Editor, and set the envelope attribute to 0 to disable it.
(This step is optional, but you usually want to do this.)

3 Move or adjust the controls to create a new default state of the spline.
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4 Re-select the object being deformed by the Muscle Spline deformer.

5 Adjust the envelope back to 1.0 to see how the muscle looks with the
curve in this state if it deforms. (You can also do this step at the end if
you prefer.)

6 Select Muscle > Simple Muscles > Reset Base Pose for Muscle Spline
Deformer.

After a moment the object is reset as if it was not deformed. The current
state of the spline is now used as the default state for the deformation.

38 | Chapter 2   Creating Muscles



7 Move the controls to see how the object deforms differently with the
new default spline state.

Related topics

■ cMuscleSplineDeformer node on page 183

Set up custom muscle shapes with the Muscle Spline deformer

If you use the Muscle Spline deformer, you can also use Custom Muscle
Shaping. This tool lets you directly modify and sculpt the exact muscle
deformation and shape you want for any length that the muscle is at. As the
muscle length changes, each custom shape you make is triggered.

This is similar to creating a blendshape for the muscle driven by the muscle
length, except that the deformation is tied directly into the Muscle Spline
deformer, and you can directly modify the shape of the muscle in the current
pose instead of having to sculpt in the original reset pose.

Set up a Muscle Spline deformer | 39



To set up custom muscle shapes

1 Select an object that is rigged with a Muscle Spline deformer for its
deformation.

2 If you want to scrub to different frames, disable any Jiggle on the deformer
controls.

If Jiggle is on, the shaping you see is not accurate because the muscle
shape includes the Jiggle effect. You can disable Jiggle by selecting each
muscle control and setting the Jiggle amount for each to 0, or using the
Muscle Parameters tab.

3 With the muscle selected, select Muscle > Simple Muscles > Custom
Muscle Shapes from the main menu bar.

4 The Muscle Spline Deformer Shape window appears, with the name of
the object and deformer at the top. If you have not already selected a

muscle, you can press the  button to load the selected geometry.

5 Pose the muscle into the problem pose where the length causes it to
deform into an undesirable shape. Notice how the Current State slider
at the bottom of the window changes as the length of the muscle changes.
A value of -1 means the muscle is totally squashed, +1 means totally
stretched, and 0 means it is at the default length.
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6 Click Prep for Sculpt. The temporary piece of sculpting geometry appears
with the points ready for editing. The color changes to reflect that you
are in Sculpting mode. You can adjust the temporary color using the color
swatch next to the Prep for Sculpt button.

7 Sculpt any changes on this temporary sculpt object to make the muscle
look how you want it at this length. \
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8 If you are creating a new shape for this length, click Create New. If you
are fixing an existing shape, select the shape from the list on the right
and click Edit.

9 If you click Create New, a window appears asking for the name of the
new target shape pose. Enter a unique name and click OK.

After a moment, the original object appears with the correction applied
to it. The new or edited pose appears in the list on the right side of the
window with the Current State value the shape was made at next to the
name.

10 Adjust the muscle length interactively or play your animation.

The muscle goes into the sculpted pose whenever it reaches the specified
length. You can adjust the Blend value to control how the fading on and
off for the shape occurs. Lower values make the shape appear only when
the length is close to the length where the sculpt was done, larger values
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blend on even if the length is farther away. You can also edit the existing
pose, or create more poses for other lengths.

Related topics

■ Muscle Spline Deformer Shape window on page 158

Create a Muscle Stretch deformer
The Muscle Stretch deformer is an alternative deformer to the spline-based
muscle deformer. It has fewer options for squash and stretch, and only allows
for three controls at the start, middle, and end. All of the settings exist entirely
on the deformer itself.

To set up the Muscle Stretch deformer on an object

1 Select the object you want to apply the deformer to.

The following example uses a simple NURBS object, but you can use any
geometry. (It must be NURBS-based if you want to connect it as a muscle.)
For proper automated rigging, the local Y-axis of the geometry needs to
point down the length of the object.

2 Select Muscle > Simple Muscles > Apply Muscle Stretch Deformer from
the main menu bar.
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A Muscle Stretch deformer is applied to the object, and locators are created
and rigged as controls. A cyan locator represents the starting control, and
an orange locator represents the end control.

Base locators are also created. If you move the Base along with the Start
or End locators, the deformation does not change, but you can easily edit
the base location of the movers. Moving the MidBase automatically makes
the middle mover adjust. If you move or adjust only the Start, Mid, or
End locators, you deform the object with basic squash, stretch and jiggle.

Delete a muscle Jiggle cache
Muscles store Jiggle information as you playback or scrub time. You can delete
this information to save memory before saving the file, or simply to clear out
muscle Jiggle information without having to re-scrub the timeline.

To clear the muscle Jiggle cache

1 Select Muscle > Muscles/Bones > Delete Muscle Jiggle Cache.
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2 Enter the time range for which you want to delete the internal cache
data.

3 Select the muscles for which you want to delete the cache data, then click
Delete Jiggle Cache for Selected Muscles.

Related topics

■ Understand muscle Jiggle on page 9

■ Per-Point Jiggle deformation on page 58

Set up a Master muscle control
In many cases, each section of a character has several muscles. While you can
provide an animator with many individual muscle controls and jiggle settings,
it can also be useful to group muscles together with one overlying control to
provide Jiggle, Cycle, and Rest values. This lets the animator control the Jiggle,
Cycle, and Rest of an upper leg (for example), using only three attributes
instead of several controls for each muscle in the leg.

The Setup Master Muscle Control window lets you create a Master Control
object to hold all of the attributes, then sets up each of the chosen muscle
controls to be driven by an expression from the master. Typically, muscle
Jiggle can be offset from one muscle to another even in the same group. The
script properly retains these offsets so that as the animator adjusts the master
values, the same amount of offset per muscle is kept.

1 Create an object to be the Master Control. This object can be a group, a
curve, or anything else that you want to hold the attributes.

NOTE You cannot use any of the locator controls that are created
automatically when you create a muscle as the Master Control object.

2 The following example uses a simple curve shape created by hand.
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3 Select the object, then select Muscle > Muscles/Bones > Setup Master
Muscle Control from the main menu bar.

The Setup Master Muscle Control window appears.

4 Select the middle muscle controls on all of the muscles you want to
control as a group. In general, you do not want to select the endpoints
of the muscles, as they are already stable. In this example, we have selected
the iControls of the upper leg muscles.

5 Click the load selection  button next to the Controls area to load
the muscle controls.

6 Select the Master Control object you created, then click the Master Control

 button to load the object into the window.

7 Specify a Name for this group of muscles. This name is used when the
Master Control creates the attributes and expression.

TIP Right-click the Name field to select preset naming conventions.
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8 Click Setup Master Muscle Control. If the attributes needed did not yet
exist on the Master Control, they are created and set to a default value
based on the muscles.

The Master Control is selected, and the attributes that display now control
the whole group of muscles at once. In addition, the original iControls
now have a different set of capitalized JIGGLE, CYCLE and REST attributes.
These provide the animator with a way to offset the amount of each item
from the Master Control.

You can lock and hide the Translate, Rotate, and Scale attributes since
they are not needed. Using the jiggle/cycle/rest attributes controls each
of the original muscles.

9 You can repeat this process for other sections of the character, using the
same Master Muscle Control for all of them.

Fix invalid Muscle Object nodes
If you duplicate a capsule or muscle object node manually, certain required
connections may not be recreated properly from the transform to the Muscle
Object shape node. Selecting Muscle > Muscles/Bones > Fix Invalid Muscle
Object nodes from the main menu auto-detects and fixes these for you.

For example, if you manually duplicate a capsule and move it, you may notice
that its shape does not appear to follow where the transform is. Using this
utility corrects that problem.
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Skin Deformation

Skin deformation
The core of Maya® Muscle is the deformer. The deformer provides the main
skin deformation and ties into most of the other parts of the plug-in. It can be
used to do muscle and skin deformation, or used as a stand-alone deformer on
top of other typical Maya tools to provide options such as caching and per-point
jiggle.

The Muscle deformer can be used for several deformation effects, the primary
ones being Sticky or Sliding deformation. Any node that has a Muscle Object
shape can be connected and weighted for use with these deformation features:

■ Sticky deformation on page 50

■ Sliding deformation on page 53

■ Displacement deformation and rendering on page 56

■ Force deformation on page 58

■ Per-Point Jiggle deformation on page 58

■ Relax deformation on page 59

■ Smooth deformation on page 60

Before the cMuscleSystem node can be used, it must be applied to an object. In
addition, various other nodes are typically connected, such as muscles or bones,
Muscle Directions, Muscle Smart Collides or other features. This guide explains
different aspects of setting up the Muscle deformer and modifying it.

In order to use the Muscle deformer as a skin solution for Sticky or Sliding
weights, you must first connect muscle/bone objects. You can connect any

3
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NURBS, polygon mesh, or capsule object that has a Muscle Object shape node
to the system.

You can connect multiple objects at once, even to multiple Muscle deformed
objects. For example, if you select three muscles and two skin objects that
have Muscle applied, then select Muscle > Muscle Objects > Connect selected
Muscle Objects, the three muscles are connected to both of the skin deformers.

Sticky deformation
One of the main uses for the Muscle deformer is as an addition or replacement
for the Maya skinCluster. This node gives similar skinning techniques for
capsules/joints, as well as polygon bones. It also lets you attach points to the
surface of NURBS objects for more control over deformation.

The overall process is similar in that you apply the Muscle deformer to your
mesh, convert objects to Muscle Objects that are then connected, and finally
weight your points to the muscle/bone objects.

You can also use Relative Sticky mode to apply only new influences such as
muscles to your mesh without getting a double transform. See Relative Sticky
deformation on page 52.

Sticky weights

Sticky weights function similarly to Maya skinClusters, but they are more
powerful. They allow you to attach the points of your skin mesh directly to
a muscle, bone, or capsule. These weights are usually normalized, which means
that the overall weights for a point need to add up to exactly 1.0 for all
muscles/bones the point is weighted to. If they add up to less, the point gets
left behind when the skeleton is moved. If they add up to more, they move
too much.

Sticky weights operate differently depending on what type of object you are
weighting to:

Sticky Weights with capsules/polygon bones

When weighting a point with sticky weights to a capsule or polygon bone,
only the transformation of that object causes the point to move. That is, only
translating, rotating or scaling that object affects the skin. This is similar to
Maya weights.
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Sticky Weights with NURBS muscles

When weighting a point with Sticky weights to a NURBS muscle, the point is
actually attached to the surface of the muscle. Therefore, the skin moves even
if only the surface shape changes or points on the muscle adjust, in addition
to any transformation on the muscle itself. This means if the muscle pivot
stays at the same spot, but the shape of the muscle changes, the skin is still
affected. Typically, the muscle deforms with a proprietary Muscle-based
deformer and squashes or stretches. As this happens, any points that are Sticky
weighted to the muscle move along with the surface, including if the muscle
jiggles. You can also set up NURBS objects to deform or move with other tools
such as a blendshape.

NOTE The first time you paint Sticky weights on your object, you must select your
main base or root bone, set the weight to 1.0, and click Set Weight/Flood. This
floods the bone or object to have 100% of all the weight. If you do not do this
initially, you may see points move incorrectly when painting, since they may not
have a truly normalized weight of 1.0 even though the Normalize button is on.

Muscle provides you with three sets of Sticky weights: Sticky, StickyB, and
StickyC. Each one functions as a normal Sticky weight, but you can use each
set to paint different effects.

Some example workflows for using multiple Sticky weight sets:

■ Weight one set to bones only, and another to bones and muscles, allowing
animators to switch between the two modes.

■ For a character that often needs a different weight set, such as for sitting
in a chair, paint a secondary set of weights for those shots.

■ Weight only bones or capsules to the Sticky weight set, then save and load
weights from the Sticky set to the StickyB set so that they match. Add more
weights in the StickyB set for muscles. The Sticky set is purely rigid like a
Maya skinCluster, while the StickyB set is the regular full weighting.
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TIP You can load and save Sticky weights across the sets using the Save Weights
window. See Load and save weights on page 88.

Visualize Sticky Bind distance

When you bind a NURBS muscle to a Muscle deformer, you can select which
points are bound and thus weightable to the muscle based on distance. The
Muscle plug-in provides a way to see what the default distance is based on a
sphere. Any points within the sphere's radius are usable if the Auto-Calculate
mode is used. You can also manually adjust the sphere radius to see if other
values might work better, if you are going to specify your own value.

Note that this is providing the skin point the ability to be properly Sticky
weighted to the muscle. It does not actually set up any default weighting. This
simply allows the point to work properly with Sticky weighting to the given
NURBS muscle. If the point is not within the range allowed during bind, and
later on Sticky weights are painted to it, the Muscle deformer calculates the
binding on the fly, slowing down Sticky deformation speed.

TIP You can detect and fix errors with Sticky binding using Muscle > Skin Setup
> Auto-Fix Invalid Sticky Bind Points.

Related topics

■ Sticky attributes on page 188

Relative Sticky deformation
Relative Sticky mode lets you mark certain muscles or bones as “Relative” so
that you do not get a double transformation when using a regular skinCluster
along with the Muscle deformer.

Using this approach, you can rig your character using regular joints and a
skinCluster, apply Muscle on top, then add muscles or capsules for extra Sticky
or Sliding weights on top of the skinCluster.

You can also set up Relative Sticky deformation even if you are not using a
skinCluster, for example if you are using clusters to deform an object.

You can turn Relative Sticky mode on as you apply the Muscle deformer to
an object with skinClusters (see Apply the Muscle deformer on page 61), or
after you have applied the Muscle deformer (see Set up Relative Sticky
deformation on page 72).
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When you turn Relative Sticky mode on, the cMuscleSystem node’s Relative
Sticky attribute is set to relative (on). In addition, a new helper deformer
named cMuscleRelative is created and set to deform the mesh. This deformer
should be positioned before the skinCluster node, but after any other deformers
such as blendshapes.

In addition, each cMuscleObject node for capsules, bones or muscles has a
Relative attribute. If on, the muscle uses Relative Sticky deformation. If off, it
operates as if Relative mode is off.

This is used to get normalization on painting weights. For example, when
using Relative Sticky mode, you want to create one dummy capsule object to
connect into the Muscle deformer for Sticky weights. For this one capsule,
turn its Relative attribute to off (using Muscle > Skin Setup > Set Selected
Bones/Muscles as Not Relative menu item), then flood all Sticky weights to
this bone. The capsule should never move from its initial location. You can
then connect muscles and start adding and smoothing weights to them for
Sticky weights. These should generally have Relative set to on. In this way
you can still properly normalize Sticky weights back to the dummy capsule.

Related topics

■ Apply the Muscle deformer on page 61

■ Set up Relative Sticky deformation on page 72

■ cMuscleObject node on page 170

Sliding deformation
The Sliding attributes of the Muscle deformer node let you cause the skin
mesh to show objects truly sliding underneath. See Sliding attributes on page
188 for descriptions of each Sliding attribute of the Muscle deformer.

NOTE Sliding does not require Sticky weighting. For example, you can connect
objects on the deformer to only get Sliding effects. This allows you to use Maya
skin for basic skinning, then get Sliding or other features from the Muscle deformer.

Sliding weights

Sliding Weights let you use any capsule, bone or muscle to push out the skin
surface and give true sliding results. The points themselves do not move along
with the object, but instead are pushed out or collide with it.
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Sliding weights are not usually normalized. That is, multiple muscles can affect
the same point 100%. If more than one muscle is pushing out on a point, the
point moves to the location farthest outside.

TIP You can get interesting results using a combination of Sliding and Sticky
weights on a muscle. For example, the muscle can pull the points along slightly
if the sticky weights are somewhat low, and then also have full 100% sliding on
as well. The result is that the muscle will slide under, but also tug or pull slightly
on the skin.

The calculation speed of Sliding is based on the type of object doing the slide,
as well as the Muscle sliding quality setting. In general, capsules are the fastest
to use for sliding, polygon objects give moderate speed, and NURBS muscles
are the slowest.

With this in mind, you may want to use capsules as much as possible for basic
bone sliding effects. For example, rather than modeling a polygon knee bone,
you might be able to get similar results with faster speed using a non-uniformly
scaled-down capsule instead.

In addition, you want to paint only the area that the bone or muscle can slide
over for that bone or muscle. This limits the sliding calculation of the given
object to only the points you weight and speeds up deformation. For example,
a bicep (arm) muscle never slides skin around a leg, so you only need to paint
sliding weights for the biceps around the arm.

In creases or areas where the skin folds along itself you may find some points
that do not slide outwards properly. To help with these areas, you can use a
cMuscleDirection node as described in Direction weights on page 54. This
node overrides the direction the skin slides to make it move outwards properly.

Direction weights

Direction weights allow you to get better control over Sliding effects. They
cause the points weighted to the cMuscleDirection node to be moved in the
direction you specify.

For example, if some points are sliding the wrong way, or are moving in an
incorrect direction, usually in crease areas or areas where the skin has folding,
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you can create and paint weights to a Muscle Direction to control the direction
these points slide.

Related topics

■ cMuscleDirection node on page 164

■ Create a Muscle Direction object on page 74

NOTE If you are directly skinning subdivision surface objects, you will likely
have to set up cMuscleDirection nodes for the entire mesh to get proper sliding.

IMPORTANT Muscle Direction objects can be created as independent objects,
or if the menu command is called, and a capsule object is currently selected,
the cMuscleDirection node is created as a new shape under the existing capsule.
This lets you have just one object that is both a capsule and a radial direction
node at the same time.

Using Direction nodes

Radial directions are useful when dealing with areas of a sliding skin that are
cylindrical or that need a cylindrical-type push out for sliding. Usually sliding
is based on the surface shaping. If there is a concavity or wrinkle, you can use
a Muscle Direction to fix the direction of the slide. Radial directions work well
for things where you would normally have a long bone inside of the main
center of the mesh, for example an upper or lower arm, upper or lower leg,
and so on. These are cases where you probably have one main bone or capsule
for the upper arm running in the center line of that area. If you have a capsule
for that, you can select it and make it a Muscle Direction object. If you do not
have a capsule, you can create a separate radial direction object parented to
the bone.

Vector directions can be useful for areas where the sliding or skin pinches
more, such as in the back of a knee, or in an elbow area. The direction object
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can split the angle of the two bones and keep the slide direction pointing
outwards so that the two slides do not push into each other.

Related topics

■ cMuscleDirection node on page 164

Related topics

■ Set a constant fat offset for Sliding deformation on page 73

Displacement deformation and rendering
Maya Muscle provides displacement options for more advanced deformation
and effects. Displacement nodes can be connected to Muscle deformers for a
point deformation adjustment. Displace nodes provide sliding or offset effects
as the node approaches the surface of the mesh. This is similar to sliding with
capsules or muscles, but is based on an image map and is faster than true
sliding weights.

Alternatively, the same nodes can be connected to a special
cMuscleDisplace-capable Maya shader or mental ray shader network. This can
give a higher-quality displacement and sliding effect at render time.

Advanced topics with cMuscleDisplace

The cMuscleDisplace feature gives you a fast way to obtain Sliding effects.
When used as a shader, you not only get sliding that does not calculate until
render time, but you can also get more detailed Displacement/Sliding than
you get with just topology, since more detail is created. For example, a simple
white square with some blurry falloff as a texture map can be used to quickly
create sliding hip bones, or clavicle effects.
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A good use for this is something like a rib cage. You can paint one or more
maps simulating a rib cage texture, and apply this as a displacement map. The
cMuscleDisplace node is parented or constrained to the proper joints/bones
in your character rig, then the shader is applied to the model. In this way, as
the skin mesh moves on the character’s body, the displacement effects appear
to slide. As the cMuscleDisplace node approaches or moves away from the
mesh, the amount of sliding increases or decreases.

Other possible ideas include things like an Adam’s apple/neck texture. You
can rig a joint that is aim constrained from the base of the neck to the front
of your model’s chin. This joint could have a cylindrical cMuscleDisplace node
parented to it, with a detailed neck texture. As the neck moves and the
joint/aim constraint is adjusted, you get very detailed sliding effects on the
skin using a shader.

It is important to note that you can ‘chain’ multiple cMuscleShaders together.
Each shader has an inDisplacement attribute. You can connect the
displacement attribute from each node to the inDisplacement of the next one,
or to other standard Maya displacement nodes. Then you can connect the
last one into the final shading group.

In addition, you can connect the shader nodes to other utilities. For example,
you can create a blendColors node that uses the displacement value as the
blender. This changes the color of the surface as the displacement/sliding
increases near the surface. (This works best when the Amplitude is set to 1.0,
due to the order in which color is calculated.)

In some cases, you want to connect only the Displacement effect as created
by one node, not the entire chain. In these cases you can use the
displacementLocal attribute on the shader. This returns only the displacement
from the current cMuscleDisplace node. The displacementLocalNormalized
is the same thing, but with the value normalized from 0 to 1 even if the
Amplitude is larger than 1.

Finally, if you set up a shading network, you can also connect the same
cMuscleDisplace nodes to the Muscle deformer. Using this approach, you can
visualize the displacement by turning on the Enable Displace attribute on the
deformer. When rendering, you can turn off Enable Displace, and use only
the resulting shaders to obtain the final effect.

Related topics

■ Set up Displacement deformation on page 76

■ Displace attributes on page 190

■ cMuscleDisplace node on page 165
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Force deformation
The Muscle deformer has a set of weights and attributes that let you apply
gravity and wind/noise type effects to the mesh. See Force attributes on page
190 for a complete list of these attributes.

For example, Gravity lets you set a direction, then painted Force weights cause
those points to move in the direction specified.

Wind settings let you apply a noise-type effect that moves through the mesh
at a specified speed and density.

Related topics

■ Set up Force deformation on page 84

Per-Point Jiggle deformation
The per-point skin Jiggle feature lets you get Jiggle effects directly on each
point of your skin mesh. This is similar to the way Jiggle works for the existing
muscle deformers.

The Jiggle part of the deformer does not require any Sticky or Sliding bones
or muscles. In essence, it can be used as a completely stand-alone feature of
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the deformer. This allows you to apply the Muscle deformer to any object,
then use it to get per-point Jiggle effects, even if the object is not ‘skinned’.

You can paint or set weights for each point to have individual Jiggle, Cycle
frame time, and Rest frame time values. These weights (which range from 0
to 1) are then modified based on the min/max values on the Muscle deformer
node. A painted weight of 0 gets the minimum value set, a painted weight of
1 gets the maximum value set, and anything in-between interpolates.

TIP Jiggle calculations for per-point skin jiggle can use a lot of RAM. Consider
caching the effect, or using muscles to get similar effects. Refer to Point-caching
on page 107.

Related topics

■ Set up Jiggle deformation on page 84

Relax deformation
The Relax feature of the Muscle deformer lets you apply Relax and Wrinkle
effects to the skin mesh. The effect of this is that as points stretch or get farther
apart, Relax tries to keep them back at their original relative distance. As they
get closer, Relax attempts to cause wrinkling to make them stay the right
distance apart.

In addition, Muscle offers separate Wrinkle and Relax weights, so that as areas
compress, you can get predefined wrinkling to occur.

Relax, like Jiggle, can be used as a stand-alone feature. For example, even if
you are not skinning or using muscles or bones with the deformer, you can
apply the deformer to any object, turn on Relax, and paint Relax or Wrinkle
weights. This causes your mesh to still use Relax features.
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Typically, you want to use Relax around any area that slides, so that the slide
effect pulls up the skin around it as well as where it has slid the mesh.

When you paint Relax weights you are setting what points on the mesh might
be adjusted after the basic skinning and sliding has occurred. These points are
either pulled along or pushed out in a wrinkling fashion. Any point weighted
to 0 is unmoved by the Relax/Wrinkle, although points around it may be
affected.

By default, the Relax weights default to 1.0 for the entire mesh, so you can
simply enable it in the deformer settings to turn it on. Wrinkle weights default
to 0, so that you do not get any wrinkle effects unless painted.

Related topics

■ Relax attributes on page 192

Smooth deformation
The Smooth feature of the Muscle deformer lets you apply a smoothing
operation on your skin mesh. The effect of this is that points move together
and cause your mesh to smooth out and lose detail.

Smooth deformation can be used as a stand-alone feature. For example, even
if you are not skinning or using muscles or bones with the deformer, you can
apply the deformer to any object, turn on Smooth, and paint smooth weights.
This causes your mesh to still use Smooth features.
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Smooth can be used to help pull areas that are sliding or to smooth areas in
your mesh where unwanted wrinkling or pinching is occurring.

In many cases, Smooth can give results similar to Relax and is usually faster.
In other cases, you can use Relax for things like wrinkles, then use Smooth in
addition. It is recommended that you use either Relax, Smooth, or both when
dealing with areas that slide.

Related topics

■ Smooth attributes on page 193

Apply the Muscle deformer
Any surface object can have the Maya Muscle skin deformer applied to it,
however the best results are achieved using polygon mesh objects. Using
NURBS or subdivision surfaces results in slower feedback with painting, as
well as other performance issues and limitations.

If you use subdivision surfaces, your workflow might be to rig a polygon mesh,
then connect the mesh into the subdivision surface using a blendshape or
direct connection. If your subdivision surface cannot be left in polygon proxy
mode, you can create a duplicate that is in polygon proxy mode, and use that
as a go-between object for the connections. While this may seem slower, in
many cases using a polygon object for a rigging mesh results in faster animation
feedback and playback.

The Muscle deformer when applied can be connected to Muscle Object bones,
capsules, or muscles to provide for the skinning deformation. Weights can be
applied for typical Sticky skinning, or only for Sliding, Jiggle, or other features
which allow it to also work on top of Maya skin.
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To apply the Muscle deformer onto an object

1 Select the object you want to apply the Muscle skin deformer on.

2 Select Muscle > Skin Setup > Apply Muscle System Skin Deformer from
the main menu bar.

After the calculation is complete, the Muscle deformer is applied and
ready for use on the object. The more points the mesh has, the longer
this process takes.

You can immediately use several options such as per-point skin Jiggle,
Relax, Smooth, Self-collision, or cache. In order to use Sticky or Sliding
options you must first connect muscles or bones to the deformer.

Refer to the following steps if you are applying the deformer to an object
with skinClusters.

To apply the Muscle deformer onto an object with skinClusters

1 Select the object with skinClusters to which you want to apply the Muscle
skin deformer.

2 Select Muscle > Skin Setup > Apply Muscle System Skin Deformer from
the main menu bar.

When the Muscle skin deformer is applied to a mesh that has a skinCluster
on it, a window appears asking if you want to use the deformer with
Relative Sticky weights as opposed to normal Sticky. Relative Sticky mode
lets you apply muscles and bones into the Muscle deformer without
getting a double-transform from the skinCluster. See Relative Sticky
deformation on page 52 for more information.

3 Click Yes if you want to apply the deformer and turn Relative Sticky mode
on.

NOTE You can also apply this option later if you choose. See Set up Relative
Sticky deformation on page 72.

A new cMuscleRelative node is created and the cMuscleSystem node
Relative Sticky attribute is set to relative.
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Related topics

■ Relative Sticky deformation on page 52

■ cMuscleRelative node on page 172

■ cMuscleSystem node on page 187

Convert Maya skin to Maya Muscle
Instead of applying the Muscle deformer to an existing skinned mesh, you
can also convert a skinCluster to the Muscle setup. This effectively replaces
the skinCluster with Muscle’s Sticky weights. To do this, joints are converted
to capsules (meaning they have a cMuscleObject shape node applied) so that
they can be connected. In addition, weighting from the skinCluster is
automatically transferred to the cMuscleSystem node.

You can decide whether to use Relative mode for Sticky weights, or to use a
Muscle deformer for all deformation. One of the benefits of using Muscle is
that you can paint three sets of Sticky weights and blend between them as
needed. See Sticky deformation on page 50 and Relative Sticky deformation
on page 52.

To convert an existing skinCluster deformed object to a Muscle deformed
object

1 Select the object that has a Maya skinCluster applied. Make sure your
joints/objects are in the default original bind pose for the skinCluster.
(That is, your mesh needs to be in its original default state.)

2 Select Muscle > Skin Setup > Convert Maya Skin to Muscle System from
the main menu bar.
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3 In the window that appears, do one of the following:

■ To delete the original skinCluster, click Delete.

■ To disable the original skinCluster (by setting the envelope to 0), click
Disable.

The conversion starts to change the joints to capsules.

4 Select the proper axis in the window that appears asking which axis you
are using down the length of your joints.

The joints convert to have cMuscleObject shape nodes as capsules, and
the deformer is applied with the original weighting transferred. When
finished, your deformation looks the same, but it now uses the Muscle
deformer. You can now use the options for this deformer such as adding
muscles for Sticky or Sliding weighting and so on.

Related topics

■ Capsules on page 5

64 | Chapter 3   Skin Deformation



Connect Muscle Objects to a Muscle deformer
Once you have added a Muscle Object shape node to an object, you can
connect it to a Muscle skin deformer. The process is slightly different depending
on what type of object you are connecting.

To connect capsules or polygon mesh bones to a Muscle deformer

1 Select the capsule(s) or polygon object(s) you want to connect and select
one or more skin objects that have the Muscle deformer applied. The
order of selection does not matter.

NOTE Make sure the skin and bones are in the default base pose position
that you want as the default skin binding position.

2 Select Muscle > Muscle Objects > Connect selected Muscle Objects from
the main menu bar.

The selected objects are immediately connected. The Sticky Bind window
appears as Maya Muscle connects the surface of each object to the surface
of your mesh with Sticky weights.

To connect NURBS objects to a Muscle deformer

1 Select the NURBS object(s) you want to connect, then select one or more
skin objects that have a Muscle deformer applied. The order of selection
does not matter.

NOTE Make sure the skin and bones are in the default base pose position
that you want as the default skin binding position.

2 Select Muscle > Muscle Objects > Connect selected Muscle Objects from
the main menu bar.

The Sticky Bind Maximum Distance window appears. This window lets
you set how far a point can be from the center of the NURBS muscle and
be properly Sticky weighted. For example, you usually do not need a
muscle for the right arm to affect points on the left leg of a mesh. You
can use this window to limit the area of effect the muscle will have on
the mesh.
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3 In the Sticky Bind Maximum Distance window, select the option you
want to use:

■ Click Auto-Calculate to let Maya Muscle calculate the best Sticky Bind
distance for each selected NURBS muscle.

TIP Maya Muscle also has a visualization tool that lets you see the area
the Auto-Calculate option will use before you connect the muscle. See
Visualize Sticky Bind distance on page 52.
In addition, the Show Warnings attribute (when set to on) tells you
which points (if any) are outside the range of the Sticky Bind distance
and to which muscle. This can be helpful to determine if and when
you need to rebind-sticky for certain muscles.

■ Click Avg. Value to use the number you specify in the Max. Distance
from center of muscle value field. (The default value that displays is
the average value for all selected NURBS objects. This value is
acceptable if all the selected muscles are about the same size.)
Any point outside of this maximum distance value is ignored during
the initial muscle connection. This speeds up the calculation of the
connection of muscles for larger meshes.

If you later try to weight to a point outside the Max. distance value,
that point is calculated on the fly (and slows down deformation). If
this happens, you can go back and re-Bind the Sticky data for the
muscle to correct it. You can also correct using the Muscle > Skin
Setup > Auto-Fix Invalid Sticky Bind Points menu item.

■ Click ALL Points to connect the muscle so it can be weighted to any
point on the mesh.

See Sticky Bind Maximum Distance window on page 149 for more
information.

The Sticky Bind window appears as each muscle is processed and
connected.

When finished, your muscles, bones, and capsules are connected to the Maya
Muscle skin deformer, and you can paint/set weights. See Paint Muscle weights
on page 86.

IMPORTANT Simply connecting muscles does not set default weights. You have
to manually paint weights, or use the Muscle > Weighting > Apply Default Weights
option.
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Re-Initialize setup data on Maya Muscle
In some cases, you may want to re-initialize the data that Maya Muscle uses
for its deformation. For example, when converting older cMuscleSystem files
to Maya Muscle files, you must re-initialize the setup data on the Muscle
deformer, otherwise it does not deform anything.

To re-initialize existing Muscle data

1 Select the meshes that have the Muscle deformer applied that you want
to re-initialize.

2 Make sure your mesh is in its default rest pose.

3 Select Muscle > Skin Setup > Re-Initialize Setup Data on Muscle System
from the main menu bar.

The node is re-processed.

Auto-Fix invalid Sticky Bind points
When connecting a NURBS muscle to the Muscle skin deformer, only certain
points are calculated for Sticky weighting. Later on if you weight a point that
was not properly bound, the deformer appears to get slower since it now
calculates this information on the fly during deformation.

To fix points that have weighting to muscles that they were not originally
bound to, you can use the following auto-fix option:

1 Select the mesh that has a Muscle deformer applied with Sticky weights
to muscles.

2 Select Muscle > Skin Setup > Auto-Fix Invalid Sticky Bind Points from the
main menu bar.

The mesh is checked, and any muscles/points that need it are corrected.

Disconnect muscle nodes
In some cases, you may want to disconnect all Muscle nodes of a certain type
from the Muscle deformer.
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To disconnect all Muscle nodes of the same type

 ➤ Select Muscle > Skin Setup, then select the appropriate menu item for
the type of node you want to disconnect.

For example, to disconnect all cMuscleDisplace nodes, you would select
Muscle > Skin Setup > Disconnect all Muscle Displaces.

Disconnect selected Muscle Objects
To remove a muscle, bone or capsule from a Muscle deformer

1 Select the muscles, bones, or capsules you want to disconnect and select
one or more Muscle deformed objects. The number and order of the
selection does not matter.

2 Select Muscle > Muscle Objects > Disconnect selected Muscle Objects
from the main menu bar.

Weights are zeroed and the nodes are properly disconnected.

If you have accidentally deleted or improperly removed/disconnected a
Muscle Object, you can use Muscle > Skin Setup > Auto-Fix
Deleted/Missing Muscles to correct this.

Auto-Fix deleted/missing muscles
The Muscle menu includes an item for disconnecting muscles from the
deformer. Using this option to disconnect muscles lets the plug-in zero out
weights for the muscle or bones that have been disconnected. If you have
deleted or disconnected a bone or muscle without using this menu item, the
internal weighting and indexing of the deformer can be disrupted.

To fix improperly disconnected muscles

1 Select the mesh that has a Muscle deformer applied with Sticky weights
to muscles.

2 Select Muscle > Skin Setup > Auto-Fix Deleted/Missing Muscles from the
main menu bar.

The mesh is checked, and the internal indexing is corrected. Weighting
is not adjusted in any way.
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Delete muscle history
You can delete history on a model deformed with the Muscle deformer, but
it is important to use the Safe Delete History option in order to avoid deleting
Muscle or other connected nodes automatically.

To safely delete muscle history

1 Select the object you want to delete history for.

2 Select Muscle > Skin Setup > Safe Delete History from the main menu
bar.

The Muscle system first disconnects the nodes from the selected object,
then deletes the history.

Reset base pose for selected Muscle Objects
Any capsule, bone, or muscle has a Base Pose reset or created. This allows you
to adjust the location of a muscle or bone without having to entirely delete
and recreate the skin deformer.

For example, after placing a joint/capsule and weighting some points to it,
you might decide you need to move the capsule for better deformation. Rather
than having to lose your weighting and disconnect, then recreate the Muscle
deformer, you can reposition the joint and reset the Base Pose for it. This
causes the Muscle deformer to look at the object as if it was originally bound
at that pose.

If you edit the default shape of a NURBS muscle, you should also reset its base
pose. If you are resetting a joint/capsule that you have moved, you also have
to reset any child capsules or muscles attached to it that have been moved
(meaning you need to reset the entire hierarchy of what changed and below).

To reset the Base Pose for a capsule, bone or muscle

1 Select the capsule, bone or muscle object(s) you want to reset the base
pose for.

2 Select Muscle > Muscle Objects > Reset Base Pose for selected Muscle
Objects.

Your objects are reset for any and all Muscle deformers they are tied to.
If the object you are resetting is a NURBS muscle, then the muscle
automatically recalculates sticky bind distance with an automated value.
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When finished, your skin deformation appears as if the object was just
bound with no change from these objects.

Create base for selected Muscle Objects
While resetting the Base Pose is a one-time event, creating an actual Base
object lets you interactively move and adjust the capsule/bone/muscle without
affecting the skin geometry.

While in most cases this is not needed, you can do advanced rigging, or allow
for pivot adjustment, resizing rigs without re-skinning, and so on with this
technique.

To create a Base for a capsule, bone or muscle

1 Select the capsule, bone or muscle object(s) you want to create a base
object for.

2 Select Muscle > Muscle Objects > Create Base for selected Muscle Objects.

When finished, the object(s) you selected are duplicated and connected
to the Muscle deformer so that they act as a base object. Moving the base
along with the original object lets you adjust the object without affecting
the skin.

3 When you are finished with the base, you can delete the base object.

Re-Bind Sticky for selected Muscle Objects
Connecting NURBS muscles into a Maya Muscle system lets you specify what
points can actually be weighted to the muscle when doing Sticky weighting.
If you paint weights to a point that was originally outside of the Sticky-bind
distance, that point calculates its binding on the fly, slowing down
deformation. In case you made your original distance too small, you can
always go back and reset the Sticky bind information for a muscle to use a
larger distance, or all points.

To re-bind the Sticky information for a NURBS muscle

1 Select the muscle or muscles you want to re-bind distance Sticky
information for.

2 Select the Muscle deformed objects that you are going to rebind to.
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3 Select Muscle > Muscle Objects > Re-Bind Sticky for selected Muscle
Objects from the main menu bar.

The Sticky Bind Maximum Distance window appears.

4 Select the option you want (see Sticky Bind Maximum Distance window
on page 149) and click the appropriate button.

The Sticky Bind progress window appears and the muscle can now use
points based on the options you chose.

Related topics

■ Sticky deformation on page 50

Visualize the Sticky Bind distance
To visualize the Sticky Bind distance for selected NURBS muscle(s)

1 Select one or more NURBS muscles for which you want to see the Sticky
bind distance.

2 Select Muscle > Muscle Objects > Visualize Sticky Bind Distance for
selected Muscle Objects.

A visualize sphere appears for each NURBS muscle you selected. This
shows you what area is sticky weightable on your mesh. Any point within
the sphere will be properly bound when connected.
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When you are finished examining the distances, you can delete the visualize
spheres.

Set up Relative Sticky deformation
If you are applying the Muscle deformer to an object that has skinClusters,
you can turn on Relative Sticky mode using the window that appears as you
apply the deformer. See Apply the Muscle deformer on page 61.

If you have applied the Muscle deformer and chose not to turn Relative Sticky
mode on at that time, you can still turn Relative Sticky mode on by doing the
following.

To turn on Relative Sticky mode

1 Select the object you want to set up for Relative Sticky mode. (The object
must already have the Muscle deformer applied.)

2 Select Muscle > Skin Setup > Setup for Relative Sticky Deformation.

The Muscle deformer Relative sticky attribute switches to relative (on)
and a new cMuscleRelative deformer is created and connected. If a
skinCluster existed on your object, the deformer is automatically placed
properly just before it in the history list. If there was no skinCluster, the
deformer is placed in the front of the history.

If you want to change the order of the history for the cMuscleRelative
deformer, right-click and select All Inputs to do the typical reordering
operations.
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Set selected Muscle Objects to Relative Sticky mode

When using Relative Sticky weighting, you can independently set each capsule,
bone or muscle to be in Relative mode or not. This lets you set one dummy
capsule that never moves to be “Not relative” so that you can normalize Sticky
weights with it. By default, they are marked as Relative.

To turn Relative Sticky mode on for an individual Muscle Object

1 Select the Muscle Object (capsule, bone, or muscle).

2 Do one of the following:

■ Select Muscle > Skin Setup > Set Selected Bones/Muscles as Relative
from the main menu bar.

■ Manually set the relative attribute to 1 to turn it on.

To turn Relative Sticky mode off for an individual Muscle Object

1 Select the Muscle Object (capsule, bone, or muscle).

2 Do one of the following:

■ Select Muscle > Skin Setup > Set Selected Bones/Muscles as Not Relative
from the main menu bar.

■ Set the object’s relative attribute to 0 to turn it off.

Related topics

■ cMuscleRelative node on page 172

■ Relative Sticky deformation on page 52

Set a constant fat offset for Sliding deformation
Sliding deformation causes the skin mesh to move outside of any bone or
muscle it hits. Sometimes you may model your mesh very precisely. If a muscle
or bone causes the mesh to move out in the default state, you may prefer to
allow the skin to stay below the surface of the mesh or bone, in essence keeping
the original sculpted model exactly as it was. You can use the useBind and
allowNegFat attributes of the Muscle deformer to do this.

The useBind attribute stores the fat offset of the skin mesh to the closest
bone/muscle and uses that offset throughout the deformation, even if the
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point is slid by another muscle. Usually, the fat value on each bone/muscle
sets the offset between the object and the skin. Once useBind is enabled, this
offset is stored per point on the skin and is used regardless of changes to the
muscle or bone objects.

The result is that the "fat" or offset between the skin and any muscle is
constant. If allowNegFat is on, it allows the fat or offset to be below or inside
a muscle or bone, keeping the original mesh intact.

NOTE There are other options on the cMuscleObject nodes themselves, such as
fat and reverseNormals that also affect how sliding works. Refer to cMuscleObject
node on page 170 for more information on those settings.

In addition, you can use Direction weights and Direction nodes to help adjust and
control the way Sliding occurs. See cMuscleDirection node on page 164.

To set up useBind mode

1 Select the Muscle deformed object and go to the original bind pose state
of the model.

2 Select Muscle > Skin Setup > Bind Fat on Muscle System from the main
menu bar.

The fat distance is stored on the cMuscleSystem node, and the object
returns to its modeled state.

It is important to note that using binding can cause undesirable effects when
muscles slide away or to different areas on the mesh. This is because the offset
from the muscle has been stored, so the change in fat can still be seen. This
usually means that for characters, you may not want to use Bind Fat, but
instead should make sure your muscles are inside of your original skin mesh.

Create a Muscle Direction object
To create a Muscle Direction object

1 Select Muscle > Direction > Make Muscle Direction from the main menu
bar.

If nothing is selected, a new direction object is created. If a capsule object
or objects are selected, a direction object is created as a child shape of the
capsule as a radial direction node.

A Muscle Direction locator appears.
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2 You can adjust the settings now, or adjust them after connecting to a
cMuscleSystem node.

NOTE The falloffInner attribute only controls the display of the
cMuscleDirection node. The effect of the node is determined solely by
weighting. The falloffInner value has no effect on the result.

The falloffOuter value only affects "radial" or capsule-based Muscle
Directions. Raising this value effectively ‘lengthens’ the radial direction
object, shown by the increasing length of the red center-line. It has no
effect in "vector" mode.

3 To connect the direction node to a Muscle deformed object, select both
the deformed object and any Muscle Direction objects you want to
connect. (Selection order does not matter.)

4 Select Muscle > Direction > Connect selected Muscle Directions from the
main menu bar.

The objects are connected, but have no effect until Direction weights are
painted or set.

5 Select the skin mesh, then select Muscle > Paint Muscle Weights to open
the Muscle Paint window.

6 In the Muscle Paint window, switch the Weights to Direction, and select
the proper direction node to paint.

7 Paint weights on the areas you want. Any points affected by the Muscle
Direction that are sliding have the direction of their slide adjusted. Shown
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below, the direction node has been rotated, and points that were pushing
outwards are now sliding/pushed out along the axis specified by the
cMuscleDirection node.

NOTE You can have more than one cMuscleDirection node affect an area of
points and use weighting to blend their effect together.

Set up Displacement deformation
If you want to use the cMuscleDisplace node as a deformation feature, you
can create a displace node and connect it to a Muscle deformed object.

After creating or connecting a cMuscleDisplace node, you may want to adjust
its attributes to get the desired effect. See cMuscleDisplace node on page 165
for descriptions of the attributes. Since Displacement nodes are distance-based
(that is, they falloff or have more effect as they approach or move away from
the surface) there are no weights to paint.

To set up a displace node for deformation

1 Select Muscle > Displace > Create Muscle Displace from the main menu
bar.

A new cMuscleDisplace node is created and selected. By default, this node
is a planar-style displace node. This displace setup not only includes the
group node and cMuscleDisplace locator shape, but also a file input for
selecting the file texture. You can see this by graphing the selected displace
node in the Hypershade or Hypergraph.
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2 Select the file node going into the cMuscleDisplace shape and select an
image file to use as the texture. Typically, you select the node, go to the
Attribute Editor, and click the folder icon next to the Image Name field
to browse for an image file to use.

NOTE Advanced users can also create any traditional Maya 2D texture and
connect the shader’s outColor into the displace node dispData.shader attribute
instead of using a file texture node.

The image should be black where you want no effect, and white where
you want the displacement to push out or occur.

3 Change the attributes of your cMuscleDisplace node as needed and
connect it to a Muscle deformer.

For example, you can change the cMuscleDisplace node from Planar
mode to Cylindrical, or set other options.
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To connect a cMuscleDisplace node

1 Select one or more cMuscleDisplace node objects, then select one or more
Muscle deformed objects (objects with the Muscle skin deformer applied).
(The order of selection does not matter.)

2 Select Muscle > Displace > Connect selected Muscle Displace nodes.

The nodes are now connected.

3 Select the Muscle deformed object and find the cMuscleSystem deformer
node in the Channel Box or in the Attribute Editor.

4 Set the Enable Displace attribute to on.

You can now see the displacement effect. You may need to move, scale
or change other settings on the cMuscleDisplace node to see the effect.

When you no longer want to use a displacement node, you can disconnect it
from the cMuscleSystem deformer.

To disconnect a displace node

1 Select one or more cMuscleDisplace nodes and one or more Muscle
deformed objects. (The order of selection does not matter.)

2 Select Muscle > Displace > Disconnect selected Muscle Displace nodes
from the main menu bar.

The item is disconnected, and no longer affects the mesh.
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Connect a NURBS Curve to a cMuscleDisplace node

When the cMuscleDisplace mode is set to Curves, the position and image map
on the displace node no longer matter, and instead NURBS curves that are
connected to the node are used to do the displacement. As the curves approach
the surface, they move the points out.

NOTE This feature works for deformation-based displacement, and Maya shader
displacement, but is not supported with the mental ray version of the shader.

In order to use this feature, you must connect NURBS curves into the
cMuscleDisplace node. You can select one or more curves, but the radius/falloff
of them will be the same and is set from the cMuscleDisplace node it is
connected to. If you want to use different radius/falloffs, you must use multiple
cMuscleDisplace nodes.

To connect a curve

1 Draw a NURBS curve or curves using standard Maya curve tools.

2 Create a cMuscleDisplace node as described in Set up Displacement
deformation on page 76.

3 Select one or more curves and a cMuscleDisplace node.

4 Select Muscle > Displace > Connect NURBS Curve to Muscle Displace
from the main menu bar.

The curves are now connected. The displacement node itself should be
connected to the Muscle deformer, or as part of a shading network. See
Create Maya cMuscleShader network on page 79.

5 Switch the cMuscleDisplace mode to Curves. The curves are now used to
deform the surface.

To disconnect a curve from a cMuscleDisplace node:

1 Select the NURBS curve(s) and the cMuscleDisplace node.

2 Select Muscle > Displace > Disconnect NURBS Curve from Muscle Displace.

The curve is disconnected and no longer affects the deformation even if
the node is in Curves mode.

Create Maya cMuscleShader network

The cMuscleDisplace feature can operate as a shader as well as a deformation
tool. To do this, a special cMuscleShader node for Maya is created that does
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displacement and handles a connection from a cMuscleDisplace node. This
shader is then connected to the material for your object. The cMuscleShader
is a shader designed for the internal Maya renderer.

To set up a node for Maya-based cMuscleDisplace shading

1 Create a basic material and apply it to your mesh.

2 Select Muscle > Displace > Create Maya Muscle Shader Network from the
main menu bar.

A new cMuscleShader and a new cMuscleDisplace node are created and
selected.

3 Open the Hypershade and graph the selected objects.

4 Select the file node going into the shader and select an image file to use
for the displacement. The image should be black where you want no
effect, and white where you want it to displace the geometry.

5 Select the cMuscleDisplace shader node and your main Maya material
and graph them in the Hypershade.

6 Drag the cMuscleShader onto the Shading Group for the material and
select “other” from the menu that appears.
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The Maya Connection Editor appears.

7 From the shader on the left, select Displacement and connect it to the
Displacement Shader on the right side.

8 Close the Connection Editor.

Now you can see the connection from the shader into the shading group.

9 Use the Maya renderer to see the effect. You can use typical Maya
adjustments to increase the displacement quality. For example, you can
select the mesh and increase the number of Initial and Extra displacement
samples in the Displacement Map section of the Attribute Editor for your
mesh.

Create a mental ray mib_cMuscleShader network

The cMuscleDisplace feature can operate as a shader as well as a deformation
tool. For mental ray rendering, a special mib_cMuscleShader node is created
that does displacement and handles a connection from a cMuscleDisplace
node. This shader is then connected to the material for your object.

To set up a node for mental ray-based cMuscleDisplace shading

1 Create a basic material and apply it to your mesh.

Set up Displacement deformation  | 81



2 Select Muscle > Displace > Create Mental Ray mib_cMuscleShader Network
from the main menu bar.

A new mib_cMuscleShader and a new cMuscleDisplace node are created
and selected.

3 Open the Hypershade and graph the selected objects.

4 Select the mentalray_Texture node going into the shader and select an
image file to use for the displacement with the Attribute Editor. The image
should be black where you want no effect, and white where you want it
to displace the geometry.

5 Select the cMuscleDisplace shader node and your main Maya material
and graph them in the Hypershade.

6 Drag the cMuscleShader onto the Shading Group for the material and
select “other” from the menu that appears.

The Maya Connection Editor appears.

7 From the shader on the left, select Displacement and connect it to the
Displacement Shader on the right.

8 Close the Connection Editor.

Now you can see the connection from the shader into the shading group.
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9 Render the scene with the mental ray renderer to see the effect. You may
want to use typical Maya mental ray adjustments to make higher quality
displacement.

For example, in the Options tab of the Render Settings window, you can
expand the Tessellation section. In that section, you can click the texture
icon beside Displace Approx to create a new mentalrayDisplaceApprox
node for rendering this scene. To do this, you must first select mental
ray as the renderer. In the Attribute Editor you can then set this to a
Spatial approximation method, Fine approximation style, and increase
the Max Subdivisions as desired.

Related topics

■ Displacement deformation and rendering on page 56
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Set up Force deformation
To apply force deformation effects to a mesh

1 Apply the Muscle deformer to a mesh. See Apply the Muscle deformer
on page 61.

2 Paint Force weights on your mesh. See Paint Muscle weights on page 86.

3 Adjust the Force attributes as desired on the cMuscleSystem node. (For
example, set enableForce to on. See Force attributes on page 190 for
descriptions of these attributes.)

Related topics

■ Force deformation on page 58

■ Force attributes on page 190

Set up Jiggle deformation
To use Jiggle

1 Paint Jiggle weights on the object and set up the values as needed on the
deformer. (See Jiggle attributes on page 192.)

2 Step forward frame-by-frame through the animation. As you do this,
Muscle calculates the proper Jiggle effects.

3 Jump to any frame or adjust the Jiggle values at any time and play back
the animation.
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NOTE You do not have to re-step frame by frame if you adjust only the Jiggle
values. However, if you change your core animation or motion of the object,
you must step forward frame by frame again so that Muscle can recalculate
the Jiggle information properly.

For example, if you complete your basic animation, turn on Jiggle, and step
frame-by-frame through the animation, the deformer calculates the Jiggle
and it displays properly. You can alter any of the min/max JIggle settings and
play back (even if you skip frames) and the Jiggle stays accurate.

If you then adjust your initial animation, for example by rotating a joint
differently, you must re-step frame by frame so that the deformer can
recalculate the Jiggle effects.

Related topics

■ Per-Point Jiggle deformation on page 58

■ Jiggle attributes on page 192

Apply default weights
The Default Weights window lets you set initial weighting on your mesh.
Normally, connecting a node or creating a Muscle deformer does not set any
default weights. This window allows you to set or re-set initial values based
either on the nodes connected in (for multi-weight types), or based on other
factors such as curvature or direction (for single weight types like Jiggle and
Relax).

The window operates on selected points or on all points if a mesh is selected.
In this way, you can re-set or apply default weights to just part of your model,
even if you have already weighted another part of it.

IMPORTANT In many cases, you want to have only certain Muscle Objects used
during Sticky or Sliding weight defaults. For example, you may make a
capsule/bone that you plan on using for Sliding, but not for Sticky. However, when
you apply default weights it may apply weights. To correct this, cMuscleObject
nodes have an affectSticky and affectSliding attribute. If you set this before applying
default weights, this information is used to cull those nodes as needed.

For example, you can set the bone to have affectSticky set to off or 0, so that
object is not used when setting sticky weights.
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To apply default weights

1 Select Muscle > Weighting > Apply Default Weights from the main menu
bar.

The Default Weights window appears. There are several options available,
depending on the selected Weight type. See Default Weights window on
page 154 for a detailed description.

2 Select the type of Weight you want to apply defaults for. Depending on
the type of weight, different options appear.

3 Set the Smooth value as desired. Maya determines which point is applied
to which node, or to what value, then applies a Smooth operation to the
weights. The Smooth value sets how many iterations the smooth operation
applies.

4 Select the mesh you want to apply default weights for. If you want to
apply default weights for a part of the mesh, select only those points.

TIP If the Muscle Paint window is open, you can see the weights when the
operation is complete.

5 Click Apply Default Weights.

Paint Muscle weights
The Muscle Paint window provides a number of different weight types to paint
for the various deformation features. In addition to painting weights or
applying default weights, you can also load, save, mirror, transfer, and prune
weights.
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To paint weights

1 Select the object you want to paint weights for.

The object must have a Muscle deformer applied. You can also select
points of the object, which allows the painting to be effectively ‘masked’
so that you only paint on the selected points.

2 Select Muscle > Paint Muscle Weights from the main menu bar.

The Muscle paint weights feature draws a colored mesh similar to Maya
painting if you are using a polygon mesh. For NURBS and subdivision
surfaces, colored points display instead.

The Muscle Paint window appears, and you can start painting.

NOTE You must have Locators set to on in the Show menu of your scene
view to see skin weight painting colors.

3 In the Weights drop-down, select the type of weight you want to paint.
The default is Sticky but you can also select Sliding, Direction or any of
the other weights.

TIP If you are painting Sticky weights for the first time, select your base or
root bone, set the Weight value to 1.0, and click Set Weight/Flood.

This floods the bone or object to have 100% of all the weight. If you do not
do this initially, points may move incorrectly as you paint because they may
not have a truly normalized weight of 1.0, even though the Normalize button
is on.

4 Select the muscle or bone object, and begin painting on the mesh.

TIP Hold down the b key and drag left and right in the scene view to change
the size of the brush.

5 (Optional) Test the results of your weighting by animating your rig, and
tweak the weighting as necessary.

6 (Optional) Select a different weight type in the Weights drop-down menu
and repeat the previous steps for the other weight types (Sliding, Relax,
Wrinkle, Jiggle, Cycle, Rest weights and so on).
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TIP As you switch between weight types, you can disable each type to
improve speed. For example, you may want to disable Sliding weights as you
work with Relax weights.

You can also disable the deformer as you paint weights for faster interaction.

When you are finished with the other weight types, you can use the Smooth
weights to fix any problems.

To set point weights on each point or multiple points

 ➤ In the Muscle Paint window, turn off the Paint option.

You can now directly select points on the mesh, and set their weights
with the slider. The average weight for selected points is shown in the
Weight field when points are selected and Live Update is on.

When finished, if you want to return to Paint mode, you can deselect
any currently selected points, then turn the Paint option back on to return
to painting the entire mesh. Alternatively, if you leave some points
selected, only those points are paintable, and you have effectively ‘masked’
the painting to only the selected points.

Related topics

■ Apply default weights on page 85

■ Mirror weights on page 91

■ Transfer weights on page 93

■ Prune weights on page 93

■ Muscle Paint window on page 149

Load and save weights
The Save Weights window allows you to save the various types of weights on
an object to a text file. These weights can then be reloaded onto the same or
different objects by point order or point position. In addition, by saving and
reloading the mesh by point position with mirroring options set correctly,
you can use the Save/Load weights to mirror your weighting. (There is a
separate Mirror tool for faster built-in mirroring as well.)
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To save weights

1 Select Muscle > Weighting > Load/Save Weights from the main menu
bar.

The Save Weights window appears.

The top section holds shared information on what muscle system to
load/save weights for, and the filename to use. The second section
contains the option to save various types of weights. The third section
contains the load options and related features.

2 Select a mesh that has a Muscle deformer applied and click the load

selection  button in the Node area.

3 Specify a file name, or browse to a file by clicking the  button.

4 Select the type of weights you want to save in the Weights drop-down
list, then click Save Weights.

All points of the object deformed by the provided cMuscleSystem node
are saved, even if only some points are currently selected on the object.

To load weights onto a mesh

1 Select Muscle > Weighting > Load/Save Weights from the main menu
bar.
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The Save Weights window appears. This window also contains options
for loading weights.

2 Select the type of weights to load in the Weights drop-down list.

If the weight type is similar, you can save from one type and reload onto
another. For example, both Sticky and Sliding weights use the same
muscle/bone list, thus you can save one and reload onto the other. All
of the Jiggle, Cycle, Rest, Relax and Smooth weights are simple per-point
weights, so you can save the weights from one type, then load it onto
another. This lets you save weights from Jiggle (for example) and re-load
it into the Rest weights.

The Normalize option turns on/off automatically, but you can override
the value to determine whether loaded weights are normalized to 1.0 for
each point. This setting has no effect on simple per-point weights.

3 Select whether to load by Pt. Order (Point Order), World Pos. (World
Position), or Local Pos. (Local Position).

If the object for which you are loading weights is point-compatible, Pt.
Order is much faster. If your point count has changed, or you are reloading
onto a different object, select World Pos. or Local Pos.. These modes
interpolate weights if new edge loops are added to a mesh, or if the meshes
are relatively similar.

You can enter a tolerance value of 0 or higher to make sure loaded weights
only occur if points are relatively close to the original mesh, or set it to
-1 to ignore. You can also prune weights to any number of decimal places.

When loading by World or Local Position, you can specify an axis that
the loaded information is mirrored across. This is often used with the
Search/Replace fields.

For example, if you have saved weights for a character but have only
weighted the left side, you can chose the X-axis for the Mirror Pos. and
enter the appropriate Search/Replace values such as _L and _R. This causes
a loaded point to be compared to the opposite side and weights to be
applied to matching muscles/bones based on naming.

4 Select the points you want to load the weights on. If none are selected,
all points on the deformed mesh are chosen and loaded automatically.

If you are attempting to mirror weights it is important to only select the
points on the side you are loading the weights for. For example, if you
have saved weights for a rig that has the left side properly weighted, when
loading, you select only the right side points and set the proper mirror
options to set the right side values.

90 | Chapter 3   Skin Deformation



NOTE Remember that loading weights applies to selected points, or to all
points if none are selected. You can use this to your advantage by selecting
only the points that need to be loaded both for speed purposes and to make
sure you do not change weights on parts of the mesh you want to leave
alone.

TIP You can click Select Influences from File to re-select all original
capsules/bones/muscles that were used from the originally saved mesh. This
is useful if you want to re-apply the same rig onto another object, or if you
have removed Muscle deformation and want to reconnect those items. In
addition, this option works with the Search/Replace fields. This lets you select
opposite side muscles for connection into a Muscle deformer.

For example, if you have a left and right arm mesh and have saved Sticky
weights for the left side, you can then set Search and Replace to change the
naming from _L to _R, and click Select Influences from File. Because of the
Search/Replace settings, this selects the right side influences which you can
then connect to the right side mesh.

NOTE Saving weights automatically stores all data needed for any load
operation later. However, save weight files originating from subdivision
surfaces do NOT currently allow for a reload by point position. If you need
to use weighting by point position, you must save the weights from either a
NURBS or polygon mesh object.

Related topics

■ Save Weights window on page 155

Mirror weights
The Mirror Weights window is a fast way to reflect weighting values from one
side of your mesh to another. While the Save/Load Weight window does let
you mirror weights, the Mirror Weights window does not require an external
file. It uses a simpler closest point algorithm for matching points, and so is
faster, but it works best when the mesh sides are symmetric or close to
symmetric.

Like the other weight tools, Mirror Weights can operate on the entire mesh,
or only on selected points.
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To mirror weights for a mesh

1 Select Muscle > Weighting > Mirror Weights from the main menu bar.

The Mirror Weights window appears.

2 Select the mesh you want to mirror weights for and click  to load
it into the window.

TIP Right-click the Node field to select from a list of Muscle deformed objects
in the scene.

3 Select the weight type you want to mirror from the Weights drop-down
list.

4 Select the position to use during mirroring. World Pos. uses the world
position of the mesh, Local Pos. uses the object position.

5 Specify the Point Position Match Tolerance.

Since points on the opposite side are matched by position, this specifies
how far they can be and still be determined as a match. Larger values
means they are more likely to find a match. A smaller value is more
precise. The default tolerance is -1, which means that the closest point
will match regardless of distance.

TIP Right-click the Tolerance field to bring up several default settings.

6 Set the direction to mirror across. This defaults from +X to –X, setting
weights for points on the –X side.

7 Enter the Search/Replace string for your naming conventions. In order
to properly mirror influence-based weights such as Sticky weights, your
muscles/bones should be named with some sort of naming convention.
For example, if your left side muscles use _L at the end, and the right use
_R, set the _L as the Search and _R as the Replace when mirroring from
the left to the right sides.

TIP Right-click the Search field to bring up several common naming
conventions.

8 Select any points you want to load weights for. If no points are chosen,
all points on the mesh for the side you are mirroring to are used.

9 Click Mirror Weights. The weights are mirrored from one side to the
other.
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Transfer weights
The Transfer Weights window allows you to move weights from one or more
bones/muscles/capsules or direction nodes onto another. A typical use for this
is when you have one or more joints weighted but you want to transfer all
the weights from those influences onto another, such as moving weight from
an arm bone onto an arm muscle. Another use is if you have accidentally
weighted points to the wrong object. You could simply move the weights
from the original influence onto the correct one. The window operates on
selected points. If no points are selected, all points are used.

To transfer weights

1 Select Muscle > Weighting > Transfer Weights from the main menu bar.

The Transfer Weights window appears.

2 Select the mesh that is deformed by the Muscle deformer and load it into

the first field by clicking the appropriate load selection  button.

3 Select the objects you want to transfer the weights from and click the

appropriate  button. You can specify one or more objects. For
example, you could transfer weights from multiple neck bones onto one
bone.

4 Select the object you want to move the weights to and click the

appropriate  button.

5 When you are ready to transfer the weights, select the points you want
to transfer for. If no points are selected, then the entire mesh is used.

6 Click Transfer Weights for Selected Points.

Prune weights
The Prune Weights window allows you to set weights that are below a certain
specified value to zero. This has the effect of removing small or unneeded
weights and generally cleaning up any weights that you may not want to have
on nodes.

1 Select a mesh that has the Muscle deformer applied that you want to
prune weights for.
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2 Select Muscle > Weighting > Prune Weights from the main menu.

The Prune Weights window appears.

3 From the Weight drop-down list, select the weight type you want to
prune.

4 Enter the value you want to prune at. Any weights below this value are
set to 0. For weight types that normalize (such as Sticky weights), any
needed remainders are redistributed to the largest weight.

5 Click Prune Weights.
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Collision

Collision
Maya® Muscle provides a number of collision options that can be applied on
top of any other deformer. For example, you can apply a multi-collision or
Muscle collision in order to get self-collision effects on top of a skinCluster.
Collision is deformer-based, and not a simulation, so there is no run up or
pre-processing needed.

Maya Muscle provides three different types of collision: Smart Collision,
Self-Collision and Multi-Object Collision (which can include self-collision
results). In addition, there is a sliding/collision type KeepOut node that can
provide sliding effects on transform nodes. Each collision type is described in
the following sections:

■ Smart Collision on page 95

■ Self Collision on page 97

■ Multi-Object Collision on page 99

■ Transform collisions with KeepOut nodes on page 99

Related topics

■ Collision attributes on page 194

Smart Collision
Smart Collision is a collision deformation that is part of the main Muscle
deformer. This collision lets you set up regions and a cSmartCollide plane node

4
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to determine how to handle collision. The collision results can be a simple
planar collision effect, or can be switched to a true mesh-mesh collision for
more accurate results.

In addition to providing collision, the cSmartCollide node and deformation
also allow for several other weight types that augment basic skinning effects.
These weights can help bulk or bulge out parts of a mesh, create wrinkle effects,
slide points, and otherwise get better deformation at joint locations, all without
using extra joints or muscles.

For example, a cSmartCollide node provides weights that bulge out the parts
of the mesh where two joints rotate together, and thus can provide very quick
volume effects for things like fingers, without the overhead of using actual
muscles.

Smart Collision is the fastest of the three collision methods offered by Maya
Muscle.

Understanding Smart Collision

One of the main purposes of the Smart Collision nodes is to fix typical
problems encountered with skinning. You can use Smart Collision without
activating real collision. The Muscle Smart Collide node has several attributes
for movement. The attributes control the strength or amount of motion applied
on weighted points, and each has a corresponding weight map. For example,
the bulkA/bulkB attributes are related to the Smart Bulk weights that you can
paint.

The painted weights or attributes affect the mesh more or less as the two joints
become more or less aligned. That is, the effects of the movement weights are
“triggered” based the rotation of the joints. As the B joint rotates towards the
A joint, the effects increase. Each point is adjusted based on the painted weight
and by the attribute. For example, a weight painted at 1.0 for Bulk is multiplied
by the Bulk A or Bulk B attribute depending on if the point is also in the A or
B “region” weight. If a point is not included in the original “region” weights,
then it is not deformed.

It is important to note that most of the weights move points more on the side
that the joints are rotating together, than on the opposite side. For example,
if a finger bend inwards, the Bulk weights, even if painted around the entire
mesh, mostly affect the “inside” parts of the finger. In this way, you can apply
weights to things like a spine or belly all around your character, but the actual
area that bulges only occurs as the joints rotate in that direction. The falloff
angle for this can be set using the angleMin and angleMax attributes on the
Muscle Smart Collide node. This falloff angle is implied based on the joint
rotation to be the bisect of the two joints.
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Besides movement options, the Smart Collision node also offers either planar
or mesh-mesh collision. Both weights for the areas of flattening/collision can
be painted, as well as areas to be volumized or puffed based on the collision.

For detailed descriptions of the Collision attributes refer to
cMuscleSmartCollide node on page 173.

Smart Collision region weights

Once created and connected, you must set weights for each Muscle Smart
Collide node. This can be done manually, or using the Default Weights
window. There are two main features to Smart Collision nodes: weights that
affect motion of the skin results of the mesh, and actual collision-related
weights and attributes. For example, there are bulk or sliding weights that
affect how points move, which can help remove unwanted skinning artifacts
such as pinching. In order to use all of these tools, you must weight two sets
or “regions” of points so that the deformer knows which area is which.

Related topics

■ cMuscleSmartCollide node on page 173

■ Default Weights window on page 154

Self Collision
The Muscle deformer also offers automatically calculated Self Collision, which
is based on collision area groupings that you define. Enabling Self Collision
can be slower, since it runs over the entire mesh grouping you create (although
Self Collision weights can be painted to cull areas you do not want calculated).
The benefit of this approach is that there is less setup work and fewer attributes
to deal with than Smart Collision, and it functions even in areas that are not
connected by two joints. The computation automatically finds, resolves, and
corrects the areas that you define as self-colliding.

Self Collision is not time-based, so you can apply the Muscle deformer to a
static model and have it resolve collisions. There are three paintable Self
Collision weights types available in the Muscle Paint window:

■ Self Collision weights are used to cull parts of the mesh you do not need
to collide with. For example, if the head of your character is effectively
rigid, you can remove it from the collision computations.
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■ Self Rigidity weights allow you to make parts of your mesh harder (more
rigid) or softer (more elastic) when they collide. For example, an arm may
be harder than a belly area, so the arm would be painted a higher weight.

■ Self Volumize weights allow you to paint what areas of the mesh can move
or volumize out more than other areas.

It is important to note that Self Collision is related to the detail resolution of
your model. The more detailed the model, the slower collision is, but the more
accurate. Collision is partially point-based, so it cannot occur when the areas
colliding are smaller than a polygon on the mesh. In general, collision appears
smoother and more accurate when you use a more detailed model.

In addition, the collision occurs in point groupings that you define. This is
similar to SmartCollide nodes where you paint an A and B set of points. For
Self Collision, you use the Self Collision Grouping window (Muscle > Self/Multi
Collision > Self Collision Grouping) to mark pairs of regions you want to
collide. For example, if you want the upper leg and lower leg to collide, you
create a grouping defining the points in each area, and store that to the
cMuscleSystem node.

Related topics

■ Set up Self Collision on page 102

■ Collision attributes on page 194
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Multi-Object Collision
Maya Muscle provides a separate Muscle Multi Collide deformer that can be
applied to multiple objects or single objects. This allows you to create
object-object collision effects, and to use Maya Muscle’s Self Collision ability
on surfaces.

Since this is a regular Maya deformer, there is only one paintable weight type,
and that is the built-in Maya deformer weights. These weights are used to set
rigidity on the object, rather than for culling or envelope effects.

Related topics

■ cMuscleMultiCollide node on page 169

Transform collisions with KeepOut nodes
Maya Muscle provides one more utility for collision/sliding, which is the
Muscle KeepOut node. This node lets you drive the translate/rotate of a
transform node, such as a group, so that the node can “slide” or collide with
any Muscle object (such as a capsule, muscle, or bone).

This gives you the power of Maya Muscle’s Sliding algorithm, allowing for
sliding or collision-type effects, but with transform objects. Using Muscle
KeepOut nodes, you can create a number of interesting rigging tricks or
constraints.

For example, you can create a ground plane, make it a Muscle Object, rig an
animation control to slide against the plane, and get ground locking effects.
Or, parent a special flatten joint to an arm and have it collide with a capsule
or Muscle Object in the chest as the arm lowers, keeping the arm always outside
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the chest. KeepOut nodes give you sliding effects paired with custom rigging
possibilities using joints/transforms and constraints.

For objects like muscles or clothing, you can create a rib-cage capsule or muscle,
then have a joint that “keeps-out” from that node, so that even if the animator
poses the arm down, the skin joint collides and does not penetrate.

Related topics

■ Rig an object hierarchy for KeepOut collision on page 104

■ cMuscleKeepOut node on page 168

Set up Muscle Smart Collision
In order to use Smart Collision, you must create Muscle Smart Collide nodes.
These are special locators that are connected to two different joints or
transforms, and are automatically constrained (with a Muscle Smart Constraint
node) to stay between them. As this node moves and rotates, it affects the
different directions used by various weights to help with skinning. The plane
also helps determine how to do the actual collision.

To create a Muscle Smart Collide node

1 Select two joints, bones, or transforms. In this case, the order of selection
matters.

The first joint typically represents the “A” region or side, and the second
joint the “B” side. Normally, you want to select two joints that are
connected, although this is not strictly required. For example, you can
select an UpperArm bone and a LowerArm or Elbow bone.

2 Select Muscle > Smart Collision > Create Muscle Smart Collide from the
main menu bar.

A new Muscle Smart Collide locator is created. This node has several
attributes that relate to the deformation. Before it can be used, it must
be connected to a Muscle deformed object.
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Connect selected Muscle Smart Collide nodes
Once a Muscle Smart Collide node is created, it must be connected and
weighted in a Muscle deformer.

To connect a node to a Muscle deformed object

1 Select one or more Muscle Smart Collide nodes, and one or more Muscle
deformed objects (the order of selection does not matter).

2 Select Muscle > Smart Collision > Connect selected Muscle Smart Collide
nodes from the main menu bar.

The collide nodes are now connected, and are ready to be weighted and
used.

To disconnect a Muscle Smart Collide node:

1 Select one or more Muscle Smart Collide nodes, and one or more Maya
Muscle deformed objects (the order of selection does not matter).

2 Select Muscle > Smart Collision > Disconnect selected Muscle Smart
Collide nodes from the main menu bar.

The collide nodes are disconnected and no longer affect the
cMuscleSystem node.

Set up Smart Collision region weights
To set up initial weighting for a Muscle Smart Collide node

1 Create and connect the node to a deformer as described earlier. (See Set
up Muscle Smart Collision on page 100 and Connect selected Muscle Smart
Collide nodes on page 101.)
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2 If you have not already done so, on the cMuscleSystem node for the
object you are deforming, set the smartCollision attribute to “on”. This
enables Smart Collision on the deformer.

3 In the Paint Weights window, set weights for the Smart Region A and
Smart Region B weights for the connected node.

Typically, you want to set weights to 100% value for each region. Areas
“before” the plane would be “A”, and after would be “B”. For example,
if the collide node is parented to an elbow, the upper arm points would
be “A” and the lower arm “B”. These regions help determine what points
are allowed to be deformed and collided by each A or B attribute.

If you have a span of points that is shared, set the weights to 0.5 instead
of 1.0. This allows the points to be affected by both attributes.

4 Weight the other Smart Collide weights and set the values you require
on the node.

Related topics

■ Muscle Paint window on page 149

Set up Self Collision
To use Self Collision

1 If you have not already done so, apply a Muscle deformer on your object.

2 Select Muscle > Self/Multi Collision > Self Collision Grouping from the
main menu bar.
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3 In the window, specify a name for the grouping you want to create.

4 Select points for the first half of the area you want to collide. For example,

select an upper arm region of points, and click the load selection 
button to load these point indexes into the window in the Pts A section.

5 Select the other half of the area you want to collide and load those points

by clicking the  button in the Pts B area.

6 Click Create New Grouping.

This data is now stored on the Muscle deformer so that it knows which
areas of your mesh to collide.

7 Select the Muscle deformer on the object.

8 In the Channel Box or Attribute Editor, set the selfCollision attribute to
on.

Collisions are computed.

9 Adjust the Self Collision, Self Rigidity and Self Volumize weights as
desired. You can also adjust the attributes related to Self Collision in the
Self Collision Grouping window on page 156.

Set up Muscle Multi Collision
To apply multi-object collision to objects

1 Select the objects you want to use in the multi-object collision.

2 Select Muscle > Self/Multi Collision > Apply Muscle Multi Collide
Deformer from the main menu bar.

A new Muscle Multi Collide deformer is applied and connected to all
objects. In the Channel Box or Attribute Editor you can set other options,
such as volumization and self collision (which causes self collision to be
calculated on each object as well as multi-object collision).

3 If you want to adjust rigidity weight, select the object you want to adjust

and select Modify > Paint Attributes Tool >  .

The Paint Attributes tool appears. The weights
“cMuscleMultiCollide#.weights” appear in the Weights button.
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If this does not appear, use the following MEL command to set weights
as paintable:

makePaintable -attrType "multiFloat" -sm "deformer" "weightGeo

metryFilter" "weights" makePaintable -attrType "multiFloat" -sm

"deformer" "cMuscleMultiCollide" "weights"

4 Start painting weights.

Lower weights work the opposite from the way they do with the Muscle
deformer. In this case, a weight of 0 is more rigid, and a weight of 1 (the
default) is soft.

5 If you want to modify the effect or prune/cull the deformation, use the
regular Maya membership tools such as Edit Membership to remove
points from the calculation.

By default, Volumize is set to 0, and you can increase this on the deformer.

Related topics

■ Multi-Object Collision on page 99

Rig an object hierarchy for KeepOut collision
To rig an object hierarchy for KeepOut

1 Select the object you want rigged for Keep Out functionality.

The selected object is considered the “animation control” that the
animator uses to create poses. Any child objects are reparented under the
KeepOut node and can collide with any number of Muscle Objects.

2 Select Muscle > Self/Multi Collision > Rig selection for KeepOut from the
main menu bar.

A new group is inserted as a child of the hierarchy. By default, this
KeepOut node attempts to project against its X-axis to stop children from
going into Muscle Objects.

The Muscle KeepOut node calculates the required information and has
other attributes for the settings of the KeepOut node. A group parented
underneath called the “Driven” group, stops or collides with the objects.

You can now connect the KeepOut node to Muscle Objects. See Connect
muscles to KeepOut on page 105.
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Related topics

■ Transform collisions with KeepOut nodes on page 99

■ cMuscleKeepOut node on page 168

Connect muscles to KeepOut
Once a KeepOut hierarchy is rigged, you must connect it to one or more
Muscle Object nodes (such as capsules, bones or muscles) that you want it to
collide against.

1 Select the Muscle KeepOut locator or parent group.

2 Ctrl-click to select the Muscle Object or objects you want it to collide
against.

3 Select Muscle > Self/Multi Collision > Connect Muscles to KeepOut.

The nodes are now connected, and the driven group will attempt to slide
along the direction provided to stay outside the connected muscle objects.

To disconnect a muscle object from a KeepOut calculation

1 Select the Muscle KeepOut locator or parent group, as well as the Muscle
Object nodes to disconnect from.

2 Select Muscle > Self/Multi Collision > Disconnect Muscles from KeepOut
from the main menu bar.

The node is now disconnected and no longer affects the Muscle KeepOut.

Related topics

■ cMuscleKeepOut node on page 168
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Caching

Point-caching
The point-cache feature of the Maya® Muscle deformer lets you cache all point
information that occurs up to the deformation stage. This provides faster
feedback after the main deformation and animation is complete. For example,
you can use this feature for faster timeline scrubbing when doing lighting or
rendering.

Like the Jiggle and Relax deformation features, caching is an independent feature
of the deformer. This means it can be used even if you are not doing skinning
or any other calculation with the deformer, but can be applied on top of other
deformers to write out and read cache data for your object.

When caching is disabled or set to write-node mode, the main deformer
calculates with whatever settings are active. When caching is in read-node mode,
main calculations are disabled and a simple point-cache is performed.

For file cache, you can set the location where the files are stored using the
Attribute Editor, or by selecting Muscle > Caching > Set Location of Cache File
from the main menu.

If you set Cache to write-file, each frame outputs one ASCII text file with
information on the points for the mesh based on the location and filename you
specify. If you are using node-based caching, the Cache Path has no effect.

NOTE You can also use Maya’s Geometry Cache feature for caching. See Geometry
caching overview in the Animation guide.

Related topics

■ cMuscleSystem node on page 187

5
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Create a cache
To create a cache

1 Select a Muscle deformed object.

2 Select Muscle > Caching > Create Cache from the main menu bar.

The Generate Cache window appears.

3 Enter the Start and End frames you want to create the cache for. The
default values are based on the current Time Slider range.

4 With the Cache To options, specify if you want to generate the cache to
external files, or internally on the node.

5 Make sure your mesh or meshes are selected, and click Generate Cache
for Selected Objects.

The timeline auto-scrubs and a cache is stored. When finished, the cache
attribute is set to Read mode for the type of cache you created for each
object that was affected.

Delete a node cache
Deleting a node-based cache can help reduce file size.

NOTE To delete file caches you must manually delete the files.

To delete a node-based cache

1 Select Muscle > Caching > Delete Node Cache from the main menu bar.

2 In the Delete Cache window, enter the frame range to delete.

3 Click Delete Node Cache for Selected Objects.
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Technical API

Maya Muscle Commands
The following are the various commands that the Maya Muscle plug-in provides.
These commands are used within the Maya Muscle scripts, but can also be used
in your custom MEL scripts.

All commands have a -h option or -help option for help. For many commands
you can also type the command with no options to get help. For example,
"cMuscleBindSticky -h;" provides help on the cMuscleBindSticky command. In
addition, this also ties into the Maya "help" command so that "help
cMuscleBindSticky" provides less verbose and simpler information on the
command.

Related topics

■ Muscle Nodes on page 161

cMuscleBindSticky
Description: Calculates Sticky-Bind information for NURBS muscles to Muscle
deformers.

Flags:

DescriptionArgumentLong FlagShort Flag

Calculate center and overall distance for
default sticky binding based on distance

-cbind-c

from the given muscle. Returns 4 values,
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DescriptionArgumentLong FlagShort Flag

the first three are the X, Y, Z values of the
center, the fourth is the default distance.

Maximum distance from center of muscle
to affected points for binding.

float-dist-d

The Muscle deformer node to sticky bind
to.

string-system-sys

Muscle (cMuscleObject) node you are
going to bind. Must already be connected
to the system node.

string-muscle-mus

The direct index 0...n of the muscle. Either
this or -muscle must be provided for
binding.

int-mindex-mi

Examples:

cMuscleBindSticky -system cMuscleSystemNode -muscle cMuscleObject

Node ; // Perform sticky bind on given muscle to system node.

cMuscleBindSticky -system cMuscleSystemNode -mindex 0 ; // Perform

sticky bind on first muscle to system node.

cMuscleBindSticky -system cMuscleSystemNode -mindex 0 -d 2.5 ; //

Perform sticky bind on first muscle to system node, but only to

points within 2.5 units from the center of the muscle.

float $result[4] = `cMuscleBindSticky -cbind -muscle cMuscleObject

Node` ; // Calculate best distance and center for sticky distance

binding.

cMuscleCache
Description: Caches Muscle deformed objects over time.

Flags:

DescriptionArgumentLong FlagShort Flag

End frame to use when caching.int-endf-e
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DescriptionArgumentLong FlagShort Flag

Type of cache to write, either "node" or
"file". If not provided, then "node" is as-
sumed as default.

string-mode-m

Start frame to use for caching process.int-start-s

Examples:

cMuscleCache -start 0 -end 100 -mode "file" cMuscleSystem1

cMuscleSystem2 ; // Write to external file cache for the two given

cMuscleSystem // nodes from frame 0 to 100.

cMuscleCompIndex
Description: For a selected NURBS component CV, this returns a single entry
index that corresponds to the internal index that a scripted or programmed
deformer would see in the MItGeometry loop.

Flags:

None

Examples:

cMuscleCompIndex myNurbsSurface.cv[3][2] ; // Get index number as

a single order for this vert.

cMuscleQuery
Description: Gets information about a Muscle deformer node.

Flags:

DescriptionArgumentLong FlagShort Flag

Return direction (cMuscleDirection) nodes
tied to the system.

-direction-dir

Return the geometry being deformed by
this system.

-geometry-geo
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DescriptionArgumentLong FlagShort Flag

Return the logical indices the muscles/dir-
ections are connected to, instead of their
names.

-index-idx

Return muscle/bone (cMuscleObject)
nodes tied to the system.

-muscle-mus

Return smartcollide nodes tied to the sys-
tem.

-smartcol-
lide

-smr

The Muscle deformer we are getting in-
formation from.

string-system-sys

Examples:

cMuscleQuery -system cMuscleSystemNode -muscle ; // Return all

muscles tied to the system node.

cMuscleQuery -system cMuscleSystemNode -direction ; // Return all

dir's tied to the system node.

cMuscleQuery -system cMuscleSystemNode -mus -idx ; // Return the

indexes the muscles are connected into. // ie: sys

tem.muscleData[#], this returns the #.

cMuscleQuery -system cMuscleSystemNode -dir -idx ; // Return the

indexes the directions are connected into. // ie: sys

tem.dirData[#], this returns the #.

cMuscleQuery -system cMuscleSystemNode -geometry ; // Return the

name of the geometry this system is deforming.

cMuscleRayIntersect
Description: Returns closest location point of a ray intersect with a surface.
Returns X, Y, Z and a 0 or 1 for if successful.

Flags:

DescriptionArgumentLong FlagShort Flag

Specify bone angle to allow when grow-
ing. Defaults to -1, which means ignore.
Otherwise use 0 - 180.

float-boneangle-ba
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DescriptionArgumentLong FlagShort Flag

Specify starting location of bone. Defaults
to 0,0,0.

float float
float

-bonepoint1-bpt1

Specify ending location of bone. Defaults
to 0,0,0.

float float
float

-bonepoint2-bpt2

Do intersection in Object space of
provided, otherwise uses World space as
default.

-local-loc

Amount final point distance should be
multiplied to adjust final result. For ex-

float-mult-mlt

ample 2.0 returns a point twice as far as
it would be normally. Defaults to 1.0.

Amount points should be offset inward
from point. This simulates a fat offset from
the hit surface. Defaults to 0.0.

float-offset-off

Specify from location of ray. Defaults to
0,0,0.

float float
float

-point1-pt1

Specify ending location of ray. Defaults to
0,1,0.

float float
float

-point2-pt2

Examples:

cMuscleRayIntersect -pt1 0 0 0 pt2 0 1 0 pCube1 ; // Return loca

tion of ray intersect from pt1 to pt2 on surface.

cMuscleRelaxSetup
Description: Prepares the Muscle deformer for deforming a mesh. This
command must be executed before the deformer can work. While in previous
versions this command was used only for Relax setup, it is now used to
initialize many different features on the deformer, despite retaining its original
name and argument.
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Flags:

DescriptionArgumentLong FlagShort
Flag

Generate new spring information for Relax.-gens-
pring

-gen

Examples:

cMuscleRelaxSetup -gensprings cMuscleSystem1 ;

cMuscleSplineBind
Description: Binds or shapes geometry for the given cMuscleSplineDeformer.

Flags:

DescriptionArgumentLong FlagShort
Flag

Perform the bind.-bind-b

Return position of the start/end points of the
surface. Returns 6 values, the first 3 are the

-endpts-ep

X,Y,Z position of the start, the next 3 are the
X,Y,Z position of the end in World space.

Custom shape index to store.int-sindex-si

Target shape for shape creation.string-target-tgt

Examples:

cMuscleSplineBind -bind cMuscleSplineDeformer1 ; // Perform bind

on given muscle spline deformer, so deformation // can occur.

float $posData[6] = `cMuscleSplineBind -endpts cMuscleSplineDe

former1` ; // Retrieve the start/end points on the surface where

the start/ // end movers should be placed at.

cMuscleSplineBind -si 3 -tgt "shapeTgtObjShape" cMuscleSplineDe

former1 ; // Store a new shaping target at index 3 from the given

shape // object.
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cMuscleWeight
Description: Sets or gets Muscle deformer weights.

Flags:

DescriptionArgumentLong FlagShort
Flag

Enable or disable Lock/Hold weights on a
muscle or direction node.

boolean-lock-l

cMuscleObject or cMuscleDirection node for
the muscle, bone or direction you are getting
or setting weights for.

string-muscle-mus

The direct index 0...n of the muscle, bone or
direction. Either this or -muscle must be
provided for setting/getting weights.

int-mindex-mi

Will normalize the weights for the point, but
keeps the value you are setting as is. Defaults
to on if not specified.

boolean-normalize-n

The direct point index of the weight to set.
Either this or an obj.component must be
provided.

int-pindex-pi

The Muscle deformer weights are being set for.string-system-sys

Value of weight set, or marks as a get.float-value-v

What type of weight to alter, must be a string
of one of the following:"sticky", “stickyb”,

string-weight-wt

“stickyc”, "sliding", "direction",” smartregiona”,
“smartregionb”, “smartbulk”, “smartbulkangu-
lar”, “smartbulkwiden”, “smartslide”,
“smartslideangular”, “smartsmooth”,
“smartwrinkle”, “smartflatten”, “smartvolum-
ize”, “force”, “jiggle”, “cycle”, “rest”, “relax”,
“wrinkle”, “smooth”, “smoothcompress”,
“smoothexpand”, “selfcollision”, “selfrigidity”,
“selfVolumize”.If left blank, sticky is assumed.
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Examples:

cMuscleWeight -system cMuscleSystemNode -muscle cMuscleNode -v 0.0

-wt "sticky" -normalize true mySkin.vtx[12] ; // Set Sticky Weight

to 0 with normalization on

cMuscleWeight -system cMuscleSystemNode -muscle cMuscleNode -v 0.0

-wt "sliding" mySkin.vtx[12] ; // Set Sliding Weight to 0

cMuscleWeight -system cMuscleSystemNode -muscle cMuscleNode -v 0.0

-wt "direction" mySkin.vtx[12] ; // Set Direction Weight to 0

cMuscleWeight -system cMuscleSystemNode -v 0.0 -wt "relax"

mySkin.vtx[12] ; // Set Relax Weight to 0

cMuscleWeight -system cMuscleSystemNode -v 0.0 -wt "smooth"

mySkin.vtx[12] ; // Set Smooth Weight to 0

cMuscleWeight -system cMuscleSystemNode -muscle cMuscleNode -wt

"sticky" -q -v mySkin.vtx[12] ; // QUERY Sticky Weight

cMuscleWeight -system cMuscleSystemNode -muscle cMuscleNode -wt

"sliding" -q -v mySkin.vtx[12] ; // QUERY Sliding Weight

cMuscleWeight -system cMuscleSystemNode -muscle cMuscleNode -wt

"direction" -q -v mySkin.vtx[12] ; // QUERY Direction Weight

cMuscleWeight -system cMuscleSystemNode -wt "relax" -q -v

mySkin.vtx[12] ; // QUERY Relax Weight

cMuscleWeight -system cMuscleSystemNode -mi 0 -pi 12 -wt "sticky"

-q -v ; // QUERY Sticky Weight of 0th muscle on the 12th point

cMuscleWeight -system cMuscleSystemNode -mi 0 -lock true ; // Set

Sticky Lock Weights on 0th muscle to on

cMuscleWeight -system cMuscleSystemNode -mi 0 -wt "sliding" -lock

true ; // Set Sliding Lock Weights on 0th muscle to on

cMuscleWeight -system cMuscleSystemNode -mi 0 -wt "direction" -

lock true ; // Set Direction Lock Weights on 0th direction node

to on

cMuscleWeight -system cMuscleSystemNode -mi 0 -q -lock ; // QUERY

Sticky Lock Weights on 0th muscle

cMuscleWeightDefault
Description: Sets initial/default weights for the selected Muscle deformed
objects for the provided weight type and options provided. This is also used
to fix invalid Sticky bindings.
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Flags:

DescriptionArgumentLong FlagShort
Flag

For Direction mode, sets the angle range for
a point to be considered weighted. Default is
45.0.

float-angle-ang

For single weight types, this means use
curvature method.

-bycurve-byc

For single weight types, this means use direc-
tion/angle method.

-bydirec-
tion

-byd

For Curve mode, specifies the curvature
needed. 1.0=more curved. 0.0=flat.

float-curve-crv

Specify this flag to set default weights.-default-def

For Direction mode, this sets the direction to
try to match. Default is 0,-1,0.

float float
float

-direction-dir

Falloff distance to use for weighting sliding
and direction style weights.

float-falloff-fa

If this flag is provided, Muscle re-binds sticky
muscle-points that need it. This fixes errors

-fixsticky-fix

that occur when the showWarnings option on
the deformer is on. When setting default sticky
weights, this occurs automatically.

Will normalize the weights when loading.
Usually you want this on for sticky.

boolean-normalize-n

Prunes weights to provided number of
decimal points. Default is 0 which means do
not prune.

int-prune-pr

Reverses the effect of single weight by
Curvature mode so weights are higher when
flatter instead of curved.

-reverse-rev
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DescriptionArgumentLong FlagShort
Flag

How many iterations to smooth weights. Usual
values are between 0 and 20.

Int-smooth-sm

The Muscle deformer to affect.string-system-sys

What type of weight to alter, must be a string
of one of the following:"sticky", “stickyb”,

string-weight-wt

“stickyc”, "sliding", "direction",” smartregiona”,
“smartregionb”, “smartbulk”, “smartbulkangu-
lar”, “smartbulkwiden”, “smartslide”,
“smartslideangular”, “smartsmooth”,
“smartwrinkle”, “smartflatten”, “smartvolum-
ize”, “force”, “jiggle”, “cycle”, “rest”, “relax”,
“wrinkle”, “smooth”, “smoothcompress”,
“smoothexpand”, “selfcollision”, “selfrigidity”,
“selfVolumize”.If left blank, sticky is assumed.

Examples:

cMuscleWeightDefault -sys cMuscleSystem1 -default -wt "sticky" -

normalize true -smooth 3; // Set default sticky weights

cMuscleWeightDefault -sys cMuscleSystem1 -default -wt "sliding" -

smooth 2 -falloff 50.0 ; // Set default sliding weights

cMuscleWeightDefault -sys cMuscleSystem1 -default -wt "direction"

-smooth 0 ;

// Set default direction weights

cMuscleWeightDefault -sys cMuscleSystem1 -default -wt "jiggle" -

bydirection -direction 0.0 -1.0 0.0 -angle 45.0 ; // Set default

jiggle weights based on points that have normals // facing straight

down within a 45 degree threshold.

cMuscleWeightDefault -sys cMuscleSystem1 -fixsticky ; // Automat

ically rebind sticky any muscle-points that need it

cMuscleWeightMirror
Description: Mirrors Muscle deformer weights across an axis from one side to
another.
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Flags:

DescriptionArgumentLong FlagShort
Flag

The mirror axis when loading by point position.
You can use this to mirror the points in conjunc-

int-axis-a

tion with Search and Replace. -1 means no
mirror. 0=X-axis, 1=Y-axis, 2=Z-axis.

String for Replace in each influence name.string-replace-rep

When loading by point position, space to use
for points. Either "world" or "object". Default is
"world".

string-space-spc

String for search in each influence name.string-search-src

Muscle deformer.string-system-sys

When loading by point position, points must
be within this distance squared to be loaded.

float-tolerance-tol

Default is -1 which means ignore. Any value 0
or higher is used as a tolerance match.

What type of weight to alter. Must be a string
of one of the following:"sticky", “stickyb”,

string-weight-wt

“stickyc”, "sliding", "direction",” smartregiona”,
“smartregionb”, “smartbulk”, “smartbulkangu-
lar”, “smartbulkwiden”, “smartslide”,
“smartslideangular”, “smartsmooth”,
“smartwrinkle”, “smartflatten”, “smartvolum-
ize”, “force”, “jiggle”, “cycle”, “rest”, “relax”,
“wrinkle”, “smooth”, “smoothcompress”,
“smoothexpand”, “selfcollision”, “selfrigidity”,
“selfVolumize”.If left blank, sticky is assumed.

Examples:

cMuscleWeightMirror -sys cMuscleSystem1 -wt "sticky" -a 0 -search "Lf" -replace
"Rt" ; // Mirror sticky weights from -X to +X taking into account // any search
and replace
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cMuscleWeightSave
Description: Loads or saves Muscle deformer weights to an external file.

Flags:

DescriptionArgumentLong FlagShort
Flag

The mirror axis when loading by point position.
You can use this to mirror the points in conjunc-

int-axis-a

tion with Search and Replace. -1 means no
mirror. 0=X-axis, 1=Y-axis, 2=Z-axis.

Either "save" or "load" or "infs". Default is "load".string-action-act

Specify file to use.string-file-f

Mode for loading points. Either "pointorder" or
"pointposition". Default is "pointorder".

string-mode-m

Normalizes the weights when loading. Usually
you want this on for sticky.

boolean-normalize-n

Prunes weights to provided number of decimal
points. Default is 0 which means do not prune.

int-prune-pr

String for Replace in each influence name.string-replace-rep

When loading by point position, space to use
for points. Either "world" or "object". Default is
"world".

string-space-spc

String for search in each influence name.string-search-src

Muscle deformer.string-system-sys

When loading by point position, points must
be within this distance squared to be loaded.

float-tolerance-tol

Default is -1 which means ignore. Any value 0
or higher is used as a tolerance match.

What type of weight to alter. Must be a string
of one of the following:"sticky", “stickyb”,

string-weight-wt
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DescriptionArgumentLong FlagShort
Flag

“stickyc”, "sliding", "direction",” smartregiona”,
“smartregionb”, “smartbulk”, “smartbulkangu-
lar”, “smartbulkwiden”, “smartslide”,
“smartslideangular”, “smartsmooth”,
“smartwrinkle”, “smartflatten”, “smartvolum-
ize”, “force”, “jiggle”, “cycle”, “rest”, “relax”,
“wrinkle”, “smooth”, “smoothcompress”,
“smoothexpand”, “selfcollision”, “selfrigidity”,
“selfVolumize”.If left blank, sticky is assumed.

Examples:

cMuscleWeightSave -sys cMuscleSystem1 -wt "sticky" -f

"c:/temp/foo.txt" -action "save" ; // Save sticky weight, with no

pruning

cMuscleWeightSave -sys cMuscleSystem1 -wt "sticky" -normalize true

-f "c:/temp/foo.txt" -action "load" ; // Load sticky weights and

normalize them on load

cMuscleWeightSave -sys cMuscleSystem1 -wt "jiggle" -prune 3 -f

"c:/temp/foo.txt" -action "load" ; // Load jiggle weights and prune

to 3 decimal places

cMuscleWeightSave -f "c:/temp/foo.txt" -search "Lf" -replace "Rt"

-action "infs" ; // Return the list of bones/muscles that were

used in this file // taking into account any search and replace

cMuscleWeightPrune
Description: Prunes Muscle deformer weights to fewer decimal places.

Flags:

DescriptionArgumentLong FlagShort
Flag

Normalizes the weights when loading. Usually
you want this on for sticky.

boolean-normalize-n

Muscle deformer.string-system-sys

What type of weight to alter. Must be a string
of one of the following:"sticky", “stickyb”,

string-weight-wt
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DescriptionArgumentLong FlagShort
Flag

“stickyc”, "sliding", "direction",” smartregiona”,
“smartregionb”, “smartbulk”, “smartbulkangu-
lar”, “smartbulkwiden”, “smartslide”,
“smartslideangular”, “smartsmooth”,
“smartwrinkle”, “smartflatten”, “smartvolum-
ize”, “force”, “jiggle”, “cycle”, “rest”, “relax”,
“wrinkle”, “smooth”, “smoothcompress”,
“smoothexpand”, “selfcollision”, “selfrigidity”,
“selfVolumize”.If left blank, sticky is assumed.

Examples:

cMuscleWeightPrune -sys cMuscleSystem1 -default -wt "sticky" -

normalize true -prune 3; // Prune sticky weights to 3 decimal

places
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Muscle Menu

Muscle > Muscles/Bones

Muscle > Muscles/Bones > Muscle Creator
Opens the Muscle Creator window. See Muscle Creator window on page 146.

Muscle > Muscles/Bones > Convert Surface to
Muscle/Bone

Adds a Muscle Object shape node to the selected object so that it can be
connected to the Muscle deformer.

Related topics

■ Convert Maya joints to capsules on page 13

■ Convert polygonal meshes to bones on page 15

Muscle > Muscles/Bones > Make Capsule
Creates a capsule object.

■ Capsules on page 5

■ Create a capsule on page 10

7

123



Muscle > Muscles/Bones > Make Capsule with End
Locator

Creates a capsule object with an End Locator. See Create a capsule on page
10.

Muscle > Muscles/Bones > Add End Locator to Capsule
Adds an end locator to the selected capsule object.

Muscle > Muscles/Bones > Generate Polygon Cylinders
from Capsules

Creates polygon cylinders the same size and material color as the selected
capsule objects. You can use these cylinders to render a representation of your
capsules. See Create polygon cylinders from capsules on page 12.

Muscle > Muscles/Bones > Delete Muscle Jiggle Cache
Opens the Delete Muscle Jiggle Cache window, letting you select a time range
for which you want to delete the jiggle cache for selected objects.

Related topics

■ Delete a muscle Jiggle cache on page 44

Muscle > Muscles/Bones > Fix Invalid Muscle Object
nodes

Fixes connections for selected Muscle Objects.

For example, if you duplicate and move a capsule or Muscle Object manually,
you may notice that its shape does not appear to follow where the transform
is. This occurs because certain required connections may not be recreated
properly from the transform to the Muscle Object shape node.
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Muscle > Muscles/Bones > Setup Master Muscle Control
Opens the Setup Master Muscle Control window, letting you select the muscles
you want to control as a group and define a Master Control object.

Muscle > Simple Muscles

Muscle > Simple Muscles > Muscle Builder
Opens the Muscle Builder window. See Muscle Builder window on page 139.

Muscle > Simple Muscles > Set Muscle Parameters
Opens the Muscle Builder window to the Muscle Parameters tab.

Muscle > Simple Muscles > Apply Muscle Spline Deformer
Applies the MuscleSpline deformer. See Set up a Muscle Spline deformer on
page 35.

Muscle > Simple Muscles > Custom Muscle Shapes
Opens the Muscle Spline Deformer Shape window so you can define custom
muscle shapes.

Related topics

■ Muscle Spline Deformer Shape window on page 158

Muscle > Simple Muscles > Reset Base Pose for Muscle
Spline Deformer

Resets the object as if it was not deformed. This pose becomes the default state
for deformation.
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Muscle > Simple Muscles > Apply Muscle Stretch
Deformer

Applies a Muscle Stretch deformer to the selected object and creates locators
that are rigged as controls.

Muscle > Skin Setup

Muscle > Skin Setup > Apply Muscle System Skin
Deformer

Applies the Muscle deformer to the selected mesh.

See Apply the Muscle deformer on page 61.

Muscle > Skin Setup > Convert Maya Skin to Muscle
System

Use this to convert an object that has a skinCluster applied to have a Muscle
shape node instead. During the conversion, a window appears asking you to
select the axis that points down the length of the selected object.

During the conversion, the following occurs:

■ Joints are converted to capsules (they have a Muscle Object shape node
applied) so they can be connected

■ The skinCluster is replaced with Sticky weights.

■ The Muscle deformer is applied and weighting from the skinCluster is
transferred to the cMuscleSystem node

Related topics

■ Convert Maya skin to Maya Muscle on page 63
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Muscle > Skin Setup > Re-Initialize Setup Data on Muscle
System

Re-initializes the data that Muscle uses for deformation. This is useful, for
example, if you are converting older cMuscleSystem files. See also Re-Initialize
setup data on Maya Muscle on page 67.

Muscle > Skin Setup > Bind Fat on Muscle System
Stores the fat offset distance from the skin mesh to the closest bone/muscle.
This is used throughout the deformation, even if the point is slid by another
muscle.

Muscle > Skin Setup > Auto-Fix Invalid Sticky Bind Points
Automatically corrects any muscles/points that have weighting to muscles
they were not originally bound to. See also Auto-Fix invalid Sticky Bind points
on page 67.

Muscle > Skin Setup > Auto-Fix Deleted/Missing Muscles
Automatically detects and corrects internal indexing, zeroing out weights for
muscles or bones that have been disconnected. See also Auto-Fix
deleted/missing muscles on page 68.

Muscle > Skin Setup > Safe Delete History
Disconnects nodes from the selected object, then deletes the history.

Muscle > Skin Setup > Disconnect all Muscle Objects
Disconnects all Muscle Object nodes from the selected object.

Muscle > Skin Setup > Disconnect all Muscle Directions
Disconnects all Muscle Direction nodes from the selected object.
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Muscle > Skin Setup > Disconnect all Muscle Displaces
Disconnects all Muscle Displace nodes from the selected object.

Muscle > Skin Setup > Disconnect all Smart Collides
Disconnects all Smart Collide nodes from the selected object.

Muscle > Skin Setup > Setup for Relative Sticky
Deformation

Creates and connects a helper Muscle Relative deformer and switches to
Relative Sticky mode. This deformer is connected to the main cMuscleSystem
node. See Relative Sticky deformation on page 52.

If a skinCluster is connected to the selected object, the deformer is placed
before it in the history list.

Muscle > Skin Setup > Set Selected Bones/Muscles as Not
Relative

Turns Relative mode off for the selected object.

Muscle > Skin Setup > Set Selected Bones/Muscles as
Relative

Turns Relative mode on for the selected object.
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Muscle > Muscle Objects

Muscle > Muscle Objects > Connect selected Muscle
Objects

Connects the selected objects to the Muscle deformer. See Connect Muscle
Objects to a Muscle deformer on page 65.

Muscle > Muscle Objects > Disconnect selected Muscle
Objects

Disconnects the selected muscles, bones, or capsules from the Muscle deformer.
Weights are zeroed and the nodes are properly disconnected. See See also
Disconnect selected Muscle Objects on page 68.

Muscle > Muscle Objects > Reset Base Pose for selected
Muscle Objects

Resets the base pose for the selected capsule, bone, or muscle object.

Muscle > Muscle Objects > Delete selected Muscle
Deletes the selected muscle and removes any nodes and connections that are
no longer required. See Delete a muscle on page 21.

Muscle > Muscle Objects > Create Base for selected
Muscle Objects

Duplicates the selected capsule, bone, or muscle object(s) as a base object
connected to the Muscle deformer.
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Muscle > Muscle Objects > Re-Bind Sticky for selected
Muscle Objects

Opens the Sticky Bind Maximum Distance window, letting you select options
for re-binding distance sticky information.

See Sticky Bind Maximum Distance window on page 149.

Muscle > Muscle Objects > Visualize Sticky Bind Distance
for selected Muscle Objects

Displays a visualize sphere for each selected NURBS muscle to show the sticky
weightable area on your mesh. Any point within this sphere will be properly
bound when connected. See Visualize the Sticky Bind distance on page 71.

Muscle > Paint Muscle Weights
Opens the Muscle Paint window, where you can paint or set weights for the
Muscle deformer. See Muscle Paint window on page 149.

Muscle > Weighting

Muscle > Weighting > Apply Default Weights
Opens the Default Weights window, which lets you set initial weighting on
your mesh. See Default Weights window on page 154.

Muscle > Weighting > Load/Save Weights
The Save Weights window allows you to save the various types of weights on
an object to a text file. These weights can then be reloaded onto the same or
different objects by point order or point position. See Load and save weights
on page 88 and Save Weights window on page 155.
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Muscle > Weighting > Mirror Weights
Opens the Mirror Weights window, which lets you reflect weighting values
from one side of your mesh to another. See Mirror weights on page 91.

Muscle > Weighting > Transfer Weights
Opens the Transfer Weights window which allows you to move weights from
one or more bones/muscles/capsules or direction nodes onto another. See
Transfer weights on page 93.

Muscle > Weighting > Prune Weights
Opens the Prune Weights window, which allows you to set weights that are
below a certain specified value to zero. See Prune weights on page 93.

Muscle > Direction

Muscle > Direction > Make Muscle Direction
If nothing is selected, a new direction object is created. If a capsule object or
objects are selected, a direction object is created as a child shape of the capsule
as a radial direction node. See Create a Muscle Direction object on page 74.

Muscle > Direction > Connect selected Muscle Directions
Connect a selected direction node to a selected Muscle deformed object. This
has no effect until Direction Weights are painted or set.

Muscle > Direction > Disconnect selected Muscle
Directions

Disconnects a selected direction node from a selected Muscle deformed object.
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Muscle > Displace

Muscle > Displace > Create Muscle Displace
Creates a new displace node. By default, this node is a planar-style displace
node. See Set up Displacement deformation on page 76.

Muscle > Displace > Connect selected Muscle Displace
nodes

Connects selected Muscle Displace nodes to selected Muscle deformed objects.

Muscle > Displace > Disconnect selected Muscle Displace
nodes

Disconnects selected Muscle Displace nodes from selected Muscle deformed
objects.

Muscle > Displace > Connect NURBS Curve to Muscle
Displace

Connects one or more curves and a Muscle Displace node.

Muscle > Displace > Disconnect NURBS Curve from
Muscle Displace

Disconnects one or more curves and a Muscle Displace node. The curve no
longer affects the deformation even if the node is in Curves mode.

Muscle > Displace > Create Maya Muscle Shader Network
Creates a new Muscle Shader and a new Muscle Displace node. See Create
Maya cMuscleShader network on page 79 and cMuscleDisplace node on page
165.
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Muscle > Displace > Create Mental Ray
mib_cMuscleShader Network

Creates a new mib_cMuscleShader and a new Muscle Displace node. See Create
a mental ray mib_cMuscleShader network on page 81.

Muscle > Smart Collision

Muscle > Smart Collision > Create Muscle Smart Collide
Creates a Smart Collide locator for the selected joints, bones, or transforms.
The Smart Collide is a node with several attributes that relate to deformation.
This node must be connected to a Muscle deformed object before it can be
used.

Related topics

■ Smart Collision on page 95

■ Set up Muscle Smart Collision on page 100

■ cMuscleSmartCollide node on page 173

Muscle > Smart Collision > Connect selected Muscle
Smart Collide nodes

Connects one or more Smart Collide nodes to one or more Muscle deformed
objects.

Related topics

■ Smart Collision on page 95

■ cMuscleSmartCollide node on page 173
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Muscle > Smart Collision > Disconnect selected Muscle
Smart Collide nodes

Disconnects one or more Smart Collide nodes from one or more Muscle
deformed objects.

Related topics

■ Smart Collision on page 95

■ cMuscleSmartCollide node on page 173

Muscle > Self/Multi Collision

Muscle > Self/Multi Collision > Self Collision Grouping
Opens the Self Collision Grouping window which lets you set up regions to
collide with on your mesh.

Related topics

■ Self Collision on page 97

■ Set up Self Collision on page 102

■ Self Collision Grouping window on page 156

Muscle > Self/Multi Collision > Apply Muscle Multi
Collide Deformer

Applies and connects a new Muscle Multi Collide deformer to all selected
objects.

Related topics

■ Set up Muscle Multi Collision on page 103

■ cMuscleMultiCollide node on page 169
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Muscle > Self/Multi Collision > Rig selection for KeepOut
Creates a new group as a child of the selected hierarchy.

Muscle > Self/Multi Collision > Connect Muscles to
KeepOut

Connects the nodes of the selected Muscle KeepOut locator (or parent group)
and one or more selected Muscle Object nodes (such as capsules, bones, or
muscles).

Related topics

■ Connect muscles to KeepOut on page 105

■ cMuscleKeepOut node on page 168

Muscle > Self/Multi Collision > Disconnect Muscles from
KeepOut

Disconnects the nodes of the selected Muscle KeepOut locator (or parent
group) and one or more selected Muscle Object nodes (such as capsules, bones,
or muscles).

Related topics

■ Connect muscles to KeepOut on page 105

■ cMuscleKeepOut node on page 168

Muscle > Caching

Muscle > Caching > Set Location of Cache File
Opens a file browser, letting you set the location where you want cache files
stored.

Muscle > Self/Multi Collision > Rig selection for KeepOut | 135



Muscle > Caching > Create Cache
Opens the Generate Cache window, letting you specify options, then generate
cache files for the selected Muscle deformed object. See Create a cache on page
108.

Muscle > Caching > Delete Node Cache
Deletes a node-based cache. See Delete a node cache on page 108.

NOTE To delete file caches, you must manually delete the files.

Muscle > Caching > Delete Per-Point Skin Jiggle Cache
Deletes the Jiggle information for the specified time range. See Delete a muscle
Jiggle cache on page 44.

Muscle > Selection

Muscle > Selection > Select connected muscleObjects
from selected muscleSystems

Selects all Muscle Objects connected to the selected cMuscleSystem node.

Muscle > Selection > Select connected muscleDirections
from selected muscleSystems

Selects all Direction nodes connected to the selected cMuscleSystem node.

Muscle > Selection > Select connected muscleSystems
from selected muscleObjects

Selects all cMuscleSystem nodes connected to the selected Muscle Object
(capsule, bone).
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Muscle > Selection > Select connected muscleSystems
from selected muscleDirections

Selects all cMuscleSystem nodes connected to the selected Direction node.

Muscle > Bonus Rigging

Muscle > Bonus Rigging > Create Muscle Spline
Opens the Muscle Spline window. See Muscle Spline window on page 157 and
Set up a Muscle Spline deformer on page 35.

Muscle > Bonus Rigging > Surface Attach
Creates an attach point for the selected object. See Set up muscle attach points
on page 17.

Muscle > Bonus Rigging > Fix Surface Attach to allow for
Poly Smooth

If you set up Surface Attach points for a polygon mesh using Muscle > Bonus
Rigging > Surface Attach, then smooth the polygon mesh, the attach point
locator may move. To return the locator to the correct position on the polygon
mesh, select the locator object, then select this menu item.

Muscle > Selection > Select connected muscleSystems from selected muscleDirections | 137



138



Muscle Windows and Tools

Muscle Builder window
This window lets you build a valid NURBS surface attached to two objects with
editable cross sections. When finished, the window also provides an easy way
to adjust parameters for both the simple muscle and any deformers applied.

This window is the original muscle creation tool for cMuscleSystem and is
provided for those who still want to use the older spline deformer.

Build tab

The Build tab lets you choose where and how to generate a basic NURBS surface
muscle. Generally, you want two joints or capsules to attach the muscle to.
These joints should have their alignment with the local Y-axis pointing down
the length.

Attach Obj 1/Attach Obj 2 Once a muscle is built, selecting this lets you select
and then interactively move the attachment locator for either end of the muscle.

8
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<<< (Load selection) The  button loads the selected object into the text
field to specify where the muscle is built and attached to.

At Specifies where the joint is located along the Y-length of the attach object.

Off X Specifies where the muscle attachment is located along the attach
object’s local X-axis.

Off Z Specifies where the muscle attachment is located along the attach
object’s local Z-axis.

nSpans Sets the number of cross sections down the length of the muscle. If
changed, you must click Build/Update again to update the NURBS muscle.

nSegs Sets the number radial sections around the muscle. If changed, you
must click the Build/Update button to update the NURBS muscle.

Width Alters the overall width of the muscle.

Falloff Adjusts the scaling at the ends of the muscle. Lower values make the
ends of the muscle rounder and thicker, larger values make the ends of the
muscle thinner.

Build/Update Creates or updates the muscle.

Delete Cancels the build operation and deletes any muscle geometry, cross
sections, and insertion locators.

Cross Section tab

The Cross Section tab lets you edit the cross section curves of the muscle you
are building, letting you customize the shape of the muscle.

The following are the settings in the Cross Section tab:

Cross Section list Lets you select one or more spans to adjust or edit. When
not in Editing mode, it selects the span. When in Editing mode, it highlights
and allows point manipulation of the cross section span(s).

Edit Cross Section/EDITING Lets you go into Component mode to directly
manipulate points of the cross sections of the muscle.

cMuscleBuilderCamera viewports The tab has built-in camera views that
automatically isolate the cross sections of the muscle as it is being built. You
can manipulate points in these views, or you can adjust the cross sections or
NURBS surface directly in any scene view.
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Finalize tab

The Finalize tab finishes the muscle building process, and converts the NURBS
surface into a shape that is usable with the Muscle skin deformer. Until a
muscle is finalized, it is not yet connectable or usable as a muscle, and does
not have any muscle deformation applied.

The Finalize tab lets you choose which muscle deformer to apply and the
options for it. It also converts the NURBS mesh to have a Muscle Object shape
node so that it can work with the Muscle deformer. Finally, it rigs the muscle
with the deformer, constraining it to the original attach objects or joints, and
places it within a basic muscle rig hierarchy in the Maya scene.

The following are the settings in the Finalize tab:

Deformer Specifies which deformer is used when rigging the muscle. The
cMuscleSplineDeformer is the preferred method, as it is more powerful and
flexible.

Num Controls If you specified the cMuscleSplineDeformer, you can define
how many controls to create for the muscle. You must have at least two, one
for each end. Typically three or more are used to get extra control or jiggle in
the middle of the muscle.

Type Specifies the type of control curve shape for the controls on the muscle.
This is for display purposes only, as changing this setting does not alter the
output of how the muscle deforms or looks.

Create Mirrored Muscle Specifies whether to create a second muscle for
symmetric rigging, mirrored along the specified world axis.

Search/Replace When building a mirrored muscle, sets the naming
convention used for determining where to build the mirrored copy and how
to name it.

Convert to Muscle button When ready to finalize the building of your muscle,
clicking this button deletes any related building curves and nodes, then
converts the NURBS surface to a compatible Maya Muscle object.
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Muscle Parameters tab

The Muscle Parameters tab lets you update or change parameters on selected
muscle objects. This includes cMuscleObject node changes, as well as changes
to any Muscle Spline deformer or Muscle Stretch deformers.

This tab is divided into five main sections, one for Muscle Object changes,
one for basic Stretch setting for both the Muscle Spline deformer and the
Muscle Stretch deformer, one for spline length for the Muscle Spline deformer
only, one for Jiggle presets for both deformers, and finally a basic Copy/Paste
option that lets you copy all of these settings from one object to another.

NOTE You can also alter these values directly in the Channel Box or Attribute
Editor for the related nodes.

The following are the settings in the Muscle Parameters tab:

Generic Settings
Realtime Update If on, changes you make in the Muscle Parameters tab are
automatically applied to any selected muscles. If a muscle is selected, its values
are automatically loaded into the window. If off, you must click the Load and
Apply buttons to apply settings.

Muscle Object Settings
Strength When used with the Muscle skin deformer, this controls the sliding
strength from this object. Generally this value is set to 1.0.

Fat When used with the Muscle skin deformer, this defines an offset from
the surface of the object to the skin mesh that is pushed when sliding is used.
For example when fat is set to zero, the skin does not push out until the surface
of the capsule, bone or muscle touches it. When you increase the fat value, a
gap is created between the capsule, bone or muscle, and the skin.

Reverse Normals When used with the Muscle skin deformer, this changes
the sliding effect to cause points to push inside of the muscle instead of outside.
Typically, this attribute is set to off.

Radius For capsules, this sets the main radius or size of the capsule.

Length For capsules, this sets the length of the capsule. If a capsule
End-Locator is created, it automatically drives this value based on distance.

Capsule Axis For capsules, sets which axis the capsule length uses.

Draw
Specifies what is drawn on screen.
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off Nothing is drawn.

fat The object is drawn at its fat distance, or showing the offset where the
skin sits if sliding is used.

muscle Shows the true radius of the capsule without the fat added, or the true
surface of the polygon object or NURBS muscle.

Shaded
Sets how the drawing occurs in the scene view.

wireframe-only Objects draw as a wireframe even when in Shaded mode.

shaded Objects are drawn in wireframe if the scene view is in wireframe, and
shaded when the scene is in shaded view.

wireframe-and-shaded The object is drawn the same way, except it draws
the wireframe on top of the shaded object in Shaded mode.

Highlight wire Maya highlights selected objects in white or green by default.
When this value is 1, the wireframe for selected objects is highlighted the
same way. When set to 0, no highlighting occurs, so the wireframe color does
not change when the object is selected.

Highlight Shaded The same as above, but this controls whether the shaded
color and object are highlighted when selected.

nSeg Controls how many segments down the length of the capsule are drawn.
Even though more or less segments are drawn, with sliding effects a true
smooth capsule is always used, so this parameter affects drawing only, not
deformation.

nSides Controls how many sides around the diameter of the capsule are
drawn. Even though more or less segments are drawn, with sliding effects a
true smooth capsule is always used, so this parameter affects drawing only,
not deformation.

Load Selected Loads the values for the currently selected muscle. If Realtime
Update is on, this happens automatically when the selection changes.

Apply Muscle Object Values Applies the current values onto all selected
muscles. If Realtime Update is on, this happens automatically when a value
in the Muscle Parameters tab changes.

Stretch Volume Presets
Default/Small/Medium/Large Set all of the values for Squash and Stretch
to a preset value.
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Squash-X/Squash-Z Set the scaling of the overall start/middle/end of the
muscle as its length gets shorter. These settings work for both Muscle Spline
deformer and Muscle Stretch deformed objects. For Muscle Stretch deformed
objects, the average of the X and Z is used, since Muscle Stretch does not have
separate X and Z settings.

Stretch-X/Stretch-Z Set the scaling of the overall start/middle/end of the
muscle as its length increases. These settings work for both Muscle Spline
deformer and Muscle Stretch deformed objects. For Muscle Stretch deformed
objects, the average of the X and Z is used, since Muscle Stretch does not have
separate X and Z settings.

Up Axis Specifies which axis is used for the Up-Vector for the start/end aim.
Also sets which axis is the Up-Vector for Muscle Spline deformer controls. If
you see flipping or twisting on a muscle, changing this value can correct it.

aimStart/aimEnd For muscles built with the Muscle Builder window, this
sets the amount that the start or end of the muscle either aims towards the
opposite end, or stays as if it was parented to the joint.

Load Selected Loads the values of the currently selected muscle. If Realtime
Update is on, this happens automatically when the selection changes.

Apply Stretch Values Applies the current values to all selected muscles. If
Realtime Update is on, this happens automatically when a value in the window
is changed.

Spline Length Settings
Set Current as Default Sets the current length of the muscle as its default
length. Since this is typically set when the Muscle Spline deformer is applied,
this is not usually necessary.

Set Current as Squash Sets the current length of the muscle as its minimum
squash length. When a Muscle Spline deformer object gets to this length, its
Squash Volume setting is fully on. If it squashes more, the scale factor does
not change.

Set Current as Stretch Sets the current length of the muscle as its maximum
stretch length. When a Muscle Spline deformer object gets to this length, its
Stretch Volume setting is fully on. If it stretches more, the scale factor does
not change.

Jiggle Presets
Default/Light/Medium/Heavy/OFF Sets all of the basic Jiggle parameters
to a preset value.
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NOTE If you have a Muscle Spline deformer object with more than three controls,
the Start/Mid/End values are interpolated smoothly along the length of the muscle.

Jiggle Sets the overall strength of the jiggle on each part of the muscle. Bigger
values create more motion.

Cycle The number of frames it takes the muscle to bounce. Smaller values
make the muscle bounce faster, higher values make it bounce slower over
more frames.

Rest The number of frames it takes the muscle to come to rest. Smaller values
make the muscle stop jiggling more quickly, higher values make the muscle
continue to jiggle longer.

Dampen On Squash Controls how the muscle behaves with jiggle as its
length changes. When set to 0, the jiggle values are applied as they are set.
When set to 1, the jiggle amount dampens down and the cycle gets faster as
the muscle gets squashed. This makes the muscle look more like it is applying
pressure since the jiggle stops as the muscle contracts.

Dampen On Stretch Controls how the muscle behaves with jiggle as its
length changes. When set to 0, the jiggle values are applied as they are set.
When set to 1, the jiggle amount dampens down and the cycle gets faster as
the muscle gets stretched. This makes the muscle look more like it is applying
pressure, since the jiggle stops as the muscle expands.

Load Selected Loads the current values for the selected muscle. If Realtime
Update is on, this happens automatically when the selection changes.

Apply Jiggle Values Applies the current values from the window onto all
currently selected muscles. If Realtime Update is on, this happens automatically
when a value in the window is changed.

Copy/Paste Muscle Settings
Copy from Selection Copies all settings from the currently selected muscle
into the clipboard.

Paste to Selected Pastes all values from the clipboard onto the selected
muscles.

Related topics

■ Create simple muscles with the Muscle Builder on page 26
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Muscle Creator window
The Muscle Creator window lets you build deformable and posable,
parametric-style NURBS muscles.

Create tab
Muscle Name Lets you specify the base name of the muscle.

Num. Controls/Cross Sections Lets you specify how many control objects
are created along the length, and how many modeling cross sections exist
along the length to create the shape.

Num. Segments Around Sets the number of points on a cross section circle
that the muscle will have for modeling.

Attach Start Lets you load a selected object as the start object for the muscle.

Attach End Lets you load a selected object as the end object for the muscle.

Create cMuscleObject shape node When on, a cMuscleObject shape node
is created when you click Create Muscle. When off, no cMuscleObject shape
node is created.

Create Muscle Creates a NURBS muscle based on the options specified in the
Create tab.

Mirror Settings
Mirror Axis Lets you specify the axis you want to mirror across.

Search/Replace Let you specify the naming conventions you want to search
for and replace during the mirror operation. For example, when mirroring
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muscles from the left to the right, you could enter “Lf” in the Search field,
and “Rt” in the Replace field.

Mirror Muscle From Selection Mirrors the currently selected muscle.

Copy/Paste Settings
Copy First Selected Muscle, Paste to Other Selected Muscles Copies all
settings from the first selected muscle (such as jiggle control values and
sculpting information), and pastes onto any other selected muscle.

Edit tab

Sculpting settings
Affect Lets you select which axis of the cross sections to edit. The default is
X-Z.

Location Sets which part of the muscle the Sculpt slider affects. Setting the
slider to the left adjusts the start of the muscle more, while setting it to the
right adjusts the end of the muscle more.

Falloff Affects how big the falloff is from the Location. A lower slider value
for Falloff means you affect fewer cross sections, a larger falloff affects more.

Sculpt Changes the size of the muscle.

Grow Settings
Grow to Surface Enter the name of the mesh you want to grow muscle to,

or select the mesh and click the  button to load it.

Main Bone Enter the name of the main joint that runs down the length of

the muscle, or select the joint and click the  button to load it.

Main Bone Tip Loads automatically when you load the Main Bone. You can

also enter this bone manually using the  button.

Angle Controls which points on a cross section are grown. If you set the Angle
to 180, every point on the cross section grows outwards. If set to a value smaller
than 180, only points within that angle range grow.

Fat Sets an offset to keep the grown points inside the surface.

For example if you set Fat to 2, points are grown up to 2 units from inside the
surface. You can think of this as an offset from the muscle to the grown surface.
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% Rest/Sq/St For each cross section point that is grown, these values set the
final amount for where points are placed. By default the Rest points are at
100%, or where the point hits the surface. You can set the Squash and Stretch
percentages so that these curves grow more or less than the Rest curve.

Setting the % Rest/Sq/St values higher than 100% causes the muscle to grow
based on the shape of the selected Grow To Surface mesh, but lets the cross
sections grow past the mesh.

Grow Muscle Grows the muscle outwards from the centerline defined by the
Main Bone and Main Bone Tip bones you have selected.

Grow Sel Points Grows the muscle outwards from selected points.

Reset to Cyl Resets the muscle to a perfect cylinder shape.

Poses settings
Set Current State As buttons
Store the Rest, Squash, Stretch states for the selected muscle.

Reset Width Resets the Attach locator distance to be the new default start/end
width for the muscle.

Cross section settings

Options at the bottom of the Edit tab let you select controls or cross sections
for the selected muscle(s).

Controls Lets you select the cross section controls for each cross section.
These are the animation controls that have Jiggle settings for each part.

CSect Rest Lets you set the Rest or default state cross sections for modeling
the default shape of the muscle.

CSect Squash Lets you select the Squash cross sections, for shaping how the
muscle looks in a Squash state.

CSect Stretch Lets you select the Stretch cross sections, for shaping how the
muscle looks in a Stretch state.

Attach Locs Provides a fast way to select the end point attach locators.

Attach Rest Lets you select the default attach positions for each cross section,
so that you can adjust how the muscle center line is set in default pose.

Attach Squash Selects the Squash attach points so you can adjust the center
line of the muscle for a Squash pose.
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Attach Stretch Selects the Stretch attach points so you can see how the center
line of the muscle looks in a Stretch state.

Related topics

■ Create muscles with the Muscle Creator on page 18

■ Sculpt muscles on page 22

■ Grow a muscle on page 23

■ Set muscle pose states on page 21

Sticky Bind Maximum Distance window
This window sets how far a point can be from the center of the NURBS muscle
and be properly sticky weighted.

Max. Distance from center of muscle Lets you manually enter a maximum
distance.

Auto-Calculate Lets Maya Muscle determine the best overall distance from
the muscle geometry center point to use for sticky binding.

To preview this distance, you can turn on the visualize spheres. See Visualize
Sticky Bind distance on page 52.

Avg. Value Uses the number you specify in the Max. Distance from center of
muscle value field. (When more than one NURBS object is selected, the number
displayed is the average for all of them.)

ALL Points Connects the muscle so it can be weighted to any point on the
mesh. You should only use this option if you can tolerate the resulting memory
hit.

Muscle Paint window
The Muscle Paint window lets you paint or set all weights for the main Muscle
deformer. It operates as a painting tool or as a point-based editor. It provides
much of the same functionality as the usual Maya artisan tools, but also
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provides true color feedback and painting of each weight type that Maya
Muscle allows.

The options and features in the Muscle Paint window are described below:

Geo Sets what geometry is currently being painted.

TIP Right-click the Geo field to load meshes that have the Muscle deformer applied.

Node Displays which Muscle deformer is currently being used on the given
geometry.

TIP Right-click the Node field to enable or disable the entire deformer to
temporarily get faster weight painting feedback.

Brush profiles There are four brush profiles: Gaussian, Soft, Solid and Square.
The first two provide a soft falloff around the edge of the brush. This results
in smoother weighting, but the values on each point may not match exactly
the value you specified. The Solid and Square brushes always provide exact
values, but without the softer edge.

Opacity Sets the opacity of the brush. Mostly useful when doing a Smooth
operation. This can set the strength of doing a Smooth paint. In other modes
this acts as a multiplier of the actual weight. For example, if weight is set to
1.0, but you set opacity to 0.5, the actual weight being painted is 0.5.
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TIP Right-click the Opacity field to select a preset weight value.

Radius Sets the size of the brush.

TIP Right-click the Radius field to bring up several common brush sizes.

Stylus Allows the usual Maya Artisan tablet support. Stylus pressure can affect
brush opacity, radius, or both.

Reflect Mirrors painting onto the opposite side of the mesh while you paint.
The weight is set to the same muscle/bone that is selected, but is painted on
both sides. You can choose which axis to mirror the brush over. This is useful
for painting per-point skin Jiggle or Relax weights, to get a mirrored effect.

Project When checked, the paint brush is circular and projected from the
current camera view. When off, the brush profile is perpendicular to the surface
you are painting on.

Paint When on, you can paint directly on the mesh. If points are selected
when you open the Muscle Paint window, or when the Paint checkbox is
turned on, only those points are paintable and this “masks” the rest of the
mesh. If no points are selected, the entire mesh is paintable.

When off, you can directly select points on your surface and set the weight
by adjusting the slider or clicking Set Weight/Flood. When off, the window
works more like a component editor.

Weights Sets what weight you are painting on the deformer. For weights that
are not tied to a bone/muscle, such as Relax or Jiggle weights, the influence
list is empty.

Normalize Automatically turns on/off and in general does not need to be
changed. Sets whether the painted weights are normalized to a value of 0 to
1 across all muscle/bones. For example, when painting on Bone A, if Bone B
has weight, the value between the two always adds up to one. This is on for
Sticky weights, so that your mesh moves 100% when you move your skeleton.
For most other weights, this is off.

Weight Sets the weight to paint with, or if Paint mode is off, sets the weight
of the currently selected points.

TIP Right-click the Weight field to select a preset weight value.

Live Update When Paint mode is off and you are directly setting component
weights, this specifies if the changes to the slider are updated immediately or
if you have to click Set Weight/Flood. If on, any changes to the weight take
place immediately. If off, then you must click Set Weight/Flood to set the
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weight change. In addition, when on, the Weight value displays the average
weight to the current muscle/bone for all selected points. If off, the weight
does not update when the point selection changes.

Set Weight/Flood When in Paint mode, this floods the current value and
operation across all points or masked points you are painting on. When Paint
mode is off, this sets the weight specified on the selected points.

Replace/Add/Scale/Smooth
When in Paint mode, this sets the paint operation you are doing.

Replace Changes the weights to the value you set when you paint on each
point.

Add Adds the weight value to each point.

Scale Scales the weight down by the given value.

Smooth Smooths the weight across the points.

NOTE When doing a Smooth operation, make sure you have "HOLD" enabled in
the Influence list for most of your bones/muscles to ensure that weights do not
get smoothed onto undesirable influences.

Influence list
Shows all the currently selected Muscle Objects, or other nodes tied into the
deformer when painting weights. For example, when painting Direction, it
shows the Muscle Direction objects that are connected. You can select which
influence you want to paint weights for from this list, and then paint or set
weights. If more than one object is chosen, only the top one is used.

To select multiple objects, Ctrl-click when selecting to toggle them.

Right-click the list to view additional options.

Select All/Select None Lets you easily select all or none of the objects in the
list. This can be used, for example, if you want to enable or disable Lock
Weights for the entire list.

Select Points from Highlighted Nodes Selects the points that have a weight
other than 0 from the selected node. If you are painting a single weight type,
any point that is weighted over zero is selected. This can be useful to obtain
a mask, or to simply debug and see what nodes are affecting what points on
the mesh.

Highlight Nodes from Selected Points Works the opposite way. You can
select one or more points on your mesh, and this option highlights the items
in the influence list that are affecting that point. This provides a way to debug
what is affecting the point.
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NOTE If you are filtering the list, only the nodes listed are highlighted even if
another node is affecting the point. This can be a good way to obtain a filter. For
example, you can select a point, highlight the nodes that are affecting it, then
right-click the Filter field to set the visible list to only show these influences.

Finally, you can Enable or Disable Lock/Hold weights for the influences. When
an influence has HOLD applied, the weights that object has cannot be changed.

For example if you weight Bone A to have a 0.75 weight on a point, "HOLD"
Bone A, and attempt to replace the weight to Bone B with 1.0, Bone B only
gets 0.25, since that is the only weight not currently locked off. When doing
Smooth or Scale operations it is usually a good idea to "HOLD" all influences
except the ones you are currently adjusting to ensure that extra weight does
not go to other objects.

TIP Resize the Muscle Paint window to get a longer list of objects.

Filter field Lets you limit the items shown in the Influence list by
name/wildcard. You can filter one or more wildcards or explicit names. For
example, setting the field to “*Lf*” only shows objects that have “Lf”
somewhere in the name. Setting it to “Head* Neck*” shows only objects that
start with Head or Neck.

If you right-click the field, you can reset the list to all by entering “*”. In
addition, you can filter to selected nodes. If you have highlighted one or more
items in the list, you can filter to show only those explicit nodes.

Draw When on, the current weight values on the points are drawn on the
mesh. For polygon mesh objects, this displays on the surface of the mesh. For
all other objects, this displays individual point colors on each vertex. When
off, the color display is turned off.

Gray option Overrides the current colors of the weight painting and sets the
weights to draw from white to black as the value goes from 1 to 0.

Point Size slider Sets the size of the points displayed when the Draw option
is on for NURBS or subdivision surfaces. This has no effect when painting on
polygon meshes.

Color A/B/C sliders Let you customize the colors used when painting. The
colors range from A to B to C as the weight goes from 1.0 to 0.5 to near 0.0.
Any color that is exactly at 0 is black. It is recommended that you set the C
color to something other than black so that you can detect small weight values.

Close button Closes the Muscle Paint window and turns off color and Paint
mode.
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NOTE The Muscle Paint window creates a Muscle Display shape on the mesh.
You can manually delete this node when not painting. Restarting the Muscle Paint
window automatically recreates this node if needed. It can also create a
polyColorPerVertex node which you can also remove.

Related topics

■ Paint Muscle weights on page 86

Default Weights window
The following options are available in the Default Weights window, depending
on which Weight type is selected.

Weight Sets the type of weight to be applied. Weights that have influences,
such as Sticky, Sliding, Direction, or Smart-collision have only Smooth options
available, as their weighting is determined by the node that is connected.
Single weight types have other options.

Smooth Sets how many Smooth operations the Default Weights window
applies after it determines initial weighting for the mesh.

Falloff When setting Sliding weights, this sets the distance at which the
weight from the muscle or bone will falloff over so that the weight drops off.

By Direction When setting a single weight type, this allows you to set the
weight based on the direction of the normal of the point. For example, you
can use this to weight the underside of a creature for jiggle so that the bottom
jiggles more than the top.

Direction For setting by direction, this sets the direction to compare to. The
default is 0, -1, 0 or negative Y, so points are weighted more towards the
bottom of a mesh.

Angle For direction-based weighting, this sets the spread angle at which the
point is allowed to be weighted. For example, the default 45 means any point
whose normal is within 45 degrees of the set direction gets a weight.

By Curvature Lets you set weights based on the curvature of the model. You
can set weights to be more or less depending on if the model is more smooth,
or has more angles to it.

Curve Sets the angle at which points have to be curved from their neighbors
to weight. For example, a setting of 5 means that any point must be 5 degrees
or more apart for it to be weighted.
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Reverse Curvature Sets the curvature weighting such that the final values
are reversed. In this way, a value of 5 means any point that is 5 degrees apart
or more is weighted smoother.

Prune Weights Lets you specify how small weights can be by decimal place.
This helps remove or prune small weights from the default weighting.

Apply Default Weights Starts the weighting process.

Related topics

■ Load and save weights on page 88

Save Weights window
The Save Weights window includes options for saving and loading Muscle
weights. The following settings and options are found in the Save Weights
window:

Node Specifies the node to load or save weights for.

Save settings
Filename Specifies the file to be used when saving weights. This is a simple
ASCII text file for easy custom manipulation outside of Maya.

Weights Lets you select the type of weight to save.

Save Weights Saves weights for all points of the deformed Muscle object
specified in the Node field.

Load settings

Filename Specifies the file to be used when loading weights. Click the 
button to browse and select a file containing saved weights.

Weights Sets the type of weight to load. You can save from one type and
load onto another if the weight types are compatible.

Normalize Turns on/off automatically, but you can override the value to
determine whether loaded weights are normalized to 1.0 for each point. This
setting has no effect on simple per-point weights.

Load By Specifies if loading occurs by point order/index or by point position.
Point position loads are slower but allow for mirroring of weights, as well as
reloading onto topology that may have changed.
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Point Position Match Tolerance A value of 0 or higher sets the distance at
which point position loading must match the distance from the original
surface. A value of -1 means disable/ignore tolerance.

TIP Right-click the Tolerance field to select a preset Tolerance value.

Prune weights to When checked, weights that are loaded are pruned to the
specified number of decimal places. The default is 3, so a weight of 0.12345
becomes 0.123.

TIP Right-click the Prune decimal places field to select a preset number of decimal
places.

Mirror Pos. This is used during point position loading to mirror the loaded
points. This is typically used in conjunction with the Search/Replace fields.

Search/Replace Used with the Mirror Position option. After a matching point
is found, this does a Search/Replace on each original influence so that loaded
weights can be applied onto a mirrored side. For example, if a Search/Replace
is set to _L and _R and a point is found to be weighted to a muscle named
MuscleBicep_L, when the weight is loaded it is instead applied to
MuscleBicep_R.

Select Influences from File When a weight file is saved, it also contains
information on what original bones/muscles/capsules were used. Clicking this
button re-selects the original influences based on the data in the file. This
option works in conjunction with Search/Replace, so it can be used not only
for reselecting all influences, but for selecting mirrored influences.

Load Weights Loads the weights from the file onto the mesh that is deformed
from the specified Muscle deformer node. This works for selected points. If
no points are selected, all points on the object are automatically selected and
loaded. When loading weights for mirroring it is important to only select the
points on the side of the object you want to load so that the original side
remains intact.

Self Collision Grouping window
The Self Collision Grouping window lets you set up regions to collide with
on your mesh. Each pair of points attempt to collide with each other when
Self Collision is enabled. The window automatically refreshes when a different
Muscle deformed object is selected.

The Self Collision Grouping window includes the following options:
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cMuscleSystem Shows which Muscle deformer is related to the object/points
you are selecting.

Name When creating or editing/renaming a group, specify a name here for
what it represents. Spaces are allowed.

PtsA/PtsB Lets you load/specify the point indexes of each half of the grouping.

The  button loads selected points into the window. The PtsA/PtsB button
lets you re-select the points you originally chose to view/edit your grouping.

Self Collision Groups Displays each grouping you have created, showing its
name and the number of points in the A and B sides of the group.

Edit Lets you replace the data for the currently selected item in the list, with
the data in the Name/PtsA/PtsB section of the window.

Delete Deletes a selected grouping from the list.

Muscle Spline window
The following describes the basic options in the Muscle Spline window:

Name Specifies a name to use for the spline and all related objects. This should
be unique to avoid naming conflicts.

Num Insertion Controls & Type Sets how many control objects/points are
created for the spline. Each point has a tangent length and jiggle controls.
You can also select the type of shape or node to be used as a control object.

Num Driven & Type Sets how many objects are ‘stuck’ on the spline curve.
These objects are driven by the curve and move/rotate as the curve moves.
Typically, joints are used since you can then use them to do skinning, but
you can select other objects as well.

Constrain Mid Controls If on, all of the middle control objects are
automatically constrained to be positioned and aimed the right way between
the first and last created controls. You still have manual control over each of
them. If off, the controls are not constrained.

Create Muscle Spline Rig When ready, click this button to create a spline
setup with the options you have selected.

Related topics

■ Create a Muscle Spline deformer on page 34
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Muscle Spline Deformer window
The following are the basic options in the Muscle Spline Deformer window:

Name Enter a unique name not used by any Muscle Spline or Muscle Spline
deformers. The rig nodes created use this name.

Num Controls Sets how many controls are used by the spline and deformer.
You must have at least two, one for the start and one for the end of the spline.

Type Lets you select the shape of the spline controls.

Make Muscle Object If checked, the object is also converted to have a Muscle
Object shape node so that it can be connected to the Muscle skin deformer.

Setup Muscle Spline Deformer Applies a deformer to the selected object
with the provided settings.

Related topics

■ Create a Muscle Spline deformer on page 34

Muscle Spline Deformer Shape window
The following are the options in the Muscle Spline Deformer Shape window:

Geo Specifies what geometry is modified.

<<< (Load Selection) The  button loads the selected geometry into the
window for editing.

Def Shows the Muscle Spline deformer that is going to do the shaping.

Prep for Sculpt Prepares the mesh for sculpting and creates a temporary piece
of geometry that you can modify directly to make the shape correction.

Color Swatch Sets the color for the temporary piece of sculpt geometry.

Create New After you sculpt a change on the temporary geometry, this creates
a new target shape for the Current State length.

Edit After you sculpt a change on the temporary geometry, select the shape
you want to modify from the list on the right and click this button. The
original shape is replaced by the one you just sculpted.

Rename Select a shape from the list and click to rename the target.
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Delete Select a shape from the list on the right and click to delete that target
shape.

Blend Sets how the shape or shapes you created blend on and off. Smaller
values cause the shapes to trigger only when the length of the muscle is very
close to the original sculpt length. Larger values cause the shapes to blend
even with the current muscle state/length is farther away from the sculpt
length.

Current State Shows the current state the muscle is in. A value of -1 means
the muscle is fully squashed, +1 means fully stretched, and 0 means the muscle
is in its default length.

Related topics

■ Set up custom muscle shapes with the Muscle Spline deformer on page 39

Muscle Spline Deformer Shape window | 159



160



Muscle Nodes

Muscle Nodes
This guide describes all of the nodes associated with Maya Muscle.

cMuscleCreator node
This is a dependency node that calculates the necessary NURBS surface to create
a new muscle. Effectively, this node outputs the current shape of the muscle
based on input curves and other attributes.

Below are descriptions of the attributes in the cMuscleCreator node.

Cross Sections Sets the number of cross sections on the final NURBS geometry
muscle. Note this is different than the actual cross section curves/controls. Cross
section curves/controls can only be set before creation in the Muscle Creator
window.

Sides Sets the number of points around the NURBS muscle.

Tolerance Sets the precision the cMuscleCreator node uses internally for dealing
with things like muscle length. Defaults to 24. Higher values are more precise.
You do not have to change this value.

Up Axis Since the cMuscleCreator node automatically drives the attach points,
it needs to know how to handle twisting/rotation. This attribute determines
which cross axis is used. If you observe problems with flipping, you can change
this axis to adjust the orientation of the controls.

Flat Cross Sections
Sets whether the cross section curve points drive the surface based only on their
X-Z locations, or their 3D positions.

9
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on The cross section curves, even if modeled in 3D, only affect the muscle in
a flat way.

off Moving a cross section point along the length of the muscle also sculpts
the muscle points along its length.

Show Controls Turns the visibility of the related controls for the muscle on
and off.

Show Rest Movers Turns the visibility of the related rest shapes for the muscle
on and off.

Show Squash Movers Turns the visibility of the related squash shapes for the
muscle on and off.

Show Stretch Movers Turns the visibility of the related stretch shapes for the
muscle on and off.

Gravity Strength Each “Attach Rest” control for the muscle has a gravity
attribute to set how much each cross section is affected by gravity. This
attribute is a multiplier to make the muscle move due to gravity.

Gravity Jiggle Causes the muscle to move more in the direction of gravity
when jiggle occurs.

Gravity Cycle Affects the cycle rate of the muscle as it moves towards gravity
to make it appear slower at the top.

GravityX/Y/Z Set the direction of gravity. Defaults to negative Y.

Based On
Sets how the muscle determines what state it is in (rest, squash or stretch).

length Only the length of the muscle (based on the attach controls) drives
the state of the muscle.

pose Only the pose data set (if you have stored poses using the Rest, Squash,
Stretch buttons) are used.

pose or length Length is used until the pose buttons have been stored, then
the pose data is used instead. This is the default state.

Interp Mode
Sets how the muscle state interpolates between the three states.

linear Gives linear interpolation. This is the default.

smooth-step Gives a smoother interpolation of the states.
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animCurve Lets you adjust an Sq and St curve using Maya’s Graph Editor to
set the rate at which the muscle state changes from rest to squash or rest to
stretch.

Pose Uses If you are using the pose state of the muscle, (you have used the
pose buttons rather than length of the curve), this determines how the state
is read. The pose can be determined by the angle of the child bone to the
parent, the relative position, or both.

Pose Read Axis Sets which axis of the bones to use for reading the pose.

Pose Use Twist Sets whether or not twisting away from the pose state returns
the muscle to the default state. Defaults to off.

Def Width Start/Def Width End The default distances for the start/end
locators of the muscle. These can be automatically set using the Reset Width
button in the Pose section of the window. This information is used when
autoWiden is used.

Len Default/Len Squash/Len Stretch Represent the distance of the implied
muscle curve based on the positions of the muscle attach controls. When
using “length” to determine the state of the muscle, these values inform the
muscle which state it is in.

Auto Rotate Sets the muscle controls and attach curves so that the controls
can automatically rotate as needed.

Auto Widen Moving the original attach points at either end of the muscle
make the last span of the muscle stretch. If you want to have the entire muscle
widen or narrow based on this distance, you can turn autoWiden up. This
causes the entire muscle to scale out if the start/end attach points move.

Dampen On Squash/Dampen On Stretch Cause muscle jiggle and cycle to
dampen as the muscle goes into a squash or stretch state to help simulate
tension in the muscle.

Manual Sq St An animation control that lets you manually scale the muscle
into its squash or stretch cross sections regardless of the pose it is in. Negative
values cause it to stretch, positive values cause it to squash.

Linear Auto Squash/Linear Auto Stretch Even if you have set or adjusted
the attach positions for the muscle, you can override your settings with these
attributes. This causes the muscle cross sections to go into a linear position
from start to end as the state of the muscle hits the squash or stretch pose.

User Scale This attribute can be connected into the main scaling node of your
rig to support a rig scale on the muscles.
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Reset Frame Sets the frame at which jiggle starts. Jiggle is disabled at any
frame on or before this value. You can animate this with a stepped key so that
if you are animating multiple shots in one Maya file and the character moves
suddenly, you do not get unwanted jiggle.

Related topics

■ Create muscles with the Muscle Creator on page 18

cMuscleDirection node
This is a locator node that implements direction adjustment for Sliding and
connects to the Muscle deformer node.

The following are the attributes of the cMuscleDirection node:

Strength Controls the strength of the effect cMuscleDirection has on the
points. This is an effect on top of the existing painted weights. Values higher
than 1 only alter the effect if two or more cMuscleDirection nodes are
competing over the same points.

Falloff Inner/Falloff Outer These control the display of the node. They have
no effect on the output surface.

Type
Sets the type of push the direction gives.

vector Provides a basic slide push along one direction, indicated by the arrow
on the cMuscleDirection node.

radial Changes the node so the push is outward from a center line, more like
a capsule or several rings.

Length For radial mode, controls the length the cMuscleDirection displays
as.

Dir Axis Sets which axis the direction node uses. For Vector mode, this axis
is the one used to control the direction of the slide. For Radial mode, this is
the primary center line axis from which the direction radially pushes out.

Lock Dir Wt For paint weights, this sets the weights for this node to be locked.
This setting is not usually edited by hand.

Draw Controls whether the locator draws in the scene view.

Highlight Controls whether or not the locator shows its true colors or the
Maya default colors when selected.
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N Sides Sets the level of detail of the drawing. This has no effect on the output
result of the skin. Higher values cause the wireframe to look smoother but
draw slower.

In Color/Out Color Set the wireframe color of the inner and outer drawing
parts of the cMuscleDirection locator. (This can be accessed in the Attribute
Editor when the cMuscleDirection node is selected.)

Related topics

■ Using Direction nodes on page 55

cMuscleDisplace node
This is a locator node that shows the mapping information and location
needed to apply the cMuscleDisplay geometric or shader-based deformation
effects.

The following are the various attributes for the cMuscleDisplace node:

Mode
Sets the projection type of the cMuscleDisplace node.

planar Sets the displacement to be based on a flat plane. As this plane
approaches the surface of the mesh, points move outwards.

cylindrical Similar, but uses a cylindrical projection. This mode can be more
useful when parenting the node to a bone/joint/capsule. In that way, as the
bone or joint moves to or from the surface, the displacement effect can occur.

curves Lets you connect any number of NURBS curves. This replaces the
effect of the image map, and instead uses the radius and falloff to control the
effect as the curves approach the surface. When in curves mode, the locator
displaces as a large letter “C”, and its location/position has no effect.
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Length In Planar mode, controls the size of the plane. (You can non-uniformly
scale the displace node to get non-square shapes.) In Cylindrical mode, controls
the length of the cylinder. In Curves mode, Length has no effect other than
to adjust the displace size of the cMuscleDisplace node.

Size Radius In Planar mode, this has no effect. In Cylindrical mode, sets the
radius of the cylinder. In Curves mode, sets the implied radius of the curves
that are connected into the displace node.

Amplitude Controls the height or strength that the displace node has on the
points.

Falloff For Planar and Cylindrical modes this sets the falloff distance the plane
or cylinder has. As the displace node approaches the surface, the displace effect
occurs. As it moves away, the effect falls off. This value sets how far it has to
move before the effect diminishes to nothing. For Curves mode, this sets the
distance from the curve that the displacement falls off from.

Push Mode
Sets the way the displacement occurs. This only affects deformation-based
displacement, not render/shader displacement.

normal Displacement occurs as the point is moved along its normal (or
affected by cMuscleDirection nodes/Direction weights for deformation). This
is the default.

gizmo The direction of the push is based on the actual cMuscleDisplace node
itself. This can be seen by rotating a planar displace, or by using a cylindrical
displacement. In these cases the points move along the direction of the
cMuscleDisplace locator, rather than the point normal.

Combine Mode The order in which you connect cMuscleDisplace nodes
matters, as each displace effect is calculated one after the other. Since each
displace can affect the mesh, the deformer needs to determine how to combine

166 | Chapter 9   Muscle Nodes



the two nodes. The default “max” mode takes whichever displacement node
and amplitude would push the point the most. This more closely matches
how sliding effects work, as whichever node would have the largest effect is
how the points end up moving. The “add” mode combines both displacements,
always adding the effect of the displace node onto the existing displacement.

In the image below, two displace nodes exist with a soft white square for the
image map causing a box to push out. In “max” mode, you can see that
whichever is higher causes the points to move out. In “add” mode, the effect
of the displace is doubled where the boxes overlap.

Draw This is a display option only. Shows or hides the locator node.

Highlight Maya highlights selected objects in white or green by default. When
this value is 1, the wireframe for selected objects is highlighted the same way.
When set to 0, no highlighting occurs, so the wireframe color does not change
when the object is selected.

Color Wireframe Sets the color the cMuscleDisplace node displays in the
scene view. (This attribute displays in the Attribute Editor only.)

Color Wireframe 2 Sets the color the cMuscleDisplace node displays when
selected. (This attribute displays in the Attribute Editor only.)

N Sides For cylindrical modes, sets the visible number of spans/detail on the
cylinder. It has no effect on the actual displacement computation.

NOTE The cMuscleSystem node also includes the enableDisplace and
collisionDisplace attributes that affect displacement deformations. See Displace
attributes on page 190.

Related topics

■ Set up Displacement deformation on page 76
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■ Connect a NURBS Curve to a cMuscleDisplace node on page 79

cMuscleDisplay node
This is a locator node that implements color display and calculation of Muscle
deformer weights. It is automatically removed from a mesh when the Muscle
Paint window is closed.

Related topics

■ Paint Muscle weights on page 86

cMuscleKeepOut node
This is a locator node that creates a transform-based sliding or collision effect
against cMuscleObject nodes. This node calculates the needed offset or position
of a child object so that the object appears to collide against Muscle Object
bones, capsules, or muscles.

For example, you can parent a special flatten joint to an arm and have it collide
with a Muscle Object in the chest when the arm lowers so that the arm always
stays outside the chest.

The cMuscleKeepOut node has the following attributes:

Enable Sets whether the Keep Out node is active. When set to off, the
computation is disabled.

In DirectionX/Y/Z Sets the local direction of the node that the sliding
attempts to use. The actual slide direction is reversed, so you may want to set
a –Y in order to have the Y-axis appear to do the sliding.

Quality
This is the same as the sliding quality on the Muscle deformer. For NURBS
muscle objects:

Full Creates a proper true slide.

Medium Uses an approximation of the surface.

Low Uses a capsule to approximate the shape.

Draw Sets whether the KeepOut node is drawn.
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Related topics

■ Transform collisions with KeepOut nodes on page 99

cMuscleMultiCollide node
This is a deformer node that provides a standalone deformer, more simple
than the main Muscle deformer, to provide both multi-object or self-collision
effects.

The following are the attributes for adjusting the multi collision deformer:

Envelope The standard Maya deformer envelope attribute that enables or
disables the entire deformer. When set to 0, multi-object collision is disabled.

Tolerance Sets the internal tolerance used by the computations. This is
multiplied by other values internally, and does not need to be adjusted.

Falloff Sets the distance at which points are volumized from each collision
area.

Volumize Sets the amount of bulging or volumization that occurs for the
collision areas.

Blur Iterations When a collision occurs, points are moved/flattened to resolve
the collision. This effect can be blurred out to affect other points surrounding
the collision to result in a smoother/softer look. This sets how many iterations
occur for this calculation.

Relax Iterations After collision, points within the falloff region can be relaxed
with the Relax algorithm. This sets how many iterations are used for it.

Relax Strength After self collision, points within the falloff region can be
relaxed with the Relax algorithm. This sets how strong the relax effect is.

Smooth Iterations After collision, points within the falloff region can be
smoothed with the usual Smooth algorithm. This sets how many iterations
are used.

Smooth Strength After collision, points within the falloff region can be
smoothed with the Smooth algorithm. This sets the strength of the smooth
effect.

Smooth Hold For collision smoothing, this sets the amount of smooth hold
during the smooth operation. At higher values, points are not allowed to
smooth along their normal and retain volume more.
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Related topics

■ Multi-Object Collision on page 99

■ Self Collision on page 97

cMuscleObject node
This is a locator node that implements the main muscle/bone/capsule object
node. Any NURBS surface, polygon mesh, or transform/joint that connects
to a Muscle deformer node must have this applied to it as a shape node with
proper connections.

The following are descriptions of the attributes in the cMuscleObject node.

Sticky Strength When used with the Muscle deformer, this controls the Sticky
strength from this object. Generally set to 1.0, this is a multiplier with Sticky
weights that have been painted for this node. Along with the Sliding Strength
attribute, this value lets you tweak the amount of Sticky versus Sliding after
painting weights.

Sliding Strength Sets the amount of Sliding effect the object has. Typically
set to 1.0. Along with the Sticky Strength attribute, this value lets you tweak
the amount of Sticky versus Sliding after painting weights.

Fat When used with the Muscle skin deformer, this defines an offset between
the surface of the capsule, bone, or muscle object and the skin that is pushed
out when sliding is used.

For example, when Fat is set to 0, the skin does not push out until the surface
of the capsule, bone or muscle touches it. When the fat value increases, a gap
is created between the capsule, bone or muscle, and the skin.

Reverse Normals When used with the Muscle skin deformer, this changes
the sliding effect to cause points to push inside of the muscle instead of outside.
Typically this attribute is set to off. You can turn this on to create muscles or
bones that appear to collide with the mesh instead of sliding underneath.

Relative Sets whether the effect of the node is Relative for cases where the
cMuscleSystem node has Relative Sticky set to relative (on). When on (the
default), the Sticky effect of the muscle is considered to be more local so that
there is no double transformation.

NOTE This only has an effect when the cMuscleSystem Relative Sticky attribute
is set to relative (on).
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Radius For capsules, this sets the main radius or size of the capsule.

Length For capsules, this sets the length of the capsule. If a capsule End-Locator
is created, it automatically drives this value based on distance.

Capsule Axis For capsules, sets which axis is the length axis of the capsule.

Affect Sticky Used by the Default Weights tool. If a node has Affect Sticky
set to on, default weights are set for this node for Sticky weights.

Affect Sliding Used by the Default Weights tool. If a node has Affect Sliding
set to on, default weights are set for this node for sliding weights.

User Scale X/Y/Z For NURBS muscles, used to modify the effect of Sticky
weighting so that scaling of the rig works properly. Generally, the top level
rig control used to scale your rig can be connected to these attributes.

Lock Sticky Wt Not usually edited manually, this is used with painting to
allow the Sticky weights to be locked objects.

Lock Sliding Wt Not usually edited manually, this is used with painting to
allow the Sliding weights to be locked for this object.

Draw
Sets what is drawn on screen.

off Nothing is drawn.

fat The object is drawn at its fat distance, or showing the offset where the
skin sits if sliding.

muscle It shows the true radius of the capsule without the fat added, or the
true surface of the polygon object or NURBS muscle.

Shaded
Sets how the drawing occurs in the scene view.

wireframe-only Objects draw as a wireframe, even when in Shaded mode.

shaded Objects are drawn in wireframe if the scene view is in wireframe, and
shaded when the scene is in shaded view.

wireframe-and-shaded The object is drawn the same way, except it draws
the wireframe on top of the shaded object in Shaded mode.

Highlight Maya highlights selected objects in white or green by default. When
this value is 1, the wireframe for selected objects is highlighted the same way.
When set to 0, no highlighting occurs, so the wireframe color does not change
when the object is selected.
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Highlight Shaded The same as above, but this controls whether the shaded
color and object are highlighted when selected.

N Seg Controls how many segments down the length of the capsule are drawn.
Even though more or less segments are drawn, with sliding effects a true
smooth capsule is always used, so this parameter affects drawing only, not
deformation.

N Sides Controls how many sides around the diameter of the capsule are
drawn. Even though more or less segments are drawn, with sliding effects a
true smooth capsule is always used, so this parameter affects drawing only,
not deformation.

Wire Color For capsules, sets the color the capsule displays when in Wireframe
shading mode. This attribute is available in the Attribute Editor only.

Shade Color For capsules, sets the color the capsule displays when in Shaded
mode. This attribute is available in the Attribute Editor only.

Related topics

■ Connect Muscle Objects to a Muscle deformer on page 65

cMuscleRelative node
This is a helper deformer node that connects with the main cMuscleSystem
deformer node to provide Relative Sticky skinning ability. It should be placed
below a skinCluster or other typical Maya deformers, but after any blendshapes
or deformers that affect more of the base state of the mesh.

The only attribute for this node is Envelope, which must be left on for Relative
mode to function properly.

Related topics

■ Set up Relative Sticky deformation on page 72

■ Apply the Muscle deformer on page 61

■ cMuscleSystem node on page 187
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cMuscleShader node
This is a Maya Shader node that calculates the needed displacement shading
for the cMuscleDisplace functionality in the Maya renderer.

Related topics

■ cMuscleDisplace node on page 165

cMuscleSmartCollide node
This is a locator node that draws a plane displaying the guide for the
cMuscleSmartCollide deformation feature of the main deformer.

Basic attributes

The following are the basic attributes of the cMuscleSmartCollide node:

Enable Lets you enable or disable a specific cMuscleSmartCollide node while
leaving others functional.

Collide Mode
For collision, sets the type of collision that occurs.

plane This mode is faster, but simply compresses points along a plane.

mesh This mode is a true mesh-mesh intersection that more accurately moves
points in the collision, but is slower.

Axis Sets the axis along which the cMuscleSmartCollide node is constrained.
This is typically set to the Y-axis, assuming your joints have the Y-axis down
their length. The node attempts to detect the proper value, but you can adjust
this if you require a different result.

Angle Min/Max Most weights can be painted entirely around the mesh, but
are only driven in the direction at which the joints are coming together. These
values set the falloff from this direction of the weights. All points within the
minimum angle move fully, falling off to the outer angle. For the smoothest
interpolation you can set a 0 to 180 range.

Bias The cMuscleSmartCollide node is automatically constrained to the two
transforms and connected using a cMuscleSmartConstraint node. By default,
the rotation of the node is the average of the two joints or transforms. This
attribute lets you bias this value towards one joint or the other. Negative values
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make it orient more towards the A node, and positive values towards the B
node.

Bias Adjust In some cases, you want the node to be split evenly between the
A and B joints/transforms, but then as the joints rotate and trigger, you want
to adjust the bias. This attribute sets the change in bias to occur as the node
is triggered.

User Scale This attribute can be connected to a master scaling node in your
rig in order to allow for scalable rigs.

Manual Scale Since the movement and other attributes are distance-based,
this is another optional scale setting that is a multiplier on these values. For
example, rather than setting bulkA to 10, bulkAngular to 10 and so on, you
can leave these values at 1 and set Manual Scale to 10. This value gets initialized
when the node is created based on the distance of the joints originally chosen.

Smooth-Pre attributes

The Smooth weights and related attributes apply a basic Muscle smoothing
effect. Like other weights, these are affected by the angle falloff. Pre-smoothing
is applied before the other Smart Collision deformation is applied.

Smooth Iterations Pre The node can use Smart Smooth weights to compute
a pre-smoothing operation on the mesh before the other parts of the deformer
occur. This sets how many iterations are done. Values around 0 to 24 are
recommended.

Smooth Strength Pre For Pre-smoothing, sets how strong the effect is.

Smooth Hold Pre For Pre-smoothing, this sets smooth holding, which causes
the points to smooth more or less along their normal. When set to 1, the point
is not allowed to smooth along its normal, so it maintains volume but does
not smooth as much.

Movement attributes
Bulk A/B These weights and attributes set how much the mesh moves
outwards radially from the A or B joint. The direction is assumed from the
joint location, and occurs in the direction that the joints are moving together.
This can be useful to imply muscles or volume in the mesh.

Bulk Angular A/B Angular bulk weights are similar to bulk, but occur in the
average direction of the two joints, and thus are the same direction for both
the A and B sides. This can be used to fix weights at the center of the joints,
for things like a rubber-hose effect caused by skinning.
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Bulk Widen A/B Widen weights cause the mesh to scale outwards in a
direction perpendicular to the bending of the joints. Like other weights, these
are scaled by the Angle Min and Angle Max settings.

Slide A/B Smart Slide weights cause the painted points to translate away from
the center down the length of the joints. The “A” region points move backward
and the “B” region points move forward. This can help increase the gap (if
desired) at the connection. It can also simulate real skin being pulled along
by a muscle. For example, when your wrist bends down, the skin on the bottom
moves towards the elbow. You can use sliding weights with positive or negative
values on the cMuscleSmartCollide node to get these effects.

Slide Rear A/B Slide Rear attributes use the same slide weights as the slide
attributes, but cause the points on the “back” side of the mesh to move in the
opposite direction. Again, this can be used to simulate muscle movement and
help skinning. “Slide” moves points on the inside of the falloff angle, slideRear
moves points on the outside.
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Slide Angular A/B These weights cause the points to move away from the
plane in the direction of the plane normal. This can be used to help compress
or expand the area right at the joint location.

Slide Angular Rear A/B These weights move points outwards along the
backwards average direction of the joint angles. This is similar to a reverse
bulkAngular and can be used to help simulate elbow protrusions or knuckles.

Wrinkle A/B Smart Wrinkle weights move points outwards from the joints,
and along their normals depending on the wrinkleSpread attribute. This is a
separate and different weight then the Wrinkle weights. Regular Wrinkle
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weights are a part of the Relax deformation and are applied when points are
compressed and Relax mode is used. Smart Wrinkle is a part of the Smart
Collision node and deformation, and is applied as the Smart Collide node is
triggered.

Wrinkle Spread Sets whether the wrinkle direction occurs more radially or
more from the normal. When set to 0, the wrinkle is more flat around the
plane radially. When set to 1, it uses the normal of the point.

Collision attributes
Flatten A/B Along with Smart Flatten weight, lets you control what parts of
the mesh collide and flatten, and the amount of flattening for the A or B
points due to self collision. Typically set to 1.0 for the entire area you want
the cMuscleSmartCollide node to affect.

Rigid A/B Sets how rigid the A or B points are. Points that are more rigid move
less during self collision.

This lets you set one side to be more or less rigid than the other when colliding
happens. For example, if one area is supposed to be harder or less likely to be
moved, you can increase the Rigid A or Rigid B values to make that side less
moveable during flattening.

Collision Blur Iterations After a collision has been computed, the motion of
the collided points can be blurred out to also affect other points. This can
help soften the effect of the collision in surrounding areas.

Volumize A/B When a collision occurs, surrounding points can be volumized
or bulged out to preserve volume. Along with Smart Volumize weights, these
attributes set the amount of that bulge.

Volumize Offset The direction and amount of volumization is based on an
implied center point for the collision. This is based at the joint pivot for the
B joint, but in reality is typically a certain amount down the length of the
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joints. This value lets you set the motion/offset of the center of collision as
the node is triggered, to slide this internal location and get better volumization
effects.

Volumize Puff Sets whether points are volumized from the collision in a
radial fashion or if they expand outwards based on their normal. When set
to 0, points are volumized radially so they do not re-collide, when set to 1,
points are volumized along their normals.

Volumize Dist Sets the distance a point can be from the collision/plane and
still be volumized. Along with the paintable Smart Volumize weights, this
attribute controls the amount of points bulging out due to collision, letting
you create a smooth ramp on the points being volumized.

Volumize Falloff In addition to the distance from plane, this falloff value
specifies a spherical 3D falloff from the implied center of collision. Points
volumize with less effect falling off at this distance.

Smooth Post attributes

Post-smoothing is applied after the deformation and collision is calculated.
These can be used to help smooth out areas for better results before or after
the deformation.

Smooth Iterations Post The node can use Smart Smooth weights to compute
a post-smoothing operation on the mesh after the other parts of the deformer
occur. This sets how many iterations are used. Values from 0 to 24 are
recommended.

Smooth Strength Post For Post-smoothing, sets how strong the effect is.
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Smooth Hold Post For Post-smoothing, sets smooth holding, which causes
the points to smooth more or less along their normal. When set to 1, the point
is not allowed to smooth along its normal, which helps maintain volume, but
does not smooth as much.

Lock Smart Wt Used by the Muscle Paint tool to mark whether a node has
“HOLD” enabled for weighting. Nodes that have HOLD enabled in the
Influence list are locked and cannot have their weights adjusted. This value
is not usually edited directly.

Display attributes
Draw Turns the display of the cMuscleSmartCollide node on or off.

Shaded Sets the display of the node: wireframe, shaded, or wireframe and
shaded.

Highlight Maya highlights selected nodes in white or green by default. When
this value is 1, selected nodes are highlighted the same way. When set to 0,
no highlighting occurs, so the node color does not change when selected.

Color Sets the display color of the node when not triggered.

Color Trigger As the node gets triggered (as the joints rotate together) the
color of the cMuscleSmartCollide node interpolates to this color.

Opacity Sets the opacity of the plane drawn in the scene view for the node.
When set to 1 the plane is solid, when set to 0 it is transparent.

Display Size Adjusts the display size of the plane. This does not affect actual
computations.

Related topics

■ Smart Collision on page 95

cMuscleSmartConstraint node
This is a dependency node that takes information in a cMuscleSmartCollide
setup and drives the location and orientation of the actual cMuscleSmartCollide
node.

Related topics

■ cMuscleSmartCollide node on page 173

■ Smart Collision on page 95
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cMuscleSpline node
This is a locator node that implements the drawing and calculation of a basic
Hermite-curve with support for any number of control points, and outputs
any number of points along the curve. Since the cMuscleSpline node is the
basis of the cMuscleSpline deformer, many of these settings control the
deformer itself as well as the spline.

Below are descriptions of the attributes in the cMuscleSpline node. To see
these attributes, select a cMuscleSpline object and open the Attribute Editor.
For descriptions of the spline control object attributes, see
cMuscleSplineDeformer node on page 183.

Draw
Sets what is displayed for the spline curve itself.

Off Causes the spline to disappear.

spline Draws only the spline.

spline and points Draws the spline and dots for each control point.

spline, points and tangents Draws the tangents as well.
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Color Sets the display color of the spline curve.

NOTE In the Attribute Editor, you can also use a regular Maya color swatch to set
the color.

Tolerance Sets the level of quality used when calculating the spline length
and when drawing the curve. Lower values are rougher and more inaccurate,
higher values are more accurate. 24 is a good default value, and does not have
to be changed.

Tangent Mode
Sets the tangent mode. In order to understand how this works, you can change
the tangentMode and move the controls around interactively to compare how
they work in both cases.

relative Tangents automatically grow/shrink based on the distance from one
control point to another. This can help result in a smoother curve.

absolute The tangent length at each point is exactly as it is set and does not
change.
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Up Axis Sets which axis for each control point is used as the "up" axis. This
is what controls the spin of the driven joints/nodes along the curve. If you
find you get flipping, you can switch the up axis from X to Z or the reverse.

NOTE That twist is only handled up to 180 degrees, after which you see a flip.

Reset Frame For jiggle calculation, this sets which frame the jiggle resets on.
Any jiggle on or before this frame is off. You can key this value with a stepped
key to get resetting of jiggle on different frames as needed, for example if there
are different shots to be animated in one scene.

Dampen On Squash
Controls how the curve behaves with jiggle as its length changes.

0 Jiggle values are applied as they are set.

1 The jiggle amount dampens down and the cycle gets faster as the curve gets
squashed.

Dampen On Stretch
Controls how the curve behaves with jiggle as its length changes.

0 Jiggle values are applied as they are set.

1 The jiggle amount dampens down and the cycle gets faster as the curve is
stretched.

Len Default/Squash/Stretch Set the default/min/max length of the spline.
As the length goes from default to squash, the dampenOnSquash is affected,
and as it goes from default to stretch, the dampenOnStretch is affected. If this
spline is tied to a cMuscleSplineDeformer node, these settings also set the

182 | Chapter 9   Muscle Nodes



driving of the muscle squash and stretch as the spline length goes between
these values.

NOTE These values do not clamp the actual length of the spline, but set the
min/max range for when the squash and stretch can occur.

Cur Len An output of the spline that shows the current length of the spline
curve. This can be useful for custom rigging.

Pct Squash/Stretch An output value that shows the amount of squash or
stretch the spline is undergoing. The values range from 0 to 1. As the curLen
goes from the lenDefault to lenSquash, the pctSquash goes from 0 to 1. As the
curLen goes from the lenDefault to lenStretch, the pctStretch goes from 0 to
1. These values can be useful for custom rigging.

Related topics

■ cMuscleSplineDeformer node on page 183

■ Create a Muscle Spline deformer on page 34

■ Set up a Muscle Spline deformer on page 35

cMuscleSplineDeformer node
This is a deformer node that provides a more powerful muscle deformation
than the cMuscleStretch deformer, including custom muscle shaping. This
node is partially driven from a cMuscleSpline node.

Below are descriptions of the attributes in the cMuscleSplineDeformer node.
For descriptions of the spline control object attributes, see Spline control object
attributes on page 184.

NOTE Many of these settings can be changed in the Muscle Parameters tab.

Cur Len The current length of the curve of the cMuscleSpline.

Pct Squash The current amount the spline curve is squashed. This value ranges
from 0 to 1 as the spline gets shorter.

Pct Stretch The current amount the spline curve is stretched. This value ranges
from 0 to 1 as the spline gets longer.

Enable Shaping If on, custom muscle shaping is active and any shapes set
up by the artist are used as the spline changes length.
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Shaping Blend For custom muscle shaping, controls how the shapes blend
together. A larger value causes the shapes to falloff over a bigger length range
and blend more together at a time. Smaller values make the shapes turn on
and off only when the spline length is closer to the length the shape was made
for.

Squash XStart/Squash ZStart Controls the amount of scaling on X or Z for
the beginning section of the object when the spline is shorter than the default
length.

Squash XMid/Squash ZMid Controls the amount of scaling on X or Z for
the middle section of the object when the spline is shorter than the default
length.

Squash XEnd/Squash ZEnd Controls the amount of scaling on X or Z for
the end section of the object when the spline is shorter than the default length.

Stretch XStart/Stretch ZStart Controls the amount of scaling on X or Z for
the beginning section of the object when the spline is longer than the default
length.

Stretch XMid/Stretch ZMid Controls the amount of scaling on X or Z for
the middle section of the object when the spline is longer than the default
length.

Stretch XEnd/Stretch ZEnd Controls the amount of scaling on X or Z for
the end section of the object when the spline is longer than the default length.

Spline control object attributes

The following are the attributes for the spline Control Objects:

Translate/Rotate Each control has an overall translate/rotate that positions
the location of the spline points. You can manually parent your controls to
get more of an FK-type setup.

Tangent Length Controls the length of the tangent at each point. As the
value increases, the tangent gets longer.

Jiggle Each control point has independent jiggle. This sets the strength of
the jiggle at this location. Larger values mean bigger motion.
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Jiggle X/Y/Z Controls the amount of jiggle relative to the local space of the
control.

Jiggle Impact Sets the strength of the impact jiggle that occurs when the
muscle starts or stops moving suddenly. The motion is applied in a radial
fashion around the axis of the spline.

Jiggle Impact Start/Jiggle Impact Stop Set how much force must be applied
to trigger the jiggle impact motion. Larger values make the jiggle less likely
to trigger, smaller values make it more likely.

Cycle Sets the number of frames it takes the control point to bounce. Smaller
values have a faster, higher frequency bounce, larger values have a slower
bounce.

Rest Sets the number of frames it takes the Jiggle to come to rest after force
on it stops. Smaller values make the Jiggle stop sooner, larger values make the
Jiggle continue longer.

Related topics

■ cMuscleSpline node on page 180

■ Set up custom muscle shapes with the Muscle Spline deformer on page 39

cMuscleStretch node
This is a deformer node that does basic 3-point deformation on any object.
Can be used for fast muscle deformation.

Manual Squish Lets you make the muscle squash down even if the length
does not change. This causes the squash/stretch scale settings to be applied
to the geometry. Higher values cause a stretch deformation, lower values cause
a squash deformation.

Max Stretch Sets the percentage at which the stretch is at maximum. A value
of 2 means the muscle can grow 2 times longer than the default to get fully
stretched.

Stretch Start/Stretch Mid/Stretch End Set the X-Z scale factor for the object
when the muscle length grows.

Max Squash Sets the percentage at which the squash is at maximum. A value
of 0.5 means the muscle can be half as long as the default to get fully squashed.
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Squash Start/Squash Mid/Squash End Set the X-Z scale factor for the object
when the muscle length shrinks.

X Factor/Z Factor Allow the overall X and Z squashing to be adjusted to get
non-uniform squash and stretch.

Weight Start/Weight Mid/Weight End Set the "pull" of each control to the
geometry. These settings can help fine-tune how the start, middle, and end
of the muscle looks as the controls move.

Reset Frame Sets the frame where jiggle resets. Any frame on or before this
gets zero jiggle effect. This can be keyed, usually with stepped keys to allow
for jiggle to be reset midway through an animation, such as if you have
multiple shots and there is fast action between frames causing the need for
jiggle to reset.

Jiggle Start/Jiggle Mid/Jiggle End Set the strength of the jiggle for the start,
middle, and end of the object. Higher values mean bigger motion.

Cycle Start/Cycle Mid/Cycle End Set the number of frames it takes for the
related section to bounce. Smaller values result in a faster, higher frequency
bounce, larger values result in a slower bounce.

Rest Start/Rest Mid/Rest End Set the number of frames it takes for the related
section to stop jiggling. Smaller values mean the motion stops sooner, larger
values cause the jiggle to last longer.

Dampen On Squash Causes the jiggle to dampen off and get faster if the
object is in a stretched state.

Dampen On Stretch Causes the jiggle to dampen off and get faster if the
object is in a stretched state.

Related topics

■ Create a Muscle Stretch deformer on page 43

cMuscleSurfAttach node
This is a locator node that attaches to either NURBS or polygon surfaces. The
node calculates translate and rotate (as well as normal and tangent) for the
object given the u,v location to attach to for NURBS, or two edges and a sub
u-v location within the implied polygon for polygon meshes. This lets you
‘stick’ the locator to a deforming NURBS or mesh surface.
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Related topics

■ Set up muscle attach points on page 17

cMuscleSystem node
This is a deformer node that implements the main skin deformer node. It
supports multiple connections from cMuscleObject, cMuscleDirection and
cMuscleSmartCollide nodes for basic skinning and Sliding. It can also operate
standalone for Caching, Relax, Jiggle, Self Collision and so on.

Main attributes

The Muscle skin deformer has several important attributes that are not all
directly tied to any specific feature.

Envelope The common Maya envelope setting that specifies the resulting
amount of deformation applied by the deformer. Setting this to 0 has the
same effect as disabling the nodeState setting, and effectively turns the
deformer off.

Cache
Sets the state of the caching algorithm.

disabled The cache feature is not used.

write-file Writes out the cache to a separate ASCII file each time the frame
is changed.

read-file Reads in the cache from external files.

write-node Writes cache data directly onto the Muscle deformer node each
time the frame is changed.

read-node Reads cache data from the Muscle deformer node.

Show Warnings This option turns on the display of warning messages output
to the script editor. This is an important option, as it lets you know if you
have sticky weights set for muscles that were not bound properly to the points.
When this occurs, Muscle deformation can slow down. To see if you have
invalid bindings, turn on showWarnings and examine the script editor. You
can then select Muscle > Skin Setup > Auto-Fix Invalid Sticky Bind Points from
the main menu bar to correct them.

User Scale XY/Z These attributes let you connect the master scaling node for
your rig into the deformer. This way distance-based values, like force items,
can work properly when the rig is scaled up or down.
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Sticky attributes

The Muscle deformer includes the following attributes that affect how Sticky
deformation works:

Enable Sticky Enables and disables sticky deformation.

Relative Sticky
Lets you select whether Relative Sticky mode is on or off.

off Turns Relative Sticky mode off. Sticky weights move the point on the mesh
fully, like a skinCluster.

relative Turns Relative Sticky mode on. cMuscleObjects are deformed in such
a way that you do not get a double-transform when a skinCluster is used below
Muscle.

For more information, refer to Relative Sticky deformation on page 52.

Force Normalize Since Muscle Objects can have their Sticky values affected
by their Sticky Strength attribute, and because you can choose not to normalize
weights with Relative Sticky mode, you can force normalization of the
weighting during deformation. When on, all Sticky weight values are
normalized to 1.0 during deformation.

Sticky A/B/C These attributes determine which set of Sticky weights you are
using. These values can be blended, although you typically have only one set
on at a time. The values for these attributes are internally normalized so that
you do not get a double transform. For example, setting stickyA/B/C to 1, 1,
0, actually results in a 0.5 0.5 0 result.

Related topics

■ Sticky deformation on page 50

Sliding attributes

The following are the basic Sliding settings on the Muscle deformer:

Enable Sliding When set to 1.0, sliding is enabled if you have painted Sliding
weights for the object you want to slide.

Paint weights only where sliding is needed for that object. You can also paint
Direction weights as described earlier to get more control over the direction
of the slide.

Quality
Sets the quality of the sliding calculations. Higher values look better but are
slower.
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Full True capsule, polygon bone and NURBS muscle sliding is calculated.

Medium Any NURBS muscles are slightly lowered in quality to give faster
performance. Often, you can use Medium quality and get an acceptable level
of sliding. Polygon bones are not changed by Medium quality.

Low All objects including both polygon meshes and NURBS objects are
converted to capsules internally. This provides some idea of what sliding looks
like, although it is not very accurate. For best results, your geometry of any
polygon objects should have the length of the geometry down the object’s
local Y-axis. This gives the most accurate capsule replacement.

Shrink Wrap Normally, sliding only occurs when a capsule/bone/muscle
pushes outward farther than the surface of the mesh. The Shrink Wrap attribute
lets sliding occur even if the objects are lower than the skin. In effect, it causes
the skin to look not only outside but also inside, and moves the skin mesh to
the object that is the farthest out. This can be useful to get tighter muscle
definition, or even as a modeling tool. If there is no object to slide onto, the
point is left where it is.
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Use Bind Stores the fat offset of the skin mesh to the closest bone/muscle and
uses that offset throughout the deformation, even if the point is slid by another
muscle.

See Set a constant fat offset for Sliding deformation on page 73 for more
information.

Allow Neg Fat This is used when useBind is on. When active, this allows
points to stay below any muscle/bone if the muscle/bone was originally
intersecting the model when the fat was bound. If off, the mesh is always on
the surface. If useBind is off, this attribute has no effect.

Related topics

■ Sliding deformation on page 53

Displace attributes
Enable Displace Disables or enables the entire displacement computation for
the Muscle deformer.

Collision Displace Determines how the Collisions attributes for other
deformation features work. For example, when a Smooth operation is done,
you can have it smooth, but still “re-slide” with muscles still colliding against
muscles or bones that are sliding on the surface of the mesh. When enabled,
these “re-collisions” not only include sliding muscles/bones, but also include
displace nodes. When off, operations like Jiggle, Relax and Smooth do not
re-compute displacement deformation even if their Collision mode is set to
on.

Related topics

■ Displacement deformation and rendering on page 56

Force attributes
Enable Force Enables or disables the force calculation.

Gravity Strength Specifies the amount points move in the gravity direction.
This amount is multiplied by the Force point weights for each point.

Gravity X/Y/Z Sets the gravity direction for points to move when affected
by gravity.
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Wind Strength Set the amount of point motion based on wind/noise. Larger
values move points more.

Wind Dir X/Y/Z Sets the general direction points move based on wind. These
values are normalized, so 1, 1, 0 actually becomes 0.5, 0.5, 0 internally.

Wind Speed Sets the rate of change in the wind as time passes. Smaller values
cause slower changes to the noise displacement. Larger values make a faster
change over each frame.

Wind Noise Typically 0 to 1. This sets how much the wind effect is noisy
versus just the painted weight value. At a value of 0, the points simply move
in the wind direction with no visible noise. At 1, the points move in a random
way, with the noise changing based on the windSpeed. Values over 1 cause
extra displacement.

Wind Noise Scale Sets the visible feature size of the noise. Larger values make
the noise/wind bumps larger, and tend to result in a smoother looking
displacement. Smaller values cause smaller noise bumps.

Wind Noise Dirty Sets how dirty the noise or wind looks. Even with a large
windNoiseScale, increasing this value causes sharper and more frequent
changes to the displacement. The lowest value is 1.
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NOTE Wind is applied in a world-space. This means even if the Wind Speed is 0,
moving your object around in space causes the noise to change.

Related topics

■ Force deformation on page 58

Jiggle attributes

The following are the Muscle deformer settings for Jiggle:

Enable Jiggle When off, the jiggle calculation is disabled for speed. When
on, per point skin jiggle is calculated.

Jiggle Collisions Allows sliding collision to be handled during jiggle effects.
This way, if a point hits something it would normally slide or push out from,
it still slides. The enableSliding option must be on for this to work. Note that
jiggle does not do self-collision.

Reset Frame Sets the base frame at which (and earlier), Jiggle has no effect
and is reset. This can be useful if you are animating more than one shot in a
file, and the character moves rapidly from one frame to the next. You can key
this value with a stepped keyframe to adjust it to reset at the start of each shot.

Jiggle Min/Jiggle Max Once you have painted Jiggle weights, this sets the
actual amount or strength of Jiggle applied on those points.

Cycle Min/Cycle Max Once you have painted Cycle weights, this sets the
frame time it takes for each point to bounce based on the painted weights.

Rest Min/Rest Max Once you have painted rest weights, this sets the frame
time it takes for each point to stop moving and come to rest.

Related topics

■ Per-Point Jiggle deformation on page 58

Relax attributes

The following are the Muscle deformer settings for Relax:

Enable Relax When off, this disables the Relax calculations for speed. When
on, Relax is enabled.

Relax Mode
Sets the type of Relax calculation applied.
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normal Sets up Relax to wrinkle when points are compressed and pull when
points are stretched. The amount of wrinkle is less than with Wrinkle mode.

pull With this mode, wrinkling does not occur at all, and relax only operates
when the points are pulled farther apart or stretched.

wrinkle Operates like "pull", with both wrinkling or pull effects affecting the
mesh, however the amount of wrinkle is increased. Wrinkle weights affect the
wrinkle section, Relax weights affect the pull effects.

Relax Collisions When on, collisions with sliding bones or muscles occur
during relax calculations. This often gives the desired result of Relax when
sliding is used. The enableSliding attribute must be on for this to work.
Collisions also occur with displace nodes if collisionDisplace is on and
displacement is in use.

Relax Iterations Sets the number of calculations performed for Relax. Higher
values are more accurate and stable, but take longer. Values in the range from
8 to 64 usually work well. Often, a middle value of 24 or 36 provides enough
stability and deformation. If increasing the number only changes the mesh
slightly, using the lower value usually suffices.

Relax Strength Sets the overall strength of the Relax. This is an easy way to
lower the effect of the entire Relax calculation instead of repainting weights.
If your mesh flies apart, lowering this value can help.

Wrinkle Strength For the Wrinkle mode, sets the amount of wrinkling that
occurs as the mesh compresses. Values over 1 are allowed.

Relax Compress Like Relax Strength, but applied only to points as they
compress.

Relax Expand Like Relax Strength, but applied to points as they expand or
are pulled farther apart.

Related topics

■ Relax deformation on page 59

Smooth attributes

The following are the Muscle deformer settings for Smooth:

Enable Smooth When off, this disables the smooth calculations for speed.
When on, the Smooth feature is enabled.

Smooth Collisions When on, collisions with sliding bones or muscles occur
during Smooth calculations. This often gives the desired result of Smooth
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when sliding is used. The enableSliding attribute must be on for this to work.
This also collides with the cMuscleDisplace node if Displace mode is active
and collisionsDisplace is on.

Smooth Iterations Sets the number of calculations performed for smooth.
Higher values cause more smoothing, but take longer. Values in the range
from 8 to 64 usually work well. A middle value of 24 or 36 often provides
enough stability and deformation. If increasing the number only changes the
mesh slightly, using the lower value usually suffices.

Smooth Strength Sets the overall strength of the Smooth. This is an alternative
way to lower the effect of the entire Smooth calculation without repainting
weights.

Smooth Compress The Smooth operation can change the look of the default
mesh. Using Smooth Compress instead of Smooth Strength causes painted
points to be smoothed only if that part of the mesh is undergoing compression.
This can be used to help with areas that pinch.

Smooth Expand The Smooth operation can change the look of the default
mesh. Using Smooth Expand instead of Smooth Strength causes painted points
to be smoothed only if they are pulled farther apart.

Smooth Hold Normally, Smooth causes a mesh to lose volume since it smooths
in all three directions. Applying Smooth Hold makes the smooth occur less
in the direction of the normal of the point. This means that points can still
smooth out, but lose less volume. Values between 0.5 and 0.8 are
recommended.

Related topics

■ Smooth deformation on page 60

Collision attributes

The following attributes on the Muscle deformer let you adjust how Self
Collision works:

Self Collison Enables or disables the Self Collision calculation. Can be set to
off for speed, then turned on before render or final checking.

Self Tolerance Sets the internal tolerance used by the computations. This is
multiplied by other values internally, and does not need to be adjusted.

Self Falloff When a collision occurs, the points around are bulged out to
preserve volume. This value represents the distance that the points falloff to
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zero over for the volumization effect. Larger values mean a larger area is
volumized.

Self Volumize Sets the amount or strength of points that are volumized/bulged
out to preserve volume.

Self Blur Iterations When a collision occurs, points are moved/flattened to
resolve the collision. This effect can be blurred out to affect other points
surrounding the collision to result in a more smooth/soft look. This sets how
many iterations occur for this calculation.

Self Relax Iterations After self collision, points within the falloff region can
be relaxed with the Relax algorithm. This sets how many iterations are used.

Self Relax Strength After self collision, points within the falloff region can
be relaxed with the Relax algorithm. This sets how strong the relax effect is.

Self Smooth Iterations After self collision, points within the falloff region
can be smoothed with the Smooth algorithm. This sets how many iterations
are used.

Self Smooth Strength After self collision, points within the falloff region can
be relaxed with the Relax algorithm. This sets how strong the relax effect is.

Self Smooth Hold For the self collision smoothing, this sets the amount of
smooth hold during the smooth operation. At higher values, points are not
allowed to smooth along their normal and retain volume more.

Related topics

■ Self Collision on page 97

Related topics

■ cMuscleObject node on page 170

■ cMuscleDirection node on page 164

■ cMuscleSmartCollide node on page 173
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Maya Muscle Advanced
Techniques

The Maya Muscle Advanced Techniques tutorials assume that you have a basic familiarity
with the main tools and features of Maya, as well as basic Maya rigging knowledge. At the
end of the tutorials, you should have a good feel for how to use the Maya Muscle skin deformer
for your own characters and projects.

This chapter includes the following tutorials:

■ Rigging simple muscles on page 197

■ Rigging muscles on page 232

Rigging simple muscles

Introduction
This tutorial is designed to illustrate the basic workflow of creating simple
muscles with the Maya Muscle Builder. The tutorial includes six lessons:

■ Lesson 1: Setting up basic skin deformation on page 198

■ Lesson 2: Painting Sticky weights to bones on page 204

■ Lesson 3: Setting up simple muscles on page 210

■ Lesson 4: Painting Sticky weights to simple muscle on page 217

■ Lesson 5: Setting up Sliding deformation on page 222

■ Lesson 6: Setting up Jiggle deformation on page 228

10
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Preparing for the lessons
To ensure the lessons work as described, confirm that you have Maya Muscle
loaded. The Muscle menu displays in the main menu bar if Muscle is loaded.
If you need to load Muscle manually, see Load Maya Muscle on page 2 in
the Maya Muscle guide.

If you have not already done so, download the Maya Muscle Advanced
Techniques Lesson Data from the following location:
www.autodesk.com/maya-advancedtechniques.

It is recommended that you save your work periodically and at the end of
each section as you progress through this tutorial, however sample files of the
finished scene for each lesson are also included.

Lesson 1: Setting up basic skin deformation
This lesson shows you how to set up an object to be deformed by the Muscle
deformer with bones and joints. You will prepare a rig for basic skin
deformation and set initial weighting on your mesh.

NOTE If you already have an object with a Maya skinCluster applied, you can
easily convert it to use Muscle following a workflow similar to this lesson. See
Convert Maya skin to Maya Muscle on page 63 in the Maya Muscle guide to learn
how to convert a skinCluster to the Muscle setup.

Open the scene for the lesson

1 Load the DragonLeg_Basic_Start.mb file.

This scene contains a basic polygon mesh of a leg, some joints with a
simple, animated IK rig, and some background lights.

2 In the Display Layer Editor, turn off the lyrSkin and lyrLIGHTS layers to
hide the skin and view the underlying rig.

3 Scrub the timeline to view the animation.

You can see the basic IK rig setup as the leg moves back and forth over
time. In addition to the basic Maya joints, there are two polygon bone
objects for the hip blade and kneecap.
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Set up muscles

Currently, there is no stable root joint for this rig. Rather than creating a Maya
joint as the root, and since you will be using the Muscle deformer for skinning,
you can create a capsule object to use as the root.

Capsules are like joints, except that they have a true size and thickness and
can be used by the Muscle skin deformer as both joints for Sticky weighting
and actual sliding effects. They effectively work as bones, and are faster than
polygon mesh bones.

To create and set up a capsule object

1 Select Muscle > Muscles/Bones > Make Capsule to create a capsule object.

A capsule object appears at the origin. In the Outliner, you can see a
group called grpMUSCLES is added. This group holds all capsules and
muscles and is designed to keep your rig hierarchy clean.

NOTE Since capsules are locators, you must have Show Locators turned on
the scene view’s Show menu in order to see them.

2 Select Muscle > Simple Muscles > Set Muscle Parameters to open the
Muscle Builder window.

The top of the Muscle Parameters tab lets you edit basic attributes for
capsules, bones, and muscles.

NOTE You can also use the Attribute Editor or Channel Box to control Muscle
deformers and settings for any capsule, bone, or muscle.

3 In the Muscle Object Settings, adjust the capsule’s Length to a value of
4. If you want, you can also adjust the other muscle object settings, such
as the color.

4 Close the Muscle Builder window when you are finished editing the
parameters.

5 Move and rotate the capsule to a position beside the boneBlade object
as shown. This is a good location for your root object.
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Since only objects that have a cMuscleObject shape node can be connected
to the Muscle skin deformer for skinning, you need to convert all of the
joints and polygon bones to have this node.

Convert the joints to bones

Rather than manually creating a capsule by hand for each joint, Maya Muscle
provides an automatic way to convert joints to capsules so that they can be
directly connected to the Muscle deformer. Converted joints function as both
a regular Maya joint and a Muscle capsule object.

1 Select all of the joints in the dragon leg rig.
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TIP Use the filter field at the top of the Outliner window as a quick way to
isolate all of the leg joints. Enter jnt* to display only the leg joint objects,
which use that naming convention.

2 Select Muscle > Muscles/Bones > Convert Surface to Muscle/Bone.

Since you are converting joints and not a surface, the Joint to Capsule
Conversion window appears. You need to know which axis is running
down the length of the joints in your rig. The default for Maya is X.
However, on this rig a custom Joint Orient tool was used to get a cleaner
joint rotation axis. It is highly recommended you use this sort of tool to
set up your joints before rigging.

3 Click Y-Axis, since the Y-axis runs down the length of the joints in this
scene.

Each joint is converted to be a capsule object and have the shape node.
You can adjust the color and length of capsules in the Muscle Parameters.

Since you did not originally select the polygon bone objects when you
converted, you must also convert these mesh objects so they can be
connected into the Muscle deformer for skinning.

4 Select the kneecap and blade bone objects, then select Muscle >
Muscles/Bones > Convert Surface to Muscle/Bone.

The polygon mesh objects are converted and connected to a new
cMuscleObject shape node.
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While there is no visible change, the new shape node can be seen in the
Channel Box. You can also use the Muscle Builder window to turn on
display of the shape and adjust colors or other features as well. Make sure
you leave the Strength setting at 1.0.

Now that you have a series of joints and polygon mesh objects that have been
converted to work with the Muscle skin deformer, you can apply the skin
deformer and connect the muscle objects.

Apply the Muscle skin deformer

In these steps, you select only the mesh you are applying the deformer to.
You connect the bones and muscles afterwards.

To apply the Muscle skin deformer

1 Turn on the lyrSkin layer in the Display Layer Editor and select the dragon
leg skin mesh in the scene view.

2 Select Muscle > Skin Setup > Apply Muscle System Skin Deformer.

As the deformer is applied, a window appears to pre-calculate required
information for the Relax deformer in case you use it later.

When the process is complete, the dragon leg mesh looks the same, but
it now has the Muscle skin deformer applied. You can view the
cMuscleSystem1 node attributes in the Channel Box or Attribute Editor.

At this point, animating the mesh will have no deformation effect, because
you have not yet connected or weighted any bones or muscles to the skin
mesh. In the next steps, you will connect all the capsules and bones.

202 | Chapter 10   Maya Muscle Advanced Techniques



Connect the muscle objects

1 Go to frame 0 and notice the bones/capsules are in their default base
pose.

2 Select the following in the Outliner:

■ All of the capsule objects created in the previous lesson, including the
root capsule object and all the joints that you converted to capsules.

■ The two polygon bone objects (boneKneeCapRt and boneBlade).

■ The skin mesh (pSkinMesh).

3 Select Muscle > Muscle Objects > Connect selected Muscle Objects.

All the bones are connected into the Muscle deformer. At this point,
scrubbing the timeline still does not produce any motion on the skin
mesh because you have not yet applied the default skin weights.

Apply default weights

Applying default weights to bones and polygon mesh objects is similar to
weighting with the Maya skinCluster. The points on the skin will move when
the capsule/bone moves.

To apply default weights

1 Select the skin mesh (pSkinMesh).

TIP If the Muscle Paint window is open, you can see the weights when the
operation is complete.

2 Select Muscle > Weighting > Apply Default Weights.

The Default Weights window appears. There are several options available,
depending on the selected Weight type. See Default Weights window on
page 154 in the Maya Muscle guide for a detailed description.

3 Select Sticky from the Weight drop-down list.

4 Set the Smooth value to 3. The Smooth value sets how many iterations
the smooth operation applies.

5 Click Apply Default Weights.

Now that you have applied default Sticky weights, scrubbing the timeline
shows the effect. The skin mesh moves when the capsules/bones move.
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This concludes the first lesson. You can find the completed file for this lesson,
DragonLeg_Basic_End.mb, in the Maya Muscle Advanced Techniques folder.

Beyond the Lesson

In this lesson you learned how to:

■ Create a capsule object

■ Convert joints to bone capsules

■ Apply the Muscle deformer to a skin mesh

■ Connect bone and capsule objects to a skin mesh

■ Apply default weights to a rig

Now you are ready to refine the default weighting on your dragon leg mesh
by painting weights with the Muscle Paint window.

Lesson 2: Painting Sticky weights to bones
In the next steps you will paint weights on the mesh. The Muscle Paint window
lets you paint weights for capsules, bones, and muscles, as well as set weights
on points, much like a component editor.

Open the scene for the lesson

 ➤ Load the scene you worked on in the previous lesson or load the
DragonLeg_Paint_Start.mb file.

This scene contains the dragon leg with connected bones and capsule
objects. The dragon leg mesh is set up with default Sticky weights applied
to the capsules for basic skin deformation.

You can use the Display Layer Editor to show and hide various parts of
this rig.

Paint weights

After you apply default weights to the bones and polygon mesh objects, you
can use the Muscle Paint window to refine those weights, increasing or
decreasing the effect of the default weights.

1 In the scene view, select Shading > Smooth Shade All, if it is not already
on.
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2 Select the skin mesh object (pSkinMesh) then select Muscle > Paint Muscle
Weights.

The Muscle Paint window appears and the mesh appears in Paint mode,
in a black color.

The Muscle Paint window provides many of the same basic features as
the Artisan paint tools. See Muscle Paint window on page 149 in the Maya
Muscle guide to learn more about its specific attributes.

3 Select Sticky from the Weights drop-down menu.

4 Select jntShoulder in the Influence list and turn on Replace.

5 In the jntShoulder (hip) area of the dragon leg, paint weights to the
shoulder (hip) bone.

Wherever you paint, the default weights are replaced with the weight
value you are painting (by default, 1). You can adjust the Weight value
in the Muscle Paint window and continue painting.

TIP Press and hold the b key while dragging in the scene view to adjust the
size of the brush.
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6 When you are finished painting weights, close the Muscle Paint window.

7 Scrub the timeline to see how your painted weights affect the way the
skin deforms as the bones move.

In the next steps, you set weights on specific points, rather than painting
them on the entire upper leg.

Set weights to specific points

1 Open the Muscle Paint window and select the jntLegUp object in the
Influence list.

2 Turn off Paint mode in the Muscle Paint window.
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The painting features are now disabled in the Muscle Paint window, and
the points of the skin mesh appear.

3 Select the specific points on the upper leg where you want to set weights.

TIP Use the Lasso Tool for more precision when selecting points.

Notice that the Live Update option is on. This means that as you drag
the Weight slider, the weights update interactively. When Live Update
is off, you can set the weight value, but the weight does not change until
you click Set Weight/Flood.

When you have multiple points selected and Live Update is on, the
Weight slider automatically adjusts to show the average weight to the
current object for the selected points. For example, if you select some
points where the mesh is black and some where the mesh is red, the
Weight slider shows the average value of those points.

4 Use the Weight slider to drag the value to 0.5. Notice that the color turns
yellow to show this area has half the weight.

5 Continue dragging the slider up to 1.0. The selected points on the dragon
leg mesh are now weighted 100% to the upper leg bone.
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Smooth weights

In the next steps, you will smooth the transition between the shoulder (hip)
and upper leg joint. To make sure weights don’t get re-normalized to other
bones, you can lock weights.

1 Clear your selection by clicking an empty area of the scene, then turn
Paint mode on in the Muscle Paint window.

NOTE It's important that you have no points selected when you turn Paint
mode back on. If you turn Paint mode on with some points selected, only
those points are paintable. When you turn Paint mode on with nothing
selected, the entire mesh becomes paintable again.

2 In the Influence list, select everything except for the jntShoulder and
jntLegUp bones, then right-click and select Enable Lock/Hold Weight on
highlighted items from the pop-up menu.

A HOLD marker appears next to each joint, meaning the current weights
for those items are locked and cannot be adjusted, even if you paint
around that item. You can now safely smooth weights between the
shoulder and upper leg only, since those are the only two joints currently
unlocked.

3 Select jntLegUp in the Influence list, and turn on Smooth.

4 Paint along the top edge of the upper leg a few times.

5 Scrub the timeline to see the smooth deformation between the shoulder
and upper leg.
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6 Select all the items in the Influence list, right-click and select Disable
Lock/Hold Weight on highlighted items to continue painting on other
bones.

7 Continue to paint and smooth weights to the joints/capsules for basic
rigid bone skinning with the techniques you have learned in this lesson.
Leave the weights on the polygon knee cap and blade at zero, as you will
use those objects for Sliding effects in a later lesson.

When you are finished, you have a basic skin setup with bones. You can find
the completed file for this lesson, DragonLeg_Paint_End.mb, in the Maya
Muscle Advanced Techniques folder.

Beyond the lesson

In this lesson you learned how to:

■ Paint sticky weights to bones using the Muscle Paint window

■ Apply weights to specific points on a mesh

■ Apply Smooth weights for better transition between weights

Painting Sticky weights to bones or capsules gives an effect similar to Maya
skinClusters. The main benefits of the Muscle skin deformer for this type of
work is both the color feedback, as well as the ability to use other features of
the deformer such as Sliding, Jiggle and so on as discussed in the following
lessons.

In general, it is recommended that you first paint weights to only the capsules
and bones on your mesh before working with muscles and Sticky weights.
This can help keep your weighting structured and organized.
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Lesson 3: Setting up simple muscles
In the previous lessons, you set up the Muscle deformer with only capsules
and bones. This gives you a good foundation to build your additional skinning
from. In this lesson you learn how to create simple muscles and set up muscle
deformation on your mesh.

Open the scene for the lesson

1 Load the file you worked on in the previous lesson, or load the
DragonLeg_Muscles_Start.mb file.

This file has the dragon leg with all the muscles and bones connected
with default and basic Sticky weights applied to the capsules.

2 Do one of the following to change the skin mesh display so you can see
the underlying rig:

■ In the Display Layer Editor, turn off the lyrSkin layer to temporarily
hide the skin as you work on the muscle.

■ From the panel menus, select Shading > XRay.

Create a simple muscle

While you can convert and rig any existing NURBS surface to be a muscle,
Maya Muscle provides a tool to easily build and set up muscles interactively.
In the next steps you use the Muscle Builder to create simple muscles.

1 From the main menu, select Muscle > Simple Muscles > Muscle Builder.

The Muscle Builder appears.

2 Using the Outliner, do the following to load the muscle Attach Objects:

■ Select the jntShoulder capsule and click  for Attach Obj 1.

■ Select the jntLegLo capsule and click  for Attach Obj 2.

These  buttons load the selected objects into the Attach Object
fields for you.

3 Click Build/Update.
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A muscle shape is generated from the start Attach Object (Attach Obj 1)
to the end Attach Object (Attach Obj 2). You may want to change your
scene view to wireframe or X-ray mode while you work.

TIP You can click the Attach Obj 1 or Attach Obj 2 buttons to directly select
the attach locators and position them in the scene view.

For this tutorial, you can leave the parameters in the Build tab at their
default settings. If you want, you can adjust the simple muscle settings.
See Build tab on page 139 in the Maya Muscle guide to learn about the
attributes available.

NOTE If you scrub the timeline, the muscle stays attached but will not yet
squash or stretch properly because you have not yet set up deformation.

Once your muscle is generally placed and set, you can sculpt the muscle
shape into something more specific.

Sculpt the simple muscle shape

1 In the Muscle Builder, switch to the Cross Section tab.

This tab has three main sections. The list on the left shows you each cross
section of your muscle. Typically the first and last cross sections are
adjusted. There are two view panels showing you the view of all of your
muscle cross sections down the length and from the side.

2 Select Curve 3 and Curve 5 from the Cross Section list. Note that you can
move them on the X- and Z-axis in the view panel.

Selecting one or more items in the Cross Section curve list selects those
curves. You can then move them in the view panels here, or in the scene
view.

3 Click Edit Cross Section at the top of the tab.

The cross sections are now active for editing and the view panels
automatically switch to component mode so you can directly edit the
points of the cross section curves.

4 Continue editing the cross sections until you are happy with the shape
of the muscle.
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TIP You can pan in the view panels of the Muscle Builder. To easily re-center
the view panels, click the Cross Section tab again.

5 When you are finished, click the EDITING label at the top of the tab to
turn off the editing mode.

You are now finished sculpting your muscle. In the next steps you finish
the building process and rig the muscle to deform properly.

Finalize the simple muscle

1 In the Muscle Builder window, switch to the Finalize tab.

This tab lets you choose how to deform and rig your muscle. For further
information about the attributes of the Finalize tab, see Finalize tab on
page 141.

2 Ensure the Muscle Spline Deformer is selected, and Num Controls is set
to 3.

NOTE This gives you three movers: one at the start, one at the middle, and
one at the end of the muscle.

3 Click Convert to Muscle.

A warning dialog box appears to notify you that this operation will finalize
the cross sections of this muscle. The dialog box also lets you select the
base name of the muscle and controls.
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We recommend that you find a useful and readable naming scheme so
that you can easily select and weight the muscles in the Muscle Paint
window later. For example, if you create a muscle located near the upper
leg, on the rear side in the center, you could name it "hamstringCenter".

4 Enter a name and click OK.

The muscle is rigged and a cMuscleObject shape node is created. In
wireframe mode, you can see three yellow box controls. These controls
can be animated and have Jiggle settings on them that are created and
constrained to the proper capsules.

5 Switch to the Muscle Parameters tab and scroll down.

This section lets you customize the deformers on the selected muscles.
You can also directly manipulate some of the controls in the Attribute
Editor or Channel Box.
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To see the deformer attributes in the Channel Box, select the muscle
surface.

6 Scrub the timeline frame by frame to see the muscle squash and stretch.
After you have done this once, you can jump to any frame and adjust
Muscle Parameters at any time and the playback is still correct.

Adjust the squash and stretch

Before you set the muscle squash and stretch, it's a good idea to set the
minimum and maximum length of the muscle. By default, the muscle’s
minimum squash is set to half its original length, and its maximum stretch
is set to double its original length. When the muscle length changes to these
settings, you get the maximum amount of volume change.

To adjust the squash and stretch length settings

1 Set the scene view shading to Smooth Shade All and turn off the lyrSkin
layer in the Display Layer Editor.

2 Leaving the Muscle Parameters tab of the Muscle Builder open, do the
following to define the Squash pose:

■ Select the FootIKMover control and raise the leg to a squashed
position.

■ Select the muscle surface.

■ In the Spline Length Settings section of the Muscle Parameters tab,
click Set Current as Squash.

This sets the muscle’s minimum squash value to the current length.
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3 Do the following to define the Stretch pose:

■ Select the FootIKMover control and move it down so the leg is fully
extended.

■ Select the muscle surface.

■ In the Spline Length Settings section, click Set Current as Stretch.

Setting the minimum and maximum stretch length values cause the
squash/stretch settings to more directly affect the visual output, since
they are more closely related to the actual lengths the muscle is changing
by. This can also help stop stretching from losing volume. In addition,
this makes the Dampen On Squash and Dampen On Stretch values work
properly.

4 Adjust the Stretch Volume Presets as required.

Make sure you have the muscle surface selected so that changes you make
in the Muscle Builder affect the muscle. The stretch settings let you set
the basic X- and Z-axis radial volume change for the start, middle and
end of the muscle.

If you are getting flipping when the muscle contracts, changing the
Up-Axis can fix this. When the muscle is bent, the aim values set how
the tips orient themselves.

Lesson 3: Setting up simple muscles | 215



TIP You can play the animation and adjust the settings while the animation
plays. Clicking a Stretch Volume preset automatically sets the values to one
of several preset values.

View the Jiggle parameters

For Jiggle on simple muscles, you have overall control from the start to the
middle to the end of the muscle. If you rig a muscle and create more than
three movers, you can also directly set specific Jiggle values on the yellow
movers. You can experiment to see the effect of the Jiggle Presets located on
the Muscle Parameters tab of the Muscle Builder window.

To view the Jiggle parameters

1 Play the animation.

2 As the animation plays, click each of the Jiggle Presets buttons (Default,
Light, Medium, Heavy, and OFF) to see the effect each preset has on the
muscle.

Beyond the lesson

In this lesson you learned how to:

■ Create a simple muscle using the Muscle Builder

■ Sculpt and finalize a simple muscle

■ Adjust muscle parameters

Because you rigged the simple muscle with the cMuscleSplineDeformer, you
can also do custom muscle shaping to get exact control over how the muscle
looks at various lengths. For further information see cMuscleSplineDeformer
node on page 183 and Set up a Muscle Spline deformer on page 35 in the Maya
Muscle guide
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As you build more simple muscles, note that in some cases, you may want
muscles and bones to penetrate. For example when using Shrink Wrap, it's
better to have a solid mass of muscles even if they penetrate than to have gaps
or spaces between them.

You can now go back to the Build tab, select new settings, and continue
building more muscles for your rig using the techniques you have learned. A
completed muscle rig for this lesson called DragonLeg_Muscles_End.mb.

Lesson 4: Painting Sticky weights to simple muscle
In the previous lessons, you created muscles and bones and set skin weights
for the bone capsules. In this lesson, you add weights for simple muscles. This
is the same process as weighting for bones, except with muscle weights, the
mesh deforms not only when the muscle moves as a whole, but also when its
surface moves or jiggles. Since the skin mesh is effectively attached to the
muscle surface with Sticky weights, when the muscle jiggles or bulges, so does
the skin that is weighted to it. This step alone can give a high level of
additional realism and interest to your rigs.

Just as you connected the bones in an earlier lesson, you first need to connect
the muscles to the Muscle skin deformer. Since they were created with the
Muscle Builder, they are already rigged with the cMuscleObject shape node
and can be immediately connected.

Open the scene for the lesson

 ➤ Load the file you worked on in the previous lesson or load the
DragonLeg_Sticky_Start.mb file.

This file has the skin mesh weighted to the bone capsules, and the muscles
are set up and attached to the bones.
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Visualize the Sticky Bind distance

Unlike weighting to bones, when weighting to muscles the skin mesh points
are bound to the surface of the muscle. Setting this operation up takes some
time, so when the muscles are first connected, a Sticky Bind operation is
calculated from the skin to the muscle. In order to speed up this calculation,
only points within a certain distance from the center of the muscle are
calculated. For example, a muscle for a character’s left arm typically does not
need to be weighted to points on the character’s right leg. Sticky Bind ensures
that only points close to the muscle are calculated.

To control this, once you attempt to connect a simple muscle, a window
appears asking you what Sticky Bind distance to use. Typically, using the
Auto-Calculate value is sufficient, but there may be cases where you want to
preview the effect of this value. As an example, we can take a muscle and
visualize the Sticky Bind distance for it.

Any points within the Sticky Bind distance are calculated, and can be weighted
to the muscle properly. Any points outside this distance are ignored. Note
that this process is simply setting whether the point is allowed to be weighted,
it does not actually do any weighting. Any points outside the distance can
have weights set, but usually deform incorrectly. If you set the distance too
low, you can always go back and re-bind Sticky (even to the entire mesh) later.

To visualize the Sticky Bind distance

1 Select the simple muscle located in the upper thigh.

2 From the main menu, select Muscle > Muscle Objects > Visualize Sticky
Bind Distance for selected Muscle Objects.

A yellow visualization sphere appears around the selected muscle.
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The radius of the sphere can help you visualize the Sticky Bind distance.

3 Adjust the sphere’s Radius value in the Channel Box to see how a larger
or smaller value would work.

NOTE The sphere itself is just a temporary object and has no relevance to
the muscle, other than to help you visualize the distance.

4 Delete the sphere when you are finished.

Now you can connect the muscle surfaces to the skin.

Connect muscle objects

1 Go to frame 0, and do the following:

■ Ensure the bones and muscles are in their default base pose.

■ Select all of the NURBS muscles and the skin mesh.
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2 Select Muscle > Muscle Objects > Connect selected Muscle Objects.

The Sticky Bind Maximum Distance window appears. For more
information see Sticky Bind Maximum Distance window on page 149.

3 Click Auto-Calculate.

Each muscle is connected to the Muscle skin deformer and set up to allow
for Sticky weights. When this process is complete, you can paint muscle
weights the same way you painted bone/capsule weights.

Paint muscle weights

1 Select only the skin mesh.

2 From the main menu, select Muscle > Paint Muscle Weights.

The Muscle Paint window appears. Just like painting the capsule weights,
you can use this window to paint or set Sticky weights for the muscles.

3 In the Weights drop-down menu, select Sticky.

4 Select a muscle in the Influence list.

A good way to paint muscle weight is to slowly add up weight from the
bones onto the muscle.

5 To start painting muscle weights:

■ Set the Weight value to a small value, such as 0.1, and select Add as
the paint mode.
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■ Paint weights for the muscle on the skin.

■ Scrub the timeline to see how the animation looks with this
deformation.

TIP You can also right-click the Weight slider to select from preset weights
in increments of 1/10th.

6 Practice painting weights for each muscle until you get deformation
effects you like. Notice how the skin moves along with the muscle surface
as the Sticky weights are added to the muscle.

TIP Don't worry about interpenetration of the muscles since typically you do not
render the muscles, only the skin. In the next lesson, you add Sliding weights for
the muscles and bones, which helps the skin push out from the muscle if they
intersect.

You can find the completed file for this lesson, DragonLeg_sticky_End.mb, in
the Maya Muscle Advanced Techniques folder. This file also has an adjusted
animation to display muscle deformation.

Beyond the lesson

In this lesson you learned how to:

■ Visualize the Sticky Bind distance

■ Connect simple muscle objects to the Muscle skin deformer
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■ Paint muscle weights

Lesson 5: Setting up Sliding deformation
You now have a working muscle rig for the leg mesh. The Muscle skin deformer
provides even more quality in the rigging with Sliding weights. The Sliding
deformer lets you create muscle and bone sliding under the skin. Combined
with the Relax weights you will set in a later lesson, you can achieve very
effective skin pulling and sliding effects.

Open the scene for the lesson

 ➤ Load the file you worked on in the previous lesson or load the
DragonLeg_Sliding_Start.mb file.

This file has the leg properly skinned and weighted with bones and
muscles using Sticky weights.

Enable Sliding deformation

1 Select the skin mesh, and in the Channel Box under INPUTS click the
cMuscleSystem1 node to display its attributes.

Each main section of the deformer is broken down by label headings. For
now, use the ones listed under SLIDING. The Sliding deformer can be
turned on and off for faster interaction and playback.
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2 Turn on Enable Sliding and leave quality set to Full.

Later you can adjust the quality attribute as needed. See Sliding attributes
on page 188  in the Maya Muscle guide for further information.

Paint Sliding weights

Start by painting weights for the hip blade bone.

1 Select the skin mesh, then select Muscle > Paint Muscle Weights.

The Muscle Paint window appears.

2 In the Weights drop-down menu, select Sliding.

3 Set the Weight value to 1.0 and turn on Replace.

4 In the Influence list, select boneBlade.

5 Paint weights where the blade bone might push out.

TIP It's important to paint only the area around the bone for speed purposes,
and also so points on distant parts of the mesh aren’t affected by the blade
bone.

As you paint, you can see the Sliding deformation start to happen. Note
that the slide is not accurate because there is not enough detail in the
mesh relative to the bone. This is a good example of a situation where
you may want more skin detail for areas where smaller or thinner bones
or muscles cause the sliding.
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Set a Fat offset

For areas where a muscle or bone often penetrates the skin when sliding, you
can set a Fat value to create an offset between the muscle or bone and the
skin. Each muscle or bone object has this Fat attribute on its cMuscleObject
shape node.

A good example is the MusHipBack muscle, since the skin often penetrates
the muscle on the back. The image below shows that muscle painted with
Sliding weights, and a fat offset on the muscle set to 0.55.

To define an offset from the skin mesh to the bone blade

1 Select the bone blade object.

2 In the Attribute Editor, select the cMuscleObject_boneBlade1 tab to view
the cMuscleObject shape node attributes for the bone blade.

3 Set the Fat value to 1.0.

The skin is now offset from the bone blade.
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Notice that right now the Sliding only affects a few points, is somewhat sharp,
and is causing some self penetration in the muscle. In the next steps, you will
use Direction weights to improve the sliding.

Create a Direction node

1 Make sure nothing is selected, close the Muscle Paint window, then select
Muscle > Direction > Make Muscle Direction.

By default, a vector type direction node is created at the origin. It has an
arrow that points in the direction the Sliding will attempt to work once
it is connected to the Muscle skin deformer.

In this case, since nothing was selected, a new cMuscleDirection shape
node is created.

TIP Since you may often want to have radial direction nodes created based
on the center line of your mesh, and since capsules are typically used for
bones that run down the centerline, you can easily convert any capsule to
also function as a cMuscleDirection node. Simply select the capsule, then
select Muscle > Direction > Make Muscle Direction. The capsule will be
converted to be both a capsule and a radial muscle direction simultaneously.
You can then connect the capsule to the deformer as a capsule muscle object
and/or a muscle direction and use it both ways.

2 In the Channel Box or Attribute Editor, set the cMuscleDirection node’s
Type attribute to radial.

This creates a radial-type push out along an axis. The Length and Falloff
Outer attributes control how far this axis goes.

Next, you connect the direction object to the Muscle deformer.

Connect the Direction node

1 Select the direction object and the skin mesh.

2 From the main menu, select Muscle > Direction > Connect selected Muscle
Directions.
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The Direction object is connected, although there is no visible change
on the mesh because you have not yet painted Direction weights.

3 Move the Direction object to align it with the rear hip muscle.

4 Parent the Direction object to the first hip muscle cube mover.

5 Set the Length attribute to 3.0.
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Leave the Falloff Outer attribute set to 1.0, as it only changes the length
at the tips. The actual effect of the direction node comes only from
weighting. The Inner/Outer Falloff values are primarily for visual feedback.

Paint Direction weights

1 Select the skin mesh, then select Muscle > Paint Muscle Weights.

2 In the Muscle Paint window, select Direction in the Weights drop-down
menu.

This lets you set and paint Direction weights for any connected direction
nodes.

3 Paint Direction weights around the hip, in the same area where you
painted Sliding weights.

The Sliding direction is now corrected so that it pushes out radially from
the center line of the muscle direction node. This corrects the penetration
problem.

4 Scrub the timeline to see the animation.

5 In the Channel Box under INPUTS, click the cMuscleSystem1 node.

6 Toggle the Enable Sliding option on and off to compare how the mesh
looks with Sliding enabled and disabled.

7 Continue to paint weights and create direction nodes as needed, or open
DragonLeg_Sliding_End.mb to see a finished example.
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Beyond the lesson

In this lesson you learned how to:

■ Set up Sliding deformation

■ Paint Sliding weights

■ Set a Fat offset

■ Adjust how the slide occurs by setting up a directional node

Lesson 6: Setting up Jiggle deformation
So far you have a working leg with flexing muscles. To provide even more
control, Maya Muscle lets you paint Jiggle weights per-point on your mesh.

NOTE You can use the Jiggle deformer even if you are not doing muscle skinning.
For example, you can paint and add weights for jiggling on any moving object to
get jiggle effects, even if the object is skinned with a Maya skinCluster, or not
skinned at all.

Open the scene for the lesson

 ➤ Load the file you worked on in the previous lesson or load the
DragonLeg_Jiggle_Start.mb file.

This rig has a complete leg with bones and muscles, and with Sticky and
Sliding weights applied.

Enable Jiggle deformation

Like other features, the Jiggle deformer can be turned on and off independently.
When Jiggle occurs, Jiggle collisions can also be enabled to help make sure
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points do not move into bones and muscles that are sliding. Note that there
is no self-collision, this is simply sliding collision if the Sliding deformer is
also enabled.

1 Select the skin mesh.

2 In the Attribute Editor, select the cMuscleSystem1 tab.

3 Turn on Enable Jiggle.

Paint Jiggle weights

1 Select the skin mesh.

2 Select Muscle > Paint Muscle Weights.

The Muscle Paint window opens.

3 In the Muscle Paint window, select Jiggle from the Weights drop-down
menu.

4 Paint Jiggle weights in the middle center of the leg, as shown. (You can
paint weights on other areas of the skin mesh where you want to have
per-point skin jiggle.)

5 Experiment with painting different areas of the mesh, and playblast your
animation to see the results. Typically, jiggle-related weights benefit from
a smoother falloff on the painting. Close the Muscle Paint window when
finished.

Lesson 6: Setting up Jiggle deformation | 229



NOTE You can review the other Jiggle attributes on the cMuscleSystem node
in the Channel Box or Attribute Editor. See Jiggle attributes on page 192 in
the Maya Muscle guide for more details about each attribute.

The basic leg rigging is now complete. You can find the completed file for this
lesson, DragonLeg_Jiggle_End.mb, in the Maya Muscle Advanced Techniques
folder.

NOTE Since the Jiggle calculations for per-point skin jiggle can use significant
machine resources, you can use Muscle’s per-point cache feature to provide faster
animation playback during operations like lighting or rendering. In the next steps
you cache each frame of animation internally on the node in the Maya scene itself.
This way you can cache playback, then playback within Maya for faster speed and
interaction.

Create a cache

1 Select the skin mesh object.

2 From the main menu, select Muscle > Caching > Create Cache.

The frame range is the current Time Slider range, and the cache data is
stored within the Maya scene. Leave the default options in the Generate
Cache dialog that appears.

NOTE In this lesson you use node-based caching, however if you are planning
on using external file-based caching, you can set the path and base filename
using the Attribute Editor, or by selecting Muscle > Caching > Set Location
of Cache File from the main menu.

3 Make sure your skin mesh is still selected and click Generate Cache for
Selected Objects.

A progress window appears as the Time Slider scrubs and the cache is
calculated.

Once the dragon leg animation is cached, you can have faster playblasts,
or change camera angles and playback to see how the animation looks
from different angles. Since the data is cached, deformation is not really
being calculated, making playback faster.

4 Playback the animation.

Depending on the speed of your computer, the cached animation plays
back in near real-time. The cache attributes on the cMuscleSystem node
(which can be seen in the Channel Box or Attribute Editor) shows that
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the cache is now set to read-node. This means it is now reading the point
cache rather than doing full calculations.

NOTE While you are viewing the cached data, attempting to change settings
(such as turning Sliding deformation on or off, or attempting to paint weights)
will have no effect on the mesh.

To remove the cache

 ➤ Do one of the following:

■ Select Muscle > Caching > Delete Node Cache, then select which
frames to clear.

■ Switch the cache attribute of the cMuscleSystem node to disabled.
This disables caching and returns to the normal calculation.

Beyond the lesson

In this lesson you learned how to:

■ Set up Jiggle deformation

■ Paint Jiggle weights

■ Set up a per-point cache to facilitate faster playback

You can find the completed file for this lesson, DragonLeg_Cache_End.mb, in
the Maya Muscle Advanced Techniques folder.
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Rigging muscles

Introduction

This Advanced Technique tutorial shows you the basic workflow and features
of the Maya Muscle Creator in several lessons:

■ Lesson 1: Create and set up a muscle object on page 233

■ Lesson 2: Set muscle pose states on page 236

■ Lesson 3: Edit the muscle shape on page 239

■ Lesson 4: Adjusting muscle length on page 242

■ Lesson 5: Sculpting muscles on page 246

■ Lesson 6: Mirroring muscles on page 250

Preparing for the lessons
To ensure this tutorial works as described, confirm that you have Maya Muscle
loaded. The Muscle menu displays in the main menu bar if Muscle is loaded.
If you need to load Muscle manually, see Load Maya Muscle on page 2 in
the Maya Muscle guide.

If you have not already done so, download the Maya Muscle Advanced
Techniques Lesson Data from the following location:
www.autodesk.com/maya-advancedtechniques.
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It is recommended that you save your work periodically and at the end of
each section as you progress through this tutorial, however sample files of the
finished scene for each example are also included.

Lesson 1: Create and set up a muscle object

Open the scene for the lesson

1 Load the Sabertooth_Create_Start.mb file.

This scene contains a quadruped rig with its joints converted to have
capsules. You can use the Display Layer Editor to show and hide the skin
of the model.

2 Scrub the timeline and watch the walk cycle animation.

The quadruped rig is currently lacking a muscle structure. This lesson shows
you a workflow example using the Muscle Creator to add muscles. The Muscle
Creator lets you not only create and mirror muscles, but also provides controls
to sculpt and shape them so they move in a realistic fashion.

Create muscles

1 From the main menu, select Muscle > Muscles/Bones > Muscle Creator.

The Muscle Creator window appears. The top half of the Create tab
contains controls that let you set the name of your muscle, the number
of controls/cross sections, the number of segments around your muscle,
and the joints to which the muscle is attached.

2 In the Muscle Creator window, do the following:

■ Enter Mus_L_FrontLeg as the Muscle Name.
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TIP Naming your muscles clearly helps you better identify them within
the hierarchy, for example by differentiating muscles from the character’s
right and left sides.

■ Set Num. Controls / Cross Sections to 4.

■ Set Num. Segments Around to 8.

3 Keeping the Muscle Creator window open, do the following to set the
muscle’s Attach objects:

■ Select the bn_L_F_Humerus01 capsule (in the scene view or Outliner)

then click the Attach Start  button in the Muscle Creator window.

■ Select the bn_L_F_TiborRaiiMinor01 capsule and click the Attach End

 button.
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The  buttons load the selected objects into the Attach Start and
Attach End fields for you.

4 Click Create Muscle.

The new muscle is attached to the joints you specified in the Attach Start
and Attach End fields.

To see the muscle clearly, you may want to change your scene view to
wireframe. The muscle is primarily comprised of a NURBS surface, two
attach points at each end of the muscle, and a series of cross section
controls.
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Beyond the lesson

In this lesson you learned how to create a muscle attached to two joints. You
can find the completed file for this lesson, Sabertooth_Create_End.mb, in the
Maya Muscle Advanced Techniques folder.

Now you are ready to refine and edit the muscles of the saber tooth tiger by
setting the pose states and adjusting the locators at each end of the muscle.

Lesson 2: Set muscle pose states
This lesson shows you how to set up the muscle pose states.

Open the scene for the lesson

1 Load the Sabertooth_Set_Start.mb file.

This scene contains the saber tooth tiger with a front leg muscle.

2 Scrub the timeline to see how the leg muscle deforms throughout the
animation.

Notice the exaggerated deformation of the front leg muscle. By default,
all muscles contain a certain amount of jiggle, which is causing the
deformation. In the next steps, you will remove the default Jiggle so that
you can better visualize and set the muscle’s pose states.
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Setting pose states

NOTE Although it is best to set the pose states before you begin sculpting your
muscles, you can edit them at any point in your muscle creation process.

To turn off the default Jiggle

1 Select the front leg muscle.

2 Switch to the Front camera in the scene view and select the four cross
section controls along the length of the muscle surface.

These outer wireframe boxes store the Jiggle settings.

3 In the Channel Box, set the Jiggle attribute to 0.

4 Switch back to the Perspective view and scrub through the animation
again.

The muscle deformation is much more natural. Without the default Jiggle
value, it is easier to set the three main pose states in the next steps.

To set the pose states

1 Select the front leg muscle.

2 From the main menu, select Muscle > Muscles/Bones > Muscle Creator.

3 In the Muscle Creator, switch to the Edit tab.

The Edit tab contains controls that let you shape and fine tune your
muscle surfaces in the different pose states.
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4 Go to frame 3, where the front leg muscle is in a rest state.

5 In the Poses section of the Muscle Creator, click the Rest button.

This sets the muscle’s current pose as its rest state.

6 Go to frame 15 and click Stretch.

At this point, the humerus and leg joints are almost parallel, indicating
a good muscle stretch position.

The muscle surface thins out when the state is set.

7 Go to frame 7 and click Squash.

This is the point where the humerus is almost perpendicular to the leg
joints, indicating a good muscle squash.
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The muscle surface’s volume expands a little to compensate for its new
set state.

Now that you have set the pose states, you can turn Jiggle back on. You can
now clearly see the front leg muscle bulge and stretch as you scrub through
the animation.

Beyond the lesson

In this lesson you learned about setting muscle pose states. You can find the
completed file for this lesson, Sabertooth_Set_End.mb in the Maya Muscle
Advanced Techniques folder.

Now you are ready to adjust the muscle’s attach points locators, as well as edit
its length and shape.

Lesson 3: Edit the muscle shape
Each muscle you create using the Muscle Creator is constrained to two separate
attach locators on each end. These locators are parented to the joints you
specified when you first created the muscle. You can move these locators to
change the muscle shape. Here, you adjust them so that the muscle surface
wraps around the front leg.

NOTE You can re-parent the muscles to different joints of your rig by re-parenting
the muscle attach locators.
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Open the scene for the lesson

 ➤ Load the file Sabertooth_Edit_Start.mb.

This scene contains the saber tooth tiger with a front leg muscle that has
all three pose states set.

Adjust the position of muscle locators

To adjust the muscle locators

1 Select the front leg muscle.

2 Open the Muscle Creator and switch to the Edit tab.

The lower part of the Edit tab lists all the different cross section controls
and attach points available for the selected muscle.

3 In the Attach Locs section, Ctrl-select the two end locators of the leg
muscle: locMus_L_FrontLeg_End1 and locMus_L_FrontLeg_End2.

4 Using the Move tool, move the locators lower on the Y-axis until they
are near the ankle, then move them on the Z-axis until they are in front
of humerus joint.

Notice that the muscle surface stretches to compensate for the new locator
position.
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5 Select locMus_L_FrontLeg_Start1 and move it close to the base of the
humerus joint, by the side of the leg facing outwards.

6 Select locMus_L_FrontLeg_Start2 and move it next to
locMus_L_FrontLeg_Start1.

Notice that each cross section control along the muscle surface
individually rotates to compensate for the adjusted locator position.
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7 Scrub through the animation to see how the muscle behaves based on
its new shape.

Beyond the lesson

In this lesson you learned how to shape your muscle by adjusting its attach
locators. You can find the completed file for this lesson,
Sabertooth_Edit_End.mb, in the Maya Muscle Advanced Techniques folder.

Now you are ready to adjust the length of the muscle surface.

Lesson 4: Adjusting muscle length

Muscles created with the Muscle Creator window have three built-in cross
section curve sets that you can edit: one for the default rest position, one for
the squash state, and another for the stretch state. You can directly edit these

242 | Chapter 10   Maya Muscle Advanced Techniques



curves in the scene view, or using the Muscle Creator window. The following
example shows you how to adjust the muscle length for each of these poses.

Open the scene for the lesson

1 Load the Sabertooth_Length_Start.mb file.

This scene contains the saber tooth tiger with capsulated bones, a front
leg muscle, and a neck muscle that has been set in all three pose states.

2 Scrub frame by frame to see the neck muscle squash and stretch.

Notice that the neck muscle travels down from the cervical joints to the
humerus joint in a straight line, which causes the muscle surface to either
stick out too much from the tiger’s body, or go through the shoulder
joints. This not only looks unnatural, but it also affects how the muscle
works. In the next steps, you will fix this by changing the muscle’s center
line for each of its pose states so that it follows the contours of the tiger’s
body.

Adjust the muscle length

In the following steps, you will use the muscle locators to adjust the muscle
length for each of the pose states.

Adjust the rest locators

1 Select Muscle > Muscles/Bones > Muscle Creator from the main menu.

The Muscle Creator window opens.

2 Go to frame 0, where the neck muscle is in a rest state.

3 Select the neck muscle surface and switch to the Edit tab in the Muscle
Creator.

4 In the Attach Rest section, select AttachMidMus_L_Neck11.

This selects the first inner wireframe box at the top of the neck muscle,
which represents the attach point for the nearby cross section.
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5 Using the Move tool, adjust the position of the top part of the neck muscle
so it goes around (instead of through) the cervical joint.

6 Repeat the process with the remaining Attach Rest points until you’re
satisfied with the results.

The muscle shape should be organic and follow the tiger’s body. Don’t
worry about placing the attach points perfectly, as you can always tweak
them later.

Adjust the squash locators

1 Go to frame 5, where the neck muscle is in a squash state.

2 Adjust the center line for this state by selecting the attach points from
the Attach Squash section of the Edit tab, and then reposition them using
the Move tool.
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Adjust the stretch locators

1 Go to frame 17, where the neck muscle is in a stretch state.

2 Select the attach points from the Attach Stretch section of the Edit tab,
then reposition them using the Move tool so that the muscle goes around
the shoulder before ending at the humerus.

3 Scrub through the animation to view the effect of the changes you made.
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Beyond the lesson

In this lesson you learned to adjust the muscle’s length by altering its center
line. You can find the completed file for this lesson,
Sabertooth_Length_End.mb, in the Maya Muscle Advanced Techniques folder.
Now you are ready to sculpt the muscle surface.

Lesson 5: Sculpting muscles
You can also edit a muscle’s cross section curves to sculpt the muscle into the
shape you want. The Muscle Creator sculpting controls let you choose which
pose state and axis to edit, and provide sliders to help you adjust the muscle
surface.

NOTE  Make sure you select the desired pose state before editing your muscle. If
multiple states are selected at once, changes you make on the muscle surface are
reflected in all selected states.

Open the scene for the lesson

 ➤ Load the Sabertooth_Sculpt_Start.mb file.

This scene contains the saber tooth tiger with capsulated bones, a front
leg muscle, and a neck muscle which has been set in all three pose states.

Sculpt muscles in each pose state

1 Open the Muscle Creator (Muscle > Muscles/Bones > Muscle Creator) and
switch to the Edit tab.
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2 Select the neck muscle.

The neck muscle in the current rest state needs to be thinner on its Z-axis.

3 In the Sculpting section of the Muscle Creator, make sure only the Z axis
and Rest parameters are selected.

4 Drag the Sculpt slider to the left until the muscle loses its tube shape and
looks more like a flat strip.

Keep the Rest parameter selected, deselect the Z axis, and select the X
axis.
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5 Drag the Location slider to the left until it is under the St parameter and
drag the Falloff slider to roughly the same position.

This isolates the cross section curve at the top of the neck muscle that is
slightly curved inwards.

6 Drag the Sculpt slider to the right until the inward curvature disappears.

7 Go to frame 17, where the neck muscle’s stretch state is being pulled to
its limit.
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NOTE Before you sculpt a muscle in a desired state, make sure you scrub to
a frame that best represents the muscle in that state. Otherwise, you may
not properly see the results of your deformations on your muscle surface.

8 Drag the Location slider to the middle and drag the Falloff slider to the
right. This sets the sculpting range at its maximum, so the entire muscle
length is affected.

9 Select the Z axis and St parameters.

10 Drag the Sculpt slider to the left until the entire muscle is thinner.
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11 Scrub the animation again to view your sculpting changes.

Beyond the lesson

In this lesson you learned how to sculpt a muscle in different pose states. You
can find the completed file for this lesson, Sabertooth_Sculpt_End.mb, in the
Maya Muscle Advanced Techniques folder.

Lesson 6: Mirroring muscles
The Muscle Creator lets you mirror muscles using their naming convention
as reference. You can mirror a selected muscle at any point in your creation
process.

Open the scene for the lesson

 ➤ Load the Sabertooth_Mirror_Start.mb file.

This scene contains the saber tooth tiger with muscle applied to the neck
and leg joints. You will mirror a muscle from one front leg to the other.

250 | Chapter 10   Maya Muscle Advanced Techniques



Mirror muscle

1 Open the Muscle Creator window (Muscle > Muscles/Bones > Muscle
Creator) and switch to the Create tab.

2 In the Mirror section, select X as the Mirror Axis.

3 Enter _L in the Search field, and _R in the Replace field.

The muscle for each “side” of the mesh needs to be parented to joints
that follow a Left or Right naming convention.

TIP  You can also right-click the Search field and select from the available
naming conventions. This automatically fills in the Replace field.

4 Select the front leg muscle surface.
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5 In the Muscle Creator window, click Mirror Muscle from Selection.

A new muscle is created on the right front leg based on the selected
muscle.

6 (Optional) To mirror an additional muscle, select it and click Mirror
Muscle from Selection again.
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Beyond the lesson

In this lesson you learned how to mirror muscles from one side of the mesh
to the other. You can find the completed file for this lesson,
Sabertooth_Mirror_End.mb, in the Maya Muscle Advanced Techniques folder.
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Troubleshooting Muscle

This section answers troubleshooting questions and provides tips and tricks for Maya® Muscle.

Troubleshoot capsules
I can’t see my capsules or Muscle Objects You must have Show Locators
checked in the Show menu of your Maya scene to see these objects.

I duplicated a capsule, but it doesn’t work. Capsules are special locators that
need special connections set up. Simply duplicating the object does not keep
or restore these connections on the duplicate object. It is recommended that
you always use the Muscle > Muscles/Bones > Make Capsule menu item rather
than duplicate existing capsules. See Create a capsule on page 10.

If you have duplicated a capsule or muscle that already has a cMuscleObject
shape node, you can use the Fix Invalid Muscle Object Nodes menu item to
re-create a valid shape, but any old settings on the original shape will be lost.
See Fix invalid Muscle Object nodes on page 47.

Troubleshoot muscles
Can I still use earlier cMuscleSystem 1.xx files? Due to some technical changes
in the core functionality, it is necessary to convert/update files from earlier
versions of cMuscleSystem before they work with Maya Muscle. See Re-Initialize
setup data on Maya Muscle on page 67.

When I reference in a rig with muscles, I get file load errors. You may
encounter this issue as you test your rig or scrub time to test Jiggle in your rig
file. Try deleting the Jiggle cache for all muscles: Delete a muscle Jiggle cache
on page 44. This removes Jiggle cache information from the rig, so that it can
be cleanly set in the referenced rig animation file. You may not see this error
until you animate and reload the animation file with the referenced rig.
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Disconnecting a muscle takes a long time. Is there another way to do
this? Yes. The Disconnect menu item attempts to first zero out any weights
to the muscle or node you are disconnecting, which can take a long time. To
speed this up, you can do a manual disconnect.

To manually disconnect muscles

1 In the Muscle Paint window, select the node you want to delete and zero
all Sticky weights (flood to 0).

2 Delete the muscle or node, or disconnect its connections to the deformer.

3 Select Muscle > Skin Setup > Auto-Fix Deleted/Missing Muscles from the
main menu bar. This properly finalizes the disconnect.

Troubleshoot painting muscle weights
I can’t see my paint weight colors./The colors and weights don’t appear
to update. From the panel menus, select Show > Locators so you can see and
get updates on painting weights.

I’ve already started skinning and I want to adjust and reposition my
muscle or capsule. Muscle lets you reset the base pose for a muscle or bone,
even if it is already skinned. This means that even after you start skinning,
you can reposition or edit the default position of that object so that the Sticky
weights skinning is effectively reset. See Reset base pose for selected Muscle
Objects on page 69.

I painted Sticky weights to a muscle but the points seem to fly off, or the
deformation gets really slow. Make sure that when you bound your muscle
the Sticky Bind distance was set large enough to include the points you are
weighting for, or Re-Bind sticky for the muscle. See Re-Bind Sticky for selected
Muscle Objects on page 70. Also, in the Influence list of the Muscle Paint
window, make sure that the "HOLD" weights option is not enabled for any
object that is also weighted to that point if you are trying to scale or smooth
weights.

There is also a showWarnings option on the Muscle deformer that you can
turn on to see which muscles may have points outside the range, so that you
can re-bind sticky on those muscles. Points will no longer fly off, but the
deformation may get slower as binding information is calculated ‘on the fly’
as needed. To fix this, see Auto-Fix invalid Sticky Bind points on page 67.

Why do I see a polyColorPerVertex node on my mesh? The Paint Weights
for polygon object uses Maya's polyColorPerVertex node to help display
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coloring, so you will see this node on any polygon object deformed with the
Muscle deformer. In addition, any earlier values are overwritten. If you are
using the polyColorPerVertex node for your own purposes, you need to finish
painting and setting up deformation weights first, before you go and use the
node for your own purposes.

When painting, if I go and move an object, I can't seem to get back to
Paint mode. If you change from painting to use the Move or Rotate tool (for
example), you have effectively exited the Paint mode. To return to painting
without having to close and reopen the Muscle Paint window, reselect the
object you are painting weights for, and in the Muscle Paint window, click
on the bones/muscle or weight in the list of items you are painting.

Can I delete the cMuscleDisplayShape node? Yes, you can delete
cMuscleDisplay shape nodes. Doing so can help you to apply a blendShape
node to your mesh. The Muscle Paint window re-creates this node when it is
opened again. In Maya Muscle, these nodes are automatically deleted when
the Muscle Paint window is closed properly.

Troubleshoot deformation
When I paint/alter settings on the deformer for my mesh, nothing seems
to happen and I am still getting old deformation. Check to see if you have
the cache attribute set to read-node or read-file. When the cache mode is set
to read-node or read-file, you do not see changes to the deformer since it is
effectively only using the cache for deformation. First, set the cache attribute
to disabled to make it update.

Can I cache negative frames? Yes. The Muscle deformer allows for up to
1024 negative frame values. This is also why the output to file caches are offset
with an additional 1024 added to the actual frame number saved.

Can I use sub-frames? Yes. Muscle properly deforms on subframe intervals,
even when using cache data. Cache data is linearly interpolated between cache
frame information.

What is the difference between the Relax and Smooth weights? Relax can
at first appear similar to Smooth, but they are different. Relax weights cause
the mesh to attempt to get back to a more original state keeping points more
or less where they used to be, which can also cause wrinkling. Smooth weights
actually smooth the points out, not caring about the original point location.
Typically, Smooth brings points closer together and loses detail, while Relax
moves points closer or farther depending on what is needed.
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Do you have any tips for the Relax feature? Relax can be a slow calculation.
You usually want to turn this on only at the end of your work before rendering.
When painting or setting Relax weights, you can disable the entire deformer
by setting the envelope to 0. In addition, if you are going to preview an
animation with Relax, it is recommended that you turn it on, then generate
a cache of your animation sequence to play it back from any angle at a faster
speed. See Create a cache on page 108.

In most cases, the new wrinkle or pull modes work best. This helps relax out
muscle sliding effects without wrinkling. You can use the separate Wrinkle
weights to get wrinkle effects. normal mode can cause a popping-wrinkling
effect which may be undesirable.

For overall smoothing, you can also use Smooth weights. You can use Relax
to get wrinkles with painted wrinkles and wrinkle mode active, then use
Smooth weights and smoothing to do more of a true smooth deformation.

Do you have any suggestions for using Shrink Wrap? Shrink Wrap slows
down your sliding effects. You can use it for a modeling feature, but it is
recommended that you turn off Shrink Wrap for actual rigging purposes. In
addition, a similar effect can be achieved by simply modeling your geometry
smaller or inside the muscles, instead of outside. That is, instead of making
your skin mesh larger and surrounding your muscles, make it smaller and use
regular sliding without Shrink Wrap to get a very similar effect.

I can't apply a blendshape to my mesh after Muscle has been applied. Make
sure you have deleted any cMuscleDisplay shape nodes. For example, you can
do this by running the following MEL command:

delete `ls -type "cMuscleDisplay" "*"` ;

This deletes all cMuscleDisplay nodes. After that you can apply a blendshape
deformer. Opening the Muscle Paint window again recreates these nodes, but
they are automatically removed when the dialog is closed properly.

Smart Collide deformation doesn't seem to work with Maya skinClusters
being used underneath Maya Muscle. If you are using Muscle above a
skinCluster, use the Relative mode for deformation. This is needed even if you
are not skinning with actual Sticky weights. Switching to use Relative mode
(see Relative Sticky deformation on page 52) causes the Smart Collision routines
to work properly when a skinCluster is used below Maya Muscle.

Muscle Self Collision sometimes pops on and off. The Self Collision
algorithm can sometimes appear to disable if the collision areas are too
complicated. This can also happen based on how large the collision area is.
In many cases, you can simply paint "0" value collision weights on the backs
of areas you do not need to collide and this can help resolve these issues, as
well as speed up the calculations. For example, on an arm, you can paint a

258 | Chapter 11   Troubleshooting Muscle



large section on the back of the elbow as black (or 0) to help it solve properly
when the front of the arm collides. Another solution is to use the Muscle
Smart Collide nodes which are both faster and more stable than fully
automated self collision. (See cMuscleSmartCollide node on page 173.)

Is there a reason to delete Muscle Jiggle Cache, Per-Point Skin Jiggle Cache
or Node Cache? Yes. First, if you are referencing a rig, and the rigger has test
animated the muscles in the rig, you may get an error reloading an animation
file. This is because both the rig and the animation file are attempting to store
muscle Jiggle information. To fix this, see Delete a muscle Jiggle cache on page
44.

In addition, if you have animated a shot and plan to do a node or external
file cache for speed during lighting, rendering, or playback, there is no need
to keep that data or per-point skin Jiggle data, since you have already effectively
cached every point. Deleting per-point skin Jiggle data saves a lot of disk space
when saving the scene. If you do not delete the per-point skin Jiggle cache
your Maya files may become large.

Deleting the Node Cache can also help reduce file size, if you have decided
the cache is bad or you do not want to use it anymore. You can also cache to
an external file instead. (See Delete a node cache on page 108.)

Is there a way to mirror muscles from one side to another? For new muscles
built with the Muscle Creator window, you can copy/paste or mirror muscles
after they are created. See Mirror muscles on page 25.

If you use the older Muscle Spline deformer, it is recommended that you use
the Mirror option found in the Finalize tab of the Muscle Builder window as
you build simple muscles. You must have proper naming on your Attach
objects and on the muscle for this to work. Mirroring must occur as you create
the muscle.
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