Legal Notices

© 2015 Autodesk, Inc. All Rights Reserved. Except where otherwise noted, this work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License that can be viewed online at http://creativecommons.org/licenses/by-nc-sa/3.0/.

This license content, applicable as of 16 December 2014 to this software product, is reproduced here for offline users:

CREATIVE COMMONS CORPORATION IS NOT A LAW FIRM AND DOES NOT PROVIDE LEGAL SERVICES. DISTRIBUTION OF THIS LICENSE DOES NOT CREATE AN ATTORNEY-CLIENT RELATIONSHIP. CREATIVE COMMONS PROVIDES THIS INFORMATION ON AN "AS-IS" BASIS. CREATIVE COMMONS MAKES NO WARRANTIES REGARDING THE INFORMATION PROVIDED, AND DISCLAIMS LIABILITY FOR DAMAGES RESULTING FROM ITS USE.

License

THE WORK (AS DEFINED BELOW) IS PROVIDED UNDER THE TERMS OF THIS CREATIVE COMMONS PUBLIC LICENSE ("CCPL" OR "LICENSE"). THE WORK IS PROTECTED BY COPYRIGHT AND/OR OTHER APPLICABLE LAW. ANY USE OF THE WORK OTHER THAN AS AUTHORIZED UNDER THIS LICENSE OR COPYRIGHT LAW IS PROHIBITED.

BY EXERCISING ANY RIGHTS TO THE WORK PROVIDED HERE, YOU ACCEPT AND AGREE TO BE BOUND BY THE TERMS OF THIS LICENSE. TO THE EXTENT THIS LICENSE MAY BE CONSIDERED TO BE A CONTRACT, THE LICENSOR GRANTS YOU THE RIGHTS CONTAINED HERE IN CONSIDERATION OF YOUR ACCEPTANCE OF SUCH TERMS AND CONDITIONS.

1. Definitions

a. "Adaptation" means a work based upon the Work, or upon the Work and other pre-existing works, such as a translation, adaptation, derivative work, arrangement of music or other alterations of a literary or artistic work, or phonogram or performance and includes cinematographic adaptations or any other form in which the Work may be recast, transformed, or adapted including in any form recognizably derived from the original, except that a work that constitutes a Collection will not be considered an Adaptation for the purpose of this License. For the avoidance of doubt, where the Work is a musical work, performance or phonogram, the synchronization of the Work in timed-relation with a moving image ("synchroning") will be considered an Adaptation for the purpose of this License.

b. "Collection" means a collection of literary or artistic works, such as encyclopedias and anthologies, or performances, phonograms or broadcasts, or other works or subject matter other than works listed in Section 1(g) below, which, by reason of the selection and arrangement of their contents, constitute intellectual creations, in which the Work is included in its entirety in unmodified form along with one or more other contributions, each constituting separate and independent works in themselves, which together are assembled into a collective whole. A work that constitutes a Collection will not be considered an Adaptation (as defined above) for the purposes of this License.

c. "Distribute" means to make available to the public the original and copies of the Work or Adaptation, as appropriate, through sale or other transfer of ownership.

d. "License Elements" means the following high-level license attributes as selected by Licensor and indicated in the title of this License: Attribution, Noncommercial, ShareAlike.

e. "Licensor" means the individual, individuals, entity or entities that offer(s) the Work under the terms of this License.

f. "Original Author" means, in the case of a literary or artistic work, the individual, individuals, entity or entities who created the Work or if no individual or entity can be identified, the publisher; and in addition (i) in the case of a performance the actors, singers, musicians, dancers, and other persons who act, sing, deliver, declaim, play in, interpret or otherwise perform literary or artistic works or expressions of folklore; (ii) in the case of a phonogram the producer being the person or legal entity who first fixes the sounds of a performance or other sounds; and, (iii) in the case of broadcasts, the organization that transmits the broadcast.

g. "Work" means the literary and/or artistic work offered under the terms of this License including without limitation any production in the literary, scientific and artistic domain, whatever may be the mode or form of its expression including digital form, such as a book, pamphlet and other writing; a lecture, address, sermon or other work of the same nature; a dramatic or dramatico-musical work; a choreographic work or entertainment in dumb show; a musical composition with or without words; a cinematographic work to which are assimilated works expressed by a process analogous to cinematography; a work of drawing, painting, architecture, sculpture, engraving or lithography; a photographic work to which are assimilated works expressed by a process analogous to photography; a work of applied art; a literary, scientific and artistic domain, whatever may be the mode or form of its expression including digital form, such as a book, pamphlet and other writing; a lecture, address, sermon or other work of the same nature; a dramatic or dramatico-musical work; a choreographic work or entertainment in dumb show; a musical composition with or without words; a cinematographic work to which are assimilated works expressed by a process analogous to cinematography; a work of drawing, painting, architecture, sculpture, engraving or lithography; a photographic work to which are assimilated works expressed by a process analogous to photography; a work of applied art; an illustration, map, plan, sketch or three-dimensional work relative to geography, topography, architecture or science; a performance; a broadcast; a phonogram; a compilation of data to the extent it is protected as a copyrightable work; or a work performed by a variety or circus performer to the extent it is not otherwise considered a literary or artistic work.

h. "You" means an individual or entity exercising rights under this License who has not previously violated the terms of this License with respect to the Work, or who has received express permission from the Licensor to exercise rights under this License despite a previous violation.

i. "Publicly Perform" means to perform public recitations of the Work and to communicate to the public those public recitations, by any means or process and the communication to the public of the performances of the Work, including by public digital performance; to broadcast and rebroadcast the Work by any means including signs, sounds or images.

j. "Reproduce" means to make copies of the Work by any means including without limitation by sound or visual recordings and the right of fixation and reproducing fixations of the Work, including storage of a protected performance or phonogram in digital form or other electronic medium.
2. Fair Dealing Rights. Nothing in this License is intended to reduce, limit, or restrict any uses free from copyright or rights arising from limitations or exceptions that are provided for in connection with the copyright protection under copyright law or other applicable laws.

3. License Grant. Subject to the terms and conditions of this License, Licensor hereby grants You a worldwide, royalty-free, non-exclusive, perpetual (for the duration of the applicable copyright) license to exercise the rights in the Work as stated below:

■ a. to Reproduce the Work, to incorporate the Work into one or more Collections, and to Reproduce the Work as incorporated in the Collections;

■ b. to create and Reproduce Adaptations provided that any such Adaptation, including any translation in any medium, takes reasonable steps to clearly label, demarcate or otherwise identify that changes were made to the original Work. For example, a translation could be marked "The original work was translated from English to Spanish," or a modification could indicate "The original work has been modified."

■ c. to Distribute and Publicly Perform the Work including as incorporated in Collections; and,

■ d. to Distribute and Publicly Perform Adaptations.

The above rights may be exercised in all media and formats whether now known or hereafter devised. The above rights include the right to make such modifications as are technically necessary to exercise the rights in other media and formats. Subject to Section 8(f), all rights not expressly granted by Licensor are hereby reserved, including but not limited to the rights described in Section 4(e).

4. Restrictions. The license granted in Section 3 above is expressly made subject to and limited by the following restrictions:

■ a. You may Distribute or Publicly Perform the Work only under the terms of this License. You must include a copy of, or the Uniform Resource Identifier (URI) for, this License with every copy of the Work You Distribute or Publicly Perform. You may not offer or impose any terms on the Work that restrict the terms of this License or the ability of the recipient of the Work to exercise the rights granted to that recipient under the terms of the License. You may not sublicense the Work. You must keep intact all notices that refer to this License and to the disclaimer of warranties with every copy of the Work You Distribute or Publicly Perform. When You Distribute or Publicly Perform the Work, You may not impose any effective technological measures on the Work that restrict the ability of a recipient of the Work from You to exercise the rights granted to that recipient under the terms of the License. You may not offer or impose any terms on the Work that restrict the terms of this License or the ability of the recipient of the Work to exercise the rights granted to that recipient under the terms of the License. This Section 4(a) applies to the Work as incorporated in a Collection, but this does not require the Collection apart from the Work itself to be made subject to the terms of this License. If You create a Collection, upon notice from any Licensor You must, to the extent practicable, remove from the Collection any credit as required by Section 4(d), as requested. If You create an Adaptation, upon notice from any Licensor You must, to the extent practicable, remove from the Adaptation any credit as required by Section 4(d), as requested.

■ b. You may Distribute or Publicly Perform an Adaptation only under: (i) the terms of this License; (ii) a later version of this License with the same License Elements as this License; (iii) a Creative Commons jurisdiction license (either this or a later license version) that contains the same License Elements as this License (e.g., Attribution-NonCommercial-ShareAlike 3.0 US) ("Applicable License"). You must include a copy of, or the URI, for Applicable License with every copy of each Adaptation You Distribute or Publicly Perform. You may not offer or impose any terms on the Adaptation that restrict the terms of the Applicable License or the ability of the recipient of the Adaptation to exercise the rights granted to that recipient under the terms of the Applicable License. You must keep intact all notices that refer to the Applicable License and to the disclaimer of warranties with every copy of the Work as included in the Adaptation You Distribute or Publicly Perform. When You Distribute or Publicly Perform the Adaptation, You may not impose any effective technological measures on the Adaptation that restrict the ability of a recipient of the Adaptation from You to exercise the rights granted to that recipient under the terms of the Applicable License. This Section 4(b) applies to the Adaptation as incorporated in a Collection, but this does not require the Collection apart from the Adaptation itself to be made subject to the terms of the Applicable License.

■ c. You may not exercise any of the rights granted to You in Section 3 above in any manner that is primarily intended for or directed toward commercial advantage or private monetary compensation.
The exchange of the Work for other copyrighted works by means of digital file-sharing or otherwise shall not be considered to be intended for or directed toward commercial advantage or private monetary compensation, provided there is no payment of any monetary compensation in connection with the exchange of copyrighted works.

d. If You Distribute, or Publicly Perform the Work or any Adaptations or Collections, You must, unless a request has been made pursuant to Section 4(a), keep intact all copyright notices for the Work and provide, reasonable to the medium or means You are utilizing: (i) the name of the Original Author (or pseudonym, if applicable) if supplied, and/or if the Original Author and/or Licensor designate another party or parties (e.g., a sponsor institute, publishing entity, journal) for attribution ("Attribution Parties") in Licensor's copyright notice, terms of service or by other reasonable means, the name of such party or parties; (ii) the title of the Work if supplied; (iii) to the extent reasonably practicable, the URI, if any, that Licensor specifies to be associated with the Work, unless such URI does not refer to the copyright notice or licensing information for the Work; and, (iv) consistent with Section 3(b), in the case of an Adaptation, a credit identifying the use of the Work in the Adaptation (e.g., "French translation of the Work by Original Author," or "Screenplay based on original Work by Original Author"). The credit required by this Section 4(d) may be implemented in any reasonable manner; provided, however, that in the case of a Adaptation or Collection, at a minimum such credit will appear, if a credit for all contributing authors of the Adaptation or Collection appears, then as part of these credits and in a manner at least as prominent as the credits for the other contributing authors. For the avoidance of doubt, You may only use the credit required by this Section for the purpose of attribution in the manner set out above and, by exercising Your rights under this License, You may not implicitly or explicitly assert or imply any connection with, sponsorship or endorsement by the Original Author, Licensor and/or Attribution Parties, as appropriate, of You or Your use of the Work, without the separate, express prior written permission of the Original Author, Licensor and/or Attribution Parties.

e. For the avoidance of doubt:

i. Non-waivable Compulsory License Schemes. In those jurisdictions in which the right to collect royalties through any statutory or compulsory licensing scheme cannot be waived, the Licensor reserves the exclusive right to collect such royalties for any exercise by You of the rights granted under this License;

ii. Waivable Compulsory License Schemes. In those jurisdictions in which the right to collect royalties through any statutory or compulsory licensing scheme can be waived, the Licensor reserves the exclusive right to collect such royalties for any exercise by You of the rights granted under this License if Your exercise of such rights is for a purpose or use which is otherwise than noncommercial as permitted under Section 4(c) and otherwise waives the right to collect royalties through any statutory or compulsory licensing scheme; and,

iii. Voluntary License Schemes. The Licensor reserves the right to collect royalties, whether individually or, in the event that the Licensor is a member of a collecting society that administers voluntary licensing schemes, via that society, from any exercise by You of the rights granted under this License that is for a purpose or use which is otherwise than noncommercial as permitted under Section 4(c).

f. Except as otherwise agreed in writing by the Licensor or as may be otherwise permitted by applicable law, if You Reproduce, Distribute or Publicly Perform the Work either by itself or as part of any Adaptations or Collections, You must not distort, mutilate, modify or take other derogatory action in relation to the Work which would be prejudicial to the Original Author's honor or reputation. Licensor agrees that in those jurisdictions (e.g. Japan), in which any exercise of the right granted in Section 3(b) of this License (the right to make Adaptations) would be deemed to be a distortion, mutilation, modification or other derogatory action prejudicial to the Original Author's honor and reputation, the Licensor will waive or not assert, as appropriate, this Section, to the fullest extent permitted by the
applicable national law, to enable You to reasonably exercise Your right under Section 3(b) of this License (right to make Adaptations) but not otherwise.

5. Representations, Warranties and Disclaimer
UNLESS OTHERWISE MUTUALLY AGREED TO BY THE PARTIES IN WRITING AND TO THE FULLEST EXTENT PERMITTED BY APPLICABLE LAW, LICENSOR OFFERS THE WORK AS-IS AND MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND CONCERNING THE WORK, EXPRESS, IMPLIED, STATUTORY OR OTHERWISE, INCLUDING, WITHOUT LIMITATION, WARRANTIES OF TITLE, MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, NONINFRINGEMENT, OR THE ABSENCE OF LATENT OR OTHER DEFECTS, ACCURACY, OR THE PRESENCE OF ABSENCE OF ERRORS, WHETHER OR NOT DISCOVERABLE. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OF IMPLIED WARRANTIES, SO THIS EXCLUSION MAY NOT APPLY TO YOU.

6. Limitation on Liability. EXCEPT TO THE EXTENT REQUIRED BY APPLICABLE LAW, IN NO EVENT WILL LICENSOR BE LIABLE TO YOU ON ANY LEGAL THEORY FOR ANY SPECIAL, INCIDENTAL, CONSEQUENTIAL, PUNITIVE OR EXEMPLARY DAMAGES ARISING OUT OF THIS LICENSE OR THE USE OF THE WORK, EVEN IF LICENSOR HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

7. Termination
a. This License and the rights granted hereunder will terminate automatically upon any breach by You of the terms of this License. Individuals or entities who have received Adaptations or Collections from You under this License, however, will not have their licenses terminated provided such individuals or entities remain in full compliance with those licenses. Sections 1, 2, 5, 6, 7, and 8 will survive any termination of this License.

b. Subject to the above terms and conditions, the license granted here is perpetual (for the duration of the applicable copyright in the Work). Notwithstanding the above, Licensor reserves the right to release the Work under different license terms or to stop distributing the Work at any time; provided, however that any such election will not serve to withdraw this License (or any other license that has been, or is required to be, granted under the terms of this License), and this License will continue in full force and effect unless terminated as stated above.

8. Miscellaneous
a. Each time You Distribute or Publicly Perform the Work or a Collection, the Licensor offers to the recipient a license to the Work on the same terms and conditions as the license granted to You under this License.

b. Each time You Distribute or Publicly Perform an Adaptation, Licensor offers to the recipient a license to the original Work on the same terms and conditions as the license granted to You under this License.

c. If any provision of this License is invalid or unenforceable under applicable law, it shall not affect the validity or enforceability of the remainder of the terms of this License, and without further action by the parties to this agreement, such provision shall be reformed to the minimum extent necessary to make such provision valid and enforceable.

d. No term or provision of this License shall be deemed waived and no breach consented to unless such waiver or consent shall be in writing and signed by the party to be charged with such waiver or consent.

e. This License constitutes the entire agreement between the parties with respect to the Work licensed here. There are no understandings, agreements or representations with respect to the Work not specified here. Licensor shall not be bound by any additional provisions that may appear in any communication from You. This License may not be modified without the mutual written agreement of the Licensor and You.

f. The rights granted under, and the subject matter referenced, in this License were drafted utilizing the terminology of the Berne Convention for the Protection of Literary and Artistic Works (as amended on September 28, 1979), the Rome Convention of 1961, the WIPO Copyright Treaty of 1996, the WIPO Performances and Phonograms Treaty of 1996 and the Universal Copyright Convention (as revised on July 24, 1971). These rights and subject matter take effect in the relevant jurisdiction in which the License terms are sought to be enforced according to the corresponding provisions of the implementation of those treaty provisions in the applicable national law. If the standard suite of rights granted under
applicable copyright law includes additional rights not granted under this License, such additional rights are deemed to be included in the License; this License is not intended to restrict the license of any rights under applicable law.

Creative Commons Notice

Creative Commons is not a party to this License, and makes no warranty whatsoever in connection with the Work. Creative Commons will not be liable to You or any party on any legal theory for any damages whatsoever, including without limitation any general, special, incidental or consequential damages arising in connection to this license. Notwithstanding the foregoing two (2) sentences, if Creative Commons has expressly identified itself as the Licensor hereunder, it shall have all rights and obligations of Licensor.

Except for the limited purpose of indicating to the public that the Work is licensed under the CCPL, Creative Commons does not authorize the use by either party of the trademark "Creative Commons" or any related trademark or logo of Creative Commons without the prior written consent of Creative Commons. Any permitted use will be in compliance with Creative Commons’ then-current trademark usage guidelines, as may be published on its website or otherwise made available upon request from time to time. For the avoidance of doubt, this trademark restriction does not form part of this License.

Creative Commons may be contacted at http://creativecommons.org/.

Certain materials included in this publication are reprinted with the permission of the copyright holder.

Creative Commons FAQ

Autodesk’s Creative Commons FAQ can be viewed online at http://www.autodesk.com/company/creative-commons, and is reproduced here for offline users.

In collaboration with Creative Commons, Autodesk invites you to share your knowledge with the rest of the world, inspiring others to learn, achieve goals, and ignite creativity. You can freely borrow from the Autodesk Help, Support and Video libraries to build a new learning experience for anyone with a particular need or interest.

What is Creative Commons?

Creative Commons (CC) is a nonprofit organization that offers a simple licensing model that frees digital content to enable anyone to modify, remix, and share creative works.

How do I know if Autodesk learning content and Autodesk University content is available under Creative Commons?

All Autodesk learning content and Autodesk University content released under Creative Commons is explicitly marked with a Creative Commons icon specifying what you can and cannot do. Always follow the terms of the stated license.

What Autodesk learning content is currently available under Creative Commons?

Over time, Autodesk will release more and more learning content under the Creative Commons licenses.

Currently available learning content:

- Autodesk online help-Online help for many Autodesk products, including its embedded media such as images and help movies
- Autodesk Learning Videos-A range of video-based learning content, including the video tutorials on the Autodesk YouTube™ Learning Channels and their associated iTunes® podcasts.
- Autodesk downloadable materials-Downloadable 3D assets, digital footage, and other files you can use to follow along on your own time

Is Autodesk learning and support content copyrighted?

Yes. Creative Commons licensing does not replace copyright. Copyright remains with Autodesk or its suppliers, as applicable. But it makes the terms of use much more flexible.

What do the Autodesk Creative Commons licenses allow?

Autodesk makes some of its learning and support content available under two distinct Creative Commons licenses. The learning content is clearly marked with the applicable Creative Commons license. You must comply with the following conditions:

- Attribution-NonCommercial-ShareAlike (CC BY-NC-SA) This license lets you copy, distribute, display, remix, tweak, and build upon our work noncommercially, as long as you credit Autodesk and license your new creations under the identical terms.
- Attribution-NonCommercial-No Derivative Works (CC BY-NC-ND) This license lets you copy, distribute, and display only verbatim copies of our work as long as you credit us, but you cannot alter the learning content in any way or use it commercially.
**Special permissions on content marked as No Derivative Works.** For video-based learning content marked as No Derivative Works (ND), Autodesk grants you special permission to make modifications but only for the purpose of translating the video content into another language.

These conditions can be modified only by explicit permission of Autodesk, Inc. Send requests for modifications outside of these license terms to creativecommons@autodesk.com.

**Can I get special permission to do something different with the learning content?**

Unless otherwise stated, our Creative Commons conditions can be modified only by explicit permission of Autodesk, Inc. If you have any questions or requests for modifications outside of these license terms, email us at creativecommons@autodesk.com.

**How do I attribute Autodesk learning content?**

You must explicitly credit Autodesk, Inc., as the original source of the materials. This is a standard requirement of the Attribution (BY) term in all Creative Commons licenses. In some cases, such as for the Autodesk video learning content, we specify exactly how we would like to be attributed.

This is usually described on the video’s end-plate. For the most part providing the title of the work, the URL where the work is hosted, and a credit to Autodesk, Inc., is quite acceptable. Also, remember to keep intact any copyright notice associated with the work. This may sound like a lot of information, but there is flexibility in the way you present it.

Here are some examples:

- “This document contains content adapted from the Autodesk® Maya® Help, available under a Creative Commons Attribution-NonCommercial-Share Alike license. Copyright © Autodesk, Inc.”
- “This is a Finnish translation of a video created by the Autodesk Maya Learning Channel @ www.youtube.com/mayahowtost. Copyright © Autodesk, Inc.”
- “Special thanks to the Autodesk® 3ds Max® Learning Channel @ www.youtube.com/3dsmaxhowtost. Copyright © Autodesk, Inc.”

**Do I follow YouTube’s standard license or Autodesk’s Creative Commons license?**

The videos of the Autodesk Learning Channels on YouTube are uploaded under YouTube’s standard license policy. Nonetheless, these videos are released by Autodesk as Creative Commons Attribution-NonCommercial-No Derivative Works (CC BY-NC-ND) and are marked as such.

You are free to use our video learning content according to the Creative Commons license under which they are released.

**Where can I easily download Autodesk learning videos?**

Most of the Autodesk Learning Channels have an associated iTunes podcast from where you can download the same videos and watch them offline. When translating Autodesk learning videos, we recommend downloading the videos from the iTunes podcasts.

**Can I translate Autodesk learning videos?**

Yes. Even though our learning videos are licensed as No Derivative Works (ND), we grant everyone permission to translate the audio and subtitles into other languages. In fact, if you want to recapture the video tutorial as-is but show the user interface in another language, you are free to do so. Be sure to give proper attribution as indicated on the video’s Creative Commons end-plate. This special permission only applies to translation projects. Requests for modifications outside of these license terms can be directed to creativecommons@autodesk.com.

**How do I let others know that I have translated Autodesk learning content into another language?**

Autodesk is happy to see its learning content translated into as many different languages as possible. If you translate our videos or any of our learning content into other languages, let us know. We can help promote your contributions to our growing multilingual community. In fact, we encourage you to find creative ways to share our learning content with your friends, family, students, colleagues, and communities around the world. Contact us at creativecommons@autodesk.com.

**I have translated Autodesk learning videos into other languages. Can I upload them to my own YouTube channel?**

Yes, please do and let us know where to find them so that we can help promote your contributions to our growing multilingual Autodesk community. Contact us at creativecommons@autodesk.com.

**Can I repost or republish Autodesk learning content on my site or blog?**

Yes, you can make Autodesk learning material available on your site or blog as long as you follow the terms of the Creative Commons license under which the learning content is released. If you are simply referencing the learning content as-is, then we recommend that you link to it or embed it from where it is hosted by Autodesk. That way the content will always be fresh. If you have translated or remixed our learning content, then by all means you can host it yourself. Let us know about it, and we can help promote your contributions to our global learning community. Contact us at creativecommons@autodesk.com.

**Can I show Autodesk learning content during my conference?**

Yes, as long as it’s within the scope of a noncommercial event, and as long as you comply with the terms of the Creative Commons license outlined above. In particular, the videos must be shown unedited with the exception of modifications for the purpose of translation. If you wish to use Autodesk learning content in a commercial context, contact us with a request for permission at creativecommons@autodesk.com.
Can I use Autodesk learning content in my classroom?
Yes, as long as you comply with the terms of the Creative Commons license under which the learning material is released. Many teachers use Autodesk learning content to stimulate discussions with students or to complement course materials, and we encourage you to do so as well.

Can I re-edit and remix Autodesk video learning content?
No, but for one exception. Our Creative Commons BY-NC-ND license clearly states that "derivative works" of any kind (edits, cuts, remixes, mashups, and so on) are not allowed without explicit permission from Autodesk. This is essential for preserving the integrity of our instructors' ideas. However, we do give you permission to modify our videos for the purpose of translating them into other languages.

Can I re-edit and remix Autodesk downloadable 3D assets and footage?
Yes. The Autodesk Learning Channels on YouTube provide downloadable 3D assets, footage, and other files for you to follow along with the video tutorials on your own time. This downloadable material is made available under a Creative Commons Attribution-NonCommercial-ShareAlike (CC BY-NC-SA) license. You can download these materials and experiment with them, but your remixes must give us credit as the original source of the content and be shared under the identical license terms.

Can I use content from Autodesk online help to create new materials for a specific audience?
Yes, if you want to help a specific audience learn how to optimize the use of their Autodesk software, there is no need to start from scratch. You can use, remix, or enrich the relevant help content and include it in your book, instructions, examples, or workflows you create, then Share-Alike with the community. Always be sure to comply with the terms of the Creative Commons license under which the learning content is released.

What are the best practices for marking content with Creative Commons Licenses?
When reusing a CC-licensed work (by sharing the original or a derivative based on the original), it is important to keep intact any copyright notice associated with the work, including the Creative Commons license being used. Make sure you abide by the license conditions provided by the licensor, in this case Autodesk, Inc.

Trademarks
The following are registered trademarks or trademarks of Autodesk, Inc., and/or its subsidiaries and/or affiliates in the USA and other countries: 123D, 3ds Max, Alias, ATC, AutoCAD LT, AutoCAD, Autodesk, the Autodesk logo, Autodesk 123D, Autodesk Homestyler, Autodesk Inventor, Autodesk MapGuide, Autodesk Streamline, AutoLISP, AutoSketch, AutoSnap, AutoTrack, Backburner, Backdraft, Beast, BIM 360, Burn, Buzzsaw, CADmep, CAICE, CAMduct, Civil 3D, Combustion, Communication Specification, Configurator 360™, Constructware, Content Explorer, Creative Bridge, Dancing Baby (image), DesignCenter, DesignKids, DesignStudio, Discreet, DWF, DWG, DWG (design/logo), DWG Extreme, DWG TrueConvert, DWG TrueView, DWGX, DFS, Ecotect, ESTmep, Evolver, FABmep, Face Robot, FBX, Fempro, Fire, Flame, Flare, Flint, ForceEffect, FormIt, Freewheel, Fusion 360, Glue, Green Building Studio, Heidi, Homestyler, HumanIK, i-drop, ImageModeler, Incinerator, Inferno, InfraWorks, InfraWorks 360, Instructables, Instructables (stylized robot design/logo), Inventor, Inventor HSM, Inventor LT, Lustre, Maya, Maya LT, MIMI, Mockup 360, Moldflow Plastics Advisers, Moldflow Plastics Insight, Moldflow, Moondust, MotionBuilder, Movimento, MPA (design/logo), MPA, MPI (design/logo), MPX (design/logo), MPX, Mudbox, Navisworks, ObjectARX, ObjectDBX, Opticore, Pixl, Pixlr-o-matic, Productstream, Publisher 360, RasterDWG, RealDWG, ReCap, ReCap 360, Remote, Revit LT, Revit, RiverCAD, Robot, Scaleform, Showcase, Showcase 360, SketchBook, Smoke, Socialcam, Softimage, Sparks, SteeringWheels, Stitcher, Stone, StormNET, TinkerBox, ToolClip, TopoBase, Toxik, TrustedDWG, T-Splines, ViewCube, Visual LISP, Visual, VRED, Wire, Wiretap, WiretapCentral, XSI.
All other brand names, product names or trademarks belong to their respective holders.

Disclaimer
THIS PUBLICATION AND THE INFORMATION CONTAINED HEREIN IS MADE AVAILABLE BY AUTODESK, INC. "AS IS." AUTODESK, INC. DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE REGARDING THESE MATERIALS.
What's New in Autodesk DirectConnect 2016
**Improvements in DirectConnect 2016**

- CATIA V4 importer supports .model files created from CATIA V5-6R2014.
- CATIA V5 importer supports V5-6 R2014V5R24) files.
- Granite importer supports version 9.0.
- Parasolid exporter supports V 27.
- IPT/IAM importer supports files created from Inventor 2016.
- DWG importer/exporter supports files from AutoCAD 2016 (2015 on OSX)
# Contents

## Chapter 1 What Is Autodesk DirectConnect
- Supported products and translators

## Chapter 2 Installation and Licenses
- DirectConnect and Installation

## Chapter 3 Translator Details
- Autodesk Inventor
- CATIA V4
- CATIA V5
- DWF
- DWG DXF
- IGES
- JT
- NX
- Open Inventor and Cosmo
- Pro/ENGINEER
- SolidWorks
- STEP
- STL
- STL
- ZPR
Chapter 4  Locations of Imported Data ........................................... 45
  Autodesk Alias Data .............................................................. 45
  Autodesk Maya Data ............................................................. 46
  Autodesk Showcase Data ......................................................... 46
  Autodesk Opticore Studio Data ................................................. 47

Chapter 5  Glossary ................................................................. 49
  Glossary terms ................................................................. 49
    ASM (.asm) ................................................................. 49
    assembly ................................................................. 49
    BSD license .............................................................. 49
    CATIA V4 ................................................................. 49
    CATIA V5 ................................................................. 49
    CGR (.cgr) ................................................................. 49
    Cosmo ................................................................. 50
    CSB (.csb) ................................................................. 50
    DLV (.dlv) ................................................................. 50
    DRAW (DR) ................................................................. 50
    DWF ................................................................. 50
    DWG ................................................................. 50
    DXF ................................................................. 50
    G (.g) ................................................................. 50
    Granite ................................................................. 50
    IAM (.iam) ................................................................. 50
    IGES ................................................................. 50
    IPT (.ipt) ................................................................. 51
    IV (.iv) ................................................................. 51
    JT ................................................................. 51
    NX ................................................................. 51
    Open Inventor .............................................................. 51
    PCRE ................................................................. 51
    Pro/ENGINEER ............................................................ 51
    PRT (.prt) ................................................................. 51
    SLDASM (.sldasm) .......................................................... 51
    SLDPRD (.sldprt) .......................................................... 51
    SolidWorks ............................................................... 52
    SPACE (SP) ............................................................... 52
    SPF ................................................................. 52
    STEP (.step) .............................................................. 52
    STL ................................................................. 52
    STP (.stp) ................................................................. 52
    V3Rx ................................................................. 52
    ZPR ................................................................. 52
Autodesk® DirectConnect is a family of data translators. Each of these translators imports a specific CAD file format into one or more of the following Autodesk® software products:

- Autodesk® Alias®
- Autodesk® Maya®
- Autodesk® Showcase®
- Autodesk® Opticore® Studio
- 3ds Max®/3ds Max® Design
- VRED™

The translators also export some CAD file formats from some products.
## Supported products and translators

**Import to Autodesk Alias, Autodesk Showcase, Autodesk Maya, Autodesk Opticore Studio, 3ds Max, 3ds Max Design, VRED:**

<table>
<thead>
<tr>
<th>File Format</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Autodesk Inventor</strong> (page 8)&lt;sup&gt;®&lt;/sup&gt;</td>
<td>Not available in 3ds Max/3ds Max Design</td>
</tr>
<tr>
<td><strong>CATIA V4</strong> (page 10)&lt;sup&gt;®&lt;/sup&gt;</td>
<td>V4.xx and earlier V3RX Levels, and .model files from CATIA V5-6R2014</td>
</tr>
<tr>
<td><strong>CATIA V5</strong> (page 12)&lt;sup&gt;®&lt;/sup&gt;</td>
<td>V5 R23 (V5-6R2013)</td>
</tr>
<tr>
<td><strong>DWG DXF</strong> (page 17)&lt;sup&gt;®&lt;/sup&gt;</td>
<td>Up to V2015</td>
</tr>
<tr>
<td><strong>IGES</strong> (page 19)</td>
<td>V5.3</td>
</tr>
<tr>
<td><strong>JT</strong> (page 24)</td>
<td>Up to V10.0</td>
</tr>
<tr>
<td><strong>Pro/ENGINEER</strong> (page 34) and Creo &lt;sup&gt;®&lt;/sup&gt;</td>
<td>Up to Wildfire 5.0, and Granite 8.0, neutral (.neu)</td>
</tr>
<tr>
<td></td>
<td>Creo, up to V2</td>
</tr>
<tr>
<td></td>
<td>Not Available in Showcase</td>
</tr>
<tr>
<td><strong>NX</strong> (page 26)&lt;sup&gt;®&lt;/sup&gt;</td>
<td>UG V13.0 to NX 9.0</td>
</tr>
<tr>
<td><strong>Open Inventor™ and Cosmo™</strong> (page 32)</td>
<td>All versions</td>
</tr>
</tbody>
</table>

---

2 | Chapter 1  What Is Autodesk DirectConnect
File Format

Not available in 3ds Max/3ds Max Design

**SolidWorks** (page 36)® (1) 2003-2014
Must be licensed and running on the import machine.

SPF
Alias (.wire)

**STEP** (page 38)
AP214, AP203E2

**STL** (page 40) (Stereo-lithography)
Not available in 3ds Max/3ds Max Design

---

**Export from: Autodesk Alias, Autodesk Maya, 3ds Max, 3ds Max Design, VRED:**

<table>
<thead>
<tr>
<th>File Format</th>
<th>Windows® 7, 64-bit; Windows® 8, 64-bit</th>
<th>Apple® Mac OS® X® 10.7, 10.8, 10.9, 64-bit</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>DWG DXF</strong> (page 17) Real Dwg 2015, Alias (.wire) only. Not available in 3ds Max/3ds Max Design.</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td><strong>IGES</strong> (page 19) V5.3 Not available in 3ds Max/3ds Max Design.</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td><strong>NX</strong> (page 26) UG V15.0*, NX1.0, 3.0, 5.0, 7.0, 8.0 Not available in 3ds Max/3ds Max Design.</td>
<td>✔</td>
<td>Not available</td>
</tr>
</tbody>
</table>

---

Supported products and translators | 3
<table>
<thead>
<tr>
<th>File Format</th>
<th>Windows® 7, 64-bit; Windows® 8, 64-bit</th>
<th>Apple® Mac OS® X® 10.7, 10.8, 10.9, 64-bit</th>
</tr>
</thead>
<tbody>
<tr>
<td>SPF</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Alias (.wire)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>STL (Stereo-lithography)</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Not available in 3ds Max/3ds Max Design.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZPR (page 42)®</td>
<td>✔</td>
<td>Not available</td>
</tr>
<tr>
<td>(ZPrint CAD for Rapid Prototyping) V1.2</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Installation and Licenses

DirectConnect and Installation

Autodesk® DirectConnect software installs automatically when the following Autodesk software is installed:

- Autodesk® Alias®
- Autodesk® Maya®
- Autodesk® Showcase®
- 3ds Max®/3ds Max® Design
- VRED™
- VRED™ Design
- VRED™ Professional
- VRED™ Presenter

Autodesk DirectConnect software is provided on the media with Autodesk® Opticore® Studio software, in the Autodesk DirectConnect 2016 folder. It requires manual installation.

For information about installing these software products, refer to their respective installation guides.

**NOTE** DirectConnect Help is supported only on Microsoft® Internet Explorer®. Performance on other browsers does not provide consistent results.
Support platforms

Autodesk DirectConnect runs on the same platform as the Autodesk product it installs with:

<table>
<thead>
<tr>
<th>Autodesk Software</th>
<th>Microsoft® Windows® 7, 64-bit; Windows® 8, 64-bit</th>
<th>Apple® Mac OS® X® 10.7, 10.8, 10.9, 64-bit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autodesk Alias</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Autodesk Maya</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Autodesk Showcase</td>
<td>✓</td>
<td>Not available</td>
</tr>
<tr>
<td>Autodesk Opticore Studio</td>
<td>✓</td>
<td>Not available</td>
</tr>
<tr>
<td>3ds Max/3ds Max Design</td>
<td>✓</td>
<td>Not available</td>
</tr>
<tr>
<td>VRED</td>
<td>✓</td>
<td></td>
</tr>
</tbody>
</table>

System requirements

Autodesk DirectConnect requires the following amount of available disk space:

- Windows 7: 700 MB for 32-bit, and 900 MB for 64-bit
- Windows 8: 900 MB for 64-bit
- Mac OS X: 300 MB for 64-bit

DirectConnect installs with other products, so your system must also accommodate the host product requirements. (For the system requirements of the host product, consult the appropriate installation guide.)
Translator Details
Autodesk® Inventor® is a 3D mechanical design, product simulation, tooling creation, and design communication software.

Autodesk® DirectConnect supports the import of Autodesk Inventor part (*.ipt) and assembly (*.iam) files into the Autodesk® Alias®, Autodesk® Maya®, Autodesk® Opticore® Studio, and VRED™ software. See installation information in Install Autodesk DirectConnect. (page 5)

**Import Autodesk Inventor files**

1. Choose the menu path in your installed Autodesk software product:

   - **Autodesk Alias**: File > Open or File > Import > File
   - **Autodesk Maya (Windows version)**: File > Open Scene or File > Import
   - **Autodesk Opticore Studio**: File > Import
   - **VRED**: File > Import

2. In the browser, select an Autodesk Inventor *.ipt or *.iam file.
3 Click **OK**, or **Open** to launch the translator and import the file.

**NOTE** To maintain the original positioning and orientation of part files in your scene, import the assembly file. Importing part files before the assembly file positions all of them at the origin (0,0,0), and removes the original positioning.

**Types of data imported**

NURBS are imported, and the following information is maintained on import:
- Brep bodies
- Data organization
- Tolerances and units
- Material colors and simple transparency
- Weld maps (beads only)
- Thread maps
- Decals

For locating the imported data, see *Locations of Imported Data* (page 45).

**Limitations**

- Work sources, display meshes, and some 2D/3D sketches are automatically excluded when importing an Autodesk Inventor file.
- Some cylindrical surfaces (pipes) do not trim properly.
CATIA® is computer-aided design software from Dassault Systèmes.

Autodesk DirectConnect supports the import of CATIA V4 (all versions, plus V3RX Levels) into the Autodesk Alias, Autodesk Showcase, Autodesk Opticore Studio, 3ds Max®/3ds Max® Design, and VRED software. The import includes geometric sets, attributes, such as names, layers, RGB colors, and visibility, and the CATIA file types. See installation information in Install Autodesk DirectConnect. (page 5)

DirectConnect supports CATIA model and export files produced with CATIA V4.xx and earlier V3RX Levels, and .model files from CATIA V5-6R2014.

Import CATIA V4 files

1. Choose the menu path in your installed Autodesk software product:

   Autodesk Alias
   File > Open or File > Import > File

   Autodesk Maya (Windows version)
   File > Open Scene or File > Import
2 In the browser, select a CATIA V4 *.model, *.mdl, *.session, *.exp, *
*dlv,*.dlv3, or *.dlv4 file.

3 Click OK, or Open.

The translator launches automatically, and the file imports into the
scene.

**Types of SPACE (SP) entities supported for import**

- Point (Type 1)
- Line (Type 2)
- Parametric curve (Type 3)
- Plane (Type 4)
- Parametric surface (Type 5)
- Face (Type 6)
- Volume (Type 7)
- Transformation (Type 9)
- Edge (Type 12)
- Circle (Type 20)
- Ellipse (Type 21)
- Parabola (Type 22)
- Hyperbola (Type 23)
- Polyhedral surface (Type 16)
- Composite curve (Type 24)
- Solids - Mockup (Type 17, secondary type 1)
- Exact solid (Type 17, secondary type 2)
- Space ditto (Type 28)
- Parametric skin (Type 35)
- NURB curve (Type 46)
- NURB surface (Type 47)

**NOTE**
- To locate this data in your Autodesk software, see Locations of Imported Data (page 45).
- For information about options in Alias for data importation, see the Autodesk Alias Help.
- For definitions on these data types, consult your CATIA documentation.

## CATIA V5

CATIA is computer-aided design software from Dassault Systèmes.

Autodesk DirectConnect supports import of CATIA V5 (R6-R24) files in the Autodesk Alias, Autodesk Maya, Autodesk Showcase, Autodesk Opticore Studio, 3ds Max/3ds Max Design, and VRED software. See installation information in Install Autodesk DirectConnect. (page 5)

Export of CATIA V5 Part files is available only in Alias (release 10 - 23).
Import CATIA V5 files

1. Choose the menu path in your installed Autodesk software product:
   - Autodesk Alias: File > Open or File > Import > File
   - Autodesk Maya (Windows version): File > Open Scene or File > Import
   - Autodesk Showcase: File > Import > File
   - Autodesk Opticore Studio: File > Import
   - 3ds Max/3dsMax Design: Application Menu > Import > Select File to Import dialog

2. In the browser, select a CATIA V5 (*.CATProduct, *.CATPart, or *.cgr) file.
3. Click OK, or Open to launch the translator and import the file into the scene.

Types of data imported

We support the import of files from CATIA V5 releases V5 (R6-23), and the following types of data:
- Point
- Line
- Arc
- Ellipse
- Parabola
- Hyperbola
- BSpline curve
- Polynomial curve
- Plane
- Cylindrical surface
- Conical surface
- Spherical surface
■ Toroidal surface
■ BSpline surface
■ Revolve surface
■ Ruled surface
■ Open body
■ Solid body
■ Layer
■ Geometric set
■ Part (from CATIA V5 release 6 and higher)
■ Product (from CATIA V5 release 6 and higher)
■ Attributes (RGB color, layer, name, visibility, and materials)
■ Per face color assignments
■ Cloud mesh data
■ Tessellated data
■ Weld data

NOTE
■ To locate this data in your Autodesk software, see Locations of Imported Data (page 45).
■ For information about options in Alias for data importation, see the Autodesk Alias Help.
■ For definitions about these data types, consult your CATIA documentation.

File formats referenced

The following are some of the file formats that can be referenced by CATIA V5 assembly files:
■ .CATProduct
■ .CATPart
■ .model
■ .cgr
■ .stl
Design Web Format (DWF™) is a file format developed by Autodesk for Web viewing and printing.

Autodesk DirectConnect supports the export of Autodesk Alias tessellated model data to file in DWF(*.dwf) format up to version 2014, to view in Autodesk Design Review and Project Freewheel. See installation information in Install Autodesk DirectConnect. (page 5)

NOTE For more information about software setup for Autodesk Alias, see the Autodesk Alias Help.

Export DWF files

1 In Autodesk Alias, select a file to be exported as a DWF, and click File > Export > Active As

, or File > Save As

2 On the File Formats menu, select DWF (.dwf).
Set export options, and then click **Save**.

<table>
<thead>
<tr>
<th>Option</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Export Curves</strong></td>
<td>When turned <strong>ON</strong>, exports curves.</td>
</tr>
<tr>
<td><strong>Export Symmetry</strong></td>
<td>If an Alias layer has symmetry turned <strong>ON</strong>, this information and the geometric objects resulting from symmetry can be merged and converted, or left intact (unmerged) and converted. When turned <strong>OFF</strong>, layer symmetry is not exported.</td>
</tr>
</tbody>
</table>
| **Tessellator** | **Fast** Models triangulate quickly and less accurately.  
**Accurate** Models triangulate slowly and more accurately.  
- **Tolerance** The amount a polygonal surface can deviate from the original NURBS surface. The default value is 0.01.  
- **Limit Edge Length** If selected, a Max edge length slider controls maximum size of the triangles. If unchecked, there is no limit to the size of the triangles.  
- **Max Edge Length** The maximum length of any triangle edge (in current linear units). |

**Types of data exported**

The DirectConnect translator for DWF exports only meshes. The Alias scene DAG hierarchy is preserved. Associated color information is also exported.

**NOTE** For information about options in Alias for data importation, see the Autodesk Alias Help.
The DWG and DXF® file types are drawing files and Drawing eXchange files in the AutoCAD® software.

Autodesk DirectConnect supports the import of AutoCAD (DWG and DXF) files into the Autodesk Alias, Autodesk Maya, Autodesk Opticore Studio, and VRED software. See installation information in Install Autodesk DirectConnect. (page 5)

**Import DWG/DXF files**

1. Choose the menu path in your installed Autodesk software product:

   - **Autodesk Alias**  
     File > Open or File > Import > File
   - **Autodesk Maya**  
     File > Open Scene or File > Import
   - **Autodesk Opticore Studio**  
     File > Import

2. Browse to, and select a DWG (.dwg) or DXF (.dxf) file.

3. Click **OK**, or **Open** to launch the translator and import the file.
Types of DWG and DXF data imported

- Colors
- Materials
- Lines, arcs, and splines
- Extruded curves
- Extrusions
- Layers
- Meshes
- Surfaces
- Text
- 3D solids

IMPORTANT
- Showcase does not support the AutoCAD material attribute Illumination. Alias supports the AutoCAD material attribute Illumination; however, it is called Incandescence.
- Showcase supports only 3D hierarchical data. It does not support 2D drawings.

NOTE
- To locate this data in your Autodesk software, see Locations of Imported Data (page 45).
- For information about options in Alias for data importation, see the Autodesk Alias Help.
- With want curves set to ON, DWG and DXF both support curves and round-trip data export. If they do not come in, set want curves to ON.

Export DWG/DXF files (Autodesk Alias)

1. In your Autodesk software, choose File > Save As

   , or File > Export > Active As

   .
2 On the **File Formats** menu, click **DWG** or **DXF**. For details about the available options, see the Help in the Autodesk software.

3 Select a **DWG/DXF** version, and click **Save**.

**IGES**

Initial Graphics Exchange Specification (IGES) is a file format for transferring graphics data between CAD/CAM systems.

Autodesk DirectConnect supports the import and export of the neutral IGES V5.3 (*.iges or *.igs) format files in the Autodesk Alias, Autodesk Maya (Windows version), Autodesk Showcase, Autodesk Opticore Studio, 3ds Max/3ds Max Design, and VRED software. See installation information in **Install Autodesk DirectConnect**. (page 5)

**NOTE** For more information about software setup for Autodesk Alias, see the Autodesk Alias Help.

**Import IGES files**

1 Choose the menu path in your installed Autodesk software product:

- **Autodesk Alias**
  - **File > Open** or **File > Import > File**

- **Autodesk Maya (Windows version)**
  - **File > Open Scene** or **File > Import**

- **Autodesk Showcase**
  - **File > Import > Import Files**
2 In the browser, select a native IGES V5.3 (*.iges or *.igs) file.
3 Click OK, or Open to launch the translator and import the file into the scene.

Export IGES files
1 In your Autodesk software, choose File > Save As, or File > Export > Active As.
2 On the File Formats menu, click DWG or DXF. For details about the available options, see the Help in the Autodesk software.
3 Save to a native IGES V5.3(*.iges or *.igs) file.

Troubleshoot (Autodesk Alias)
If the files you import contain unsatisfactory data, change the following import options in Autodesk Alias:

Default Trim Curves
Specifies the trim curves that the processor uses. You can select parameter space curves, model space curves, or use the flag that is present in the IGES file. By default, the preference flag in the IGES files is used.

Shrink Surface
When turned ON, Alias detects trimmed surfaces with trim boundaries that are the same as, or isoparametric to, the natural boundaries of the untrimmed surface. It then converts these surfaces into Alias surfaces by shrinking the untrimmed surface to the trim boundaries.

When turned OFF, Alias converts all trimmed surfaces of this type to Alias trimmed surfaces.
Types of data imported

The DirectConnect for IGES translator imports ASCII format IGES files with or without linefeed characters at the end of each record. The software does not support Binary IGES files.

The software imports NURBS for this file format and maintains the following information on import:
■ Surfaces and curves
■ Data organization (groups, layers, visibility, and instances)
■ Units
■ Colors

NOTE
■ For information about this data in your Autodesk software, see Locations of Imported Data (page 1).
■ For information about options in Alias for data importation, see the Autodesk Alias Help.

Identify IGES supported entities in log files

The following table shows IGES entities supported on import by DirectConnect for IGES.

![Table of IGES entities supported](image)

<table>
<thead>
<tr>
<th>Type</th>
<th>Form</th>
<th>IGES Entity</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>0</td>
<td>circular arc</td>
</tr>
<tr>
<td>102</td>
<td>0</td>
<td>composite curve</td>
</tr>
<tr>
<td>104</td>
<td>0-3</td>
<td>conic arc, ellipse, parabola, hyperbola</td>
</tr>
<tr>
<td>106</td>
<td>1</td>
<td>copious data</td>
</tr>
</tbody>
</table>

NOTE The input translator ignores any entities with an entity use flag value 02 (Definition), except for entity use flag value with IGES Subfigure Definition entity (Type 308).
<table>
<thead>
<tr>
<th>Type</th>
<th>Form</th>
<th>IGES Entity</th>
</tr>
</thead>
<tbody>
<tr>
<td>106</td>
<td>2</td>
<td>copious data</td>
</tr>
<tr>
<td>106</td>
<td>11</td>
<td>copious data</td>
</tr>
<tr>
<td>106</td>
<td>12</td>
<td>copious data</td>
</tr>
<tr>
<td>106</td>
<td>63</td>
<td>closed area</td>
</tr>
<tr>
<td>108</td>
<td>0</td>
<td>plane</td>
</tr>
<tr>
<td>108</td>
<td>+/- 1</td>
<td>bounded plane</td>
</tr>
<tr>
<td>110</td>
<td>0</td>
<td>line</td>
</tr>
<tr>
<td>112</td>
<td>0</td>
<td>parametric curve</td>
</tr>
<tr>
<td>114</td>
<td>0</td>
<td>parametric surface</td>
</tr>
<tr>
<td>116</td>
<td>0</td>
<td>point</td>
</tr>
<tr>
<td>118</td>
<td>0 - 1</td>
<td>ruled surface</td>
</tr>
<tr>
<td>120</td>
<td>0</td>
<td>surface of revolution</td>
</tr>
<tr>
<td>122</td>
<td>0</td>
<td>tabulated cylinder</td>
</tr>
<tr>
<td>123</td>
<td>0</td>
<td>direction</td>
</tr>
<tr>
<td>124</td>
<td>0</td>
<td>transformation matrix</td>
</tr>
<tr>
<td>126</td>
<td>0-5</td>
<td>rational B-spline curve</td>
</tr>
<tr>
<td>128</td>
<td>0-9</td>
<td>rational B-spline surface</td>
</tr>
<tr>
<td>Type</td>
<td>Form</td>
<td>IGES Entity</td>
</tr>
<tr>
<td>------</td>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>130</td>
<td>0</td>
<td>offset curve</td>
</tr>
<tr>
<td>140</td>
<td>0</td>
<td>offset surface</td>
</tr>
<tr>
<td>141</td>
<td>0</td>
<td>boundary entity</td>
</tr>
<tr>
<td>142</td>
<td>0</td>
<td>curve on surface</td>
</tr>
<tr>
<td>143</td>
<td>0</td>
<td>boundary surface</td>
</tr>
<tr>
<td>144</td>
<td>0</td>
<td>trimmed surface</td>
</tr>
<tr>
<td>186</td>
<td>-1,0,1</td>
<td>Manifold Solid BRep Object (MSBO)</td>
</tr>
<tr>
<td>190</td>
<td>0,1</td>
<td>plane surface (1)</td>
</tr>
<tr>
<td>192</td>
<td>0,1</td>
<td>right circular cylindrical surface</td>
</tr>
<tr>
<td>194</td>
<td>0,1</td>
<td>right circular conical surface</td>
</tr>
<tr>
<td>196</td>
<td>0,1</td>
<td>spherical surface</td>
</tr>
<tr>
<td>198</td>
<td>0,1</td>
<td>toroidal surface</td>
</tr>
<tr>
<td>308</td>
<td>0</td>
<td>subfigure definition</td>
</tr>
<tr>
<td>402</td>
<td>7, 9</td>
<td>associativity instance</td>
</tr>
<tr>
<td>408</td>
<td>0</td>
<td>singular subfigure instance</td>
</tr>
<tr>
<td>502</td>
<td>1</td>
<td>vertex list</td>
</tr>
<tr>
<td>504</td>
<td>1</td>
<td>edge list</td>
</tr>
<tr>
<td>Type</td>
<td>Form</td>
<td>IGES Entity</td>
</tr>
<tr>
<td>------</td>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>508</td>
<td>0,1</td>
<td>loop</td>
</tr>
<tr>
<td>510</td>
<td>1</td>
<td>face</td>
</tr>
<tr>
<td>514</td>
<td>1,2</td>
<td>shell</td>
</tr>
</tbody>
</table>

(1) For type 190, 0 means unparameterized surface and 1 parameterized. The plane surface type is unbounded unless it is subordinate to another entity, such as the Bounded Surface Entity (type 143) or the Trimmed parametric Surface Entity (type 144), that references its bounding geometry.

**IGES levels**

The system adds all supported geometric IGES entities that are associated with IGES level $<n>$ to an Alias layer called LEVEL$<n>$.

For example, if a 126 B-spline entity directory entry indicates that it is on level 42, then it is added as Layer LEVEL42.

**JT**

The JT Open Program develops and supports the DirectModel format JT for the visualization of 3D models.

Autodesk DirectConnect supports the import of JT (up to V10) files into the Autodesk Alias, Autodesk Maya, Autodesk Showcase, Autodesk Opticore Studio, 3ds Max/3ds Max Design and VRED software. See installation information in Install Autodesk DirectConnect. (page 5)
Import JT files

1. Choose the menu path in your installed Autodesk software product:
   - **Autodesk Alias**: File > Open or File > Import > File
   - **Autodesk Maya**: File > Open Scene or File > Import
   - **Autodesk Showcase**: File > Import > Import Files
   - **Autodesk Opticore Studio**: File > Import
   - **3ds Max/3dsMax Design**: Application Menu > Import > Select File to Import dialog

2. In the browser, select a (*.jt) file.
3. Click **OK**, or **Open** to launch the translator and import the file into the scene.

Type of data imported

The software maintains the following information when importing JT files:
- Precise geometric data conversion
- Data organization (parent and child hierarchal data, visibility, and instances)
- Units
- Levels of detail (degrees of tessellation)
- Materials (brightness (shininess), ambient color, specular color, diffuse color, and emission color)
- Textures (embedded image files)
- XT BRep and JT BRep topology
- Coordinate systems or locators
- User defined and customized attributes and properties
NOTE

■ To locate this data in your Autodesk software, see Locations of Imported Data (page 1).

■ For Information about Alias options for data importation, see the Autodesk Alias Help.

Limitations

■ Import options are not available.

■ The software automatically excludes curve geometry and animation when importing a JT file.

NX

NX® is a solid modeling package based on the Parasolid kernel. The package contains many (mostly optional) modules, for example CAD, CAM, CAE, sheet metal applications, knowledge bases, quality control, and rapid prototyping. The file structure is binary.

Autodesk DirectConnect supports the import of NX files (UG V13.0 through NX 9.0) into the Autodesk Alias, Autodesk Maya, Autodesk Showcase, Autodesk Opticore Studio, 3ds Max/3ds Max Design, and VRED software. It supports the export of NX UG15.0*, NX 1.0, NX 3.0, NX 5.0, NX 7.0, and NX 8.0.

See installation information in the Install_DirectConnect.pdf document on the installation CD.
**Import NX files**

1. Choose the menu path in your installed Autodesk software product:

   - **Autodesk Alias**: File > Open or File > Import > File
   - **Autodesk Maya** (Windows version): File > Open Scene or File > Import
   - **Autodesk Showcase**: File > Import > Import Files
   - **Autodesk Opticore Studio**: File > Import
   - **3ds Max/3dsMax Design**: Application Menu > Import > Select File to Import dialog

2. In the browser, select an NX (version UG V13.0 to NX 9.0) part or assembly *.prt file.
   For information about import options in Alias, see the Autodesk Alias Help.

3. Click **OK**, or **Open** to launch the translator and import the file into the scene.

**Export NX files - Autodesk Alias, Autodesk Maya**

1. In your installed Autodesk software, choose the menu path:

   - **Autodesk Alias**: File > Save As
     - or File > Export > Active As
   - **Autodesk Maya**: File > Export all
     - or File > Export Selection

2. In Alias, on the **File Formats** menu, click **NX**.

3. In Maya, the file type is **UG_DCE**.
4. For options, see the Help in the Autodesk software.
5. Click Save.

See the Alias documentation for details about building a model for maximum compatibility between NX and Alias.

**Supported Alias geometry types for export to NX**

The translator does not support non-geometry entities, such as lights, cameras, textures, windows, and animations. The numbers in the table entries refer to Notes for NX entities following the table.

<table>
<thead>
<tr>
<th>Alias Entity</th>
<th>NX Entity</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conic (ellipse/hyperbola/parabola)</td>
<td>Bcurve</td>
</tr>
<tr>
<td>Conic</td>
<td>Curve</td>
</tr>
<tr>
<td>Circle</td>
<td>Circle</td>
</tr>
<tr>
<td>Line</td>
<td>Line</td>
</tr>
<tr>
<td>Curve</td>
<td>BCurve</td>
</tr>
<tr>
<td>Surface</td>
<td>BSurface (1), (2)</td>
</tr>
<tr>
<td>Trimmed Surface</td>
<td>Face (1), (2)</td>
</tr>
<tr>
<td>Plane</td>
<td>Bsurface (1), (2)</td>
</tr>
<tr>
<td>Shader</td>
<td>Colour Attribute (3)</td>
</tr>
<tr>
<td>Shell (Open)</td>
<td>Sheet Body</td>
</tr>
<tr>
<td>Shell (Closed)</td>
<td>Solid Body</td>
</tr>
<tr>
<td>Layer</td>
<td>Layer (4)</td>
</tr>
<tr>
<td>Category</td>
<td>Category</td>
</tr>
</tbody>
</table>

Notes for NX entities:

1. A plane is determined by three points.
2. A surface is determined by four points.
3. The attributes for these entities are set to default values.
4. Layer properties are applied to this entity.
Notes for NX entities

(1) NX cannot have free-standing surfaces, so it maps all surfaces to faces which must be attached to a sheet body.

(2) Splits appear in surfaces that have internal discontinuities at the discontinuities.

(3) Mapped as a Display Attribute of the mapped surface or shell.

(4) Layer name is not mapped.

Supported Alias NX entities for Alias import

<table>
<thead>
<tr>
<th>NX Entity Objects</th>
<th>Alias Entity</th>
</tr>
</thead>
<tbody>
<tr>
<td>BSurface</td>
<td>Surface</td>
</tr>
<tr>
<td>Bounded Plane</td>
<td>Surface</td>
</tr>
<tr>
<td>Cylindrical Surface</td>
<td>Surface</td>
</tr>
<tr>
<td>Conical Surface</td>
<td>Surface</td>
</tr>
<tr>
<td>Tabulated Cylinder</td>
<td>Surface</td>
</tr>
<tr>
<td>Rules Surface</td>
<td>Surface</td>
</tr>
<tr>
<td>Blended Face Surface</td>
<td>Surface</td>
</tr>
<tr>
<td>Surface of Revolution</td>
<td>Surface</td>
</tr>
<tr>
<td>Offset Surface</td>
<td>Surface</td>
</tr>
<tr>
<td>Sculptured Surface</td>
<td>Surface</td>
</tr>
<tr>
<td>BCurve</td>
<td>Curve</td>
</tr>
<tr>
<td>Line</td>
<td>Line (Curve)</td>
</tr>
<tr>
<td>NX Entity Objects</td>
<td>Alias Entity</td>
</tr>
<tr>
<td>-------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Bcurve</td>
<td>Curve</td>
</tr>
<tr>
<td>Point</td>
<td>Point (Curve) (1)</td>
</tr>
<tr>
<td>Sheet Body</td>
<td>Shell (Open) (2)</td>
</tr>
<tr>
<td>Assembly</td>
<td>Groups/Instance (3)</td>
</tr>
<tr>
<td>Layer</td>
<td>Layer</td>
</tr>
<tr>
<td>Category</td>
<td>Category</td>
</tr>
<tr>
<td>Space points</td>
<td>Space points</td>
</tr>
<tr>
<td>Annotation leaders (locators of type annotator in .wire files)</td>
<td>Annotation leaders (locators of type annotator in .wire files)</td>
</tr>
</tbody>
</table>

**Notes for Alias NX (object) entities**

1. An NX point converts to a degree 1 curve composed of two coincident points. On export to NX, this construction converts back to an NX point.
2. If the sheet body only points to one face, then Alias converts the face to a trimmed surface.
3. This is a one-way mapping. Assemblies cannot be exported.
4. Added as blind data. Can be re-exported.

**Types of data imported**

We support the import of the following types of NX geometry, and attributes such as name, color, layer, and visibility.

- Point
- Line
- BCurve
- Circle
- Ellipse

30 | Chapter 3 Translator Details
- Parabola
- Hyperbola
- Surface Parameter Curve
- Trimmed Curve
- Intersection Curve
- BSurface
- Planar Surface
- Spherical Surface
- Cylindrical Surface
- Conical Surface
- Surface of Revolution
- Spun Surface
- Offset Surface
- Ruled Surface
- Swept Surface
- Toroidal Surface
- Blended Edge Surface
- Blended Bound Surface
- Facet
- Sheet Body
- Solid Body
- Part
- Instance
- Assembly
- Category
- Coordinate systems or locators
Open Inventor and Cosmo

Open Inventor™ is a 3D file format from Silicon Graphics Inc., with no relation to Autodesk Inventor software.

Autodesk DirectConnect supports the import of Open Inventor ASCII or binary (*.iv) files, or Cosmo 3D™ scene binary (*.csb) files into the Autodesk Alias, Autodesk Maya, Autodesk Showcase, and Autodesk Opticore Studio software. See installation information in Install Autodesk DirectConnect. (page 5).

Import Open Inventor or Cosmo files

1 Choose the menu path in your installed Autodesk software product:

   Autodesk Alias           File > Open or File > Import > File
   Autodesk Maya (Windows version) File > Open Scene or File > Import
   Autodesk Showcase        File > Import > Import Files
   Autodesk Opticore Studio File > Import

2 Browse to and select an Open Inventor (*.iv) or Cosmo (*.csb) file.
3 Click OK, or Open.
   The translator launches and imports the file.
Type of data imported

The software imports polygons and NURBS for these file formats, and maintains the following information on import:

- Data organization (parent, child, and groups)
- Units
- Materials
- Textures
- Polygonal Shapes
- Transformation nodes

**NOTE** To locate this data in your Autodesk software, see Locations of Imported Data (page 45).

Limitations

When importing Open Inventor files, the system automatically excludes lines, cameras, lights, manipulators, tolerances, and animation.
Pro/ENGINEER

Pro/ENGINEER® is a computer-aided design software application.

Autodesk DirectConnect supports the import of Pro/ENGINEER (Wildfire® R5 or lower) and Creo (up to V2) part, assembly, or PTC® Granite® (Release 9 or lower) files (*.prt, *.asm, *.g, *.neu) into the Autodesk Alias, Autodesk Maya, Autodesk Opticore Studio, and 3ds Max/3ds Max Design software. See installation information in Install Autodesk DirectConnect. (page 5)

NOTE For information about additional software setup for Autodesk Alias, see the Autodesk Alias Help.

Import Pro/ENGINEER files

1. Choose the menu path in your installed Autodesk software product:

   Autodesk Alias  
   File > Open or File > Import > File

   Autodesk Maya (Windows version)  
   File > Open Scene or File > Import

   Autodesk Showcase  
   File > Import > Import Files
2 Select a Pro/ENGINEER part(*.prt), assembly (*.asm), Granite (*,.g), or neutral (.neu) file.
3 Click **OK**, or **Open** to launch the translator and import the file.

**NOTE** To maintain the original positioning and orientation of part files in your scene, import the assembly file. Importing part files before the assembly file positions all of them at the origin (0,0,0) and removes the original positioning.

**Type of data imported**

The software imports NURBS for this file format and maintains the following data on import:
- Precise geometric surface and topology information
- Data organization
- Tolerances and units
- Layers and colors

**NOTE**
- To locate this data in your Autodesk software, see Locations of Imported Data (page 45).
- For information about options in Alias for data importation, see the Autodesk Alias Help.

**Limitations**

- The software changes node names based on geometry, assembly, or part names.
- When importing a Pro/ENGINEER file, the software automatically excludes construction history, lines, and animation.
- Granite does not support layers or curves.
SolidWorks® is a computer-aided design software application.

Autodesk DirectConnect supports the import of SolidWorks part *.sldprt and assembly *.slidasm files into the Autodesk Alias, Autodesk Maya, Autodesk Showcase, Autodesk Opticore Studio, and 3ds Max/3ds Max Design software.

**NOTE** For information about additional software setup for Autodesk Alias, please see the *Autodesk Alias Data Transfer* reference book and the Autodesk Alias Help.

**Import SolidWorks files**

**NOTE**

Before you can import SolidWorks files, purchase, install, and license SolidWorks 2005 through 2014 on the same machine, and have it running. See installation information in *Install Autodesk DirectConnect*. (page 5)

1. Choose the menu path in your installed Autodesk software product:

   - **Autodesk Alias**  
     File > Open or File > Import > File
   - **Autodesk Maya (Windows version)**  
     File > Open Scene or File > Import
   - **Autodesk Showcase**  
     File > Import > Import Files
   - **Autodesk Opticore Studio**  
     File > Import
3ds Max/3dsMax Design

Application Menu > Import > Select File to Import dialog

2 Select a SolidWorks part (*.sldprt) or assembly *.sldasm file. If you cannot see the files, start the SolidWorks software, minimize its window, and then try again to open the files.

3 Click OK, or Open to launch the translator and import the file into the scene.

NOTE To maintain the original positioning and orientation of part files in your scene, import the assembly file. Importing part files before the assembly file positions all of them at the origin (0,0,0) and removes the original positioning.

Type of data imported

The software imports NURBS for this file format and maintains the following information on import:

- Precise geometric surface and topology information
- Data organization
- Tolerances and unit
- Colors

NOTE

- To locate this data in your Autodesk software, see Locations of Imported Data (page 45).
- For information about Alias options for data importation, see the Autodesk Alias Help.

Limitations

When importing SolidWorks files, the software automatically excludes construction history, lines, and animation.
Standard for the Exchange of Product Data (STEP) is an ISO standard exchange format that multiple programs can recognize. It is used for transferring graphics data between CAD/CAM systems.

Autodesk DirectConnect supports the import of STEP (*.stp or *.step) files into the Autodesk Alias, Autodesk Maya, Autodesk Showcase, Autodesk Opticore Studio, and 3ds Max/3ds Max Design software. See installation information in Install Autodesk DirectConnect (page 5).

Import STEP files

1. Choose the menu path in your installed Autodesk software product:
   
   **Autodesk Alias**  
   File > Open or File > Import > File

   **Autodesk Maya (Windows version)**  
   File > Open Scene or File > Import

   **Autodesk Showcase**  
   File > Import > Import Files

   **Autodesk Opticore Studio**  
   File > Import
In the browser, select a native STEP (*.stp or *.step) file.

Click **OK**, or **Open** to launch the translator and import the file into the scene.

**Types of data imported**

The software imports NURBS for this file format and maintains the following information on import:

- Precise geometric surface and topology information (ISO 10303:42)
- Data organization (layers)
- Tolerances and units
- Colors

**NOTE**

- To locate this data in your Autodesk software, see [Locations of Imported Data](#) (page 45).
- For information about Alias options for data importation, see the Autodesk Alias Help.

**Export STEP files**

To export STEP files from the CAD software, use AP203 or AP214 specifications.
STL

STL is a file format native to the stereolithography CAD software created by 3D Systems. Multiple software packages support the STL file format.

Autodesk DirectConnect supports the import of STL files into the Autodesk Alias, Autodesk Maya, Autodesk Showcase, and Autodesk Opticore Studio software, and the export of STL files from the Autodesk Alias and Autodesk Maya software. See installation information in Install Autodesk DirectConnect. (page 5).

Import STL files

1. Choose the menu path in your installed Autodesk software product:

   Autodesk Alias       File > Open or File > Import > File

   Autodesk Maya (Windows version)   File > Open Scene or File > Import

   Autodesk Showcase      File > Import > Import Files

   Autodesk Opticore Studio File > Import

2. In the browser, select a native .stl (Stereolithography) file.
3 Click **OK**, or **Open** to launch the translator and import the file into the scene.

**Type of files imported**

We support ASCII and binary STL (color STL) files.

**NOTE** To locate this data in your Autodesk software, see Locations of Imported Data (page 45).

**Export STL files**

1 In your Autodesk software, choose the appropriate menu item:

   - **Autodesk Alias**
     - File > Export > Rapid Prototype
   - **Autodesk Maya (Windows version)**
     - File > Export All
     - or File > Export Selection

2 In Maya, the file type is **STL_DCE**, and you can specify the file type as either ASCII or binary.

   - Click **OK**.
   - In Alias, on the **File Format** menu, click **STL**. You can also specify tolerance levels used in the export of the file.

3 Pick the meshes or shell to export, then click **Accept**.

4 Adjust settings, if necessary, and click **Update**.

5 Click **Accept**.

6 In the **Object name** box (Windows), or **Save As** box (Mac), enter a name for the file, and click **Save**.
ZPR

ZPrint CAD format (ZPR™) is a proprietary file format developed by Z Corporation® and used with ZPrint and ZEdit for printing on high definition color 3D printers.

Autodesk DirectConnect supports the export of ZPR (*.zpr) files to use in the Autodesk rapid prototyping solution in the Autodesk Alias, Autodesk Maya, Autodesk Showcase, and Autodesk Opticore Studio software. See installation information in Install Autodesk DirectConnect. (page 5)

Export ZPR files using the output command

1. Select a file to export as a ZPR file.
2. Choose File > Export > Rapid Prototype.
Depending on the entity selected for export, such as a shell, additional setup can be required. For information about additional setup options, see the Autodesk Alias Help.

4 Pick the meshes or shell to export, then click Accept.
5 Adjust settings, if necessary, and click Update.
6 Click Accept.

Types of data exported for ZPR

- Triangle meshes with simple colors.
- Textures for use with ZEdit and Zprint software for rapid prototyping.
Locations of Imported Data

Autodesk Alias Data

<table>
<thead>
<tr>
<th>Data Organization</th>
<th>Tolerances and Units</th>
<th>Colors (Shaders)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parts and assembly information displays in the Windows &gt; Information &gt; Layer Categories window.</td>
<td>View unit settings at Preferences &gt; Construction Options.</td>
<td>Colors are visible in the Render &gt; Multi-lister &gt; Shaders window.</td>
</tr>
</tbody>
</table>

For information about these settings, menu items, and options, see the Autodesk® Alias® Help.
Autodesk Maya Data

**Data Organization**

To view layer information, display the Layer Editor: click **Display > UI Elements > Channel Box/Layer Editor** or display the Relationship Editor: click **Window > Relationship Editors > Display Layers**.

To view assembly definition and assembly reference nodes, see **Window > Outliner** or the node **Attribute Editor**.

**Tolerances and Units**

View unit settings at **Window > Settings/Preferences > Preferences > Settings**.

Change the **Working Units** and **Tolerance** settings.

**Colors (Shaders)**

Colors are imported as shaders and are visible at **Window > Rendering Editors > Hypershade**.

For more information about these settings and menu items, see the Autodesk® Maya® Help.

---

Autodesk Showcase Data

**Data Organization**

View Layers, parts, and assembly hierarchies in the Organizer window (**Edit > Organizer**). This window shows the original file hierarchy. You can create your own arrangements of objects. You can view and change the state of objects to visible, hidden, or deleted.

**Tolerances and Units**

Change unit settings in the **Import Status** window (**File > Import > Import Status Window**). For more information, see the Showcase documentation.

Change tessellation quality in the **Import Status** window. For more information, see the Showcase documentation.

To adjust the Level of Detail (LOD) for models imported into Showcase, click **File > Settings > Performance and Quality**. To set Showcase to determine LOD, select **Automatic quality control**.

**Colors (Shaders)**

Colors import as materials, and are visible from **Appearance > Material Properties**.

46 | Chapter 4  Locations of Imported Data
For more information about these settings and menu items, see the Autodesk® Showcase® Help.

## Autodesk Opticore Studio Data

<table>
<thead>
<tr>
<th>Data Organization</th>
<th>Tolerances and Units</th>
<th>Colors (Shaders)</th>
</tr>
</thead>
<tbody>
<tr>
<td>View the node structure in the Scene Graph Editor, in the Window &gt; Scene Graph Editor menu. It opens by default.</td>
<td>There are no units in Studio. All imported data is considered the same unit. Set tolerances for tessellation in the File &gt; Preferences dialog box, GeomX tab. <strong>NOTE</strong> GeomX is not available until you load the GeomX module in the Modules tab (in the same dialog box) and restart Studio. Set tessellation tolerances on the GeomX tab, Import tessellation section. To retesselate, use the Window &gt; GeomX &gt; Tessellate dialog box, and enter new settings.</td>
<td>Colors can be shaders or appearances. In the Scene Graph Editor, in scenegraph, all colors are visible in the appearance field of a shape node.Appearances are visible only in the Scene Graph Editor. Shaders are visible in both the Scene Graph Editor and through the Windows &gt; Shader List dialog box.</td>
</tr>
</tbody>
</table>
Glossary

Glossary terms

ASM (.asm)
A file format used by Pro/ENGINEER to represent an assembly.

assembly
An organizational file that fits together a collection of manufactured parts into a complete model.

BSD license
The Berkeley Software Distribution license for redistribution and use of source code.

CATIA ➤ V4
CATIA V4 is computer-aided design software from Dassault Systèmes. Autodesk DirectConnect allows the exchange of 3D model data from CATIA V4, using .model, .session, .exp, .dlv, and .dlv3 files.

CATIA ➤ V5
CATIA V5 is computer-aided design software from Dassault Systèmes. Autodesk DirectConnect allows the exchange of 3D model data from CATIA V5, using the native CATIA part (.CATPart), product (.CATProduct), and (.cgr) files.

CGR ➤ (.cgr)
CATIA Graphical Representation (.cgr) is the triangulated format used by CATIA V5.
**Cosmo™**
A legacy 3D file format from Silicon Graphics Inc. using efficient binary compression and *.csb (Cosmo scene binary) files.

**CSB (.csb)**
Cosmo 3D™ scene binary (*.csb) files.

**DLV (.dlv)**
A file format used by CATIA V4 computer-aided design software from Dassault Systèmes.

**DRAW (DR)**
A two-dimensional entity defined in the drafting and detailing world.

**DWF™**
Design Web Format, a file format developed by Autodesk for web viewing and printing.

**DWG™**
AutoCAD drawing file) A file format used by Autodesk AutoCAD software that contains lines, curves, and 3D data.

**DXF™**
(Drawing eXchange File) A file exchange format containing ASCII code and binary representations of the objects in a DWG file.

**G (.g)**
A file format used by Pro/ENGINEER PTC Granite for import into the Autodesk products that DirectConnect supports.

**Granite ➤**
A CAD technology platform for design collaboration using solid models.

**IAM (.iam)**
A file format in the Autodesk Inventor software represent an assembly.

**IGES**
(Initial Graphics Exchange Specification) A file format for transferring graphics data between CAD/CAM systems. A neutral file format that can be imported into any number of CAD or modeling packages.
IPT (.ipt)
A file format in the Autodesk Inventor software to represent a part.

IV (.iv)
A file format in the Open Inventor software.

JT
JT is a DirectModel file format that is developed and supported by the JT Open Program for the visualization of 3D models.

NX ➤
NX is a solid modeling package based on the Parasolid kernel. The package contains many (mostly optional) modules: for example, CAD, CAM, CAE, sheet metal applications, knowledge bases, quality control, and rapid prototyping. The files structure is binary.

Open Inventor™
Open Inventor is a legacy 3D file format from Silicon Graphics, Inc. Open Inventor is not related to Autodesk Inventor software. Open Inventor is an object-oriented 3D toolkit that describes complete 3D scenes, which can be made interactive and that are optimized for OpenGL. It is an ASCII or binary file format.

PCRE
The Perl-compatible regular expressions is a library of functions to support regular expressions, with syntax and semantics as close as possible to the syntax and semantics in the Perl 5 language.

Pro/ENGINEER ➤
A solid modeling CAD/CAM/CAE software product from Parametric Technology Corporation that requires positional construction tolerances.

PRT (.prt)
A file format used by NX to represent a part or assembly file.

SLDASM (.sldasm)
A file format used by SolidWorks to represent an assembly file.

SLDPRT (.sldprt)
A file format used by SolidWorks to represent a part file.
**SolidWorks**

A solid modeling CAD/CAM/CAE software product from SolidWorks Corporation that requires positional construction tolerances.

**SPACE (SP)**

A three-dimensional entity defined in the 3D modeling world.

**SPF**

Alias SPF (Studio Packet File) is a native file format used by Autodesk Alias software, with the extension .wire.

**STEP (.step)**

An international standard for the exchange of geometric product definitions. STEP formats that are relevant to Autodesk products are AP203 (general mechanical CAD) and AP214 (automotive CAD).

**STL**

An STL (StereoLithography) file is a triangular representation of 3D surface geometry. The surface is tessellated, or broken down logically into a series of small triangles (facets). A perpendicular direction and three points representing the vertices (corners) of the triangle describe each facet.

**STP (.stp)**

A file format used in STEP (Standard for the Exchange of Product Data) for transferring graphics data between CAD/CAM systems.

**V3Rx**

A file format generated by a version of CATIA that is older than V4.

**ZPR**

ZPrint CAD format (ZPR) is a proprietary file format developed by Z Corporation. It is used with ZPrint and ZEdit for printing on high definition color 3D printers. Autodesk Direct lets you export files in ZPR (*.zpr) format to use in the Autodesk Rapid Prototyping solution.
Index

A

Autodesk Alias
  locate imported data 45
  view unit settings 45
  visible colors 45
Autodesk AutoCAD drawing files 17
Autodesk DirectConnect 1
  improvements
    install 5
    supported platforms 5
    supported products 2
    supported translators 2
Autodesk Inventor
  file formats 8
  translator 8
Autodesk Maya
  imported colors 46
  locate imported data 46
  unit settings 46
Autodesk Opticore Studio
  imported colors 47
  locate imported data 47
  tessellation tolerances 47
Autodesk Showcase
  imported colors 46
  locate imported data 46
  unit settings 46

C

CATIA V4
  file types 10
  translator 10
CATIA V5
  file types 12
  translator 12
Cosmo
  file types 32
  translator 32

D

Design Web Format 15
Drawing eXchange File 17
DWF translator 15
DWG DXF translators 17

F

file formats
  .cgr, .CATProduct, .CATPart 12
  .dwf 15
  .dwg, .dxf 17
  .iam 8
  .iges, .igs 19
  .ipt 8
  .iv, .csb 32
  .jt 24
  .model, .mdl, .session, .exp, .dlv 10
  .prt 26
  .prt, .asm, .g, .neu 34
  .sldprt, .sldasm 36
  .stl 40
  .stp, .step 38
  .zpr 42

I

IGES (Initial Graphics Exchange Spec.)
  Alias import options 19
  file types 19
  levels 19
  log files 19
  translator 19
improvements in Directconnect
install Autodesk DirectConnect 5
<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>J</td>
<td>JT file types</td>
<td>24</td>
</tr>
<tr>
<td></td>
<td>translator</td>
<td>24</td>
</tr>
<tr>
<td>N</td>
<td>NX file types</td>
<td>26</td>
</tr>
<tr>
<td></td>
<td>translator</td>
<td>26</td>
</tr>
<tr>
<td>O</td>
<td>Open Inventor file types</td>
<td>32</td>
</tr>
<tr>
<td></td>
<td>translator</td>
<td>32</td>
</tr>
<tr>
<td>P</td>
<td>Pro/ENGINEER file types</td>
<td>34</td>
</tr>
<tr>
<td></td>
<td>translator</td>
<td>34</td>
</tr>
<tr>
<td>S</td>
<td>SolidWorks file types</td>
<td>36</td>
</tr>
<tr>
<td></td>
<td>translator</td>
<td>36</td>
</tr>
<tr>
<td></td>
<td>STEP file types</td>
<td>38</td>
</tr>
<tr>
<td></td>
<td>translator</td>
<td>38</td>
</tr>
<tr>
<td></td>
<td>STL file types</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td>translator</td>
<td>40</td>
</tr>
</tbody>
</table>

- **support platforms**: 5
- **supported products and translators**: 2
- **system requirements**: 5

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>T</td>
<td>trademarks</td>
<td></td>
</tr>
<tr>
<td></td>
<td>translators</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Autodesk Inventor</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CATIA V4</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td>CATIA V5</td>
<td>12</td>
</tr>
<tr>
<td></td>
<td>Cosmo</td>
<td>32</td>
</tr>
<tr>
<td></td>
<td>DirectConnect</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>DWF</td>
<td>15</td>
</tr>
<tr>
<td></td>
<td>DWG DXF</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>IGES</td>
<td>19</td>
</tr>
<tr>
<td></td>
<td>JT</td>
<td>24</td>
</tr>
<tr>
<td></td>
<td>NX</td>
<td>26</td>
</tr>
<tr>
<td></td>
<td>Open Inventor</td>
<td>32</td>
</tr>
<tr>
<td></td>
<td>Pro/ENGINEER</td>
<td>34</td>
</tr>
<tr>
<td></td>
<td>SolidWorks</td>
<td>36</td>
</tr>
<tr>
<td></td>
<td>STEP</td>
<td>38</td>
</tr>
<tr>
<td></td>
<td>STL</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td>ZPR</td>
<td>42</td>
</tr>
</tbody>
</table>

- **Windows platform**: 5

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Z</td>
<td>ZPR file types</td>
<td>42</td>
</tr>
<tr>
<td></td>
<td>translator</td>
<td>42</td>
</tr>
<tr>
<td></td>
<td>ZPrint CAD format</td>
<td>42</td>
</tr>
</tbody>
</table>