Contents

Chapter 1  New Features in This Release  .................................................. 1
  New Features for Getting Started ...................................................... 1
  New Features for Drawing Electrical Systems ................................... 1
  New Features for Drawing Piping Systems ........................................ 2
  New Features for Drawing Radiant Heating Systems ........................... 2
  New Features for Customizing Catalogs ............................................ 3
  New Features for Customizing Display .............................................. 3
  New Features for Building Systems .................................................. 3

Chapter 2  Moving from AutoCAD to AutoCAD MEP ................................. 5
  AutoCAD to AutoCAD MEP Task Comparisons .................................... 5
  Creating Building Systems ............................................................... 6
    AutoCAD MEP Workspaces .......................................................... 6
    Insertion Tools .............................................................................. 7
    Layer Keying ................................................................................. 7
  Modifying Building Systems ............................................................. 7
    Associative Movement .................................................................... 7
    Grips ............................................................................................. 8
    Snaps ............................................................................................ 11
  Automating Design Tasks .................................................................. 12
    Domain-Specific Ribbons ............................................................... 12
    Auto Layout ................................................................................... 12
    Interference Detection .................................................................... 12
    Connectivity Checks ....................................................................... 13
  Working With Sizing and Calculation Tools ........................................ 13
    Sizing Tools .................................................................................. 13
    Electrical Circuit Manager ............................................................. 14
    Plumbing Tools ............................................................................... 14
    Pipe Routing Preferences .............................................................. 14
    Solution Tips .................................................................................. 15
  Creating Accurate Construction Documents ....................................... 15
  Section Views ................................................................................... 15
<table>
<thead>
<tr>
<th>Chapter 3 Getting Started</th>
<th>27</th>
</tr>
</thead>
<tbody>
<tr>
<td>About AutoCAD MEP</td>
<td>27</td>
</tr>
<tr>
<td>AutoCAD MEP Workflow</td>
<td>28</td>
</tr>
<tr>
<td>Intelligent Objects</td>
<td>28</td>
</tr>
<tr>
<td>Location of Part Catalogs</td>
<td>29</td>
</tr>
<tr>
<td>Analysis Tools</td>
<td>30</td>
</tr>
<tr>
<td>Project Management Tools</td>
<td>30</td>
</tr>
<tr>
<td>Contacting Autodesk</td>
<td>30</td>
</tr>
<tr>
<td>Getting Help</td>
<td>31</td>
</tr>
<tr>
<td>Guides</td>
<td>31</td>
</tr>
<tr>
<td>Tutorials</td>
<td>32</td>
</tr>
<tr>
<td>Training</td>
<td>32</td>
</tr>
<tr>
<td>Classes</td>
<td>32</td>
</tr>
<tr>
<td>Courseware</td>
<td>32</td>
</tr>
<tr>
<td>E-Learning</td>
<td>32</td>
</tr>
<tr>
<td>Certification</td>
<td>33</td>
</tr>
<tr>
<td>Discussion Groups</td>
<td>33</td>
</tr>
<tr>
<td>Additional Resources</td>
<td>33</td>
</tr>
<tr>
<td>Updating AutoCAD MEP</td>
<td>33</td>
</tr>
<tr>
<td>The AutoCAD MEP 2010 Drawing Domain</td>
<td>33</td>
</tr>
<tr>
<td>Workspace Fundamentals</td>
<td>35</td>
</tr>
<tr>
<td>Default Workspaces in AutoCAD MEP</td>
<td>36</td>
</tr>
<tr>
<td>Creating Workspaces</td>
<td>37</td>
</tr>
<tr>
<td>Switching Workspaces</td>
<td>37</td>
</tr>
<tr>
<td>Workspace Settings</td>
<td>37</td>
</tr>
<tr>
<td>Workspace Components</td>
<td>38</td>
</tr>
<tr>
<td>Ribbon</td>
<td>39</td>
</tr>
<tr>
<td>Displaying the Ribbon</td>
<td>39</td>
</tr>
<tr>
<td>Using the Ribbon</td>
<td>39</td>
</tr>
<tr>
<td>Locating Commands in the Workspace</td>
<td>41</td>
</tr>
<tr>
<td>Creating a Duct System</td>
<td>194</td>
</tr>
<tr>
<td>------------------------------------------------------------</td>
<td>-----</td>
</tr>
<tr>
<td>Configuring Duct System Definitions</td>
<td>181</td>
</tr>
<tr>
<td>Creating a Duct System Definition</td>
<td>181</td>
</tr>
<tr>
<td>Specifying a Calculation Method for Duct Sizing</td>
<td>182</td>
</tr>
<tr>
<td>Configuring the Display of Ducts and Fittings</td>
<td>183</td>
</tr>
<tr>
<td>Using Spaces for Load Analysis</td>
<td>183</td>
</tr>
<tr>
<td>Configuring Space Styles</td>
<td>183</td>
</tr>
<tr>
<td>Configuring Zone Styles</td>
<td>185</td>
</tr>
<tr>
<td>Adding Spaces to a Floor Plan</td>
<td>185</td>
</tr>
<tr>
<td>Adding Engineering Data to Spaces</td>
<td>187</td>
</tr>
<tr>
<td>Attaching Property Sets to Zones</td>
<td>189</td>
</tr>
<tr>
<td>Attaching Spaces to Zones</td>
<td>189</td>
</tr>
<tr>
<td>Exporting Zones for Load Analysis</td>
<td>190</td>
</tr>
<tr>
<td>Reviewing Spaces and Zones</td>
<td>191</td>
</tr>
<tr>
<td>Importing Load Analysis Results</td>
<td>192</td>
</tr>
<tr>
<td>Using Space and Zone Calculated Data</td>
<td>193</td>
</tr>
<tr>
<td>Modifying Components Using Grips</td>
<td>195</td>
</tr>
<tr>
<td>Selecting Components</td>
<td>199</td>
</tr>
<tr>
<td>About Associative Movement</td>
<td>219</td>
</tr>
<tr>
<td>Adding HVAC Equipment</td>
<td>194</td>
</tr>
<tr>
<td>Adding HVAC Equipment</td>
<td>195</td>
</tr>
<tr>
<td>Adding Parts In-Line to Ducts</td>
<td>195</td>
</tr>
<tr>
<td>Configuring Mechanical Parts for Analysis</td>
<td>196</td>
</tr>
<tr>
<td>Adding Duct</td>
<td>196</td>
</tr>
<tr>
<td>Drawing a Duct Run</td>
<td>196</td>
</tr>
<tr>
<td>Adding Duct Using Grips</td>
<td>200</td>
</tr>
<tr>
<td>Drawing a Vertical Duct Run</td>
<td>201</td>
</tr>
<tr>
<td>Drawing 1-Line Duct</td>
<td>201</td>
</tr>
<tr>
<td>Calculating Duct Sizes for a Duct System</td>
<td>203</td>
</tr>
<tr>
<td>Adding a Duct Fitting Manually</td>
<td>205</td>
</tr>
<tr>
<td>Drawing Flexible Duct</td>
<td>206</td>
</tr>
<tr>
<td>Adding a Parallel Duct Run</td>
<td>207</td>
</tr>
<tr>
<td>Offsetting Duct from Existing Geometry</td>
<td>208</td>
</tr>
<tr>
<td>Drawing Sloped Duct</td>
<td>208</td>
</tr>
<tr>
<td>Using the Elevation Lock</td>
<td>208</td>
</tr>
<tr>
<td>Connecting Ducts Through Referenced Drawings</td>
<td>209</td>
</tr>
<tr>
<td>Adding a Takeoff to a Duct</td>
<td>211</td>
</tr>
<tr>
<td>Converting a Line to Duct</td>
<td>213</td>
</tr>
<tr>
<td>Converting a Polyline to Flexible Duct</td>
<td>213</td>
</tr>
<tr>
<td>Adding Turning Vanes to Fittings</td>
<td>214</td>
</tr>
<tr>
<td>Creating a Custom Duct Fitting</td>
<td>215</td>
</tr>
<tr>
<td>Using the Part Size Not Found Dialog</td>
<td>217</td>
</tr>
<tr>
<td>Annotating a Duct System</td>
<td>218</td>
</tr>
<tr>
<td>Adding a Label to a Duct</td>
<td>218</td>
</tr>
<tr>
<td>Adding a Hatching Pattern to Identify a Duct System</td>
<td>219</td>
</tr>
<tr>
<td>Modifying a Duct System</td>
<td>219</td>
</tr>
<tr>
<td>About Associative Movement</td>
<td>219</td>
</tr>
<tr>
<td>Selecting Components</td>
<td>219</td>
</tr>
<tr>
<td>Modifying Components Using Grips</td>
<td>220</td>
</tr>
<tr>
<td>Moving Duct Components</td>
<td>221</td>
</tr>
<tr>
<td>Modifying the Elevation of HVAC Parts and Ducts</td>
<td>222</td>
</tr>
<tr>
<td>Modifying the Length of Ducts</td>
<td>225</td>
</tr>
<tr>
<td>Rotating Duct Components</td>
<td>228</td>
</tr>
<tr>
<td>Modifying HVAC Equipment</td>
<td>230</td>
</tr>
<tr>
<td>Modifying HVAC MvPart Location</td>
<td>230</td>
</tr>
<tr>
<td>Modifying HVAC Parts</td>
<td>231</td>
</tr>
<tr>
<td>Changing a Part to Match Another Part</td>
<td>232</td>
</tr>
<tr>
<td>Modifying the Flow Value Assigned to a Part</td>
<td>232</td>
</tr>
<tr>
<td>Modifying the System Assigned to a Part Connection</td>
<td>232</td>
</tr>
</tbody>
</table>
## Chapter 7  Drawing Piping Systems  

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modifying Duct</td>
<td>232</td>
</tr>
<tr>
<td>Modifying the Size or Shape of a Duct</td>
<td>233</td>
</tr>
<tr>
<td>Modifying Duct Using AutoCAD Commands</td>
<td>234</td>
</tr>
<tr>
<td>Breaking or Merging Duct</td>
<td>234</td>
</tr>
<tr>
<td>Locking the Size of a Duct or Fitting</td>
<td>235</td>
</tr>
<tr>
<td>Modifying the System Assigned to a Duct</td>
<td>235</td>
</tr>
<tr>
<td>Modifying a Duct Fitting</td>
<td>235</td>
</tr>
<tr>
<td>Modifying the Layout of Flexible Duct</td>
<td>236</td>
</tr>
<tr>
<td>Moving an Off-Center Takeoff</td>
<td>237</td>
</tr>
<tr>
<td>Modifying a Custom Fitting</td>
<td>237</td>
</tr>
<tr>
<td>Modifying Turning Vanes</td>
<td>238</td>
</tr>
<tr>
<td>Modifying Insulation or Lining</td>
<td>238</td>
</tr>
<tr>
<td>Checking Connectivity in a Duct System</td>
<td>239</td>
</tr>
<tr>
<td>Modifying Annotation</td>
<td>239</td>
</tr>
<tr>
<td>Modifying a Label</td>
<td>239</td>
</tr>
<tr>
<td>Calculating Duct Sizes Using External Tools</td>
<td>241</td>
</tr>
<tr>
<td>Specifying ASHRAE Fitting Types</td>
<td>242</td>
</tr>
<tr>
<td>Exporting Duct System Data</td>
<td>242</td>
</tr>
<tr>
<td>Importing Optimized System Data</td>
<td>244</td>
</tr>
<tr>
<td>Resizing a System</td>
<td>244</td>
</tr>
<tr>
<td>Creating Duct System Construction Documents</td>
<td>245</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modifying Duct</td>
<td>232</td>
</tr>
<tr>
<td>Male-Female Fittings</td>
<td>267</td>
</tr>
<tr>
<td>Connector Assignments</td>
<td>265</td>
</tr>
<tr>
<td>Connection Types for Pipe and Pipe Fittings</td>
<td>266</td>
</tr>
<tr>
<td>Male-Female Fittings</td>
<td>266</td>
</tr>
<tr>
<td>Pipe Joints</td>
<td>268</td>
</tr>
<tr>
<td>Pipe Length</td>
<td>268</td>
</tr>
<tr>
<td>Pipe Snaps</td>
<td>270</td>
</tr>
<tr>
<td>Pipe Elevation Lock</td>
<td>270</td>
</tr>
<tr>
<td>Pipe Grips</td>
<td>271</td>
</tr>
<tr>
<td>Configuring Pipe System Settings</td>
<td>274</td>
</tr>
<tr>
<td>Configuring Routing Preferences</td>
<td>279</td>
</tr>
<tr>
<td>Creating or Copying a Routing Preference</td>
<td>279</td>
</tr>
<tr>
<td>Configuring Properties for a Routing Preference</td>
<td>280</td>
</tr>
<tr>
<td>Configuring Size Ranges</td>
<td>280</td>
</tr>
<tr>
<td>Deleting a Routing Preference</td>
<td>281</td>
</tr>
<tr>
<td>Configuring System Definitions</td>
<td>281</td>
</tr>
<tr>
<td>Creating a System Definition</td>
<td>281</td>
</tr>
</tbody>
</table>
## Chapter 8 Drawing Radiant Heating Systems

- Radiant Heating Systems Overview .............................................................. 335
- Creating Radiator Parts .................................................................................. 336
- Using a Calculation Program to Add Radiators ............................................. 337
  - Adding Radiators Using Calculated Data ...................................................... 338
  - Rules About Updating Existing Radiators .................................................... 339
  - Exporting Drawing Information for Analysis ............................................... 340
- Designing Radiant Heating Systems ............................................................... 340
  - Adding a Radiator MvPart ........................................................................... 341
  - Modifying a Radiator MvPart ....................................................................... 343
- Radiator Valves ............................................................................................... 343
  - Adding a Radiator Valve .............................................................................. 343
  - Modifying a Radiator Valve .......................................................................... 344
  - Moving a Radiator Valve ............................................................................. 344
  - Connecting MvParts Using Alignment Grips ................................................. 345
- Creating Pipe Runs for Radiators ................................................................. 346
  - Adding Parallel Pipes to a Radiant Heating System ...................................... 347
  - Correcting a Parallel Pipe Routing Conflict ................................................. 350
  - Connecting Multiple Radiators to Parallel Pipes ......................................... 350
  - Correcting a Radiator Connection Failure ..................................................... 351

## Chapter 9 Drawing Electrical Systems

- About Electrical Systems .................................................................................. 353
- Design Workflow for Electrical Systems .......................................................... 353
  - Define System Requirements ....................................................................... 353
  - Design the Electrical System Project ............................................................ 354
- Circuits ............................................................................................................ 356
  - Electrical Project Database .......................................................................... 356
  - Circuit Manager ............................................................................................. 356
- Electrical Objects ............................................................................................ 357
  - Devices ........................................................................................................... 357
  - Panels ............................................................................................................ 358
  - Wires ............................................................................................................... 359
- Wire Size Calculations ..................................................................................... 360
- Cable Trays and Conduits ................................................................................ 360
  - Auto Layout ................................................................................................... 361
  - Cable Tray and Conduit Settings .................................................................. 361
  - Electrical and Wire Ways Snaps ................................................................... 361
- Customizable Electrical Content ..................................................................... 362
- Control the Appearance and Behavior of Electrical System Designs .............. 363
  - Creating Electrical System Definitions ....................................................... 363
  - Creating Load Category Definitions ............................................................... 364
  - Configuring Electrical Preferences ............................................................... 365
    - Specifying Voltage Definitions .................................................................. 365
    - Configuring Circuiting Options .................................................................. 366
    - Specifying an Electrical Project Database File ........................................ 367
  - Device Style Setup ....................................................................................... 367
    - Specifying Design Rules for Device Styles ................................................. 367
    - Configuring Connectors for Device Styles ................................................. 368
    - Specifying Classifications for Device Styles .............................................. 369
  - Configuring Styles for Panels ..................................................................... 371
    - Specifying Design Rules for Panel Styles .................................................. 372
    - Configuring Connectors for Panel Styles .................................................... 372
  - Configuring Styles for Wires ....................................................................... 373
    - Defining Design Specifications for Wire Styles ......................................... 373
    - Specifying Annotation for Wire Styles ....................................................... 374
  - Configuring Layout Preferences for Cable Tray or Conduit ......................... 376
    - Specifying Alignment for Cable Tray or Conduit Insertion .......................... 376
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specifying the Slope for Cable Tray or Conduit</td>
<td>377</td>
</tr>
<tr>
<td>Breaking Cable Tray or Conduit at Even Intervals</td>
<td>378</td>
</tr>
<tr>
<td>Specifying Annotation for Cable Tray or Conduit</td>
<td>379</td>
</tr>
<tr>
<td>Specifying Default Parts for Cable Tray or Conduit</td>
<td>379</td>
</tr>
<tr>
<td>Configuring Connections for Cable Tray</td>
<td>380</td>
</tr>
<tr>
<td>Working with Circuits</td>
<td>380</td>
</tr>
<tr>
<td>Using an Electrical Project Database</td>
<td>381</td>
</tr>
<tr>
<td>How the Electrical Project Database Works</td>
<td>381</td>
</tr>
<tr>
<td>Creating an Electrical Project Database</td>
<td>382</td>
</tr>
<tr>
<td>Linking to the Electrical Project Database</td>
<td>383</td>
</tr>
<tr>
<td>Reloading the Electrical Project Database</td>
<td>383</td>
</tr>
<tr>
<td>Unlinking From the Electrical Project Database</td>
<td>384</td>
</tr>
<tr>
<td>Using Circuits</td>
<td>384</td>
</tr>
<tr>
<td>Creating Circuits Using the Circuit Manager</td>
<td>385</td>
</tr>
<tr>
<td>Configuring a Circuit</td>
<td>387</td>
</tr>
<tr>
<td>Viewing Circuit Information</td>
<td>388</td>
</tr>
<tr>
<td>Linking Panels</td>
<td>389</td>
</tr>
<tr>
<td>Managing Circuits in a Project</td>
<td>390</td>
</tr>
<tr>
<td>Creating Electrical Systems</td>
<td>391</td>
</tr>
<tr>
<td>Adding Devices</td>
<td>391</td>
</tr>
<tr>
<td>Configuring the Electrical Connectors of a Device</td>
<td>395</td>
</tr>
<tr>
<td>Example: Aligning a Device to Floor Plan Geometry</td>
<td>398</td>
</tr>
<tr>
<td>Example: Adding Devices at a Specific Distance Interval</td>
<td>399</td>
</tr>
<tr>
<td>Example: Adding a Specific Number of Devices</td>
<td>401</td>
</tr>
<tr>
<td>Example: Inserting a Device into a Wire</td>
<td>403</td>
</tr>
<tr>
<td>Adding Panels</td>
<td>403</td>
</tr>
<tr>
<td>Example: Aligning a Panel to Floor Plan Geometry</td>
<td>409</td>
</tr>
<tr>
<td>Copying Devices and Panels</td>
<td>409</td>
</tr>
<tr>
<td>Example: Copying a Device</td>
<td>411</td>
</tr>
<tr>
<td>Example: Copying a Panel</td>
<td>412</td>
</tr>
<tr>
<td>Adding Wires</td>
<td>412</td>
</tr>
<tr>
<td>Drawing or Generating Wires</td>
<td>413</td>
</tr>
<tr>
<td>Drawing a Home Run</td>
<td>418</td>
</tr>
<tr>
<td>Creating a Wire from a Polyline</td>
<td>419</td>
</tr>
<tr>
<td>Adding Electrical Equipment</td>
<td>419</td>
</tr>
<tr>
<td>Drawing Cable Trays and Conduits</td>
<td>420</td>
</tr>
<tr>
<td>Drawing a Cable Tray or Conduit Run</td>
<td>421</td>
</tr>
<tr>
<td>Adding a Cable Tray or Conduit Branch</td>
<td>423</td>
</tr>
<tr>
<td>Adding Cable Tray or Conduit Fittings Manually</td>
<td>424</td>
</tr>
<tr>
<td>Checking Electrical Systems</td>
<td>425</td>
</tr>
<tr>
<td>Calculating Wire Sizes Using the Circuit Manager</td>
<td>425</td>
</tr>
<tr>
<td>Viewing Circuit Information</td>
<td>426</td>
</tr>
<tr>
<td>Checking Circuit Loads</td>
<td>426</td>
</tr>
<tr>
<td>Generating a Circuit Report</td>
<td>427</td>
</tr>
<tr>
<td>Showing Circuited Devices</td>
<td>427</td>
</tr>
<tr>
<td>Showing Connected Objects</td>
<td>428</td>
</tr>
<tr>
<td>Viewing Power Totals</td>
<td>428</td>
</tr>
<tr>
<td>Modifying Electrical Systems</td>
<td>428</td>
</tr>
<tr>
<td>Modifying Circuits</td>
<td>429</td>
</tr>
<tr>
<td>Moving Circuits to Manage Demand Load</td>
<td>429</td>
</tr>
<tr>
<td>Modifying Circuit Properties</td>
<td>429</td>
</tr>
<tr>
<td>Deleting Circuits</td>
<td>430</td>
</tr>
<tr>
<td>Modifying Devices and Panels</td>
<td>431</td>
</tr>
<tr>
<td>Moving a Device or Panel</td>
<td>431</td>
</tr>
<tr>
<td>Modifying Device Properties</td>
<td>434</td>
</tr>
<tr>
<td>Modifying Panel Properties</td>
<td>439</td>
</tr>
<tr>
<td>Modifying Wires</td>
<td>440</td>
</tr>
<tr>
<td>Modifying Wire Layouts</td>
<td>441</td>
</tr>
<tr>
<td>Modifying Wire Properties</td>
<td>441</td>
</tr>
<tr>
<td>Moving Tick Marks on Wires</td>
<td>443</td>
</tr>
</tbody>
</table>
## Chapter 10  Drawing Plumbing Systems

### Contents

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flipping Tick Marks on Wires</td>
<td>443</td>
</tr>
<tr>
<td>Modifying Electrical Equipment</td>
<td>444</td>
</tr>
<tr>
<td>Modifying Cable Trays and Conduits</td>
<td>444</td>
</tr>
<tr>
<td>Modifying the Layout of a Cable Tray or Conduit Run</td>
<td>444</td>
</tr>
<tr>
<td>Changing the System of a Cable Tray or Conduit Run</td>
<td>445</td>
</tr>
<tr>
<td>Changing the Elevation of a Cable Tray or Conduit Run</td>
<td>445</td>
</tr>
<tr>
<td>Modifying the Size of a Cable Tray or Conduit Run</td>
<td>446</td>
</tr>
<tr>
<td>Modifying the Length of Cable Tray or Conduit Segments</td>
<td>446</td>
</tr>
<tr>
<td>Breaking and Merging Cable Tray or Conduit Segments</td>
<td>449</td>
</tr>
<tr>
<td>Modifying a Cable Tray or Conduit Fitting</td>
<td>450</td>
</tr>
<tr>
<td>Rotating Cable Tray or Conduit Fittings</td>
<td>450</td>
</tr>
<tr>
<td>Annotating Electrical System Drawings</td>
<td>452</td>
</tr>
<tr>
<td>Adding Labels to Wire, Conduit, and Cable Tray</td>
<td>452</td>
</tr>
<tr>
<td>About Panel Schedules</td>
<td>453</td>
</tr>
<tr>
<td>Updating Panel Schedules</td>
<td>455</td>
</tr>
<tr>
<td>Exporting a Panel Schedule to Excel</td>
<td>459</td>
</tr>
<tr>
<td>Creating Panel Schedule Table Styles</td>
<td>460</td>
</tr>
<tr>
<td>Creating Electrical System Construction Documents</td>
<td>461</td>
</tr>
<tr>
<td>Creating Plumbing Systems</td>
<td>463</td>
</tr>
<tr>
<td>Plumbing Design Workflow</td>
<td>463</td>
</tr>
<tr>
<td>Plumbing Systems Overview</td>
<td>464</td>
</tr>
<tr>
<td>Plumbing Runs and Lines</td>
<td>464</td>
</tr>
<tr>
<td>Plumbing System Definitions</td>
<td>465</td>
</tr>
<tr>
<td>Plumbing Fittings</td>
<td>465</td>
</tr>
<tr>
<td>Associative Movement</td>
<td>466</td>
</tr>
<tr>
<td>Movement of a Plumbing Line Segment</td>
<td>466</td>
</tr>
<tr>
<td>Movement of an MvPart</td>
<td>467</td>
</tr>
<tr>
<td>Plumbing Grips</td>
<td>469</td>
</tr>
<tr>
<td>Grips for Adding to a Plumbing Run</td>
<td>469</td>
</tr>
<tr>
<td>Grips for Modifying a Plumbing Run</td>
<td>470</td>
</tr>
<tr>
<td>Rise/Run Angles and Slope</td>
<td>475</td>
</tr>
<tr>
<td>Fixture Units</td>
<td>475</td>
</tr>
<tr>
<td>Calculations</td>
<td>475</td>
</tr>
<tr>
<td>Plumbing Line Sizing Tables</td>
<td>475</td>
</tr>
<tr>
<td>Customizing Plumbing Content</td>
<td>477</td>
</tr>
<tr>
<td>Creating Style-Based Content</td>
<td>477</td>
</tr>
<tr>
<td>Creating Catalog-Based Content</td>
<td>477</td>
</tr>
<tr>
<td>Configuring Plumbing System Definitions</td>
<td>477</td>
</tr>
<tr>
<td>Creating a Plumbing System Definition</td>
<td>478</td>
</tr>
<tr>
<td>Specifying the Default Fittings for a Plumbing System Definition</td>
<td>478</td>
</tr>
<tr>
<td>Configuring Fixture Unit Tables</td>
<td>479</td>
</tr>
<tr>
<td>Applying a Default Fixture Unit</td>
<td>479</td>
</tr>
<tr>
<td>Creating a Fixture Unit Table</td>
<td>480</td>
</tr>
<tr>
<td>Importing a Fixture Unit Table into a Drawing</td>
<td>480</td>
</tr>
<tr>
<td>Specifying Plumbing Line Sizing Tables</td>
<td>480</td>
</tr>
<tr>
<td>Configuring Styles for Plumbing Lines and Fittings</td>
<td>481</td>
</tr>
<tr>
<td>Specifying Annotation for a Plumbing Line Style</td>
<td>481</td>
</tr>
<tr>
<td>Specifying Standard Sizes for a Plumbing Line Style</td>
<td>482</td>
</tr>
<tr>
<td>Specifying Type and Subtype for a Plumbing Fitting Style</td>
<td>482</td>
</tr>
<tr>
<td>Connectors for a Plumbing Fitting Style</td>
<td>483</td>
</tr>
<tr>
<td>Specifying Plumbing Preferences for Labels and Flow Arrows</td>
<td>484</td>
</tr>
<tr>
<td>Creating Plumbing Systems</td>
<td>484</td>
</tr>
<tr>
<td>Adding Plumbing Equipment and Fixtures</td>
<td>485</td>
</tr>
<tr>
<td>Adding Plumbing Lines</td>
<td>486</td>
</tr>
<tr>
<td>Drawing a Plumbing Run from Equipment or Fixtures</td>
<td>486</td>
</tr>
<tr>
<td>Drawing a Plumbing Run Using Add Grips</td>
<td>487</td>
</tr>
<tr>
<td>Drawing a Plumbing Run</td>
<td>488</td>
</tr>
</tbody>
</table>
Chapter 11 Drawing Schematic Diagrams ........................................... 517

Creating a Plumbing Run from a Polyline ........................................ 488
Connecting Plumbing Lines at Different Elevations ........................ 489
Overriding the Default Plumbing Fittings for an Individual Run .......... 489
Adding Plumbing Fittings Manually .............................................. 490
Adding an Expansion Loop to a Plumbing Run .............................. 491
Modifying Plumbing Systems ....................................................... 492
Component Selection ................................................................. 492
Selecting Connected Branches ...................................................... 492
Filtering Plumbing Objects by Part Properties ............................... 492
Filtering Selections by Part Type .................................................. 493
Modifying Plumbing Equipment and Fixtures ............................... 494
Calculating the Slope of a Plumbing Line ...................................... 495
Modifying Plumbing Lines and Fittings Using Grips ....................... 496
Moving Plumbing Lines and Fittings ............................................. 497
Modifying the Length of Plumbing Lines ...................................... 497
Rotating Plumbing Fittings .......................................................... 498
Modifying Plumbing Lines and Fittings ........................................ 498
Modifying the System Assigned to a Plumbing Line or Fitting ......... 498
Reversing the Flow of a Plumbing Run ......................................... 499
Modifying the Elevation of a Plumbing Line or Fitting .................. 499
Modifying the Location Coordinates of a Plumbing Line or Fitting .... 500
Modifying the Nominal Size of a Plumbing Line Segment .............. 500
Modifying the Style of a Plumbing Line or Fitting ......................... 501
Calculating the Sizes of Supply Plumbing Lines ............................ 501
Sizing Supply Plumbing Lines ....................................................... 501
Reviewing the Sizing Results for Supply Plumbing Lines ................ 503
Calculations for the Longest Run .................................................. 503
Calculations at Selected Component ............................................ 504
How the Software Performs Calculations to Size Plumbing Lines .... 507
Calculating the Sizes of Sanitary Plumbing Lines ............................ 508
Overview of Sizing Sanitary Plumbing Lines .................................. 508
Sanitary Branch Sizing ............................................................... 509
Sanitary Offset Sizing ............................................................... 510
Sanitary Stack Sizing ............................................................... 511
Sizing Sanitary Plumbing Lines ..................................................... 511
Sizing Sanitary Plumbing Lines for Multiple Floors ....................... 512
Reviewing the Sizing Results for Sanitary Plumbing Lines ............... 513

Chapter 11  Drawing Schematic Diagrams ........................................... 517

About Schematic Diagrams .......................................................... 518
Schematic Lines ................................................................. 519
Schematic Symbols .............................................................. 519
Drawing in Orthographic Mode ................................................... 519
Drawing in Isometric Mode ........................................................ 520
Customizing Schematic Content .................................................. 521
Configuring Schematic Settings .................................................... 521
Creating Schematic System Definitions ...................................... 521
Configuring Styles for Schematic Lines ....................................... 522
Defining Designations for Schematic Line Styles ......................... 522
Specifying Annotation for Schematic Line Styles ......................... 523
Creating a Schematic Diagram .................................................... 525
Adding Schematic Lines in Orthographic Mode ........................... 525
Adding Schematic Symbols in Orthographic Mode ....................... 527
Adding Schematic Lines in Isometric Mode .................................. 528
Adding Schematic Symbols in Isometric Mode .............................. 531
Adding Schematic Lines Using Grips ........................................... 534
Creating a Schematic Line from an AutoCAD Line, Arc, or Polyline .... 534
Modifying a Schematic Diagram .................................................. 534
Associative Movement ............................................................... 535
### Chapter 12  Creating Construction Documents

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Construction Document Workflow</td>
<td>547</td>
</tr>
<tr>
<td>Creating Construction Documents</td>
<td>548</td>
</tr>
<tr>
<td>Annotation</td>
<td>548</td>
</tr>
<tr>
<td>Scaling Annotation</td>
<td>549</td>
</tr>
<tr>
<td>Label Curve Styles</td>
<td>555</td>
</tr>
<tr>
<td>Labels</td>
<td>559</td>
</tr>
<tr>
<td>Adding Annotation Symbols from DesignCenter</td>
<td>560</td>
</tr>
<tr>
<td>Tags</td>
<td>561</td>
</tr>
<tr>
<td>Adding a Tag</td>
<td>562</td>
</tr>
<tr>
<td>Modifying Property Set Data for a Part</td>
<td>562</td>
</tr>
<tr>
<td>Using Part Number Tags and Schedules</td>
<td>563</td>
</tr>
<tr>
<td>Working with Part Number Tags and Schedules</td>
<td>564</td>
</tr>
<tr>
<td>Schedules</td>
<td>566</td>
</tr>
<tr>
<td>Adding a Schedule</td>
<td>566</td>
</tr>
<tr>
<td>Linking a Schedule to an External Drawing</td>
<td>567</td>
</tr>
<tr>
<td>Creating an Electrical Panel Schedule</td>
<td>567</td>
</tr>
<tr>
<td>Updating a Schedule</td>
<td>567</td>
</tr>
<tr>
<td>Exporting a Schedule to a Spreadsheet</td>
<td>568</td>
</tr>
<tr>
<td>Views</td>
<td>568</td>
</tr>
<tr>
<td>Creating a General View</td>
<td>568</td>
</tr>
<tr>
<td>Creating a Detail View</td>
<td>569</td>
</tr>
<tr>
<td>Creating a Section View</td>
<td>570</td>
</tr>
<tr>
<td>Creating an Elevation View</td>
<td>573</td>
</tr>
<tr>
<td>Updating a Section or Elevation View</td>
<td>575</td>
</tr>
<tr>
<td>Sheets</td>
<td>576</td>
</tr>
<tr>
<td>Creating a Sheet</td>
<td>576</td>
</tr>
<tr>
<td>Creating a Cover Sheet</td>
<td>577</td>
</tr>
<tr>
<td>Ordering Sheets in the Sheet Set</td>
<td>578</td>
</tr>
<tr>
<td>Publishing a Sheet Set to DWF™</td>
<td>578</td>
</tr>
<tr>
<td>Adding Elevation Labels</td>
<td>578</td>
</tr>
<tr>
<td>Checking Your Drawings</td>
<td>579</td>
</tr>
<tr>
<td>Showing Solution Tips</td>
<td>579</td>
</tr>
<tr>
<td>Showing Connected Runs</td>
<td>581</td>
</tr>
<tr>
<td>Showing Connected Objects</td>
<td>581</td>
</tr>
<tr>
<td>Finding Interferences</td>
<td>582</td>
</tr>
<tr>
<td>Running Interference Detection</td>
<td>582</td>
</tr>
<tr>
<td>Viewing and Resolving Interferences</td>
<td>584</td>
</tr>
<tr>
<td>Tagging Interferences or Openings</td>
<td>585</td>
</tr>
<tr>
<td>Exiting Interference Detection</td>
<td>586</td>
</tr>
<tr>
<td>Excluding a Material from 2D Section Shrinkwrap</td>
<td>586</td>
</tr>
<tr>
<td>Collecting Project Data</td>
<td>587</td>
</tr>
<tr>
<td>Defining Property Set Definitions</td>
<td>588</td>
</tr>
<tr>
<td>Defining Property Set Data</td>
<td>588</td>
</tr>
<tr>
<td>Using Classifications</td>
<td>589</td>
</tr>
</tbody>
</table>
Chapter 15 Customizing Catalogs ................................................. 771
About Catalog Editor ............................................................. 771
Key Catalog Terms ................................................................ 773
Opening Catalog Editor .......................................................... 774
Opening a Part Catalog in Catalog Editor ................................ 774
Customizing Catalogs in Catalog Editor .................................... 774
  Working with Part Data in the Tree View ............................... 774
  Working with Part Data in the Table View ............................ 775
  Creating Parts in Catalog Editor ........................................... 777
  Adding Part Sizes in Catalog Editor ...................................... 777
  Adding Custom Data to Parts in Catalog Editor ...................... 778
<table>
<thead>
<tr>
<th>Chapter 16</th>
<th>Customizing AutoCAD MEP</th>
<th>785</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating Part Catalogs in Catalog Editor</td>
<td>779</td>
<td></td>
</tr>
<tr>
<td>Working with Part Data in Excel</td>
<td>780</td>
<td></td>
</tr>
<tr>
<td>Validating and Regenerating Part Catalogs</td>
<td>781</td>
<td></td>
</tr>
<tr>
<td>Validating the Parts in a Catalog</td>
<td>781</td>
<td></td>
</tr>
<tr>
<td>Regenerating a Part Catalog</td>
<td>782</td>
<td></td>
</tr>
<tr>
<td>Migrating Part Catalogs</td>
<td>782</td>
<td></td>
</tr>
<tr>
<td>Redefining the Catalog Parts in a Drawing</td>
<td>783</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 16</th>
<th>Customizing AutoCAD MEP</th>
<th>785</th>
</tr>
</thead>
<tbody>
<tr>
<td>Styles and Support Files</td>
<td>786</td>
<td></td>
</tr>
<tr>
<td>Customizing Tool Palettes</td>
<td>787</td>
<td></td>
</tr>
<tr>
<td>Creating a Tool Palette</td>
<td>787</td>
<td></td>
</tr>
<tr>
<td>Creating a Tool Palette Set</td>
<td>787</td>
<td></td>
</tr>
<tr>
<td>Customizing a Tool Palette Set</td>
<td>788</td>
<td></td>
</tr>
<tr>
<td>Specifying Different Tool Palettes for the Tool Palette Set</td>
<td>789</td>
<td></td>
</tr>
<tr>
<td>Renaming the Tool Palette Set</td>
<td>789</td>
<td></td>
</tr>
<tr>
<td>Customizing Tools</td>
<td>789</td>
<td></td>
</tr>
<tr>
<td>Creating Tools for Style-Based Content</td>
<td>790</td>
<td></td>
</tr>
<tr>
<td>Creating Tools from Routing Preferences</td>
<td>792</td>
<td></td>
</tr>
<tr>
<td>Creating Tools from AEC Content in DesignCenter</td>
<td>792</td>
<td></td>
</tr>
<tr>
<td>Creating Command Tools</td>
<td>793</td>
<td></td>
</tr>
<tr>
<td>Creating Property-Based Tools</td>
<td>794</td>
<td></td>
</tr>
<tr>
<td>Changing Tool Properties</td>
<td>795</td>
<td></td>
</tr>
<tr>
<td>Changing Tool Icons</td>
<td>795</td>
<td></td>
</tr>
<tr>
<td>Deleting Tools</td>
<td>796</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 17</th>
<th>Working with the U.K Profile</th>
<th>797</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using Other Profiles</td>
<td>797</td>
<td></td>
</tr>
<tr>
<td>Working with Hangers</td>
<td>798</td>
<td></td>
</tr>
<tr>
<td>Configuring Hanger Styles</td>
<td>798</td>
<td></td>
</tr>
<tr>
<td>Adding Hangers</td>
<td>799</td>
<td></td>
</tr>
<tr>
<td>Modifying Hangers</td>
<td>801</td>
<td></td>
</tr>
<tr>
<td>Rotating Cable Trays</td>
<td>801</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Glossary</th>
<th>803</th>
</tr>
</thead>
<tbody>
<tr>
<td>Glossary Terms</td>
<td>803</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Appendix - Reference Information</th>
<th>821</th>
</tr>
</thead>
<tbody>
<tr>
<td>Definitions of Part Properties</td>
<td>821</td>
</tr>
<tr>
<td>Using Object Match</td>
<td>826</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Index</th>
<th>831</th>
</tr>
</thead>
</table>
New Features in This Release

NOTE AutoCAD® MEP 2010 is built on AutoCAD and AutoCAD Architecture. See the Help systems for those products to learn about their new features and enhancements.

New Features for Getting Started

Improved Ribbon-Based User Interface

Ribbon tabs group commands according to the current architectural task. For example, there is one tab for annotating a drawing and another for generating output files. Seeing only the tools required for the current task reduces learning time. Logical and thematic panels group subtask commands, making them easier to find and access. For more information, see Workspace Components on page 38.

New Features for Drawing Electrical Systems

Panel Schedule Enhancements

As you design and refine electrical systems, a graphical representation shows that an electrical panel schedule is out of date. Adding or changing circuits and panels, plus certain other operations, require that panel schedules be refreshed. Use the Regen command to update the schedule. For more information, see Updating Panel Schedules on page 459.

Wire Add Grips on Devices

As you lay out electrical designs, use the new Add grip (") on electrical devices to invoke the add-wire mode for connecting one or more devices. When using the Add grip, you add wire of the same style as that used by the previous use of the command. For more information, see Drawing or Generating Wires on page 413.
New Features for Drawing Piping Systems

**Drawing Sloped Piping Layouts**
Catalog content has been expanded to support gravity-based designs for sanitary drain, waste, vent, and sewer/storm drainage systems. Auto layout can generate routing solutions for sloped piping systems based on points you specify in the drawing. Sloped piping layouts model real-world piping requirements. For more information, see Sloped Piping on page 256 and Drawing Sloped Piping on page 308.

**New Parts Added to Pipe Routing Preferences**
The Pipe domain has been expanded to include fittings, such as laterals and eccentric transitions, that you can use in sloped piping designs. You can also connect to a sloped pipe with a wye (lateral) or an angled tee, instead of a 90-degree tee. For more information, see Routing Preferences on page 250.

**Updated Pipe Properties Palette**
New settings for sloped piping layouts on the Pipe Properties palette include slope and slope format, bend and branch angles, and branch fitting. For more information, see Pipe Properties Palette (Add Mode) on page 286 and Drawing Sloped Piping on page 308.

You can apply a slope value to an angled pipe run as you lay out pipes and fittings, without having to manually calculate angles. AutoCAD MEP includes different slope formats (such as angle, percentage, and rise/run) to accommodate your piping requirements. For more information, see Configuring Pipe Layout Preferences on page 293.

Angle of deflection (also called fitting tolerance) specifies whether to allow deflection at joints with a tolerance angle and includes female connection types with non-standard angles based on manufacturer requirements. To enable angle of deflection as you add pipe, select Yes for the Use fitting tolerance option on the Pipe Properties palette. For more information, see Angle of Deflection (Fitting Tolerance) on page 267, Pipe Properties Palette (Add Mode) on page 286, and Drawing Sloped Piping on page 308.

**Customizing Symbols for Pipe Connection Types**
You can customize symbols for pipe connection types (such as grooved, glued, and flanged) for 1-Line display configurations. You match a pipe connector type with a graphics block. For more information, see Configuring System Definitions for 1-Line, 2-Line, or Single Line Graphics on page 282.

New Features for Drawing Radiant Heating Systems

**Creating Parallel Pipe Runs**
Using a single routing as the guide, you can create the parallel pipework required for a radiator system. Create two pipe segments, invoke the Parallel Pipe tool, select one segment to be the baseline pipe, and draw pipe, which will create a second pipe run in parallel with the baseline pipe. For more information, see Adding Parallel Pipes to a Radiant Heating System on page 347.

With one radiator connected to a pipe system, select it, right-click, and click Connect Multiple Parts, and connect all other radiators in your design to the pipe system. For more information, see Connecting Multiple Radiators to Parallel Pipes on page 350.
New Features for Customizing Catalogs

**Migrating Part Catalogs**
To ensure that you are using the most current catalog data in your engineering designs, you can upgrade catalogs in a domain. For more information, see Migrating Part Catalogs on page 782.

**Redefining the Catalog Parts in a Drawing**
You can scan the pipe fittings and MvParts in a legacy drawing and update the drawing with any modified catalog parts. For more information, see Redefining the Catalog Parts in a Drawing on page 783.

New Features for Customizing Display

**Configuring the Display of AutoCAD MEP Objects Based on Elevation**
Enable Display by Elevation on the Options dialog to configure display components to show or hide MvParts, as well as pipe, cable tray, conduit, and duct objects, based on elevation. You can differentiate the display attributes for these parts relative to their location above or below the active cut plane and display ranges. For more information, see Display of Objects Based on Elevation on page 144.

New Features for Building Systems

**Converting Solids or Mass Elements to Block-Based Parts**
Convert 3D solids or mass elements directly to block-based MvParts. It is no longer necessary to convert the 3D solid or mass element object to an AutoCAD block, and then convert the block to an MvPart. For more information, see Converting MvBlocks to Block-Based Parts on page 743.

**Importing Manufacturer-Specific Parts from Autodesk Inventor**
Use the Building Component command to import manufacturer-specific content created by Autodesk Inventor or similar applications into AutoCAD MEP as block-based MvParts. No intermediate conversion to AutoCAD blocks is necessary.
AutoCAD MEP, an AutoCAD-based building design solution, enhances AutoCAD functionality with tools designed for mechanical, electrical, and plumbing (MEP) engineers, designers, and drafters. This section describes several features where AutoCAD MEP builds on AutoCAD capabilities for designing building systems.

## AutoCAD to AutoCAD MEP Task Comparisons

The following table contrasts functionality that is available in AutoCAD and AutoCAD MEP.

<table>
<thead>
<tr>
<th>Functionality</th>
<th>In AutoCAD</th>
<th>In AutoCAD MEP</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automate sheet management</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Manage and update project standards and deviations</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Edit geometric elements (such as lines, polylines, arcs, and circles)</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Import or export data in DWG, DWF™, IFC, and other formats</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Import or export engineering data in the Green Building Extensible Markup Language (gbXML) format for analysis by third-party tools</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Adjust annotation on page 17 style and scaling</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Use the AutoCAD MEP workspaces on page 6, along with the grips on page 8 and snaps on page 11 on MEP objects to create intelligent, connected building systems</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Use layer keying on page 7 to automatically map objects to defined layers in a drawing</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Use associative movement on page 7 to modify building systems in the X, Y, and Z planes without breaking connectivity in existing layouts</td>
<td>no</td>
<td>yes</td>
</tr>
</tbody>
</table>
Creating Building Systems

AutoCAD meets the fundamental drafting needs of the AEC, civil engineering, and manufacturing industries. You use basic geometric elements, such as lines, arcs, and circles, to draw engineering layouts.

With AutoCAD MEP, you create intelligent building systems that exceeds AutoCAD capabilities. You use MEP parts to create complete, connected systems that contain information you can use to analyze and refine your designs. For example, you can create a duct system on page 194 that contains ceiling diffusers with a specified flow rate. The system can detect the amount of downstream airflow required by the diffusers. You can use sloped piping on page 256 to design gravity-based piping system. You can use circuit features on page 380 to create and manage circuits for your electrical plans. You can place plumbing equipment and fixtures in a drawing to create a plumbing run on page 464.

AutoCAD MEP Workspaces

Out of the box, AutoCAD MEP contains tools geared to mechanical, electrical, and plumbing professionals in the building industry. The workspace environments (electrical, HVAC, piping, plumbing, and schematic) include individual palettes and domain-specific ribbons to optimize your workflow tasks.

The tool palette includes parts related to the current domain. You can define tool properties from the tool or properties palette. You can also customize the tool palette to include unique tools commonly used in
your company’s engineering designs. For more information, see Working with Tool Palettes on page 87 and Customizing Tool Palettes on page 787.

RELATED  See also Workspace Components on page 38.

**Insertion Tools**

You can use add grips (عدل) along with the domain-specific palettes in AutoCAD MEP to add components to your drawings. After adding a part from the tool palette, use add grips on a segment or object to route the pipe, plumbing, electrical, schematic, or duct system to ensure connectivity along the run. You can draw a run from one end of the part segment, from a midpoint of a part segment, from a multi-view part (called an MvPart), or from a fitting, such as an elbow or a tee. For more information, see Grips for Adding to a Pipe Run on page 272.

AutoCAD MEP also lets you automatically insert fittings into a run. For example, AutoCAD MEP can identify the type of elbow fitting to insert into a plumbing layout, based on the preferences defined for the plumbing system. When drawing pipe runs, you can use different routing preferences on page 250 that match your pipe specifications to ensure that the proper fittings are inserted automatically. As you draw cable tray or conduit in the Electrical workspace, the software adds fittings based on the defined preferences.

**Layer Keying**

As you add parts to your layouts, each object is automatically placed on the correct layer. With layer keying, AutoCAD MEP automatically places an object on a predefined layer that conforms to a particular layer standard. You can modify the layer standards to map to specific company standards. You can also turn layers on or off for a particular system or use filters to disable objects on a particular layer. For more information, see AutoCAD MEP Layer Standards on page 132.

**Modifying Building Systems**

In AutoCAD, you modify the geometric elements, including lines, arcs, and circles, in your design projects. You use common editing tools in the software, such as COPY, TRIM, and EXTEND. See the AutoCAD Help for more information.

AutoCAD MEP helps you streamline the task of modifying building systems using techniques such as associative movement, grips, and snaps.

**Associative Movement**

You can move, shrink, or stretch connected objects (such as part segments and fittings) to a new location in a drawing without breaking the connection between parts or altering other portions of the run. For more information, see Associative Movement on page 248.

With associative movement, you use grips to move the connected parts as a single unit while other parts remain in place in the same layout. The software identifies the parts that are connected and maintains their connectivity. The following illustrations show the progression of the associative movement feature in the Piping domain.
NOTE Associative movement lets you move objects in the XY plane. You can also modify the elevation of connected parts relative to their top, centerline, or bottom orientation in side and isometric views.

Grips

You can use grips to make direct changes to a part segment in a drawing. Hovering over a grip displays a tooltip describing the grip’s function. Some tooltips also suggest options, such as using the CTRL or ALT keys. For more information, see Designing with Dynamic Input and Grips on page 114.

Several types of grips are available:

- Add grips (➕) add segments, such as duct, pipe, plumbing line, wire, cable tray, or conduit, to a new or existing run without sacrificing connectivity along the run.
Pipe segment

Pipe fitting (elbow with flange connections)

Base-mounted pump (MvPart)

- Location grips ( ) move a component in the current XY plane. Location grips appear at the insertion and connector points on a part.

Plumbing

MvPart

- Lengthen grips ( ) change the length of a part segment. Lengthen grips use the segment's current orientation to maintain connectivity in the existing run.
Flip grips (左→右) switch the orientation of some parts (such as fittings or takeoffs) based on the direction of the grip.

Takeoff selected — Flip grip shown

Orientation flipped

Diamond-shaped rotate grips (左→右) in isometric views rotate an object around its centerline to any angle, if that object has round connectors on opposite ends. Rotate grips are available on parts and fittings that can be rotated without breaking the connection with existing objects.

Rotating a damper in an isometric view
Elevation grips (▲) modify the elevation of part segments in side and isometric views relative to the top, centerline, or bottom of the segment. Elevation grips appear at the insertion and connector points on the specified part segment.

---

**Snaps**

AutoCAD MEP includes AutoCAD object snaps and AutoCAD MEP snaps. You use object snaps to snap drawing points to geometric locations on other objects. For example, you can snap to the endpoint of a line or snap to the intersection of 2 lines.

AutoCAD MEP snaps connect MEP objects to other objects, maintaining the integrity and connectivity of the system. For example, you can use pipe snaps to connect a pipe, fitting, or MvPart directly to a pipe end connector at the end of a pipe segment. AutoCAD MEP snaps are available in all the engineering workspaces. For more information, see Configuring AutoCAD MEP Snaps on page 75.

Segments, such as duct and pipe, contain end connector snaps and curve connector snaps. End connector snaps connect new objects to the ends of existing objects. Curve connector snaps connect a segment anywhere along the centerlines of existing objects. For example, when you can use pipe curve connector snaps on an existing pipe run, the software inserts a pipe fitting in the resulting branch, as shown next.

**Snapping a pipe to an existing run using the pipe curve connector**

---

You can use electrical snaps to wire a junction box to a light. You can also use wireway snaps to make connections to a cable tray, conduit, or electrical MvParts.
Automating Design Tasks

In AutoCAD, design tasks are performed manually. AutoCAD does not automatically update the part specification data in construction documents.

AutoCAD MEP includes features that automate many engineering tasks and provides immediate feedback as you perform those tasks.

Domain-Specific Ribbons

Out of the box, each engineering workspace in AutoCAD MEP includes a contextual ribbon with preferences and system definitions unique to the active domain. You can use preferences to automate many design layout functions. For example, you can define default parts to use during layout, and you can also specify properties, such as annotation labels, connection behavior, and display settings.

AutoCAD MEP provides system definitions, such as design rules, display properties, and rise/drop configurations. System definition settings control the appearance and functions of parts in a system. You can also override system settings to accommodate unique part requirements. For more information, see Workspace Components on page 38.

Auto Layout

Auto layout can generate routing solutions that you can use as you lay out duct, pipe, cable tray, or conduit runs. AutoCAD MEP automatically inserts the appropriate segments and fittings based on the current part or routing preferences. For more information, see Auto Layout on page 252.

Interference Detection

You can improve project coordination using the interference detection tool. The software checks for interferences between different types of objects, such as between ducts and pipes or between these MEP objects and architectural/structural objects, such as walls. Interference detection can occur on objects within the current drawing, objects in referenced drawings (xrefs), or objects in both the current drawing and in
an xref. AutoCAD MEP shows interferences as mass elements in the drawing. You can add tags to the mass element and insert opening symbols that get captured in a linked interference detection schedule. For more information, see Finding Interferences on page 582.

Connectivity Checks

The built-in connectivity tools ensure that objects are properly connected and that adjacent objects are updated accordingly. Connectivity tools also promote the precision of the sizing and calculation tools.

You use the Show Connected Run command to verify the connectivity in a duct, pipe, plumbing line, conduit, cable tray, or wired electrical run. This functionality is especially useful with complicated designs.

You use the Show Connected Objects command to identify the other objects that are connected to a particular object. The software verifies that adjacent parts are properly connected and that connectivity is continuous throughout the run or branches. In the Electrical workspace, the Show Connected Objects command checks the connectivity between the lighting devices, wires, junction boxes, and switches in a lighting network, as well as between MvParts and conduit or cable tray runs.

Working With Sizing and Calculation Tools

AutoCAD MEP includes several built-in sizing and calculation tools.

Sizing Tools

Because duct systems connect intelligently, AutoCAD MEP can calculate duct sizes. The software uses the air flow values you assign for the outlet parts in a duct system. The Duct System Size Calculator computes duct sizes for an entire connected system or for portions of a system. The Instant Sizing Calculator computes sizes for ductwork as you draw duct runs or when you modify existing runs.

Instant sizing tool
Electrical Circuit Manager

You can configure circuits and panels for electrical systems. When you assign devices to a circuit, the device loads are automatically added to the circuit load. The Circuit Manager displays circuit load, circuit information, or a circuit report for one or more selected devices. The Circuit Manager also displays overloaded circuits in red. You can turn on a feature to be notified when a circuit is overloaded as you are assigning devices to circuits. For more information, see Checking Electrical Systems on page 425.

Plumbing Tools

Out of the box, AutoCAD MEP includes sample sizing tables for supply lines and sanitary lines, based on typical industry standards. Supply plumbing line sizing tables specify the equivalent plumbing line length values for fittings and valves. Sanitary plumbing line sizing tables specify the maximum allowable fixture unit loads for different types of sanitary runs (stacks, branches, and offsets). You can also customize the sizing tables to meet your project requirements or conform to applicable codes.

You can also use the plumbing line slope tool to compute the start elevation, end elevation, or slope of a plumbing line based on the starting or ending points in the run. The software prompts for one of three entries — starting point of the segment, ending point, or slope. For more information, see Calculating the Slope of a Plumbing Line on page 495.

Pipe Routing Preferences

AutoCAD MEP uses the routing preference in the Piping domain as specified in the Style Manager to insert fittings as you draw the pipe run. If you try to add or modify a part, angle, or transition that is not defined in the current routing preference, AutoCAD MEP prompts you to make a part substitution. You are also
prompted if you try to connect objects with different joint types. For more information, see Routing Preferences on page 250 and Choosing a Part on page 303.

**Solution Tips**

AutoCAD MEP displays optional solution tips that highlight where invalid connections exist between objects in the layout. Solution tips describe the problem and offer one or more possible solutions. For more information, see Showing Solution Tips on page 579.

---

**Creating Accurate Construction Documents**

In AutoCAD, there is no automated way to revise construction documents to reflect changes in your original drawing or to automate the creation of section views. As the design changes, manually updating section views is not only time-consuming but also error-prone. You also would need to use a text editor in AutoCAD to perform tasks, such as adding labels to objects, formatting text, justifying positioning, or setting scale representations.

In AutoCAD MEP, you can maximize your productivity using automated tools, such as tagging, labeling, annotation scaling, and layout symbols. Because project drawings are created, stored, and maintained using the drawing management tools in AutoCAD MEP, the resulting construction documents are updated automatically when changes get made.

**Section Views**

You can create section views from your AutoCAD MEP model, as shown next.
Specifies the parts of the drawing to include in the new section view

You can regenerate section views after you change any aspects of the model. Because you view AutoCAD MEP systems in 3 dimensions, you can also create elevation and detail views. For more information, see Creating a Section View on page 570.

**Tagging**

AutoCAD MEP automates part tagging. For example, as you create a building system, you can add part number tags to objects in the drawing.
Each tagged part contains a property set that you configure on the Properties palette based on the part specification. Part schedules linked to the drawing reflect the tagged data. For more information, see Defining Property Set Data on page 588 and Tags on page 561.

**Labeling and Annotation Scaling**

AutoCAD MEP lets you add labels and flow arrows as you lay out a run. You can specify the number of labels or flow arrows and the placement of the annotation. As you make changes, the labeling updates automatically.
The annotation scaling feature lets you specify different annotation scales for model space and for individual viewports in paper space. The annotation scales and plots accurately even if different scales for the viewports in the layout are used.

### Layout Symbols

AutoCAD MEP displays symbols that represent unique conditions in the layout. For example, rise/drop symbols reflect the elevation direction of vertical segments in the layout for any predefined orthographic view (top, bottom, left, right, front, or back).

You can display objects differently based on elevation on page 144. You can also change the appearance of hidden lines, layers, line types, or color for crossing or overlapping objects at different elevations in 2-line plan views. For example, AutoCAD MEP displays hidden lines as dashes, as shown next. For more information about the various display options in AutoCAD MEP, see AutoCAD MEP Displays on page 134.

**Hidden lines shown as dashes**
Project Management

AutoCAD MEP controls the management of project sheets and views through the use of the Project Navigator. As you design systems in AutoCAD MEP, you develop 3-dimensional models that are saved in construct drawings.

Construction documents consist of views and sheets. A view references the model in the construct drawing, and it consists of one view of the model with a specific drawing scale. Two examples of view drawings are a cross-sectional view of an HVAC system and a floor plan of a lighting system.

Views are referenced onto sheets for plotting or transmitting. Because views and sheets reference the model, you only need to update the model, and the changes are automatically propagated through the views and sheets.

Schedules

Creating and maintaining accurate schedules can be complex, error-prone, and time-consuming. However, AutoCAD MEP automates this task by linking the schedule to the original AutoCAD MEP designs.

An MEP schedule displays tagged parts, along with selected attributes for each part, in tabular form, as shown next.

Device schedule

<table>
<thead>
<tr>
<th>Quantity</th>
<th>Tag</th>
<th>Module Size</th>
<th>Neck Size</th>
<th>Description</th>
<th>Construction</th>
<th>Make of Design</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>A1</td>
<td>24&quot; x 24&quot;</td>
<td>12&quot; x 24&quot;</td>
<td>Perforated Supply Diffuser</td>
<td>White Powder Coat</td>
<td>AX1560</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>B1</td>
<td>24&quot; x 24&quot;</td>
<td>12&quot; x 24&quot;</td>
<td>Perforated Supply Diffuser</td>
<td>White Powder Coat</td>
<td>AX1560</td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>C</td>
<td>12&quot; x 5&quot;</td>
<td>12&quot; x 5&quot;</td>
<td>General Supply Grille</td>
<td>White Powder Coat</td>
<td>AX1560</td>
<td></td>
</tr>
</tbody>
</table>

Because schedules built in AutoCAD MEP are linked, any changes, additions, or deletions to the existing tagging data or part specifications are automatically updated in the schedule. The schedule format inherits the schedule table style assigned to the schedule tool. However, you can modify the table style to reflect the desired data format.

Leveraging AutoCAD Knowledge in AutoCAD MEP

The AutoCAD user interface guides you through the CAD design process. AutoCAD MEP builds on the fundamental infrastructure, capabilities, and familiar AutoCAD user interface. Therefore, you do not need to toss away your knowledge about AutoCAD.

Your familiarity with AutoCAD helps you lessen your learning curve and maximize your productivity. The contextual ribbon structures, domain-specific tool and properties palettes, and task-oriented dialogs in AutoCAD MEP reflect the particular task-based design work you are performing. For more information, see Workspace Components on page 38.

The AutoCAD command line is also available at the lower left corner of the AutoCAD MEP user interface. When you enter a command, the software prompts you with the next step. For more information about the command line, see the AutoCAD Help.
Working with AutoCAD Commands in AutoCAD MEP

Because AutoCAD MEP is built on the AutoCAD infrastructure, all of the commands in AutoCAD are available in AutoCAD MEP. However, some differences exist between the commands to modify basic AutoCAD objects, such as lines, polylines, and arcs, and the commands to modify intelligent building systems objects, such as parts, fittings, and segments of duct, pipe, or cable tray.

This section provides guidance on using AutoCAD commands in an AutoCAD MEP environment. The effects of commands on building systems objects are discussed, and, where applicable, alternative or more enhanced methods of accomplishing tasks are suggested.

NOTE Many of the sections that follow reference AutoCAD Help topics. The quickest way to locate an AutoCAD topic referenced in AutoCAD MEP Help is to click the Search tab in the Help window, select the Search titles only option, copy and paste or enter the AutoCAD topic name, and then click List Topics.

ALIGN

The ALIGN command moves, rotates, and tilts objects so they align with other objects.

When you use ALIGN to align an object in AutoCAD MEP, you can snap and attach the object to another at the new location, but the command does not intelligently connect the 2 objects. This action results in an invalid connection in the overall building system.

To maintain the connectivity of objects, use Alignment grips to align devices or panels, and use Location or Rotate grips, snaps, and polar tracking to align other objects. The grips enable you to move or rotate objects while optionally maintaining their connections to other objects.

For more information, see the following topics:
- Moving Duct Components on page 221
- Rotating Duct Components on page 228
- Moving Pipe Components Using Location Grips on page 320
- Rotating Pipe Components on page 321
- Moving a Device or Panel on page 431
- Modifying the Layout of a Cable Tray or Conduit Run on page 444
- Rotating Cable Tray or Conduit Fittings on page 450
- Moving Plumbing Lines and Fittings on page 497
- Rotating Plumbing Fittings on page 498
- “Align Objects” in the AutoCAD Help

ARRAY

The ARRAY command creates copies of objects in a rectangular or polar (circular) pattern called an array.

In AutoCAD MEP, you can use ARRAY to create arrays of a selection set of objects (for example, a complete duct branch). If possible, the software connects a suitable object in each copy of the selection set, such as a tee or takeoff, to a segment at each destination.

Unlike COPY or MOVE, ARRAY does not align or orient the copies of the selection set when it connects them to objects at their destinations. The copies maintain the alignment and orientation of the original selection set.
BREAK

The BREAK command breaks an object between 2 points that you specify and optionally creates a gap between the new objects that are created.

In AutoCAD MEP, when you use BREAK to break segments of duct, pipe, cable tray, or conduit, or to break plumbing lines, the software connects the 2 new segments if the first and second specified break points are the same. However, when you break a segment where a takeoff is connected, the software connects the takeoff to only 1 of the 2 new segments. You should reposition the takeoff as needed.

You can break one or more duct, pipe, cable tray, or conduit segments into multiple segments of a specific length. For example, in the Piping domain, you use the Pipe Length on page 329 dialog.

For more information about BREAK, see “Break and Join Objects” in the AutoCAD Help. For more information about breaking segments into multiple segments in AutoCAD MEP, see:

- Breaking or Merging Duct on page 234
- Breaking or Merging Pipe Segments on page 329
- Breaking and Merging Cable Tray or Conduit Segments on page 449

CHAMFER

The CHAMFER command connects 2 objects with an angled line. It is typically used to represent a beveled edge on a corner, but it can also be used to extend 2 objects until they intersect.

In AutoCAD MEP, CHAMFER only works on AutoCAD objects, such as lines, polylines, and 3D solids. It does not work on building systems objects, such as schematic lines, plumbing lines, or duct, pipe, cable tray, or conduit segments. To extend and connect these types of objects, use FILLET, EXTEND, or a combination of grips, snaps, and polar tracking.

For more information, see “Create Chamfers” in the AutoCAD Help.

COPY

The COPY command creates duplicates of objects at a specified distance and direction from the originals.

In AutoCAD MEP, when you use COPY to copy a selection set of objects (for example, a complete duct branch), the software copies the objects and, if possible, connects a suitable object in the selection set, such as a tee or takeoff, to a segment at the destination. When connecting the object, the software breaks into the segment and then aligns and orientates the object (and the selection set). For more information, see “Copy Objects” in the AutoCAD Help.

To copy a device or panel, use Alignment grips instead. The grips enable you to align the copy perpendicular to an object, such as a wall. For more information, see Copying Devices and Panels on page 409.

ERASE

The ERASE command removes a selection set of objects from a drawing.

In some cases in AutoCAD MEP, ERASE joins the objects that remain after you erase an object. For example, it joins remaining duct or pipe segments when you erase inline parts. However, when you erase fittings, the
software disconnects the remaining objects because it does not know how to join them. In these cases, you can connect or merge the disconnected objects to reflect the desired design.

**NOTE** Erasing objects does not remove unused, named items from a drawing. You must purge them.

For more information, see the following topics:

- Breaking and Merging Duct Segments on page 234
- Breaking or Merging Pipe Segments on page 329
- Breaking and Merging Cable Tray or Conduit Segments on page 449
- “Erase Objects” in the AutoCAD Help

**EXPLODE**

The EXPLODE command breaks a compound object into its component objects.

In AutoCAD MEP, the first time that you explode a building systems object (for example, a part or fitting), the software converts the object to an anonymous block reference and changes its Z (elevation) value to zero. You can then explode the object again to convert it to its primitive AutoCAD components, such as lines, arcs, and splines.

Typically, you explode the objects in a drawing in order to share the drawing with users who do not have AutoCAD MEP or an AutoCAD MEP object enabler, or who have a version of AutoCAD not supported by the Export to AutoCAD commands.

**WARNING** Exploding a building systems object causes the object to permanently lose its connectivity with other objects, among other changes. For this reason, always create a copy of the source drawing, and then explode the objects on the copy.

For more information, see Export to AutoCAD on page 591.

**EXTEND**

The EXTEND command extends objects to meet other objects.

In AutoCAD MEP, EXTEND works on duct, pipe, cable tray, and conduit segments, and plumbing lines. However, fittings are not automatically inserted. To have fittings inserted automatically based on the preferences in the drawing, use Add grips instead.

You can also extend plumbing lines and schematic lines using the FILLET command.

For more information, see the following topics:

- Adding Duct Using Grips on page 200
- Adding Pipe Using Grips on page 302
- Drawing a Plumbing Run Using Add Grips on page 487

**FILLET**

The FILLET command fillets and rounds the corners of objects. If you use this command to connect 2 objects and set the fillet radius to zero, the command trims or extends the objects until they intersect but does not create an arc.
In AutoCAD MEP, you can use FILLET to fillet not only AutoCAD objects, such as lines, polylines, and arcs, but also schematic lines and plumbing lines. By using FILLET with a fillet radius of zero (default), you can easily connect schematic lines or plumbing lines by extending or trimming them. You can use the command in orthographic mode or isometric mode.

**Filleting plumbing lines**

![Diagram showing the process of filleting plumbing lines]

**NOTE** The resulting single schematic line or plumbing line has the properties of the segment that you select first, such as system, style, and flow direction. In the case of plumbing lines, the resulting plumbing line also has an elbow of the type specified for the plumbing system. For more information, see Specifying the Default Fittings for a Plumbing System Definition on page 478.

For more information about the FILLET or EXTEND commands, see the AutoCAD Help.

---

**JOIN**

The JOIN command joins similar objects to form a single, unbroken object. You can also use it to create complete circles and ellipses from arcs and elliptical arcs.

In AutoCAD MEP, JOIN only works on AutoCAD objects, such as lines, polylines, arcs, and splines. However, you can join duct, pipe, cable tray, or conduit segments, as well as plumbing lines, by merging them. You can also connect plumbing lines or schematic lines with the FILLET command.

For more information, see the following topics:

- Breaking or Merging Duct on page 234
- Breaking or Merging Pipe Segments on page 329
- Breaking and Merging Cable Tray or Conduit Segments on page 449

---

**LENGTHEN**

The LENGTHEN command changes the length of lines, polylines, arcs, and splines and the included angle of arcs.

In AutoCAD MEP, LENGTHEN does not work on duct, pipe, cable tray, or conduit segments. Rather, you can use Lengthen grips to modify the length of segments. Depending on the editing mode you select, the grips move or lengthen connected objects to maintain their connectivity.
For more information, see the following topics:

- Modifying the Length of Ducts on page 225
- Modifying the Length of a Pipe Segment on page 322
- Modifying the Length of Cable Tray or Conduit Segments on page 446
- Modifying the Length of Plumbing Lines on page 497
- “Resize or Reshape Objects” in the AutoCAD Help

**MATCHPROP**

The MATCHPROP command copies some or all of the properties of one object to other objects.

In AutoCAD MEP, MATCHPROP only copies AutoCAD object properties, such as color, layer, linetype, and linewidth. To copy building systems object properties, such as system, elevation, and size, use the Match command option when adding or modifying an object. For more information see the following topics:

- Using Object Match on page 826
- “Copy Properties Between Objects” in the AutoCAD Help

**MIRROR**

In AutoCAD, the MIRROR command creates a mirror image copy of an object. MIRROR works similarly in AutoCAD MEP. For more information, see “Mirror Objects” in the AutoCAD Help.

**MOVE**

The MOVE command moves objects a specified distance in a specified direction.

In AutoCAD MEP, when you use MOVE to move a selection set of parts, fittings, and segments (for example, a complete duct branch), the software moves the objects and, if possible, connects a suitable object in the selection set, such as a tee or takeoff, to a segment at the destination. When connecting the moved object to the segment, the software breaks into the segment and then aligns and orients the object (and the selection set). However, the command does not connect or adjust disconnected objects that remain at the original location.

As an alternative to MOVE, use Location grips to move parts, fittings, segments, and schematic symbols. Depending on the editing mode you select, the Location grips move or adjust all affected objects to maintain the connectivity of the run.

To move devices or panels, use Alignment grips. The grips let you accurately align a device or panel perpendicular to an object, such as a wall.

To move schematic lines, use MOVE or enter a new location on the Location tab of the Schematic Line Properties dialog.

For more information, see the following topics:

- Moving Duct Components on page 221
- Moving Pipe Components Using Location Grips on page 320
- Moving a Device or Panel on page 431
- Modifying the Layout of a Cable Tray or Conduit Run on page 444
OFFSET

The OFFSET command copies a selected object, giving the copy a shape that reflects the original. Because OFFSET offsets polylines, in AutoCAD MEP you can use it to offset schematic lines.

You can also use this command to offset individual segments of duct, pipe, cable tray, or conduit, and individual plumbing lines. However, because the command does not support the selection of multiple objects, you cannot use it to offset a complete run.

For more information, see “Offset an Object” in the AutoCAD Help.

PURGE

The PURGE command removes unused, named AutoCAD objects, such as blocks, layers, and styles, from a drawing.

Because PURGE purges only AutoCAD objects, in AutoCAD MEP you should purge unused building systems objects first, and then use the Style Manager to purge unused system definitions.

For more information, see the following topics:
- Purging AutoCAD MEP Objects on page 590
- Purging Systems on page 101
- “Erase Objects” in the AutoCAD Help

ROTATE and ROTATE3D

The ROTATE command rotates an object around a base point. The ROTATE3D command rotates an object around a 3-dimensional axis.

In AutoCAD MEP, you can use ROTATE3D to rotate fittings around a specified axis and connection point. However, a quicker and easier alternative is Rotate grips. In plan or isometric views, you can use Rotate grips to rotate both fittings and inline parts. The grips adjust connected objects and maintain their connectivity whenever possible.

For more information, see the following topics:
- Rotating Duct Components on page 228
- Rotating Pipe Components on page 321
- Rotating Cable Tray or Conduit Fittings on page 450
- Rotating Plumbing Fittings on page 498
- “Rotate Objects” in the AutoCAD Help
SCALE
The SCALE command makes an object uniformly larger or smaller.
In AutoCAD MEP, SCALE properly resizes schematic symbols, electrical devices, electrical panels, plumbing fittings, and plumbing valves. You can also resize schematic symbols using their grips in Scale grip mode.
For more information, see the following topics:
■ Resizing Schematic Symbols on page 544
■ “Resize or Reshape Objects” in the AutoCAD Help

STRETCH
The STRETCH command relocates the object endpoints that lie across or within a crossing window selection.
In AutoCAD MEP, STRETCH increases the length of ducts, pipes, cable trays, conduits, and plumbing lines, but it does not adjust connected objects and can break their connectivity. For this reason, use Lengthen grips, instead of STRETCH, to modify the lengths of segments. Depending on the editing mode you select, the Lengthen grips move or lengthen connected objects to maintain their connectivity. On unconnected segments, you can also use the Start or End grips to change both the length and angle of the segment. To stretch or change the angle of a schematic line, drag a grip point to a new location.
For more information, see the following topics:
■ Modifying the Length of Ducts on page 225
■ Modifying the Length of a Pipe Segment on page 322
■ Modifying the Length of Cable Tray or Conduit Segments on page 446
■ Modifying the Length of Plumbing Lines on page 497
■ Modifying the Length of Schematic Lines on page 541
■ “Resize or Reshape Objects” in the AutoCAD Help

TRIM
The TRIM command trims objects at a cutting edge defined by other objects.
In AutoCAD MEP, TRIM only works on plumbing lines and segments of duct, pipe, cable tray, and conduit. However, fittings are not automatically inserted. For more information, see “Trim or Extend Objects” in the AutoCAD Help.

Help Resources
The AutoCAD MEP Help provides various help resources. Click ![Help Icon] and then click a help resources in the list. You can also explore various help resources in the Welcome Screen page in AutoCAD MEP.
Welcome to AutoCAD MEP 2010, an AutoCAD-based building design and construction documentation solution for Mechanical/Electrical/Plumbing engineers, designers, and drafters.

This section introduces you to the software and describes how to contact Autodesk, get help, navigate the user interface, and perform basic but important tasks.

About AutoCAD MEP

AutoCAD MEP is designed for the MEP (mechanical, electrical, piping, and plumbing) disciplines in the building industry. It includes:

- Catalogs of drawing objects that represent the real-world parts in building systems and that connect intelligently to one another.
- Tools specific to the mechanical, electrical, and plumbing disciplines, such as analysis tools for sizing systems for optimal performance.
- Common design tools that you can use in all 3 disciplines:
  - Project management tools that integrate building system designs with architectural building plans.
  - Tools for specifying design preferences that control how objects appear and behave.
- Drawing templates with basic, standards-based settings to get you started quickly.

You can use the software to design comprehensive systems for commercial, institutional, and residential building plans.
AutoCAD MEP Workflow

AutoCAD MEP provides features that allow the creation of very complex designs. While the software has many intricacies, there is a basic workflow for using it. Use the following table to navigate to detailed workflows for designing mechanical, electrical, and plumbing systems.

<table>
<thead>
<tr>
<th>General task</th>
<th>View more information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Establish high-level project parameters, and create document sets</td>
<td>Define project standards, the look of the drawing area, the look of parts, the tool catalogs to use, and other settings. See Working with Drawing Management Projects on page 129. Create sheets, sheet lists, and cover sheets for construction document sets. See Construction Document Workflow on page 547.</td>
</tr>
<tr>
<td>Link to architectural floor plans</td>
<td>Use Project Navigator to create cross references to the floor plans onto to which MEP designs will display. See Working with Referenced Drawings on page 158</td>
</tr>
<tr>
<td>Create preliminary domain outlines using flow and 1-line diagrams</td>
<td>Use the schematic tool set in MEP to create concept designs. See About Schematic Diagrams on page 518</td>
</tr>
</tbody>
</table>
| Create detailed domain designs using catalog parts and custom content        | Create:  
  - HVAC designs on page 163  
  - Electrical designs  
  - Plumbing designs  
  - Radiant heating system designs  
  - Piping system designs  
| Circulate designs for review                                                 | Use Drawing Compare to see how drawings differ from one revision to another. See Comparing Drawings on page 592 |

Intelligent Objects

AutoCAD MEP is an object-based CAD application. When you design in the application, you use large collections of objects that represent the real-world components in mechanical, electrical, and plumbing systems. Examples of these objects include segments of duct, pipe, cable tray, and plumbing lines; fittings of all types; and equipment—called multi-view parts or MvParts in the software—such as air handling units, electrical transformers, and drinking fountains.
AutoCAD MEP objects are composed of lines, arcs and other standard AutoCAD objects, but they also contain information that allows them to function like the real-world components that they represent, to relate intelligently to one another, and to display in a 2-dimensional (2D) or 3-dimensional (3D) context. The objects have specially designed connection points called connectors that enable them to connect intelligently to appropriate objects and transfer information, such as shape, size, and system.

As an example, you can insert a variable air volume (VAV) box into an HVAC system drawing, and then draw a duct from one of its connectors. When you draw the duct, the software detects the size and shape of the connector on the VAV box and draws an appropriate duct segment as shown.

Drawing duct from a VAV box

To continue the example, you can draw and connect additional duct segments, fittings, and HVAC equipment that are all intelligently connected in the same manner. As you do so, the software inserts and adjusts the objects in the run to maintain their connectivity. For example, it inserts appropriately-sized fittings as you lay out duct segments. It also inserts an appropriately-sized transition fitting if you change the size of a segment.

The ability of the software to detect the attributes of objects and act accordingly to maintain the connectivity of the system is an important aspect of the software. It enables you to design fully connected systems quickly and preserves their connectivity when you modify them.

**Location of Part Catalogs**

AutoCAD MEP includes objects that include hundreds of industry-specific, standards-based fittings and multi-view parts called MvParts. The objects are organized into part catalogs, which you access when you add or modify objects in your drawings.

The following part catalogs are available in both imperial and metric units:

- Cable Tray
- Conduit
- Duct
- MvParts on page 76 for all building systems disciplines
- Pipe

The software also includes additional content for style-based objects: electrical devices and panels, plumbing fittings and valves, and schematic symbols.
Analysis Tools

Mechanical, electrical, and plumbing systems require analysis to ensure proper sizing and operation. AutoCAD MEP includes several, integrated engineering tools for performing analyses:

- Before you begin to design, you can model spaces and zones to determine the heating and cooling loads for a building plan. You can also export the engineering data in Green Building Extensible Markup Language (gbXML) for analysis by third-party tools, and then import the results into your drawing. For more information, see Calculating Duct Sizes Using External Tools on page 241.

- As you draw, you can use instant sizing tools to calculate duct or wire sizes. For more information, see Drawing a Duct Run on page 196 or Drawing or Generating Wires on page 413.

- After you complete your design, you can analyze the HVAC, electrical, or plumbing system to check loads and resize components for optimal performance. For more information, see Calculating Duct Sizes for a Duct System on page 203, Calculating Wire Sizes Using the Circuit Manager on page 425, Calculating the Sizes of Supply Plumbing Lines on page 501, or Calculating the Sizes of Sanitary Plumbing Lines on page 508.

Project Management Tools

AutoCAD MEP includes tools that formalize and automate the processes related to building model design and documentation:

- a Project Browser—Use this tool to create design projects and specify high-level project information and settings, such as the project number, project name, and the file locations of the tool palettes and content library to use on the project.

- a Project Navigator—Use this tool to perform project-specific tasks, such as defining building levels and divisions, creating drawings, and creating plotting sheets.

When you manage your project using the Project Browser and Project Navigator, you have consistency in all aspects of the project. Everyone on your design team has a centralized project environment from which to access the most current information, tools, and documents—from project templates to composite views and construction documents.

For more information, see Working with Drawing Management Projects on page 129.

Contacting Autodesk

Use the following resources to contact Autodesk about AutoCAD MEP and other Autodesk products.

Corporate Headquarters

For general inquiries and information, contact Autodesk corporate headquarters:

Autodesk, Inc.
111 McInnis Parkway
San Rafael, CA 94903
USA
Phone: 415-507-5000, Web site: http://www.autodesk.com
Sales Information
To purchase additional Autodesk software, contact your local reseller. For the name of the authorized reseller nearest you, call 1-800-964-6432 or refer to the Reseller Center Web site: http://www.autodesk.com/resellers.

Technical Support
If you have a technical question, contact your local reseller or refer to the AutoCAD MEP Web site: http://www.autodesk.com/support. The Web site provides links to frequently asked questions, a searchable knowledge base, and searchable discussion groups.

For information on other help resources, see Getting Help on page 31.

Feedback
If you have a suggestion for a product enhancement, a compliment, or a complaint, or if you think you have found a defect, we would like to know about it. To provide feedback, visit the AutoCAD MEP Web site: http://www.autodesk.com/contact.

Getting Help
AutoCAD MEP includes several resources designed to help you learn the software.

Guides
To quickly get you started with AutoCAD MEP, the software includes several AutoCAD MEP guides in PDF format:

- *AutoCAD MEP 2010 User’s Guide*. This guide includes conceptual information on all features and step-by-step instructions on performing end user tasks. The information in the guide is also included in the online help.

- *AutoCAD MEP 2010 Network Administrator's Guide*. This guide provides information on how to perform network installations or multi-seat, stand-alone installations.

- *AutoCAD MEP 2010 Stand-Alone Installation Guide*. This guide provides information on how to perform a stand-alone installation for an individual user.

You can access PDF versions of the installation guides from the Installation Wizard, which launches when you insert the installation disc into your DVD drive. Click the Documentation link at the bottom of the left pane.

A PDF version of the *AutoCAD MEP 2010 User’s Guide* is located in the following folder: \Program Files\AutoCAD MEP 2010\Help.

To open or print a guide, you must have Adobe® Acrobat® Reader installed on your computer. If you do not have Acrobat Reader installed, you can download the latest version from the Adobe Web site: http://www.adobe.com.

**NOTE** PDF versions of the user’s guides for AutoCAD Architecture and AutoCAD are also available on the AutoCAD MEP installation disc. To access them, use Windows® Explorer to navigate to the \Install\docs folder.
Tutorials

AutoCAD MEP includes these in-depth, domain-specific tutorials that are available by download:

- Mechanical/Piping
- Electrical
- Plumbing
- Construction Documents

In addition to these in-depth tutorials, the Express Workshop provides mini-tutorials to get up and running quickly.

For more information, click ➤ Tutorials from the InfoCenter in the software.

Training

Training programs and products from Autodesk help you learn the key technical features of your Autodesk software and improve your productivity. For the latest information about Autodesk training, visit http://www.autodesk.com/autocadmep-training or contact your local Autodesk office.

Classes

Be more productive with Autodesk® software. Get trained at an Autodesk Authorized Training Center (ATC®) with hands-on, instructor-led classes to help you get the most from your Autodesk products. Enhance your productivity with proven training from over 1,400 ATC sites in more than 75 countries. For more information about Autodesk Authorized Training Centers, contact atc.program@autodesk.com or visit the online ATC locator at http://www.autodesk.com/atc.

Courseware

Autodesk publishes many courseware titles each year for users at all levels to improve their productivity with Autodesk software. The preferred training materials of Autodesk partners, these books are also well-suited for self-paced, standalone learning. All courseware simulates real-world projects with hands-on, job-related exercises. **Autodesk Official Training Courseware (AOTC)** is developed by Autodesk. **Autodesk Authorized Training Courseware (AATC)** is developed by Autodesk partners, including titles in a growing number of languages. **Autodesk Official Certification Courseware (AOCC)** teaches the knowledge and skills assessed on the Certification examinations. Visit http://www.autodesk.com/aotc to browse the Autodesk Courseware catalog.

E-Learning

Autodesk e-Learning for Autodesk Subscription customers features interactive lessons organized into product catalogs. Each lesson is 20-40 minutes in length and features hands-on exercises, with an option to use a simulation or the software application. You can also use an online evaluation tool that identifies gaps in skills, determines what lessons will be most helpful, and gauges learning progress.

If you are a member of Autodesk subscription, you can access e-Learning and other subscription services from within your Autodesk product. For more information about Autodesk subscription resources, visit http://www.autodesk.com/subscription.
Certification

Gain a competitive edge with your career by obtaining Autodesk Certification, validating your knowledge and skills on Autodesk products. Autodesk provides an end-to-end solution for assessing your readiness for certification, preparing for certification, and obtaining certification. For more information on Autodesk Certification, visit http://www.autodesk.com/certification.

Discussion Groups

Autodesk provides searchable, peer-to-peer discussion groups and blogs in which you can ask questions and share information with other users of Autodesk products, including AutoCAD MEP. For more information, see the Autodesk Web site: http://www.autodesk.com/autocadmep-community.

Additional Resources

From the Help menu in the software, you can access additional help resources, including but not limited to a searchable AutoCAD MEP knowledge base, resources for developers, and support services for members of the Autodesk Subscription program.

Updating AutoCAD MEP

AutoCAD MEP includes a notification tool called the Communication Center that keeps you informed about service pack availability. If you are a member of the Autodesk Subscription program, the Communication Center also notifies you of additional product information, such as extension availability, tips, and support information. You can set the Communication Center to notify you of updates and other information daily, weekly, or monthly, or you can update on demand. For more information, see “Overview of Communication Center” in the AutoCAD Help.

The AutoCAD MEP 2010 Drawing Domain

The AutoCAD MEP 2010 user interface provides access to the commands and controls that enable the production of intricate M/E/P designs. Later sections describe this workspace in detail. By way of introduction, here are the highlights:

Ribbon

Using the Microsoft Office 2007 model, AutoCAD MEP 2010 now uses the ribbon as the central access point for commands. The ribbon contains a number of tabs on which commands are grouped according to conceptual task types or selected objects.

The ribbon replaces the menu bar and the toolbars as the primary command access point.

Application Menu

The application menu contains basic commands pertaining to the drawing as a whole: Open, Save, Print, Export etc. Like the menu browser it replaces, the application menu is accessed by clicking MEP in the upper-left corner of the workspace.
Workspaces

AutoCAD MEP is equipped with six workspaces (HVAC, Piping, Electrical, Plumbing, Schematic, and Architecture). The default workspace after initial installation is HVAC, but can be user-defined (see Workspace Settings on page 37).

NOTE The tool palette groups associated with all the workspaces are available from the context menu of the tool palettes set.

Drawing Status Bar Menu

The drawing status bar menu has been removed from AutoCAD MEP 2010. Commands formerly found there can now be accessed from the application menu.

Commands on the old menu

<table>
<thead>
<tr>
<th>Drawing Setup...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drawing Properties...</td>
</tr>
<tr>
<td>Plot Preview</td>
</tr>
<tr>
<td>Bit... (Ctrl+P)</td>
</tr>
<tr>
<td>Publish...</td>
</tr>
<tr>
<td>Publish to Web...</td>
</tr>
<tr>
<td>Publish to MapGuide...</td>
</tr>
<tr>
<td>Publish to 3D DAE...</td>
</tr>
<tr>
<td>eTransmit...</td>
</tr>
</tbody>
</table>

Help Access

With the removal of the menu bars, the commands to access Help features have been moved into the InfoCenter at the top right of the application window. Here, you can find the online resources of InfoCenter and the Help menu, which lets you access Help, Tutorials, and other interactive resources.
Toolbars

Toolbars have been removed from AutoCAD MEP. Commands formerly found on toolbars can now be accessed from the ribbon.

Autodesk Seek

You can use Autodesk Seek to find product design information. Many content providers, both corporate partners and individual contributors, publish to Autodesk Seek. Content includes 3D models, 2D drawings, specifications, brochures, and other descriptions of products or components.

Import design content into AutoCAD MEP 2010

You can also share your own content with others using Autodesk Seek. Upload drawings or blocks to Autodesk Seek to give your partners and customers ready access to your content.

Workspace Fundamentals

Workspaces are user interface configurations that determine the ribbon panels that display in the drawing window. For example, the workspace determines whether the Tool Palettes window and Command Line window float or dock to specific sides of the application window.

If you work in a multi-disciplinary firm and perform several different design tasks, such as the design of HVAC and piping systems, workspaces are particularly useful. You can use them to save user interface configurations that are tailored to different tasks. Once the workspaces are created, you can quickly switch between them as needed.
Example of Piping workspace

![Image of Piping workspace]

Default Workspaces in AutoCAD MEP

AutoCAD MEP includes pre-built workspaces for several building systems disciplines.

<table>
<thead>
<tr>
<th>Workspace</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HVAC</td>
<td>Configured for the design of HVAC systems. Ribbon tabs are populated with HVAC tools and commands, and the HVAC tool palette group is displayed.</td>
</tr>
<tr>
<td>Piping</td>
<td>Configured for the design of piping systems. Ribbon tabs are populated with piping tools and commands, and the Piping tool palette group is displayed.</td>
</tr>
<tr>
<td>Electrical</td>
<td>Configured for the design of electrical systems. Ribbon tabs are populated with electrical tools and commands, and the electrical Electrical tool palette is displayed.</td>
</tr>
<tr>
<td>Plumbing</td>
<td>Configured for the design of plumbing systems. Ribbon tabs are populated with plumbing tools and commands, and the Plumbing tool palette group is displayed.</td>
</tr>
<tr>
<td>Schematic</td>
<td>Configured for the design of schematic diagrams. Ribbon tabs are populated with schematic tools and commands, and the Schematic tool palette is displayed.</td>
</tr>
<tr>
<td>Architecture</td>
<td>Configured for the design of architectural plans. Ribbon tabs are populated with architecture-specific tools and commands and the architecture tool palette group is displayed.</td>
</tr>
</tbody>
</table>
Creating Workspaces

You can create your own personal workspaces or, if your design organization requires more control over your drawing environment, your CAD manager can create read-only workspaces designed to be shared by many users.

To create a personal workspace

1. Arrange the ribbon panels in the drawing environment as desired.
2. On the application status bar, click the active workspace ➤ Save Current As.
3. Enter a name for the workspace, and click Save.

For more information on workspaces, including information on modifying workspaces and the differences between workspaces and profiles, see “Create Task-Based Workspaces” in AutoCAD Help.

Switching Workspaces

To activate a workspace, select the workspace name from the drop-down list on the application status bar.

Workspace Settings

Select Workspace Settings from the drop-down list on the application status bar to:

- Set the default workspace (MyWorkspace)
- Change the order of the workspaces list
- Add separators
- Specify whether to automatically save workspace changes
Workspace Components

The workspace consists of a drawing window with ribbon, tool palettes, and other controls that you use to set up a M/E/P project, create your design, and generate construction documents.

In the following sections, each component of the workspace is described in detail. Components can be turned off and on for different workspaces, depending on your requirements.

For an interactive guide to the user interface, click the Help button in the InfoCenter on the top right of the application window and click User Interface Overview.
Ribbon

The ribbon is the central location for accessing commands in AutoCAD MEP 2010. The ribbon is organized into tabs that reflect common tasks in the drawing process. There are 2 types of tabs:

- Static tabs are available regardless of whether objects are selected in the drawing area. The commands on these tabs previously appeared on menus and toolbars.

  Static Home tab

- Contextual tabs display depending on the object selected in the drawing area. When you select a duct, the ribbon displays a contextual tab for Duct. The commands on the contextual tabs reflect the commands on the context (right-click) menu of an object.

  Contextual tab for duct objects

Displaying the Ribbon

To display the ribbon if it is not displayed in your workspace, or has been turned off, enter `ribbon` on the command line.

You can use the button at the right of the tab names to modify the appearance of the ribbon as follows:

- To display only the panel titles of the ribbon tabs, click (Minimize to Panel Titles) at the top right of the ribbon.

- To display only the tab names as titles, click again (Minimize to Tabs).

- To redisplay the full ribbon, click a third time (Show Full Ribbon).

Using the Ribbon

To start a command from the ribbon

1. If the ribbon is not displayed by default, enter `ribbon` on the command line.
2. Click the desired tab.
3. Move the cursor over the commands on the tab as needed to view tooltips describing the commands.
4. Click a command.
Some ribbon commands are grouped under a drop-down menu. You can access them by clicking the arrow next to the command.

**Example of drop-down menu**

Some panels have an expansion arrow ▼ to indicate that the panel can be expanded. The expanded part typically contains commands that are less frequently used.

5 The expanded panel is displayed when you click the arrow ▼. To pin the expanded part of the panel onscreen, click ▪.

**To tear of a panel from a static ribbon tab**

6 If you want a panel from a static tab to remain in your workspace when you switch to another tab, you can tear the panel off its tab and use it as a floating palette. To do so, move the cursor over the title bar of the panel, and then drag the panel off the ribbon and into the drawing area.
The software automatically saves any changes you make to the workspace unless you changed the default workspace setting on page 37 for saving changes.

To return a floating panel to the ribbon

7 Move the cursor over the floating panel, and click Return Panels to Ribbon.

To hide and display tabs and panels

8 To hide or display tabs and panels:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>hide a tab</td>
<td>right-click anywhere on the ribbon, click Tabs and click the static tab to deselect it.</td>
</tr>
<tr>
<td>display a tab</td>
<td>right-click anywhere on the ribbon, click Tabs and click the static tab to select it.</td>
</tr>
<tr>
<td>hide a panel</td>
<td>click the tab you want to modify, click Panels, right-click on the ribbon, and click the panel name to deselect it.</td>
</tr>
<tr>
<td>display a panel</td>
<td>click the tab you want to modify, click Panels, right-click on the ribbon, and click the panel name to select it.</td>
</tr>
</tbody>
</table>

A check mark next to each tab or panel name indicates that it is currently being displayed on the ribbon.

Locating Commands in the Workspace

The ribbon is intuitive and task-related, and so the transition from menus and toolbars to the new UI will in most cases be quick and easy. However, it is a new design and so the following tips might be helpful to be productive without a break.

Where is My Command? Tool

The Where is my command? tool is a help file that lists all commands by their previous menu location and displays their current location on the ribbon.
Where is My Command? tool

You can access the Where is my Command? tool from the Help menu ➤ Where is my Command, or from the landing page of the regular Online Help.

Home Tab

The Home tab contains the most frequently used commands within the software. Basic object and drawing tools can be found here, as well as frequently used utilities like modification tools, layers, and basic annotation. Use the Home tab as your starting point in a new drawing.

Application Menu

The application menu has a Search mode, where you can enter a full or partial command name, and see a list of locations in the user interface where the command can be accessed. For more information, see Application Menu on page 48.

Context Menu

Commands that refer to a selected object appear on the contextual tab for that object. Commands disappear from the ribbon after the object is deselected.

Duct context tab

The command layout of the contextual tab of an object is in most cases based on the structure of commands on the context menu of the object.
Duct context menu

For example, on the context menu of a duct you can find the Add Selected command. On the contextual Duct tab, you can find the Add Selected command on the General panel.

Finding More Information about the Ribbon

Use the following resources to find out more about the ribbon:

- New Features Workshop
- Tutorials

Static Ribbon Tabs

The workspace comprises a set of static tabs that are optimized for M/E/P tasks. The default HVAC workspace for the US version of AutoCAD MEP 2010 includes the following static tabs on the ribbon. The following sections describe these tabs and the panels they contain.

Home Tab

The Home tab contains the most frequently used commands within the software. Basic object and drawing tools can be found here, as well as frequently used utilities like modification tools, layers, and basic annotation.

- Build. Contains the basic commands for adding the most commonly used objects, like ducts, duct fittings, and equipment, as well as commands for opening the tool palettes on page 87, Properties palettes on page 91, and the Content Browser Overview.
- Draw. Contains common linework tools, like lines, polylines, and rectangles, as well as hatch and boundary tools and polygons.
- Modify. Contains commands for manipulating objects and linework in a drawing. In addition to standard commands like Move, Rotate, Erase, Offset, Mirror, Scale, Array, Explode, Join, there is also a command for converting AEC objects to mass elements and converting mass elements to 3D Solids.

- Layers. Contains commands that you need to work with layers. You can open the Layer Manager and the Layer States Manager from here.

- Annotation. Contains basic commands for inserting text, leaders, and dimensions. For more information, see Annotate Tab on page 45.

- Inquiry (Schematic and Architecture workspaces only). Contains commands for measuring distance and areas, and the AutoCAD list command. Furthermore, you can find commands for evaluating architectural spaces.

- Section and Elevation. Contains commands for generating sections and elevations of your plan or model. To create sections and elevations with callouts, see the Callouts panel on the Annotate tab on page 45.

- Details. Accesses Detail Component Manager from which you can insert detail components directly into drawings or onto tool palettes.

**Floating View Panel**

The floating View panel offers access to the commands for Views, visual styles, and the Zoom and Pan tools. This panel is not docked to the ribbon by default, so you can access it independently of the current ribbon tab. You can dock the floating View panel to the Home tab, if desired.

**Insert Tab**

The Insert tab lets you work with references, blocks, multi-view blocks, attributes, and content from external sources like Content Browser and Autodesk Seek.

- Reference. Contains commands for working with external references (xrefs), DWF/DWFx files, DGN underlays, and raster images.

- Block. Contains commands for inserting and editing blocks and multi-view blocks.

- Attributes. Contains commands for creating and editing attributes.

- Import. Contains commands for importing Radiator, WMF, ACIS, 3D Studio Max, DGN, and LandXML files.

- Content. Contains commands for inserting content from Content Browser Overview, from DesignCenter, or from Autodesk Inventor into your drawing.

- Seek Panel: The Seek panel lets you search online for prefabricated design content. For more information about Seek, see “Use Autodesk Seek to Share Drawings” in the AutoCAD Help.
Annotate Tab

The Annotate tab contains commands that help you to mark up your drawing files.

**Annotate tab**

- **Tools.** Accesses the Document tool palettes set.
- **Text.** Contains all commands for text and text styles and accesses the Fields editor.
- **Dimensions.** Contains commands for inserting and editing both AEC and AutoCAD dimensions.
- **Scheduling.** Contains commands for inserting schedule tables on page 566 for basic objects, creating and inserting schedule tags on page 566, and running a space evaluation. Additionally, you can create schedule table styles, and renumber property set data on page 588.
- **Callouts.** Contains commands for placing title marks, sections, elevations, and detail views.
- **Label.** Provides commands for attaching MEP Labels and leaders.
- **Keynoting.** Contains commands for adding sheet and reference keynotes, keynote legends, opening the keynote editor, and selecting a keynote database.
- **Markup.** Accesses commands for marking up a drawing for review. You can add revision clouds, mask blocks, wipeouts, open the Markup Set Manager, and load a markup DWF.
- **Annotation Scaling:** Commands here let you add the current scale to objects, display and edit the scale list, and add and delete scales for annotative objects.

Analyze Tab

The Analyze tab contains all the commands you need to make engineering calculations on the objects in the current workspace. These calculation tools vary from the HVAC workspace to the Electrical and other workspaces.

**Analyze tab**

- **Inquiry.** Provides tools to check for interferences between MEP objects and mass elements, to determine the distance between or area bounded by selected objects, and the QuickCalc tool for performing calculations.
- **HVAC.** Provides a duct size calculation tool, plus a way to import DuctXML and gbXML data.
- **Space and Zone:** Provides tools for adding spaces and zones to your drawings, and to create and modify space/zone templates.

View Tab

The View tab is the central location for defining and changing views and navigating the drawing.
NOTE  The View tab contains a number of commands also found on the application status bar.

- **Navigate.** Contains the ViewCube and SteeringWheels, as well as the Pan, Zoom, and Orbit commands.

- **Appearance.** Here, you can select predefined views, create new views, open View Manager, select a visual style, open the Visual Styles Manager, and define Walk and Fly settings. You can access predefined display themes. You can also adjust clip planes and access the Regenerate commands.

- **Coordinates.** Contains commands relevant to the World Coordinate System (WCS) or User Coordinate System (UCS).

- **Viewports.** Here you can switch between different viewport configurations, create new viewports, and clip and join viewports.

- **Face Effects.** Contains commands for defining object settings, including shading, color, face lighting, and x-ray.

- **Edge Effects.** Contains command for defining edge settings, including facet edges, isolines, edge overhang, jitter, and silhouette. You can also define the color of obscured edges and edge intersections here.

- **MEP View.** Provides tools to see the flow direction of ducts and pipes, a command to display broken connections (solution tips), and a way to adjust the compass settings. The expanded tab provides a way to hide the compass bar, and a tool for controlling the size of solution tips.

- **Windows.** Contains most of the commands that were on the Windows menu in previous versions. Here you can switch between open drawings, arrange open windows onscreen, lock the workspace windows, display and hide the drawing window status bar on page 53, turn items on the drawing window status bar on an off, and display the text window.

### Manage Tab

On the Manage tab, you can find features for advanced users and CAD managers.

- **Action Recorder.** Contains commands for recording and playing action macros.

- **CAD Standards.** Contains commands for configuring AutoCAD standards, check your drawing for standards violations, and start Layer Translator.

- **Project Standards.** Contains commands associated with project standards for an AEC project. You can configure project standards, synchronize the project with its standards, synchronize standards with each other, and audit projects and drawings.

- **Style and Display.** Accesses the Style Manager, the Display Manager, the AEC Dimension Style Wizard, the structural member catalog, and the structural member wizard. You can also define and insert profiles.

- **Preferences (HVAC, Piping, Electrical, and Plumbing workspaces only).** Provides a way to set or modify preferences.

- **MEP Content.** Provides commands to launch Content Builder and Catalog Editor. The expanded panel provides tools to change, test, and migrate catalog data, as well as tools to batch convert and decompose drawing components.
Applications. Contains commands for loading extra applications, like ARX, LSP, or VB applications, and running user-defined scripts and VBA macros. Also accesses the VBA Manager and the Visual Basic and Visual Lisp editors here.

Customization. Accesses the User Interface Editor (CUI) and the tool palettes on page 87.

## Contextual Tabs

The following table lists and describes the contextual tabs in AutoCAD MEP. All contextual tabs include a General panel containing several generic commands, such as Select System, Object Viewer, and Isolate Objects.

<table>
<thead>
<tr>
<th>Contextual Tab Name</th>
<th>Unique Commands</th>
</tr>
</thead>
<tbody>
<tr>
<td>Duct</td>
<td>Insert Equipment, Duct Properties, Duct Modify, Duct Length, Calculate Duct Sizes, Set Flow Direction, Show/Update Flow</td>
</tr>
<tr>
<td>Duct Fitting</td>
<td>Insert Equipment, Duct Fitting Properties, Duct Fitting Modify, Add/Remove Vanes, Calculate Duct Sizes, Set Flow Direction, Show/Update Flow</td>
</tr>
<tr>
<td>Duct Custom Fitting</td>
<td>Insert Equipment, Custom Fitting Properties, Calculate Duct Sizes, Set Flow Direction, Show/Update Flow</td>
</tr>
<tr>
<td>Duct Flex</td>
<td>Insert Equipment, Flex Duct Properties, Flex Duct Modify, Calculate Duct Sizes, Set Flow Direction, Show/Update Flow</td>
</tr>
<tr>
<td>Pipe</td>
<td>Insert Equipment, Pipe Properties, Modify Run, Pipe Length, Set Flow Direction, Show Flow</td>
</tr>
<tr>
<td>Pipe Fitting</td>
<td>Insert Equipment, Set Flow Direction, Show Flow</td>
</tr>
<tr>
<td>Pipe Custom Fitting</td>
<td>Insert Equipment, Custom Fitting Properties, Set Flow Direction, Show Flow</td>
</tr>
<tr>
<td>Plumbing Line</td>
<td>Insert Fitting, Modify Plumbing Line, Add Expansion Loop, Merge Plumbing Line, Size Plumbing Line, Show Objects for Sizing, Reverse Flow</td>
</tr>
<tr>
<td>Plumbing Fitting</td>
<td>Show Connected Objects</td>
</tr>
<tr>
<td>Cable Tray</td>
<td>Modify Cable Tray, Cable Tray Properties, Cable Tray Length</td>
</tr>
<tr>
<td>Cable Tray Fitting</td>
<td>Modify Fitting, Fitting Properties</td>
</tr>
<tr>
<td>Conduit</td>
<td>Modify Conduit, Conduit Properties, Conduit Length</td>
</tr>
</tbody>
</table>
Application Menu

The application menu contains commands that are relevant for the drawing as a whole.

The application menu contains commands for the following file operations:

- Create new drawings and projects
- Open drawing files, project files, DGN files, and IFC files
■ Save drawings to the current file format, to AutoCAD 2007 file format, as DWT file, or as DWS file
■ Export files to DGN, DWF, PDF, IFC, gBXML, and DuctXML formats, and previous versions of AutoCAD
■ Plot drawings
■ Publish drawings to Mapguide, DWF, Seek, and eTransmit
■ Access drawing setup and drawing utilities
■ Access the program options
■ Close drawings and projects
■ Exit AutoCAD MEP

Accessing the Application Menu

To access the application menu, click at the upper-left corner of the workspace.

The application menu remains open as long as the cursor is located inside the application menu window. To close the application menu, either activate a menu command, or click outside of the application menu window.

Using the Application Menu to Locate Commands

In the application menu, you can search for a command and then select it from the list of matches. Search results are retrieved from the following locations:

■ Application menu
■ Static ribbon tabs
■ Any contextual tab currently on display
■ Quick Access toolbar

You can enter the following strings to search for:

■ Display name of the command in application menu, ribbon or Quick Access toolbar. For example, you can enter “Style Manager” or “Plot Preview”.
■ Part of the display name: If you are not sure what the exact name is you can enter a part of the name, for example “Style” or “Save”. This will retrieve all commands that contain that string.
■ Actual command name: You can enter the name of a command as it would be typed on the command line, for example “aecstylemanager” or “dist.” This will retrieve all locations this command can be found in.

IMPORTANT When searching for AutoCAD MEP 2010 commands, you must include the Aecb prefix (for example, aecbPipeAdd instead of PipeAdd) to the command.

In addition to instances of the search string, the results include the contents of the associated tooltip and any search tags you have defined in the Customize User Interface editor (CUI). For information about search tags, see “Assign Search Tags” in the AutoCAD help.
1 At the upper-left corner of the workspace, click \( \text{Menu} \) to open the application menu.
2 In the text entry box at the top of the menu, enter the desired search term. A list of matches replaces the regular application menu display.

![Application Menu with Recently Opened Documents](image)

3 To select one of the found commands, click it.

4 To return to the regular application menu display, click \( \text{X} \) at the right side of the text entry box.

**Displaying Recently Opened Documents in the Application Menu**

The application menu lets you display a list of recently opened documents according to preferences you specify.

1 Click \( \text{Menu} \) to open the application menu.

2 At the top of the menu, click Recent Documents \( \text{Recent Documents} \).

3 At the top of the menu, under Recent Documents, specify how you want documents grouped:
   - By access date
   - By Size
   - By Type (DWG, APJ, and DGN)
   - By Ordered List (alphabetical order)
4 At the top right of the list of documents to specify whether to display file type icons or preview images next to the document names.

5 If you want to keep a document in the list, regardless of its last-saved date, click its pushpin so that the image changes from to . The document will remain in the list until you unpin it.

### Displaying Currently Open Documents in the Application Menu

The application menu lets you display currently open documents.

1. Click to open the application menu.
2. At the top of the menu, click Open documents.
3. At the top right of the list of documents, to specify whether to display file type icons or preview images next to the document names.

### Changing the Number of Recent Files and Actions in the Application Menu

Use this procedure to change the default number (9) of recent documents displayed in the application menu:

1. Click to open the application menu.
2. At the bottom of the application menu, click Options.
3. On the Open and Save tab of the Options dialog, under Application Menu, change the value for Number of recently-used files.
4. Click OK.

### Quick Access Toolbar

The Quick Access toolbar is a customizable toolbar located at the top of the application window, just to the right of the application menu button.

By default, this toolbar contains a set of frequently used commands for the application. You can add and remove commands as needed.
To add a command from the ribbon

1. On the ribbon, locate the command you want to add.
2. Right-click the command, and click Add to Quick Access Toolbar.

**NOTE** Not all commands can be added to the Quick Access toolbar. If a command is ineligible, the Add to Quick Access Toolbar command is not visible in the context menu.

To add other commands to the Quick Access Toolbar

3. On the Quick Access toolbar, click the down arrow at the right end of the toolbar, and select More Commands.
4. In the Customize User Interface Editor, select the command you want to add and drag it onto the Quick Access toolbar.

To remove a command from the Quick Access toolbar

➤ Select the command on the Quick Access toolbar, right-click, and click Remove from Quick Access Toolbar.

**Context Menus**

When you right-click in the drawing area, the content of the context menu depends on the currently selected object(s). For example, if one or more duct objects are selected, a duct-specific context menu is displayed as shown.

**Duct context menu**

Most commands that can be found on the context menu of an object exist in the contextual ribbon tab of the object, too.

If more than one type of object is selected, the context menu includes only those commands that can be applied to all the selected objects. Likewise, the ribbon displays a Multiple Objects contextual tab that contains only the applicable commands. If no objects are selected, the general context menu is displayed as shown below. This menu contains non-object-specific commands.
Tool Palettes

Tool palettes provide the main method for accessing tools to create objects in your model. You can have tools for standard objects as well as for objects with specific styles and properties. Tool palettes are organized by tool palette groups in a tool palettes set. You can create your own tool palettes, or you can copy existing tool palettes from the Content Browser.

For more information, see Working with Tool Palettes on page 87.

Properties Palette

The Properties palette provides a central location to view and modify both the physical and graphical properties of an object. The object can be one you are about to draw, or one that is already selected in the drawing area. Using the Extended Data tab of the Properties palette, you can also attach other kinds of information to an object, such as classifications, notes, reference documents, hyperlinks, and property set data. You typically keep the Properties palette open during an AutoCAD MEP session.

For more information, see Working with the Properties Palette on page 91.

Drawing Status Bar

Located at the bottom of the drawing area, the drawing status bar displays status information about the current drawing and provides access to the following commands that can be applied to the drawing.

The drawing status bar contains the following information and controls:

- Project Information: If the drawing is part of an AutoCAD MEP project, this information includes the name of the project and the type of file, (such as View or Construct). For more information, see Concepts of Drawing Management.

- Annotation Scale: To change the annotation scale for the current viewport, click the current value, and select a new one from the list. Changing the scale may also change the Level of Detail setting described below.
■ Annotation Visibility: Click \( \text{●} \) to show annotative objects for all scales. Click \( \text{●} \) to automatically add scales to annotative objects when the annotation scale changes.

■ Level of Detail: Shows the current display configuration of the active viewport and provides a drop-down list from which you can select another configuration.

■ Cut Plane: Identifies the global cut plane height for the active display configuration and provides access to a dialog that lets you adjust the setting. For more information, see Overriding the Cut Plane on page 150.

■ (Surface Hatch Toggle): Lets you switch the display of surface hatching on or off. For more information, see Working with Surface Hatches.

■ (Layer Key Overrides): Lets you switch layer key overrides on or off in the Layer Key Overrides dialog. For more information, see Layer Key Overrides.

■ (Isolate Objects): Lets you hide or display objects you have selected in the drawing.

■ (AEC Project Standards): When a project is loaded, click here to synchronize or configure standards for the current project. For more information, see Project Standards Overview.

■ (Autodesk Trusted DWG): This icon indicates that you have opened a DWG, DWT, or DWS file that is created using Autodesk applications or RealDWG™-based applications.

■ (Manage Xrefs): Click to open the External References palette, where you can reload xrefs that are associated with your current drawing.
Missing Standards File(s): When applicable, this warning indicates that standards files are missing in the current drawing; you can then check settings for the standards and configure them as necessary. For more information, see Configuring Project Standards.

Drawing Status Bar Menu: A drop-down list of the settings and commands available for display on the drawing status bar.

Showing and Hiding Commands on the Drawing Status Bar

You can specify which features on the drawing status bar menu are shown or hidden as needed.

1  At the right end of the drawing status bar, click the drawing status bar menu arrow.

2  Select commands you want show, and clear commands you want to hide.

Showing and Hiding the Drawing Status Bar

The drawing status bar can be turned on and off from the ribbon or from the application status bar on page 56.

To show and hide the drawing status bar, click View tab ▶ Windows panel ▶ Drawing Status Bar.

Command Line

You can directly enter commands using the command line window located immediately below the drawing status bar.

To hide and display the command line window, click View tab ▶ Windows panel ▶ Command Line.

If you want to hide the floating command line window except for its title bar when you are not using it, click on the title bar of the command line window. Moving the cursor over the title bar will redisplay the command line window. This icon is not displayed when the command line is docked at the bottom of the drawing area.
Floating command line

Application Status Bar

The application status bar contains settings for the current drawing session. Some settings, such as options for different elevations, only display if you are working within a project.

The group of commands on the left side of the application status bar can be displayed as icons or text labels.

**Commands displayed as icons**

**Commands displayed as text labels**

To change the display of these commands right-click any of them, and select Use Icons.

To activate or deactivate any of the commands in this group, click the icon or label. Blue indicates an active control; gray indicates an inactive control. To change the settings for one of these commands, right-click the icon or label, and click Settings.

For detailed information about these options, see “Use Precision Tools” in the AutoCAD help.

The following commands and settings are available on the application status bar:

- **Cursor coordinate values**: Controls the coordinate format as either relative or absolute. For more information, see “Overview of Coordinate Entry” in the AutoCAD help.

- **(Snap)**: Lets you restrict the movement of the cursor to the drawing grid.

- **(Grid)**: Lets you display a rectangular grid as a drawing aid.

- **(Ortho)**: Lets you restrict cursor movement to horizontal and vertical directions when creating and modifying objects.

- **(Polar Tracking)**: Lets you restrict cursor movement to specified angles.

- **(Object Snap)**: Lets you restrict movement of the cursor to specified points on objects, such as the midpoint or an intersection point.

- **(Object Snap Tracking)**: Lets the cursor track along alignment paths based on other object snap points when specifying points in a command. This feature can be used only in conjunction with Object Snap.
(Dynamic UCS): Lets you temporarily and automatically align the XY plane of the UCS with a plane on a solid model while creating objects.

(Dynamic Input): Lets you enter values for objects directly onscreen near the cursor. Dynamic input can be turned on and off during creating or editing an object in the drawing area.

(Lineweight): Lets you turn the lineweight display component on or off for objects in the drawing. In model space, lineweights are displayed in pixels and do not change when zoomed in or out. Displaying the lineweight could create some very heavy line display.

(Quick Properties): This feature is intended for AutoCAD objects and is turned off in AutoCAD MEP.

(Model Space) or (Paper Space): Switches between layouts. For more information, see “Work with Model Space and Paper Space” in the AutoCAD Online Help.

(Quick View Layouts): Lets you preview model space and all layouts in a drawing as a horizontal row of images. Click on a preview image to display the layout. For more information, see Quick View Tools and “Navigate within a Drawing (Model Space and Layouts)” in the AutoCAD Help.

(Quick View Drawings): Lets you preview all currently open drawings with their model space and layouts. Click on the preview image to display the drawing or layout. For more information, see Quick View Tools and “Navigate Between Open Drawings” in the AutoCAD Help.

(ShowMotion): Provides an onscreen display that can be used to create, select, and play back cinematic camera animations called shots. These animations can be used for presentation purposes or for navigation. For more information, see “ShowMotion” in the AutoCAD Help.

(Pan): Lets you drag the view to reposition it within the drawing area

(Zoom): Lets you increase or decrease the apparent size of objects in the drawing area

(SteeringWheel): Lets you display a tracking menu containing different navigation tools. For more information, see “Navigate with SteeringWheels” in the AutoCAD Online Help.

(Workspaces): Lets you switch between workspaces. For more information, see Workspace Fundamentals on page 35.

(Toolbar/Window Positions): Lets you switch between docked windows and toolbars and floating windows and toolbars.

Elevation: Click to open the Elevation Offset dialog. Select a level for the calculation of the elevation offset. This option is available only if your current drawing is a construct drawing from an AEC project.

(Replace Z value with current elevation): Can be switched on or off, replacing the existing Z value with the current elevation.
(Clean Screen): Click to switch between the standard screen and a full screen. In full-screen mode, all toolbars and palettes (except the tool palettes) are hidden. Hidden palettes retain their current state.

**Showing and Hiding Commands on the Application Status Bar**

You can show or hide individual commands on the application status bar menu.

1. At the right end of the application status bar, click the application status bar menu arrow.

2. Select commands as desired.

---

**NOTE** Alternatively, you can click View tab ➤ Windows panel ➤ Status Bar to access these commands.

---

**Project Navigator Palette**

The Project Navigator palette is the central location to create, modify, and access AutoCAD MEP project files. You typically have the Project Navigator palette open in the workspace while you work on a project. For more information, see Concepts of Drawing Management.
Finding Information in AutoCAD MEP

In addition to online help and tutorials, AutoCAD MEP provides various ways to quickly access the information you need to be successful with new and existing features. Review the sections below to learn how you can get help quickly and with minimal disruption of your workflow.

InfoCenter Toolbar

InfoCenter is a central location where you can search for product-related help and other information sources. You can search for information through keywords (or by typing a phrase), display the Communication Center panel for product updates and announcements, or display the Favorites panel to access saved topics.

When you enter keywords or type a phrase, and then press ENTER or click the Search button, you search multiple Help resources in addition to any files that have been specified in the InfoCenter Settings dialog. The results are displayed as links on a panel. You can click any of these links to display the Help topic, article, or document.

In addition, Communication Center displays Did You Know balloons for selected feature areas. These balloons provide knowledge base information and general instructional messages such as tips. You can click on the arrow icon to expand the balloon to view the detailed information.

Example of Did You Know balloon

For detailed information about InfoCenter, see “Find Information Using InfoCenter” in the AutoCAD Help.
Help Menu

With the removal of the menu bars, the commands to access Help features have been moved into the InfoCenter at the top right of the application window. Here, you can find the Help menu that lets you access Help, Tutorials, and other interactive resources.

![Help menu](image)

Communication Center

Communication Center is accessed from the InfoCenter toolbar. This resource displays links to information about product updates and product announcements, and may include links to Subscription Center, CAD Manager specified files, and RSS feeds.

F1 Context Help

For many commands and dialogs you can access a context-related Help topic using one of the following methods:

- Press F1 while a command is active or a dialog is open.
- Press F1 while a ribbon tooltip is displayed.
- Click the Help button in a dialog.

Tooltips

In addition to interactive tooltips that help you to create and edit objects (see Direct Editing with Grips and Dynamic Dimensions), AutoCAD MEP provides tooltips that display information about the command, option, or file over which you pause the cursor.

Command Tooltips

A short description displays whenever you pause the cursor over a command in any of the following locations:

- The ribbon
- The Quick Access toolbar

For some commands, an extended tooltip displays after a user-specified time interval.
Controlling the Display of Command Tooltips

You can change the display of command tooltips. For extended tooltips, you can define a time interval between the display of the basic tooltip and the extended tooltip.

1. Click ➤ Options.
2. Click the Display tab.
3. Under Window Elements, select Show Tooltips.
4. If you want to change the time interval between displaying the basic tooltip and the extended tooltip, select a different value for Number of seconds to delay. If you want to turn off the extended tooltip information completely, deselect Show extended Tooltips.

Dialog and Palette Tooltips

The following dialogs and palettes support extended tooltips:

- Project Browser dialog
- Project Navigator palette
- Drawing Compare palette
- Interference Detection palette
Object Rollover Tooltips

When you pause the cursor over an object in the drawing area, an informational tooltip displays basic information about the object.

Unlike the rollover tooltips provided for AutoCAD objects, such as lines or polylines, this information is standardized and cannot be changed. For information on how to configure rollover tooltips for AutoCAD objects, see “Customize Rollover Tooltips” in the AutoCAD Customization Guide.

Property Palette Tooltips

The Properties palette displays tooltips when you pause the cursor over a property in the list.
In the Project Navigator, you can display thumbnail previews of project drawings. The preview can be a 
graphic or a detail, or a combination of both. Displaying thumbnails can be helpful when you are navigating large projects with many drawings.

To activate preview tooltips in Project Navigator

1. On the Quick Access toolbar, click (Project Navigator).
2. Open the Constructs, Views, or Sheets tab
3. Right-click in the toolbar area at the bottom of the tab.
4 Click Tooltip style, and select one of these options:

<table>
<thead>
<tr>
<th>Tooltip Style Option</th>
<th>Tooltip Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Displays only the name of the drawing file. Use this option if you want to maximize the file tree visibility.</td>
</tr>
<tr>
<td>Preview</td>
<td>Displays only a preview image of the file. You can specify the preview size (Small, Medium, or Large).</td>
</tr>
<tr>
<td>Details</td>
<td>Displays a text description of the file, identifying its location, size, last-saved date, and last editor.</td>
</tr>
<tr>
<td>Preview &amp; Details</td>
<td>Displays a preview image and a text description. You can specify the preview size (Small, Medium, or Large).</td>
</tr>
</tbody>
</table>

5 If you want to display the information provided with the preview and detail tooltips, right-click, and click Preview/Details Pane. This option displays either a text description, or a preview of a selected graphic in an area below the file tree.

![Image of file tree and preview/details pane]

**Solution Tips**

The intended interaction among objects in an AutoCAD MEP drawing depends on various rules about how objects are placed in relation to one another. Whenever the software identifies a problem with the placement of objects or their components, a solution tip icon is displayed to identify the location of the problem, as shown.
Move the cursor over the icon to display a message that describes the problem and provides one or more possible solutions. Some solution tips provide complete instructions for resolving the problem. Where more detailed instructions are required, you can press F1 to access the relevant topic in Help.

Note that not all object configuration problems have an easily identifiable cause or a specific solution. This is often true in the case of boolean operations where an entity such as a body modifier is added to or subtracted from an object. In these cases, the solution tip identifies the kind of object or component involved and suggests corrective action. You may be advised to modify the location or the geometry of the object, but it is essentially a trial-and-error approach. The messages are tips rather than guaranteed solutions.

By default, solution tip icons are displayed when you are drafting, but not during plotting or publishing. You can change these settings in the Options dialog using the following procedure:

1. Click \( \text{Options.} \)
2. In the Options dialog, click the AEC Editor tab.
3. In the Solution Tip panel, select or clear Drafting and Plotting/Publishing as desired.

### Object Grip Tooltips

Objects in AutoCAD MEP have grips to manipulate them. Each grip has a tooltip that displays the function of the grip.

#### Pipe fitting grips and tooltip

When you use a grip to edit an object, in many cases additional information appears in a tooltip, helping you to perform the grip action.
Working in Model Space and Paper Space

There are 2 distinct working environments in which you can create objects in an M/E/P drawing:

- **Model Space.** This space is a limitless, 3D drawing area. In model space, you draw, view, and modify your building system designs.

- **Paper Space.** This space is a 2D sheet layout environment. In paper space, create specific views of your designs, add annotation, and create plotting sheets.

In AutoCAD MEP, these spaces are accessible on 2 or more tabs at the bottom of the drawing area: the Model tab, the Work tab, and one or more sheet tabs. They are turned off by default.

- **Model Tab.** This tab is available on both the model and sheet templates. It can be set to only TILEMODE 1, which means you can divide the drawing area into multiple viewports (a process called tiling). Each tiled viewport can display a different view of the model. For example, one viewport might display a plan view, and another might display a side view. The same display configuration must be used in all tiled viewports, and you cannot use floating viewports or freeze different layers in different tiled viewports.

- **Work Tab.** Available on the model templates, this tab enables you to work with your design in both plan and 3D at the same time. The tab contains 2 viewports, each of which is assigned a default display configuration. One viewport is assigned a Top (plan) view direction for working with schematic, single-line, double-line, or reflected ceiling plans. The other viewport is assigned an isometric view direction for creating isometric drawings and performing other tasks better suited to an isometric view. You can create a copy to add a second work tab, or delete the work tab if it is not needed for a particular project.

- **Sheet Tabs.** These tabs (also called layout tabs) are available on the sheet templates. Use the tabs to configure a layout of your drawing for plotting or printing. The sheet tabs include a border and title block, which you can modify and apply to your projects or replace with a custom border and title block.

There are advantages to working on tabs other than the Model tab. On other tabs, you can assign different display configurations to different viewports, freeze different layers in different viewports, and use floating viewports.

By default, you can switch between tabs using the status bar buttons on the application status bar.

The tab controls are provided as status bar buttons to maximize your drawing space.

To display the actual tabs, right-click the Model or Work icon, and click Display Layout and Model tabs.

The default templates provided with the software each include one or more layout tabs for designing and plotting building systems. The tabs are configured to promote efficient and accurate designs.

For more information on working in model space and paper space, see “Work with Model Space and Paper Space” in AutoCAD® Help.

Customizing the Display of MEP Objects

Custom Display is a special editing mode for making on-screen changes to the components of an MEP object in plan view. For example, you might want to add unique line work, such as vanes, hangers, and accessories to objects and fittings. Or, while working on a mechanical layout with piping, you might have a rack layout to which you want to add pipe breaks in order to see multiple elevations of the rack in a plan view. Finally,
while placing equipment, such as electrical panels or base-mounted pumps, you might want to use a hidden line to indicate equipment pads or the access space required by the manufacturer around the equipment.

**NOTE** You can edit duct, pipe, cable tray, conduit, Multi-View Parts, wires, devices, and panels using Custom Display. However, Custom Display is not available for plumbing lines and fittings, or for schematic objects and symbols.

You can use Custom Display to edit objects that reside in externally referenced drawings (xrefs). When you save the changes, they do not affect the xref drawing itself. The custom display is valid only as long as the xref is associated with the same host drawing.

When the Custom Display mode is active, you can continue to add to other MEP objects in the drawing, but not to the object being edited. Also, you can use commands to add and delete linework for the object being edited.

**NOTE** If you share drawings with users who are using an earlier version of AutoCAD MEP, they will be able to see and remove custom displays. However, they will not be able to edit the custom displays.

---

**Using Custom Display**

When you begin a Custom Display session, a temporary in-place edit profile is drawn around the object being edited, and all other objects in the drawing are unavailable and dimmed.

**NOTE** You can change the brightness of the dimming that appears during a Custom Display mode session. Click ➤ Options ➤ Display tab. Under Fade Control, for In-place edit and annotative representations, enter a value or drag the slider, then click OK.

After making changes, you can save the changes and exit the Custom Display session. Alternatively, you can discard the changes before exiting to revert to the original state of the object.

**To customize the display of an object**

1. On the command line, enter `objectgraphicsedit`.
2. Select the object to edit.
3. To zoom to the object, click Edit In Place ➤ Graphics panel ➤ Zoom To.$$.$$.
4. Add to, modify, or delete the graphics for the object.
   For example, you might want to add linework to indicate an equipment pad and an access area for a chiller.

5. To save the changes and exit, click Edit In Place ➤ Edits panel ➤ Finish ✅. Otherwise, to discard the changes and exit, click Edit In Place: Graphics tab ➤ Edits panel ➤ Cancel ✗.

**NOTE** Objects edited using Custom Display use the Custom Graphics display component. After an object has been edited using this method, any display overrides applied to the object, its style, or its system are ignored.

**To remove the custom display for an object**

1. On the command line, enter `objectgraphicsoverrideremove`.
2. Select the object from which to remove the custom display.
   You can also select the object, right-click, and click Remove Custom Graphics.

**NOTE** With the exception of MvParts, when an object is moved, custom displays are removed.
Default preferences, such as part catalogs and system layout settings, can be specified once and used repeatedly. Using one set of preferences for multiple drawings can help to maintain conformity to project standards, but designers can also draw systems without having to configure preferences first.

**Drawing Preferences**

Drawing preferences control the form and function of your designs. There are 2 general types:

- Layout preferences
- Initialization preferences

You can specify preferences for a single drawing, or save them in a template to be shared by a design team. The AutoCAD MEP sample templates include default preferences, so you can begin designing immediately. As you become more familiar with the software, you can experiment with different settings until you create the drawing environment that best suits your needs.

**About Layout Preferences**

Layout preferences are based on specific drafting or design requirements. Typically, you apply them to a specific mechanical/electrical system and change them as needed to achieve the desired design. Examples include settings for the default parts and the connections to use during layout. For more information, see

- Configuring Duct Layout Preferences on page 174
- Configuring Pipe Layout Preferences on page 293
- Configuring Layout Preferences for Cable Tray or Conduit on page 376

**NOTE** You can specify additional preferences for electrical and plumbing drawings. For more information, see Configuring Electrical Preferences on page 365 and Specifying Plumbing Preferences for Labels and Flow Arrows on page 484.
Initialization Preferences

Initialization preferences are settings that you typically specify at the start of a project, you apply to all systems, and you do not change during the design process. Examples include settings for crossed objects, general connection rules, and the file locations for catalogs and style-based content.

Initialization preferences can be accessed from the Options button on the Application menu. Drafting settings control the on-screen behavior of the cursor by specifying parameters such as snap increments for distances and angles. They also control how an object being drawn will snap to existing drawing objects. The Options dialog also contains settings for default part catalogs, building elevations, drawing layout behavior, and tooltip displays.

Specifying Part Catalogs and Style-Based Content Locations

1. Click ➤ Options.
2. In the Options dialog, click the MEP Catalogs tab.
3. Under Catalogs, expand a domain-specific category (for example, duct) and specify the catalogs you want available during layout. Part catalogs have an APC (Autodesk Part Catalog) file extension.

<table>
<thead>
<tr>
<th>If you want to ...</th>
<th>Then ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>add a catalog</td>
<td>select the category to which you want to add the catalog, and click Add. In the file selection dialog, navigate to the catalog (APC file), select it, and click Open.</td>
</tr>
<tr>
<td>remove a catalog</td>
<td>select the catalog, and click Remove.</td>
</tr>
<tr>
<td>specify a different catalog</td>
<td>Select the catalog that you want to replace, and click Browse. In the file selection dialog, navigate to the catalog (APC file), select it, and click Open.</td>
</tr>
</tbody>
</table>
If you want to ... Then ...

reorder catalogs select the catalog, and click Move Up or Move Down as needed.

The order in which the catalogs are listed on the MEP Catalogs tab is also the order in which they are listed during part selection during layout.

4 Under Style-Based Content Paths, for each type of content (electrical devices, electrical panels, plumbing fittings, and schematic symbols), specify the folder that contains the content you want available during layout. To do so, click the value for Path, and click \(\ldots\). In the folder selection dialog, browse to the folder, select it, and click Open.

**NOTE** The Shared Content Path specifies the location for generic part templates, primitives (limited part models from which you can quickly build complete parts), and other configuration files required by the software. It is shared in the sense that it is required by the software regardless of the specific content packs (Global, U.S. Metric, and so on) you are using.

AutoCAD MEP includes part catalogs and content libraries, respectively, containing hundreds of industry-standard parts and style-based objects. However, you can also create your own custom catalogs and custom content. For more information, see Customizing Catalogs on page 771, Customizing Catalog-Based Content on page 641, and Customizing Style-Based Content on page 599.

**IMPORTANT** To facilitate the process of upgrading to a new version of AutoCAD MEP, add all of your custom parts to custom catalogs; do not add custom parts to the catalogs provided with the software. When you upgrade, this allows you to easily move your custom catalogs to the appropriate locations in your new installation (where new versions of the catalogs provided with the software are located).

In the Options dialog, you specify the locations of the content (part catalogs and style-based content) you need available during layout. If the content is stored on your computer, you specify local locations in the dialog. If it is stored on a network because it is shared by multiple users, you specify network locations.

You can specify multiple part catalogs for a category. For example, you can specify the duct catalog provided with the software and a custom duct catalog for the Duct category. However, if 2 parts in different catalogs have the same ID or the same name, only the part in the catalog that is higher in the list will be displayed during part selection (for example, when adding MvParts to a drawing or when selecting pipe fittings for a routing preference definition).

**Layout Rules**

You can configure layout rules for system connections, the use of non-standard parts, and the display of interferences between drawing objects.

**Part Connection Rules**

You can allow or prevent connections between dissimilar parts. In general, you do not want to connect dissimilar systems. For unique design situations, however, you might want to allow such a connection or be prompted on a case-by-case basis.

For example, you might be drafting a water supply layout where you define one system for cold water and another for hot water. During layout, rather than having a third system for the main supply that enters the building, you might draft the main supply pipe on the cold water system and connect to the hot water heater that is a part of the hot water system. In this case, you would want to connect the hot water and cold...
water systems. You could configure layout rules to either allow the connection automatically or prompt you before making the connection.

For a connection to be valid, the connected parts must be assigned to the same system group and the connector style rules must be met. System groups are configured for part system definitions, and they enable you to connect different part systems that are assigned to the same system group. For example, you can connect medium-pressure supply duct to low-pressure supply duct if both are assigned to the supply system group.

When a connection test fails, you can prevent a connection from being made. You can also allow a connection of dissimilar systems, or allow a connection when the system of the part being drawn is automatically changed to match the system to which it is connecting.

**NOTE** It is recommended that you use Prompt for user input as the default preference until you become familiar with AutoCAD MEP.

### Configuring Connection Test Rules

1. Click Options.
2. In the Options dialog, click the MEP Layout Rules tab.
3. Under Connection Test Mismatch, select a rule:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>draw the part to the selected point without connecting to the existing part</td>
<td>select Do not make connection.</td>
</tr>
</tbody>
</table>
| be prompted before connecting to an existing system | select Prompt for user input. If you accept a connection between dissimilar systems, you have 2 options:  
  ■ You can establish a valid connection by changing the part’s system to match the existing system.  
  ■ You can ignore the system and create an invalid connection. |

**NOTE** If you select this option, when you are connecting devices with wires, and the system of the wire does not match the system of the electrical connector on the device, you cannot add the wire.

**NOTE** If you select this option, when you are connecting devices with wires, and the system of the wire does not match the system of the electrical connector on the device, you are prompted to accept the change of the system of the connector. If you do not accept the change, you cannot add the wire. The system of the device, which only determines how the device is displayed, is not affected.
If you want to… Then…

always connect the parts and change the part’s system to match the existing system

select Automatically match and make connection.

NOTE If you select this, when you are connecting devices with wires, and the system of the wire does not match the system of the electrical connector on the device, you can add the wire. The system of the connector on the device is automatically changed. The system of the device, which only determines how the device is displayed, is not affected.

Standard and Custom Part Sizes

You can specify that custom sizes can be used for parts during layout, or you can allow only defined part sizes in the part catalog. For example, when creating a piping layout you might need an elbow with an angle that does not match any elbows in the part catalog. An elbow with the custom angle can be automatically created in your layout.

If you use custom sizes, any custom parts created are available only in the current drawing and are not saved to the part catalogs for future use. If your designs require custom sizes on a regular basis, see Customizing Catalog-Based Content on page 641.

Configuring Part Selection

1 Click Options.
2 In the Options dialog, click the MEP Layout Rules tab.
3 Under Part Selection, select the sizing option you want to specify:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>allow only standard sizes from the part catalog</td>
<td>select Use Catalog Parts Only.</td>
</tr>
<tr>
<td>be prompted before choosing a custom size for a part</td>
<td>select Prompt when Non-Standard Parts are Needed. If you accept the proposed part, the custom part is created. If you decline, the last segment drawn is removed.</td>
</tr>
<tr>
<td>always allow custom sizes for parts</td>
<td>select Use Non-Standard Parts.</td>
</tr>
</tbody>
</table>

Defining System Elevations

1 Click Options.
2 In the Options dialog, click the MEP Elevations tab.
Define the elevation:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>add an elevation</td>
<td>click <img src="image.png" alt="image" /> and specify the name, elevation, and description.</td>
</tr>
<tr>
<td>edit an elevation</td>
<td>select an elevation. Click in the name, elevation, or description field and edit the text.</td>
</tr>
<tr>
<td>delete an elevation</td>
<td>select an elevation and click <img src="image.png" alt="image" />.</td>
</tr>
</tbody>
</table>

You can define elevations to use for your systems during layout. You can create elevations for different systems on the same floor or for multiple floors in a single building. You can also manually enter elevations as you add parts, but using defined elevations maintains accuracy and saves time.

For example, if you want all air supply ducts on the first floor to have an elevation of 12'-0'', create an elevation of 12'-0'' with the name Supply - 1st Floor. You can select this elevation when adding duct in the drawing. All non-vertical duct segments and fittings in the run are automatically placed at 12'-0''.

### Configuring Tooltip Settings

Tooltips are displayed when you hover the cursor over items such as menus, icons or palettes. AutoCAD MEP tooltips provide a quick view of object information, such as the object name, the system to which it is assigned, and its elevation.

**To specify the information displayed in AutoCAD MEP tooltips**

1. Click ![image](image.png) ➤ Options.
2. In the Options dialog, click the Display tab.
3. Under Window Elements, specify the desired tooltip options.

You can also control the color, size, and transparency of tooltips. See the Tooltip Appearance Dialog Box topic in the AutoCAD help file for more information.
AutoCAD MEP Snaps

AutoCAD MEP includes 2 kinds of snaps:

■ **Object Snaps.** These are standard AutoCAD® snaps that allow you to snap drawing points to geometric locations on other objects. For example, you can snap to the endpoint of a line, or snap to the intersection of 2 lines.

■ **AutoCAD MEP Snaps.** These enable you to snap objects intelligently to other building system objects, thereby creating valid connections with existing systems. AutoCAD MEP snaps are available for schematic, duct, pipe (also used for plumbing), electrical, and wire way systems (cable tray or conduit). You can use the snaps to quickly and precisely draw a system that is fully connected. For example, if the snaps for pipes are turned on, you can draw a pipe and connect it to an existing pipe run. When you snap the pipe to the run, the software creates a valid connection, which maintains the integrity of the pipe system. There are 2 types of AutoCAD MEP snaps: end connectors (often referred to as just connectors) and curve connectors. Use end connectors to connect new objects to the ends of existing objects. Use curve connectors to connect new objects anywhere along the centerlines of existing objects.

When you use AutoCAD MEP snaps, the software inserts an appropriate fitting when needed, as shown in the following example of adding a pipe branch.

When you turn on AutoCAD MEP snaps, they remain on until you turn them off. If the snaps are off when you use an Add command, the relevant AutoCAD MEP snap is turned on only for the Add command. For example, if all AutoCAD MEP snaps are off and you start the plumbing line Add command, the Pipe Curve and Pipe Connector snaps are turned on. Once you exit the plumbing line Add command, the Pipe Curve and Pipe Connector snaps are turned off.

**TIP** You can also enter the following AutoCAD MEP snaps on the command line, which can be helpful if you miss a connector during object selection: SCON (Schematic Connector), DCON (Duct Connector), PCON (Pipe Connector), ECON (Electrical Connector), WCON (Wire Way Connector), SCUR (Schematic Curve), DCUR (Duct Curve), PCUR (Pipe Curve), ECUR (Electrical Curve), and WCUR (Wire Way Curve).

### Configuring AutoCAD MEP Snaps

Use this procedure to turn AutoCAD MEP snaps on or off.
1 On the application status bar, right-click (object snap), then choose Settings.

2 In the Drafting Settings dialog, click the Object Snap tab, and then scroll down to AutoCAD MEP.

3 Click to select the snaps you want to activate. You can also click the check box to the right of the AutoCAD MEP title bar to select all the snaps at one time. Click the check box again to clear all the AutoCAD MEP snap selections.

**Mechanical, Electrical, and Plumbing Equipment in Building Systems**

You can lay out a building system design by adding mechanical, electrical, and plumbing equipment to your drawing. In the software, equipment is referred to as Multi-view Parts, MvParts, or parts. MvParts model the size and shape of a part, and they can intelligently connect to AutoCAD MEP parts. The software includes hundreds of MvParts commonly used in commercial, institutional, and industrial building systems. You can place these parts accurately in your drawing and also modify their size, elevation, or location.

MvParts are organized by type and stored in part catalogs. You or your CAD manager can customize part catalogs or create custom parts to meet company standards or project requirements. For more information, see About Catalog Editor on page 771 and Content Builder on page 646.

The part catalogs available to you during a drawing session are specified in the initialization preferences. For more information, see Specifying Part Catalogs and Style-Based Content Locations on page 70.

Architectural drawings referenced in an AutoCAD MEP drawing can contain MvBlock parts that might be useful as MvParts. MvBlocks are similar to MvParts in that they can be viewed from different directions (such as isometric or orthographic). However, MvBlocks cannot connect intelligently in a building system. Instead, you can convert MvBlocks into MvParts and then assign engineering information and connectors to them for use in the building system.

For example, in the HVAC workspace, the reference drawing may contain an MvBlock of an air grille that you want to connect to your HVAC network. You can convert the grille to an MvPart with duct connections. Similarly, a plumbing drawing might contain a sink as an MvBlock that you want to connect to your plumbing system. You can convert the sink to an MvPart and then specify the water supply and drain connectors. For more information, see Converting MvBlocks to Block-Based Parts on page 743.
**About Electrical Equipment**

Unlike devices, panels, and wires, electrical equipment does not work with circuits. You can only connect equipment to physical wireways such as conduit and cable tray. In some cases, such as a junction box, there are both devices and MvParts available in the electrical catalogs. The junction box device works with circuits and connects to wires. The junction box MvPart connects with conduit.

Electrical drawings are usually shown in 2D, where devices and panels are represented with symbols, and wiring is represented with single lines. In plan view, electrical MvParts display the actual part geometry to scale. You can display equipment in 3D. For example, you might want to show a 3D model that includes the electrical equipment, conduits, and cable trays for the building. In this case, you can display the real-world geometry of the objects in a 3D view.

**Examples of electrical equipment**

![Generator](image1)

![Junction Box](image2)

For more information, see [Adding Electrical Equipment](#) on page 419 or [Modifying Electrical Equipment](#) on page 444.

**About Pipe Equipment**

The software includes a plumbing part catalog that contains hundreds of parts in thousands of sizes. Pipe MvParts range from large equipment, such as chillers and cooling towers, to small components, such as valves and fire sprinklers. The following example shows Pipe MvParts in an isometric view.

**From left to right: Firetube boiler, centrifugal chiller, and cooling tower**

You can change an MvPart from one type to another on page 324. For example, you can change a ball valve to a butterfly valve. In the part catalogs, parts are divided into types, such as valves. The Valves type is divided into subtypes such as ball, butterfly, gate, and globe.

For more information, see [Adding Pipe Equipment](#) on page 285 or [Modifying Pipe Equipment](#) on page 322.
About Mechanical Equipment (HVAC)

The software includes an HVAC part catalog that contains hundreds of parts in thousands of sizes. The part types range from large components, such as rooftop air conditioning units, to small components, such as grilles. For some HVAC parts, such as air terminals and VAV boxes, you can assign flow values; these values can be used to calculate duct sizes.

The following example shows mechanical MvParts (HVAC domain) in an isometric view:

From left to right: Furnace, VAV box, and ceiling diffuser

For more information, see Adding HVAC Equipment on page 194 or Modifying HVAC Equipment on page 230.

About Plumbing Equipment and Fixtures

The software includes a plumbing part catalog that contains hundreds of parts in thousands of sizes. The part types include plumbing equipment, such as pumps and water heaters, and plumbing fixtures, such as drains, water closets, and sinks. The following shows a few examples.

**Plumbing equipment**

<table>
<thead>
<tr>
<th>Plan view</th>
<th>3D view</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Hot water boiler" /></td>
<td><img src="image2" alt="Hot water boiler" /></td>
</tr>
</tbody>
</table>

**Plumbing fixtures**

<table>
<thead>
<tr>
<th>Plan view</th>
<th>3D view</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image3" alt="Rectangular shower stall" /></td>
<td><img src="image4" alt="Rectangular shower stall" /></td>
</tr>
<tr>
<td><img src="image5" alt="Oval lavatory" /></td>
<td><img src="image6" alt="Oval lavatory" /></td>
</tr>
</tbody>
</table>
For more information, see Adding Plumbing Equipment and Fixtures on page 485 or Modifying Plumbing Equipment and Fixtures on page 494.

Working with Catalog-Based Content

Building systems are typically assembled from fabricated, off-the-shelf components. The part catalogs included with AutoCAD MEP offer an extensive collection of parts for use during design. You can query the part catalogs to assist with part selection, retrieve parts for integration into your designs, and store parts you create in a catalog for future use.

**Parts of a mechanical system**

![Duct fitting](image1)

**Parts of an electrical system**

![Cable tray fitting](image2)

**Parts of a plumbing system**

The following part catalogs are available in both metric and imperial units:

- Cable Tray
- Conduit
- Duct
- Multi-view Parts for all building systems disciplines
- Pipe

The software also includes style-based content for devices, panels, plumbing fittings, valves, and schematic symbols.
NOTE U.S. metric content is developed based on the U.S. General Services Administration (GSA) standards for metric design. U.K. and Global metric content is developed based on the British Standards Institute (BSI) standards for metric design.

As you design systems, the parts and style-based content available to you depends on the catalogs and content locations you have specified on the MEP Catalogs tab of the Options dialog. (For more information, see Specifying Part Catalogs and Style-Based Content Locations on page 70.) If you require a part that is not available, you can use the tools provided with the software to create custom catalogs that contain custom parts.

RELATED For more information on creating parametric or block-based content, see Working with Parametric Parts on page 649 or Working with Block-Based Parts on page 743.

IMPORTANT To facilitate the process of upgrading to a new version of AutoCAD MEP, add all of your custom parts to custom catalogs. Do not add custom parts to the catalogs provided with the software. When you upgrade, this allows you to easily move all of your custom catalog content as a whole to the catalog folders for the new version (where new versions of the catalogs provided with the software are also located). You can use both types of catalogs during layout if you specify multiple catalogs for a domain, as described in Specifying Part Catalogs and Style-Based Content Locations on page 70.

How Catalog Parts are Stored and Referenced

AutoCAD MEP part catalogs are typically organized in chapter folders grouped by related parts. Within the chapters reside part families that store individual part sizes. A part family is a group of related part sizes. The following example shows the organization of a pipe part catalog.

Example of US Imperial pipe parts catalog

NOTE The organization of the pipe parts catalog varies depending on the profile in which you are running AutoCAD MEP. For more information, see Pipe Parts Catalog on page 262.
You can browse part catalogs through the Add and Modify dialogs, which give you direct access to the parts currently available to integrate into your designs. When you select a part from a part catalog, you are selecting a specific part size that is defined in a part family.

In the Add Multi-view Parts dialog and Multi-view Part Modify dialog, you can also use the Part Filter tab to specify part properties to query a part family to find a specific part size. You can view the part sizes available in a part family by clicking Details. The available part sizes are presented in an easy-to-navigate part size table. Select Display/Hide additional parameters to show all the parameters in the table.

NOTE The Visible attribute is initially set in the Parameters Configuration view in the Size Parameters dialog in Content Builder. For more information, see Size Parameter Attributes on page 83.

How Catalog Parts Are Defined

A catalog part is defined by the associated files, or definition files, that store the part information:

- **DWG file.** The drawing stores the model geometry that defines the appearance and enables the display of the part.
- **BMP file.** Stores the preview image of the part, which helps to identify the part during part selection.
- **XML file.** The extensible mark-up language (XML) file stores the part size and additional part properties that define the part.

Each part family in a catalog contains references to the associated definition files. If a file is missing, the part cannot be defined and is not available during part selection. The definition files are saved in the associated catalog folder in the ProgramData\Autodesk\MEP 2010\enu\AEC Content directory.

NOTE AutoCAD MEP provides a catalog editor that a CAD manager or advanced user can use to browse, edit, or add part content to part catalogs. For more information, see About Catalog Editor on page 771.
Part Sizes

To understand how individual part sizes relate to the definition files of a part, it is important to understand how the part data is defined in the XML file. Part data stored in the XML definition file consists of 2 types of properties: common parameters and size parameters.

Common parameters remain constant for all part sizes. They are defined once in a part family and are shared by all part sizes. If you change a common parameter, it is updated for all part sizes. Common parameters include domain, type, and subtype. The following examples show common parameters for a mechanical, electrical, and plumbing part size.

- **Mechanical**: Common parameters for the 6 x 4 inch Rectangular Floor Register part size are as follows:
  
  | duct component | air terminal | rectangular floor register |
  
- **Electrical**: Common parameters for the 13 Hole Large Outlet Box - 1 inch Conduit part size are as follows:
  
  | conduit component | junction box | square outlet box |
  
- **Plumbing**: Common parameters for the 5 x 5 inch Rectangular Floor Drain part size are as follows:
  
  | pipe component | drain plumbing | rectangular floor drain |
  
Size parameters include a set of parameter attributes such as name, description, and units; and parameter values such as size dimensions and material type. A size parameter can define one or more part sizes depending on how the size parameter is stored in the part family. Different storage methods enable multiple part sizes to be defined by various combinations of size parameters.

Viewing part sizes in Catalog Editor and in the part size table of the Add dialog

---

82 | Chapter 4  Drawing Essentials
Size Parameter Attributes

Parameter attributes are defined by both fixed and extensible lists of values. Attribute values are specified by AutoCAD MEP and cannot be changed; however, attribute values must be specified for custom data parameters that are added. Fixed data values cannot be edited. Extensible data values can be changed based on a list of predefined values, or extended to accommodate user-defined values. The following table shows the parameter attributes used to define size parameters.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Type of Data</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Extensible</td>
<td>D1, A2, user-defined</td>
</tr>
<tr>
<td>Description</td>
<td>Extensible</td>
<td>Diameter D1, Angle A2, user-defined</td>
</tr>
<tr>
<td>Context</td>
<td>Fixed</td>
<td>Connection Port Diameter, Path Angle</td>
</tr>
<tr>
<td>Index</td>
<td>Fixed</td>
<td>0, 1, 2, 3</td>
</tr>
<tr>
<td>Data Type</td>
<td>Fixed</td>
<td>Double, Integer, Boolean, String</td>
</tr>
<tr>
<td>Visible</td>
<td>Fixed</td>
<td>True, False</td>
</tr>
<tr>
<td>Units</td>
<td>Extensible</td>
<td>in, ft, mm, m, deg</td>
</tr>
</tbody>
</table>

Size Parameter Storage Types

Size parameters are separated into 4 types of data, referred to as “storage types.” Each storage type has unique characteristics that determine how the size parameters are used to define the part.

- **Basic Tables.** Store each parameter as a separate column. An entire row across multiple columns defines related parameters of a specific part size. All parameter columns must have the same number of values.
- **Constant Lists.** Store each parameter as a separate list and can be used in combination with other lists of values to define multiple part sizes. Each parameter list is independent and can have an infinite number of values.
- **Constants.** Store each parameter as a separate value that remains the same for all part sizes.
- **Calculations.** Store each part parameter as a formula. Values are calculated for each parameter based on other values specified for the part size.

Default Parts

Default parts are the parts automatically inserted by the software as you lay out runs of duct, pipe, cable tray, or conduit. You can change the default parts during layout.

If you use systems in your designs, you can define different default parts for each system. During layout, if you need to add a part that has no default defined, the software prompts you to select a part to use.

For more information, see:
- **Duct:** Specifying Default Parts for Layout on page 180
- **Pipe:** Configuring Size Ranges on page 280
- **Cable tray and conduit:** Specifying Default Parts for Cable Tray or Conduit on page 379

You can also specify the plumbing fittings used by default for plumbing system definitions. For more information, see Specifying the Default Fittings for a Plumbing System Definition on page 478.
Importing a Building Component into AutoCAD MEP 2010

AutoCAD MEP 2010 can import content originally produced by Autodesk Inventor. This capability allows the creation of custom content that can easily be transported to MEP drawings.

Export Requirements in Autodesk Inventor

In order for a building component to be correctly imported into AutoCAD MEP 2010, it must be prepared for export in Autodesk Inventor, and saved as a Building Component Autodesk Exchange file (*.adsk). For more information, consult the Inventor User Guide.

When you import an Inventor building component into AutoCAD MEP 2010, you can choose whether the component is imported as a multi-view part, a multi-view block, or a block. For more information on changing the UCS during import, see Changing the UCS During Import in the AutoCAD Architecture Help.

To import Inventor content

1. Click Insert tab ➤ Content panel ➤ Content Browser drop-down ➤ Building Component.
2. In the Import Building Component dialog, select the Autodesk Exchange Format file (*.adsk) that you want to import.
3. Select if you want to import the component as a multi-view part (MvPart), a block, or a multi-view block.
   An Import dialog opens to allow you specify a name and description, and to change the orientation of the MvPart, block, or multi-view block during insertion.

4. When inserting a single part, the image in the viewer will be the part that is inserted, i.e front, top, etc. Any axonometric view will insert the 3D part.
   If necessary, use the ViewCube in the preview window to display the component in the desired view.
5. Use the Rotate buttons to rotate the model around its X, Y, or Z axis when inserted into the drawing.
6. Select a catalog chapter in which to place the part and click Add.
   Depending on the type of component inserted, you have different options for editing it in AutoCAD MEP 2010. For information on multi-view parts, see Behavior of a Block-Based Part.
Working with Style-Based Content

Objects that use styles are referred to as style-based content. Styles are sets of parameters that you assign to objects to determine their appearance or function. Objects in AutoCAD MEP that use styles include schematic symbols, devices, panels, and plumbing fittings. Styles define additional behaviors that traditional block-based objects do not have. For example, a symbol style determines the appearance of the symbol in different views, how connecting lines are trimmed, and the location and type of smart connectors used to create an intelligent building system.

You can create style-based content by defining new object styles. You assign a style to all instances of an object that share the same characteristics. For example, you can assign one symbol style to all 3-way float valves and another symbol style to all 3-way pneumatic valves.

You can define the appearance of style-based content by assigning block-based graphics to specific views of the style. This enables you to convert traditional block-based objects, such as symbols, into usable content in AutoCAD MEP. Hundreds of add-on block-based objects are available from third-party vendors. Many building product manufacturers provide inventories of block-based symbols, and many design offices now sell libraries of custom block-based symbols. With the ability to create new styles, you can easily convert symbol libraries into style-based content and customize AutoCAD MEP to suit your needs.

The key to working with style-based content is organizing the content in a logical way. You can organize related style-based content in libraries and categorize the libraries into smaller subsets of related content. To understand the operations, commands, and options available with style-based content in AutoCAD MEP, it is important to understand how style-based content is stored and referenced in a drawing. Central to working with style-based content is understanding style definitions.

NOTE For information on creating style-based content, see Customizing Style-Based Content on page 599.

How Style-Based Content is Stored and Referenced

In AutoCAD MEP, schematic symbols, devices, panels, and plumbing fittings are style-based content. Each piece of style-based content is defined by a style. You can create style definitions using Style Manager or one of several conversion tools provided by the software. (For more information, see Customizing Style-Based Content on page 599.) Style-based content can be stored in individual drawings; however, it is better to store style-based content in libraries that can be categorized and accessed through the dialogs and worksheets in the software.

A style definition is similar to an AutoCAD® block definition, which consists of all information associated with the block. Style definitions store all information associated with a piece of style-based content. The key difference between a block definition and a style definition is that a block definition stores information related only to appearance, whereas a style definition stores additional information related to function and behavior. For example, a traditional block-based symbol definition stores the geometry of the symbol. A style-based symbol definition stores the geometry of the symbol for each view direction. It also specifies how connecting lines are trimmed, defines the location and type of smart connectors used to create intelligent building systems, and determines the display properties of the symbol. For more information about defining styles, see Configuring Styles on page 603.

Style definitions are referenced when you add style-based content to your drawing. AutoCAD MEP does not copy information from the style definition to the drawing area. Instead, it establishes a link between the style-based content and the style definition. If the style definition is changed, all references are updated.

Style-based content can be stored in libraries. Generally, your drawings include symbols that you draw repeatedly, such as schematic symbols, devices, panels, and plumbing fittings. Style-based content libraries
eliminate the need to redraw objects or copy and paste objects between drawings. You can create style-based content and store related content in a single drawing file that acts as a library. You associate the drawing file, or library, with your drawing in the Options dialog, so it can then be accessed through the Add dialog, Modify dialog, and Select worksheet (accessed from the Properties palette). For more information, see Specifying Part Catalogs and Style-Based Content Locations on page 70.

Orthographic and Isometric Views of Style-Based Content

Style-based content can have different appearances, depending on the display representation and view direction. Styles have view assignments that enable you to assign a specific view block to each view direction of a display representation. For example, a symbol can have one appearance when viewed from the top in plan view and another appearance when viewed from the left in plan view. For more information, see AutoCAD MEP Displays.

You can assign appearances to style-based content for both orthographic and isometric views in the plan display representation. 2-dimensional (2D) plan view drawings are the most common type of drawing created to represent design layouts. You can create both orthographic and isometric 2D plan view drawings in AutoCAD MEP.

When working with plan and isometric views of style-based content, 2 modes are available for creating, adding, and modifying style-based content:

- **Orthographic mode.** Works in the standard orthographic drafting view directions (top, bottom, front, back, left, right, and 3D).
- **Isometric mode.** Works in the standard isometric drafting isoplanes (left, top, and right), with the associated iso rotations (up, down, left, and right).

For each view of style-based content, additional view blocks must be created and assigned to a specific view in the style definition. The assigned views determine the appearance of the style-based content in your drawing. For orthographic views, you can create 6 plan/elevation view blocks and assign them to each ortho view respectively, or use a 3D model block to represent the ortho view. For information on view settings, see Defining the Views of a Style on page 604.

**Orthographic view directions (for recessed double duplex receptacle)**

![Orthographic View Directions](image)

For isometric views, twelve view blocks should be created for each piece of style-based content.
Isometric view directions and orientations

When creating or editing style-based content, you specify the mode on the Views tab in the Style Definition dialog. In Orthographic mode, you can assign view blocks to each orthographic view direction. In Isometric mode, you can assign view blocks to each iso rotation for each isoplane. For more information, see Defining the Views of a Style on page 604.

When adding or modifying style-based content, you specify the mode on the Properties palette, Add dialog, or Modify dialog. In Orthographic mode, you can draft your layout in the top view, add style-based content in plan view, and then change the view direction to view your layout and style-based content from the bottom, front, back, left, right, or in 3D. In Isometric mode, you can draft your layout on the different isoplanes and insert style-based content with the appropriate iso rotation.

Working with Tool Palettes

AutoCAD MEP includes a large inventory of tools organized into both discipline-specific and common tool palettes. For example, there are several tool palettes containing documentation tools, such as those for annotation and callouts. There are also numerous tool palettes containing tools for mechanical, electrical, piping, schematic, and plumbing design. To explore palettes:

- Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Tools .
- To browse the complete collection of tool and tool palette catalogs provided with the software, click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content Browser .

The tool palette set is the collection of tool palettes specified for the current profile in the Tool Palettes File Locations setting.

1 Click ➤ Options.
2 In the Options dialog, click the Files tab.
If the tool palette set contains a large number of tool palettes, you can create tool palette groups for the current profile and organize the palettes in the tool palette set inside the groups. This enables you to display either all of the palettes in the tool palette set or only those in a single group, switching between tool palette groups as needed. The profiles included with the software define several tool palette groups for the tool palettes, including HVAC, Piping, Electrical, Plumbing, Schematic, and Architectural.

If you are working in a project, the tool palette set also includes a tool palette group for the project. When you set a project as current, the software appends the AutoCAD® Tool Catalog (ATC) file location for the project-specific tool palettes to the path for the tool palette set. When you close the current project or set another one as current, it removes the project-specific tool palettes from the path.

You or your CAD manager can customize the existing tool palettes and tools as well as create new ones. You can also make customizations to a tool palette set. For information, see Customizing Tool Palettes on page 787 or Customizing Tools on page 789.

### Opening the Tool Palette Set

Use any of these methods to open the tool palette set specified for the current profile:

- Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Tools.
- Press **CTRL+3**

### Changing the Active Group in the Tool Palette Set

1. On the title bar of the tool palette set, click (Properties).
2. On the context menu, select the tool palette group that you want to display.

Example of HVAC tool palette
Modifying the Appearance of the Tool Palette Set

The tool palette set has several display options that you can set according to your design preferences.

Docking the Tool Palette Set

1. On the title bar of the tool palette set, click \( icon \) (Properties), and then click Allow Docking.
2. Click the title bar, and then drag the tool palette set to one side of your screen.
   The software displays a preview graphic to indicate the proposed position of the docked tool palette set.
3. Release the mouse button when the tool palette set is in the location that you want.

To undock the palette, click the palette near the top and then drag it into the drawing area.

Hiding the Tool Palette Set

When you enable the auto-hide feature of the tool palette set, the software hides all but its title bar when you move your pointing device away from it. This gives you greater visibility over your design at times when you are not working with tools.

To enable the auto-hide feature, click \( icon \) (Auto-hide) on the title bar of the tool palette set. In this mode, you can display the tool palette set again by hovering your pointing device over the title bar.

To disable the auto-hide feature, click \( icon \) (Auto-hide) again.

Adjusting the Transparency of the Tool Palette Set

You can display the tool palette set while retaining a view to the drawing underneath by applying transparency to the tool palette set.

Tool palette set with transparency

\[\text{NOTE} \quad \text{Transparency is not available if the palette is docked or hardware acceleration is enabled.}\]
To adjust the transparency of the tool palette set

1. On the title bar of the tool palette set, click (Properties), and then click Transparency.
2. In the Transparency dialog, adjust the transparency.

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>increase the transparency</td>
<td>drag the slider to the right.</td>
</tr>
<tr>
<td>decrease the transparency</td>
<td>drag the slider to the left.</td>
</tr>
<tr>
<td>turn off transparency</td>
<td>select Turn off window transparency.</td>
</tr>
</tbody>
</table>

Modifying the Appearance of Tools

You can modify the appearance of tools in the following ways:

- increase or decrease the size of tool images
- modify the display and arrangement of tools. You can display tools with icons only; icons with text, or in single-column list view that includes icons and text.

The same tool palette with three different views

Several factors can influence the appearance that you select for tools, such as the need for additional drawing space, your familiarity with the tools, and the complexity of the tool images. For example, new users might choose to display tools with small images in a single-column list, which provides the aid of the tool name as well as the image. Alternatively, experienced users might choose to display tools with medium-sized images and without names in order to maximize drawing space.

To modify the appearance of one or more tool palettes

1. If you want to modify the appearance of only a single tool palette, open that palette.
2. Right-click the palette that is currently open, and click View Options.
3. Drag the Image size slider to the left to decrease the size for tool images or to the right to increase it.
Working with the Properties Palette

The Properties palette provides a central location to view the properties of an object. You can review information about the style, dimensions, location, property set data, and other important characteristics of an object. You typically keep the Properties palette open during an AutoCAD MEP session.

Opening the Properties Palette

Use any of the following methods to open the Properties palette:

- Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties .
- Press CTRL+1.
- Select an object in the drawing, right-click, and click Properties.
- Double-click an object in the drawing.

Modifying Object Properties Using the Properties Palette

You can use the Properties palette to modify the properties of one or more objects at the same time. However, keep in mind the following:

- Changes are applied only to the objects you select. They are not applied to other connected objects in the system.
- When you modify multiple objects simultaneously, you can only modify the properties that are editable and have the same name, category, and possible values for all of the selected objects. Properties that do not have the same name and category are not displayed on the palette. If the value of a displayed property is the same for the objects, the palette displays the value; otherwise, it displays *VARIES*.
Modifying Display Properties Using the Properties Palette

You can use the Display tab on the Properties palette to control the graphical properties of an object by adjusting the settings for its individual display components, such as contours and center lines. The changes you make on this tab are immediately visible in the display representation currently in effect, such as Plan or Model, and you have the option of applying your changes to other display representations as well. For more information, see Modifying Elevation-Based Display Components on the Properties Palette on page 149.

Modifying the Appearance of the Properties Palette

The Properties palette has several display options that you can set according to your design preferences.

Docking the Properties Palette

1 On the title bar of the Properties palette, click (Properties), and then click Allow Docking.
2 Click the title bar, and then drag the palette to one side of your screen.
   The software displays a preview graphic to indicate the proposed position of the docked palette.
3 Release the mouse button when the palette is in the location that you want.

To undock the palette, click the palette near the top and then drag it into the drawing area.

Hiding the Properties Palette

When you enable the auto-hide feature of the Properties palette, the software hides all but its title bar when you move your pointing device away from it. This gives you greater visibility over your design at times when you are not working with the palette.

To enable the auto-hide feature, click (Auto-hide) on the title bar of the Properties palette. In this mode, you can display the palette again by hovering your pointing device over the title bar.

To disable the auto-hide feature, click (Auto-hide) again.

Adjusting the Transparency of the Properties Palette

You can display the Properties palette while retaining a view to the drawing underneath by applying transparency to the palette.

**NOTE** Transparency is not available if the palette is docked or hardware acceleration is enabled.

To adjust the transparency of the Properties palette

1 On the title bar of the Properties palette, click (Properties), and then click Transparency.
2 In the Transparency dialog, adjust the transparency.

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>increase the transparency</td>
<td>drag the slider to the right.</td>
</tr>
<tr>
<td>decrease the transparency</td>
<td>drag the slider to the left.</td>
</tr>
</tbody>
</table>
If you want to… then…

| turn off transparency | select Turn off window transparency. |

**Working with Systems**

In AutoCAD MEP, a system is a network of connected parts that represents a real-world building system. The connected parts act together by maintaining the same look and feel throughout the system. For example, a network of connected parts including duct, pipe, fittings, and equipment can represent an air supply system, or a network of connected parts including conduit, wiring, devices, and panels can represent a power supply system.

Systems store properties that remain constant for all parts within a network of connected parts. When systems are used during design layout, new parts inherit the current system’s property defaults, such as size and shape. This provides a fast and consistent method of laying out parts. Systems make it easier to modify connected parts by simultaneously applying changes to the entire network of parts.

Including systems in your project standards has several benefits:

- You have the ability to define and work with multiple systems within a single drawing.
- You can apply default system properties to components during layout, which saves time and provides consistency.
- It is easier to manage parts in your design drawings through display representations.
- You can manage complete building models within a single drawing by grouping systems.

Systems can be created as needed during design layout. However, it is recommended that a series of systems be defined at the start of a project and maintained throughout its life. AutoCAD MEP provides a set of predefined systems based on common industry standards. Each system has default definitions including system abbreviations, layer keys, and display properties.

Electrical and plumbing systems are also categorized by system type. System types control unique behaviors of related systems. In electrical systems, the system type controls properties such as the number of poles. In plumbing systems, the system type controls pipe sizing, fitting orientation, and fixture connections.

Systems are style-based, and, as a result, you access them through Style Manager.
Duct systems

Systems are loaded through AutoCAD MEP templates. If you are not using an AutoCAD MEP template, you can import system definitions from other drawings with Style Manager. Additional system definitions can be found in the System Definitions.dwg, which is located in a subfolder of the following folder: \\ProgramData\\Autodesk\\MEP 2010\\enu\\Styles. For more information about sharing system definitions between drawings, see Copying Systems Between Drawings on page 100.

The topics in this section provide information on working with systems that applies to all building systems disciplines. For discipline-specific information, see:

- Configuring Duct System Definitions on page 181
- Configuring System Definitions on page 281
- Creating Electrical System Definitions on page 363
- Configuring Plumbing System Definitions on page 477
- Creating Schematic System Definitions on page 521

For additional information about Style Manager, see Style Manager in AutoCAD Architecture Help.

About System Groups

System groups associate related systems without changing individual system properties. This enables you to connect different systems within a single drawing while maintaining display flexibility. You can define a system group to include any number of individual systems.

As an example, assume you want to connect a recirculating hot water line to a supply hot water line. You assign both system definitions to the same system group: non-potable water. When you draw the pipe runs,
you can connect the recirculating line to the supply line and still have a connected pipe system. The following pipe run shows how the recirculating line (HWC) is connected to the supply line (HWS).

If 2 systems are not assigned to the same system group and you try to connect them, you are prompted to change the system of the connecting run to match the system of the receiving run. If you do not change the system of the connecting run, the appropriate fitting is inserted to connect to the receiving run, but the system is not connected. The connecting run is not a part of the system, so any changes you make to that system are not applied to the connecting run.

The following are examples of the benefits of grouping systems in the mechanical, electrical, and plumbing modules.

- **Mechanical**: If you are designing a heating supply system, you can create a separate system for each zone of a building, and then group the individual systems together as one complete heating supply system for the building.

- **Electrical**: If you are designing a power supply system, you can create a separate system for each voltage rating within the building, and then group the individual systems together as one complete power supply system for the building.

- **Plumbing**: If you are designing a sanitary waste system, you can create a separate system for each floor of a building, and then group the individual systems together as one complete sanitary waste system for the building.

System groups can be created as needed, but it is recommended that you create them when creating systems.

**NOTE** If dissimilar systems are allowed to connect and no system group has been defined, the connection is not valid. (If solution tips are turned on, a solution tip marker is displayed at the invalid connection. For more information, see Part Connection Rules on page 71 and Showing Solution Tips on page 579.) If you create a system group after you have laid out system components, the related invalid connections are dynamically updated to be valid.

---

**Creating Systems**

**IMPORTANT** When defining a sanitary pipe system that uses gray water or black water, you need to define the system type as Waste. Otherwise, the Size Sanitary Pipe command will not recognize the system as a sanitary pipe system, and you will not be able to size the pipe run.
To create a system

1 Within a domain-specific workspace, open the Style Manager and access the system definitions by doing one of the following:
   ■ Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ HVAC System Definitions.
   ■ Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Piping System Definitions.
   ■ Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Electrical System Definitions.
   ■ Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Plumbing System Definitions.
   ■ Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Schematic System Definitions.

2 Create a new system:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a system with default properties</td>
<td>in the left pane of the Style Manager, right-click System Definitions, and click New.</td>
</tr>
<tr>
<td>create a system from an existing system</td>
<td>in the left pane of the Style Manager, right-click the system you want to copy, and click Copy. Right-click the copy, and click Paste.</td>
</tr>
</tbody>
</table>

3 Enter a name and description for the new system, and press ENTER.

4 Specify the general properties of the system. For help, see:
   ■ Specifying the Design Rules of a System on page 97
   ■ Specifying the Rise/Drop Style of a System on page 98
   ■ Specifying the Display Properties of a System on page 99
   ■ Attaching Notes and Files to a System on page 100

5 Specify any discipline-specific properties of the system. For help, see:
   ■ Configuring Duct System Definitions on page 181
   ■ Configuring System Definitions on page 281
   ■ Configuring Plumbing System Definitions on page 477
   ■ Creating Electrical System Definitions on page 363
   ■ Creating Schematic System Definitions on page 521
Specifying the Design Rules of a System

The design rules of a system definition are properties that determine the behavior and display of the system.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Abbreviation</td>
<td>Identifies the system to which the parts are assigned. This is a short system name, typically two or three characters in length. The abbreviation can be used when labeling objects and creating schedules.</td>
</tr>
<tr>
<td>System Group</td>
<td>Identifies the group of related systems with which the system is associated. System groups allow you to connect different systems while maintaining their individual system properties. For more information, see About System Groups on page 94.</td>
</tr>
<tr>
<td>System Type</td>
<td>Identifies the type of system. Available in electrical and plumbing systems only. Power &amp; Lighting and Cable Tray are 2 examples of system types in electrical systems. Every electrical system must have a specified system type. Hot Water and Waste are 2 examples of system types in plumbing systems. A plumbing system does not require a system type. However, sanitary pipe systems that use gray water or black water must specify the System Type as Waste. Otherwise, the Size Sanitary Pipe command does not recognize the system as a sanitary pipe system, and you are not be able to size the pipe run.</td>
</tr>
<tr>
<td>Layer Key</td>
<td>Identifies the layer to which objects in the system are added.</td>
</tr>
</tbody>
</table>

To specify the design rules of a system

1. Within the domain-specific workspace, open the Style Manager, and access the appropriate system definitions:
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ HVAC System Definitions.
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Piping System Definitions.
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Electrical System Definitions.
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Plumbing System Definitions.
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Schematic System Definitions.

2. In the left pane, select the system, and, in the right pane, click the Design Rules tab.
Design Rules tab for an electrical system definition

3 Configure the design rules:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>specify a system abbreviation</td>
<td>for Abbreviation, enter an abbreviation.</td>
</tr>
<tr>
<td>specify a system group</td>
<td>for System Group, select or enter a group name. New names are added to the list of existing names.</td>
</tr>
<tr>
<td>select a layer key</td>
<td>for Layer Key, select a layer key. The list of available layer keys depends on the layer key style specified for the drawing. To create a layer key override, click [...] beside the appropriate Layer Field, select an override value in the dialog, and click OK.</td>
</tr>
</tbody>
</table>

4 If the system definition is for electrical or plumbing, for System Type, select a system type. The list of available system types is not customizable.

Specifying the Rise/Drop Style of a System

Rise symbols and drop symbols represent the elevation direction of vertical segments in your layout for any predefined orthographic view (top, bottom, left, right, front, or back).

Rise/drop styles define the graphical appearance of rises and drops in your layout. You can assign different rise/drop styles to different systems. For information about creating a rise/drop style, see Rise/Drop Styles on page 612.

To specify the rise/drop style of a system

1 Within the domain-specific workspace, open the Style Manager and access the system definitions:
   ■ Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ HVAC System Definitions.
   ■ Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Piping System Definitions.
Specifying the Display Properties of a System

Display properties control how parts that belong to the system are displayed in your layout. System definitions use the display properties configured for the display representations, but you can override display settings to customize display for a system definition.

For information on the AutoCAD MEP display system, see AutoCAD MEP Displays.

To specify the display properties of a system

1. Within the domain-specific workspace, open the Style Manager and access the system definitions:
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ HVAC System Definitions.
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Piping System Definitions.
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Electrical System Definitions.
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Plumbing System Definitions.
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Schematic System Definitions.

2. In the left pane, select the system, and, in the right pane, click the Display Properties tab.

3. Under Display Representations, select the display representation you want to override.

4. For the selected display representation, select Style Override.

5. In the Display Properties dialog, modify the display properties of the display components as needed.
   - To edit each property, click its field.

6. Click OK twice.

NOTE You might need to regenerate your drawing to display rise graphics and drop graphics for systems that have existing runs drafted.
Attaching Notes and Files to a System

1. Within the domain-specific workspace, open the Style Manager and access the system definitions:
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ HVAC System Definitions.
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Piping System Definitions.
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Electrical System Definitions.
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Plumbing System Definitions.
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Schematic System Definitions.

2. In the left pane, select the system to which you want to attach notes or files and, in the right pane, click the General tab.

3. Click Notes.

4. To add a note, click the Notes tab, and enter a note.

5. To work with reference documents, click the Reference Docs tab:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>attach a reference file</td>
<td>click Add, select a file, and click OK.</td>
</tr>
<tr>
<td>edit the description of a reference file</td>
<td>select the file, and click Edit. Edit the description, and click OK.</td>
</tr>
<tr>
<td>edit a reference file</td>
<td>double-click the reference file name to start its application.</td>
</tr>
<tr>
<td>detach a reference file</td>
<td>select the file name, and click Delete.</td>
</tr>
</tbody>
</table>

6. Click OK twice.

Copying Systems Between Drawings

You can manage your systems more efficiently by storing them in a single drawing or template and then copying them into new drawings as you need them.

NOTE Additional system definitions can be found in System Definitions.dwg, which is located in a subfolder of the following folder: \ProgramData\Autodesk\MEP 2010\enu\Styles.

To copy a system

1. Click Manage tab ➤ Style & Display panel ➤ Style Manager.

   The software opens the Style Manager with the current drawing expanded in the tree view. Any drawings open in the current session are also shown in the tree view.
Open the drawing into which to copy the system:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then in Style Manager…</th>
</tr>
</thead>
<tbody>
<tr>
<td>copy the system to a drawing that is not open in Style Manager</td>
<td>click File ➤ Open Drawing, select the drawing, and click Open.</td>
</tr>
<tr>
<td>copy the system to a new drawing</td>
<td>click File ➤ New Drawing, enter a name for the drawing, and click Save.</td>
</tr>
</tbody>
</table>

Expand System Definitions under the open drawings to display those systems in the drawings.

Right-click the system definition to copy to another drawing, and click Copy.

To copy all system definitions, right-click System Definitions, and click Copy.

Right-click the drawing into which to copy the system definition, and click Paste.

The system definition is copied into the selected drawing. If the drawing already contains a system with the same name, the duplicate name is displayed in the Import/Export - Duplicate Names Found dialog.

Resolve duplicate system names, if prompted:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>prevent Style Manager from overwriting the existing system definition with the new system definition of the same name</td>
<td>select Leave Existing, and click OK.</td>
</tr>
<tr>
<td>replace the existing system definition with the new system definition</td>
<td>select Overwrite Existing, and click OK.</td>
</tr>
<tr>
<td>keep the existing system definition and add the new system definition with a different name</td>
<td>select Rename to Unique, and click OK. Style Manager appends a number to the name of the new system definition. Right-click the system definition and click Rename to change the name.</td>
</tr>
</tbody>
</table>

You can click Apply instead of OK to save your changes and continue working in Style Manager.

**Purging Systems**

You can purge any systems that are not applied to parts in the drawing.

To purge a system

1. Within the domain-specific workspace, open the Style Manager and access the system definitions:
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ HVAC System Definitions .
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Piping System Definitions .
Selecting a Display Configuration

In addition to using orthographic and isometric views in a drawing, AutoCAD MEP includes many display settings that control how objects appear in a drawing. Display representations control how objects appear in different views. Display configurations are groups of display representations designed for specific tasks. For example, you can change from a 1-line display configuration to a 2-line. You can also change to a discipline-specific display configuration, such as one that shows mechanical systems in specified colors and linetypes yet screens all other types of systems.

The default templates include display settings you can use for all aspects of project design and documentation. You can also customize displays to meet specific project requirements. For more information on displays, see Display System Structure on page 135.

To change the current display configuration

1 Click the current display configuration in the Drawing Window status bar.

The displays included with the drawing are listed.
Default display configurations included in the Aecb Model drawing template

2 Select a display configuration from the list.

For more information on the display configurations included in the Aecb Model drawing template, see Display Configurations on page 139.

Essentials of Objects

Building systems are typically assembled from fabricated, off-the-shelf parts. With AutoCAD MEP, you create design layouts by assembling objects that represent real-world parts, such as duct, cable tray, pipe segments, fittings, equipment, devices, panels, and fixtures. All parts are classified as specific types of objects. Understanding the different types of objects is crucial to understanding how the software draws parts and applies multiple display representations to those parts.

There are 2 types of parts: block-based and parametric. A block-based part is a specific instance of a part with predefined properties such as shape and size. Block-based parts are predefined based on properties and a series of AutoCAD® blocks. Each block represents the part in a different view, enabling the parts to have different appearances in different view directions.

Different views of a mechanical part

Different views of an electrical part
A parametric part is dynamically generated based on predefined or user-defined properties, such as shape and size. The part properties determine how the part is generated. Parametric parts are generated as 3-dimensional model blocks; therefore, different appearances display in different view directions. For more information about parametric and block-based parts, see Understanding Parametric and Block-Based Parts on page 641.

Parts can have specific behaviors, such as automatic cleanup when connecting to other parts, or default insertion under certain design circumstances. Parts can have multiple components, such as a centerline, insulation, and lining. The object type of a part is the basis for controlling part behavior and display representations.

### Object Types

The following table describes the object types in AutoCAD MEP.

<table>
<thead>
<tr>
<th>Object</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cable Tray Fitting</td>
<td>A part dynamically generated based on predefined properties to which other parts can be connected. It can be inserted during layout and includes as components connector, annotation, centerline, and rise/drop.</td>
</tr>
<tr>
<td>Cable Tray</td>
<td>A part dynamically generated based on predefined properties to which other parts can be connected. It is trimmed when fittings are connected and includes as components connector, annotation, centerline, and rise/drop.</td>
</tr>
<tr>
<td>Circuit</td>
<td>A non-graphical object that represents the connection between electrical components. It has unique identifying properties including system, rating, panel, number of devices, length, number of poles, voltage, total load, demand factor, and estimated demand load.</td>
</tr>
<tr>
<td>Conduit Fitting</td>
<td>A part dynamically generated based on predefined properties. It can be inserted during layout and includes as components connector, annotation, centerline, and rise/drop.</td>
</tr>
<tr>
<td>Conduit</td>
<td>A part dynamically generated based on predefined properties to which other parts can be connected. It is trimmed when fittings are connected and includes as components connector, annotation, centerline, and rise/drop.</td>
</tr>
<tr>
<td>Device</td>
<td>A style-based part that can appear as one of several predefined blocks, depending on the display representation and the direction from which it is viewed. It is used by the Wire object type to complete connections between multiple electrical parts.</td>
</tr>
<tr>
<td>Duct Custom Fitting</td>
<td>A part dynamically generated from a centerline created from user-selected AutoCAD entities, such as lines and arcs, for the geometry.</td>
</tr>
<tr>
<td>Duct Fitting</td>
<td>A part dynamically generated based on predefined properties to which other parts can be connected. The part can be inserted by the software as you lay out duct and includes as components contour, connector, annotation, centerline, insulation, lining, and rise/drop.</td>
</tr>
<tr>
<td>Object</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Duct</td>
<td>A part dynamically generated based on predefined properties to which other parts can be connected. It is trimmed when fittings are connected and includes as components contour, connector, annotation, centerline, insulation, lining, and rise/drop.</td>
</tr>
<tr>
<td>Flex Duct</td>
<td>A part dynamically generated based on predefined properties and a single user-defined centerline to which other parts can be connected. It includes as components contour, connector, annotation, centerline, insulation, lining, and rise/drop; has multiple graphic representations.</td>
</tr>
<tr>
<td>Flex Pipe</td>
<td>A part dynamically generated based on predefined properties and a single user-defined centerline to which other parts can be connected. It includes as components contour, connector, annotation, centerline, insulation, lining, and rise/drop and it has multiple graphic representations.</td>
</tr>
<tr>
<td>Label Curve</td>
<td>A style-based object that uses attributes to query part information for labeling. Each label can be dynamically anchored, yet modified independently of its related part.</td>
</tr>
<tr>
<td>MvPart</td>
<td>A parametric or block-based part that can appear differently in different views based on predefined or user-defined properties or predefined AutoCAD blocks, and depending on the display representation and the direction from which it is viewed. The part can have one or more connection points, and it represents equipment such as air terminals and fans, and fixtures such as lavatories and toilets.</td>
</tr>
<tr>
<td>Panel</td>
<td>A style-based part that can appear as one of several predefined blocks, depending on the display representation and the direction from which it is viewed. It is used by the Wire object type to complete connections between multiple electrical parts.</td>
</tr>
<tr>
<td>Pipe Custom Fitting</td>
<td>A part dynamically generated from a centerline created from user-selected AutoCAD entities, such as lines and arcs, for the geometry.</td>
</tr>
<tr>
<td>Pipe Fitting</td>
<td>A part dynamically generated based on predefined properties to which other parts can be connected. It can be inserted by the software as you lay out pipe and includes as components contour, connector, annotation, centerline, insulation, lining, and rise/drop.</td>
</tr>
<tr>
<td>Pipe</td>
<td>A part dynamically generated based on predefined properties to which other parts can be connected. It is trimmed when fittings are connected and includes as components contour, connector, annotation, centerline, insulation, lining, and rise/drop.</td>
</tr>
<tr>
<td>Plumbing Fitting</td>
<td>A style-based part generated based on predefined properties to which other parts can be connected. It can be inserted during layout and maintains knowledge of flow direction, slope, elevation, and fixture unit load. It includes as components centerline, connector, annotation, rise/drop, slope, and fitting.</td>
</tr>
<tr>
<td>Plumbing Line</td>
<td>A style-based part generated based on predefined properties to which other parts can be connected. It can have different appearances when crossing other segments and different graphical representations for different types of plumbing lines. It is trimmed when additional segments and fixtures are connected and maintains knowledge of flow direction, slope, elevation, and fixture unit load. It includes as components centerline, connector, annotation, rise/drop, slope, and fitting.</td>
</tr>
<tr>
<td>Schematic Line</td>
<td>A single-segment or multi-segment line used to specify the connectivity and logic dependencies of a building systems layout. It has multiple annotation styles for crossing lines and is trimmed when schematic symbols are added. The properties of a schematic line include system, designation, and ID.</td>
</tr>
<tr>
<td>Object</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Schematic Symbol</td>
<td>A block symbol used to specify real-world equipment or parts, such as fittings or valves, that works in conjunction with schematic lines. It connects to schematic lines by breaking into the line or attaching to the end of the line when added. The properties of a schematic symbol are system and ID.</td>
</tr>
<tr>
<td>Wire</td>
<td>A style-based part generated based on predefined properties to which other parts can be connected. It has multiple annotation styles for crossing segments and connections, and multiple graphic representation styles for different types of wire. It cleans up when additional wire segments, accessories, panels, and devices are connected.</td>
</tr>
</tbody>
</table>

### Matching Object Properties

Use the match properties feature when you want to match the style and object display properties between AutoCAD MEP objects of the same type. For MEP objects of different types you can use the command to match basic AutoCAD properties. Likewise, you can match basic AutoCAD properties between an AutoCAD entity and an AEC object.

When you match properties between some style-based MEP objects, both the style properties and the display properties of the selected source object are applied to one or more selected destination objects. For non-style-based objects and most style-based objects, only display properties are matched. In either case, the display properties are applied to all display representations of the destination object.

<table>
<thead>
<tr>
<th>Object Types for Which Both Style and Display Properties Are Matched</th>
<th>Object Types for Which Only Display Properties Are Matched</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fabrication</td>
<td>Cable Tray</td>
</tr>
<tr>
<td>Hangers</td>
<td>Cable Tray Fitting</td>
</tr>
<tr>
<td>Label Curve</td>
<td>Conduit</td>
</tr>
<tr>
<td>Plumbing Lines</td>
<td>Conduit Fitting</td>
</tr>
<tr>
<td>Schematic</td>
<td>Device</td>
</tr>
<tr>
<td>Wire</td>
<td>Duct</td>
</tr>
<tr>
<td></td>
<td>Duct Custom Fitting</td>
</tr>
<tr>
<td></td>
<td>Duct Fitting</td>
</tr>
<tr>
<td></td>
<td>Duct Flex</td>
</tr>
<tr>
<td></td>
<td>Multi-View Part</td>
</tr>
<tr>
<td></td>
<td>Panel</td>
</tr>
<tr>
<td></td>
<td>Pipe</td>
</tr>
<tr>
<td></td>
<td>Pipe Fitting</td>
</tr>
<tr>
<td></td>
<td>Pipe Custom Fitting</td>
</tr>
</tbody>
</table>
Overrides

When you use the match properties feature, any style or object overrides in effect for the source object are applied to all display representations of the destination object. Overrides currently in effect for the destination object will be removed if they conflict with corresponding settings for the source object. If you want to change a setting for a particular display property in a particular display representation, the recommended method is to use the Display tab of the Properties palette. For more information, see Modifying Elevation-Based Display Components on the Properties Palette on page 149.

To match object properties

1. Click Home tab ➤ Modify panel ➤ Match Properties.
2. Select the source object whose properties you want to copy.
   The cursor changes to a paintbrush symbol.
3. Select one or more destination objects to which you want to apply the properties of the source object.
   Source object properties are applied to each destination object as it is selected.
4. When finished selecting destination objects, press ENTER.

Working with Connectors

When you place building systems objects in your layout, you connect them using connection points. A valid connection point is a predefined point—called a connector—on a building systems object where properties such as system, shape, and size are conveyed to other building systems objects. Conveying properties between objects creates intelligent building systems. All building systems objects have smart connectors. Objects can have a single connector, such as on a terminal, receptacle, or water meter, or they can have multiple connectors, such as on an air handling unit or junction box.

To ensure that you are attaching to a connector on a building systems object, use AutoCAD MEP snaps. These snaps locate building systems connectors, similar to the way that AutoCAD® object snaps (osnaps) locate connection points, such as an object’s midpoint.

Connecting flexible duct to an air terminal

![Connection diagram]
When a connection is made, the new object inherits the properties of the original object. These properties define the new object and can include system, elevation, and geometric properties, such as shape and size.

The connectors of a style define the location of the connection points on the object and specify each connector's domain. The domain is the type of building system to which the object or connector belongs. For example, an electrical object, such as a junction box, belongs to the electric domain. Building systems objects can have connectors that belong to different domains. For example, an air handling unit belongs to the HVAC domain, but it has multiple connectors that belong to different domains: a connector for gas belongs to the pipe domain and a connector for power belongs to the electric domain. Each domain has a predefined list of properties that can be compared to ensure that valid connections are made.

For more information, see Configuring the Connectors of a Style on page 608.

**Connection Behavior**

Connector styles specify the rules that determine which properties are compared and whether connections are allowed between objects based on the results of the comparison. For example, when connecting pipe to pipe, typically you want to ensure that the 2 pipe segments are the same size and belong to the same system unless specifically designed otherwise.

**RELATED** For more information on connector behavior for catalog-based content, see Rules for Connector Behavior on page 652. For more information related to style-based content, see Connector Styles on page 616.

**Checking Connections**

You can verify the validity of connections, runs, and systems. The software provides tools for checking a layout for valid connections, showing the location of disconnected connections, and viewing an entire connected run from start to end. For more information, see Checking Your Drawings on page 579.

**Working with Anchors**

An anchor is a general linking mechanism within AutoCAD MEP. Building systems objects can be anchored to each other, enabling you to create a relationship between objects. Anchoring objects can be useful for positioning lavatories or toilets along a wall, or air terminals or light fixtures in a ceiling grid. You can choose from 3 types of anchors to attach building systems objects:

- **Curve anchors.** Attach objects to the base curve, typically the centerline, of other objects.

- **System anchors.** Attach objects to a system run. Anchored objects can be moved along the entire run to other runs assigned to the same system.
■ Reference anchors. Attach objects by reference to other objects, such as attaching an end-of-line schematic symbol to a schematic line. When the symbol is moved, the line maintains connectivity and is stretched to the new location.

Certain objects are, by default, anchored to other objects; however, their behavior can differ slightly depending on object type. For example, when a schematic symbol is added to an existing line, the symbol is, by default, attached to the schematic line using a system anchor. The symbol can be easily moved along the line or moved to another unconnected line of the same system. It cannot, however, be moved outside a line and stand alone. To do that, you must first remove the anchor between the symbol and line.

Attaching Objects with a Curve Anchor

Use this procedure to attach objects with a curve anchor. With curve anchors, you can attach building systems objects to the base curve of other building systems objects. The movement of an object anchored with a curve anchor is constrained by the object to which it is anchored. You can change the position of an anchored object relative to the curve in the X, Y, and Z directions. You can also rotate and flip the object along its axes. Curve anchors are best suited for attaching objects to linear objects like segments.

To attach an object with a curve anchor

1. Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content Browser.
2. Select the MEP Stock Tool Catalog.
3. In the Content Browser, on the left navigation bar, select Common ➤ Common Items.
4. Click the i-drop icon on the Curve Anchor tool, and drag the tool onto your drawing.
5. Enter at (attach object), and then select the object to be anchored.
6. Select a point on the curve to which to anchor the object.

   The object is anchored to the curve at the X position. When the object is placed, the Y and Z positions are 0.

7. To change the position of the anchored object, do any of the following:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then enter...</th>
</tr>
</thead>
<tbody>
<tr>
<td>move the object to a different curve</td>
<td>s (set curve), select the anchored object, press ENTER, and then select a new curve.</td>
</tr>
<tr>
<td>change the position of the object along the curve by specifying a distance from the center or end of the curve</td>
<td>p (x position), select the anchored object, and select a point on the base curve. Then enter a distance and specify what to measure to: Near edge, Far edge, or Center.</td>
</tr>
<tr>
<td>change the rotation of the anchored object</td>
<td>r (rotation), select the anchored object, press ENTER, and then specify a rotation angle.</td>
</tr>
<tr>
<td>rotate the object around the X axis</td>
<td>x (rotation X), select the anchored object, press ENTER, and then enter or specify a rotation angle.</td>
</tr>
<tr>
<td>rotate the object around the Y axis</td>
<td>y (rotation Y), select the anchored object, press ENTER, and then enter or specify a rotation angle.</td>
</tr>
<tr>
<td>change the anchored end of the object</td>
<td>an (set anchored), select the anchored object, and then select a point on or near the base curve end.</td>
</tr>
</tbody>
</table>

8. Press ENTER.
Attaching Objects with a System Anchor

Use this procedure to attach objects with a system anchor. With system anchors, you can attach building systems objects to other building systems objects based on their assigned system. The movement of an object anchored with a system anchor is constrained by the object to which it is anchored. You can change the position of an anchored object by dragging the object along the entire system run. You can also drag the anchored objects to other runs assigned to the same system.

To attach an object with a system anchor

1. Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content Browser.
2. Select the MEP Stock Tool Catalog.
3. In the Content Browser, on the left navigation bar, select Common ➤ Common Items.
4. Click the i-drop icon on the Systems Anchor tool, and drag the tool onto your drawing.
5. Select the object to be anchored.
6. Select a point on the curve to which to anchor the object, and press ENTER.

The object is anchored to the curve at the X position. When the object is placed, the Y and Z positions are 0.

Rotating Objects Attached with Curve Anchors

1. Select the object that is attached to a curve, such as the centerline of another object.
2. Rotate the selected object:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then right-click, and click…</th>
</tr>
</thead>
<tbody>
<tr>
<td>flip the object along the X axis</td>
<td>Curve Anchor ➤ Flip X.</td>
</tr>
<tr>
<td>flip the object along the Y axis</td>
<td>Curve Anchor ➤ Flip Y.</td>
</tr>
<tr>
<td>flip the object along the Z axis</td>
<td>Curve Anchor ➤ Flip Z.</td>
</tr>
</tbody>
</table>

Attaching Objects with a Reference Anchor

Use this procedure to attach objects with a reference anchor. With reference anchors, you can attach building systems objects to other building systems objects by reference, or association. The movement of an object anchored with a reference anchor maintains the association between the objects. When you change the position of the anchored object, the reference object is moved along with it. A point of connection is always maintained. Reference anchors are best suited for attaching objects to non-linear objects (like flex duct or wire) that may change in layout frequently.

To attach an object with a reference anchor

1. Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content Browser.
2. Select the MEP Stock Tool Catalog.
3. In the Content Browser, on the left navigation bar, select Common ➤ Common Items.
4. Click the i-drop icon on the Reference Anchor tool, and drag the tool onto your drawing.
5. Select the object to be anchored.
6. Select a point on or near the end of the curve to which to anchor the object, and press ENTER.

The object is anchored to the end of the curve.
Then right-click, and click…

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then right-click, and click…</th>
</tr>
</thead>
<tbody>
<tr>
<td>rotate the object around the X axis</td>
<td>Curve Anchor ➤ Set Rotation X, enter the number of degrees, and press Enter.</td>
</tr>
<tr>
<td>rotate the object around the Y axis</td>
<td>Curve Anchor ➤ Set Rotation Y, enter the number of degrees, and press Enter.</td>
</tr>
<tr>
<td>rotate the object around the Z axis</td>
<td>Curve Anchor ➤ Set Rotation, enter the number of degrees, and press Enter.</td>
</tr>
</tbody>
</table>

NOTE The flip and rotate commands rotate the object relative to the axes of the curve to which it is attached.

If the object is an isometric symbol, it is rotated to the orientation that most closely matches the angle you specify. For examples of these orientations, see Orthographic and Isometric Views of Style-Based Content on page 86.

**Releasing Anchored Objects**

Use this procedure to release anchored objects, whether anchored with a curve, system, or reference anchor. When you release an anchored object from another object, you remove the relationship between the objects. You can release any anchored object, even those objects anchored by default when added to a drawing.

To release anchored objects

1. Select one or more objects with anchors that you want to release.
2. Release the objects:
   - If you want to release…                  then…
   - objects anchored with curve anchors     right-click, and click Curve Anchor ➤ Release.
   - objects anchored with systems anchors   right-click, and click Systems Anchor ➤ Release.
   - objects anchored with reference anchors right-click, and click Reference Anchor ➤ Release.

The objects are released; however, no change is visible.

**Part Anchors**

You can access anchor information in two ways in AutoCAD MEP:

- From the Anchor tab in the Multi-view Part Properties dialog (for MvParts)
- From the Properties palette (Piping and Schematic domains)

NOTE The Anchor icon ( ) and associated worksheet on the Properties palette will only appear if the selected pipe fitting or symbol uses anchors.
An anchor links an AutoCAD MEP object to another object or to a layout curve or grid. In the Piping domain, this worksheet applies to fittings that use anchors (i.e., takeoffs). In the Schematic domain, it applies to symbols. You can view and modify the X, Y, and Z insertion points relative to the current coordinate system and rotation angle of the anchor. You can reposition anchored objects along a segment axis by specifying a dimensioned location or by flipping the anchor around the X, Y, or Z axis. The Anchor tab is available only after the objects have been anchored with an anchor tool.

Using the Compass

To create an accurate model of your layout, you often need to draw relative to a particular UCS plane or relative to other objects in your building model. As you draw, you can use the Compass to guide the direction of your run. Any part you add to a layout can be aligned to a specified rotation angle or snap increment angle on the Compass. You can use tick marks on the Compass as a visual reference to guide the alignment of the insertion point and angle of a part. Using snap increments and tick marks provides a fast and consistent method of laying out runs.

Examples of Compass tick mark increment settings

For most drafting tasks, it is useful to assign tick marks based on the specified snap increment. For example, if the snap increment is at 45 degrees, then assign tick marks to appear at 45 or 90 degrees. However, if the snap increment is less than 45 degrees, such as 15 degrees, assign the tick marks to appear at 30, 45, or 90 degrees to avoid a cluttered Compass display.

NOTE The snap increment and tick marks are independent settings of the Compass and do not need to match in value. You can place a part by snapping to a specified angle without aligning to a tick mark on the Compass.

You can also change the color and size of the Compass display to enhance the visibility of the Compass as it overlaps and aligns with objects in your drawing. The Compass size is expressed in pixels and remains constant regardless of the zoom scale factor you apply to a drawing.
Compass diameter changes

When the Compass is enabled, you can switch the UCS plane you are drafting by using the Plane option. Each time you switch planes the UCS axis changes:

- The X axis switches to the Y axis.
- The Y axis switches to the Z axis.
- The Z axis switches to the X axis.

Understanding this behavior is important when drawing at different angles and elevations using the Compass. The following example illustrates how you can draw a rigid duct run with segments that are aligned with the 3 different UCS planes when the Compass is enabled.

1. Draw 2 duct segments in the first UCS plane.

2. On the command line, enter p (plane), and then draw 2 duct segments in the second UCS plane.
3 Enter p (plane), and draw 2 duct segments in the third UCS plane.

4 Enter p (plane) again to return the UCS place to its original orientation.

Customizing the Compass Display

Use this procedure to customize the Compass display. As you draw, the Compass guides the direction of your run. It is helpful to use the Compass to align your parts with walls, ceilings, and other architectural elements in the drawing. You can use the Compass Settings dialog to control tick marks, snap increment, compass diameter, and color. For more information, see Using the Compass on page 112.

To customize the Compass display

1 Click View tab ➤ MEP View panel ➤ Compass.
2 In the Compass Settings dialog, specify the Compass display:

<table>
<thead>
<tr>
<th>If you want to change the...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>diameter of the Compass</td>
<td>enter a value for Compass Diameter.</td>
</tr>
<tr>
<td>display color of the Compass</td>
<td>click , select a color tile or enter the name or number of the color you want to use, and then click OK.</td>
</tr>
<tr>
<td>snap increment</td>
<td>select Enable Snap, and enter a value.</td>
</tr>
<tr>
<td>tick mark increment</td>
<td>select Enable Tick Marks, and enter a value.</td>
</tr>
</tbody>
</table>

**TIP** You can control the number of decimal places, or precision, of the value for the Compass tick mark increment by changing the AutoCAD® Units Precision setting.

Designing with Dynamic Input and Grips

Dynamic input is a command interface that displays near the cursor and includes command prompts, cursor input fields, and dimension input fields.

Grips are small, solid-filled shapes displayed at strategic points on a selected object. You can use grips to modify an object in many ways. For example, you can use grips to lengthen or rotate the object, or modify its location or elevation. You can also use grips to quickly create runs of duct, pipe, cable tray or conduit.
Together, dynamic input and grips enable you to make precise and accurate modifications to your mechanical, electrical, or plumbing design directly in the drawing area. Because you do not divert your attention to the command window and dialogs as frequently, you maintain focus on the design and increase your productivity.

**Dynamic Input**

Dynamic input is a command interface that displays near the cursor and includes 3 dynamic components:

- Command prompts that instruct you on performing tasks.
- Cursor input fields that allow you to enter relative or absolute coordinates in polar or Cartesian format.
- Dimension input fields that allow you to specify length and angle changes or new overall dimensions.

**Enabling and Disabling Dynamic Input**

To disable or enable dynamic input, click on the application status bar. Dynamic input is enabled by default.

You can also disable, enable, and modify the settings for the 3 components of dynamic input individually. For more information, see “Use Dynamic Input” in AutoCAD® Help.
Grip Tooltips

You can hover your pointing device over a grip to display a short description of its function. Depending on the grip and context, the tooltip might also contain information about the available grip editing modes.

Tooltip for Show all insertion points grip on electrical panel

Tooltip for Location grip on valve

Grip Constraints

When you drag a grip on an object in order to change its dimension properties, AutoCAD MEP often constrains the grip to a line, curve, or plane. Whenever the constrained position of a grip differs from the current cursor position, the software displays dotted lines or arcs to inform you of the constraint and its effect.

As an example, refer to the following illustration of lengthening a duct segment. The current cursor position cannot result in an angle change because the software always constrains the Lengthen grip to the current angle of the segment.

Trigger Grips

Unlike grips that you drag in the drawing to change the dimension properties of an object, trigger grips immediately perform an action when you click them.

Some trigger grips change the editing mode of an object. Other trigger grips set the properties of an object. For example, clicking the Rotate grip on an object rotates it 180 degrees, which changes the value of its Rotation property. Holding the Ctrl key while clicking flips the object 90 degrees.
Grip Editing Modes

The grip editing mode determines how the action you perform using a grip is executed by AutoCAD MEP. If a grip has multiple editing modes, the software lists them in the grip tooltip, and you must specify the mode to use.

Trigger grips have 1 or 2 editing modes. To use the default mode, simply click the grip. To use the second mode, hold CTRL while clicking the grip. In the following illustration, the pipe elbow fitting has a Rotate grip with 2 modes for rotating 180 or 90 degrees.

Drag grips that require you to specify points or dimensions can have one or multiple editing modes. For these grips, you select a mode and then use the grip. In the following illustration, the variable air volume (VAV) box has a Location grip with 3 editing modes.

To specify a grip editing mode

1 Click the grip to select it.
2 Select a mode:

<table>
<thead>
<tr>
<th>If you want to use...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>the first mode</td>
<td>modify the object using the grip. The first mode listed in the tooltip is the default mode.</td>
</tr>
<tr>
<td>the second mode</td>
<td>press and release CTRL.</td>
</tr>
<tr>
<td>a subsequent mode</td>
<td>press and release CTRL as many times as needed.</td>
</tr>
</tbody>
</table>

You can now modify the object using the grip.
Drafting with Flow Direction

Flow direction is the forward movement of a material or fluid (such as air or water) through the components of a system. You can set or reverse the flow direction of a duct run or a pipe run between 2 branches. Once you set the flow direction, you can show it using flow markers, toggling the markers on and off as needed. The flow markers are solid 2D arrows displayed at the midpoint of segments.

Flow markers indicating the flow direction of a pipe run

NOTE In addition to flow markers, you can also add flow labels (sometimes referred to as flow arrows in the software) to duct runs and pipe runs. Like flow markers, flow labels show the current flow direction of the run if the flow direction has been set, and they are scaled according to the annotation scale. Unlike flow markers, flow labels are fully annotative objects, which means you can modify and delete them. For information on adding flow labels as you draw, see Adding Labels or Flow Arrows to Ducts on page 177 or Adding Labels or Flow Arrows to Pipe on page 317.

To set or reverse the flow direction of a duct or pipe run

1 Select a segment in the run.
2 Click Duct tab ➤ Calculations panel ➤ Set Flow Direction .

You can perform the same operation on a pipe run using Set Flow Direction on the Pipe tab.

3 The current flow direction of the run is shown by an arrow in the center of the selected segment. If the run does not have an assigned flow direction, the start point of the segment is considered upstream, and a default flow direction is shown.

4 Do one of the following:
   - Enter y (yes) to reverse the flow direction.
Enter n (no) to accept the indicated flow direction.

The selected run between branches is assigned the indicated flow direction. Flow direction for a run stops at branch fittings (fittings with 3 or more connectors, such as tees and crosses) and MvParts.

**NOTE** To reverse the flow direction of a single segment, select it, right-click, and click ReverseSegment (or enter reversesection).

To turn flow markers on or off for all runs that have a flow direction

1. Select a segment in a run.
2. Click Pipe tab or Duct tab ➤ Calculations panel ➤ Show Flow.

**NOTE** If you do not want flow markers to appear on construction documents, turn them off before plotting or publishing.

## Selecting Similar Objects

AutoCAD MEP provides a way to select similar objects. You can use the Select Similar command to select objects that have the same style in order to make global changes to the objects.

**NOTE** Block references are selected based on their layer and block definition.

**To select similar objects**

1. Select the first object.
2. Click the object’s contextual ribbon tab ➤ General panel ➤ Select System drop-down ➤ Select Similar.

You can also use AutoCAD® commands on the Properties palette to select objects:

- **Select Objects command**—Use this command to create a selection set with your pointing device, for example, by creating a window selection.
- **Quick Select command**—Use this command to create a selection set filtered by a specific property, such as lineweight or plot style.
Selecting MEP Objects

AutoCAD MEP provides a way to select MEP objects by system, domain, or connected branch within an object’s contextual ribbon, General panel ➤ Select System drop down.

To select similar objects by group, domain, or connected branches

1. Select an MEP object, such as a duct or pipe.
2. From the contextual ribbon for the object, click General panel ➤ Select System drop-down.
3. Make a selection from the sub-menu.

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Use...</th>
</tr>
</thead>
<tbody>
<tr>
<td>select the objects in a particular system, such as an HVAC system</td>
<td>Select System</td>
</tr>
<tr>
<td>select the objects in all systems</td>
<td>Select System Group</td>
</tr>
<tr>
<td>select the objects in a domain, such as the Duct domain (Duct segments, fittings, flex duct, etc.)</td>
<td>Select Domain</td>
</tr>
<tr>
<td>select via tabbing the sequence of connected objects that lie between two branches (a branch is any part that has three or more connectors, i.e., tee, cross, etc.)</td>
<td>Select Connected Branches</td>
</tr>
</tbody>
</table>

4. Select an object, if not already selected, or use the Tab key to cycle among connected branches.

Regenerating an AutoCAD MEP Model

Use this procedure to regenerate an AutoCAD MEP model. You should regenerate a drawing model after making a large number of changes to the model, after applying new display representations to objects in
the model, or if you are working with external reference (xref) files. Regenerating an AutoCAD MEP model steps through its objects and displays them based on current settings and preferences. You should also regenerate the model when objects do not display correctly, specifically after an AutoCAD® Regen. However, to avoid performance problems during regeneration of large drawings, select only those objects that are displaying incorrectly.

To regenerate an AutoCAD MEP model

1. Click View tab ➤ Appearance panel ➤ Regenerate drop-down ➤ Regenerate Model.
2. Select one or more objects to regenerate, or press ENTER to regenerate the entire drawing.

Viewing Part Properties

Every part in AutoCAD MEP has unique characteristics or properties that define the part’s state, appearance, or value. Properties can be predefined or user-defined and, depending on the type of object or the specific property, are accessible through the Properties palette.

During layout you define, select, and specify part properties through the Properties palette. At times you might want to know details about an existing part in your drawing, such as part type or sub type.

The Properties palette lists the properties for the selected part. You can modify general object properties such as color and layer, and location object properties such as rotation angle. For more information, see Modifying Object Properties Using the Properties Palette on page 91.

NOTE The Add dialog currently appears when you add some MEP objects in AutoCAD MEP, such as electrical, HVAC, and Multi-view parts (called MvParts). Likewise, the Modify or Properties dialogs appear when you change properties for some MEP objects.

Basic Part Information

You can access properties on the Design tab of the Properties palette. Expand Basic to view the various settings.

Duct properties on the Properties palette

You can also assign property set information to objects that typically have associated schedules, such as MvParts. Click the Extended Data tab on the Properties palette for Property Sets.
System Assignments for Parts and Connectors

You can access the systems assigned to parts on the Design tab of the Properties palette. Expand Basic and make your selection for System from the list.

Available assignments for plumbing systems

You can select an object (such as a pipe, flex pipe, and pipe fitting) on the Piping Tool palette and add it to your drawing. Then, select the newly added segment and click on Connection Details on the Design tab of the Properties palette to view pipe connection properties on the Connection Details worksheet.
Connection details for Pipe in Add mode

You can view and modify additional details for pipe connections.

Connection Details dialog in the Modify mode

NOTE Changing a system assignment on a connection may change the system assignment of connecting parts, depending on the connector style rules in your drawing.

On the Design tab of the Properties palette, you can also assign a style for the label and flow arrow associated with a piping or plumbing object by choosing it from the list.
Assigning a piping label style

Part Styles

You can access object styles from the Design tab on the Properties palette. Expand Basic ➤ General and choose a style from the list. Only the styles defined in your drawing are shown.
Part Property Details

You can view and modify part property details on the Design tab of the Properties palette. For schematic lines, you can define the designation ID for labeling. For parts, such as ducts and cable trays, you can view a list of part properties that dynamically change when you swap parts from the part catalog. Part properties include general part data, such as type and sub-type, connector type, dimension, system, and location properties.
For other parts, such as plumbing lines, you can view and modify part properties including elevation, nominal size, and slope. You can view the read-only value for the calculated size of the pipe. When you change the part properties, the part is dynamically updated in your layout.
Part Location

You can access part location information on the Properties palette. You can view and modify the X, Y, and Z insertion points relative to the current coordinate system and rotation angle of the part. Expand Basic ➤ Location on the Properties palette to specify elevation, start, mid, and end point values. Click Additional Information for other location coordinates. This option is available only after the part has been added to the drawing.

Location properties for Cable Tray
Working with Projects

This section describes how to create a project environment and establish standards for your projects. By using project standards, you can enhance efficiency, automate repetition, and maintain consistency across your project drawings and construction documents.

Working with Drawing Management Projects

The Drawing Management feature formalizes the processes related to building system design and documentation. This feature automates the management, viewing, and construction of building systems, ensuring consistency in all aspects of the project. Consequently, your entire design team has a centralized project environment for accessing the most current documents.

The basis of the Drawing Management feature is a sophisticated referenced drawing (xref) feature enhanced from standard AutoCAD xref functionality. Project elements are referenced into constructs; constructs are referenced into views, and views are referenced into plotting sheets. Powerful linking features ensure that source files can be distributed over many different locations on a single computer or network, enabling simultaneous access by others working on the same project.

3D detail view of a mechanical room
The Drawing Management feature has two main components:

**Project Browser**

Project Browser creates projects and specify high-level project information and settings, such as the project number, project name, contact information, and the file locations of the drawing templates, tool palettes, and the project-specific Content Browser library to use.

**Project Navigator**

Project Navigator centralizes project-specific tasks, such as defining building levels and divisions (wings), creating project drawings, and creating plotting sheets.

A drawing must be part of a project to synchronize with project standards. The Drawing Management feature ensures that project standards are properly enforced. You cannot apply project standards to standalone drawings. You can copy standard styles and display settings into standalone drawings, but they are not synchronized when the standards change.

**RELATED** See Concepts of Drawing Management in the AutoCAD Architecture Help.

**TIP** Discipline-specific exercises that use the Drawing Management feature are provided in hands-on tutorials in AutoCAD MEP.

**Establishing Project Standards**

Typically, at the beginning of a project, you establish the standards that guide the project design. Project standards, called CAD standards, enhance efficiency, automate repetition, and maintain consistency across your project drawings and construction documents.

Templates store the following standards required to begin a drawing:

- Unit type and precision
- Drawing and plotting scales
Dimension and text styles
Layer structures
Linetypes and lineweights

You can also establish the following design-specific standards on a drawing-by-drawing basis or add them to a template:

- Design and drawing preferences
- Coordinate systems
- Design and plotting display layouts
- Title blocks and borders

AutoCAD MEP, together with AutoCAD Architecture, provide several tools for establishing and managing standards. You can learn how to create standards for the following:

<table>
<thead>
<tr>
<th>To create</th>
<th>then learn about</th>
</tr>
</thead>
<tbody>
<tr>
<td>custom layer structures</td>
<td>layers, layer standards, layer key styles, layer keys, and the Layer Manager in AutoCAD MEP Layer Standards on page 132</td>
</tr>
<tr>
<td>standard fonts</td>
<td>text styles and the Style Manager in Creating Construction Documents on page 547 and Style Manager</td>
</tr>
<tr>
<td>standard dimensions</td>
<td>dimension styles and the Style Manager in Creating Construction Documents on page 547 and Style Manager</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE</strong> AutoCAD MEP objects do not support AEC Dimensions. Be sure to use AutoCAD MEP annotation tools or AutoCAD® dimensions.</td>
</tr>
<tr>
<td>annotation, such as labels</td>
<td>label styles and the Style Manager in Creating Construction Documents on page 547 and Style Manager</td>
</tr>
<tr>
<td>custom display representations</td>
<td>object types, standard display representations, and the Display Manager in Essentials of Objects on page 103 and AutoCAD MEP Displays on page 134 in this Help system and Display System in the AutoCAD Architecture Help</td>
</tr>
<tr>
<td>design layouts</td>
<td>design and layout preferences in Drawing Preferences on page 69</td>
</tr>
<tr>
<td>title blocks and borders</td>
<td>layout tabs and templates in AutoCAD MEP Templates on page 156</td>
</tr>
<tr>
<td>standard methods for plotting</td>
<td>plot styles, layout tabs, templates, and the Style Manager in AutoCAD MEP Templates on page 156 and Style Manager</td>
</tr>
</tbody>
</table>

The Project Standards feature lets you establish, maintain, and synchronize standards across all drawings in a Drawing Management project. Project standards include standard styles, display settings, and AutoCAD standards that are used across all project drawings. Standard styles and display settings are specified in one or more standards drawings associated with the project. Project drawings can then be synchronized with these standards throughout the project life cycle, either automatically, or on demand.

**RELATED** See Project Standards Overview in the AutoCAD Architecture Help.
AutoCAD MEP Layer Standards

The Layer Management feature in AutoCAD MEP lets you organize, sort, and group layers using layer standards, layer key styles, and layer overrides. Layer standards define the naming of new layers according to the structure defined in the standard. AutoCAD MEP includes a number of predefined layer standards and matching layer key styles based on common building system industry norms.

You can change any part of the layer name structure using layer key overrides within the layer key style. You can also override layer names for all of the layer keys in a layer key style or for individual layer key styles.

Layer Standards Overview

Layers organize the objects in a drawing and enforce linetype, color, and other standards. They are the equivalent of the overlays used in paper-based drafting. For example, in paper-based drafting, a building plan might contain overlays for the foundation, floor plans, and mechanical, plumbing, or electrical layouts. In AutoCAD MEP, you can organize the same information on layers in your drawings.

This section provides a summary of AutoCAD MEP layer standards and other related concepts.

Layer Standards

Layer standards establish naming conventions for the layers in your drawings. A layer standard contains rules that determine the structure of the layer names in a drawing. You can use layer standards to enforce and manage project standards for layers.

The software provides several default layer standards based on industry-standard layering conventions (for example, MEP Object - Based on AIA, and BS1192 - AUG Version 2). When you create a layer based on a layer standard, the name of the layer has several parts separated by delimiters, such as hyphens. Each part of the name is determined by the rules that are set in the layer standard definition. The default layer standard definitions for AutoCAD MEP are based on common industry layer standards. For example, according to the MEP Object layer standard, the layer name for duct is M-Duct-Std.

You can incorporate the default layer standards into your project standards, customize them, or create your own.
Layer Key Styles and Layer Keys

Each layer standard has a corresponding layer key style. A layer key style contains a set of layer keys. The layer keys assign objects to defined layers with names that conform to the layer standard. When you add an object to your drawing, the software automatically draws the object on the layer assigned to it in the current layer key style. This process is called layer keying.

Layer keys for duct and duct fitting objects

<table>
<thead>
<tr>
<th>Layer Key</th>
<th>Description</th>
<th>Layer Settings</th>
<th>Color</th>
<th>Line Type</th>
<th>Line Weight</th>
<th>Plot Style</th>
<th>Allow Override</th>
</tr>
</thead>
<tbody>
<tr>
<td>DRAINAGE</td>
<td>Drainage poly.</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td></td>
</tr>
<tr>
<td>Duct</td>
<td>HVAC Duct</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td></td>
</tr>
<tr>
<td>DuctConnection</td>
<td>HVAC Duct</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td></td>
</tr>
<tr>
<td>ELECTRIC</td>
<td>HVAC Duct</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td></td>
</tr>
</tbody>
</table>

Layer Standards Drawing

AutoCAD MEP lets you specify the layer standard and layer key style to use in the current drawing. You can also specify that the selected layer standard and layer key style be imported automatically into new drawings.

The software includes several layer standards and several layer key styles in a layer standards drawing named AecbLayerStd. This drawing is located in `\Documents and Settings\All Users\Application Data\Autodesk\ACD-MEP 2010\enu\Layers` or in one of its subfolders, depending on the content you installed. The templates provided with the software are configured to load an appropriate AecbLayerStd drawing into new drawings that you create.

NOTE The Layers folder contains other layer standards drawings with similar names that have appended version numbers (for example, AecbLayerStd5.dwg). These layer standards drawings originate from earlier versions of the software and are included to support legacy drawings.

Layer Properties Manager

The Layer Properties Manager lets you view and manage the layers in the current drawing. You also use the Layer Manager to access and manage the components that support layering, such as layer standards, layer key styles, layer keys, and layer key overrides.

In the Layer Properties Manager, all the layers in the current drawing are displayed in the All layer group. If you link any referenced drawings (xrefs) to the drawing, the layers are listed in an Xref layer group.
Specifying a Layer Standard and a Layer Key Style

1. Click Home tab ➤ Layers panel ➤ Select Layer Standard ➤ to select Layer Standard.
2. In the Drawing Setup dialog, click the Layering tab.
3. Under Layer Standards/Key File to Auto-Import, click ➤ to browse to the desired layer standards drawing (DWG or DWT file). Make your selection on the Open Layering File dialog.
4. If you saved the layer standards drawing on page 133 in the same folder as the default layer standard drawing, you can access the folder by clicking the Content folder in the left pane and then clicking the Layers folder.
5. Under Default Layer Standard in the Drawing Setup dialog, select the layer key style to use in your drawing, and click Apply.

Specify how to apply the layer settings:

- If you want to... then...
  - save the layer settings for the current drawing and apply them globally
  - select Save as Default.

- If you also changed the drawing units, the software prompts you to specify whether existing objects in the current drawing should be scaled for the new units.

Accessing Layer Key Styles and Layer Keys

1. Click Home tab ➤ Layers panel ➤ Layer Key Styles ➤ to access Layer Key Styles.
2. In the Style Manager, select a layer key style, and then click the Keys tab in the right pane.
   - The Keys tab displays the layer keys and related settings, including layer, color, linetype, and lineweight.

AutoCAD MEP Displays

Traditional, manual CAD designs require that you draw a single object (such as a duct or a pipe) multiple times in different drawings to produce different views of the same object. For example, you might have a 1-line drawing of a duct and piping layout and a separate 2-line drawing of the same layout to clarify the construction documents. For each drawing, you use a separate collection of drafting entities to represent the objects.
AutoCAD MEP provides tools to view an object in the layout in different ways. This saves time and maintains consistency across all your project drawings.

**Display System Structure**

The AutoCAD MEP display system controls how objects appear in a viewport. By specifying the objects for display and the direction from which to view them, you can produce different displays, such as plan layouts, 3D models, isometric riser diagrams, and schematic diagrams. Establishing standard displays helps maintain consistency across multiple drawings.

Three main components comprise the AutoCAD MEP display system:

- **Display representations** on page 137 for controlling how individual objects are displayed
- **Display sets** on page 139 for grouping display representations of objects
- **Display configurations** on page 139 for assigning display sets to view directions

These components are hierarchical in nature. Each display configuration contains some display sets, and each display set contains some display representations. The components work together to create the display system as follows:

Most AutoCAD MEP objects have 1 Line, 2 Line, Model, and Plan display representations on page 137. This is because these are the most common design scenarios that require different views of a building system.
Some building systems objects, such as label curve objects and schematic objects, have only a general display representation because the display of these objects does not change in different views. The sample templates have default display settings for new and tiled viewports. Default drawing settings guide new users. They also help more experienced CAD managers maintain consistency across project drawings by customizing the sample templates or creating new templates with different display settings.

1. To specify the default display settings for an individual drawing, click Utilities ➤ Drawing Setup.
2. Click the Display tab on the Drawing Setup dialog.

Display Manager

The Display Manager is the central location for the display system components in your AutoCAD MEP drawings. You set up display configurations, display sets, and display representations in the left pane of the Display Manager. The right pane details information about a selected display system component.

Related See The Display Manager in the AutoCAD Architecture Help.
Display Representations

Display representations represent the first level of display control. Display representations define how an object appears in a drawing.

You can also preview display representations by clicking (Floating Viewer) in the Display Manager. The Floating Viewer displays how a specific object appears in different display representations and view directions.

RELATED See Viewing Display Representations and Viewing an Object in a Display Representation in the AutoCAD Architecture Help.

Display Representations in AutoCAD MEP

AutoCAD MEP includes, among others, the following display representations:

1 Line
- Used for centerline depiction of an object in 2D or 3D
- In some cases, also used for isometric drawings

1 Line Screened
- Same as 1 Line display representation
- Exception: Objects screened for use as background

2 Line
- Used for 2D or 3D contour depiction of an object in plan and model drawings
- Fast, underlying graphical display engine
- For speed, hidden lines and rise/drop symbology not shown

2 Line Screened
- Same as 2 Line display representation
- Exception: Objects screened for use as background

Model
Used for full 3D wireframe depiction of an object

Model Screened
- Same as Model display representation
- Exception: Objects screened for use as background

Plan
- Used for 2D or 3D contour depiction of an object
- Has a graphical display engine that is slower than that for 2 Line but with higher quality (and thus, better for plotting)
- Hidden lines and rise/drop symbology shown
Plan Presentation
- All objects screened so that the user can create display themes or apply interference detection highlighting and display only the affected objects
- Hatching shown

Plan Screened
- Same as Plan Presentation
- Exception: Hatching not shown

Plan High Detail
- Unused
- AutoCAD Architecture display representation provided for use in AutoCAD MEP
- Turns on all architectural subcomponents (for example, all wall components)

Plan Low Detail
- Unused
- AutoCAD Architecture display representation provided for use in AutoCAD MEP
- Turns on some architectural subcomponents

Schematic
Used for 2D symbolic depiction of 3D MvParts for schematic diagrams

Schematic Screened
- Same as Schematic display representation
- Exception: Objects screened
- For use in the MEP Presentation display configuration

Reflected
- Unused
- AutoCAD Architecture display representation provided for use in AutoCAD MEP

General
Used for objects that do not require different graphics for different representations or types of drawings (for example, annotation, plumbing lines, and plumbing fittings)

General Screened
- Same as General display representation
- Exception: Objects screened
The color of the grayed out (screened) objects in the background of building systems design drawings is controlled by layer G-Bgrd-Std-Scrn. The colors of the hidden lines applied to objects in building systems design drawings are controlled by the following layers:

- E-Hidn-Std-High and E-Hidn-Std-Subd for electrical objects
- M-Hidn-Std-High and M-Hidn-Std-Subd for mechanical objects
- G-Hidn-Std-High for plumbing objects

### Display Sets

Display sets represent the second level of display control. Display sets are collections of display representations on page 137 of objects that control how a group of objects appears.

Typically, you create display sets for a specific task or type of drawing, such as a reflected ceiling plan. You can also use them to show or hide objects according to classification, such as construction status (new, existing, or demo). See Display of Objects by Classification on page 154 for more information.

**RELATED** See Viewing Display Sets in the AutoCAD Architecture Help.

### Display Configurations

Display configurations represent the final level of display control. A display configuration contains one or more display sets that control the representation of objects in your drawing when viewed from different directions (Top, Bottom, Left, Right, Front, Back, and Default). The different views help with design layout and for plotting presentation drawings or construction documents.

**RELATED** See Viewing Display Configurations in the AutoCAD Architecture Help.

#### AutoCAD MEP Display Configurations

AutoCAD MEP includes the following display configurations based on the display representations on page 137 in the software.

<table>
<thead>
<tr>
<th>Display Configuration</th>
<th>Display Representations by view direction</th>
<th>Recommended use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard</td>
<td>Plan (Top), Model (all other view directions)</td>
<td>Not recommended when working with building systems objects because non-building systems objects are displayed with full color. For medium detail drawings</td>
</tr>
<tr>
<td>Mechanical</td>
<td>Mechanical - Plan (Top), Mechanical - Model (all other view directions)</td>
<td>Combined mechanical duct and pipe drawings; hidden lines and rise/drop symbology are used; electrical and plumbing objects are screened</td>
</tr>
<tr>
<td>Mechanical - Duct - 1-Line</td>
<td>Mechanical - Duct 1-Line Plan (Top), Mechanical - Duct 1-Line Model (all other view directions)</td>
<td>1-line mechanical duct drawings; pipe is 1-line and screened; rise/drop symbology is used, but not hidden lines; all non-duct objects are screened</td>
</tr>
<tr>
<td>Mechanical - Duct - 2-Line</td>
<td>Mechanical - Duct 2-Line Plan (Top), Mechanical - Duct 2-Line Model (all other view directions)</td>
<td>2-line mechanical duct drawings; pipe is by size and screened; hidden lines and rise/drop symbology are used; all non-duct objects are screened</td>
</tr>
<tr>
<td>Display Configuration</td>
<td>Display Representations by view direction</td>
<td>Recommended use</td>
</tr>
<tr>
<td>----------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Mechanical - Pipe by Size</td>
<td>Mechanical - Pipe By Size Plan (Top), Mechanical - Pipe By Size Model (all other view directions)</td>
<td>2-line and 1-line mechanical pipe drawings; uses system definitions to display pipe as 2-line, 1-line, or graphical 1-line by size; hidden lines and rise/drop symbology are used; all non-pipe objects are screened</td>
</tr>
<tr>
<td>Electrical</td>
<td>Electrical - Plan (Top), Electrical - Model (all other view directions)</td>
<td>Combined electrical lighting, power, and system drawings; hidden lines and rise/drop symbology are used; all non-electrical objects are screened</td>
</tr>
<tr>
<td>Electrical - Lighting</td>
<td>Electrical - Lighting Plan (Top), Electrical - Lighting Model (all other view directions)</td>
<td>Electrical lighting drawings; shows lights, diffusers, ceiling grid, and common objects like junction boxes; hidden lines and rise/drop symbology are used; all non-lighting objects are screened</td>
</tr>
<tr>
<td>Electrical - Power</td>
<td>Electrical - Power Plan (Top), Electrical - Power Model (all other view directions)</td>
<td>Electrical power drawings; shows common objects like junction boxes; hides lights, diffusers, and ceiling objects; hidden lines and rise/drop symbology are used; all non-power objects are screened</td>
</tr>
<tr>
<td>Plumbing</td>
<td>Plumbing - Plan (Top), Plumbing - Model (all other view directions)</td>
<td>Plumbing drawings; hidden lines and rise/drop symbology are used; all non-plumbing objects are screened; pipes are 1-line; ducts are 2-line</td>
</tr>
<tr>
<td>MEP Basic 2-Line</td>
<td>MEP Basic 2-Line - Plan (Top), MEP Basic 2-Line - Model (all other view directions)</td>
<td>2-line engineering drawings of duct, pipe, or cable tray without rise/drop symbology or hidden lines</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>NOTE</strong> This is the fastest configuration for drawing systems because the graphical detail is lower and the underlying graphical display engine is quicker.</td>
</tr>
<tr>
<td>MEP Design</td>
<td>MEP Design - Plan (Top), MEP Design - Model (all other view directions)</td>
<td>For engineering design and modeling that shows all architectural objects, all building systems objects, and ceiling grid; for coordination and placement of objects</td>
</tr>
<tr>
<td>MEP Presentation</td>
<td>MEP Presentation - Plan (Top), MEP Presentation - Model (all other view directions)</td>
<td>Screened presentation drawings; screens all objects except display themes and interferences For information on applying interference detection, see Finding Interferences on page 582 in this Help. For information on display themes, see Display Themes in the AutoCAD Architecture Help.</td>
</tr>
</tbody>
</table>
## Hierarchy of Display Control

The display control operates according to the following hierarchy:

- **Object**
- **Style**
- **System Definition**
- **Domain Drawing Default**

If no object-level display control overrides are in effect, control then passes to that object’s style-level definition. If no style-level overrides are in effect, control then passes to that object’s system definition. If no system definition settings are in effect, control then passes to the drawing default level.

You can apply multiple overrides to an object, essentially layering them on the object. As you remove the layers of overrides, the highest override in the hierarchy takes control.

### Synchronization of Display Settings

Display properties are synchronized across other AutoCAD MEP objects within a domain. For example, if you change the display properties for duct segments whose display is controlled by Drawing Default, the display properties are also changed for duct, duct fittings, duct custom fittings, and duct flex.

Ideally you should use the Display tab on the Properties palette to make direct changes to the display properties for an object in a drawing. However, you can also use the Style Manager or Display Manager to manage all (unfiltered) display properties for an object whose display is controlled by Drawing Default or System Definition.

When a display override is added to or removed from a system, display properties are also synchronized within a domain. Display properties are synchronized for the following domains/objects:

- **Pipe**: Pipe, pipe fitting, pipe custom fitting, pipe flex
- **Duct**: Duct, duct fitting, duct custom fitting, duct flex
- **Cable tray and cable tray fitting**
- **Conduit and conduit fitting**
- **Plumbing line and plumbing fitting**

### Managing Display Settings During Project Setup

The default display settings in a drawing determine the display of objects when no display overrides are in effect. As the CAD manager, you set up a template or project and specify the display settings that will remain in effect in the drawing. During project setup, the way that you set the default settings for display representations depends on the type of object. For example, you can use:

- **Style Manager** on objects in the duct, pipe, cable tray, and conduit domains to make the same changes that affect all objects in that domain
Display Manager to set default display settings for all other types of objects

**Levels for Specifying Display Settings Setup**

- Drawing default display settings determine the display of objects when no overrides are in effect.
- System-level overrides are specified for systems, such as an exhaust duct system, and determine the display of all the objects assigned to the system.
- Style-level overrides are specified for a style, such as a device style, and determine the display of all the objects using that style.

**Specifying Default Display Settings**

You can specify default display settings using the Style Manager or the Display Manager.

**TIP** In the Style Manager and the Display Manager, the entire collection of unfiltered display components are visible and available for editing. In contrast, on the Display tab on page 143 of the Properties palette, the display properties are filtered based on the object that is selected in the drawing area.

**Using the Style Manager**

1. Click Manage tab ➤ Style & Display panel ➤ Style Manager.
2. Expand the desired objects folder, such as HVAC Objects.
3. Expand the system definitions for that object.
4. Select a system, and then click the Display Properties tab in the right pane.
5. Under Display Representations, double-click the display representation where you want to specify defaults (for example, Plan).
6. In the Display Properties dialog, click a display properties for one of the display components, and make the desired changes.

**TIP** You can also click the display representation and then click for the same result.

**Using the Display Manager**

1. Click Manage tab ➤ Style & Display panel ➤ Display Manager.
2. Expand the Representations by Object folder.
3. Double-click an object in the list.
4. Click a display representation listed under the object where you want to specify defaults.
5. In the right pane on the Layer/Color/Linetype tab, click a display property for one of the display components (such as Linetype), and make the desired changes.

**RELATED** See Editing a Display Representation in the AutoCAD Architecture Help.
Applying System-Level Overrides

Use the Style Manager to apply system-level display overrides that control the display representation for objects in a particular system (such as Duct - Low-Pressure Supply).

NOTE Although MvParts can be assigned a system, their display properties are not controlled by systems.

1. Click Manage tab ➤ Style & Display panel ➤ Style Manager ➤ Style Manager.
2. Expand the desired objects folder, such as HVAC Objects.
3. Expand the system definitions for that object.
4. Select a system, and then click the Display Properties tab in the right pane.
5. Under Style Override, select the box for the display representation where you want to apply an override.
6. In the Display Properties dialog, modify the display properties of the display components as needed.

Applying Style-Level Overrides

Use the Style Manager to apply style-level overrides that control a display representation for all objects of a particular style (for example, a device style for a junction box).

1. Open the drawing that contains the style to override.
2. Click Manage tab ➤ Style & Display panel ➤ Style Manager ➤ Style Manager.
3. Expand the category and the style type that you want to override.
4. Select the style, and then click the Display Properties tab in the right pane.
5. Under Display Representations, select the display representation where you want to apply an override, and select the corresponding box in the Style Override column.
6. In the Display Properties dialog, modify the display properties.

Configuring Display Settings During Design

The Display tab of the Properties palette directly controls the graphical properties of objects in an AutoCAD MEP drawing.

On the Display tab of the Properties palette, click ➤ (Select Components), and then click an object in the drawing area to make changes to the display properties.
General Display Properties

- Display components: Allows you to adjust settings for the object's individual display components, such as contours and centerlines.

**NOTE** Only the active component display properties for the selected object are listed.

- Display controlled by: Choose from the list of 3 options:
  - Object: Applies changes to all objects with the specified system (for example, Duct System Definition: Supply - Low Pressure) for which no object overrides are in effect (called system override). This selection takes precedence over the drawing default setting and style setting.
  - Style: Applies changes to all objects with the specified style (for example, Duct Style: 300 mm Diameter Round Duct) for which no object overrides are in effect (called style override). This selection takes precedence over the drawing default setting.
  - System definition: Adds a system definition override to the selected object.
  - Domain drawing default: Applies changes to all objects within a domain.

**RELATED** See Hierarchy of Display Control on page 141.

- Display representation: Displays the current display representation (such as Plan).

Component Display Properties

- Basic defines the color, layer, linetype, linetype scale, and linewidth properties of the selected object.

Click (along the General title bar) for the Apply Display Component Properties to Other Display Representations worksheet to change other display representations at the same level indicated by the Display controlled by value.

**TIP** A display component must be selected for this button to appear. The corresponding worksheet will only reflect display representations that can be applied to the selected component.

Changes made on the Display tab become immediately visible in the display representation of the current drawing. You can also apply changes to other display representations. For example, you can specify whether a change you make to a display property will apply to the selected component for all objects of that type, all objects of that style, or only the selected object.

**Display of Objects Based on Elevation**

In some regions, construction documents must show building system objects differently based on their elevation. For example, you might be required to display an object below the floor slab in the plan view with one linetype, and another object above the floor slab but below the cut plane with another linetype.
You can meet such requirements using the Display by Elevation feature. The Display by Elevation feature includes the following elevation-based display components:

- Contour
- Connector
- Center Line
- Hatch
- Insulation
- Lining
- Rise Drop
- Annotation

You can configure these display components to show or hide the following AutoCAD MEP objects relative to the floor plan and the cut plane on page 147:

- Cable tray, cable tray fitting
- Conduit, conduit fitting
- Duct, flexible duct, duct fittings, and custom duct fitting
- MvParts
- Pipe, flexible pipe, pipe fitting, custom pipe fitting

Any rise/drop symbols associated with these objects will inherit the elevation-based display characteristics of the parent object.

If you create a 2D section or 2D elevation with a display set that uses 1-Line or Plan display representations, the section or elevation also shows the objects with the elevation-based display properties.

**NOTE** Only objects in the Duct domain can be configured with 1 Line elevation-based components.

The elevation-based display components control the display of objects when the following conditions are met:

- The Display by Elevation feature is enabled on page 147.
- The current view is Top (plan).
- The current display configuration uses 1-Line or Plan display representations on page 137.

You can configure elevation-based display components using the Style Manager or the Display Manager (see Specifying Default Display Settings on page 142). The following example shows contour display components in the Display Manager when the Display by Elevation feature is enabled on page 147:
Display settings differentiate objects above or below the display range. For example, you can set linetypes and line colors on page 143 to display differently depending on elevation. You can also use the display settings to hide an object based on its elevation. Hiding objects is useful when you create construction documents for a specific floor plan from a model that spans multiple stories.

You can also configure elevation-based display components that apply to a particular object in the drawing using the Display tab of the Properties palette (see Configuring Display Settings During Design on page 143).

The next example shows the Display tab with the relevant display component based on the elevation of the selected object. The cut height is 2500 mm, the display above range is 3500 mm, and the display below range is 0. At an elevation of -1000 mm, the duct object, located below the display range, is hidden.

NOTE Display settings are stored in the drawing. When you enable the Display by Elevation feature in the drawing template for your project, all drawings created from the template will have the feature enabled by default and will include the correct display settings. If you are working in a project environment, make sure you copy the display settings to all of the templates you are using for constructs, views, and sheets.

**Workflow for Displaying Objects Based on Elevation**

**Review the steps**

Enable the Display by Elevation feature.

**View more information**

Select Enable Display by Elevation to differentiate objects that are placed above or below the cut plane in the layout. See Enabling the Elevation-Based Display Components.
Review the steps

Set the criteria that determines how objects display in the drawing area based on elevation.

Configure display components for each elevation-based object in the drawing.

Allow for exceptions to the display configuration.

View more information

For each display configuration that uses 1-Line or Plan display representations in Top (plan) view, enter a cut height as well as height ranges for above and below the display range. See Specifying the Cut Plane and Display Range for a Display Configuration on page 147.

In the 1-Line and Plan display representations, configure settings for display components. For example, specify linetype or line color values to differentiate objects based on elevation. See Configuring Elevation-Based Display Components on page 149.

Configure overrides for cut plane and display range values. See Overriding the Cut Plane on page 150.

Enabling the Elevation-Based Display Components

1 Click ➤ Options.
2 On the MEP Display Control tab, select Enable Display by Elevation.

**NOTE** From the command line, you can also enter `displaybyelevation` and then follow the prompts to enable this feature.

**RELATED** See Display of Objects Based on Elevation on page 144.

Specifying the Cut Plane and Display Range for a Display Configuration

When you configure a display configuration, you can specify the cut plane and display ranges. In the plan view, AutoCAD MEP uses the cut plane settings for the current display configuration. It also uses the elevation of an object to determine which display component (Below, Low, High, or Above) is used to display the object.
For a pipe object with a slope on page 256, the object’s starting point determines its elevation.

 RELATED Global cut plane and display range settings for a display configuration in AutoCAD MEP objects are used differently from AutoCAD Architecture objects. See Working with Cut Planes in a Project in the AutoCAD Architecture Help.

To set cut plane and display ranges

1 Select Enable Display by Elevation in the Options dialog.
2 Specify the cut plane settings using one of the following methods:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>define the cut plane height for the current display configuration</td>
<td>click the Cut Plane value on the drawing window status bar.</td>
</tr>
<tr>
<td>define the cut plane height for any display configuration</td>
<td>Click Manage tab ➤ Style &amp; Display panel ➤ Display Manager ➤ Select a display configuration that uses a Plan display representation in Top (plan) view or a 1 Line (for Duct domain only). Click the Cut Plane tab in the right pane.</td>
</tr>
</tbody>
</table>

3 For Cut Height, enter a value for the cut plane.
   The cut plane is the height at which an object is cut to produce the plan representation.

Example of Cut plane tab in the Display Manager

![Example of Cut plane tab in the Display Manager](image)

The values you enter for the Above and Below ranges are not relative to the cut height. They are absolute height values calculated from the WCS origin. Therefore, the value that you enter for Display Above Range must be greater than the value that you enter for Cut Height. Invalid values will produce incorrect results.

NOTE The Calculate button on the Cut Plane tab is only available if you selected a project using Project Navigator and the current drawing is multi-story. It opens a Cut Plane dialog that you use to set the cut plane height for objects at a specific level. For more information, see Levels in the AutoCAD Architecture Help.

4 For Display Above Range, enter a value for the top range of the floor plan.
   Objects above this range are displayed using the Above display components. For example, in 1-line display representations, this is the Single Line - Above component. In plan display representations, these are the Contour - Above, Insulation - Above, and Rise Drop - Above components.
   Objects at or below this range, but above the cut height, are displayed using the High display components.

5 For Display Below Range, enter a value for the bottom range of the floor plan.
   Objects at or below the cut plane, but above this height, are displayed using the Low display components. Objects at or below this height are displayed using the Below display components. For more information, see Specifying the Display Properties of a Space Style.
Configuring Elevation-Based Display Components

In the Style Manager, you can change a display representation for all elevation-based display components for objects in a particular domain. However, in the Display Manager, you configure the display representation for domain objects individually.

Make sure that you coordinate the configurations of the elevation-based display components with each other (such as, contour components with insulation components), and with the display components that are not elevation-based (for example, connector display components).

To configure elevation-based display components

1. Select Enable Display by Elevation in the Options dialog.
2. Click Manage tab ➤ Style & Display panel ➤ Style Manager ➤.
3. Expand the desired objects folder.
4. Expand the system definitions.
5. Select the desired system definition, and then click the Display Properties tab in the right pane.
6. To configure the Plan display representation, select Plan (default), and then click ➤.
7. On the Layer/Color/Linetype tab of the Display Properties dialog, specify values for the elevation-based display components, such as Contour, Single Line, and Hatch. Click OK when done.
8. To configure 1-line, on the Display Properties tab, select a 1-line display representation, and click ➤. Repeat the previous step in the Display Properties dialog.

To activate the display range in model view

1. Click Manage tab ➤ Style & Display panel ➤ Display Manager ➤.
2. On the left pane, expand Sets, and select MEP Design - Model.
3. On the right pane, click the Display Options tab.
4. Under Live Sections and Materials, select Section AEC Objects by Display Range defined in Display Configuration.

As a result, the elevation-based display range you specified for the cut plane on page 147 is visible in model view.

Modifying Elevation-Based Display Components on the Properties Palette

You can modify the current display components for an object in a drawing using the Display tab on the Properties palette.

1. Switch to the desired workspace.
2. Select Enable Display by Elevation in the Options dialog.
3. Select an object.
4. Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties ➤.
5. On the Properties palette, click the Display tab.
6. Select an object in the drawing. The current display representation appears under General.
NOTE Instead of selecting an object, you can click at the bottom of the Display tab, and then click the display component in the drawing for the same result.

7 Under General, for Display controlled by, select the level at which you want your changes applied.
8 Under General, for Display component, select a display component from the list. Only the elevation-based display components that pertain to the selected object are listed.
9 Click (on the General title bar) to apply changes to other display representations at the same level indicated by the Display controlled by property. Make changes to the Apply Display Component Properties to Other Display Representations worksheet.

TIP A display component must be selected for this button to appear. The corresponding worksheet will only reflect display representations for the selected component.

The following example shows the current display component details on the Display tab for the selected pipe object.

RELATED See Using the Properties Palette to Change Display Properties on page 149 in the AutoCAD Architecture Help for more information.

Overriding the Cut Plane

To display all the architectural and business system objects correctly, some designs require different cut planes and display ranges for AutoCAD MEP objects as opposed to AutoCAD Architecture objects.

RELATED See Object-Specific Cut Planes in the AutoCAD Architecture Help for more information.

To apply cut plane overrides on the Display tab

1 Switch to the desired workspace.
2 Select Enable Display by Elevation in the Options dialog.
3 Select an object.

4 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties.

5 Under Object Display Properties, configure settings for the current configuration as follows:
   a Select Yes for Above level override, and then specify a value for Above range.
   b Select Yes for Cut height override, and then specify a value for Cut height.
   c Select Yes for Below level override, and then specify a value for Below range.

**BEST PRACTICE** Some objects spanning multiple cut planes might include a Rise/Drop symbol on an elevation-based display component that is turned off, causing the object to be hidden. In those cases, you can override the cut plane for that particular object so that it appears in the drawing area.

**To apply cut plane overrides in the Display Manager**

1 Select **Enable Display by Elevation** in the Options dialog.

2 Click Manage tab ➤ Style & Display panel ➤ Display Manager.

3 Expand the Configurations folder.

4 Select a display configuration from the list.

5 Click the Cut Plane tab in the right pane.

6 Apply the desired override for the display configurations that use this display representation.

<table>
<thead>
<tr>
<th>If you want to</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>define the visible range above the cut plane</td>
<td>enter a value for Display Above Range.</td>
</tr>
<tr>
<td>define the cut plane height</td>
<td>enter a value for Cut Height.</td>
</tr>
<tr>
<td>define the visible range below the cut plane</td>
<td>enter a value for Display Below Range.</td>
</tr>
</tbody>
</table>

The values you enter for the Above and Below ranges are not relative to the cut height. They are absolute height values calculated from the WCS origin. Therefore, the value that you enter for Display Above Range must be greater than the value that you enter for Cut Height. Invalid values will produce incorrect results.

**NOTE** The Calculate button on the Cut Plane tab is only available if you selected a project using Project Navigator and the current drawing is multi-story. It opens a Cut Plane dialog that you use to set the cut plane height for objects at a specific level. For more information, see Levels in the AutoCAD Architecture Help.

---

**Display of Crossing Objects in 2-Line Plan Views**

You can change the appearance of hidden lines, layers, line types, or color for crossing or overlapping objects at different elevations in 2-line plan views.

**Configuring the Display of a Gap Between Crossing Objects**

You can configure a gap to display between crossing objects or disable hidden lines for MvParts. These settings are applied to all objects in the drawing.
1 Click ➤ Options.
2 In the Options dialog, click the MEP Display Control tab.
3 Under Crossing Objects Display, specify one of the following:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>specify a gap to the outside of the crossing objects</td>
<td>select Apply Gap to Outside, and then enter a value for Gap Width.</td>
</tr>
<tr>
<td>specify a gap to the inside of the crossing objects</td>
<td>select Apply Gap to Inside, and then enter a value for Gap Width.</td>
</tr>
<tr>
<td>specify no gap to the outside of the crossing objects</td>
<td>clear Apply Gap to Outside (the default).</td>
</tr>
<tr>
<td>specify no gap to the inside of the crossing objects</td>
<td>clear Apply Gap to Inside (the default).</td>
</tr>
<tr>
<td>change the size of the gap as the annotation scales</td>
<td>select Apply Annotation Scale to Gap change</td>
</tr>
<tr>
<td>specify the gap size</td>
<td>enter a value for the gap</td>
</tr>
<tr>
<td>increase drawing performance when using hidden lines</td>
<td>select Save Hidden Lines in Drawing.</td>
</tr>
<tr>
<td>have hidden lines ignore MvParts</td>
<td>select Disable Hidden Lines for MvParts.</td>
</tr>
</tbody>
</table>

**Modifying Hidden Lines for Objects**

You can modify hidden line properties such as color, linetype, and visibility use the display properties dialog for selected objects.

1 Select the object, right-click, and click Edit Object Display.
2 In the Object Display dialog, click the Display Properties tab.
3 Select the Plan display representation.
4 Open the Display Properties dialog:
   - If you want to change the object display representation so that all objects in the drawing display the same way, click ➤ (Edit Display Properties).
   - If you want to change the display for the selected object only, select Object Override for the Plan display representation.
5 In the Display Properties dialog, specify the settings for the display components with Hidden in their name.

**Display of Center Lines on Ducts**

In display configurations that use 2-line display representations for ducts and fittings, you display center lines on the ducts and fittings by turning on the visibility of the Center Line display components (in the display representations).
However, in display configurations that use Plan display representations, you have more flexibility. You can:
- Display or hide the center lines on all ducts and fittings
- Display or hide the center lines on ducts and fittings of specific shapes
- Display or hide the center lines on flexible ducts
- Extend the center lines of round takeoffs and oval takeoffs to the center lines of mains

In the following image, center lines are displayed on the round ducts and fittings to the left of the multi-shape transition fitting, but they are not displayed on the transition fitting or the rectangular duct on the right.

If you create a 2D section or 2D elevation using a display set that uses the Plan display representations, the section or elevation also shows the center lines as specified.

**NOTE** You can also display center lines on rise symbols and on drop symbols by specifying center line blocks in rise/drop styles. For more information, see Defining Rise/Drop Styles on page 614.

**To display center lines on ducts and fittings in Plan display representations**

1. Click ➤ Options.
2. Click the MEP Display Control tab.
3. Under Center Line Display, specify the ducts and fittings on which you want to display center lines.

**NOTE** The Display on Multi-shape Fittings setting works in conjunction with the shape-dependent settings. The center line on the fitting is displayed if center lines are enabled for the shape corresponding to at least one of its connectors.

**IMPORTANT** To display center lines on all ducts and fittings regardless of shape, select all of the options. For center lines to be visible in display configurations using Plan display representations, these settings must be configured as required, and the Center Line display components must be set to Visible (which you do later in this procedure). You cannot complete the latter task alone.

4. If you want to display center lines on flexible ducts, select Display Center Line on Flex Ducts.

**NOTE** If you are using duct system definition overrides, and you do not want to display center lines on the flexible ducts assigned to those systems, deselect this option. A system definition override that turns on the Center Line display component does so for all duct objects, including flexible ducts. However, center lines are not displayed on any flexible ducts unless this option is selected.
5 If you want to extend the center lines on takeoffs to the center lines of the mains, select Extend Center Line for Takeoffs.

NOTE The center line on a takeoff is displayed if center lines are enabled for the shape corresponding to the branch connector. It is extended to the main if you select Extend Center Line for Takeoffs, and the takeoff is round or oval (not rectangular or multi-shape).

In the following steps, you turn on the visibility of the Center Line display components in the Plan display representations for all duct objects.

6 Click Manage tab ➤ Style & Display panel ➤ Style Manager ➤ Style Manager.
7 In the left pane of Style Manager, select any system definition, and in the right pane, click the Display Properties tab.
8 Select the Plan display representation, and click ➤ .

NOTE Accessing and configuring a display representation in this way automatically applies the changes to the same display representation for all duct objects (ducts, duct fittings, custom duct fittings, and flexible ducts). You can achieve the same results by configuring the display representations using Display Manager, but this requires you to configure the display representation for ducts, repeat the changes in the same display representation for duct fittings, repeat them again for custom duct fittings, and so on.

9 In the Display Properties dialog, click the Layer/Color/Linetype tab.
10 Click the icons under Visible to turn on the Center Line display components.
11 Configure the remaining display properties of the Center Line display components as required.

If needed, you can also apply system-level overrides or style-level overrides.

NOTE You can also enable the display of center lines on ducts or fittings by entering the command corresponding to the shape or type: ROUNDDUCTCENTERLINE, RECTANGULARDUCTCENTERLINE, OVALDUCTCENTERLINE, MULTISHAPEFITTINGCENTERLINE, FLEXDUCTCENTERLINE, or TAKEOFFCENTERLINE.

Display of Objects by Classification

You can hide or show objects in a display set based on object classification. For example, if you classify objects by construction status, such as New, Existing, and Demo, you can exclude objects with the Demo classification from the display. When the display is used in the drawing, those objects do not appear.

Objects filtered from the display are not removed from the drawing. Their display is turned off only in viewports using the display set in which objects of that classification are filtered. You can change the filter to display them again. Because the objects still exist in the drawing, the display of other objects in the drawing does not change. For example, if you filter dampers from a floor plan, the ducts that connect to the dampers still end at the points where the dampers are located.

RELATED See Displaying Objects by Classification and Classification Definitions in the AutoCAD Architecture Help.
Adding Custom Graphics as a Display Component

You can add custom blocks to the display representations of some building systems objects. For example, you can add custom blocks to mechanical pipe runs to add symbology to designate hangers.

To create a custom component for a building systems object

1. Draw the custom component, and save it as a block.
2. Select a building systems object, right-click, and click Edit Object Display.
3. In the Object Display dialog, click the Display Properties tab.
4. Select any display representation except one of the Plan display representations, and click (Edit Display Properties).
5. In the Display Properties dialog, click the Other tab.

**NOTE** If the Other tab is not available, the selected building systems object does not support custom graphics as a display component.

6. Under Custom Block Display, click Add.
7. In the Custom Block dialog, click Select Block.
   In the Select a Block dialog, select the block that you created.
8. To specify a scale, in the Custom Block dialog, under Scale to Fit, specify a scale to maintain for the block based on the size of the block entities.
   You can select Width, Height, Depth, Lock XY Ratio, or a combination of these options.
9. To mirror the block upon insertion, under Mirror In, specify the direction to mirror the block:
   - Mirror X creates a mirror of the block in the X direction, along the segment curve.
   - Mirror Y creates a mirror of the block in the Y direction.
   - Mirror Z creates a mirror of the block in the Z direction.
10. To insert an instance of the block, under Insertion Point, specify a position for the block on the object by selecting an X, Y, and Z position on the segment curve.
    **IMPORTANT** When Repeat Block Display under Repeat Mode is selected, Insertion Point is unavailable (shaded).
11. To specify an offset for the block, under Insertion Offset, enter distances for the X, Y, or Z directions from the segment curve.
12. To repeat the block along a segment, under Repeat Mode, select Repeat Block Display, and enter a distance for Start Offset and/or End Offset and Spacing.
    The insertion point of the first block is located at the start offset location. The block is then repeated, placed according to the specified distance for spacing between blocks. The last block is placed at or near the end offset location to allow for equal spacing between blocks based on the specified distance.
13. Click OK 3 times.

Troubleshooting Object Display

If objects are displayed incorrectly or not at all, follow these suggestions for troubleshooting the problem:

1. Verify that the object’s layer is on.
2 Verify that the viewport in which the object will display is on.
3 If you are using referenced drawings (xrefs), confirm the method of attachment and the xref configuration.

Under certain circumstances, the Display Manager can assist you in troubleshooting object display problems. Check the display configurations to:

■ Identify the display set applied to the viewport
■ Verify that a display representation is selected in that display set
■ View the display properties to confirm that the components are turned on

AutoCAD MEP Templates

Once you establish project standards, you can create custom templates that are unique to your project. You can create a custom template in several ways:

■ (Recommended) Modify an existing template.
■ Save a drawing as a template.
■ Create the template from scratch.

RELATED See “Use a Template File to Start a Drawing” in the AutoCAD Help.

Default Drawing Templates

Drawing templates store default preferences, controls, and content common to all drawings in a project. You can start on a project immediately by using a template. This saves time and provides consistency when creating multiple drawings.

AutoCAD MEP includes several default templates in metric or imperial units. Most notably:

■ Aecb Model, a template for designing building systems
■ Aecb Sheet, a template for plotting building systems

The templates have specified drawing units, drawing scales, and annotation size. They also have defined layout tabs, display representations, and plotting setups, which serve as a guide to the recommended use of model space and paper space.

Using default templates helps you become more familiar with the software to create new drawings and incorporate them into your project standards. Later, you can modify the default templates or create your own to meet specific company or project requirements.

Perform the action associated with one of the following components:

Layer structures

1 Click Home tab ➤ Layers panel ➤ Layer Properties.
2 Click Layer Standards.
3 Click Import/Export. For more information, see Importing Layer Standards in the AutoCAD Architecture Help.
Styles, such as system definitions and object styles

1. Click Manage tab ➤ Style & Display panel ➤ Style Manager.
2. Select the style from the tree view of the first drawing, and drag it to the tree view of the second drawing.

RELATED For more information, see Copying Styles Between Drawings in the AutoCAD Architecture Help.

Design content such as text styles, dimension styles, and linetypes

1. Click Insert tab ➤ Content panel ➤ Content drop-down ➤ Design Center.
2. Select the content type from the tree view.
3. Double-click the specific design content to add it to the drawing.

NOTE For more information, see “DesignCenter” in AutoCAD® Help.

Layout tabs

1. If the Model tab and layout tabs are visible, right-click any tab, and select From template.
2. In the Select Template From File dialog, select the file that contains the layout tabs that you want to add to your drawing, and click Open.
3. In the Insert Layouts dialog, select the layout tabs.
   If the Model tab and layout tabs are not visible, you can display them by right-clicking either corresponding status bar button, and clicking Display Layout and Model tabs.

NOTE For more information, see Creating and Saving Drawings in the AutoCAD Architecture Help.

NOTE If you do not use a template to create new drawings, you must save the drawing settings and standards that you need in each individual drawing.

Creating a Custom Template from a Template or Drawing

An efficient method for creating custom templates is to start with an existing template or drawing, modify it, and save it as a new template. This method works best when minor modifications to the existing template or drawing can provide the custom template that you need.

To create a custom template from a template or drawing

1. Click Open ➤ Drawing.
2. If you are using an existing template (DWT file) as a base for your new template, in the Select template dialog, verify that Drawing Template File (*.dwt) is selected for Files of type.
3. Browse to the template or drawing file from which to create the new template and open it.
4. Modify the template or drawing.
   You can change preferences or controls in the drawing, add or replace the border or title block, import or configure standards, and erase or add drawing elements.
Creating a Custom Template

If you use different standards for each project, creating custom templates is recommended instead of creating them based on existing templates. You can save time and maintain accuracy by starting with a clean project environment and customizing only those standards required for the project. In addition, creating the clean template means you do not need to clean out irrelevant information from an existing template or drawing.

To create a custom template

1. Click New ➤ Drawing.
2. In the Select template dialog, select acad.dwt from the list of templates, and then modify the template.
   You can change preferences or controls in the drawing, add or replace the border or title block, import or configure standards, and erase or add drawing elements.
3. Click Save As ➤ AutoCAD Drawing Template.

   TIP By default, the software saves the new template in the \Documents and Settings\All Users\Application Data\Autodesk\ACD-MEP 2009\enu\Template folder.

4. For File name, enter a name for the new template, and click Save.
5. In the Template Options dialog, enter a brief description of the template, and specify the measurements, and click Help to learn about New Layer Modifications.

   NOTE AutoCAD MEP template settings are not necessarily the same as AutoCAD default template settings. When creating a new template, it is recommended that you click Utilities ➤ Drawing Setup, and specify the drawing units and scale in the Drawing Setup dialog.

Working with Referenced Drawings

When you create an AutoCAD MEP drawing, you often need to relate your layout to an architectural drawing, such as a floor plan, a reflected ceiling plan, or an AutoCAD Architecture building model.

You can begin with a drawing that contains the walls and other spatial elements that you need by attaching another drawing called a referenced drawing or xref. Xrefs are drawings that are linked to, and displayed in, the current drawing.
Whenever you open a drawing, the software reloads the xref drawings attached to it so that changes made to the xref drawings are reflected in your building system drawing. For example, if you attach an architectural floor plan as an xref, and the architect subsequently changes the location of the building’s mechanical room, the changes to the architectural floor plan are automatically reflected in your building systems drawing the next time that you open it. You can also reload xrefs on demand and check for interferences between building system objects and structural members by applying interference detection highlighting to your drawing.

There are 2 types of xrefs: attachment and overlay. Unlike an attached xref, an overlaid xref is not displayed when the drawing is itself attached or overlaid as an xref to another drawing—a process referred to as nesting xrefs. Overlaid xrefs are designed for data sharing in a network environment. By overlaying an xref, you can see how your drawing relates to the drawings of other groups without changing your drawing by attaching an xref. Changes made to an xref drawing, whether attached or overlaid, are displayed in your drawing when you open the drawing or reload the xref.

Linking xrefs to your drawings is effective when creating design drawings and construction documents. Design projects typically involve the coordination of many drawings, and sharing the content of those drawings is fundamental to efficient project management. Establishing standards for using xrefs helps you to use drawings optimally and minimize the need to re-create drawing content.

The following cite several advantages to using xrefs in AutoCAD MEP drawings:

- You can reference an architectural drawing as a base for your mechanical, electrical, or plumbing drawings. In addition, you are aware immediately of any changes to the architectural drawing because the changes are reflected when you open your drawing or reload the xref.

- You can assemble master drawings from individual design drawings. For example, several people can work with different sections of a design for a large building (such as by floor or by wing), and the individual designs can be referenced into a master drawing.

- You can attach drawings containing borders, title blocks, and other office standards for plotting as xrefs for easy maintenance.

- You can choose not to load an xref if you do not need it as a reference. The xref does not use system resources when it is not loaded.

**NOTE** See Concepts of Drawing Management in the AutoCAD Architecture Help and “Reference Other Drawing Files” in AutoCAD Help.

**Attaching or Overlaying Xrefs**

Xrefs enable you to begin with a drawing that contains walls and other spatial elements that you need, such as a floor plan, reflected ceiling plan, or AutoCAD Architecture building model.

**NOTE** In a Drawing Management project, attach xrefs using the Project Navigator only. For more information, see Concepts of Drawing Management in the AutoCAD Architecture Help.

If you attach or overlay an xref created in a previous version of the software, the file format of the xref is not updated to the current version (which would make the xref incompatible with the version in which it
was created). The exception to this is when the xref contains annotative objects, and the host drawing is configured to automatically add scale representations to annotative objects as the annotation scale changes.

RELATED See Adding and Modifying Scale Representations on page 554.

To attach or overlay an xref

1. Click Insert tab ➤ Reference panel ➤ Attach.
2. In the Select Reference File dialog, open the file you want to attach or overlay.
3. In the Attach External Reference dialog, select one of the following for Reference Type:
   - Attachment: Saves a copy of the xref drawing in your drawing.
   - Overlay: Creates a link to the xref drawing in your drawing.
4. Specify the insertion point, scale, and rotation angle; or click Specify On-screen to use the cursor.
5. Click OK, and, if necessary, specify the insertion point, scale, or rotation angle in the drawing.

Reloading Xrefs

When you open a drawing, the software automatically reloads all xrefs. However, you can reload xrefs at any time when you want to ensure the most current versions are displayed in your drawing.

To reload an xref

1. Click Insert ➤ Reference panel ➤ ➤ External References tool palette.
2. On the External References palette, select the name of an xref, right-click, and click Reload All References.

Clipping Xrefs

After attaching or overlaying an xref, you can define a clipping boundary to display only a portion of the xref.

Clipping an xref is often useful when you want to:

- Work with a specific part of a large architectural floor plan
- Enlarge a specific part of a building systems drawing (for example, to show a detailed layout in a mechanical or electrical room)
- Lay out construction documents
- Improve drawing performance because you load only a part of the xref drawing

To clip an xref

1. Click Insert ➤ Reference panel ➤ Clip.
2. Select a reference.
3. At the prompt, select New Boundary by pressing ENTER.
4. Select a rectangular or polygonal clipping boundary, and then specify the corners or vertices of the boundary.

The software clips the image based on the area that you specified, and hides the portion of the xref outside the clipping boundary.
Changing the Display Configurations of Xrefs

1 Open the host drawing that contains the xref drawing for which you want to specify a different display configuration.
2 Select the xref drawing that you want to change, right-click, and click Edit Object Display.
3 In the Object Display dialog, click the Xref Display tab.
   If the settings on the tab are unavailable, you cannot change the display configuration used for the xref overlay.
4 Select Override the display configuration set in the host drawing.
5 Select the display configuration to use.
   The listed display configurations are those available in the xref drawing. Select Domain Drawing Default if you want to use the default display configuration specified in the host drawing.
6 Click View tab ➤ Appearance panel ➤ Regenerate drop-down ➤ Regenerate Drawing And Viewports.

**NOTE** If you specified that the drawing should always use its own display configurations when it is inserted as an xref overlay, you cannot change the display configuration used to display the xref objects in the host drawing. For more information, see Specifying the Display Configurations Used in Xref Overlays in the AutoCAD Architecture Help.
This section offers instructions on how to use AutoCAD MEP to design and draft heating, ventilation, and air conditioning (HVAC) systems for a building plan.

**HVAC System Workflow**

Mechanical system design best practice starts with the establishment of project parameters. HVAC designers can then design duct and necessary piping systems to create, size, and connect heating and cooling components.

*An example of rooftop mechanical systems.*

Before you begin drafting, you can establish design preferences and HVAC system definitions that fit your project. Once you define the systems for your drawing, you can assign systems to equipment and ductwork as you draw and modify your duct networks.
**Mechanical System Workflow**

Click in the left column to see a workflow demonstration. The right column provides links to help topics that supply more detailed information.

<table>
<thead>
<tr>
<th>Watch a demo</th>
<th>View more information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Define HVAC design parameters</td>
<td>Specify routing and auto-layout behavior, duct size calculation parameters, and duct rise and drop display style by Configuring Duct System Settings on page 174</td>
</tr>
<tr>
<td>Define a project</td>
<td>Specify the tool catalogs to use and other project information by Working with Projects on page 129</td>
</tr>
<tr>
<td>Link to floor plans</td>
<td>Use Project Navigator to create drawing sheets and views and attach an architectural floor plan as an external reference by Working with Referenced Drawings on page 158</td>
</tr>
<tr>
<td>Specify or leverage spaces, and use them to create room take-off schedules</td>
<td>Spaces make it easy to export building information via gbXML for the calculation of heating and cooling loads. See Using Spaces for Load Analysis on page 183</td>
</tr>
<tr>
<td>Calculate heating and cooling loads</td>
<td>Use one of a variety of 3rd-party tools to determine heating and cooling loads by Calculating Duct Sizes Using External Tools on page 241</td>
</tr>
</tbody>
</table>

**Duct System Workflow**

Click in the left column to see a workflow demonstration. The right column provides links to help topics that supply detailed information.

<table>
<thead>
<tr>
<th>Watch a demo</th>
<th>View more information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create preliminary 1-line designs</td>
<td>Prepare a conceptual design for evaluation by building engineers and code officers. See About Schematic Diagrams on page 518</td>
</tr>
</tbody>
</table>
Flow Annotation

You can access flow annotation information for air terminals from the Flow Annotation tab in the Equipment Properties dialog. You can specify up to 8 locations to place flow arrows around the air terminal. You can select the block for the flow arrow, and you have the option of using the same block for all flow arrows or selecting different blocks based on location. You can specify the rotation angle and the offset from the air terminal for each flow arrow, and you can specify a flow value. The Flow Annotation tab is available only after the air terminal has been added to the drawing.
Duct

You can draw ductwork in many different sizes and shapes. Fittings such as elbows and tees can be placed automatically as you draft. You can also manually add fittings to your runs, which is beneficial if you want to use fittings not specified in the duct layout preferences.

NOTE When you add duct runs, AutoCAD MEP inserts rise symbols and drop symbols as needed based on the rise/drop style assigned to the system of the run.

After you perform the initial layout of your mechanical equipment, you can draw ductwork to connect equipment and create networks. AutoCAD MEP includes many features that streamline the design and drawing of duct runs.

The process for adding duct runs is the same. You can add duct as 1-line objects as you design preliminary routes, and then modify them to 2-line objects as you specify properties such as size and connection type. 1-line duct runs appear as single-line representations while 2-line runs display the actual geometry of the duct, even in isometric views. You do not necessarily need to draw runs as 1-line elements at first; you can draw defined 2-line duct at any time.

NOTE 1-line duct objects differ from schematic lines in that they act as placeholders for sized 2-line duct objects. You can convert 1-line duct objects directly to 2-line duct objects of specific size and shape.

On the left, a top view of a 1-line duct run and on the right, a defined 2-line duct run.
You can draw duct runs in all 3 dimensions. You can also add sloped runs by specifying rise/run values. As you draw duct runs, fittings are automatically inserted to accommodate your routing geometry. The layout preferences specify which fittings are used. For more information, see Specifying Default Parts for Layout on page 180.

1-line and 2-line duct runs can be routed 3 dimensions.

You can size duct systems using engineering analysis tools included in AutoCAD MEP. You can use a duct system size calculator to size duct systems, and you can use instant duct size calculators in the Add dialog and Modify dialog to size individual segments.

**Flexible Duct Runs**

You can draw flexible duct runs. Flexible runs can be connected to rigid runs to create complete and accurate networks. Because flexible ducts are typically round in shape, the correct transition fitting is inserted when you connect to a duct segment of a different shape. You can specify a system for flexible duct components just as you can with rigid duct. You can also assign flexible and rigid components to the same system.

Flexible duct runs can be connected to equipment and MvParts.

You can draft a flexible duct run using different segment modes. Individual segments can be drafted as lines, arcs, or splines to create different configurations of flexible runs. For more information, see Configuring Flexible Duct Preferences on page 179.

You configure the display properties of flexible duct using several display components:

- **Contour**. Use this component to configure the contour lines.
- **Contour - Details**. Use this component to configure the interior contour lines.
- **Connector**. Use this component to configure the connector lines at start points and endpoints.
- **Annotation**. Use this component to configure the graphics pattern.
For more information on the display system, see AutoCAD MEP Displays on page 134.

**Auto-layout**

As you draw duct runs, you lay out the duct run geometry by specifying points in the drawing. The software automatically inserts duct segments and fittings along the layout. You can control which ducts and fittings are inserted by configuring duct layout preferences before you begin drawing duct runs.

The software includes many tools to streamline the layout of a duct run. You can use the compass to specify an angle, and you can use tracking lines to align a component with another object or line. You can use snaps to connect to duct objects, or to a geometric point on an object or line.

**HVAC System Settings**

There are several settings you can configure to control the construction, display, and annotation of duct systems. The primary settings are:

- **Duct layout preferences**: These settings specify routing and auto-layout behavior, and can be used to automatically add items such as labels and insulation to duct runs.

- **HVAC system definitions**: These settings specify duct size calculation parameters and duct display information, such as layer key settings, rise and drop display style, and display properties.

The duct layout preferences are applied to all duct runs as you draw them. When you add a duct run, you specify a system definition. The duct layout preferences specify what parts and connections are used in a duct run, and the system definition controls the display.

For information on working with duct settings, see Configuring Duct System Settings on page 174.

**Duct Fitting Vanes**

You can access turning vane information for duct fittings from the Vanes tab in the Properties dialog. The Vanes tab has only one control, Enable Vanes. Use the Vanes tab to specify whether an individual fitting should display turning vanes.

**NOTE** If you want to display turning vanes, you must add vanes to the duct fitting. Select the duct fitting, click Duct Fitting tab ➤ Duct Vanes panel ➤ Add Vanes. The vane graphic is added to the fitting style. The Enable Vanes control defines if an individual fitting should display vanes.
Vanes tab in the Duct Fitting Properties dialog

Takeoff Position

You can access position information for duct fitting takeoffs from the Takeoff Position tab in the Duct Fitting Properties dialog. You can move the takeoff along or across a duct segment. You can specify a location by selecting an offset distance and position based on the start point and endpoint of the duct segment. You can relocate the takeoff to a different side of, or angle around, the duct segment. You can specify a new rotation angle, or flip the fitting based on the X, Y, or Z axis. The Takeoff position tab is available only for takeoff duct fittings that have been added to the drawing.

Duct Sizing Methods and Tools

Because AutoCAD MEP duct systems connect intelligently, they can be sized automatically by the software. In the software, a duct run is defined as any ductwork connected to one or more outlet devices that have a defined outlet flow. Outlet devices such as air diffusers are considered the ends of the duct system. Each duct segment in the run can pass on the flow values for all outlet devices that are downstream from it. These flow values are used to calculate sizes for each duct segment in the run.
Duct Sizing Methods

Duct sizes are calculated using either the equal friction method or constant velocity method. For more information, see Specifying a Calculation Method for Duct Sizing on page 182.

The calculations for duct friction losses are based on the Darcy and Altshul-Tsal equations described in the 2001 ASHRAE Fundamentals Handbook, Chapter 34, as follows:

- Duct friction loss for round, rectangular, and oval ducts is calculated using equation 19.
- Duct friction factor for round, rectangular, and oval ducts is calculated using equation 21.
- Reynolds Number is calculated using equation 23.
- Equivalent round duct diameter for a rectangular duct is calculated using equation 25.
- Equivalent round duct diameter for a flat oval duct is calculated using equations 26, 27, and 28.

To size friction for the rectangular or oval duct, the calculations use the equivalent round duct diameter and its velocity.

The dialogs for Add Ducts and Modify Duct list the actual velocity for the selected CFM and duct size, not the velocity used in the duct friction calculations. The actual velocity is displayed for duct fitting and acoustical analysis.

When a CFM is not displayed in the dialogs for Add Ducts or Modify Duct, the friction or velocity values shown are the values specified in the Design Parameters for the Duct System Definition. To specify design parameters for the Duct System Definition, see Specifying a Calculation Method for Duct Sizing on page 182.

The Add Ducts dialog shows an asterisk next to the Velocity field to indicate that the constant velocity method was used to calculate duct size.

The Modify Duct dialog shows the fixed parameter value for velocity that was used to calculate duct size.

Duct sizes are calculated based on the flow values assigned to all outlet devices detected in the system. For more information on assigning flow values, see Configuring Mechanical Parts for Analysis on page 196.
Duct Sizing Tools

There are 3 options for calculating duct sizes:

- The Duct System Size Calculator calculates sizes to convert 1-line duct systems to sized 2-line duct systems. It can also calculate sizes for duct systems with defined shapes.
- The Instant Sizing Calculator calculates sizes for individual duct segments.
- Third-party, external analysis tools work in conjunction with AutoCAD MEP to analyze duct systems.

You can use any of these sizing tools at any time. The duct system size calculator can be used for both preliminary designs and modifications. The instant sizing calculator is best suited for modifying discrete parts of the system.

Duct Size Calculator

The duct size calculator can be used to calculate duct sizes for an entire connected system or for portions of a system. With the 1-line feature, you can draw duct systems using 1-line duct objects that act as placeholders for sized duct objects. After you add supply and outlet equipment to complete the system, you can use the duct size calculator to calculate duct sizes for the entire connected network. For more information, see Calculating Duct Sizes for a Duct System on page 203.

Instant Duct Sizing

If you have assigned flow values to outlet equipment, you can use the instant sizing tool to calculate sizes for ductwork as you draw duct runs. You can also use the instant sizing tool when modifying existing duct runs.

You can calculate duct sizes using either the equal friction method or the constant velocity method. To specify which duct sizing method to use, see Specifying a Calculation Method for Duct Sizing on page 182. The instant sizing tool calculates capacity by adding the flow values for all outlets detected in the duct run. If no flow values have been assigned to outlet devices, the capacity displayed is zero.

If you are drawing a duct segment connected to an outlet device with a specified flow capacity, the flow value is detected. If you are drawing a branch that is not yet connected to outlet devices, you can select outlet devices to be considered when calculating size. You can also manually enter a flow capacity to be used for size calculations.

The instant sizing tool detects flow capacity of outlet devices connected to the run.

When you execute the calculate size command, the instant sizing tool performs 2 calculations. First, it calculates the exact duct size based on the flow capacity value and a fixed parameter (either friction or velocity, depending on which calculation method is specified). The exact duct size is compared to available
duct sizes in the catalog, and the next larger size from the catalog is selected. The velocity and friction values are then recalculated using the duct size selected from the catalog.

**Duct Sizing Using Third Party Tools**

You can use external analysis tools to size duct networks in AutoCAD MEP drawings. For more information, contact your local Autodesk reseller.

**Duct System Snaps**

Duct snaps offer a quick and accurate way to connect duct objects. As you draw duct runs, you can use duct snaps to connect a duct, fitting, or MvPart directly to a duct connector on another object. You can connect to duct end connectors located on the ends of objects. You can also connect to duct curve connectors located at any point along a duct segment. For more information on using snaps, see *Using MEP Snaps* on page 75.

**Grips**

Grips offer a quick way to modify a duct object or MvPart. When you select a duct object or MvPart in a drawing, the grips for that object are displayed. For more information on using grips to modify objects, see *Modifying Components Using Grips* on page 220.

Top view of a duct run before moving.

Using the location grip to move the duct branch to the adjacent room.
The duct branch moved to the new location.

Grips can also be used to quickly start drawing a duct run from a duct, fitting, or MvPart. For more information, see Adding Duct Using Grips on page 200.

From top to bottom: add grips for a duct segment, a pipe elbow fitting, and a VAV outlet plenum.

Use the add grip at the midpoint of a run to create a new branch run.
Use the add grip on a connected 90 degree fitting to create a new branch.

**Configuring Duct System Settings**

The topics in this section offer specific instructions on how to configure the primary duct settings. If you take time to configure settings prior to drawing duct systems, you should be able to lay out your designs more quickly and accurately. Duct settings are stored with a drawing. You can use different duct settings for different drawings, and you can share one set of duct settings among drawings.

For general information on duct settings, see HVAC System Settings on page 168.

**Configuring Duct Layout Preferences**

Duct layout preferences can be configured to automate certain features as you draw duct runs. They include routing behavior settings, annotation settings, flexible duct settings, and connection settings. Many of the features in duct layout preferences can also be done manually to a duct run after it is created, but you may be able to save time and improve accuracy by specifying these settings before drawing duct systems.

Layout preferences are stored with the drawing. You can use different layout preferences for different drawings, and you can share layout preferences among drawings.

**Configuring Justification for Duct Insertion**

Use this procedure to specify how duct is positioned when inserted in a drawing. For example, by default the horizontal and vertical justification for duct insertion is set to the centerline of the duct run. The centerline of the resulting duct segments and fittings will be placed along the points you specify as you draw duct runs. The elevation provides the baseline for the vertical justification.

You can change the justification for duct insertion. For example, if you want to align the top of the duct run with a ceiling, you change the vertical justification to top. If you want to offset the duct run horizontally from a wall, you change the horizontal justification to right or left, and specify an offset distance from the wall.

You can change the horizontal and vertical justification to achieve 9 different insertion settings. As you specify justification locations, the preview image instantly displays the resulting settings.

**Preview image for justification settings**
1 From the HVAC workspace, click Manage tab ➤ Preferences panel ➤ Duct.

NOTE You can also open Duct Preferences from the Add Ducts dialog. Click (Preferences) in the lower left corner of the dialog. Any changes you make to Duct Preferences remain in effect after you close the Add Ducts dialog. For more information, see Offsetting Duct from Existing Geometry on page 208.

2 In the Duct Layout Preferences dialog, click the Routing tab.
3 Specify the justification settings for duct insertion:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>align the duct centerline along the points you specify for the duct run</td>
<td>under Justification, specify Center for Horizontal and Vertical. Specify 0 for Offset.</td>
</tr>
<tr>
<td>align one side of the duct along the points you specify for the duct run</td>
<td>under Justification, specify Left or Right for Horizontal, or Top or Bottom for Vertical. Use a combination of the 2 to align 2 sides along the insertion points.</td>
</tr>
<tr>
<td>offset the duct by a uniform distance from the points you specify for the duct run</td>
<td>enter a distance for Offset.</td>
</tr>
</tbody>
</table>

### Configuring Sloped Duct

Use this procedure to specify an angle or rise/run for sloped duct.

1 In the HVAC workspace, click Manage tab ➤ Preferences panel ➤ Duct.

NOTE You can also open Duct Preferences from the Add Ducts dialog. Click (Preferences) in the lower left corner of the dialog. Any changes you make to Duct Preferences remain in effect after you close the Add Ducts dialog.

2 In the Duct Layout Preferences dialog, click the Routing tab.
3 Specify the vertical slope:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
</table>
| specify an angle | - Under Duct Layout Rise/Run, select Angle.  
- Enter an angle value for Rise/Run, and for Increment.  
When you start the Add Ducts command, the rise/run value is displayed in the Add Ducts dialog. You can increase or decrease the angle by the increment value. |
| specify a fraction | - Under Duct Layout Rise/Run, select Fraction.  
- Enter a fractional value for Rise/Run.  
The Increment field is inactive. When you start the Add Ducts command, the fractional rise/run value is displayed in the Add Ducts dialog. You can modify it by entering a new value. |

For more information on drawing sloped duct, see Drawing Sloped Duct on page 208.
**Breaking Duct at Even Intervals**

Use this procedure to automatically break duct segments during layout. For example, if a duct system is going to be fabricated from straight ducts that are 10 feet long, you can configure duct layout preferences so that straight runs are automatically broken into 10-foot intervals as you draw them. Joints are automatically added at the break interval.

When turned on, the automatic break length setting is applied to all duct system definitions. For example, the automatic break length is applied to supply air, return air, or any other defined duct system in the drawing. If you want to use different break lengths when drawing different systems, change the break length as shown in this procedure prior to working with each system. You can also break or join duct segments after you have drawn them; see *Breaking or Merging Duct* on page 234.

1. In the HVAC workspace, click Manage tab ➤ Preferences panel ➤ Duct.

   **NOTE** You can also open Duct Preferences from the Add Ducts dialog. Click (Preferences) in the lower left corner of the dialog. Any changes you make to Preferences remain in effect after you close the Add Ducts dialog.

2. In the Duct Layout Preferences dialog, click the Routing tab.

3. Under During Layout, select Duct Length.

4. Specify the duct segment length by selecting a length from the drop-down list, or by entering a value.

**Adding Lining or Insulation**

Use this procedure to automatically add insulation or lining to ducts as you draw them. Insulation and lining display as hidden lines, and are only visible when the duct is viewed as 2-line. When turned on, insulation or lining is added to all duct system definitions as you draw them. You can add both insulation and lining to a duct, or you can just add one of them.

**NOTE** Insulation and lining are annotation elements only, and are used to visually convey where they are used on a duct system.
You can manually add, remove, or modify insulation or lining on duct components. For more information, see Modifying Insulation or Lining on page 238.

1 In the HVAC workspace, click Manage tab ➤ Preferences panel ➤ Duct.

**NOTE** You can also open Duct Preferences from the Add Ducts dialog. Click (Preferences) in the lower left corner of the dialog. Any changes you make to Duct Preferences remain in effect after you close the Add Ducts dialog.

2 In the Duct Layout Preferences dialog, click the Ducts tab.
3 Under Lining and Insulation, select Apply Insulation or Apply Lining, or both.
4 Enter a value for Thickness.

**NOTE** To turn off lining or insulation, open the Duct Preferences dialog, click the Ducts tab, and under Insulation or lining, deselect Apply Insulation or Apply Lining.

### Adding Labels or Flow Arrows to Ducts

Use this procedure to automatically add labels or flow arrows to ducts as you draw them.

**Size labels and flow arrows on a duct system**

![Diagram showing labels and flow arrows on ducts]

When turned on, labels or flow arrows are added to new duct runs as you draw them. They are not automatically added to existing duct runs in the drawing. You can manually add, remove, or modify labels and flow arrows on duct components. For more information, see Adding Labels or Flow Arrows to Pipe on page 317.

1 In the HVAC workspace, click Manage tab ➤ Preferences panel ➤ Duct.

**NOTE** You can also open Duct Preferences from the Add Ducts dialog. Click (Preferences) in the lower left corner of the dialog. Any changes you make to Duct Preferences remain in effect after you close the Add Ducts dialog.

2 In the Duct Layout Preferences dialog, click the Ducts tab.
3 Under Labels and Flow Arrows, select the first Apply Labels/Flow Arrows.
4 For Style, select a label or flow arrow style from the drop-down list.

For more information on label and flow arrow styles, see Modifying a Label Style on page 555.
5 Under Layout Method, specify how many labels or flow arrows to add to each straight segment of the duct run:

<table>
<thead>
<tr>
<th>If you want to</th>
<th>then</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify the total number of labels or flow arrows to display on each straight segment of the duct run</td>
<td>select Space Evenly, and enter a value for Number of Labels. Note that the number of labels or flow arrows is automatically added to each straight segment.</td>
</tr>
<tr>
<td>Insert a label or flow arrow at a uniform interval on each straight segment of the duct run</td>
<td>select Repeat Every, and enter a value for Distance. Note that if a segment length is less than the interval distance, a label or flow arrow is not automatically added to that segment.</td>
</tr>
</tbody>
</table>

- Flow Arrows Spaced Evenly, 1 per segment

- Flow Arrows Repeated at a Uniform Interval

6 To specify 2 label or flow arrow styles to a duct run, select the second Apply Labels/Flow Arrows, and follow the previous steps to define the type and placement.

NOTE To turn off the automatic insertion of labels or flow arrows, open the Duct Preferences dialog, click the Ducts tab, and under Labels and Flow Arrows, deselect one or both Apply Labels/Flow Arrows.

**Configuring the Display of Turning Vanes and Flanges**

1 In the HVAC workspace, click Manage tab ➤ Preferences panel ➤ Duct ➤ Ducts ➤ Duct Preferences. 
2 In the Duct Layout Preferences dialog, click the Vanes and Flanges tab.
3 To display turning vanes on fittings in 2-Line and Plan display representations, select Enable Vanes.
   If you apply vanes to a single fitting, they are automatically applied to all fittings of the same subtype and size.
   To disable vanes for selected fittings, clear this setting. If you do, you can still apply vanes to fittings, but you must repeat for one fitting at a time. They are not applied to all fittings of the same subtype and size. For more information, see Adding Turning Vanes to Fittings on page 214.
   **NOTE** The visibility and display properties of turning vanes are determined by the Annotation display component.

To show flanges on ducts and fittings in Plan or Model display representations

4 Select Enable Flange Connector Graphics.
5 For each duct shape (round, rectangular, and oval), enter values for the flange size and flange thickness.
The software adds these entries to the Extended tab of the Properties palette as property set data. If you do not want to display flanges and add the property set data, clear Enable Flange Connector Graphics.

To modify values for one or more selected ducts or fittings

6 Select one or more ducts or fittings, and click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties ➤.

7 On the Design tab of the Properties palette, expand Advanced.

8 For Flange dimensions, enter values for Connector 1 and Connector 2. Changing the values to zero for a connector causes the flange not to display once you regenerate the model.

**NOTE** You can only display flanges on ducts that have a flange connection type. Their visibility and display properties are determined by the Connector display component.

### Configuring Flexible Duct Preferences

**NOTE** For information on configuring the display properties of flexible duct, see Flexible Duct Runs on page 167.

1 In the HVAC workspace, click Manage tab ➤ Preferences panel ➤ Duct ➤.

**NOTE** You can also open Duct Preferences from the Add Ducts dialog. Click ➤ (Preferences) in the lower left corner of the dialog. Any changes you make to Duct Preferences remain in effect after you close the Add Ducts dialog.

2 In the Duct Layout Preferences dialog, click the Flex Ducts tab.

3 For Segment Mode, specify the default layout method for flex duct:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>lay out the flex duct as a series of straight line segments</td>
<td>select ➾ (Line) for Segment Mode. Specify a value for Radius of Curvature. Any angled transitions in the flex duct segment use this radius value.</td>
</tr>
<tr>
<td>lay out the flex duct as a series of arcs</td>
<td>select ➾ (Arc) for Segment Mode.</td>
</tr>
<tr>
<td>lay out the flex duct as a complex curve by specifying points for a spline</td>
<td>select ➾ (Spline) for Segment Mode.</td>
</tr>
</tbody>
</table>

4 Under 1 Line Annotation, for Graphics, select an annotation pattern. This pattern is applied to flex duct runs after you draw them, and it is visible for flex duct systems displayed as 1-line.

5 Under 1 Line Annotation, for Pitch, specify a value. This specifies the interval between the pattern, and it is based on the drawing scale.

6 Repeat the previous steps for 2 Line Annotation. This pattern is visible for flex duct systems displayed as 2-line.

For information on drawing flex duct runs, see Drawing Flexible Duct on page 206.
Specifying Default Parts for Layout

Use this procedure to specify the parts and fittings that are inserted automatically as you draw a duct run.

1. In the HVAC workspace, click Manage tab ➤ Preferences panel ➤ Duct.

   NOTE You can also open Duct Preferences from the Add Ducts dialog. Click (Preferences) in the lower left corner of the dialog. Any changes you make to Duct Preferences remain in effect after you close the Add Ducts dialog.

2. In the Duct Layout Preferences dialog, click the Parts tab.

   a. For Part Group Definition, select the definition to be modified.
   b. For Connection Type, select a connection type.
      The tree structure updates to display only those parts available for the selected connection type.
   c. For each part type, select a default part.

Configuring Duct Connections

Use this procedure to specify whether to use a tee or a takeoff when connecting a new run along an existing duct segment. You can also specify how to connect duct branches to air terminals.

1. In the HVAC workspace, click Manage tab ➤ Preferences panel ➤ Duct.

   180 | Chapter 6   Drawing HVAC Systems
NOTE You can also open Duct Preferences from the Add Ducts dialog. Click (Preferences) in the lower left corner of the dialog. Any changes you make to Duct Preferences remain in effect after you close the Add Ducts dialog.

2 In the Duct Layout Preferences dialog, click the Connections tab.

3 For Connection Style, verify that HVAC Connector Style is specified.
4 Under Connect with Duct, select Use Takeoff or Use Tee.
5 For Terminal-Duct Connection, specify how to connect duct to air terminals.
   When you select a connection option, a corresponding preview graphic displays.

Configuring Duct System Definitions

A system definition is typically named for the duct system it will be used for, such as supply or return air. The settings for a system definition control many of the display properties of a duct system. A layer key style is assigned to a system definition, and this dictates the layer, color and linetype for the system. A system definition can also be configured for duct size calculations.

You can also assign a system definition to a system group. In the software, duct runs that have different system definitions cannot connect to each other without changing the system for the connecting duct run. You can, however, assign a system group to different system definitions. This allows duct runs from different system definitions to connect while maintaining the same system for each run. For example, you can assign the same system group to Supply - High Pressure and Supply - Medium Pressure. You then can connect duct runs between these 2 systems while maintaining their original system definition settings.

The default templates include many duct system definitions, such as chilled water, heating hot water, and steam. Duct system definitions are stored with a drawing. You can use different system definitions for different drawings, and you can share system definitions among drawings.

Creating a Duct System Definition

TIP The default templates contain several system definitions that you can modify or copy.
1 In the HVAC workspace, click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ HVAC System Definitions.

2 Create the duct system definition:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then in the left pane of Style Manager…</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a new, blank system definition</td>
<td>right-click Duct System Definitions, and click New. Enter a name, and press ENTER.</td>
</tr>
</tbody>
</table>
| copy an existing definition, so you can modify the copy | do the following:  
  - Right-click the system definition you want to copy, and click Copy.  
  - Right-click Duct System Definitions, and click Paste.  
  - Right-click the copy, click Rename, enter a new name, and press ENTER. |

3 On the General tab, enter a description for the duct system definition.

4 Specify values for other general properties that are common to systems in all disciplines: mechanical, electrical, and plumbing. For more information, see Creating Systems on page 95.

5 Specify a calculation method for duct sizing. For more information, see Specifying a Calculation Method for Duct Sizing on page 182.

---

**Specifying a Calculation Method for Duct Sizing**

You must specify duct sizing parameters for each duct system on which you will use Duct Sizing Methods and Tools on page 169.

1 In the HVAC workspace, click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ HVAC System Definitions.

2 On the Style Manager, select a duct system under Duct System Definitions.

3 In the right pane of Style Manager, select the Design Parameters tab.

4 Specify which method to use to calculate duct sizes:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>use the constant velocity method</td>
<td>select Velocity, and enter a value.</td>
</tr>
<tr>
<td>use the equal friction method</td>
<td>select Friction, and enter a value.</td>
</tr>
</tbody>
</table>

The fixed parameter value is displayed in the Add Duct dialog and Modify Duct dialog, and is indicated with an asterisk (*).
NOTE The fixed parameter value is only used initially to calculate the exact duct size, which is then used to specify an available size in the catalog. Once you calculate duct size, the fixed parameter value in the Add dialog or Modify dialog might differ from the value specified in Design Parameters. See Duct Sizing Methods and Tools on page 169 for an explanation of how the duct sizing calculations are made.

5 Specify a value for Roughness. This is the roughness value of the ductwork material.
6 Specify a value for Density. This pertains to the medium, such as air, used in the system.
   The default value initially displayed in the software is the density of air at sea level, and at a temperature of 68 degrees F (20 degrees C).
7 Continue specifying the design parameters for other duct systems, and click OK.

Configuring the Display of Ducts and Fittings
In most cases, you configure the display of ducts and fittings as you do for other object types. However, to support the creation of construction documents, you have additional options in display configurations that use 1-Line or Plan display representations. You can

■ Display ducts and fittings with different properties (for example, linetypes) based on their elevation in the design. This feature is available in 1-Line and Plan display representations. For more information, see Display of Objects Based on Elevation on page 144.
■ Display center lines on ducts and fittings based on their shape. This feature is available in Plan display representations. For more information, see Display of Center Lines on Ducts on page 152.

For an introduction to the display system in AutoCAD MEP, see AutoCAD MEP Displays on page 134.

Using Spaces for Load Analysis
In AutoCAD MEP, spaces are entities that model the interior spaces of rooms. You group spaces into zones. A zone represents an actual building zone that has its own heating and cooling requirements. You can use spaces and zones to aid in calculating the heating and cooling loads for a building plan.

After you create spaces and zones, you can assign to them the engineering data needed for calculating loads and airflows. You export the engineering and building information in Green Building XML (gbXML) format. You can use gbXML files in external analysis tools. After you analyze the file, you can import the results into your drawing. You can view the calculated loads and airflows for the spaces and zones, and design your duct systems accordingly.

Configuring Space Styles
You can configure space styles for the different room types in the building plan. For example, if you are designing an HVAC system for a manufacturing facility, you can create space styles for offices, manufacturing areas, and warehouse areas.

Regarding load calculations, the most important setting for a space style is its classification. When you define a classification for a space style, the occupant density and outside air flow requirements are automatically set. These values are included in the software, and are based on the appropriate mechanical standard or code. For more information, see Viewing Classification Settings on page 185.

If multiple rooms use the same density of lighting and equipment, you can add property sets to the style that enable you to specify lighting and equipment loads per area. This action alleviates the need to manually
enter lighting and equipment loads for each individual space. If you need to change the lighting and equipment load for a space, you can override these values using the Properties palette.

You can also specify the display properties for the space—such as visibility, layer, color, and linetype—and you can specify a hatching pattern to enhance the visibility of spaces in the floor plan.

To create a space style

1. Open the drawing to which you want to add spaces.
2. Click Manage tab ➤ Style & Display panel ➤ Style Manager ➤ .
3. In Style Manager, expand the current drawing.
4. Expand Architectural Objects ➤ Space Styles.
5. Right-click Space Styles, and click New.
6. Rename the new style, and verify that it is selected.

To specify a lighting and equipment load per area

7. In the right pane, click the General tab.
8. At the bottom of the pane, click Property Sets.
9. In the Edit Property Sets Data dialog, click (Add Property Sets).
10. In the Add Property Sets dialog, select SpaceEngineeringStyles, and click OK.

NOTE This property set is only available in drawings created from templates provided with Autodesk Building Systems 2007 or AutoCAD MEP 2010. If this property set is not available, you can copy and paste it from the Aecb Model drawing template using Style Manager. In Style Manager, it is located in Documentation Objects ➤ Property Set Definitions.

11. In the Edit Property Sets Data dialog, enter the area lighting and equipment loads, and click OK.

You can also specify a gbXML space type override if you want to restrict this style to a specific space type. If you use this setting, it overrides any classification you specify for the space style as shown in the following steps.

To specify a classification

12. Click the Classifications tab.
13. For Space Occupancy, click .
14. In the Select Classification dialog, expand the directories under the desired standard, select a space type, and click OK.
15. Use the previous steps to create additional space styles.
16. To modify the display of spaces with the selected style, click the Display Properties tab, and modify the display settings as desired.

NOTE You must assign a classification to use the gbXML export feature. You can assign a classification to the space style, or you can specify a classification override in the space style property set. You can also manually specify a classification on the Extended Data tab of the Properties palette.

NOTE For complete information on working with space styles, see Space Styles in the AutoCAD Architecture Help.
Viewing Classification Settings

You can view the occupant densities and air flows configured for classification types.

1. Click Manage tab ➤ Style & Display panel ➤ Style Manager ➤ Style Manager.
2. In the Style Manager, expand Multi-Purpose Objects ➤ Classification Definitions.
3. Click Space Occupancy.
4. In the right pane, click the Classifications tab.
5. Expand the classifications under Space Occupancy, and select the space type you want to view.
6. On the right side of Style Manager, click Property Sets.

The Edit Property Set Data dialog displays the values for the classification.

<table>
<thead>
<tr>
<th>General</th>
<th>Applies To</th>
<th>Classification</th>
<th>Version History</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Space Occupancy</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>ASHRAE 90.1-2004</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Correction Facilities (ASHRAE 2004)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Educational Facilities (ASHRAE 2004)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Food and Beverage Service (ASHRAE 2004)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>General (ASHRAE 2004)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Hotels or Motels or Resorts or Dormitories (ASHRAE 2004)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Offices (ASHRAE 2004)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Miscellaneous Spaces (ASHRAE 2004)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Public Assembly Spaces (ASHRAE 2004)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Retail (ASHRAE 2004)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Sports &amp; Entertainment (ASHRAE 2004)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>UDC 1.977</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>CIBEE</td>
<td></td>
</tr>
</tbody>
</table>

Configuring Zone Styles

You can create zone styles to specify the display and design rules for zones. In regard to load calculations, however, zone styles have no relevant settings that you need to configure. Zone styles are located in Style Manager under the Documentation Objects. For more information, see Zone Styles in the AutoCAD Architecture online help.

Adding Spaces to a Floor Plan

You can add spaces to a drawing using the objects in a referenced floor plan drawing (xref) as the bounding objects. Using the Space tool, you can generate a space for a room bounded by AEC objects, such as walls and floors, or AutoCAD objects, such as lines and blocks. The Space tool is located on the Analysis palette in the HVAC tool palette group.

When adding spaces, be sure to specify the appropriate space styles. After you create the spaces for a floor plan, you assign engineering datato them using property sets. You also specify surface types, such as exterior walls, using the Space/Zone Manager.
NOTE For complete information on creating, editing, and updating spaces, see Spaces in the AutoCAD Architecture online help.

Recommendations for Floor Plans

The Space tool should work with most kinds of floor plan drawings. When generating spaces, you can use the extruded 3D space type for most applications. The space perimeter is determined by the floor geometry, and the space is extruded vertically to a specified height. Whether the floor plan consists of 3D AEC objects, 3D AutoCAD lines, or 2D AutoCAD lines, you can generate extruded 3D spaces based on the floor outline. Note, however, that spaces generated from linework floor plans may require editing. For example, if a linework floor plan shows door swings into a room, the space generated from the floor outline might exclude the area in the door swing linework.

If a room does not have a constant perimeter throughout its height, such as it has sloped walls or ceilings, you can generate 3D free form spaces to automatically conform to the irregular volume. You can only create 3D free form spaces, however, if the floor plan is developed in 3D from AEC or AutoCAD objects.

When you generate spaces, they are specified as associative by default. Associative spaces are automatically linked to their bounding objects. If you modify the bounding objects, you can manually update the space in one step to match the new room shape. However, spaces set as associative cannot be edited. When working with referenced floor plans, it is recommended that you configure the spaces based on the type of floor plan you are using:

- AutoCAD Architecture floor plan: If the floor plan consists of AEC objects, you can generate a space that not only matches the floor plan geometry, but also detects openings such as windows and doors. It is recommended that you leave the space as associative if you have immediate access to updated floor plans. That way you can manually update the space to match the latest floor plan.
  However, if you want to edit the space openings or space surfaces, you need to set the space to be non-associative. When you do this, the openings are maintained, but the space no longer interacts with its bounding objects.

- AutoCAD linework and blocks, 2D or 3D: You can generate spaces for both 2D and 3D linework drawings. For 2D linework, you can generate extruded 3D spaces. For 3D linework, you can generate extruded 3D spaces or free form 3D spaces. For both types, it is recommended that you generate the spaces, set them to be non-associative, and then manually add openings and specify surface types. You can manually edit the space geometry to match any changes to the floor plan.

For load analysis purposes, you must use extruded 3D spaces or free form 3D spaces. Do not use 2D spaces. This ensures that the room volumes are accurately modeled.

TIP If the spaces and their bounding objects are in the same drawing, you can configure the software to update the spaces automatically when you make changes to the bounding objects. For more information, see Activating and Deactivating Automatic Updates in the AutoCAD Architecture Help.

Modeling Openings on Spaces

Spaces can be configured to include openings such as doors and windows. If you create spaces based on AEC objects in an AutoCAD Architecture drawing, the spaces can automatically detect the openings.

Generated spaces are associative by default. They detect openings automatically, and cannot be manually edited unless you set them to be non-associative on the Properties palette. If you generate extruded 3D spaces using linework in a 2D floor plan, you have to set the spaces to be non-associative before you can add openings to the spaces.

Manually created spaces are not associative by default, and you can edit their surfaces and openings. For information on doing so, see How Changing the Space Geometry Affects Surface Openings in the AutoCAD Architecture online help.
If you change a space from associative to non-associative or vice versa, existing openings are maintained in most cases. When you change a 3D free form space to a 3D extruded space, openings that do not intersect with the base profile of the extruded space are lost.

**Modeling Surface Types on Spaces**

Space surfaces can be configured for surface type. For example, a wall can be interior or exterior, and a floor can be interior, slab, or underground. However, you do not need to specify surface types in order to use the gbXML export tool. The tool automatically figures out the correct surface type when the gbXML file is created. For example, surfaces that have no adjacent spaces are considered exterior, and wall surfaces below grade level \( z = 0 \) are considered underground. You can specify surface types in the Space/Zone Manager.

**Adding Engineering Data to Spaces**

For load calculation purposes, you must add SpaceEngineeringObjects, ThermalProperties, and ZoneEngineeringObjects styles property sets to all spaces that you want to analyze. From the Style Manager, copy property set definitions from the gbXML Property Set Definitions drawing into your current drawing. Once you have assigned these property set definitions to the spaces and zones in your drawing, you can edit the engineering data to model the appropriate environmental conditions. You are then ready export this data in gbXML format for use in various analysis software programs.

1. Click Manage tab ➤ Style & Display panel ➤ Style Manager .
2. Click File ➤ Open Drawing.
3. In the Open Drawing dialog, navigate to \ProgramData\Autodesk\MEP 2010\enu\Styles\Imperial.
4. Select the gbXML Property Set Definitions drawing and click Open.
5. Expand the gbXML Property Set Definitions Documentation Objects folder.
    The SpaceEngineeringObjects, ThermalProperties, and ZoneEngineeringObjects styles comprise this property set.
7. Copy the Property Set Definitions to your current drawing, and then click OK.
    The engineering data styles are ready to be applied the spaces and zones in your drawing.
8. Select the spaces to which you want to add the property set data, and click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties .
9. On the Properties palette, click the Extended Data tab, and then click (Add Property Sets).
10. In the Add Property Sets dialog, select SpaceEngineeringCalculatedData, SpaceEngineeringObjects, and SpaceObjects, and then click OK.
The property set is added to the selected spaces, and it can be viewed on the Extended Data tab.

11 Under Classification, verify that a room type (a classification) is specified for Space Occupancy. Any classification configured for the specified space style displays here. You can override it by clicking the room type, and specifying another room type in the Select Classification dialog. If the current value is *Unspecified*, specify a room type.

12 Under Property Sets, you can specify values for the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Occupancy</td>
<td>Enter the number of occupants for the room. This value may be used for calculating the required outdoor air flow depending on the code and classification. If Occupancy is 0, the occupant density for the classification is used to calculate outside air.</td>
</tr>
<tr>
<td>ConditionType</td>
<td>Specify how to condition the room.</td>
</tr>
<tr>
<td>LightingLoad</td>
<td>Enter the lighting load for the room. If you specified lighting load per area in the style, the DefaultLightingLoad property set calculates the lighting load based on the room area. You can override that value by entering a value for LightingLoad here.</td>
</tr>
<tr>
<td>EquipmentLoad</td>
<td>Enter the equipment load for the room. If you specified equipment load per area in the style, the DefaultEquipmentLoad property set calculates the equipment load based on the room area. You can override that value by entering a value for EquipmentLoad here.</td>
</tr>
<tr>
<td>OutsideAirFlow</td>
<td>If you enter a value, it overrides the required airflow calculated from the classification.</td>
</tr>
</tbody>
</table>
If you are exporting gbXML data for analysis, you do not need to enter values for these fields. Airflow will be calculated for this space, and you can enter your desired values after you import the load calculations. These values are for the flow rate for the room, not for the flow per unit area or per person.

Note that the RequiredOAFlow (occupant air flow) property is not editable. Its value is calculated automatically when you specify a room type for Space Occupancy and a number of occupants for Occupancy.

### Attaching Property Sets to Zones

Before exporting space data to gbXML, you must assign all spaces to a zone. You configure a zone for analysis by specifying the heating and cooling temperatures for the zone.

**To attach property sets to a zone**

1. Create zones, as described in Configuring Zone Styles on page 185.
2. Select all zones, and click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties.
3. On the Extended Data tab of the Properties palette, click ![Add Property Sets](Add Property Sets.png).
4. In the Add Property Sets dialog, select ZoneEngineeringObjects, and click OK.

The property set is added to the selected zone, and it can be viewed on the Extended Data tab.

5. Under Property Sets, specify the appropriate values for design heating and cooling temperatures.

### Attaching Spaces to Zones

For load calculation purposes, you must assign all spaces to one or more zones. You can also attach zones to other zones, which is useful for exporting zone data through reference drawings. However, the Export
gbXML command exports only those zones that have spaces assigned. Zones without spaces assigned to them will not be exported.

1 Select a zone.
2 Click the Add (Plus) grip.

NOTE Alternatively, click Click Zone tab ➤ Modify panel ➤ Attach.

3 Select the spaces or zones to attach to the zone.
   You can attach spaces or zones in reference drawings to a zone in the current drawing.
4 Continue attaching spaces to zones using the previous steps.

IMPORTANT Zones in reference drawings cannot be exported to gbXML unless they are attached to a zone in the current drawing. However, even when a zone in a reference drawing is attached to a zone in the current drawing, any zone will not be exported if the spaces attached to it are attached to other zones that have already been added to the export map.

TIP You can use the Space/Zone Manager to review the zone hierarchy, and to review space information such as surface and opening type. For more information, see Opening the Space/Zone Manager and Editing Space Surface Properties.

### Exporting Zones for Load Analysis

After you have configured spaces with property set values and have attached spaces to zones, you can export the engineering and building information in gbXML format.

1 Open the drawing that contains the zone data you want to analyze.

   NOTE You can analyze a complete building by attaching zones and spaces in xref drawings to zones in a current drawing. The adjacent spaces and space surface types are automatically detected for all spaces at export.

2 Click ➤ Export ➤ gbXML.
   If necessary, scroll down to display additional export options.
3 In the Export to gbXML dialog, specify the export settings:
   - File name: Specify a file name and location.
   - Select Objects: The dialog automatically detects all zones in the current drawing. Zones in reference drawings cannot be exported unless they are attached to a zone in the current drawing. If the dialog does not detect all zones, click Select Objects and select the desired zones.
   - Building Type: Specify a building type and postal ZIP code that may be used by the external analysis program.
   - Progress: Click Start to run the export.
Success: If any errors occur during export, the event log opens to allow you to view error messages. You can view the event log at any time by clicking View Event Log.

4 The gbXML file can now be used in various analysis software programs.

Reviewing Spaces and Zones

You can use the Space/Zone Manager to review the zone hierarchy, and to review space information such as surface and opening type.

1 Select a space or a zone.
2 Open Space/Zone Manager using one of the following methods:
   - Click Space tab ➤ Helpers panel ➤ Space/Zone Manager.
   - Click Zone tab ➤ Helpers panel ➤ Space/Zone Manager.
   - On the Design tab in the Properties palette, under Basic ➤ General, click next to Space/Zone Manager.
3 In Space/Zone Manager, select both Show All Zones and Spaces and Show Space Surfaces.

You can expand zones to review the spaces attached to them. You can expand spaces to review surfaces, surface types, and openings.

4 To modify a surface type, such as specify a wall as interior or exterior, verify that Show Space Surfaces is selected.

5 Expand the space, and select the surface to specify.
   Move the Space/Zone Manager, if necessary, and note that the selected surface is highlighted on the drawing.

6 For Type, specify a surface type from the drop-down list.

7 Use the previous steps to specify surface types for all spaces.

**Importing Load Analysis Results**

After you perform load analysis, you can import the gbXML file with results back into your drawing.

1 Open the drawing that contains the zones and spaces used when you exported the original gbXML file.

   **NOTE** If you calculated loads for spaces in xref drawings, repeat the import procedure on every drawing that contains spaces.

2 Click Analyze tab ➤ HVAC panel ➤ Import gbXML.

3 In the Import gbXML dialog, specify the analyzed XML file, and click Open.
   The gbXML results are applied to the spaces and the zones in the drawing.

4 To view calculations, click a space or zone, and click the Extended Data tab on the Properties palette.
The calculation results are displayed under `SpaceEngineeringCalculatedData` for spaces, and `ZoneEngineeringCalculatedData` for zones.

The `SupplyAirFlow` calculated value is used in the space tag and space schedules. You can manually enter values for return air flow.

**NOTE** The Import gbXML command provides no direct information about the success or failure of the import operation. Examine the calculated results to determine the success of the import operation.

### Using Space and Zone Calculated Data

After you import load calculations into your drawing and apply them to spaces, you can display the calculation results in tags and schedules to help you design your HVAC system.

**A space tag example**

![Space Tag Example](image)

**A simple space schedule example**

<table>
<thead>
<tr>
<th>Room</th>
<th>Space Type</th>
<th>Area</th>
<th>Supply</th>
<th>Return</th>
<th>Ventilation</th>
</tr>
</thead>
<tbody>
<tr>
<td>LAB 247</td>
<td>LABORATORY</td>
<td>1,654.7</td>
<td>2,000 CFM</td>
<td>0 CFM</td>
<td>2,000 CFM</td>
</tr>
<tr>
<td>COMMON SPACE 22H</td>
<td>LABORATORY SUPPORT</td>
<td>682.2</td>
<td>150 CFM</td>
<td>150 CFM</td>
<td>25 CFM</td>
</tr>
<tr>
<td>LAB 248</td>
<td>LABORATORY</td>
<td>1,882.2</td>
<td>4,600 CFM</td>
<td>0 CFM</td>
<td>4,600 CFM</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4,235.0</td>
<td>6,150 CFM</td>
<td>150 CFM</td>
<td>6,000 CFM</td>
</tr>
</tbody>
</table>

The space tags and schedules are located in the Content Browser. You can drag and drop them onto a tool palette.

**To load the space tag onto a tool palette**

1. Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content Browser ➤ Content Browser ➤ MEP Documentation Tool Catalog - Imperial.
In the left pane, click HVAC ➤ HVAC Tags.
4 Click Text Tags.
5 In the upper-right corner, click Next until you get to the page with the Space tag.
6 Move the cursor over the i-drop symbol.

7 Drag the i-dropper from the Content Browser, and drop the space tag tool onto a tool palette.
8 To add the space schedule, repeat the previous steps. The Space Engineering Schedule is located in HVAC ➤ HVAC Schedules of the Documentation Tool Catalog.
9 Close Content Browser.

For information on placing space tags on your drawing, see Tags on page 561. For information on scheduling spaces, see Schedules on page 566. You are more likely to use space tags and schedules in construct drawings as design aids. You may not necessarily include them on view and sheet drawings for construction documents.

**Creating a Duct System**

After you configure duct settings, you can create duct systems by adding equipment and duct runs to a drawing. The most common way to add parts and duct runs is to use the tools on the HVAC tool palettes set. Duct parts and equipment also contain grips you can use to draw duct runs directly from an object without selecting a tool.

You can insert an architectural floor plan as a reference, and design duct systems around that floor plan. After you create duct systems, you can modify them to refine your design, or to accommodate changes to the building plan.

The topics in this section offer specific instructions on how to use the software features to create duct systems.

**Adding HVAC Equipment**

In the software, equipment is referred to as MvParts (multi-view parts), or simply parts. You can place parts anywhere on a floor plan. You can add them as stand-alone objects, and then draw duct runs to connect them, or you can add MvParts by connecting them to existing duct runs. MvParts have connectors that allow them to connect directly with duct objects.

The software includes a default duct part catalog that contains hundreds of parts in thousands of sizes. The part types range from large components, such as rooftop air conditioning units, to small components, such as grilles.

If the part catalog does not contain the exact component you want to use, you can create your own custom parts:

- **Convert MvBlocks** in AutoCAD or AutoCAD Architecture drawings to MvParts.
- **Use the Parametric Part Wizard** to quickly configure a parametric version of a common part.
- **Use Content Builder** to create all levels of block-based or parametric parts.
Adding HVAC Equipment

You add HVAC equipment using the tools on the Equipment tool palette in the HVAC tool palette group. You select a tool, use the Add MvParts dialog to select a part and configure its properties, and then add the part to the drawing.

**RELATED** See Mechanical, Electrical, and Plumbing Equipment in Building Systems on page 76.

**To add HVAC equipment**

1. In the HVAC workspace, do one of the following:
   - Click Home tab ➤ Build panel ➤ Equipment drop-down, and select one from the list.
   - Open the Equipment tool palette, and select an equipment tool. If necessary, scroll to display the tool.
   
   The software displays the Add MvParts dialog showing a tree view of the current catalog. The software opens the catalog at the part type folder associated with the tool you selected.

2. On the Part tab, select a part subtype in the part type folder. Click Display/Hide additional part parameters to display or hide table details.

3. Click Details to view the sizes available for the selected part subtype.

4. Some part subtypes have large numbers of available sizes. If necessary, filter the list by clicking the Part Filter tab and specifying the filtering criteria. For example, you can filter the list according to connection size or type.

   **NOTE** The part catalogs and content locations specified in the Options dialog determine the parts available to you when adding a part. For more information, see Specifying Part Catalogs and Style-Based Content Locations on page 70.

5. Select a part for Part Size Name.

6. Select a defined elevation or enter a value for Elevation.

7. If you can assign airflow values to the part, click the Flow tab. For outlet devices, enter the airflow value for Flow; for supply devices, enter an airflow value for each connector.

8. Specify an insertion point in the drawing, and use the compass to specify a rotation angle.

9. Repeat the preceding step to add additional parts with the same properties.

10. Press *ENTER* to end the command.

Adding Parts In-Line to Ducts

Use this procedure to add an in-line or anchored MvPart, such as a damper, to a duct.

1. Select an MvPart to add as shown in Adding HVAC Equipment on page 195.

2. To place the part on a duct, move the cursor to a duct segment to display a duct end or duct curve connector.

3. Click the duct connector to place the part in-line to the duct or anchored to a duct end, and use the compass to specify a rotation angle.

4. Repeat the preceding step to add additional parts with the same properties.

5. Press *ENTER* to end the command.

Once the part is inserted, you can use grips to rotate the part around the centerline of the duct segment. You can also flip an in-line part such as a fan to orient the part in the proper flow direction. For more information, see Rotating Duct Components on page 228.
Configuring Mechanical Parts for Analysis

You can assign air flow values to duct system equipment such as air terminals. The duct system can be analyzed, and sizes can be calculated using these values.

1 Select the part.

   **TIP** To configure all similar parts in the drawing at once, select the part, and click Equipment tab ➤ General panel ➤ Select Similar.

2 Click Equipment tab ➤ Modify panel ➤ Equipment Properties.

3 In the Multi-view Part Properties dialog, click the Flow tab and specify the airflow values:

   **If you want to** … then …

   - specify an air flow value for an outlet device, such as a ceiling diffuser
     - enter the value for Flow.

   - specify an air flow value for a supply device, such as a VAV box
     - specify an air flow value for each connector.

Adding Duct

AutoCAD MEP includes many features for drawing, sizing and modifying ductwork. The duct part catalogs included with the software contain thousands of parts you can draw in duct systems. Duct is available in many sizes and shapes. Fittings are also available in many configurations and sizes.

The parts available to you when drawing duct runs are controlled by the part catalogs. For information on specifying part catalogs, see Specifying Part Catalogs and Style-Based Content Locations on page 70. You can configure preferences to control how duct runs are routed, displayed, and connected. For more information, see Configuring Duct System Settings on page 174.

You can also assign duct runs to systems. AutoCAD MEP includes defined systems for duct. For example, you can assign a duct network to the Supply - Low Pressure system. For more information on system definitions, see Configuring Duct System Definitions on page 181.

AutoCAD MEP includes tools you can use to calculate sizes for systems or individual segments. There are external analysis tools that work with AutoCAD MEP drawings to analyze and size duct.

Drawing a Duct Run

Use this procedure to add a duct run. In the Add dialog, you can specify the system and properties such as elevation, shape, and size. You can also calculate sizes for duct segments in the run using the instant sizing tool.

You can choose to draw with a rise/run angle or use routing to specify a default elbow angle.

You can define additional properties of the duct run, such as insulation or lining, by specifying layout preferences.

**NOTE** When you add duct runs, AutoCAD MEP inserts rise symbols and drop symbols as needed based on the rise/drop style assigned to the system of the run.
1 In the HVAC workspace, do one of the following:

- Click Home tab ➤ Build panel ➤ Duct drop-down ➤ Duct.
- Open the Duct tool palette, and select a duct tool.

2 If you typically begin a design by defining the duct runs according to system, select a duct tool with a specific, predefined system, such as the Supply - Low Pressure tool. The duct that you draw inherits the system's properties, such as its design parameters, display properties, and rise and drop style. For more information, see Working with Systems on page 93.

**NOTE** You can also begin drawing a duct run by clicking an Add grip on a part, duct fitting, or duct segment. Clicking the grip opens the Add Ducts dialog.

3 In the Add Ducts dialog, specify a system for System.

4 Specify a coordinate system and value for Elevation:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>draw a run at a defined elevation</td>
<td>select an elevation name for Elevation.</td>
</tr>
<tr>
<td>draw a run at a specified elevation relative to a wall or other duct or duct</td>
<td>enter the desired elevation, specify justification and offset, and use AutoCAD snaps or AutoCAD MEP snaps to specify points on the wall, duct, or other objects.</td>
</tr>
<tr>
<td>start a branch at a specified elevation on a riser</td>
<td>enter the desired elevation and use AutoCAD MEP snaps to specify a point on the riser.</td>
</tr>
<tr>
<td>start a branch from a vertical run with a riser at a specified elevation</td>
<td>enter the desired elevation and use AutoCAD MEP snaps to specify a point on the vertical run.</td>
</tr>
<tr>
<td>extend a sloped duct or duct segment to a specified elevation</td>
<td>enter the desired elevation, click Use Rise/Run, and use AutoCAD MEP snaps to specify the endpoint of a sloped duct or duct.</td>
</tr>
</tbody>
</table>

If you lock the elevation, the elevation from the objects that you connect to is not inherited.

5 You can specify the offset in 2 directions:

<table>
<thead>
<tr>
<th>If you want to specify...</th>
<th>then select...</th>
</tr>
</thead>
<tbody>
<tr>
<td>the horizontal offset</td>
<td>Left, Right, or Center. Enter the horizontal distance of the run from the wall or other objects.</td>
</tr>
<tr>
<td>the vertical offset</td>
<td>Top, Center, or Bottom. Enter the vertical distance of the run from the ceiling or other objects.</td>
</tr>
</tbody>
</table>

6 Specify connection type, duct shape, and duct size. To calculate duct size using the instant sizing tool:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>calculate size for round duct</td>
<td>accept the detected value for Capacity, or enter a value for Capacity. Click .</td>
</tr>
</tbody>
</table>

Adding Duct | 197
<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>calculate size for oval or rectangular</td>
<td>accept the detected value for Capacity, or enter a value for</td>
</tr>
<tr>
<td>duct based on a fixed height</td>
<td>Capacity. Specify a size for Height, and click for Width. You can</td>
</tr>
<tr>
<td></td>
<td>change the height and recalculate the width repeatedly until you</td>
</tr>
<tr>
<td></td>
<td>achieve a desirable duct size.</td>
</tr>
<tr>
<td>calculate size for oval or rectangular</td>
<td>accept the detected value for Capacity, or enter a value for</td>
</tr>
<tr>
<td>duct based on a fixed width</td>
<td>Capacity. Specify a size for Width, and click for Height. You can</td>
</tr>
<tr>
<td></td>
<td>change the width and recalculate the height repeatedly until you</td>
</tr>
<tr>
<td></td>
<td>achieve a desirable duct size.</td>
</tr>
<tr>
<td>calculate duct size using a single</td>
<td>click and select a single outlet device. The flow value of the</td>
</tr>
<tr>
<td>outlet flow device that is not yet</td>
<td>outlet device is specified for Capacity. Click .</td>
</tr>
<tr>
<td>connected to the duct</td>
<td>calculate duct size using a single outlet flow device that is not</td>
</tr>
<tr>
<td></td>
<td>yet connected to the duct.</td>
</tr>
<tr>
<td>calculate duct size by using multiple</td>
<td>click and select multiple outlet devices. The Capacity value is</td>
</tr>
<tr>
<td>outlet flow devices that are not yet</td>
<td>increased by the combined flow values of the selected devices. Click</td>
</tr>
<tr>
<td>connected to the duct</td>
<td>.</td>
</tr>
</tbody>
</table>

For more information, see **Specifying a Calculation Method for Duct Sizing** on page 182.

7 You can select Use Rise/Run and enter a value in degrees to continue drawing the duct at an upward or downward angle.

8 Click Use Routing, and then select a routing method:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>draw with a predefined elbow angle</td>
<td>select an elbow angle.</td>
</tr>
<tr>
<td>define your own elbow angle in the</td>
<td>select User Defined, and specify a point for the elbow angle. You can</td>
</tr>
<tr>
<td>drawing area</td>
<td>draw either with or without the Compass.</td>
</tr>
<tr>
<td>define your own elbow angle in the</td>
<td>enter a value for the elbow angle.</td>
</tr>
<tr>
<td>dialog</td>
<td>select Show Catalog for Elbow Angle. To optimize drawing performance,</td>
</tr>
<tr>
<td></td>
<td>elbow angles from the catalog are hidden by default.</td>
</tr>
<tr>
<td>update the Elbow Angle options to select</td>
<td>select Hide Catalog.</td>
</tr>
<tr>
<td>elbow angles from the catalog</td>
<td></td>
</tr>
<tr>
<td>hide the Elbow Angle options from the</td>
<td></td>
</tr>
<tr>
<td>catalog in order to increase drawing</td>
<td></td>
</tr>
<tr>
<td>performance</td>
<td></td>
</tr>
<tr>
<td>draw with only the selected elbow angle</td>
<td>click the Lock icon next to Elbow Angle. The next segments you draw</td>
</tr>
<tr>
<td></td>
<td>will have the same elbow angle.</td>
</tr>
<tr>
<td>draw with both an elbow angle and a</td>
<td>click the Preferences icon, and then click the Routing tab. Deselect</td>
</tr>
<tr>
<td>rise or drop to a specific elevation</td>
<td>Automatically create riser at new Elevation, and then click OK. Enter</td>
</tr>
<tr>
<td></td>
<td>an elevation and draw the segment with an elbow angle.</td>
</tr>
<tr>
<td>save drawing performance and not display</td>
<td>click the Preferences icon, and then click the Routing tab. Deselect</td>
</tr>
<tr>
<td>the elbow as you draw with a specified</td>
<td>Preview Elbow when Compass is Enabled or Preview Elbow when Compass is</td>
</tr>
<tr>
<td>elbow angle</td>
<td>Disabled.</td>
</tr>
</tbody>
</table>
If you want to... then...

specify the predefined elbow angles displayed in the Elbow Angle list click the Preferences icon, and then click the Routing tab. Enter or delete elbow angles in the Predefined Elbows Angles list.

NOTE The selection of elbow angles does not apply to the first segment that you draw.

9 Specify a start point, and then continue to specify points to add more segments to your run. Connection fittings are inserted to connect each segment as you draw.

10 Change the elevation as needed, and continue to specify points to add more segments to your run. Vertical segments are added by default.

**Starting a Run From Existing Duct**

Use this procedure to connect a new duct segment to an existing duct segment. You can use duct snaps to automatically connect a new run anywhere along an existing duct segment or fitting.

The fittings that are automatically inserted between the existing duct and the new duct are configured in the routing preference and duct layout preference.

1 Open and configure the Add Ducts dialog. For more information, see Drawing a Duct Run on page 196.

**Starting from a Duct End**

2 To start a new run from the end of a segment, move the cursor over the end of the existing duct segment to display the duct end connector snap.

3 Click the duct end connector to specify the start point of the new run.

   The size and system for the new run match the existing duct.

4 In the Add Ducts dialog, specify a routing preference for Routing Preference.

5 To use a different size for the new run, specify a new size.

   If you use a different size for the new run, a transition fitting is inserted to connect the new duct to the existing duct. If the duct layout preference is not configured with an appropriate transition fitting, you are prompted to choose a part.

6 To use a different shape for the new run, specify a new shape for Shape.

   If the duct layout preference is not configured with an appropriate transition fitting, you are prompted to choose a part.

7 Continue specifying points to lay out the run.

**Starting Along a Duct**

8 To start a run at a point along a duct segment, move the cursor over the existing duct segment to display the duct curve connector snap.

9 Click the duct curve connector to specify the start point for the new run.

   Based on the connection type configured in the duct layout preference, a takeoff or tee is inserted.

10 Continue specifying points to lay out the run.
Ending a Run on an Existing Duct

11 To connect a run to an existing segment, move the cursor over the existing duct segment to display the duct curve connector or duct end connector.

12 Click the duct curve or duct end connector to specify the endpoint of the run and connect to the existing segment.

Closing the Add Ducts Command

13 In the Add Ducts dialog, click Close.

Connecting a Duct Run to Equipment

Use this procedure to connect a duct run to equipment. When you start or end a run at a piece of equipment (MvPart), the start point or endpoint snaps to the nearest connection point on the MvPart. Simple MvParts, such as terminals, fans, and humidifiers, contain only one connection point. However, many of the more complex types of MvParts, such as tanks and pumps, contain multiple connection points. Some MvParts even have connection points that belong to different domains, such as a furnace that has both duct and pipe connection points.

NOTE This procedure assumes that you have placed equipment in your drawing. For more information, see Adding HVAC Equipment on page 195.

To connect a duct run to equipment

1 In the HVAC workspace, do one of the following:
   ■ Click Home tab ➤ Build panel ➤ Duct drop-down ➤ Duct .
   ■ Open the Duct tool palette, and select a duct tool.
   
   If you select a duct tool with a specific, predefined system (for example, the Supply - Low Pressure tool), the duct that you draw inherits the system’s properties, such as its design parameters, display properties, and rise and drop style.

2 With AutoCAD MEP snaps enabled, select a starting point for the segment at the connector of an MvPart, and continue selecting points to draft the run as necessary.
   
   The default run direction of the duct is dependent on the connector assigned to the MvPart. Typically, the run direction is perpendicular to the connector face of the MvPart.

   The type of connector assigned to the MvPart and the connector rules specified in the drawing determine the type of segment that can be connected to the MvPart.

3 When you finish drafting your run, press ENTER.

Adding Duct Using Grips

Use this procedure to draw duct runs using the add grips on ducts, fittings, and MvParts. Using an add grip is an efficient way to quickly begin drawing a duct run, and it ensures connectivity between the object and duct run.

Some fittings also contain add grips that enable you to create a new branch directly from the fitting. For example, an elbow has add grips you can use to automatically convert the elbow to a tee, and you can draw a duct run directly from the new tee connection. The existing duct branches remain connected to the other tee connections.
1 Select the object in the drawing, and click the add grip to begin drawing a duct run:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>start a run from one of the ends of a duct segment</td>
<td>click the add grip at one end of the segment.</td>
</tr>
<tr>
<td>start a run from the midpoint of a duct segment</td>
<td>click the add grip at the midpoint of the segment. A tee or takeoff is automatically inserted, depending on the connection specified for duct layout preferences.</td>
</tr>
<tr>
<td>start a run from an MvPart</td>
<td>click the add grip on the MvPart connection.</td>
</tr>
<tr>
<td>start a run from a fitting, such as an elbow or tee</td>
<td>click the add grip pointing in the direction of where you want to start the new run.</td>
</tr>
</tbody>
</table>

2 In the Add Ducts dialog, if you start from an MvPart, specify a system type for System.

3 If you start from a duct segment or fitting, the new run inherits the system.

4 If you change the size before specifying the first segment of the new run, a transition is automatically inserted between the object and new duct segment after you specify the first point of the new run.

   If the appropriate transition is not configured in the routing preference, you are prompted to choose a part.

5 Continue specifying points for the duct run layout geometry.

6 In the Add Ducts dialog, click Close.

### Drawing a Vertical Duct Run

Use this procedure to add a vertical run to a duct run.

1 Start the Add Ducts command, and begin laying out the duct run.
   For basic information on laying out a duct run, see Drawing a Duct Run on page 196.

2 Specify the point in the layout where you want to start the vertical segment.

3 In the Add Ducts dialog, specify the elevation of the endpoint of the vertical segment.

4 Continuing specifying points for the duct run geometry.

5 In the Add Ducts dialog, click Close.

### Drawing 1-Line Duct

Use this procedure to draw 1-line duct systems to configure preliminary routes and connect mechanical equipment placed in the drawing. 1-line ducts are added as undefined duct components and displayed as a single line. They act as placeholders for the eventual defined duct components.

In order to ensure connectivity between objects in the system, use AutoCAD MEP snaps to snap objects to connections.

This procedure provides quick instructions for drawing 1-line duct systems. For complete information on drawing ducts, see Drawing a Duct Run on page 196.
1 Open the Add Duct dialog:
   **If you want to...**    **then...**
   draw duct directly from an MvPart    select the MvPart and click the Add Duct grip for the connection you want to draw from.

   draw duct from any point    select the 1-Line tool on the Duct tool palette in the HVAC tool palette group.

2 In the Add Ducts dialog, verify that Connection Type and Shape are set to Undefined.
3 Specify a type for System.
4 Specify a defined elevation for Elevation, or enter a height value for Elevation. If you are drawing from an Add Duct grip on an MvPart, the duct automatically assumes the elevation from the MvPart.
5 Specify points to place the duct run.

   **NOTE** To align duct with parts or building geometry, use tracking as you draw. Tracking works with both object snaps and AutoCAD MEP snaps.

   Use AutoCAD MEP snaps when connecting a duct run to an MvPart. If you are connecting to a part, especially one on a different elevation than the duct run, more than one routing option may be offered. It can be helpful to use 2 viewports to get an accurate preview of each routing option. For example, the Aebc Model drawing template includes a Work layout tab where the workspace is configured for 2 viewports.
To create a new duct run, click New Run in the Add Duct dialog. You can use AutoCAD MEP snaps to draw new branches on duct segments. You can also use add grips on MvParts, ducts, and duct fittings to create new runs.

You can insert 1-line duct fittings. Use the 1-Line tool on the Fitting tool palette, or use a duct fitting tool on the same palette and specify the Placeholder fitting from the Duct and Fittings catalog.

Top view of a simple 1-line system. A VAV box is connected to 4 air diffusers.

When you have completed the 1-line layout for a system, check connectivity to ensure the system is connected. Select any part of the system, right-click, and then click Connected Objects ➤ Show Connected Run. If any part of the system is not connected, duct size tools will either not work or will provide inaccurate results.

You can use location grips on ducts, duct fittings, and MvParts to move parts of a system. For more information on modifying the layout of duct systems, see Modifying a Duct System on page 219.

You can use the duct system size calculator to convert 1-line systems to sized 2-line systems. For more information, see Calculating Duct Sizes for a Duct System on page 203.

**Calculating Duct Sizes for a Duct System**

Use this procedure to calculate duct sizes for a system. You can use the duct system size calculator to calculate sizes for both undefined 1-line or defined 2-line systems. In order to calculate duct sizes, you must assign flow values to all outlet parts in the duct system. Calculations are performed using the method and design parameters specified in the duct system definition. For more information, see Duct Sizing Methods and Tools on page 169.

You can calculate sizes for an entire system, or you can calculate sizes for selected portions of a system. If you modify a portion of a system, you can run the duct size calculator again.

1 Select any object in a connected system.
An example of a 1-line system.

2 Click Duct Flex tab or Duct tab ➤ Calculations panel ➤ Calculate Duct Sizes 📊.

3 In the Duct System Size Calculator, specify which ducts to size:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>size all objects in a system</td>
<td>select Calculate complete system.</td>
</tr>
<tr>
<td>size selected objects</td>
<td>select Calculate selected objects, click ➡️, and select the objects you want to size. Press enter.</td>
</tr>
</tbody>
</table>

4 Specify the shape for the sized ducts:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>specify the same shape for all parts</td>
<td>select All and specify a shape.</td>
</tr>
<tr>
<td>specify different shapes for the trunk and runouts</td>
<td>select Individual. Specify a shape for Trunk and for Runouts. Note that there must be a fan at the start of the system to use the Inherit from Fan shape for Trunk.</td>
</tr>
<tr>
<td>specify the runouts to use the same shape and size as the air terminal connection</td>
<td>select Use shape and size from air terminals on runouts. Note that this deactivates Runout shape if you are specifying individual shapes for the trunk and runouts.</td>
</tr>
</tbody>
</table>

**NOTE** If you are sizing ducts with defined shapes, you cannot change their shape. You can calculate sizes, but you cannot override the shapes already assigned to the ducts.

5 Specify design parameters to apply to this calculation:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>use different parameters than those specified in the HVAC System Definitions style</td>
<td>select Override design parameters from system definition(s). Select the parameter (Velocity or Friction) to change, and enter a new value. These values are only used for this specific calculation. The system definition values remain the same, and are used on all subsequent calculations.</td>
</tr>
<tr>
<td>specify a maximum diameter for round ducts</td>
<td>select Round max. size and enter a value. If a duct must be larger than this diameter to meet flow requirements, specify Rectangular or Oval for For larger size. The height of the rectangular or oval duct will not exceed the maximum round size.</td>
</tr>
</tbody>
</table>
If you want to... then...

| Specifying a maximum height for rectangular or oval ducts | Select Rectangular/Oval Max. Height and enter a value. |
| Specifying which duct sizes to use from the duct catalog | Select All, 1 inch increment, or Even sizes only. |
| Applying duct size calculations to any objects in the system that already have a defined shape | Select Apply sizing to parts with defined shape. |

6 Click Start.

7 When the calculations are complete, the system is resized in the drawing.

The example drawing converted to a sized 2-line duct system.

If any errors occurred during calculations, click View Event Log to see a description of the error.

Note that duct segments are not broken into multiple segments. The calculated duct size is applied to the entire duct segment. For example, you may want to reduce the duct size at all points where the system services 2 air diffusers. To refine your system, you can break a duct into segments and recalculate sizes. For more information on breaking duct, see Breaking or Merging Duct on page 234.

**Adding a Duct Fitting Manually**

Typically, AutoCAD MEP adds fittings as you draw a duct run based on the default fittings specified in the duct layout preferences. However, you can also add them manually. You can add a fitting to an existing segment or run. You can also add a fitting from which to start a segment or run, or to customize the connection to a part.

You manually add duct fittings using the tools on the Fitting tool palette in the HVAC tool palette group. You select a tool, use the Add Duct Fittings dialog to select the fitting and configure its properties, and then add the fitting to the drawing.

**To manually add a duct fitting**

1 In the HVAC workspace, do one of the following:
   - Click Home tab ➤ Build panel ➤ Duct Fitting drop-down ➤ Duct Fitting.
   - Open the Fitting tool palette, and select a fitting tool. If necessary, scroll to display the tool.
The software displays the Add Duct Fittings dialog, which displays a tree view of the current catalog.

2 The software opens the catalog at a part type folder associated with the fitting tool you selected. If necessary, navigate to the appropriate folder for the type and shape of fitting you want.

3 Select a part subtype (a fitting subtype) in the part type folder. Click Display/Hide additional part parameters to display or hide table details in this dialog.

4 Click Details to view the sizes available for the selected subtype.

5 Some subtypes have large numbers of available sizes. If necessary, filter the list by clicking the Part Filter tab and specifying the filtering criteria.

6 Select a part (a fitting) for Part Size Name.

7 Select a defined elevation or enter a value for Elevation.

NOTE The elevation is applicable when you are connecting the fitting to a vertical or riser segment. If you are connecting the fitting to a horizontal segment, you do not enter an elevation. The software places the fitting at the same elevation as the segment to which it is connected.

8 Specify an insertion point in the drawing. You can connect the fitting to a segment or insert it as a stand-alone object.

9 Use the compass to specify a rotation angle.

10 Repeat the preceding 2 steps to add additional fittings with the same properties.

11 Press ENTER to end the command.

NOTE You can apply turning vanes to duct fittings to reduce pressure loss. In plan view, turning vanes are displayed on fittings as annotation. For more information, see Adding Turning Vanes to Fittings on page 214.

Drawing Flexible Duct

NOTE For information on configuring the display properties of flexible duct, see Flexible Duct Runs on page 167.

1 In the HVAC workspace, do one of the following:
   - Click Home tab ➤ Build panel ➤ Duct drop-down ➤ Flex Duct .
   - Open the Duct tool palette, and select the Flex Duct tool.

You can draw flexible duct runs directly from an MvPart or duct using add grips. When you press Ctrl while selecting an Add grip on a part, the Add Flex Duct dialog opens.

2 For Segment Mode, click Line, Arc, or Spline.
   For information about Spline, see “Draw Splines” in AutoCAD Help.

3 You can specify a system and an elevation.

4 You can specify the offset if you are using the line segment mode.

<table>
<thead>
<tr>
<th>If you want to specify...</th>
<th>then select...</th>
</tr>
</thead>
<tbody>
<tr>
<td>the horizontal offset</td>
<td>Left, Right, or Center. Enter the distance of the run from the wall or other horizontal object.</td>
</tr>
<tr>
<td>the vertical offset</td>
<td>Top, Center, or Bottom. Enter the distance of the run from the ceiling or other vertical object.</td>
</tr>
</tbody>
</table>

5 Specify the connection type and diameter.
6 Specify a start point.
   If using Spline segment mode, specify a start tangent point or press ENTER for none.

7 Continue to specify points to add more segments to the run.
   To switch between segment modes during layout, enter l (line) to draft a line segment, enter a (arc) to draft an arc segment, or enter sp (spline) to draft a spline segment.
   Line and arc segments are joined together to create a single segment in the run. Spline segments remain separate segments in the run.
   To switch between planes during layout, enter p (plane) to toggle between the X, Y, and Z axes.

8 When you finish drafting the run, press ENTER.
   If drafting a spline segment, specify an end tangent point or press ENTER for none. The flexible run is displayed.
   If drafting a line or arc segment, press ENTER or click Close. The flexible run is displayed.

   **NOTE** To draft multiple flexible runs, click New Run to end the current run and start drafting a new run without ending the command.

---

**Adding a Parallel Duct Run**

Use this procedure to draw a duct run parallel to an existing duct run. You can use justification in the Add Ducts dialog to offset a new duct run from an existing run. When you draw the parallel run, you select points on the existing run, and the new parallel run is created at the offset distance. You can select points on the existing run using object snaps or AutoCAD MEP snaps.

**NOTE** Drawing a parallel duct run may be easier if you use a 1-line display for the existing duct run. This reduces the potential number of points to pick, and allows you to accurately select transition points. To view a duct system as 1-line, change the current display configuration. The Mechanical - Duct 1-line display configuration included with the default Aecb Model drawing template is configured to show duct segments and fittings as 1-line.

1 Start the Add Ducts command.
   For basic information on laying out a duct run, see Drawing a Duct Run on page 196.

2 In the Add Ducts dialog, specify the offset:

   **If you want to** | **then**
   --- | ---
   offset the new run at a horizontal distance (X or Y direction) from the existing run; both runs are at the same elevation | for Horizontal, specify a value for Offset. To offset the new run in a positive X or Y direction from the existing run, enter a positive value. To offset in a negative X or Y direction, enter a negative value.
   offset the new run at a vertical distance from the existing run; both runs have the same X-Y dimensions, but are at different elevations | for Vertical, specify a value for Offset. To offset the new run in a positive Z direction from the existing run, enter a positive value. To offset in a negative Z direction, enter a negative value.

3 In the drawing, select a point on the existing duct run.
   You can use AutoCAD MEP snaps to select duct connectors, or object snaps to select points on duct geometry.

4 Continue selecting points along the duct run.

5 In the Add Ducts dialog, click Close.
**Offsetting Duct from Existing Geometry**

Use this procedure to draw a duct run that is offset at a specified distance from existing geometry. For example, you can draw a duct run that is offset a specific distance from a wall in a referenced drawing. The geometry can be AutoCAD lines or blocks, AutoCAD Architecture building objects, or AutoCAD MEP objects, and the geometry can exist in a reference drawing. You can select points on the geometry using snaps.

1. Start the Add Ducts command.
   
   For basic information on laying out a duct run, see Drawing a Duct Run on page 196.

2. In the Add Ducts dialog, specify the offset:

<table>
<thead>
<tr>
<th>If you want to</th>
<th>then</th>
</tr>
</thead>
<tbody>
<tr>
<td>offset the new run at a horizontal distance (X or Y direction) from the geometry; the geometry and duct run are at the same elevation</td>
<td>for Horizontal, specify a value for Offset. To offset the new run in a positive X or Y direction from the existing geometry, enter a positive value. To offset in a negative X or Y direction, enter a negative value.</td>
</tr>
<tr>
<td>offset the new run at a vertical distance from the geometry; both have the same X-Y dimensions, but are at different elevations</td>
<td>for Vertical, specify a value for Offset. To offset the new run in a positive Z direction from the geometry, enter a positive value. To offset in a negative Z direction, enter a negative value.</td>
</tr>
</tbody>
</table>

3. In the drawing, select a point on the geometry.
   
   You can use object or AutoCAD MEP snaps to select points on geometry.

4. Continue selecting points along the geometry.

5. In the Add Ducts dialog, click Close.

**Drawing Sloped Duct**

Use this procedure to draw a duct run with a vertical slope. For information on specifying the slope, see Configuring Sloped Duct on page 175.

1. Start the Add Ducts command, and start laying out the duct run.
   
   For basic information on laying out a duct run, see Drawing a Duct Run on page 196.

2. Specify the point in the layout where you want to start the sloped portion of the run.

3. In the Add Ducts dialog, under Layout Method, select Use Rise/Run.

4. Specify the end point for the sloped segment.

5. To turn off sloped layout and return to horizontal runs, under Layout Method, select Use Routing.

6. Continuing specifying points for the duct run geometry.
   
   If you add a vertical segment at the end of a sloped segment, you may be prompted to choose a part. If a fitting with the proper angle does not exist, you can accept the creation of a custom transition.

7. In the Add Ducts dialog, click Close.

**Using the Elevation Lock**

Use this procedure to lock the elevation while drawing a duct run. This restricts the duct run to the specific elevation, and can avoid undesirable effects when drawing a duct run. For example, you may unintentionally snap to another object at a different elevation. Another case may occur when you try to connect a horizontal
run to a vertical segment. Your segment may try to snap to one end of the vertical segment instead of connecting along the segment at the desired elevation. To avoid these situations, you can lock the elevation.

You can turn on the elevation lock for a portion of a duct run, and turn it off for other portions where you want to use different elevations. If the lock is turned on, you cannot connect to an object on a different elevation. You must turn the elevation lock off before connecting the objects.

By default, the lock is turned off each time you start the Add Ducts command.

1 Start the Add Ducts command.
   For basic information on laying out a duct run, see Drawing a Duct Run on page 196.

2 In the Add Ducts dialog, next to the elevation value, click the unlock button.
   The button changes to show that the lock is on.

3 Specify points for the duct run.

   **TIP** To connect a horizontal duct to a vertical duct, move the cursor over the vertical segment to get a duct curve connector, and click on it. If you have difficulty achieving the desired connection, try using a different view, such as a side or isometric view, when connecting the horizontal duct run to the vertical segment.

4 To turn off the elevation lock, click the lock button.
   The button changes to show that the lock is off.

5 In the Add Ducts dialog, click Close.

**Connecting Ducts Through Referenced Drawings**

Use this procedure to connect duct systems in a current drawing with duct systems in referenced drawings. For example, a design for a multi-floor building includes a rooftop air conditioning unit. A medium velocity supply air duct runs vertically from the bottom of the AC unit to the ground floor. You can connect a system for each floor with the vertical supply air trunk even if the trunk exists in a reference drawing. The fittings needed to connect the floor system with the trunk are automatically saved in the reference drawing.

**IMPORTANT** You can connect to objects in an xref, but any modifications to connected objects in the current drawing will not be propagated through to the xref drawing. For example, a duct run in the current drawing is connected to duct in an xref drawing. If you modify the duct size in the current drawing, only the duct in the current drawing is modified.
Simple duct systems on separate floors connected to a vertical trunk in a reference drawing.

1 Verify that the xref containing the duct system is loaded in the drawing, and verify that the reference drawing itself is not open.

2 Draw a duct run to connect your duct system with the duct system in the reference drawing. Use the Lock Elevation icon in the Add Duct dialog to connect the duct run to the reference object at the same elevation as the duct run. If you do not lock the elevation, the duct run is likely to connect to a duct end connector on the reference object.

Use a duct curve or duct end connector to connect with the reference duct.

**NOTE** It can be helpful to use 2 viewports to get an accurate preview of the routing and connection point with the reference duct.

3 Click Yes when prompted by the Save to Xref dialog.

Note that the changes are permanently saved to the duct in the reference drawing.
Adding a Takeoff to a Duct

Takeoffs enable you to position a fitting at any location on a duct segment. You attach the takeoff to the center line or curve of the segment, and then rotate the takeoff to a specified angle around the segment.

You can also position the takeoff off center from the center line or curve of the segment, referred to as an off-center takeoff. For example, you can attach the takeoff to the side of a duct segment above the center line. The offset distance is defined as the distance from the center line of the duct segment to the center line of the takeoff fitting.

**TIP** When attaching takeoffs, it is helpful to work in an isometric view of your model.

**To add a takeoff to a duct segment**

1. In the HVAC workspace, open the Fitting tool palette, and select the Takeoff tool. If necessary, scroll to display the tool.
   The software displays the Add Duct Fittings dialog showing a tree view of the current catalog.
2. The software opens the catalog at a part type folder associated with the Takeoff tool. If necessary, navigate to the appropriate folder for the shape of takeoff you want.
3. Select the takeoff fitting to add.
4. Select a size for Part Size Name.
5. In the drawing, specify a location along the length of the duct segment to place the takeoff.
6. To add an off-center takeoff, skip to Step 11.
7. Specify the placement preferences:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>toggle the compass on or off as you position the takeoff</td>
<td>right-click in the drawing area, and click Compass.</td>
</tr>
</tbody>
</table>
If you want to... then...

change the location of the takeoff along the length of the duct segment right-click in the drawing area, and click Slide. Drag the fitting along the duct segment, and select a new location.

8 Specify the rotation angle:

<table>
<thead>
<tr>
<th>If you want to specify the...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>rotation angle on the Y axis</td>
<td>right-click, and click rotate Y. Drag the takeoff around the Y axis, and select a position. You can also enter a number for the angle.</td>
</tr>
<tr>
<td>rotation angle on the Z axis</td>
<td>right-click, and click rotate Z. Drag the takeoff around the Z axis and select a position. You can also enter a number for the angle.</td>
</tr>
<tr>
<td>rotation axis on the command line</td>
<td>enter Y for rotate Y, or enter Z for rotate Z.</td>
</tr>
</tbody>
</table>

9 Press ENTER to end the command.

10 To add an off-center takeoff after you specify the location on the duct, right-click in the drawing area, and click Offcenter. The Off Center tab is displayed in the Add Duct Fittings dialog, and Enable off center placing is selected.

11 Specify the position of the takeoff:

<table>
<thead>
<tr>
<th>If you want to specify the...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>side of the duct segment to which to attach the takeoff</td>
<td>in the dialog, click the Side cell, and select a location around the duct segment: center, top, bottom, left, or right.</td>
</tr>
</tbody>
</table>

**NOTE** The left and right sides of the duct segment are determined by the direction the segment was drafted.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>justification of the takeoff</td>
<td>in the dialog, click the Justification cell, and select left, center, right, top, or bottom depending on the specified side.</td>
</tr>
<tr>
<td>off-center distance</td>
<td>in the dialog, click the Offset cell, and enter a number for the offset distance.</td>
</tr>
</tbody>
</table>

**NOTE** The offset is measured from the justification (left, right, center, top, or bottom) of the duct segment.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>position of the takeoff by sliding around the duct segment</td>
<td>in the drawing, specify a side and justification, drag the takeoff around the segment, and select a position.</td>
</tr>
<tr>
<td>rotation angle</td>
<td>in the drawing, drag the fitting around the X axis, and select a location. Right-click in the drawing area, and click Rotate Y or Rotate Z to change the rotation axis. You can also enter a specific angle.</td>
</tr>
</tbody>
</table>
12 Specify the rotation angle around the duct segment:

<table>
<thead>
<tr>
<th>If you want to specify the...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>rotation angle on the X axis</td>
<td>click the X cell under Rotate Around, drag the takeoff around the X axis, and then select a position. You can also enter a number for the angle.</td>
</tr>
<tr>
<td>rotation angle on the Y axis</td>
<td>right-click in the drawing area, and click rotate Y. Drag the takeoff around the Y axis, and then select a position. You can also enter a number for the angle in Y under Rotate Around in the Add Duct Fittings dialog on the Off Center tab.</td>
</tr>
<tr>
<td>rotation angle on the Z axis</td>
<td>right-click in the drawing area, and click rotate Z. Drag the takeoff around the Z axis, and then select a position. You can also enter a number for the angle in Z under Rotate Around in the Add Duct Fittings dialog on the Off Center tab.</td>
</tr>
</tbody>
</table>

13 Press ENTER to exit the command.

**TIP** Once you have added the takeoff, you can rotate it using Rotate grips.

## Converting a Line to Duct

Use this procedure to convert a line into a duct run using the Duct Convert command. You can define the path of a segment with an AutoCAD® line and then convert this line into a duct segment.

**To create a duct segment from a line**

1. Define the curve of the segment path with the AutoCAD Line command.
2. On the command line, enter **ductconvert**.
3. Select the line you want to convert, and press ENTER.
4. Do one of the following:
   - Press ENTER or enter **n** (no) to leave the layout geometry in the drawing.
   - Enter **y** (yes) to erase the layout geometry from the drawing.
5. In the Modify Duct dialog, specify a System, Elevation, Shape, Part, and Size, and then click OK. If you specify a flow capacity for the duct, you can calculate size using the instant sizing tool. See **Modifying Duct** on page 232 for more information.

## Converting a Polyline to Flexible Duct

Use this procedure to convert a polyline, line, arc, or spline into a flexible duct or run using the Convert Flex Duct command. You can define the path of the run using polylines, lines, arcs, splines, or a combination of these objects, and then convert these objects into a flexible duct run.

**To create flexible run from a polyline**

1. Define the curve of the layout path with either the AutoCAD Fillet or Spline command.
2. Select the polyline, line, arc, or spline you want to convert, right-click, and click Convert to ➤ Flex Duct.
3 Do one of the following:
   ■ Press ENTER or enter n (no) to leave the layout geometry in the drawing.
   ■ Enter y (yes) to erase the layout geometry from the drawing.

4 In the Modify Flex Duct dialog, specify a System, Elevation, Size, and Part, and then click OK.

Adding Turning Vanes to Fittings

Use this procedure to add turning vanes to a fitting. Vanes are considered annotation, and are not considered objects. You can add vanes to all fittings, or only to specific fittings.

To add vanes to fittings

1 Enable vanes in the duct layout preferences.
2 Select a fitting to which you want to add vanes.
3 Click Duct Fitting tab ➤ Duct Vanes panel ➤ Add Vanes.
4 The vane settings are displayed in the command line window.
   To change the settings, enter s (settings), and specify the vane settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>radius</td>
<td>radius of curvature for the vanes</td>
</tr>
<tr>
<td>arc angle</td>
<td>determines the size of the vane arc relative to the circular path that defines the vane; for example, 45 degrees is 1/8 of the circular path</td>
</tr>
<tr>
<td>number of vanes</td>
<td>total number of vanes to add to each fitting; the vanes are spaced equally along the vane path</td>
</tr>
<tr>
<td>Setting</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>mirror current vanes</td>
<td>for tees; mirror the first set of vanes around a specified line</td>
</tr>
<tr>
<td>keep vane path</td>
<td>displays vane path on the fitting; specify no to not show the vane path</td>
</tr>
</tbody>
</table>

5 When prompted to select a start point, specify the inside corner of the fitting.
6 Specify the outside corner of the fitting as the vane path endpoint.
   Vanes are added to each fitting of the same size and subtype.
7 If you are mirroring vanes, specify the start and endpoints of the mirror line.
   A second set of vanes is added to the tee.

**TIP** To apply or remove turning vanes on selected fittings, select a fitting, and click Duct Fitting tab ➤ Modify panel ➤ Duct Fitting Properties 📱. In the Duct Fitting Properties dialog, click the Vanes tab, and select or clear Enable Vanes.

**Creating a Custom Duct Fitting**

You can create a custom fitting when a required fitting is not available from the part catalog or you have a unique design situation. You create custom fittings by converting AutoCAD® lines, arcs, and polylines into AutoCAD MEP objects with connectors. Part properties, such as size, shape, and system definition are inherited from the connecting parts to maintain system integrity. Custom fittings are style-based objects accessible through the Style Manager. Each custom fitting you create represents a single style.
NOTE Custom fittings cannot be added to a part catalog. If you create a custom fitting to be used multiple times, you can share custom fittings between drawings using the copy and paste functionality.

Before you create a new custom fitting, you need to draw the centerline of the fitting you want to create. Typically, the centerline is drawn connecting ductwork and can be any combination of AutoCAD lines, arcs, or polylines.

**Defining a custom fitting polyline centerline**

![Diagram](image)

**To create a custom fitting**

1. Draw the centerlines of the new custom fitting with lines, polylines, or arcs.

   **NOTE** If you draw linework from endpoints of an existing duct, the shape and size of the duct is inherited by the end segment of the fitting that you create.

2. Click Home tab ➤ Build panel ➤ Duct Fitting drop-down ➤ Duct Custom Fitting.
3 Select the polylines, lines, or arcs that represent the centerline of the custom fitting, and press ENTER.

![Create Duct Custom Fitting dialog]

4 In the Create Custom Fitting dialog, enter a name, and then select a system.

5 Specify the shape and size for the start and end of each segment, and then select Mitered End if an end is mitered.

   Use the Object Viewer to view the segment you are specifying properties for. As you step through the Create Custom Fitting dialog, the Object Viewer highlights the current segment.

6 If the properties assigned to the current segment are the same for all segments, select Apply to All Segments.

7 If the properties of the next segment are different from those of the current segment, click Next. The Next button is not available if you select Apply to All Segments.

8 Click Finish, and enter y (yes) to erase the original centerline geometry or n (no) to keep the original geometry in the drawing.

9 Press ENTER.

   **NOTE** If any size or shape properties of the segments are incomplete, the custom fitting cannot be created and the Missing Size or Shape Information error message is displayed.

---

**Using the Part Size Not Found Dialog**

Sometimes, when adding or modifying a part, the size that you define does not fit the criteria defined in the part catalogs. In these cases, you are prompted with the Part Size Not Found dialog. Use this dialog to select an alternate size definition for the part.

The top portion of the dialog indicates the size criteria that is incompatible with the part you defined. For example, you specify a height for a takeoff. If the values that you define in the part filter are not matched within the catalog, you can create a custom size.

**NOTE** Not all parts that are included in the program support custom sizing.

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>use a part from the catalog</td>
<td>select a part size from the list, and click Use selected part size from catalog.</td>
</tr>
<tr>
<td>create a new part to maintain the values that you defined</td>
<td>click Create custom sized part.</td>
</tr>
<tr>
<td>use the values that you defined for the part, and allow an invalid connection to be made</td>
<td>click Ignore and continue.</td>
</tr>
</tbody>
</table>
NOTE In contrast, the Multiple Parts Sizes Found dialog appears when the current catalog contains multiple sizes specified for a part that you are trying to insert. Choose the desired size from the list of available catalog part sizes that match the specified nominal size specified.

Annotating a Duct System

You can add annotation, such as labels and flow arrows, to duct systems in a drawing. For information on adding more advanced annotation, such as tags, schedules, cross-sectional views, and details, see Creating Construction Documents on page 547.

Adding a Label to a Duct

Use this procedure to manually add a label or flow arrow to a duct. The label styles can be configured to display properties such as duct diameter or system type. For more information on label styles, see Modifying a Label Style on page 555.

1 In the HVAC workspace, do one of the following:
   - Click Annotate tab ➤ Label panel ➤ MEP Label .
   - Open the Annotation tool palette, and select a label tool.

2 On the Properties palette, under General, for Style, specify a style from the drop-down list.

3 Under Layout Method, specify how many labels or flow arrows to add to each duct segment you select, as follows:

<table>
<thead>
<tr>
<th>If you want to</th>
<th>then</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify the total number of labels or flow arrows to display on each duct segment</td>
<td>select By quantity, and enter a value for Number of labels. Note that the number of labels or flow arrows is automatically added to each straight segment.</td>
</tr>
<tr>
<td>Insert a label or flow arrow at a uniform interval on each duct segment</td>
<td>select By distance, and enter a value for Distance between. Note that if a duct segment length is less than the interval distance, a label or flow arrow is not added to that segment.</td>
</tr>
</tbody>
</table>

Flow Arrows Spaced Evenly, 1 per segment

Flow Arrows Repeated at a Uniform Interval

4 In the drawing, select the objects you want to label, and press enter.

5 If you specified One by one for the layout method, specify the location on the duct to add the label.
By default, the label is placed along the duct segment. Press Ctrl before specifying the label location to move the label off the duct.

6 In the Add Labels dialog, click Close.

You can add, modify, or delete labels using grips. For more information, see Modifying a Label on page 239. You can also configure duct preferences to automatically add labels and flow arrows as you draw duct runs. For more information, see Adding Labels or Flow Arrows to Ducts on page 177.

Adding a Hatching Pattern to Identify a Duct System

Use this procedure to add hatching patterns to duct systems so that you can easily identify separate systems on complex drawings. For example, you can specify different hatch patterns for supply and return duct systems.

1 In the drawing that contains the duct systems, click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ HVAC System Definitions.
2 Select a duct system.
3 In the right pane, select the Display Properties tab.
4 Double-click Plan under Display Representations.
5 In the Display Properties dialog, select the Layer/Color/Linetype tab.
6 Select Hatch under Display Component, and specify it as visible.
7 Click the Hatching tab, and specify a hatch pattern.
8 Click OK 3 times.

Modifying a Duct System

The topics in this section offer specific instructions on how to modify all aspects of a duct system. You can modify duct systems in your drawings at any point during the design process.

About Associative Movement

You can move MvParts, fittings, or duct segments without breaking the connection with the rest of the system. This feature is called associative movement. Used in conjunction with certain grips, associative movement enables you to move a component quickly and accurately in a duct run.

For example, you can move an MvPart to a new location. The duct segments attached to the MvPart can move, shrink or stretch to maintain a connection with the system. You can also move a duct segment without affecting the location of MvParts or other portions of the run.

Selecting Components

You must select a component in order to modify it. There are several ways you can select one or more components in a drawing:

- Move the cursor over an object, and click to select it.
- Click outside an object or group of objects, drag a bounding box around the desired objects, and click a second time to select all objects that are completely within the bounding box.
- Use the Select Similar command to select all other objects in the drawing that have the same part subtype, size, and system as the selected object.
Use the Select Connected Branches command to select all components of a duct run, or a portion of the duct run.

Use a bounding box to select a group of objects, and use the Properties palette to modify settings for a particular part type.

To select connected branches

1. Select a duct or fitting.
2. Click [Duct, Duct Flex, or Duct Fitting] tab ➤ General panel ➤ Select System drop-down ➤ Select Connected Branches .
3. Press tab to cycle through the connection options.
4. When the desired branch is highlighted, press enter.
5. Repeat the preceding 2 steps to select other branches, even if they are not connected to the original duct system.
6. Press enter to select the branches.

To filter selections in the Properties palette

7. Use a bounding box to select multiple objects.
8. In the Properties palette, on the Design tab, select the part type from the drop-down list at the top.
9. Edit the part properties available for that part type.

To deselect objects

10. Press Esc.

Modifying Components Using Grips

You can use grips to quickly and accurately modify any component in a duct system. With associative movement, you can also change locations for parts in a duct run while maintaining connectivity with the rest of the system.

There are several grips you can use to modify components:

<table>
<thead>
<tr>
<th>Grip</th>
<th>Description</th>
<th>Available on</th>
</tr>
</thead>
<tbody>
<tr>
<td>add</td>
<td>Starts the Add Ducts command; allows you to draw new runs directly from the grip location</td>
<td>ducts, fittings, and MvParts</td>
</tr>
<tr>
<td>location</td>
<td>move a part</td>
<td>ducts, fitting, and MvParts</td>
</tr>
<tr>
<td>elevation</td>
<td>change elevation for a part</td>
<td>ducts, fittings, and MvParts</td>
</tr>
<tr>
<td>rotation</td>
<td>rotate a part around a duct centerline; also flip parts in place, usually to orient a part for flow direction</td>
<td>in-line or anchored MvParts, fittings, and takeoffs</td>
</tr>
<tr>
<td>lengthen</td>
<td>change the length of a duct</td>
<td>duct</td>
</tr>
</tbody>
</table>
Moving Duct Components

You can move duct segments, duct fittings, and parts using Location grips. If the object is connected to a system, you can choose to move connected objects to maintain connectivity. You can move the object in the current XY plane only.

**NOTE** For information on modifying the elevation, see *Modifying the Elevation of HVAC Parts and Ducts* on page 222.

**To move a duct segment, duct fitting, or part**

1. Select the object to move.
   
   An example of a Location grip for a duct segment.

2. Click the Location grip (blue square) on the selected object.

3. Specify the new location for the part:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>move the object while maintaining connectivity, and keep the location of MvParts fixed</td>
<td>click the Location grip and specify the new location for the object. Note that any MvPart remains fixed. If an MvPart is oriented along the same vector as the object, the object remains fixed also.</td>
</tr>
<tr>
<td>move the object while maintaining connectivity with connected objects, and move any MvParts oriented along the same vector as the object</td>
<td>click the Location grip and press <code>ctrl</code> once. Specify the new location for the object. Note that the MvPart moves with the object to a new location.</td>
</tr>
<tr>
<td>move the object by itself, breaking connectivity with the system</td>
<td>click the Location grip and press <code>ctrl</code> twice. Specify the new location for the object.</td>
</tr>
</tbody>
</table>

If you maintained connectivity, note that the connected objects in the same plane stretched in the direction of the move.
Moving an object using a location grip

NOTE If a duct segment is not connected to another object, you can change its angle and length using the Start or End grip.

The Start and End grips enable you to change the XYZ location of the start point or endpoint of the segment. This makes them particularly useful when initially designing duct runs because you can use them to easily connect a segment to an existing run.

Modifying the Elevation of HVAC Parts and Ducts

In side and isometric views, you can modify the elevation of HVAC parts and duct segments using Elevation grips ( ).

AutoCAD MEP displays Elevation grips on HVAC parts at their insertion points and connector points so you can easily modify their elevations and connect them to existing runs. The software displays a single Elevation grip on duct segments, but you use the grip to modify the elevation relative to the top, centerline, or bottom of the segment.

If the part or duct segment is connected to other objects, you must specify whether you want AutoCAD MEP to maintain their connectivity when you modify the elevation.
To modify the elevation of an HVAC part or duct segment

1. Change to a side or isometric on page 86 view.
2. Select the part or duct segment.
3. Select the Elevation grip to use.
4. If the part or duct segment is connected to another object, specify whether and how to maintain connectivity:

- **If you want to...**
  - maintain connectivity by adjusting only duct fittings and segments, and retain the current locations of parts
  - proceed to the next step.

- maintain connectivity by adjusting all objects, including parts
  - press **CTRL**.

- break connectivity
  - press **CTRL** twice.

5. Specify the new elevation:

- **If you want to...**
  - specify the new overall elevation relative to a point on the part or segment (for example, the centerline)
  - press **TAB** as many times as needed to activate the appropriate input field, and enter the resulting dimension. Press **ENTER**.

- raise or lower the elevation by a specified dimension
  - Drag the cursor to begin raising or lowering the elevation. Press **TAB** as many times as needed to activate the appropriate elevation input field, and enter the relative dimension. Press **ENTER**.
Modifying the elevation of a duct

1. Select duct segment.
2. Select elevation grip.
3. Input fields for relative dimension.
   - Specify point location.
4. Input fields for absolute dimensions.
5. Activate input field.

Press Ctrl to cycle between:
- Maintain connections
- Change elevation, fixed MIPs
- Change elevation, movable MIPs
- Break connection
- Change elevation
You can also modify the elevation by selecting the object, and selecting the corresponding component’s Modify command from Modify panel on the contextual ribbon tab, as appropriate. Then, in the Modify dialog you enter a new value for Elevation and click OK. When you use this method instead of Location grips, the software adjusts connected fittings and segments to maintain connectivity, but retains the locations of parts.

**NOTE** To use the dimension input fields, both dynamic input (on the application status bar) and the Dimension Input drafting setting must be enabled. They are enabled by default. If you have disabled them, you can specify the new elevation by dragging the cursor and specifying a point in the drawing, or by entering the coordinates in the command window.

### Modifying the Length of Ducts

You can modify the length of duct segments using Lengthen grips ( ). Because the grips constrain a segment to its current angle, they are particularly useful for modifying the lengths of ducts you have already placed.

When you use the Lengthen grip on an end connected to another object, you must specify whether you want AutoCAD MEP to maintain connectivity between the objects when you modify the length.
Lengthen grips on duct segments

NOTE For information on modifying the length of flex ducts, which do not have Lengthen grips, see Modifying the Layout of Flexible Duct on page 236.

To modify the length of a duct segment

1 Select the duct segment.
2 Select the Lengthen grip on the end you want to modify.
3 If the segment is connected to an object on the end you selected, specify whether and how to maintain connectivity:

   | If you want to... | then...
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>maintain connectivity by adjusting only duct fittings and segments, and retain the current locations of parts</td>
<td>proceed to the next step.</td>
</tr>
<tr>
<td>maintain connectivity by adjusting all objects, including parts</td>
<td>press CTRL.</td>
</tr>
<tr>
<td>break connectivity</td>
<td>press CTRL twice.</td>
</tr>
</tbody>
</table>

4 Specify the segment length:

   | If you want to... | then...
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>specify the new total length</td>
<td>press TAB to activate the input field for specifying the resulting dimension, and enter the new length. Press ENTER.</td>
</tr>
<tr>
<td>specify the difference between the current length and new length</td>
<td>Drag the cursor to begin lengthening or shortening the segment, and enter the change in length in the input field that is active by default. Press ENTER.</td>
</tr>
<tr>
<td>specify a new endpoint</td>
<td>drag the grip to the endpoint, and click to specify the point.</td>
</tr>
</tbody>
</table>
NOTE To use the dimension input fields, both dynamic input (on the application status bar) and the Dimension Input drafting setting must be enabled. They are enabled by default. If you have disabled them, you can specify the new length by selecting a stretch point in the drawing or entering one in the command window.

The following example illustrates how to modify the length of a duct segment. The horizontal duct segment is stretched to the right and doubled in length. Because the modification occurs in the moveable MvParts editing mode, connected objects including parts are adjusted to maintain their connectivity. More specifically, the vertical duct segment and the ceiling diffuser attached to its right branch are moved.

Lengthening a duct

select segment

select Lengthen grip, then select editing mode
NOTE If the duct segment is not connected to another object, you can change both its length and angle using the Start or End grip.

The Start and End grips enable you to change the XYZ location of the start point or endpoint of the segment. This makes them particularly useful when initially designing runs because you can use them to easily connect a segment to an existing run.

---

**Rotating Duct Components**

You can use the arrow-shaped ( ) Rotate grip to rotate HVAC in-line parts, duct fittings, and takeoffs 180 or 90 degrees in the direction indicated by the grip.
In isometric views, if the part, fitting, or takeoff has round connectors on opposite ends, you can also use the diamond-shaped ( ) Rotate grip to rotate the object around its centerline to any angle you specify.

AutoCAD MEP displays Rotate grips on all HVAC in-line parts, fittings, and takeoffs with connectors on opposite ends. However, when necessary to preserve the connectivity of duct runs, the software limits the available rotation options or hides the grips. For example, in the following illustration, you can rotate the wye fitting on the left in several ways, but you cannot rotate the wye fitting on the right due to the connected branch.

When you rotate a part, fitting, or takeoff that is connected to other objects, the software adjusts the connected objects to maintain their connectivity. For example, the software might make minor adjustments to the lengths of connected duct segments after you have flipped a fitting. If it cannot adjust the objects, it disconnects them.
To rotate an in-line part, fitting, or takeoff

1. Select the part, fitting, or takeoff.
2. Rotate the object:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>rotate the object 180 degrees (flip the object)</td>
<td>click the Flip grip (.flip).</td>
</tr>
<tr>
<td>rotate the object 90 degrees</td>
<td>while pressing CTRL, click the Flip grip (.flip).</td>
</tr>
</tbody>
</table>

**NOTE** If the part is rectangular or oval, the software automatically switches its height and width values.

<table>
<thead>
<tr>
<th>rotate the object to an angle you specify</th>
<th>click the Rotate grip (rotate), and do one of the following:</th>
</tr>
</thead>
<tbody>
<tr>
<td>■ enter the new absolute angle in the active dimension input field.</td>
<td></td>
</tr>
<tr>
<td>■ drag the cursor to reduce or increase the angle, click TAB to activate the dimension input field for specifying the angle change, and enter the value.</td>
<td></td>
</tr>
<tr>
<td>■ drag the grip to a new location.</td>
<td></td>
</tr>
<tr>
<td>■ enter the value in the command window.</td>
<td></td>
</tr>
</tbody>
</table>

---

### Modifying HVAC Equipment

You can modify an MvPart, such as its size, location, or system assigned to its connectors.

You can also use grips to efficiently move MvParts. For more information, see **Modifying Components Using Grips** on page 220.

**RELATED** See **Mechanical, Electrical, and Plumbing Equipment in Building Systems** on page 76.

### Modifying HVAC MvPart Location

Use this procedure to specify coordinates for the exact location of mechanical parts in a drawing. This procedure will not maintain connectivity with a system, but it does allow you to specify exact coordinates for the location of a part.

**NOTE** The most efficient way to move a part, especially relative to other objects in the building plan, is to use Location grips; the grips move a part while maintaining its connectivity to a duct system. For more information, see **Moving Duct Components** on page 221.

To move a part

1. Select the part, and click Equipment tab ➤ Modify panel ➤ Equipment Properties ➤ .
2. In the Multi-view Part Properties dialog, click the Location tab.
3. Select the coordinates (world or current) on which to base the location.
4 Specify the new location:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>specify exact coordinates for the location.</td>
<td>specify the X, Y, and Z coordinates under Insertion.</td>
</tr>
<tr>
<td>rotate the part around the X, Y, or Z axis</td>
<td>specify the X, Y, and Z values under Normal.</td>
</tr>
<tr>
<td>rotate the part in the current plane</td>
<td>specify an angle for Rotation.</td>
</tr>
</tbody>
</table>

Modifying HVAC Parts

Use this procedure to modify the mechanical equipment in a drawing. Changes to equipment might require changes to connecting ductwork, although in many cases the ductwork can be updated automatically.

To modify HVAC equipment

1 Select the part to modify.

   NOTE To change all similar parts at once, select a part, click Equipment tab ➤ General panel ➤ Select Similar , and then continue with the modification.

2 Click Equipment tab ➤ Modify panel ➤ Modify Equipment .

3 In the Multi-view Part Modify dialog, specify the changes:

   If you want to modify... | then...
   the part subtype | in the part type folder, select a different part subtype.

   NOTE You cannot change the type of part. To replace the part with one of a different type, erase the part and add a new one.

   the part size | select a different part for Part Size Name.

   the elevation | select a defined elevation or enter a value for Elevation.

   NOTE To modify the elevation of the part while maintaining its connection to ductwork, use Elevation grips instead. For more information, see Modifying the Elevation of HVAC Parts and Ducts on page 222.

   the airflow values for an outlet or supply device | click the Flow tab. For outlet devices, modify the airflow value for Flow; for supply devices, modify the airflow value for each connector.
Changing a Part to Match Another Part

Use this procedure to change an MvPart to match another MvPart in the drawing. You can change an MvPart of one type to match an MvPart of another type. For example, you can change a valve to a pump.

1. Select the MvPart you want to change.
2. Click Equipment tab ➤ Modify panel ➤ Modify Equipment.
3. In the Multi-view Part Modify dialog, click (Match) in the lower-left corner.
4. In the drawing, select the MvPart you want to match.
5. Press enter to match both the part and the elevation.
   In the Modify Multi-view Part dialog, you can also specify a different size for Part Size Name, or a different value for Elevation.
6. In the Modify Multi-view Part dialog, click Close.

To change the size of the MvPart, see Modifying HVAC Parts on page 231.

Modifying the Flow Value Assigned to a Part

Use this procedure to change or assign a flow value for devices such as fans, VAV boxes, and ceiling diffusers.

1. Select the part you want to modify.
2. Click Equipment tab ➤ Modify panel ➤ Modify Equipment.
3. In the Multi-view Part Modify dialog, click the Flow tab.

Modifying the System Assigned to a Part Connection

Use this procedure to change the system assigned to an MvPart connector. When you add an MvPart to a drawing, there are no systems assigned to its connectors. If you connect a duct run to an MvPart connector, the connector inherits the system setting from the connecting duct object.

You can specify the system for MvPart connectors. Then, if you use the add grip to begin drawing duct runs directly from the MvPart, the system is already specified for the new run.

If you change the system for an MvPart connector that is connected to a duct run, the system for the duct run changes to match that of the MvPart connector.

1. In the drawing, select the MvPart you want to modify.
2. Click Equipment tab ➤ Modify panel ➤ Equipment Properties.
3. In the Multi-view Part Properties dialog, click the Systems tab.
4. In the System column, click in the field for the connector you want to specify.
5. Select a system from the drop-down list.

Modifying Duct

After adding ductwork, you can modify the segments and runs based on design changes or layout requirements. You can move single objects or groups of connected objects. You can change the system, elevation, shape, size, and part type of a duct segment. You can also use the duct system size calculator and instant sizing tool to recalculate duct sizes as you modify and refine your systems. You can also change a duct fitting in a run, the position of an off-center fitting, or a custom fitting.
To enhance visual clarity in a drawing, you can assign hatching patterns to ductwork to easily identify different duct systems. For example, you can assign hatching patterns to ductwork that will be demolished as part of a building modification.

**Modifying the Size or Shape of a Duct**

Use this procedure to change the shape or size of a duct segment. You can change one segment at a time, or you can resize the entire run. When changing a single segment, you need to add a transition in order to adjust it to the rest of the run. You can also calculate duct sizes using the instant sizing tool.

**To modify the size or shape of a duct segment**

1. Select the segment.
2. Click Duct Flex tab or Duct tab ➤ Modify panel ➤ Duct Modify .
3. In the Modify Duct dialog, specify the duct shape for Shape.
4. Specify new sizes. You can manually select sizes or calculate them using the instant sizing tool:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>calculate size for round duct</td>
<td>accept the detected flow value for Capacity, or enter a flow value for Capacity. Click . The calculated duct size is displayed for Diameter.</td>
</tr>
<tr>
<td>calculate size for oval or rectangular duct based on a fixed height</td>
<td>accept the detected flow value for Capacity, or enter a flow value for Capacity. Specify a size for Height, and click for Width. You can change the height and recalculate the width repeatedly until you achieve a desirable duct size.</td>
</tr>
<tr>
<td>calculate size for oval or rectangular duct based on a fixed width</td>
<td>accept the detected flow value for Capacity, or enter a flow value for Capacity. Specify a size for Width, then click for Height. You can change the width and recalculate the height repeatedly until you achieve a desirable duct size.</td>
</tr>
</tbody>
</table>

For more information, see [Specifying a Calculation Method for Duct Sizing](#) on page 182.

5. In the Maintain Connection dialog, specify a method to re-establish a valid connection between the segment and the rest of the run:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then select…</th>
</tr>
</thead>
<tbody>
<tr>
<td>modify the entire run to match the parameters of the selected segment</td>
<td>Resize Branch to a Junction/Transition.</td>
</tr>
<tr>
<td>insert a transition fitting to connect the duct or duct fitting without changing the entire run</td>
<td>Add Transition Fitting.</td>
</tr>
</tbody>
</table>

If you have chosen to modify an entire run that is connected to another run, the junction fitting that connects the 2 runs is replaced. The correct transition fitting is inserted in its place to maintain a valid connection at that junction.
Modifying Duct Using AutoCAD Commands

See the AutoCAD® Help for information on using AutoCAD commands to modify a duct.

Breaking or Merging Duct

You can break or merge duct segments. You can also choose to have duct segments broken automatically as you draw them.

Breaking a Duct Segment

Use this procedure to apply a single break at a specific location in an existing duct segment.

1. On the command line, enter `break`.
2. Select the duct segment you want to break.
3. Enter `f` (first point), and specify the location of the first break on the segment.
4. Enter `@` to specify the location of the second break as the same as the first.
   This applies only one break to the segment, and it maintains connectivity between the new segments.

Breaking and Merging Duct Segments

When merging segments, you cannot cross fittings to join segments.

1. Select the ducts to break or merge, and click Duct tab ➤ Modify panel ➤ Duct Length.

![Duct Length dialog box]

2. In the Duct Length dialog, specify the operation:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>apply the length to the entire run</td>
<td>select Apply to Duct Run.</td>
</tr>
<tr>
<td>manually select duct segments to modify</td>
<td>click (Select Objects), and select specific segments to break or merge.</td>
</tr>
<tr>
<td>break a segment</td>
<td>select Break, and enter a value for Duct Length. You can also click (Pick Length), and specify a start and endpoint for the new length.</td>
</tr>
</tbody>
</table>
If you want to… then…
merge multiple segments select Merge, click the Select Object icon, and select the segments to merge.

Locking the Size of a Duct or Fitting

Use this procedure to lock the size of a duct component when modifying a run. When a component is locked, its size cannot be changed even if the entire branch is being resized. Transition fittings are added to each end of the locked object. For example, if a duct segment passes through an area with limited clearance, you can lock the size for that segment.

To lock the size of a duct segment or fitting
1. Select the segment or fitting.
2. Lock the size by doing one of the following:
   - On the Properties palette, expand Advanced, and under Calculation Settings, specify Yes for Lock Size.

Modifying the System Assigned to a Duct

Use this procedure to change the system of a duct run. Systems are defined to help maintain consistency throughout a run and across multiple drawings in a project. When you change a segment’s system, all components having valid connections to the selected segment are updated to the new system.

To modify the system assigned to a duct
1. Select the duct segment.
2. Click Duct tab ➤ Modify panel ➤ Duct Modify .
3. In the Modify Duct dialog, select a new system from the System drop-down list, and click OK.

Modifying a Duct Fitting

Use this procedure to change the size or subtype of a duct fitting.

1. Select the duct fitting, and click Duct Fitting tab ➤ Modify panel ➤ Duct Fitting Modify .
2. In the Modify Duct Fitting dialog, modify the fitting:

<table>
<thead>
<tr>
<th>If you want to modify…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>the part subtype (for example, change a mitered elbow to a smooth radius elbow)</td>
<td>click the Part tab. In the part type folder, select a different part subtype.</td>
</tr>
</tbody>
</table>

NOTE You cannot change the type of part, for example, change an elbow to a tee. To replace the part with one of a different type, erase the part and add a new one.
If you want to modify... then...
the part size click the Part tab, and select a different part for Part Size Name.
the type or size of the connection points click the Part Filter tab, and then modify the values for each connector.

### Modifying the Layout of Flexible Duct

You can modify the layout of a flexible duct run drawn using the spline segment mode by moving, adding, or deleting vertices through the Flex Duct Modify command. A vertex is the location where spline segments meet. Use this procedure to modify the vertices of a flexible duct run drawn using the spline segment mode.

**NOTE** If you drew a flexible duct run using the line or arc segment mode, you can modify the layout with the AutoCAD\textsuperscript{®} Modify commands or grips.

1. Select the spline flex duct.
2. Click Duct Flex tab ➤ Modify panel ➤ Flex Duct Modify.
3. On the command line, enter `v` (edit Vertex).

**NOTE** This entry invokes the vertex editing mode from the command line.

4. Press Enter on the command line to Enter the desired vertex editing option from the command line.

   If you enter `n` (Next) or `p` (Previous) to switch between the vertices in the spline to select the vertex to modify, the active vertex switches to the next or previous vertex in the direction that the flex duct was drawn. Depending on the location of the active vertex, one or both of the options may be available.

5. Edit the vertex layout on the command line as follows:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the tangent of the start or end segment</td>
<td>Enter <code>t</code> (Tangent) and then specify a start tangent. Start or end vertex must be active for this option to be visible.</td>
</tr>
<tr>
<td>connect a flex part to another part</td>
<td>Enter <code>c</code> (Connect) and select a part to which to connect. Start or end vertex must be active for this option to be visible.</td>
</tr>
<tr>
<td>move a vertex</td>
<td>Enter <code>m</code> (Move), and then drag the vertex to the new position.</td>
</tr>
<tr>
<td>remove a vertex</td>
<td>Enter <code>r</code> (Remove).</td>
</tr>
<tr>
<td>insert a new vertex</td>
<td>Enter <code>i</code> (Insert). Click to specify the insertion point of the new vertex.</td>
</tr>
<tr>
<td>update the view based on your changes</td>
<td>Enter <code>g</code> (Regen).</td>
</tr>
<tr>
<td>exit the vertex mode</td>
<td>Enter <code>x</code> (Exit).</td>
</tr>
</tbody>
</table>
Moving an Off-Center Takeoff

You can move an off-center takeoff along or across a segment.

You can also relocate the takeoff to a different side of, or angle around, the segment.

**TIP** When modifying off-center takeoffs, it is helpful to work in a 3D view of your model.

To move an off-center takeoff

1. Select the takeoff, and click Duct Fitting tab ➤ Modify panel ➤ Duct Fitting Properties.
2. In the Duct Fitting Properties dialog, click the Takeoff Position tab.
3. Modify the position:

<table>
<thead>
<tr>
<th>If you want to change the…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>side of the duct to which the takeoff is attached</td>
<td>click the Side cell, and select a new side: center, top, bottom, left, or right.</td>
</tr>
<tr>
<td>justification of the takeoff’s position</td>
<td>click the Justification cell, and select a new justification (center, top, bottom, left, or right), depending on the specified side.</td>
</tr>
<tr>
<td>off-center distance</td>
<td>click the Offset cell, and enter a number for the distance.</td>
</tr>
<tr>
<td>position along the length of the segment</td>
<td>click the From cell, select Start, Mid Point, or End, and then click the To cell, and select Starting Edge, Center, or Ending Edge to specify a direction from which to calculate the new position. Click Distance, and enter a number for the distance.</td>
</tr>
<tr>
<td>rotation axis of the takeoff</td>
<td>select Flip X, Flip Y and/or Flip Z to change the rotation of the takeoff along the duct segment. Depending on the selected axis and the current position of the takeoff, the display of the takeoff may not change.</td>
</tr>
</tbody>
</table>

Modifying a Custom Fitting

You can modify a custom fitting after it has been created. A custom fitting tends to be highly specific and is generally a 1-time-use part. However, you can modify a custom fitting for multiple uses by using the AutoCAD Modify commands.

When modifying custom fittings, keep in mind the following:

- When you initially explode a custom fitting, it is converted to the active view block. Exploding the custom fitting a second time converts the block to its associated linework.
- ERASE, MOVE, ROTATE and ROTATE3D, and SCALE commands break system connections.
- COPY, MIRROR, OFFSET, and ARRAY commands maintain custom fitting part properties and property sets.

**RELATED** See AutoCAD® Help for more information on the above commands.

### Modifying Turning Vanes

You cannot modify the number or layout of turning vanes once they are added to a fitting. You can remove the vanes from all or selected fittings, and then add vanes with different settings to all or selected fittings. To add vanes, see [*Adding Turning Vanes to Fittings* on page 214.]

**To remove vanes from all fittings**

1. To remove vanes from all fittings of the same size and subtype, select a fitting.
2. Click Duct Fitting tab ➤ Duct Vanes panel ➤ Remove Vanes 🕒.

**To remove vanes from selected fittings only**

3. To remove vanes from selected fittings, select one or more fittings, and click Duct Fitting tab ➤ Modify panel ➤ Duct Fitting Properties 🕒.
4. In the Duct Fitting Properties dialog, click the Vanes tab.
5. Deselect Enable Vanes.

### Modifying Insulation or Lining

Use this procedure to add or modify insulation or lining on a duct run. You can add insulation or lining, or both, to duct segments and duct fittings.

**NOTE** In the software, insulation and lining are annotation only. You can also only view insulation and lining on duct displayed as 2-line.

1. Select one or more duct segments or duct fittings, and
   - if the object selected is a duct, click Duct tab ➤ Modify panel ➤ Duct Properties 🕒.
   - if the object selected is a duct fitting, click Duct Fitting tab ➤ Modify panel ➤ Duct Fitting Properties 🕒.
   - if the object selected is a duct flex, click Duct Flex tab ➤ Modify panel ➤ Flex Duct Properties 🕒.
2. Click the Lining and Insulation tab.
3. Specify the change:
   - If you want to add insulation, select Apply Insulation, and specify a value for Thickness.
   - If you want to modify the insulation thickness, specify a new value for Thickness.
   - If you want to add lining, select Apply Lining, and specify a value for Thickness.
If you want to          then

modify the lining thickness   specify a new value for Thickness.

remove insulation or lining  deselect Apply Insulation or Apply Lining.

You can also add insulation or lining automatically as you draw duct runs. For more information, see Adding Lining or Insulation on page 176.

Checking Connectivity in a Duct System

Use this procedure to check connectivity of the duct systems in your drawings. Checking connectivity is useful if you are experiencing difficulties modifying a duct system.

➤ Check connectivity for a duct network:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>show solution tips on all systems</td>
<td>Click View tab ▶ MEP View panel ▶ Show Solution Tips 🔴 . All disconnects are highlighted in red. For more information, see Showing Solution Tips on page 579.</td>
</tr>
<tr>
<td>check connectivity between adjacent parts</td>
<td>select a part, and click [Duct, Duct Flex, or Duct Fitting] tab ▶ Modify panel ▶ Show Connected Objects drop-down ▶ Show Connected Objects 🔴 .</td>
</tr>
<tr>
<td>check connectivity on a duct run</td>
<td>select a part in the run, and click [Duct, Duct Flex, or Duct Fitting] tab ▶ Modify panel ▶ Show Connected Objects drop-down ▶ Show Connected Run 🔴 .</td>
</tr>
<tr>
<td>check connectivity among duct branches</td>
<td>select a part, and click [Duct, Duct Flex, or Duct Fitting] tab ▶ General panel ▶ Select System drop-down ▶ Select Connected Branches 🔴 . Press Tab to cycle through the connected upstream and downstream branches.</td>
</tr>
</tbody>
</table>

Modifying Annotation

You can modify all aspects of labels and flow arrows. For information on modifying annotation such as tags and schedules, see Creating Construction Documents on page 547.

Modifying a Label

After you place a label in your drawing, you can apply a new style, change the spacing along the object, or change how it is displayed. You can use grips to add or remove individual labels from an object, or offset a label from the object.

A label is updated dynamically if the object to which it is attached is modified. For example, if the size of the duct, cable tray, or duct is modified, the label attached to it reflects the change in size.
To modify a label using grips

1 Select a label to turn on the grips.

2 Specify the change:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>add a label</td>
<td>click the Add Label grip. Hold down <strong>CTRL</strong> while clicking to add labels at even spacing.</td>
</tr>
<tr>
<td>remove a label</td>
<td>click the Remove Label grip. You can remove individual labels regardless of the method used to add the labels.</td>
</tr>
<tr>
<td>move a label</td>
<td>click the Location grip and move the label to a new location along the curve. Press <strong>CTRL</strong> after clicking the Location grip to offset the label from the curve.</td>
</tr>
<tr>
<td>add labels spaced at a specific distance along a curve</td>
<td>click the Repeat Distance grip, and click along the curve to specify a distance from the beginning of the curve to the selected point. Labels are added along the curve, and are spaced at this distance.</td>
</tr>
<tr>
<td>space multiple labels evenly along a curve</td>
<td>Hold down <strong>CTRL</strong> and click the Repeat Distance grip.</td>
</tr>
</tbody>
</table>

To modify a label from the ribbon or context menu:

1 Select a label and:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>add a label node</td>
<td>Click Label tab ➤ General panel ➤ Add Selected drop-down ➤ New Label Node ☑, and select a point on or near the object.</td>
</tr>
<tr>
<td>remove a label node</td>
<td>Click Label tab ➤ Modify panel ➤ Delete ✖.</td>
</tr>
<tr>
<td>offset a label node</td>
<td>Click Label tab ➤ Modify panel ➤ Offset ✄, enter an offset distance, and press <strong>ENTER</strong>. You can offset an individual label, or you can offset all labels in your drawing.</td>
</tr>
</tbody>
</table>
If you want to…

Then…

rotate a label node

Click Label tab ➤ Modify panel ➤ Rotate , select a rotation point, and enter a rotation value. You can rotate an individual label, or you can rotate all labels in your drawing.

anchor the label to a different object

Click Label tab ➤ Modify panel ➤ Move To Object , and select the new object to which to anchor the label.

NOTE Alternatively, you can right-click and select a Label modify command.

2 If you want to modify the layout method or label style, double-click a label to open the Properties palette.

3 Expand General, and for Style, select a new label style.

NOTE The configuration of the label curve style determines whether labels that use the style are considered annotative (scaled accordingly when the annotation scale changes). For more information, see Annotative Objects on page 549.

4 Expand Dimensions, and select a new layout method:

If you want to display the labels… then select…

one at a time One by one.

evenly spaced along the curve By quantity, and enter a value for Number of labels.

with a repeated spacing value By distance, and enter a value for Distance between.

Calculating Duct Sizes Using External Tools

Once you have drawn a duct system, you can analyze the system design to determine the optimal sizes for system components. You export system data from the drawing and analyze it using an external software tool. Once the data has been analyzed, and optimal sizes have been calculated for system components, you then import the calculated data into your drawing and resize the system. Trane® VariTrane™ Duct Designer and Elite Ductsize are 2 applications that can analyze and size duct systems in AutoCAD MEP drawings.

Duct system data is exported and imported in Duct Design Extensible Markup Language (DDXML). DDXML is a schema used to store and transfer data for duct networks. It can be used directly in duct analysis packages.

This is the typical process of evaluating and resizing a system:

- Review your duct systems to ensure it complies with generally acceptable design practices. External analysis tools may have difficulty analyzing unorthodox systems or components.
- Assign ASHRAE identification numbers to all fittings if your external analysis tool requires it.
- Export system information directly from the drawing in DDXML format.
- Analyze the DDXML file using an external tool. Component sizes are calculated and written to the DDXML file.
- Once analyzed, import the DDXML file into your drawing.
- Automatically resize your system based on the calculated results.
Specifying ASHRAE Fitting Types

Use this procedure to assign ASHRAE identification numbers to duct fittings in a duct system. You can assign ASHRAE numbers to fittings by using the Properties palette, or by using the Modify Fitting ID dialog in the event log of the Duct System XML Export dialog.

The American Society of Heating, Refrigerating, and Air-Conditioning Engineers (ASHRAE) publishes a database that includes loss coefficient tables for many duct fittings. Each duct fitting in the database is identified by a unique number. The external tool you use to analyze your system may require that all fittings in the system are assigned an ASHRAE fitting number.

To specify an ID in the Properties palette

1. In the drawing, select the fitting that you want to specify and click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties ➤ Expand Advanced ➤ Expand Engineering Data.

   **TIP** To specify all fittings of the same type in the drawing at once, select one fitting, and click Duct Fitting tab ➤ General panel ➤ Select System drop-down ➤ Select Similar.

2. On the Properties palette, expand Advanced, and expand Engineering Data.
3. In the Assigned Engineering ID drop-down list, view the available choices, if any, for ASHRAE fitting numbers.
   - If the ASHRAE number you want to use is in the list, select it for Assigned Engineering ID.
   - If there is more than one ASHRAE number to choose from, consult the ASHRAE Duct Fitting Database to make sure you choose the most appropriate fitting for your system. Some fittings are dependent on flow direction or duct system type, such as supply or exhaust.

4. If the ASHRAE number you want is not in the list, or there are no numbers listed, enter the ASHRAE fitting number for Assigned Engineering ID.
5. Press ESC to deselect.
6. Continue specifying fittings, if necessary.

To specify an ID when exporting to duct system XML

6. After exporting a duct system for analysis, click View Event Log in the Duct System XML Export dialog.
7. If there are any error warnings for multiple fitting IDs in the Event Log, select the warning, and click (Modify Fitting ID).
8. In the Modify Fitting ID dialog, specify an ID in the Fitting drop-down list, or enter a fitting ID, and click OK.
   - This ID is assigned to the fitting in the drawing. Repeat as necessary to resolve all fitting ID warnings.
   - If desired, you can run the duct system export again to include the revised fitting IDs.

Exporting Duct System Data

Use this procedure to export the engineering data for your duct system. Once you have completed preliminary designs for your duct systems, you can export the data in DDXML format. You then analyze the exported file with an external tool, which in turn calculates the optimal sizes for your system.
To be eligible for exporting, each system must have at least one start point and one endpoint. A system is defined as any ductwork between a start point and one or more endpoints. A start point must consist of a fan or other air handling device. Endpoints must consist of outlet devices such as air terminals. Flow values must be assigned to outlet devices in order to properly size system components.

For example, a supply system uses an air handling unit to supply air to several rooms. Each room includes an air terminal as the outlet for the air. In this example, the system includes all ductwork from the air handling unit to each air terminal. If there was no air handling unit in the drawing, you would not be able to export the system data.

**TIP** To preview the connectivity of a system, select an object within the system, and click [Duct, Duct Flex, or Duct Fitting] tab ➤ Modify panel ➤ Show Connected Objects drop-down ➤ Show Connected Run.

These are additional considerations prior to exporting data:

- Start points can be fans, air handling units, or similar MvParts such as a VAV boxes, mixers, or economizers.
- To ensure proper sizing, assign flow values to all outlet devices, such as air terminals. For more information on modifying MvPart properties to assign flow values, see Configuring Mechanical Parts for Analysis on page 196.
- If the outlet device is an end cap, it is assigned a flow value of zero.
- Variable air volume controllers (VAV boxes) with 2 connectors, such as single duct or shut off VAV boxes, are considered part of the duct run unless they are ending a branch. If they end a branch, they must have a flow value assigned. If they do not end a branch, the flow value assigned to them is not used.
- VAV boxes with more than 2 connectors, such as dual duct boxes, are considered end points. Any ductwork beyond the VAV box is not considered. The flow value assigned to the VAV box connector is used for analysis.
- Duct segments that contain takeoffs are considered as one plenum duct when exported. If you want the analysis tool to assign different sizes to different parts of the duct, use the break command to divide the duct into multiple segments, and insert transition fittings where appropriate.

Prior to exporting, consult your external analysis package to see if there are any additional requirements you need to include in your system. For example, you may need to specify the ASHRAE fitting type for all duct fittings as shown in Specifying ASHRAE Fitting Types on page 242. There may also be system design constraints that you need to consider.

**To export duct system data:**

1. Click ➤ Export ➤ Duct XML.
2. In the Duct System XML Export dialog, specify a path and file name for the output file. Note that the file extension for a DDXML file is *.ddx.
3. Click Select Object.
4. In the drawing, select any duct segment or fitting within the system that you want to export.
5. In the Duct System XML Export dialog, specify a system for Select System Type.
6. Click Start.
7. When the export is complete, the DDXML file is created in the specified directory.
8. If any errors were encountered during export, click View Event Log to see a list errors.

To modify your system before attempting to export again, see Modifying a Duct System on page 219.
After you successfully export your system data, you analyze it using an external tool. You then import it back to your drawing as shown in Importing Optimized System Data on page 244.

**Importing Optimized System Data**

Use this procedure to import duct system data that has been analyzed and optimized by an external analysis tool.

1. Open the drawing that contains the system for which you exported the system data.
2. Click Analyze tab ➤ HVAC panel ➤ Import Duct XML.
3. In the Duct System XML Import dialog, specify the DDXML file you want to import, and click Open.
4. The optimized data is assigned to the system in the drawing.

After you successfully import optimized system data into your drawing, you can automatically resize each component to its calculated value. For information on resizing duct systems, see Resizing a System on page 244.

**Resizing a System**

Use this procedure to resize a system after you have imported an optimized duct system XML file.

*The preliminary system design before resizing*
1 In the HVAC workspace, open the Analysis tool palette, and select the External Data Resize tool.

2 In the System Resize dialog, click Select Object.

3 In the drawing, select a duct segment or fitting in the system you want to resize.

4 In the System Resize dialog, specify a preference for custom parts:

<table>
<thead>
<tr>
<th>If you...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>want to use custom parts when resizing the system</td>
<td>select Allow parts with custom size.</td>
</tr>
<tr>
<td>want to only use parts available in the catalog</td>
<td>deselect Allow parts with custom size, and specify how to select parts whose calculated size does not exactly match an available size in the catalog.</td>
</tr>
</tbody>
</table>

5 Click Start.

6 After the command has been fully executed, the system is automatically resized. Review the drawing to make sure all fittings and ductwork have been resized properly. Click View Event Log to view any errors encountered during resizing.

**Creating Duct System Construction Documents**

You can annotate drawings with labels, tags, and schedules. Additionally, you can create construction documents that include cross-sectional views and details. For more information, see Creating Construction Documents on page 547.
Drawing Piping Systems

This section offers instructions on how to use AutoCAD MEP to design and draft mechanical piping systems for a building plan.

Pipe Systems Overview

Pipe system engineers design parallel and gravity-based pipe systems that range in size and complexity. With AutoCAD MEP, you can define piping specifications, routing preferences, and system definitions that the software can use when laying out the pipe run. You can adjust the layout based on routing solutions that the software generates. You can also annotate the system as you place pipe objects and other equipment and then generate accurate construction documents from those drawings.

Workflow for Designing a Pipe System

Review the steps

1. Set up a project and open a drawing.
2. Create a preliminary 1-line conceptual design.
3. Specify the pipes and fittings to be used as you draw a pipe run.

View more information

1. Specify standards for pipe systems. Attach the drawing to an architectural floor plan as an external reference. See Working with Projects on page 129.
2. Prepare a conceptual design for evaluation by code officers and senior engineers. See About Schematic Diagrams on page 518.
3. Define piping design specifications for AutoCAD MEP to use when laying out the pipe run. See Configuring Routing Preferences on page 279 for an overview and Configuring Routing Preferences on page 279 for more information.
Review the steps

Specify system definitions for chilled water or steam systems, size ranges, and display properties.

Add boilers, chillers, pumps, heat exchangers and other equipment.

Connect equipment along pipe runs and layout the pipe system (sloped or non-sloped).

Modify the pipe layout.

Generate construction documents.

View more information

Define the look of your piping layouts. See Configuring System Definitions on page 281 for an overview and Configuring System Definitions on page 281 for more information.

Place equipment in a drawing. See Adding Pipe Equipment on page 285 for more information.

Configure pipe settings and pipe layout preferences, and apply routing solutions. See topics under Adding Pipe on page 286 and Using Routing Solutions to Connect Objects on page 306. See Drawing Sloped Piping on page 308 to layout gravity-based pipe systems.

Refine portions of the existing layout. See topics under Modifying a Piping System on page 318.

Annotate the system as you place objects. Then, create construction documents. See Creating Construction Documents on page 548.

Associative Movement

You can move multi-view parts on page 76 (called MvParts), fittings, or pipe segments using location grips. This functionality is called associative movement. When you move an MvPart to a new location, the pipe segments attached to that part can move, shrink, or stretch to maintain a connection with the system. You can also move a pipe segment without affecting the location of MvParts or other portions of the pipe run.

NOTE For more information, see Mechanical, Electrical, and Plumbing Equipment in Building Systems on page 76 and Moving Pipe Components Using Location Grips on page 320.

Movement of a Pipe Segment

The following illustrations show how location grips are used to move a pipe away from a pump (MvPart).
Location grip selected on pipe segment

New location specified

Resulting layout

The fittings connected to the pipe move with the pipe, but all other components in the run remain fixed in their original position. The elbows connected to the pipe move with it, and the length of the pipes connected to the elbows change. The system remains connected.

Movement of a Pipe MvPart

The following illustrations show how location grips are used to move a pump (MvPart). The pipes and fittings move with it, but all other components in the run remain fixed in their original position.
Routing Preferences

You use routing preferences to draw accurate pipe systems in auto layout on page 252. Pipe routing preferences specify which pipe part to insert as you lay out the pipe run. Couplings are inserted at the proper pipe length and at break points on page 297 in the pipe run. Routing preferences meet design standards and specifications and contain the pipe parts (pipes and fittings) used to lay out your pipe run.

A pipe part routing preference includes one or more size ranges on page 280 for pipe parts and fittings, such as elbows, tees, laterals, and transitions. The software organizes the size ranges based on nominal pipe diameters. You can use pipe parts and fittings in a specified size range as you lay out the pipe run. The following example shows the routing preferences for Glued. Notice that the Pipe drop-down list organizes the available parts based on material type (US Imperial and US Metric profiles).
Routing preferences, showing parts organized based on material type

Multiple size ranges provide more flexibility in your piping designs. For example, assume a design specification for a chilled water system requires commercial steel pipe with threaded connections for all pipe sizes 3" and lower. The system also specifies commercial steel pipe with 150 class, weld neck, flange connections for pipe sizes 3 1/2" and higher.

When you configure a routing preference for a particular specification, the appropriate fittings are automatically inserted as you design the piping layout. Auto layout on page 252 can generate different routing solutions, and prompts you to select the best alternative.

Pipe run drawn using a particular routing preference (Top view, Mechanical - Pipe by Size display configuration)

**Pressure Pipes and Gravity Pipes**

AutoCAD MEP includes routing preferences for pressure pipes (horizontal or vertical piping designs) and gravity pipes (sloped piping on page 256). For example, the software will insert laterals or angled tees, when appropriate, in auto layout.

Pressure pipes use the following routing preferences (US Imperial profile):

- Butt welded
- Grooved and threaded
Slip on flanged - 150 lb. and threaded
Threaded 2000 lb.

Gravity pipes on page 291 use the following routing preference (US Imperial):
- Cast Iron soil pipe (no hub)
- Duct iron mechanical joint
- High-density polyethylene (HDPE)
- Sanitary drain, waste, vent

**RELATED** For more information about changing routing preferences, see Configuring Routing Preferences on page 279. For more information about building parametric parts to supplement in routing preferences, see Creating a Parametric Fitting with Content Builder on page 675.

**Size Ranges in Routing Preferences**

Pipes and fittings in a size range must have common nominal sizes in a routing preference that you can use in a pipe run. The following conditions apply to size ranges:

- The lower limit of a size range (shown in Size Upper Limit) is set to the smallest size in common with all the selected parts. However, if you create a size value for a mid-size range that is less than the higher limit of the previous size range, the mid-size range value automatically moves to the previous size range. For example, if you set a value of 3 in size range 2, but that value is less than what is in size range 1, size range 2 becomes size range 1 and size range 1 becomes size range 2.
- The list of available sizes for the upper limit of the size range (Size Upper Limit) is filtered to include only the sizes that are common to all of the selected parts.
- The available range of sizes for the selected part is displayed for the part.

For example, when creating a routing preference, you select a pipe with sizes that range from 1/8” to 60” and an elbow with sizes that range from 1” to 24”. Because the lower limit of the size range is set to 1”, you can select an upper limit as high as 24”.

**NOTE** The size ranges in the routing preference definitions in drawings created with Autodesk Building Systems 2007 were not validated by the software to ensure the selected parts had nominal sizes in common within the specified range. When you open these drawings in AutoCAD MEP, they are validated. However, the validation might result in the resetting of some of the upper limits to different sizes, and the resetting of some of the parts to "NONE".

The size ranges and description appear on the Properties palette when you add a pipe segment to a pipe run. The nominal sizes are grouped based on the size ranges for the selected routing preference.

**Auto Layout**

As you draw pipe runs, you lay out the pipe geometry by specifying points in the drawing. You control how the pipes, fittings, and transitions are automatically inserted based on what is specified in the current routing preference.
Auto-layout example: The user moves the cursor at a 90 degree angle to the pipe segment.

A 90 degree elbow is automatically inserted after the point is specified.

Several AutoCAD MEP tools help to streamline the layout of a pipe run. For example, you can specify an angle using the compass. The available angles inside the elbow content determine the applicable auto-layout angles. With the compass, you can restrain the cursor to specific angles based on compass settings. Using tracking lines, you can align a component with another object or line. Object snaps let you connect to pipe objects or to a geometric point on an object or line.

Auto layout can generate layout solutions for sloped piping systems based on points in the drawing. You can draw sloped piping layouts if the current routing preference supports angle of deflection (allowable fitting tolerance). As you draw pipe, sloped pipe-related properties on the Properties palette. For example, you can select Yes for Use fitting tolerance to turn on angle of deflection on a joint if the current routing preference supports angle of deflection. As you lay out the pipe run, you can set a slope value on the Properties palette and the slope format on the General tab in the Pipe Layout Preferences dialog.

**TIP** If you are routing pressure piping on page 251, you can increase the software response time by doing the following: specify No for Use fitting tolerance, specify the desired angle for Bend angle, and specify the preferred Branch fitting. This helps the software generate more specific auto-layout routing solutions on page 254 based on specific settings.

**NOTE** When you connect a pipe segment directly to another segment in a pipe run (constrained layout on page 255), the software displays the actual slope value for the pipe segment. For more information on this feature, see Slope Value Displayed in Constrained Piping Layouts on page 257.

**RELATED** For more information, see Sloped Piping on page 256, Angle of Deflection (Fitting Tolerance) on page 267, Pipe Properties Palette (Add Mode) on page 286, and General Preferences on page 294, and Drawing Sloped Piping on page 308.

Auto layout determines whether to insert a transition. If the software makes this insertion, the angle of deflection is equally distributed between female connectors on a fitting that supports sloped piping. For example, if you set the slope value on the Properties palette to 10 (degrees), and the pipe object has 2 female connectors, then each connector can have an angle of deflection of 5 degrees each. The value cannot exceed the stored AoD (angle of deflection) value on the part.
Routing Solutions

When you connect objects at different elevations or slopes, or connect objects whose centerlines are not aligned, the software can generate routing solutions with different combinations of fittings or joints. You can preview the routing solutions and select the desired alternative.

**TIP** To accurately preview routing solutions, especially those at different elevations or slopes, you can use a workspace configured for 2 viewports. You can work in plan view in one viewport, and use an isometric view in the other viewport to preview routing solutions. You can also use the 3D Orbit view while you are previewing routing solutions.

If none of the routing solutions presented on the command line are satisfactory, select one that most closely matches your requirements and then use grips to modify the layout.

The following example describes how routing solutions work when connecting a pipeline to a chiller. The pipeline is on a different elevation, and the end of the pipeline is not in line with the chiller connection.

You select the last pipe segment, and click (Add grip) on the open end. You move the cursor to the chiller connection, and then click the pipe end connector.

**The second viewport is set to an isometric view to preview routing solutions**

The software can generate 2 routing solutions. Each routing solution is based on the fittings that you selected for Routing Preference on the Properties palette. The angles are determined by the allowable angles in the selected elbow (such as 45 or 90 degrees). You preview the routing solutions and select the most suitable layout.
First routing solution

Second routing solution

**TIP** If you are routing pressure piping on page 251, you can increase the software response time by doing the following: specify No for Use fitting tolerance, specify the desired angle for Bend angle, and specify the preferred Branch fitting. This helps the software generate more specific auto-layout routing solutions based on specific settings.

**Constrained Layout Solutions**

AutoCAD MEP can generate constrained layout solutions. Constrained layout intelligently connects one pipe object to another in sloped on page 256 (gravity-based) or non-sloped (pressure-based) pipe systems, even if the 2 pipe segments are at different slopes or elevations. AutoCAD MEP achieves constrained layout based on the following guidelines:

- Horizontal routing solutions are supported when you connect 2 objects at different elevations.
- New vertical segments that are added to a pipe run remain vertical to the UCS (current user coordinate system).
- If you select Yes for Use fitting tolerance on the Pipe Properties palette on page 286 and the joint supports angle of deflection, the angle of deflection is distributed equally between the female connectors on the pipe object. For example, if you set a slope value of 10 degrees on the Properties palette, and the pipe object has 2 female connectors, then each connector can have an angle of deflection on page 267 of 5 degrees each. The value cannot exceed the maximum allowable angle of deflection (AoD) that is stored in the content for the part.
NOTE When you connect a pipe segment directly to another segment in a pipe run (constrained layout on page 255), the software displays the actual slope value for the pipe segment. For more information on this feature, see Slope Value Displayed in Constrained Piping Layouts on page 257.

Sloped Piping

The sloped piping feature in AutoCAD MEP expands catalog content and pipe fitting routing preferences to support gravity-based piping designs for sanitary drain, waste, vent, and sewer/storm drainage systems. For example, you can lay out the main of a drainage system with a 1/4” per foot slope and connect several branches with different slope angles based on the distance and height from the main. The system can generate possible layout solutions for sloped systems based on points you specify in the drawing, the slope value, and the allowable angle of deflection on page 267 for the pipe fitting used.

Sloped piping layouts model real-world piping requirements. Fittings are inserted based on the orientation of the pipe segment. As a result, pipes fit flexibly into couplings. AutoCAD MEP rotates the orientation of an elbow (or other fitting) around the attached point based on the centerline of the sloped pipe. The software lays out pipe and fittings with a horizontal slope and transitions between sloped and vertical pipes eliminating the need to manually calculate angles.

AutoCAD MEP applies slope in the Z direction of the current user coordinate system (UCS) in a drawing. You create sloped piping systems using elbows, tees, wyes, or other fittings that connect an angled segment to a horizontal segment. The next example shows a rise/run ratio of 3/10 for the sloped segment where the elbows are rotated to accommodate the slope value.

Sloped segment perpendicular to horizontal segments (front view)

You can create slopes in straight runs if you have the appropriately angled fittings. In the next example, a 45-degree elbow connect a 45-degree sloped segment to horizontal segments.

Sloped pipe segment, 45 degrees (side view)

AutoCAD MEP supports the design of sloped connections by using wyes (laterals) or angled tees to connect a branch to a main. It inserts angled tees/wyes at the correct orientation to connect a sloped branch to a sloped main. You can also choose an eccentric fitting (with different diameter openings at each end with different centerlines) or a concentric fitting (with different diameter openings at each end with the same centerline).
Slopes Supported by Gravity-Based Piping Systems

The Gravity Pipe tab on page 291 on the Piping tool palette contains the pipe tools that support sloped piping. Gravity-based pipe designs support drain, process drain, sanitary, sanitary vent, and storm systems in the following slopes:

- 1/8” per foot
- 1/4” per foot
- 1/2” per foot

Slope Value Displayed in Constrained Piping Layouts

The software displays the current slope value of a pipe segment that is connected to another segment in a pipe run (constrained layout on page 255). The slope value only appears when the software displays possible routing solutions on page 254. See the following example.

A pipe segment can have a slope value specified on the Pipe Properties palette on page 286, or it can have a different slope depending on a particular routing solution that is used. This feature provides an immediate visual indicator to let you know exactly what solution is used and the associated slope value. To turn off this feature, enter PipeSlopeDisplay on the command line. Then enter n at the prompt: Slope value displayed during pipe layout [Yes/No] <current value>:

RELATED For more information on using the sloped piping feature, see Drawing Sloped Piping on page 308.

Pipe System Definitions

Pipe system definitions specify display information, such as pipe display by size, layer key settings, rise/drop display style, and other display properties. You typically associate a system definition to a type of pipe system, such as chilled water or steam. The settings for a system definition control many of the display properties of a pipe system. You assign a layer key style to a system definition. This designation dictates the layer, color, and linetype for the system. You can also configure a system definition to display pipes as 1-line or 2-line by size.

You can assign a system definition to a system group. In the software, pipe runs that have different system definitions cannot connect to each other without changing the system for the connecting pipe run. You can, however, assign a system group to different system definitions. This allows pipe runs from different
system definitions to connect while maintaining the same system for each run. For example, you can assign the same system group to Heating Hot Water - Supply and Heating Hot Water - Recirculation. You then can connect pipe runs between these 2 systems while maintaining their original system settings.

The default templates include many pipe system definitions, such as chilled water, heating hot water, and steam. Pipe system definitions are stored with a drawing. You can use different system definitions for different drawings, and you can share system definitions between drawings.

**Pipe System Displays**

In a drawing, pipe systems can be displayed as 1-line, graphical 1-line, 2-line, or single line graphics. Each variation refers back to the actual location in the 3D model.

You do not need to specify a pipe system as 1-line or 2-line. You only need to create a pipe system once using parts, such as pipe segments and fittings. You can then use display configurations and system definitions to control the 1-line or 2-line displays of the pipe system.

The parts in the pipe system maintain their properties (such as part type, size, and connection type) whether they are displayed as 1-line or 2-line. You can switch between configurations to view a pipe system as 1-line or 2-line. You can also use 1-line and 2-line displays by pipe size in the same drawing.

You can combine graphical 1-line, 1-line, or 2-line displays in the same drawing. You can use 1-line displays to create preliminary layouts, allocate space, or show a simpler view of a system in a complex drawing. For plotting purposes, you can also combine 2-line, 1-line, and graphical 1-line displays in the same drawing. You can display large diameter pipe systems as scaled 2-line, medium diameter systems as scaled 1-line, and small diameter systems as graphical 1-line. In the following illustration, the larger diameter systems appear as 2-line and smaller systems as 1-line.

**TIP** The 1-line display is not the same as a schematic display. In a 1-line display, the layout does represent the actual geometry and location of all pipeline components. Whether a pipeline is displayed as 1-line or 2-line, it still contains all the defined pipe properties, such as size and system. You can also view 1-line or 2-line displays in isometric views.

**RELATED** For more information, see Configuring System Definitions for 1-Line, 2-Line, or Single Line Graphics on page 282 and Configuring Graphics for Single Line Pipe Display on page 283.

**Display Configurations in AutoCAD MEP**

The default Aecb Model drawing templates include the following display configurations. You can use the display configurations to view piping as 1-line, 2-line, or a combination of both.

<table>
<thead>
<tr>
<th>Display configuration</th>
<th>Description</th>
<th>Additional notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>MEP Design</td>
<td>Shows large diameter piping and equipment as 2-line and smaller diameter system as 1-line; all parts and fittings scaled for 2-line and 1-line, but</td>
<td>Uses the Plan display representation and is based on the Pipe By Size setting in the System.</td>
</tr>
</tbody>
</table>

258 | Chapter 7  Drawing Piping Systems
## Display configuration

<table>
<thead>
<tr>
<th>Configuration</th>
<th>Description</th>
<th>Additional notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>MEP Basic 2-Line</td>
<td>Shows all pipe components and equipment as 2-line, regardless of system definition configurations for 1-line and graphical 1-line; hidden lines and rise/drop symbology not used</td>
<td>Uses the 2 Line Display Representation While rise/drops are displayed in Basic 2-line, hidden lines are not calculated. This display is best suited when laying out designs if hidden lines are not needed and in Model views to accurately depict the 2 line representation of the objects.</td>
</tr>
<tr>
<td>Mechanical Pipe By Size</td>
<td>Shows all piping and equipment as 2-line, but can use system definition configuration to show 2-line, 1-line, or graphical 1-line, depending on size; uses hidden lines and rise/drop symbology</td>
<td>Uses the Plan display representation for pipe objects and Plan Screened for other disciplines This allows all objects that are not pipe-related to be screened as background.</td>
</tr>
<tr>
<td>MEP Schematic</td>
<td>Shows all piping as 1-line, and shows all equipment as schematic symbols; uses hidden lines and rise/drop symbology; graphical 1-line unavailable in this configuration</td>
<td></td>
</tr>
<tr>
<td>Mechanical</td>
<td>Shows all piping and equipment as 2-line, but can use the system definition configuration to show 2-line, 1-line, or graphical 1-line, depending on size. Hidden lines and rise/drop symbology are used</td>
<td>Uses Plan Display Rep for Mechanical and Plan Screened for non-Mechanical</td>
</tr>
</tbody>
</table>

You can **switch the current display configuration** in a drawing for the desired 1-line or 2-line display. To use a combination of 1-line and 2-line displays based on nominal pipe size, use a system definition for the pipe system in conjunction with the appropriate display configuration for the drawing.

**RELATED** For more information, see Display System Structure on page 135, Display Configurations on page 139, and Display Representations on page 137.

## 1-Line Display

You use 1-line displays for annotation of construction documents. The fittings and connections in a 1-line pipe system display at their actual envelope dimensions. In-line and anchored components, such as valves, also appear as scaled 1-line. MvParts are displayed as scaled 2-line.

In the following example, fittings, such as tees, elbows, and reducers, represent their actual envelope dimensions. A gate valve and a check valve also appear as scaled 1-line components. The pump displays as scaled 2-line.


**Graphical 1-Line Display**

You can choose a graphical 1-line display to show a generalized routing of a pipe system. The graphical 1-line display uses non-scaled components. It displays equipment as schematic symbols but does not visually indicate a fitting or joint type. The sizes of components and equipment symbols are not related to their actual dimensions but are related to the physical model location.

In the following example, a natural gas line and hot water line are connected to a boiler. The pipe lines and their in-line components, including valves, reducers, a pressure regulator, and a pressure gauge, display as 1-line symbols. The boiler displays as a scaled 2-line component. The gas line uses threaded connections, while the hot water line uses soldered connections. The connection types are indicated on the fittings.

If you use a 1-line or 2-line display to plot a large pipe system, the fittings and equipment on smaller pipe runs might not render well because they are so small compared to the size of the entire system. If you use the graphical 1-line display for smaller diameter pipe systems, the fittings and equipment symbols plot at a specified size.

Graphical 1-line is a basic way to display a system. It does not alter the components in the system. The pipe components in graphical 1-line still contain all the defined properties, such as size, type, and system, and they can be changed to display as scaled 1-line or 2-line.

**RELATED** For more information, see Configuring System Definitions for 1-Line, 2-Line, or Single Line Graphics on page 282 and Configuring Graphics for Single Line Pipe Display on page 283.

**2-Line Display**

A 2-line display shows pipe components as scaled, 2-dimensional objects. In isometric views, the objects display as 3-dimensional objects. Fittings and equipment are displayed based on the contours of their physical
geometry. Typically, larger diameter pipelines are displayed as 2-line to allocate space or check interference with surrounding objects.

**Straight Centerline Display of Elbows**

Pipe standards and companies use straight centerlines in 1-line, 2-line, model, and plan displays to accurately represent the location of the intersection of an elbow. Pipe designs typically determine the centerline path. Wastewater piping contractors and fabricators use straight centerlines to guarantee accuracy in process piping installations and fabrication drawings.

The centerline display of elbows in AutoCAD MEP is based on the path and orientation of connectors 1 and 2 on the elbow. The centerline display typically follows the path of the curve. It is generated in all orthographic and model views.

The following example shows a straight centerline of elbows on a pipe in 2-line display. One of the elbows in the illustration is 45 degrees and the other is 90 degrees.

*Straight centerline on pipe in 2-line display*

You can control the centerline display of elbows and store your display results in the drawing. This capability applies to the Piping domain, as well as Electrical, and HVAC. For more information about configuring the straight centerline display, see [Configuring the Straight Centerline Display of Elbows](#) on page 284.

**Placeholder Parts**

Placeholder parts are 1-line dimensionless parts you can use for preliminary designs. When you draw systems with placeholder parts, the software inserts segments and fittings at appropriate points like other pipe types. You can convert placeholder parts to any other part type, such as commercial steel or copper tubing.

To draw a system with placeholder parts, configure a routing preference using placeholder parts in the default part catalog. The default Aecb Model drawing template includes a placeholder routing preference. Draw systems just as you would for any other pipe type. To convert the placeholder parts to other parts, modify
Pipe Parts Catalog

The pipe parts catalog contains parts in a pipe system in thousands of sizes. The Piping domain includes the following part types:

- Connector
- Coupling
- Cross
- Elbow
- Endcap
- Offset wye (lateral)
- P-Trap
- Takeoff
- Tee
- Transition
- Wye
- Undefined

Pipe parts catalogs are organized differently, depending on the profile where you run AutoCAD MEP. In the US Imperial and US Metric profiles, catalogs are individually organized based on material type, as follows:

- Cast iron
- Copper
- Ductile iron
- Plastic
- Steel

Fittings in these categories are grouped by connection type (such as threaded). The following shows the pipe parts catalog for cast iron parts.
Pipe parts catalog for cast iron pipe parts

In the Global profile, the pipe parts catalog is organized by type and outside diameter, as follows:

- Commercial pipe: Pipe and fitting dimensions based on commercial steel pipe; also includes plastic pipes, such as PVC.
- Ductile iron: Pipe and fitting dimensions based on commercial iron pipe
- Tube and fitting dimensions based on copper tubing
- Placeholder: Dimensionless 1-line parts used for preliminary pipe runs; can be converted to other pipe types

The following example shows the pipe MvParts catalog under the Mechanical chapter.

**Pipe MvParts under Mechanical**

Each pipe directory in the Global profile consists of fittings common to that pipe type. Pipe fittings are typically classified by part type, connection type, and pressure rating. The next example shows a directory structure for a class 3000 socket weld coupling.
Pipe fittings and connectors have specific connection types, but pipe segments do not. Pipe connectors, such as flanges, are treated as separate objects in the actual construction. For example, when a flanged elbow is connected to a pipe segment, a separate flanged connector is added to the pipe segment. You can account for all the connectors in the system and create schedules for them. Connection engagement lengths (CEL) are also used to accurately represent pipe lengths and joint locations in the system.

RELATED For more information, see Connector Engagement Length on page 267, Pipe Length on page 268, and Connectors of a Parametric Part on page 666.

Pipe Connections

Pipe connections model the components and construction of an actual piping system. Connectors attach pipe segments to joints, fittings, and MvParts. Separate joints, such as flanges and couplings, reflect actual construction components in schedules. Connection engagement length (CEL) is configured for parts to ensure accurate pipe lengths and joint locations.

Pipe Connectors

Pipe segments and fittings have connectors that allow pipe objects (such as pipe segments, fittings, and pipe MvParts) to form an intelligent system.

Connectors on pipe segments and most fittings are located at each end of the part.
Connectors on grooved couplings are located inside the coupling at the CEL depth, due to the design geometry of the grooved coupling.

**Grooved coupling connector locations**

MvPart and fitting connectors are assigned a connection type. For example, a base-mounted pump has flange connection types assigned to its connectors, and a threaded coupling has a threaded connection type assigned to it. A connector on an MvPart behaves similarly to a pipe connector on a fitting or pipe segment.

**RELATED** For more information about male-female connections, see Male-Female Fittings on page 267 and Recommendations for Creating Parametric Fittings Content on page 651.

Pipe segments do not have connection types assigned to their connectors. They do, however, inherit the connection type of the connected pipe fitting. For example, if a socket weld coupling is connected to one end of a pipe segment, the pipe connector on that end inherits the socket weld connection type. For more information, see Viewing Connection Details on page 311.

**Connector Assignments**

AutoCAD MEP determines the connectors on a pipe fitting or segment and adds the appropriate joints as specified in the pipe part routing preferences on page 250. The number of joints that the software adds depends on the connection type. The next illustration shows a pipe segment and fittings. The software determines the number of joints, as follows:

- **#1** refers to a pipe segment with an undefined connection type.
- **#2** refers to a grooved coupling with female connectors.
- **#3** refers to an elbow fitting with male connectors and undefined connection types.

The pipe segment (#1) inherits the connection type from the female grooved coupling (#2). The connector on the elbow fitting (#3) inherits the connection type from the female grooved coupling (#2), as specified in the routing preferences.

**RELATED** For more information, see Rules for Connector Behavior on page 652.
## Connection Types for Pipe and Pipe Fittings

You assign connection types in the Connector Properties dialog as you build fittings content using the Content Builder (see Adding Connectors to a Parametric Fitting on page 682). Assigned connection types are then displayed on the Connection Assignments tab on page 296 of the Pipe Layout Preferences dialog. The following table shows the different orientations of pipe connection types:

<table>
<thead>
<tr>
<th>Connection type</th>
<th>Connection orientation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flanged, all types</td>
<td><img src="image" alt="Diagram" /> Fitting to pipe: Flanges are typically included on fittings. A separate flange is added to the pipe segment. Pipe to pipe: A separate flange is added to each pipe end to create the connection. Fitting to fitting: Fittings with inherent flanges connect directly to each other. No separate flanges are added to the connection.</td>
</tr>
<tr>
<td>Threaded, Socket weld, Glued, Brazed</td>
<td><img src="image" alt="Diagram" /> Fitting to pipe: Pipe segments typically have inherent male ends, and fittings are typically female. The pipe inserts directly into the fitting. Pipe to pipe: A female coupling is inserted between the pipe segments. Fitting to fitting: Fittings connect directly to each other.</td>
</tr>
<tr>
<td>Grooved</td>
<td><img src="image" alt="Diagram" /> Fitting to pipe: Fittings and pipe segments are considered to have grooved ends that are ready to accept a coupling. A coupling is added to connect the fitting and pipe. Pipe to pipe: A coupling is added to connect the pipe segments. Fitting to fitting: A coupling is added to connect fittings.</td>
</tr>
<tr>
<td>Butt weld</td>
<td><img src="image" alt="Diagram" /> No extra objects are added. Fittings and pipe segments connect directly to each other.</td>
</tr>
</tbody>
</table>

**NOTE** The Piping domain includes a connection type called Same Connection. When Same Connection is configured for a pipe object that is attached to a hub, connector 1 inherits the connection type of the connection type on connector 2 of the attached hub. For more information, see Rules for Connector Behavior on page 652.

**RELATED** For more information about building parametric fittings content, see Adding Connectors to a Parametric Fitting on page 682 and Recommendations for Creating Parametric Fittings Content on page 651.
**Male-Female Fittings**

You can use Content Builder to create custom parametric parts with male, female, or a combination of both types of connectors based on real-world piping requirements. For example, you can set the CEL (connector engagement length on page 267) values to match the actual depth of the connector. You also can set the AoD value (angle of deflection on page 267) to match the allowable fitting tolerance on page 267 for the connector based on manufacturer specifications.

**RELATED** For more information, see [Recommendations for Creating Parametric Fittings Content](page 651), [Connectors of a Parametric Part](page 666), and [Creating a Parametric Fitting with Content Builder](page 675).

**Connector Engagement Length**

Each fitting in the pipe parts catalog on page 262 includes one or more connector engagement length (CELn) values. CEL is the length of pipe that is inserted into a fitting connection. CEL values are based on industry standards and are configured for all pipe fittings.

Except for grooved couplings, pipe connectors are located on the ends of pipe segments and fittings. In the software, when a pipe connects to a fitting, the end of the pipe is connected to the end of the fitting. In an actual pipeline, the pipe is inserted into the fitting.

**Pipe end connects to fitting end**

**RELATED** For more information about pipe connectors (including grooved couplings) and how pipe length is determined, see [Pipe Connectors](page 264) and [Pipe Length](page 268).

**Angle of Deflection (Fitting Tolerance)**

Angle of deflection specifies whether to allow deflection at joints that have a tolerance angle. Angle of deflection includes female connection types with non-standard angles based on manufacturer and user requirements. Angle of deflection is stored in the catalog content and is only available for those female fittings that are supported in the manufacturer specification. To turn on angle of deflection on supported female fittings in sloped piping on page 256 designs, select Yes for Use fitting tolerance on the Pipe Properties palette on page 286.

**RELATED** For more information, see [Sloped Piping](page 256) and [Drawing Sloped Piping](page 308).
**Pipe Joints**

AutoCAD MEP treats pipe joints as objects that are separate from the pipe segment. For example, a pipe segment with flanged connections actually comprises 3 objects: 1 pipe segment and 2 flanges.

The software adds joints as you draw pipe, based on selections made under Routing Options on the Pipe Properties palette on page 286. Having joints presented as separate objects renders more accurate systems that reflect the physical construction of the pipe system. You can create schedules for joint components, such as flanges or couplings. You can also manipulate the joints by changing their connection type or by refining their location on a pipe run.

The software categorizes pipe joints as fittings in the pipe parts catalog on page 262. Fittings are listed in the couplings directory and the asymmetric connectors directory. An example of an asymmetric connector is a socket weld flange. One side of the flange is configured with a socket to connect with a pipe, and the other side is a flange face that will connect with an adjacent flange.

**Pipe Length**

The length of a pipe segment is accurately modeled using separate joints. Cut length on the Properties palette is the actual length of the pipe and includes the depths needed to engage the flanges.

**Cut length on Properties palette**

Cut length refers to the distance between connectors inside a pipe segment. The following diagram differentiates pipe length from cut length, based on CEL (connector engagement length on page 267).
The reported cut length value varies depending on the connection type of the attached fitting. For example, with hub flange couplings, the software considers the overall length of the connected object (including the coupling length). The following example shows how the software reports the cut length based on this scenario. The overall calculated length includes the pipe length plus the coupling length, as shown next.

Pipe length varies, depending on what is connected to the pipe. The following illustrations show various pipe examples.

The first illustration shows a pipe segment. The second illustration shows a flange joint added to the pipe segment. The overall length of the pipe and joint is the same as the original pipe. However, the pipe end is moved so that it is in the same location as the flange connector. The pipe length is reduced by the width of the flange, and the CEL (connection engagement length on page 267) for the flange is added to the length to calculate the cut length.
The third and fourth illustrations show other fittings connected to the pipe end. If a coupling is added, the midpoint of the coupling is located at the original pipe end location. The pipe end is moved to the adjacent coupling face. An elbow is added at the end of the pipe, and the pipe end stays in the same location. The pipe length stays the same, but the cut length increases because the elbow CEL is added to the length. For each of the connections shown, the resulting pipe cut lengths vary from the original pipe length.

Cut length with grooved connections are reported differently. Due to their design geometry, grooved coupling connectors are located inside the coupling at their CEL on page 267 depth. Unlike other connection types, pipe ends insert into grooved couplings.

Joints and fittings have the following effect on pipe segments and cut length:

- When modifying pipe segments using lengthen grips on page 276 and dynamic dimensions, the dynamic length dimensions do not include CEL values.
- If you are working with a specific pipe length in a system, such as a stock length and you add or change a fitting, this might affect the cut length of a pipe segment.

**Pipe Snaps**

Pipe snaps quickly and accurately connect pipe objects. As you draw a pipe, you can use pipe snaps to connect a pipe, fitting, or MvPart directly to a pipe end connector at the end of a pipe segment. You can also connect to pipe curve connectors at any point along a pipe segment.

Pipe end connector

Pipe curve connector

**Pipe Elevation Lock**

You can lock pipe elevation as you draw a horizontal pipe run.

By restricting the pipe run to a specific elevation, you can avoid unintentional snapping to another object at a different elevation. When you want to connect a horizontal run to a vertical segment, locking the
elevation prevents the horizontal segment from snapping to one end of the vertical segment. It allows you to connect along the segment at the desired elevation. You can turn on the elevation lock for a portion of a pipe run, and turn it off for other portions where you want to use different elevations. If the lock is turned on, you cannot connect to an object on a different elevation.

**NOTE** The locked setting automatically resets to the unlocked state after a current pipe add session is ended.

Consider a scenario where you are working in the top view. You attempt to connect a horizontal run to a riser. You configure 2 viewports in the drawing window. The top view is used in the left pane and an isometric view to the right to preview routing solutions. In the top view, only the pipe end connector is available on the riser.

If you select the pipe end connector, routing solutions are offered that do not connect the horizontal run to the riser at the correct elevation.

If you lock the elevation before selecting the pipe snap on the riser, you connect to the riser at the elevation of the horizontal run.

You can lock the elevation for a portion of a pipe run and unlock it for other portions where you want to use different elevations. If locked, you cannot connect to an object on a different elevation. Additionally, you cannot lock elevation on a sloped pipe on page 256 segment.

**Pipe Grips**

Grips let you quickly add or modify pipe objects or MvParts. All available grips are displayed when you select an object in a drawing.
Grips for Adding to a Pipe Run

The add grips ( ¶ ) on pipe segments, pipe fittings, and MvParts let you accurately add more pipe objects to a run. Add grips ensure connectivity along the pipe run.

On a pipe segment

On a pipe fitting

On an MvPart (pump)

Used to draw pipe directly from a pump (isometric view)

Add grips on some fittings let you create a new branch directly from the fitting. For example, you can use an add grip on an elbow to convert it to a tee when drawing a pipe run. The existing pipe branches remain connected.
Add grip on an elbow

Pipe run drawn from the elbow

Elbow automatically converted to a tee

**RELATED** For more information, see *Adding Pipe Using Grips* on page 302.

### Grips for Modifying a Pipe Run

AutoCAD MEP includes various grips for modifying pipe objects in a pipe run.

#### Location Grips

Location grips let you move parts in the current XY plane in a pipe run while still maintaining connectivity with the rest of the system. This is known as associative movement. Location grips appear on the insertion and connector points on the part.
Elevation Grips

Elevation grips (▲) let you modify the elevation of parts and pipe segments in the model view, relative to the top, centerline, or bottom of the segment.

If the pipe segment or part is connected to other objects, you can specify whether to maintain their connectivity when you modify the elevation. For more information, see Modifying the Elevation of Pipe Components on page 320.

NOTE Elevation grips are not available on flex or sloping pipe segments. You modify the elevation of the start point of a flex pipe segment using the Properties palette. You modify sloping pipe segments by adjusting the elevations of connected fittings.
The following example shows how to modify the elevation of a pipe segment. To provide more room for accessing the valve hand wheels, a horizontal pipe segment is raised by a dimension relative to its current elevation. As a result, the software adjusts connected objects to maintain their connectivity.

**Modifying the elevation of a pipe**

![Diagram showing how to modify the elevation of a pipe](image)

**Flip and Rotate Grips**

Arrow-shaped (←) flip grips let you rotate piping in-line parts, fittings, and takeoffs 180 or 90 degrees in the direction indicated by the grip.
Rotating a 3-way valve 90 degrees in plan view

![Diagram of a 3-way valve with flip grip and rotate grip]

In isometric views, diamond-shaped ( △ ) rotate grips let you rotate the object around its centerline to any angle you specify.

AutoCAD MEP displays flip grips on all piping in-line parts, fittings and takeoffs with connectors on opposite ends. However, when it is necessary to preserve the connectivity of pipe runs, the software limits the available rotation options or hides the grips. For example, you can rotate a wye fitting on the left in several ways, but you cannot rotate the wye fitting on the right due to the connected branch.

When you rotate a part, fitting, or takeoff that is connected to other objects, the software adjusts the connected objects to maintain their connectivity. For example, the software might make minor adjustments to the lengths of connected pipe segments after you have flipped a fitting. If it cannot adjust the objects, it disconnects them.

RELATED For more information, see Rotating Pipe Components on page 321.

Lengthen Grips

Lengthen grips let you modify the length of pipe segments ( □ ). Lengthen grips constrain a segment to its current angle, making them particularly useful for lengthening pipe segments that are already placed.
When you use the lengthen grip on an end that is connected to another object, you can specify whether to maintain connectivity between the objects. For more information, see Modifying the Length of a Pipe Segment on page 322.

**Lengthen grips on pipe segments**

The next illustrations show a pipe segment in a sprinkler system that is lengthened with grips. To avoid interference with a duct system, the software adjusts the connected objects to maintain their connectivity.
Selected pipe

Selected lengthen grip in edit mode

New length entered

Resulting layout
If the pipe segment is not connected to another object, you can change both its length and angle using the Start grip or End grip. The Start and End grips let you change the XYZ location of the start point or endpoint of the segment. This is useful when you are initially designing runs because it lets you connect a segment to an existing run.

NOTE When using lengthen grips, the lengthen value displayed in the dynamic dimension is the same as the pipe length but may not be the same as the cut length. For more information, see Pipe Length on page 268.

Configuring Pipe System Settings

Pipe tools include properties for configuring pipe runs and ensuring more accurate piping designs. Pipe system settings are stored with a drawing. You can have different pipe system settings for different drawings and can share them between drawings.

Configuring Routing Preferences

You configure pipe part routing preferences by specifying a size range, parts, and connections to use in a pipe run.

RELATED For more information about creating new content, see Recommendations for Creating Parametric Fittings Content on page 651 and Workflow for Creating a Parametric Fitting with Content Builder on page 674.

Creating or Copying a Routing Preference

1 In the Piping workspace, click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Routing Preference Definitions.
2 Create or copy a routing preference, as follows:

<table>
<thead>
<tr>
<th>If you want to ...</th>
<th>then in the left pane of Style Manager ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a new, blank routing preference</td>
<td>Right-click Pipe Part Routing Preferences in the left pane, and click New. Enter a name, and press Enter.</td>
</tr>
</tbody>
</table>
If you want to ...  then in the left pane of Style Manager ...

| copy an existing routing preference | Right-click the routing preference in the left pane, and click Copy. Next, right-click Pipe Part Routing Preferences, and click Paste. Then, right-click the copied item, and click Rename. Enter a new name, and press Enter. |

**RELATED** For information on tools created from routing preferences, see *Creating Tools from Routing Preferences* on page 792.

### Configuring Properties for a Routing Preference

1. In the **Piping workspace**, click **Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Routing Preference Definitions**.
2. In the left pane of Style Manager, select a routing preference.
3. In the right pane, click the **General tab**, and configure the general properties.

<table>
<thead>
<tr>
<th>If you want to ...</th>
<th>then ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the name of the routing preference</td>
<td>enter the new name for Name.</td>
</tr>
<tr>
<td>add or change the description of the routing preference</td>
<td>enter information for Description.</td>
</tr>
<tr>
<td>add notes, such as a revision history</td>
<td>Click Notes. Click the Notes tab, and enter the information.</td>
</tr>
<tr>
<td>add a link to a reference document, such as a piping specification</td>
<td>Click Notes. Click the Reference Docs tab, and click Add. In the Select Reference Document dialog, browse to the document, and click Open. In the Reference Document dialog, enter a description of the document, and then click OK twice.</td>
</tr>
</tbody>
</table>

**RELATED** For information on transferring a routing preference to the tool palette, see *Creating Tools from Routing Preferences* on page 792.

### Configuring Size Ranges

1. In the **Piping workspace**, click **Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Routing Preference Definitions**.
2. Select a routing preference.
3. In the right pane, click the **Preferences tab**.
4. For **Part**, select a part type.

The part list contains all the unfiltered parts in the pipe catalog for the part type.

If you select a part that will modify the part size range, the software prompts as follows:

**NOTE** If you select *NONE* for a part type, the software will prompt you to choose a part during pipe layout if a part type is needed to satisfy the layout geometry. If you select a part without any sizes in common with one or more other parts, the other parts are reset to *NONE*. 

280 | Chapter 7   Drawing Piping Systems
5 To specify the upper and lower limits for a size range, do the following:

<table>
<thead>
<tr>
<th>If you want to specify ...</th>
<th>then ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>the upper limit</td>
<td>select a size for Size Upper Limit. You can select from the list of nominal sizes that are common to all of the selected parts in the size range. If a subsequent size range exists, its lower limit is changed based on the upper limit you selected for the current size range. If you need to select a larger size than is allowed in the list of choices, select different parts for the size range.</td>
</tr>
<tr>
<td>the lower limit</td>
<td>change the value for Size Upper Limit for the preceding size range. The lower limit of Size Range 1 is always defined by the selected parts in the range.</td>
</tr>
</tbody>
</table>

**TIP** You can switch the order of 2 size ranges by changing the upper limit of one range so that it is larger or smaller than the other.

6 Enter a description for the size range, if desired.

7 Add a range to designate a new size range.

The new size range is appended to the list of ranges. Its lower limit is the next catalog size up from the upper limit for the preceding size range, and its upper size limit is the largest catalog size.

8 To delete a range, select the name of the size range, and click Remove Size Range.

**NOTE** It is possible to create and save an invalid size range. For example, specifying an upper limit that is already in use by another size range could invalidate the size range. If a size range is invalid, "Invalid Size Range" is specified for Size Upper Limit in the routing preference definition, and the sizes in that range are unavailable nominal sizes on the Properties palette.

**Deleting a Routing Preference**

1 In the Piping workspace, click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Routing Preference Definitions .
2 In the left pane of Style Manager, right-click the routing preference you want to delete, click Purge, and then click OK.

**Configuring System Definitions**

Pipe system definitions specify display properties, such as pipe display by size, layer key settings, and rise/drop display style.

**Creating a System Definition**

**TIP** The default templates contain several system definitions that you can copy or modify.
1 In the **Piping workspace**, click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Piping System Definitions.

2 Create a pipe system definition:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then in the left pane of Style Manager…</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a new system definition</td>
<td>Right-click Pipe System Definitions in the left pane, and click New. Enter a name, and press Enter.</td>
</tr>
<tr>
<td>copy an existing definition</td>
<td>Right-click the system definition in the left pane, and click Copy. Next, right-click Pipe System Definitions, and click Paste. Then, right-click the copy, click Rename, enter a new name, and press Enter.</td>
</tr>
</tbody>
</table>

3 On the General tab, enter a description for the pipe system definition.

4 Specify values for other general properties that are common to other disciplines: mechanical, electrical, and plumbing. For more information, see **Creating Systems** on page 95.

5 Specify how to display pipes in the system. For more information, see **Configuring System Definitions for 1-Line, 2-Line, or Single Line Graphics** on page 282.

### Configuring System Definitions for 1-Line, 2-Line, or Single Line Graphics

1 In the **Piping workspace**, click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Piping System Definitions.

2 In the left pane of Style Manager, expand Piping Objects.

3 Expand Pipe System Definitions.

4 Select a system.

5 In the right pane, click the Single Line Graphics tab.

**To specify 1-line**

6 Choose an action below:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>display pipe and equipment as scaled 1-line</td>
<td>select Show pipe and inline/anchored components as Single Line displays. Then for pipe sizes less than or equal to, enter an upper limit diameter.</td>
</tr>
<tr>
<td>display pipe and equipment as graphical 1-line, not to scale, with equipment represented by schematic symbols</td>
<td>select Display pipe and inline/anchored components as graphical 1-line. For pipe sizes less than or equal to, enter an upper limit diameter. Then for Inline/anchored MvPart plot length, enter a plot length.</td>
</tr>
</tbody>
</table>
To specify 2-line

7 In the right pane of Style Manager, clear Display pipe and inline/anchored components as single line displays and Display pipe and inline/anchored components as graphical 1-line.

To specify single-line graphics

8 In the right pane of Style Manager, select Display pipe and inline/anchored components as single line displays.
9 For pipe sizes less than or equal to, enter an upper limit diameter.
10 Select Display pipe and inline/anchored components as graphical 1-line.
11 For pipe sizes less than or equal to, enter an upper limit diameter.
12 Enter a plot length for inline/anchored MvParts.
13 For Single Line Graphics Style (connector graphics), select a style.

TIP The blocks specified in the selected style will appear in the 1-line displays for the current system.

Configuring Graphics for Single Line Pipe Display

When configuring graphics for a single line pipe display, you match a connector type with a graphics block that most closely represents it in the current drawing.

1 In the Piping workspace, click Manage tab ➤ Style & Display panel ➤ Style Manager ➤ Style Manager.
2 In the left pane of Style Manager, expand Piping Objects.
4 Select a style.
5 In the right pane, click the Single Line Graphics tab.

6 For Connector Graphics Block, select a block that matches the pipe connection type in the left column.

**NOTE** Block naming for unique connection graphics use Aecb_ConnectionType. However, many connection types use the same Aecb_StandardPipe1LineGraphic graphics block.

7 Under Scaling for selected block, select Use Annotation Scale to scale the block to the annotation plot size.

8 Select Override Scale, and enter values for coordinates X, Y, and Z.

**NOTE** The annotation selections work together. The annotation scale determines whether the block should be annotative. The override scale determines whether the block should be scaled beyond the initial size of the annotation block. By default, blocks are scaled to the size of the nominal diameter. For more information, see Scaling Annotation on page 549.

---

**Configuring the Straight Centerline Display of Elbows**

You can control the centerline display of elbows and store results in the drawing.

**To display the straight centerline**

1 Enter `DisplayStraightCenterlines`.

2 Enter the domain: c (Conduit), d (Duct), p (Pipe), or a (All).

3 Enter y (Yes) to display straight centerlines on all applicable objects.

**NOTE** For more information, see Straight Centerline Display of Elbows on page 261.
Creating a Piping System

You insert an architectural floor plan as a reference and design piping systems within that floor plan. You then create a piping system by adding equipment and pipe runs to a drawing. You can add pipe components in the following ways:

- Click Home tab ➤ Build panel ➤ Pipe drop-down ➤ Pipe .
- Click Home tab ➤ Build panel ➤ Pipe Fitting .
- Click Home tab ➤ Build panel ➤ Equipment drop-down ➤ Filter or other equipment.
- Using add grips on pipe objects to add additional parts to the layout. For more information, see Grips for Adding to a Pipe Run on page 272.
- Selecting a pipe tool from the tool palette. For more information, see Adding Pipe Using the Tool Palette on page 291.
- Entering PipeAdd from the command line
- Selecting a pipe object, and clicking Pipe tab, Pipe Flex tab, or Pipe Fitting tab ➤ General panel ➤ Add Selected .
- Selecting an MvPart, and clicking Equipment tab ➤ General panel ➤ Add Selected .

After you create piping systems, you can modify the layout to reflect changes from the original design.

Adding Pipe Equipment

You can place an MvPart in a drawing. You can also add an in-line or anchored MvPart to a pipe.

RELATED See Mechanical, Electrical, and Plumbing Equipment in Building Systems on page 76.

Placing a Pipe MvPart in a Drawing

1 In the Piping workspace, select a tool from the Pipe Equipment tool palette.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Equipment drop-down and select from pipe equipment choices.

The Add MvParts dialog displays the current part catalog at the part type folder associated with the tool you selected.

2 On the Part tab, select a part subtype in the folder.
3 Click Details to view available sizes.
4 Select Display/Hide additional parameters to expand the contents of the parameters table.
5 Click the Part Filter tab, and enter the desired criteria under Filter by Dimensions.

NOTE The part catalogs and content locations determine the parts that you can add. If the part is unavailable, you can create a custom part using Content Builder.

6 Select a part size name.
7 Select a defined elevation, or enter a value.
8 (Optional) Click the K-Factor tab to assign a K-factor value to sprinklers.

**TIP** Sprinklers are listed under Fire Protection.

9 Specify an insertion point in the drawing, and use the compass to specify a rotation angle.

10 Press Enter to end the command.

**TIP** To add another MvPart that is currently in the drawing, select the MvPart, click Equipment tab ➤ General panel ➤ Add Selected . You can also use the AutoCAD COPY or ARRAY commands to add more MvParts. For more information on these AutoCAD commands, see the AutoCAD Help.

**Adding Parts In-Line to Pipe**

1 Add a Pipe MvPart, as described in Placing a Pipe MvPart in a Drawing on page 285.

2 To place the part on a pipe, move the cursor to a pipe segment to display a pipe end or pipe curve connector.

3 Click the pipe connector to place the part in-line to the pipe or anchored to a pipe end, and use the compass to specify a rotation angle.

4 Press ENTER to end the command.

After the part is inserted, you can use grips to rotate the part around the centerline of the pipe segment. You can also flip an in-line part, such as a check valve, to orient the part in the proper flow direction.

**Adding Pipe**

You can draw pipe runs anywhere on a floor plan. All pipes and fittings include connectors that let you connect directly to other pipe objects and MvParts.

Prior to drawing pipe systems, if necessary, review pipe routing preferences and system definitions. See Configuring Pipe System Settings on page 279.

**Pipe Properties Palette (Add Mode)**

This section defines the properties on the Design tab of the Properties palette that you use to add pipe objects. The Design tab is divided into two categories: Basic and Advanced.
## Basic Properties

By default, Basic properties are displayed on the Pipe Properties palette.

### NOTE
In the following tables, properties related to sloped piped layouts on page 256 are preceded by an asterisk (*). Properties related to flexible pipe are preceded by double asterisks (**) and are only available when you add flexible pipe.

<table>
<thead>
<tr>
<th>General</th>
<th>Action</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Enter an explanation for the pipe part (optional).</td>
<td>Standard (default); selections derived from the catalog</td>
</tr>
<tr>
<td>System</td>
<td>Select a system definition for the pipe object in the current drawing.</td>
<td></td>
</tr>
<tr>
<td>Routing preference</td>
<td>Select a routing preference for the pipe object in the current drawing.</td>
<td>Standard (default); selections derived from the catalog</td>
</tr>
<tr>
<td>Nominal size</td>
<td>Select a size on page 252 within the range specified in the current routing preference.</td>
<td>2&quot; (first time); thereafter, last used value selected</td>
</tr>
<tr>
<td>Size lock</td>
<td>Lock to prevent the nominal size from being edited in Modify mode.</td>
<td>[Unlocked (default)] [Locked]</td>
</tr>
</tbody>
</table>

### Dimensions

<table>
<thead>
<tr>
<th>Dimension</th>
<th>Action</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Routing preference</td>
<td>Select a routing preference for the pipe object in the current drawing.</td>
<td>Standard (default); selections derived from the catalog</td>
</tr>
<tr>
<td>Nominal size</td>
<td>Select a size on page 252 within the range specified in the current routing preference.</td>
<td>2&quot; (first time); thereafter, last used value selected</td>
</tr>
<tr>
<td>Size lock</td>
<td>Lock to prevent the nominal size from being edited in Modify mode.</td>
<td>[Unlocked (default)] [Locked]</td>
</tr>
</tbody>
</table>
### Dimensions

**Specify cut length**
- **Cut length**
  - Select Yes and then, for Cut length, enter a dimension. Selecting No hides the Cut length property.
  - **No (default)**

**RELATED** For more information, see Pipe Length on page 268.

### Placement

**Elevation**
- Enter a Z value (elevation) above or below the XY plane of the current user coordinate system (UCS).
  - **0 (default)**

**Elevation lock**
- Lock to prevent objects of one elevation to snap to objects of another elevation.
  - **Unlocked (default)**
  - **Locked**

**Start elevation**
- Enter an elevation for connector 1 on the pipe object. Start elevation is the same value as Elevation.
  - **0 (default)**

### Justification

**Justify**
- Orientate the justification of the pipe object.
  - **Center (default)**
  - **Center Left**
  - **Center Right**
  - **Top Left**
  - **Top Center**
  - **Bottom Right**
  - **Bottom Left**
  - **Bottom Center**
  - **Top Right**

**Horizontal offset**
- Enter a placement offset in the horizontal direction from the insertion point.
  - **0 (default). This field is editable.**

**Vertical offset**
- Enter a placement offset in the vertical direction from the insertion point.
  - **0 (default)**

### Routing

**Slope format**
- View the current slope format (not editable). The slope format affects the slope property (for example, as a fraction, decimal, or percentage).

**NOTE** To change the slope format, click Preferences to open the Pipe Layout Preferences on page 293 dialog.
<table>
<thead>
<tr>
<th><strong>Routing</strong></th>
<th><strong>Action</strong></th>
<th><strong>Selections</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>■ Rise value, Run=constant value</td>
</tr>
<tr>
<td></td>
<td></td>
<td>■ Fractional Rise value, Run= constant value</td>
</tr>
<tr>
<td>*Slope</td>
<td>Enter a slope value (rise/run in previous releases) that reflects the slope format.</td>
<td>0 (default)</td>
</tr>
<tr>
<td><strong>NOTE</strong></td>
<td>If you change the slope value while you are adding more pipe parts to a run, a fitting will be added to adjust the slope.</td>
<td></td>
</tr>
<tr>
<td>*Bend angle</td>
<td>Select the angle to constrain the routing in the pipe run.</td>
<td>The bend angle value is pre-defined in the catalog: 45 or 90 degrees.</td>
</tr>
<tr>
<td>*Bend angle lock</td>
<td>Lock to prevent the bend angle from being edited.</td>
<td>■ Unlocked (default)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>■ Locked</td>
</tr>
<tr>
<td><strong>Segment</strong></td>
<td>Select the layout method for the flexible pipe on page 310.</td>
<td>■ Line</td>
</tr>
<tr>
<td></td>
<td></td>
<td>■ Arc</td>
</tr>
<tr>
<td></td>
<td></td>
<td>■ Spline</td>
</tr>
<tr>
<td><strong>Radius factor</strong></td>
<td>If Line is selected for Segment, enter a radius value.</td>
<td></td>
</tr>
<tr>
<td>*Branch angle</td>
<td>Select the angle (for example, 45 or 90 degrees) to which tees and laterals are constrained in the branch.</td>
<td>The selections vary, depending on the angles that are defined in the catalog content. For example, if lateral is selected, then only angles from the routing preferences pertaining to the selected lateral appear. Takeoff appears as a read-only value of 90 degrees.</td>
</tr>
<tr>
<td>*Branch angle lock</td>
<td>Lock the branch angle to prevent it from being edited.</td>
<td>■ Unlocked (default)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>■ Locked</td>
</tr>
</tbody>
</table>

**Advanced Properties**

Advanced properties are collapsed by default. To view advanced properties, click (Down arrow).
### Advanced properties shown expanded

![Advanced properties shown expanded](image)

**NOTE** In the following tables, properties related to *sloped piped layouts* on page 256 are preceded by an asterisk (*). Properties related to flexible pipe are preceded by double asterisks (***) and are only available when you add flexible pipe.

<table>
<thead>
<tr>
<th>Properties</th>
<th>Action</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connection details</td>
<td>Click <img src="image" alt="icon" /> to open the Connection Details worksheet.</td>
<td>For more information, see <strong>Viewing Connection Details</strong> on page 311.</td>
</tr>
<tr>
<td>Insulation thickness</td>
<td>Enter the <strong>insulation thickness</strong> on page 317 for the pipe segment.</td>
<td>0 (default)</td>
</tr>
<tr>
<td>Routing options <strong>Graphics</strong></td>
<td>Select the desired pattern for flexible pipe. For more information, see <strong>Drawing a Flexible Pipe Run</strong> on page 310.</td>
<td><strong>Circle</strong>&lt;br&gt;<strong>Curve</strong>&lt;br&gt;<strong>Oval</strong>&lt;br&gt;<strong>Single line, single line 2</strong>&lt;br&gt;<strong>Vertical, vertical 2</strong></td>
</tr>
<tr>
<td><strong>Pitch</strong></td>
<td>Enter a pitch value. For more information, see <strong>Drawing a Flexible Pipe Run</strong> on page 310.</td>
<td><strong>Yes</strong> (default)&lt;br&gt;<strong>No</strong></td>
</tr>
<tr>
<td>*Use fitting tolerance</td>
<td>Select Yes to turn deflection on at joints that have a tolerance angle specified in the content. This property controls the tolerance for the female fitting connection. <strong>TIP</strong> If a fitting (such as a flange) does not support angle of deflection, the software will disregard a Yes selection. See <strong>Angle of Deflection (Fitting Tolerance)</strong> on page 267.</td>
<td><strong>Tee or Wye (Lateral) (default)</strong>&lt;br&gt;<strong>Tee only</strong>&lt;br&gt;<strong>Takeoff only</strong>&lt;br&gt;<strong>Wye (Lateral) only</strong>&lt;br&gt;<strong>Wye (Lateral) or Tee</strong></td>
</tr>
<tr>
<td>*Branch fitting</td>
<td>Select the fitting combination you want to use when adding a branch. If you select a double fitting combination (such as Tee or Wye), the software will use the first fitting, and if unsuccessful, will use the second fitting.</td>
<td><strong>Tee or Wye (Lateral) (default)</strong>&lt;br&gt;<strong>Tee only</strong>&lt;br&gt;<strong>Takeoff only</strong>&lt;br&gt;<strong>Wye (Lateral) only</strong>&lt;br&gt;<strong>Wye (Lateral) or Tee</strong></td>
</tr>
</tbody>
</table>
## Routing options

<table>
<thead>
<tr>
<th>Setting</th>
<th>Action</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fitting settings</td>
<td>Click ![image] to open the Fitting Settings worksheet. For more information, see <a href="#">Overriding a Fitting</a> on page 305.</td>
<td>Opens the Fitting Settings worksheet</td>
</tr>
<tr>
<td><em>Preferences</em></td>
<td>Click ![image] to configure pipe layout preference settings. For more information, see <a href="#">Configuring Pipe Layout Preferences</a> on page 293.</td>
<td>Opens the Pipe Layout Preferences dialog (includes the <strong>General Preferences</strong> tab on page 294 and the <strong>Connection Assignments</strong> tab on page 296)</td>
</tr>
</tbody>
</table>

## Labels

<table>
<thead>
<tr>
<th>Setting</th>
<th>Action</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Style</td>
<td>Select the label style for the pipe run.</td>
<td>![image] <em>NONE</em> (default)</td>
</tr>
<tr>
<td></td>
<td>RELATED For more information about By Quantity and By Distance, see <a href="#">General Preferences</a> on page 294.</td>
<td>![image] By Quantity</td>
</tr>
<tr>
<td></td>
<td></td>
<td>![image] By Distance</td>
</tr>
</tbody>
</table>

## Flow arrows

<table>
<thead>
<tr>
<th>Setting</th>
<th>Action</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Style</td>
<td>Select the flow arrow style for the pipe run.</td>
<td>![image] <em>NONE</em> (default)</td>
</tr>
<tr>
<td></td>
<td>RELATED For more information about By Quantity and By Distance, see <a href="#">General Preferences</a> on page 294.</td>
<td>![image] By Quantity</td>
</tr>
<tr>
<td></td>
<td></td>
<td>![image] By Distance</td>
</tr>
</tbody>
</table>

**TIP** If you are routing pressure piping on page 251, you can increase the software response time by doing the following: specify No for Use fitting tolerance, specify the desired angle for Bend angle, and specify the preferred Branch fitting. This helps the software generate more specific auto-layout routing solutions on page 254 based on specific settings.

## Adding Pipe Using the Tool Palette

1. In the Piping workspace, to display the Piping tool palette, click **Home tab ➤ Build panel ➤ Tools drop-down ➤ Tools ![image]**.  
   The Piping tool palette contains separate tabs for pressure pipe and gravity pipe tools.

2. Click the Pressure Pipe or the Gravity Pipe tab.  
   Use pressure pipe tools in non-sloped piping designs.
Use gravity pipe tools in sloped piping designs.
Configuring Basic Properties for Pipe

1. On the Properties palette on page 286, under General, enter a description for the pipe object (optional).

2. Select the system definition for the pipe run. For more information, see Pipe System Definitions on page 257.

3. Under Dimensions, select the routing preference. Routing preferences reflect the size ranges, pipe parts, and fitting connections that the software uses as you lay out the pipe run. For more information, see Routing Preferences.

4. Select a nominal size. The drop-down list includes the available sizes common to the pipes and fittings specified in the current routing preference. For more information, see Size Ranges in Routing Preferences on page 252.

   **TIP** You can optionally lock this property. Locking the nominal size prevents an accidental change to sizing values when you are modifying the pipe routing.

   **NOTE** The available sizes apply to the pipes and fittings specified in the current routing preference. Sizes are grouped based on the size ranges in that routing preference. If a size is unavailable, you can select a different routing preference or modify the parts in the size range for the selected routing preference. For more information, see Configuring Size Ranges on page 280.

5. Under Placement, enter the elevation for the pipe object. The elevation is the Z value above or below the XY plane of the current user coordinate system (UCS).

**RELATED** For more information, see Pipe Properties Palette (Add Mode) on page 286.

Configuring Pipe Layout Preferences

You use the Pipe Layout Preferences dialog to define layout preferences for a pipe run, including slope, elevation, labels, and flow arrows. You can also assign male to female connection types when an undefined, male connection type is attached to a female connection type.

Pipe layout preferences are stored with the drawing. You can use different layout preferences for different drawings, and you can share layout preferences between drawings.

- In the Piping workspace, use any of these methods to access pipe layout preferences:
  - Click Manage tab ➤ Preferences panel ➤ Piping
  - On the Properties palette on page 286, under Routing, click (Preferences).
  - Start the Add Pipes command on page 291.

**RELATED** For more information, see Pipe Properties Palette (Add Mode) on page 286.
General Preferences

You use the General tab in the Pipe Layout Preferences dialog to control pipe layout preferences for slope, elevation, labels, and flow arrows. You can specify preferences for slope, elevation, labels, and flow arrows.

General tab in the Pipe Layout Preferences dialog

Slope preferences

1 On the General tab of the Pipe Layout Preferences dialog on page 293, select a slope format. Slope format affects the Slope property on the Properties palette on page 286. Slope format is stored with the drawing. The list includes the following slope formats:

<table>
<thead>
<tr>
<th>Slope format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Angle</td>
<td>Expressed in degrees (for example, 2 degrees)</td>
</tr>
<tr>
<td>Percentage</td>
<td>Expressed as a percent, where 100%=45 degrees</td>
</tr>
<tr>
<td>Percentage</td>
<td>Expressed as a percent, where 100%=90 degrees</td>
</tr>
<tr>
<td>Rise/Run</td>
<td>Expressed as a fraction (for example, 1/48 or 1/100)</td>
</tr>
<tr>
<td>Rise/Run with Constant Rise</td>
<td>Expressed as a decimal</td>
</tr>
<tr>
<td>Rise/Run with Constant Run</td>
<td>Expressed as a decimal</td>
</tr>
<tr>
<td>Rise/Run with Fractional Rise, Constant Run</td>
<td>Expressed as a fraction, such as 1/4 for a 1/4” rise with a 12” run</td>
</tr>
</tbody>
</table>

**NOTE** The Slope property on the Properties palette is displayed as a fraction.

**NOTE** The Slope property on the Properties palette displays the Run portion of Rise/Run (for example, 20, where run is 1).

**NOTE** The Slope property on the Properties palette displays the Rise portion of Rise/Run.
2 Choose drawing units for Rise and for Run.

   The Units list is only turned on if you first selected a slope format. The units in the list are
   derived from the current profile and from selections made in the Drawing Setup dialog. For
   example, for Metric, you can choose meters, millimeters, etc. For Imperial, you can choose feet
   or inches.

3 Enter a Constant value.

   You can only edit constant value for Rise if you previously selected Rise/Run with Constant Rise
   for Slope format. You can only edit constant value for Run if you previously selected Rise/Run
   with Constant Run for Slope format.

4 Select slash (/) or colon (:) for the preferred ratio divider.

Elevation preferences

5 Do either of the following:

   a Select Automatically create riser at new elevation to turn on this layout behavior.

   b Select Override slope based on elevation and placement point to automatically calculate
      the slope value based on the current elevation and the location of the cursor in the drawing.

6 NOTE Override slope is not available (grayed out) when you select Automatically create a riser at
      the new elevation.

Label preferences

7 Select a label style.

   Label preferences are stored in the registry.

   NOTE If you select None, skip the next step.

8 Select By quantity or By distance:

   ■ For By quantity, enter the number of labels to add to each straight segment.

   ■ For By distance, enter a segment length. If the segment length is less than the interval
     distance, a label is not automatically added to that segment.

   NOTE For more information, see Modifying a Label Style on page 555 and Adding Labels or Flow
     Arrows to Pipe on page 317.

Flow arrow preferences

9 Select a flow arrow style from the list.

   NOTE If you select None, skip the next step.

10 Select By quantity or By Distance:

   ■ For By quantity, enter the number of flow arrows to add to each straight segment.

   ■ For By distance, enter a segment length. If the segment length is less than the interval
     distance, a flow arrow is not automatically added to that segment.

The following examples show label and flow arrows in a pipe run:
Connection Assignments

You use the Connection Assignments tab to assign the proper name of a male connection type to its female counterpart.

1. In the Pipe Layout Preferences dialog on page 293, click the Connection Assignments tab.

2. For Male Connection, click a male connection type, and then click ↓ (Down arrow).

3. Select a male connection type that you want to assign to the corresponding female connection type in the left column.
Any connection type designated as Undefined that attaches to a female connector type in a drawing will display as male and will reflect the selection made in this dialog.

NOTE Male or female connection types must adhere to rules for connection behavior on page 652 based on the CEL on page 267 value. Connector assignments originate from the catalog content.

Configuring Justification for Pipe Insertion

The software sets the horizontal and vertical justification for pipe insertion to the centerline of the pipe. The centerline of the resulting pipe segments and fittings will be placed along the points you specify as you draw pipe runs. The elevation specifies the height location for vertical justification.

![A pipe object justified along its centerline](image)

To set justification and horizontal and vertical offsets

1. On the Properties palette on page 286, under Placement ➤ Justification, specify the justification settings for pipe insertion:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>align the pipeline centerline along the points you specify for the pipe run</td>
<td>under Justification, specify Center for Horizontal and Vertical. Specify offset values for each.</td>
</tr>
<tr>
<td>align one side of the pipeline along the points you specify for the pipe run</td>
<td>under Justification, specify from one of nine combinations of Left, Right, Top, or Bottom settings for Justify to align 2 sides along the insertion points.</td>
</tr>
<tr>
<td>offset the pipeline by a uniform distance from the points you specify for the pipe run</td>
<td>enter vertical and horizontal distance offsets.</td>
</tr>
</tbody>
</table>

You can optionally lock the pipe elevation property. See Locking Pipe Elevation During Drawing on page 315.

Specifying Cut Length

1. Start the Add Pipes command on page 291.
2. On the Properties palette on page 286, under Dimensions, choose Yes to specify a cut length for the pipe run.
3. Enter a cut length value.

Consider this scenario. If a pipe system is going to be fabricated from 10-foot long pipes, you can configure pipe layout preferences so that straight pipe runs are automatically broken into 10-foot intervals as you draw them. Joints are automatically added at the break interval. The resulting pipes and couplings are still connected as a pipe system. After the pipe run is drawn, the pipe runs are automatically cut into lengths.
When activated, the automatic cut length is applied to all pipe system definitions. For example, the cut length is applied to chilled water systems, steam systems, natural gas systems, or any other defined pipe system in the drawing. If you want to use different cut lengths when drawing different pipe systems, change the cut length as described in this procedure prior to working with each system. You can also break or join pipe segments after you have drawn them. For more information, see Breaking or Merging Pipe Segments on page 329.

### Drawing a Pipe Run

1. Start the Add Pipes command on page 291.
2. In the drawing, specify a starting point for the pipe run.
3. Continue specifying points to lay out the geometry of the pipe run.

As you lay out a pipe run, fittings are inserted based on the routing preference and pipe layout preference settings. If you lay out geometry for which a part is not specified in the preference or if the part is available but the specified size or angle is not, the software prompts you to make a substitution.

**TIP** The compass, object snaps, AutoCAD MEP snaps, Ortho mode, and tracking lines are tools you can use to lay out a pipe run.

4. To start a new run, enter `n` (New run) on the command line, and specify the settings on the Properties palette on page 286.

**NOTE** When you add pipe runs, AutoCAD MEP inserts rise symbols and drop symbols based on the rise/drop style assigned to the system of the run.

### Connecting to Existing Pipe

You can use pipe snaps to connect a new run anywhere along an existing pipe segment or fitting. The fittings that are automatically inserted between the existing pipe and the new pipe are configured in the routing preference and pipe layout preference.

To connect a new pipe segment to an existing segment

1. If necessary, turn on the AutoCAD MEP pipe snaps.
2. Start the Add Pipes command on page 291.
3 To start a new run from the end of a segment, move the cursor over the end of the existing pipe segment to display the pipe end connector snap.

4 Click the pipe end connector to specify the start point of the new run. The routing preference, size, and system for the new run match the existing pipe.

5 On the Properties palette on page 286, under Routing Options, specify a layout method.

6 To use a different size for the new run, specify a new nominal size under Dimensions.

**IMPORTANT** The available sizes include those common to all of the pipes and fittings specified in selected routing preference. This ensures that you select a pipe size that matches fittings of the same size. (The sizes are also grouped according to the size ranges defined in the routing preference.) If a size is not available, select a different routing preference, or modify the parts in the size ranges in the current routing preference.

If you use a different size for the new run, a transition fitting is inserted to connect the new pipe to the existing pipe.

7 Continue specifying points to lay out the run.

**TIP** You can also use the add grips to start a pipe run from a pipe end.

**To start along a pipe**

8 To start a run at a point along a pipe segment, move the cursor over the existing pipe segment to display the pipe curve connector snap.

9 Click the pipe curve connector to specify the start point for the new run. Based on the connection type configured in the pipe layout preference, a takeoff or tee is inserted.

10 Continue specifying points to lay out the run.
To end a run on an existing pipe

11 Move the cursor over the existing pipe segment to display the pipe curve connector or pipe end connector.

12 Click the pipe curve or pipe end connector to specify the endpoint of the run and connect to the existing segment.

Based on the connection type configured in the pipe layout preference, a takeoff or tee is inserted.

If you try to connect pipes on different elevations, AutoCAD MEP creates one or more routing solutions you can preview and use to automatically connect the pipes.

13 Press Enter to end the command.

Connecting a Pipe Run to an MvPart

You can connect a pipe run to an MvPart. If so, check the connection type and size on the MvPart so that you can specify your routing preference and pipe size accordingly. You can also manually specify a part to connect a run to an MvPart.

To connect a pipe run to an MvPart

1 Start the Add Pipes command on page 291 and begin laying out the pipe run.

2 As your pipe run approaches the MvPart that you want to connect to, click Track (Object Snap Tracking) on the application status bar to line up your pipe run with the desired connection on the MvPart.

Using tracking to align a pipe run with a pipe connection on a chiller
3 Move the cursor over the MvPart connection to display the pipe end connector.

4 Click the pipe end connector to connect the pipe run to the MvPart.

**TIP** You might be prompted to accept or undo the connection.

If the pipe segment centerline is not aligned with the MvPart connector centerline, the software automatically presents **routing solutions** you can preview and use.

5 If the size or connection type of the pipe segment does not match the size or connection type of the MvPart, specify the fittings to use to make the connection:

<table>
<thead>
<tr>
<th>If...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>the pipe size differs from the MvPart connection size</td>
<td>a transition fitting is automatically inserted. Accept the connection. If a transition is not specified in the routing preference, the <strong>Choose a Part dialog</strong> prompts you to specify the transition.</td>
</tr>
<tr>
<td>the pipe connection type differs from the MvPart connection type</td>
<td>the <strong>Choose a Part dialog</strong> prompts you to specify the fittings for this connection.</td>
</tr>
<tr>
<td>you want to use a fitting in the part catalog that is not configured in the routing preference</td>
<td>specify the fitting on the <strong>Properties palette</strong> on page 286, and insert it at the end of the pipe run. For more information, see <strong>Overriding a Fitting</strong> on page 305. Once the fitting is inserted, you might need to move the fitting to connect the pipe run with the MvPart.</td>
</tr>
</tbody>
</table>

**Adding a Vertical Segment to a Pipe Run**

1 Start the **Add Pipes command** on page 291 and begin **laying out the pipe run**.

2 Specify the point in the layout where you want to start the vertical segment.

   The elevation at this point is the start point of the vertical segment. You can specify start and end elevation values later when you **modify the pipe run** on page 325.

3 On the **Properties palette** on page 286, under **Placement**, specify the elevation of the endpoint of the vertical segment.
4 Continue specifying points for the pipe run geometry.

**TIP** When drawing pipe systems, you can check connectivity among components, and you can set and view flow direction. Maintaining connectivity in a system ensures that all modifications are applied to the appropriate parts. For more information, see Checking Connectivity in a Pipe System on page 332 and Drafting with Flow Direction on page 118.

---

**Adding Pipe Using Grips**

1 Select the object in the drawing, and click `{ add grip }` to begin drawing a pipe run:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>start a run from one of the ends of a pipe segment</td>
<td>click the add grip at one end of the segment.</td>
</tr>
<tr>
<td>start a run from the midpoint of a pipe segment</td>
<td>click the add grip at the midpoint of the segment. A tee or takeoff is automatically inserted, depending on the connection specified for pipe layout preferences.</td>
</tr>
<tr>
<td>start a run from an MvPart</td>
<td>click the add grip on the MvPart connection.</td>
</tr>
<tr>
<td>start a run from a fitting, such as an elbow or tee</td>
<td>click the add grip pointing in the direction of where you want to start the new run.</td>
</tr>
</tbody>
</table>

**TIP** The software will use the part specified in the Routing Preferences if possible. If not, the Choose a Part dialog on page 303 will prompt you to pick a part to insert into the layout at the appropriate angle.
<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>add a joint to an existing pipe run</td>
<td>hold down the Ctrl key while clicking the add grip and then click to add pipe.</td>
</tr>
<tr>
<td><strong>TIP</strong></td>
<td>If the Use fitting tolerance property on the Properties palette on page 286 is set to Yes, a coupling will be added to the pipe. This is true only if it is within the allowable fitting tolerance (angle). On the other hand, if Use fitting tolerance is set to No, an elbow will be added.</td>
</tr>
</tbody>
</table>

2 On the Properties palette on page 286, under Routing Options, specify the layout method that you want to apply to the new pipe run.

3 If you start from an MvPart, under Dimensions, specify a system and a routing preference.

   The software remembers the routing preference and system setting. The routing preference and slope (if applicable) are automatically set based on the connected object. If you start from a pipe segment or fitting, the new run inherits those preferences.

4 If you change the nominal size before specifying the first segment of the new run, a transition is automatically inserted between the object and the new pipe segment after you specify the first point of the new run.

**IMPORTANT** The available sizes include those common to all of the pipes and fittings specified in selected routing preference. This ensures that you select a pipe size that matches fittings of the same size. (The sizes are also grouped according to the size ranges defined in the routing preference.) If a size is not available, select a different routing preference, or modify the parts in the size ranges in the current routing preference.

5 Continue specifying points for the pipe run layout geometry.

**Manually Specifying Parts During Layout**

As you draw a pipe run, fittings are automatically inserted into the layout based on the current preferences. Sometimes, however, you might be prompted to specify parts that are not included in the current routing or part preference.

**Choosing a Part**

The Choose a Part dialog displays if you try to add or modify a part in a run that is not stored in your preferences. You will be prompted to make a substitution from the catalog. The following example shows the dialog in the Piping domain in the US Imperial or US Metric profile:
The following table summarizes scenarios where the Choose a Part dialog is displayed, prompting you for a part substitution:

<table>
<thead>
<tr>
<th>Scenario</th>
<th>Displays a dialog as you add to the layout</th>
<th>Displays a dialog as you modify the layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>The part is not stored in the current routing preference (for pipe) or part preference (for duct, cable tray, or conduit).</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>The current routing or part preference includes the correct part but not the specified angle.</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>The part size is not specified in the current routing or part preference.</td>
<td>yes The dialog prompts you to select a reducer.</td>
<td>yes</td>
</tr>
<tr>
<td>An additional part is required in the layout, and the reducer that you specified does not meet the size requirement.</td>
<td>no</td>
<td>yes A reducer is automatically added.</td>
</tr>
<tr>
<td>You tried to connect objects with different joint types (for example, butt welded and fusion) that are not included in the current routing or part preference.</td>
<td>yes</td>
<td>no</td>
</tr>
</tbody>
</table>

If you modify a pipe layout, the Choose a Part dialog zooms to the part in the layout that requires action. After you make a selection, the original view is resumed. To turn off this feature, clear Zoom to the object. Your last preference for the specific domain is automatically retained until you change it.

The substitution you make only applies to the specific location in the layout. If you repeat this action while the Pipe Add command is still active, the dialog prompts you to select a part again.

If the preferred part or connection type is unavailable, click Cancel and then add the desired fitting on page 306 manually.

You might also be prompted to choose a part multiple times if you try to connect objects either with different connection types on page 266 or whose centerlines are not aligned. In such cases, the parts you choose are automatically used to create one or more routing solutions.
Overriding a Fitting

You can override a routing preference and specify a different part to use while drawing a pipe run. For example, if you want to use a threaded takeoff for a specific run instead of the default butt-welded takeoff, you can override the default takeoff.

When you override a default part, it remains in effect until you end the Pipe Add command. The next time you add pipes, the default part in the routing preference is resumed.

NOTE As long as the Pipe Add command is active, the override part is used in place of the default part.

To override a default fitting

1 Start the Add Pipes command on page 291.
2 On the Properties palette on page 286, expand Advanced, and under Routing Options, click (Fitting Settings).

Fitting Settings worksheet

The Fitting Settings worksheet shows the current description and size range from the catalog, and lists the available types and parts. If no value is available, the worksheet shows “- -”.

3 In the Fitting Settings worksheet, select the fitting type to override.
4 Choose a part from the drop-down list.
5 Specify points to lay out the pipe run.

The overridden part is automatically inserted into the layout.

The override is removed after you end the PipeAdd command. The next time you run PipeAdd, the default part from the routing preference is once again used.

Multiple Parts Found

If you try to create a fitting with more than one size available for the pipe you are adding, the Multiple Parts Found dialog prompts you to make choose one. If you modify the layout, the software zooms to the location where you need to select a substitute part. After you select from the list of available part size names, the original layout is resumed. To turn off this feature, clear Zoom to the object. The software remembers your last preference.
Using Routing Solutions to Connect Objects

1 Start a pipe segment from the first object.
   For information on starting a pipe run from an existing pipe object, see Adding Pipe Using Grips on page 302 or Connecting to Existing Pipe on page 298.

2 Move the cursor directly to the second object to display a pipe end or pipe curve connector.

3 Click the pipe connector.

4 If you are connecting to an object with a different pipe size or a different routing preference, you may be prompted to choose a part to connect to the second object.
   The first routing solution is displayed.

5 To preview the next routing solution, enter n (next), and press Enter.

6 Repeat the previous step to preview more routing solutions.

7 When you preview a preferred routing solution, enter a and press Enter to accept that routing solution.
   The pipe run is automatically updated.

Adding a Pipe Fitting Manually

AutoCAD MEP adds pipe fittings as you draw a pipe run based on the default fittings specified in the pipe routing preferences. However, you can also add a pipe fitting manually to an existing segment or to a run.

Routing preferences specify the common fittings used for most pipe layouts. However, the default pipe parts catalog includes many other fittings you can use.

To add a pipe fitting manually

1 In the Piping workspace, select a fitting on the Pipe Fitting tool palette.

   NOTE Alternatively, click Home tab ➤ Build panel ➤ Pipe Fitting drop-down ➤ Pipe Fitting.

2 On the Properties palette, under General, click the part image next to Part.

3 In the Select a Part dialog, choose a part from the catalog.
Select a Part dialog

Under Select Part from Catalog, the dialog organizes pipe fittings based on material type in the US Imperial and US Metric profiles. For more information, see Pipe Parts Catalog on page 262.

4 (Optional) Select Display/Hide additional part parameters to expand the contents of the parameters table.

5 Under Filter by Dimensions, filter the list of parts.

 NOTE The part catalogs and content locations determine the parts that you can select.

6 Select a part size and click OK.

7 On the Properties palette on page 286, under Placement, enter an elevation.

 NOTE If you insert a fitting in an existing pipe run, you do not need to specify the elevation. The fitting inherits the elevation and system settings from that pipe run.

8 Specify an insertion point in the drawing, and use the compass to specify a rotation angle.

You can use pipe curve or pipe end connectors to insert the fitting on an existing pipe object.

Creating a Custom Pipe Fitting

You can create a custom pipe fitting when the required fitting is not available from the part catalog or you need to match a unique design. You create custom fittings by converting AutoCAD lines, arcs, and polylines into AutoCAD MEP objects with connectors. Part properties, such as size, shape, and system definition are inherited from the connecting parts to maintain system integrity. Part properties, such as CEL (connector engagement length) and AoD (angle of deflection), are stored with the drawing. Custom fittings are style-based objects that you can access from Style Manager. Each custom fitting you create represents a single style. For more information, see Connector Engagement Length on page 267 and Angle of Deflection (Fitting Tolerance) on page 267.
NOTE You cannot add custom fittings to a part catalog. If you create a custom fitting to be used multiple times, you can share custom fittings between drawings using the copy and paste functionality.

1 In the Piping workspace, draw the centerlines of the new custom fitting using lines, polylines, or arcs.

2 Click Home tab ➤ Build panel ➤ Pipe Fitting drop-down ➤ Pipe Custom Fitting.

3 Click the lines just drawn, and then press Enter.

4 In the Create Custom Fitting dialog, enter a name, and select a system.

5 Select the diameter for the start and end of each segment, and then select Mitered End if an end is mitered.

6 Determine if the properties are applied to some or all of the segments:

   ■ If the properties assigned to the current segment are the same for all segments, select Apply to All Segments.

   ■ If the properties of the next segment are different from those of the current segment, click Next twice.

   NOTE The Next button is not available if you select Apply to All Segments.

7 Click Finish.

8 On the command line, enter y (yes) to erase the original centerline geometry or n (no) to keep the original geometry in the drawing.

NOTE If any size or shape properties of the segments are incomplete, the software will prompt you that it cannot create the custom fitting.

Drawing Sloped Piping

1 Start the Add Pipes command on page 291 to lay out the pipe run.

   NOTE You can use the Gravity Pipe tab on the Piping tool palette to add pipe segments to a sloped piping layout. For more information, see Adding Pipe Using the Tool Palette on page 291. You can also use Add grips on page 302 to add to a pipe run.

2 On the Properties palette on page 286, under General, select a routing preference that supports sloped piping.

   NOTE For more information on routing preferences that support sloped piping, see Routing Preferences on page 250 and Sloped Piping on page 256.

3 Select a nominal size in the current routing preference.

4 Under Routing, click (Preferences) to open the Pipe Layout Preferences on page 293 dialog.
NOTE You cannot edit Slope format on the Properties palette. You select a format that satisfies your piping requirements in the Pipe Layout Preferences dialog. For example, selecting Rise/Run with Fractional Rise sets a fractional slope per foot (for example, 1/4” per foot). For more information, see General Preferences on page 294.

5 Under Slope, for Slope format, select the preferred format and click OK.

6 On the Properties palette, under Routing, enter a slope value based on the slope format.

   TIP A negative slope value pitches the pipe downward from the main or branch (as seen in isometric view in the drawing). For example, -1/4” reflects a downward 1/4” per foot slope.

7 Expand Advanced.

8 Under Routing Options, for Use Fitting tolerance, select Yes.

   Fitting tolerance refers to the angle of deflection that is allowed on a fitting connection. Yes (default) turns on angle of deflection for fittings that support sloped pipe runs. Selecting No turns this option off. For more information, see Angle of Deflection (Fitting Tolerance) on page 267 and Sloped Piping on page 256.

   TIP If a female fitting, such as a flange, does not support angle of deflection, the software disregards a Yes selection.

9 For Branch fitting, select the desired combination. For example, Tee then Lateral (default) specifies that first a tee is added to the branch, followed by a lateral.

10 Under General, for Routing, select a branch angle.

   The content in the routing preference includes 45 and 90 degrees. The angle you choose determines how the branch will be drawn. You select Values from catalog selection to use all angles in the current routing preference in the layout.

   If the desired angle in the layout is outside the range of the standard angle and tolerance, the Choose a Part dialog prompts you to make a part substitution. For more information, see Choosing a Part on page 303.

11 Specify a point in the drawing, and click to draw the pipe.
Adding pipe

**NOTE** If you connect a pipe segment directly to another segment in a pipe run, the software displays the actual slope value for the pipe segment. For more information, see Constrained Layout Solutions on page 255 and Slope Value Displayed in Constrained Piping Layouts on page 257.

As you continue to lay out parts in the pipe run, auto layout on page 252 can generate different routing solutions on page 254. The command line prompts you to accept the preferred solution.

The software inserts a coupling or an elbow into the piping layout, depending on the allowable fitting tolerance. For example, you might draw pipe at an angle of 5 degrees. Then, if the layout angle is less than the allowable fitting tolerance of 10 degrees, a coupling is inserted into the layout. However, if the layout angle is greater than the allowable fitting tolerance, the software inserts an elbow.

12 (Optional) To make connection assignments on fittings in your template drawing, click the Connection Assignments tab in the Pipe Layout Preferences dialog. For more information, see Connection Assignments on page 296.

13 Press Enter to exit from the Pipe Add command.

**TIP** If you are routing pressure piping on page 251, you can increase the software response time by doing the following: specify No for Use fitting tolerance, specify the desired angle for Bend angle, and specify the preferred Branch fitting. This helps the software generate more specific auto-layout routing solutions on page 254 based on specific settings.

**RELATED** For a summary of all the pipe properties, including those related to gravity (sloped) piping, see Pipe Properties Palette (Add Mode) on page 286.

## Drawing a Flexible Pipe Run

Use this procedure to draw a flexible pipe run.

**NOTE** You cannot draw a sloped flexible pipe run in AutoCAD MEP. As a result, properties related to Sloped Piping will not appear on the Properties palette on page 286. See Sloped Piping on page 256 for more information.
1 If necessary, in the Piping workspace, click Home tab ➤ Build panel ➤ Tools drop-down ➤ Tools.

2 Select a flexible pipe tool from the Piping tool palette.

**TIP** You can also use the PipeFlexAdd command or hold down the Alt key for the same result.

3 On the Properties palette on page 286, under General, specify a system.
4 Under Dimensions, specify a routing preference.
5 Select a nominal size for each pipe connector.
6 Under Placement, specify an elevation.
7 Under Routing Options, for Segment, specify the layout method for the flex pipe as follows:

<table>
<thead>
<tr>
<th><strong>If you want to</strong></th>
<th><strong>then...</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>lay out the flex pipe as a series of straight line segments</td>
<td>select [Line for Segment. Specify a value for Radius factor. Any angled transitions in the flex pipe segment use this radius value. \right</td>
</tr>
<tr>
<td>lay out the flex pipe as a series of arcs</td>
<td>select \Arc for Segment. \right</td>
</tr>
<tr>
<td>lay out the flex pipe as a complex curve by specifying points for a spline</td>
<td>select \Spline for Segment. \right</td>
</tr>
</tbody>
</table>

8 Expand Advanced ➤ Graphics. Under 1-Line, select an annotation pattern for Graphics. This pattern is applied to flex pipe runs after you draw them, and it is visible for flex pipe systems displayed as 1-line.

9 Specify a value for Pitch. The pitch specifies the interval between the pattern, based on the drawing scale.

10 Repeat the previous steps for 2 Line and click OK when done. This pattern is visible for flex pipe systems displayed as 2-line.

**TIP** You can use pipe curve or pipe end connectors to connect a flexible pipe run with a rigid pipe object. You can use flexible and rigid pipes in the same system while maintaining connectivity throughout the system.

### Viewing Connection Details

1 In the drawing, select a pipe object.
2 On the Properties palette on page 286, expand Advanced.
3 Click \Connection details\.
The Connection Details worksheet displays the following information depending on the type of pipe object that is selected. All values except location coordinates are read-only. You can edit Location X, Location Y, and Elevation Y in this worksheet:

- **Nominal size**: Size as specified in the routing preference
- **Flow direction**: In, out, or bidirectional orientation of the flow of the pipe object
- **Connection type**: Connection assignment that you make on the Connection Assignments on page 296 tab in the Pipe Layout Preferences dialog
- **Maximum tolerance angle (AoD)**: Maximum allowable angle of deflection for fittings stored in the catalog content
- **Current tolerance angle**: Current angle of deflection for the selected fitting as specified in the catalog content
- **Location X, Location Y, and Elevation Z (editable)**: Applies to the 2D and elevation coordinates

**TIP** Maximum tolerance angle (AoD) and current tolerance angle are displayed in current angle units.
Adding a Parallel Pipe Run Using Offsets

You can use justification on the Properties palette to offset a new pipe run from an existing run. When you draw the parallel run, you select points on the existing run, and the new parallel run is created at the offset distance. You can select points on the existing run using AutoCAD MEP snaps.

**TIP** Drawing a parallel pipe run might be easier if you use a 1-line display for the existing pipe run. This reduces the potential number of points to specify, and it allows you to accurately select transition points. For more information, see Pipe System Displays on page 258.

**RELATED** For additional information about drawing parallel pipe runs, see Adding Parallel Pipes to a Radiant Heating System on page 347.

**To draw a parallel pipe run using offsets**

1. Verify that the AutoCAD MEP pipe snaps are turned on, and turn off (Object Snap) and (Object Snap Tracking) on the application status bar.
2. Start the Add Pipes command on page 291.
3. On the Properties palette on page 286, under Justification, specify the horizontal and vertical offsets:

<table>
<thead>
<tr>
<th>If you want to</th>
<th>then</th>
</tr>
</thead>
<tbody>
<tr>
<td>offset the new run at a horizontal distance (X or Y direction) from the existing run, with both runs at the same elevation</td>
<td>under Justification, set a value for Horizontal offset. To offset the new run in a positive X or Y direction from the existing run, enter a positive value. To offset in a negative X or Y direction, enter a negative value.</td>
</tr>
<tr>
<td>offset the new run at a vertical distance from the existing run, with both runs having the same X-Y dimensions at different elevations</td>
<td>under Justification, set a value for Vertical offset. To offset the new run in a positive Z direction from the existing run, enter a positive value. To offset in a negative Z direction, enter a negative value.</td>
</tr>
</tbody>
</table>

4. In the drawing, select the pipe end connector at the start of the existing pipe run.
5. Continue selecting points along the run.

**IMPORTANT** To achieve the most accurate layout, select points at each end of the pipe segments. For angled transitions, such as elbows, select only the pipe curve connector at the logical intersection of the fitting centerlines as shown in the following example.
Note that for elbows and other curved fittings, a pipe curve connector is displayed at the logical intersection of the fitting centerlines. This ensures that the pipe is offset the specific distance along the entire parallel run.

**IMPORTANT** If you draw parallel pipe runs at a close distance to each other, and plot them at a small scale, they may blend together on the plotted sheet. In the drawing, you may need to space the pipe runs far enough apart so that they render accurately and individually on the plot.

### Offsetting Pipe from Existing Geometry

You can draw a pipe run that is offset a specific distance from existing geometry, such as a wall, in a referenced drawing. The geometry can be AutoCAD® lines or blocks, AutoCAD Architecture building objects, or AutoCAD MEP objects, and the geometry can exist in a reference drawing. You can select points on the geometry using snaps.

**To draw an offset pipe run**

1. **Start the Add Pipes command** on page 291.

2. On the **Properties palette** on page 286, under Placement ➤ Justification, specify the horizontal and vertical offsets as follows:

<table>
<thead>
<tr>
<th>If you want to</th>
<th>then</th>
</tr>
</thead>
<tbody>
<tr>
<td>offset the new run at a horizontal distance (X or Y direction) from the geometry, with the geometry and pipe run at the same elevation</td>
<td>set a value for Horizontal offset. To offset the new run in a positive X or Y direction from the existing geometry, enter a positive value. To offset in a negative X or Y direction, enter a negative value.</td>
</tr>
<tr>
<td>offset the new run at a vertical distance from the geometry, with both having the same X-Y dimensions at different elevations</td>
<td>set a value for Vertical offset. To offset the new run in a positive Z direction from the geometry, enter a positive value. To offset in a negative Z direction, enter a negative value.</td>
</tr>
</tbody>
</table>

3. In the drawing, select a point on the geometry.
You can use object or AutoCAD MEP snaps to select points on the geometry.

4. Continue selecting points along the geometry.
   To turn off the offset at any point, specify 0 for Horizontal Offset or Vertical Offset, and continue laying out the run.

---

### Locking Pipe Elevation During Drawing

1. Start the Add Pipes command on page 291.
2. On the Properties palette on page 286, under Placement, specify an elevation and begin the pipe run.
3. Lock the elevation property to prevent a pipe segment along a run to snap to a segment at a different elevation.

_TIP_ By default, the lock is turned off whenever you start the PipeAdd command. The setting also resets to Unlocked when the command ends. See Pipe Elevation Lock on page 270 for more information.

_TIP_ To connect a horizontal pipe to a vertical pipe, move the cursor over the vertical segment to get a pipe curve connector, and click on it. If necessary, try using a different view, such as a side or isometric view, to achieve the desired connection.

---

### Adding a Takeoff to a Pipe

You can add a takeoff perpendicular to the pipe centerline and rotate it at any angle around the pipe. The simplest way to add a takeoff is to connect a pipe segment to a pipe curve connector on an existing segment. If a takeoff is the specified connection type in the pipe layout preferences, a takeoff is automatically inserted to connect the new segment to the existing segment.

To add a takeoff to a pipe segment

1. If necessary, in the Piping workspace, click Home tab ➤ Build panel ➤ Tools drop-down ➤ Tools ⦿.
2. Select a fitting, tap, or takeoff from the Piping tool palette.
3 On the Properties palette on page 286, under General, click the part image.
4 In the Select a Part dialog, choose a part from the catalog.

**Select a Part dialog**

Under Select Part from Catalog, the dialog organizes pipe parts based on material type in the US Imperial and US Metric profiles. For more information, see Pipe Parts Catalog on page 262.

5 Select Display/Hide additional parameters to expand the contents of the parameters table.
6 Under Filter by Dimensions, filter the list of parts.

**NOTE** The part catalogs and content locations determine the parts that you can add.

7 Select a part size and click OK.
8 In the drawing, move the cursor to the location on the pipe segment to add the takeoff.
9 Click the pipe curve connector.

**TIP** For 1-line pipe, a pipe curve connector appears when you move the cursor over the pipe centerline. For 2-line pipe, a pipe curve connector appears when you move the cursor over the contour lines of the pipe.

10 (Optional) To change the insertion point after you place the takeoff, enter **sl** (slide), and specify a new insertion point.
11 Enter an angle to rotate the takeoff around the pipe, or use the compass to specify an angle.
12 Press **Enter** to end the command.

**TIP** You can use rotate grips to **rotate** the newly added takeoff.
Adding Insulation to Pipe

Insulation is only visible when piping is displayed as 2-line. When you activate this feature, insulation is added to all pipe system definitions as you draw pipe. A new pipe or pipe fitting inherits the insulation values from the existing pipe or pipe fitting where it was added.

![Insulation on Pipe System](image)

**NOTE** Insulation is an annotation element that shows where insulation is used on a pipe system. Because it is not an object, you can only modify how and where it displays in the drawing. However, you cannot create schedules for insulation.

To add insulation to pipes

1. Start the Add Pipes command on page 291.
2. On the Properties palette on page 286, expand Advanced, and enter an insulation thickness.

Adding Labels or Flow Arrows to Pipe

You can add annotation, such as labels and flow arrows, as you lay out the pipe run. You can configure label styles to display pipe diameter or system type properties.

![Label and Flow Arrow on Pipe](image)

To add a label or flow arrow

1. Start the Add Pipes command on page 291.
3. Under Label, specify a style from the list.
4. For Layout Method, specify the label and flow arrow configurations to add to each pipe segment you select:

<table>
<thead>
<tr>
<th>If you chose</th>
<th>then</th>
</tr>
</thead>
<tbody>
<tr>
<td>By quantity</td>
<td>specify the total number of labels or flow arrows to display on each pipe segment. Note that the number of labels or flow arrows is automatically added to each straight segment.</td>
</tr>
<tr>
<td>By distance</td>
<td>specify the distance to insert a label or flow arrow at uniform intervals on each pipe segment. Note that if a pipe segment length is less</td>
</tr>
</tbody>
</table>
If you chose  

then

than the interval distance, a label or flow arrow is not added to that segment.

Flow arrows by distance

Flow arrows repeated at a uniform interval

**RELATED** For more on annotation, such as tags, schedules, cross-sectional views, and details, see Annotation on page 548.

**Converting a Polyline to Flexible Pipe**

1. Select the polyline, line, arc, or spline to convert.
2. Right-click, and click Convert to ➤ Flex Pipe.
3. On the command line, enter n (No) to leave the layout geometry or y (Yes) to erase it from the drawing.
   If prompted, choose a part.
4. On the Properties palette on page 286, configure basic piping properties.

**Modifying a Piping System**

You can make changes to a pipe system at any point during the design process. The topics in this section offer instructions on how to modify various aspects of the pipe system.

**Selecting or Filtering Objects**

There are various ways to select objects in a drawing. For example, you can:

- Move the cursor over an object, and click to select it.
- Drag the cursor from left to right to select only objects that are entirely enclosed by the rectangular area.
- Select similar objects in a drawing that have the same part subtype, size, and system as the selected object. For more information, see Selecting Similar Objects.
- Select MEP objects based on different criteria: System, System Group, Domain, or Connected Branches. For more information, see Selecting MEP Objects on page 120.

You can filter objects and modify those with a common property on the Properties palette on page 325. For more information, see Filtering Pipe Objects with Quick Select on page 319 and Filtering by Pipe Part Type on page 319.
Filtering Pipe Objects with Quick Select

1 Select multiple objects.

Select Connected Branches command used to select a pipe run

2 On the Properties palette on page 325, click (Quick Select).

3 In the Quick Select dialog, specify the following filter settings and then click OK:
   ■ Object type
   ■ Property
   ■ Operator
   ■ Value

Selection set filtered by part type where only elbows in the run are selected

Filtering by Pipe Part Type

1 Select multiple objects.

2 Select the part type from the list at the top of the Properties palette on page 325.

3 Edit the part properties available for that part type.
Modifying Components Using Grips

You can use grips to modify pipe components in a pipe run including:

- Location grips
- Elevation grips
- Flip grips (rotate 180 degrees)
- Lengthen grips

Moving Pipe Components Using Location Grips

1. Select the part or pipe segment.
2. Select a location grip.
3. If the part or pipe segment is connected to another object, specify whether and how to maintain connectivity:
   
<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>maintain connectivity by adjusting all objects, including MvParts</td>
<td>click the location grip and then click the Ctrl key once.</td>
</tr>
<tr>
<td>break connectivity</td>
<td>click the location grip and then click the Ctrl twice.</td>
</tr>
</tbody>
</table>

   **NOTE** If you want to maintain connectivity by adjusting only pipe fittings and segments and retain the current locations of MvParts, skip to the next step.

4. Specify the new location:
   
<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>specify the new location relative to the current location</td>
<td>for an offset in the X direction, move the part in the direction of its new location, enter a value, and press Enter. For an offset in the Y direction, press Tab to toggle to the Y offset, enter a value, and press Enter.</td>
</tr>
<tr>
<td>manually specify the new location</td>
<td>drag the cursor to move the location, and click to specify the new location. You can use object snaps, AutoCAD MEP snaps, and tracking lines to help specify the new location point.</td>
</tr>
</tbody>
</table>

   **NOTE** To use the dimension input fields, both dynamic input (on the status bar) and the Dimension Input drafting setting must be turned on (default). If you have turned them off, you can specify the new location by dragging the cursor and specifying a point in the drawing or by entering the coordinates in the command window.

Modifying the Elevation of Pipe Components

1. Change to a side or isometric view.
2. Select a part or pipe segment.
3. Select the elevation grip to use.
4 If the part or pipe segment is connected to another object, specify whether and how to maintain connectivity:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>maintain connectivity by adjusting only pipe fittings and segments, and retain the current locations of parts</td>
<td>proceed to the next step.</td>
</tr>
<tr>
<td>maintain connectivity by adjusting all objects, including parts</td>
<td>press Ctrl.</td>
</tr>
<tr>
<td>break connectivity</td>
<td>press Ctrl twice.</td>
</tr>
</tbody>
</table>

5 Specify the new elevation:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>specify the new overall elevation relative to a point on the part or segment (for example, the centerline)</td>
<td>press Tab as many times as needed to activate the appropriate input field, and then enter the resulting dimension. Press Enter.</td>
</tr>
<tr>
<td>raise or lower the elevation by a specified dimension</td>
<td>drag the cursor to begin raising or lowering the elevation. Press Tab as many times as needed to activate the appropriate input field, and then enter the relative dimension. Press Enter.</td>
</tr>
</tbody>
</table>

**TIP** To use the dimension input fields, both dynamic input (on the status bar) and the Dimension Input drafting setting must be turned on (default). If you have turned them off, you can specify the new elevation by dragging the cursor and specifying a point in the drawing, or by entering the coordinates in the command window.

---

**Rotating Pipe Components**

1 Select the in-line part, pipe fitting, or takeoff.

2 Rotate the object as follows:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>rotate the object 180 degrees (flip the object)</td>
<td>click the flip grip ( ).</td>
</tr>
<tr>
<td>rotate the object 90 degrees</td>
<td>while pressing CTRL, click the flip grip ( ).</td>
</tr>
<tr>
<td>rotate the object to an angle you specify</td>
<td>click the rotate grip ( ), and do one of the following: enter the new absolute angle in the active dimension input field.</td>
</tr>
<tr>
<td></td>
<td>drag the cursor to reduce or increase the angle, click Tab to activate the dimension input field for specifying the angle change, and enter the value.</td>
</tr>
<tr>
<td></td>
<td>drag the grip to a new location.</td>
</tr>
<tr>
<td></td>
<td>enter the value in the command window.</td>
</tr>
</tbody>
</table>
Modifying the Length of a Pipe Segment

1. Select the pipe segment.
2. Select the lengthen grip on the end you want to modify.
3. If the segment is connected to an object on the end you selected, specify whether and how to maintain connectivity:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>maintain connectivity by adjusting only pipe fittings and segments, and retain the current locations of parts</td>
<td>proceed to the next step.</td>
</tr>
<tr>
<td>maintain connectivity by adjusting all objects including parts</td>
<td>press Ctrl.</td>
</tr>
<tr>
<td>break connectivity</td>
<td>press Ctrl twice.</td>
</tr>
</tbody>
</table>

4. Specify the segment length:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>specify the new total length</td>
<td>press Tab to activate the input field for specifying the resulting dimension, and then enter the new length. Press Enter.</td>
</tr>
<tr>
<td>specify the difference between the current length and new length</td>
<td>drag the cursor to begin lengthening or shortening the segment, and then enter the change in length in the input field that is active by default. Press Enter.</td>
</tr>
<tr>
<td>specify a new endpoint</td>
<td>drag the grip to the endpoint, and click to specify the point.</td>
</tr>
</tbody>
</table>

**NOTE** To use the dimension input fields, both dynamic input (on the status bar) and the Dimension Input drafting setting must be turned on. They are turned on by default. If you have turned them off, you can specify the new length by selecting a stretch point in the drawing or entering one in the command window.

Modifying Pipe Equipment

You can modify MvPart properties, including location, elevation, size, or system assigned to its connectors. You can also use grips to move MvParts. For more information, see Modifying Components Using Grips on page 320.

**RELATED** See Mechanical, Electrical, and Plumbing Equipment in Building Systems on page 76.

Modifying the Location or Elevation of an MvPart

You can change the location or elevation of an MvPart using the Properties palette or the Multi-view Part Properties dialog. Either method causes the MvPart to break from any pipe runs to which it is currently connected.
Using the Properties palette

1 Select the MvPart you want to modify in the drawing.
2 On the Properties palette on page 325, under Placement, specify a location or orientation change:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the elevation</td>
<td>specify an elevation.</td>
</tr>
<tr>
<td>rotate the MvPart around its normal axis</td>
<td>specify a value for Rotation.</td>
</tr>
<tr>
<td>enter coordinates to specify a new location</td>
<td>1 Click (Additional information).  2 In the Location worksheet, under Insertion Point, specify the new X, Y, and Z coordinates and click OK.</td>
</tr>
<tr>
<td>change the normal axis, and reorient the part along the new normal</td>
<td>1 Click (Additional information).  2 In the Location worksheet, under Normal, specify 1 for the normal axis and 0 for the other 2 axes and click OK.</td>
</tr>
</tbody>
</table>

Using the Multi-view Part Properties dialog

1 In the drawing, select the MvPart to modify.
2 Click Equipment tab ➤ Modify panel ➤ Equipment Properties ➤ Equipment Properties.  3 In the Multi-view Part Properties dialog, click the Location tab.  4 Specify the location or orientation change, and then click OK, as follows:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>rotate the part around its normal axis</td>
<td>Under Rotation, specify a value for Angle.</td>
</tr>
<tr>
<td>enter coordinates to specify a new location</td>
<td>Under Insertion Point, specify the new X, Y, and Z coordinates.</td>
</tr>
<tr>
<td>change the normal axis and reorient the part along the new normal</td>
<td>Under Normal, specify 1 for the normal axis and 0 for the other 2 axes.</td>
</tr>
</tbody>
</table>

Modifying the Size or Elevation of an MvPart

1 Select the MvPart to change.
2 Click Equipment tab ➤ Modify panel ➤ Modify Equipment ➤ Modify Equipment.  3 On the Part tab of the Multi-view Part Modify dialog, select a part from the part type folder.  4 To filter the list of parts, click the Part Filter tab and specify a part size name from the list.  

**NOTE** The part catalogs and content locations determine the parts that you can add.

5 Specify an elevation and click OK.
NOTE If you change the elevation for an MvPart that is connected to other objects, the objects remain connected and are placed at the new elevation.

Matching an MvPart of One Type to Another

1 Select the MvPart to change.
2 Click Equipment tab ➤ Modify panel ➤ Modify Equipment.
3 In the Multi-view Part Modify dialog, click (Match).
4 In the drawing, select the MvPart you want to match.
5 Press Enter to match both the part and the elevation.
6 Click OK in the Multi-view Part Modify dialog to complete the match.

Modifying the K-Factor

1 Select the part (for example, sprinkler) you want to modify (see Mechanical folder ➤ Fire Protection).
2 Click Equipment tab ➤ Modify panel ➤ Modify Equipment.
3 In the Multi-view Part Modify dialog, click the K-Factor tab.
4 Specify a new value for K-Factor and click OK.

Modifying the System for an MvPart Connector

When you add an MvPart to a drawing, no systems are assigned to its connectors. If you connect a pipe run to an MvPart connector, the connector inherits the system setting from the connecting pipe object.

You can specify the system for MvPart connectors. Then, if you use the add grip to begin drawing pipe runs directly from the MvPart, the system is already specified for the new run.

If you change the system for an MvPart connector that is connected to a pipe run, the system for the pipe run changes to match that of the MvPart connector.

To change the system assigned to an MvPart connector

1 In the drawing, select the MvPart to modify.
2 Click Equipment tab ➤ Modify panel ➤ Equipment Properties.
3 In the Multi-view Part Properties dialog, click the Systems tab.
4 In the System column, click the cell for the connector you want to specify.
5 Select a system from the list, and click OK.

Modifying Pipe

You can modify many aspects of pipes, flex pipes, and pipe fittings, including type, size, location, system, and connected pipe runs.
Pipe Properties Palette (Modify Mode)

This section defines the properties on the Design tab of the Properties palette that you use as you modify the piping system. The Design tab is divided into two sections: Basic and Advanced.

Basic Properties

Basic properties are expanded by default. The properties reflect the last stored value.

<table>
<thead>
<tr>
<th>General</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Information about the object (optional)</td>
</tr>
<tr>
<td>Layer</td>
<td>The layer style on page 132 for the selected object</td>
</tr>
<tr>
<td>System</td>
<td>The system definition for the selected object</td>
</tr>
</tbody>
</table>

### Dimensions

<table>
<thead>
<tr>
<th>Description</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Routing preference</td>
<td>The routing preference for the selected pipe object</td>
</tr>
<tr>
<td>Nominal size</td>
<td>The size on page 252 in the routing preference for the selected object</td>
</tr>
<tr>
<td>Size lock</td>
<td>Lock prevents the editing of nominal size while you are modifying the pipe routing.</td>
</tr>
<tr>
<td>Cut length</td>
<td>The reported value of the length on page 268 of the pipe</td>
</tr>
</tbody>
</table>

### Placement

<table>
<thead>
<tr>
<th>Description</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Elevation</td>
<td>The elevation of the pipe object</td>
</tr>
</tbody>
</table>
### Placement

<table>
<thead>
<tr>
<th>Description</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start elevation</td>
<td>The elevation at the starting and ending points of the pipe segment</td>
</tr>
<tr>
<td>End elevation</td>
<td></td>
</tr>
</tbody>
</table>

**Start/end elevation on Properties palette**

<table>
<thead>
<tr>
<th>Placement</th>
<th>Elevation</th>
<th>UCS: Z</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start elevation</td>
<td>UCS: Z</td>
<td></td>
</tr>
<tr>
<td>End elevation</td>
<td>UCS: Z</td>
<td></td>
</tr>
</tbody>
</table>

**Move attached segments**

The ability to specify whether to move the attached pipe segments if the location of the selected part has changed (default — Yes)

**Additional information**

Click to open the Location worksheet.

**NOTE** For more information, see Modifying the Pipe or Fitting Location on page 328.

### Routing

<table>
<thead>
<tr>
<th>Description</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>*Slope format</td>
<td>The display of the current slope format</td>
</tr>
<tr>
<td>*Slope</td>
<td>The slope value of the current pipe object</td>
</tr>
</tbody>
</table>

**NOTE** You cannot modify this format selection. You cannot modify this value.

### Advanced Properties

Advanced properties are collapsed by default. To view advanced properties, click (Down arrow).
Advanced properties (includes pipe flex properties)

NOTE In the following table, properties related to sloped piped layouts on page 256 are preceded by an asterisk (*). Properties related to flexible pipe are preceded by double asterisks (**) and are only available when you add flexible pipe.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connection details</td>
<td>Click to open the Connection Details worksheet.</td>
</tr>
<tr>
<td></td>
<td>NOTE For more information, see Connection Details on page 264.</td>
</tr>
<tr>
<td>Anchors (for fittings)</td>
<td>Click to open the Anchor worksheet.</td>
</tr>
<tr>
<td></td>
<td>NOTE The Anchor icon and Anchor worksheet only display for pipe fittings and</td>
</tr>
<tr>
<td></td>
<td>symbols that use anchors (such as takeoffs). For more information, see Part</td>
</tr>
<tr>
<td></td>
<td>Anchors on page 111.</td>
</tr>
<tr>
<td>Insulation thickness</td>
<td>The insulation thickness of the current pipe segment</td>
</tr>
<tr>
<td><strong>Graphics</strong></td>
<td>The pattern for flexible pipe</td>
</tr>
<tr>
<td></td>
<td>NOTE For more information, see Drawing a Flexible Pipe Run on page 310.</td>
</tr>
<tr>
<td><strong>Pitch</strong></td>
<td>The pitch value for flexible pipe</td>
</tr>
<tr>
<td></td>
<td>NOTE For more information, see Drawing a Flexible Pipe Run on page 310.</td>
</tr>
<tr>
<td><strong>Geometry</strong></td>
<td>Used when you modify the layout of flexible pipe</td>
</tr>
<tr>
<td></td>
<td>NOTE For more information, see Modifying the Layout of a Flexible Pipe on</td>
</tr>
<tr>
<td></td>
<td>page 331.</td>
</tr>
</tbody>
</table>
Modifying the Routing Preference and Nominal Size

You can apply a different routing preferences on page 250 to a pipe run to change connection types, such as change a run from flanged connections to grooved. You can also change pipe type, such as change commercial pipe to iron pipe.

1. Select a pipe segment in a run.
2. On the Properties palette on page 325, under Dimensions, specify a routing preference.
3. Under Dimensions, select a nominal size.

**IMPORTANT** The available sizes include those common to all of the pipes and fittings specified in selected routing preference. This ensures that you select a pipe size that matches fittings of the same size. (The sizes are also grouped according to the size ranges defined in the routing preference.) If a size is not available, select a different routing preference, or modify the parts in the size ranges in the current routing preference.

4. Click Pipe tab ➤ Modify panel ➤ Modify Run ➤ Modify Run.
5. In the Modify Pipe Run dialog, change the routing preferences and other settings for objects connected to the selected object. For more information, see Modifying Connected Objects Along a Pipe Run on page 329.

Modifying the Pipe or Fitting Location

1. In the drawing, select the part to modify.
2. On the Properties palette on page 325, under Placement, specify the location or orientation to change:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the elevation</td>
<td>enter a different value for Elevation.</td>
</tr>
<tr>
<td>rotate the MvPart around its normal axis</td>
<td>specify a value for Rotation.</td>
</tr>
<tr>
<td>enter coordinates to specify a new location</td>
<td>1. Click (Additional Information).&lt;br&gt;2. In the Location worksheet, under Insertion Point, specify the new X, Y, and Z coordinates and click OK.</td>
</tr>
<tr>
<td>change the normal axis, and reorient the part along the new normal</td>
<td>1. Click (Additional Information).&lt;br&gt;2. In the Location worksheet, under Normal, specify 1 for the normal axis, and specify 0 for the other 2 axes, and then click OK.</td>
</tr>
</tbody>
</table>

3. Deselect that part, and then select the fitting in the drawing you want to modify.
4. On the Properties palette on page 325, click (Additional Information).
5. In the Location worksheet, specify the location or orientation to change and then click OK.

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>rotate the part around its normal axis</td>
<td>Under Rotation, specify a value for Angle.</td>
</tr>
</tbody>
</table>
Then...

Under Insertion Point, specify the new X, Y, and Z coordinates.

Under Normal, specify 1 for the normal axis, and specify 0 for the other 2 axes.

---

**Modifying Connected Objects Along a Pipe Run**

When you change a dimension associated with a pipe or fitting that is connected to other objects, you can modify the routing properties for a pipe or fitting going in the same direction along the pipe run.

1. Select a pipe.
2. Click Pipe tab ➤ Modify panel ➤ Modify Run ➤ Modify Run.
3. In the Modify Pipe Run dialog, change one or more settings (routing preference, nominal size, system, and elevation) on the Modify Pipe Run dialog and click OK.

**NOTE** You might be prompted to make a part substitution in the run. For more information, see Choosing a Part.

---

**Breaking or Merging Pipe Segments**

You can break or merge pipe segments in a pipe run. For example, you can break 1 pipe segment into 2 or more adjacent segments. You can also merge 2 or more adjacent pipe segments to form 1 pipe segment. You can apply the break or merge command to all or part of a pipe run.

**To break or merge pipe segments in a pipe run**

1. Select a pipe segment to break or merge.
2. Click Pipe tab ➤ Modify panel ➤ Pipe Length ➤ Pipe Length. For more information, see Pipe Length on page 268.
3. In the Pipe Length dialog, specify the segments to break or merge:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>apply the length command to the entire pipe run</td>
<td>select Apply to Pipe Run.</td>
</tr>
</tbody>
</table>
If you want to… then…

manually select segments to modify click (Select Objects), and select specific segments to break or merge.

4 Specify the operation and then click OK:

If you want to… then…

break a segment select Break, and enter a value for Pipe Length.

You can also click (Pipe Length), and specify a start point and endpoint for the new length. The cut length for the pipe segments is the same as the break length.

merge multiple segments that are adjacent, connected, and aligned along the same centerline select Merge, click (Select Objects), and select the segments to merge.

NOTE The last used routing preference selection is preserved.

5 (Optional) Use the Properties palette to verify cut length for full-length segments. See Connector Engagement Length on page 267 for more information about cut length.

Locking the Size of a Pipe or Fitting

You can lock the nominal size of an existing pipe or fitting to ensure that it is not accidentally changed when you are modifying the pipe routing. For example, you might lock the diameter if a pipe run passes in close proximity to building elements or other systems, and the pipe diameter cannot be increased without interfering with other components.

To lock the nominal diameter

1 Select the pipe segment or fitting to lock.

2 On the Properties palette on page 325, under Dimensions, select Locked for Size lock (Unlocked by default).

When locked, the nominal size list is inactive and the pipe or fitting diameter cannot be modified. You can, however, still modify the length or elevation of a pipe segment. To turn off a size, unlock this setting on the Properties palette.
Modifying the System Assigned to a Pipe

1 Select a pipe segment in the pipe run.
2 On the Properties palette on page 325, select a system.

   NOTE Alternatively, you change the system by clicking Pipe tab ➤ Modify panel ➤ Modify Run.

3 (Optional) You can also use the Modify Run command to update the connected pipe segments along the designated pipe run.

Modifying a Pipe Fitting

You can modify a fitting. For example, you can change an elbow from a standard radius to a long radius. However, you cannot change it to another type — for example, an elbow to a cross.

1 Select the pipe fitting.
2 On the Properties palette on page 325, click the part image next to Part.
3 In the Select a Part dialog, choose a part from the catalog.
4 Select Display/Hide additional parameters to expand the contents of the parameters table.
5 Under Filter by Dimensions, filter the list of parts.

   NOTE The part catalogs and content locations determine the parts that you can add.

6 Select a part size and then click OK.

   NOTE If you specify a fitting size that is different from the objects connected to the fitting, you can modify the connected pipe segments in the pipe run on page 329.

7 On the Properties palette, under Placement, specify an elevation.

   NOTE If you are inserting a fitting in an existing pipe run, you do not need to specify the elevation. The fitting inherits both the elevation and system from the pipe run when you insert it.

Modifying the Layout of a Flexible Pipe

1 Select the flexible pipe segment.
2 On the Properties palette on page 325, expand Advanced, and then expand Geometry.
3 Click the left or right arrows at Vertex directly under Geometry to toggle to the desired location along the spline.

   NOTE This procedure uses the spline segment mode.

4 Specify values for the X, Y, and Z vertices.

For a flexible pipe that was drawn using any of the segment modes (line, arc, or spline), you can use grips to move the location of control points.

1 Select the flexible pipe segment.
2 Select the location grip to move the segment to a new location.
TIP Click the location grip and then the Ctrl key once to maintain the connection with the MvPart. Click the location grip and then the Ctrl key twice to break the connection.

Modifying Insulation on a Pipe or Fitting

1. Select one or more pipe segments or pipe fittings.
2. On the Properties palette on page 325, expand Advanced.
3. Specify the properties for insulation thickness:

<table>
<thead>
<tr>
<th>If you want to</th>
<th>then</th>
</tr>
</thead>
<tbody>
<tr>
<td>modify insulation</td>
<td>specify a value for Thickness (default is 0).</td>
</tr>
<tr>
<td>remove insulation</td>
<td>enter 0.</td>
</tr>
</tbody>
</table>

NOTE Insulation is an annotation element, not an object. You can only view insulation on pipe displayed as 2-line.

Checking Connectivity in a Pipe System

Take the appropriate action to check connectivity in a pipe network:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>show solution tips on all systems</td>
<td>Click View tab ➤ MEP View panel ➤ Solution Tip. All disconnects are highlighted in red.</td>
</tr>
<tr>
<td>check connectivity between adjacent parts</td>
<td>Select a pipe, and click Pipe tab ➤ Modify panel ➤ Show Connected Objects drop-down ➤ Show Connected Objects.</td>
</tr>
<tr>
<td>check connectivity on a pipe run (a pipe run terminates at a junction such as a tee)</td>
<td>Select a pipe, and click Pipe tab ➤ Modify panel ➤ Show Connected Objects drop-down ➤ Show Connected Run.</td>
</tr>
<tr>
<td>check connectivity among pipe branches</td>
<td>Select a pipe, and click Pipe tab ➤ General panel ➤ Select System drop-down ➤ Select Connected Branch. Press Tab to cycle through the connected upstream and downstream branches.</td>
</tr>
</tbody>
</table>

Modifying a Label or Flow Arrow

After placing a label in your drawing, you can apply a new style, change the spacing along the object, or change its appearance. Note that the software automatically updates a label attached to a pipe if the parent object is modified.
To modify a label using grips

1 Select a label to turn on the grips on page 271.

2 Specify the change:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>add a label</td>
<td>click the add grip. Hold down Ctrl while clicking to add labels at even spacing.</td>
</tr>
<tr>
<td>move a label</td>
<td>click the location grip, and move the label to a new location along the curve. Press Ctrl after clicking the location grip to offset the label from the curve.</td>
</tr>
<tr>
<td>add labels spaced at a specific distance along a curve</td>
<td>click the Repeat Distance grip, and click along the curve to specify a distance from the beginning of the curve to the selected point. Labels are added along the curve, spaced at the specified distance.</td>
</tr>
<tr>
<td>space multiple labels evenly along a curve</td>
<td>hold down Ctrl and click the Repeat Distance grip.</td>
</tr>
</tbody>
</table>

To modify a label from the ribbon or context menu

1 Select a label and do one of the following:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>add a label node</td>
<td>click Label tab ➤ General panel ➤ Add Selected dropdown ➤ New Label Node ➤, and select a point on or near the object.</td>
</tr>
<tr>
<td>remove a label node</td>
<td>click Label tab ➤ Modify panel ➤ Delete ➤.</td>
</tr>
<tr>
<td>offset a label node</td>
<td>click Label tab ➤ Modify panel ➤ Offset ➤, enter an offset distance, and press Enter. You can offset an individual label, or you can offset all labels in your drawing.</td>
</tr>
<tr>
<td>rotate a label node</td>
<td>click Label tab ➤ Modify panel ➤ Rotate ➤, select a rotation point, and enter a rotation value. You can rotate an individual label, or you can rotate all labels in your drawing.</td>
</tr>
</tbody>
</table>
If you want to anchor the label to a different object, then click Label tab ➤ Modify panel ➤ Move To Object ➤ Move To Object, and select the new object to which to anchor the label.

2 To change the label properties, select the label in the drawing, and then on the Design tab of the Properties palette on page 325 under Dimensions, modify the layout method as follows:

<table>
<thead>
<tr>
<th>If you want to display the labels...</th>
<th>then select...</th>
</tr>
</thead>
<tbody>
<tr>
<td>one at a time</td>
<td>One by one</td>
</tr>
<tr>
<td>evenly spaced along the curve</td>
<td>By distance, and enter a value for distance.</td>
</tr>
<tr>
<td>with a repeated spacing value</td>
<td>By quantity, and enter a value for the number of labels.</td>
</tr>
</tbody>
</table>

3 Select a new label style.

**NOTE** The configuration of the label curve style determines whether labels that use the style are considered annotative (scaled accordingly when the annotation scale changes). For more information, see Annotative Objects on page 549.
Drawing Radiant Heating Systems

This section describes how to use AutoCAD MEP to create and modify the radiators, valves, and the pipe work used in radiant heating systems.

Radiant Heating Systems Overview

Refer to the following workflow for creating and modifying radiator systems:

- **Review the steps**
  - Set up a project
  - Import radiator data files
  - Place radiators in drawing
  - Run parallel supply and return pipes

- **View more information**
  - Specify tool catalogs to use and other project information. See Working with Projects on page 129
  - Use the BDH files that contain radiator data in your drawings. See Creating Radiator Parts on page 336
  - Use windows and walls to locate and orient radiators. See Adding a Radiator MvPart on page 341
  - Place hot and cold radiator feed and return pipes in your drawings. See Adding Parallel Pipes to a Radiant Heating System on page 347
Creating Radiator Parts

Radiator data in BDH files derive from radiator manufacturers, heating load calculation applications (such as SOLAR COMPUTER Desktop), and design software in the D A CH radiator market. Radiator data includes length, width, height, company name, and part name. You import a BDH file (.dat) and then create the radiator definitions in the MvParts (DEU).apc catalog in AutoCAD MEP. You use Multi-view parts (MvParts) to model the size and shape of the real-world parts, such as radiators. AutoCAD MEP organizes MvParts, such as radiators, by type and stores that data in part catalogs. A default radiator template controls the graphic look of the radiator. This template is located at C:\Documents and Settings\All Users\Application Data\Autodesk\ACD-MEP 2010\enu\Aecb Catalogs\D A CH\MvParts\Mechanical\Radiators\Radiator Template_deu.xml. You can change the template to modify the radiator’s appearance. See How Catalog Parts are Stored and Referenced on page 80.

**NOTE** Ensure that you select the AutoCAD MEP D A CH profile on the Profiles tab of the Options dialog. See Creating Drawing Environment Configurations for Users on page 785.

To create custom radiator parts

1. Click ➤ Open ➤ BDH Radiator Content.
In the Import BDH File dialog, under Part Catalog, select the MvParts catalog where the parts will reside.

Under Select BDH File, browse to the BDH file (.dat) and select it. Chapter Name updates with the manufacturer name from the file and the targeted number of created or updated parts.

Click OK. The software updates the parts in the Mechanical ➤ Radiator folder of the MvParts catalog under the specified folder name. AutoCAD MEP organizes parts according to the subchapter names specified in the BDH file and also updates existing radiators. For more information about using catalog-based content, see Specifying Part Catalogs and Style-Based Content Locations on page 70.

### Using a Calculation Program to Add Radiators

You can use a heating calculation program, such as SOLAR COMPUTER Desktop, to determine the:

- Number of radiators to insert
- Radiator part type to use
- Size of each radiator required to heat specified spaces in an AutoCAD MEP drawing

This procedure uses the data file (.dat) in BDH format to define the set of available radiator parts used in both the calculation program and in AutoCAD MEP. You can download BDH files from a radiator manufacturer.

To place radiators in an AutoCAD MEP drawing using a heating calculation program, you create data files that are exchanged between the heating calculation program and AutoCAD MEP.

Use the following workflow to place radiators in an AutoCAD MEP drawing using SOLAR COMPUTER Desktop.

1. In AutoCAD MEP, create a gbXML (Green Building XML) file for the spaces in the drawing to place radiators. See Exporting Drawing Information for Analysis on page 340.
2. In SOLAR COMPUTER Desktop, import the gbXML file.
3. In SOLAR COMPUTER Desktop, import the BDH file that describes available radiator types and sizes.
4. In SOLAR COMPUTER Desktop, calculate the type, size, and number of radiators required to heat each space in the AutoCAD MEP drawing.
5. In SOLAR COMPUTER Desktop, export an XML file that contains the calculated radiator data.
6 In AutoCAD MEP, import the BDH file to create the required radiator part types and sizes. See Creating Radiator Parts on page 336.

**NOTE** You only should import the BDH file if you intend to modify the radiators after they are placed in the drawing.

7 In AutoCAD MEP, import the XML file created by SOLAR COMPUTER Desktop to place the radiators in the drawing.

### Adding Radiators Using Calculated Data

You can add radiators to a drawing using data from an XML file produced by a heating calculation program such as SOLAR COMPUTER Desktop. The XML file contains an identifier for one or more of the spaces in the model. Each space identifier in the file precedes a list of the radiators to be placed into the space.

**NOTE** If the current drawing includes multiple copies of the same xref, the software operates only on the first copy and ignores the other copies.

**IMPORTANT** For each space in the file that matches a space in the drawing, the software processes the associated radiator list depending on the selected layout method.

**To add new radiators to a drawing using calculation data**

1. In the piping workspace, click Insert tab ➤ Import panel ➤ Radiator.
2. In the Import Radiators dialog, under Select file, browse to the XML file that contains the imported calculation data, and open it.

3. For Layout method, select one of the following.
   - **Automatic: Spaces**
     The software places the radiator by applying the positioning options to a window and its wall.
     The software adds a radiator beneath each window in the space. It matches the length of the radiators in the list to the width of the windows in the space. If the list contains more radiators than the number of windows currently in the space, the software zooms to that space and prompts you to enter 2 points to place the additional radiators.
   - **Manual: Two points**
     The positioning options apply to the line defined by the specified left and right points.
The software zooms to the space being processed. For each radiator in the list, the software prompts you to enter 2 points to position the radiator within the space.

4 Specify the positioning options for the radiators.

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>center each radiator</td>
<td>for Justification, select Center.</td>
</tr>
<tr>
<td>place each radiator off center</td>
<td>for Justification, select Left or Right, and for Offset, enter a distance.</td>
</tr>
<tr>
<td>place each radiator a specified distance from a wall</td>
<td>for Distance from wall, enter a value.</td>
</tr>
</tbody>
</table>

5 For Elevation, specify an elevation, or enter a value.

6 If the XML file specifies a radiator part size that does not already exist, in the Missing Radiator Parts dialog, select one of the following:
   ■ Create Custom Parts: Adds the missing radiator parts to the current drawing
     The software does not create the parts in the MvParts catalog or make them available for use in other drawings. You can reference the added radiators for tasks such as scheduling. However, the capability for changing them is limited.
   
     NOTE Click Always create custom parts if you do not want the dialog to display again.

   ■ Cancel: Ends the processing so that you can create the required radiator parts in the MvParts catalog and then run the command again.
     The parts will then be available for use in this or other drawings. (See Creating Radiator Parts on page 336.)

7 If the file contains more radiators than windows for a space, the software zooms to the space. Follow the prompts and enter 2 points to place each radiator.

Rules About Updating Existing Radiators

The drawing information you export to a gbXML file in AutoCAD MEP includes information about the existing radiators. A calculation program, such as SOLAR COMPUTER Desktop, uses this information during its calculations. The program includes any required changes to existing radiators in the resulting XML file.

When you import SOLAR COMPUTER Desktop’s XML file into AutoCAD MEP, these rules apply to existing radiators:

■ When data for an existing radiator is encountered in the XML file, AutoCAD MEP updates the drawing with the part type and size of the radiator. The software maintains any valves connected to the radiator in the drawing. It also adjusts connections to pipes to accommodate the new part type and size if possible.

■ The positioning options specified in the Import Radiator dialog (such as Justification, Distance from Wall, and Elevation) are not applied when an existing radiator is updated.

■ The software deletes radiators with no corresponding information in the XML file from the drawing.

■ The software updates only the radiators in the current drawing but ignores radiators in other xrefs associated with the drawing. You must import radiators into each of these xrefs to update them.
Exporting Drawing Information for Analysis

In AutoCAD MEP, you use spaces to model the interior areas of rooms as explained in Adding Spaces to a Floor Plan on page 185. You group the spaces into zones that represent the real-world heating and cooling zones. See Attaching Spaces to Zones on page 189 for more information.

After you create spaces and group them into zones, you can export the information to a file in the Green Building XML (gbXML) format as follows.

1 Click ➤ Export ➤ gbXML.
   If necessary, you can scroll down to locate the command from the list.

2 In the gbXML Export dialog, for File Name, specify a file name and folder.

3 Click Select Objects to choose the zones to be exported.

4 Specify a building type and zip code.

5 Click Start.

6 If an error occurs during the export process, click View Event Log to learn more about the error.

Designing Radiant Heating Systems

You can quickly and easily add radiator MvParts to selected spaces, windows, or locations in a drawing. After a radiator is in place and connected to valves and piping, you can modify its type, size, elevation, and location while maintaining those connections.

For information about using calculation programs to add radiators to a drawing, see Using a Calculation Program to Add Radiators on page 337.
Adding a Radiator MvPart

1. If necessary, activate the Piping workspace.

2. Click Home tab ➤ Build panel ➤ Equipment drop-down ➤ Equipment.

3. Navigate to Plumbing - Radiators in the tree view of the Add Multi-view Parts dialog, and for Part Size Name, select a part size name from the list.

   You can select a part size name for the radiator or let the software calculate the correct part size on the Layout tab (described later in this procedure).

4. For Elevation, select a value.

5. (Optional) Click the Display/Hide additional parameters check box to toggle between displaying or hiding additional parameters in this dialog.

   **TIP** You can click Details to view the available sizes for the current radiator.

6. On the Layout tab, under Layout Method, select the method for adding the radiators to the drawing.

   **If you want to...**                      **Then...**
   
   place radiators relative to every window in selected spaces  select Spaces.
   
   place radiators relative to selected windows  select Windows.
   
   specify 2 points for each radiator to be placed  select Two points.
   
   place radiators by specifying the insertion point  select Insert point. Command-line prompts will ask you to specify insertion points.
7 Specify the positioning options for the radiators.

**If you want to...** | **Then...**
---|---
center each radiator | for Justification, select Center.
place each radiator off center | for Justification, select Left or Right, and for Offset, enter a distance.
place each radiator a specified distance from a wall | for Distance from wall, enter a value.

8 If you want the software to calculate the radiator size, select Use Width from Window. You can also specify a value for Subtract Window Width by to decrease the width by the distance specified. The height and depth are predefined by the selected part size.

9 Select the objects or points used to place the radiators.

**If you selected this layout method...** | **Then...**
---|---
Spaces | select one or more spaces in the drawing or xref. The software places the radiators relative to each window in the selected spaces, according to the specified positioning options. The software adds the radiators to the drawing based on the location and dimensions of the specified windows. For each radiator, the software uses the closest available part size. This value is less than the window width minus the value for Subtract Window Width by.

Windows | select one or more windows in the drawing or xref, and click a point inside the building. The software places a radiator relative to each selected window.
If you selected this layout method... Then...

<table>
<thead>
<tr>
<th>Two points</th>
<th>specify the left and right points for each radiator to be added. The software applies the positioning options to the line defined by the specified left and right points. It calculates the radiator size using the distance between the 2 points instead of a window width.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert point</td>
<td>specify insertion point</td>
</tr>
</tbody>
</table>

10 If desired, modify the settings in the Add Multi-view Parts dialog and add additional radiators.

**Modifying a Radiator MvPart**

When you modify a radiator, its connections to valves and pipes are maintained if possible. Branch pipes that connect the radiator to parallel pipes are adjusted to maintain the connection to the parallel pipes. If the connections to the parallel pipes cannot be maintained, the branch pipes will disconnect from the main run and move along with the radiator.

To modify a radiator, you use the same procedures that apply to all MvParts, as follows:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the part type, size, or elevation of a radiator</td>
<td>Select one or more radiator MvParts, and then click Equipment tab ➤ Modify panel ➤ Modify Equipment. Modify settings in the Multi-view Part Modify dialog. See Modifying the Size or Elevation of an MvPart on page 323 for more information.</td>
</tr>
<tr>
<td><strong>TIP</strong></td>
<td>You can also change elevation on the Properties palette.</td>
</tr>
<tr>
<td>move a radiator</td>
<td>use the (Location) grip. See Moving Pipe Components Using Location Grips on page 320.</td>
</tr>
<tr>
<td>move and connect an unconnected radiator</td>
<td>use the (Alignment) grip to connect and align the radiator to a connector. See Connecting MvParts Using Alignment Grips on page 345.</td>
</tr>
</tbody>
</table>

**Radiator Valves**

In AutoCAD MEP, radiator valves are MvParts. You can use grips to perform many of the operations involving radiator valves.

**Adding a Radiator Valve**

1 Select a radiator.
2 Click the \( + \) (Add) grip on a radiator connector.

3 In the Add Multi-view Parts dialog, use the Part and Part Filter tabs to select a valve type and size. See Placing a Pipe MvPart in a Drawing on page 285.

4 Press \textbf{Enter} to add the valve to the connector.

5 Press \textbf{Enter} to end the command.

\textbf{NOTE} You can use a rotate grip to flip the valve 180 or 90 degrees. See \textit{Modifying a Radiator Valve} on page 344.

---

**Modifying a Radiator Valve**

To modify a radiator MvPart valve, use the same procedures that apply to all MvParts as follows:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the valve type</td>
<td>Select the MvPart valve, and then click Equipment tab ➤ Modify panel ➤ Modify Equipment ➤ Modify Equipment. See Modifying the Size or Elevation of an MvPart on page 323. The valve's connections with the radiator and any pipes are maintained if possible.</td>
</tr>
<tr>
<td>rotate the valve 180 or 90 degrees</td>
<td>use the arrow-shaped ( \downarrow ) Rotate grip. See Rotating Pipe Components on page 321.</td>
</tr>
<tr>
<td>rotate a valve around a centerline to any angle</td>
<td>use the diamond-shaped ( \rightarrow ) Rotate grip in an isometric view. See Rotating Pipe Components on page 321</td>
</tr>
</tbody>
</table>

---

**Moving a Radiator Valve**

When a radiator valve is connected to a radiator, you can use grips to move it to a connector on the same radiator or another radiator. If you move the valve to a connector on the same radiator, connections to pipes
are maintained if possible. If you move the valve to a connector on another radiator, connections to pipes are not maintained.

The type of grip used to move a valve depends on how the valve is connected.

- **Location grip:** Visible when the valve is connected to the main run
  Use the location grip to move the valve to the same or a new radiator, maintaining the connection to the main run.

- **Alignment grip:** Visible when the valve is not connected to the main run
  Use the alignment grip to move the valve and align it to another connector.

To move a radiator valve, do the following:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>move a radiator valve that is connected to a radiator and maintain the connections with piping if possible</td>
<td>use the (Location) grip displayed at the valve connector. See Moving Pipe Components Using Location Grips on page 320.</td>
</tr>
<tr>
<td>move a valve and change its alignment</td>
<td>use the (Alignment) grip displayed at the valve connector. See Connecting MvParts Using Alignment Grips on page 345.</td>
</tr>
</tbody>
</table>

### Connecting MvParts Using Alignment Grips

You use the alignment grip to connect an MvPart to another object by aligning their connectors and placing the MvPart in the correct orientation. The alignment grip lets you accurately move a radiator valve to another side of the radiator.

The alignment grip only appears on an MvPart connector when you can move or realign the MvPart without affecting other connections. Otherwise, use the location grip on the connector to move the MvPart.

**To move a valve to another connector and maintain alignment**

1. Select the radiator valve MvPart.
2. Click the alignment grip on the valve/part you want to move.
3. Select another radiator connector to align the selected valve.
Creating Pipe Runs for Radiators

After you have placed the radiators in your drawing, use this procedure to create the parallel pipework for a radiator system.

1. Add the parallel pipes for the radiator supply and return. See Adding Parallel Pipes to a Radiant Heating System on page 347.
2 Add valves to the connectors on a typical radiator. See *Adding a Radiator Valve* on page 343.

3 Add branch pipes to connect the valves to the supply and return pipes. See *Connecting to Existing Pipe* on page 298 and *Connecting a Pipe Run to an MvPart* on page 300.

4 Copy the valves and branch pipe layout to similar radiators to connect them to parallel pipes. See *Connecting Multiple Radiators to Parallel Pipes* on page 350.

---

**Adding Parallel Pipes to a Radiant Heating System**

Use this procedure to route parallel runs in piping systems.

**NOTE** You cannot create sloped parallel pipes in AutoCAD MEP. As a result, *sloped piping* on page 286-related properties on the Properties palette will be disabled (unavailable). See *Sloped Piping* on page 256 for more information.

1 If necessary, activate the Piping workspace.

2 Create 2 or more starting parallel pipe segments. For each segment, specify properties, such as the routing preference and the system.
3 Click Home tab ➤ Build panel ➤ Pipe drop-down ➤ Parallel Pipe.

**TIP** You can also start the command by entering *PipeParallel* on the command line.

4 Select a baseline pipe.
Routing begins at the open end of the baseline pipe. If the pipe is open at both ends, select the pipe by clicking near the end where you want the routing to begin.

5 Select one or more pipes to be routed parallel to the baseline pipe, and press *Enter.*
The baseline pipe becomes active.

6 Add pipe segments.

The software adds pipe segments to the baseline pipe and the parallel pipe(s). Each pipe segment is created according to the routing preferences and properties specified for the starting pipe segment. A constant distance is maintained between the pipe segments where possible.
NOTE If the routing preference for one or more of the pipes does not specify a required pipe type or fitting, the Choose a Part dialog prompts you to specify a different part. See Choosing a Part on page 303 for more information.

7 If you make changes on the Properties palette, the following guidelines apply:

- A change to a property that guides the placement of the baseline pipe, such as Justification or Compass, applies only to the baseline pipe.

- A change that affects the physical characteristics of a pipe segment being created, such as Size or Insulation Thickness, affects all pipe segments in the run.

- A new Elevation value modifies the elevation of all pipes being routed. The distance between the pipes is maintained over the elevation change unless it results in a conflict.

- You cannot change some properties, including System, Routing Preferences, Fitting Settings, and Layout Method, while the PipeParallel command is active.

8 To designate a different pipe as the baseline pipe, enter b. The current routing options, such as Justification or Compass, apply to the new baseline pipe.

To connect the baseline pipe to a radiator valve

9 Click the Pipe End Connector on the valve.

10 Enter a to accept the displayed solution.

Another pipe becomes the baseline pipe. When only one pipe remains to be routed, the PipeParallel tool behaves like PipeAdd.

11 End the command by doing one of the following:

- Connect the final pipe to an object, such as a radiator valve or another pipe.
- Press Enter.
Correcting a Parallel Pipe Routing Conflict

When using the PipeParallel command to add parallel pipes, you might specify a point or a property value that causes a conflict between 2 of the pipes being routed. This situation generally occurs when you specify a small turn or a change in elevation while routing pipes with different diameters, as shown in the following illustration:

When a conflict occurs, a dialog prompts you for action. Choose either of the following:

- Click Undo to restart from the last created pipe segment, and proceed by specifying a point or property that does not cause a routing conflict.
- Accept the proposed new distance between the parallel runs of pipe. This distance is maintained between the pipes as you continue routing them.

Connecting Multiple Radiators to Parallel Pipes

1. Add valves to the connectors on a radiator (the source radiator) and create branch pipes that connect the radiator to a set of parallel supply and return pipes.

   See Adding a Radiator Valve on page 343, Connecting to Existing Pipe on page 298, and Connecting a Pipe Run to an MvPart on page 300.

2. Select the source radiator.

3. Right-click, and click Connect Multiple Parts.

4. Select one or more target radiators, and press Enter.
If the routing preference for a branch pipe does not specify a fitting for the connection, the Choose a Part dialog prompts you to specify a different fitting. See Choosing a Part on page 303 for more information.

**TIP** If you change a valve location on one radiator, run Connect Multiple Parts again to update all other connected radiators.

The target radiators are connected to parallel pipes using valve types and branch pipe properties copied from the source radiator. The following rules apply:

- Any existing valves or branch pipes are removed from the target radiator before it is connected.
- The valves from the source radiator are copied to the target radiator.
- The routing preferences from the source radiator branch pipes are used to create the branch pipes on the target radiator.
- The target radiator is connected to the same parallel pipes as the source radiator. If the source radiator’s parallel pipes do not run parallel to the target radiator, the target radiator is connected to the nearest set of parallel pipes within a reasonable distance from the radiator.
- The connectors on the source radiator are mapped to the connectors on the target radiator. For example, the valve and branch pipes attached to the lower-left connector on the source radiator will be copied to the lower-left connector on the target radiator. If there is not a direct one-to-one correspondence between the connectors on the source and target radiators, the software looks for the best possible match. If a match cannot be found, a connector on a target radiator might remain unconnected.
- As much as possible, the connections between the systems specified for the parallel pipes are maintained. For example, if the Hot Water Return pipe system is connected to the right side of the source radiator, the Hot Water Return pipe system will be connected to the right side of the target radiator.
- The connection to a target radiator can be adjusted even if the distance between the target and the parallel pipes differs from that of the source radiator.
- Sometimes a target radiator cannot be connected. For more information about the causes of connection failures, see Correcting a Radiator Connection Failure on page 351.

### Correcting a Radiator Connection Failure

The valves and branch pipes from the source radiator are copied to the target radiator even if the software cannot connect a target radiator to parallel pipes. You can then manually connect the branch pipes. You can use Solution Tips to view information about connection failures and instructions for correcting them. See Showing Solution Tips on page 579.

The following conditions report a failed connection:

- The radiator is not parallel to the main pipes.
- The radiator is too close to the main pipe, preventing enough space for the fittings in the branch.
- The target radiator is placed on the wrong side of the pipes. The radiator might also be rotated 180 degrees.
■ The radiators differ in type or orientation. For example, the target might be a single-panel radiator, and the source a two-panel radiator.

■ The software could not find a match between all the connectors on the source radiator and the target radiator. In this case, some of the connections might have succeeded.
This section provides instructions for using AutoCAD MEP to design and draft the electrical systems for a building plan.

**About Electrical Systems**

AutoCAD MEP includes many features that you can use to create, modify, and plot electrical system designs. The topics in this section provide general information about electrical features.

**Design Workflow for Electrical Systems**

Use the electrical features in AutoCAD MEP during the design development and construction document phases of a building project to design and document a building’s electrical systems.

**Define System Requirements**

Click in the left column to view a workflow demonstration. The right column provides links to help topics that provide detailed procedures.
Configure Electrical Preferences

Select voltages for the project, circuiting features, such as naming conventions and wire sizing factors, by Configuring Electrical Preferences on page 365.

Define Design Specifications for Wires

Choose the characteristics of hot, neutral, and ground/isolated ground wires by Defining Design Specifications for Wire Styles on page 373.

Select Equipment, Device, and Lighting Fixture Styles

Choose a wire cleanup method and drawing layer for lighting fixtures, junction boxes, and other devices by Device Style Setup on page 367.

Design the Electrical System Project

Click in the left column to view a workflow demonstration. The right column provides links to help topics that provide detailed procedures.

Create preliminary 1-line designs

Prepare the conceptual design for evaluation by building engineers and code officers. See About Schematic Diagrams on page 518.

Create an electrical project database

Create a repository for panel and circuit data by Creating an Electrical Project Database on page 382. You can create this database before or after you add circuits and panels to a drawing.

Add electrical equipment

Support your electrical system by Adding Electrical Equipment on page 419, including generators, transformers, and switchboards.

Add electrical panels

Place panels in your electrical layout by Adding Panels on page 403. You could also create one or more circuits at the same time.
Task | View more information
---|---
Specify or leverage spaces, and use them to create room take-off schedules | To help calculate power totals and wire sizes, use any architectural drawing-supplied spaces, or specify your own. See Adding Spaces to a Floor Plan on page 185.
Add a receptacle to a wall and align it using this Example: Aligning a Device to Floor Plan Geometry on page 398. View additional examples of other methods for adding devices. Save time as you draw by duplicating existing drawing elements by Copying Devices and Panels on page 409.
Place fixtures and devices | Add power and lighting circuits for receptacles, small appliances, and light fixtures by Creating Circuits Using the Circuit Manager on page 385. You can create circuits for switches and junctions boxes, and others for communications and fire safety equipment.
Create circuits | Add power and lighting circuits for receptacles, small appliances, and light fixtures by Creating Circuits Using the Circuit Manager on page 385. You can create circuits for switches and junctions boxes, and others for communications and fire safety equipment.
Draw cable trays and conduits | Create pathways for electrical wiring by Drawing Cable Trays and Conduits on page 420. You can specify elevation, slope, and branching options.
Add wires | Draw line, arc, snake, polyline, chamfer, or spline wires manually or generate them with a single command by Adding Wires on page 412.
Check and modify electrical systems | Calculate power totals and wire sizes by Checking Electrical Systems on page 425 and make needed changes by Modifying Electrical Systems on page 429.
Insert a panel schedule | Use MEP-supplied panel schedule tables to display the panel, circuit, wire, and load data for panels by Generating Panel Schedules on page 455.
Circuits

You can use AutoCAD MEP circuit features to create and manage circuit assignments across an entire project. In the software, a circuit is a non-graphical element that stores circuit information in a database. You can configure a circuit to assign properties, such as electrical system, rating, voltage, and panel assignment. You assign devices, such as lights and receptacles, to a specific circuit in a panel. For power and lighting circuits, use circuit features for an automatic warning when device loads exceed the circuit capabilities. The circuiting features can adapt to many different workflows. For example, you can add devices to plans, and then assign them to circuits later. You can also create circuits first, and then assign devices to them as you add devices to drawings. You can also create circuits and assign devices to them before assigning the circuit to a panel.

Electrical Project Database

Using the electrical project database file, you can create and share the most current circuit information across all drawings in an electrical project. It is required for any drawing that contains circuits. The electrical project database is a file saved with .epd as the file extension. For information about how the electrical project database works, see Using an Electrical Project Database on page 381.

Circuit Manager

Use the Circuit Manager for the following tasks:

- Viewing information about circuits or panels
- Creating new circuits
- Changing the properties of circuits
- Deleting circuits
- Generating a circuit report
- Linking panels
- Calculating wire sizes

Using the Circuit Manager, you can view all the circuits defined in the drawing and in the project database. Circuits are organized by panel and system type.
Circuit Manager

To search for a panel, enter the panel name above the list. You can view the properties of each circuit in the Circuit Manager.

- Expand a specific panel to list all circuits by system type assigned to that panel.
- Expand a circuit type under a panel (for example, Power and Lighting) to list all circuits of that type assigned to the panel.

The right pane of the Circuit Manager lists information about the circuits in your drawing (or in all drawings, if you are using the electrical project database). The information is based on what you selected in the left pane—a panel, circuit type, or circuit. Overloaded circuits display in red.

While you can modify some circuit properties using the Circuit Manager, other properties are displayed for reference and are read-only. For example, you can modify the name and description of a circuit, but the number of poles and phases (for ANSI) are read-only.

For circuits whose system type is specified as Power and Lighting, you can use the Circuit Manager to calculate wire sizes based on the circuit rating. When checking wire sizes, you have the option of automatically resizing them if they are undersized or oversized when compared to the calculated sizes.

The header section of the Circuit Manager contains information from the panel object properties and circuit settings for the selected panel, including voltage, phases/wires, panel rating and type, main rating size, design capacity, AIC rating, mounting, and enclosure.

The footer section contains calculations for connected loads and demand factor, including a summary and totals for connected loads for each load category, totals for each load category multiplied by the demand factor, demand load total and available spare capacity, and load distribution among the phases.

**Electrical Objects**

Electrical objects are the components you use to design electrical systems. Devices, panels, and wires are referred to as electrical objects. Most objects, such as receptacles, switches, and telecommunications outlets, are typically displayed symbolically, and are not drawn to scale in plan view. Objects such as lights also display symbolically, yet they are scaled to their actual envelope dimensions in plan view. This enables you to easily place the lights to achieve your desired lighting density, and it also enables you to check for interferences among larger electrical components and surrounding systems.

**Devices**

Typically, the first step in drafting an electrical plan, such as a power or lighting plan, is to place the devices and panels in the appropriate locations on the floor plan. AutoCAD MEP provides a library of electrical devices that includes most of the elements that you need to complete your plans:

- Power receptacles
- General lighting fixtures
- Fluorescent lighting fixtures
- Switches
- Communication devices
- Fire safety devices
- Junction boxes

Usually, you **add devices** in plan view to produce construction documents, but you can also display parts differently in different views. For example, in a 3D view of an electrical system, you can display the real-world geometry of the devices, while in a 2D plan view you can represent them as one-line symbols.

### Examples of electrical devices

![3D view of electrical devices]

#### Annotating and Scheduling Devices

A property set is a user-defined group of related properties, such as a part number or a manufacturer’s name. A tag is a symbol that can display the data in a property set attached to an object. You use both to annotate electrical drawings and create schedules.

To facilitate the annotation and scheduling of devices, you can specify property sets and tags in the properties of device tools, so they are automatically attached to the devices that you add to drawings. For information about creating device tools, see *Creating Tools for Style-Based Content* on page 790.

You can also manually specify property sets and a device tag using the Properties palette when you add devices.

### Panels

Typically, the first step in drafting an electrical plan, such as a power or lighting plan, is to place the devices and panels in the appropriate locations on the floor plan. AutoCAD MEP provides a library of panels that includes most of the elements that you need to complete your plans, such as recessed panels and surface door panels.

Usually, you **add panels** in plan view to produce construction documents, but you can also display parts differently in different views. For example, in a 3D view of an electrical system, you can display the real-world geometry of the panels, while in a 2D plan view you can represent them as one-line symbols.
Examples of electrical panels

When you add panels, you can create circuits at the same time. You can specify a naming convention for the circuits in the electrical preferences for the drawing.

**Wires**

After adding electrical devices to a layout, you can connect the devices with wires and, if desired, assign the devices to a circuit at the same time. You can add the wires manually. If the devices are already assigned to a circuit, you can have the software generate wires. For more information, see Adding Wires on page 412.

Connecting devices with wiring and a home run

To maintain the connectivity of a circuit, wires are anchored to devices. As a result, when you move a device, the connected wires stretch accordingly.

While you can connect devices with wires to graphically represent circuits, wires are not necessary for you to assign devices to circuits and view electrical loads. However, adding wires without assigning circuits can be useful during the preliminary design phase when the specifications are not defined.

You use wire styles to distinguish different types of wiring configurations, for example:

- 1-pole for general lighting and power distribution
- Multi-pole for equipment and power distribution
- Low voltage for security, fire alarm, or communication

The wire style determines several wire properties, such as the wire material, the number of wires, and the annotation preferences.

After you have created a wire run, you can add labels to indicate the wire style or to identify the circuit to which the run is assigned.
Wire Size Calculations

You can automatically calculate wire sizes for circuited wire runs. As you add wire, you can use the instant sizing tool to automatically calculate wire sizes based on the circuit rating. You can also use the Circuit Manager to calculate wire sizes for any wires assigned to a circuit. Wire sizes are calculated based on the National Electrical Code (NEC) 2002 Handbook: Table 250.122 for ground conductors, and Table 310.16 for current-carrying conductors.

For more information, see Adding Wires on page 412, Modifying Wire Properties on page 441, and Calculating Wire Sizes Using the Circuit Manager on page 425.

Cable Trays and Conduits

You can draw cable tray and conduit runs in order to form complete electrical networks.

In the software, a run is the cable tray or conduit parts that encase or support wires, bringing them from one point, such as a junction box or a panel, to another point, such as the junction with another run. A network is a group of interconnected cable tray or conduit runs.

Viewing conduit and junction boxes in 3D

To add cable trays and conduits to a drawing, you draw the main runs, locating the risers. Then you connect any branches to form a network. Fittings are added to connect segments when forming a run, and to connect runs to risers and branches when forming a network.

A cable tray or conduit run is made up of individually drawn segments. You draw a segment by specifying its properties in the Add dialog, and then specifying points in the drawing.

Drawing a cable tray segment

Once you have drawn the cable tray or conduit runs, you can connect them to form a complete cable tray or conduit network. AutoCAD MEP snaps can help you locate valid connection points on objects in your drawing. You can start a run at the end of a segment or run, or at any point along the path of another run. In this case, the software inserts an appropriate fitting to connect the 2 runs, creating a branch.
Drawing a branch

Cable tray and conduit components store properties such as connection type, size, system, and part type. When you connect to existing cable tray or conduit runs to create branches, part properties are inherited, providing a consistent method of drafting a layout. This ensures that you are creating intelligent building system designs.

NOTE Once you have completed your connections, you can apply solution tips to test whether your connections are valid.

You can also assign systems to cable tray and conduit to enable layouts to act together by maintaining the same look and feel throughout the system. For example, a group of cable tray runs can represent a power and lighting system, while another group of cable tray runs can represent a general system. For more information, see Working with Systems on page 93.

Auto Layout

As you draw cable tray or conduit runs, you lay out wireway geometry by specifying points in the drawing. The software automatically inserts segments and fittings along the layout. You can control which parts are inserted by configuring layout preferences before you begin drawing your wireway runs.

Cable Tray and Conduit Settings

You can use cable tray and conduit layout preferences to specify layout behavior as you draw wireway runs. You can configure layout preferences to add annotation automatically, to specify default parts for auto-layout, and to specify slopes for angled segments.

Electrical and Wire Ways Snaps

Like all building systems objects, electrical objects have connectors that enable them to connect intelligently with each other, and transfer information along connected runs. As you draw electrical systems, you make these intelligent connections using 2 types of AutoCAD MEP snaps:

- **Electrical Snaps.** Use these snaps to make connections when adding wires to devices and panels.
- **Wire Ways Snaps.** Use these snaps to make connections to cable tray, conduit, and electrical equipment (also called Multi-view Parts or MvParts).

Like all AutoCAD MEP snaps, electrical snaps and wire ways snaps both have 2 subtypes:

- **End Connector Snaps.** Use these snaps to connect an object to an endpoint on another object.
- **Curve Connector Snaps.** Use these snaps to connect an object anywhere along the centerline of another object.
Wiring a junction box to a light with electrical snaps

Connecting one cable tray to another with wire ways snaps

For more information about AutoCAD MEP snaps, including how to enable or disable them, see Using AutoCAD MEP Snaps.

Customizable Electrical Content

Typically, electrical content is created by CAD managers or other users in a similar functional role. There are 2 types of electrical content:

- **Style-based content.** This refers to objects that are defined by styles, which are sets of properties and associated view blocks. In electrical drawings, style-based content includes devices, panels, wires, and schematic objects for schematic diagrams.

- **Catalog-based content.** This refers to objects that are defined by part definitions and associated part models, and that are grouped into part catalogs. In electrical drawings, catalog-based content includes electrical equipment (also called multi-view parts, MvParts, or parts), conduits, cable trays, and fittings. You specify systems (a type of style) for catalog-based content. A system stores properties that are shared by all building system objects assigned to the system. This gives a consistent look and feel to the electrical systems in a drawing. For more information, see Working with Systems on page 93.

For a general introduction to these content types, see Working with Style-Based Content on page 85 and Working with Catalog-Based Content on page 79.

**Style-Based Content**

You can create the styles that define devices, panels, wires, and schematic objects from scratch using Style Manager. For an overview of this process, see Workflow for Creating Style-Based Content on page 599.

Additionally, there are several ways to convert single objects or batches of objects to device styles or schematic symbol styles. You can

- Convert a single AutoCAD block, MvBlock, or MvPart to a device. In addition to the converted device, this creates the associated device style.
■ Convert the device styles or schematic symbol styles provided with AutoCAD MEP to their individual components (the settings and the view blocks), customize the components, and then convert the components back to styles.

■ Convert a batch of AutoCAD blocks in a custom block library to device styles or schematic symbol styles.

For more information, see Customizing Style-Based Content on page 599.

Catalog-Based Content
You create catalog parts using Content Builder, a content creation tool that includes 3D modeling and 2D drawing features. You can create 2 types of parts: parametric or block-based. For information about their differences, see Understanding Parametric and Block-Based Parts on page 641.

For information about using Content Builder to create parts, see
■ Building Parametric Fittings Using Content Builder on page 650
■ Creating Block-Based Parts Using Content Builder on page 754

Control the Appearance and Behavior of Electrical System Designs
You can configure various settings that control the appearance and behavior of objects in your electrical system designs.

Creating Electrical System Definitions
A system definition specifies behaviors and display properties that apply to all of the objects in a system. Typically, you create and name electrical system definitions according to the real-world electrical systems that they represent, such as
■ Device - Power - 277V
■ Device - Lighting - 120V
■ Conduit - Emergency

TIP The default templates contain several system definitions that you can copy and modify.

To create an electrical system definition

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Electrical System Definitions ➤ .
2 Create the system definition:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then in the left pane of Style Manager…</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a new, blank system definition</td>
<td>right-click Electrical System Definitions, and click New. Enter a name, and press Enter.</td>
</tr>
<tr>
<td>copy an existing definition</td>
<td>do the following:</td>
</tr>
<tr>
<td></td>
<td>■ Right-click the system definition you want to copy, and click Copy.</td>
</tr>
<tr>
<td></td>
<td>■ Right-click Electrical System Definitions, and click Paste.</td>
</tr>
</tbody>
</table>
If you want to... then in the left pane of Style Manager...

- Right-click the copy, click Rename, enter a new name, and press Enter.

Use the tabs in the right pane to configure the system definition.
Electrical system definitions have properties that are common to systems in other disciplines. For information about configuring these properties, see Creating Systems on page 95.

Creating Load Category Definitions

You can specify a demand factor to calculate the estimated demand load from a circuit. The demand factor can:

- Be a constant value
- Be a constant value for all motors, except the largest motor
- Vary depending on the load total
- Vary depending on the quantity of the objects

Each demand factor is assigned a value that is multiplied by the load to determine the demand for a load category. It is important to define a demand load so that you do not overload the circuit. Defining a demand factor also provides you with a real calculation of the estimated demand load.

For example, for the load category Lighting, with a demand factor of 1.00, if you have 10 lights at 60 VA each, the load is 60 VA x 10 (lights) = 600 VA. Therefore, the lights for the load of this load category would be 600 VA. However, this value applies only if all the lights are turned on at the same time. If you plan to have just half the lights on at a time, you would specify the demand factor as a constant value set to 0.5 (or 50%). The estimated load is then 600 VA x 0.5 (demand factor unit) = 300 VA. Building codes provide guidance what values to use for demand loads. For example, if the total receptacle load on a panel is 20,000 VA, the demand factor could be 15,000 VA depending on the local code.

Using a different example, if the demand factor were set to vary depending on the quantity of the objects, for example for elevators, the minimum demand factor value would be 72% (or .72). The estimated load is then 600 VA x 0.72 (demand factor unit) = 432 VA.
Demand factors are assigned to load categories and load categories are assigned to device connectors. The estimated load for a device is calculated by using the load and the value for the demand factor. The estimated demand load is displayed in the Circuit Manager and in the Panel Schedule. The Panel Schedule also shows the load for each load category style.

**TIP** The default templates contain several load category styles that you can copy and modify.

**To create a load category definition**

1. Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Load Category Definitions.
2. Click Load Category Definitions. Right-click, and click New.
3. Enter a name, and press Enter.
4. Select the new load category style.
5. On the General tab, enter a description for the load category.
6. On the Demand Factor tab, select the demand factor type.
7. Specify the value(s) for demand factor as necessary.

### Configuring Electrical Preferences

Before you begin creating circuits, you can specify electrical preferences for the following features:

- Voltages that will be available for the project
- Circuiting features, such as naming conventions, overload checks, and wire sizing factors
- An electrical project database file that contains panels and circuits for the project

**NOTE** For information about the electrical project database file, see Using an Electrical Project Database on page 381.

### Specifying Voltage Definitions

Use the Voltage Definitions tab of the Electrical Preferences dialog to enter valid voltages for different numbers of poles. The voltage values are the default values available when you are working with devices and circuits.

Each voltage definition has a minimum value and maximum value that define the valid range when a device is to be connected to a circuit.

**NOTE** Voltage settings for 2-pole and 3-pole should be the same, otherwise some values may not be available in the Circuit Settings worksheet.

**To define voltage definitions**

1. From the Electrical workspace, click Manage tab ➤ Preferences panel ➤ Electrical.
2. In the Electrical Preferences dialog, click the Voltage Definitions tab.
3. Select a pole type, click (Add Voltage Definition), and then specify the voltage amount, the minimum value, and the maximum value.

**NOTE** To delete a voltage, expand a pole, select a voltage, and click (Remove Voltage Definition).
Configuring Circuiting Options

Use the Circuiting tab of the Electrical Preferences dialog to specify circuiting options, such as a default circuit naming convention, the type of overload protection to use when creating circuits, and the ambient temperature to use when calculating wire sizes.

The circuit naming convention determines the naming of all circuits. You define a naming convention by specifying a prefix, such as power, and a numbering system that can be used to sort through the circuits in your drawing. It is possible to create circuits even if there are no panels; in this case, the circuit uses the existing naming convention, and the circuit is designated as “unassigned.”

Total load is used when checking for overloads as you create circuits. Overload protection provides warning messages when circuits are overloaded.

**NOTE** Overload checks can only be used with circuits specified as Power and Lighting. Overload checks do not work with circuits specified as General or Other. These circuit types do not have current ratings or voltages assigned to them.

The ambient temperature that you specify is used to determine the correction factor for ampacity when calculating wire sizes as you add or modify wire runs. For more information about calculating wire sizes, see *Wires* on page 359.

To specify circuiting options

1. From the Electrical workspace, click Manage tab ➤ Preferences panel ➤ Electrical ➤.
2. In the Electrical Preferences dialog, click the Circuiting tab.
3. If you want each drawing to use different names for circuits, select Require Unique Circuit Names per Drawing.
4. Specify a prefix and numbering convention to use for naming circuits:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then click…</th>
</tr>
</thead>
<tbody>
<tr>
<td>use no prefix</td>
<td>None.</td>
</tr>
<tr>
<td>use the panel name as a prefix</td>
<td>Panel Name.</td>
</tr>
<tr>
<td>create your own prefix</td>
<td>User defined, and enter the name in the box.</td>
</tr>
<tr>
<td>number circuits sequentially regardless of the number of poles</td>
<td>Use Sequential Numbers. Poles are created sequentially at the start number that you specify. For example, if the start number is set to 1, then the next pole added is assigned the number 2.</td>
</tr>
<tr>
<td>group circuit names by even and odd poles</td>
<td>Group using Number of Poles. Select this option when creating branch circuits to group together even and odd circuits. For example, if you are working with a 3 pole circuit, and you have a start number of 1, then the next pole created is numbered 3.</td>
</tr>
<tr>
<td>increase the circuit serial number when you add poles</td>
<td>Increase by Number of Poles. Select this option when you want to increase the serial number of the circuit by the number of poles. Each 1 pole needs 1 number, each 2 pole needs 2 numbers, and each 3 pole needs 3 numbers.</td>
</tr>
</tbody>
</table>

5. Select a Start Number from the list. The default value is 1. The serial number is attached to the end of the circuit name.
6 Under Overload, specify the overload protection method to use:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then select…</th>
</tr>
</thead>
<tbody>
<tr>
<td>automatically check overloads when creating circuits</td>
<td>Check Overload when circuiting.</td>
</tr>
<tr>
<td>show the circuits that are overloaded in the Circuit Manager</td>
<td>Display Overload in the Circuit Manager.</td>
</tr>
<tr>
<td>specify the maximum circuit rating percentage to allow before prompting</td>
<td>a percentage that, when reached, causes a prompt to be displayed.</td>
</tr>
</tbody>
</table>

7 Under Wire Sizing, specify a value for Ambient Temperature.

**Specifying an Electrical Project Database File**

Use the Electrical Project Database tab of the Electrical Preferences dialog to specify a file that serves as the electrical project database. For more information, see Using an Electrical Project Database on page 381.

**Device Style Setup**

Devices are a type of style-based content, which is the collective term for building system objects that use styles to define their appearance and behavior. When you add a device to a drawing, you are adding an instance of a style, and the software establishes a link between the object and the style that defines it. When you modify the style, the software updates the object accordingly.

**Specifying Design Rules for Device Styles**

The design rules of a device style specify:

- The type of device represented by the style
- The drawing layer on which devices of the style are placed
- The method of wire cleanup used for devices of the style

**To specify the design rules of a device style**

1. Open the drawing that contains the device style.
2. In the Electrical workspace, open the device style by doing one of the following:
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager ➢. In the left pane of the Style Manager, expand Electrical Objects, then expand Device Styles, and select the style.
   - Select an device in the drawing that uses the style and click Device tab ➤ General panel ➤ Edit Style drop-down ➤ Edit Style ➢.
3. Click the Design Rules tab.
4. For Type, select a device type.
   - The list of device types corresponds to the types defined and used in the software, and it is not customizable.
When the software calculates loads in power totals or in the Circuit Manager, it totals the loads into 3 groups according to device type: lighting, receptacles, and, for all other device types, other.

A corresponding modify command is available for each device type. While pressing Ctrl, you can press A to quickly select all of the objects in the drawing, and then enter a modify command, such as LIGHTINGMODIFY, to filter the selection set to include only the devices of the specified type.

**NOTE** Keep the classification for the Device Type classification definition the same as the value for Type unless you have added a custom classification that is more appropriate. For more information, see Specifying Classifications for Device Styles on page 369.

5 For Layer Key, select the layer key that corresponds to the layer on which devices of this style are placed when they are added to drawings.

The list of available layer keys is determined by the layer standard and layer key style that is specified for the current drawing. For more information, see Specifying a Layer Standard and a Layer Key Style on page 134.

6 For Wire Cleanup, select a wire cleanup method.

This selection determines how wires are displayed when connected to devices or panels. The preview image on the right provides an example of the current selection.

### Configuring Connectors for Device Styles

Devices can have a single connection point or multiple connection points.

**To configure the connectors of a device style**

1 Open the drawing that contains the device style.

2 In the Electrical workspace, open the device style by doing one of the following:
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager ➤ . In the left pane of the Style Manager, expand Electrical Objects, then expand Device Styles, and select the style.
   - In the drawing, select a device that uses the style, and click Device tab ➤ General panel ➤ Edit Style drop-down ➤ Edit Style ➤ .

3 Click the Connectors tab.

4 For Description, enter a descriptive name that identifies what the connector represents, such as Normal Power.

5 For System Type, select Power and Lighting, Other, or General.

6 Specify a value for Connection Point X, Y, and Z, or click Add Center Points from View Blocks in Top View to create a centered connector.

7 If you selected Power and Lighting for System Type, do the following:
   - Specify values for the following additional connector properties:

<table>
<thead>
<tr>
<th>Connector Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of poles</td>
<td>The number of poles on the connector: 1, 2, or 3. You can select a number, select By Circuit to retrieve the value from the circuit when it is assigned, or select Undefined.</td>
</tr>
</tbody>
</table>
## Connector Property Description

**Voltage**
The voltage on the connector. You can enter a voltage, select from the voltages defined in the drawing that are valid for the currently specified number of poles, select By Circuit to retrieve the value from the circuit when it is assigned, or select Undefined.

**Load Phase 1 Load Phase 2 Load Phase 3**
The load (in VA) on the connector. For each device added, this load is added to the circuit. You can use this to automatically assign a load as you add the device. If the Number of Poles is &lt;Undef&lt; or 1, only Load Phase 1 is editable. If Number of Poles is 2, then Load Phase 1 and Load Phase 2 are editable. If Number of Poles is 3, then Load Phase 1, Load Phase 2, and Load Phase 3 are editable.

**Load Category**
The load category of the connector. You can select from the load category defined in the drawing, or you can select Undefined.

**Load Sub-category**
The load sub-category of the connector. You can select Motor.

**Maximum Overcurrent Rating (amps)**
Reserved for future use.

**Power Factor**
Reserved for future use.

---

**NOTE** If you select Undefined for Number of Poles or Voltage, and you do not specify a value when adding a device, a default value of By Circuit is used. This means the value from the circuit is retrieved and used when the device is assigned to a circuit. In addition, note that when you change the value for Number of Poles, Voltage, or Load in a device style, instances of the style in the drawing are not updated.

For each of the properties, for Prevent Override, specify whether to allow the override of the value in the style when adding devices. Select Yes to prevent overrides, or select No to allow them.

8 To add a connector, click ![icon], and configure its properties.

9 To remove a connector, select the connector, and click ![icon].

**WARNING** Use caution when removing connectors. Doing so can break the connectivity of a circuit because the connector is removed from all instances of the style in the drawing.

---

### Specifying Classifications for Device Styles

A classification definition contains a set of classifications (named properties or characteristics) that you apply to one or more object types. For example, a Construction Status classification definition might contain the following classifications: Existing, Demo, and New.
You can create display sets that show or hide objects based on their classifications, such as a display set that shows only devices classified as lighting. Many of the display sets provided with the software are configured in this manner.

You can also use classifications to control the content of schedules by including

- Only objects that meet specific classification criteria
- Classification definitions as columns
- Additional information from property sets that you create and attach to classifications

Because you frequently need to classify the devices in a drawing by type, AutoCAD MEP includes a Device Type classification definition that applies to devices, and it contains classifications for the device types defined in the software.

Classification definitions that apply to devices are displayed on the Classifications tab of each device style. When configuring a device style, this is where you specify a classification for the Device Type classification definition and for any custom classification definitions. Most of the device styles included with the software specify a classification for the Device Type classification definition.

**Classifications tab of a 12 x 24 Recessed device style**

Because a device in a drawing is an instance of a device style, the device has a property for each classification definition in the device style. On the Extended Data tab of the Properties palette, you can view or override the classification for one or more devices in the drawing.
To specify the classifications of a device style

1. Open the drawing that contains the device style.
2. In the Electrical workspace, open the device style by doing one of the following:
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager ➤ . In the left pane of the Style Manager, expand Electrical Objects, then expand Device Styles, and select the style.
   - In the drawing, select a device that uses the style and click Device tab ➤ General panel ➤ Edit Style drop-down ➤ Edit Style ➤ .
3. Click the Classifications tab.
4. Specify a classification for the Device Type classification definition:
   - Click beside the Device Type classification.
   - In the Select Classification dialog, under Device Type, select a classification.
   
   **NOTE** Keep the classification for the Device Type classification definition the same as the value for Type unless you have added a custom classification that is more appropriate. For information about the Type property of a device style, see Specifying Design Rules for Device Styles on page 367.

5. Click OK.
6. Specify a classification for any custom classification definitions in a similar manner.

**NOTE** For more information about classifications, see Using Classifications on page 589 in AutoCAD MEP Help, as well as Classification Definitions and Displaying Objects by Classification in AutoCAD Architecture Help.

---

**Configuring Styles for Panels**

Panels are a type of style-based content, which is the collective term for building system objects that use styles to define their appearance and behavior. When you add a panel to a drawing, you are adding an instance of a style, and the software establishes a link between the object and the style that defines it. When you modify the style, the software updates the object accordingly.
Specifying Design Rules for Panel Styles

The design rules of a panel style specify the method of wire cleanup used for panels of the style.

NOTE You can change the layers on which panels are placed when they are added to drawings by remapping their layers using Layer Manager. For more information, see Remapping Objects to Different Layers in AutoCAD Architecture Help.

To specify the design rules of a panel style

1. Open the drawing that contains the panel style.
2. From the Electrical workspace, open the panel style by doing one of the following:
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager ➤ Style Manager. In the left pane of the Style Manager, expand Electrical Objects, then expand Panel Styles, and select the style.
   - In the drawing, select a panel that uses the style and click Panel tab ➤ General panel ➤ Edit Style drop-down ➤ Edit Style ➤ Edit Style.
3. Click the Design Rules tab.
4. For Wire Cleanup, select a wire cleanup method.
   This selection determines how wires are displayed when connected to panels. The preview image on the right provides an example of the current selection.

Configuring Connectors for Panel Styles

1. From the Electrical workspace, open the panel style by doing one of the following:
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager ➤ Style Manager. In the left pane of the Style Manager, expand Electrical Objects, then expand Panel Styles, and select the style.
   - In the drawing, select a panel that uses the style and click Panel tab ➤ General panel ➤ Edit Style drop-down ➤ Edit Style ➤ Edit Style.
2. Click the Connectors tab.
3. For Description, enter a name or phrase that identifies what the connector represents.
4. For Domain, select Electrical.
5. Specify a value for Connection Point X, Y, and Z, or click Add Center Points from View Blocks in Top View to create a centered connector.
6. To add a connector, click ➤ , and configure its properties.
7. To remove a connector, select the connector, and click ➤ .
WARNING Use caution when removing connectors. Doing so can break the connectivity of a circuit because the connector is removed from all instances of the style in the drawing.

Configuring Styles for Wires

Wires are a type of style-based content, which is the collective term for building system objects that use styles to define their appearance and behavior. When you add a wire to a drawing, you are adding an instance of a style, and the software establishes a link between the object and the style that defines it. When you modify the style, the software updates the object accordingly.

Defining Design Specifications for Wire Styles

IMPORTANT The material and temperature rating of wires, which are specified in the wire style, are used by the instant sizing tool to calculate the wire sizes. To use the sizing tool, you must select a material from the available choices instead of entering one. For information about using the sizing tool, see Drawing or Generating Wires on page 413 or Modifying Wire Properties on page 441.

1 Open the style by doing one of the following:
   ■ From the Electrical workspace, click Manage tab ➤ Style & Display panel ➤ Style Manager. In the left pane of the Style Manager, expand Electrical Objects, then expand Wire Styles, and select the style.
   ■ Select a wire that uses the style in your drawing and click Wire tab ➤ General panel ➤ Edit Style drop-down ➤ Edit Style.

2 Click the Specifications tab.

3 Under Hot, specify property values for the conductors:
4 Under Neutral, specify property values for the neutral wires:

- Specify whether the properties of the neutral wires should match those of the conductors:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>use the property values specified</td>
<td>click Match hot, and for Size of hot in %, enter the size of the neutral</td>
</tr>
<tr>
<td>for the conductors</td>
<td>wires expressed as a percentage of the size of the conductors.</td>
</tr>
<tr>
<td>specify property values for the</td>
<td>click Specify neutral, and then specify values for Material, for Insulation,</td>
</tr>
<tr>
<td>neutral wires</td>
<td>and for Temp. Rating.</td>
</tr>
</tbody>
</table>

5 Under Ground and under Isolated Ground, specify property values for the ground wires:

**Specifying Annotation for Wire Styles**

When you draw a wire, you can select a style for the wire on the Properties palette. The style determines the annotation properties for the wire, such as the tick marks to use for conductor, neutral, and ground wiring; the symbol to use for home run arrows; and how to display connections.

**NOTE** Wire tick marks are always displayed in plan views unless you turn them off through (Edit Display Properties) on the Display Properties tab in the Style Manager or the Wire Style Properties dialog. For more information, see Configuring the Display Properties of a Style on page 610.

The style of a wire also determines how crossing wires are displayed. You can display crossing wires as is, or with an overlap or a break of a specific width.

If you select the overlap style or break style, you must also specify a corresponding priority value. In a drawing, if 2 crossing wires have the same priority value in their corresponding styles, the order in which the wires were drawn determines which wire displays the overlap or break. If the priority values are different, the priority values determine this. Refer to the following table for more information.

<table>
<thead>
<tr>
<th>If the crossing style of the 2 wires is…</th>
<th>And if the priority values of the 2 wires are…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>overlap</td>
<td>the same</td>
<td>the wire drawn second displays the overlap.</td>
</tr>
<tr>
<td>break</td>
<td>the same</td>
<td>the wire drawn first displays the break.</td>
</tr>
<tr>
<td>mixed (one is overlap, and the other is break)</td>
<td>the same</td>
<td>the wire drawn second determines the crossing style to use. If the style is overlap, the wire drawn second displays the overlap. If the style is break, the wire drawn first displays the break.</td>
</tr>
<tr>
<td>overlap</td>
<td>different</td>
<td>the wire with the lower priority value displays the overlap.</td>
</tr>
<tr>
<td>break</td>
<td>different</td>
<td>the wire with the higher priority value displays the break.</td>
</tr>
<tr>
<td>mixed (one is overlap, and the other is break)</td>
<td>different</td>
<td>the wire with the lower priority value determines the crossing style to use. If the style is overlap, the wire with the lower priority value displays the overlap. If the style is break, the wire with the higher priority value displays the break.</td>
</tr>
</tbody>
</table>
To change the draw order of a selected wire, click Home tab ➤ Modify panel ➤ Bring to Front drop-down and then choose one of the options offered.

**To specify annotation for a wire style**

1. Open the style by doing one of the following:
   - From the Electrical workspace, click Manage tab ➤ Style & Display panel ➤ Style Manager. In the left pane of the Style Manager, expand Electrical Objects, then expand Wire Styles, and select the style.
   - In the drawing, select a wire that uses the style and click Wire tab ➤ General panel ➤ Edit Style drop-down ➤ Edit Style.

2. Click the Annotation tab.

3. Under Tick Marks, select a symbol type, and enter a tick mark size and angle for conductor, neutral, and ground.

4. For Distance, enter the spacing for tick marks between conductor and neutral wires, or neutral and ground wires.

5. Specify how to display tick marks:
   - To show tick marks on each segment, select Display on wire segment.
   - To show tick marks on home runs, select Display on home run.
   - For Paper distance between same kind of ticks, enter the distance between the tick marks on a segment.

6. Under Home Run Arrow, select an arrow style, and enter a size.
   - To show only one home run arrow for each circuit, select Display one arrow for each circuit.

7. Under Crossings, select a style for crossing wires.
You can specify that the crossing wires are displayed as is, with an overlap, or with a break.

8 If you selected the overlap style or the break style, for Break/Overlap Paper Width, enter the width of the overlap or the break, and for Break/Overlap Priority, enter a number.

9 Under Connections, select a connection node symbol type for wire junctions, and enter a size.

**Configuring Layout Preferences for Cable Tray or Conduit**

You can configure layout preferences for cable tray and conduit to control the layout and appearance of wireway runs.

As you draw cable tray or conduit, you can click in the Add dialog to change the preferences as needed during layout. Any changes you make remain in effect until you change them again.

Layout preferences are stored in the drawing. The sample templates provided with AutoCAD MEP include default preferences so you can begin design layout immediately. You can create custom templates that include company-specific or project-specific preferences.

**Specifying Alignment for Cable Tray or Conduit Insertion**

By default, the cable tray and conduit that you draw is center-aligned horizontally and vertically. As a result, the centerlines of the segments and fittings are placed along the points you specify. You can change the alignment and also specify an offset distance. Changing alignments is useful if you want to run conduit or cable tray along drawing geometry.

For example, if you want to add conduit at the along a wall at the bottom of the ceiling, you can set the justification to the top-left corner. When you draw the conduit, you simply need to select points along the top of the wall to place the conduit as desired.

1 Do one of the following in the Electrical workspace:
   - Click Manage tab ➤ Preferences panel ➤ Cable Tray.
   - Click Manage tab ➤ Preferences panel ➤ Conduit.

**TIP** You can also access the layout preferences from the Add Cable Trays or Add Conduits dialog. Click in the lower-left corner of the dialog. Any changes you make remain in effect until you change them again.

2 In the Layout Preferences dialog, click the Routing tab.
Offset preferences on the Routing tab

3 Specify the alignment for cable tray or conduit insertion:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>align the centerlines of the cable trays or conduits along the points you specify for the run</td>
<td>under Justification, select Center for Horizontal and for Vertical. Enter 0 for Offset A and for Offset B.</td>
</tr>
<tr>
<td>align one or 2 sides of the cable trays or conduits along the points you specify for the run</td>
<td>under Justification, select Left or Right for Horizontal, and/or select Top or Bottom for Vertical.</td>
</tr>
<tr>
<td>offset the cable trays or conduits from the points you specify for the run</td>
<td>enter a distance for Offset A and/or for Offset B.</td>
</tr>
</tbody>
</table>

To assist you, the preview image on the right provides an example of the current selections.

Specifying the Slope for Cable Tray or Conduit

Slope is applied to cable tray or conduit in the Z direction of the current coordinate system in the drawing (typically the vertical direction for a building plan).

1 In the Electrical workspace, do one of the following:
   - Click Manage tab ➤ Preferences panel ➤ Cable Tray.
   - Click Manage tab ➤ Preferences panel ➤ Conduit.

TIP You can also access the layout preferences from the Add Cable Trays or Add Conduits dialog. Click in the lower-left corner of the dialog. Any changes you make remain in effect until you change them again.

2 In the Layout Preferences dialog, click the Routing tab.

Conduit rise/run preferences on the Routing tab
### 3 Specify the slope:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>specify an angle</td>
<td>Under Layout Rise/Run, click Angle. For Rise/Run, enter the number of degrees, and for Increment, enter the number of degrees by which to increase or decrease the angle. When you add cable tray or conduit, the rise/run angle is used as the default slope in the Add dialog, as shown below.</td>
</tr>
<tr>
<td>specify a fraction</td>
<td>Under Layout Rise/Run, click Fraction, and for Rise/Run, enter a fraction. When you add cable tray or conduit, the rise/run fraction is used as the default slope in the Add dialog, as shown below.</td>
</tr>
</tbody>
</table>

You can click ▲ to quickly increase or decrease the number of degrees by the value you specify for Increment in the rise/run preferences, or you can enter a new number.

You can modify it by entering a new value.

---

### Breaking Cable Tray or Conduit at Even Intervals

Use this procedure to break cable tray or conduit segments into specific lengths as you draw wireway runs.

**To break cable tray or conduit during layout**

1. In the Electrical workspace, do one of the following:
   - Click Manage tab ➤ Preferences panel ➤ Cable Tray.
   - Click Manage tab ➤ Preferences panel ➤ Conduit.
2 In the Layout Preferences dialog, click the Routing tab.

3 Click Cable Tray Length or Conduit Length, specify the segment length, and click OK.

TIP As you draw, you can also access and change the layout preferences by clicking (Preferences) in the Add dialog.

Specifying Annotation for Cable Tray or Conduit

You can specify labels or flow arrows to be added to cable tray or conduit runs as you draw them. For cable tray runs, you can also specify the hatch pattern to apply. You can specify vertical or 45-degree lines and the line spacing to use.

To specify annotation for cable tray or conduit layout

1 In the Electrical workspace, click one of the following:
   - Click Manage tab ➤ Preferences panel ➤ Cable Tray .
   - Click Manage tab ➤ Preferences panel ➤ Conduit .

2 In the Layout Preferences dialog, click the Annotations tab.

3 To specify a cable tray pattern, under Cable Tray Pattern, select a type of line pattern, and enter a value for Spacing.
   To assist you, the preview image on the right provides an example of the current selections.

4 Under Labels and Flow Arrows, select a style and specify a layout method. You can define labels only, flow arrows only, or both.

Specifying Default Parts for Cable Tray or Conduit

Use this procedure to specify the parts and fittings that are inserted automatically as you draw a cable tray or conduit run.
1 In the Electrical workspace, click one of the following:
   ■ Click Manage tab ➤ Preferences panel ➤ Cable Tray.
   ■ Click Manage tab ➤ Preferences panel ➤ Conduit.

2 In the Layout Preferences dialog, click the Parts tab.
3 For Part Group Definition, select the definition to be modified.
4 For Connection Type, select a connection type.
   The tree structure updates to display only those parts available for the selected connection type.
5 For each part type, select a default part.

**Configuring Connections for Cable Tray**

1 In the Electrical workspace, click Manage tab ➤ Preferences panel ➤ Cable Tray.
2 Click the Connections tab.
3 For Connection Style, verify that Cable Tray Connector Style is specified.
4 Specify how to make connections to existing segments and fittings:

<table>
<thead>
<tr>
<th>If you want…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>the software to automatically insert a fitting when you connect one cable tray segment to another</td>
<td>under Connect with Cable Tray, select Use Fitting.</td>
</tr>
<tr>
<td>to directly connect one cable tray segment to another</td>
<td>under Connect with Cable Tray, clear Use Fitting.</td>
</tr>
<tr>
<td>the software to automatically replace the elbow with a tee when you connect a cable tray segment to an elbow</td>
<td>under Connect with Elbow, select Use Tee.</td>
</tr>
<tr>
<td>to directly connect the cable tray segment to the elbow</td>
<td>under Connect with Elbow, clear Use Tee.</td>
</tr>
<tr>
<td>the software to automatically replace the tee with a cross when you connect a cable tray segment to a tee</td>
<td>under Connect with Tee, select Use Cross.</td>
</tr>
<tr>
<td>to directly connect the cable tray segment to the tee</td>
<td>under Connect with Tee, clear Use Cross.</td>
</tr>
</tbody>
</table>

For each setting, you can preview the type of connection you have specified in the corresponding image.

**Working with Circuits**

You can use AutoCAD MEP circuit features to create and manage circuits for your electrical plans. You use the electrical project database to manage panel and circuit assignments for electrical devices across all electrical system drawings. Use the Circuit Manager feature to manage and view circuit information as you create and modify your systems.
Using the circuit features, you can automate some tasks, such as calculating circuit loads, checking circuit overloads, or calculating wire sizes. For example, create panel schedules automatically from the circuit data in the electrical project database file. Also, you can add home run tags to wire runs, to automatically display the panel and circuit assignments in the home run tag.

Also, the circuit features are also very flexible. They can accommodate different workflows. For example, you can create panels and circuits first, and then assign devices to circuits when you add the devices to drawings. Also, you can add devices to drawings before creating any circuits. After you create circuits, you can go back and assign devices to them. As you refine your electrical system designs, you can change circuit assignments for devices, modify circuit properties, and move circuits around on a panel.

Using an Electrical Project Database

In AutoCAD MEP, an electrical project database is a file that contains the panels and circuits to which you assign devices and wires. The electrical project database resides in its own file, which is assigned a file extension of .epd. The devices that make up electrical systems reside in separate drawings that are linked to the electrical project database file.

You use the electrical project database to manage your circuits and loads across all electrical drawings in a project. As you create and refine your circuited systems, the electrical project database keeps track of devices and loads in all linked drawings. Using an electrical project database ensures that circuit assignments and loads are accurate even if devices in multiple drawings are assigned to the same circuit.

How the Electrical Project Database Works

An electrical project database is required for any drawing that contains circuits. It can be specified at any time before or after circuits are created. If an electrical project database has not been specified and circuits are added to a drawing, you will be prompted to specify the name of an electrical project database file.

The electrical project database manages the circuit assignments in all linked drawings. As you create and refine electrical system drawings, you can use the Circuit Manager to view and manage panel and circuit information. Access the Circuit Manager from either the panel drawing or any of the linked drawings. As you work on electrical systems, you can view current circuit information, such as total load and number of devices assigned to each circuit.
Creating an Electrical Project Database

An electrical project database is a file that contains panel and circuit data for all drawings that are connected to it. The electrical project database file can be specified at any time before circuits are created. If an electrical project database file has not been specified, and circuits are created with the PANELADD command or in the Circuit Manager, you are prompted to specify an electrical project database file. After you create this file, you can link to it from other drawings. It is recommended that you use only one electrical project database per project.

You create circuits in the electrical project database, and assign them to panels. As you create electrical systems in other drawings, you can assign devices and wires to the circuits in the electrical project database.

To create a new electrical project database file before creating circuits:

1. Click Manage tab ➤ Preferences panel ➤ Electrical.
2. Option the Electrical Project Database tab and click New.
3. Optionally, in the new drawing, reference a floor plan drawing for the placement of your panels.
4. To add panels to the drawing, use a panel tool on the Panel tool palette, or use the PANELADD command.
   Create circuits as you add a panel, or add a panel and add circuits later using the Circuit Manager.

To create a new electrical project database file when prompted while creating circuits:

1. In the Electrical Project Database dialog, click Create a new EPD file.
2. Specify a filename and click OK.

To open an existing electrical project database file when prompted while creating circuits:

1. In the Electrical Project Database dialog, click Open an existing EPD file.
2. Browse to the location and name of the existing electrical project database file, and click OK.
Linking to the Electrical Project Database

Create a file to serve as the electrical project database. Then, link drawings to the electrical project database. You can link a drawing to only one electrical project database at a time.

1. Create a new drawing, or open an existing drawing that you want to link to the electrical project database.
2. Click Manage tab ➤ Preferences panel ➤ Electrical ➤
3. In the Electrical Preferences dialog, click the Electrical Project Database tab.
4. For Project Database, click .
5. In the Open dialog, browse to the file you want to use as the electrical project database.
6. Select the electrical project database file, and click Open.
   The file name is displayed for Project Database, and Used Database shows the directory path.
7. For path type, select either Use Fixed Path or Use Relative Path.
   - Fixed path: If you use a fixed path reference, moving the electrical project database file to another directory, this also breaks the links with associated electrical drawings. If you move an entire project to another directory, this will also break the links between the electrical project database file and the linked drawings. To move the electrical project database file, you must open each linked drawing and configure the electrical project database to its new file path.
   - Relative path: If you use a relative path reference, the link remains intact as long as the electrical project database file is in the same location relative to the linked drawing. You can move a project or rename directories in the project without breaking the links to associated electrical drawings.
     If Use Relative Path is inactive, you must save the current drawing in order to make it active.
8. The electrical project database status icon displays in the application status bar.

You can now assign devices to circuits in the electrical project database. You can assign devices to a circuit as you add or modify them. If more than one electrical drawing is open and being worked on, you can reload the electrical project database in your current drawing by reloading the electrical project database.

**IMPORTANT** When you are working in linked drawings, the electrical project database must be closed. If it is open, you are prompted to close it when you try to save a linked drawing. No data can be written from linked drawings to the electrical project database unless the electrical project database is closed.

Reloading the Electrical Project Database

If two or more people are working simultaneously on electrical drawings, you can reload the latest data from the electrical project database into your current drawing to ensure that you have current circuit information. Or, if you have two or more linked drawings open, and you save changes to one, you can reload the electrical project database, thus adding the changes to the other drawing.

For example, if someone assigns devices to a circuit in another drawing while your drawing is open, you can reload the electrical project database in your current drawing, and view the current number of devices assigned to that circuit. This ensures that you have accurate circuit information across all drawings that use the electrical project database.

As soon as a linked drawing is saved, the Electrical Project Database Status icon indicates that the database needs to be reloaded in your current drawing. If a linked drawing is not open when changes are made, you...
do not need to reload the electrical project database. The latest version of the electrical project database is loaded automatically when you open the drawing.

The steps in the following procedure show how to manually reload the electrical project database. Also, the database is also always reloads when you open a drawing.

**NOTE** Note that the electrical project database reloads automatically every 5 minutes. This time interval is not configurable, and it is always on.

**To manually reload the electrical project database**

1. In the application status bar, note that the electrical project database status displays an alert marker [ ].
   This marker indicates that changes have been saved to the electrical project database from one or more linked drawings.
2. Click the Electrical Project Database Status icon once, or right-click the icon and click Reload Electrical Project Database.
   The electrical project database status displays as current.
3. If the electrical project database cannot find one or more of the drawings linked to the electrical project database, the Electrical Project Database Reload dialog prompts you, giving you the option to remove the missing drawing data from the electrical project database.
   If you do not want to use the drawing in the electrical project database, select the check box to remove its data from the electrical project database. For example, the missing drawing is one you deleted and that you did not want to use.
   If you want to keep the drawing data in the electrical project database, clear the check box. For example, you want to use the missing drawing, but it resides on a server that is temporarily unavailable.

**Unlinking From the Electrical Project Database**

You can remove a linked drawing from the electrical project database as long as all of the circuits in the drawing have been removed. When you unlink a drawing from the electrical project database, the next time you save the drawing, the data from that drawing is automatically removed from the electrical project database.

**To unlink a drawing from the electrical project database**

1. In the drawing you want to unlink, click Manage tab ➤ Preferences panel ➤ Electrical [ ].
2. In the Electrical Preferences dialog, click the Electrical Project Database tab.
3. For Project Database, select <None> from the drop-down list.
4. Save the drawing.

The drawing and its electrical data are removed from the electrical project database. You can reload the electrical project database in any linked drawings that are open.

**Using Circuits**

You can create and store circuits in the same drawing as the panel to which they are assigned. By using the electrical project database, you can assign devices—such as lights or receptacles—to circuits in the electrical project database. Then you can share current circuit information across all electrical drawings in a project.
You can also create circuits in a drawing, add devices to the same drawing, and assign the devices to those circuits as you add or modify the devices. In that situation, you do not use an electrical project database, and you cannot share that circuit information with other drawings.

In a typical workflow, you identify the location of panels before you create circuits—generally, during the schematic design phase. However, you can create circuits at the following points in the electrical system design process:

- Before you add panels, and before you draw any electrical systems (using the Circuit Manager)
- When you add panels (using the Properties palette)
- After you add devices and panels (using the Circuit Manager)

You can create one circuit or multiple circuits at the same time. To graphically represent the circuit in the drawing, you can also add wires to the drawing.

**System Types of Circuits**

When you create a circuit, you specify its system type, such as Power and Lighting. The system type determines which components you can connect to a circuit.

Circuits are available in 3 system types:

- Power and Lighting: Devices whose connectors are configured for this system type can only connect to circuits of the same type. By default, devices that are configured for Power and Lighting include receptacles, small appliances, and light fixtures.

- General: Devices whose connectors are configured for this system type can connect with all system types for special use cases. For example, by default, switches and junction boxes are configured for the General system type and can be assigned to either General, Power and Lighting, or Other circuits.

- Other: Devices whose connectors are configured for this system type can only connect with circuits of the same type. These devices typically include communication and fire safety components.

Generally, when you select a device, the system type property of the connector is already assigned. You can change properties of connectors using device style connectors. For more information, see Configuring the Electrical Connectors of a Device on page 395.

If you are using the Power and Lighting or Other system type, the connectors of the devices must use the same system type in order to be placed on the same circuit. To connect a device of any system type to a circuit, use the General system type.

**Tip** Before creating circuits, create electrical system and load category definitions, and configure electrical preferences. Then, you can take better advantage of the circuit feature, reducing the number of details you must specify when adding circuits. For more information, see Creating Electrical System Definitions on page 363 and Control the Appearance and Behavior of Electrical System Designs on page 363.

**Creating Circuits Using the Circuit Manager**

If you did not create circuits when adding a panel, you can use the Circuit Manager to create one or more circuits. You typically create panels and circuits in a drawing and add them to an electrical project database. Other drawings can then reference these panels and circuits. You can link any drawing to an electrical project database and then use its panels and circuits in multiple drawings.

You can create circuits at any point in the design process. You can create circuits as you add panels, or at any point after you add panels. You can also create circuits before adding any panels, and assign those circuits after you add panels. You can add one circuit or multiple circuits at once.
NOTE The Circuit Manager can remain open while you work in your drawing.

To create circuits using the Circuit Manager

1 In the drawing that contains or will contain at least one electrical panel, select a device and click Device tab ➤ Circuits panel ➤ Circuit Manager drop-down ➤ Circuit Manager.

2 In the left pane of the Circuit Manager, select the panel to which you want to add one or more circuits. If you have not yet added any panels, select <Unassigned>. Any new panels are automatically added to <Unassigned>. After you create panels, you can drag and drop circuits from <Unassigned> into the desired panels.

To add a single circuit:

3 Add a single circuit using any of the following methods:
   - Click (Create New Circuit) or click the drop-down arrow next to Create New Circuit ( ) to specify a circuit type.
   - Right-click the panel name, and select New <circuit type>.
   - Right-click the system type (for example, Power and Lighting) under the panel name, and click New Circuit.

To add multiple circuits:

4 Add multiple circuits using any of the following methods:
   - Click (Create Multiple Circuits).
   - Right-click the panel name, and select New Multiple Circuits.

5 In the Create Multiple Circuits dialog, under Common properties, specify the following:
   - Panel: If you selected a panel name before starting this command, this field will be inactive. If you selected <Unassigned>, select a panel from the drop-down list. Select <Unassigned> in this list if you do not want to assign the circuit to a panel yet.
   - System Type: Specify a type of system for the circuits.
   - System: Specify a system for the circuits.
6 Under <System Type> Properties, specify the number of 1-pole, 2-pole, and 3-pole circuits and their respective voltages.

**NOTE** After adding new circuits, update the panel schedules in your drawing. See **Updating Panel Schedules** on page 459 for more information.

### Configuring a Circuit

After you create circuits, configure circuit properties, such as voltage, rating, load category, and system.

1. Open the drawing that contains the circuits and select a device.
2. Click Device tab ➤ Circuits panel ➤ Circuit Manager drop-down ➤ Circuit Manager.
3. In the left pane of the Circuit Manager, expand the panel, expand the branch (for example, Power and Lighting), and select the circuit to be configured.
   To edit properties for multiple circuits, select the branch in the left pane that contains the circuits. On the right pane, use Shift or Ctrl to select multiple rows in the circuit list view.
4. Double-click the circuit property field in the right pane.
5. Enter the new information, or select a new property from the list.
   Depending on the system type, you can modify the following properties:
   - Name: Specify a name, using **naming conventions** for new circuits using electrical preferences.
   - Description: Typically a brief description of the type of devices and the area of the building this circuit will service.
   - System: The electrical system definition for the circuit.
Rating (Power and Lighting only)

Voltage (Power and Lighting only)

The number of devices and circuit length are calculated for you as you assign devices to circuits. For power and lighting circuits, the total load is also calculated for you.

Circuit length is calculated only if the devices and circuits are contained in the same drawing. Typically, you assign devices in one drawing to circuits in the electrical project database file. In that case, the circuit length always displays as <Used in multiple drawings>.

After you assign one or more devices to a circuit, not all properties are editable. To reconfigure a property for a circuit with devices assigned to it, you can modify the devices, set their circuit assignments to <Unassigned>, and then modify the circuit property in the Circuit Manager. You can also create a new circuit, configure it as desired, and modify the devices to assign them to the new circuit. Then, delete or reuse the old circuit.

If you are using an electrical project database file, and you configure a circuit that is being used by devices in other drawings, you are prompted to open and save the affected drawings to ensure that the circuit information is current. For more information, see Electrical Project Database on page 356.

IMPORTANT When you assign power and lighting devices to circuits, make sure the voltage and number of poles for the device are the same or less than the circuit settings. If the device voltage exceeds the circuit voltage, or the number of poles on the device exceeds the number of circuit poles, you will not be able to assign the device to that circuit.

Viewing Circuit Information

Use the Circuit Manager to view circuit data and information for electrical system drawings. If you use an electrical project database, you can view circuit data in any linked drawing. If you do not use an electrical project database, you can view circuit data in the current drawing.

To view circuit information

1. In the drawing, select a device and click Device tab ➤ Circuits panel ➤ Circuit Manager drop-down ➤ Circuit Manager .
2. In the Circuit Manager, expand the panel, and select the system type (for example, Power and Lighting) to view the circuits.

If you use an electrical project database, you can edit circuit settings from the current drawing only. You cannot edit circuit settings for other drawings linked to the electrical project database.

For power and lighting circuits, the Circuit Manager displays overloaded circuits in red. For more information, see Viewing Circuit Information on page 426.
Linking Panels

After linking panels, use the Circuit Manager to transfer the panel demand and connected load totals for each load category from one panel to another.

To link panels in the same drawing:

1. Select a panel and click Panel tab ➤ Connections panel ➤ Connect To Other Panel.
2. In the first Panel to Panel connection dialog, select the panel that will be fed by another panel.
3. In the second Panel to Panel Connection dialog, select the method to use when connecting the panels, and click OK.

<table>
<thead>
<tr>
<th>If you select…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Circuit breaker in panel</td>
<td>the panel is added as a sub-fed panel to an existing circuit in the linked panel.</td>
</tr>
<tr>
<td>Feed-thru lugs</td>
<td>the panel is added as a sub-fed panel to a feed-thru lug circuit in the linked panel.</td>
</tr>
<tr>
<td>Sub-feed lugs</td>
<td>the panel is added as a subfed panel to a subfeed lug circuit in the linked panel.</td>
</tr>
<tr>
<td>Subfeed breaker</td>
<td>the panel is added as a subfed panel to a subfeed breaker circuit in the linked panel.</td>
</tr>
<tr>
<td>Panels are connected through a transformer (panels are different voltages)</td>
<td>the panel is connected through a transformer when panels are of different voltages.</td>
</tr>
</tbody>
</table>
The sub-fed (linked) panel is shown indented in the tree view in the left pane.

<table>
<thead>
<tr>
<th>Circuit Manager</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type panel name</td>
</tr>
<tr>
<td>PFI (Current Drawing)</td>
</tr>
<tr>
<td>Power and Lighting</td>
</tr>
<tr>
<td>PFI (Current Drawing)</td>
</tr>
<tr>
<td>Power and Lighting</td>
</tr>
<tr>
<td>PFI (Current Drawing)</td>
</tr>
<tr>
<td>Power and Lighting</td>
</tr>
<tr>
<td>PP4 (Current Drawing)</td>
</tr>
<tr>
<td>Power and Lighting</td>
</tr>
<tr>
<td>PP4 (Current Drawing)</td>
</tr>
<tr>
<td>Power and Lighting</td>
</tr>
<tr>
<td>LPI (Current Drawing)</td>
</tr>
<tr>
<td>Power and Lighting</td>
</tr>
<tr>
<td>LPI (Current Drawing)</td>
</tr>
<tr>
<td>Power and Lighting</td>
</tr>
<tr>
<td>LPI (Completed Power PFI)</td>
</tr>
<tr>
<td>&lt;Unassigned&gt; (Current Drawing)</td>
</tr>
</tbody>
</table>

**NOTE** A warning symbol appears if you try to create a circular reference by linking a panel back to the panel that feeds it.

**NOTE** You cannot link a panel to more than one panel at a time.

**NOTE** Anytime you add or delete circuits, you will need to update any existing panel schedules. See Updating Panel Schedules on page 459.

To remove a link between panels:

➤ Select the panel and click Panel tab ➤ Connections panel ➤ Remove Connection To.

**NOTE** You can connect to a panel only once using either the feed-thru lugs, subfeed lugs, or subfeed breaker option. You can use the circuit breaker option only when there are available circuits.

## Managing Circuits in a Project

As you create and refine your electrical system designs, you can manage your circuits using the following tips:

- Use an **electrical project database file** to manage circuits across all drawings in a project.
- **Create circuits when you add a panel**, or add circuits to panels later using the Circuit Manager.
- **Configure circuit settings** only in the drawing that contains the circuits. After you assign at least one device to a circuit, many of the circuit settings are no longer editable.
- **Configure loads for device styles** so that the load is automatically configured when you add the device to a drawing.
- **Assign devices to circuits** as you add the devices, or add the devices first and then assign them to circuits later.
- Keep circuit data current in multiple electrical drawings by **reloading the electrical project database**.
- **Configure electrical preferences** so that you are automatically notified of circuit overloads for power and lighting circuits.
- Use **circuit-checking features** to see circuit information for a selected device. You can also verify circuit connectivity to display the devices that are assigned to the same circuit.
As you refine your designs, you can move circuits around on a panel to balance loads. Also, you can drag and drop circuits from one panel to another.

Generate panel schedules automatically from the circuit data.

Creating Electrical Systems

Use AutoCAD MEP to create designs for typical electrical systems such as lighting plans, power plans, and telecommunications plans. You can also create plans for electrical equipment, such as switchboards or emergency power generators, and draw the conduit or cable tray networks to connect the equipment.

When creating lighting, power, and telecommunications plans, you add devices to the floor plan, and you connect the devices with wire runs. You can use panel and circuit features to assign the devices to circuits. You can also use circuit features to manage loads for power and lighting circuits.

When creating plans for electrical equipment, you add MvParts to floor plans, and you draw conduit or cable tray runs to connect equipment.

Adding Devices

After attaching a referenced drawing (xref) of the architectural plan to your drawing, typically you continue by placing devices and panels in the layout. You can place devices and then connect them with wires. You can also insert a device onto a wire, in which case the device breaks into the wire and creates 2 wires.

When you add a device to your drawing, you can assign the device to a circuit, or you can leave the circuit unassigned until you know the circuit to use. This ability means you can create circuits and connect them to devices at any time during the design process. For information about using circuits across multiple drawings, see Working with Circuits on page 380.

To add devices

1. In the Electrical workspace, start the add command by doing one of the following:
   - Click Home tab ➤ Build panel ➤ Device .
   - Open a device tool palette, and select a tool.
     If necessary, scroll to display the tool. Because tools contain preconfigured properties for the objects they create, you might not need or be able to specify some of the device properties referenced in this procedure.
   - Enter deviceadd.
NOTE On the Properties palette, * indicates a property is available only when you are adding devices, not when you are modifying them.

Specify general properties

2. On the Properties palette, if necessary, double-click on the device display to open the style selector dialog.

3. For Description, click [ ] , enter a description of the device, and click OK.

Specify location properties

4. If you selected One by One for Layout Method, expand Location, and for Align to objects, specify how you want to align the devices:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>snap to an object using object snaps and have the software align the device perpendicular to the object</td>
<td>select Yes. The software can align the device perpendicular to a wall, ceiling grid, space boundary, line, polyline, spline, arc, or circle in the current drawing or in an xref.</td>
</tr>
</tbody>
</table>
If you want to... | then...
---|---
NOTE If you have difficulty snapping and aligning to an object, zoom to the area or modify the size of the AutoSnap aperture as needed. The aperture size determines how close to a snap point you can be before the magnet locks the aperture box to the snap point. You can modify the size on the Drafting tab of the Options dialog. For more information, see “Drafting Tab (Options Dialog Box)” in Autodesk® AutoCAD® Help.

| manually align the device | select No. |

NOTE If you select Yes for Align to objects, the software inserts the device using the insertion point of the underlying block and rotates it as needed to align it perpendicular to the object to which you snap. As a result, you cannot specify a value for Justification on the Properties palette, or a value for Rotation on the command line.

If you selected Distance around space or Quantity around space for Layout method, Align to objects is automatically set to Yes.

5 For Justification, select the point on the device to use as the insertion point.
You can select either the insertion point of the view block that represents the device, or one of 9 other points on the device, such as Top Left or Middle Center.

6 Specify an elevation by doing one of the following:
- For Preset Elevation, select a defined elevation.
- For Elevation, enter an elevation.

Because devices have 2D views and many have 3D views assigned to them, the insertion point of devices should be specified as 0. The elevation property of the device (not the insertion point) should be used to assign the 3D view to the correct elevation. Follow these simple rules:
- The Z-value of Connectors should always be defined as 0.
- The Insertion point Z-value of device shall be 0.
- To set the elevation of the device to anything other than 0, use the Elevation property of the device on the Properties palette. This setting defines the 3D offset of the device from the current UCS. The object will display at the set elevation when viewing it in a 3D or Iso view.

The difference in the elevation of the devices, the wires, and the panel for a circuit is used to calculate the circuit length. Note that the circuit length can only be calculated if the panel and all of the devices on the circuit are in the current drawing.

Specify advanced properties

7 Expand Advanced, expand System, and for System, select the system to which the device belongs.

NOTE The system assigned to the device determines its display properties, and the system assigned to an electrical connector on a device determines the connections that can be made to the connector. For more information about connectors, see Configuring the Electrical Connectors of a Device on page 395. For more information about systems, see Creating Electrical System Definitions on page 363 and Working with Systems on page 93.
8 Expand Design Data, and for ID, enter an ID for the device. The ID is an optional number that you can assign.

9 Expand Tag, and for Insert Tag, select the tag to anchor to the object. The list of tags includes the tags in the current drawing and, if specified, the tag specified in the tool you selected.

A tag is a symbol that can display the data in a property set that is attached to the object. A property set is a user-defined group of related properties, such as a part number or a manufacturer’s name, which you can specify in the properties of a tag tool or manually attach to an object using the Extended Data tab of the Properties palette. You use property sets and tags to annotate drawings and create schedules for construction documents.

TIP Instead of manually adding tags and property sets to devices one-by-one using the Properties palette, you can create device tools that automatically add them to devices when the devices are inserted. For more information, see Creating Tools for Style-Based Content on page 790.

Specify connector properties

10 Expand Advanced, expand Circuits, and click Electrical Properties.

NOTE You can edit Electrical Properties later by selecting a device in the drawing and clicking Device tab ➤ Circuits panel ➤ Circuit Properties.

11 On the Electrical Properties worksheet, configure the electrical connectors, as explained in Configuring the Electrical Connectors of a Device on page 395.

Insert the devices

12 If you selected Quantity around space or Distance around space for Layout method, insert the devices as follows:

■ In the drawing, move the cursor to the location for the first device. This must be a point on a space boundary.

■ Examine the preview of the device layout, and, if necessary, move the cursor to a different location.

■ Click to insert the devices.

13 If you selected One by One for Layout method and Yes for Align to objects, insert the devices as follows:

■ If you want to insert the device into a wire, enter w (wire), and select the wire. Otherwise, proceed to the next step.

■ Use object snaps to snap to an object (such as a wall) at the desired insertion point, and click to insert the device.

■ Repeat the previous steps to add additional devices with the same properties.

14 If you selected One by One for Layout method and No for Align to objects, insert the devices as follows:

■ If you want to insert the device into a wire, enter w (wire), select the wire, and move the device along the wire to the desired location. Otherwise, proceed to the next step.

■ Click to specify the insertion point.

■ Rotate the device by moving the cursor or entering the number of degrees on the command line, and click to insert the device. Alternatively, you can press Enter to accept the default rotation, and then click.
Repeat the previous steps to add additional devices with the same properties.

15 On the Properties palette, modify the device properties and then insert additional devices, or press Enter to end the add command.

**NOTE** If you are using the electrical project database file, and two or more electrical drawings are open, you can update each drawing to include the most current circuit information by reloading the electrical project database in each open drawing. For example, if you add lighting devices to a circuit in the electrical project database, and a power drawing is open and using circuits on the same panel, you can reload the electrical project database in the power drawing to have current circuit information.

### Configuring the Electrical Connectors of a Device

When you add a device to a drawing, you need to configure its connectors using the Electrical Properties worksheet. Typically, devices have a single electrical connector.

You can configure an electrical connector using either of the following methods:

- Assign the connector to a circuit. If you know the circuit, you can select it. Otherwise, you can make panel and connector property selections to filter the list of available circuits, and then select one. Once you select a circuit, the System value is no longer editable. If the system type of the connector is Power and Lighting, then the values for Voltage and for Number of poles are not editable. This prevents changes that do not agree with the selected circuit. You can then configure the connector properties that remain editable.

As you add devices with connectors that are assigned to a circuit, the circuit is updated and evaluated for overloads based on the load and load category of the connectors. In the circuiting preferences, you can specify whether the software warns you of overloads, so you can decide whether to proceed and add...
the devices. If you overload a circuit, you are not notified of the overload again during the drawing session.

Configure the connector properties, but do not assign the connector to a circuit. Later, after you identify the circuit to use, you can assign the circuit.

NOTE If the style of the device does not allow the override of a connector property value, that property is not editable even when no circuit has been assigned. For information about allowing and preventing overrides, see Configuring Connectors for Device Styles on page 368.

To configure the electrical connectors of a device

1 Start the add command by doing one of the following:
   - Click Home tab ➤ Build panel ➤ Device.
   - Open a device tool palette, and select a tool.
   - Enter `deviceadd`.

2 On the Properties palette, expand Advanced, expand Circuits, and click Electrical Properties.

   NOTE You can apply these settings later by selecting a device in the drawing and clicking Device tab ➤ Circuits panel ➤ Circuit Properties.

   The Electrical Properties worksheet lists the connectors on the device and shows the system type and description for each connector. These attributes of the device are determined by the device style, and, to change them, you must modify the connectors in the style.

3 Under Electrical Connectors, select a connector to configure.

   The properties of the selected connector are displayed under Connector Properties.

Optionally assign the connector to a circuit

4 If necessary, you can filter the list of available circuits:

<table>
<thead>
<tr>
<th>If you want to select from the circuits…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>on a specific panel</td>
<td>for Show circuits from panel, select the panel.</td>
</tr>
<tr>
<td>that are not assigned to a panel</td>
<td>for Show circuits from panel, select Unassigned.</td>
</tr>
<tr>
<td>with a specific system</td>
<td>for System, select the system.</td>
</tr>
<tr>
<td>with a specific number of poles</td>
<td>for Number of Poles, select the number.</td>
</tr>
<tr>
<td>with a specific voltage</td>
<td>for Voltage, select or enter the voltage.</td>
</tr>
</tbody>
</table>

   Detailed descriptions of the connector properties are described later in this procedure.

NOTE The circuits available for Circuit are the circuits in the current drawing, or in the electrical project database file, if one is specified for the current drawing. The circuits available are those that match the values you have specified for the connector properties, and have either a system type of General or the same system type as the connector.

   Beside each circuit name, the current load on the circuit is displayed. The load is the total load on the circuit across all applicable drawings, including the electrical project database file.
5 For Circuit, select the circuit.

Specify the connector properties

6 Under Value, specify values for the connector properties.

<table>
<thead>
<tr>
<th>Connector Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>System</td>
<td>The system of the connector. If the system type of the connector is General, you can select from all of the electrical systems defined in the drawing. Otherwise, you can select from systems with the same system type (Power and Lighting, or Other).</td>
</tr>
<tr>
<td>Load Phase 1, Load Phase 2, Load Phase 3</td>
<td>The load on the connector. Applies only to connectors whose system type is Power and Lighting. If the Number of Poles is <code>&lt;Undefined&gt;</code> or 1, only Load Phase 1 is editable. If Number of Poles is 2, then Load Phase 1 and Load Phase 2 are editable. If Number of Poles is 3 or <code>&lt;By Circuit&gt;</code>, then Load Phase 1, Load Phase 2, and Load Phase 3 are editable. You can enter a value. Otherwise, the value in the style is used and shown.</td>
</tr>
</tbody>
</table>
| Voltage            | The voltage on the connector. Applies only to connectors whose system type is Power and Lighting. You can do one of the following: 
  ■ enter a voltage
  ■ select from the voltages defined in the drawing that are valid for the currently specified number of poles
  ■ select By Circuit to retrieve the value from the circuit when it is assigned |
<p>| Number of poles    | The number of poles on the connector: 1, 2, or 3. Applies only to connectors whose system type is Power and Lighting. You can select a number, or you can select By Circuit to retrieve the value from the circuit when it is assigned. |</p>
<table>
<thead>
<tr>
<th>Connector Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Load Category</td>
<td>The load category of the connector. Applies only to connectors whose system type is Power and Lighting. You can select from the load categories defined in the drawing.</td>
</tr>
<tr>
<td>Load Sub-category</td>
<td>The load sub-category of the connector. You can select Motor.</td>
</tr>
<tr>
<td>Maximum Overcurrent Rating (amps)</td>
<td>Reserved for future use.</td>
</tr>
<tr>
<td>Power Factor</td>
<td>Reserved for future use.</td>
</tr>
</tbody>
</table>

As you specify values for the connector properties, the information in the Value Set By column changes accordingly:

<table>
<thead>
<tr>
<th>If…</th>
<th>then Value Set By is…</th>
</tr>
</thead>
<tbody>
<tr>
<td>the value of the property matches the value specified in the device style</td>
<td>Style Default</td>
</tr>
<tr>
<td>the value of the property does not match the value specified in the device style</td>
<td>Style Override</td>
</tr>
<tr>
<td>there is no value specified in the device style</td>
<td>empty</td>
</tr>
<tr>
<td>the value of the property is By Circuit in the device style or in the currently selected connector</td>
<td>Circuit</td>
</tr>
</tbody>
</table>

Example: Aligning a Device to Floor Plan Geometry

In this example, you add a single receptacle and align it to a wall.

1 In a new drawing, attach or overlay a drawing of an architectural floor plan.
2 In the Electrical workspace, open the Power-Lighting Device tool palette, and select a receptacle tool.
3 If necessary, on the Properties palette, change the style of the receptacle to be added:
   ■ Expand Basic, and on the General bar, click .
   ■ In the left pane of the Select Device worksheet, navigate to the drawing that contains the style.
   ■ In the right pane, select the style, and click OK.
4 Expand Layout, and for Layout method, select One by One.
5 Expand Location, and for Align to objects, select Yes.
   This causes the receptacle to align to the object to which you snap. You can snap and align to a wall, ceiling grid, space boundary, line, polyline, spline, arc, or circle in the current drawing or in a referenced drawing (xref).
6 In the drawing, snap to a wall at the desired insertion point, and click to specify the point.
TIP When you are prompted for a point, you can temporarily enable an object snap by entering the first 3 characters of its name. This is useful when you require a snap that you do not want as a running object snap, such as Nearest, which snaps to the nearest point on an object.

NOTE If you have difficulty snapping and aligning to an object, zoom to the area, or modify the size of the AutoSnap aperture as needed. The aperture size determines how close to a snap point you can be before the magnet locks the aperture box to the snap point. You can modify the size on the Drafting tab of the Options dialog. For more information, see “Drafting Tab (Options Dialog Box)” in Autodesk® AutoCAD® Help.

7 Press Enter.

NOTE For detailed information about adding devices and configuring their properties, see Adding Devices on page 391.

Example: Adding Devices at a Specific Distance Interval

In this example, you add receptacles to a room at a specific distance interval. You specify the insertion point of the first device on a space boundary created for the room, and the software aligns all of the devices along the boundary.

1 In a new drawing, attach or overlay a drawing of an architectural floor plan.
2 Activate an electrical display configuration.
3 If the floor plan drawing does not contain spaces, generate a space for a room by doing the following:
   ■ Open the Power-Lighting Device tool palette, and select the Space tool.
   ■ In the drawing, specify a point within a room, and press Enter.

NOTE By default, the electrical display configurations use the Reflected Screened display representation for Space objects. This display representation makes the boundaries of spaces visible in drawings, but adds the spaces to a non-plotting layer. The display representation is not used by any other display configurations provided with the software. For more information about the display system, see AutoCAD MEP Displays on page 134.
4 On the Power-Lighting Device tool palette, select a receptacle tool.

5 If necessary, on the Properties palette, change the style of the receptacle to be added:
   - Expand Basic, and on the General bar, click .
   - In the left pane of the Select Device worksheet, navigate to the drawing that contains the style.
   - In the right pane, select the style, and click OK.

6 Expand Layout, and for Layout method, select Distance around space.

7 For Distance between, enter a value.
   You can also enter a value by clicking and specifying 2 points in the drawing.

8 In the drawing, move the cursor to the location for the first device. This must be a point on the space boundary.

   ![Diagram of receptacles laid out automatically]

   **NOTE** If the software does not detect a space boundary, you can still insert the devices and have the software align them automatically, but you must manually specify the location for each device one at a time.

9 Examine the preview of the receptacle layout, and if necessary, move the cursor to a different location on the boundary.

   **NOTE** On the Properties palette, you can view the value for Number of devices. This read-only property is updated when the preview is displayed.

10 Click to insert the receptacles, and press Enter to end the command.

11 Depending on the layout and your design requirements, you might need to make minor adjustments to the receptacles. For example, you might need to move or remove the last receptacle added along the boundary.

   ![Diagram of receptacles adjusted manually]
NOTE For detailed information about adding devices and configuring their properties, see Adding Devices on page 391.

Example: Adding a Specific Number of Devices

In this example, you add a specific number of telephone outlets to a room. You specify the insertion point of the first outlet on a space boundary created for the room, and the software aligns all of the outlets along the boundary.

1 In a new drawing, attach or overlay a drawing of an architectural floor plan.
2 Activate an electrical display configuration.
3 If the floor plan drawing does not contain spaces, generate a space for a room by doing the following:
   ■ Open the Comm-Fire Device tool palette, and select the Space tool.
   ■ In the drawing, specify a point within a room, and press Enter.

NOTE By default, the electrical display configurations use the Reflected Screened display representation for Space objects. This display representation makes the boundaries of spaces visible in drawings, but adds the spaces to a non-plotting layer. The display representation is not used by any other display configurations provided with the software. For more information about the display system, see AutoCAD MEP Displays on page 134.

4 On the Comm-Fire Device tool palette, select a telephone tool.
5 If necessary, on the Properties palette, change the style of the telephone outlet to be added:
   ■ Expand Basic, and on the General bar, click .
   ■ In the left pane of the Select Device worksheet, navigate to the drawing that contains the style.
   ■ In the right pane, select the style, and click OK.
6 Expand Layout, and for Layout method, select Quantity around space.
7 For Number of devices, enter a number.
8 In the drawing, move the cursor to the location for the first device. This must be a point on the space boundary.

9 Examine the preview of the telephone outlets, and if necessary, move the cursor to a different location on the boundary.

10 Click to insert the outlets, and press Enter to end the command.

NOTE If the software does not detect a space boundary, you can still insert the devices and have the software align them automatically, but you must manually specify the location for each device one at a time.

NOTE On the Properties palette, you can view the value for Distance between. This read-only property is updated when the preview is displayed.

NOTE For detailed information about adding devices and configuring their properties, see Adding Devices on page 391.
Example: Inserting a Device into a Wire

In this example, you insert a service disconnect into a wire.

1 Open the Power-Lighting device tool palette, and select a disconnect tool.
2 On the Properties palette, expand Basic, and expand Layout.
3 For layout method, select One by One.
4 Expand Location, and for Align to objects, select No.
   This enables you to manually rotate the device in the drawing.
5 For justification, select Middle Center.
6 Enter w (wire), and in the drawing, select the wire into which to insert the device.
7 Move the device along the wire to the desired location, and click to specify the insertion point.
8 Rotate the symbol into position.
9 Click to insert the device, and press Esc.

TIP You can also insert a device into a wire and align the device perpendicular to the object to which you snap. This can be helpful when you want to break into a wire and, for example, add a receptacle aligned to a wall. For more information, see Adding Devices on page 391.

Adding Panels

After attaching a referenced drawing (xref) of the architectural plan to your drawing, typically you continue by placing panels or devices in the layout.

When you add a panel, you can create one or more circuits assigned to the panel at the same time. Alternatively, you can use Circuit Manager to create the circuits before or after you add panels or devices.

IMPORTANT To use a panel and its circuits in multiple drawings, create an electrical project database file and link the drawing to the electrical project database.

To add panels:

1 Start the add command by doing one of the following:
   - Click Home tab ➤ Build panel ➤ Panel .
   - Open the Panel tool palette, and select a tool.
If necessary, scroll to display the tool. Because tools contain preconfigured properties for the objects they create, you might not need to specify some of the panel properties referenced in this procedure.

Enter `paneladd`.

**NOTE** On the Properties palette, indicates a property is available only when you are adding panels, not when you are modifying them.

### Specify general properties

2. On the Properties palette, if necessary, specify or change the panel to add by selecting a panel style:

<table>
<thead>
<tr>
<th>If you want to select a panel style…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>in the current drawing</td>
<td>expand Basic, expand General, and for Style, select the style.</td>
</tr>
<tr>
<td>in a drawing in the directory specified as the default content location for electrical panels, or in the style drawing referenced in the properties of the tool you selected</td>
<td>on the General bar, click . In the left pane of the Select Panel worksheet, navigate to the drawing that contains the style, and select the drawing. In the right pane, select the style, and click OK.</td>
</tr>
</tbody>
</table>

3. For Description, enter a description of the panel.

### Specify location properties

4. Expand Location, and for Align to objects, specify how you want to align the panel:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>snap to an object using object snaps and have the software align the panel perpendicular to the object</td>
<td>select Yes. The software can align the panel perpendicular to a wall, space boundary, line, polyline, spline, arc, or circle in the current drawing or in an xref.</td>
</tr>
<tr>
<td>manually align the panel</td>
<td>select No.</td>
</tr>
</tbody>
</table>

**NOTE** If you select Yes for Align to objects, the software inserts the panel using the insertion point of the underlying block and rotates it as needed to align it perpendicular to the object to which you snap. As a result, you cannot specify a value for Justification on the Properties palette, or a value for Rotation on the command line.

5. For Justification, select the point on the panel to use as the insertion point.

You can select either the insertion point of the view block that represents the panel, or one of 9 other points on the panel, such as Top Left or Middle Center.

6. Specify an elevation by doing one of the following:

   - For Preset Elevation, select a defined elevation.
   - For Elevation, enter an elevation.

The difference in the elevation of the devices, the wires, and the panel for a circuit is used to calculate the circuit length. Note that the circuit length can only be calculated if the panel and all of the devices on the circuit are in the current drawing.
Specify advanced properties

7 Expand Advanced, expand System, and for System, select the system to which the panel belongs. For more information about systems, see Creating Electrical System Definitions on page 363 and Working with Systems on page 93.

8 Expand Design Data, and for Name, enter a unique name for the panel.

9 For Rating, enter a panel rating.

10 For Voltage phase-to-neutral, select from the drop-down list. The voltage list comes from the Electrical Preferences - Voltage Definitions.

11 For Voltage phase-to-phase, select from the drop-down list. The voltage list comes from the Electrical Preferences - Voltage Definitions.

12 For Phases, select the number of phases: 1 or 3.

13 For Wires, select the number of wires: 3 or 4.

14 For Main type, select Main lugs only (MLO) or Main circuit breaker (MCB).

15 For Main size (amps), enter the main size.

16 For Design capacity, enter the design capacity.

17 For Panel type, select ANSI or ISO.

18 For Enclosure type, enter an enclosure type.

19 For Mounting, select Surface, Recessed, or Floor.

20 For AIC rating, enter a rating.

21 For Fed from, enter the fed from information.

22 For Notes, enter any notes.

Optionally create one or more circuits for the panel

23 If you do not want to create circuits, skip this section and proceed to the section on inserting the panel. Otherwise, expand Circuits, and for Create circuits, select Yes.
24 Beside Circuit Settings, click .

25 On the Circuit Settings worksheet, for System Type, select the system type of the circuits: Power and Lighting, General, or Other.

**NOTE** If you select Power and Lighting or Other for the system type, the connectors on the electrical objects in your drawing must have the same system type in order to be placed on the circuit. To allow devices of any system type to be connected to the circuit, select General for the system type. The General system type allows objects of different system types to connect. For more information, see Circuits on page 356.

26 For System, select an electrical system for the circuits.

27 Specify additional circuit properties, which vary according to the system type of the circuit:

<table>
<thead>
<tr>
<th>If the system type is...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power and Lighting</td>
<td>Do the following:</td>
</tr>
<tr>
<td></td>
<td>■ Enter the total number of slots on the panel.</td>
</tr>
<tr>
<td></td>
<td>■ Enter the number of 1-pole, 2-pole, and 3-pole circuits to create. You can only create 3-pole circuits if you selected 3 for Phases on the Properties palette.</td>
</tr>
<tr>
<td></td>
<td>■ For each type of circuit to create (1-pole, 2-pole, and 3-pole), select a voltage. You can select from the voltages defined in the drawing that are valid for the number of poles.</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE</strong> If the number of 1-pole, 2-pole, and 3-pole circuits is less than the number of slots, the remaining circuits will be created with a rating of 0.</td>
</tr>
</tbody>
</table>
If the system type is... then...

General or Other for Number of circuits, enter the number of circuits to create.

28 For Circuit Description, specify the description for circuits with breakers and circuits without breakers that will display in the Circuit Manager when new circuits are created.

Insert the panels

29 In the drawing, insert the panels as follows:

<table>
<thead>
<tr>
<th>If, for Align to objects, you selected...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes</td>
<td>use object snaps to snap to an object (such as a wall) at the desired insertion point, and click to insert the panel.</td>
</tr>
</tbody>
</table>

**NOTE** If you have difficulty snapping and aligning to an object, zoom to the area or modify the size of the AutoSnap aperture as needed. The aperture size determines how close to a snap point you can be before the magnet locks the aperture box to the snap point. You can modify the size on the Drafting tab of the Options dialog. For more information, see “Drafting Tab (Options Dialog Box)” in the Autodesk® AutoCAD® Help.

<table>
<thead>
<tr>
<th>No</th>
<th>do the following:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>▪ Click to specify the insertion point.</td>
</tr>
<tr>
<td></td>
<td>▪ Rotate the panel by moving the cursor or entering the number of degrees on the command line, and click to insert the panel. Alternatively, you can press Enter to accept the default rotation, and then click.</td>
</tr>
</tbody>
</table>

30 Repeat the previous step to add additional panels with same properties.

31 On the Properties palette, modify the panel properties and then insert additional panels, or press Enter to end the command.

Optionally link the panel to an existing panel

32 If you do not want to link this panel to an existing panel, skip this section. Otherwise, select the panel, right-click and click Connect To.
33 Select the panel you want to connect to and click OK.

![Panel To Panel Connection](image)

**NOTE** Valid connections are shown in bold.

34 Select the method to use when connecting the panels and click OK.

![Panel to Panel Connection Method](image)

<table>
<thead>
<tr>
<th>If you select...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Circuit breaker in panel</td>
<td>the panel is added as a subfed panel to an existing circuit in the linked panel.</td>
</tr>
<tr>
<td>Feed-thru lugs</td>
<td>the panel is added as a subfed panel to a feed-thru lug in the linked panel.</td>
</tr>
<tr>
<td>Subfeed lugs</td>
<td>the panel will be added as a subfed panel to a subfeed lug circuit in the linked panel.</td>
</tr>
<tr>
<td>Subfeed breaker</td>
<td>the panel will be added as a subfed panel to a subfeed breaker circuit in the linked panel.</td>
</tr>
<tr>
<td>Panels are connected through a transformer (panels are different voltages)</td>
<td>the panel will be connected through a transformer when panels are of different voltages.</td>
</tr>
</tbody>
</table>

**NOTE** To remove the link to a panel, select the panel, click **Panel tab ➤ Connections panel ➤ Remove Connection To**.
Example: Aligning a Panel to Floor Plan Geometry

In this example, you add a panel and align it to a wall.

1. In a new drawing, **attach or overlay a drawing** of an architectural floor plan.
2. In the **Electrical workspace**, open the Panel tool palette, and select a panel tool.
3. If necessary, on the Properties palette, change the style of the panel to be added:
   - Expand Basic, and on the General bar, click .
   - In the left pane of the Select Panel worksheet, navigate to the drawing that contains the style.
   - In the right pane, select the style, and click **OK**.
4. Expand Location, and for Align to objects, select Yes.
   This causes the panel to align to the object to which you snap. You can snap and align to a wall, space boundary, line, polyline, spline, arc, or circle in the current drawing or in a referenced drawing (xref).
5. In the drawing, snap to a wall at the desired insertion point, and click to specify the point.
   **TIP** When you are prompted for a point, you can temporarily enable an object snap by entering the first 3 characters of its name. This is useful when you require a snap that you do not want as a running object snap, such as Nearest, which snaps to the nearest point on an object.
   **NOTE** If you have difficulty snapping and aligning to an object, zoom to the area, or modify the size of the AutoSnap aperture as needed. The aperture size determines how close to a snap point you can be before the magnet locks the aperture box to the snap point. You can modify the size on the Drafting tab of the Options dialog. For more information, see “Drafting Tab (Options Dialog Box)” in Autodesk® AutoCAD® Help.
6. Press **Enter**.

   **NOTE** For detailed information about adding panels and configuring their properties, see Adding Panels on page 403.

Copying Devices and Panels

You can copy devices and panels using Alignment grips ( ). Unlike the AutoCAD COPY command, the grips can optionally align the copy perpendicular to the object to which you snap, such as a wall or a ceiling grid.

By default, Alignment grips are displayed at the electrical connector points on devices and panels. However, you can toggle on additional grips by clicking the Show all insertion points grip. The additional grips are
located at the justification points available when adding devices and panels, for example, Top Left, Bottom Center, and Insertion Point. In the following image, one receptacle displays the default Alignment grip; the other also displays the additional grips.

![Image of receptacles showing default and additional grips]

**NOTE** When you copy multiple devices or panels at the same time using Alignment grips, you must select a base grip on one device or panel (the base device or base panel) for the copy action. If you align the copy of the base device or base panel to an object, the other copies inherit the same angle of rotation. The other copies also maintain their position relative to the base copy.

**To copy a device or panel**

1. Select the device or panel.
2. Select the Alignment grip to use to insert the copy:
   - **If you want to insert the copy relative to...**
     - its electrical connector point
     - another point on the device or panel
   - **Then...**
     - select the default grip.
     - click the Show all insertion points grip, and select the grip.

   **NOTE** To copy multiple devices or panels at the same time, while pressing **Shift**, select the same Alignment grip on each of the devices or panels to create the selection set. Then, on one device or panel, reselect the grip to use it as the base grip.

3. Specify how you want to align the copy:
   - **If you want to...**
     - snap to an object using object snaps and have the software align the copy perpendicular to the object
     - place the copy using the angle of rotation of the original device or panel
   - **Then...**
     - proceed to the next step. When you select an Alignment grip, this behavior is active by default.
     - press **Ctrl**. This toggles off the alignment behavior, but you can still snap to an object to place the copy.

   **NOTE** The software can align the copy perpendicular to a wall, ceiling grid, space boundary, line, polyline, spline, arc, or circle in the current drawing or in a referenced drawing (xref).

4. Enter **c** (copy).
5. **Copy the device or panel:**
   - **If you want to...**
     - use the base grip point as the base point for the copy
   - **Then...**
     - specify the second point (the insertion point of the copy) by doing one of the following:
       - specify a point in the drawing. For example, you can snap to a point on a wall.
<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>■ enter the coordinates, and press Enter.</td>
<td></td>
</tr>
</tbody>
</table>

specify a base point and then a second point  
enter b (base point), specify the base point, and then specify the second point.

**NOTE** If you have difficulty snapping and aligning to an object, zoom to the area, or modify the size of the AutoSnap aperture as needed. The aperture size determines how close to a snap point you can be before the magnet locks the aperture box to the snap point. You can modify the size on the Drafting tab of the Options dialog. For more information, see “Drafting Tab (Options Dialog Box)” in the Autodesk® AutoCAD® Help.

6 Repeat the previous step to place additional copies.

7 Press Esc.

**NOTE** When copying a device, the loads will increase for the circuit. Use the REGEN command to update a panel schedule for that circuit. If the new load exceeds the limit for the load category, the panel schedule will need a new row. A diagonal line through the panel schedule will indicate that the schedule is out of date. See Updating Panel Schedules on page 459 for more information.

---

**Example: Copying a Device**

In this example, a receptacle is copied to 2 locations in a room.

![Example Diagram](image-url)
**Example: Copying a Panel**

In this example, a recessed panel is copied and aligned elsewhere on the same wall.

1. Select panel
2. Click Show all insertion points grip
3. Select Alignment grip
4. Enter 0, then place copy

**Adding Wires**

Although you can connect devices with wires to graphically represent circuits, wires are not necessary for you to assign devices to circuits and to view electrical loads.

You can also add wires without assigning circuits, which can be useful during the preliminary design phase when the specifications are not defined.
Drawing or Generating Wires

You can add wires by doing one of the following:

- Drawing the wires manually by using a wire tool, or by using the + grip on an electrical device
- Generating the wires using a command. In this case, you must specify a circuit in the wire’s properties.

If you assign the devices to a circuit as you connect them with wires, the circuit is updated and evaluated for overloads based on the load and load category of the connectors on the devices. In circuiting preferences, you can specify whether the software warns you of the overloads, so you can decide whether to proceed and add the wire. If you overload a circuit, you are not notified of the overload again within the drawing session.

When you use the + grip to invoke a wire-add operation, the software uses the set of properties for the connector of the chosen device. For example, for system, it will use the system type of the connector of the chosen device. If the system type is undefined, the wire-add operation uses the last used system in that drawing or session for the system type. The Properties palette will filter the Systems list to display only those systems that match the connector.

The Properties palette will also show:

- Circuit, unless it is unassigned
- Panel, based on the circuit

The list of available circuits will show only those that can be used for the chosen connector. When a connector circuit is unassigned, the available list shows:

- For Power and Lighting circuits, the first available circuit with no load, or the one with the least amount of load
- For Other circuit connectors, the first available circuit of that type
- For General circuits, the first circuit available

The list of circuits also displays the total assigned load for each circuit. The list of panels will show the last used panel, or All if Circuit is undefined.

You can add wires using any of the following types of wire segments.

<table>
<thead>
<tr>
<th>Wire Segment Type</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line. Use this type to draw wires using straight lines.</td>
<td>![Line Example]</td>
</tr>
<tr>
<td>Arc. Use this type to draw wires with arcs.</td>
<td>![Arc Example]</td>
</tr>
<tr>
<td>Snake. Use this type to draw wires with arcs that alternate the offset direction.</td>
<td>![Snake Example]</td>
</tr>
<tr>
<td>Polyline. Use this type to draw wires with lines connected with filleted corners.</td>
<td>![Polyline Example]</td>
</tr>
<tr>
<td>Chamfer. Use this type to draw wires with plateaus.</td>
<td>![Chamfer Example]</td>
</tr>
</tbody>
</table>
**Wire Segment Type**

**Example**

Spline. Use this type to draw wires with curves that pass through or near a set of specified points.

---

**To add wires**

1. In the **Electrical workspace**, start the add command by doing **one** of the following:
   - Click Home tab ➤ Build panel ➤ Wire.
   - Select the + grip on a device.
   - Open the Wire tool palette, and select a tool. If necessary, scroll to display the tool. Because tools contain preconfigured properties for the objects they create, you might not need to specify some of the wire properties referenced in this procedure.
   - Enter wireadd.

**NOTE** On the Properties palette, indicates a property is available only when you are adding wires, not when you are modifying them.

---

**Specify general properties (optional when using the + grip)**

2. On the Properties palette, if necessary, specify or change the wire to add by selecting a wire style:
   - Expand Basic, and expand General.
   - For Style, select a wire style.
     - You can select from the wire styles in the current drawing.
   - If you want to calculate wire sizes using the instant sizing tool, do not select the Standard style provided with the software. By default, that style does not specify a wire material, which is required to calculate the sizes.
3 For Description, enter a description of the wire.

Specify location properties

4 Expand Location, and for Segment, select the type of wire segment to use:

<table>
<thead>
<tr>
<th>If you want to use…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line</td>
<td>select Line.</td>
</tr>
<tr>
<td>Arc</td>
<td>select Arc, and do the following: ■ For Height, enter the height of the geometry. ■ For Offset, select Left or Right, which indicates the side on which to display the geometry.</td>
</tr>
<tr>
<td>Snake</td>
<td>select Snake, and specify values for Height and Offset.</td>
</tr>
<tr>
<td>Polyline</td>
<td>select Polyline, and for Radius, enter a radius to set the curvature for the fillets.</td>
</tr>
<tr>
<td>Chamfer</td>
<td>select Chamfer, and specify values for Height and Offset.</td>
</tr>
<tr>
<td>Spline</td>
<td>select Spline, and specify values for Height and Offset.</td>
</tr>
</tbody>
</table>

**TIP** When drawing wires using arc, snake, or spline segments, you can override the values for Offset and for Height by specifying a point between 2 devices. This can be helpful when you want to route the wires around walls, equipment, or other floor plan geometry, or when you are unsure of the value to specify for Offset. For an example, see Example: Drawing Wires on page 417.

5 Specify an elevation by doing one of the following:

- For Preset Elevation, select a **defined elevation**.
- For Elevation, enter an elevation.

The difference in the elevation of the devices, the wires, and the panel for a circuit is used to calculate the circuit length. Note that the circuit length can only be calculated if the panel and all of the devices on the circuit are in the current drawing.

Specify advanced properties

6 Expand Advanced, expand System, and for System, select the system of the wire.

**NOTE** If the electrical connector on the device to which the wire will be connected does not have a specified system, you can connect a wire of any system to the connector. However, if the connector has a specified system, the system of the wire must be the same. If it is not the same, you cannot add the wire unless the system of the electrical connector is changed to match. Depending on how you have configured the connection rules, you are prompted to accept the change before adding the wire, the change is made without prompting you, or you cannot make the change and add the wire. The system of the device, which only determines how the device is displayed, is not affected. For more information about systems, see Creating Electrical System Definitions on page 363 and Working with Systems on page 93.

7 Expand Design Data, and specify whether to assign the devices to a circuit as you connect them with wires:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>connect the devices with wires without assigning a circuit</td>
<td>for Circuit, select Unassigned.</td>
</tr>
</tbody>
</table>
If you want to… then…

<table>
<thead>
<tr>
<th>assign the devices to a circuit</th>
<th>for Show circuits from panel, select the panel that contains the circuit. You can select from the panels in the current drawing, or in the electrical project database. Then, for Circuit, select the circuit.</th>
</tr>
</thead>
</table>

**IMPORTANT** To use the instant sizing tool to calculate the wire sizes, you must select a circuit whose system type is Power and Lighting. You cannot select Unassigned or a circuit of different system type.

---

**NOTE** As you connect the devices with wires, the software assigns the devices to the specified circuit unless they are already assigned to one. In this case, the Circuit property cannot be changed. You can manually create a multiple-branch circuit by changing the specified circuit as you add wires, or by drawing a wire between 2 devices that are already assigned to different circuits.

---

**Specify wire sizes**

8 Expand Dimensions, and specify the wire sizes by doing one of the following:

- On the Dimensions bar, click ![instant sizing tool](image) to have the instant sizing tool calculate the sizes. The tool calculates the sizes based on:
  - The material and temperature rating of the wire, which are specified in the wire style
  - The rating of the specified Power and Lighting circuit
  - The ambient temperature specified in the drawing. For information about specifying the ambient temperature, see Configuring Circuiting Options on page 366.

- Select or enter wire sizes for the hot, neutral, ground, and isolated ground wires.

The wires for which you need to calculate or specify sizes depend on the design specifications of the selected wire style.

---

**Insert the wires**

9 Connect the devices with wires:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>insert the wires manually</td>
<td>in the drawing, use <strong>electrical snaps</strong> to manually specify the devices to connect with wires. For an example, see Example: Drawing Wires on page 417.</td>
</tr>
</tbody>
</table>

**NOTE** As you connect the devices with wires, on the Properties palette you can view the assigned circuit (Connected circuits) and its total load (Connected load). In the case of multiple-branch circuits, all circuits and their total loads are shown.

| generate the wires | enter g (generate) on the command line to generate wires between all the devices assigned to the specified circuit. |

---
Optionally insert a home run wire

10 Do one of the following:

- To add a home run, press Enter, and click in the direction of the panel. The appearance of the home run depends on the annotation properties of the wire style.

- To end the command without adding a home run, press Enter twice. You can add a home run later, as shown in Drawing a Home Run on page 418.

Example: Drawing Wires

In this example, you connect receptacles with wires using the spline wire segment. You override the default height and offset direction for one of the wires, so you can draw the wire along the wall.

1 In a new drawing, attach or overlay a drawing of an architectural floor plan.

2 Add several receptacles to a room as shown.

3 Select the left most receptacle and click on the + grip.

4 On the Properties palette, enter a distance for Height, and specify Left for Offset.

5 Using electrical end connector snaps, specify the first device to connect with wires.

6 Snap to the electrical connector on the second device.
7 Draw the third wire by manually overriding the height and the offset direction of the wire. To do this, specify a point between the devices, and then snap to the third device.

8 Press Enter twice to end the command without adding a home run.

NOTE For detailed information about adding wires and configuring wire properties, see Drawing or Generating Wires on page 413.

Drawing a Home Run

A home run is a wire that graphically represents the wiring of a circuit to a central location that acts as the distribution point for the power, typically, a panel. You do not need to connect the home run to the panel. You can draw the home run in the direction of the panel, as is common practice.

The appearance of the home run is determined by the annotation properties of the wire style.

While you can use a single home run to represent the connection of one or more circuits to a single panel, sometimes devices are assigned to multiple circuits on different panels. For example, you might have a lighting fixture with 2 electrical connectors, where the first connector is assigned to a circuit on a panel for normal lighting, and the second connector is assigned to a circuit on a panel for emergency lighting. When
a device is assigned to multiple circuits on multiple panels, you must add a home run to each panel. This allows you to subsequently tag each home run with the correct panel information. Make sure the locations of the electrical connectors in the device style are not the same, so you are able to draw a home run from each connector.

To draw a home run

1. Select an existing wire on the circuit, and click Wire tab ➤ General panel ➤ Add Selected.
2. Using electrical snaps, select a device in the circuit.
3. Press Enter, and specify a point in the direction of the circuit’s panel.

Creating a Wire from a Polyline

You can convert an AutoCAD® line, arc, or polyline to a wire.

1. Select the line, arc, or polyline that you want to convert, right-click, and select Convert to Wire.
2. Do one of the following:
   - Press Enter or enter n (no) to leave the layout geometry in the drawing.
   - Enter y (yes) to erase the layout geometry from the drawing.
3. In the Modify Wires dialog, specify values for the wire properties, such as system and voltage.
4. Click OK.

Adding Electrical Equipment

After you add devices and panels to your layout and update the circuitry to include voltage and load requirements, typically you continue by adding the electrical equipment needed to support the system. You can place the equipment in specific locations on the floor plan.

You add electrical equipment using the tools on the Equipment tool palette in the Electrical tool palette group. You select a tool, use the Add Multi-view Parts dialog to select a part and configure its properties, and then add the part to the drawing.

RELATED See Mechanical, Electrical, and Plumbing Equipment in Building Systems on page 76.

To add electrical equipment

1. In the Electrical workspace, Click Home tab ➤ Build panel ➤ Equipment drop-down ➤ Generator (or other provided equipment).
The software displays the Add Multi-view Parts dialog, which displays a tree view of the current catalog.

![Add Multi-view Parts dialog](image)

The software opens the catalog at the part type folder associated with the tool you selected.

2 On the Part tab, select a part subtype in the part type folder.

3 Click Details to view the sizes available for the selected part subtype.

4 Some part types have large numbers of available sizes. If necessary, filter the list by clicking the Part Filter tab and specifying the filtering criteria. For example, you can filter the list according to connection size or type.

**NOTE** The part catalogs and content locations specified in the Options dialog determine the parts available to you when adding a part. For more information, see Specifying Part Catalogs and Style-Based Content Locations on page 70.

If the part you want is not available, you or your CAD manager can create a custom part using Content Builder.

5 Select a part for Part Size Name.

6 Select a defined elevation from the list or enter a value for Elevation.

7 Specify an insertion point in the drawing, and use the compass to specify a rotation angle.

8 Repeat the preceding step to add additional parts with the same properties.

9 Press Enter to end the command.

### Drawing Cable Trays and Conduits

You can add cable tray and conduit runs in different sizes.

As you draw runs, the software inserts fittings, such as elbows and tees, to connect segments and runs to other segments, runs, or equipment. The default parts specified in the cable tray and conduit preferences
determine the fittings that are inserted by the software. To override the default fittings for an individual run, access the fitting preferences in the Add dialog and select different fittings.

You can also manually add fittings to your drawing, which is beneficial when you want to create unique connections to other runs or equipment.

**NOTE** For information about specifying layout preferences, see Configuring Layout Preferences for Cable Tray or Conduit on page 376.

### Drawing a Cable Tray or Conduit Run

**NOTE** When you add cable tray runs or conduit runs, AutoCAD MEP inserts rise symbols and drop symbols as needed based on the *rise/drop style* assigned to the system of the run.

1. In the Electrical workspace, open the Cable Tray & Conduit tool palette, and select a cable tray or conduit tool. If necessary, scroll to display the tool.

   **NOTE** Alternatively, you can click Home tab ➤ Build panel ➤ Cable Tray or click Home tab ➤ Build panel ➤ Conduit.

   The cable tray and conduit tools have specific, predefined systems, such as Power - 120V or Data. The cable tray or conduit that you draw inherits the system’s properties, such as its design parameters, display properties, and rise and drop style. For more information, see Working with Systems on page 93.

2. Select a system for system.
3. Select a defined elevation or enter a value for Elevation.
4 Specify how to draw the run:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>draw a run at a specified elevation relative to a wall or other cable tray or conduit</td>
<td>enter the desired elevation, specify justification and offset, and use AutoCAD® snaps or AutoCAD MEP snaps to specify points on the wall, duct, pipe, or other objects.</td>
</tr>
<tr>
<td>start a branch at a specified elevation on a riser</td>
<td>enter the desired elevation, and use AutoCAD MEP snaps to specify a point on the riser.</td>
</tr>
<tr>
<td>start a branch from a vertical run with a riser at a specified elevation</td>
<td>enter the desired elevation, and use AutoCAD MEP snaps to specify a point on the vertical run.</td>
</tr>
<tr>
<td>extend a sloped cable tray or conduit segment to a specified elevation</td>
<td>enter the desired elevation, click Use Rise/Run, and use AutoCAD MEP snaps to specify the endpoint of a sloped duct or pipe.</td>
</tr>
</tbody>
</table>

If you lock the elevation by clicking , the elevation from the objects that you connect to is not inherited.

5 Specify the offset and the rise/run angle:

<table>
<thead>
<tr>
<th>If you want to specify…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>the horizontal offset</td>
<td>select Left, Right, or Center. Enter the distance of the run from the wall or other horizontal object.</td>
</tr>
<tr>
<td>the vertical offset</td>
<td>select Top, Center, or Bottom. Enter the distance of the run from the ceiling or other vertical object.</td>
</tr>
<tr>
<td>the rise/run angle</td>
<td>Select Use Rise/Run and then enter a value in degrees.</td>
</tr>
</tbody>
</table>

6 For cable tray, you can specify the width and height.
7 For conduit, you can specify the connection type and diameter.

8 Click Use Routing, and then select a routing method:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>draw with a predefined elbow angle</td>
<td>select an elbow angle from the list.</td>
</tr>
<tr>
<td>define your own elbow angle in the drawing area</td>
<td>select User Defined for Elbow Angle. Specify a point for the elbow angle. You can draw either with or without the Compass.</td>
</tr>
<tr>
<td>define your own elbow angle in the dialog</td>
<td>enter a value for Elbow Angle.</td>
</tr>
<tr>
<td>update the options in the Elbow Angle list to select elbow angles from the catalog</td>
<td>select Show Catalog for Elbow Angle. Elbow angles from the catalog are not displayed by default in order to increase drawing performance.</td>
</tr>
<tr>
<td>hide the options from the catalog in the Elbow Angle list in order to increase drawing performance</td>
<td>select Hide Catalog for Elbow Angle.</td>
</tr>
<tr>
<td>draw with only the selected elbow angle</td>
<td>click the Lock icon next to Elbow Angle. All segments you draw next will have the same elbow angle.</td>
</tr>
</tbody>
</table>
If you want to… then…

draw with both an elbow angle and a rise or drop to a specific elevation  
then click the Preferences icon, and then click the Routing tab. Clear Automatically create riser at new Elevation, and then click OK. Enter an elevation and draw the segment with an elbow angle.

save drawing performance and not display the elbow as you draw with a specified elbow angle  
then click the Preferences icon, and then click the Routing tab. Clear Preview Elbow when Compass is Enabled and/or Preview Elbow when Compass is Disabled.

specify the predefined elbow angles that are displayed in the Elbow Angle list  
then click the Preferences icon, and then click the Routing tab. Enter or delete elbow angles in the Elbows Angles list.

NOTE The selection of elbow angles does not apply to the first segment that you draw.

9 Specify a start point in the drawing, and then continue to specify points to add more segments to your run.

   The software inserts the appropriate fittings to connect the segments that you draw. For information about temporarily overriding the default fittings, see Drawing Cable Trays and Conduits on page 420.

10 Click Close.

The system and parameter settings you specify remain in effect until you change them.

Adding a Cable Tray or Conduit Branch

After you draw your cable tray or conduit runs, you can add branches to connect the runs to form a complete network. You can use AutoCAD MEP snaps to help you locate valid connection points on the objects in your drawing.

NOTE You can connect different systems by selecting either Prompt for User Input or Connect Test Mismatch in the Layout Rules tab of the Options dialog.

When you start a run at the end of a segment, the nearest valid connection point is not always the endpoint of a segment. You can form a valid connection at any point along the path of another run. In this case, the software inserts an appropriate fitting to connect the 2 runs.

Drawing a branch

To add cable tray or conduit to an existing segment, select the segment, and click Cable Tray tab or Conduit tab ➤ General panel ➤ Add Selected . This enables you to match the properties of the selected segment without having to redefine them in the Add dialog.
Connecting a cable tray run to a cable tray trunk that is the same size

NOTE When you add cable tray or conduit runs, AutoCAD MEP inserts rise symbols and drop symbols as needed based on the rise/drop style assigned to the system of the run.

To add a cable tray or conduit branch

1 Turn on the Wire Ways Curve or Wire Ways Connector snaps. For help with this step, Using AutoCAD MEP Snaps.
2 In the Electrical workspace, open the Cable Tray & Conduit tool palette, and select a cable tray or conduit tool. If necessary, scroll to display the tool that you want.

   NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Cable Tray or click Home tab ➤ Build panel ➤ Conduit.

3 Using the Wire Ways Connector or Wire Ways Curve snap, select the first segment to connect, and then select the second segment.
You can modify properties on the command line.
4 Click Close or press Enter to end the command.
   Once you complete your connections, you can use Solution Tips to test whether your connections are valid. For more information, see Showing Solution Tips on page 579.

Adding Cable Tray or Conduit Fittings Manually

Generally, as you draw a cable tray or conduit run, the software adds fittings based on the default fittings specified in the cable tray or conduit preferences. However, you can also add cable tray or conduit fittings manually. You can add a fitting to an existing segment or run. You can also start a segment or run from a fitting, or customize the connection to an MvPart.

To add a cable tray or conduit fitting

1 In the Electrical workspace, open the Cable Tray & Conduit tool palette, and select a fitting tool. If necessary, scroll to display the tool.

   NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Cable Tray or click Home tab ➤ Build panel ➤ Conduit.
On the Part tab in the Add Cable Tray Fittings dialog, select a part type folder, and then select a part subtype in the folder.

Select Display/Hide additional part parameters to display or hide more information in this dialog.

Click Details to view the sizes available for the selected part type.

Some part subtypes have large numbers of available sizes. If necessary, filter the list by clicking the Part Filter tab and specifying the filtering criteria. For example, you can filter the list according to connection size or type.

Select a part for Part Size Name.

Select a defined elevation or enter a value for Elevation.

Specify an insertion point in the drawing, and use the compass to specify a rotation angle.

Repeat the preceding step to add additional fittings with the same properties.

Click Close.

Checking Electrical Systems

AutoCAD MEP includes circuit information tools to help you make decisions about circuit and panel assignments. You can review information for a single circuit or for all circuits in the drawing. You can also calculate power totals for selected devices. If you are using the electrical project database, you can maintain accurate circuit information across all drawings.

Calculating Wire Sizes Using the Circuit Manager

When you check the wire sizes for circuits, the software calculates the sizes from the circuit rating and then compares them to the actual wire sizes in the circuit. You can then optionally resize undersized or oversized wires.

To check the wire sizes for circuits

1 In the Electrical workspace, select a wire and click Wire tab ➤ Circuits panel ➤ Circuit Manager drop-down ➤ Circuit Manager.

2 On the right pane of the Circuit Manager, select the circuit (or circuits) to check.

Use SHIFT or CTRL to select multiple rows in the circuit view list to select multiple circuits. Choosing a panel on the left pane selects only the first circuit in the circuit list.

NOTE Before you can calculate wire sizes, you must add wire to the devices in the circuit. You must also set the type of conductor material for the wire style used, for example, copper or aluminium (for more information, see Configuring Styles for Wires on page 373).

3 Click (Calculate Wires).

4 In the Calculate Wire Sizes dialog, specify a resizing option:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>compare wire sizes to calculated values without changing any sizes</td>
<td>select Check only.</td>
</tr>
<tr>
<td>check wire sizes and have undersized wires resized automatically</td>
<td>select Change Under dimensioned.</td>
</tr>
<tr>
<td>check wire sizes and have both undersized and oversized wires resized automatically</td>
<td>select Change All.</td>
</tr>
</tbody>
</table>
5 Click OK. If you chose to resize any wires, the wire sizes are updated in the right pane under Wires. If you chose only to check the wire sizes, the Calculate Wire Size - Results dialog displays the results of the analysis.

Viewing Circuit Information

You can view the voltage, load, and length of a particular circuit to help you make design decisions, such as whether to extend an existing circuit or how to make panel assignments.

To view circuit information

1 Select a wire or a device, click Wire tab or Device tab ➤ Circuits panel ➤ Circuit Manager drop-down ➤ Circuit Info.

If you are using the electrical project database file, and have reloaded the electrical project database in the current drawing, note that the circuit load reflects the total load from all devices assigned to the circuit. The devices contributing to the total load can reside in multiple drawings.

2 Click Close.

Checking Circuit Loads

Circuit loads can be automatically tabulated for circuits of the Power and Lighting system type. When you assign devices to a circuit, their loads are automatically added to the circuit load. You can view circuit loads in the Circuit Manager, or you can view circuit information or a circuit report for one or more selected devices.

You can use the circuiting settings in the Electrical Preferences to indicate circuit overload conditions. When turned on, overloaded circuits are displayed in red on the Circuit Manager. You can also turn on a feature to notify you when a circuit is overloaded as you are assigning devices to circuits in the drawing.

Circuit Manager displaying an overloaded circuit
If you are using an electrical project database file, which is recommended for creating and maintaining accurate circuit information across all drawings in a project, the circuit information is accurate and complete even if devices in multiple drawings are assigned to the same circuit.

**Generating a Circuit Report**

As you create schedules for your electrical design, you might find it helpful to view information about particular circuits in the drawing. In a circuit report, you can view the assigned panel name, circuit name, voltage, load (in VA), circuit length, and number of devices for one or more selected circuits.

You can copy the information in a circuit report to the Clipboard, and then paste it into another application, such as a spreadsheet or word processing application.

**NOTE** The Circuit Manager also supports Copy to Clipboard (CTRL + C).

**To generate a circuit report**

1. To report on a wire or device, select the object, click Wire tab or Device tab ➤ Circuits panel ➤ Circuit Manager drop-down ➤ Circuit Info.

2. If you want to copy the report into another program, click (Copy to Clipboard).

**Showing Circuited Devices**

You can use the Show Circuited Devices command to highlight all devices that are part of the same circuit. This feature finds all of the devices in the current drawing that are connected to the same circuit.

**NOTE** You can also check the connectivity of a run or individual object. For more information, see Checking Your Drawings on page 579.

**To show circuited devices**

1. In the Electrical workspace, use one of the following methods to show circuited devices:
   - Select a wire or device and click Wire tab or Device tab ➤ Circuits panel ➤ Show Circuited Objects drop-down ➤ Show Circuited Objects.
   - Select a device, right-click, and click Connected Objects ➤ Show Circuited Objects.

   The devices connected in the circuit are highlighted.

2. Press Enter to exit the command and remove the highlighting.
Example of highlighting circuited devices

**NOTE** You can also access the Show Circuited Devices command from the Circuit Manager. In the Circuit Manager, you select a circuit that has one or more connected devices and, on the toolbar, click (Show Circuited Devices).

### Showing Connected Objects

You can highlight all connected objects in a run or network. For example, you can check a lighting network to ensure connectivity between the lighting devices, wires, junction boxes, and switches. You can also check an equipment drawing to ensure connectivity between MvParts and conduit or cable tray runs.

**To show connected objects**

1. In the Electrical workspace, select an object, and click the object’s contextual ribbon tab (such as Cable Tray Fitting tab) ➤ Modify panel ➤ Show Connected Objects drop-down ➤ Show Connected Objects.
2. All objects connected to the selected object are highlighted.
3. Press Enter to exit the command and remove the highlighting.

### Viewing Power Totals

To avoid overloading circuits, you can calculate a power total for devices before you connect them. You can display a power total for a selection set that includes lighting, receptacles, and other devices, which includes all devices of all other types.

**To view power totals**

1. In the Electrical workspace, click Analyze tab ➤ Electrical panel ➤ Power Totals.
2. Select the devices for which to view a total, and press Enter.

**NOTE** Alternatively, you can select a device and click Device tab ➤ Circuits panel ➤ Power Totals.
Modifying Electrical Systems

You can modify all aspects of your electrical system designs.

Modifying Circuits

As you change and refine the electrical system design, you might need to adjust the organization of the circuits. Use the Circuit Manager to view how circuits are organized, move circuits between panels, delete circuits that are no longer being used, and resize wires in a circuit. You can also edit some circuit properties, but you cannot edit others, such as the circuit length, without making changes to the actual electrical design.

The Circuit Manager is the only place where you can access circuit objects to make changes. Because circuits are non-graphical elements, nothing changes visually in your drawing when you make circuit changes. However, by accessing circuit information about an electrical component or generating a circuit report about a selection of components, you can see the effects of the changes you have made.

NOTE If you are using an electrical project database, you cannot edit circuits from any linked drawing. To modify circuits, open the electrical project database file and modify them using the Circuit Manager. Save and close the electrical project database file before continuing work on any linked drawings. If circuit modifications affect any linked drawings, you are prompted to open and save them in order to update them with the most current electrical project database information.

Moving Circuits to Manage Demand Load

When you view circuits in the Circuit Manager and see that the load is too high on a panel, move one or more of its circuits to a different panel. All of the information about the circuit and its device connections moves with the circuit to the new panel.

Unless you have used wire to represent the circuit, you can make this move without physically changing anything in your drawing. If you are using an electrical project database, you are prompted to open and save any linked drawings that are affected by the modifications.

To move circuits between panels

1. In the Electrical workspace, select a panel and click Panel tab ➤ Circuits panel ➤ Circuit Manager.
2. In the Circuit Manager, in the expanded panel tree view in the left pane, click the circuit to be moved and drag it onto a different panel.
   You can now see the voltage and load information change in the Circuit Manager.

NOTE Anytime you modify circuits, you will need to update any existing panel schedules. See Updating Panel Schedules on page 459.

Modifying Circuit Properties

Use the Circuit Manager to change the property information of circuits. You can edit some circuit properties only if there are no devices connected to the circuit.

After you assign one or more devices to a circuit, you can edit only a few of the circuit properties.

Depending on the system type, you can modify the following circuit properties:

- Name
NOTE  Anytime you modify circuit properties, you will need to update any existing panel schedules. See Updating Panel Schedules on page 459.

The Load Category is a style that you can modify using the Style Manager. For more information, see Creating Load Category Definitions on page 364.

To modify circuit properties

1 In the Electrical workspace, and click Analyze tab ➤ Electrical panel ➤ Circuit Manager ➤.
2 In the left pane of the Circuit Manager, select the circuit to be modified.
   If you want to edit the properties of multiple circuits, select the branch in the left pane that contains the circuits. On the right pane, use SHIFT or CTRL to select multiple rows in the circuit list view.
3 In the list view in the right pane, double-click the circuit property to be modified.
4 Enter the new information, or select a new property from the list.

Deleting Circuits

Use the Circuit Manager to delete circuits. If you delete a circuit that is not attached to any devices, the circuit is deleted without warning. If the circuit is attached to devices, you are prompted to confirm the deletion.

To delete circuits

1 In the Electrical workspace, click Analyze tab ➤ Electrical panel ➤ Circuit Manager ➤.

   NOTE  Alternatively, you can select a device and click Device tab ➤ Circuits panel ➤ Circuit Manager drop-down ➤ Circuit Manager ➤.

2 In the Circuit Manager, do one of the following:

   If you want to delete… then…
   a single circuit select the circuit in the left pane in the tree view.
   multiple circuits select the system type in the left pane, and use SHIFT or CTRL to highlight and select the circuits in the right pane.

3 Click (Delete circuit).

   NOTE  When you delete a circuit, be sure to use the Update Panel Schedule command to update any panel schedules associated with that circuit to remove its data from the schedule.
Modifying Devices and Panels

You can move the devices and panels in a drawing, and you can modify their properties.

If you are using an electrical project database, and you modify the properties of panels in the electrical project database, you must save and close the electrical project database before working on linked drawings.

Moving a Device or Panel

You can move devices and panels using Alignment grips ( ). Unlike the AutoCAD MOVE command, you can optionally use the grips to align the device or panel perpendicular to the object to which you snap, such as a wall.

By default, Alignment grips are displayed at the electrical connector points on devices and panels. However, you can toggle on additional grips by clicking the Show all insertion points grip. The additional grips are located at the justification points available when adding devices and panels, for example, Top Left, Bottom Center, and Insertion Point. In the following image, one receptacle displays the default Alignment grip. The other also displays the additional grips.

NOTE When you move multiple devices or panels at the same time using Alignment grips, you must select a base grip on one device or panel (the base device or base panel) for the move action. If you align the base device or base panel to an object, the other devices in the selection set inherit the same angle of rotation. They also maintain their position relative to the base device or base panel.

To move a device or panel

1 Select the device or panel.

2 Select the Alignment grip to use to move the device or panel:
   
   If you want to move the device or panel relative to...
   
   Then...

   its electrical connector point
   
   select the default grip.

   another point on the device or panel
   
   click the Show all insertion points grip, and select the grip.

NOTE To move multiple devices or panels at the same time, while pressing Shift, select the same Alignment grip on each of the devices or panels to create the selection set. Then, on one device or panel, reselect the grip to use it as the base grip.
Specify how you want to align the device or panel:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>snap to an object using object snaps and have the software align the device or panel perpendicular to the object</td>
<td>proceed to the next step. When you select an Alignment grip, this behavior is active by default.</td>
</tr>
<tr>
<td>place the device or panel using its current angle of rotation</td>
<td>press Ctrl. This toggles off the alignment behavior, but you can still snap to an object.</td>
</tr>
</tbody>
</table>

Move the device or panel:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>use the base grip point as the base point for the move</td>
<td>specify the second point (the insertion point) by doing one of the following:</td>
</tr>
<tr>
<td></td>
<td>■ specify a point in the drawing. For example, you can snap to a point on a wall.</td>
</tr>
<tr>
<td></td>
<td>■ enter the coordinates, and press Enter.</td>
</tr>
<tr>
<td>specify a base point and then a second point</td>
<td>enter b (base point), specify the base point, and then specify the second point.</td>
</tr>
</tbody>
</table>

NOTE: If you have difficulty snapping and aligning to an object, zoom to the area, or modify the size of the AutoSnap aperture as needed. The aperture size determines how close to a snap point you can be before the magnet locks the aperture box to the snap point. You can modify the size on the Drafting tab of the Options dialog. For more information, see “Drafting Tab (Options Dialog Box)” in the Autodesk® AutoCAD® Help.

5 Press Esc.

Example: Moving a Device

In the following example, a telephone outlet is moved from one wall to another.
Example: Moving a Panel

In the following example, a recessed panel is moved from one wall to another.
Modifying Device Properties

You modify the properties of devices using the Properties palette. For general information about modifying object properties using the palette, see Modifying Object Properties Using the Properties Palette on page 91.

**NOTE** For information about moving devices, see Moving a Device or Panel on page 431.

**To modify device properties**

1. Select the devices:

<table>
<thead>
<tr>
<th>if you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>manually select the devices</td>
<td>in the drawing, select one or more devices individually, or select multiple devices at the same time by creating a window selection, crossing selection, or selection fence. For more information, see “Select Multiple Objects” in Autodesk® AutoCAD® Help.</td>
</tr>
</tbody>
</table>
If you want to... then...

select all of the devices on one or more circuits

- do the following:
  - Start Circuit Manager.
  - In the left pane, select the circuits, and in the right pane, click .
  - Press Esc twice.
  - Enter deviceprops, enter p (previous), and press Enter.

select all of the devices of a specific type

- While pressing Ctrl, press A to select all of the objects in the drawing. Then enter a modify command:
  - ReceptacleModify - Receptacles
  - LightingModify - Lights
  - SwitchModify - Switches
  - JunctionBoxModify - Junction Boxes
  - CommunicationModify - Communication
  - FireSafetyModify - Fire Safety
  - OtherPowerModify - Other power, i.e., motors
  - SecurityModify - Security

2 If you want to replace the selected devices with those of a different style, on the Properties palette, select a device style:

If you want to select a style... then...

in the current drawing

- expand Basic, expand General, and for Style, select the style.

in a drawing in the directory specified as the default content location for electrical devices

- on the General bar, click . In the left pane of the Select Device worksheet, navigate to the drawing that contains the style, and select the drawing. In the right pane, select the style.

**WARNING** Use caution when replacing devices after you have attached wires. If the replacement devices have different connection points than the original devices, the wires do not connect properly, and the circuit is broken. Additionally, if the replacement devices have default values for connector properties (for example, for Voltage or for Number of poles), you might need to modify the values.

3 On the Properties palette, modify other general properties as needed:

If you want to change... then...

the description

- for Description, click , enter a description, and click OK.

the layer on which the devices are placed

- for Layer, select a different layer. You can select from the layers in the current drawing.
4 Expand Location, and modify the location properties as needed:

<table>
<thead>
<tr>
<th>If you want to change...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>the rotation</td>
<td>for Rotation, enter a new angle.</td>
</tr>
</tbody>
</table>

**NOTE** You can also use Alignment grips to align the device perpendicular to other floor plan geometry, such as a wall.

the elevation

For Preset elevation, select a defined elevation, or for Elevation, enter an elevation. The difference in the elevation of the devices, the wires, and the panel for a circuit is used to calculate the circuit length. Note that the circuit length can only be calculated if the panel and all of the devices on the circuit are in the current drawing.

the insertion point or normal. (The normal is the extrusion direction that is used when elevation is applied to the model view.)

click Additional information. On the Location worksheet, enter the coordinates for the insertion point or normal, and click OK.

**NOTE** When possible, use Alignment grips to move a device. The grips move connected wires accordingly. Although using the Location worksheet does not break the connection between a device and connected wires, you might need to redraw the wires.

5 Expand Advanced, and modify the advanced properties as needed:

<table>
<thead>
<tr>
<th>If you want to change...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>the system</td>
<td>expand System, and for System, select the system.</td>
</tr>
</tbody>
</table>

**NOTE** The system assigned to the device determines its display properties. The system assigned to an electrical connector on the device determines the connections that can be made to the connector. For more information about connectors, see Configuring the Electrical Connectors of a Device on page 395.

the device ID, which is an optional number

expand Design Data, and for ID, enter a new ID.

the properties of an electrical connector

expand Circuits, and click Electrical Properties. On the Electrical Properties worksheet, modify the electrical connectors as explained in Modifying the Electrical Connectors of a Device on page 437, and click OK.

6 Press Esc.

**NOTE** Anytime you modify devices, you will need to update any existing panel schedules. See Updating Panel Schedules on page 459.
Modifying the Electrical Connectors of a Device

NOTE You should be familiar with Configuring the Electrical Connectors of a Device on page 395 before using the procedure described under this topic.

You modify the electrical connectors of a device using the Electrical Properties worksheet.

When modifying a connector, keep in mind the following:

■ If a circuit is specified for the connector, the System value is not editable. If the system type of the connector is Power and Lighting, then the values for Voltage and for Number of poles are also uneditable. This prevents changes that do not agree with the selected circuit. You can make these properties editable by selecting Unassigned for Circuit.

■ If a circuit is not specified for the connector, and a property is still not editable, this is because the device style does not allow the override of the value specified in the style. For information about allowing and preventing style overrides, see Configuring Connectors for Device Styles on page 368.

■ When you assign or change the circuit of a connector, or when you modify the load or load category of the connector, the affected circuits are updated accordingly and evaluated for overloads. In the circuiting preferences, you can specify whether the software warns you of the overloads, so you can decide whether to proceed or cancel the action. If you overload a circuit, you are not notified of the overload again within the drawing session.

When modifying the connectors on multiple selected devices, also keep in the mind the following:

■ If you overload a circuit when you are modifying devices assigned to different circuits, you are still notified of the overload as described above. However, you must use the Circuit Manager to identify the overloaded circuit.

■ If a property is not editable for at least one of the selected devices, it is read-only.
The electrical connectors on all the selected devices are listed by number. If a connector of a given number has a different system type for at least one of the devices, *VARIES* is shown for System Type, and only the properties in common are shown.

*VARIES* is also shown for any other property that does not have the same value for all of the selected devices.

Power and Lighting connectors only: *VARIES* is also shown for properties with values that are retrieved from different sources (for example, style override versus By Circuit). Additionally, when the value is By Circuit for all of the selected devices, *VARIES* is shown if the selected connector on all of the devices is not assigned to the same circuit. Refer to the following table for example scenarios.

<table>
<thead>
<tr>
<th>Value displayed in worksheet</th>
<th>Value for connector 1 on device 1</th>
<th>Value for connector 1 on device 2</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>VARIES</em></td>
<td>By Circuit [same value as for device 1]</td>
<td>By Circuit [same value as for device 1]</td>
</tr>
<tr>
<td>value is the style default</td>
<td></td>
<td></td>
</tr>
<tr>
<td>value is a style override</td>
<td></td>
<td></td>
</tr>
<tr>
<td>By Circuit</td>
<td></td>
<td></td>
</tr>
<tr>
<td>[value from assigned circuit]</td>
<td>By Circuit</td>
<td>By Circuit</td>
</tr>
<tr>
<td>[value from circuit 1]</td>
<td>By Circuit</td>
<td>By Circuit</td>
</tr>
<tr>
<td>[value from circuit 1]</td>
<td>By Circuit</td>
<td>By Circuit</td>
</tr>
</tbody>
</table>

To modify the electrical connectors of devices

1. Select the devices, and click Device tab ➤ Circuits panel ➤ Circuit Properties.
2. On the Electrical Properties worksheet, select a connector.

Optionally assign the connector to a circuit

3. If necessary, you can filter the list of available circuits by selecting a panel for Show circuits from panel, and by specifying values for the connector properties.
   The selections available for Circuit include the circuits in the current drawing, and, if specified for the current drawing, in the electrical project database that match the values you have specified for the connector properties, and that have a system type of General. If the system type of the selected connector on all of the devices is the same, the selections also include the circuits that have that system type (Power and Lighting, or Other). However, if the system type of the connector varies across the selected devices, the selections are limited according to their values.
   Beside each circuit name, the current load on the circuit is displayed. The load is the total load on the circuit across all applicable drawings, including the electrical project database.

4. For Circuit, do one of the following:
   - Select a circuit to assign the selected connector on all of the devices to it.
   - Select Unassigned to remove any circuit assignments from the devices.

NOTE Once a circuit is selected, the System value is not editable. If the system type of the connector is Power and Lighting, then the values for Voltage and for Number of poles are also uneditable. This prevents changes that do not agree with the selected circuit.
Specify the connector properties

5 Under Value, specify values for the connector properties.

For descriptions of each property, see Configuring the Electrical Connectors of a Device on page 395.

If you are using the electrical project database, and have more than one drawing open, you can reload the electrical project database in each open drawing. This updates the circuit information for each drawing. For example, if you modify a device load, or change the circuit assignment for the device, you can reload the electrical project database in other open drawings to reflect these changes.

Modifying Panel Properties

You modify the properties of panels using the Properties palette. For general information about modifying object properties using the palette, see Modifying Object Properties Using the Properties Palette on page 91.

NOTE For information about moving panels, see Moving a Device or Panel on page 431.

To modify panel properties

1 Select the panels.

2 If you want to replace the panels with those of a different style, on the Properties palette, select a panel style by doing one of the following:

<table>
<thead>
<tr>
<th>If you want to select a style…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>in the current drawing</td>
<td>on the Properties palette, expand Basic, expand General, and for Style, select the style.</td>
</tr>
<tr>
<td>in a drawing in the directory specified as the default content location for electrical panels</td>
<td>on the General bar, click . In the left pane of the Select Panel worksheet, navigate to the drawing that contains the style, and select the drawing. In the right pane, select the style.</td>
</tr>
</tbody>
</table>

3 Modify other general properties as needed:

<table>
<thead>
<tr>
<th>If you want to change…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>the description</td>
<td>for Description, click , enter a description, and click OK.</td>
</tr>
<tr>
<td>the layer on which the panels are placed</td>
<td>for Layer, select a different layer. You can select from the layers in the current drawing.</td>
</tr>
</tbody>
</table>

4 Expand Location, and modify the location properties as needed:

<table>
<thead>
<tr>
<th>If you want to change…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>the rotation</td>
<td>for Rotation, enter a new angle.</td>
</tr>
<tr>
<td></td>
<td>NOTE You can also use Alignment grips to align the panel perpendicular to other floor plan geometry, such as a wall.</td>
</tr>
<tr>
<td>the elevation</td>
<td>for Preset elevation, select a defined elevation, or for Elevation, enter an elevation. The difference in the elevation of the devices, the wires, and the panel for a circuit is used to calculate the circuit length.</td>
</tr>
</tbody>
</table>
If you want to change... then...

<table>
<thead>
<tr>
<th>the insertion point or normal. (The normal is the extrusion direction that is used when elevation is applied to the model view.)</th>
<th>Note that the circuit length can only be calculated if the panel and all of the devices on the circuit are in the current drawing.</th>
</tr>
</thead>
<tbody>
<tr>
<td>click Additional information. On the Location worksheet, enter the coordinates for the insertion point or normal, and click OK.</td>
<td>NOTE You can also use Alignment grips to move the panel.</td>
</tr>
<tr>
<td>the panel name</td>
<td>For Name, enter a unique name.</td>
</tr>
<tr>
<td>the panel rating</td>
<td>For Rating, enter a new rating.</td>
</tr>
<tr>
<td>the number of slots</td>
<td>For Slots, enter a new number.</td>
</tr>
<tr>
<td>the voltage</td>
<td>For Voltage, enter a new voltage.</td>
</tr>
<tr>
<td>the phase</td>
<td>For Phases, select 1 or 3.</td>
</tr>
</tbody>
</table>

**NOTE** The rating and voltage of a panel do not affect how the software functions. However, they are made available as automatic properties.

5 If necessary, expand Advanced, expand System, and for System, select a new system.

6 Expand Design Data, and modify the design data properties as needed:

<table>
<thead>
<tr>
<th>If you want to change...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>the panel name</td>
<td>For Name, enter a unique name.</td>
</tr>
<tr>
<td>the panel rating</td>
<td>For Rating, enter a new rating.</td>
</tr>
<tr>
<td>the number of slots</td>
<td>For Slots, enter a new number.</td>
</tr>
<tr>
<td>the voltage</td>
<td>For Voltage, enter a new voltage.</td>
</tr>
<tr>
<td>the phase</td>
<td>For Phases, select 1 or 3.</td>
</tr>
</tbody>
</table>

**NOTE** Do not assign more circuits to a panel than allowed for by the number of slots. If a panel has more circuits than slots, some of the circuits cannot be included in the panel schedule. When you create a schedule, the software warns you if this situation exists.

7 Press Esc.

**NOTE** Anytime you modify panels, you will need to update any existing panel schedules. See Updating Panel Schedules on page 459

If you are using this drawing as an electrical project database, and you modify properties for a panel whose circuits are used in linked drawings, you are prompted to open and save the affected drawings when you save the electrical project database.

**Modifying Wires**

After drawing or generating wires, you might need to make changes to the layout or to the wire properties.
Modifying Wire Layouts

You can modify the layout of wires by moving their vertices using Location grips. This can be helpful when you want to clean up the layout by moving the wires around walls, equipment, or other floor plan geometry.

To maintain the connectivity of a circuit, wires are anchored to devices. As a result, you cannot move the wires using the grips at their endpoints. Instead, when you move a device, the connected wires stretch accordingly.

To modify the layout of a wire

1. Select the wire.
2. Click the Location grip at a wire vertex.
3. Move the grip to a new location, and click to specify the point.
4. Press Esc.

Modifying Wire Properties

You modify the properties of wires using the Properties palette. For general information about modifying object properties using the palette, see Modifying Object Properties Using the Properties Palette on page 91.

NOTE For information about moving wires, see Modifying Wire Layouts on page 441.
To modify wire properties

1 Select the wires.

**NOTE** Before you can calculate wire sizes, you must add wire to the devices in the circuit. You must also set the type of conductor material for the wire style used, for example, copper or aluminium (for more information, see Configuring Styles for Wires on page 373).

2 On the Properties palette, expand Basic, and modify the basic properties as needed:

<table>
<thead>
<tr>
<th>If you want to change…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>the description</td>
<td>expand General. For Description, click ☑, enter a description, and click OK.</td>
</tr>
<tr>
<td>the layer on which the wires are placed</td>
<td>expand General, and for Layer, select a different layer. You can select from the layers in the current drawing.</td>
</tr>
<tr>
<td>the wire style</td>
<td>expand General, and for Style, select the style. You can select from the wire styles defined in the current drawing.</td>
</tr>
</tbody>
</table>
| the elevation           | expand Location, and do one of the following:  
  ■ For Preset elevation, select a defined elevation.  
  ■ For Elevation, enter an elevation.  
  The difference in the elevation of the devices, the wires, and the panel for a circuit is used to calculate the circuit length. Note that the circuit length can only be calculated if the panel and all of the devices on the circuit are in the current drawing. |

3 Expand Advanced, and modify the advanced properties as needed:

**IMPORTANT** To use the instant sizing tool to calculate the wire sizes, all of the selected wires must have:

■ An assigned circuit whose system type is Power and Lighting
■ The same wire style

<table>
<thead>
<tr>
<th>If you want to change…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>the system</td>
<td>expand System, and for System, select the system.</td>
</tr>
</tbody>
</table>
| the wire sizes         | expand Dimensions, and specify the wire sizes by doing one of the following:  
  ■ On the Dimensions bar, click ☑ to have the instant sizing tool calculate the sizes. The tool calculates the sizes based on the material and temperature rating of the corresponding wire style; the rating of the specified Power and Lighting circuit; and the ambient temperature specified in the drawing.  
  ■ Select or enter wire sizes for the hot, neutral, ground, and isolated ground wires.  
  The wires for which you need to specify sizes depend on the design specifications of the selected wire style. |

4 Press Esc.
TIP You can add labels to wires to indicate circuit assignments or wire styles. For more information, see Labels on page 559.

Moving Tick Marks on Wires

1 Select the wire.
2 Click the Location grip for the tick marks.
3 Move the grip to a new location along the wire, and click to specify the point.
4 Press Esc.

NOTE You specify whether to display tick marks on wire segments and home runs in the annotation properties of wire styles.

Flipping Tick Marks on Wires

1 Select the wire.
2 Click a Flip grip to flip the tick marks in the direction indicated by the arrow.
3 Press Esc.

NOTE You specify whether to display tick marks on wire segments and home runs in the annotation properties of wire styles.
Modifying Electrical Equipment

After you have finished the electrical system layout and checked the calculations for the final design, typically you verify the electrical equipment in the drawing and, if necessary, add or modify equipment. You might also need to do so during the design process due to changes in the requirements.

Changes to equipment might require changes to the associated circuit. For information about modifying circuits, see Modifying Circuits on page 429.

RELATED  See Mechanical, Electrical, and Plumbing Equipment in Building Systems on page 76.

To modify electrical equipment

1 Select the part to modify, click Equipment tab ➤ Modify panel ➤ Modify Equipment ➤.
2 In the Multi-view Part Modify dialog, modify the part:

If you want to change… then…
the part subtype select a different subtype in the part type folder. Then click Details to view the list of available part sizes, and optionally filter the list according to specify criteria on the Part Filter tab. For example, you can filter the list by connection type and size.

NOTE While you can change the part subtype, you cannot change the part type. To replace the part with one of a different type, erase the part and add a new one.

the size select a different size for Part Size Name.
the elevation select a defined elevation from the list or enter a value for Elevation.

Modifying Cable Trays and Conduits

Typically, cable tray and conduit runs are modified frequently during the design process due to architectural or structural changes, or modifications to the system requirements. For example, if the architect increases the overall size of the building, the cable tray layout needs to be modified to accommodate the new size. Cable tray sizes might increase, additional conduits might be added, or you might need to re-route the wiring for the new building size. You might also need to modify fittings, particularly when branches are resized or devices connected to conduit are changed.

Modifying cable tray segments and fittings

Modifying the Layout of a Cable Tray or Conduit Run

You can change the layout of a cable tray or conduit run using grips or AutoCAD® commands, such as MOVE or STRETCH.

To change the layout of a cable tray or conduit run

1 Select the segment that you want to change.
2 Do one of the following:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>move cable tray or conduit</td>
<td>Click Home tab ➤ Modify panel ➤ Move ➤ . Specify the distance and direction by specifying a base point and then a second point. You can also move the object by clicking the Location grip.</td>
</tr>
<tr>
<td>copy and paste cable tray or conduit</td>
<td>Click Cable Tray tab or Conduit tab ➤ General panel ➤ Add Selected ➤ . Specify the distance and direction by specifying a start point and then a second point.</td>
</tr>
</tbody>
</table>

For more information, see “Move Objects” or “Copy Objects” in AutoCAD Help.

**TIP** The quickest way to locate an AutoCAD topic referenced in AutoCAD MEP Help is to click the Search tab in the Help window, select the Search titles only option, copy and paste or enter the AutoCAD topic name, and then click List Topics.

## Changing the System of a Cable Tray or Conduit Run

Systems are defined to make it easier to comply with project standards in all drawings within a project. You can modify the system designation of individual connection points. For more information, see Working with Systems on page 93.

**To change the system of a cable tray or conduit run**

1. Select the segment you want to modify.
2. Click Cable Tray tab ➤ Modify panel ➤ Modify Cable Tray ➤ or click Conduit tab ➤ Modify panel ➤ Modify Conduit ➤ .
3. Select a different system for System, and click OK.

## Changing the Elevation of a Cable Tray or Conduit Run

1. Select the segment you want to modify.
2. Click Cable Tray tab ➤ Modify panel ➤ Modify Cable Tray ➤ or click Conduit tab ➤ Modify panel ➤ Modify Conduit ➤ .
3. Select a defined elevation or enter a new value for Elevation, and click OK.

**NOTE** Your cable tray or conduit changes when you change the elevation of one or more segments. You might need to draw a transition or connecting cable tray or conduit in order to reconnect the run.

4. Check your cable tray or conduit run to find out if you need to add more segments or change the elevation of other segments in order to reconnect the run.
5. You can connect segments by adding transitions or bends and additional cable tray or conduit segments.

Modifying Cable Trays and Conduits | 445
Modifying the Size of a Cable Tray or Conduit Run

Use this procedure to change the size of a cable tray or conduit run. You can change one segment at a time or you can resize the entire run. When changing a single segment, you need to add a transition in order to adjust it to the rest of the run.

**To modify the size of a cable tray or conduit run**

1. Select the segment you want to modify.
2. Click Cable Tray tab ➤ Modify panel ➤ Modify Cable Tray or click Conduit tab ➤ Modify panel ➤ Modify Conduit.
3. Specify new size values for the width and height of the cable tray, or specify a new diameter for conduit.
4. Click OK.
5. In the Maintain Connection dialog, specify a method for maintaining a valid connection between the segment and the rest of the run:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then select…</th>
</tr>
</thead>
<tbody>
<tr>
<td>modify the entire run to match the parameters of the selected segment</td>
<td>Modify to next junction/transition.</td>
</tr>
<tr>
<td>insert a transition fitting to connect the cable tray or conduit without changing the entire run</td>
<td>Modify to maintain connection to next part.</td>
</tr>
</tbody>
</table>

If you have chosen to modify an entire run that is connected to another run, the junction fitting that connects the 2 runs is replaced. The software inserts an appropriate transition fitting in its place to maintain a valid connection at that junction.

Modifying the Length of Cable Tray or Conduit Segments

You can modify the length of cable tray and conduit segments using Lengthen grips ( ). Because the grips constrain a segment to its current angle, they are particularly useful for modifying the lengths of runs you have already placed.

When you use the Lengthen grip on an end connected to another object, you must specify whether you want AutoCAD MEP to maintain connectivity between the objects when you modify the length.
Cable tray segments with activated grips

To modify the length of a cable tray or conduit segment

1 Select the segment.
2 Select the Lengthen grip on the end you want to modify.
3 If the segment is connected to an object on the end you selected, specify whether and how to maintain connectivity:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>maintain connectivity by adjusting only fittings and segments, and retain the current locations of parts</td>
<td>proceed to the next step.</td>
</tr>
<tr>
<td>maintain connectivity by adjusting all objects, including parts</td>
<td>press Ctrl.</td>
</tr>
<tr>
<td>break connectivity</td>
<td>press Ctrl twice.</td>
</tr>
</tbody>
</table>

4 Specify the segment length:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>specify the new total length</td>
<td>press Tab to activate the input field for specifying the resulting dimension, and enter the new length. Press Enter.</td>
</tr>
<tr>
<td>specify the difference between the current length and new length</td>
<td>Drag the cursor to begin lengthening or shortening the segment, and enter the change in length in the input field that is active by default. Press Enter.</td>
</tr>
<tr>
<td>specify a new endpoint</td>
<td>drag the grip to the endpoint, and click to specify the point.</td>
</tr>
</tbody>
</table>

**NOTE** To use the dimension input fields, both dynamic input (on the application status bar) and the Dimension Input drafting setting must be enabled. They are enabled by default. If you have disabled them, you can specify the new length by selecting a stretch point in the drawing or entering one in the Command window.
The following example illustrates how to modify the length of a conduit segment. A horizontal conduit segment is stretched to the right. Because the modification occurs in the moveable MvParts editing mode, connected objects including parts are adjusted to maintain their connectivity. More specifically, the vertical conduit, connected fittings, and the transformer are moved.

**Lengthening conduit**

1. Select the segment.
2. Select the Lengthen grip, then select the editing mode.
3. Enter the new length.
4. Specify the new value.

Result:
NOTE If the cable tray or conduit segment is not connected to another object, you can change both its length and angle using the Start or End grip.

Start and End grips enable you to change the XYZ location of the start point or endpoint of a segment. They are particularly useful when initially designing runs because you can use them to easily connect a segment to an existing run.

---

**Breaking and Merging Cable Tray or Conduit Segments**

After you have drafted cable tray or conduit runs, you can break an individual segment, break an entire run, or merge multiple segments. This can be helpful for determining the number of individual segments a manufacturer needs to supply.

When merging segments, you cannot cross fittings to join segments.

**Breaking a conduit into segments**

1. Select the cable tray or conduit, click Cable Tray tab ➤ Modify panel ➤ Cable Tray Length , or click Conduit tab ➤ Modify panel ➤ Conduit Length .

2. Specify how you want to break or merge the cable tray or conduit:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>apply the length to the entire run</td>
<td>select Apply to Cable Tray Run or Apply to Conduit Run.</td>
</tr>
<tr>
<td>specify a new segment length</td>
<td>select Break.</td>
</tr>
<tr>
<td>merge segments</td>
<td>select Merge.</td>
</tr>
<tr>
<td>select a cable tray or conduit</td>
<td>click the Select Objects icon, and select specific segments.</td>
</tr>
</tbody>
</table>
If you want to... then...
change the length

enter or select a new length for each cut length. The 10 last-used lengths are stored as defined segment lengths. You can also specify the length by specifying points in the drawing.

If you have selected to break segments, the software breaks the selected segment or run into multiple segments of the specified length. If the segment cannot be broken evenly by the specified length, the last broken segment might be shorter.

**Modifying a Cable Tray or Conduit Fitting**

1. Select the fitting, click Cable Tray Fitting tab ➤ Modify panel ➤ Modify Fitting ➡️, or click Conduit Fitting tab ➤ Modify panel ➤ Modify Fitting ➡️.
2. Select Display/Hide additional part parameters to display or hide more information in this dialog.
3. Click Details to view the sizes available for the selected part subtype.
4. Modify the fitting:

<table>
<thead>
<tr>
<th>If you want to modify...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>the part subtype</td>
<td>select a different subtype in the part type folder.</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE</strong> While you can change the part subtype, you cannot change the part type, for example, replace an elbow with a tee. To replace the part with one of a different type, erase the part and add a new one.</td>
</tr>
<tr>
<td>parameters, such as connection size or type</td>
<td>click the Part Filter tab, and specify the parameters you want to filter the list of available part sizes accordingly. Then select the part you want for Part Size Name.</td>
</tr>
<tr>
<td>the size</td>
<td>select a size for Part Size Name. click the Details button to expand the list of parts that match the parameters you specified, and then select a part from the Part Size Name list.</td>
</tr>
</tbody>
</table>

**Rotating Cable Tray or Conduit Fittings**

You can use arrow-shaped (🔄) Rotate grips to rotate cable tray and conduit fittings 180 or 90 degrees in the direction indicated by the grip.
Rotating a cable tray fitting 180 degrees in plan view

In isometric views, you can also use diamond-shaped ( ) Rotate grips to rotate conduit fittings around the centerline to any angle.

A conduit tee fitting in an isometric view

AutoCAD MEP displays Rotate grips on cable tray and conduit fittings with connectors on opposite ends. However, when necessary to preserve the connectivity of runs, the software limits the available rotation options or hides the grips. For example, in the following illustration, you can rotate the unconnected conduit fitting on the left in several ways, but you cannot rotate the conduit fitting on the right due to the connected conduit segments.

A conduit fitting with Rotate grips and another without them

When you rotate a fitting that is connected to other objects, the software adjusts the connected objects to maintain their connectivity. For example, the software might make minor adjustments to the lengths of connected segments after you have flipped a fitting. If it cannot adjust the objects, it disconnects them.

To rotate a cable tray or conduit fitting

1. Select the fitting.
2 Rotate the fitting:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>rotate the fitting 180 degrees (flip the fitting)</td>
<td>click the Rotate grip ( ).</td>
</tr>
<tr>
<td>rotate the fitting 90 degrees</td>
<td>while pressing Ctrl, click the Rotate grip ( ).</td>
</tr>
<tr>
<td>rotate the fitting to an angle you specify</td>
<td>click the Rotate grip ( ), and do one of the following:</td>
</tr>
<tr>
<td>■ enter the new absolute angle in the active dimension input field.</td>
<td></td>
</tr>
<tr>
<td>■ drag the cursor to reduce or increase the angle, click Tab to activate the dimension input field for specifying the angle change, and enter the value.</td>
<td></td>
</tr>
<tr>
<td>■ drag the grip to a new location.</td>
<td></td>
</tr>
<tr>
<td>■ enter a value for Rotation on the Location tab of Fitting Properties</td>
<td></td>
</tr>
<tr>
<td>■ enter the value in the command window.</td>
<td></td>
</tr>
</tbody>
</table>

### Annotating Electrical System Drawings

The topics in this section describe how to create and modify panel schedules for your electrical drawings. For information about annotating the drawings using other elements, such as labels, tags, and documentation symbols, see Creating Construction Documents on page 547.

### Adding Labels to Wire, Conduit, and Cable Tray

You can manually add labels to wires, conduits, and cable trays. For more information, see Labels on page 559. You can also configure layout preferences to add labels automatically to cable tray and conduit as you draw them. For more information, see Specifying Annotation for Cable Tray or Conduit on page 379.
About Panel Schedules

In AutoCAD MEP, you use the default panel schedule table styles to create the following types of panel schedules:

■ Sample 1-phase branch circuit panel schedule

<table>
<thead>
<tr>
<th>PANEL</th>
<th>LP1</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

■ Sample 3-phase branch circuit panel schedule

<table>
<thead>
<tr>
<th>PANEL</th>
<th>LP1</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Sample switchboard panel schedule

<table>
<thead>
<tr>
<th>SWITCHBOARD LP2</th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>EVE, MTH, YR</strong></td>
<td><strong>SWITCH NAME</strong></td>
<td><strong>DESCRIPTION</strong></td>
<td><strong>AMPERES (AMP)</strong></td>
<td><strong>VOLTAGE (V)</strong></td>
</tr>
<tr>
<td>1, 1-5</td>
<td>12/5</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>2-44</td>
<td>12/5</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>2-6-3</td>
<td>20/3</td>
<td>SHED</td>
<td>10</td>
<td>230V</td>
</tr>
<tr>
<td>4-19</td>
<td>20/3</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>15</td>
<td>12/5</td>
<td>SHED</td>
<td>100</td>
<td>230V</td>
</tr>
<tr>
<td>12</td>
<td>20/1</td>
<td>SHED</td>
<td>410</td>
<td>230V</td>
</tr>
<tr>
<td>10</td>
<td>20/1</td>
<td>SHED</td>
<td>110</td>
<td>230V</td>
</tr>
<tr>
<td>14</td>
<td>20/1</td>
<td>SHED</td>
<td>100</td>
<td>230V</td>
</tr>
<tr>
<td>10</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>16</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>17</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>18</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>20</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>21</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>22</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>23</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>24</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>25</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>26</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>27</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>28</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>29</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>30</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>31</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>32</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>33</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>34</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>35</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>36</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>37</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>38</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>39</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>40</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>41</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
<tr>
<td>42</td>
<td>20/1</td>
<td>SHED</td>
<td>0</td>
<td>230V</td>
</tr>
</tbody>
</table>

### Sample distribution panel schedule

<table>
<thead>
<tr>
<th>DISTRIBUTION BOARD DP1</th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>CIRCUIT NUM.</strong></td>
<td><strong>3 W 2 W</strong></td>
<td><strong>SERVICE PANEL</strong></td>
<td><strong>GENERAL LOAD (KW)</strong></td>
<td><strong>TOTAL GENERAL LOAD (KW)</strong></td>
</tr>
<tr>
<td>1, 2, 5</td>
<td>220/1</td>
<td>220/1</td>
<td>1.00</td>
<td>2.00</td>
</tr>
<tr>
<td>3-24</td>
<td>220/1</td>
<td>220/1</td>
<td>1.00</td>
<td>2.00</td>
</tr>
<tr>
<td>25-50</td>
<td>220/1</td>
<td>220/1</td>
<td>1.00</td>
<td>2.00</td>
</tr>
<tr>
<td>51-75</td>
<td>220/1</td>
<td>220/1</td>
<td>1.00</td>
<td>2.00</td>
</tr>
<tr>
<td>76-100</td>
<td>220/1</td>
<td>220/1</td>
<td>1.00</td>
<td>2.00</td>
</tr>
<tr>
<td>101-125</td>
<td>220/1</td>
<td>220/1</td>
<td>1.00</td>
<td>2.00</td>
</tr>
<tr>
<td>126-150</td>
<td>220/1</td>
<td>220/1</td>
<td>1.00</td>
<td>2.00</td>
</tr>
<tr>
<td>151-175</td>
<td>220/1</td>
<td>220/1</td>
<td>1.00</td>
<td>2.00</td>
</tr>
<tr>
<td>176-200</td>
<td>220/1</td>
<td>220/1</td>
<td>1.00</td>
<td>2.00</td>
</tr>
<tr>
<td>201-225</td>
<td>220/1</td>
<td>220/1</td>
<td>1.00</td>
<td>2.00</td>
</tr>
<tr>
<td>226-250</td>
<td>220/1</td>
<td>220/1</td>
<td>1.00</td>
<td>2.00</td>
</tr>
<tr>
<td>251-275</td>
<td>220/1</td>
<td>220/1</td>
<td>1.00</td>
<td>2.00</td>
</tr>
<tr>
<td>276-300</td>
<td>220/1</td>
<td>220/1</td>
<td>1.00</td>
<td>2.00</td>
</tr>
<tr>
<td>301-325</td>
<td>220/1</td>
<td>220/1</td>
<td>1.00</td>
<td>2.00</td>
</tr>
</tbody>
</table>

**Table: Sample distribution panel schedule**

**Legend:**
- **AMP:** Amperes
- **V:** Volts
- **KW:** Kilowatts
- **KVAR:** KiloVARs
- **KVA:** KiloVArs

**Graph:**
- **3 W 2 W:** Three-Wire Two-Wire
- **220/1:** 220 Volts Single Phase
- **GENERAL LOAD (KW):** General Load in Kilowatts
- **TOTAL GENERAL LOAD (KW):** Total General Load in Kilowatts

**Notes:**
- The schedule is designed for a specific electrical system configuration.
- The load distribution is based on typical residential or commercial settings.
- The data is provided for planning purposes and may require adjustments based on specific requirements.

---

**Chapter 9: Drawing Electrical Systems**

454
Typically, you would add a panel schedule to a panel schedule sheet that does not contain any panels. But for a smaller project you might add a panel schedule to a drawing that contains one or more panels. You can customize a schedule to define the panel, circuit, wire, and load data that it contains, and how it is organized.

Generating Panel Schedules

You can generate panel schedules for a single drawing, or for circuits that span multiple drawings. Once generated, you can continue to add devices to circuits, or even new circuits and panels.

When you make changes to your drawings that affect the information in a panel schedule, the panel schedule will need updating. Such changes include:

- Adding and deleting circuits
- Deleting a panel
- Linking or unlinking panels
- Attaching or detaching devices to/from a circuit
- Changing the number of load categories used by the panel
- Changing the phase load of a device
- Changing circuit properties, such as rating or description
- Changing panel properties, such as panel name, rating, or wires
Any change to a panel, circuit, or device that makes a panel schedule’s data invalid is noted by a line drawn through that panel schedule. When a schedule becomes out of date, you must update it. You can ensure that the panel data is accurate by executing either a REGEN command, when loads increase/decrease, or an Update Panel Schedule command when you need to add or remove schedule entries. You can select the schedule, right-click, and select Update Panel Schedule from the context menu. Actions that can make a panel schedule out of date include:

- Adding or deleting circuits
- Linking or unlinking panels
- Changing load categories
- Reloading an updated electrical project database
- An externally referenced file uses an electrical project database that is older than the one referenced in the current drawing

To generate a panel schedule for a panel that does not reside in the current drawing, you must specify an electrical project database (if one has not already been set) on the Electrical Project Database tab of the Electrical Preferences dialog.

To generate a panel schedule on a separate sheet

1. Create a new general view drawing, and open it.
2. Click Manage tab ➤ Preferences panel ➤ Electrical ➤ .
3. In the Electrical Preferences dialog, click the Electrical Project Database tab.
4. For Project Database, specify the electrical project database file.
5 In the Electrical tool palettes set, click the Tag and Schedule palette.

6 Click a panel schedule tool.

**NOTE** Alternatively, you can select a panel in the drawing, and click Panel tab ➤ Circuits panel ➤ Panel Schedule.

7 In the Panel Schedule dialog, for Panel, specify the panel for which you want to create the schedule.

The panels available in the drop-down list are assigned to the electrical project database.

8 Select a panel schedule table style.

9 For Show panels from, select Electrical project database, and click OK.

10 Repeat the previous steps as necessary to create additional panel schedules for the same sheet.

To generate a panel schedule in the current drawing, you can use the Panel Schedule tool on the Electrical tool palette. You can also create a panel schedule using the Circuit Manager.
To generate a panel schedule in the current drawing using the Circuit Manager

1 Click Analyze tab ➤ Electrical panel ➤ Circuit Manager.

**NOTE** Alternatively, you can select a panel and click Panel tab ➤ Circuits panel ➤ Circuit Manager.

2 Select the name of a panel in the left pane of the Circuit Manager, right-click, and click Insert Panel Schedule.

3 In the Panel Schedule dialog, for Panel schedule table style, select a style.

4 Click OK.

5 Click in the current drawing to place the panel schedule.
Updating Panel Schedules

Update panel schedules when panels, connected circuits, or devices change. For example, if you add light fixtures to an electrical drawing and connect them to a circuit on a panel, the values in the panel schedule do not update automatically. You must update the panel schedule to reflect the changes to the circuit.

- To update all panel schedules in the drawing, click View tab ➤ Appearance panel ➤ Regenerate drop-down ➤ Regenerate, or enter re (for REGEN) at the command line.
- To update a selected panel, right-click, and select Update Panel Schedule.

Exporting a Panel Schedule to Excel

Easily manage a panel schedule by exporting it to a Microsoft® Excel spreadsheet. After it is in Excel, you can modify, remove, and add tables, cells, and values.

NOTE The panel schedule in AutoCAD MEP and the exported panel schedule, in Excel, are not linked, so changing a value in one location will not update the value in the other location.

To export a panel schedule to Excel

1. Select the panel schedule you want to export, right-click, and click Export.
2. In the Export Data dialog, enter a filename and click Save.
The exported panel schedule data is saved as a text file with a .csv file extension. Open the file in Excel and work with the data as needed.

Creating Panel Schedule Table Styles

Create your own custom panel schedule table style to match the layout of your company’s standard panel schedule. First, create the custom table, and then create the panel schedule table style from the table. When creating the custom table, insert placeholder field codes where the panel and circuit data would display. When the custom panel schedule table style is used to generate a panel schedule, the field codes are replaced with the panel and circuit values from the Circuit Manager. For more information about creating schedule table styles see “Create and Modify Tables” in the AutoCAD Help.

The following field codes are available specifically for use in panel schedule tables:

<table>
<thead>
<tr>
<th>Panel Field Names</th>
<th>Panel Field Names</th>
<th>Circuit Field Names</th>
</tr>
</thead>
<tbody>
<tr>
<td>Panel Name</td>
<td>Panel Notes</td>
<td>Circuit Name</td>
</tr>
<tr>
<td>Panel Rating</td>
<td>Panel Load Category Name</td>
<td>Circuit Description</td>
</tr>
</tbody>
</table>
Creating Electrical System Construction Documents

You can annotate electrical drawings with labels, tags, and schedules. Additionally, you can create construction documents that include cross-sectional views and details. For more information, see Creating Construction Documents on page 547.

TIP For hands-on practice at creating construction documents, complete the electrical tutorial provided with the software.
This section provides an overview of a typical workflow using AutoCAD MEP to design a plumbing system, describes the major components in a plumbing system, and provides step-by-step procedures for performing drawing tasks.

**Plumbing Design Workflow**

A typical workflow using AutoCAD MEP to design a plumbing system includes the following steps:

1. **Configure system settings**
2. **Set up a project**
3. **Set up a pipe sizing table**
4. **Open a drawing and attach architectural plan**

**View more information**

- Control the form and function of objects in your drawings by specifying design preferences. See [Drawing Preferences on page 69](#) and [Configuring Plumbing System Definitions on page 477](#).
- Specify standards (for example, the templates and tool catalogs to use), and integrate the plumbing system plans with the architectural plans. See [Working with Projects on page 129](#).
- Specify the fixture unit table and plumbing line sizing table (pipe sizing table). See [Configuring Fixture Unit Tables on page 479](#) and [Specifying Plumbing Line Sizing Tables on page 480](#).
- Use Project Navigator and attach an architectural floor plan as an external reference. See [Working with Referenced Drawings on page 158](#).
**Plumbing Systems Overview**

AutoCAD MEP includes many features you can use to create, modify, and plot plumbing system designs. The topics in this section provide general information on plumbing features.

**Plumbing Runs and Lines**

After you place the equipment and fixtures in the drawing, you can create a plumbing run. A plumbing run is a set of plumbing lines, consisting of individually drawn segments, that carry gas or fluid from one point to another. A network is the set of interconnected plumbing runs within a system, such as those that carry waste water from the connected toilets, sinks, and showers to the main drain line.
Before you draw a plumbing run, you specify a system for the segment on the plumbing line Properties palette. As you draw the run, the software inserts plumbing fittings based on the default fittings configured for that system definition. However, when necessary, you can override the default fittings for an individual run or manually add an individual fitting. For information on specifying default fittings, see Specifying the Default Fittings for a Plumbing System Definition on page 478.

Plumbing lines are 2-dimensional (2D) and can be system-based and style-based. For this reason, before you add plumbing lines to a drawing, you should define the plumbing systems, plumbing line styles, and plumbing fitting styles.

The plumbing line system determines the system type (i.e., Cold Water, Waste, or Fire Protection), the fittings that the software inserts when necessary, and other properties. Systems help maintain consistency throughout a run and across multiple drawings in a project. Once you define the plumbing systems, you select a system on the Properties palette as you draw plumbing runs. For more information, see Configuring Plumbing System Definitions on page 477.

The plumbing line style determines the appearance and function, such as the available standard sizes and how crossing plumbing lines display in plan view. You can create plumbing line styles based on information such as the size, type, and gauge of the material (i.e., Schedule 40 Carbon Steel or Copper Tube). As with systems, once you define the styles, you can select a style on the Properties palette as you draw plumbing runs.

**Plumbing System Definitions**

A plumbing system definition is typically named for the plumbing system for which it will be used, such as domestic hot water or sanitary sewer. The settings for a system definition control many of the display properties of a plumbing system. For example, a layer key style is assigned to a plumbing system definition, which dictates the layer, color, and linetype for the plumbing system.

In the software, plumbing runs that have different systems cannot connect to each other without changing the system for the connecting run. The exception is when the 2 system definitions comprise the same system group. System groups allow different systems to connect to each other.

**Plumbing Fittings**

As you specify systems for equipment, fixtures, and plumbing line segments, AutoCAD MEP inserts plumbing fittings based on those specified in the system definition. Therefore, you should specify default fittings for the plumbing system definitions to use on a project. You can specify default fittings for 4 types of fittings: elbows, tees, crosses, and transitions. For example, you can specify that the software place a base tee in the drawing rather than a straight tee. For information on specifying default fittings, see Specifying the Default Fittings for a Plumbing System Definition on page 478.
NOTE When a fitting is required but it cannot fit the layout, plumbing lines are inserted. For example, the next illustration shows 2 instances where elbows could not be inserted, and so the software inserted plumbing lines instead.

In designs that require unique fittings (common to piping or plumbing), you can **override the default fittings** or you can **add a fitting manually**.

You can create plumbing fitting styles based on information such as type (i.e., tee, cross, trap, or check valve) and subtype (i.e., 45-degree mitered, 90 degree long-radiused, or 3-way). The style determines the appearance and function of the plumbing fitting. Styles provided with the software include Cross and Sanitary Tee.

While you can manually create elbow fitting styles, the software automatically creates them as you design your layout. The software inserts elbows and then adds corresponding elbow styles to the drawing as needed. The type of elbow you specify as the default for the plumbing system, in conjunction with the angle of the elbow that is added to the layout, determines the name of the elbow style (for example 60 Degree Standard Radiused Elbow).

**Associative Movement**

You can move MvParts, fittings, or plumbing segments without breaking their connections with the rest of the system. Used in conjunction with certain grips, the associative movement feature enables you to move a plumbing run component quickly and accurately.

For example, when you move an MvPart to a new location, the plumbing segments attached to the MvPart can move, shrink, or stretch to maintain a connection with the system. You can also move a plumbing segment without affecting the location of MvParts or other portions of the run.

**Movement of a Plumbing Line Segment**

The following example shows a plumbing line that is moved. The fittings connected with the plumbing line move with it. However, all other components in the run remain fixed in their original position.
Location grip on plumbing line objected selected

New location specified

Resulting layout

Notice how the elbows connected to the plumbing line moved with it and the plumbing lines connected to the elbows changed length. The system is still connected.

**Movement of an MvPart**

The following example shows a toilet that is moved. The plumbing lines and fittings move with it. However, all other components in the run remain fixed in their original position.
Location grip on the MvPart selected

New location specified

Resulting layout
Plumbing Grips

Grips offer a quick way to add or modify plumbing objects or MvParts. The applicable grips become visible when you select an object in a drawing.

Grips for Adding to a Plumbing Run

Using add grips provides an efficient way to quickly begin drawing a plumbing line. It ensures connectivity between the object and plumbing line.

- **Add grips on a plumbing line segment**

![Add grips on a plumbing line segment](image)

- **Add grips on a plumbing fitting**

![Add grips on a plumbing fitting](image)

- **Add grips on an MvPart (a sink)**

![Add grips on an MvPart (a sink)](image)

Some fittings also contain add grips that enable you to create a new branch directly from the fitting. For example, an elbow has add grips you can use to automatically convert the elbow to a tee, from which you can then draw a plumbing line. The existing plumbing branches remain connected to the other 2 tee connections.
Grips for Modifying a Plumbing Run

Plumbing runs are typically modified throughout the design process due to architectural or structural modifications to the system requirements. For example, if the architect increases the size of a room, the corresponding plumbing system supplying that room needs to be modified. You might need to lengthen the plumbing lines, add fixtures, or reroute the plumbing lines for the room.

Several grips are available in AutoCAD MEP to modify components in a plumbing system.

Location Grips

You can move a plumbing component in the current XY plane using a location grip. Location grips appear on parts at their insertion points and connector points.
If the plumbing line segment is not connected to another object, you can change both its length and angle using the Start grip or End grip.

The Start and End grips enable you to change the XY location of the start point or end point of the segment. This is useful when you are initially designing runs because you can easily connect a segment to an existing run.

If the part or plumbing line segment is connected to other objects, you must specify whether you want to maintain their connectivity when you move the part.

**Rotate Grips**

You can use the Rotate grip to rotate plumbing in-line parts, fittings, and takeoffs 180 or 90 degrees in the direction indicated by the grip.
Rotating a 3-way valve 90 degrees in plan view

AutoCAD MEP displays Rotate grips on the plumbing line in-line parts, fittings, and takeoffs with connectors on opposite ends. However, when necessary to preserve the connectivity of plumbing runs, the software limits the available rotation options or hides the grips.

When you rotate a part, fitting, or takeoff that is connected to other objects, the software adjusts the connected objects to maintain their connectivity. For example, the software might make minor adjustments to the lengths of connected plumbing line segments after you have flipped a fitting. If it cannot adjust the objects, it disconnects them.

The rotate grip turns a part 180 degrees. The flip grip orients a part (in-line or anchored MvParts, fittings, or takeoffs) for flow direction.

Lengthen Grips

You can modify the length of plumbing line segments using lengthen grips. Because the grips constrain a segment to its current angle, they are particularly useful for modifying the length of plumbing line segments you have already placed.

When you use the lengthen grip on an end that is connected to another object, you must specify whether you want AutoCAD MEP to maintain connectivity between the objects.
The following example illustrates how a plumbing line segment in a vent system is lengthened. To avoid interference with a duct system, the software adjusts connected objects to maintain their connectivity.
Chapter 10  Drawing Plumbing Systems

Plumbing line segment selected

Lengthen grip selected

New length specified

Resulting layout
**Rise/Run Angles and Slope**

In a plumbing drainage system, you need a minimum slope at all times. To define the slope, you enter the rise and run values on the Properties palette as you draw the plumbing line, and the software calculates the slope. The software also calculates the rise and run values if you instead enter a slope percentage.

As you draw plumbing lines with a defined slope percentage, the software displays a slope glyph that indicates the direction of the slope and whether the slope angles is in an up or down direction.

**Viewing the slope glyph**

The elevation reflects the rise value. When you end a segment, the Properties palette reflects the elevation value. As you continue to add segments, the elevation updates to reflect the elevation of the last-drawn segment.

**Fixture Units**

You access fixture unit information on the Fixture Units tab of the Multi-view Part Properties dialog.

You can specify the fixture unit table to size the following:

- Plumbing line
- Type of fixture
- Type of occupancy (whether intended for public or private use)

You can also view connector information for each connection point on the fixture.

**Calculations**

In plumbing system drawings, you can access information about plumbing line sizing calculations for fixtures (MvParts) on the Calculations tab in the Multi-view Part Properties dialog, accessed by clicking a fixture, then clicking Equipment tab ➤ Modify panel ➤ Equipment Properties 🎯.

The values on this tab only appear if you have sized the corresponding plumbing line. Because they are read-only, the values cannot be changed. You can view the flow rate and pressure properties for each connector of the fixture along with the minimum and the calculated values. The minimum flow rate and pressure values are required to adequately supply water to the fixture. The calculated flow rate and pressure values are the actual values calculated by the plumbing line sizing commands based on the design layout in the drawing. You can also view the system type of each connector.

**Plumbing Line Sizing Tables**

The plumbing line sizing feature relies on 2 types of plumbing line sizing tables (also referred to as pipe sizing tables) when performing sizing calculations:

- Supply plumbing line sizing tables specify the equivalent plumbing line length values for fittings and valves.
Sanitary plumbing line sizing tables specify the maximum permissible fixture unit loads for different types of sanitary runs (stacks, branches, and offsets).

The proper reference and use of plumbing line sizing tables are essential to accurate plumbing line sizing. If you plan to do sizing, you should first identify the plumbing line sizing tables to use and verify their accuracy.

AutoCAD MEP includes sample sizing tables for supply lines and for sanitary lines, based on industry standards. However, you or your CAD manager can create your own sizing tables that meet your project requirements and conform to applicable codes. You can use the sample tables as guides for creating your own tables. For more information, see Specifying Plumbing Line Sizing Tables on page 480.

Design Values for Supply Plumbing Line Sizing

The Design Values section of the Size Supply Plumbing Line dialog lets you define the design parameter values of the supply run. Before you enter values, you need to know the source of the water and the pounds per square inch of pressure being produced. You also need to know the pressure requirement for the fixture located at the highest elevation in the building model.

Plumbing Line Sizing Table

Select the supply plumbing line sizing table (pipe sizing table) that you created based on applicable codes, such as the Uniform Plumbing Code. To verify the values in the table definition, open it by clicking the Plumbing Line Sizing Table icon, and then click the Equivalent Plumbing Line Lengths tab.

The plumbing module reads the values of the valves and fittings in your drawing and verifies that they are correct for the length of supply line in the run.

Restrict Velocity

Selecting Restrict Velocity prevents a plumbing line size with a flow velocity that exceeds the value that you enter. The restricted velocity should be the maximum velocity that you want in the run. This can avoid issues such as water hammer. The default restrict velocity value is 10 ft./s.

Pressure at Source

Pressure at Source defines the amount of water pressure coming into the building. For example, the pressure at the source of the building could be from a booster pump. The default value is 60 psi.

Pressure at Highest Fixture

Pressure-Highest Fixture defines the minimum amount of pressure to be supplied to the highest-level fixture in the supply run to ensure adequate flow. For example, a third-floor toilet fixture at an elevation of 35 feet might require 15 psi in order to flush. The default value is 15 psi.
Friction Loss—Water Meter

If a water meter is included in your design, then you should account for the total friction loss of the water meter. A water meter is considered part of the water utility. Typically it is not a part of the building. Often it is not included in the design. Therefore, the default value is 0 psi.

Hazen-Williams C-factor

The C-factor determines the friction loss of the run using the Hazen-Williams formula. The factor “C” is known as the “Hazen-Williams C” or “friction loss coefficient C.” The C-factor relates the relative roughness of the interior wall of the pipe and varies between different types of pipe. The C-factor is typically 100 for steel pipe and 130 for brass and copper. The default value used in sizing supply plumbing lines is 100.

Customizing Plumbing Content

Typically, CAD managers and other users create plumbing content. AutoCAD MEP provides 2 types of plumbing content:

- **Style-based content** refers to 2D objects that are defined by styles. Styles are sets of properties and associated view blocks. In plumbing drawings, style-based content includes plumbing lines, plumbing fittings, and schematic objects for schematic diagrams.

- **Catalog-based content** refers to 3D objects that are defined by part definitions and associated part models, and are grouped into part catalogs. In plumbing drawings, catalog-based content includes plumbing equipment (called multi-view parts, MvParts, or parts) and plumbing fixtures. You specify systems (a type of style) for catalog-based content. A system stores properties that all building system objects assigned to the system can share. This gives a consistent look and feel to the systems in a drawing. See Working with Style-Based Content on page 85 and Working with Catalog-Based Content on page 79 for more information on content types.

Creating Style-Based Content

Style Manager lets you create style-based content on page 599 that defines plumbing lines, plumbing fittings, and schematic objects. You convert batches of existing objects to schematic symbol styles in the following ways:

- Convert the schematic symbol styles provided with AutoCAD MEP to their individual components (the settings and the view blocks), customize the components, and then convert the components back to schematic symbol styles

- Convert a batch of AutoCAD blocks in a custom block library to schematic symbol styles

Creating Catalog-Based Content

You can create 2 types of catalog parts, parametric and block-based, using Content Builder. Content Builder is a content creation tool that includes 3D modeling and 2D drawing features. For more information, see Building Parametric Fittings Using Content Builder on page 650 and Creating Block-Based Parts Using Content Builder on page 754.

Configuring Plumbing System Definitions

This section explains how to configure properties that control the appearance and behavior of objects in your plumbing system designs.
Creating a Plumbing System Definition

1 In the Plumbing workspace, click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Plumbing System Definitions.

2 Create the plumbing system definition using the left pane of Style Manager:

<table>
<thead>
<tr>
<th>To</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a new system definition</td>
<td>1 Right-click Plumbing System Definitions, and click New.</td>
</tr>
<tr>
<td></td>
<td>2 Enter a name, and press ENTER.</td>
</tr>
<tr>
<td>copy an existing definition</td>
<td>1 Right-click an existing system definition, and click Copy.</td>
</tr>
<tr>
<td></td>
<td>2 Right-click Plumbing System Definitions, and click Paste.</td>
</tr>
<tr>
<td></td>
<td>3 Right-click the copied item, and click Rename.</td>
</tr>
<tr>
<td></td>
<td>4 Enter a new name, and press ENTER.</td>
</tr>
</tbody>
</table>

3 On the General tab, enter a name and description.

4 On the Defaults tab, specify the default fittings to use during layout.

5 On the remaining tabs, specify other properties pertaining to this system definition, and then click OK.

TIP When defining a sanitary plumbing system that uses gray water or black water, you must define the system type as Waste on the Design Rules tab. Otherwise, the sizing calculator will not recognize the system as a sanitary system, and you will be unable to size the run.

Specifying the Default Fittings for a Plumbing System Definition

When you specify systems for equipment, fixtures, and plumbing lines as you draw, AutoCAD MEP inserts plumbing fittings based on the default fittings specified for the associated system definition. For this reason, you should specify default fittings for the plumbing system definitions that you are using for a project. You can specify default fittings for 4 types of fittings:

- Elbows
- Tees
- Crosses
- Transitions

For example, you can specify that a base tee be placed as you draw rather than a straight tee.

NOTE If your design requires unique fittings, you can override the default fittings for an individual run or add a fitting manually.
To specify the default fittings for a plumbing system definition

1 In the Plumbing workspace, click Manage tab ► Style & Display panel ► Style Manager drop-down ► Plumbing System Definitions.

NOTE Alternatively, you can select a fitting in the drawing, and click Plumbing Fitting tab ► General panel ► Edit Style drop-down ► Edit System Style.

2 In Style Manager, select the system where you will specify the default fittings.

3 On the Defaults tab, specify the type of fitting and click OK:
   ■ Elbow

   TIP As you draw a system, the software adds elbows as needed and the corresponding elbow styles to the drawing. The type of elbow you specify here, in conjunction with the angle of the elbow that is added, determines the name of the elbow style (for example 60 Degree Standard Radiused Elbow). Because the elbow styles are stored in the drawing, you can apply them to other elbows during layout modification.

   ■ Tee
   ■ Tee Up
   ■ Tee Down
   ■ Cross
   ■ Transition

NOTE If a list is empty or does not contain the desired fitting, click Import, select a fitting, and then click OK. Because the software draws elbows dynamically based on the direction of the run, there is no import option for elbows.

Configuring Fixture Unit Tables

Fixture unit tables specify fixture units by fixture type and occupancy type for the following types of systems: cold water, hot water, and sanitary waste. Fixture unit table definitions are available in Style Manager on the Table tab.

When you add or modify a fixture in your drawing, you specify a fixture unit table and fixture type in the Add Multi-view Parts dialog.

AutoCAD MEP applies a default fixture unit value to each connector on the fixture based on the system type of the connector and the fixture values that you specify in the worksheet. However, you can modify the applied values when necessary.

Applying a Default Fixture Unit

1 Locate all the rows in the fixture unit table that match the fixture type of the fixture.

2 In those rows, locate the row that matches the subtype of the fixture.

3 If the software cannot identify the specified row, locate the row based on matching keywords in the subtype name of the fixture.
If the software cannot find a match for the fixture in the specified fixture unit table, it does not assign default fixture unit values to the fixture. To take advantage of the application of default values, you should create and use fixture unit tables that correspond to the plumbing fixtures.

When performing sizing calculations for plumbing lines, the software uses the fixture unit values applied to the fixtures in your drawing. If you plan to do plumbing line sizing, you should first identify the fixture unit tables to use and verify their accuracy.

The software includes a sample fixture unit table based on industry standards. However, you or your CAD manager should create fixture unit tables to meet your project requirements and conform to applicable codes, such as the Uniform Plumbing Code. You can use the sample table as a guide.

Creating a Fixture Unit Table

1. In the Plumbing workspace, click Manage tab ➤ Style & Display panel ➤ Style Manager ➤ .
2. In the left pane of Style Manager, open Plumbing Objects, and then open Fixture Unit Table Definitions.
3. Under Fixture Unit Table Definitions, click Standard, right-click, and click Copy.
4. Select Fixture Unit Table Definitions, right-click, and click Paste.
5. Select Standard (2), right-click, click Rename, enter the name of the fixture unit table definition that you are creating, and press ENTER.
6. In the right pane, click the General tab and enter a name and description. You can also click Notes to add text notes or reference documentation.
7. To modify the table, click the Table tab, select the desired rows, use the Add, Modify, and Remove buttons, and click OK.

Importing a Fixture Unit Table into a Drawing

1. With both drawings open, activate the Plumbing workspace.
2. Click Manage tab ➤ Style & Display panel ➤ Style Manager ➤ .
3. In the left pane of Style Manager, select the fixture unit table to import (located under the drawing that contains it), right-click, and click Copy.
4. Under the drawing where you want to import the table, select Fixture Unit Table Definitions, right-click, and click Paste.

Specifying Plumbing Line Sizing Tables

1. In the Plumbing workspace, click Manage tab ➤ Style & Display panel ➤ Style Manager ➤ .
2. In the left pane of Style Manager, under Plumbing Objects, click one of the sizing table definitions (supply pipe or sanitary pipe).
3. In the left pane of Style Manager, click Standard, right-click, and click Copy.
4. Click the applicable Sizing Table Definitions item (Supply Pipe or Sanitary Pipe), right-click, and click Paste.
5. Select Standard (2), right-click, click Rename, enter the name of the sizing table you are creating, then press ENTER.
6. Click the General tab, and change the name and description. Click Notes to add text or reference documentation.
Specify definitions that are specific to Supply or Sanitary pipes:

- To create a supply pipe sizing table definition, click the Equivalent Plumbing Line Lengths tab and use the New Row, Remove Row, New Column, Modify Column, and Remove Column buttons to change the table definition as necessary.

- To create a sanitary pipe sizing table definition, choose either the Stacks, Branches, or Offsets tab and use the New and Remove buttons to change the rows in the table definition as necessary.

Configuring Styles for Plumbing Lines and Fittings

Plumbing line styles and plumbing fitting styles, respectively, determine the appearance and function of plumbing lines and plumbing fittings. For example, a plumbing line style determines how a plumbing line is displayed when crossing other plumbing lines, its available nominal sizes, and its display properties.

This section provides information on styles specific to plumbing. For general information that is applicable to all building systems disciplines, including plumbing, see Configuring Styles on page 603.

**NOTE** The plumbing module does not distinguish between the horizontal branches and main runs in a network. Therefore, consider creating a unique plumbing line style for horizontal branches.

Specifying Annotation for a Plumbing Line Style

A plumbing line style determines how the line displays when it crosses another line. When the elevations of 2 crossing lines are different, then the crossing style of the line at the higher elevation is used. When the elevations of the lines are the same, then the software uses the crossing style of the line drawn second.

<table>
<thead>
<tr>
<th>If the crossing style of the 2 lines is...</th>
<th>And if the priority values of the 2 lines are...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>overlap</td>
<td>the same</td>
<td>the line drawn second displays the overlap.</td>
</tr>
<tr>
<td>break</td>
<td>the same</td>
<td>the line drawn first displays the break.</td>
</tr>
<tr>
<td>mixed (one is overlap, and the other is break)</td>
<td>the same</td>
<td>the line drawn second determines the crossing style to use. If the style is overlap, the line drawn second displays the overlap. If the style is break, the line drawn first displays the break.</td>
</tr>
</tbody>
</table>

To specify annotation for a plumbing line style

1. With the **Plumbing workspace activated**, click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Plumbing Line Styles.  

   **NOTE** Alternatively, you can select a plumbing line that uses the style in the drawing, and click Plumbing Line tab ➤ General panel ➤ Edit System Style drop-down ➤ Edit Plumbing Line Style.

2. In Style Manager, select the style.

3. On the Annotation tab, under Crossings, select a style for crossing plumbing lines.
You can specify that the crossing lines are displayed as is, with an overlap, or with a break.

4 If you select the overlap style or break style, enter the paper width of the overlap or break, and click OK.

TIP To change the draw order of a selected line (for example, Send to Back), click Home tab ➤ Modify panel ➤ Draworder drop-down ➤ Send To Back.

Specifying Standard Sizes for a Plumbing Line Style

Before you draw a plumbing run, you select a style and specify a nominal size on the Properties palette. The nominal sizes available on the Properties palette reflect the same sizes that you previously designated in Style Manager.

To specify standard sizes for a plumbing line style

1 With the the Plumbing workspace activated, open the style by doing one of the following:
   ■ Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Plumbing Line Styles. In the left pane of Style Manager, click the style to specify, and in the right pane, click the Standard Sizes tab.
   ■ Select a plumbing line that uses the style in the drawing, and click Plumbing Line tab ➤ General panel ➤ Edit System Style drop-down ➤ Edit Plumbing Line Style.

2 On the Standard Sizes tab, specify the standard (nominal) sizes for the plumbing line style:
   ■ To add a size, click (New Size), enter a value, and press ENTER.
   ■ To modify a size, double-click the size, enter a different value, and press ENTER.
   ■ To delete a size, select the size, and click (Remove Size).

Specifying Type and Subtype for a Plumbing Fitting Style

The type and subtype of a plumbing fitting style determine the default fitting behaviors for the style, for example, whether a tee is long-radiused or short-radiused.

To specify the type and subtype for a plumbing fitting style

1 With the the Plumbing workspace activated, open the style by doing one of the following:
   ■ Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Plumbing Fitting Styles.
   ■ Select a plumbing fitting that uses the style in the drawing and click Plumbing Fitting tab ➤ General panel ➤ Edit Style drop-down ➤ Edit Style.
2 On the Details tab, select a fitting type from the list, followed by a fitting subtype, and then click OK.

Connectors for a Plumbing Fitting Style

All AutoCAD MEP objects have one or more smart connectors (connection points). These smart connectors enable objects to connect intelligently to appropriate objects and to transfer information such as shape, size, and system. You add connectors to style-based objects such as plumbing fittings by adding the connectors to the styles that define the objects. You can also remove connectors from styles, or change their type and location.

Because plumbing fittings have grips, it is important for the connectors of a plumbing fitting style to be configured correctly. For a given connector, the connection point value must be the length of the segment, and its connection direction must be positive (1) or negative (-1) depending on its orientation from the origin (0,0). In addition, you must define the connectors in a specific order. The following image of an elbow, tee, and cross identifies the order for each type of fitting.

For example, the following table identifies how you would configure an elbow, tee, and cross—all with segments 0.5 inches long.

<table>
<thead>
<tr>
<th>Part Type</th>
<th>X, Y, and Z Values for Connection Direction</th>
<th>X, Y, and Z Values for Connection Direction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Elbow</td>
<td>Connector 1: 0, 0.5, 0</td>
<td>Connector 1: 0, 1, 0</td>
</tr>
<tr>
<td></td>
<td>Connector 2: -0.5, 0, 0</td>
<td>Connector 2: -1, 0, 0</td>
</tr>
<tr>
<td>Tee</td>
<td>Connector 1: -0.5, 0, 0</td>
<td>Connector 1: -1, 0, 0</td>
</tr>
<tr>
<td></td>
<td>Connector 2: 0.5, 0, 0</td>
<td>Connector 2: 1, 0, 0</td>
</tr>
<tr>
<td></td>
<td>Connector 3: 0, 0.5, 0</td>
<td>Connector 3: 0, 1, 0</td>
</tr>
<tr>
<td>Cross</td>
<td>Connector 1: -0.5, 0, 0</td>
<td>Connector 1: -1, 0, 0</td>
</tr>
<tr>
<td></td>
<td>Connector 2: 0.5, 0, 0</td>
<td>Connector 2: 1, 0, 0</td>
</tr>
<tr>
<td></td>
<td>Connector 3: 0, 0.5, 0</td>
<td>Connector 3: 0, 1, 0</td>
</tr>
<tr>
<td></td>
<td>Connector 4: 0, -0.5, 0</td>
<td>Connector 4: 0, -1, 0</td>
</tr>
</tbody>
</table>

Configuring Connectors for a Plumbing Fitting Style

1 Open the drawing that contains the style.
2 In the Plumbing workspace, open the plumbing fitting style by doing one of the following:
   ■ Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Plumbing Fitting Styles. In the left pane of Style Manager, select the style.
In the drawing, select a plumbing fitting that uses the style, and click Plumbing Fitting tab ➤ General panel ➤ Edit Style drop-down ➤ Edit Style ➤ Edit Style.

3 On the Connectors tab, for Description, enter a descriptive name, such as Cold_Water_Supply.
4 For Domain, select pipe.
5 Specify values for connection points X, Y, and Z. (Typically, you do not use the center points of the view blocks as connectors for plumbing fittings.)

**IMPORTANT** Use caution when modifying the connection points on connectors or removing connectors. Either action can break the connectivity between objects because the connector is modified in or removed from all instances of the style in the drawing.

6 Specify values for connection directions X, Y, and Z.
7 If you want to add a connector, click ➤ and configure the connector properties.
8 If you want to remove a connector, select the connector, and click ➤ .
9 Click OK.

**Specifying Plumbing Preferences for Labels and Flow Arrows**

1 In the Plumbing workspace, click Manage tab ➤ Preferences panel ➤ Plumbing ➤ .
2 To apply labels as you draw, click the first Apply Labels/Flow Arrows check box, and select a label style from the list.
3 To apply flow arrows as you draw, click the second Apply Labels/Flow Arrows check box, and select an arrow style from the list.
4 Under Layout Method for both the label style and the arrow style, specify the desired method, and then click OK:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>place a fixed number of evenly spaced labels or arrows along the plumbing line</td>
<td>select Space Evenly, and enter the number of labels or arrows to place on the plumbing line (related to By quantity on the Properties palette).</td>
</tr>
<tr>
<td>place the labels or arrows along the plumbing line based on a repeated spacing value</td>
<td>select Repeat Every, and enter the distance to specify equidistant spacing between labels or flow arrows along the plumbing line (related to By distance on the Properties palette).</td>
</tr>
</tbody>
</table>

**TIP** As you draw, you can specify the label or flow arrow preferences on the Design tab of the Properties palette under Labels and Flow Arrows.

**RELATED** For more on annotation, such as tags, schedules, cross-sectional views, and details, see Annotation on page 548.

**Creating Plumbing Systems**

The topics in this section describe how to use the features in AutoCAD MEP to create plumbing system designs.
Adding Plumbing Equipment and Fixtures

After attaching an external reference file (xref) of your architectural plan to your drawing, typically you continue by adding plumbing equipment and fixtures. You can place them in specific locations on floor plans and reflected ceiling plans.

RELATED  See Mechanical, Electrical, and Plumbing Equipment in Building Systems on page 76.

You add plumbing equipment and fixtures using the tools on the Equipment tool palette in the Plumbing tool palette group or ribbon, and following this sequence:

- Select a tool
- Use the Add Multi-view Parts dialog to select a part from the catalog
- Configure its properties
- Add the part to the drawing

To add plumbing equipment or fixtures

1. If necessary, activate the Plumbing workspace.
2. Open the Equipment tool palette, and select an equipment or fixture tool.

   NOTE  Alternatively, you select equipment from the Home tab ➤ Build panel ➤ Equipment drop-down on the ribbon.

   The Add Multi-view Parts dialog appears, showing a tree view of the current Plumbing catalog.
3. On the Part tab, select a part subtype in the part type folder that is associated with the tool you selected.
4. Click Details to view the sizes available for the selected part subtype.
5. Because some part subtypes have multiple available sizes, optionally click the Part Filter tab to filter the list and specify the filtering criteria.

   NOTE  The part catalogs and content locations specified in the Options dialog determine the parts available to you when adding a part. For more information, see Specifying Part Catalogs and Style-Based Content Locations on page 70. If the part you want is unavailable, you can create a custom part using Content Builder.

6. Select a part for Part Size Name.
7. Specify an elevation.
8. If the part is a fixture, click the Fixture Units tab, and specify the following:
   - Fixture unit table
   - Fixture type
   - Occupancy type (public or private)

   TIP  Before adding the fixture, you should verify the accuracy of the selected fixture unit table and ensure it meets your design requirements. When you add the fixture, the software applies a default fixture unit value to each of its connectors based on the system type of the connector and the property values that you specified on the Fixture Unit Table tab. The default values are correct for most design situations. However, you should examine the values and modify them if required. If you subsequently perform plumbing line sizing, the software uses the fixture unit values applied to the fixture in the calculations.
Specify an insertion point in the drawing, and use the compass to specify a rotation angle.

Press ENTER to end the command.

Adding Plumbing Lines

You add plumbing lines using the plumbing line tool palette or ribbon, and the Properties palette to specify plumbing line properties.

NOTE As you draw plumbing runs in plan view and change the elevation, the software inserts an elbow down drop symbol when needed to represent the vertical segments in the run. You can manually insert an elbow up plumbing fitting if needed at the end of the plumbing line.

Drawing a Plumbing Run from Equipment or Fixtures

When you start or end a plumbing run at a piece of equipment or a fixture, the start point or end point of the plumbing line snaps to the nearest connection point on the equipment or fixture. Simple fixtures and equipment, such as a utility sink, typically contain only one connection point. However, complex fixtures and equipment, such as tanks and lavatories, often contain multiple connection points. Some even have connection points that belong to different systems, such as both a supply system and a drain system.

To draw a plumbing run from equipment or a fixture

1. Add the necessary equipment or fixtures.
2. Open the Plumbing Line tool palette, and select a plumbing line tool.

NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Plumbing Line.

3. On the Design tab of the Properties palette, under General, specify a plumbing line style. The specified plumbing line style determines its appearance and function. For example, it might determine how the line is displayed when it crosses other lines. For more information, see Configuring Styles for Plumbing Lines and Fittings on page 481.

4. Under System, make a selection from the list. The system specified for a plumbing run determines the fittings that are inserted as you draw, as well as other properties. For more information, see Configuring Plumbing System Definitions on page 477.

5. With the Pipe Connector snap enabled, select a starting point for the plumbing line at a connector on the equipment or fixture.

NOTE If more than one connector is available, the Select Connector dialog appears. Select a connector and click OK.

The elevation and the default run direction of the plumbing line are dependent on the connector assigned to the fixture or MvPart. Typically, the run direction is perpendicular to the fixture or MvPart.

6. Continue specifying points to draw the run as necessary.
7. Press ENTER when done.
Drawing a Plumbing Run Using Add Grips

1 Select the object in the drawing, and click \(\text{Grips for Adding to a Plumbing Run on page 469}\) to begin drawing a plumbing line:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>start a run from one of the ends of a plumbing line segment</td>
<td>click the add grip at that end of the segment.</td>
</tr>
<tr>
<td>start a run from the midpoint of a plumbing line segment</td>
<td>click the add grip at the midpoint of the segment. A tee or takeoff is automatically inserted, depending on the connection specified for plumbing layout preferences.</td>
</tr>
<tr>
<td>start a run from an MvPart</td>
<td>click the add grip on the MvPart connection.</td>
</tr>
<tr>
<td>start a run from a fitting, such as an elbow or tee</td>
<td>hold down the Ctrl key and click the add grip pointing in the direction of where you want to start the new run.</td>
</tr>
</tbody>
</table>

2 On the Design tab of the Properties palette, specify a system.

The system determines the fittings that are inserted as you draw, as well as other properties. For more information, see Configuring Plumbing System Definitions on page 477.

**NOTE** If you start from an MvPart, select a system type for System. If you start from a plumbing line segment or fitting, the new run inherits the system.

3 Next, specify a plumbing line style.

The style determines the appearance and function of the plumbing line, such as how the line is displayed when it crosses other lines. For more information, see Configuring Styles for Plumbing Lines and Fittings on page 481.

4 Specify an elevation for the plumbing segment.

5 For Nominal Size, specify the diameter of the plumbing line.

**NOTE** If you change the nominal size before specifying the first segment of the new run, a transition is automatically inserted between the object and new plumbing line segment after you specify the first point of the new run.

6 Specify whether the nominal size should be locked from editing.

Locking the nominal size prevents an accidental change to sizing values when you are modifying the plumbing line.

7 If desired, for Offset, enter the distance from the run to other drawing objects.

8 Enter values for Rise and Run.

**NOTE** The software calculates the slope using the rise and run values that you enter. If you specify a slope percentage instead, the software calculates the rise and run values.

9 Specify a start point. For example, you can begin the run by using a Pipe Connector snap to snap to the endpoint of an existing plumbing line or snap to a point along the curve of the line.

10 Specify additional points to add segments to the run. (Fittings are automatically inserted as you lay out the run.) As you specify points, change the elevation when necessary.

For information on connecting to plumbing lines at a different elevation, see Connecting Plumbing Lines at Different Elevations on page 489.
11 Press *ENTER* to end the command.

**Drawing a Plumbing Run**

1. If necessary, **activate the Plumbing workspace**.
2. On the Plumbing Line tab of the Plumbing tool palette, select a plumbing line tool.

   **NOTE** To draw a plumbing run, you can also click the add grip on an existing plumbing line segment or click Home tab ➤ Build panel ➤ Plumbing Line.

3. On the Design tab of the Properties palette, under General, specify a plumbing line style.
   The style determines the appearance and function of the plumbing line, such as how the line is displayed when it crosses other lines. For more information, see Configuring Styles for Plumbing Lines and Fittings on page 481.

4. Specify a system.
   The system determines the fittings that are inserted as you draw, as well as other properties. For more information, see Configuring Plumbing System Definitions on page 477.

5. Specify an elevation.

6. For Nominal Size, specify the diameter of the plumbing line.

7. If desired, for Offset, enter the distance from the run to other drawing objects.

8. Enter values for Rise and Run.

   **NOTE** The software calculates the slope using the rise and run values that you enter. If you specify a slope percentage instead, the software calculates the rise and run values.

9. Specify a start point. For example, you can begin the run by using a **Pipe Connector snap** to snap to the endpoint of an existing plumbing line or snap to a point along the curve of the line.

10. Specify additional points to add segments to the run. (Fittings are automatically inserted as you lay out the run.) As you specify points, change the elevation when necessary.
    For information on connecting to plumbing lines at a different elevation, see Connecting Plumbing Lines at Different Elevations on page 489.

11. Press *ENTER* to end the command.

   The system and parameter settings that you specify remain in effect until you change them.

**Creating a Plumbing Run from a Polyline**

You can define the path of a run using a combination of polylines and lines, and then convert these objects into a plumbing run.

1. Define the curve of the layout path with the AutoCAD® PLINE or LINE command.

2. Select the polyline or line that you want to convert, right-click, and click Convert to ➤ Plumbing Line.

3. Do one of the following:
   - Press *ENTER* or enter *n* (no) to leave the layout geometry in the drawing.
   - Enter *y* (yes) to erase the layout geometry from the drawing.

4. Specify values for the plumbing line on the Design tab of the Properties palette, including style, dimensions, system, etc.
Connecting Plumbing Lines at Different Elevations

As you draw a plumbing system, sometimes you need to start or end a run by connecting (snapping) to the endpoint of an existing plumbing line, or to a point along its curve.

If the connecting plumbing line has a different elevation than the one you are starting or ending, you are prompted to decide how to connect the 2 plumbing lines:

**Add a riser to the connecting plumbing line**

If you are connecting to an end connector, the software inserts a drop symbol to represent the change in elevation. If you are connecting to a point on the curve of the plumbing line, the software inserts the tee specified as the default fitting for Tee Up or for Tee Down in the plumbing system definition, depending on the elevation of the 2 lines.

**RELATED** For more information on specifying default fittings, see Specifying the Default Fittings for a Plumbing System Definition on page 478.

**Add a riser to the fixture**

If you are connecting from a fixture to a plumbing line, the software adds a riser to the fixture (MvPart), rather than to the end of the connecting line.

**Adjust the slope**

The slope of the plumbing line that you are starting or ending is adjusted based on the difference in elevation. If you are connecting to an end connector, an elbow is inserted. If you are connecting to a point on the curve of the plumbing line, a tee is inserted.

**Adjust the connecting plumbing line elevation**

The elevation of the plumbing line you are starting or ending is changed to match the elevation of the plumbing line to which you are connecting. If you are connecting to an end connector, an elbow is inserted. If you are connecting to a point on the curve of the plumbing line, a tee is inserted.

**Do Not Make a Connection**

Avoid making the connection.

Overriding the Default Plumbing Fittings for an Individual Run

Before you draw a plumbing run, you specify a system. As you draw the run, the software inserts plumbing fittings based on the default fittings configured in that system definition.

Generally, this insertion behavior for fittings is desirable because all of the runs in a plumbing system typically have the same types of fittings. For example, a sanitary waste system typically has runs with sanitary tee fittings. However, you can override the default fittings for an individual run that you are drawing. This enables the run to have a unique set of fittings regardless of the system.
NOTE You can also add a fitting manually, which is beneficial when you want to add a single unique fitting.

To override the default plumbing fittings for an individual run

1 In the Plumbing workspace, select a tool on the Plumbing Line tab of the Plumbing tool palette.

   NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Plumbing Line ✓.

2 On the Design tab of the Properties palette, under Default Fitting Overrides, click the desired fitting type to override.
3 On the Select a Style dialog, specify the fittings style override to be used during layout of the current run.

   If you want to specify a... then click...
   tee Tee, and click a type of tee.
   tee up Tee Up, and click a type of tee.
   tee down Tee Down, and click a type of tee.
   cross Cross, and click a type of cross.
   transition Transition, and click a type of transition.

4 Draw the plumbing run using the new default fittings, and press ENTER to end the command.
   Once you end the command, the software restores the default fittings to those specified in the plumbing system definitions.

Adding Plumbing Fittings Manually

Before you draw a plumbing run, you specify a system. The software determines the fittings to insert based on the default fittings configured in that system definition.

When necessary, you can override the default fittings for an individual run, or add a fitting manually. This is useful in design situations that require unique fittings.

When you add a plumbing fitting manually, the fitting breaks into the plumbing line, which results in a separate segment on each side of the fitting.

To add a plumbing fitting manually

1 If necessary, activate the Plumbing workspace.
2 Select a tool on the Fittings tab of the Plumbing tool palette.

   NOTE Alternatively, you can click Home tab ➤ Build panel ➤ Plumbing Fitting ✓.

3 On the Design tab of the Properties palette, under General, click the image to the right of Style.
4 On the Select a Style dialog, choose the desired plumbing fitting style.
5 On the Design tab of the Properties palette, specify the insertion properties for the selected fitting:

   If you want to specify... then...
   plumbing system select a system.
If you want to specify... then...

- an elevation at which to place the fitting: select an elevation.
- a grip point location on the fitting: select a method for Justification.
- a rotation angle: select Specify rotation on screen. Select No, and then enter the number of degrees for Rotation.
- specify the rotation angle upon insertion: select Specify rotation on screen and select Yes.
- specify an identification label: enter text for the ID (under Advanced)

6 Click in the drawing to specify the insertion point.
7 If you selected Specify Rotation on Screen, rotate the fitting into position or press ENTER to accept the default rotation.
8 Add additional fittings as needed. You can select different fittings and specify different properties as you add them.

Adding an Expansion Loop to a Plumbing Run

Add an expansion loop to a long hot water run to allow for pipe expansion and contraction as the pipe heats during water flow.

1 Select a segment of the plumbing run, and click Plumbing Line tab ➤ Modify panel ➤ Add Expansion Loop .

IMPORTANT If you add an expansion loop after performing size calculations, you need to resize the plumbing run.

2 Specify the start point for the expansion loop.
3 Specify the second point for the expansion loop.
4 Specify the distance away from the run to place the expansion loop.
5 Specify the side of the run on which to place the expansion loop.

Adding an expansion loop

- select plumbing line
- specify first expansion loop point
- specify second expansion loop point
- specify expansion loop distance
- specify side for expansion loop
- resulting expansion loop
Modifying Plumbing Systems

The topics in this section describe how to modify plumbing system designs. AutoCAD MEP lets you modify your plumbing system designs with grip controls in the drawings as well as various tools.

Component Selection

This section describes various ways to select and filter components in a drawing:

- Move the cursor over an object, and click to select it.
- Drag the cursor from left to right to select only objects that are entirely enclosed by the rectangular area.
- Select an object, right-click, and click Select Similar. This command selects all objects in the drawing that have the same part subtype, size, and system as the selected object.

**NOTE** Alternatively, you can click Plumbing Line tab ➤ General Panel ➤ Select System drop-down ➤ Select Similar, or Plumbing Fitting, Equipment or Multiple Objects tab ➤ General Panel ➤ Select Similar.

- Select an object, and click contextual ribbon [component] tab ➤ General panel ➤ Select System drop-down ➤ Select Connected Branches. This command selects all components of a plumbing run or a portion of the plumbing run.
- Select a plumbing line or fitting and click Plumbing Line tab or Plumbing Fitting tab ➤ General panel ➤ Select System drop-down and then choose one of the other options from the list — Select System, Select System Group, or Select Domain.
- Select a group of objects, and use the Properties palette Quick Select filter to refine the selection set to objects with a common property.

To deselect an object or objects, press Esc.

For more information, see "Select Multiple Objects" in AutoCAD® Help.

Selecting Connected Branches

1. Select a plumbing line or fitting.
2. Click Plumbing Line tab or Plumbing Fitting tab ➤ General panel ➤ Select System drop-down ➤ Select Connected Branches.
3. Enter n to cycle through the connection previews.
4. When the desired branch is highlighted, press Enter.
5. Repeat the previous steps to select other branches, even if they are not connected to the original plumbing system.
6. Press Enter to select the branches.

Filtering Plumbing Objects by Part Properties

1. Select multiple objects.
In this example, the Select Connected Branches command is used to select a plumbing run.

2 Click (Quick Select) at the upper-right corner of the Properties palette.
3 On the Quick Select dialog, specify the filter properties:
   ■ For Object type, select Plumbing Fitting.
   ■ For Properties, select System.
   ■ For Operator, select =Equals.
   ■ For Value, enter ByLayer.
4 In this example, the selection set was filtered by part type. Now, only the elbows in the run are selected.

5 In the How to apply section, select Include in new selection set.
6 If you want to append the results of the Quick Select to the current selection set, select Append to current selection set and click OK.

**Filtering Selections by Part Type**

1 Select multiple objects in your drawing.
2 Select the part type from the drop-down list at the top of the Properties palette.

Modifying Plumbing Equipment and Fixtures

After you have finished the plumbing system layout and checked the calculations for the final design, typically you verify the plumbing equipment and fixtures in the drawing and, if necessary, make additions or modifications. You might also need to do this during the design process due to changes in the requirements.

Changes to equipment or fixtures might require changes to connecting plumbing lines. For information on modifying plumbing lines, see Modifying Plumbing Lines and Fittings Using Grips on page 496 or Modifying Plumbing Lines and Fittings on page 498.

RELATED See Mechanical, Electrical, and Plumbing Equipment in Building Systems on page 76.

To modify plumbing equipment or fixtures

1 Select on page 492 the part to modify and click Equipment tab ➤ Modify panel ➤ Modify Equipment ➤ .

2 In the Multi-view Part Modify dialog, choose the appropriate action to modify the part.

Change the part subtype.
Select a different subtype in the part type folder. Click Details to view the list of available part sizes, and optionally filter the list according to specific criteria on the Part Filter tab. For example, you can filter the list by connection type and size.

Change the size.
Select a size for Part Size Name.

Change the elevation.
Select a defined elevation or enter a value for Elevation.

3 If you are modifying a fixture, click the Fixture Units tab and specify the following:
   ■ a fixture unit table for Fixture Unit Table.
   ■ a fixture type for Fixture.
   ■ an occupancy type (public or private) for Occupancy.
Calculating the Slope of a Plumbing Line

You can calculate the start elevation, end elevation, or slope of a plumbing line using the plumbing line slope tool.

**NOTE** Since plumbing lines are 2-dimensional (2D) only, the information provided by the plumbing line slope tool is for calculation purposes only.

To use the plumbing line slope tool, you need to enter at least 1 of the following values for the plumbing line to be calculated:

- Start point
- End point
- Slope

**To calculate the slope of a plumbing line**

1. **Select** on page 492 the plumbing line segment.

2. Click Analyze tab ➤ Plumbing panel ➤ Slope Plumbing. A green dot indicates the start of the selected plumbing line. A red dot indicates the end.

3. You can redefine the start point or the end point of the plumbing run.
In the Plumbing Line Slope dialog, click Select Start Point of Run or Select End Point of Run.

4 In the drawing area, click a new start point or end point for the selected plumbing run.

5 For Calculation, select the parameter you want to calculate.

6 Enter the corresponding values for the selected calculation:

<table>
<thead>
<tr>
<th>If you want to Calculate...</th>
<th>then enter...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Elevation</td>
<td>end elevation and slope</td>
</tr>
<tr>
<td>End Elevation</td>
<td>start elevation and slope</td>
</tr>
<tr>
<td>Slope</td>
<td>start elevation and end elevation</td>
</tr>
</tbody>
</table>

7 Press Tab to perform the calculation and then click OK.

**NOTE** The slope and elevation of any connected branch lines or MvParts will not change when you modify the slope of a plumbing line. The connected elements will remain connected to the modified plumbing line.

---

**Modifying Plumbing Lines and Fittings Using Grips**

You can use grips to modify components in a plumbing run including:

- Location grips
- Lengthen grips
- Rotate grips
**Moving Plumbing Lines and Fittings**

1. Select on page 492 the part or plumbing line segment.
2. Select the **Location grip** to use.
3. If the part or plumbing line segment is connected to another object, specify whether and how to maintain connectivity:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>maintain connectivity by adjusting only plumbing fittings and segments, and retain the current locations of MvParts</td>
<td>proceed to the next step.</td>
</tr>
<tr>
<td>maintain connectivity by adjusting all objects, including MvParts</td>
<td>press Ctrl.</td>
</tr>
<tr>
<td>break connectivity</td>
<td>press Ctrl twice.</td>
</tr>
</tbody>
</table>

4. Specify the new location:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>specify the new location relative to the current location</td>
<td>for an offset in the X direction, move the part in the direction of its new location, and enter the offset distance. For an offset in the Y direction, press Tab to toggle to the Y offset, and enter the offset distance.</td>
</tr>
<tr>
<td>manually specify the new location</td>
<td>Move the cursor to the new location, and click. You can use object snaps, AutoCAD MEP snaps, and tracking lines to help you specify the new location point.</td>
</tr>
</tbody>
</table>

**NOTE** To use the dimension input fields, both **dynamic input** (on the status bar) and the Dimension Input drafting option must be selected, which is the default setting. If you have deselected them, you can specify the new location by moving the cursor and clicking a point in the drawing, or by entering the coordinates in the command window.

You can also modify the location of a plumbing line or fitting using the Properties palette. For more information, see **Modifying the Location Coordinates of a Plumbing Line or Fitting** on page 500. For examples showing how to move a plumbing line or an MvPart, see **Associative Movement** on page 466.

**Modifying the Length of Plumbing Lines**

1. Select on page 492 the plumbing line segment.
2. Select the **Lengthen grip** on the end you want to modify.
3. If the segment is connected to an object on the end you selected, specify whether and how to maintain connectivity:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>maintain connectivity by adjusting only plumbing fittings and segments, and retain the current locations of parts</td>
<td>proceed to the next step.</td>
</tr>
</tbody>
</table>
If you want to... then...
maintain connectivity by adjusting all objects, including parts press Ctrl.

break connectivity press Ctrl twice.

4 Specify the segment length:
If you want to... then...
specify the new total length press Tab to activate the input field for specifying the resulting dimension, and then enter the new length.

specify the difference between the current length and new length drag the cursor to begin lengthening or shortening the segment, and then enter the change in length in the input field that is active by default.

specify a new end point drag the grip to the desired end point location, and click to specify the point.

NOTE To use the dimension input fields, both dynamic input (on the status bar) and the Dimension Input drafting option must be selected, which is the default setting. If you have deselected them, you can specify the new length by moving the cursor to a stretch point in the drawing or by entering the coordinates in the command window.

Rotating Plumbing Fittings
1 Select the object to be rotated.
2 Rotate the object:
If you want to... then...
rotate the object 180 degrees (flip the object) click the Rotate grip.

rotate the object 90 degrees while pressing CTRL, click the Rotate grip.

Modifying Plumbing Lines and Fittings
The topics in this section describe how to modify plumbing lines and fittings using the Properties palette.

Modifying the System Assigned to a Plumbing Line or Fitting
When you change the system assigned to a plumbing line or fitting, the software applies the change to all components having valid connections to the selected segment.

To change the system of a plumbing line or fitting
1 Select on page 492 a segment or plumbing fitting in the plumbing run in your drawing.
2 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties .
3 On the Design tab of the Properties palette, under System, specify a different system.

**NOTE** Alternatively, you can select a plumbing line, click Plumbing Line tab ➤ Modify panel ➤ Modify Plumbing Line , and select a different system in the Modify Plumbing Lines dialog box.

---

**NOTE** The plumbing line system determines the system type (i.e., Cold Water, Waste, or Fire Protection) and the associated fittings that the software inserts when necessary. Systems help maintain consistency throughout a run and across multiple drawings in a project. For more information on systems, see Configuring Plumbing System Definitions on page 477.

---

**Reversing the Flow of a Plumbing Run**

When you reverse the flow of a plumbing run, you cannot see the change in direction unless flow arrows are applied to the run. However, you can determine it by looking at the sweep on the sanitary tees.

**To reverse the flow of a plumbing run**

1. Select a segment on the plumbing run in your drawing.
2. Click Plumbing Line tab ➤ Calculation panel ➤ Reverse Flow .

For information on applying flow arrows as you draw, see Specifying Plumbing Preferences for Labels and Flow Arrows on page 484.

**NOTE** Reversing the flow of a plumbing run does not propagate to the connected objects. If you reverse the flow of a plumbing run after performing sizing calculations, you need to resize the run.

---

**Modifying the Elevation of a Plumbing Line or Fitting**

Plumbing lines are two-dimensional (2D). Therefore, the elevation of a plumbing line or fitting is for calculation purposes only.

**To modify the elevation of a plumbing line**

1. Select on page 492 the plumbing line or the plumbing fitting in your drawing.
2. Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties .
3. On the Design tab of the Properties palette, under Placement, specify a different value for Elevation.
4. Under Slope, specify values for Rise, Run, and Slope (%).

**NOTE** Alternatively, you can select a plumbing line, click Plumbing Line tab ➤ Modify panel ➤ Modify Plumbing Line , and change the setting for Elevation, Rise, Run, and Slope in the Modify Plumbing Lines dialog.

Changing the elevation of a plumbing line or plumbing fitting might break the corresponding connection to other components. As a result, you should check for disconnections. Changing the elevation of a plumbing line might also change the elevation of connected objects on the same level.

5. Click View tab ➤ MEP View panel ➤ Solution Tips .
For more information on solution tips, see Showing Solution Tips on page 579.

6 If necessary, reconnect disconnected components in the run by adding connecting segments, changing the elevation of segments, or moving or lengthening components. You can recreate valid connections using AutoCAD MEP snaps.

### Modifying the Location Coordinates of a Plumbing Line or Fitting

The preferred method for moving plumbing lines and fittings is to use location grips. However, you can also modify the location of a plumbing line using the Properties palette.

**To change the location coordinates**

1 Select on page 492 the plumbing line in your drawing that you want to modify.

2 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties.  

3 On the Design tab of the Properties palette, under Placement ➤ Elevation, click Additional Information.

4 In the Location dialog, specify the placement or orientation changes.

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>specify a new location</td>
<td>under Insertion Point, specify the new X, Y, and Z coordinates, and click OK.</td>
</tr>
<tr>
<td>change the normal axis, and reorient the part along the new normal</td>
<td>under Normal, specify 1 for the normal axis and 0 for the other 2 axes, and click OK.</td>
</tr>
</tbody>
</table>

**IMPORTANT** Using this method to modify the location coordinates of a plumbing line will cause the plumbing line to disconnect from any plumbing runs to which it is currently connected.

### Modifying the Nominal Size of a Plumbing Line Segment

1 Select on page 492 the plumbing line segment in your drawing.

2 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties.  

3 On the Design tab of the Properties palette, under Dimensions, specify a different nominal size.

4 Specify a new size for Nominal Size.

**TIP** You can lock Nominal size. When locked, the nominal size list is inactive and the associated diameter cannot be modified. You can, however, still modify the length or elevation of a plumbing object. To turn off a size, unlock this setting on the Properties palette.

**NOTE** Alternatively, you can select a plumbing line, click Plumbing Line tab ➤ Modify panel ➤ Modify Plumbing Line, and change the setting for Nominal Size or lock the setting.

The plumbing line style determines the appearance and function of the line, including size. As a result, the defined plumbing line style dictates the nominal sizes that are available for selection on the Properties palette.

**NOTE** Since plumbing lines are two-dimensional (2D) only, the size of a plumbing line is for calculation purposes only. Changing the size of a plumbing line does not automatically insert the necessary fitting.
Modifying the Style of a Plumbing Line or Fitting

1 Select on page 492 the plumbing line or plumbing fitting in your drawing.

2 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties.

3 On the Design tab of the Properties palette, under Style, specify a different style.

NOTE Alternatively, you can select a plumbing line and click Plumbing Line tab ➤ Modify panel ➤ Modify Plumbing Line , to change the setting for Style.

Plumbing line styles are based on information such as the size, type, and gauge of the material (i.e., Schedule 40 Carbon Steel or Copper Tube). Plumbing fitting styles are based on information such as type (i.e., tee, cross, trap, or check valve) and subtype (i.e., 45-degree mitered, 90 degree long-radiused, or 3-way). The style determines the appearance and function of the plumbing fitting. For more information on styles, see Configuring Styles for Plumbing Lines and Fittings on page 481.

Calculating the Sizes of Supply Plumbing Lines

Before you size a supply plumbing system, you should:

■ Complete a draft of the system.

■ Verify the accuracy of the fixture unit table you are using. For more information, see Configuring Fixture Unit Tables on page 479.

■ Create a sizing table for supply plumbing lines based on applicable codes, such as the Uniform Plumbing Code, or verify the accuracy of the table you are using. For more information, see Specifying Plumbing Line Sizing Tables on page 480.

NOTE You can only size supply plumbing systems whose system type is Hot Water or Cold Water.

Sizing Supply Plumbing Lines

WARNING If you make any modifications to the supply system, you need to resize the plumbing lines.

1 Complete a draft of the supply system.

2 Select a run whose system type is Hot Water or Cold Water. When you select the run, specify the point on the run at which to find the flow rate, velocity, and plumbing line diameter.

3 Click Plumbing Line tab ➤ Calculation panel ➤ Size Plumbing Line .

NOTE To calculate sizing values without resizing the run, access the sizing calculator by clicking Analyze tab ➤ Plumbing panel ➤ Size Plumbing , and then press ENTER at the command prompt.
The software highlights all plumbing lines, fittings, and fixtures connected to, and downstream from, the plumbing line, as illustrated in the following drawing.

4 In the Size Supply Plumbing Line dialog, under **Design Values**, define the following sizing parameter values:

**Equivalent Plumbing Line Length for the Valves and Fittings**

For Plumbing Line Sizing Table, select the plumbing line sizing table definition that you created based on applicable codes, such as the Uniform Plumbing Code, and verify its accuracy.

**TIP** To examine the table definition in order to verify its accuracy, click the Plumbing Line Sizing Table icon.

**Appropriate Plumbing Line Size**

Select **Restrict Velocity**, and enter the maximum velocity that you want in the run. This setting ensures that the plumbing line does not exceed a certain value, thus avoiding issues such as water hammer.

**Amount of Water Pressure Coming into the Building**

Enter a value for **Pressure at Source**. For example, the pressure at the source of the building could originate from a booster pump.

**Minimum Amount of Pressure**

Enter a value for **Pressure-Highest Fixture**. For example, a third-floor toilet fixture at an elevation of 80 feet might require 15 psi in order to flush. This setting ensures that the minimum amount of pressure to be supplied to the highest-level fixture in the supply run will guarantee an adequate flow.

For more information on the parameters involved in sizing plumbing lines, see **Design Values for Supply Plumbing Line Sizing** on page 476.

The non-editable sections in the Size Supply Plumbing Line dialog contain the results of the sizing calculations. For more information, see **Reviewing the Sizing Results for Supply Plumbing Lines** on page 503.

5 Click **OK** to resize the system.
Reviewing the Sizing Results for Supply Plumbing Lines

Two sections of the Size Supply Plumbing Line dialog provide you with final calculations:

- Calculations for the Longest Run
- Calculations at Selected Component

### Calculations for the Longest Run

When you select a supply system to size, the plumbing module highlights all plumbing lines, fittings, and fixtures connected to, and downstream from the specific plumbing line you select. It then identifies the longest run in the system by calculating the equivalent plumbing line lengths of all connected fixtures, fittings, and valves.

The longest run is defined as the longest run in an entire network of connected runs in a system. It is the main run used to determine the sizing requirements. Typically, it connects the booster pump to the limiting fixture (the fixture located at the highest elevation in the building).

The Calculations for the Longest Run section of the Size Supply Plumbing Line dialog contains the non-editable, calculated values for the longest run.

#### Calculations for the Longest Run section

<table>
<thead>
<tr>
<th>Developed Length</th>
<th>Pressure Drop</th>
</tr>
</thead>
<tbody>
<tr>
<td>15148 mm</td>
<td>227.722 kPa</td>
</tr>
</tbody>
</table>

#### Developed Length

Developed Length is the length of the longest run, including the equivalent length of the fittings. The plumbing module passes through the entire plumbing system to obtain the plumbing line length of each fixture. The program then refers to the supply plumbing line sizing table (pipe sizing table) that you selected. The sizing table provides the equivalent plumbing line length values associated with each fitting and valve on the run, so that these values can be included in the calculation. The run that has the highest value for the equivalent plumbing line length is considered to be the limiting run, or the run that requires the most resistance.
**Elevation Difference**

Elevation Difference is the difference in height between the highest elevation and the lowest elevation in the run. For example, if the run is laid out from a fixture at an elevation of 2'-0" to the main run entering the building at an elevation of 6", then the difference in elevation is 1'-6".

**Pressure Drop**

Pressure Drop displays the loss of pressure between the limiting fixture and the source, typically a booster pump.

The pressure drop uses the calculated elevation difference, also known as head loss, and adds this value to the total friction loss in the limiting run.

The plumbing module uses the following formula to calculate this value:

\[
\text{Pressure Drop} = \text{Head Loss} + \text{Friction Drop}
\]

The formula is defined as follows:

- Pressure Drop is head loss plus friction drop.
- Head Loss is the elevation difference.
- Friction Drop is the friction loss for the limiting run.

To calculate the friction loss, the plumbing module uses the Hazen-Williams formula:

\[
F = 0.2093 \left(\frac{100}{C}\right)^{1.852} \times \left(\frac{q^{1.852}}{d^{4.866}}\right)
\]

The Hazen-Williams formula is defined as follows:

- \(F\) is friction drop for the longest run per 100 feet (or per 100 meters) of pipe (plumbing line).
- \(C\) is the inside pipe roughness or friction loss coefficient. The default value is 100.
- \(q\) is the total flow of the downstream fixture units measured in gpm (or L/s).
- \(d\) is the inside diameter of the pipe.

**Downstream Fixture Units**

Downstream Fixture Units displays the calculated value of all connected fixtures in the selected system.

To calculate the downstream fixture units value, the plumbing module totals the required fixture units for all connected fixtures on the run that you select.

**Calculations at Selected Component**

When you select a plumbing line in the supply run to size, you specify the point on the run at which the software calculates the flow rate, velocity, and plumbing line diameter. For example, to find the flow rate of the source, you would select the plumbing line closest to the booster pump.

The Calculations at Selected Component section of the Size Supply Plumbing Line dialog contains the non-editable, calculated values for the selected component.
Calculations at Selected Component section

Flow Rate

Flow Rate represents the amount of fluid that travels through the plumbing line that you selected over a period of one minute. The plumbing module calculates the flow rate using the plumbing line diameter and friction loss values. The plumbing module estimates the flow rate using Hunter’s Curve (mixed), which takes into consideration fixtures that only periodically require a specific amount of flow. Therefore, the plumbing line is not sized based on the total amount of flow required by all fixtures, but rather on the expected flow based on the probability that each fixture is being used. The calculated value is then used as a basis for the Hazen-Williams formula. The result is the flow rate displayed in the Size Supply Plumbing Line dialog.

Following is the Hazen-Williams formula:

\[ F = 0.2083 \left( \frac{100}{C} \right)^{1.852} \times \left( \frac{q^{1.852}}{d^{4.865}} \right) \]

The Hazen-Williams formula is defined as follows:

- F is friction drop for the longest run per 100 feet (or per 100 meters) of pipe (plumbing line).
- C is the inside pipe roughness or friction loss coefficient. The default value is 100.
- q is the total flow of the downstream fixture units measured in gpm (or L/s).
- d is the inside diameter of the pipe.

Actual Velocity

Actual Velocity is the speed at which the fluid travels through the plumbing line you selected and is based on the calculated values for the plumbing line diameter and minimum friction loss.

The plumbing module uses the following formula to calculate the actual velocity:

\[ V = \frac{Q}{A} \]

The formula is defined as follows:

- V is velocity.
- Q is flow rate.
- A is the inside cross-sectional area of the plumbing line.

The inside cross-sectional area is calculated as follows, where d is the inside diameter of the plumbing line.

\[ A = \frac{\pi d^2}{4} \]

Plumbing Line Diameter

Plumbing Line Diameter displays the diameter necessary to accommodate the flow rate and velocity of the selected plumbing line. The plumbing module estimates the size of each plumbing line at 8 feet per second.
The following information outlines how the plumbing line diameter is calculated:

- The plumbing module calculates the pressure available for friction loss throughout the supply system by subtracting Pressure at Source from Pressure of the Highest Fixture, minus Pressure Drop, minus Friction Loss-Water Meter.

- If the available pressure drop is insufficient, then the plumbing module increases the size of all the components in the run by one size (all sizes go up one plumbing line size) and recalculates Pressure Drop.

- If the Restrict Velocity option is enabled and the calculated actual flow velocity exceeds the restricted velocity, then the plumbing module increases the size of the run by one plumbing line size and recalculates Pressure Drop.

Once the plumbing module has found the correct plumbing line size, the corresponding standard nominal size is found from the calculated standard inside diameter. To view the size iterations used by the plumbing module, see the Standard Plumbing Line Sizing table in the following section.

**Standard Plumbing Line Sizing Table**

Use the following table as a reference for standard sizing calculations of plumbing lines. All values of \( d \), the inside diameter of the pipe (plumbing line), are in inches and are based on a Schedule 40 Steel Pipe gauge. To size the plumbing line, the calculation rounds up to the nearest standard size. The plumbing module assumes that all plumbing lines being sized are similar to Schedule 40 Standard Steel Pipe when determining an inside diameter.

<table>
<thead>
<tr>
<th>If the nominal size is...</th>
<th>then the inner diameter is...</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.125</td>
<td>0.269</td>
</tr>
<tr>
<td>0.25</td>
<td>0.364</td>
</tr>
<tr>
<td>0.375</td>
<td>0.493</td>
</tr>
<tr>
<td>0.5</td>
<td>0.622</td>
</tr>
<tr>
<td>0.75</td>
<td>0.824</td>
</tr>
<tr>
<td>1</td>
<td>1.049</td>
</tr>
<tr>
<td>1.25</td>
<td>1.380</td>
</tr>
<tr>
<td>1.5</td>
<td>1.610</td>
</tr>
<tr>
<td>2</td>
<td>2.067</td>
</tr>
<tr>
<td>2.5</td>
<td>2.469</td>
</tr>
<tr>
<td>3</td>
<td>3.068</td>
</tr>
<tr>
<td>3.5</td>
<td>3.548</td>
</tr>
<tr>
<td>4</td>
<td>4.026</td>
</tr>
<tr>
<td>5</td>
<td>5.047</td>
</tr>
<tr>
<td>6</td>
<td>6.065</td>
</tr>
</tbody>
</table>
How the Software Performs Calculations to Size Plumbing Lines

The following is for informational purposes only.

1 Determine the friction loss.
   The plumbing module determines the friction loss of the run using the Hazen-Williams formula.
   \[
   F = 0.2093 \left( \frac{100}{C} \right)^{1.857} \times \left( \frac{q^{1.852}}{d^{4.1865}} \right)
   \]
   The Hazen-Williams formula is defined as follows:
   - \( F \) is friction drop for the longest run per 100 feet (or per 100 meters) of pipe (plumbing line).
   - \( C \) is the inside pipe roughness or friction loss coefficient. The default value is 100.
   - \( q \) is the total flow of the downstream fixture units measured in gpm (or L/s).
   - \( d \) is the inside diameter of the pipe.

2 Calculate the change in elevation.
   The plumbing module calculates the change in elevation for the limiting run by subtracting the value of the Highest Fixture from the Pressure at Source.

3 Determine the total pressure drop.
The plumbing module determines the total pressure drop for the run as follows:

Total Pressure Drop = Friction Loss + Elevation Change

4 Determine the available pressure for Friction Loss.

The plumbing module determines the pressure available for the Friction Loss by subtracting the Pressure at Source from the Pressure at the Highest Fixture, minus Pressure Drop, minus Friction Loss-Water Meter.

5 Compare the Pressure Drop to the Pressure Available.

The plumbing module then compares the Pressure Drop to the Pressure Available. These values need to be equal to or greater than the available pressure. If the values do not match because the pressure available is insufficient, then the plumbing module increases the size of the run by one plumbing line size (all sizes go up one size) and recalculates the pressure drop.

6 Display the results.

When the calculations are completed, the plumbing module displays the calculated values in the Size Supply Plumbing Line dialog. For more information, see Reviewing the Sizing Results for Supply Plumbing Lines on page 503.

Calculating the Sizes of Sanitary Plumbing Lines

Before you size a sanitary system, you should:

■ Complete a draft of the system.
■ Verify the accuracy of the fixture unit table you are using. For more information, see Configuring Fixture Unit Tables on page 479.
■ Create a sizing table for sanitary plumbing lines based on applicable codes, such as the Uniform Plumbing Code, or verify the accuracy of the table you are using. For more information, see Specifying Plumbing Line Sizing Tables on page 480.

NOTE You can only size sanitary plumbing systems whose system type is Waste.

Overview of Sizing Sanitary Plumbing Lines

You can only size sanitary systems whose system type is Waste. For example, if you create system definitions for sanitary black water and sanitary gray water, you must define the system type as Waste. Otherwise, you cannot size the systems. For information on creating system definitions, see Configuring Plumbing System Definitions on page 477.

When you size a sanitary system, you can base the plumbing line sizing on 1 of 4 main types of runs:

■ Branch
■ Offset/Home Drains
■ Stack Spanning 3 Stories or Less
■ Stack Spanning More than 3 Stories

The type of run that you specify determines the sizing method that the software uses.
Sanitary Branch Sizing

When you define the sanitary run as a branch, the software performs the sizing calculations using the information on the Branches tab in the sanitary plumbing line sizing table (pipe sizing table), whose definitions can be found in the Style Manager.
Sanitary Offset Sizing

When you define the sanitary run as an offset or a home drain, the plumbing module performs the sizing calculations using the information on the Offsets tab in the sanitary plumbing line sizing table (pipe sizing table), whose definitions can be found in Style Manager.

Most sanitary systems are found in buildings that contain multiple floors. Each floor of the building is typically represented in a separate drawing. When sizing a sanitary system that spans multiple floors, you must size the plumbing lines for each drawing separately, starting from the highest floor and working downward. You can then reference the individual calculation values from the higher floors as you perform sanitary plumbing line sizing on the lower floors. For more information, see Sizing Sanitary Plumbing Lines for Multiple Floors on page 512.

The software does not distinguish between a horizontal offset and a horizontal branch. Therefore, you might want to create a style to represent a plumbing line that is a horizontal offset. For example, you could create a style called Black Pipe - Horizontal Offset, and select this style from the list on the Properties palette when you add the plumbing line.
Sanitary Stack Sizing

When you define your sanitary run as a stack spanning 3 stories or less, or more than 3 stories, the plumbing module performs the sizing calculations using the information on the Stacks tab in the sanitary plumbing line sizing table (pipe sizing table), whose definitions can be found in Style Manager.

Sizing Sanitary Plumbing Lines

Sanitary plumbing line sizing is typically required for sanitary black water system types. When you create sanitary system types for gray water, you need to define the system type as Waste in order for the sizing to work.

If you are working on a sanitary system in a building that contains multiple floors, see Sizing Sanitary Plumbing Lines for Multiple Floors on page 512.

**WARNING** If you make any modifications to the sanitary plumbing system, you need to resize the plumbing lines.

To size sanitary plumbing lines

1. Complete a draft of the sanitary system.
2. Select a run whose system type is Waste.

**NOTE** You cannot size systems whose system type is Storm Drain.

The software highlights all plumbing lines, fittings, and fixtures connected to, and downstream from the plumbing line.

3. Click Plumbing Line tab ➤ Calculation panel ➤ Size Plumbing Line ➔.

**NOTE** To calculate sizing values without resizing the run, access the sizing calculator by clicking Analyze tab ➤ Plumbing Panel ➤ Size Plumbing ➔, and then press ENTER at the command prompt.

The software displays the Size Sanitary Plumbing Line dialog.
4 In the Size Sanitary Plumbing Line dialog, under Design Values, select the plumbing line sizing table definition that you created based on applicable codes, such as the Uniform Plumbing Code. The software uses the table definition to determine the maximum permissible fixture unit loads for the type of run that you specify in the next step.

**TIP** To examine the table definition in order to verify its accuracy, click the Plumbing Line Sizing Table icon.

5 Select a type of plumbing line for Base Sizing On. You can base the sizing on a branch, offset or home drain, or stack.

The non-editable sections in the Size Sanitary Plumbing Line dialog contain the results of the sizing calculations. For more information, see Reviewing the Sizing Results for Sanitary Plumbing Lines on page 513.

6 Click OK to resize the system.

### Sizing Sanitary Plumbing Lines for Multiple Floors

Most sanitary systems are found in buildings that contain multiple floors, and each floor of the building is typically represented in a separate drawing. When sizing a sanitary system that spans multiple floors, you must size the plumbing lines for each drawing separately, starting from the highest floor and working downward. You can then reference the individual calculation values from the higher floors as you perform sizing on the lower floors.

**To calculate a sanitary system in a 3-story building**

1 Open the third-floor drawing and perform the following actions:

![Size Sanitary Plumbing Line dialog](image)

a Click the plumbing line closest to the second floor riser to select the run to size for the third floor.

b Under Design Values, verify that Branch is selected for Base Sizing On.

c Make a note of the calculated value for Fixture Units Upstream. You need to know this value for the subsequent steps.
2 Open the second-floor drawing and perform the following actions:

- **a** Click the plumbing line closest to the first floor riser to select the run to size for the second floor.
- **b** Under Design Values, select Offset/Home Drains for Base Sizing On.
- **c** Enter the Fixture Units Upstream value from the previous step for Fixture Units from Branches Connecting Outside of this Drawing. The selected run is sized appropriately, and the value for Size of Plumbing Line is updated accordingly.
- **d** Make a note of the calculated value for Fixture Units from Upstream Stack. You need to know this value for the next step.

3 Open the first-floor drawing and perform the following actions:

- **a** Click the plumbing line closest to the end of the main run that discharges out of the building to select the run to size for the first floor.
- **b** Under Design Values, select Offset/Home Drains for Base Sizing On.
- **c** Add the values for the Fixture Units from Upstream for the third floor (first step) and the Fixture Units from Upstream Stack for the second floor (second step).
- **d** Enter the result for Fixture Units from Branches Connecting Outside of this Drawing. The selected run is sized appropriately, and the value for Size of Plumbing Line is updated accordingly.

**Reviewing the Sizing Results for Sanitary Plumbing Lines**

The lower, non-editable sections of the Size Sanitary Plumbing Line dialog provide you with the final sizing calculations.
Sanitary Branch Sizing

If you based the sizing on branches, the Size Sanitary Plumbing Line dialog displays the results of the sizing for the branches in the drawing.

The Fixture Units Upstream value is the result of all connected fixtures in the drawing. This value assumes that all connected fixtures are in the current drawing. Once the Fixture Unit Upstream value is defined, the software calculates the value for Size of Branch.

Sanitary Offset Sizing

If you based the sizing on offsets or home drains, the Size Sanitary Plumbing Line dialog displays the results of the sizing for the offsets and home drains in the drawing.

The Fixture Units from Upstream Stack value is the result of all connected fixtures in the drawing. To calculate this value, in Fixture Units from Branches Connecting Outside of this Drawing, enter the calculated sum from the floor above. When working with a multiple story building, the drawing for each floor in the sanitary waste system should be saved in a separate file and must be calculated separately. For more information, see Sizing Sanitary Plumbing Lines for Multiple Floors on page 512.

Once the Fixture Unit Upstream Stack value is defined, the software calculates the value for Size of Plumbing Line. You can also view the slope of the selected plumbing line in Slope of Plumbing Line.
Sanitary Stack Sizing

If you based the sizing on stacks, the Size Sanitary Plumbing Line dialog displays the results of the sizing for the stacks in the drawing.

The Fixture Units from Branches Connecting in this Drawing value is the result of all connected fixtures in the drawing. However, when working with a multiple story building, typically each floor is saved in a separate drawing file. To accurately size the sanitary system for each floor, you must size the sanitary system for each floor separately, working downward. For each floor, in Fixture Units from Branches Connecting Outside of this Drawing, enter the Fixture Units from Branches Connecting in this Drawing value from the floor above. For more information, see Sizing Sanitary Plumbing Lines for Multiple Floors on page 512.
A schematic drawing is a two-dimensional (2D), not-to-scale flow diagram that shows the logic and operation of a building system. You draft a schematic or single-line diagram of your system to use as a basis for your complete design layout, or to create plumbing riser diagrams or details associated with your design. Generally, drafting a schematic diagram is one of the first steps in the building systems design process; however, not every project requires a schematic diagram.

Schematic diagrams are useful, for example, for representing how air moves through a building’s heating system or how electrical power, or hot and cold water, are carried through a building. They can also show relationships between equipment and other components in a system. For example, a mechanical schematic diagram can identify the types of equipment required for a system and show the connecting duct or pipe.

Sample mechanical schematic diagram

You create a schematic diagram by connecting symbols with lines to show the basic function of the building system. The diagram typically includes little information about individual parts.

You can create schematic diagrams in an orthographic or an isometric view direction. The orthographic plan view drawing is the more common type of schematic diagram. The isometric diagram is typically used for a complex layout that requires the representation of additional details.

**NOTE** Do not use a schematic diagram if you want to
- Create elevations or sections based on the drawing
- Use the duct sizing tools or plumbing sizing tools provided with AutoCAD MEP. To use these tools, create the system using ducts and duct fittings, or plumbing lines and plumbing fittings.
About Schematic Diagrams

You draw schematic lines just as you draw regular lines in AutoCAD®, using AutoCAD MEP snaps and tooltips to help you. You add schematic symbols just as you add entities in AutoCAD, using an insertion point for placement and a rotation angle.

However, schematic lines and symbols are more powerful than AutoCAD lines and objects because they recognize the connection points built into each schematic symbol, enabling you to create an intelligent building system diagram.

Connecting a schematic line to a schematic symbol

You can assign systems to schematic lines and symbols. Schematic systems store properties that remain constant for all lines and symbols within the schematic diagram. They enable the lines and symbols in a layout to act together as one by maintaining the same look and feel. For example, a layout of schematic symbols and lines can represent a mechanical air supply system, an electrical power supply system, or a cold water supply system. New lines and symbols inherit the current system’s property defaults, such as layer and color, providing a consistent method of drafting the schematic diagram. For more information, see Working with Systems on page 93.

Mechanical schematic line and symbol components

Electrical schematic line and symbol components

Plumbing schematic line and symbol components
Schematic Lines

You can create schematic lines from AutoCAD® lines, arcs, or polylines.

In addition to assigning systems to schematic lines, you can create schematic line styles to distinguish between different system types. Schematic line styles specify how crossing lines are displayed, the symbol used to represent a connection point, and the list of available designation IDs, among other properties.

Schematic Symbols

AutoCAD MEP provides an extensive library of schematic symbols that snap together to represent the connectivity and logical dependencies of real-world parts and equipment. Schematic symbols are style-based content defined by a variety of style properties. Style properties specify the behavior of each schematic symbol, such as how lines that connect to the symbol are trimmed. For more information, see Configuring Styles on page 603.

There are 2 types of schematic symbols:

- **In-line symbols.** These symbols can be anchored anywhere along a schematic line. Fittings, valves, gauges, and controls such as switches, signals, and devices are examples of in-line symbols. These symbols are attached to the line. They move when the line is moved, and they are erased when the line is erased. You can also relocate the symbol by moving the symbol along the schematic line.

  **Inserting a schematic symbol into a schematic line**

  ![Inserting a schematic symbol into a schematic line](image)

  specify insertion point on schematic line

  resulting in-line schematic symbol

- **End-of-line symbols.** These symbols typically appear at the start or end of a schematic line. An end-of-line symbol needs to be placed first and then connected to a schematic line. Equipment such as diffusers, pumps, fans, and tanks are examples of end-of-line symbols. End-of-line symbols move with the schematic line, and if the symbol moves the line is stretched with it. End-of-line symbols are not erased when the line is erased, and the line and the symbol can be erased individually.

  **Connecting a schematic line to a schematic symbol**

  ![Connecting a schematic line to a schematic symbol](image)

  specify schematic line start point on schematic symbol

  resulting schematic line attached to schematic symbol

For more information on anchors, see Working with Anchors on page 108.

Schematic symbols are organized into categories by type to make them easy to find. You can add, delete, and rename categories to customize the organization of the schematic symbols to meet your needs. You can also create custom schematic symbols or symbol libraries to match company standards or specific project requirements. For more information, see Customizing Style-Based Content on page 599.

Drawing in Orthographic Mode

You can draw a schematic diagram in orthographic (plan) mode. Orthographic mode enables you to draw the diagram in a 2D plan view.
When you draw in orthographic mode, you add schematic lines and symbols in the world coordinate system (WCS). In the WCS, the X axis is horizontal, the Y axis is vertical, and the Z axis is perpendicular to the XY plane.

**Orthographic drawing parameters**

As you add or move lines or symbols, you can use several tools to restrict cursor movement:

- Use the compass to guide the placement of lines or symbols.
- Use the AutoCAD® Ortho mode to restrict the cursor to the horizontal or vertical axes. The orthogonal alignment depends on the current snap angle, or grid and snap settings.
- Use the grid to help you to align symbols and visualize the distances between them.
- Use snaps for specifying precise points for placement of symbols or lines.

You can turn these tools on or off at any time during drawing and editing.

For more information, see **Creating a Schematic Diagram** on page 525.

**Drawing in Isometric Mode**

You can draw a schematic diagram in isometric mode. Isometric mode simulates a 3-dimensional (3D) plan view, where lines are drafted on rotated isoplanes and symbols appear tilted along the isometric axes. This provides the illusion of a 3D view in a 2D model.

Isometric drawings simulate a 3D object from a particular viewpoint by aligning along 3 major axes. The Isoplane option on the Properties palette restricts cursor movement to appropriate rotated angles along isometric planes. You can work on one of 3 isometric planes, each with an associated pair of axes:

- **Left.** Aligns symbols and lines along 90-degree and 150-degree axes.
- **Top.** Aligns symbols and lines along 30-degree and 150-degree axes.
- **Right.** Aligns symbols and lines along 30-degree and 90-degree axes.

**Viewing isometric planes**
Choosing one of the 3 isometric planes causes the AutoCAD® Ortho mode and the crosshairs to be aligned along the corresponding isometric axes in the WCS. You can switch between planes as you draft. For example, you can start a run on the top plane, switch to the left plane to draw a riser, and then switch to the right plane to complete the run.

Although an isometric drawing appears to be 3D, it is actually a 2D representation. Therefore, you cannot extract 3D distances, display objects from different view ports, or remove hidden lines automatically.

For more information, see Creating a Schematic Diagram on page 525.

Customizing Schematic Content

Schematic lines and schematic symbols are style-based content. This means the objects are defined by styles, which are sets of properties and, for schematic symbols, also include associated view blocks to represent the symbol geometry. For a general introduction to style-based content, see Working with Style-Based Content on page 85.

You can manually create the styles that define schematic lines and symbols using Style Manager. For an overview of this process, see Workflow for Creating Style-Based Content on page 599.

Additionally, there are several ways to convert batches of objects to schematic symbol styles. You can

- Convert the schematic symbol styles provided with AutoCAD MEP to their individual components (the settings and the view blocks), customize the components, and then convert the components back to schematic symbol styles.
- Convert a batch of AutoCAD blocks in a custom block library to schematic symbol styles.

For more information, see Customizing Schematic Symbol Content on page 630.

Configuring Schematic Settings

If you take time to configure schematic settings prior to drawing schematic diagrams, you can lay out your designs more quickly and accurately. Schematic settings are stored in the Style Drawing, and you can import them into the current drawing or open the content drawings.

Creating Schematic System Definitions

A system definition is typically named for the system it will represent, such as return air, lighting, or domestic cold water. The settings for a system definition control many of the display properties of a system. For example, you can specify a layer key for a system, which determines the layer, color, and linetype for the system.

System definitions are stored in the drawing, and you can copy them between drawings.

TIP The default templates contain several system definitions that you can copy or modify.

To create a schematic system definition

1 In the Schematic workspace, click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Schematic System Definitions.
2 Create the schematic system definition:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then in the left pane of Style Manager…</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a new, blank system</td>
<td>right-click Schematic System Definitions, and click New. Enter a name, and press ENTER.</td>
</tr>
<tr>
<td>definition</td>
<td></td>
</tr>
<tr>
<td>copy an existing definition, so</td>
<td>do the following:</td>
</tr>
<tr>
<td>you can modify the copy</td>
<td>■ Right-click the system definition you want to copy, and click Copy.</td>
</tr>
<tr>
<td></td>
<td>■ Right-click Schematic System Definitions, and click Paste.</td>
</tr>
<tr>
<td></td>
<td>■ Right-click the copy, click Rename, enter a new name, and press ENTER.</td>
</tr>
</tbody>
</table>

3 On the General tab, enter a description for the schematic system definition.

4 Specify values for the other properties of the system definition that are common to systems in all disciplines: mechanical, electrical, and plumbing. For help, see

- Specifying the Design Rules of a System on page 97
- Specifying the Display Properties of a System on page 99
- Attaching Notes and Files to a System on page 100

Configuring Styles for Schematic Lines

The styles for schematic lines and schematic symbols determine their appearance and function. For example, schematic line styles determine how crossing lines are displayed, the symbol used to represent a connection point, and the designations (IDs) to choose from when adding a schematic line.

NOTE This section provides information that is specific to styles for schematic lines and schematic symbols. For general information on working with all types of styles, including those for schematic lines and schematic symbols, see Configuring Styles on page 603.

Defining Designations for Schematic Line Styles

When you draw a schematic line, you can select a designation for the line on the Properties palette. The designation is a text ID that helps you to identify the line in the layout. The style you select for the line determines the list of designation IDs from which you can choose; you can select an ID from the list or enter a different one.

Example designation IDs

To define designations for a schematic line style

1 Open the drawing that contains the style.
2 In the Schematic workspace, open the style by doing one of the following:

- Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Schematic Line Styles. In the left pane of the Style Manager, select the style.
- In the drawing, select a schematic line that uses the style, and click Schematic Line tab ➤ General panel ➤ Edit System Style drop-down ➤ Edit Schematic Line Style.

3 Click the Designations tab.

4 Define the designations:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>add a designation</td>
<td>click , click the Designation field, enter an ID, and press ENTER.</td>
</tr>
<tr>
<td>edit a designation</td>
<td>click the corresponding Designation field, edit the ID, and press ENTER.</td>
</tr>
<tr>
<td>delete a designation</td>
<td>select a designation, and click .</td>
</tr>
</tbody>
</table>

**Specifying Annotation for Schematic Line Styles**

When you draw a schematic line, you can select a style for the line on the Properties palette. The style determines the annotation properties for the line, such as the symbols used to represent start points, endpoints, and connections.

The style of a schematic line also determines how crossing lines are displayed. You can display crossing lines as is, or with an overlap or a break of a specific width.

If you select the overlap style or break style, you must also specify a corresponding priority value. In a drawing, if 2 crossing lines have the same priority value in their corresponding styles, the line with the lower...
Z-axis value will display the overlap or break. If the priority values are different, the priority values determine this. Refer to the following table for more information.

<table>
<thead>
<tr>
<th>If the crossing style of the 2 lines is...</th>
<th>And if the priority values of the 2 lines are...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>overlap</td>
<td>the same</td>
<td>the line drawn second displays the overlap.</td>
</tr>
<tr>
<td>break</td>
<td>the same</td>
<td>the line drawn first displays the break.</td>
</tr>
<tr>
<td>mixed (one is overlap, and the other is break)</td>
<td>the same</td>
<td>the line drawn second determines the crossing style to use. If the style is overlap, the line drawn second displays the overlap. If the style is break, the line drawn first displays the break.</td>
</tr>
</tbody>
</table>

TIP To change the draw order of a selected line, right-click, click Display Order, and select a command (for example, Send to Back) on the submenu.

To specify annotation for a schematic line style

1. Open the drawing that contains the style.
2. In the Schematic workspace, open the style by doing one of the following:
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Schematic Line Styles 📊. In the left pane of the Style Manager, select the style.
   - In the drawing, select a schematic line that uses the style, and click Schematic Line tab ➤ General panel ➤ Edit System Style drop-down ➤ Edit Schematic Line Style 📊.
3. Click the Annotation tab.

![Annotation tab](image)

4. Under Crossings, select a style for crossing schematic lines.
   
   You can specify that the crossing lines are displayed as is, with an overlap, or with a break.

5. If you selected the overlap style or the break style, for Break/Overlap Paper Width, enter the width of the overlap or the break, and for Break/Overlap Priority, enter a number.
6. Under Connections, select a connection node symbol for line junctions, and enter a size.
7. Under Start & End Settings, select a symbol for the start and end of a line, and enter a size for each.
Creating a Schematic Diagram

You create a schematic diagram by connecting symbols with lines to show the basic function of a building system in the overall design. You drag and drop schematic symbols into a drawing and connect the symbols with schematic lines, drawing the schematic lines just as you draw lines in AutoCAD®. However, schematic lines and symbols are more powerful than AutoCAD lines and objects because they recognize the connection points built into each schematic symbol, enabling you to create an intelligent building system diagram.

Typically, you alternate between drawing schematic symbols and drawing schematic lines, essentially drafting them together. You can add freestanding or end-of-line symbols in a drawing and connect them later. For example, you can add a pump and connect the supply and return lines at a later time, or you can add a fan and connect the wire at a later time. You can also draft the lines first and then add in-line symbols. For example, you might add a duct heater that breaks into a run in a hot air system, or add a device after wire has been run to a panel.

You can draw a schematic diagram in orthographic (plan) or isometric on page 520 mode.

Adding Schematic Lines in Orthographic Mode

When you are drawing in orthographic mode, you add schematic lines in the world coordinate system (WCS). In the WCS, the X axis is horizontal, the Y axis is vertical, and the Z axis is perpendicular to the XY plane.

You can use the compass to guide your placement of lines. You can also use the AutoCAD® Ortho mode to restrict the cursor movement to the horizontal or vertical axes. The orthogonal alignment depends on the current grid and snap settings. You can turn these tools on or off at any time.

To add schematic lines in orthographic mode

1. In the Schematic workspace, start the add command by doing one of the following:
   - Open a schematic tool palette, and select a schematic line tool.
     If necessary, scroll to display the tool. Because tools contain pre-configured properties for the objects they create, you might not need or be able to specify some of the schematic line properties referenced in this procedure.
   - Click Home tab ➤ Build panel ➤ Schematic Line.
   - Enter slineadd.
NOTE  On the Properties palette, *indicates a property is available only when you are adding schematic lines, not when you are modifying them.

2 Expand Basic, and for Description, click, enter a description for the schematic line, and click OK.

3 For Style, select a schematic line style.
   You can select from the styles in the current drawing.

4 If you want to change the current system, for System, select the system to which the schematic line belongs.
   You can select from the systems in the current drawing. For more information on systems, see Creating Schematic System Definitions on page 521.

   TIP  You can create schematic line tools that reference styles and systems in content libraries (DWG files). For more information, see Creating Tools for Style-Based Content on page 790.

5 For Orientation, select Ortho.

6 Expand Advanced, and for ID, select or enter an ID designation.
   The currently selected schematic line style determines the list of available IDs. For more information, see Defining Designations for Schematic Line Styles on page 522.

7 In the drawing, specify the start point for the line, or use schematic AutoCAD MEP snaps to connect the line to a symbol or another line.

8 Continue to specify points to draw the schematic line.

9 If necessary, on the Properties palette, modify the schematic line properties, and add additional lines.

10 Press ENTER to end the add command.

   TIP  You can quickly connect existing schematic lines by extending or trimming them using the AutoCAD command FILLET.
Adding Schematic Symbols in Orthographic Mode

When you are drawing in orthographic mode, you add schematic symbols in the world coordinate system (WCS). In the WCS, the X axis is horizontal, the Y axis is vertical, and the Z axis is perpendicular to the XY plane.

You can use the compass to guide your placement of symbols. You can also use the AutoCAD® Ortho mode to restrict the cursor movement to the horizontal or vertical axes. The orthogonal alignment depends on the current grid and snap settings. You can turn these tools on or off at any time.

Schematic symbols are connected to lines with anchors. For more information, see Schematic Symbols on page 519.

To add schematic symbols in orthographic mode

1 In the Schematic workspace, start the add command by doing one of the following:
   ■ Open a schematic tool palette, and select a schematic symbol tool.
      If necessary, scroll to display the tool. Because tools contain pre-configured properties for the objects they create, you might not need or be able to specify some of the schematic symbol properties referenced in this procedure.
   ■ Select a schematic line, and click Schematic Line tab ➤ General panel ➤ Insert Symbol 🍃.
   ■ Click Home tab ➤ Build panel ➤ Schematic Symbol 🍃.
   ■ Enter symboladd.

NOTE On the Properties palette, 🍃 indicates a property is available only when you are adding schematic symbols, not when you are modifying them.
2 On the Properties palette, if necessary, specify or change the symbol to add by selecting a schematic symbol style:

<table>
<thead>
<tr>
<th>If you want to select a schematic symbol style...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>in the current drawing</td>
<td>expand Basic, and expand General. For Style, select the style.</td>
</tr>
<tr>
<td>in a drawing in the directory specified as the default content location for schematic symbols, or in the style drawing referenced in the properties of a tool you selected</td>
<td>on the General bar, click [button]. In the left pane of the Select Schematic Symbol worksheet, navigate to the drawing that contains the style, and select the drawing. In the right pane, select the style, and click OK.</td>
</tr>
</tbody>
</table>

3 For Description, click \[button\], enter a description for the schematic symbol, and click OK.

4 For System, select the system to which the schematic symbol belongs.
   
   You can select from the systems in the current drawing. For more information on systems, see Creating Schematic System Definitions on page 521.

5 If Orientation is enabled under Drawing Mode, select Ortho.

   **NOTE** If the style you selected does not have any defined isometric views, Orientation is read-only and set to Ortho. For information on creating views for styles, see Defining the Views of a Style on page 604.

6 For Justification, select the point on the symbol to use as the insertion point.
   
   You can select either the insertion point of the view block that represents the symbol, or one of 9 other points on the device, such as Top Left or Middle Center.

7 Expand Advanced, and for ID, enter the ID to use to identify this symbol.
   
   You can add the ID to your diagram as a label. The label style that you select when you add the label determines the font and size of the ID.

8 In the drawing, click to specify the insertion point.
   
   If you specify a point on a schematic line, the symbol breaks into and aligns with the line. It then behaves like an in-line symbol.

   **TIP** Use object snaps, such as Nearest or Midpoint, to help place schematic symbols.

9 Rotate the symbol into position, or enter the angle of rotation on the command line.
   
   Alternatively, to accept the default rotation, press ENTER.

   **NOTE** The rotation is applied only to end-of-line symbols. The rotation of an in-line symbol is determined by the schematic line into which it is inserted.

10 Repeat the previous 2 steps to insert additional symbols with the same properties.
   
   You can also modify the properties on the palette, and then add additional symbols.

11 Press ENTER to end the add command.

**Adding Schematic Lines in Isometric Mode**

When you are drawing in isometric mode, you add schematic lines on one of the 3 isometric planes: left, top, or right. Each isometric plane has an associated pair of axes. Choosing an isometric plane causes the
AutoCAD® Ortho mode and the crosshairs to be aligned along the corresponding isometric axes in the world coordinate system (WCS). Working in isometric mode is beneficial, for example, when creating electrical riser diagrams.

As you draw, you can switch between planes by selecting a different value for Isoplane on the Properties palette. Switching between planes enables you to draw a continuous isometric run, where segments are drafted both horizontally and vertically along the different isoplanes. For example, you might draw one segment on the top plane, switch to the left plane to draw a riser, and then switch to the right plane to complete the run.

**Drawing a schematic line on the left isoplane**

![Image of a schematic line on the left isoplane]

**Drawing a schematic line on the top isometric plane**

![Image of a schematic line on the top isometric plane]

**Drawing a schematic line on the right isometric plane**

![Image of a schematic line on the right isometric plane]

**To add schematic lines in isometric mode**

1. In the Schematic workspace, start the add command by doing one of the following:
   - Open a schematic tool palette, and select a schematic line tool. If necessary, scroll to display the tool. Because tools contain preconfigured properties for the objects they create, you might not need or be able to specify some of the schematic line properties referenced in this procedure.
   - Click Home tab ➤ Build panel ➤ Schematic Line
   - Enter `slineadd`.

NOTE On the Properties palette, indicates a property is available only when you are adding schematic lines, not when you are modifying them.
2 Expand Basic, and for Description, click , enter a description for the schematic line, and click OK.

3 For Style, select a schematic line style. You can select from the styles in the current drawing.

4 For System, select the system to which the schematic line belongs. You can select from the systems in the current drawing. For more information on systems, see Creating Schematic System Definitions on page 521.

TIP You can create schematic line tools that reference styles and systems in content libraries (DWG files). For more information, see Creating Tools for Style-Based Content on page 790.

5 For Orientation, select Isometric.

6 For Isoplane, select the isoplane on which to start drawing: Left, Top, or Right.

7 Expand Advanced, and for ID, select or enter an identification label.

The schematic line style that you select determines the list of available IDs. You can select an ID from the list or enter a different one. For more information, see Defining Designations for Schematic Line Styles on page 522.

8 In the drawing, specify the start point for the line, or use schematic AutoCAD MEP snaps to connect the line to a symbol or another line.

9 Continue to specify points to draw the schematic line.

10 To change isoplanes as you draw, on the Properties palette, select a different isoplane for Isoplane, and then continue to specify points to draw the line.

The UCS icon and crosshairs adjust to the selected isoplane.

11 If necessary, on the Properties palette, modify the schematic line properties and add additional lines.

12 Press ENTER to end the add command.

TIP You can quickly connect existing schematic lines by extending or trimming them using the AutoCAD FILLET command.
Adding Schematic Symbols in Isometric Mode

When you are drawing in isometric mode, you add schematic symbols on one of the 3 isometric planes: left, top, or right. Each isometric plane has an associated pair of axes. Choosing an isometric plane causes the AutoCAD® Ortho mode and the crosshairs to be aligned along the corresponding isometric axes in the world coordinate system (WCS). Working in isometric mode is beneficial, for example, when creating electrical riser diagrams.

As you draw, you can switch between planes by selecting a different value for Isoplane on the Properties palette. Switching between planes enables you to continuously add end-of-line or in-line symbols on the different isoplanes. For example, you might add one symbol on a line on the top plane, switch to the left plane to add a symbol on a riser, and then switch to the right plane to add an end-of-line symbol to complete the run.

Adding Schematic Symbols in Isometric Mode

Adding a schematic symbol to the left isoplane

Adding a schematic symbol to the top isoplane

Adding a schematic symbol to the right isoplane

Schematic symbols are connected to lines with anchors. For more information, see Schematic Symbols on page 519.

To add schematic symbols in isometric mode

1 In the Schematic workspace, start the add command by doing one of the following:
   - Open a schematic tool palette, and select a schematic symbol tool.
     If necessary, scroll to display the tool. Because tools contain preconfigured properties for the objects they create, you might not need or be able to specify some of the schematic symbol properties referenced in this procedure.
Select a schematic line and click Schematic Line tab ➤ General panel ➤ Insert Symbol.

Click Home tab ➤ Build panel ➤ Schematic Symbol.

Enter symboladd.

NOTE On the Properties palette, * indicates a property is available only when you are adding schematic symbols, not when you are modifying them.

2 On the Properties palette, if necessary, specify or change the symbol to add by selecting a schematic symbol style:

If you want to select a schematic symbol style… then…

in the current drawing expand Basic, and expand General. For Style, select the style.

in a drawing in the directory specified as the default content location for schematic symbols, or in the style drawing referenced in the properties of a tool you selected on the General bar, click . In the left pane of the Select Schematic Symbol worksheet, navigate to the drawing that contains the style, and select the drawing. In the right pane, select the style, and click OK.

NOTE Not all schematic symbols provided with the software have isometric views. Drawings containing symbols with both orthographic and isometric views are named accordingly.

3 For Description, click , enter a description for the schematic symbol, and click OK.

4 For System, select the system to which the schematic symbol belongs.

For more information on systems, see Creating Schematic System Definitions on page 521 and Working with Systems on page 93.
5 For Orientation, select Isometric, and for Isoplane, select the isoplane onto which to place the symbol.

**NOTE** If the style you selected does not have any defined isometric views, Orientation is read-only and set to Ortho. If this is the case, select a different style. For information on creating views for styles, see Defining the Views of a Style on page 604.

6 For Justification, select the point on the symbol to use as the insertion point.

You can select either the insertion point of the view block that represents the symbol, or one of 9 other points on the device, such as Top Left or Middle Center.

7 Expand Advanced, and for ID, enter the ID to use to identify this symbol.

You can add the ID to your diagram as a label. The label style that you select when you add the label determines the font and size of the ID.

8 In the drawing, click to specify the insertion point, which typically is a point on a schematic line.

If you specify a point on a line, the symbol breaks into and aligns with the line. It then behaves like an in-line symbol.

**TIP** Use object snaps, such as Nearest or Midpoint, to help place schematic symbols.

9 Rotate the symbol into position by doing one of the following:

- In the drawing, use the compass to rotate the symbol.
- On the command line, enter the angle of rotation, and press ENTER.
- Enter `is` (iso rotation), enter the orientation of the symbol within the isoplane (right, up, left, or down), and press ENTER.

Alternatively, you can press ENTER to accept the default rotation.

**NOTE** The rotation is applied only to end-of-line symbols. The rotation of an in-line symbol is determined by the line into which it is inserted.

10 Repeat the previous 2 steps to insert additional symbols with the same properties.

11 To change isoplanes as you draw, on the Properties palette, select a different isoplane for Isoplane, and then continue to add symbols.

The UCS icon and crosshairs adjust to the selected isoplane.

12 If necessary, on the Properties palette, modify the schematic symbol properties, and add additional symbols.

13 Press ENTER to end the add command.
Adding Schematic Lines Using Grips

Use the add grips on existing schematic lines or symbols to quickly and efficiently add schematic lines. The add grips are available in orthographic or isometric mode.

To add schematic lines using the add grip

1. Select a schematic line or symbol, and click the (+) Add grip.
2. Specify additional points for the schematic line layout geometry.
3. Press ENTER to end the command.

Creating a Schematic Line from an AutoCAD Line, Arc, or Polyline

You can create a schematic line from an AutoCAD® line, arc, or polyline.

To create a schematic line

1. Draw an AutoCAD line, arc, or polyline.
2. Right-click the object to convert, and click Convert to ➤ Schematic Line.
3. Do one of the following:
   - Press ENTER or enter n (no) to leave the layout geometry in the drawing.
   - Enter y (yes) to erase the layout geometry from the drawing.
   - The software displays the Modify Schematic Lines dialog.
4. In the Modify Schematic Lines dialog, specify a System, Style, and Designation ID.
   - You can also specify these properties on the command line. Enter sy (system), enter st (style), or enter i (designation ID).

TIP To assign the properties of an existing schematic line to the converted schematic line, enter m (match), select an existing schematic line, specify what properties to match, and then press ENTER.

Modifying a Schematic Diagram

After you add schematic lines and symbols to your drawing, you can edit their properties and make additional modifications. For example, you can move a schematic line or symbol, or assign the line or symbol to a different system.
**Associative Movement**

You can move schematic symbols or line segments without breaking their connections with the rest of the geometry. This feature is called associative movement. Used in conjunction with certain grips, associative movement enables you to move a schematic run component quickly and accurately.

For example, when you move a schematic symbol to a new location, the line segments attached to the symbol can move, shrink, or stretch to maintain a connection with the schematic layout. You can also move a schematic line segment without affecting the location of schematic symbols or other segments of the run.

**Selecting Components**

You must select a component in order to modify it. There are several ways you can select one or more components in a drawing:

- Move the cursor over an object, and click to select it.
- Drag the cursor from left to right to select only objects that are entirely enclosed by the rectangular area.
- Drag the cursor from right to left to select objects that are entirely or partially enclosed by the rectangular area.
- Select an object and click [Schematic Line or Schematic Symbol] tab ➤ General panel ➤ Select System drop-down ➤ Select Similar . This command selects all objects in the drawing that have the same part subtype, size, and system as the selected object.
- Select an object, and click [Schematic Line or Schematic Symbol] tab ➤ General panel ➤ Select System drop-down ➤ Select Connected Branches . This command selects all components of a schematic run, or a portion of the schematic run.
- Select a group of objects, and use the Properties palette to modify settings for a particular system.
- Select a group of objects, and use the Properties palette Quick Select filter to refine the selection set to objects with a common property.

For more information on selecting objects, see "Select Multiple Objects" in the AutoCAD® Help.

**To select connected branches**

1. Select a schematic line or fitting.
   - In this example, the Select Connected Branches command is used to select a schematic run.
2. Click [Schematic Line or Schematic Symbol] tab ➤ General panel ➤ Select System drop-down ➤ Select Connected Branches .
3. Press Tab to cycle through the connection previews.
4. When the desired branch is highlighted, press ENTER.
5. Repeat the previous steps to select other branches, even if they are not connected to the original schematic system.
6. Press ENTER to select the branches.

**To filter selections by system**

1. Select multiple objects.
2. On the Design tab of the Properties palette, select the system from the drop-down list.
To filter selections by part properties

1 Select multiple objects.
2 On the Properties palette, click Quick Select.
3 In the Quick Select dialog, specify the filter properties. For example:
   - For Object type, select a Schematic.
   - For Properties, select SystemType.
   - For Operator, select =Equals.
   - For Value, enter acebSystemTypeColdWater.
4 In the How to apply section, select Include in new selection set.
5 If you want to append the results of the Quick Select to the current selection set, select Append to current selection set.

To deselect objects, press ESC.

Modifying the Properties of a Schematic Line

You modify the properties of schematic lines using the Properties palette. For general information on modifying object properties using the palette, see Modifying Object Properties Using the Properties Palette on page 91.

To modify the properties of schematic lines

1 Select the schematic lines.
2 On the Design tab of the Properties palette, modify the properties:

<table>
<thead>
<tr>
<th>If you want to modify…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>the description</td>
<td>expand Basic ➤ General. For Description, click to revise the description, and click OK.</td>
</tr>
<tr>
<td>the layer on which the schematic lines are placed</td>
<td>for Layer, select a layer. You can select from the layers in the current drawing.</td>
</tr>
<tr>
<td>the style</td>
<td>for Style, select a style. You can select from the styles in the current drawing.</td>
</tr>
<tr>
<td>the system</td>
<td>expand System, and for System, select a new system. You can select from the schematic system definitions in the current drawing.</td>
</tr>
<tr>
<td>the location</td>
<td>click Additional information, enter the new coordinates for the insertion point on the Location worksheet, and click OK.</td>
</tr>
</tbody>
</table>

   **NOTE** You can also move schematic lines using grips or the AutoCAD® MOVE command. For more information, see Moving Schematic Lines on page 538.
   
   | the ID                  | expand Advanced ➤ Design Data. For ID, enter an ID. The selected style determines the list of available IDs. For information on defining IDs for schematic line styles, see Defining Designations for Schematic Line Styles on page 522. |
Press ESC.

## Modifying the Properties of a Schematic Symbol

You modify the properties of schematic symbols using the Properties palette. For general information, see [Modifying Object Properties Using the Properties Palette](#) on page 91.

**RELATED** See also [Moving Schematic Symbols](#) on page 540 and [Rotating Schematic Symbols](#) on page 542.

### To modify the properties of schematic symbols

1. Select the schematic symbols.
2. If you want to change the style of the symbol, on the Properties palette, select a symbol style by doing one of the following:

<table>
<thead>
<tr>
<th>If you want to select a style...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>in the current drawing</td>
<td>expand Basic ➤ General. For Style, select the style.</td>
</tr>
<tr>
<td>in a drawing in the directory specified as the default content location for schematic symbols</td>
<td>under General, click ![folder]. In the left pane of the Select Schematic Symbol worksheet, navigate to the drawing that contains the style, and select the drawing. In the right pane, select the style, and click OK.</td>
</tr>
</tbody>
</table>

3. Modify additional properties as needed:

<table>
<thead>
<tr>
<th>If you want to modify...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>the description</td>
<td>for Description, click ![pencil] to revise the description, and click OK.</td>
</tr>
<tr>
<td>the layer on which the schematic symbols are placed</td>
<td>for Layer, select a layer. You can select from the layers in the current drawing.</td>
</tr>
<tr>
<td>the system</td>
<td>expand System, and for System, select a new system. You can select from the <a href="#">schematic system definitions</a> in the current drawing.</td>
</tr>
<tr>
<td>the orientation</td>
<td>expand Drawing Mode, and for Orientation, select Ortho or Isometric.</td>
</tr>
<tr>
<td>the isoplane (for isometric symbols only)</td>
<td>expand Drawing Mode, and for Isoplane, select an isoplane (isometric plane): Left, Top, or Right.</td>
</tr>
</tbody>
</table>

**NOTE** You can also use grips to rotate the symbol around the 3 isoplanes; for more information, see [Rotating Isometric Symbols](#) on page 542.

| the rotation (for orthographic, end-of-line symbols only) | expand Location, and for Rotation, enter the number of degrees. |

**NOTE** For information on rotating symbols, including in-line symbols, in other ways, see **Rotating Schematic Symbols** on page 542.
If you want to modify... then...
the location (for end-of-line symbols only) click Additional information, enter new coordinates for the insertion point on the Location worksheet, and click OK.

NOTE You can also move both end-of-line symbols and in-line symbols using Location grips. For more information, see Moving Schematic Symbols on page 540.

the ID expand Advanced, expand Design Data, and for ID, revise the value for ID.

4 Press ESC.

**Moving Schematic Lines**

You can move a schematic line by

- Selecting a grip and dragging it to a new location
- Using the AutoCAD® MOVE command
- Entering new coordinate values for the insertion point of the line using the Properties palette. You can also use the palette to change the normal or the angle of rotation, as described later in this section.

When you move a schematic line, in-line schematic symbols that are anchored to the line are moved along the line.

**To move a schematic line in orthographic mode using grips**

1 Select the line.
2 Click the Location grip .
3 Move the line:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>use the grip point as the base point for the move</td>
<td>drag the line to a new location, and click.</td>
</tr>
<tr>
<td>specify a base point, and then specify a second point</td>
<td>enter b (base point), specify the base point, and then specify the second point.</td>
</tr>
</tbody>
</table>

If the schematic line segment is not connected to another object, you can change both its length and angle using the Start grip or End grip. The Start grip and End grip only appear on the schematic line in orthographic mode.

The Start and End grips enable you to change the XYZ location of the start point or end point of the segment. This is useful when you are initially designing runs because you can easily connect a segment to an existing run.
To move a schematic line in isometric mode using grips

In isometric mode, the Move Isoplane grip will move the schematic line in the direction which is perpendicular to the plane in which the schematic line lies.

1 Select the line.

2 Click the Move Isoplane grip.

3 Move the line:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>use the grip point as the base point for the move</td>
<td>drag the line to a new location, and click.</td>
</tr>
<tr>
<td>specify a base point, and then specify a second point</td>
<td>enter b (base point), specify the base point, and then specify the second point.</td>
</tr>
</tbody>
</table>

To move or rotate a schematic line using coordinate values

A schematic line has an orientation with respect to the world coordinate system (WCS) or the current user coordinate system (UCS). For example, if the schematic line is parallel to the XY plane, then its normal, or perpendicular, plane is parallel to the Z axis. You can change the orientation of the schematic line by aligning its normal with another axis, such as an isometric axis. You can also rotate the schematic line on its plane by changing the rotation angle.

1 Select the schematic line.

2 On the Properties palette, expand Basic. Under Location, click Additional information for the Location worksheet.

3 Specify the new location for the schematic line:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>relocate the schematic line</td>
<td>enter new coordinate values under Insertion Point.</td>
</tr>
<tr>
<td>locate the schematic line on the XY plane</td>
<td>make the normal of the schematic line parallel to the Z axis: under Normal, enter 1 for Z, and enter 0 for X and Y.</td>
</tr>
<tr>
<td>locate the schematic line on the YZ plane</td>
<td>make the normal of the schematic line parallel to the X axis: under Normal, enter 1 for X, and enter 0 for Y and Z.</td>
</tr>
<tr>
<td>locate the schematic line on the XZ plane</td>
<td>make the normal of the schematic line parallel to the Y axis: under Normal, enter 1 for Y, and enter 0 for X and Z.</td>
</tr>
</tbody>
</table>
If you want to...  then...

change the rotation of the schematic line  under Rotation, enter a new value for Angle.

4 Click OK, and press ESC.

For information about the WCS and the UCS, see “Use Coordinates and Coordinate Systems” in the AutoCAD® Help.

**Moving Schematic Symbols**

You can use grips to move orthographic and isometric schematic symbols along schematic lines and drawings. You can also use the AutoCAD® MOVE command for moving symbols not anchored to schematic lines.

**To move a schematic symbol in orthographic mode**

1 Select the symbol.
2 Click the Location grip .
3 Move the symbol:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>use the grip point as the base point for the move</td>
<td>drag the symbol to a new location, and click.</td>
</tr>
<tr>
<td>specify a base point, and then specify a second point</td>
<td>enter b (base point), specify the base point, and then specify the second point.</td>
</tr>
</tbody>
</table>

4 Press ESC.

**To move a schematic symbol in isometric mode**

In isometric mode, the Move Isoplane grip will move the schematic symbol in the direction which is perpendicular to the plane in which the schematic symbol lies.

1 Select the symbol.
2 Click the Move Isoplane grip .
3 Move the line:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>use the grip point as the base point for the move</td>
<td>drag the line to a new location, and click.</td>
</tr>
<tr>
<td>specify a base point, and then specify a second point</td>
<td>enter b (base point), specify the base point, and then specify the second point.</td>
</tr>
</tbody>
</table>

4 Press ESC.

**NOTE** You can also move end-of-line symbols by specifying a new insertion point on the Location worksheet. To access the worksheet, select the symbol, and click under Location on the Properties palette.
Modifying the Length of Schematic Lines

You can modify the length of schematic line segments using lengthen grips. Because the grips constrain a segment to its current angle, they are particularly useful for modifying the length of schematic line segments you have already placed.

When you use the lengthen grip on an end that is connected to another object, you must specify whether you want AutoCAD MEP to maintain connectivity between the objects.

Unconnected schematic line segment

Connected schematic line segment

To modify the length of a schematic line segment

1. Select the schematic line segment.
2. Click the Lengthen grip on the end you want to modify.
3. If the segment is connected to an object on the end you selected, specify whether and how to maintain connectivity:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>maintain connectivity by adjusting only schematic</td>
<td>proceed to the next step.</td>
</tr>
<tr>
<td>fittings and segments, and retain the current</td>
<td></td>
</tr>
<tr>
<td>locations of parts</td>
<td></td>
</tr>
<tr>
<td>maintain connectivity by adjusting all objects,</td>
<td>press Ctrl.</td>
</tr>
<tr>
<td>including parts</td>
<td></td>
</tr>
<tr>
<td>break connectivity</td>
<td>press Ctrl.</td>
</tr>
</tbody>
</table>

4. Specify the segment length:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>specify the new total length</td>
<td>press Tab to activate the input field for specifying the resulting</td>
</tr>
<tr>
<td></td>
<td>dimension, and then enter the new length.</td>
</tr>
<tr>
<td>specify the difference between the current length</td>
<td>drag the cursor to begin lengthening or shortening the segment, and</td>
</tr>
<tr>
<td>and new length</td>
<td>then enter the change in length in the input field that is active by</td>
</tr>
<tr>
<td></td>
<td>default.</td>
</tr>
<tr>
<td>specify a new end point</td>
<td>drag the grip to the desired end point location, and click to specify</td>
</tr>
<tr>
<td></td>
<td>the point.</td>
</tr>
</tbody>
</table>
NOTE To use the dimension input fields, both dynamic input (on the status bar) and the Dimension Input drafting option must be selected, which is the default setting. If you have deselected them, you can specify the new length by moving the cursor to a stretch point in the drawing or by entering the coordinates in the command window.

Rotating Schematic Symbols

You can rotate schematic symbols after you have placed them.

Rotating Orthographic Symbols

You can use the Rotate (Flip) grip to rotate schematic symbols 180 degrees in the direction indicated by the grip.

When you rotate a schematic symbol that is connected to other objects, the software adjusts the connected objects to maintain their connectivity. For example, the software might make minor adjustments to the lengths of connected schematic line segments after you have flipped a symbol. If it cannot adjust the objects, it disconnects them.

NOTE

When you add an in-line orthographic symbol, the rotation applied to the symbol is determined by the schematic line into which it is inserted. Because the symbol is attached to the line with a curve anchor, you can rotate the symbol by rotating the curve anchor, using the Curve Anchor commands on the context menu. For more information, see Rotating Objects Attached with Curve Anchors on page 110.

You can also rotate the symbol using the Properties palette if you release the anchor first. However, this method requires that you break the relationship between the symbol and the line. You can restore the relationship by reattaching the symbol with a curve anchor, as described in Attaching Objects with a Curve Anchor on page 109. To rotate an orthographic symbol using the Properties palette, first select the symbol. On the Properties palette, expand Basic, and expand Location. For Rotation, enter the number of degrees and press ESC.

Rotating Isometric Symbols

Isometric schematic symbols have 2 types of rotation grips:

- Rotate grips: Use these grips to rotate a symbol in its current isometric plane (isoplane).
- Isometric plane grips: Use these grips to rotate a symbol around the 3 isoplanes: left, top, and right.
NOTE Because schematic symbols are attached to schematic lines using curve anchors, you can also rotate symbols using the Curve Anchor commands on the context menu. For more information, see Rotating Objects Attached with Curve Anchors on page 110.

To rotate an isometric schematic symbol

1. Select the symbol.
2. Rotate the symbol:
   - If you want to... then...
     - rotate the symbol, in its current isoplane, in 90-degree increments around its base point click a Rotation grip as many times as needed.
     - change the isoplane (left, top, and right) of the symbol click the Isometric plane grip as many times as needed.

3. Press ESC.

Rotating a symbol in its current isoplane

In the top isoplane, before rotation

In the top isoplane, after 180 degree rotation
Rotating a symbol around the 3 isoplanes
In the left isoplane, before isometric plane rotation

In the top isoplane, after isometric plane rotation

Resizing Schematic Symbols

Use these procedures to change the size of a schematic symbol by scaling the symbol with the AutoCAD® SCALE command. The schematic symbol has a scale factor with respect to your annotation and drawing scale. You can scale an instance of a schematic symbol by a user-defined scale factor, by referencing a specified size, or by using grips and stretching the symbol to the desired size.

NOTE To change the default scale factor of a schematic symbol, modify the schematic symbol style. For more information, see Defining the Views of a Style on page 604.

Resizing by Scale Factor

There are 2 ways to resize a schematic symbol using a scale factor. You can specify a base point and a length, which are used as the scale factor based on the current drawing units. You can also enter a scale factor directly.

Resizing a schematic symbol by using a scale factor changes the dimensions of the selected symbol but does not alter the symbol’s aspect ratio. A scale factor greater than one enlarges the symbol. A scale factor less than one shrinks the symbol.

As an example, in the following procedure you decrease the size of a schematic symbol by half, scaling it by a factor of 0.5. The numbers enclosed in parentheses refer to the illustration that follows the procedure.

To resize a schematic symbol by a scale factor

1 Select the object to scale (1), and click Home tab ➤ Modify panel ➤ Scale.
2 Specify the base point (2).
3 Enter .5 for the scale factor and press ENTER.
   The selected object is resized appropriately (3).
Resizing a schematic symbol by scale factor

You can resize a schematic symbol by reference. When you resize by reference, you specify the current length of a symbol as a reference for the new length. For example, if one side of a schematic symbol is 2.5 units long, and you want to expand it to 3.5 units, use 2.5 as the reference length and 3.5 as the new length. You can also scale by specifying a base point and 2 reference points and dragging the symbol.

As an example, in the following procedure you increase the size of a schematic symbol by specifying the reference length and 2 reference points, and then dragging the symbol to specify the new length. The numbers enclosed in parentheses refer to the illustration that follows the procedure.

To resize a schematic symbol by reference

1. Select the object to scale (1), and click Home tab ➤ Modify panel ➤ Scale.
2. Specify the base point (2).
3. Enter $r$ (reference).
4. Specify the first reference point (3).
   
   **NOTE** You can also enter a value for the reference length. If you enter a value, skip to step 6.

5. Specify the second reference point (4).
6. Drag the symbol and specify a point (5).
   
   **NOTE** You can also enter a value for the new length.

The selected symbol is resized appropriately.

Resizing Using Grips

Schematic symbols can be converted to blocks, by using the BLOCK command, or by using Copy and then Paste as Block. When selected as blocks, they have a single grip at the insertion point that displays as an empty blue box. To scale the symbol, select the blue box at the insertion point as the base grip (base point), select Scale grip mode, and then move the cursor to resize the symbol.
As an example, in the following procedure you decrease the size of a schematic symbol using the Scale grip mode by dragging the symbol to specify a new size. The numbers enclosed in parentheses refer to the illustration that follows the procedure.

**To resize a schematic symbol using grips**

1. Select a schematic symbol (1).
   
   The software displays a single grip as an empty blue box at the symbol’s insertion point.

2. Select the empty blue box at the symbol’s insertion point to change it to a red solid box (2).

   **NOTE** The selected grip is used as the base point for scaling.

3. Select the Scale grip mode by doing one of the following:
   
   - Enter `sc` (scale).
   - Cycle through the grip modes by pressing the `SPACEBAR` or `ENTER` key, and select Scale.

4. Move the cursor to reduce the size of the object, and then click to specify the new size (3).

   The object is scaled appropriately (4).

**Resizing a schematic symbol using grips**

![Diagram of schematic symbol resizing](image)

**NOTE** For more information, see “Grips” under system variables in the AutoCAD® Help.
This section explains how to create construction documents using the tools in AutoCAD MEP.

**Construction Document Workflow**

It is recommended that project drawings are created, stored, and managed using the drawing management tools in AutoCAD MEP. When you use Project Navigator to manage drawings, you can efficiently create construction documents that reference the building system drawings.

After you create a project, you can manage drawings from a central location. For more information, see *Working with Drawing Management Projects* on page 129.

A typical workflow for creating documents with AutoCAD MEP is as follows:

1. **Create a construct**
   - Save your drawing as a construct on the Constructs tab in Project Navigator. See *Creating Construction Documents* on page 548

2. **Create views**
   - Create views for drawings and schedules to be included in sheets. See *Views* on page 568

3. **Create sheets**
   - Create sheet drawings for publishing and plotting. Place view drawings on the appropriate sheets. See *Creating a Sheet* on page 576
Creating Construction Documents

AutoCAD MEP includes many features to create and maintain construction documents. You can use drawing management tools such as Project Browser and Project Navigator to create and manage project drawings. By using external reference capabilities, you can create models of systems, and then create construction documents referencing different views and equipment in the model. If you change the model, you can apply the changes automatically to the construction documents.

TIP For hands-on practice at creating construction documents, complete a discipline-specific tutorial provided with the software.

Annotation

You can annotate your drawings with the tools available in AutoCAD MEP. Annotation can be categorized as follows:

- Object labels, general text, and dimensions
- Annotation symbols
- Tags and schedules
- View and detail marks

Labels and documentation symbols are the primary annotation types for drawings. To display object information such as system name, size, and dimensions, use labels. To add information such as leaders, break marks, title marks, and revision clouds, use annotation symbols from the symbol libraries in DesignCenter™.

Tags are used to mark equipment for scheduling. When a schedule is added to a drawing, it can automatically display property set data for tagged parts. If you modify tagged equipment, you can automatically update the schedule to reflect the changes.

Section, elevation, and detail views can display discrete parts of a building plan. You can generate these views automatically from the system model. If you modify the system model in its construct drawing, you can automatically update detail, section, or elevation views to reflect the changes.
Scaling Annotation

The annotation scale of a viewport allows you to plot annotation at the same height or size regardless of the viewport scale. You can specify an annotation scale for model space and for each viewport in paper space. This means you can use different scales for the viewports in a layout (for example, one for a plan view and one for a detail view), and the annotation will scale and plot at the correct size.

Annotative objects are scaled according to the current annotation scale if they have a corresponding scale representation. If they do not, they are scaled according to the annotation scale in which they were created. Annotative components in other, non-annotative AutoCAD MEP objects are always scaled according to the current annotation scale. For information on when an object or component is considered annotative, see Annotative Objects on page 549.

Annotative Objects

Annotative objects are defined as objects that participate in annotation scaling; that is, they scale accordingly when the annotation scale changes. You can identify whether an object is annotative by doing either of the following:

- Select the object, enter list, and view the value for Annotative in the dialog
- Move the cursor over the object. An icon ( ) is displayed if the object is annotative. (Multiple shapes indicate the object supports multiple scale representations.)

An AutoCAD MEP drawing might include

- AutoCAD MEP objects that are annotative
- AutoCAD MEP objects that are not annotative but have annotative components
- AutoCAD and AutoCAD Architecture objects that are annotative

Annotative AutoCAD MEP Objects

In AutoCAD MEP, labels are annotative objects if the corresponding label curve style is configured to be annotative. You configure a label curve style to be annotative in one of 2 ways depending on the type of style.

If the label curve style uses block graphics or flow arrow graphics, and Use Annotation Scale for Block is selected in the style, then the style is considered annotative. (As a convenience, this is selected by default when you select a block whose Annotative property is set to Yes, but you can deselect it.)
Example block-based label curve style

If the label curve style uses a text style, then the configuration of the text style determines whether the label curve style is considered annotative.

Example text-based label curve style

The following table describes how labels are scaled based on the configuration of the text style that is used by a label curve style.

<table>
<thead>
<tr>
<th>If the Annotative property is ...</th>
<th>And the value for Paper Text Height (or Height) is ...</th>
<th>Then labels of the style are scaled to ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>selected or cleared</td>
<td>zero</td>
<td>the annotation plot size (specified in the Drawing Setup dialog) multiplied by the current annotation scale.</td>
</tr>
<tr>
<td>selected</td>
<td>greater than zero</td>
<td>the value specified for Paper Text Height multiplied by the current annotation scale.</td>
</tr>
<tr>
<td>cleared</td>
<td>greater than zero</td>
<td>the value specified for Height.</td>
</tr>
</tbody>
</table>

NOTE When the text style is configured in this way, the label curve style is not considered annotative.

When you modify a label curve style to make it annotative or non-annotative (using the methods described above for block-based styles and text-based styles), all labels using the style are updated accordingly in the
drawing. In the case of a block-based style, you cannot make the style annotative or non-annotative by modifying the Annotative property in the underlying block definition.

**NOTE** Schedules are not considered annotative. Therefore, they do not scale accordingly when the annotation scale changes. When you insert a schedule into a drawing, it uses the annotation scale that is current at the time of insertion, and its scale does not subsequently change.

**AutoCAD MEP Objects with Annotative Components**

Some AutoCAD MEP objects are not annotative, but they have components that are (or can be) annotative. The following table lists these components.

**Domain** | **Annotative Components of AutoCAD MEP Objects**
--- | ---
All | ■ Rise symbols and drop symbols
■ View blocks of MvParts if Use Annotation Scale is selected in the corresponding MvPart style definition. You select this on a per-view basis on the Views tab in Style Manager.

**HVAC** | ■ Flow markers
■ Annotation pattern on flexible ducts
■ Flow arrows on air terminals if Use Annotation Scale for Block is selected in the MvPart properties. You select this on the Flow tab in the Multi-view Part Properties dialog.

**Piping** | ■ Flow markers
■ Annotation pattern on flexible pipes
■ Placeholder pipe
■ In Graphical 1-Line: rise symbols, drop symbols, in-line/anchored MvParts, and reducers

**Electrical** | ■ Home runs, tick marks, and gaps on wires
■ Pattern on cable trays
■ View blocks of devices and panels if Use Annotation Scale is selected in the corresponding device style or panel style. You select this on a per-view basis on the Views tab in Style Manager.

**Plumbing** | ■ Plumbing fittings

**NOTE** Plumbing fittings are always scaled according to the current annotation scale in model space.
■ Gaps on plumbing lines

**Schematic** | ■ Schematic symbols

**NOTE** Schematic symbols are always scaled according to the current annotation scale in model space.
■ Start symbols, end symbols, connections symbols, and gaps on schematic lines
Domain: Annotative Components of AutoCAD MEP Objects

TIP You can use the conversion tools provided with the software to update large numbers of schematic symbols to be annotative. For more information, see Customizing Schematic Symbol Content on page 630.

The Hatch display component is not an annotative component of an object. Therefore, it does not scale accordingly when the annotation scale changes.

IMPORTANT Objects with annotative components that are block-based (for example, flow arrows on air terminals, and view blocks for devices) are considered annotative based on whether Use Annotation Scale (for Block) is selected. The Annotative property in the associated block definition has no bearing on whether the object is annotative.

Other Annotative Objects

The following AutoCAD Architecture objects can be annotative depending on their configuration:

- Multi-view Blocks (MvBlocks)
- AEC dimensions

For more information, see Annotation Scaling in the AutoCAD Architecture Help.

The following AutoCAD objects can be annotative depending on their configuration:

- Text
- MText
- Dimensions
- Leaders
- Blocks
- Hatching
- Linetypes
  If the MSLTSCALE system variable is set to 1, linetypes displayed in model space are scaled according to the annotation scale. If the PSLTSCALE system variable is set to 1, linetypes displayed in paper space are scaled according to the viewport scale in paper space. For more information, see “MSLTSCALE” and “PSLTSCALE” in the AutoCAD Help.

For more information on scaling AutoCAD objects, see “Scale Annotations” in the AutoCAD Help.

Setting the Annotation Scale

You can specify different annotation scales for model space and for individual viewports in paper space.

When you change the annotation scale, annotative objects and objects with annotative components are scaled accordingly. Connected objects, such as the wires connected to devices, are also updated accordingly. You do not need to regenerate the model.

In paper space, the viewport scale and the annotation scale are synchronized. When you change the viewport scale, the annotation scale is changed to match. However, you can change the viewport scale without affecting the annotation scale by zooming in or out of the viewport with the mouse wheel or by using the zoom commands.
To set the current annotation scale

1. To set the annotation scale for model space, change to the Model tab. To set the annotation scale for a viewport in paper space, select the viewport.

2. On the drawing window status bar, click the current annotation scale, and select a new scale from the flyout menu.

You can also

- Set the annotation scale for model space by selecting a scale on the Scale tab of the Drawing Setup dialog. To access the dialog, click on the drawing window status bar, and click Drawing Setup.
- Set the current annotation scale for the current space by setting the CANNOSCALE system variable. For more information, see “Set Annotation Scale” in the AutoCAD Help.

**Displaying and Hiding Annotative Objects**

When you add an annotative object to a drawing, the object will support only the annotation scale that is current at that time. In other words, the object has only one scale representation. To support additional annotation scales, you can add scale representations to the object.

In model space or in a layout viewport in paper space, you can display only the annotative objects that support the current annotation scale, or you can display all the annotative objects. You switch between these 2 options, respectively, using and on the drawing window status bar.

If you display all the annotative objects, those that do not support the current annotation scale are displayed using the annotation scale in which they were created.

For more information, see “Display Annotative Objects” and “ANNOALLVISIBLE” in the AutoCAD Help. For information on adding support for an annotation scale to an object, see Adding and Modifying Scale Representations on page 554.

**NOTE** Objects that are not annotative but have annotative components, such as devices and air terminals, are always displayed and scaled according to the current annotation scale. They cannot be hidden using this setting.
Adding and Modifying Scale Representations

Scale representations enable you to display the same annotative objects differently in different viewports in paper space. You can add scale representations to objects, remove them, and move their locations in the drawing.

**NOTE** Objects that are not annotative but have annotative components, such as devices and air terminals, do not have scale representations. Annotative components are always displayed and scaled according to the annotation scale.

Adding the Current Scale Representation

To add the current scale representation to an object, select the object, right-click and click Annotative Object Scale ➤ Add Current Scale.

You can also add and remove scale representations using the commands on the Annotative Scale panel of the context menu.

Automatically Adding Scale Representations

To automatically add a scale representation to all annotative objects, including those in referenced drawings (xrefs), when you change to that scale, click on the drawing window status bar, so that it is displayed as .

In model space, typically you will want to disable this option if you are working in a drawing that has multiple scales so that scales are not unnecessarily added to all of the annotative objects.

**WARNING** Using this option to add scale representations to the annotative objects in an xref created in a previous version of the software automatically updates the file format of the xref to the current version. This means you can no longer open the drawing in the previous version.

For more information, see “Set Annotation Scale” and “ANNOAUTOSCALE” in the AutoCAD Help.

Moving Scale Representations

Use the Location grips on an annotative object to move the object:

- Labels and AEC dimensions have a single Location grip for all scale representations. This allows you to specify one location for all of the scale representations of the object. For an example with duct, see Modifying a Label on page 239. For an example with pipe, see Modifying a Label or Flow Arrow on page 332.
- Annotative MvBlocks have 2 Location grips: one for specifying a location for all of the scale representations, and one for specifying a location for only the current scale representation.
- All other annotative objects have a Location grip for each scale representation, which means you can specify different locations for each scale representation. To move the object in all scale representations, use the MOVE command instead.

For more information, see “Add and Modify Scale Representations” in the AutoCAD Help.

Exporting Annotated Drawings to AutoCAD

When you export an AutoCAD MEP drawing to AutoCAD, the annotative objects—like all other objects—are exploded into basic AutoCAD objects that maintain their original layer, color, and linetype.
If you export a drawing with multiple viewports in paper space, the annotative objects are exploded into multiple blocks, one for each viewport, in order to maintain visual fidelity. You can export annotative AutoCAD objects in the same way by selecting **Maintain visual fidelity for annotative objects** on the **Open and Save tab** in the Options dialog. For more information, see “Save a Drawing” in the AutoCAD Help.

Beginning with AutoCAD 2009, if you open an exported AutoCAD MEP drawing in AutoCAD, the AutoCAD MEP objects that were annotative prior to export will be annotative in AutoCAD.

**Label Curve Styles**

Label curve styles define the content and display of annotation labels. When you create, edit, or copy label styles, you use Style Manager. Style Manager provides a central location where you can view and work with label styles from multiple drawings and templates.

You can specify the text style, position of text on the curve, the information displayed in the label, and how the label is displayed in your drawing. When you change a label style, the labels in the current drawing that were created with that style change.

**Copying Label Styles Between Drawings**

Use this procedure to copy label curve styles between drawings. You can manage label styles by creating them in one template drawing, and copying them into other drawings as needed.

1. Click Manage tab ➤ Style & Display panel ➤ Style Manager.
   
   Style Manager is displayed with the current drawing expanded in the tree view. The label curve styles in the current drawing are displayed under Label Curve Styles in the Documentation Objects folder.

2. In Style Manager, click File menu ➤ Open Drawing, and browse to the drawing that contains the style that you want to copy to your current drawing.

3. Open the drawing with the style that you want to copy. The new drawing opens in Style Manager.

4. Under the new drawing, expand Documentation Objects ➤ Label Curve Styles to display the label styles in the drawing.

5. Right-click the label style that you want to copy, and click Copy.

6. Right-click Label Curve Styles in the destination drawing, and click Paste. The style is copied into the destination drawing.

**Modifying a Label Style**

You can modify label style properties, such as the text style, position of text on the curve, the information displayed in the label, and how the label is displayed in your drawing.

**Specifying General Style Information**

Use this procedure to access the general style properties from the General tab for the label curve style. General style properties include label name, description, and notes. You can also assign property set information to objects that have associated schedules.

1. Select a label, and click Label tab ➤ General panel ➤ Edit Style.
2 In the Label Style dialog, click the General tab.
3 Specify the desired information, and click OK.

NOTE The name should be modified with caution. Avoid duplicate names to prevent confusion.

Changing Label Style Annotation Properties

You can use the options on the Label Style Annotation tab to specify how the object information is displayed in the label.

To set label style annotation properties

1 Select a label, and click Label tab ➤ General panel ➤ Edit Style ➤.
2 In the Label Style dialog, click the Label Style Annotation tab.

3 From the Options list, select one of the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Block graphics</td>
<td>Use a specific block. You can also specify a scale factor to apply to the block. If you want the block to scale accordingly when the annotation scale changes, select Use Annotation Scale for Block. NOTE The Use Annotation Scale for Block setting, not the Annotative property in the selected block definition, determines whether the label curve style is annotative. For more information, see Scaling Annotation on page 549.</td>
</tr>
<tr>
<td>Use Objects Properties</td>
<td>The properties displayed in the label are different for different objects in AutoCAD MEP. The ID is displayed for schematic symbols, the designation is displayed for schematic lines, and the properties of the closest connector are displayed for MvParts.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>For mechanical objects, specify a prefix,</td>
<td>For mechanical objects, specify a prefix, suffix, and symbol to display with the dimensions of duct, pipe, and duct and pipe fittings. For electrical objects, specify a prefix, suffix, and symbol to display with the dimensions of cable tray, conduit, and cable tray and conduit fittings. For wire, the panel name is displayed if there is a home run, otherwise the circuit number is displayed. The ID is displayed for devices, and the panel name is displayed for panels. For plumbing objects, specify a prefix, suffix, and symbol to display with the dimensions of plumbing lines and plumbing fittings.</td>
</tr>
<tr>
<td>suffix, and symbol to display with the</td>
<td></td>
</tr>
<tr>
<td>dimensions of duct, pipe, and duct and pipe</td>
<td></td>
</tr>
<tr>
<td>fittings.</td>
<td></td>
</tr>
<tr>
<td>For electrical objects, specify a prefix,</td>
<td></td>
</tr>
<tr>
<td>suffix, and symbol to display with the</td>
<td></td>
</tr>
<tr>
<td>dimensions of cable tray, conduit, and</td>
<td></td>
</tr>
<tr>
<td>cable tray and conduit fittings.</td>
<td></td>
</tr>
<tr>
<td>For wire, the panel name is displayed if</td>
<td></td>
</tr>
<tr>
<td>there is a home run, otherwise the circuit</td>
<td></td>
</tr>
<tr>
<td>number is displayed. The ID is displayed for</td>
<td></td>
</tr>
<tr>
<td>devices, and the panel name is displayed for</td>
<td></td>
</tr>
<tr>
<td>panels.</td>
<td></td>
</tr>
<tr>
<td>For plumbing objects, specify a prefix,</td>
<td></td>
</tr>
<tr>
<td>suffix, and symbol to display with the</td>
<td></td>
</tr>
<tr>
<td>dimensions of plumbing lines and plumbing</td>
<td></td>
</tr>
<tr>
<td>fittings.</td>
<td></td>
</tr>
<tr>
<td>Displays both the object properties and the</td>
<td></td>
</tr>
<tr>
<td>abbreviation assigned to the system</td>
<td></td>
</tr>
<tr>
<td>definition for objects except devices,</td>
<td></td>
</tr>
<tr>
<td>panels, MvParts, and schematic symbols and</td>
<td></td>
</tr>
<tr>
<td>lines. For devices, panels, and MvParts,</td>
<td></td>
</tr>
<tr>
<td>the abbreviated system name of the closest</td>
<td></td>
</tr>
<tr>
<td>connector is displayed. For schematic symbols</td>
<td></td>
</tr>
<tr>
<td>and lines, the assigned system label is</td>
<td></td>
</tr>
<tr>
<td>displayed.</td>
<td></td>
</tr>
<tr>
<td>Displays the abbreviation assigned to the</td>
<td></td>
</tr>
<tr>
<td>system definition for objects except</td>
<td></td>
</tr>
<tr>
<td>devices, panels, MvParts, and schematic</td>
<td></td>
</tr>
<tr>
<td>symbols and lines. For devices, panels, and</td>
<td></td>
</tr>
<tr>
<td>MvParts, the abbreviated system name of the</td>
<td></td>
</tr>
<tr>
<td>closest connector is displayed. For schematic</td>
<td></td>
</tr>
<tr>
<td>symbols and lines, the assigned system label</td>
<td></td>
</tr>
<tr>
<td>is displayed.</td>
<td></td>
</tr>
<tr>
<td>Specify that the object style description</td>
<td></td>
</tr>
<tr>
<td>be displayed. You can define the description</td>
<td></td>
</tr>
<tr>
<td>on the General tab in the object style</td>
<td></td>
</tr>
<tr>
<td>properties dialog. To open the style</td>
<td></td>
</tr>
<tr>
<td>properties dialog, select the object,</td>
<td></td>
</tr>
<tr>
<td>right-click, and select Edit (Object) Style.</td>
<td></td>
</tr>
<tr>
<td>Specify that the name of the component be</td>
<td></td>
</tr>
<tr>
<td>displayed. You can define the object name for</td>
<td></td>
</tr>
<tr>
<td>duct and pipe custom fittings, wire, devices,</td>
<td></td>
</tr>
<tr>
<td>panels, and schematic symbols and lines on</td>
<td></td>
</tr>
<tr>
<td>the General tab in the style properties</td>
<td></td>
</tr>
<tr>
<td>dialog for the object. To open the style</td>
<td></td>
</tr>
<tr>
<td>properties dialog, select the object,</td>
<td></td>
</tr>
<tr>
<td>right-click, and select Edit (Object) Style.</td>
<td></td>
</tr>
<tr>
<td>Specify the flow/run direction by an arrow.</td>
<td></td>
</tr>
<tr>
<td>Flow/run arrows are displayed as block</td>
<td></td>
</tr>
<tr>
<td>graphics. You can choose that type of block</td>
<td></td>
</tr>
<tr>
<td>graphic to display. If you would like to use</td>
<td></td>
</tr>
<tr>
<td>a custom flow/run arrow style that you</td>
<td></td>
</tr>
<tr>
<td>created, select Use Arrow for Type of flow/</td>
<td></td>
</tr>
<tr>
<td>run arrow, and then select the style from the</td>
<td></td>
</tr>
<tr>
<td>Select Custom Arrow Block dialog. If you</td>
<td></td>
</tr>
<tr>
<td>want the flow arrow graphics to scale</td>
<td></td>
</tr>
<tr>
<td>accordingly when the annotation scale</td>
<td></td>
</tr>
<tr>
<td>changes, select Use Annotation Scale for</td>
<td></td>
</tr>
<tr>
<td>Block.</td>
<td></td>
</tr>
<tr>
<td><strong>NOTE</strong> The UseAnnotation Scale for Block</td>
<td></td>
</tr>
<tr>
<td>setting, not the Annotative property in the</td>
<td></td>
</tr>
<tr>
<td>selected block definition, determines</td>
<td></td>
</tr>
<tr>
<td>whether the label curve style is annotative.</td>
<td></td>
</tr>
<tr>
<td>For more information, see Scaling Annotation</td>
<td></td>
</tr>
<tr>
<td>on page 549.</td>
<td></td>
</tr>
<tr>
<td>Specify a specific property set to display.</td>
<td></td>
</tr>
<tr>
<td>Select a property set definition for the</td>
<td></td>
</tr>
<tr>
<td>object, and specify a property set to display</td>
<td></td>
</tr>
<tr>
<td>in the label.</td>
<td></td>
</tr>
</tbody>
</table>
NOTE If the object does not have property sets assigned to it, you need to add the property set definitions to the object from the Properties palette, or by tagging the object.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use String</td>
<td>Display a specific string of text.</td>
</tr>
</tbody>
</table>

4 Select Mask Display of Curve to hide the centerline of the curve.

5 Specify Dimension String Options. Note that some options may not be available depending on the label option selected in a previous step:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then enter a value in…</th>
</tr>
</thead>
<tbody>
<tr>
<td>insert text before the variable</td>
<td>Prefix</td>
</tr>
<tr>
<td>separate to variables</td>
<td>Separator</td>
</tr>
<tr>
<td>insert text after the variable</td>
<td>Suffix</td>
</tr>
<tr>
<td>insert marks for an AutoCAD control code, such as %%%c, (For more information, see &quot;Control Codes and Special Characters&quot; in the AutoCAD online help.)</td>
<td>Diameter</td>
</tr>
<tr>
<td>change the distance between the beginning of the curve display and the beginning of the text (if the text intersects the curve)</td>
<td>Gap Paper Size</td>
</tr>
</tbody>
</table>

**Changing Label Style Offset Options**

You can use the options on the Label Style Offset tab to specify the text style and the position of the label relative to the curve.

**To set label style offset properties**

1. Select a label, and click Label tab ➤ General panel ➤ Edit Style 📋.
2. In the Label Style dialog, click the Label Style Offset tab.

3. Select Force To Horizontal Justification if you do not want the label to rotate at all.
To specify where the label is placed relative to the curve, select one of the following options:

<table>
<thead>
<tr>
<th>Offset option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto-Adjust for 2 Line</td>
<td>Use this option to adjust the label display for objects using a 2-line display configuration.</td>
</tr>
<tr>
<td>Auto-Adjust for 1 Line</td>
<td>Use this option to adjust the label display for objects using a 1-line display configuration.</td>
</tr>
<tr>
<td>Force Outside of Bounding Box</td>
<td>Use this option to display the label above the curve.</td>
</tr>
<tr>
<td>None</td>
<td>Use this option when you want to insert the label at the specified point.</td>
</tr>
</tbody>
</table>

5 If desired, enter a value for Clear Distance Paper Offset.

When labels have a clear distance paper offset and Auto-Adjust for 2 Line is specified, the offset is calculated from the outer edge of the curve to the bottom of the text.

When Labels have a clear distance paper offset and Auto-Adjust for 1 Line is specified, the offset is calculated from the centerline of the curve to the bottom of the text.

Labels

You can annotate objects with labels that consist of text or block definitions. The information in the label comes from object properties, such as connection size. Labels anchor to objects, yet you can still move a label without releasing it from its object. It is recommended that you add labels to construct drawings.

Adding Labels

For information on adding labels, see Adding a Label to a Duct on page 218 and Adding Labels or Flow Arrows to Pipe on page 317. In addition to duct and pipe, you can add labels to plumbing lines, wires, cable tray, conduit, and schematic lines.

Modifying Labels

For more information on modifying labels on pipe objects, see Modifying a Label or Flow Arrow on page 332.

Changing the Label Style

You can change the label style for an existing label in a drawing. For example, you can change a standard size label to a system label.

1 Double-click a label to open the Properties palette.

   NOTE Alternatively, select a label and then click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties .

2 On the Design tab, expand General under Basic.

3 Choose a label style for Style.
The label updates to reflect the properties of the new label style.

**Changing the Label Spacing**

You can change how labels are spaced along the X axis.

1. Double-click a label to open the Properties palette.

   **NOTE** Alternatively, select a label and then click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties.

2. On the Design tab, expand General ➤ Dimensions under Basic.
3. Choose a layout method under Dimensions.
   - One by One is selected by default.
   - If you choose By distance, enter a value for Distance between under Dimensions.
   - If you choose By quantity, enter the number of labels.

4. Expand Advanced.

5. Click Nodes to add, edit, or remove the grips associated with the selected layout curve on the Nodes worksheet.

---

**Adding Annotation Symbols from DesignCenter**

You can add design and documentation annotation from DesignCenter to your drawings. Documentation annotation includes symbols such as elevation labels, chases, revision clouds, and match lines. Design annotation includes symbols for parts such as electrical, mechanical, and plumbing equipment.

**NOTE** The design symbols in DesignCenter are AutoCAD® multi-view blocks (MvBlocks), and they do not connect to AutoCAD MEP objects. They are for drawing annotation only.

1. Click Insert tab ➤ Content panel drop-down ➤ Design Center.
2. On the DesignCenter palette, click the AEC Content tab.
3. Under Custom Applications, expand AutoCAD Architecture, and then expand the directory for the desired units (imperial or metric).
4. Expand the Design or Documentation directories, and continue expanding subdirectories.
When you select a subcategory that contains annotation symbols, the symbols are displayed in the right pane.

5 Drag the symbol from the right pane of DesignCenter into your drawing.
6 Specify the location and orientation for the symbol.

TIP If you want to use a DesignCenter symbol repeatedly in a project, you can drag the symbol from DesignCenter directly onto a tool palette to create a symbol tool.

Tags

In the software, tags are used primarily to add property set data to a part. After you add tags to parts, you can create equipment schedules for that type of part. The schedule is automatically populated with the property set data you specify for the part.

A tag is used secondarily to annotate a part. For example, you can add a tag to a ceiling diffuser in an HVAC system that displays the air flow assigned to the diffuser.

Property set data can consist of fixed values derived from the part, such as connection size. Data can also contain fields that you specify manually, such as a part manufacturer. For more information, see Property Set Data in the AutoCAD Architecture online help.
Adding a Tag

You must apply tags to equipment in order to create schedules for that equipment. When you add a tag to a part, the property set definitions associated with that tag are added to the part. You can enter values manually as you add the tag, and you can also modify property set data after the tag is added.

A tag is anchored to a part. If you move the part, its tag moves with it. You can, however, move the tag in the drawing without releasing it from its part.

Typically, you add tags to parts after you add the parts to a drawing. For electrical devices, you can add tags automatically as you add parts. For more information, see Creating Tools for Style-Based Content on page 790.

The default tool palettes contain several tag tools you can use for common equipment. You can also create tag tools. For more information, see Creating a Schedule Tag Tool in the AutoCAD Architecture online help.

To add a tag

1. Open the Tag and Schedule tool palette, and select a tag tool.

   **NOTE** Alternatively, you can click Annotate tab ➤ Scheduling panel ➤ Tags drop-down, and select a tag.

2. Select the object that you want to tag.

3. Specify the location for the tag:
   - Press *Enter* to center the tag on the part.
   - Click to specify a point for the tag.

   You can move tags after you insert them.

4. On the Edit Property Set Data dialog, enter desired values for fields that can be edited manually. Automatic fields are displayed in gray, and cannot be edited.

   If a tag adds property set data that is assigned to a system style or object style, that data may be inactive. You can edit this data from the Properties palette after you add the tag.

5. Click OK.

6. Continue specifying parts to tag:
   - To continue tagging parts one at a time, select an object, specify the tag location, and enter property set values.
   - To tag multiple parts with the same property set values you specified for the first part, enter m, select objects of the same part type that you want to tag, and press *Enter*. The tags are added in the same location relative to the part as the first tag. Each part also has the same property set values.

7. Press *Enter* to end the command.

You can locate many tags and schedules on the ribbon. Navigate to the Annotate tab ➤ Scheduling panel and use the drop-down buttons to see a list of available tags or schedules.

Modifying Property Set Data for a Part

You can manually change some property set values after you add a tag to a part. If the property set value is derived automatically, such as connection size, you need to modify the part itself to achieve the desired property set value.
If you delete a tag, you also remove the property set definitions that the tag assigned to the part. You lose all property set values defined for the part.

The available property sets are specified by the property set definitions assigned to the tag tool. For more information, see Property Set Definitions in the AutoCAD Architecture online help.

1 In the drawing, select one or more parts or part tags.
   Because the tag is linked to the object, you can access the same property set values by selecting either the tag or the part.

2 On the Properties palette, click the Extended Data tab.
   Example of property set data for a ceiling diffuser

3 Expand Property Sets, if necessary.

4 Edit property set values as desired.
   If property set values are derived from the part style or system style, click the edit button in the property set heading, and edit the values in the Edit Property Set Data dialog.

5 Press \textit{Esc} to deselect the parts.

**Using Part Number Tags and Schedules**

You can add part number information to an MEP system by adding part number tags to the objects in the system, including MvParts. Each tagged object has a specific property set, which you can configure according to a required pipe or duct specification. After you have added part number tags to the objects, you can create duct or pipe schedules for itemizing the objects in the system. These schedules can be sent off to an ordering or fabrication vendor.

Locate the part number tag and schedule tools on the Tags and Schedules palette.
The part number tools let you number tags individually or in a sequence, and allow using the same number for parts of the same type. Part number tags can use either numbers or text labels. While part number tags work with any MEP object, the Tags and Schedules palette provides scheduling tools only for duct and piping systems. For more information, see Working with Part Number Tags and Schedules on page 564.

**Working with Part Number Tags and Schedules**

Add part number tags to an MEP system before creating a schedule. You can also modify or remove existing part number tags.

**To add part numbers to an MEP system**

1. Click Annotate tab ➤ Scheduling panel ➤ Tags drop-down ➤ Text Part Numbering Tag.
2. Click the Rectangular, Oval, or Text Part Number tool.
3. Use the Select System button to select the system objects for tagging.
4. Choose whether to tag individual objects or connected objects.
5. Use the Add, Update, or Remove buttons to choose your Part Numbering operation.

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>Use...</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a new set of part numbers</td>
<td>Add Part Number</td>
</tr>
</tbody>
</table>
If you want to... | Use...
---|---
modify an existing set of part numbers | Update Part Numbers
delete an existing set of part numbers, including property sets | Remove Part Number

6 Set the tag starting value and add any desired tag prefix or suffix information. The tag starting value can be a number or a letter, or a combination of the two. Valid numbering sequences include:
- 1,2,3...
- A,B,C...Z,AA,AB...
- a,b,c...z,aa,ab...
- A1,A2...A9,B0,B1...
- 1A,1B...1Z,2A...

Alphanumeric Part Numbers with the Run Number (H) Followed by a Sequenced Part Number

7 Click **Include run number** to differentiate among separate but connected runs, and enter a run designator value.

8 Click **Use the same part number for identical parts** to set or cancel this option.

9 Click OK to start tag insertion.

Once the system has been tagged, use the Duct Quantity Schedule or Duct Fabrication Contract Schedule (Pipe Quantity Schedule for Piping systems) tool to add schedules to your drawing.
Schedules

You can add schedules to display part information. A schedule displays (in tabular format) a list of tagged parts along with selected attributes for each part. Schedule data is dynamic -- when you change part attributes (or delete a part) in a drawing, the schedule table automatically reflects those changes.

The schedule format is based on the schedule table style assigned to the schedule tool. You can modify schedule table styles to achieve the data format that you want to display. You can also share a schedule table style among drawings. For more information, see Working with Schedule Table Styles in the AutoCAD Architecture online help.

Adding a Schedule

This task shows how to add a schedule to a drawing that contains the tagged parts for which you want to create a schedule. Before creating a schedule, you must add tags to the parts that you want to schedule.

You can also add a schedule in its own drawing, and link to an external drawing that contains the tagged parts.

To add a schedule

1. On the Tag and Schedule tool palette, click the schedule tool for the parts you want to schedule.

   NOTE Alternatively, you can click Annotate tab ➤ Scheduling panel ➤ Schedules drop-down, and select a schedule.

2. Select the objects in the drawing that you want to schedule.
   If you use a bounding box to select all objects within an area, you can filter the selection set using Quick Select in the Properties palette. If the schedule table style is configured to use part classifications, you can select more than one type of objects, and only the parts with the appropriate classification are added to the schedule table.

3. After you select all objects to schedule, press Enter.

4. Press Enter to size the schedule table automatically.

   You can also manually specify the lower-right corner of the table.

   The schedule table is added to the drawing, and its fields are populated with the property set data configured for the scheduled parts.

Because the schedule tables are dynamically linked to the parts, you can update schedule tables as you add, remove, or modify the scheduled parts in the drawing. You do not have to manually edit the schedule.

TIP If the schedule displays each part in its own row, you can modify the schedule table style to group the same parts in a single row. Select the schedule table style in Style Manager ➤ Documentation Objects ➤ Schedule Table Styles. On the Columns tab, select Include Quantity Column, and click OK.
Linking a Schedule to an External Drawing

This task shows how to add a schedule to its own drawing, and then link it to an external drawing that contains the parts you want to schedule. If you want to have separate sheets for plan drawings and schedule drawings, it is recommended that you add a schedule to its own drawing. This alleviates the need to place the same drawing on 2 separate sheets, and then manipulating the model space view so that only the desired portion of the drawing is visible on the sheet. This will also reduce the file sizes of your sheets.

If you are using Project Navigator to manage project drawings, you can create a new general view drawing, and add the schedule to it. You link the schedule to the construct drawing that contains the parts you want to schedule. After you update the schedule, you can place its view drawing on a sheet.

1 On the Tag and Schedule tool palette, click the schedule tool for the parts you want to schedule.

   NOTE Alternatively, you can click Annotate tab ➤ Scheduling panel ➤ Schedules drop-down, and select a schedule.

2 Press Enter to schedule an external drawing.

3 Specify the location in the drawing for the upper-left corner of the schedule table, and press Enter.

4 Select the schedule.

5 In the Properties palette, select the Design tab.

6 If necessary, expand Advanced ➤ External Source.

7 For Schedule External Drawing, select Yes.

8 For External Drawing, select Browse.

9 In the Select a drawing file dialog, specify the drawing that contains the parts you want to schedule.

10 With the schedule table still selected, click Schedule Table tab ➤ Modify panel ➤ Update .

   The schedule table displays the data from the parts in the external drawing.

Creating an Electrical Panel Schedule

You can automatically generate panel schedules for electrical drawings. For more information, see Generating Panel Schedules on page 455.

Updating a Schedule

If you modify parts or part data included in a schedule, you can update the schedule table automatically to reflect the changes. When part data changes, the schedule table is displayed with a line drawn through it.

If you remove parts, you can update the schedule automatically to reflect the quantity changes. If you add parts, and want to include them in an existing schedule, you simply need to select the new parts to update the schedule.

To update the schedule table for property data changes and deleted parts

   1 In the drawing, select the schedule.
2 Click Schedule Table tab ➤ Modify panel ➤ Update.

Optionally, you can select the schedule table and change the Update Automatically setting on the Properties palette from No to Yes to immediately update the schedule any time you make a change.

To add new parts to a schedule

3 Select the schedule table, right-click, and click Selection ➤ Add.

**NOTE** Alternatively, you can click Schedule Table tab ➤ Scheduled Objects panel ➤ Add.

4 Select the additional objects in the drawing, or press Enter to schedule an external drawing.

- If you add objects from the current drawing, press Enter to update the schedule.
- If you want to add objects in an external drawing, see Linking a Schedule to an External Drawing on page 567.

With the Selection commands on the context menu of a schedule table, you can remove parts from the schedule table selection set, or reselect parts to populate the schedule table with the new selection set only.

**Exporting a Schedule to a Spreadsheet**

You can export a schedule to a spreadsheet at any time.

1 Open the drawing that contains the schedule you want to export, and select it.

2 Click Schedule Table tab ➤ Modify panel ➤ Export.

3 In the Export Schedule Table dialog, specify the output format and file name, and click OK.

**Views**

Views are the intermediate drawings between the constructs that model the system and the sheets that comprise the construction documents. View drawings typically reference one or more construct drawings. If you change anything in a construct drawing referenced in a view drawing, you can reload the construct reference drawing in the view to automatically update the changes. If you work in this manner, you only need to maintain the construct drawings, and you do not need to manually maintain the view drawings.

**Creating a General View**

You can create a general view drawing that typically displays a top view of the system design.

1 On the Quick Access Toolbar, click Project Navigator.

2 On the Project Navigator, click the Views tab.

3 In the Views directory, right-click the subdirectory where you want to add the view, and click New View Dwg ➤ General.

4 In the Add General View dialog, specify the drawing information:

- Name: Specify a file name.
- Category: Use the default directory location, or specify a new directory location.
- Drawing Template: Verify the template to use for the view drawing. This is the template specified in the project settings.
5 Click Next.

6 Specify the floors of the building plan used in the view drawing. The constructs that you want to use in the view must be assigned to the same floors.

7 Click Next.

8 Specify what constructs to use in the view. The constructs you select are attached as reference drawings to the view drawing. If a drawing is referenced as an overlay in a view drawing, it will not be included when you add the view drawing to a sheet.

**NOTE** If the construct drawing you want to use includes an overlay reference drawing, such as a building floor plan, you must select the reference drawing in addition to the construct drawing in order for it to display on the view drawing.

9 Click OK.
   The new view drawing is created, but it is not opened.

10 To open the new view drawing, double-click it on the Views tab in Project Navigator.

---

**Creating a Detail View**

This task shows how to create a new detail view drawing from a general view drawing. The detail mark is added to the general view, and the detail view is created in a new drawing. When you place the detail view on a sheet, the detail number is automatically added to the detail view, and the detail number and sheet number are automatically added to the detail mark in the general view.

1 Open the general view drawing to add the detail mark.

2 On the Annotation tool palette, click the detail mark or detail boundary tool.

**NOTE** Alternatively, use the Annotate ribbon tab and the Callouts panel drop-down to locate detail mark tools.

3 Specify the detail mark location:
   - If using the detail mark tool, specify the points for the mark leader line, and specify the direction for the detail line tail.
   - If using the detail boundary tool, specify the annotation boundary around the detail area, and specify the points for the mark leader line. The boundary displayed on the drawing is for annotation only, and is not used to define the region for the detail view.

4 At the location where you want to add the mark, press Enter.

5 In the Place Callout dialog, for New Model Space View Name, specify a name to display in the title mark of the new detail view.

6 Deselect Generate Section/Elevation.

7 For Scale, specify the drawing scale for the detail view.

8 Under Create in, click New View Drawing.

9 In the Add General View dialog, specify the drawing information:
   - Name: Specify a file name.
   - Category: Specify a directory location. It does not need to be in the same directory as the general view drawing.
   - Drawing Template: Verify the template to use for the view drawing. This is the template specified in the project settings.

10 Click Next.
11 Specify the floors of the building plan used in this detail view drawing. The constructs that you want to show in the view must be assigned to the same floors.

12 Click Next.

13 Specify what constructs to show in the view. The constructs you select are attached as reference drawings to the view drawing. If a drawing is referenced as an overlay in a view drawing, it will not be included when you add the view drawing to a sheet.

**NOTE** If the construct drawing you want to use includes an overlay reference drawing, such as a building floor plan, you must select the reference drawing in addition to the construct drawing in order for it to display on the view drawing.

14 Click OK.

15 Specify the first corner of the rectangular area that will form the boundary for the detail.

16 Specify the opposite corner.

The new detail view drawing is created, but not opened. The detail number and sheet number referenced in the detail mark display as ?.

17 Save and close the general view drawing.

18 To open the new detail view drawing, double-click it on the Views tab in Project Navigator.

When you add the detail view to a sheet, the detail number and sheet number are resolved in the marks on the detail and general view drawings.

**Creating a Section View**

You can add a section mark to a view drawing while creating a new section view drawing. Because the section view is generated from a general view, and the general view references a construct, you can automatically update the section view to reflect any changes to the construct.

1 Open the general view drawing to add the section mark.

2 On the Annotation tool palette, click the section mark tool.

**NOTE** Alternatively, use the Annotate ribbon tab and the Callouts panel to locate section mark tools.

3 In the drawing, specify the points for the section line.

   The section line determines one side of the drawing boundary.

4 At the location where you want to add the mark, press Enter.
5 Specify the section extents. The parts of the drawing enclosed by the section extents will be included in the new section view drawing.

6 In the Place Callout dialog, for New Model Space View Name, specify a name to display in the title mark of the new section view.

7 Verify that Generate Section/Elevation is selected.

8 For Scale, specify the drawing scale for the detail view.

9 Under Create in, click New View Drawing.

10 In the Add Section/Elevation View dialog, specify the drawing information:
   - Name: Specify a file name.
   - Category: Specify a new directory location.
   - Drawing Template: Verify the template to use for the view drawing. This is the template specified in the project settings.

11 Click Next.

12 Specify the floors of the building plan used in this view drawing. The constructs that you want to use in the view must be assigned to the same floors.

13 Click Next.

14 Specify what constructs to use in the view. The constructs you select are attached as reference drawings to the view drawing. If a drawing is referenced as an overlay in a view drawing, it will not be included when you add the view drawing to a sheet.

**NOTE** If the construct drawing you want to use includes an overlay reference drawing, such as a building floor plan, you must select the reference drawing in addition to the construct drawing in order for it to display on the view drawing.
15 Click OK.

16 In the general view drawing, specify the insertion point for the new section view.

The new section view will not be inserted in the general view drawing; you are specifying its location in the new drawing. It is recommended that you specify a point away from the drawing geometry. You can use the zoom and pan commands to move to an open area in the drawing without closing the generate section view command.

The new section view drawing is created, but not opened. The detail number and sheet number referenced in the section mark display as ?.

17 Save and close the general view drawing.

18 To open the new section view drawing, double-click it on the Views tab in Project Navigator.

19 Zoom extents to display the drawing contents.

The reference drawings are displayed in plan view. The section view is located at the point you specified in the general view drawing. The layers for each drawing object are preserved through
the section view. The section number in the title mark will be resolved when you place the section view on a sheet.

Creating an Elevation View

You can add an elevation mark to a view drawing while creating a new elevation view drawing. Because the elevation view is generated from a general view, and the general view references a construct, you can automatically update the elevation view drawing to reflect any changes to the construct.

1. Open the general view drawing to add the elevation mark.
2. On the Annotation tool palette, click the elevation mark tool.

   **NOTE** Alternatively, use the Annotate ribbon tab and the Callouts panel to locate elevation mark tools.

3. In the drawing, specify the location for the elevation mark.
4. Specify the viewing direction for the elevation mark.
5. In the Place Callout dialog, for New Model Space View Name, specify a name that will be displayed in the title mark of the new section view.
6. Verify that Generate Section/Elevation is selected.
7. For Scale, specify the drawing scale for the detail view.
8. Under Create in, click New View Drawing.
9. In the Add Section/Elevation View dialog, specify the drawing information:
   - Name: Specify a file name.
   - Category: Specify a new directory location.
   - Drawing Template: Verify the template to use for the view drawing. This is the template specified in the project settings.
10. Click Next.
11. Specify the floors of the building plan used in this view drawing. The constructs that you want to use in the view must be assigned to the same floors.
12. Click Next.
13 Specify what constructs to use in the view. The constructs you select are attached as reference drawings to the view drawing. If a drawing is referenced as an overlay in a view drawing, it will not be included when you add the view drawing to a sheet.

**NOTE** If the construct drawing you want to use includes an overlay reference drawing, such as a building floor plan, you must select the reference drawing in addition to the construct drawing in order for it to display on the view drawing.

14 Click OK.

15 In the drawing, specify corners of the elevation region. The parts of the drawing in the elevation region will be included in the new drawing.

16 In the general view drawing, specify the insertion point for the new elevation view. The new view will not be inserted in the general view drawing; you are specifying its location in the new drawing. It is recommended that you specify a point away from the drawing geometry. You can use the zoom and pan commands to move to an open area in the drawing without closing the generate elevation view command.
17 The new view drawing is created, but not opened. The detail number and sheet number referenced in the elevation mark display as ?.

18 Save and close the general view drawing.

19 To open the new elevation view drawing, double-click it on the Views tab in Project Navigator.

20 Zoom extents to display the drawing contents.

The reference drawings are displayed in plan view. The elevation view is located at the point you specified in the general view drawing. The layers for each drawing object are preserved through the elevation view. The elevation number in the title mark will be resolved when you place the elevation view on a sheet.

**Updating a Section or Elevation View**

If you modify a construct referenced in a view drawing with section or elevation marks, you can update the section or elevation view drawings to automatically reflect the changes to the construct.

1 On the Quick Access Toolbar, click Project Navigator .

2 On the Views tab of Project Navigator, open the drawing that contains the section or elevation view. You do not need to open the drawing that contains the section or elevation marks.
3 Click directly on the drawing geometry in the section or elevation view.
4 Click 2D Section/Elevation tab ➤ Modify panel ➤ Regenerate 🔍.
5 In the Generate Section/Elevation dialog, click OK to regenerate the section or elevation.

If you have already placed the section or elevation view on a sheet, the section or elevation view will update automatically the next time you open the sheet.

Sheets

Sheets are the construction documents that you publish or plot. You create blank sheets, and then place view drawings directly onto the sheets as reference drawings. The sheet references the view, which in turn references the construct. As a result, any changes to the construct are automatically reflected in the affected view and sheet drawings when you open them or reload their referenced drawings.

Creating a Sheet

When you create a sheet, you can add views for general plans, schedules, details, sections, and elevations. You can publish or plot a group of sheets as a sheet set.

1 On the Quick Access Toolbar, click Project Navigator 🖋.
2 On Project Navigator, click the Sheets tab.
3 Navigate to the subdirectory where you want to add the sheet.
   You can create subdirectories by right-clicking a directory, and then clicking New ➤ Subset.
4 Right-click the subdirectory, and click New ➤ Sheet.
5 In the New Sheet dialog, specify a number and sheet title, and click OK.
   The new sheet is created, but not opened.
6 Open the new sheet by double-clicking it.
7 On Project Navigator, click the Views tab.
8 In the Views directory, navigate to the view drawing that you want to place on the sheet.
   IMPORTANT If you want to place a schedule on a sheet, you must first add a viewport to the sheet.
   Click View tab ➤ Viewports panel ➤ Named and specify a viewport window on the sheet.
9 Drag the view drawing onto the sheet.
If you want to change the size of the view on the sheet, right-click and select a new scale.

NOTE If you are placing a detail, section, or elevation view, only the specific view is added to the sheet. The referenced plan view geometry is not displayed.

10 Specify the insertion point for the view.
11 To turn off grid marks in the viewport, double-click inside the viewport window.
12 Deselect Grid in the application status bar, then double-click outside the viewport window.
13 If desired, you can place more than one view on a sheet. You can also use a view on more than one sheet.

The default sheet templates in the software include a layout grid to aid in locating views on a sheet. This grid is not included in plots or DWF™ output.

To move the viewport on the sheet, select the viewport boundary and use the basic modify tools in the context menu. You can adjust the viewport size to change the viewable portion of the view drawing. You can also activate the model space view by double-clicking inside the viewport. After you activate the model space view, you can move or zoom the view drawing within the viewport. Double-click outside the viewport to deactivate the model space view and return to paper space. In paper space, you cannot modify the drawing within the viewport.

If you are placing detail, section, or elevation views on a sheet, the mark number and sheet number resolve on both the source view drawing and model space view drawing. If you change the drawing name or directory location for either view drawing, however, the mark and sheet number link will break. You may need to recreate the mark to automatically resolve the number links.

Creating a Cover Sheet

You can create a cover sheet with a sheet list table that is dynamically linked to the drawings in the sheet set. When you add the sheet list table, it automatically displays sheet names and numbers for all sheets in the sheet set. If you add, reorder, or remove sheets from the set, you can update the sheet list table automatically.

1 On the Quick Access Toolbar, click Project Navigator.
2 On the Sheets tab of Project Navigator, create a new sheet as shown in Creating a Sheet on page 576.
3 Open the new sheet.
4 If necessary, change the Sheets tab to Sheet Set View.
5 Right-click the project name at the top of the sheet set directories, and click Insert Sheet List.
6 In the Insert Sheet List Table dialog, specify the sheet list table settings, and click OK.
7 When prompted with a warning about manually editing the sheet list, click OK.
8 Specify the sheet list location on the sheet.

To update the sheet set

9 Open the sheet that contains the sheet list.
10 Select the outside border of the sheet list table.
11 Right-click, and click Update Sheet List Table.

Ordering Sheets in the Sheet Set

For sheet list tables and sheet set publishing purposes, the default order of the sheets is exactly the same as they are ordered on the Sheets tab of Project Navigator. To reorder the sheets, drag them to the desired location in the Sheet Set View. For example, if you want your cover sheet to appear first in the sheet set, drag it to the top of the sheet set view. If you do not want to include a drawing in the sheet set, right-click it and click Remove Sheet. This does not delete the sheet; it only removes it from the sheet set.

When plotting or publishing a sheet set, you can reorder, add, or remove sheets in the Publish dialog. Note that these changes will not be reflected in the sheet list table, however, and may result in publishing output of individual drawings rather than a complete set of project drawings in one DWF file.

Publishing a Sheet Set to DWF™

You can publish a sheet set to DWF™ directly from AutoCAD MEP. DWF™ files are typically much smaller in file size than regular drawings, and they can be easily shared among all parties involved in facility design and construction.

1 On the Quick Access Toolbar, click Project Navigator
2 On the Sheets tab of Project Navigator, right-click the directory that contains the sheets you want to publish, and click Publish ➤ Publish Dialog Box.
   To publish all drawings, right-click the project name at the top of the sheets directories, and click Publish ➤ Publish Dialog Box.
3 In the Publish dialog, under Publish to, select DWF file.
4 Click Publish.
5 Specify a file location, and click Select.

Adding Elevation Labels

You can add elevation labels to your drawings. Elevation labels are useful when creating construction documentation. Adding elevation labels to your drawing helps the building contractor verify that the elevation of the segment or run meets the slope requirements of the building systems. Elevation labels are accessed from DesignCenter. You can drag the elevation symbol from DesignCenter into your drawing, and select the segment to which you want to apply the elevation label. The elevation is read from the properties of the segment. If the elevation label displays the wrong elevation, then you should verify that your object is positioned correctly.
Elevation labels

\[ +12\text{'}6'' \quad -3\text{'}6'' \]

plan view label 2D section view label

NOTE You can create default elevations using the MEP Elevations tab in the Options dialog. For more information, see Defining System Elevations on page 73.

To add elevation labels

1. Click Insert tab ➤ Content panel drop-down ➤ Design Center.
2. Click the AEC Content tab.
3. In the left pane, expand Documentation ➤ Elevation Labels, and select the desired subdirectory.
4. In the right pane, select the elevation label that you want to add.
5. Drag the elevation label from DesignCenter into your drawing.
6. Select the object in your drawing to which to apply the elevation label.

WARNING If you change the elevation of the object, you need to move the elevation label to the object to update the elevation displayed in the value.

If you want to use an elevation symbol repeatedly, drag the elevation label from DesignCenter directly onto a tool palette to create an elevation label tool.

Checking Your Drawings

After drafting your building systems layouts, you need to check for valid connections between parts, completed runs from start point to endpoint, and interferences between other building systems components or structural members. You may also need to verify specific object connections. AutoCAD MEP provides tools to assist you in checking your layout:

- **Show Solution Tips.** This command shows invalid connections between components by displaying a solution tip icon at the invalid connection points. For more information, see Showing Solution Tips on page 579.
- **Show Connected Run.** This command displays a complete run of connected components by highlighting the run from start to end. For more information, see Showing Connected Runs on page 581.
- **Show Connected Objects.** This command highlights the objects that are connected to a selected object. For more information, see Showing Connected Objects on page 581.
- **Interference Detection.** This feature finds interferences between building systems or AEC structural objects by highlighting the intersecting portions of the objects. For more information, see Finding Interferences on page 582.
- **Show Circuited Devices.** In electrical system drawings, you can use this command to highlight the devices that are connected to a selected circuit. For more information, see Showing Circuited Devices on page 427.

Showing Solution Tips

During layout you must create valid connections between components to maintain intelligent building systems networks. Valid connections maintain consistency between components, including size, shape, type of system, and various part properties. You should test for valid connections.
Valid connections are determined by connector style rules, which define properties that must match between objects. A connector style has preset properties for which rules can be defined. For example, you can test for connection type and domain to prevent accidentally connecting a segment or run of the wrong connection type to an MvPart. For more information, see Connector Styles on page 616.

Solution tip icons highlight invalid connections between objects. Invalid connections can be fixed by modifying the objects that are causing the invalid connection:

- You can use grips to modify the object, and connect to adjacent objects.
- You can modify the object system to match adjacent objects, or change the system to the same system group as the adjacent objects.
- You can modify the connector style rules that apply to the objects.
- You can delete a segment or portion of the network and draft new objects using the MEP snaps.

**To test for valid connections**

1. Verify the connector style rules:
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager ➤ .
   - Expand Multi-Purpose Objects, and then expand Connector Styles.
   - Click the Rules tab, and verify the connector style rules.
   - Click OK.

**To show solution tip icons**

2. Click View tab ➤ MEP View panel ➤ Solution Tips .

   The solution tip icons are displayed. You can move your mouse over a solution tip icon to display a tooltip describing the reason for the disconnection.

**To change the size of the solution tip icon**

3. If desired, you can change the size of the solution tip icon:
   - Click View tab ➤ MEP View panel ➤ Solution Tip Size ➤ .
   - Enter a size.

   The drawing is regenerated and the size of the solution tip icon is updated.

   **NOTE** Solution tip icons remain on (visible) until you fix the invalid connection and regenerate your drawing. You can turn off solution tip icons by clicking View tab ➤ MEP View panel ➤ Solution Tips .

**To control when solution tip icons display**

4. Click ➤ Options.
5 In the Options dialog, click the AEC Editor tab.

6 Under Solution Tip, select options for displaying solution tip icons. Select Drafting to display solution tip icons as you work in a drawing file. Select Plotting/Publishing to display solution tip icons when plotting or publishing a drawing file.

NOTE You can also control the display of solution tip icons while drafting by clicking View tab ➤ MEP View panel ➤ Solution Tips.

**Showing Connected Runs**

For mechanical, electrical, and piping systems, an entire run can be highlighted. This feature can be helpful when designs are complicated or when you need to verify connectivity.

The connector style rules determine whether valid connections exist between objects. If an invalid connection is detected within the run, the run is highlighted only up to the invalid connection.

In addition to equipment, a branch, such as a tee or cross, typically represents the start point or endpoint of a run. When a branch is detected within a run, the highlighting ends at the branch.

**To show a connected run**

1 Click Duct/Pipe/Wire etc. tab ➤ Modify panel ➤ Show Connected Objects drop-down ➤ Show Connected Run.
The connected run is highlighted.

2 Press ENTER.

**Showing Connected Objects**

You can show all objects that are connected to a particular object in a drawing.
Click Duct/Pipe/Wire etc. tab ➤ Modify panel ➤ Show Connected Objects drop-down ➤ Show Connected Objects.

2 Press ENTER.

Finding Interferences

When you run interference detection, the software checks for interferences between the types of objects you specify. You can check for interferences between

- Building systems objects, for example, between ducts and pipes
- Building systems objects and architectural/structural objects, for example, between ducts and walls

The software checks for interferences between objects in the current drawing, between objects in referenced drawings (xrefs), or both (that is, between objects in the current drawing that interfere with those in an xref). When an interference is found, a mass element indicating the interference is inserted at the location. The mass element is removed when you exit interference detection mode, unless the setting to keep mass elements is enabled. In addition, you can add tags to the mass elements and insert opening symbols to show where openings in walls or other structural objects are needed. Also, tags and symbols are removed when you exit interference detection, unless you specify that they remain.

IMPORTANT Interference detection works with 3D objects (whether multi-view block-based or parametric). For plumbing systems, interference detection works only with equipment and fixtures, not plumbing lines.

Running interference detection is helpful for doing the following:

- Analyzing interferences after routing a service (such as supply and return duct), or analyzing interferences for duct objects and MvParts against walls, doors, windows, columns, and beams.
- Coordinating between disciplines for hard and soft clashes. For example, you can ensure that a supply and return system doesn’t clash into other MEP Systems and that there is enough room to mount and maintain the systems. A hard clash occurs when the geometry or 3D volume of an item or object intersects that of another item or object. A soft clash occurs when the space surrounding an item or object intersects that of another item or object. The surrounding space around an object is defined by an offset value and can be configured for pipe work, duct work, cable trays, conduits, and hangers. Hard clashes are usually more noticeable in drawings, while soft clashes are harder to detect.
- Communicating the need for holes in structural components, such as holes in load bearing walls for duct work.

NOTE When you run interference detection, the detected interferences are shown by highlighting the intersecting portions of the objects. By default, the interference highlighting color is red for hard clashes and yellow for soft clashes. Prior to running interference detection, you may want to temporarily change the color of any AutoCAD MEP objects and AEC structural members to a color other then red or yellow. As an alternative to changing colors, you may want create a display configuration set to use with interference detection.

Running Interference Detection

When you run interference detection, you can check for interferences between MEP objects, or between MEP objects and building elements. For example, while designing a supply and return duct system, you can make sure that the supply and return duct do not interfere with each other. You can also make sure that the duct systems do not interfere with any architectural or structural objects.
To start interference detection

1 Click Analyze tab ➤ Inquiry panel ➤ Interference Detection ➤ Interference Detection.

2 In the Interference Detection palette, under MEP Objects, select the types of building systems objects to be checked for interferences against other building system objects, or against architectural and structural objects. To either select all or clear all objects, right-click, and click Select All or Clear All.

3 Under Building Elements, select the types of architectural and structural objects to be checked for interferences against MEP objects. To either select all or clear all elements, right-click, and click Select All or Clear All.

4 For Clearance Check, specify whether to check for clearances and soft interferences. If set to yes, then specify the clearance offsets for each object type.

5 Click Start Interference Analysis ➤ Interference Analysis.

NOTE The Interference Analysis mode works on a per drawing basis. If you switch to another drawing, the Interference Detection palette will be updated, based on the currently active drawing.

The interferences are listed in the Interferences section of the Interference Detection palette, and are highlighted in the drawing. The Interference Detection panel is available while in Interference Detection mode. For more information, see Viewing and Resolving Interferences on page 584.

NOTE The tolerance for interferences is calculated to 5 decimal places.
### Viewing and Resolving Interferences

With a drawing open, click Analyze tab ➤ Inquiry panel ➤ Interference Detection. On the Interference Detection palette, click to start the analysis. When the analysis is completed, locate the Edit in Place tab on the ribbon to view the Interference Detection panel.

#### Interference Detection panel

Use the information in the following table to help you view and resolve each interference:

<table>
<thead>
<tr>
<th>To...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>sort the entries displayed in the list view of the Interference Detection palette</td>
<td>click the name of the column heading to sort by that column</td>
</tr>
<tr>
<td>zoom to an interference</td>
<td>in the Interference Detection palette, select an interference</td>
</tr>
<tr>
<td><strong>NOTE</strong> In order to zoom to an interference in the drawing by selecting it from the palette, zoom to mode must be enabled by clicking Activate Zoom To.</td>
<td></td>
</tr>
<tr>
<td>move between the interferences in the list view and in the drawing</td>
<td>click the Previous Interference and Next Interference buttons on the Interference Detection panel</td>
</tr>
<tr>
<td>automatically zoom to one or more interferences</td>
<td>click Zoom To on the Interference Detection panel to toggle zoom mode, and then select one or more interferences in the drawing</td>
</tr>
<tr>
<td>select and highlight an interference object in the list view</td>
<td>click Select interference mass elements to highlight in interference list, select an interference in the drawing, and press Enter</td>
</tr>
<tr>
<td>remove interferences from the drawing or the list view</td>
<td>select one or more interferences in the drawing, and then press Delete</td>
</tr>
<tr>
<td><strong>NOTE</strong> Selecting and deleting an interference from the drawing does not automatically delete the interference(s) from the list view.</td>
<td></td>
</tr>
<tr>
<td>hide the Interference Detection palette to view more of the drawing</td>
<td>click Hide Palette</td>
</tr>
<tr>
<td><strong>NOTE</strong> Use the Next Interference and Previous Interference buttons on the Interference Detection panel to move from one interference to the next.</td>
<td></td>
</tr>
<tr>
<td>To...</td>
<td>then...</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td>resolve interferences</td>
<td>use tools or commands to add or modify MEP objects</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE</strong> Resolving interferences does not automatically remove them from the list view and the drawing. You must either run the Interference Analysis again, or manually remove the interferences. You should also run the analysis again to view any new interferences that may have been caused by adding objects.</td>
</tr>
</tbody>
</table>

## Tagging Interferences or Openings

You can communicate the need for holes in structural components using interference detection. For example, you might want to create a drawing with information about holes in load bearing walls for duct work. After interference detection locates the interferences in a drawing, you can insert an opening symbol or a tag, with information about the size and elevation for each opening. Also, you might want to add tags to all interferences (mass elements) in a drawing in order to schedule and document the interferences if they are going to be resolved by other people.

### To insert an opening symbol for an interference

1. In the list view, select one or more interference objects.
2. On the Interference Detection palette, under Settings, select a opening symbol location and name from the list.
   
   **NOTE** When you specify the location, the names of all opening symbols in the specified drawing are listed.

3. Click Create Opening Symbols 🌟.

   The opening symbol is scaled to the size of the interference in plan view.

### To create a tag for an interference

1. In the list view, select one or more interference objects.
2. In the Interference Detection palette, under Settings, select a tag location and name from the list.

   **NOTE** When you specify the location, the name of all tags and Mvblocks in the specified drawing are listed.

3. Click Create Tags 🌟.

   The Interference Tag is anchored to the interference mass element and will be removed if the mass element is removed.
NOTE You can create an interference report that lists the interferences in your drawing. You must first tag the interferences that you want to include in the report, and then use the SCHEDULEADD command. A default schedule for interferences is provided. For more information about creating a schedule, see Adding a Schedule on page 566.

**Interference Report schedule**

<table>
<thead>
<tr>
<th>Number</th>
<th>Interfering Objects</th>
<th>Responsibility</th>
<th>Status</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Duct fitting &amp; Duct fitting</td>
<td></td>
<td>New</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Duct &amp; wall</td>
<td></td>
<td>New</td>
<td></td>
</tr>
</tbody>
</table>

**Exiting Interference Detection**

To exit interference detection, click End Interference Analysis. Mass elements created during the session, as well as tags attached to them will be removed. However, opening symbols that were inserted will remain.

You can save the interferences created in a drawing. On the Interference Detection palette, under Settings, for Keep interference mass elements when ending analysis mode, select Yes.

If you want to keep only specific interferences when ending interference detection, prior to exiting, remove the ones you do not want to keep. See Viewing and Resolving Interferences on page 584 for information about how to remove interferences.

**NOTE** When you exit interference detection, the interference analysis is ended for the current drawing only. If you have analyzed multiple drawings, you must exit interference detection for each drawing.

**NOTE** To have collisions appear in red while drawing, turn on collision detection. On the command line, enter collisiondetection. Be sure to turn off collision detection when no longer needed in order to preserve system resources.

**Excluding a Material from 2D Section Shrinkwrap**

Use this procedure to exclude components with a specific material assigned to them from the shrinkwrap of a 2D section.

When you create a 2D section, you can display a section component named Shrinkwrap. The shrinkwrap is the union of all object faces cut by the section line, merged into one component with one hatch pattern. This is a view frequently used for a 2D section.

By default, all components that are assigned materials are included in the shrinkwrap. However, you may want to exclude certain materials, such as glass, from the shrinkwrap.
For more information on shrinkwrap, see the AutoCAD Architecture Help.

1 Select a component with the style definitions group that contains the style you want to change, and then:
   ■ Click Duct tab ➤ General panel ➤ Edit System Style drop-down ➤ Edit Duct Style.
   ■ Click Pipe tab ➤ General panel ➤ Edit System Style drop-down ➤ Edit Pipe Style.
   ■ Click Cable Tray tab ➤ General panel ➤ Edit System Style drop-down ➤ Edit System Style.
   ■ Click Cable Tray Fitting tab ➤ General panel ➤ Edit System Style drop-down ➤ Edit System Style.
   ■ Click Pipe tab ➤ General panel ➤ Edit System Style drop-down ➤ Edit System Style.

2 In the left pane of the Style Manager, select the system style that is assigned the material you want to exclude from the shrinkwrap section.

3 Click the Other tab.

4 Select Exclude from 2D Section Shrinkwrap.

5 Click OK.

**Collecting Project Data**

Collecting project data from your layout in order to create accurate schedules is an important part of any building design project. Scheduling tends to be one of the most complex and time-consuming tasks in creating construction documents. AutoCAD MEP provides the flexibility to create and use schedule tables that are linked dynamically to your AutoCAD MEP objects. Dynamically linked schedule tables allow you to create and update schedules throughout the design process, rather than waiting until the end of the project. Schedule tables also maintain accuracy between your design layouts and the associated schedules. For information on adding schedules to drawings, see Schedules on page 566.

Schedule tables can be added to your drawings or exported to an external spreadsheet. The following steps provide an overview of the process of creating schedules:

■ Add property sets to the object type that you want to schedule. You can apply property sets by tagging equipment, or by adding object or style-based property sets from the Extended Data tab of the Properties palette. If you want to create a custom property set, you can create or edit the property set definition in Style Manager.
Specify property set values as desired for fields that can be edited manually. You can do this when you tag an object or add property sets, or you can do it at any time using the Extended Data tab of the Properties palette.

Use a schedule tool to add a schedule. The schedule format is based on the schedule table style. The schedule table is populated with the property set values from the selected objects.

Modify the schedule table style, if necessary, using Style Manager. You can modify the appearance of the headers and columns in the table, and you can specify what property set data to display.

AutoCAD MEP provides a collection of mechanical, electrical, and plumbing-specific schedule tags, such as those for HVAC, piping, equipment, plumbing fixtures, light fixtures, and circuit schedules. AutoCAD MEP also provides a collection of schedule table styles you can use or customize to meet your needs. Available schedule table styles include styles for creating equipment, fixture, and lighting schedules. You can access default schedule tags, property set definitions, and schedule table styles in drawings located in \ProgramData\Autodesk\MEP 2010\enu\Styles.

Schedule tables and the associated object properties are customizable. Customizing can be as simple as rearranging, adding, or deleting columns from a schedule table style, or as complex as creating a custom-defined report specific to a unique design or project.

Defining Property Set Definitions

Property set data that is used to generate schedule tables is created from property set definitions attached to the object. Property set definitions establish object properties that can be dynamically linked to schedule tables.

You can also use classifications to define the type of objects to which to apply the property sets. That means that you can create a certain property set for objects classified as air terminals, and another for objects classified as VAV units.

Property set definitions can be either style-based or object-based. Style-based definitions apply to all objects of a specific style, while object-based definitions apply to individual objects. For example, a Manufacturer property will probably be the same for every instance of a particular damper or MvPart style, so it should be in a style-based property set definition. However, a RegisterNumber property is different for each instance of a damper, so it should be in an object-based property set definition. Your strategy for creating style-based versus object-based property set definitions should be based on how often information might change.

AutoCAD MEP provides a group of property set definitions based on industry-standard schedules. When you use schedule tags and schedule tables, the supplied property set definitions are loaded into your drawing. You can merge, edit, and delete property set definitions. You can share property set definitions between drawings. You can also customize the part catalogs to include part properties that can be added to property set definitions. For more information, see Property Set Definitions in the AutoCAD Architecture online help.

To create your own object properties within a property set definition, you can write your own property definition formula. For example, to estimate the cost of a particular length of pipe, you can create a definition property set formula such as length x $2.00 per foot = cost.

Defining Property Set Data

You define property set data for an object by establishing a link to one or more property set definitions. The property set data assigns a value for each object property in the property set definition(s). Automatic property values are defined based on the attached object or style and are dynamically updated when the object or style is modified. Manual property values are numbers or text strings that you enter, and they can be modified at any time.
Property set data can be attached to an object, object style, or object definition. You can also edit or browse property set data or renumber any property set that increments automatically, such as a register number.

If you want to... then on the Properties Palette...

attach property set data to a selected object click the Extended Data tab, and click Add property sets. In the Add Property Sets dialog, select the property sets to attach to the object. You can also attach property sets to devices by specifying the property sets in the properties of device tools. For more information, see Creating Tools for Style-Based Content on page 790.

NOTE To attach property set data to object styles or definitions, assign the property sets to the style or definition in Style Manager.

edit property set data for one or more selected objects click the Extended Data tab, and edit the property set values that can be manually edited. If you edit a property set for a scheduled object, you can update the schedule to reflect the change.

remove property sets from selected objects click the Extended Data tab, and click Remove property sets. In the Remove Property Sets dialog, select the property set definitions to remove from the object.

change the property set value to renumber selected objects click the Extended Data tab, and change the start number and/or increment value.

Using Classifications

Classifications enable you to sort objects by creating a classification style that contains user-defined values to choose from. These classification styles are stored within the object style. You can use the classification styles to display and schedule objects. AutoCAD MEP automatically classifies objects such as multi-view parts (MvParts) and fittings. This means when you insert an air terminal into your drawing, the air terminal is classified as an MvPart with an Air_Terminal type. This enables you to create a schedule that only contains air terminals, without having to include all of the MvParts in your drawing.

Because most equipment in the software are MvParts, many equipment schedule styles use classifications to ensure that the schedule table is only populated with data from the desired part types.
Copying a Schedule Table Style

You can copy a schedule table style from another drawing and modify it to your requirements.

1. Open both drawings: the one that contains the schedule table style you want to copy, and the drawing to receive the schedule table style.
2. Click Manage tab ➤ Style & Display panel ➤ Style Manager ➤ .
3. In the left pane, expand the drawing that contains the style you want to copy.
4. Expand Documentation Objects ➤ Schedule Table Styles.
5. Right-click the desired schedule table style, and click Copy.
6. Expand the drawing to receive the schedule table style.
7. Expand Documentation Objects ➤ Schedule Table Styles.
8. Right-click Schedule Table Styles, and click Paste.

Purging AutoCAD MEP Objects

Use this procedure to remove unused AutoCAD MEP objects from a drawing. Removing objects that are not currently used helps to control drawing file size.

NOTE To purge unused system definitions, use the Style Manager. For more information, see Purging Systems on page 101.

To purge AutoCAD MEP objects

1. Click Utilities ➤ Purge AutoCAD MEP Objects.
   All unused AutoCAD MEP objects are removed from the drawing.
2. When finished, the number of items purged is displayed on the command line.

RELATED You can also run the AutoCAD purge command to remove AutoCAD-based objects such as unused blocks and layers.

Sharing Drawings

Sharing drawings is necessary in many stages of the drawing development cycle. For example, you may be asked to add a mechanical, electrical, or plumbing system to a drawing that was created in another software program. AutoCAD MEP provides an object enabler so that you can work with custom objects contained in the drawing.

You may want to share drawings using an internet-based collaboration tool like Autodesk Buzzsaw. In this case you can use a design web format (DWF) to create a file that others can view.

This section describes the tools available for sharing your AutoCAD MEP drawings. Each segment describes a tool and how it is accessed.
Displaying Custom Objects

If you open a drawing that includes a custom object that was not drawn in AutoCAD MEP, AutoCAD MEP installs an object enabler, if one is available. If an object enabler is not available, the software uses proxy graphics to display objects. You can enable proxy graphics in the Options dialog.

Object Enablers

Enablers are collaboration utilities that allow users of other Autodesk products to view and manipulate objects created in AutoCAD MEP. Enablers use ObjectDBX technology to allow object data created in AutoCAD MEP to be accessed outside its native environment. This provides data accessibility for design teams that create and receive AutoCAD MEP files.

If you open an AutoCAD MEP drawing that contains an object created in a different Autodesk product, AutoCAD MEP can automatically check http://www.autodesk.com for an object enabler to use to display the object. If it fails to find one, the object is displayed using proxy graphics instead.

To control whether AutoCAD MEP checks for object enablers, use the Live Enabler options on the System tab of the Options dialog. You can also manually check for object enablers at http://www.autodesk.com/enablers.

For more information, see “Set Interface Options” in the AutoCAD Help.

Proxy Graphics

If a LiveEnabler is not available for an object, the object may be replaced with a proxy graphic. A proxy graphic is a placeholder that represents the object. This placeholder does not have the full display or attributes of the object.

When proxy objects are drawn, AutoCAD MEP displays the Proxy Information dialog. The dialog gives you the following information:

- The total number of graphical and non-graphical proxy objects in the drawing
- The name of the missing application
- The proxy object type and display state

You can use the Proxy Information dialog to control the display of proxy objects.

Export to AutoCAD

You can create a new version of a drawing file with all AutoCAD MEP objects exploded into basic AutoCAD objects. The new version of the drawing loses the intelligence of the AutoCAD MEP objects, but the resulting basic objects can be displayed and accessed in earlier versions of AutoCAD when object enablers are not available for those versions.

When you export an AutoCAD MEP drawing to AutoCAD, all objects in the drawing are converted, depending on the selected view, either plan or 3D. AutoCAD converts 3D view objects to AutoCAD solids, and plan view objects to AutoCAD line work. Reference drawing geometry is converted to linework in a block reference. If you want to remove the block reference, use the explode command to convert the block reference to active linework.

Whether you export a drawing to AutoCAD or DXF format, the layers, colors, and linetypes of the AutoCAD MEP objects are preserved in the new drawing. For information on how annotation is handled, see Exporting Annotated Drawings to AutoCAD on page 554.
To export to AutoCAD

1 Open the AutoCAD MEP drawing you want to export.

2 Click ➤ Export ➤ AutoCAD ➤ AutoCAD 2000.

3 In the Export drawing name dialog, specify a file name and directory location for the new drawing, and click Save.
   The new drawing is created, but not opened.

Posting and Plotting Your Drawings

You can create a design web format (DWF) file to share your drawings electronically, or you can plot your drawing to a sheet. You can distribute drawings effectively using either method. For more information, see Publishing a Sheet Set to DWF™ on page 578.

Plotting

Plotter Manager lists plotter configuration (PC3) files for every non-system printer you install. Plotter configuration settings specify port information, raster and vector graphics quality, paper, and custom properties that depend on the plotter type. To open Plotter Manager, click ➤ Print ➤ Manage Plot Styles. To add a new plotter, double-click Add-A-Plotter Wizard.

You can use Plot Style Manager to add, delete, rename, copy, and edit plot style tables. Plot style tables collect groups of plot styles. A plot style controls how an object or layer is plotted by determining plotted properties, such as lineweight, color, and fill style. The Plot Style Manager is a window that shows all the plot style tables available in AutoCAD®. To open Plot Style Manager, click ➤ Print ➤ Manage Plot Styles.

When you want to preview the sheet to be plotted, click ➤ Print ➤ Plot Preview.

Comparing Drawings

A typical project requires multiple reviews at various stages in the project life cycle. When you send drawings out for review and comment, often you receive drawings containing proposed changes in return. The Drawing Compare feature allows you to visually compare the different versions and review proposed changes from architects and other engineering disciplines.

Like the traditional method of overlaying trace onto project drawings, visual cues indicate the status of drawings being compared and the state of the objects being reviewed. In addition, information is provided about changes to the properties of the objects. For more information, see Starting a Drawing Compare Session in the AutoCAD Architecture online Help.

NOTE This feature is available only to customers participating in the Autodesk Subscription Program. For more information, go to http://pointa.autodesk.com.

592 | Chapter 12  Creating Construction Documents
Using Industry Foundation Classes

The International Alliance for Interoperability (IAI) has established international standards for common architectural and construction objects in the building industry. In particular, the International Alliance for Interoperability developed an Industry Foundation Classes (IFC) data model to define CAD graphic data as 3D real-world objects. The IFC file format provides interoperability between IFC-certified software applications and reduces loss of information when files are transmitted.

You can export drawings saved in AutoCAD MEP to the IFC format and then import the file into another IFC-certified application. The dimensions of any 3D architectural objects, including building system objects, are preserved when exporting to IFC.

Before you can export an MEP drawing file to IFC, you need to map each MEP object to the appropriate IFC classification. This step allows MEP objects developed in AutoCAD MEP to display properly in other IFC-certified applications.

You can assign IFC classifications to the following MEP objects:

- Cable tray
- Cable tray fitting
- Conduit
- Conduit fitting
- Duct
- Duct custom fitting
- Duct fitting
- Duct flex
- Hanger
- Multi-View part
- Panel
- Pipe
- Pipe custom fitting
- Pipe fitting
- Pipe flex

The IfcShareBldgElements (MEP) DWG drawing file contains the IFC classifications for these MEP objects. This file resides at \ProgramData\Autodesk\MEP 2010\enu\Styles. The following IFC object classifications are supported in AutoCAD MEP:

- IfcDistributionChamberElement
- IfcDistributionControlElement
- IfcDistributionFlowElement
- IfcEnergyConversionDevice
- IfcFlowController
- IfcFlowFitting
- IfcFlowMovingDevice
Use the following procedure to assign IFC classifications to MEP objects prior to exporting to an IFC file:

**To set up IFC classifications in AutoCAD MEP**

1. Click ➤ Open ➤ Drawing to navigate to \ProgramData\Autodesk\ACA 2010\enu\Styles directory and open the IfcShareBldgElements (MEP).dwg file.

2. Click Manage tab ➤ Style & Display panel ➤ Style Manager.

3. Expand Multi-Purpose Objects ➤ Classification Definitions ➤ ifcObjectClassification in the left pane.

4. Right-click ifcObjectClassification and click Copy.

5. Click Cancel to close the Style Manager.

6. Click ➤ Close to close the IfcShareBldgElements (MEP).dwg drawing file without saving it.

**To map MEP objects to IFC**

1. Open a drawing file that contains the MEP objects where you will assign IFC classifications.

2. Click Manage tab ➤ Style & Display panel ➤ Style Manager.
3 Expand Multi-Purpose Objects ➤ Classification Definitions.

4 Right-click Classification Definitions and click Paste.

5 Click IfcObjectClassification in the left pane and then the Applies To tab in the right pane to see the applicable MEP objects (as shown below).

6 Click OK.

7 Select an MEP object in your drawing and click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties.

8 Click the Extended Data tab on the Properties palette.

9 Under Classification, click next to IfcObjectClassification to open the Select Classification dialog.
To apply a new IFC classification to the selected MEP object, choose an IfcSharedBuildingServicesElement property from the list and click OK. Your selection appears next to IFCObjectClassification on the Extended Data tab on the Properties palette. Repeat this step for each MEP object in your drawing.

**TIP** You can also click on the Quick Select icon at the upper right corner of the Properties palette to select multiple MEP objects with the same classification and then classify them on the Extended Data tab.

**NOTE** You might be unable to map some MEP objects directly to IFC. For example, you might choose to map an MvPart to IfcFlowFitting if the classification is Junction_Box, to IfcFlowMovingDevice if the classification is Fan, or to IfcFlowTerminal if the classification is Air_Terminal. Alternately, you can also leave the IFC classification as unspecified.

Save your drawing file before exporting it to an IFC file.

**To export or import IFC files**

1 To export, click ➤ Export ➤ IFC (Industry Foundation Classes).
Following the export, you can open the new IFC file in a third-party IFC viewer. The IFC classifications appear for each object that you defined previously.

2 To import a file, click ➤ Open ➤ IFC (Industry Foundation Classes).

The imported IFC file is imported as a referenced drawing (xref). You can check that the MEP objects were properly preserved.

3 To edit objects in the imported file, select an object and click External Reference tab ➤ Edit panel ➤ Edit Reference In-Place.

**NOTE** See Importing and Exporting IFC Files in the AutoCAD Architecture Help for more information.

### Select a Style

When you add a device, panel, or part to a drawing, you can use the Properties palette to choose a style to represent the new equipment.

**To Select a Style**

1. Enter DEVICEADD, PIPEADD, PANELADD, or other add-equipment command at the command line.

2. Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Properties ➤ Properties.

3. On the Design tab, click the icon in the box labeled Style to display the Select a Style dialog box.

4. Select a drawing file from the drop-down list.
   These DWG files contain content. You can specify content DWG files on the MEP Options > Catalog tab.

5. Select a **category** of equipment from the drop-down list.

6. Choose the equipment style you want to insert and then click OK.
   You can now add equipment to the drawing as needed.
Customizing Style-Based Content

You create style-based content by creating and configuring a new style.

To create schematic symbols, devices, panels, and plumbing fittings, which can require different appearances in different views (top, left, and so on), you also need to create the AutoCAD blocks (or an MvBlock) for the required views of the styles.

Workflow for Creating Style-Based Content

You create style-based content using the following high-level process:

Review the steps

Create or open the content library (DWG file) to contain the new style-based content.

Create at least one AutoCAD block to assign to a style view.

Create and configure a new style using Style Manager.

View more information

See Creating a Style-Based Content Library on page 600.

You perform this step if you are creating a schematic symbol, device, panel, or plumbing fitting, in the library drawing, create at least one AutoCAD block to assign to a style view. For more information, see Creating the Blocks for a Style on page 600.

As part of this step, you assign the blocks to different views of the style. For more information, see Creating a Style on page 601.
Review the steps

NOTE The software includes several tools that facilitate the process of creating schematic symbol styles and device styles. These tools are especially useful for creating a large number of styles at once. For more information, see Customizing Device Content on page 618 and Customizing Schematic Symbol Content on page 630.

Add the new style-based content to one or more categories, as appropriate.

See Categorizing Style-Based Content on page 617.

Save and close the library drawing.

Creating a Style-Based Content Library

When you create a style using Style Manager, the style is saved only in the current drawing. If your style-based content needs to be available for use in multiple drawings on a regular basis, create the style in a new or existing drawing that you can use as a library for permanent storage.

For example, if you want to have a library of symbols to use throughout a series of drawings for project ABC, open a new drawing called Project ABC Ortho Iso.dwg and create all of the styles in that drawing. The Project ABC Ortho Iso.dwg file acts as your style-based content library. Naming the drawing according to whether it contains symbols with orthographic and isometric views, or symbols with only orthographic views, helps users during symbol selection.

As you draw a building system, you can access the style-based content in a library if the library drawing is located in a folder specified as a default location for style-based content, or in one of its subfolders.

The following folder contains a set of customizable style-based content libraries: \ProgramData\Autodesk\MEP 2010\enu\MEPContent. The libraries have unique drawing names based on the type of content they contain.

NOTE Before customizing the libraries provided with the software, make a copy of the original libraries.

Creating the Blocks for a Style

To create a new schematic symbol, device, panel, or plumbing fitting, you must have at least one block to assign to a view of the style.

NOTE You should draw objects in blocks using line, trace, hatch, or solid, and not polyline.

You can use a simple 2D AutoCAD® block that is displayed the same in all view directions, such as in the view directions of an orthographic symbol. You can also use a Multi-view block (MvBlock) that has a different appearance for each view direction, such as the different views of an isometric symbol. The individual blocks you create are referred to as view blocks.
The number and types of blocks that you need depend on your requirements. For a schematic symbol style, typically you can create one 2D block to represent the symbol in a plan view. If you need to create isometric drawings, you can use this block to generate additional blocks for the 12 isometric views that represent the 12 isometric view directions and orientations.

For other types of style-based content, you need to create the 2D and 3D blocks required to represent the object in plan views and in model views. For example, a plumbing fitting style might require only a 2D block to represent the fitting in a plan view. Similarly, a device style might require a 2D block to symbolically represent the device in a plan view. However, if you need to create sections and elevations that display devices in actual size, the device style will also require a MvBlock for use in a model view (and in other view directions such as Front and Left).

Generally, when you insert style-based content, you want the symbol to inherit the color, linetype, and linewidth properties of the current layer standard. To ensure this, set the color, linetype, and linewidth properties individually for the geometry in each block. Create the geometry on layer 0, and specify BYBLOCK for color, linetype, and linewidth, and an insertion point of 0,0,0. To ensure the correct view block assignment, assign a unique name to each block. Unique names are also helpful for identification.

TIP Use the styles (and blocks) provided with the software as a guide for creating your own custom styles.

For an introduction to orthographic and isometric views, see Orthographic and Isometric Views of Style-Based Content on page 86.

Creating a Style

1 In the active workspace, open the Style Manager to access styles by doing one of the following:

<table>
<thead>
<tr>
<th>Workspace</th>
<th>Ribbon Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>Electrical</td>
<td>Click Manage tab ➤ Style &amp; Display panel ➤ Style Manager drop-down ➤ Electrical Device Styles.</td>
</tr>
<tr>
<td>Electrical</td>
<td>Click Manage tab ➤ Style &amp; Display panel ➤ Style Manager drop-down ➤ Electrical Panel Styles.</td>
</tr>
<tr>
<td>Electrical</td>
<td>Click Manage tab ➤ Style &amp; Display panel ➤ Style Manager drop-down ➤ Wire Styles.</td>
</tr>
<tr>
<td>Plumbing</td>
<td>Click Manage tab ➤ Style &amp; Display panel ➤ Style Manager drop-down ➤ Plumbing Fitting Styles.</td>
</tr>
<tr>
<td>Plumbing</td>
<td>Click Manage tab ➤ Style &amp; Display panel ➤ Style Manager drop-down ➤ Plumbing Line Styles.</td>
</tr>
<tr>
<td>Schematic</td>
<td>Click Manage tab ➤ Style &amp; Display panel ➤ Style Manager drop-down ➤ Schematic Symbol Styles.</td>
</tr>
</tbody>
</table>
Workspace | Ribbon Path
--- | ---
Schematic | Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Schematic Line Styles 📉.

**NOTE** To create new styles for Conduit, Cable Tray, Custom Duct/Pipe Fittings and other content, click Manage tab ➤ Style & Display panel ➤ Style Manager 📉, and click the + sign to open a domain type. Then, you can access sub-domain styles.

2 Create the style:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then in the left pane of Style Manager…</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a new, blank style</td>
<td>right-click the corresponding styles category (for example, Device Styles), and click New. Enter a name, and press Enter.</td>
</tr>
<tr>
<td>copy an existing style</td>
<td>do the following:</td>
</tr>
<tr>
<td></td>
<td>■ Right-click the style you want to copy, and click Copy.</td>
</tr>
<tr>
<td></td>
<td>■ Right-click the corresponding styles category (for example, Device Styles), and click Paste.</td>
</tr>
<tr>
<td></td>
<td>■ Right-click the copy, click Rename, enter a new name, and press Enter.</td>
</tr>
</tbody>
</table>

3 On the General tab, enter a description for the style, and click Apply.

4 Specify the general properties the style. For help, see

- Specifying the Design Rules of a Style on page 603
- Defining the Views of a Style on page 604
- Configuring the Connectors of a Style on page 608
- Configuring the Display Properties of a Style on page 610

5 Specify any discipline-specific properties of the style. For help, see

- Device Style Setup on page 367 and Configuring Styles for Wires on page 373
- Configuring Styles for Plumbing Lines and Fittings on page 481
- Configuring Styles for Schematic Lines on page 522

**Editing Style-Based Content**

You modify style-based content by modifying the properties of a style and, when applicable, its associated view blocks.

You modify the geometry of a view block manually in the drawing. To modify style properties, you can use

- The batch conversion tools available for creating and modifying schematic symbols and devices. For more information, see Customizing Schematic Symbol Content on page 630 and Customizing Device Content on page 618.
- Style Manager

In this case, the style changes are saved only in the current drawing. To apply your changes on a broader scale, open the content library drawing that contains the style, and modify the style within the library drawing. This makes the modified style available in all drawings that specify, in the Options dialog, the
Configuring Styles

Styles are sets of properties that you can assign to objects to determine their appearance or function. For example, a schematic line style defines a schematic line’s appearance, such as how the line is displayed when crossing other lines. It also controls the line’s function, such as the type of segment that the line represents in the drawing.

Specifying the Design Rules of a Style

The design rules of a style determine how schematic lines, wires, and plumbing lines are cleaned up when they are connected to, respectively, schematic symbols, devices or panels, or plumbing fittings.

To specify the design rules of a style for cleaning up lines

1. Open the style in Style Manager by doing one of the following:
   - Verify that the active workspace is Schematic. Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Schematic Symbol Styles.
   - Verify that the active workspace is Electrical. Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Electrical Device Styles.
   - Verify that the active workspace is Electrical. Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Electrical Panel Styles.
   - Verify that the active workspace is Plumbing. Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Plumbing Fitting Styles.

2. In the left pane of Style Manager, select a style.

3. In the right pane, click the Design Rules tab.
4 Select a cleanup method for schematic lines, wires, or plumbing lines, depending on the style:

<table>
<thead>
<tr>
<th>If you want to end at the...</th>
<th>then select...</th>
</tr>
</thead>
<tbody>
<tr>
<td>connection point</td>
<td>None.</td>
</tr>
<tr>
<td>edge of a surrounding hidden box</td>
<td>Bounding Box.</td>
</tr>
<tr>
<td>edge of an inscribed circle within a surrounding hidden box</td>
<td>Inscribed Circle.</td>
</tr>
<tr>
<td>edge of a circumscribed circle outside a surrounding hidden box</td>
<td>Circumscribed Circle.</td>
</tr>
<tr>
<td>at the edge</td>
<td>Trace Geometry.</td>
</tr>
</tbody>
</table>

5 Click OK.
Existing content that uses the style is updated automatically. By default, any new content uses the new method.

**Defining the Views of a Style**

Style-based content—devices, panels, plumbing fittings, schematic symbols, and multi-view parts (MvParts)—are multi-view blocks (MvBlocks) that have smart connectors that enable them to connect intelligently to form systems. An MvBlock is a custom object that can have different appearances in different view directions. To define the appearance (or view) of style-based content, you assign a pre-drawn block to a specified view in the style definition.

The number and types of blocks that you need depend on your requirements. For a schematic symbol style, typically you can create one 2D block to represent the symbol in a plan view. If you need to create isometric drawings, you can use this block to generate additional blocks for the 12 isometric views (that represent the 12 isometric view directions and orientations).

For other types of style-based content, you need to create the 2D and 3D blocks required to represent the object in plan views and in model views. For example, a plumbing fitting style might require only a 2D block to represent the fitting in a plan view. Similarly, a device style might require a 2D block to symbolically represent the device in a plan view, but—if you need to create sections and elevations that display devices in actual size—the device style will also require an MvBlock for use in a model view (and in other view directions such as Front and Left).
TIP Use the styles provided with the software as a guide for creating your own custom styles.

For an introduction to orthographic and isometric views, see Orthographic and Isometric Views of Style-Based Content on page 86.

Defining Style Views for Devices, Panels, and Plumbing Fittings

1. In the drawing that will contain the style, create the AutoCAD blocks (or the MvBlock) that will represent the object in the orthographic views and in the model view.
2. Create the style, as described in Creating a Style on page 601.
3. In the left pane of Style Manager, navigate to the style, select it, and click the Views tab.

Views tab for an existing device style

4. To add a view:
   - Click Add.
   - For View Name, enter a name, such as Plan or Model.
   - For View Block, select a block to represent the view.
     You can select from the AutoCAD blocks defined in the current drawing.

5. Specify when to use the selected view:
   - For Display Representation, select the display representation in which to display the view.
   - For View Directions, select one or more view directions in which to display the view.

NOTE To determine the view block to use to display a style-based object, the software identifies the active display representation (determined by the active display configuration) and the active view direction in the current drawing, and then searches for a view of the style that has the same specified display representation and view direction. If a matching view is found, the associated view block is used to display the object. If multiple matches are found, all of them are used to display the object. If no match is found, the object is not displayed.

6. If you want the view block to be inserted as an annotation block, select Insert as annotation block.
If desired, you can offset the annotation block from its insertion point by specifying values for Offset in X and for Offset in Y.

**NOTE** When you insert a view block as an annotation block, the Annotation display component for the object type (device, panel, or plumbing fitting) determines its display properties, such as its color, linetype, and linewidth.

By defining multiple views with the same specified display representation and view directions, you can display an object using annotative and non-annotative view blocks at the same time, and you can configure the display properties of the view blocks differently. For example, you might have a junction box style that requires a view block to represent the symbology, and a second view block to represent the annotation. This allows you to define the appearance of the annotation view block by configuring the Annotation display component for the junction box, and to define the appearance of the symbol by configuring the other display components for the junction box.

7 Specify whether to scale the view block:

<table>
<thead>
<tr>
<th>If you want to scale the view block using …</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>the current annotation scale</td>
<td>select Use Annotation Scale. This scales the block to the annotation plot size (specified on the Scale tab of the Drawing Setup dialog) multiplied by the scale factor for the current annotation scale.</td>
</tr>
<tr>
<td>a scale factor that you specify</td>
<td>select Override Scale, and for each coordinate direction (X, Y, and Z), enter the scale factor to use to scale the block. A value greater than 1 enlarges the block. A value between 0 and 1 shrinks the block.</td>
</tr>
<tr>
<td>no scale</td>
<td>do not select Use Annotation Scale or Override Scale.</td>
</tr>
</tbody>
</table>

8 If you selected Insert as annotation block, and you want the annotation view block to remain horizontal regardless of the rotation of the object in the drawing, select Keep text horizontal when rotating.

9 Add and configure additional views as previously described.

10 To remove a view, select it, and click Remove.

**WARNING** Use caution when removing views. If there is no view of the style for the current display representation and view direction in the drawing, all of the objects that use the style will not display when the drawing uses that display representation and view direction.
Defining Style Views for Schematic Symbols

1. In the drawing that will contain the style, create an AutoCAD block to represent the symbol in plan view.
2. Create the style, as described in Creating a Style on page 601.
3. In the left pane of Style Manager, navigate to the style, select it, and click the Views tab.

Views tab for an existing schematic symbol style

4. Click Generate Isometric Views.
5. In the Generate Isometric Symbol Blocks dialog, specify the orientation of the symbol in isometric views:

<table>
<thead>
<tr>
<th>If you want the symbol...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>to be oriented based on the direction of the schematic line</td>
<td>select In-line symbol.</td>
</tr>
<tr>
<td>to be oriented vertically with respect to the ground regardless of the direction of the schematic line</td>
<td>select Vertical symbol.</td>
</tr>
</tbody>
</table>

6. For Plan block to be used, select the AutoCAD block in the current drawing to use for the Ortho/Plan view.
7. If you want to overwrite existing view blocks with the blocks that will be created, select Use new blocks in the style definition.
   If you do not select this option, the blocks are created in the drawing, and they are available for selection, but they are not automatically assigned to the views of the style.
8. Click OK.
   The software creates the isometric views and the associated view blocks based on the selected block for the orthographic (plan) view.
Select a view, and under Scaling, specify how to scale the symbol block:

<table>
<thead>
<tr>
<th>If you want to scale the view block using ...</th>
<th>Then ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>the current annotation scale</td>
<td>select Use Annotation Scale. This scales the block to the annotation plot size (specified on the Scale tab of the Drawing Setup dialog) multiplied by the scale factor for the current annotation scale.</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE</strong> The Use Annotation Scale setting for the symbol, not the Annotative property in the selected symbol block definition, determines whether the symbol is annotative (scales according to the annotation scale). Also note that schematic symbols are always scaled according to the current annotation scale in model space; for more information, see Annotative Objects on page 549.</td>
</tr>
<tr>
<td>a scale factor that you specify</td>
<td>select Override Scale, and for each coordinate direction (X, Y, and Z), enter the scale factor to use to scale the block. A value greater than 1 enlarges the block. A value between 0 and 1 shrinks the block.</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE</strong> If you select both this and Use Annotation Scale, the block is scaled using the scale factors you enter, and then the result is multiplied by the scale factor for the current annotation scale.</td>
</tr>
<tr>
<td>no scale</td>
<td>do not select Use Annotation Scale or Override Scale.</td>
</tr>
</tbody>
</table>

10 Configuring the remaining views as previously described.

11 If necessary, you can click Advanced Editor to add (and remove) views in the Views dialog.

**WARNING** Use caution when removing views. If there is no view of the style for the current display representation and view direction in the drawing, all of the objects that use the style will not display when the drawing uses that display representation and view direction.

You can also use the Views dialog to specify the display representations and the view directions in which to display the view block, although typically these settings are configured for you when you generate the view blocks.

**NOTE** To determine the view block to use to display an object, the software identifies the active display representation (determined by the active display configuration) and the active view direction in the current drawing, and then searches for a view of the associated style that has the same specified display representation and view direction. If a matching view is found, the associated view block is used to display the object. If multiple matches are found, all of the associated view blocks are used to display the object. If no match is found, the object is not displayed.

12 Click OK twice.

**Configuring the Connectors of a Style**

All AutoCAD MEP objects have one or more smart connectors (connection points) that enable them to connect intelligently to appropriate objects and to transfer information such as shape, size, and system. Some objects, such as receptacles, require a single connector. Other objects, such as plumbing elbow fittings,
require multiple connectors. You add connectors to style-based objects by adding connectors to the styles that define the objects. You can also remove connectors from styles, or change their type and location.

**NOTE** For detailed information on configuring connectors for device styles and for plumbing fitting styles, both of which have unique considerations, see Configuring Connectors for Device Styles on page 368 and Connectors for a Plumbing Fitting Style on page 483.

For information on configuring the connectors of catalog-based content, such as MvParts and fittings for ducts, pipes, cable trays, and conduits, see Customizing Catalog-Based Content on page 641.

**To configure the connectors of a style**

1. Open the drawing that contains the style.
2. Open the style by doing one of the following:
   - Click Manage tab ➤ Style & Display panel ➤ Style Manager . In the left pane, navigate to the style, and select it.
   - In the drawing, select an object that uses the style, then click the object’s contextual ribbon tab ➤ General panel ➤ Edit Style drop-down ➤ Edit Style.
3. Click the Connectors tab.
4. For Description, enter a descriptive name, such as Air_Supply.
5. For Domain, select a domain. For some types of styles, only a single domain is available.
6. Specify values for connection points X, Y, and Z, or click Add Center Points from View Blocks in Top View to create a centered connector.

**WARNING** Use caution when modifying the connection points on connectors or removing connectors. Either can break the connectivity between objects because the connector is modified in or removed from all instances of the style in the drawing.

7. If you want to add a connector, click , and configure the connector properties.
8. If you want to remove a connector, select the connector, and click .
Configuring the Display Properties of a Style

By customizing the display properties of a style (in other words, by applying a style override), you can control how building systems objects using that style are displayed in your drawing. You can change individual component display properties, such as the color or layer of connectors. Any change you make affects all instances of content using this style.

For information on how the display of an object is determined when multiple types of display overrides are in effect, see Hierarchy of Display Control on page 141.

To configure the display properties of a style

1 Select an object in your drawing, and then choose one of the following procedures:
   - Click the object’s contextual ribbon tab ➤ General Panel ➤ Edit Style command.
     
     NOTE The General Panel shows an Edit System Style drop-down menu for some objects that you can then open to choose from several Edit Style commands.
   - Right-click an object in your drawing, and click the corresponding Edit Style command from the context menu.

2 In the Styles dialog, click the Display Properties tab.

3 Configure the display properties:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>change the display of an object style’s components,</td>
<td>select the display representation, click</td>
</tr>
<tr>
<td>such as visibility, layer, or color</td>
<td>Style Override, and edit the component</td>
</tr>
<tr>
<td></td>
<td>display properties.</td>
</tr>
<tr>
<td>reset the display representation to the drawing</td>
<td>click Style Override to clear the override.</td>
</tr>
<tr>
<td>default</td>
<td></td>
</tr>
</tbody>
</table>
If you want to… then…

change style-specific display settings
select the display representation, click Edit Display Properties, and then click the Other tab to make changes. The Other tab is displayed only in some display representations.

4 Click OK twice.

**Attaching Notes and Files to a Style**

General style properties include name, description, and notes. You can use general style properties to assign property set information to objects such as MvParts, which typically have associated schedules.

1 Select an object in your drawing, and then choose one of the following procedures:
   - Click the object’s contextual ribbon tab ➤ General Panel ➤ Edit Style command.

   **NOTE** The General Panel shows an Edit System Style drop-down menu for some objects, which you can then open to choose from several Edit Style commands.

   - Right-click and click the Edit Style command from the context menu.

2 In the Styles dialog, click the General tab.

3 Enter a name and description.

   **NOTE** The name is predefined by the object and should be modified with caution. Avoid duplicate names to prevent confusion.

4 Click Notes.

5 In the Notes dialog, click the Notes tab, and enter the note text.

   To select all notes, click Select All. You can use the context menu to access the standard Windows® cut, copy, paste, and delete commands for selected text.
6 Click the Reference Docs tab and enter reference information.
7 Click Add to select a reference and enter a description.
8 Click Edit to modify the location or description of a reference.
9 Click Delete to remove a reference from your drawing.
10 Click OK.
   The Notes dialog closes, and you are returned to the Style Properties dialog.
11 If available in the Styles dialog, click Property Sets.
   The Edit Property Set Data dialog is displayed.
12 In the Edit Schedule Data dialog, configure property sets for the style.

**Copying Styles Between Drawings**

In Style Manager, you can copy a style from one drawing to another by dragging the style and dropping it onto the destination drawing. This also copies all of the blocks associated with the style to the destination drawing.

For more information on copying styles, see Copying Styles Between Drawings in AutoCAD Architecture Help.

**Rise/Drop Styles**

In a drawing, rise symbols and drop symbols are used to represent vertically-oriented segments and fittings, and to indicate corresponding rises and drops in elevation in the layout. In AutoCAD MEP, a rise condition exists if an unconnected end on a vertically oriented segment or fitting is visible in the current view. If the segment or fitting is vertically oriented but does not have a visible, unconnected end, a drop condition exists. Rise/drop styles let you specify the symbols to use in both rise and drop conditions.

A rise/drop style defines not only the symbols to use, but also the 2-line and 1-line displays in which to use them. For duct rise/drop styles, you can also specify different symbols for different shapes of ducts and fittings: round, rectangular, and oval.

Rise/drop styles are used in the orthographic views: Top, Bottom, Left, Right, Front, and Back.

1-line display of a pipe run

You can specify a rise/drop style for each system in a drawing. For example, you can specify one style for a supply system and a different style for a return system. This helps to visually differentiate the systems, as shown in the following plan view of a supply run and a return run, both with vertical components.
Creating Blocks for Rise Symbols and Drop Symbols

Before you define a rise/drop style, you need to create the AutoCAD blocks that will represent the rise symbols and drop symbols. For information on creating blocks, see “Create and Store Blocks” in the AutoCAD Help. Keep the following guidelines in mind as you create the blocks:

- Rise/drop styles (and, therefore, the associated blocks) must exist in the current drawing if they are to be used. This means you must either create the blocks and styles directly in your drawing templates (which typically are used to create new drawings), or you must create them in a content library (a DWG file), and then copy them to your drawing templates.

- Before you create a block for a rise symbol, set the current color, linetype, and lineweight to ByBlock. When the block is inserted in a drawing, the values for these properties in the Rise Drop display component will be used.

- Before you create a block for a drop symbol, set the current color, linetype, and lineweight to the desired values for the symbol. When the block is inserted in a drawing, the values for these properties will be retrieved from the block definition, and any values for these properties in the Rise Drop display component will be ignored.

**NOTE** Configuring the blocks for rise symbols and drop symbols as just described allows you to specify different values for the display properties of each. You control the visibility of both using the Visibility setting for the Rise Drop display component.

- You can create a block at any size. When it is inserted in a drawing, the block is scaled so that its extents are one unit (for example, one inch or one millimeter); it is then rescaled according to the specifications in the rise/drop style.

- To ensure that the symbol is displayed in the correct location relative to a layout, specify the center of the symbol as the base point of the block.

- Create oval blocks as flat ovals, using the blocks provided with the software as a guide.

**IMPORTANT** The content packs provided with the software each include a style drawing that contains many predefined system definitions, several rise/drop styles for use with the system definitions, and supporting AutoCAD blocks for commonly used rise symbols and drop symbols. Some of the rise/drop styles and AutoCAD blocks are also made available in the drawing templates provided with the software. By default, the default symbols in any new rise/drop style use these AutoCAD blocks. To determine the extents of the blocks in order to support correct scaling, the blocks for 2-line displays include extra geometry on nested, non-plotting, frozen layers.
Defining Rise/Drop Styles

A rise/drop style specifies the symbols to use in 2-line and 1-line displays of rise conditions and drop conditions on segments and fittings.

You can define the following types of rise/drop styles: duct, pipe, cable tray, conduit, and plumbing. Duct rise/drop styles allow you to specify symbols for different shapes: round, rectangular, and oval. You can also specify whether to show a rise or a drop symbol when duct or pipe runs underneath an MvPart, or when a vertical duct has an endcap.

To define a rise/drop style

1. If necessary, create the AutoCAD blocks to be used by the symbols in the rise/drop style. For guidelines, see Rise/Drop Styles on page 612.
2. Click Manage tab ➤ Style & Display panel ➤ Style Manager .
3. In the left pane, expand the folder for the appropriate objects (for example, the Piping Objects folder).
4. Right-click Rise Drop Styles, and click New.
5. Enter a name for the new style, and press ENTER.
6. Select the new style.
7. For Description, enter a description of the style.
8. If desired, attach notes or reference documents to the style.
9. Click the Rise and Drop tab.

Rise and Drop tab for a sample pipe rise/drop style

The top pane lists the default symbols to be created by the software for the new style. The properties for the currently selected symbol are shown below.
IMPORTANT To simplify the process of configuring the symbols in a rise/drop style, it is recommended that you reconfigure as necessary—but do not remove—the default symbols. They make up the minimal set of rise symbols and drop symbols needed for all possible rise conditions and drop conditions in 2-line and 1-line displays. Without this minimal set, the style is not valid. For example, a pipe rise/drop style is not valid without the following symbols: 2-line rise, 2-line drop, 1-line rise, 1-line drop, and 1-line drop for tees and takeoffs only. Similarly, a plumbing rise/drop style is not valid without the following symbols: rise, drop.

10 Select the number of a symbol to configure.
11 For Name, enter a descriptive name that identifies the context in which the symbol will be used.
12 For Display Representation, select the display representation in which the symbol will be displayed.
   For a 2-line display, select a Plan or 2 Line display representation. For a 1-line display, select a 1 Line display representation.
13 For Block, select the AutoCAD block (defined in the current drawing) that represents the symbol.
14 If you want to display center lines on the symbol, for Center Line Block, select the AutoCAD block (defined in the current drawing) that represents the center lines.
   A preview image of the symbol, defined by the selected blocks, displays on the right.
15 Under Rise/Drop, select Rise if you want to see rise symbols instead of drop symbols for runs underneath MvParts, or ducts with endcaps.
   You can choose to see Rise symbols for either MvParts or endcaps, or both.
16 If you selected Drop under Rise/Drop, and the symbol will only be used to represent tees and takeoffs in 1-line displays, select Drop Tees/Takeoffs Only.
   In 1-line displays, which do not show the contour of an object, this identifies the appropriate symbol to use for tees and takeoffs in drop conditions.
17 If the rise/drop style is for ducts and duct fittings, under Shape, select the shape for which to use the symbol.
18 Under Scaling, specify how to scale the symbol block:

<table>
<thead>
<tr>
<th>If you want to scale the symbol block ...</th>
<th>Then ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>to the actual diameter (in 2-line displays) or the nominal diameter (in 1-line displays) of the segment or fitting</td>
<td>clear Use Annotation Scale, and clear Override Scale.</td>
</tr>
<tr>
<td>using the current annotation scale</td>
<td>select Use Annotation Scale. This scales the block to the annotation plot size (specified on the Scale tab of the Drawing Setup dialog) multiplied by the scale factor for the current annotation scale.</td>
</tr>
</tbody>
</table>

NOTE The Use Annotation Scale setting for the symbol, not the Annotative property in the selected symbol block definition, determines whether the symbol is annotative (scales according to the annotation scale).
If you want to scale the symbol block ... Then ...

| Using a scale factor that you specify | Select Override Scale, and for each coordinate direction (X, Y, and Z), enter the scale factor to use to scale the block. |

**NOTE** If you select both this and Use Annotation Scale, the block is scaled using the scale factors you enter, and then the result is multiplied by the scale factor for the current annotation scale.

When the symbol block is inserted in a drawing, it is first scaled so that its extents are one unit (for example, one inch or one millimeter); it is then rescaled based on your selection here.

19 If you want to scale the center line block relative to the symbol block, for Center Line Block Scale Factor, enter the scale factor.

For example, to scale the center line block to the same size as the symbol block, enter 1. To scale it so it is 50% larger than the scaled symbol block, enter 1.5.

**TIP** The preview image updates dynamically to assist you in specifying the desired scale factor for the center line block.

20 Select the next symbol, and configure it using the same process.

21 If you want to add additional rise graphics or drop graphics, click Add, and configure an additional symbol to be displayed in a specific rise condition or drop condition.

22 If you want to delete a symbol, click Remove.

**NOTE** In a drawing, the display properties of the symbol block—including its visibility—are determined by the settings of the Rise Drop display component for the current display representation. Similarly, the display properties of the center line block are determined by the Center Line display component. This allows you to specify different display properties for the symbols and their center lines. For information on configuring display settings, see AutoCAD MEP Displays on page 134.

**Connector Styles**

Connector styles specify the rules that determine when connections are allowed between building systems objects. The rules determine whether connections are allowed by comparing specific properties. For example, when connecting 2 segments, typically you want to ensure the segments are the same size.

AutoCAD MEP includes the following connector styles:

- Cable Tray
- Conduit
- Electric
- HVAC
- Pipe
- Schematic

**IMPORTANT** It is recommended that you keep the default configuration of the connector styles. Modifying the styles might cause the software to work improperly.
To verify the connector style rules

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager ➤ Style Manager.
2 Expand Multi-Purpose Objects, and then expand Connector Styles.
3 In the left pane, select a connector style.
4 In the right pane, click the Rules tab, and verify the connector style rules.

Categorizing Style-Based Content

You can create categories for related style-based content in the drawings located in the default style-based content locations. Because these drawings typically contain a large number of styles, categorizing the styles makes it easier for users to browse them.

Creating Categories in AutoCAD MEP

You can create categories for various MEP objects, such as devices, panels, schematic symbols, and plumbing fittings. The following steps explain how to categorize a style for plumbing fittings.

NOTE These steps are similar to those when you create other types of categories in AutoCAD MEP.

To categorize plumbing fittings

1 Click Manage tab ➤ Style & Display panel ➤ Style Manager ➤ Style Manager.
2 Expand the specific Objects node in the left pane. In this example, select Plumbing Objects.
3 Right-click the desired category — in this case, Plumbing Fitting Categories. Then click New.
4 Enter a name for the new category, and press ENTER.
5 Click the Plumbing Fitting tab in the right pane.

NOTE The name of this tab relates specifically to the category you selected previously. In this example, it is named Plumbing Fitting.
6 Click Add to add a style to the new category. Repeat to add additional styles.

7 To delete a category, right-click the category name in the left pane and click Purge.

**NOTE** Deleting a category deletes the category and the references to the styles within the category. It does not delete the actual styles.

### Customizing Device Content

This section provides information on several conversion tools you can use to create device content.

For information on creating style-based content manually, see [Workflow for Creating Style-Based Content](#) on page 599.

### Converting Blocks and Parts to Devices

You can convert a single AutoCAD block, MvBlock, or MvPart to a device. Because devices are style-based objects, and all style-based objects are defined by styles, this creates an associated device style as well.

**To convert a block or part to a device**

1. Select the AutoCAD block, MvBlock, or MvPart to convert to a device.
   
   You can select a block or part in the current drawing or in one of its [referenced drawings](#) (xrefs).

2. Click Equipment tab ➤ Modify panel ➤ Convert To Device .

3. In the Device Convert - Behavior dialog, for Name, enter a unique name for the device, and for Type, select the type of device to create.

   **TIP** The Type property of the device can be useful when you need to modify multiple objects of the same type. You can quickly select all of the objects in the drawing, and then use a modify command, such as LIGHTINGMODIFY, to modify only the objects of a specific type.

4. For Layer Key, click to open the Select Layer Key dialog, select the layer key to associate with the device, and click OK.
The list of layer keys from which you can select is determined by the layer standard and layer key style that is specified for the current drawing. For more information, see *Specifying a Layer Standard and a Layer Key Style* on page 134.

**NOTE** Since you are creating a device and an associated device style using this process, the layer key determines not only the layer key for the individual device, but also the layer key defined in the device style. For more information, see *AutoCAD MEP Layer Standards* on page 132.

5 Click Delete the original object to replace the old object with the newly converted one.
6 Click Next.

7 Specify values for the electrical connectors on the device:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>enter a description for the connector</td>
<td>enter the text in Value column for Description. Use a descriptive phrase that identifies what the connector represents, such as Normal Power.</td>
</tr>
<tr>
<td>specify a type of circuit for the connector</td>
<td>select a system type for System Type.</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE</strong> If you select Power and Lighting, you can configure additional connector properties, such as voltage and load.</td>
</tr>
<tr>
<td>center the connector on the device</td>
<td>click Add Center Points from View Blocks in Top View.</td>
</tr>
<tr>
<td>specify the X, Y, and Z values for the connector</td>
<td>enter values for Connection Point X, Connection Point Y, and Connection Point Z.</td>
</tr>
<tr>
<td>add a connector</td>
<td></td>
</tr>
<tr>
<td>remove a connector</td>
<td>select the connector, and click <img src="image" alt="icon" /> .</td>
</tr>
</tbody>
</table>

For more information on the properties of electrical connectors, see *Configuring the Electrical Connectors of a Device* on page 395.
8 If the software finds no other additional blocks or parts of the same type as the one you are converting, you can click Finish to convert the object. Otherwise, click Next.

9 If you want to convert the additional blocks or parts to devices that have the same properties, select Convert all additional references to the selected block in the drawing, and click Finish.

Using the settings that you specified as well as the AutoCAD block or the view block currently assigned to the MvBlock or MvPart, the software creates a device style and a new device. However, the device style contains additional settings that you might want to configure. For example, you might want to select a wire cleanup method other than the default method; you might also want to make changes to the default view definitions. For information on configuring device styles, see
- Device Style Setup on page 367
- Configuring Styles on page 603

TIP After you have configured the device and the device style with the appropriate settings, you can create a tool from the device by dragging it to a tool palette. For more information, see Creating Tools for Style-Based Content on page 790.

Converting Device Styles to Blocks

You can convert a set of device styles to their individual components: the style settings and the AutoCAD® blocks used by the style views. The output of the conversion process includes:

- a set of drawings that contain the AutoCAD blocks. The process creates one drawing per view block per style, so each drawing contains a single block definition.

- a device conversion script (Custom Content File or CCF file) that contains the style settings. The script contains not only the values for the style settings, but also the file path locations of the output drawings that contain the AutoCAD blocks.

Typically, you use this process when you have a set of existing device styles that you want to customize. You convert the device styles to their individual components, customize the components (the blocks and the style settings in the script), and then use the modified script to convert the modified blocks to new device styles.
NOTE This conversion process produces only the previously specified output. Your original device style drawings remain unchanged.

To convert a set of device styles to their individual blocks

1. Click Manage tab ➤ MEP Content panel ➤ Decompose Devices.

2. In the Decompose Devices dialog, for File to Decompose, then select the drawing (DWG file) that contains the device styles to convert:

   If you want to... then...
   convert the device styles in the current drawing open in AutoCAD MEP click Current Drawing.

   convert the device styles in a drawing stored locally on your computer click the radio button beside the file path, click Browse, select the drawing file, and click Open.

3. For Block, click Browse, and select the folder in which to place the drawings that contain the AutoCAD blocks used by the device style views. Click OK.

   If the selected folder already contains drawings, then during the conversion process, you will be prompted about overwriting drawings with the same name.

   NOTE Like all AutoCAD® blocks, the blocks in the output drawings are stored in an invisible data area called the block definition table. For more information, see “How Blocks are Stored and Referenced” in AutoCAD® Help.

4. For Script Path, click Browse, and select the file name of the device conversion script to create:

   If you want to... then...
   create a new script in the Select File dialog, specify the location for the new script, enter a name, and click Save.

   overwrite the contents of an existing script in the Select File dialog, select the drawing, click Save, and then click Yes to confirm that the contents of the drawing can be overwritten.
Click Decompose.
The software converts the device styles into the blocks used by the style views and generates an associated script based on the style definitions.

NOTE Because a device style specifies only the positions of the connectors and not the method in which they were initially specified, the script sets the default value of the Connector Placement property of all connectors to Specify. As a result, before you reuse the conversion script to create new device styles, you might need to change these values.

You can now modify the blocks and the script, and then use them to create new device styles based on your modifications. For more information, see Converting Blocks to Device Styles on page 622.

Converting Blocks to Device Styles

You can convert a set of AutoCAD® blocks to device styles. The output of the conversion process is a drawing (DWG file) that contains the device styles.

Typically, you use this process in 1 of 2 contexts. In the first context, you want to create device styles using the blocks in your existing block libraries. During the process, you need to create a device conversion script (Custom Content File or CCF file) that contains the style settings to use to create the device styles.

In the second context, you have already converted a set of existing device styles to their individual components, customized the components, and now you want to create new device styles based on the customizations. In this case, you already have a conversion script, which you can customize and reuse.

Regardless of the context, you use only one script to produce one drawing containing device styles. For example, you would use one script to produce one drawing containing customized styles for receptacles.

To convert a set of blocks to device styles

1 Click Manage tab ➤ MEP Content panel ➤ Batch Convert Devices ➤.

2 In the Batch Convert Devices dialog, under Conversion Script File, for Path specify the device conversion script (CCF file) to use to convert the blocks to device styles.
The conversion script contains the device style settings to use, as well as references to the drawings that contain the AutoCAD® blocks to use for the style views.

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a script</td>
<td>click Create, and create the script using the Device Conversion Script dialog. For more information, see Creating Device Conversion Scripts on page 623.</td>
</tr>
<tr>
<td>use an existing script, such as a customized version of a script generated from converting existing device styles to blocks.</td>
<td>click Browse, select the script, and click Open.</td>
</tr>
</tbody>
</table>

**NOTE** To make changes to the script prior to using it, click Edit, and modify the script using the Edit Device Script dialog. For more information, see Modifying Device Conversion Scripts on page 625.

3 For Device File, click Browse, and specify the drawing (DWG file) to contain the new device styles:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>create the drawing</td>
<td>in the Select File dialog, specify the location for the new drawing, enter a name, and click Save.</td>
</tr>
<tr>
<td>overwrite the contents of an existing drawing</td>
<td>in the Select File dialog, select the drawing, click Save, and then click Yes to confirm that the contents of the drawing can be overwritten.</td>
</tr>
</tbody>
</table>

4 Click Generate.
   The software creates the device styles using the conversion script and the block definitions from the referenced drawings.

**IMPORTANT** If you need to make a few changes to the new device styles, modify the conversion script and repeat the conversion process to apply the changes. If you make the changes using the Style Manager instead, the changes are overwritten if you subsequently repeat the conversion process.

5 If there are errors in the process, click Log to view them. Otherwise, click Close.

**Creating Device Conversion Scripts**

A device conversion script in a CCF file contains the following information:

- values for device style settings
- references to drawings that contain AutoCAD® blocks

The software uses both the script and the blocks to create the device styles and their associated views.

If you are creating a set of device styles using the blocks in your existing block libraries, you need to create a conversion script. If you are customizing a set of existing device styles, you already have a script as a result of the conversion of the existing styles to their individual components, and you can modify that script instead.

**To create a device conversion script**

1 Click Manage tab ➤ MEP Content panel ➤  ➤ Batch Convert Devices .
2 In the Batch Convert Devices dialog, under Conversion Script File, click Create.

3 In the Device Conversion Script dialog, under Convert, specify the file or files that contain the blocks to convert to device styles:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>convert the blocks in a single drawing</td>
<td>click Drawing, click Browse, select the drawing, and click Open.</td>
</tr>
<tr>
<td>convert the blocks in all drawings in a folder</td>
<td>click Folder, click Browse, select the folder, and click OK.</td>
</tr>
</tbody>
</table>

4 Under Conversion Template, for Path specify the conversion template (Custom Content Template or CCT file) to use to create the conversion script:

**NOTE** The conversion template is the mechanism by which you specify default values for the settings in the conversion script that you create. Once the script is created, you can customize the settings as needed.

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a template</td>
<td>click Create. In the Open File box, specify the location for the new template, and, for File name, enter its name. Click Save. In the Conversion Template dialog, specify the values of the template settings. Click Close to return to the Device Conversion Script dialog.</td>
</tr>
</tbody>
</table>
### Modifying Device Conversion Scripts

During the process of converting blocks to device styles, you might need to modify the device conversion script that you are using.

---

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>use an existing template</td>
<td>click Browse. In the Open File box, select the existing template, and click Open.</td>
</tr>
</tbody>
</table>

**NOTE** To make changes to the template prior to using it, click Edit. In the Conversion Template dialog, modify the values of the template settings. Click Close to return to the Device Conversion Script dialog.

---

5 In the Device Conversion Script dialog, under Conversion Script, click Browse, and specify the location of the CCF file to create for this conversion script:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a new conversion script</td>
<td>in the Select File dialog, specify the location for the new script, enter a name, and click Save.</td>
</tr>
</tbody>
</table>

| overwrite the contents of an existing script | in the Select File box, select the existing script, click Save, and then click Yes to confirm that the contents of the script can be overwritten. |

6 Click Generate.

7 After the script is created, click Close to return to the Batch Convert Devices dialog to create the device styles.

For more information, see **Converting Blocks to Device Styles** on page 622.
If the conversion script was initially generated by the software as a result of converting existing device styles to blocks, you need to modify the script to reflect the customizations that you want before you use the same script to convert the blocks to new device styles.

If you created the conversion script, you might want to modify the script to change one or more settings before repeating the conversion process. Although you can also change the settings using the Style Manager, the changes are overwritten if you subsequently repeat the conversion process.

You modify a device conversion script using the Edit Device Script dialog.

In the dialog, the displayed settings change depending on whether you select a device style, a device view, or a connector in the table. For example, in the following images, notice how the heading names differ depending on the selected object.

**Selected style**

<table>
<thead>
<tr>
<th>Style Name</th>
<th>Type</th>
<th>Category</th>
<th>Modeling</th>
<th>Layer Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>12 Long Simple</td>
<td>Lighting</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ACCEL_FLSL_2_LONG_M</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ACCEL_FLSL_2_LONG_P</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Specify</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>0.000000</td>
<td>0.000000</td>
<td>0.000000</td>
<td></td>
</tr>
<tr>
<td>ACCEL_FLSL_2_LONG_P</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Selected view**

<table>
<thead>
<tr>
<th>Style Name</th>
<th>Type</th>
<th>Category</th>
<th>Modeling</th>
<th>Layer Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>12 Long Simple</td>
<td>Lighting</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ACCEL_FLSL_2_LONG_M</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ACCEL_FLSL_2_LONG_P</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Specify</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>0.000000</td>
<td>0.000000</td>
<td>0.000000</td>
<td></td>
</tr>
<tr>
<td>ACCEL_FLSL_2_LONG_P</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Selected connector**

<table>
<thead>
<tr>
<th>Style Name</th>
<th>Type</th>
<th>Category</th>
<th>Modeling</th>
<th>Layer Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>12 Long Simple</td>
<td>Lighting</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ACCEL_FLSL_2_LONG_M</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ACCEL_FLSL_2_LONG_P</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Specify</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>0.000000</td>
<td>0.000000</td>
<td>0.000000</td>
<td></td>
</tr>
<tr>
<td>ACCEL_FLSL_2_LONG_P</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

To modify a device conversion script

1. Click Manage tab ➤ MEP Content panel ➤ Batch Convert Devices ➤ Batch Convert Devices.
2. In the Batch Convert Devices dialog, under Conversion Script File, for Path specify the device conversion script (CCF file) to use to convert the blocks to device styles. Then, click Edit.
3 In the Edit Device Script dialog, modify the script:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>modify a device style</td>
<td>select the style, and modify its properties using the available options.</td>
</tr>
<tr>
<td>add a device style</td>
<td>click , select the new style, and modify its properties.</td>
</tr>
</tbody>
</table>
| modify a view for a device style | select the view, and modify its properties using the available options.  
For example, you might want to specify a different source AutoCAD® block for the view. To do so, you can modify the block definition in the drawing specified in the Source Block property, or you can specify the file path of a different drawing. |
| add a view to a device style | select the style to which to add the view, and click . Select the view, and modify its properties. |
| modify a connector for a device style | select the connector, and modify its properties using the available options. |

**NOTE** If you are using a script generated using the Decompose Devices command, you might need to specify a value for the Connector Placement property for some connectors. The script sets this property to Specify by default. You can select  
- Specify, and then enter the X, Y, and Z coordinates  
- Center to place the connector at the center of the view block  
- Insert to place the connector at the insertion point of the view block  
- Node to place a connector at each AutoCAD point object in the view block

| add a connector to a device style | select the view to which to add the connector, and click . Select the connector, and modify its properties. |
| delete a device style, a view, or a connector | select the style, the view, or the connector, and click . |

To assist you in modifying the script, the sections that follow identify where you configure the same device style properties in the user interface. For more information on device style settings, see Device Style Setup on page 367 and Configuring Styles on page 603.

4 Click Close to save your changes and return to the Batch Convert Devices dialog to create the device styles.

For more information, see Converting Blocks to Device Styles on page 622.

**Style Properties**

The Style Name property in the device conversion script displays on the General tab of the Style Manager. On the tab, the property is called Name.
The Type, Layer Key, and Masking properties in the script display on the Design Rules tab of the Style Manager. On the tab, the Masking property is called Wire Cleanup.

The Category property in the script does not display in the Style Manager. Device categories are the mechanism by which you group the devices (device styles) in the Select Device worksheet, making it easier to browse the available devices. You create and manage device categories directly in the worksheet; for more information, see Creating Categories in AutoCAD MEP.

If you enter a name in the Category property of the device conversion script, the software adds the device (device style) to the category. If the category does not exist, it is created in the style drawing.

**View Properties**

The view properties in the device conversion script display on the Views tab of the Style Manager. On the tab, the Annotation View property is called Annotation Block.
The Source Block property in the script does not display on the tab. When you create a style view using the Style Manager, you do not specify the file path of the drawing containing the source AutoCAD block, because you are limited to selecting a block in the current drawing.

**Connector Properties**

The connector properties in the device conversion script display on the Connectors tab of the Style Manager. On the tab, the Connector Type property is called System Type.

The Connector Placement property in the script does not display on the tab. In the Style Manager, you can only specify a connector position by entering the X, Y, and Z coordinates, or by placing the connector at the center of the block, using the options shown in the image.
Customizing Schematic Symbol Content

This section provides information on several conversion tools you can use to create schematic symbol content.

For information on creating style-based content manually, see Workflow for Creating Style-Based Content on page 599.

Converting Schematic Symbol Styles to Blocks

You can convert a set of schematic symbol styles to their individual components: the style settings and the AutoCAD® blocks used by the style views. The output of the conversion process includes:

- a set of drawings that contain the AutoCAD blocks. The process creates one drawing per view block per style, so each drawing contains a single block definition.
- a symbol conversion script (Custom Content File or CCF file) that contains the style settings. The script contains not only the values for the style settings, but also the file path locations of the output drawings that contain the AutoCAD blocks.

Typically, you use this process when you have a set of existing schematic symbol styles that you want to customize. You convert the styles to their individual components, customize the components (the blocks and the style settings in the script), and then use the modified script to convert the modified blocks to new styles.

NOTE This conversion process produces only the previously specified output. Your original schematic symbol style drawings remain unchanged.

To convert a set of schematic symbol styles to their individual blocks

1 Click Manage tab ➤ MEP Content panel ➤ Decompose Symbols.

![Decompose Symbols dialog box](image)
2 In the Decompose Symbols dialog, for File to Decompose, select the drawing (DWG file) that contains the schematic symbol styles to convert:

<table>
<thead>
<tr>
<th>If you want to</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>convert the schematic symbol styles in the</td>
<td>click Current Drawing.</td>
</tr>
<tr>
<td>current drawing open in AutoCAD MEP</td>
<td></td>
</tr>
<tr>
<td>convert the schematic symbol styles in a</td>
<td>click the radio button beside the file path, click Browse, select the drawing file, and click Open.</td>
</tr>
<tr>
<td>drawing stored locally on your computer</td>
<td></td>
</tr>
</tbody>
</table>

3 For Block Path, click Browse, and select the folder in which to place the drawings that contain the AutoCAD blocks used by the views in the schematic symbol styles. Click OK.

If the selected folder already contains drawings, then during the conversion process, you will be prompted about overwriting drawings with the same name.

**NOTE** Like all AutoCAD® blocks, the blocks in the output drawings are stored in an invisible data area called the block definition table. For more information, see “How Blocks are Stored and Referenced” in AutoCAD® Help.

4 For Script Path, click Browse, and select the file name of the symbol conversion script to create:

<table>
<thead>
<tr>
<th>If you want to</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a new script</td>
<td>in the Select File dialog, specify the location for the new script, enter a name, and click Save.</td>
</tr>
<tr>
<td>overwrite the contents of an existing script</td>
<td>in the Select File dialog, select the drawing, click Save, and then click Yes to confirm that the contents of the drawing can be overwritten.</td>
</tr>
</tbody>
</table>

5 Click Decompose.

The software converts the schematic symbol styles into the blocks used by the style views and generates an associated script based on the style definitions.

**NOTE** Because a schematic symbol style specifies only the positions of the connectors and not the method in which they were initially specified, the script sets the default value of the Connector Placement property of all connectors to Specify. As a result, before you reuse the conversion script to create new schematic symbol styles, you might need to modify these values.

You can now modify the blocks and the script, and then use them to create new schematic symbol styles based on your modifications. For more information, see *Converting Blocks to Schematic Symbol Styles* on page 631.

## Converting Blocks to Schematic Symbol Styles

You can convert a set of AutoCAD® blocks to schematic symbol styles. The output of the conversion process is a drawing (DWG file) that contains the styles.

Typically, you use this process in 1 of 2 contexts. In the first context, you want to create schematic symbol styles using the blocks in your existing block libraries. During the process, you need to create a symbol conversion script (Custom Content File or CCF file) that contains the style settings to use to create the schematic symbol styles.

In the second context, you have already converted a set of existing schematic symbol styles to their individual components, customized the components, and now you want to create new schematic symbol styles based
on the customizations. In this case, you already have a conversion script, which you can customize and reuse.

Regardless of the context, you use only one script to produce one drawing containing schematic symbol styles. For example, you would use one script to produce one drawing containing customized styles for HVAC equipment.

To convert a set of blocks to schematic symbol styles

1. Click Manage tab ➤ MEP Content panel ➤ ➤ Batch Convert Symbols.

   The software displays the Batch Convert Symbols dialog.

2. In the Batch Convert Symbols dialog, under Conversion Script File, for Path specify the symbol conversion script (CCF file) to use to convert the blocks to schematic symbol styles. The symbol conversion script contains the style settings to use, as well as references to the drawings that contain the AutoCAD® blocks to use for the style views.

   **If you want to...**  
   **then...**

   - create a script  
     click Create, and create the script using the Symbol Conversion Script dialog. For more information, see Creating Symbol Conversion Scripts on page 633.

   - use an existing script, such as a customized version of a script generated from converting existing schematic symbol styles to blocks.  
     click Browse, select the script, and click Open.  
     **NOTE** To make changes to the script prior to using it, click Edit, and modify the script using the Edit Symbol Script dialog. For more information, see Modifying Symbol Conversion Scripts on page 635.

3. For Symbol File, click Browse, and specify the drawing (DWG file) to contain the new schematic symbol styles:

   **If you want to...**  
   **then...**

   - create the drawing  
     in the Select File dialog, specify the location for the new drawing, enter a name, and click Save.
If you want to… then...

| overwrite the contents of an existing drawing | in the Select File dialog, select the drawing, click Save, and then click Yes to confirm that the contents of the drawing can be overwritten. |

4 Click Generate.
The software creates the schematic symbol styles using the conversion script and the block definitions from the referenced drawings.

**IMPORTANT** If you need to make a few changes to the new styles, modify the symbol conversion script and repeat the conversion process to apply the changes. If you make the changes using the Style Manager instead, the changes are overwritten if you subsequently repeat the conversion process.

5 If there are errors in the process, click Log to view them. Otherwise, click Close.

## Creating Symbol Conversion Scripts

A symbol conversion script in a CCF file contains the following information:

- values for schematic symbol style settings
- references to drawings that contain AutoCAD® blocks

The software uses both the script and the blocks to create the schematic symbol styles and their associated views.

If you are creating a set of schematic symbol styles using the blocks in your existing block libraries, you need to create a conversion script. If you are customizing a set of existing styles, you already have a script as a result of the conversion of the existing styles to their individual components, and you can modify that script instead.

**To create a symbol conversion script**

1 Click Manage tab ➤ MEP Content panel ➤ Batch Convert Symbols.

The software displays the Batch Convert Symbols dialog.

2 In the Batch Convert Symbols dialog, click Create.

3 In the Symbol Conversion Script dialog, under Convert, specify the file or files that contain the blocks to convert to schematic symbol styles:
If you want to… then…

convert the blocks in a single drawing click Drawing, click Browse, select the drawing, and click Open.

convert the blocks in all drawings in a folder click Folder, click Browse, select the folder, and click OK.

4 Under Conversion Template, for Path, specify the conversion template (Custom Content Template or CCT file) to use to create the conversion script:

NOTE The conversion template is the mechanism by which you specify default values for the settings in the conversion script that you create. Once the script is created, you can customize the settings as needed.

If you want to… then…

create a template click Create. In the Open File box, specify the location for the new template, and, for File name, enter its name. Click Save. In the Conversion Template dialog, specify the values of the template settings. Click Close to return to the Symbol Conversion Script dialog.
If you want to… then…

use an existing template click Browse. In the Open File box, select the existing template, and click Open.

NOTE To make changes to the template prior to using it, click Edit. In the Conversion Template dialog, modify the values of the template settings. Click Close to return to the Symbol Conversion Script dialog.

5 In the Symbol Conversion Script dialog, under Conversion Script, click Browse, and specify the location of the CCF file to create for this conversion script:

If you want to… then…

create a new conversion script in the Select dialog, specify the location for the new script, enter a name, and click Save.

overwrite the contents of an existing script in the Select dialog, select the existing script, click Save, and then click Yes to confirm that the contents of the script can be overwritten.

6 Click Generate.

7 After the script is created, click Close to return to the Batch Convert Symbols dialog to create the schematic symbol styles.

For more information, see Converting Blocks to Schematic Symbol Styles on page 631.

Modifying Symbol Conversion Scripts

During the process of converting blocks to schematic symbol styles, you might need to modify the symbol conversion script that you are using.
If the conversion script was initially generated by the software as a result of converting existing schematic symbol styles to blocks, you need to modify the script to reflect the customizations that you want before you use the same script to convert the blocks to new styles.

If you created the conversion script, you might want to modify the script to change one or more settings before repeating the conversion process. Although you can also change the settings using the Style Manager, the changes are overwritten if you subsequently repeat the conversion process.

You modify a symbol conversion script using the Edit Symbol Script dialog.

In the dialog, the displayed settings change depending on whether you select a schematic symbol style, a view, or a connector in the table. For example, in the following images, notice how the heading names differ depending on the selected object.

**Selected style**

**Selected view**

**Selected connector**

To modify a symbol conversion script

1. Click **Manage tab ➤ MEP Content panel ➤ Batch Convert Symbols**.
2. In the Batch Convert Symbols dialog, under **Conversion Script File**, for **Path** specify the symbol conversion script (CCF file) to use to convert the blocks to schematic symbol styles. Then, click **Edit**.
3 In the Edit Symbol Script dialog, modify the script:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>modify a schematic symbol style</td>
<td>select the style, and modify its properties using the available options.</td>
</tr>
<tr>
<td>add a schematic symbol style</td>
<td>click 📊, select the new style, and modify its properties.</td>
</tr>
<tr>
<td>modify a view for a style</td>
<td>select the view, and modify its properties using the available options.</td>
</tr>
<tr>
<td></td>
<td>For example, you might want to specify a different source AutoCAD® block for the view. To do so, you can modify the block definition in the drawing specified in the Source Block property, or you can specify the file path of a different drawing.</td>
</tr>
<tr>
<td>add a view to a style</td>
<td>select the style to which to add the view, and click 📊. Select the view, and modify its properties.</td>
</tr>
<tr>
<td>modify a connector for a style</td>
<td>select the connector, and modify its properties using the available options.</td>
</tr>
</tbody>
</table>
|                                  | **NOTE** If you are using a script generated using the Decompose Symbols command, you might need to specify a value for the Connector Placement property for some connectors. The script sets this property to Specify by default. You can select  
  ■ Specify, and then enter the X, Y, and Z coordinates  
  ■ Select Center to place the connector at the center of the view block  
  ■ Select Insert to place the connector at the insertion point of the view block  
  ■ Select Node to place a connector at each AutoCAD point object in the view block |
| add a connector to a style       | select the view to which to add the connector, and click 📊. Select the connector, and modify its properties. |
| delete a style, a view, or a connector | select the style, the view, or the connector, and click:X. |

To assist you in modifying the script, the sections that follow identify where you configure the same properties of schematic symbol styles in the user interface. For more information on schematic symbol style settings, see Configuring Styles on page 603.

4 Click Close to save your changes and return to the Batch Convert Symbols dialog to create the schematic symbol styles.

For more information, see Converting Blocks to Schematic Symbol Styles on page 631.

**Style Properties**

The Style Name property in the symbol conversion script displays on the General tab of the Style Manager. On the tab, the property is called Name.
The Masking property in the script displays on the Design Rules tab of the Style Manager. On the tab, the property is called Line Cleanup.

The Category property in the script does not display in the Style Manager. Schematic symbol categories are the mechanism by which you group the symbols (symbol styles) in the Select Schematic Symbol worksheet, making it easier to browse the available symbols. You create and manage symbol categories directly in the worksheet.

If you enter a name in the Category property of the symbol conversion script, the software adds the symbol (symbol style) to the category. If the category does not exist, it is created in the style drawing. For more information, see Categorizing Style-Based Content on page 617.

View Properties

The view properties in the symbol conversion script display on the Views tab of the Style Manager. On the tab, the Create ISO Blocks property is called Generate Isometric Views.
The Source Block property in the script does not display on the tab. When you create a style view using the Style Manager, you do not specify the file path of the drawing containing the source AutoCAD block, because you are limited to selecting a block in the current drawing.

**Connector Properties**

The connector properties in the script display on the Connectors tab of the Style Manager.

The Connector Placement property in the script does not display on the tab. In the Style Manager, you can only specify a connector position by entering the X, Y, and Z coordinates, or by placing the connector at the center of the block, using the options shown in the image.
This chapter provides information on creating content stored in catalogs, namely, parametric and block-based parts and fittings. For information on creating style-based content, see Customizing Style-Based Content on page 599.

Understanding Parametric and Block-Based Parts

You can create 2 types of content using Content Builder: parametric parts and block-based parts. To determine what type of part to create, it is important to understand how each type is defined, how the parts are used in AutoCAD MEP, and what type is best for certain parts.

**Parametric Parts**

Parametric parts give you the flexibility to create parts that are dynamically sized according to size parameters. You define a parametric part by creating a 3D model of the part and assigning variables, or parameters, to control its shape and size. Parameters are defined by individual values, lists of values, or calculated values based on equations. When the part is placed in your drawing, you specify values for the parameters and the part is dynamically built to reflect the specified shape and size. Parametric parts enable you to create a single 3D model for a part family that can be updated to represent multiple part sizes. Parametric parts enable you to define millions of parts through a single model, depending on the number and type of parameters defined.

**RELATED** See Workflow for Creating a Parametric Fitting with Content Builder on page 674 and Workflow for Creating a Parametric MvPart with Content Builder on page 696 for steps to build parametric parts in AutoCAD MEP.

It is beneficial to create parts like equipment and fittings as parametric parts. Equipment, such as an air terminal, a junction box, or a tank, share the same geometric features; however, the features change in size according to the design. Following are examples of custom parametric parts for each module.

**Mechanical:** A 4 x 4-inch rectangular floor register looks the same as a 6 x 6-inch rectangular floor register, except for the longer length and width. By creating a parametric part, you can create a 3D model of a rectangular floor register and assign parameters for the length and width that can change in size. When the register is placed in your drawing, you can specify the length and width, and the register is dynamically built to match.
Viewing different-sized air terminals

- **Electrical:** A 13-hole junction box for 1-inch conduit looks the same as a 13-hole junction box for 3-inch conduit, except for the size of the inlet for the conduit connection. By creating a parametric part, you can create a 3D model of a 13-hole junction box and assign a parameter for the conduit connection that can change in size. When the junction box is placed in your drawing, you specify the size of the conduit and the junction box is dynamically built to match.

Viewing different-sized junction boxes

- **Plumbing:** A 120-gallon storage tank looks the same as a 350-gallon storage tank, except for the height and diameter. By creating a parametric part, you can create a 3D model of a storage tank and assign parameters for the height and diameter that can change in size. When the storage tank is placed in your drawing, you can specify the height and diameter, and the tank is dynamically built to match.

Viewing different-sized tanks

Fittings such as elbows, tees, and crosses also share geometric features that change in size according to the design. For example, a round 2-inch elbow looks the same as a round 6-inch elbow, except for the diameter and elbow radius. By creating a parametric part, you can create a single 3D model of a round elbow and assign parameters for the diameter and elbow radius that can change in size as needed. When the elbow is placed in your drawing, you can specify the diameter and radius and the elbow is dynamically built to match.

Viewing different-sized elbows
Block-Based Parts

A block-based part is defined as a multi-view part (MvPart) whose geometry is based on individual AutoCAD® blocks. Each part size is associated with a unique 3D model block, to which you specify basic information such as view representations and connector placement. 2-dimensional (2D) block representations are generated for each part size. When the part is placed in your drawing, you select a specific part size, and the unique representation of the part is added to your drawing.

You create equipment, referred to as MvParts, as block-based parts. MvParts, such as air handling units, motor control centers, or pumps, typically consist of a group of unique parts with their own geometric features. Shape, size, connection points, and properties such as manufacturer or material may differ.

**NOTE** MvParts that are simple in design, such as air terminals or fans, can also be created as parametric parts.

For example, a gas air handling unit and an electric air handling unit are not only different in shape and size but also in placement of connection points and types of connectors.

**Viewing different air handling units**

![air handling unit 1](image1.png) ![air handling unit 2](image2.png)

**TIP** Create parametric parts for equipment and fittings that are simple in design and require many part sizes. Create block-based parts for equipment and fittings that are complex in design and require only a few part sizes.

**Approaches to Creating Parts**

The Content Builder on page 647 dialog offers several task-specific options to build custom parts in AutoCAD MEP. You can create or modify both parametric and block-based parts.

Depending on the task you select, Content Builder has 2 working environments: parametric building and block-based building.

**Parametric Building Environment**

Content Builder uses the parametric building environment when you choose to create or modify a parametric part. The following example shows Content Builder displaying a rectangular duct to round conical tap tee. For more information, see Starting Content Builder on page 647.
This environment includes the following user interface features:

- The part browser is displayed on the left side of the screen and provides an organized view into the features of your part. As you define your part, additional features are nested in a hierarchy under the appropriate folder. In the browser, you can show as much or as little detail as you wish by expanding or collapsing the folders.

- The modeling area is displayed on the right side of the screen and is designed to give you full view control over your part model. You can use the standard AutoCAD view commands to change the direction in which you view your part model.

- The toolbar provides quick access to select Content Builder commands. Icons are available for saving your part, saving an existing part as a new part, generating a preview image, validating your part, and specifying part options.

- The status bar, located at the bottom of the part browser, provides updated information about part validation when you click the Validate icon on the toolbar. A description of the validation status is provided in addition to a traffic light that displays green when the part is valid and red when the part is invalid. A details button provides a list of warnings and/or errors found in your model.

- Feature-specific menus are available when you right-click a part feature in the browser window. Options that are not available are shaded.

The part browser and the modeling area are resizable windows. You can drag a corner of a window to change its shape and size, and you can drag a window to a new location on your screen.

Block-Based Building Environment

Content Builder uses the block-based building environment when you choose to create or modify a block-based part.

This environment features 2 modes:

- You create block-based parts or add part sizes to part families. The Wizard mode steps you through defining part behavior, individual part sizes, AutoCAD blocks used to represent each part size, a preview
You modify block-based parts. Tabs are available for part behavior, assigned blocks and names, preview image, part connectors, and assigned property set information. You can make changes to one or all of
the tabs at any time. For more information, see Starting Content Builder for Modifying a Block-Based Part on page 764.

Content Builder

The AutoCAD MEP software uses the term content to represent real-world parts, such as fittings and equipment. Content Builder is a content creation tool included in AutoCAD MEP. It is an integrated package of 3D modeling tools and 2D drafting and drawing capabilities that helps you to conceptualize, design, and build content. Each piece of content represents a part family, such as air terminal, junction box, or tank, that contains a collection of part sizes, such as a 4 x 4-inch rectangular floor register, a 1-inch conduit 13-hole square junction box, or a 150-gallon vertical tank, respectively. Content Builder enables you to create and modify part families and individual part sizes.

When you use Content Builder, you build 3D models of parts and generate and assign 2D drawing views of those parts to use in design layouts. The model is defined in terms of the size, shape, and position of the features that make up the part. You associate the part with a catalog and navigate to that part when you want to add it to your layout. You also add connectors to the part to enable intelligent connections to other building systems objects, in order to create complete building systems networks.

Tips for Using Content Builder

The following items are tips you should keep in mind as you use Content Builder.

■ Save a backup copy of the part catalogs before using Content Builder, in case you need to revert to the original catalogs provided with AutoCAD MEP. You can use a browser application, such as Windows® Explorer, to copy and paste the catalogs and their sub-folders to a new location.

■ Determine model dependencies. Analyze the model design to determine how features interrelate; then decide how to create the model.
Work in a 3-dimensional (3D) view. Creating the model in a 2-dimensional (2D) view may lead to confusion.

Use the order of the folders in the part browser as a guide to the steps involved in the creation process.

Do not use the EXPLODE command. Exploding a part deletes the part definition from the catalog.

Content Builder generates drawing views of your parametric part. The AutoCAD MVIEW command does not create associative views of your parts.

AutoCAD object snaps can be used to assist in object selection.

Allowing for Automatic Layer Mapping of Part Sizes for Content Builder

When using Content Builder, you assign a layer key to the part family to allow for automatic layer mapping of part sizes. Only those layer keys predefined in the layer key style selected for your current drawing are available for selection in Content Builder. Therefore, before using Content Builder, you must select a layer standard and layer key style to use for your part sizes. Recommended selections are the MEP - AIA layer standard (AecbLayerStd4.dwg) and Mech - AIA 256-color layer key style, which are provided with AutoCAD MEP. They include layer keys for all AEC objects.

A layer key style is used to map an AEC object, such as an MvPart, to a defined layer based on a layer standard. When you add an AEC object to a drawing that has a specified layer standard and layer key style, the AEC object is placed on the layer to which it is mapped. This is referred to as layer keying. For example, according to the MEP - AIA layer standard (AecbLayerStd4.dwg) and associated (Mech - AIA) layer key style, the Air Handling Unit layer key is mapped to the M-HVAC-Eqpm layer. Therefore, when you add an air handling unit to your drawing, it is assigned to the M-HVAC-Eqpm layer. For layer keying to work, you must select a layer standard and layer key style for your drawing.

NOTE To learn more about layer standards and working with layer keying, see AutoCAD MEP Layer Standards on page 132 in this Help system or Layer Management in AutoCAD Architecture Help.

To select a layer standard and layer key style

1 Click Home tab ➤ Layers panel ➤ Select Layer Standard ➝ .
   The Drawing Setup dialog is displayed.

2 On the Layering tab, under Layer Standards/Key File to Auto-Import, browse to select a drawing that contains the layer standard and layer key style you want to use, and then click Open.
   It is recommended that you select the AecbLayerStd4.dwg layer standard located in the \ProgramData\Autodesk\MEP 2010\enu\Layers folder to use the standard AutoCAD MEP layers.

3 Under Default Layer Standard, select a layer key style from the list, and then click OK.
   It is recommended that you select the Mech - AIA 256-color layer key style to make all AEC object layer keys available in Content Builder.

Starting Content Builder

When you start Content Builder, the Getting Started - Catalog Screen dialog is displayed. This task-specific dialog acts as a toggle, giving you quick access to the different working environments. The Getting Started - Catalog Screen dialog has a part catalog browser and an icon bar. You select a catalog from the list of loaded part catalogs that are specified on the MEP Catalogs tab in the Options dialog. To learn more about a part catalog and how parts are stored in a catalog, see Working with Catalog-Based Content on page 79.
IMPORTANT When selecting a catalog, it is important to analyze the type of part you want to create or modify. MvParts belong to a single catalog; however, they can have a different domain for each connection.

When selecting a part to create or modify, the Getting Started - Catalog Screen dialog detects the part domain, and guides you by activated icons to ensure that you use the correct building environment. Icons are activated based on the selected domain and part in the part catalog browser, whether parametric or block-based. For example, if you select an MvPart part catalog, both the New Block Part and New Parametric Part icons are available. However, if you select a component part catalog such as duct or cable tray, only the New Parametric Part icon is available.

Block-based parts are created and modified through the block-based building environment, and parametric parts are created and modified through the parametric building environment. For more information about the building environments in Content Builder, see Approaches to Creating Parts on page 643.

To start Content Builder and open a building environment

1 Click Manage tab ➤ MEP Content panel ➤ Content Builder . The Getting Started - Catalog Screen dialog is displayed.

2 Select a part catalog.

TIP Be sure to select the correct catalog when creating a new part. Each catalog domain creates specific data that is added to the parts in the respective catalog. The catalog path is determined by the settings used in the catalog tab of the Options dialog on page 70.
IMPORTANT To facilitate the process of upgrading to a new version of AutoCAD MEP, add all your custom parts to custom catalogs. Do not add custom parts to the catalogs provided with the software. When you upgrade, this allows you to easily move all your custom catalog content as a whole to the catalog folders for the new version (where new versions of the catalogs provided with the software are also located). You can use both types of catalogs during layout if you specify multiple catalogs for a domain, as described in Specifying Part Catalogs and Style-Based Content Locations on page 70.

3 In the Getting Started - Catalog Screen dialog, do one of the following:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then select a chapter and ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>create a new block-based MvPart</td>
<td>click <img src="image.png" alt="image" />. Enter a name and description for the MvPart, and click OK. The block-based building environment is opened for part creation.</td>
</tr>
<tr>
<td>create a new parametric MvPart</td>
<td>click <img src="image.png" alt="image" />. Enter a name and description for the MvPart, and click OK. The parametric building environment is opened for part creation.</td>
</tr>
<tr>
<td>add a new chapter for an MvPart</td>
<td>click <img src="image.png" alt="image" />, and enter a name. You can add chapters to the catalog or to another chapter.</td>
</tr>
<tr>
<td>add a new part size to an existing MvPart</td>
<td>select the MvPart, and click <img src="image.png" alt="image" />. The appropriate building environment is opened for modifying the part.</td>
</tr>
<tr>
<td>modify an existing part size</td>
<td>select the MvPart, and click <img src="image.png" alt="image" />. The appropriate building environment is opened for modifying the part.</td>
</tr>
<tr>
<td>delete an MvPart</td>
<td>select the MvPart, and click <img src="image.png" alt="image" />. The part is deleted from the catalog and is removed from the tree.</td>
</tr>
</tbody>
</table>

NOTE After selecting an MvPart, if the model geometry is unavailable, you are accessing legacy content. Legacy content can only be modified. It is recommended to modify legacy content using Catalog Editor.

## Working with Parametric Parts

You can build parametric parts using the following tools:

- **Content Builder. on page 650** This tool contains a collection of 2D drawing and 3D modeling tools. You can create parts by building them component-by-component or by assembling them from primitives, predefined models that represent basic shapes and connections.

- **Parametric Part Wizard on page 694**. This wizard enables you to quickly create common parts that require only basic models. You create the parts using templates that are included in the software.

NOTE For an introduction to parametric parts, see Understanding Parametric and Block-Based Parts on page 641.
Building Parametric Fittings Using Content Builder

Content Builder contains a collection of 2D drawing and 3D modeling tools. Content Builder lets you create parts by building them component-by-component or by assembling them from primitives (predefined models that represent basic shapes and connections).

When creating a parametric part, you define the features of the part and how they are associated with one another. Each parametric part represents a unique part family. You should analyze the catalog hierarchy to determine the best place to add part families. It is also important to notice the relationships between the different part sizes you want to create. The features you define in the model determine the flexibility you have to create multiple part sizes. You should look at the entire part you want to create, decide how to break it down into simple shapes, and determine the relationships to establish between the different shapes.

Best Practices for Creating a Parametric Fitting

Content Builder is part of AutoCAD MEP, which is built on AutoCAD®, and uses many of the tools that you may already be familiar with. Content Builder is a unique building environment that enables you to create parametric parts. Therefore, care must be taken to avoid using standard AutoCAD commands. The following tips will help you to create a parametric fitting.

Tips for Modeling the Part

The following items are tips you should keep in mind as you model the parametric part.

- Use work planes to control the UCS orientation. Using the AutoCAD UCS command does not associate the current plane with your part.
- Use the AutoCAD Point Style command to increase point sizes. It is recommended to use an absolute point size.
- Use a minimum number of points. Reusing points is less confusing and helps in constraining the model.
- Use both constraints and dimensions. Some constraint combinations may distort unconstrained features of the model. If so, delete the last constraint and consider using a dimension or a different constraint combination.
- Use Content Builder dimensions. AutoCAD dimensions are not parametric and cannot control the size, shape, or position of part content.
- Dimension large features before small features. To minimize distortion, define larger features that have an overall bearing on the model. Dimensioning small features first may restrict overall size. Delete or undo a dimension if the model shape is distorted.
- Define shape before size. If you apply constraints before dimensions, your model shape is less likely to become distorted.
- Determine model dependencies before applying constraints. A single constraint can often be used to define more than one feature's shape. Therefore, analyze the model design to help identify necessary constraints.
- Add constraints as needed to define the model shape. Because constraints often restrict more than one feature, use fewer constraints to avoid distorted models.
- When using calculated values for model parameters, be aware that calculated values are not available in the part Add Size filter.
Recommendations for Creating Parametric Fittings Content

This topic provides recommendations to use when creating or modifying content for custom parametric fittings. The first section lists general recommendations and the other sections defines recommendations specific to the parametric part.

TIP Some of the following recommendations refer to male-female parts that you can build. A male-female part includes both male and female connectors on page 267.

General Recommendations

- Pipe parts are created in the Piping domain in the Top plane.
- You must build fittings as parametric parts. Parametric refers to a method in Content Builder that uses the values of part parameters to determine the geometric configuration of the part.

RELATED For more information about parametric parts, see Parametric Part Creation Overview on page 653 and Workflow for Creating a Parametric Fitting with Content Builder on page 674. For more information about connectors on a parametric part, see Connectors of a Parametric Part on page 666.

- You should follow the guidelines for connectors that are outlined in Rules for Connector Behavior on page 652.

NOTE Content Builder verifies that all pipe connectors have parameters for connection engagement length on page 267 (CEL), angle of deflection on page 267 (AoD), and nominal diameter (ND). The missing parameters are added if necessary, and then you are prompted to accept the changes.

- Part names should use the following conventions:
  Connection Type — Schedule/Pressure Class (if any)
  Part Type — Flanged - Class 2500 - Raised Face Blind Flange

Crosses

- Connector 1 on a male-female part is male. The CEL value for the male connector is equal to 0. Connectors 2 or 3 can be male or female. Connector 4 is female.
- The CEL on page 267 value for each female connector is greater than 0.
- Path angle PathA1 is equal to 180 degrees. Path angle PathA2 and path angle PathA3 can be equal to or less than 90 degrees.

RELATED For more information about path angles, see Dimensions on page 657.

Elbows

- Connector 1 on a male-female part is male.
- For elbows with 2 connectors, connector 2 is female. For elbows with 3 connectors, connector 2 or 3 can be male or female.
- Path angle PathA1 can be any angle value.

Offset Wyes (Laterals) and Tees

- Connector 1 on a male-female part is male. Connector 1 has a CEL value of 0.
- Connector 2 is female with a CEL value greater than 0.
Connector 3 can be male or female.

Path angle PathA1 is equal to 180 degrees. Path angle PathA2 can be equal to or less than 90 degrees.

**Eccentric Transitions**

- The female connectors on a male-female part can be located on either of the 2 connectors.
- Male connection types are undefined to allow the connection name to be inherited from the associated female connector.

**Grooved - True Wye**

- Connectors on a male-female part follow a clockwise orientation. For more information, see Connectors of a Parametric Part on page 666.
- As you draw pipe, auto layout on page 252 can generate routing solutions. However, these routing solutions on page 254 do not include the insertion of true wyes.

**Mechanical Joint (Bell, Hub)**

- Connector 1 on a male-female part is male. The CEL on page 267 value is equal to 0 and is set to constant. For more information, see Dimensions on page 657.
- The CEL value for connector 2 (female) is greater than 0 and is determined by the manufacturer.
- The part type is coupling.

**Rules for Connector Behavior**

In the Content Builder, connectors are assigned an undefined type by default. For more information, see Adding Connectors to a Parametric Fitting on page 682. An undefined connection type creates a valid connection between all types of connectors when inserted into a drawing. The following guidelines apply to connector behavior:

- Connectors are created in the Piping domain with a shape that is round.
- A male connector should be assigned the undefined connection type. Male connectors with this connection type use the connection assignments functionality in the Connection Assignments tab of the Pipe Layout Preferences dialog. For more information, see Connection Assignments on page 296.
- A pipe connector should have only 1 connection name selected on the Connection Type Selection dialog in the Content Builder. However, if more than 1 connector name is selected, then the first one that the software detects will be used. For more information, see Adding Connectors to a Parametric Fitting on page 682.
- Female connectors should be set to a connection type other than undefined.
- When a female connector is connected to an undefined connection type, that female connector will appear with the male connection type assigned to the female connection type name on the Connection Assignments tab of the Pipe Layout Preferences dialog. For more information, see Connection Assignments on page 296.
- Butt-welded connections only connect to other connectors of the same type. A butt welded connector has no CEL value (connection engagement length on page 267). It connects to other butt-welded connectors without a joint.
Connector 1 is on the bell end of the bell/hub, and connector 2 is on the back end. Connector 2 reports the same connection type as connector 1 on the Connection Assignments on page 296 tab of the Pipe Layout Preferences dialog.

The Piping domain has a connection type called Same Connection. When Same Connection is configured for a connector and coupling part types that are attached to a hub, connector 1 inherits the connection type of the connection type on connector 2 of the attached hub.

**Parametric Part Creation Overview**

This section presents a detailed overview of the fundamentals of parametric part creation using Content Builder. See Workflow for Creating a Parametric Fitting with Content Builder on page 674 for a high-level outline of the procedures you will perform.

**RELATED** See How Catalog Parts are Stored and Referenced on page 80 for information about part catalogs and their hierarchical structure.

**Part Configuration of a Parametric Part**

When the parametric building environment opens, the first folder in the part browser is the Part Configuration folder. The part configuration defines the characteristics and behavior of the part according to the domain, type, and subtype, and it is required to save the part. To ensure that the part can be validated and saved correctly, you should define the part configuration before starting to model the part.

**Example of part browser**

![Part Browser Example](image)

The part configuration is defined once for a part family and remains constant for all part sizes. There are 4 required components of the part configuration:

**Part Description** Describes the part family. You can edit the part description in the part browser. However, you cannot edit the part name here. When you create a new part, you enter the part name and description in the New Part dialog. By default, the description is the same as the part name unless a different description is entered. For existing parts, the part description is predefined.

**Part Domain** Defines the family of parts, such as duct components, pipe components, cable tray components, conduit components, or MvPart components. You cannot edit the part domain in the part browser. The part domain is predefined based on the part catalog you selected in the Getting Started - Catalog Screen dialog of Content Builder. The part domain is selected from a list of predefined domains for building systems.

**Part Type** The actual type of part, such as elbow, tee, fan, damper, or tank. From the list of predefined part types in the part browser, you specify the part type, which is based on the building system and loaded part catalogs. The part type is helpful during part selection.

**Part Subtype** Categorizes part types. In the part browser, you specify the part subtype from the list of predefined subtypes. You can also enter a custom part subtype if you wish. The part subtype is helpful during part selection to filter a large group of parts of similar type.
Model of a Parametric Part

A model is the graphical representation of a parametric part. In Content Builder, a model consists of various features that have specific relationships to each other and that define the behavior of the parametric part. Some features require that you create simple shapes or points, while others require an extrusion or path. Some represent visible geometry, and some help you to position geometry precisely on a part. You can modify features to refine and improve your parts over time. You change features by modifying their size and shape or by flipping or moving them. To effectively model a parametric part, it is important to understand how each feature relates to the other features of modeling.

The following illustration shows the features that make up the model. Arrows indicate the direction of the relationship between features. For example, modifying geometry affects a profile, which affects a modifier, and so on.

The following sections introduce the features of modeling. Refer to this illustration as you learn more about each feature to help you understand the relationships between features.

Work Planes

A work plane is a modeling feature that defines the location of a plane in 3-dimensional (3D) space. It is an infinite construction plane that can be placed at any orientation in space. It can be offset from an existing work plane, or it can reference 3D geometry. Using a work plane, you define the geometry, dimensions, constraints, and profiles that make up the part model. Work planes help you to place geometry that would otherwise be difficult to position parametrically. By constraining geometry to work planes, you can control their location. Work planes help you to define relationships between features and provide control when placing features.

A work plane is displayed as a rectangular 2-dimensional (2D) object. The work plane display is only a visual representation of the infinite plane and cannot be moved or resized. However, you can control its visibility for ease of viewing the model. Offset and reference work planes are user-defined and provide the flexibility to be moved and redefined.

**NOTE** To ensure a manageable model size, it is recommended to use a minimum number of work planes.

When you right-click on a work plane in the part browser, it is highlighted in the modeling area. You can change the view direction to match that of the selected work plane when adding geometry or dimensions by using the Set View option on the Work Plane context menu.

**IMPORTANT** Any features attached to a work plane are restricted to the original plane. If you move a work plane, any features attached to the plane also move. If you delete a work plane, any features attached to the plane are also deleted. Each feature attached to a work plane appears under the Work Plane folder in the part browser.

Content Builder provides 3 default work planes that intersect at the origin of the X, Y, and Z axes. The default work planes help you to get started with modeling a part. You can add work planes at any time during the modeling process. Each work plane has its own internal coordinate system. Work planes can be created on any plane in the current user coordinate system (UCS) or in the World Coordinate System (WCS).
The following preset work planes can be added to a model from the Create Work Plane dialog:

**Default** Creates the standard ZX, YZ, and XY work planes of the WCS.

**Custom** Creates a work plane that is not available by the preset work planes. The work plane has user-defined values for the X and Y direction and the origin of the plane in the current UCS.

**Offset** Creates a work plane that is offset by a specified distance from a selected source work plane. For more information, see Offset and Reference Work Planes on page 655.

**Reference** Creates a work plane that is attached to the extents of a modifier feature. For more information, see Offset and Reference Work Planes on page 655.

**Top** Creates a work plane that matches the standard Top 3D view.

**Bottom** Creates a work plane that matches the standard Bottom 3D view.

**Front** Creates a work plane that matches the standard Front 3D view.

**Back** Creates a work plane that matches the standard Back 3D view.

**Left** Creates a work plane that matches the standard Left 3D view.

**Right** Creates a work plane that matches the standard Right 3D view.

**Viewing default work planes**

Offset and Reference Work Planes

Offset and reference work planes are relational and are based on one or more defined features in the model, such as other work planes or modifiers.

**Offset Work Planes**

An offset work plane is some distance away from another work plane. This work plane can be offset from any existing work plane, including another offset or reference work plane. You define an offset work plane by selecting a source work plane and specifying a distance between the work planes. You can use offset work planes to maintain specified or calculated distances between features, such as profiles, geometry, or modifiers. You can also use offset work planes as construction guides for locating features that would otherwise be difficult to locate parametrically. For example, use an offset work plane to define the length of a transition.

**Creating an offset work plane**

**Reference Work Planes**

A reference work plane is defined as a plane on the face of the extents of a modifier. Every modifier has an invisible extent, or boundary box, that defines the extents of the feature. You can create a work plane that
references one of the planes of the extent. To define a reference work plane, you select a modifier and a source work plane that represents the plane direction you want to create. The extents, or boundary box, of the feature is detected, and 2 valid reference work planes are available for selection. If the modifier is moved or resized, the reference work plane is moved with it.

Creating a reference work plane

Geometry

You construct a model bit by bit, building shapes to add to it and using tools to cut away the portions of the shapes you do not need. In Content Builder, these shapes are features of the part you are creating. Geometry features are the basic building blocks for defining the size and shape of the model.

Geometry that you define is 2-dimensional (2D) and must be attached to a work plane. You can switch between work planes to define different geometry. As you add geometry to a work plane, the geometry features appear under the Geometry folder of the associated work plane.

WARNING Avoid using basic AutoCAD® geometry commands. AutoCAD geometry is not valid for work planes and cannot be used to create features for parametric part models.

Viewing geometry types

Content Builder provides 9 types of geometry you can use to build the model:

Point Defined by an X and Y coordinate.

Line Defined by a position and a direction; constrained by a start point and endpoint.

Unbounded Line Defined by a position and a direction; infinite in length because it has no constraining start point or endpoint.

Circle Defined by a center point and a radius.

Arc Defined by a center point and a radius; constrained by a start point and endpoint.

Rectangle Defined by lines and points that are constrained to maintain start points and endpoints for each side and perpendicular angle.

Oval Defined by lines, arc, and points that are constrained to create 2 arcs tangent to 2 lines, with defined start points and endpoints.
**Point Reference** Defined by a point in the work plane that is based on a source point selected from a different work plane. A point reference is moved or deleted with the source point.

**Project Geometry** Defined by a projection of a modifier on a specified work plane. The project geometry is fixed and cannot be moved in the work plane. It is linked to the modifier and adjusts as the modifier changes.

## Dimensions

Models require dimension information to maintain size and position for the design. Dimensions are typically added after you have finalized the geometric features of the model or when placing a connector; however, you can add dimensions at any time during the creation process. When you add dimensions, you apply rules that control the size and position of features in the model. Dimensions work in conjunction with constraints. The model is updated when changes are made to the dimensions.

Dimensions specify the length, diameter, or rotation angle of geometric elements in the model. When a dimension is added, a corresponding size parameter is also added. This parameter creates a placeholder value for the dimension that provides flexibility for defining the values of dimensions. Dimensions can be defined as default numeric constants or as equations. Although you can use them interchangeably, they each have specific uses.

- Numeric constants are useful when a geometric element has a static or fixed size that is populated as a value in a basic table, list, or constant storage type.
- Equations are useful when the size of a feature icon must be mathematically defined relative to the size of another feature.

Content Builder assigns a variable name to each dimension parameter. Letters and numbers are used to signify the type of dimension (such as length or diameter) and the sequence in which the dimension was added to the model (1 for first, 2 for second, and so on). To keep the model shape from becoming distorted as the dimensions resize it, define the large dimensions first. Dimension type depends on the feature you choose and where you place the dimensions.

**NOTE** When adding dimensions it is recommended to select points to specify the start and end locations. It is also helpful to turn off geometry that you are not dimensioning for ease of selection.

### Viewing dimension types

![Dimension types](image)

Content Builder provides 7 types of dimensions you can add to the model:

- **Distance** Can be defined for pairs of geometry of all types. Defines a value between 2 features. The value of a distance dimension cannot be negative. When adding distance dimensions between 2 lines, it is implied that the lines are parallel with a given separation.

- **Horizontal Distance** Can be defined for pairs of geometry of all types. Defines a value between 2 features in a horizontal direction. The value of a distance dimension cannot be negative.

- **Vertical Distance** Can be defined for pairs of geometry of all types. Defines a value between 2 features in a vertical direction. The value of a distance dimension cannot be negative.
**Parallel Distance** Can be defined for pairs of geometry of all types. Defines a value between 2 features in a parallel direction. The value of a distance dimension cannot be negative.

**Perpendicular Distance** Can be defined for pairs of geometry of all types. Defines a value between 2 features in a perpendicular direction. The value of a distance dimension cannot be negative.

**Diameter** Can be defined for circular and arc geometry. Defines a value for the diameter of a circular feature.

**Angle** Can be defined for pairs of linear geometry. Defines a value for the degrees between 2 linear features. See also Path Angle.

**Path Angle** Defines the sweep (angle direction) that the software uses to ensure that the 3D part is built correctly. Path Angle appears as PathA1, PathA2, etc. under Size Parameters in the Content Builder.

### Constraints

Depending on the geometry of the model, you may need to add one or more constraints to define the shape or size of the model. Constraints enforce rules that you want the model to obey. Constrained a model controls how a model can change in shape or size, called “degrees of freedom.” For example, a circle has 2 degrees of freedom: the location of its center and its diameter. If the center and diameter are defined, the circle is fully constrained and those values can be maintained. Constraints specify the relationships of geometric features; for example, whether 2 features are perpendicular, parallel, tangent, concentric, or have the same midpoint or radius.

**NOTE** After you add geometry, dimensions, or constraints to the model, the degrees of freedom are listed on the command line.

Constraints work in conjunction with dimensions to control the shape and size of the model. Any time you modify the model, the geometry retains the relationships among features in accordance with the applied constraints. You add constraints to indicate your design intent. For example, a parallel constraint could be defined between 2 lines based on the geometry of the model. You could also add a constraint to force both lines to have the same length.

As you apply geometric constraints, continue to analyze the model, reviewing and replacing constraints as necessary. As you gain experience, you will be able to determine which constraints control the model to meet your design requirements. Some constraints work only with lines, while others work only with arcs, circles, or points.

**Applying a tangent constraint**

**Applying a parallel constraint**

**Applying a perpendicular constraint**
Applying a concentric constraint

Content Builder provides 10 geometric constraints. The following list describes these constraints and the features with which they can be used.

**Tangent** Can be defined between curved geometry (such as a circle or arc) and either another curved geometry or a line. Makes 2 curves tangential to one another, even if they do not physically share a point. Tangency is commonly used to constrain a line to an arc or circle.

**Parallel** Can be defined between pairs of geometry with a direction, such as lines. Causes 2 or more lines to be parallel to one another.

**Perpendicular** Can be defined between pairs of geometry with a direction, such as lines. Causes selected lines to lie at right angles to one another.

**Concentric** Can be defined for any combination of circles and points. Fixes the centers of the geometry to the same location. Common uses include circle to circle, where the center of both circles is the same; circle to point, where the point lies at the center of the circle; and point to point, where the points are the same.

**Coincident** Can be defined between a point and any geometry. Fixes 2 points (including center points) together; essentially, the point lies on the geometry.

**Equal Distance** Can be defined between 2 pairs of geometry. The distance between the first pair of geometries is fixed to the distance between the second pair. Equal distance constraints do not control the actual distance. Each pair of geometries must be one of the following: any combination of points and lines, 2 circles or arcs concentrically constrained, or a point and circle or arc concentrically constrained.

**Equal Radius** Can be defined between 2 circles or 2 arcs. Fixes the radius of both circles or arcs to be of the same value. Equal radius constraints do not control the value of the radii.

**Midpoint** Can be defined between a point and either 2 other points or 2 lines. The point is equal distance from the other 2 geometries. Midpoint constraints do not control the distance. A common use is constraining a point to the middle of a line.

**Symmetric** Can be defined between 2 geometries of the same type and a line. The 2 geometries are symmetrically arranged on opposite sides of the line. The symmetric constraint does not force constrained geometry to maintain an exact mirror image.

**Normal** Can be defined between a line or curve and a curve. (2 lines cannot be made normal; a perpendicular constraint must be used instead.) The curves intersect and the directions of curve tangents are perpendicular at the point of intersection. A common use is constraining a line to the normal of an ellipse.

**Profiles**

A profile is a 2-dimensional (2D) outline of a geometric shape. Using Content Builder, creating a profile is as easy as drawing a closed shape. Profiles are similar to geometry in that they are a visual representation of the 2D shapes that make up the model. Because profiles automatically associate constraints to the geometry, you can use profiles as a source of information from which to create features. You create profiles on a work plane and apply modifiers, such as extrusions, to them.

Content Builder provides 4 types of profiles to use for creating features in the model:

**Circular** Creates a profile based on a circle defined by a center point and diameter to maintain its shape.
Rectangular: Creates a profile based on a rectangle defined by 4 lines, 4 points, and 4 perpendicular constraints to maintain its shape.

Oval: Creates a profile based on an oval defined by 2 lines, 2 arcs, 4 points, and 4 tangent constraints to maintain its shape.

Custom: Creates a profile from existing geometry in the model. The geometry must be attached to a single work plane. Constraints are assigned as needed to maintain the shape of the geometry as it was selected.

Modifiers

After creating profiles, you can apply modifiers to create 3-dimensional (3D) features of the model. A modifier is a general term for any operation that affects features of the model. You can use modifiers to extrude, add, or subtract features and to sweep a profile along a path. You can also use modifiers to create cut planes and transition features.

Content Builder provides 6 types of modifiers: extrusion, path, transition, cut plane, Boolean add, and Boolean subtract. The extrusion modifier is the most common type used in part modeling and is generally the base feature for a model. When you extrude a profile to create a feature, you specify how the feature will modify the shape by choosing 1 of 4 operations: midplane, plane, from-to, or blind.

Midplane Extrusion Modifier

A midplane extrusion uses a profile as the center of the extrusion and sweeps the profile an equal distance away from each side of the center.

Applying a midplane extrusion modifier

Plane Extrusion Modifier

A plane extrusion sweeps a profile between the profile itself and a specified work plane. If the work plane is a reference work plane, the extrusion is updated when the work plane is moved.

Applying a plane extrusion modifier

From-To Extrusion Modifier

A from-to extrusion sweeps a profile between 2 work planes.
Applying a from-to extrusion modifier

Blind Extrusion Modifier
A blind extrusion sweeps a profile a specified distance along its normal, or perpendicular axis. You can flip the extrusion to sweep the profile in the opposite direction as the default normal.

Path Modifier
A path modifier sweeps a profile along path geometry. It creates a 3D feature based on the start and end profile of a piece of geometry, such as a line or an arc. The start and end profiles can be different. Path modifiers are helpful in creating elbows.

Transition Modifier
A transition modifier creates a transition body between 2 profiles. A transition includes both a start and end profile, which cannot be in the same work plane. Point references are useful to ensure that the profiles align between work planes; however, the centers do not need to align.
Applying a transition modifier

**Cut Plane Modifier**

A cut plane modifier cuts a feature into 2 parts, only 1 of which is kept. A cut plane modifier enables you to change the end of a feature to a slope, providing for the creation of more advanced features, such as an exhaust vent. You can modify the cut plane by dragging the normal, or perpendicular axis, of the modifier to create custom slopes. Cut planes are updated when the length of the modifier changes.

**NOTE** Cut planes cannot be defined parametrically. How they are defined in the model is how they will be displayed when placed in your drawing.

Applying a cut plane modifier

**Boolean Add Modifier**

A Boolean add modifier combines 2 features to create a single feature. This modifier assumes a basic concept of addition: that geometry inside other geometry, when added together, is removed. This modifier is helpful when creating models of MvParts, such as equipment, that are placed in your drawing exactly as they were created in the model.

Applying a Boolean add modifier

**Boolean Subtract Modifier**

A Boolean subtract modifier subtracts one or more features from another to create a new feature. The Boolean subtract modifier uses a basic formula when creating the resulting feature: that the subtractor objects are
removed from the base object. To see results in the model, the subtractor features must intersect with the base feature. When no intersection of features exists, the subtractor features are removed from the base feature with no visible change in the model.

**Applying a Boolean subtract modifier**

![Diagram of subtracting objects](image)

**Primitives**

Primitives are limited versions of part models that are designed for repeated use in part creation. They represent basic shapes, such as a box or a torus, and commonly used connections on parts, such as a flanged pipe connector or duct connector.

**Primitives that represent basic shapes**

- Box
- Cone
- Cylinder

**Primitives that represent part connections**

- Undefined Duct Connector - Round
- Flanged Pipe Connector
- Grooved Pipe Connector

Primitives include the following modeling features:

- work planes
- geometry, constraints, dimensions, and model parameters
- profiles (2D outlines of geometric shapes)
- modifiers (operations that create 3D features from profiles)

Primitives that represent the connections on parts also include defined connections.
Because primitives do not represent complete parts, they do not have a defined part type, size parameters, or autolayout data. A primitive is defined by a DWG file that specifies its limited configuration, and a preview image (BMP file) that facilitates its selection when users are adding primitives to parts. Because primitives are not parts, you cannot add them to catalogs. They are stored in a content folder instead.

AutoCAD MEP includes primitives for many of the shapes commonly found in parts as well as for the connections that are typically required. Because the primitives include many of the modeling features that you need to build a custom parametric part, you can use them to quickly build a part model and add connections. For more information, see Modeling with Primitives on page 702.

**Trim Lengths and Placement Points**

After you finalize the model of your part, you need to define insertion behavior to ensure that your part can be placed correctly in a drawing. Insertion behavior includes specifying the placement point, or insertion point, that is used when placing the part in a drawing, and specifying the trim lengths for parts, such as fittings, that require other components to be trimmed when placing the part in a run.

The Auto Layout option in the Content Builder Options dialog controls whether trim lengths and placement points can be defined for a part. When you enable this option, an Autolayout Data folder is available in the part browser that includes commands for adding trim lengths and placement points.

**NOTE** For parametric MvParts, the Autolayout Data folder is included in the part browser by default, enabling you to define the placement point directly during the modeling process.

**Trim Lengths**

Trim lengths are available only when creating a parametric fitting. Configured to work with the Auto Layout option enabled, trim lengths define the length dimensions used to trim other components to make room for a new fitting. For example, when you add a tee to an existing run in your drawing, the segment is trimmed to the length of the trunk, creating 2 individual segments, 1 on either side of the fitting.

Each trim length is defined from the center, or intersection point, of the fitting to an end, or connection point, of the fitting. To ensure components are trimmed correctly when placing a parametric part into a drawing, you must define trim lengths for the part in a specific order—left to right, then bottom to top. The number of trim lengths required for a part depends on the type of fitting and the number of connection points, as shown next:

- Elbows require 2 trim lengths

  ![Elbow Trim Lengths](image)

-Reducers require 2 trim lengths

  ![Reducer Trim Lengths](image)

- Tees require 3 trim lengths

  ![Tee Trim Lengths](image)
Crosses require 4 trim lengths

To add a trim length, you select valid node points that are displayed in the model and define a distance for the length. The following illustration shows how trim lengths for a tee fitting would be defined:

A tee has 3 trim lengths: 2 are defined from the center point of the trunk to each end of the trunk legs (1 & 2), and the third is defined from the center of the trunk to the end of the branch leg (3).

Placement Points

For parametric MvParts, the placement point is the insertion point used to place the part in a drawing. You simply specify a point in your model for the placement point. For parametric fittings, the Auto Layout advanced option in the Content Builder Options dialog enables automatic part insertion during layout. The connection 1 position is the insertion position, which can be toggled through.

Model Parameters

Model parameters control the model's overall shape and size by establishing relationships between defined parameters. As you add dimensions and constraints to the model, parameters appear under the Model Parameters folder in the part browser. The Model Parameters dialog provides a central location where you can view, create, and edit the dimensional parameters of the model. You can define parameters to create additional model relationships or to enhance drawing schedules later.

It is often more efficient to assign numeric values to dimensions and other feature parameters as you build the model. When you finalize the geometry, you can edit the model parameters to add calculated values. An equation assistant is available in the Model Parameters dialog to ensure that the equation you create is valid and can produce a result. Each parameter in the Model Parameters dialog includes the following:

Name A unique identifier for the parameter. Model parameters are assigned default names, such as D1, D2, and D3, that can be changed. User-defined parameters must have unique names.

Value The result of evaluating the equation.

Equation The mathematical expression that defines the value of the parameter. Constants, other model and user-defined parameters, and mathematical operators can be used in an equation. You can use the Equation Assistant to define the equation.

Description A narrative, user-defined description of the parameter.

NOTE When using a constant value in an equation, be sure to define the constant as a model parameter. You should verify that the result of the equation is non-zero to avoid undesirable results in your model.
Connectors of a Parametric Part

In the parametric building environment of Content Builder, you can add connectors to a part. Connectors enable the part to be connected intelligently to other building systems objects in your layout. You can define one or more connectors for a part.

When you add a new pipe connector to a pipe segment or MvPart, the software automatically assigns parameter values for CEL (connection engagement length) and AoD (angle of deflection). CEL and AoD are assigned the following criteria:

- Connector number associated with the CEL or AoD value; for example: CEL1 or AoD1 designating connector 1
- Description
- Constant parameter type
- Real number data type
- Units:
  - For CEL: Drawing length in units (inches or millimeters)
  - For AoD: Degrees
- Default value: 0.000

You place connectors in a left to right, then top to bottom orientation in the positive X-Y plane layout, as shown next.

Fitting connector orientation

The Piping domain includes fittings with female connectors. Connection types with female connectors include hub, bell, and mechanical joint. The female connector on an elbow or a tee is designated as connector 2. The female connector on non-symmetric fittings, such as crosses, is designated as connectors 2 and 4.

When you add a new pipe connector to a pipe segment or MvPart, the software automatically adds CEL and AoD parameters.

RELATED See Recommendations for Creating Parametric Fittings Content on page 651 for guidelines to build parametric fittings content. See also Connection Types for Pipe and Pipe Fittings on page 266 for fitting types in the Piping domain.
IMPORTANT The position of the first connector placed in the model defines the axis orientation of the part upon insertion. For example, if you place the first connector on a part with a perpendicular vector into the part, the direction of the vector defines the positive x-axis orientation when inserted into a drawing.

The shape of the connector is determined by the shape of the modifier that the connector is attached to. You define the size of the connector by placing dimensions when you add the connector to the model.

NOTE If a single profile defines more than one connector, you add dimensions to the connector only once.

After the connector has been placed, you can assign the connector type that is dependent on the domain assigned to the part. Examples of connector types include flange, slip-joint, and glued.

The domain defines the connection rules for the part. Connectors belonging to a particular domain know how to connect to other parts of the same domain, but they cannot connect to components in other domains. For example, an air terminal assigned to the duct domain cannot connect to a pipe segment.

Sizes of a Parametric Part

The model parameters of a parametric part define the default part size of the model and act as placeholders for the actual part sizes that you define later. In turn, the size parameters of the part define the actual part sizes. There is a direct connection between the model parameters and the size parameters. When you add a model parameter to the part model, the software adds a corresponding size parameter as well.

Model and size parameters of a round damper

You define the part sizes of a parametric part by specifying values for the size parameters in the Size Parameters dialog.
Size parameters of a round damper

The Size Parameters dialog has 3 modes:

- **Parameter Configuration.** You use this mode to view and change the attributes of parameters, such as the description, type of data storage, type of data, units, and visibility. The type of data storage determines whether the parameter values are stored as a list, a table, a constant, or a calculation. For more information about data storage, see How Catalog Parts are Stored and Referenced on page 80.

  **NOTE** When you add a model parameter, its corresponding size parameter has several attributes that cannot be changed, such as the data type, units, and context.

- **Values.** You use this mode to view and change the values of parameters when they are stored as lists, tables, and constants. You define multiple part sizes by entering multiple values for the size parameters. You can enter the values manually or copy and paste them from another part open in Content Builder, from a part open in Catalog Editor, or from a spreadsheet. For connector parameters, you can also insert the corresponding sizes for the segments used by default during layout.

- **Calculations.** You use this mode to view and change the calculation formulas of parameters, such as the formula for defining part size names or the formula of a custom parameter. You cannot change the formulas of parameters defined in the model in the Size Parameters dialog; use the Model Parameters dialog instead, as shown in Adding Dimensions to a Parametric Fitting on page 686.

**Non-Graphical Parameters**

In the Parameter Configuration mode of the Size Parameters dialog, you can also add non-graphical parameters to the part family. For example, you might want to add information about materials or manufacturers.

You can add non-graphical parameters in 2 ways:

- You can select from a list of optional, predefined parameters, such as Material or Part Source URL. The predefined parameters that are available depend on the part type and the existing parameters defined in your custom part family.

- You can add custom parameters. For these parameters, you can define all of the parameter attributes.

Using non-graphical parameters to store additional part information can help you to identify the parts in your drawings during the design process. It can also enhance the schedules in your construction documents. For more information, see Collecting Project Data on page 587.
**Copying and Pasting Part Sizes**

When you are adding part sizes to a part, you can copy and paste values from other part families using standard Microsoft Windows copy and paste functionality: CTRL+C for Copy and CTRL+V for Paste. The Copy and Paste commands are also available on:

- toolbar of the Size Parameters dialog
- context menu accessed by right-clicking a parameter heading or value

You can copy and paste values from another part open in Content Builder, from a part open in Catalog Editor, or from a Microsoft Excel spreadsheet.

To open Catalog Editor from inside Content Builder, click (Open Catalog Editor) on the toolbar in the Size Parameters dialog.

If you select one or more parameter values, copy them, and then paste them into another parameter, the software pastes only the values.

If you select a parameter heading in order to copy and paste all of its values, the software copies and pastes the data storage type as well. Copying and pasting values in this manner is possible between parameters with the same data storage type, and between parameters whose data storage types are List and Table. In the latter situation, the software prompts you to select whether to paste only the values, to paste the data storage type and the values, or to cancel the operation.

**Inserting the Connector Sizes of Default Segments**

Layout preferences define—by connection type and shape—the default parts for a domain (duct, pipe, cable tray, or conduit). The default parts are the segments and fittings to use by default during layout. For more information about the Duct Layout Preferences dialog, see Specifying Default Parts for Layout on page 180.

When you are creating custom parts, you can retrieve the sizes defined for the connector parameters of the default segments and insert them into the custom parts. For example, suppose you have a custom square-neck diffuser with a duct connector that is rectangular and banded. To represent the width and height of the duct connector, the diffuser has 2 size parameters named RW1 and RH1. To quickly insert a list of sizes into these parameters, you can retrieve the sizes in the RW1 and RH1 connector parameters for the segment specified as the default during layout of rectangular, banded duct.

Inserting the sizes of the default segments into your custom parts is particularly useful when the list of sizes that you need is long and closely matches the values for the corresponding default segment. Be aware that the software replaces any existing values with the inserted values. After you insert the values, you can add and remove individual sizes as needed.

**NOTE** You can only use this feature with parametric parts. In addition, you can only use this feature when the connector has a specified domain and connection type. This information is required to identify and retrieve the connector sizes of the appropriate segment in the catalog.

To insert the connector sizes of a default segment into a part

1. If necessary, open the parametric part in Content Builder.
2. In the part browser, right-click Size Parameters, and click Edit Values.
3. In the Size Parameters dialog, select the current value for the size parameter for which you want to insert the sizes of the default segment.

**NOTE** The selected parameter must have a data storage type of List or Table. If the parameter is for a pipe connector, it must have a data storage type of Table.
4 In the Size Parameters dialog, click (Default Connector Values) on the toolbar. Alternatively, you can right-click a value, and click Default.

5 If you selected the value of a pipe connector, in the Choose a Part dialog, select the pipe fitting whose values you want to insert, and click OK.
For pipe connectors only, you must select a pipe fitting because pipe fittings, not pipe segments, have connection types.

6 If the data storage type of the parameter in the default segment is not the same as that of your custom part, you must select whether to paste only the values, to paste the data storage type and the values, or to cancel the operation.
The software inserts the values of the connector parameter in the default segment into the selected connector parameter in the custom part.

**Specifying Connector Sizes for Pipe Connectors**

To add sizes to the pipe connectors on parts, enter the nominal diameter of the connector. This causes the software to retrieve an appropriate physical diameter based on the connection type.

To retrieve the physical diameter, the software searches the active pipe catalog for connectors with the same connection type and nominal diameter. If the part to which you are adding sizes is a fitting, it then filters the results to include only the connectors in the catalog with the same part subtype, if specified. Then, it retrieves the physical diameter for the nominal diameter for the first connector in the results, and inserts the value into your part.

If necessary, you can modify the physical diameter values retrieved by the software.

**Part Preview of a Parametric Part**

After you finish modeling the part and adding individual part sizes, you can preview each part size to ensure the integrity of the part before inserting the part sizes in your drawings.

*NOTE* Part Preview supports only parametric parts created with Content Builder.

You access Part Preview from the Size Parameters dialog. You can select any part size, click on the toolbar, and the Parametric Object Viewer is displayed. As you select different part sizes in the Size Parameters dialog, the Parametric Object Viewer is updated with a new part preview display. You can also rotate the part in the object viewer to see different 3-dimensional (3D) previews of the part size.
Example of Parametric Object Viewer

To preview a part size defined in a table row, you can click any cell in the row, or press ARROW+UP and ARROW+DOWN to navigate through different sizes. To preview part sizes defined in a list, you can double-click a default list value, or press CTRL ARROW+UP or CTRL ARROW+DOWN to display a list of sizes to navigate through.

Preview Image of a Parametric Part

You can create a preview image before using Content Builder to create the parametric part, or Content Builder can generate the image once you have finalized the model.

**NOTE** The bitmap size must be 200 x 200 pixels, 256 color.

The preview image is helpful in identifying the part during part selection. When using Content Builder to generate a preview image, a bitmap (BMP) image is created based on a specified view direction. You can select from the 10 standard AutoCAD® orthographic and isometric view directions to view the model (top, bottom, left, right, front, back, SW isometric, SE isometric, NE isometric, and NW isometric). The preview image is saved with the part when you save the part to the catalog.

Part Insertion Behaviors of a Parametric Part

You can specify several insertion behaviors for parametric MvParts and fittings.

There are some insertion behaviors that you specify using the part model. For an MvPart, you specify the placement (insertion) point to use when the MvPart is added to drawings by users. For a fitting, you specify trim lengths and the placement point to use when the fitting is added to drawings by the software during autolayout. Trim lengths are the length dimensions on a fitting that are used to trim other components to make room for the fitting. For more information, see Trim Lengths and Placement Points on page 664.

There are other insertion behaviors that you must specify in the Options dialog, which you can access by clicking in the Content Builder part browser.
The following table describes the behaviors (properties) that you can set in the dialog.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Custom Sizing Flag</td>
<td>Lets you create custom sizes of the part when a needed part size does not exist in the catalog. Custom sizes can be inserted by Auto Layout or by setting part filter/values in the Add dialog.</td>
</tr>
<tr>
<td>Hide Part Flag</td>
<td>Hides the part in the catalogs from which you select parts to add to drawings. <strong>NOTE</strong> By default this setting is enabled. Hiding the part is recommended when you are creating a temporary part or creating a part across multiple sessions. However, when you save a part after successfully validating it, the software prompts you to specify whether to continue to hide it.</td>
</tr>
<tr>
<td>Anchor Part</td>
<td>Available for MvParts only. Enables the MvPart to anchor to another object.</td>
</tr>
<tr>
<td>Break Into Part</td>
<td>Available for MvParts only. Enables the MvPart to break into another object.</td>
</tr>
<tr>
<td>Layer Key</td>
<td>Available for MvParts only. Specifies the layer to which the MvPart is added in drawings. For more information about layers, see AutoCAD MEP Layer Standards. When you add a fitting to a drawing, the layer to which the fitting is added is determined by the objects to which it is connected.</td>
</tr>
<tr>
<td>Display Symbol in Plan View</td>
<td>Available for MvParts only. Specifies whether to display the schematic symbol of the part instead of a model-generated view in 1-line and 2-line display representations in Top (plan) view.</td>
</tr>
<tr>
<td>AutoLayout Flag</td>
<td>Available for fittings only. Adds autolayout data to the fitting in the part browser, which enables you to specify trim lengths and a placement point. For more information, see Trim Lengths and Placement Points on page 664 and Defining the Part Insertion Behaviors of a Parametric Fitting on page 690. The software automatically adds autolayout data to MvParts.</td>
</tr>
</tbody>
</table>
NOTE If you specify that the MvPart can anchor to another object as well as break into another object, the software prompts you to select which behavior to use when adding the part to a drawing. For an example of both behaviors, see Defining the Part Behavior of a Block-Based MvPart on page 757.

**Schematic Symbol of a Parametric Part**

While parametric parts do not require schematic symbols, generally you create them for use in schematic diagrams. If a part does not have a schematic symbol, the part is not visible in schematic representations of a system. If a part does have a schematic symbol, you have the option of also using it in 1-line and 2-line representations of a system in Top (plan) view. This can be helpful for differentiating systems in a design, for example, supply and return HVAC systems.

**Model and schematic representations of parts**

<table>
<thead>
<tr>
<th>Air terminal</th>
<th>Inline pump</th>
<th>Switchboard transformer</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Air terminal" /></td>
<td><img src="image" alt="Inline pump" /></td>
<td><img src="image" alt="Switchboard transformer" /></td>
</tr>
</tbody>
</table>

**Symbol and Annotation Plane**

You create schematic symbols for parametric parts on the Symbol and Annotation plane, a horizontal plane to which you attach the symbol geometry, associated constraints and dimensions, and annotation.

**Symbol and Annotation plane in the drawing area**

In many ways, the Symbol and Annotation plane behaves like the **work planes** to which you attach the features of the part model. You attach the features of the symbol to the Symbol and Annotation plane, and you can make the plane visible or invisible, isolate its contents, or hide its contents. However, unlike the work planes that you create manually, the software automatically creates the Symbol and Annotation plane when you begin a new part in Content Builder.
As shown in the previous illustration, the default position of the Symbol and Annotation plane on the Z axis in the World Coordinate System (WCS) is high above the WCS origin. This keeps the plane and its contents out of the way while you are working on your part model. If desired, you can change the Z position of the plane. To do so, right-click the plane in the part browser, click Change Plane Position, enter a new value for the Z position, and press ENTER.

Creating Schematic Symbols for Parametric MvParts

You can create a schematic symbol for a parametric MvPart at any time. However, only parts that you add to drawings after you have created the symbol can use the symbol. You cannot update previously inserted parts to use the symbol.

There are 2 types of schematic symbols that you can add to parametric MvParts:

- **Parametric.** This type of symbol scales proportionally with the part. You create parametric symbols using parametric features: parametric geometry, dimensions, and constraints.

- **Block-based.** This type of symbol scales uniformly instead of proportionally. You create block-based symbols using standard AutoCAD objects, such as lines, arc, and circles. You can create the symbol from scratch, or you can insert an existing AutoCAD MEP symbol or 2D AutoCAD block from a DWG file.

For more information, see Creating a Schematic Symbol of a Parametric MvPart on page 735.

Workflow for Creating a Parametric Fitting with Content Builder

This workflow provides a road map for creating a parametric fitting using Content Builder.

**Review the steps**

1. **Open the Parametric Building Environment to start building content.**
   
   **View more information**
   
   You use the Content Builder in AutoCAD MEP to create a parametric fitting. See Opening the Parametric Building Environment on page 676.

2. **Specify the part configuration.**
   
   **View more information**
   
   You work in the parametric building environment to create single parametric parts. In this environment, only one part can exist in a drawing. The individual drawings are associated with a part catalog to build a library of parts. You specify the type and subtype of the part to establish basic part behavior. See Defining the Part Behavior of a Parametric Fitting on page 676.

3. **Create a 3D model of the part.**
   
   **View more information**
   
   You create models of 3D parts and use them to dynamically generate 2D views of your parts. You build your part from blocks, or features, that are parametrically combined to define the part. The model is defined in terms of the size, shape, and position of its features. You can restrict how the features of the parts fit together. To better conceptualize the size and shape of the part model, you define constraints and dimensions that determine how your part is built. See Modeling a Parametric Fitting on page 677.
Creating a Parametric Fitting with Content Builder

You can create parametric fittings, such as elbows and tees, with Content Builder. The following sections contain step-by-step procedures to help you create a tee fitting using Content Builder. Each section represents a separate phase in the creation process; therefore, you should carefully step through the sections in the following order to avoid creating unusable parts.
NOTE Parametric fittings are not used in plumbing runs. However, parametric fittings are useful for ducts, pipes, cable trays and conduit.

Opening the Parametric Building Environment

1 Click Manage tab ➤ MEP Content panel ➤ Content Builder ➤ Content Builder. The Getting Started - Catalog Screen dialog appears.

2 Under Part Domain, select a part catalog. For example, if you want to create a duct fitting, select Duct.

3 In the part catalog browser, select a chapter and click ➤ .

4 In the New Part dialog, enter a unique name and description for the part family and click OK. Name indicates the files that are associated with this new part. Description refers to the part family and is referenced in the software.

RELATED For more information about the Content Builder parametric building environment, see Approaches to Creating Parts on page 643.

5 Click View tab ➤ Appearance panel ➤ Appearance ➤ Point Style ➤ .

NOTE Alternatively, enter ddptype on the command line.

6 In the Point Style dialog, choose the desired point style, point size, and other size criteria. Changing the style of points improves their visibility in the drawing area and helps you to differentiate them from grid dots.

Point Style dialog

RELATED For more information, see “Point Style Dialog Box” in the AutoCAD Help.

Defining the Part Behavior of a Parametric Fitting

1 In the part browser, expand Part Configuration and specify the part description, type, and subtype.
2 To specify the part type, under Part Configuration on page 653, right-click Undefined, click Edit, and then select Tee.

Example of part configuration for round duct beveled tee

You specify the part type (such as tee, elbow) from a predefined list in the part browser. The selection is based on the building system domain and current part catalog.

You can also enter a new subtype. Part subtype is a sub-category of part types. You can either specify a part subtype from the predefined list or you can enter a custom part subtype.

**NOTE** Part domain defines the family of parts, such as pipe, duct, cable tray, conduit, MvPart components. Domain is predefined based on the part catalog you selected in the Getting Started - Catalog Screen dialog. This value is read-only and cannot be changed. For more information, see Part Configuration of a Parametric Part on page 653.

3 To specify the part subtype, right-click Undefined, click Edit, and select Transition Straight.

**Modeling a Parametric Fitting**

Modeling on page 654 is used to create the parametric content, constraints, and dimensions. To model a parametric part, you follow this sequence:

- Establish work planes on which to create the geometry of your model
- Create profiles and apply modifiers to define the shape and default size of the part.
  To avoid distortion in the model, start with the larger features, which have more impact on the overall size of the part and then add the smaller features. For example, for a tee fitting, you first create the trunk of the tee and then add the branch.

**Establishing the Work Planes of a Parametric Fitting**

Work planes on page 654 define the orientation in which you are working. They provide access to views, such as Front, Side, Top, etc., that let you create content.

Use this procedure to add work planes to create the geometry, paths, and constraints of a model. To avoid confusion, work with only one work plane visible, unless you are using offset or reference work planes. The following instructions refer to the part browser. The part browser is located under the ribbon to the left of the drawing area.

1 In the part browser, expand Modeling.
2 Right-click Work Planes and click Add Work Plane.
   The Create Work Plane dialog appears.
3 Click Default, and click OK.
The ZX plane, YZ plane, and XY plane are created.

4 To view the work planes in the modeling area, on the floating View panel, click View drop-down ➤ SW Isometric.

5 In the part browser, expand Work Planes.
When you select a work plane in the part browser, the work plane is highlighted in the modeling area.

Selecting the ZX Plane

6 To avoid confusion, work with only one work plane visible at a time. In the part browser, right-click ZX Plane and click Visible. Do the same for XY Plane.
The ZX Plane and XY Plane icons are unavailable (shaded). The YZ plane is the only visible work plane in the modeling area.

Modeling the Trunk of a Parametric Tee Fitting

Use this procedure to model the trunk of the tee fitting. You add the circular geometry on page 656, create the profile, and apply an extrusion modifier.

1 To create the trunk of the tee, in the part browser, right-click YZ Plane and click Add Profile ➤ Circular.
For more information about profiles, see Profiles on page 659.

2 Select a center point in the modeling area and specify a second point, or enter 12" (305 mm), to define the radius.

A circular profile is created and is added to YZ Plane in the part browser.

3 In the part browser, right-click Modifiers on page 660 and click Add Extrusion.

4 Select the circular profile in the modeling area.

   The Extrusion Modifier dialog appears.

5 Under Termination, select MidPlane for Type, enter 20" (508 mm) for Distance, and click OK.
A cylinder is created to represent the trunk of the tee and an extrusion modifier is added to Modifiers in the part browser.

**TIP** You can quickly build a part model using primitives. For information, see [Primitives](#) on page 663.

**Modeling the Branch of a Parametric Tee Fitting**

Use this procedure to model the branch of the tee fitting based on the center of the trunk. You add the circular geometry, create the profile, and apply an extrusion modifier.

1. To create the transitional branch of the tee, change the work plane. Right-click YZ Plane and click Visible; then right-click ZX Plane and click Visible.
   The YZ plane is turned off. Its icon is unavailable (shaded) in the part browser. The ZX plane is the visible work plane in the modeling area.

2. In the part browser, right-click ZX Plane and click Add Profile ➤ Circular.
   The circular profile on page 659 defines the diameter of a fitting, such as an elbow, and the connectors. You can add more geometry lines and circular profiles for more complex graphics.

3. Using object snaps with center mode enabled, select the center of the circular profile of the trunk, and enter 6" (152 mm) for the radius.
A circular profile is created and is added to ZX Plane in the part browser.

4 In the part browser, right-click Modifiers and click Add Extrusion.
5 Select the circular profile for the branch in the modeling area.
   The Extrusion Modifier dialog is displayed.
6 Under Termination, select Blind for Type, and enter 10" (254 mm) for Distance. Click OK.

A cylinder is created to represent the branch of the transitional tee and a second extrusion modifier is added to Modifiers in the part browser.
7 To flip the branch to the other side of the trunk, expand Modifiers in the part browser, right-click the second (branch) extrusion modifier and click Edit. The Extrusion Modifier dialog appears.

8 Under Termination, select Flip and click OK. The branch is flipped to the other side of the trunk.

**TIP** To verify which extrusion modifier is associated with a particular feature, click a modifier in the part browser to have the associated feature highlighted in the modeling area. For complex models, you can right-click the modifier in the part browser, and then click Rename to enter a logical name for easy identification, such as "Extruded Branch Modifier."

---

**Adding Connectors to a Parametric Fitting**

Use this procedure to add connectors to the model. The shape of the connector is determined by the shape of the modifier selected. After the connector has been placed, you can assign the connector type.

The Content Builder requires a minimum of 3 connectors to create a usable tee fitting. To ensure the fitting can be added in a drawing with valid connections, the connectors must be added in a specific order. In plan view, add connectors left to right, then bottom to top. The following example shows connectors placed on a tee fitting.

**Placing connectors on a tee fitting**

1 To add a connector, in the part browser, right-click Connections and click Add Connection.
The software prompts you to select the connector location. As you move the cursor around in the modeling area, it snaps to 4 possible locations for a connector—to both ends of the trunk and both ends of the branch.

2 To specify the first connection point, select the connector location on the left end of the trunk.

**IMPORTANT** The position of the first connector placed in the model defines the axis orientation of the part upon insertion. For example, if you place the first connector on a part with a perpendicular vector into the part, the direction of the vector defines the positive x-axis orientation when inserted into a drawing.

3 Press *ENTER* to accept the default value for the first connector number.

**TIP** The default connector numbers are in ascending numeric order, according to the order in which the connectors are added to the model. For example, the first connector is 1, the second connector is 2, and so on. You can model connections in any order you choose. However, specific parts require specific connections set in a known order. The order given for this example is valid for all tees and other fittings. See *Rules for Connector Behavior* on page 652 for more information.

4 Select a location to the left of the model to place the dimension for the profile of the trunk.
A diameter dimension (D1) is added to the model for the circular profile of the trunk. The D1 dimension is also added to Size Parameters in the part browser, and a connector is added to Connections.

5 To specify the second connection point, right-click Connections in the part browser, click Add Connection, and select the connector location on the right end of the trunk.

6 Press ENTER to accept the default value for the second connector number. You do not need to select a location for the dimension because the same profile is used for both ends of the trunk. However, the software does add a diameter dimension (D2) defined with the
value of D1 to Model Parameters in the part browser. The software also adds a diameter dimension (D2) to Size Parameters and a second connector to Connections.

7 To specify the third connection point, right-click Connections in the part browser, click Add Connection, and select the connector location on the end of the branch.

8 Press ENTER to accept the default value for the third connector number.

9 Pick a location to the left of the model to place the dimension of the circular profile of the branch in the model.

TIP Turn off object snaps if you are having problems selecting a position off the model.
A diameter dimension (D3) is added to the model and to Size Parameters in the part browser, and a third connector is added to Connections.

10 To define the connection type for each connector, in the part browser, right-click a connector in Connections and click Edit.

The Connector Properties dialog displays connector details and values, including domain, type, and shape.

NOTE Domain and shape are view-only parameters.

11 For Type, click the type specified for each connector and then click .

12 In the Connection Types Selection dialog, select the appropriate connection types.

Connector types are dependent on the related parametric fitting domain. For example, the Piping domain includes a connection type called “Same Connection”. When “Same Connection” is configured for a pipe object that is attached to a Hub, the pipe connection type will not inherit the connection type on connector 1 of the Hub, as happens with other connection types. Rather, it will inherit the connection type on connector 2 of the attached Hub.

TIP You can select connection types regardless of gender (male or female). Pipe connectors are assigned as undefined type by default. An undefined connection type creates a valid connection between all types of connectors when inserted in a drawing. See Rules for Connector Behavior on page 652 for more information.

Adding Dimensions to a Parametric Fitting

Dimensions on page 657 define the default size of a parametric fitting. You can add other sizes, such as a list of values, to create individual part sizes.
Adding Model Dimensions to a Parametric Fitting

Use this procedure to add dimensions to specify the overall default size of the model.

TIP You may find it easier to add model dimensions in the top view, rather than in a model view direction. To change the view, click View tab ➤ Appearance panel ➤ Views drop-down ➤ Top.

1. To define the overall length of the trunk, in the part browser, right-click Model Dimensions, and then click Add Distance.

NOTE For constant parameter values, you can define a constant dimension, or choose not to add a dimension and use the default value based on the actual size of the geometry. When no dimensions are added, the parameter and its value are not displayed during part size selection.

2. Select the trunk modifier feature in the modeling area, and specify a location to place the dimension.

A length dimension (LenB1) is placed in the model and is added to Model Parameters and Size Parameters in the part browser. The value of LenB1 is a default value based on the extrusion distance of the feature, and it can be changed.

3. To define the overall length of the branch, in the part browser, right-click Model Dimensions and click Add Distance.

4. Select the branch modifier feature in the modeling area, and specify a location to place the dimension.
A length dimension (LenB2) is placed in the model and is added to Model Parameters and Size Parameters in the part browser. The value of LenB2 is a default value based on the extrusion distance of the feature, and it can be changed.

5 To modify the default, or to specify a calculated value for the length of the trunk and branch, in the part browser, expand Model Parameters on page 665, right-click a length dimension, and click Edit.

The Model Parameters dialog is displayed.

**Example of Model Parameters dialog**

![Model Parameters dialog]

6 Double-click the Equation value for LenB1, and enter the equation for the diameter of the trunk plus one-half the diameter of the trunk \((D1 + (D1 * 0.5))\).

**TIP** Click Calculator to access the Equation Assistant.

7 Double-click the Equation value for LenB2, enter the equation \((0.75 * D1)\), and click Close.
The model features are updated in the modeling area to reflect the modified dimensions.

Adding Individual Part Sizes to a Parametric Fitting

You create individual part sizes by adding parameter values. Values can be a list or table of values, a constant value, or a calculation.

You can also create unique part size names. Each part size name is generated using a calculation — a formatted string of parameter values and text.

To add individual part sizes to the parametric fitting

1. To add part sizes to the fitting, in the part browser, right-click Size Parameters on page 667 and click Edit Values.
   The Size Parameters dialog is displayed. In Values mode, the dialog shows the values of the size parameters and other non-graphical parameters.

2. To add sizes to the branch connection, click the D3 parameter value and click on the toolbar.
3. In the Edit Values dialog, click Add and enter a new size. When you are finished adding sizes, click OK.

   **TIP** You can copy and paste values from other part families using standard Microsoft® Excel copy/paste functionality. For connector parameters, you can also insert the corresponding values for the segments used by default during layout.

   The parameter value list is updated.

   **NOTE** You cannot modify the formulas for calculated parameters defined in the model in the Size Parameters dialog. Use the Model Parameters dialog instead, as described in Adding Dimensions to a Parametric Fitting on page 686.

4. To specify a unique part size name, select Calculations from the list box.
The calculation strings are displayed.

5 Double-click the value cell of PrtSN.
   The Calculation Assistant dialog appears.

6 Define the part size name with a calculated value:
   ■ Highlight the value of PrtSN: Part Size Name and press DELETE.
   ■ Select 0 for Precision.
   ■ Under Insert Variable, select D1 and click Insert.
   ■ Click the value of PrtSN: Part Size Name and enter inch Dia.
   ■ Under Insert Variable, select PSTyp and click Insert.
   ■ Select PTyp and click Insert.

7 Click Evaluate. The calculation result is displayed. Click OK.
   In the Size Parameters dialog, the calculation value of PrtSN is updated with the valid string
   and, when selected, the result is displayed in the status bar.

   IMPORTANT The part size name is generated using VB (Visual Basic) Script’s FormatNumber function
   and simple string substitutions. The correct syntax is crucial. Therefore, use the Calculator to ensure
   that the string is valid.

Generating a Preview Image of a Parametric Fitting

Once you have finalized the part model, you generate a preview image on page 670 (BMP file) of the parametric
fitting. The preview image is helpful for identifying the part when users are selecting and adding parts to a
drawing. Content Builder generates the preview image based on a specified view direction. You can select
from the 10 standard AutoCAD® view directions to view the model (top, bottom, left, right, front, back, SW
isometric, SE isometric, NE isometric, and NW isometric).

1 To create a preview image, on the toolbar, click 
   The Bitmap Preview dialog is displayed.

2 Under Generate View, click a view direction for the preview image of the part.

   TIP As you select a view, the preview image window in the dialog is updated. This enables you to
   view all the available preview images for the part before selection.

   You can also click Browse to navigate to and select a bitmap image. Predefined images must be
   200 x 200 pixels saved with 256 colors.

Defining the Part Insertion Behaviors of a Parametric Fitting

Once you have finalized the model and generated a preview image, you define the insertion behaviors on
page 671. These include the trim lengths and placement point on page 664 used by the software during
autolayout. Trim lengths define the distance that a connecting segment is trimmed in order for the fitting
   to be placed in the run.

   NOTE It is helpful to clean up the appearance of the model before defining trim lengths and the placement point.
   To turn off all work planes and the associated geometry, profiles, and dimensions on those work planes, in the
   part browser, right-click each feature and click Visible.
1 In the part browser, click [Options].
The Options dialog is displayed.

2 Select or clear Custom Sizing Flag and Hide Part Flag, as appropriate.
   For descriptions of these settings, see Part Insertion Behaviors of a Parametric Part on page 671.

3 Select Auto Layout Flag to turn on auto layout, and click OK.
   In the part browser, Autolayout Data is added to the Modeling folder, and trim length points
   are displayed on the model in the modeling area.

4 Change the model view to plan view by clicking View tab ➤ Coordinates panel ➤ World
   The command line issues the next command.

5 In the part browser, expand Autolayout Data, right-click Layout Data and click Add Trim Length.

   **NOTE** To ensure components are trimmed correctly when placing a parametric part into a drawing,
   you must define trim lengths for the part in a specific order—left to right, then bottom to top.

   You are prompted to select the start and end of the trim length. Repeat this for the 3 trim lengths
   required for auto layout of the tee fitting.

   ■ Define the first trim length.
      For the start of trim length 1, select the point at the center of the trunk. For the end of trim
      length 1, select the point at the left end of the trunk.

   ■ Define the second trim length.
For the start of trim length 2, select the point at the center of the trunk. For the end of trim length 2, select the point at the right end of the trunk.

- Define the third trim length.
  For the start of trim length 3, select the point at the top of the branch (the center of the trunk). For the end of trim length 3, select the point at the bottom of the branch.

Trim length lines are displayed between the selected points.

6 In the part browser, right-click Layout Data, and click Select Placement Point.
You are prompted to select a point on your model. This point is the location at which connecting segments would intersect if they were extended along their logical paths. The placement point is used as the insertion point for the fitting when it is added to a drawing during autolayout using the Add commands.

7 Select the trim length point at the center of the trunk.
A placement point is displayed at the selected location.

Validating, Saving, and Previewing a Parametric Fitting

1 On the Content Builder toolbar, click \( \checkmark \) (Validate).

Upon successful completion of these procedures, the part is validated and the status bar at the bottom of the part browser is updated with the traffic light displayed green.

If you have errors in your model, the traffic light is red, and a dialog is displayed listing the errors. Review the errors, make necessary modifications, and repeat this step until validation is successful.

**NOTE** Warnings in the Part Family Validation Results dialog do not make the part invalid.

Once validation is successful, you can save the parametric fitting.

**To save a parametric fitting**

2 In the part browser, click \( \square \).

3 Specify whether to make the part available in the catalog:
   - Click Yes to make the part available to users.
   - Click No to keep the part hidden.

**NOTE** This prompt toggles the Hide Part option in the Options dialog in Content Builder.

The part is saved in the specified catalog location.
To preview a parametric fitting

4 To preview each part size, in the part browser, right-click Size Parameters and click Edit Values. The Size Parameters dialog is displayed.

5 Click 1 in the table to select the default part size and click . The Parametric Object Viewer is displayed.

6 Use the view options to preview the parametric tee. For more information about working with the Object Viewer, see Object Viewer in the AutoCAD Architecture Help.

7 To preview another part size, click in the Size Parameters dialog, and select a different value for D3 from the list of available sizes, and click again. The part in the Parametric Object Viewer is updated.

NOTE You can work with both the Size Parameters dialog and the Parametric Object Viewer together to preview each part size and make changes as necessary.

8 When you finish previewing part sizes, click Close in the Parametric Object Viewer, and click OK.

9 Click to save any changes made.

10 Click to close the part browser.

Building Parametric Parts Using the Wizard

A part template is a fully configured and fully dimensioned parametric part that has a basic model but does not have any part sizes. The imperial and metric catalogs in AutoCAD MEP include part templates for several, commonly used MvParts (for example, air terminals and pumps) and fittings. Using the Parametric Part Wizard, you can quickly create a new parametric part with custom sizes based on a part template.

Creating parametric parts using the part wizard is recommended when you require only a basic model to represent the part. The wizard is particularly useful for creating parts with one or a few sizes in real time as you design a building system.

If your custom part requires a more complex model than a part template provides, or if it must be block-based instead of parametric, create the part using the Content Builder instead. You can also use the Catalog Editor to copy parts and add custom part sizes to the copies.

To create a parametric part using the Parametric Part Wizard

1 Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Parametric Part Wizard .

To preview a parametric fitting

4 To preview each part size, in the part browser, right-click Size Parameters and click Edit Values. The Size Parameters dialog is displayed.

5 Click 1 in the table to select the default part size and click . The Parametric Object Viewer is displayed.

6 Use the view options to preview the parametric tee. For more information about working with the Object Viewer, see Object Viewer in the AutoCAD Architecture Help.

7 To preview another part size, click in the Size Parameters dialog, and select a different value for D3 from the list of available sizes, and click again. The part in the Parametric Object Viewer is updated.

NOTE You can work with both the Size Parameters dialog and the Parametric Object Viewer together to preview each part size and make changes as necessary.

8 When you finish previewing part sizes, click Close in the Parametric Object Viewer, and click OK.

9 Click to save any changes made.

10 Click to close the part browser.
2 Parametric Part Wizard

3 For Part Domain, select the domain of the catalog that contains the part template you want to use.
   You specify a catalog for a domain in the Options dialog. For more information, see Specifying Part Catalogs and Style-Based Content Locations on page 70.

4 For Part Type, select the part type of the template whose shape resembles the part you want to create.

5 For Part Template, select the name of the part template whose shape resembles the part you want to create.
   NOTE The lists of choices for Part Domain, for Part Type, and for Part Template are filtered to include only those for which there are defined part templates.

6 For Name, enter a name for the new part.
   The part name is used to name the XML file that defines the part. It is also displayed when the part is opened in Content Builder or Catalog Editor.

7 For Description, enter a description for the new part.
   Users select parts by description in add dialogs and modify dialogs. The description is also used to create the names of the part sizes.

8 Under Parameters, enter values for the size parameters shown in the part image.
The values are used to create the list of part sizes. To enter a value in a cell, double-click the cell, and then enter the value. To access the Copy, Paste, and Clear commands, right-click the cell.

**NOTE** In the part wizard, you enter the values for the size parameters differently depending on how they are stored in the software:

- In a table of values where all of the size parameters (columns) must have the same number of values, and a row across the columns defines a single part size
- In lists of values where the values in the lists are used in all possible combinations to define multiple part sizes

As an example of the latter, the following image shows the values for a custom round-neck diffuser. The values result in 2 part sizes, each with different values for the diameter of the neck.

**Example of Parameters showing values for custom round-neck diffuser**

<table>
<thead>
<tr>
<th>Unit</th>
<th>D1</th>
<th>L</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>125</td>
<td>450</td>
<td>450</td>
</tr>
</tbody>
</table>

Use the prompts provided by the software to guide you in entering the data. For more information about the different types of data storage for size parameters, see Part Sizes on page 82.

9 Click OK to create the part in the specified part sizes.

The software adds the part to the current catalog, more specifically, to the chapter that corresponds to the part type that you selected. The Add Multi-view Parts dialog is displayed to add the new part to your drawing, if desired.

If necessary, you can also modify the part’s data and add custom data using the Catalog Editor or Content Builder. For example, you can modify the formula used to create the names of part sizes.

**NOTE** Depending on the parts and part sizes available in your catalogs, you might also need to create additional parts and sizes to use with your new custom part.

---

**Building Parametric MvParts with Content Builder**

You can create parametric MvParts, such as air terminals and fans, using Content Builder. The next sections provide a workflow, followed by step-by-step procedures to help you create an air terminal, a junction box, and a tank using Content Builder. Each section represents a separate phase in the creation process. Therefore, you should carefully step through the sections in the following order to avoid creating unusable parts.

**Workflow for Creating a Parametric MvPart with Content Builder**

This workflow provides a road map for creating a parametric MvPart using Content Builder. Where applicable, topics focus on building specific MvParts, such as an air terminal, a junction box, and a vertical tank.
You work in the parametric building environment to create a single parametric MvPart. See Specifying the Part Configuration of a Parametric MvPart on page 698.

You create models of 3D MvParts and use them to dynamically generate 2D views of your parts. You build your part from blocks, or features, that are parametrically combined to define the MvPart. The model is defined in terms of work planes, profiles, and modifiers that define the shape and size of the MvPart. See Modeling a Parametric MvPart on page 700.

You add connectors to enable the MvPart to intelligently connect to other building systems objects in your layout. A connector is dependent on the model feature it is attached to. Therefore, shape and size are defined when the connector is added to the model. See Adding Connectors to a Parametric MvPart on page 720.

Adding dimensions and other part size information to the model defines the part sizes that can be dynamically generated from the model. This enables a single 3D model to represent multiple part sizes. See Adding Dimensions to a Parametric MvPart on page 724.

Once you have finalized the model, you generate a preview image for the MvPart by taking a snapshot of the model. Creating an image lets you preview how the part will appear in a drawing. The preview image also helps to identify the part during part selection. See Generating a Preview Image of a Parametric MvPart on page 732.

You specify the insertion behavior that you use to place the MvPart in your drawing, including layer assignment, placement point, and trim lengths for fittings. See Defining the Part Insertion Behaviors of a Parametric MvPart on page 733.
Review the steps

Validate and save the MvPart.

View more information

Once you have finalized the model, you must validate and save the MvPart. Validation checks the model and detects any errors that make the MvPart invalid. You must correct all errors in order to successfully save the MvPart and add it to a drawing. See Validating, Saving, and Previewing a Parametric MvPart on page 733.

Starting Content Builder for Creating a Parametric MvPart

Use this procedure to start Content Builder and open the parametric building environment.

1. Click Manage tab ➤ MEP Content panel ➤ Content Builder .
   The Getting Started - Catalog Screen dialog is displayed.
2. Select Multi-view Part for Part Domain.
3. In the part catalog browser, select a chapter and click .
   The New Part dialog is displayed.
4. Enter a name and description for the part family and click OK.
   By default, the description is the same as the name until you change it.
   The parametric building environment is opened. For more information, see Approaches to Creating Parts on page 643.

Specifying the Part Configuration of a Parametric MvPart

Each parametric part must have a defined part configuration in order for the part to be saved in a catalog and usable in your drawings. To specify the part configuration of a parametric MvPart, you define the part description, select a domain and type, and select or define a subtype. The part configuration defines the part’s behavior when you add the part to a drawing. The domain determines the part types you can select.

Specifying the Part Configuration of a Parametric Air Terminal MvPart

Use this procedure to specify the part configuration to define part behavior of a parametric air terminal MvPart.

1. In the part browser, expand Part Configuration and specify the part description, type, and subtype.

   **NOTE** The part domain is defined in the Getting Started - Catalog Screen dialog, is read-only, and cannot be changed.

2. To specify the part type, right-click Undefined, and click Edit.
3. Select Air Terminal for the part type.
   The predefined types are dependent on the selected part domain.
Example of part browser for air terminal

4 To specify the part subtype, right-click Undefined, and click Edit.
5 Select Diffuser for the part subtype.
   The list of predefined subtypes is dependent on the selected type.
   You can also enter a new subtype.

Specifying the Part Configuration of a Parametric Junction Box MvPart

Use this procedure to specify the part configuration to define part behavior of a parametric junction box MvPart.

1 In the part browser, expand Part Configuration and specify the part description, type, and subtype.

   NOTE The part domain is defined in the Getting Started - Catalog Screen dialog, is read-only, and cannot be changed.

2 To specify the part type, right-click Undefined and click Edit.
3 Select Junction Box for the part type.
   The predefined types are dependent on the selected part domain.
4 To specify the part subtype, right-click Undefined and click Edit.
5 Select Square Outlet Box for the part subtype.
   The list of predefined subtypes is dependent on the selected type.
   You can also enter a new subtype.
Specifying the Part Configuration of a Parametric Vertical Tank MvPart

Use this procedure to specify the part configuration to define part behavior of a parametric vertical tank MvPart.

1. In the part browser, expand Part Configuration and specify the part description, type, and subtype.

   **NOTE** The part domain is defined in the Getting Started - Catalog Screen dialog, is read-only, and cannot be changed.

2. To specify the part type, right-click Undefined, and click Edit.
3. Select Tank for the part type.
   The predefined types are dependent on the selected part domain.

4. To specify the part subtype, right-click Undefined and click Edit.
5. Select Vertical Storage Tank for the part subtype.
   The list of predefined subtypes is dependent on the selected type.
   You can also enter a new subtype.

Modeling a Parametric MvPart

To model a parametric part, you must first define work planes on which to add the geometry of the model. You then create profiles and apply modifiers to define the shape and default size of the part. To avoid distortion in the model, start with the larger features, which have more impact on the overall size of the part, and then add the smaller features.

Establishing the Work Planes of a Parametric MvPart

Use this procedure to add work planes on which to create the geometry of the model. To avoid confusion, work with only one work plane visible, unless you are using offset or reference work planes. You can create additional work planes as you need them to build the model. It is helpful to use offset work planes to locate multiple sides of a part, such as both faces of an air terminal. It is helpful to use reference work planes to locate geometry on your parts, such as knockouts for a junction box or taps on a tank.

1. In the part browser, expand Modeling.
2. Right-click Work Planes and click Add Work Plane.
   The Create Work Plane dialog is displayed.
3. Click Default and then click OK.
   The ZX plane, YZ plane, and XY plane work planes are created.
4. To view the work planes in the modeling area, on the floating View panel, click View drop-down ➤ SW Isometric.
5. In the part browser, expand Work Planes.
When you select a work plane in the part browser, the work plane is highlighted in the modeling area.

To avoid confusion, work with only one work plane visible at a time. In the part browser, right-click ZX Plane and click Visible. Do the same for YZ Plane.

The ZX Plane and YZ Plane icons are unavailable (shaded) and the XY plane is the only visible work plane in the modeling area.

6 To avoid confusion, work with only one work plane visible at a time. In the part browser, right-click ZX Plane and click Visible. Do the same for YZ Plane.

The ZX Plane and YZ Plane icons are unavailable (shaded) and the XY plane is the only visible work plane in the modeling area.
Modeling with Primitives

Primitives are limited versions of part models that are designed for repeated use in part creation. They represent basic shapes, such as a box or a torus, and commonly used connections on parts, such as a flanged pipe connector or duct connector.

Because primitives include many of the modeling features that you need to build a custom parametric part, such as profiles and modifiers, you can use them to quickly build a part model and add connections.

Building a Part Model from Primitives

1. Begin a new parametric part, specify its part configuration, and add the default work planes (ZX plane, YZ plane, and XY plane).

   RELATED For more information, see Starting Content Builder for Creating a Parametric MvPart, Specifying the Part Configuration of a Parametric MvPart, and Establishing the Work Planes of a Parametric MvPart.

2. In the part browser, click .

   Insert Primitive dialog

3. In the Insert Primitive dialog, select the primitive to add to your part model, and click Insert.

4. Select the work plane on your part to which to attach the primitive:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>attach the primitive to an existing work plane</td>
<td>in the modeling area, select the work plane.</td>
</tr>
<tr>
<td>attach the primitive to the face of an existing primitive or modifier</td>
<td>press ENTER, and, in the modeling area, select the face of the primitive or modifier.</td>
</tr>
</tbody>
</table>

   NOTE This creates a reference work plane on the selected face and attaches the primitive to the new plane.

To facilitate the selection of a plane or face, the software highlights the plane or face when you move the cursor over it.
5 Select the work plane on the primitive that you want to align with the work plane selected in the previous step. Most of the primitives included with the software include multiple work planes. To select the current plane, do nothing. To cycle through the planes on the primitive and make another plane current, enter n (next), and press ENTER. As you cycle through the planes, notice how the software repositions the primitive in the modeling area so the current plane on the primitive aligns with the selected plane on your part.

**NOTE** This step aligns the centers of the selected planes so they match. As a result, the placement of the primitive on the plane on your part depends on the location of the primitive on its own plane. The primitives included in the software were created in the center of a horizontal plane.

6 If desired, change the orientation of the primitive:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>flip the primitive so it is positioned on the other side of the plane to which it is being added</td>
<td>enter f (flip plane), and press ENTER.</td>
</tr>
<tr>
<td>rotate the primitive around the center of the plane to which it is being added</td>
<td>enter r (rotate). Move the cursor and click to specify the angle change. Alternatively, you can enter the angle change on the command line and press ENTER.</td>
</tr>
<tr>
<td>insert a mirror copy of the primitive instead</td>
<td>enter m (mirror), and press ENTER.</td>
</tr>
</tbody>
</table>

7 When you have positioned and oriented the primitive as desired, press ENTER. The software copies all of the modeling features in the primitive into your custom part. If the units in the drawing that defines the primitive do not match the units in your part drawing, the software also converts the units appropriately. You can now work with the part model as if you had created all of the features manually.

In the model parameters of your part, the descriptions of the parameters that were derived from a primitive include the name of the primitive. This makes it easier for you to differentiate parameters when you have added multiple primitives, or a mixture of primitives and manually added features, to the part model.

**Model Parameters dialog**

![Model Parameters dialog](image)

**NOTE** For a step-by-step example of adding primitives to a part model, see Example: Building a Part Model from Primitives on page 703.

### Example: Building a Part Model from Primitives

The following procedure describes how to create a round-neck rectangular diffuser using primitives on page 663. Assume you have created the part, specified its part configuration, and created the default work planes.
1 On the floating View panel, click View drop-down ➤ SW Isometric.

To add the base of the diffuser using a primitive

2 In the part browser, click ➤ (Add Primitive).
3 In the Insert Primitive dialog, select Pyramid, and click Insert.
4 In the modeling area, select the XY plane.
   This attaches the pyramid to the XY plane.
5 On the command line, enter n (next), and press ENTER to add the primitive to the diffuser.
   The Pyramid primitive has 2 work planes: 1 at the top of the pyramid and 1 at the bottom. This aligns the plane at the top of the pyramid with the XY plane on the diffuser.

To add the neck of the diffuser using a primitive

6 In the part browser, click ➤ (Add Primitive).
7 In the Insert Primitive dialog, select Cylinder, and click Insert.
8 In the modeling area, select the XY plane.
This attaches the cylinder to the XY plane.

9 On the command line, enter f (flip plane), and press ENTER. This flips the cylinder to the other side of the XY plane.

10 Press ENTER to add the primitive to the diffuser.
11 Modify the values of the model dimensions so they reflect a more appropriate default size.
   ■ Expand Model Parameters, right-click a parameter, and click Edit.
   ■ Change the values as desired.
   ■ Click Close.

12 On the XY plane, add a coincident constraint between the top point of the pyramid and the center point of the cylinder face.
   Although the 2 points currently overlap, this ensures the pyramid geometry and cylinder geometry remain aligned when the part model is changed.
TIP  To cycle through overlapping objects, move the cursor over the object on top, then press and hold \textit{SHIFT} while pressing \textit{SPACEBAR} repeatedly. To cycle through overlapping subobjects (faces, edges, and vertices) on 3D solids, move the cursor over the subobject on top, then press and hold \textit{CTRL} while pressing \textit{SPACEBAR} repeatedly.

To add the duct connector using a primitive

13 In the part browser, click (Add Primitive).
14 In the Insert Primitive dialog, select Undefined Duct Connector - Round, and click Insert.
15 On the command line, select the XY plane of the cylinder.
   This attaches the duct connector to the XY plane.
16 Press \textit{ENTER} to accept the default orientation and add the primitive to the diffuser.

![Diagram of duct connector attachment]

17 Modify the values of the model dimensions:
   ■ Expand Model Parameters, right-click a parameter, and click Edit.
   ■ For BdyD1, change the value of Equation to D1. This causes the diameter of the cylinder to change when the diameter of the duct connector (D1) changes.
   ■ Change the value of Equation for the duct connector parameters so they reflect a more appropriate default size, as shown in the following image.
   ■ Click Close.
18 Configure the duct connector.
   Specify a connection type, and, if necessary, change the flow direction. For more information, see \textit{Connectors of a Parametric Part} on page 666 and \textit{Adding Connectors to a Parametric MvPart} on page 720.
Specify connection type on Connector Properties dialog

Creating Primitives

You can create primitives in several ways:

- Create a primitive from scratch
- Copy and then modify an existing primitive
- Save a part as a primitive

If you add a primitive to a custom part, you must use one of the planes on the primitive to orient the primitive on the part. For this reason, to be valid, a primitive requires at least one work plane that contains parametric geometry.

Creating Primitives from Scratch

1. Click Manage tab ➤ MEP Content panel ➤ Content Builder ➤ Content Builder. The Getting Started - Catalog Screen dialog is displayed.

2. In the Getting Started - Catalog Screen dialog, for Part Domain, select Primitives and Re-usable Parts.
3 Select the chapter to which to add the primitive, and click \(\square\) (New Parametric Part).

4 In the New Primitive dialog, enter a name for the primitive, and click OK.

The Content Builder environment is displayed. Because primitives do not have many of the modeling features that parts have, such as part configuration information or size parameters, only a subset of modeling features are available to you.

Part browser for a custom primitive

5 Create the primitive as desired.

**TIP** In the descriptions of the model parameters, enter descriptive text and include a reference to the primitive name. This makes it easier for you to differentiate parameters when you have added multiple primitives, or a mixture of primitives and manually added features, to a part.

6 Generate a preview image (BMP file) of the primitive.

Preview images are helpful when you are selecting primitives to add to custom parts. You can generate the preview image for a primitive, which enables you to select the view direction for
the image. If you do not generate an image, the software generates an image using the SW isometric view direction when you save the primitive.

Generating a preview image is the same for a primitive as it is for an MvPart. For more information, see Generating a Preview Image of a Parametric MvPart on page 732.

7 Click ✓ to validate the part.

NOTE To be valid, a primitive requires at least one work plane that contains parametric geometry.

8 Click  

Copying and Customizing Primitives

1 Click Manage tab ➤ MEP Content panel ➤ Content Builder  .

2 In the Getting Started - Catalog Screen dialog, for Part Catalog, select Primitives and Re-usable Parts.

Getting Started - Catalog Screen dialog for primitives

3 Select the primitive to modify, and click  .

4 Modify the primitive as desired, and click  .

5 In the Save Part Family As dialog, select the chapter (folder) in which to save the primitive, enter a new name for the primitive, and click OK.
You can also copy primitives by copying the DWG files and renaming the copies. By default, the DWG and BMP files for primitives are located in the following folder: \\ProgramData\\Autodesk\MEP 2010\\enu\\Shared\\Primitives.

**Saving Parts as Primitives**

1. Open the part in Content Builder, and click .
2. In the Save Part Family As Primitive dialog, select the chapter (folder) in which to save the primitive, enter a name for the primitive, and click OK.

   The software creates the primitive using the part information that is applicable to primitives.

**Modeling a Parametric Air Terminal MvPart**

Use this procedure to model a parametric air terminal MvPart. You add the rectangular geometry for the top and bottom faces, create the profiles, add constraints to align the faces, and apply the modifiers to create the transition between faces.

**To create the face geometry**

1. To create the top face of the diffuser, in the part browser, right-click XY Plane and click Add Profile ➤ Rectangular.

   For more information about profiles, see Profiles on page 659.

2. Specify the first corner in the modeling area and then the second corner.

   A rectangular profile for the top face is created and is added to the XY plane in the part browser. Constraints for the rectangular profile are also added to the XY plane.

3. To add an offset work plane to help locate the bottom face of the diffuser, in the part browser, right-click Work Planes and click Add Work Plane.

   The Create Work Plane dialog is displayed.

4. Click Offset and enter Bottom Face for Name. Click OK.

5. In the modeling area, select the XY plane as the reference work plane, drag the cursor below the XY plane, and enter 12" (305 mm) for the offset distance.
The bottom face work plane is created.

6 To create the bottom face of the diffuser, in the part browser, right-click Bottom Face and click Add Profile ➤ Rectangular.
7 Specify the first corner in the modeling area and then the second corner.

A rectangular profile is created for the bottom face and is added to Bottom Face in the part browser. Constraints for the rectangular profile are also added to Bottom Face.

To add constraints to align the faces

1 In the part browser, right-click XY Plane and click Add Geometry ➤ Point.
2 In the modeling area, specify a point near the center of the top face rectangular profile and press ENTER.
3 In the part browser, right-click XY Plane and click Add Constraints ➤ Equal Distance.
4 In the modeling area, specify the pairs of geometric constraints.
   For the first pair, select the point in the center of the top face, and then the lower-left edge of the top face rectangular profile.
   For the second pair, select the point in the center of the top face, and then the upper-right edge of the top face rectangular profile.
The model of the top face is updated to the specified constraint.

5 Repeat steps 3 and 4 to constrain the upper-left and lower-right edges of the top face. The model of the top face is updated to the specified constraint.

NOTE When adding constraints, you may be prompted that the geometry is unconstrained by a specific number of dimensions. These prompts are for informational purposes only to assist you during the modeling process. It is recommended that you add a minimum number of constraints to define the shape of the part to avoid undesirable results.

6 To ensure the alignment of the top and bottom faces, in the part browser, right-click Bottom Face and click Add Geometry ➤ Point Reference.

7 Select the existing point in the center of the top face rectangular profile. A reference point is added to the bottom face work plane.

8 Repeat steps 3 through 5 to constrain all 4 edges of the bottom face using the reference point in the center of the bottom face.
The model of the bottom face is updated to the specified constraints.

To apply the modifiers

1. In the part browser, right-click Modifiers and click Add Transition. For more information about modifiers, see Modifiers on page 660.

2. In the modeling area, select the top face rectangular profile for the start profile; then select the bottom face rectangular profile for the end profile. A transitional box is created to represent the diffuser, and a transition modifier is added to Modifiers in the part browser.

3. To add the lip of the diffuser, in the part browser, right-click Work Planes and click Add Work Plane. The Create Work Plane dialog is displayed.

4. Click Offset and enter Lip Offset for Name. Click OK.

5. In the modeling area, select the XY plane as the reference work plane, drag the cursor above the XY plane, and enter 1" (25 mm) for the offset distance.
The Lip Offset work plane is created.

6 In the part browser, expand Modifiers, right-click Transition Modifier, and click Visible. The transition modifier display is turned off in the modeling area.

7 In the part browser, right-click Modifiers, click Add Extrusion, and select the top face rectangular profile.
The Extrusion Modifier dialog is displayed.

8 Under Termination, select Plane for Type, and select Lip Offset for To. Click OK.

A box is created to represent the top lip of the diffuser, and an extrusion modifier is added to Modifiers in the part browser.
To see the entire model of the part, in the part browser, right-click Transition Modifier and click Visible.

**Modeling a Parametric Junction Box MvPart**

Use this procedure to model a parametric junction box MvPart. You add the rectangular geometry, create the profiles, apply the modifiers to create the box itself, and add geometry for the knockouts.

1. In the part browser, right-click XY Plane and click Add Profile ➤ Rectangular.
   For more information about profiles, see Profiles on page 659.

2. In the modeling area, specify the first corner and then the second corner.

A rectangular profile for the top face is created and is added to XY Plane in the part browser. Constraints for the rectangular profile are added to XY Plane.

3. In the part browser, right-click Modifiers and click Add Extrusion.
   For more information about modifiers, see Modifiers on page 660.

4. In the modeling area, select the rectangular profile.
   The Extrusion Modifier dialog is displayed.
5 Under Termination, select Blind for Type, enter 15” (381 mm) for Distance, and click Flip. Click OK.

A box is created to represent the junction box and an extrusion modifier is added to Modifiers in the part browser.

6 To add the knockout, in the part browser, right-click XY Plane and click Add Geometry ➤ Point.

7 In the modeling area, specify a point near the center of the top of the junction box, and press \textit{ENTER}.

8 To constrain the point to the exact center of the top of the junction box, in the part browser, right-click XY Plane and click Add Constraints ➤ Equal Distance.

9 In the modeling area, specify the pairs of geometric constraints.
   For the first pair, select the point in the top center of the junction box, and then the lower-left edge of the rectangular profile.
   For the second pair, select the point in the top center of the junction box, and then the upper-right edge of the rectangular profile.

\textbf{NOTE} When adding constraints, you may be prompted that the geometry is unconstrained by a specific number of dimensions. These prompts are for informational purposes only to assist you during the modeling process. It is recommended that you add a minimum number of constraints to define the shape of the part to avoid undesirable results.

10 Repeat steps 8 and 9 to constrain the center point to the upper-left and lower-right edges of the top face.
   The model of the junction box is updated to the specified constraints.

11 In the part browser, right-click XY Plane and click Add Profile ➤ Circular.
**TIP** You may find it easier to add the knockout in the top view, rather than in a model view direction.

To change the view, click View tab ➤ Appearance panel ➤ Views drop-down ➤ Top.

12 In the modeling area, using object snaps, select the point in the top center of the junction box as the center of the circle, enter 0.5" (13 mm) for the radius, and press ENTER.

A circular profile is created and is added to XY Plane in the part browser.

13 To constrain the circular profile to the center of the top face, in the part browser, right-click XY Plane and click Add Constraints ➤ Concentric.

14 In the modeling area, select the circular profile for the first geometry and the center point of the top face for the second geometry.

15 In the part browser, right-click Modifiers and click Add Extrusion.

16 In the modeling area, select the circular profile.

The Extrusion Modifier dialog is displayed.

17 Under Termination, select Blind for Type, enter 2" (51 mm) for Distance, and select Flip. Click OK.

A cylinder is created to represent the knockout and an extrusion modifier is added to Modifiers in the part browser.

**NOTE** To create additional knockouts, create reference and offset work planes to locate the plane to which to add a knockout, and then repeat steps 6 through 14 to create each knockout.

---

**Modeling a Parametric Vertical Tank MvPart**

Use this procedure to model a parametric vertical tank MvPart; add the circular geometry for the body of the tank, create the profile, and apply an extrusion modifier. Once the body is modeled, you can create taps, such as inlet and outlet taps, based on the body geometry.
To model the body of the tank

1 To create the body of the tank, in the part browser, right-click XY Plane and click Add Profile ➤ Circular.
   For more information about profiles, see Profiles on page 659.

2 In the modeling area, specify a center point, enter 15" (381 mm) for the radius, and press ENTER.
   TIP You can also enter an exact position such as 15,15 to specify the center point at the center of the workplane.

A circular profile is created and is added to XY Plane in the part browser.

3 In the part browser, right-click Modifiers and click Add Extrusion.
   For more information about modifiers, see Modifiers on page 660.

4 In the modeling area, select the circular profile.
   The Extrusion Modifier dialog is displayed.

5 Under Termination, select Blind for Type, enter 60" (1524 mm) for Distance, and select Flip.
   Click OK.

A cylinder is created to represent the body of the tank and an extrusion modifier is added to Modifiers in the part browser.
To model a tap

1 To create an offset work plane to help locate the tap, in the part browser, right-click Work Planes and click Add Work Plane.
   The Create Work Plane dialog is displayed.

2 Click Offset and enter Tap Offset for Name. Click OK.

3 Select the XY plane in the modeling area as the reference work plane, and enter 2" (51 mm) for the offset distance.
   The tap offset work plane is created.

4 To create the tap, in the part browser, right-click Tap Offset and click Add Profile ➤ Circular.
   TIP You may find it easier to add the tap in the top view, rather than in a model view direction. To change the view, click View tab ➤ Appearance panel ➤ Views drop-down ➤ Top.

5 In the modeling area, specify a center point on the top of the tank, enter 1" (25 mm) for the radius, and press ENTER.

A circular profile is created and is added to Tap Offset in the part browser.

6 In the part browser, right-click Modifiers and click Add Extrusion.

7 In the modeling area, select the circular profile for the tap.
   The Extrusion Modifier dialog is displayed.
8 Under Termination, select Plane for Type and XY Plane for To. Click OK.

A cylinder is created to represent the tap, and an extrusion modifier is added to Modifiers in the part browser.

NOTE To create additional taps, create reference and offset work planes to locate the plane to which to add a tap; then repeat steps 4 through 8 to create each tap.

Adding Connectors to a Parametric MvPart

Connectors are used to create intelligent networks. You can add connectors to the parts you create using Content Builder. The shape of the connector is determined by the shape of the modifier to which it is attached. You define a default size of the connector when you add the connector to the model. After the connector has been placed, you can assign the connector domain and type.

Adding Connectors to a Parametric Air Terminal MvPart

Use this procedure to add connectors to a parametric air terminal MvPart. Typically, air terminals have a single connector on the top face of the diffuser to provide a connection point for the flex duct.

1. To create the connector geometry for flex duct, in the part browser, right-click Lip Offset and click Add Profile ➤ Circular.
2. In the modeling area, using object snaps, select the center point of the top face of the diffuser, enter 3’ (76 mm) for Radius, and press ENTER.

A circular profile for the flex duct connector is created and is added to Lip Offset in the part browser.
**IMPORTANT** The position of the first connector placed in the model defines the axis orientation of the part upon insertion. For example, if you place the first connector on a part with a perpendicular vector into the part, the direction of the vector defines the positive x-axis orientation when inserted in a drawing.

3 In the part browser, right-click Modifiers, click Add Extrusion, and select the circular profile. The Extrusion Modifier dialog is displayed.

4 Under Termination, select Blind for Type and enter 4” (102 mm) for distance. Click OK.

![Diagram of connector placement](image)

A cylinder is created to represent the flex duct connector, and a second extrusion modifier is added to Modifiers in the part browser.

5 To add a connector, in the part browser, right-click Connections and click Add Connection. You are prompted to select the connector location. As you move the cursor around in the modeling area, it snaps to 4 possible locations for a connector—the top and bottom faces of the diffuser, and the top and bottom of the flex duct connector.

6 Select the center point of the top of the flex duct connector and press ENTER to accept the default value for the connector number.

**NOTE** The default connector numbers are in ascending numeric order, according to the order in which the connectors are added to the model. For example, the first connector is 1, the second connector is 2, and so on. You can model connections for MvParts in any order.

7 Pick a location above and to the right of the model to place the dimension for the diameter of the flex duct connector.

![Dimension added to model](image)

A diameter dimension (D1) is added to the model for the diameter of the flex duct connector and to Model Parameters in the part browser, and a connector is added to Connections.
To define the domain and type of connection for the connector, in the part browser, expand Connections, right-click Connector 1, and click Edit. The Connector Properties dialog is displayed.

Select Domain from the list. Connector domains are dependent on the specified shape of the modifier to which the connector is attached.

Select Banded for Type from the list. Connector types are dependent on the connector domain.

Connection Types Selection dialog

NOTE Connectors are assigned an undefined type by default. An undefined connection type creates a valid connection between all types of connectors when inserted in a drawing.

Click OK.

Adding Connectors to a Parametric Junction Box MvPart

Use this procedure to add connectors to a parametric junction box MvPart. Typically, junction boxes have multiple knockouts to accommodate the required wiring. This procedure provides steps for adding a single knockout to the top of a junction box. You can repeat this procedure, making the necessary location adjustments to add other connectors.

1 To add a connector, in the part browser, right-click Connections and click Add Connection. You are prompted to select the connector location. As you move the cursor around in the modeling area, it snaps to 3 possible locations for a connector—the top and bottom of the junction box and the center of the knockout.

2 Select the center point of the knockout and press ENTER to accept the default value for the connector number.

NOTE The default connector numbers are in ascending numeric order, according to the order in which the connectors are added to the model. For example, the first connector is 1, the second connector is 2, and so on. You can model connections for MvParts in any order.

3 Pick a location above and to the right of the model to place the dimension for the diameter of the knockout.
A diameter dimension (D1) is added to the model for the diameter of the knockout, a connector is added to Connections, and D1 size parameter is added to Size Parameters.

**IMPORTANT** The position of the first connector placed in the model defines the axis orientation of the part upon insertion. For example, if you place the first connector on a part with a perpendicular vector into the part, the direction of the vector defines the positive x-axis orientation when inserted into a drawing.

4 To define the domain and type of connection for the connector, in the part browser, expand Connections, right-click Connector 1, and click Edit. The Connector Properties dialog is displayed.

5 Select Conduit for Domain from the list.
   Connector domains are dependent on the specified shape of the modifier to which the connector is attached.

6 Select Glued for Type from the list.
   Connector types are dependent on the connector domain.

**NOTE** Connectors are assigned an undefined type by default. An undefined connection type creates a valid connection between all types of connectors when inserted in a drawing.

7 Click OK.

---

**Adding Connectors to a Parametric Vertical Tank MvPart**

Use this procedure to add connectors to a parametric vertical tank MvPart. Typically, tanks have multiple connectors, an inlet and an outlet. This procedure provides steps to add a connector for the inlet of a vertical tank. You can repeat this procedure, making the necessary location adjustments to add other connectors.

1 To add a connector, in the part browser, right-click Connections and click Add Connection. You are prompted to select the connector location. As you move the cursor around in the modeling area, it snaps to 4 possible locations for a connector—the top and bottom of the tank body and the top and bottom of the tap.

2 Select the center point of the top of the tap and press `ENTER` to accept the default value for the connector number.

**NOTE** The default connector numbers are in ascending numeric order, according to the order in which the connectors are added to the model. For example, the first connector is 1, the second connector is 2, and so on. You can model connections for MvParts in any order.

3 Pick a location above and to the right of the model to place the dimension for the diameter of the tap.
A diameter dimension (D1) is added to the model for the diameter of the tap and to Model Parameters in the part browser, and a connector is added to Connections.

**IMPORTANT** The position of the first connector placed in the model defines the axis orientation of the part upon insertion. For example, if you place the first connector on a part with a perpendicular vector into the part, the direction of the vector defines the positive x-axis orientation when inserted into a drawing.

4 To define the domain and type of connection for the connector, in the part browser, expand Connections, right-click Connector 1, and click Edit.

The Connector Properties dialog is displayed.

5 Select Pipe for Domain from the list.

Connector domains are dependent on the specified shape of the modifier to which the connector is attached. When the Piping domain is selected, the System Type property is available.

6 Select Threaded for Type from the list.

Connector types are dependent on the part domain.

**NOTE** Connectors are assigned an undefined type by default. An undefined connection type creates a valid connection between all types of connectors when inserted in a drawing.

7 Select Cold Water for System Type from the list.

System types are dependent on the connector domain.

### Adding Dimensions to a Parametric MvPart

Dimensions are used to define the default size of a parametric MvPart. You add model dimensions to define the overall size of the model. You can then add other sizes, such as a list of values, to a dimension to create individual part sizes.

### Adding Model Dimensions to a Parametric Air Terminal MvPart

Use this procedure to add dimensions to specify the lengths and widths of the diffuser faces, the height of the transition, and the height of the lip that lies in the ceiling grid.

**TIP** To avoid distortion of the model, add the overall model dimensions first, and then add the individual dimensions for the geometry.

1 In the part browser, expand Modifiers, right-click each modifier, and click Visible.

This turns off the display of the modifiers in the modeling area to assist you in adding dimensions to the profiles.
2. To add a dimension for the width of the top face, in the part browser, right-click XY Plane and click Add Dimension ➤ Distance.

**NOTE** For constant parameter values, you can define a constant dimension, or choose not to add a dimension and use the default value based on the actual size of the geometry. When no dimensions are added, the parameter and its value are not displayed during part size selection.

3. In the modeling area, select the upper-left and lower-right sides of the top face, and specify a location to place the dimension.
   A length dimension (LenA1) is placed in the model and is added to Model Parameters in the part browser. The value of LenA1 is a default value based on the geometry distance of the feature, and it can be changed.

4. To add a dimension for the length of the top face, in the part browser, right-click XY Plane, and click Add Dimension ➤ Perpendicular Distance.

5. In the modeling area, select the lower-left and upper-right sides of the top face for the geometry, and select the upper-left edge of the top face for the relative line. Specify a location to place the dimension, and select the top and right corners to specify the dimension value.
   A length dimension (LenA2) is placed in the model and is added to Model Parameters in the part browser. The value of LenA2 is a default value based on the geometry distance of the feature, and it can be changed.

6. Repeat steps 2 through 5 to add width and depth dimensions to the bottom face.
   Length dimensions (LenA3, LenA4) are placed in the model and are added to Model Parameters in the part browser. The values of LenA3 and LenA4 are default values based on the geometry distance of the features, and they can be changed.

7. In the part browser, right-click each of the extrusions and click Visible.
   The flex duct connector extrusion modifier and the lip extrusion modifier are both displayed in the modeling area.

8. To define the length of the flex duct connector, in the part browser, right-click Model Dimensions and click Add Distance.

9. In the modeling area, select the flex duct connector extrusion modifier feature, and specify a location to place the dimension.
   A length dimension (LenB1) is placed in the model and is added to Model Parameters in the part browser. The value of LenB1 is a default value based on the height distance of the feature, and it can be changed.
To specify a constant height for the length of the flex duct connector, in the part browser, expand Model Parameters, right-click LenB1, and click Edit.

The Model Parameters dialog is displayed.

Double-click the Equation value for LenB1, enter 4" (102 mm), and then click Close.

To specify the height of the lip, in the part browser, right-click Model Parameters, right-click WPOf2, and click Edit.

The Model Parameters dialog is displayed.

NOTE Creating a modifier with a plane termination type enables you to use the distance between work planes as the defined length of the modifier feature. In this procedure, you use the distance between the work planes you created when adding the lip as the height dimension for the lip.

Verify that the Equation value for WPOf2 is 1" (25 mm).

If you need to change the value, double-click Equation for WPOf2, and enter a number to change the value.

Click Close.

Adding Model Dimensions to a Parametric Junction Box MvPart

Use this procedure to add dimensions to specify the length, width, and depth of the junction box.

To define the overall height of the junction box, in the part browser, right-click Model Dimensions and click Add Distance.

NOTE For constant parameter values, you can define a constant dimension, or choose not to add a dimension and use the default value based on the actual size of the geometry. When no dimensions are added, the parameter and its value are not displayed during part size selection.

In the modeling area, select the junction box modifier feature and specify a location to place the dimension.

A height dimension (LenB1) is placed in the model and is added to Model Parameters in the part browser. The value of LenB1 is a default value based on the extrusion distance of the feature, and it can be changed.

To specify the actual height of the junction box, in the part browser, expand Model Parameters, right-click LenB1, and click Edit.
The Model Parameters dialog is displayed.

4 Double-click the Equation value for LenB1, enter 4” (102 mm), and then click Close.

5 To add a dimension for the width of the junction box, in the part browser, right-click XY Plane and click Add Dimension ➤ Horizontal Distance.

6 In the modeling area, select 2 corner points to specify the width of the junction box, and specify a location to place the dimension.

7 On the command line, enter a dimension value of 4” (102 mm), and press ENTER.

A length dimension (LenA1) is placed in the model and is added to Model Parameters in the part browser. The value of LenA1 is a default value based on the geometry distance of the feature, and it can be changed.

8 To add a dimension for the depth of the junction box, in the part browser, right-click XY Plane and click Add Dimension ➤ Vertical Distance.

9 In the modeling area, select 2 corner points to specify the depth of the junction box, and specify a location to place the dimension.

10 On the command line, enter a dimension value of 2” (51 mm), and press ENTER.

A length dimension (LenA2) is placed in the model and is added to Model Parameters in the part browser. The value of LenA2 is a default value based on the geometry distance of the feature, and it can be changed.
Adding Model Dimensions to a Parametric Vertical Tank MvPart

Use this procedure to add dimensions to specify the height and diameter of the tank body, and the length for the tap of the tank.

**TIP** To avoid distortion of the model, add the overall model dimensions first, and then add the individual dimensions for the geometry.

1. To add the height dimension of the tank body, in the part browser, right-click Model Dimensions and click Add Distance.

   **NOTE** For constant parameter values, you can define a constant dimension, or choose not to add a dimension and use the default value based on the actual size of the geometry. When no dimensions are added, the parameter and its value are not displayed during part size selection.

2. In the modeling area, select the body modifier and specify a location to place the dimension. A length dimension (LenB1) is placed in the model and is added to Model Parameters in the part browser. The value of LenB1 is the height of the extrusion that represents the tank body, and it can be changed.

3. To specify the actual length of the tap, in the part browser, expand Model Parameters, right-click WPOf1, and click Edit. The Model Parameters dialog is displayed.

   **NOTE** Creating a modifier with a plane termination type enables you to use the distance between work planes as the defined length of the modifier feature. In this procedure, you use the distance between the work planes you created to locate the tap as the tap length dimension.

4. Verify that the Equation value for WPOf1 is 2" (51 mm), and then click Close.
If you need to change the value, double-click the value, and enter a different number.

**Adding Individual Part Sizes to a Parametric Air Terminal MvPart**

Use this procedure to add individual part sizes to the model. You create individual part sizes by adding parameters values. Values can be a list or table of values, constant values, or calculations.

You can also create unique part size names. Each part size name is generated using a calculation—a formatted string of parameter values and text.

1. To add part sizes to the part, in the part browser, right-click Size Parameters, and click Edit Configuration.

   The Size Parameters dialog is displayed.

   **NOTE** Calculated values set in the model cannot be edited in the Size Parameters dialog. To change these values you must edit the model.

2. To add a table of available sizes for the lengths and widths of the top and bottom faces of the diffuser, change the data storage type of the LenA1, LenA2, LenA3, and LenA4 parameters to Table.

3. In the toolbar, select Values from the list.

   The parameter values are displayed.

4. To add a new part size, click the first row in the table, and then click on the toolbar.

   A new part size row is added to the Size Parameters dialog. Repeat for each new part size you want to add.

5. For each part size, double-click in the LenA1, LenA2, LenA3, and LenA4 parameters and enter values.

   **TIP** You can copy and paste values from other part families using standard Microsoft® Windows copy and paste functionality (CTRL+C for Copy and CTRL+V for Paste). You can copy and paste values from another part open in Content Builder, from a part open in Catalog Editor, or from a Microsoft® Excel spreadsheet. For connector parameters, you can also insert the corresponding values for the segments used by default during layout.

6. When you finish adding sizes, click OK.

7. To add the size of the transition between faces, expand Model Parameters, right-click WPOf1, and click Edit.

8. In the Model Parameters dialog, double-click the Equation value for WPOf1, enter -4" (-102 mm), and click Close.

   **NOTE** You can also add an equation formula for the value. Click Calculator to access the Equation Assistant.

9. To specify a unique part size name, in the part browser, right-click Size Parameters and click Edit Calculations.

   The Size Parameters dialog is displayed.

10. Double-click PrtD in row 1.

    The Calculation Assistant is displayed.

11. In the Calculation Assistant, define the part size name.

    ■ Select 0 for Precision.
Under Insert Variable, select LenA1 and click Insert.

At the top of the dialog, click the value for Part Size Name (PrtSN), and enter x.

Under Insert Variable, select LenA2, and click Insert.

Click the value for Part Size Name (PrtSN), and enter inch Louver Face Ceiling Diffuser.

12 Click Evaluate to view the result.

13 Click OK twice.

Adding Individual Part Sizes to a Parametric Junction Box MvPart

Use this procedure to add individual part sizes to the model. You create individual part sizes by adding parameter values. Values can be a list or table of values, constant values, or calculations.

You can also create unique part size names. Each part size name is generated using a calculation—a formatted string of parameter values and text.

1 To add part sizes to the part, in the part browser, right-click Size Parameters, and click Edit Configuration.

The Size Parameters dialog is displayed.

NOTE Calculated values set in the model cannot be edited in the Size Parameters dialog. To change these values you must edit the model.

2 To add a table of available sizes for the width of the junction box, change the data storage type of LenA1 to Table.

3 In the toolbar, select Values from the list.

The parameter values are displayed.

4 To add a new part size, click the first row in the table, and then click New on the toolbar.

A new part size row is added to the Size Parameters dialog. Repeat for each new part size you want to add.

5 For each part size, double-click LenA1 and enter a size.

TIP You can copy and paste values from other part families using standard Microsoft® Windows copy and paste functionality (CTRL+C for Copy and CTRL+V for Paste). You can copy and paste values from another part open in Content Builder, from a part open in Catalog Editor, or from a Microsoft® Excel spreadsheet. For connector parameters, you can also insert the corresponding values for the segments used by default during layout.

6 To specify a unique part size name, in the toolbar, select Calculations from the list.

The calculation strings are displayed.

7 Double-click PrtD in row 1.

The Calculation Assistant is displayed.

8 In the Calculator Assistant, define the part size name.

- Select 0 for Precision.

- Under Insert Variable, select LenA1 and click Insert.

- At the top of the dialog, click the value for Part Size Name (PrtSN), and enter inch Outlet Box.
Adding Individual Part Sizes to a Parametric Vertical Tank MvPart

Use this procedure to add individual part sizes to the model. You create individual part sizes by adding parameter values. Values can be a list or table of values, constant values, or calculations.

You can also create unique part size names. Each part size name is generated using a calculation—a formatted string of parameter values and text.

1. To add part sizes to the part, in the part browser, right-click Size Parameters, and click Edit Configuration.
   The Size Parameters dialog is displayed.

   **NOTE** Calculated values set in the model cannot be edited in the Size Parameters dialog. To change these values you must edit the model.

2. To add a table of available sizes for the diameter and height of the tank body, click to change the data storage type of ND1 and LenB1 to Table.
3. In the Size Parameters dialog, select Values from the drop-down list.
   The parameter values are displayed.

4. To add a new size, click the first row in the table, and then click on the toolbar.
   A new part size row is added to the Size Parameters dialog. Repeat for each part size you want to add.

5. For each part size, double-click ND1 and LenB1 and enter values.
   The software automatically retrieves an appropriate physical diameter based on the nominal diameter that you specify and the connection type. For more information, see Specifying Connector Sizes for Pipe Connectors on page 670.

   **TIP** You can copy and paste values from other part families using standard Microsoft® Windows copy and paste functionality (CTRL+C for Copy and CTRL+V for Paste). You can copy and paste values from another part open in Content Builder, from a part open in Catalog Editor, or from a Microsoft® Excel spreadsheet. For connector parameters, you can also insert the corresponding values for the segments used by default during layout.

6. To specify a unique part size name, in the Size Parameters dialog, select Calculations from the list.
   The calculation strings are displayed.

7. Double-click PrtD in row 1.
   The Calculation Assistant dialog is displayed.

8. In the Calculation Assistant dialog, define the part size name.
   - Under Precision, select 0.
   - Under Insert Variable, select LenB1, and click Insert (to the right).
   - At the top of the dialog, click the value for Part Size Name (PrtSN), and enter inch Vertical Storage Tank.

9. Click Evaluate to see the result.
10 Click OK twice.

Generating a Preview Image of a Parametric MvPart

Use this procedure to generate a preview image of the parametric MvPart to help during part selection. Content Builder generates the preview image based on a specified view direction. You can select from the 10 standard AutoCAD® view directions to view the model (top, bottom, left, right, front, back, SW isometric, SE isometric, NE isometric, and NW isometric).

1 In the part browser, click (Generate Bitmap).

The Bitmap Preview dialog is displayed.

Example of bitmap preview of a parametric vertical tank MvPart

2 Under Generate View, click a view for the preview image of the part.

**TIP** As you select a view, the preview image window in the dialog is updated. This enables you to view all the available preview images for the part before selection.
You can also browse to and select a predefined bitmap image. Predefined images must be 200 x 200 pixels and saved with 256 colors.

3 Click OK.

**Defining the Part Insertion Behaviors of a Parametric MvPart**

1 In the part browser, click (Options).
The Options dialog is displayed.

![Options dialog]

2 Specify the insertion behaviors for the part, and click OK.
For descriptions of the settings, see Part Insertion Behaviors of a Parametric Part on page 671.

3 In the part browser, expand Autolayout Data, right-click Layout Data, and click Select Placement Point.

![Select Placement Point from Layout Data context menu]

4 Specify the point on the part model to use as the placement (insertion) point for the MvPart.
The software adds (a placement point) at the selected location.

**Validating, Saving, and Previewing a Parametric MvPart**

Use this procedure to validate a parametric MvPart, save the part family, and preview individual part sizes.

**To validate a parametric MvPart**

1 On the Content Builder toolbar, click .
Upon successful completion of these procedures, the part is validated and the status bar is updated with the traffic light displayed green.
If you have errors in your model, the traffic light is red and a dialog is displayed listing the errors. Review the errors, make necessary modifications and repeat this step until validation is successful.

| Part family validation Failed | Details |

**NOTE** Warnings in the Part Family Validation Results dialog do not make the part invalid.

Once validation is successful, you can save the parametric MvPart.

**To save a parametric MvPart**

1. On the toolbar, click
2. Specify whether to make the part available in the catalog:
   - Click Yes to make the part available to users.
   - Click No to keep the part hidden.

**NOTE** This prompt toggles the Hide Part option in the Options dialog in Content Builder.

The part is saved in the specified catalog location.

**To preview a parametric MvPart**

1. To preview each part size, in the part browser, right-click Size Parameters and click Edit Values.
2. The Size Parameters dialog is displayed.
3. Click a row in the table to select the default part size.
4. Click

The Parametric Object Viewer is displayed.

**Parametric Object Viewer dialog**

![Parametric Object Viewer dialog](image)
Select a different view from the list, or click ![3D orbit navigation icon] to view the model using 3D orbit navigation.

In the Parametric Object Viewer, select a point on the circle, and drag the cursor along the circumference of the circle to inspect the 3D model dynamically from various viewpoints.

With the Parametric Object Viewer open, select a different part size in the Size Parameters dialog. The part size is displayed in the viewer.

Inspect the model from various viewpoints to verify that the model appears sound. If your inspection reveals problems, such as segments that join improperly, make the necessary modifications, and inspect the part sizes again. Repeating this process until all part sizes appear sound.

Click ![Close icon] to close the Parametric Object Viewer.

### Creating a Schematic Symbol of a Parametric MvPart

You can create a schematic symbol for a parametric MvPart at any time. However, only parts that you add to drawings after you have created the symbol can use the symbol. You cannot update previously inserted parts to use the symbol.

There are 2 types of schematic symbols that you can add to parametric MvParts:

- **Parametric.** This type of symbol scales proportionally with the part. You create parametric symbols using parametric features: parametric geometry, dimensions, and constraints.

- **Block-based.** This type of symbol scales uniformly instead of proportionally. You create block-based symbols using standard AutoCAD® objects, such as lines, arc, and circles. You can create the symbol from scratch, or you can insert an existing AutoCAD MEP symbol or 2D AutoCAD block from a DWG file. This allows you to take advantage of existing symbol libraries or block libraries.

### Creating a Parametric Symbol

1. If necessary, open the parametric MvPart in Content Builder.
2. In the part browser, right-click Symbol and Annotation Plane, and click Visible.

   **NOTE** Although this step makes the plane visible in the drawing area, its position on the Z axis in the World Coordinate System (WCS) is high above the WCS origin, so you might need to zoom out to view the plane. You can also change the position of the plane if desired.

3. Right-click Symbol and Annotation Plane, and click Set View.
   This changes the view direction to Top (plan) view, which is the default view for the plane as well as the most common view for drawing schematic symbols. However, you can select any view that is helpful for drawing the geometry.

4. Create the schematic symbol using parametric geometry, constraints, and dimensions.
   First, use the model geometry that changes with part size to create point references and projected geometry on the Symbol and Annotation plane. Next, create the symbol geometry on the plane. Finally, add constraints and/or dimensions so that the symbol changes accordingly when the part size changes.
   To access the necessary commands, expand Symbol and Annotation Plane, right-click Parametric Graphics, and use the commands on the context menu, as follows. Click Add Geometry, and then click Point Reference.
To quickly generate the geometry of the model outline on the Symbol and Annotation plane, you can right-click the plane in the part browser, and select Part Boundary. You can use the outline geometry as a guide for the symbol geometry. When you are done, turn off Part Boundary to remove the outline geometry from the plane because it does not change in size.

**TIP** Use the Isolate Plane Contents, Hide Plane Contents, and End Object Isolation commands on the context menu of a plane to show or hide the geometry on the plane.

5. After you have drawn the symbol geometry and added the necessary constraints and dimensions, verify that when the part changes in size, the symbol changes in size in the same way:
   - In the part browser, expand Model Parameters, right-click a parameter, and click Edit.
   - In the Model Parameters dialog, modify the values of the parameters for the model, and click Close.
   - Examine the changes to the model and symbol in the drawing area.

6. If desired, add annotation to the schematic symbol.

7. If desired, specify the use of the schematic symbol instead of a model-generated view in 1-line and 2-line display representations in Top (plan) view:
   - In the part browser, click 
   - In the Options dialog, click Display Symbol In Plan View, and click OK.

8. In the part browser, click (Save Part Family).

9. Click to close the part browser.

As an example, the following illustrations show how to create a parametric schematic symbol for an air diffuser. First, to align the edges of the symbol with the edges of the diffuser, point references are created on the Symbol and Annotation plane using 2 of the corner points on the diffuser. Then, for better viewing,
the contents of the Symbol and Annotation plane are isolated. At this point, the 2 point references are the only geometry on the plane.
Next, using the point references to specify the corner points, a rectangle is drawn to represent the schematic symbol.

Finally, to cause the symbol to scale proportionally with the diffuser, the corner points of the symbol rectangle are constrained to the underlying point references. Because the point references are based on the corner points of the model, this ensures the symbol and the model remain aligned. You can also accomplish this by adding dimensions to the symbol and setting their values to the names of the corresponding model dimensions. This ensures the symbol dimensions change when the model dimensions change.

**TIP** To cycle through overlapping objects, move the cursor over the object on top, then press and hold SHIFT while pressing SPACEBAR repeatedly. To cycle through overlapping subobjects (faces, edges, and vertices) on 3D solids, move the cursor over the subobject on top, then press and hold CTRL while pressing SPACEBAR repeatedly.

### Creating an AutoCAD-Based Symbol from Scratch

1. If necessary, open the parametric MvPart in Content Builder.
2. In the part browser, right-click **Symbol and Annotation Plane**, and click Visible.

**NOTE** Although this step makes the plane visible in the drawing area, its position on the Z axis in the World Coordinate System (WCS) is high above the WCS origin, so you might need to zoom out to view the plane. You can also change the position of the plane if desired.
3 Right-click Symbol and Annotation Plane, and click Set View.
   This changes the view direction to Top (plan) view, which is the default view for the plane as well as the most common view for drawing schematic symbols. However, you can select any view that is helpful for drawing the geometry.

4 Draw the geometry of the schematic symbol using standard AutoCAD objects, such as lines, arcs, and circles.

   **TIP** Use the Isolate Plane Contents, Hide Plane Contents, and End Object Isolation commands on the context menu of a plane to show or hide the geometry on the plane.

5 In the part browser, expand Symbol and Annotation Plane, right-click Design Blocks, and click Add Schematic Block.

6 Select the plane along which to orient the 2D symbol, select the geometry of the symbol, and press ENTER.

   Typically you orient the symbol along the Symbol and Annotation plane. To do so, press ENTER to accept the current plane. However, you can also select a different plane. For example, you might want the symbol to show in side views instead of Top view for use in section and elevation drawings.

   You can select any geometry except parametric geometry created using Content Builder, which is filtered from the selection set.

7 Specify whether to erase the source geometry of the symbol:
   - Enter n (no) and press ENTER to keep the source geometry in the part.
   - Enter y (yes) or press ENTER to erase the source geometry.

   The schematic symbol is attached to the Symbol and Annotation Plane regardless of the plane where it is oriented. Therefore, the software adds a Design Block to the Symbol and Annotation Plane under Design Blocks in the part browser.

   **Adding design block**

   Design Block represents the schematic block that you have added. Typically, you create only one symbol and, therefore, only one Design Block for a part.

8 If desired, add annotation to the schematic symbol.

9 If desired, specify the use of the schematic symbol instead of a model-generated view in 1-line and 2-line display representations in Top (plan) view:
   - In the part browser, click .
   - In the Options dialog, click Display Symbol In Plan View, and click OK.

10 Click (Save Part Family).

11 Click to close the part browser.

**Creating an AutoCAD-Based Symbol from an Existing Symbol or Block**

1 If necessary, open the parametric MvPart in Content Builder.
2 In the part browser, right-click Symbol and Annotation Plane, and click Visible.

**NOTE** Although this makes the plane visible in the drawing area, its position on the Z axis in the World Coordinate System (WCS) is high above the WCS origin, so you might need to zoom out to view the plane. You can also change the position of the plane if desired.

3 Right-click Symbol and Annotation Plane, and click Set View.
   This changes the view direction to Top (plan) view, which is the default view for the plane as well as the most common view for adding schematic symbols.

4 In the part browser, expand Symbol and Annotation Plane, right-click Design Blocks, and click Insert AutoCAD Block.

5 In the Insert dialog, click Browse, navigate to the drawing that contains the symbol or block you want to insert, and select it.

6 For Name, select the name of the symbol or block.

**NOTE** If the drawing contains only a single symbol or block, you can select the drawing name instead. In this case, also click Explode to explode the drawing-level block that contains all of the blocks in the drawing. This exposes the single block inside the drawing so the software can retrieve it.

7 Specify the insertion point, scale, and rotation angle; and click OK.
   Alternatively, you can click Specify On-screen for one or more of these settings to specify the value when you insert the symbol or block.

8 In the drawing, if necessary, specify the insertion point and rotation angle.

9 Enter y (yes) or press ENTER to use the block as the schematic symbol.

10 Specify whether to erase the source geometry of the symbol:
   - Enter n (no) and press ENTER to keep the source geometry in the part.
   - Enter y (yes) or press ENTER to erase the source geometry.

The software explodes the symbol or block, and adds a Design Block to the Symbol and Annotation Plane in the part browser.

**Adding design block**

The Design Block represents the schematic block that you have added. Typically, you create only one symbol and, therefore, only one Design Block for a part.

11 If desired, add annotation to the schematic symbol.

12 If desired, specify the use of the schematic symbol instead of a model-generated view in 1-line and 2-line display representations in Top (plan) view:
   - In the part browser, click .
   - In the Options dialog, click Display Symbol In Plan View, and click OK.

13 Click (Save Part Family).

14 Click to close the part browser.
Adding Annotation to a Schematic Symbol

You can add annotation to the schematic symbol of a parametric MvPart regardless of whether the symbol is parametric or block-based. To add the annotation, you create a multiline text (mtext) object, which the software then uses to create the text block to associate with the symbol.

When the symbol is inserted into a drawing, the text block is inserted as well. If the symbol changes in size, the text block is repositioned to maintain the same relative position.

To add annotation to a parametric or block-based schematic symbol

1 If necessary, open the MvPart in Content Builder.
2 In the part browser, expand Modeling, and expand Symbol and Annotation Plane.
3 Right-click Annotation Text, and click Add Annotation Text.
4 In the drawing area, specify opposite corners of a bounding box to define the width of the multiline text object.
5 Use the In-Place Text Editor to enter the annotation text and specify its properties, such as the character height expressed in terms of the drawing units.
   For information on using the In-Place Text Editor, see “Overview of Multiline Text” in AutoCAD Help.

TIP If you set the character height of the annotation text in your building systems drawings to 1 unit, you can control the plot size of annotation entirely by the Annotation Plot Size setting on the Scale tab of the Drawing Setup dialog. For example, if the units for a drawing are inches, and the annotation plot size for the drawing is 3/32", then setting the annotation text in the drawing to 1” results in a text height of 3/32" for the plotted annotation.

6 Save your changes, and exit the editor by doing one of the following:
   ■ Click in the drawing outside the editor.
   ■ Click OK on the toolbar.
   ■ Press CTRL+ENTER.

   The software creates the text block and attaches it to the Symbol and Annotation plane. The text block now appears in the part browser under Annotation Text.

7 If you want the annotation text to remain horizontal regardless of the rotation angle of the part when it is inserted, select the text block, right-click, and click Keep Text Horizontal.

To delete the annotation text block, you can select the block in the drawing area, and press DELETE.

Modifying Parametric Parts Using Content Builder

You can modify existing parametric parts with Content Builder. For parts in the catalogs provided by AutoCAD MEP, you can change the part behavior, part size parameters, and connectors. For parametric parts you create using Content Builder, you can change the part behaviors, part size parameters, connectors, and part model including geometry, profiles, modifiers, constraints, and dimensions. You can also delete parts that you no longer need. Deleting parts can be helpful when creating custom catalogs to ensure that all associated definition files are managed correctly.

Starting Content Builder for Modifying a Parametric Part

Use this procedure to start Content Builder and open the parametric building environment for modifying a parametric part.
1 Click Manage tab ➤ MEP Content panel ➤ Content Builder .
   The Getting Started - Catalog Screen dialog is displayed.

2 In the part catalog browser, navigate to and select a parametric part.

3 To add a new part size to an existing part, click .
   The existing part is opened in the parametric building environment.

4 To modify a part size, click .
   The existing part is opened in the parametric building environment.

5 To delete a part, click .
   The selected part family is deleted from the part catalog, including all associated definition files
   (XML, DWG, and BMP files).

**Modifying a Parametric Part**

As your design develops and parts change, you can modify parametric parts using Content Builder. You can change the part behavior, part size parameters, and connectors. For parts you created using Content Builder, you can also change the part model, including geometry, profiles, modifiers, constraints, and dimensions. You can use the same procedures that guide you through creating a parametric part to modify it. This section outlines how you can modify a parametric part and provides references to the related procedures that you can use to make changes.

**IMPORTANT** When making changes to a parametric part, refer to the illustration in *Model of a Parametric Part* on page 654. This illustration shows the relationship dependencies between features that must be maintained to ensure you are creating a usable part.

**Modifying the Part Configuration**

You can change the part configuration that controls the behavior of the part. In the part browser, expand Part Configuration and change the part type or subtype. For more information, see *Defining the Part Behavior of a Parametric Fitting* on page 676 and *Specifying the Part Configuration of a Parametric MvPart* on page 698.

**Modifying the Part Model**

For parts that you created using Content Builder, you can change the model parameters that define the overall size of the model. You can change the geometry, dimensions, and constraints of the model.

You can add, modify, or remove geometry in the model; however, you must append the changed geometry to the profile in order for Content Builder to update the model and assign new geometric constraints.

You can also change the parametric relationships of model elements by modifying the geometric and dimension constraints. Because constraints control the overall shape of the model, you cannot safely make changes until you know the current constraints applied to the model. You can delete an unwanted constraint or add new constraints to reshape the sketch.

Content Builder’s parametric commands ensure that relationships among geometric elements remain intact; however, after changes are made to the model you should re-examine the geometric constraints and dimensions to verify that nothing else in the model needs to be updated. For more information, see *Modeling a Parametric Fitting* on page 677 and *Modeling a Parametric MvPart* on page 700.
Modifying Connectors

You can add, delete, and edit the connectors of a parametric part. The shape of the connector is determined by the shape of the modifier that the connector is attached to. Therefore, to change a connector’s shape you must modify the associated modifier. For more information, see Adding Connectors to a Parametric Fitting on page 682 and Adding Connectors to a Parametric MvPart on page 720.

Modifying Part Sizes

You can change the model dimensions of the part that determine the overall size of the model, such as length and width. You can also change individual size parameters for a specific part size. For example, you can change a constant value to a list of values or add custom parameters for enhancing scheduling data. For more information, see Adding Dimensions to a Parametric Fitting on page 686 and Adding Dimensions to a Parametric MvPart on page 724.

Modifying the Preview Image, Schematic Symbol, or Part Insertion Behaviors

You can change the preview image by selecting a different view direction that Content Builder uses to generate the preview image. You can also attach a predefined image. For more information, see Generating a Preview Image of a Parametric Fitting on page 690 and Generating a Preview Image of a Parametric MvPart on page 732.

You can change the insertion behaviors of the part that define how the part is added to a drawing, including layer key, trim lengths for fittings, and the placement point of a parametric part. For more information, see Defining the Part Insertion Behaviors of a Parametric Fitting on page 690 and Defining the Part Insertion Behaviors of a Parametric MvPart on page 733.

For parametric MvParts, you can also modify the schematic symbol. Schematic symbols can be predefined symbol blocks or you can create them from scratch in the modeling area of Content Builder. Therefore, you can attach a new schematic symbol or modify the schematic symbol block. For more information, see Creating an AutoCAD-Based Symbol from an Existing Symbol or Block on page 739.

Working with Block-Based Parts

A block-based part is a multi-view part (MvPart) whose geometry is based on individual AutoCAD® blocks. Each part size is associated with a unique 3D model block, to which you specify basic information such as view representations and connector placement. You can convert existing AutoCAD blocks or multi-view blocks (MvBlocks) to block-based parts, and you can create block-based parts using Content Builder.

NOTE For an introduction to block-based parts, see Understanding Parametric and Block-Based Parts on page 641.

Converting MvBlocks to Block-Based Parts

Use this procedure to convert AutoCAD® solids, mass elements, blocks, or multi-view blocks (MvBlocks) into multi-view parts (MvParts). MvBlocks, like MvParts, can be viewed from different directions, but MvBlocks cannot connect intelligently with systems.

Architectural drawings referenced in an AutoCAD MEP drawing can contain solids, mass elements, and MvBlock parts that may be useful as MvParts. You can convert MvBlocks to MvParts even if the MvBlock exists in a reference drawing.

This procedure is the same for mechanical, piping, electrical, and plumbing parts.

1. Select the element or block to convert, right-click, and select Convert to ➤ Multi-view Part.
2. In the Multi-view Part Convert - Behavior dialog, specify a name for the new part.
3. Specify a part type for Type.
4 Specify a category for Subtype.
5 Specify a layer key for the new part.
6 Click Next.
7 In the Multi-view Part Convert - Connectors view, right-click the MvPart name and select a connector type.
8 In the Part Family Connector Properties dialog, specify the properties for the connector.
9 Click OK.
10 Continue adding connections for the part.
11 To specify the location of a connection, select a connection, right-click, and select Edit Placement. Note that the MvPartBuilder - Connector Editor is displayed in your workspace.
12 Select Position for Connector.
13 Specify the placement for the connector on the MvPart.

**NOTE** Use object snaps to snap the connector placement to linework in the block drawing. When you are editing connector placement, you can make it easier to select geometry by using tools such as 3D Orbit and Pan to change the part view.

14 If the connector has a flow direction, you can specify a vector to indicate the direction, or you can specify the coordinates in the Normal field under Connector Geometry. For example, a pipe connector with an outflow in the downward direction has the normal coordinates of \(0,0,-1\).
15 To specify the placement of other connectors, select a connector at the top of the Connector Editor and specify the location on the MvPart.
16 When you have finished, click OK to close the Connector Editor.
17 If you want to change connector properties, select a connector in the Multi-view Part Convert - Connector dialog, right-click, and select Modify.
   
   If you want to change connector placement, direction, or size, right-click a connector and select Edit Placement. Use the Connector Editor to make changes.
18 Click Finish.

The resulting MvPart can now be connected to specific building systems. Note that the original block still exists; the MvPart is created as a separate entity and placed in the same location.

*An example of a MvBlock sink that was converted to an MvPart. The sink can now connect to piping for the waste system.*
The MvPart exists in the drawing but is not added to a part catalog. You can add multiple instances of a converted MvPart by copying and pasting it in a drawing. You can modify a converted MvPart by selecting it, right-clicking, and selecting Edit MvPart Style. If you want to create an MvPart from a block, and include it in a part catalog, use the Content Builder. For more information, see Content Builder on page 646.

**Best Practices for Creating a Block-Based Part**

The following tips will help you to create a block-based part using Content Builder.

- Do not save the source files (drawings for the 3D model and schematic symbol) in the catalog folders of AutoCAD MEP. The source files are working files and should be saved in a separate folder.

- To take advantage of the automatic view block creation tool in Content Builder, create the 3D model from AutoCAD® solids. This also ensures support of the part in AutoCAD MEP and for rendering, shading, and hiding in 3D model views.

- To ensure correct display control of part sizes when added to a drawing, draw all geometry for the 3D model and schematic symbol on layer 0. Assign BYBLOCK for color and linetype, and BYLAYER for lineweight.

- Assign a helpful name and description to new parts. The name specified for the part family in the New Part dialog is used to name the files that define the part in the catalog (XML file, BMP file, DWG file). The description is the phrase you see during part selection throughout AutoCAD MEP.

**Block-Based Part Creation Overview**

When you create a block-based part, you associate a pre-drawn 3D model block with basic information such as part behavior, placement of connectors, and custom data. Block-based parts represent individual part sizes. Using Content Builder, you define a part family and one or more part sizes. You can also create part sizes in an existing part family. It is important to analyze the catalog hierarchy to decide the best place to add new part families. It is also important to notice the relationships between the different part sizes you want to create. Some may be similar in type and should belong to the same part family, while others may be unique and require their own part family.

The following sections provide an overview for creating block-based parts using Content Builder.

**3D Model Block for a Block-Based Part**

Each part size of a part family represents a real-world building systems part, such as a piece of equipment. For each part size, you must create a 3D model block to represent the part size as it would look in the real world. All model blocks must be created using AutoCAD® solids in order to support automatic generation of view blocks, as well as rendering, shading, and hiding in 3D model views. Each 3D model block must be saved in an AutoCAD drawing file. You can save one or more model blocks in the same drawing file.

**IMPORTANT** Do not save the model block drawings in the catalog folders of AutoCAD MEP. These are working files and should be saved in a separate, or temporary, folder.

You should create the model block based on the standard AutoCAD UCS orientation to ensure that the individual view blocks generated by Content Builder are correct. Using the SW isometric view, create the model block at an insertion point of 0,0,0 in the world coordinate system (WCS). This ensures that each view block generated aligns to the respective side of the model block as follows:

<table>
<thead>
<tr>
<th>The...</th>
<th>aligns with the...</th>
<th>in the...</th>
</tr>
</thead>
<tbody>
<tr>
<td>top view block</td>
<td>top side of the model block</td>
<td>XY plane.</td>
</tr>
</tbody>
</table>
The...  "aligns with the...  in the..."

<table>
<thead>
<tr>
<th>Top view block</th>
<th>top side of the model block</th>
<th>XY plane.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bottom view block</td>
<td>bottom side of the model block</td>
<td>XY plane.</td>
</tr>
<tr>
<td>Front view block</td>
<td>front side of the model block</td>
<td>XZ plane.</td>
</tr>
<tr>
<td>Back view block</td>
<td>back side of the model block</td>
<td>XZ plane.</td>
</tr>
<tr>
<td>Left view block</td>
<td>left side of the model block</td>
<td>YZ plane.</td>
</tr>
<tr>
<td>Right view block</td>
<td>right side of the model block</td>
<td>YZ plane.</td>
</tr>
</tbody>
</table>

**NOTE** To ensure correct display control of part sizes when a part is added to your drawings, draw geometry for the model block on layer 0, assign BYBLOCK for color and linetype, and assign BYLAYER for lineweight.

**Sample 3D model block of an air handling unit**

**Schematic Symbol of a Block-Based Part**

Generally, every part has a schematic symbol that you add to your schematic design layouts. Using Content Builder, you can assign each part a symbol block. You can assign a different symbol to each part size, or assign the same symbol to all part sizes. The symbol block provides a schematic representation of the part size for use in plan views. Typically, the same symbol block is used for all the part sizes in a part family. You must save the symbol block in an AutoCAD® drawing file. You can save one or more symbol blocks in the same drawing file.

**IMPORTANT** Do not save the symbol block drawings in the catalog folders of AutoCAD MEP. These are working files and should be saved in a separate, or temporary, folder.

You can use any drawing command to create the geometry for the blocks. Standard AutoCAD entities such as lines, polylines, or circles are recommended. Once the schematic symbol block is created, Content Builder scales and wraps the symbol block with a bounding box of the 3D model. This ensures that valid connections can be maintained between the schematic symbol and the connecting schematic lines.

**WARNING** Be careful when using AEC-based geometry, such as walls or ducts, to create your symbol. To avoid object enabler problems, be sure to explode the geometry to base AutoCAD entities before running MvPart Builder.

To ensure correct display control of your symbol when it is added to your drawings, draw geometry for the symbol on layer 0, assign BYBLOCK for color and linetype, and assign BYLAYER for lineweight. The insertion point, or base point, is used as a reference for positioning the block upon insertion. The insertion point for the schematic block should be the same as the 3D model block that it represents. When you place the MvPart in a drawing, all associated blocks are part of one object; therefore, you want to maintain a common insertion point.
Content Builder wraps the schematic symbol with a bounding box of the 3D model and places the schematic symbol in the center of the bounding box. The bounding box is stretched around the extents of the 3D model in order to maintain accurate locations of the connection points. For easy identification, you should also use a standard naming convention that represents the part size or part family as you save your symbol block.

**Behavior of a Block-Based Part**

In the block-based building environment, you begin part definition by specifying the behavior of the part family. Every part size in a part family has the same behavior. You then specify a type, subtype, layer key, and insertion method for each part family.

**Part Type**

Part type refers to the main category for the part family. It defines unique characteristics and behaviors for the part sizes, such as the ability to assign flow annotation to an HVAC part size. Types are predefined by the application and cannot be modified. Therefore, select a type that is similar to the part sizes.

**Example of MVPart Builder (New Part) dialog**

Block-Based Part Creation Overview | 747
Part Subtype

Part subtype is the subcategory for the part family. It is useful for grouping similar parts. The subtype can be used as a filter method for part selection in the Add and Modify dialogs. Therefore, you should select a descriptive subtype name for easy identification. You can also enter a new subtype if the desired subtype is not listed.

Layer Key

You assign a layer key to the part family for automatic layer mapping of part sizes. The same layer key is used for all part sizes of a part family. When you add a part that has a specified layer key to a drawing, the part is placed on the layer to which it is mapped. For example, according to the Aecb layer standard (AecbLayerStd4.dwg) and associated Mech - AIA 256-color layer key style, the Air Handling Unit layer key is mapped to the M-HVAC-Eqpm layer. When you add an air handling unit to your drawing, it is assigned to the M-HVAC-Eqpm layer. Only those layer keys predefined in the layer key style selected for the current drawing are available for selection in Content Builder. To learn more about layer keys, see “Layer Management” in AutoCAD Help.

Insertion Method

There are 2 insertion methods for placing parts in your drawing: anchor and breaks into.

When a part is inserted using the anchor method, the part anchors to the segment or object selected. This enables the parts to act together as one. For example, a louver is defined to use the anchor method of insertion. When you add a louver to your drawing, it is anchored to a segment. If the segment is moved, the louver moves with it.

When a part is inserted using the breaks into method, the part breaks into the segment or object selected. The part remains as an individual component. For example, when you add a valve to a segment, the segment is broken into 2 separate segments. You can move the valve along the run and the connecting segments are trimmed or stretched accordingly.

Parts that are inserted using the breaks into method are sometimes referred to as in-line parts.

To have the option of choosing an insertion method when you add the part to a drawing, specify both insertion methods when defining the part. To have the part behave similarly to a standard AutoCAD® block during insertion, specify no insertion method when defining the part.
View Blocks of a Block-Based Part

Each part size represents a real-world building systems part, such as a piece of equipment, that has different representations in different views. In the block-based building environment, 2-dimensional (2D) orthographic view blocks can be generated from the 3D model of the part size. Standard AutoCAD® blocks representing the plan, elevation, and model views of a part are grouped together to create an individual part size. Typically, each part size has 6 orthographic view blocks: 1 for each view direction (top, bottom, front, back, left, right). The following illustrations represent the 6 orthographic view blocks for an air handling unit.

**Top and bottom orthographic view blocks**

The insertion point, or base point, is used as a reference for positioning the block upon insertion. All view blocks share a common insertion point of 0,0,0 in the world coordinate system (WCS) that reflects the same point on the model block. The location of the insertion point directly affects the placement of the part size when you add it to your drawing.

The previous illustrations show the insertion point of the model view as the right corner of the bottom edge of the front side. The top and bottom views have an insertion point at the right corner of the front edge,
with the top-view insertion point offset by the height of the air handling unit. The front and back views have an insertion point at the right corner of the bottom edge, with the back-view insertion point offset by the width of the air handling unit. The left and right views have an insertion point at the bottom-front corner, with the left-view insertion point offset by the length of the air handling unit.

Once view blocks are generated, they are assigned to the appropriate display representation based on view direction, name, and view block. You can change the default assignments as needed. It is possible to assign the same view block to multiple view directions, such as front and back, depending on the part symmetry. The view block assignments are as follows:

<table>
<thead>
<tr>
<th>View Block</th>
<th>Display Representation</th>
<th>View Direction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top</td>
<td>1 Line</td>
<td>Top</td>
</tr>
<tr>
<td></td>
<td>2 Line</td>
<td>Top</td>
</tr>
<tr>
<td>Bottom</td>
<td>1 Line</td>
<td>Bottom</td>
</tr>
<tr>
<td></td>
<td>2 Line</td>
<td>Bottom</td>
</tr>
<tr>
<td>Front</td>
<td>1 Line</td>
<td>Front</td>
</tr>
<tr>
<td></td>
<td>2 Line</td>
<td>Front</td>
</tr>
<tr>
<td>Back</td>
<td>1 Line</td>
<td>Back</td>
</tr>
<tr>
<td></td>
<td>2 Line</td>
<td>Back</td>
</tr>
<tr>
<td>Left</td>
<td>1 Line</td>
<td>Left</td>
</tr>
<tr>
<td></td>
<td>2 Line</td>
<td>Left</td>
</tr>
<tr>
<td>Right</td>
<td>1 Line</td>
<td>Right</td>
</tr>
<tr>
<td></td>
<td>2 Line</td>
<td>Right</td>
</tr>
<tr>
<td>Model</td>
<td>1 Line</td>
<td>3D</td>
</tr>
<tr>
<td></td>
<td>2 Line</td>
<td>3D</td>
</tr>
<tr>
<td>Symbol</td>
<td>Schematic</td>
<td>All directions</td>
</tr>
</tbody>
</table>

**NOTE** The Plan display representation is a standard display representation and is not used by AutoCAD MEP. Standard display representations cannot be deleted.

**Preview Image of a Block-Based Part**

Every part family has a graphical preview image that helps during part selection. Using Content Builder, you assign a preview image to the part family. You can create an image before using Content Builder or have Content Builder generate a preview image based on the 3D model. The preview image should be a representative image of the part family, typically a shaded model view of one of the part sizes in the SW isometric view direction. The same preview image is used for all part sizes of a part family.
If you create your own image before using Content Builder, you should save the image as a 256-color bitmap (BMP) image, 200 x 200 pixels in size. When creating your own image, it is also helpful to show dimensions and other information about the part (such as the UCS icon to represent the insertion point or arrows to represent the flow direction) to assist in selecting the part size.

Connectors of a Block-Based Part

In the block-based building environment, you can add connectors to the part. Connectors enable the part to be connected intelligently to other building systems objects in your layout. You can define one or more connectors for the part.

IMPORTANT The number of connectors must be the same for all part sizes of a part family. When you add or delete a connector from a part family, all part sizes are updated.

When you add a connector, you specify a domain. The domain is a predefined list that specifies the connection rules for a part. The domain is defined once for the part family and remains the same for all part sizes. Connectors belonging to a particular domain can connect to other parts of the same domain, but they cannot connect to components in other domains. For example, an MvPart representing an air handling unit might have the following domains specified for its connections:

<table>
<thead>
<tr>
<th>Connector Name</th>
<th>Description</th>
<th>Domain</th>
</tr>
</thead>
<tbody>
<tr>
<td>inlet</td>
<td>air entering the unit</td>
<td>duct</td>
</tr>
<tr>
<td>outlet</td>
<td>air leaving the unit</td>
<td>duct</td>
</tr>
<tr>
<td>power</td>
<td>electrical connection to the motor</td>
<td>conduit</td>
</tr>
<tr>
<td>hot water in</td>
<td>hot water entering the heating coil</td>
<td>pipe</td>
</tr>
<tr>
<td>hot water out</td>
<td>hot water leaving the heating coil</td>
<td>pipe</td>
</tr>
<tr>
<td>cold water in</td>
<td>cold water entering the chilling coil</td>
<td>pipe</td>
</tr>
<tr>
<td>cold water out</td>
<td>cold water leaving the chilling coil</td>
<td>pipe</td>
</tr>
</tbody>
</table>
The connector shape is dependent on the specified shape of the part family; however, you can specify the type, size, and location for each connector based on the part size. The connector type is specified from a list of predefined types by domain and defines additional connection rules for a part. Examples of connector types include flange, slip-joint, and glued. The size is a user-defined value and varies by shape. For example, for a rectangular shape you can define the length and width, whereas for a round shape you can define the diameter. However, you can specify whether unsized connections are allowed when defining each connector.

The location of a connector can be specified by entering coordinates based on the 3D model of the part or by picking an insertion point. You must also specify a direction vector, or normal, that sets the direction of the connector when leaving the part, typically pointing in the direction away from the part size. If you assign the direction vector correctly, the Compass is aligned when you connect components to the part.

Recommended direction vectors are as follows:

- positive x direction: 1,0,0
- positive y direction: 0,1,0
- positive z direction: 0,0,1
- negative x direction: -1,0,0
- negative y direction: 0,-1,0
- negative z direction: 0,0,-1

For connector faces that are rotated on non-standard planes, specify the connection position using drawing assistance to snap to the center of the connector face, and specify the direction pointing away from the part. You can also specify a rotation; however, the rotation typically is specified by default upon insertion.

**Property Set Information for a Block-Based Part**

For a part family or an individual part size, you can add additional data properties that can be used to help identify parts during design development or to enhance property set information for scheduling. Using Content Builder, you add custom parameters that have user-defined attributes, including description, data storage, data type, units, and visibility. Custom data can be used for properties such as manufacturer, cost, or even paint color. You can also add parameters by selecting from a list of predefined parameters based on part type, such as material or gauge. You can store property values as a table or list of values, a constant value, or a calculated value. For more information, see Part Sizes on page 82.

You can assign added data parameters to a property set to enhance a schedule. To ensure that the parameter is recognized, you must use same name for both the data parameter and the property in the property set. You can add custom properties to any property set in a drawing. You can also create custom property sets based on new parts you create and the custom data parameters you add to the parts. For more information, see Collecting Project Data on page 587.
## Workflow for Creating a Block-Based Part

This workflow provides a road map for creating a block-based part using Content Builder.

**NOTE** For more information about part catalogs and their hierarchical structure, see How Catalog Parts are Stored and Referenced on page 80.

<table>
<thead>
<tr>
<th>Review the steps</th>
<th>View more information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a 3D model and schematic symbol of your part.</td>
<td><strong>BEST PRACTICE</strong> Do not save the model or symbol block drawings in the catalog folders of AutoCAD MEP. These are working files and should be saved in a separate, or temporary, folder.</td>
</tr>
<tr>
<td>Open the Parametric Building Environment to start building content.</td>
<td>You use the Content Builder in AutoCAD MEP to create a block-based part. See Starting Content Builder for Creating a Block-Based MvPart on page 757</td>
</tr>
<tr>
<td>Define the catalog information and behavior of your part.</td>
<td>You work in the block-based building environment of Content Builder to define part sizes based on the 3D model blocks you created previously. In this environment, the individual part sizes are associated with a part family in a catalog to build a library of parts. You specify a catalog, location, and part name. You also specify the type and behavior of the part family. All part sizes within a part family are defined as the same type and are placed in your drawing with the same behavior. See Defining the Part Behavior of a Block-Based MvPart on page 757.</td>
</tr>
<tr>
<td>Assign names and views to each part size.</td>
<td>You define part size names, generate 2-dimensional (2D) orthographic views from the 3D model, and assign them to the appropriate view direction of the part size. You also assign to each part size the 2D schematic symbol you created previously. See Assigning Part Size Names and Views of a Block-Based MvPart on page 759.</td>
</tr>
</tbody>
</table>
Review the steps

Create a preview image for your part.

View more information

You assign a preview image for the part family. You can attach a pre-defined bitmap (BMP) image or have an image generated from the 3D model block. All part sizes in the part family use the same preview image. The preview image helps to identify the part during part selection. See Generating a Preview Image of a Block-Based MvPart on page 760.

Add connectors to your part.

You add connectors so that the part can connect intelligently to other building systems objects in your layout. You assign connectors to the part family, and specify the shape and domain for each connector. Therefore, all part sizes have the same number of connectors predefined with a shape and domain. The shape and domain of a connector can be changed only for the entire part family; however, the size and location of connectors can change for each part size. See Adding Connectors to a Block-Based MvPart on page 760.

Add property set information to each part.

You can specify custom data that can be used as property set information for each part size. In turn, the property set information can be used to enhance schedules that you generate during design layout. See Adding Property Set Information to a Block-Based MvPart on page 763.

Creating Block-Based Parts Using Content Builder

You can create block-based MvParts, such as air handling units and other complex equipment, with Content Builder. The following sections contain step-by-step procedures to help you create an air handling unit MvPart using Content Builder. Each section represents a separate phase in the creation process; therefore, you should carefully step through the sections in the following order to avoid creating unusable parts.

IMPORTANT MvPart Builder, the content creation tool available in previous releases of AutoCAD MEP products, has been integrated into Content Builder. MvPart Builder now exists as the block-based building environment within Content Builder, which you use to create block-based MvParts.

Creating a 3D Model and Schematic Symbol for a Block-Based MvPart

Before starting Content Builder to create a block-based part, you must draw a 3D model on page 745 block for each new part size of the part family you want to create. Save the part size models as AutoCAD blocks. You should also create a 2D schematic symbol on page 746 block that represents the part family. All 3D model blocks for the individual part sizes and the schematic symbol for the part family must be saved in the same drawing file.
Creating a 3D Model for a Block-Based MvPart

Use this procedure to create a 3D model for a block-based MvPart. To support automatic generation of view blocks by Content Builder, the model block must be created using AutoCAD® solids in the standard AutoCAD world coordinate system (WCS).

**NOTE** To ensure correct hidden line display when placing the MvPart in a drawing, be sure to create a single body using AutoCAD solids for the model for the part.

1. Create the 3D model of the part size.
2. To add points on your model to help locate connectors, enter point, press ENTER and, using object snaps, select the center of a connector on the 3D model.
   
   Add AutoCAD point objects in the location of the center of all connections. This lets you use Node object snaps to select the connection points when assigning connectors.

3. Click View tab ➤ Coordinates panel ➤ World to set the user coordinate system (UCS) to World before making a block.
   
   For more information about coordinate systems, see “Control the Display of the User Coordinate System” in the AutoCAD Help.

4. Verify that the geometry is drawn on layer 0 and is assigned BYBLOCK for color and linetype, and BYLAYER for lineweight. This helps to ensure display control for the part size.

5. Click Insert tab ➤ Block panel ➤ Create Block .
   
   The Block Definition dialog is displayed.

6. In the Block Definition dialog, enter a name for the model block.
   
   Use a standard naming convention that represents the part family and part size as you save your model block. For example, a model block for a roof-mounted air handling unit for a commercial building, with an outlet size of 24 x 24 inches, could be named AHU Commercial Roof 24x24 model.

7. Under Objects, click the Select Objects option, and then select the geometry that will make up the model block.
   
   The dialog closes temporarily while you select objects for the block. Press ENTER when you finish selecting objects. The dialog reopens.

8. Under Objects, select one of the following options:
   
   - **Retain.** Keeps selected objects in the current drawing in their original state.
   
   - **Convert to Block.** Replaces selected objects with an instance of the block.
   
   - **Delete.** Removes selected objects after the block is defined.

9. Under Base Point, click the Pick Point option and select the model block insertion point.
The insertion point, or base point, is used as a reference for positioning the block. The location of the insertion point directly affects the placement of the part size when you add it to your drawing.

10 Under Description, enter text to help identify the view block for easy retrieval.

11 To attach a hyperlink to the part, click Hyperlink, select a file or web page, and click OK twice. The model block is saved in the current drawing.

RELATED For more information, see “Block Definition Dialog Box” in the AutoCAD Help.

Creating a 2D Schematic Symbol for a Block-Based MvPart

Use this procedure to create a 2D schematic symbol for a block-based MvPart. You can use any drawing command to make the geometry for the block. It is recommended that all geometry be created using base AutoCAD® entities such as lines, polylines, or circles.

WARNING Be careful when using AEC-based geometry, such as walls or ducts, to create your symbol. To avoid object enabler problems, be sure to explode the geometry to base AutoCAD entities before running Content Builder.

To ensure correct display control of your symbol when added to your drawings, draw all geometry for the symbol on layer 0. Assign BYBLOCK for color and linetype, and BYLAYER for lineweight.

1 Click View tab ➤ Coordinates panel ➤ World , and draw the symbol view of the part. The symbol block is used as a 2D representation of the part size; therefore, it is recommended that the symbol block be drawn to represent the 2D symbol of the modeled object in plan view.

2 Verify that the geometry for the symbol is drawn on layer 0 and is assigned BYBLOCK for color and linetype, and BYLAYER for lineweight. This helps to ensure display control for the part size.

3 Click Insert tab ➤ Block panel ➤ Create Block . The Block Definition dialog is displayed.

4 In the Block Definition dialog, enter a name for the symbol. Use a standard naming convention that represents the part family as you save the symbol as a block. For example, the symbol block for a roof-mounted air handling unit for a commercial building, with an outlet size of 24 x 24 inches, could be named AHU Commercial Roof 24x24 symbol.
Starting Content Builder for Creating a Block-Based MvPart

Use this procedure to start Content Builder and open the block-based building environment.

1. Open the drawing file that contains the 3D model block(s) of the part you want to create.
   Each part size requires a unique 3D model block. You can have one or more model blocks in a single drawing file that represent each part size in a part family.

2. Click Manage tab ➤ MEP Content panel ➤ Content Builder.
   The Getting Started - Catalog Screen dialog is displayed.


4. In the tree view, select a chapter to add the new MvPart to, and click.
   The New Part dialog is displayed.

5. Enter a name and description for the part family, and click OK.
   By default, the description is the same as the name until you change it.
   The block-based building environment is opened. For more information, see Approaches to Creating Parts on page 643.

Defining the Part Behavior of a Block-Based MvPart

Use this procedure to define the part behavior of a block-based MvPart by specifying the type, subtype, layer key, and method of insertion for all part sizes of the MvPart. For more information, see Behavior of a Block-Based Part on page 747.

1. Select a type from the list.
Type refers to the main category for the part family; it defines unique characteristics and behaviors for part sizes, such as the ability to assign flow annotation to an HVAC part size. Types are predefined by the application and cannot be modified; therefore, select a type that is similar to the part sizes.

2 To define a layer key for the new part sizes, click next to Layer Key.

3 In the Select Layer Key dialog, select a layer key and click OK.

   The layer key list reflects the set of layer keys currently assigned in your drawing, based on the previously selected layer standard and layer key style. To ensure the best possible layering of part sizes, select a layer key that matches the part type.

4 For Subtype, select a subtype from the list, or enter a new subtype.

   Subtype is the subcategory for the part family; it is useful for grouping similar parts. The subtype can be used as a filter method for part selection in the MvPart Add command. Therefore, you should select or specify a descriptive subtype name for easy identification.

5 Select one, both, or none of the following options:
   - **This part family automatically BREAKS INTO existing runs.** A part size breaks into a run when you add it to your layout. The components remain as individual components. For example, you can move the value without moving either of the connecting pipe segments.

     **Adding a valve to a pipe segment**

     ![Image of a valve being added to a pipe segment]

   - **This part family automatically ANCHORS to existing runs.** A part size anchors to a run when you add it to your layout. The components act together as one when anchored. For example, if you move the duct run, the louver moves with it.

     **Adding a louver to a duct segment**

     ![Image of a louver being added to a duct segment]

6 Click Next.

   If Next is unavailable (shaded), information is missing on this page. Verify that you have completed steps 1 through 5.
Assigning Part Size Names and Views of a Block-Based MvPart

Use this procedure to add part sizes and assign view blocks on page 749 to the individual part sizes for the MvPart. You can specify a unique name for each part size. The part size name typically reflects the actual size of the part, such as width and height dimensions or the total cubic-foot-per-minute (cfm) output. It is used for part selection in the MvPart Add dialog. The part size name is also used in the part catalogs and appears as the object name when using tooltips. Therefore, you should specify a descriptive part size name for easy identification.

View blocks are generated and assigned by default for part sizes that are assigned a 3D model block whose name has a suffix of “model”; for example, AHU Commercial Roof 24x24 model. Unassigned view blocks display as empty fields. View blocks that display in red have been assigned a name based on the 3D model block; however, they are missing a defined block. You can assign a view block or generate the missing view blocks using Content Builder. Content Builder generates the 6 standard AutoCAD® view blocks (top, bottom, left, right, front, and back) from the 3D model block. It is possible to assign the same view block to multiple view directions, such as front and back, depending on part symmetry. You also assign to the part family the 2D symbol block you created previously to be used to generate a 3D symbol for each part size. The views determine how the individual part size is displayed in your drawing.

NOTE View blocks can be generated for multiple part sizes at one time. You can add multiple part sizes and then generate the missing view blocks for all part sizes.

1 To add a new part size, select a 3D model block and click .
   The list of 3D model blocks reflects the blocks in the active drawing.
   A new part size is added to the part family, and a new row appears in the table. View blocks are assigned by default when the 3D model block name has a suffix of “model.” Assigned view blocks with associated blocks display in black. Any view block assigned a name based on the 3D model block but missing a block displays in red. All unassigned view blocks display as empty fields.

2 Select a 2D symbol block from the list of blocks in the active drawing to be used to generate a 3D symbol block for each part size.
   The 3D symbol blocks are assigned to the schematic views for each part size.

   NOTE A schematic symbol is not required. If you do not want to assign a schematic symbol, select None.

3 To create the missing view blocks for those block names that display in red, click Generate Blocks.
   The Views dialog is displayed.
   View blocks are generated and named based on the associated 3D model block. View block assignments are defined based on the standard display representations and view directions; however, you can change them as needed.

   NOTE The symbol block is used in Isometric mode and is displayed as a 3D bounding box of the model block with 2D symbology to represent the part itself.

4 To make changes to a view block assignment for a part size, select a part size name, select a view number (#) under Views, and change the Display Representation and View Direction options as necessary.
   Repeat for each view block assignment you want to change.

5 Click OK.
   The new part size is updated with the generated view blocks.
6 To delete a part size, select the Part Size Name and click \( \text{delete} \).
The selected part size is deleted from the part family, and the associated row is removed from the table.

7 Click Next.
If Next is unavailable (shaded), information is missing on this page. Verify that each part size has a defined name and that all view blocks display in black.

**Generating a Preview Image of a Block-Based MvPart**

Use this procedure to generate or assign a preview image to the part family of the MvPart. You can assign an existing bitmap image or have Content Builder generate one based on the 3D model of the specified part size. The same preview image is used for all part sizes of an MvPart. For more information, see Preview Image of a Block-Based Part on page 750.

1 To assign an existing image, click Select a previously drawn image, and click \( \text{select} \).
The Select Image File dialog is displayed.

2 Browse to select a bitmap image.
The specified path and name of the image are displayed. The image itself is displayed in the image window.

3 To generate an image, click Generate an image based on a model block from the SW Isometric View.

4 Select a model block from the list.

5 Click Generate.
A preview image is generated from the model block and assigned to the part family. The image is a shaded, SW isometric view of the model block. However, no text or dimensions are added. The image is displayed in the image window.

6 Click Next.
If Next is unavailable (shaded), information is missing on this page. Verify that you have selected a preview image for the part family.

**Adding Connectors to a Block-Based MvPart**

Use this procedure to add connectors to a block-based MvPart. Defining connectors allows the part size to be connected intelligently to other building systems objects in a drawing. You can define one or more connectors for each part size of an MvPart. You can assign each connector unique part properties, such as domain, system type, shape, and size. Generally, a part has at least one connector. However, you can create a part that has no connectors. For more information, see Connectors of a Block-Based Part on page 751.

**IMPORTANT** The size and shape of every connector for a part size can be different. However, the number of connectors must be the same for all part sizes of an MvPart.

1 To add a connector, from the tree view of the part family and sizes, right-click the part family, and select the type of connector.
Shows example of context menu for part family

The Part Family Connector Properties dialog is displayed.

**Part Family Connector Properties dialog**

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connection Name</td>
<td></td>
</tr>
<tr>
<td>Flow Direction</td>
<td>Bidirectional</td>
</tr>
<tr>
<td>Connection Domain</td>
<td>Duct</td>
</tr>
<tr>
<td>Connection Shape</td>
<td>Rectangular</td>
</tr>
<tr>
<td>Unsized</td>
<td>False</td>
</tr>
</tbody>
</table>

2 Specify a value for each of the properties and click OK:

<table>
<thead>
<tr>
<th>To specify the…</th>
<th>then click the value cell and…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>enter a descriptive name.</td>
</tr>
<tr>
<td>Connection Shape</td>
<td>select a shape from the list. The available shapes are dependent on the domain of the connector.</td>
</tr>
<tr>
<td>additional properties, such as Flow Direction</td>
<td>select from the list. Additional properties that are available are dependent on the domain of the connector.</td>
</tr>
<tr>
<td>Unsized</td>
<td>select True or False. Selecting True allows the connector to be unsized and valid connections to be made with unsized segments.</td>
</tr>
</tbody>
</table>

These properties are assigned to the connector for all part sizes.

**NOTE** The connector domain is based on the type of connector selected and cannot be changed in the properties dialog. Also, the Unsized value cannot be changed once the connector is defined.

3 To edit connector properties, right-click a connector, and click Edit Connector. A property palette is displayed.
Example of connector property palette

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connector Name</td>
<td>Outlet</td>
</tr>
<tr>
<td>Flow Direction</td>
<td>Bidirectional</td>
</tr>
<tr>
<td>Connection Name</td>
<td>Outlet</td>
</tr>
<tr>
<td>Connection Shape</td>
<td>Rectangular</td>
</tr>
<tr>
<td>Connection Position</td>
<td>0,0,0</td>
</tr>
<tr>
<td>Connection Normal</td>
<td>0,0,1</td>
</tr>
<tr>
<td>Connection Rotation</td>
<td>0</td>
</tr>
<tr>
<td>Rectangular Connectors</td>
<td>15</td>
</tr>
</tbody>
</table>

4 Specify the connector properties:

<table>
<thead>
<tr>
<th>To specify the…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>position of the connector</td>
<td>enter p (position), or click for Connection Position, and select a point on the model. The connection position is updated in the palette. If you added object point to the model at the locations of the connectors, use the Node object snap to snap to the location.</td>
</tr>
<tr>
<td>direction to draw connecting components by a single point</td>
<td>enter n (normal), or click for Connection Normal, drag the cursor in the correct direction, and select a point. The connection normal is updated in the palette. To ensure that components are connected perpendicularly to the part, use AutoCAD’s Ortho mode to restrict the cursor when selecting the direction.</td>
</tr>
<tr>
<td>direction to draw connecting components by 2 points</td>
<td>enter n (normal), select the first point, and then select the second point. The connection normal is updated in the palette.</td>
</tr>
<tr>
<td>type of connection</td>
<td>in the property palette, select a type for Connection Type.</td>
</tr>
<tr>
<td>rotation of the connector</td>
<td>in the property palette, enter a number of degrees for Rotation. Typically, the rotation value is 0 (zero).</td>
</tr>
<tr>
<td>size of the connector</td>
<td>in the property palette, enter a number for the size properties. The size properties vary depending on the shape of the connector.</td>
</tr>
</tbody>
</table>

5 Click OK, and then click Next.
Adding Property Set Information to a Block-Based MvPart

Use this procedure to add property set information to a block-based MvPart. Property set information is optional. Therefore, you can click Finish to complete the creation of your part without adding property set information. For more information, see Property Set Information for a Block-Based Part on page 752.

1 In the MvPart Builder dialog, select the part family or an individual part size, and click Edit Properties.

The Property Editor dialog is displayed. Parameters for CEL (connection engagement length) and AoD (angle of deflection) appear in the Block-Based Parameter Configuration, allowing a change to the Data Storage and Visibility values under Attribute.

NOTE CEL and AoD only appear for pipe connectors, not for connectors in other domains.

Property Editor dialog

2 To add custom data, on the toolbar in the Property Editor dialog, select Parameter Configuration from the list, and click + (New).

The New Parameter dialog is displayed.

3 Select a new parameter, or select Custom Data 1 and enter a name, and then click OK.

A new parameter column is added as the last column. You may need to scroll over to view the added column.

4 To specify the parameter attributes, click the appropriate cell, and select or enter a new value.

You can change the data storage, data type, units, visibility, and description. For more information, see Part Sizes on page 82.

NOTE The default data storage type for the PrtSN (Part Size Name) attribute is Table; however, you can change the data storage type to Calculation. Defining the PrtSN attribute as a calculated value enables you to define the name of each part size based on the values of other attributes, such as height and width, and provides additional options in the Blocks & Names section of the block-based building environment.

5 To add a list of values, do the following:

- Select List for Data Storage, and then select Values on the toolbar.

- Click the custom data value cell, and click ➕ on the toolbar. The Edit Values dialog is displayed.

- Click Add and enter a new value.
When you finish adding values, click OK.

6 To add a constant value, do the following:
   ■ Select Constant for Data Storage, and then select Values on the toolbar.
   ■ Double-click the custom data value cell, and enter a value.

7 To add a calculated value, do the following:
   ■ Select Calculation for Data Storage, and then select Calculations on the toolbar.
   ■ Double-click the custom data value cell and, in Calculation Assistant, enter an equation to be used to calculate the value.

8 To add a table of values, do the following:
   ■ Select Table for Data Storage, and then select Values on the toolbar.
   ■ Double-click the custom data cell value for each part size row, and enter a unique table value.

9 When you are finished editing properties of the part sizes, click OK.

   NOTE You can also edit the values of custom data attributes on the Properties page of MvPart Builder. Select a part size in the tree view, click Value and enter a new attribute value.

10 Click Finish.
    The part is saved and added to the catalog in the specified location.

Modifying Block-Based Parts Using Content Builder

You can use Content Builder to modify an existing block-based part. You can modify the entire part family or an individual part size. Once the part has been saved to a catalog, any modifications you make using Content Builder are made directly to the source files stored in the catalog. You can modify the 3D model block and/or symbol; you can also modify the model and schematic symbol of the part size. You can redefine a part size based on a new 3D model block and reassign the schematic symbol of a part size based on a new symbol block.

   NOTE When you modify existing part sizes in a part catalog, your changes apply only to part sizes that you add to a drawing after the part catalog is modified. Part sizes existing in a drawing are not affected. You should use Content Builder to modify individual part sizes wherever possible.

Starting Content Builder for Modifying a Block-Based Part

Use this procedure to start Content Builder and open the block-based building environment for modifying a block-based part.

   IMPORTANT When adding new part sizes to an existing part family, you must add the new 3D model blocks to the existing DWG file for the part family prior to starting Content Builder. The DWG files for a catalog part are stored in the \ProgramData\Autodesk\MEP 2010\enu\Tool Catalogs folder, in the appropriate part catalog subfolder. For example, to add a new part size to the Gas Fired Roof Mounted AC Unit, add the new 3D model block to \ProgramData\Autodesk\MEP 2010\enu\MEPContent\USI\MvParts\Mechanical\Roof Mounted AC Units.

   1 Click Manage tab ➤ MEP Content panel ➤ Content Builder .
       The Getting Started - Catalog Screen dialog is displayed.
2 In the tree view, navigate to and select a block-based part.

3 To add a new part size to an existing part, click .

The block-based building environment is opened and the MvPart Builder (Add Part Size) dialog is opened. The process is the same as that of creating a new part.

IMPORTANT The 3D model blocks created for the new part sizes must exist in the part family DWG file stored in the catalog.

4 To modify a part, click .

The block-based building environment is opened and the MvPart Builder (Modify Part Size) dialog is displayed. This dialog has tabs that enable you to change only what you need to change, in any order.

5 To delete a part, click .

The selected part family is deleted from the part catalog, including all associated definition files (XML file, DWG file, and BMP file).

Modifying a Block-Based Part

As your design develops and parts change, you can add new part sizes or modify existing part sizes using Content Builder. When you add a new part size, you are guided through the process step by step. When you modify an existing part size a tabbed dialog enables you to change only what you need to change. For more information, see Approaches to Creating Parts on page 643.

For each part size, you can change the 3D model block, schematic symbol, part behavior, view blocks, preview image, connectors, and property set information. You can use the same procedures that guide you through creating a block-based part to modify it. This section outlines how you can modify a block-based part and provides references to related procedures that you can use.

Modifying the 3D Model Block and Schematic Symbol

You can change the 3D model block of an individual part size. You can edit the existing 3D model block or create a new 3D model block for one or more part sizes. Changing the 3D model block requires that you regenerate the view blocks for the part size to ensure the correct display of the part in a drawing. For more information, see Creating a 3D Model for a Block-Based MvPart on page 755.

You can also change the schematic symbol that is assigned to the part size or attach a new schematic symbol. When you change the schematic symbol, you are changing it for all part sizes in the part family. For more information, see Creating a 2D Schematic Symbol for a Block-Based MvPart on page 756.

NOTE All changes must be made in the part family DWG file stored in the part catalog prior to starting Content Builder. When modifying an existing 3D model block, modify the block stored in the part family DWG file. When replacing an existing 3D model block with a new 3D model block, delete the existing block and then add the new block in the part family DWG file.

Modifying the Part Behavior

You can change the part behavior that defines how the part is added to a drawing, including type, subtype, layer key, and insertion method. You can make changes to a single part size or to multiple part sizes. For more information, see Defining the Part Behavior of a Block-Based MvPart on page 757.

NOTE Avoid making changes in the Behavior tab or page in the parametric part wizard unless you want to change the behavior of the part family. Any changes you make to the part family affect every part size for that part.
Modifying the Part Size Name and View Blocks

You can change the part size name and view blocks that are used to display a part size in a drawing. When you change the 3D model block of a part size, you must regenerate the view blocks based on the new model block to ensure correct display. It is possible to assign the same view block to multiple view directions, such as front and back, depending on the part symmetry. You can also manually create individual view blocks for a part size and attach them accordingly. For more information, see Assigning Part Size Names and Views of a Block-Based MvPart on page 759.

Modifying the Preview Image

You can change the preview image of the part size. In doing so, you change the preview image for all part sizes in the selected part family. You can regenerate a preview image based on a new 3D model block, or attach a predefined image. For more information, see Generating a Preview Image of a Block-Based MvPart on page 760.

Modifying the Connectors

You can add, delete, and edit the connectors of a part size. You can change the size, type, and location of the individual part size connector; however, the shape and domain are determined by the associated connector defined for the part family. When you delete a connector, you are deleting the connector for all part sizes in the part family. When you add a connector, you are adding a connector to all part sizes in the part family. For more information, see Adding Connectors to a Block-Based MvPart on page 760.

IMPORTANT The size and shape of every connector for a part size can be different. However, the number of connectors must be the same for all part sizes of a part.

Modifying the Property Information

You can change the property information of a part size. You can add, delete, and edit custom properties for a part size. When you add a custom property, you are adding a custom property to every part size in the part family. You can modify custom property values as needed to enhance schedule data for the parts in your drawing. For more information, see Adding Property Set Information to a Block-Based MvPart on page 763.

Working with Custom Parameter Groups

Custom parameters store additional, user-defined information about a part, such as manufacturer or product information.

If you have a set of custom parameters that are common to multiple parts, you can create the custom parameters for one part, save the parameters as a group in a Microsoft® Excel® file, and then retrieve the group whenever you need to add the same parameters to additional parts.

Saving Custom Parameters in Groups

When you save a group of custom parameters in a Microsoft® Excel® (XLS) file, you can save parameter attributes as well as parameter values.

NOTE Once you become familiar with how this feature saves the customer parameter data in an XLS file, you can also create the files manually by copying the format. If you do so, make sure to use only the first worksheet in the XLS file. When you add saved parameters to parts, the software reads only the data on the first worksheet.

To save a set of custom parameters

1 In Content Builder, open the part that contains the custom parameters that you want to save.
For information on adding custom data to parts using Catalog Editor, see Adding Custom Data to Parts in Catalog Editor on page 778. For information on adding custom data to parts using Content Builder, see Sizes of a Parametric Part on page 667 or Adding Property Set Information to a Block-Based MvPart on page 763.

2 Depending on the type of part, do one of the following:
   ■ If the part is parametric, in the part browser, right-click Size Parameters, and click Edit Configuration. Then, in the Size Parameters dialog, click (Save Custom Parameter Group).
   ■ If the part is block-based, in the MvPart Builder dialog, click the Properties tab, and click Edit Properties. Then, in the Property Editor dialog, click (Save Custom Parameter Group).

The Save a Custom Parameter Group dialog is displayed. It lists all of the custom parameters that have been added to the part that is currently open.

Save a Custom Parameter Group dialog

3 Specify the parameters to save as a group:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>save a custom parameter</td>
<td>Select Save in Group for that parameter. You can also click Select All to save all of the custom parameters in the group.</td>
</tr>
<tr>
<td>save the current value for a custom parameter</td>
<td>Select Yes for Save Value(s) for that parameter. This saves the value for the part that is currently open.</td>
</tr>
<tr>
<td>not save the value for a custom parameter</td>
<td>Select No for Save Value(s) for that parameter.</td>
</tr>
</tbody>
</table>

4 For File name, specify the file name and location of the XLS file in which to save the group of custom parameters.

NOTE The file is saved in a default MEP Parameter Groups subfolder. However, you can optionally browse to a different folder location, such as a project-specific folder.

If you specify the file name and location of an existing file, the custom parameters in the file are overwritten with your current selections.
5 Click OK.

Adding Groups of Saved Custom Parameters to Parts

1 Create or open the part to which you want to add a group of saved custom parameters. For help with this step, see Working with Parametric Parts on page 649 or Working with Block-Based Parts on page 743.

2 Depending on the type of part, do one of the following:
   ■ If the part is parametric, in the part browser, right-click Size Parameters, and click Edit Configuration. Then, in the Size Parameters dialog, click ![Insert Custom Parameter Group](Insert Custom Parameter Group).
   ■ If the part is block-based, in the MvPart Builder dialog, click the Properties tab, and click Edit Properties. Then, in the Property Editor dialog, click ![Insert Custom Parameter Group](Insert Custom Parameter Group).

3 In the Open dialog, select the Microsoft® Excel® (XLS) file that contains the group of custom parameters.

4 Click Open.

   The software adds the custom parameters in the selected file to the part. If the part already has a parameter with the same name as a parameter stored in the file, the parameter in the file is not added to the part.

   If the file contains saved values for the parameters, the values are also added to the part.

Testing Parts Created with Content Builder

It is important to test each part size before using it in your drawings. You should verify the insertion point, all view representations, and each connector. If testing produces undesirable results, you should modify and retest the appropriate part sizes. Although testing can be a tedious process, following the guidelines presented here will verify that your part sizes work correctly for AutoCAD MEP.

Testing the Display Representations of a Part

Depending on whether you test part sizes in a drawing started from scratch or from a template, you verify accurate view representations in 1 of 2 ways: by scrolling through the various display configurations in a viewport, or by scrolling through the various layout tabs in a template. You should see representations on the Model tab similar to the following as you change display configurations for the viewport.

```
TIP To quickly change display configurations for a viewport, select a display configuration from the list in the bottom-right corner below the drawing area.
```
Testing the Connectors of a Part

Testing every connector is necessary to ensure that the part size can connect intelligently to other building systems objects. Connectors are shown as graphical objects representing the size, shape, and location of connection points on a part size in your drawing. If the connection positions were assigned correctly, they should match the model block geometry of the part size. If the connection positions were not assigned correctly, the connectors may appear as graphical objects floating in space. To verify the connection position of each connector, snap to the correct location and connect a segment. A valid connection should be made and you should be able to continue to draft the run.

It is also important to test the connection direction vectors. To do this, you connect a valid building systems object to every part connector for each part size and draft a run. Verify that the default direction of the Compass lets you lay out the building systems objects in the correct direction away from the part size.

Testing the View Block Orientations of a Part

Once each view block for a part size has been assigned, you should verify that the part display is correct for each view. When view blocks are generated, you add your part to a drawing based on the AutoCAD MEP template, and scroll through the layout tabs to verify that the display of the part is correct. However, if you created the view blocks from scratch and saved them as individual AutoCAD® blocks, you use a different method to verify the display of the view blocks. Using the SW Isometric view, insert each view block at an insertion point of 0,0,0 in the WCS. Each view block should align to the respective side of the model block as follows:

<table>
<thead>
<tr>
<th>The...</th>
<th>aligns with the...</th>
<th>in the...</th>
</tr>
</thead>
<tbody>
<tr>
<td>top view block</td>
<td>top side of the model block</td>
<td>XY plane.</td>
</tr>
<tr>
<td>bottom view block</td>
<td>bottom side of the model block</td>
<td>XY plane.</td>
</tr>
<tr>
<td>front view block</td>
<td>front side of the model block</td>
<td>XZ plane.</td>
</tr>
<tr>
<td>back view block</td>
<td>back side of the model block</td>
<td>XZ plane.</td>
</tr>
<tr>
<td>left view block</td>
<td>left side of the model block</td>
<td>YZ plane.</td>
</tr>
<tr>
<td>right view block</td>
<td>right side of the model block</td>
<td>YZ plane.</td>
</tr>
</tbody>
</table>
Customizing Catalogs

The default part catalogs provided with AutoCAD MEP include an array of common industry parts. The Catalog Editor is a standalone utility with Windows® Explorer-like navigation that provides a central location for viewing and working with the default part catalogs, and creating new ones. Use the Catalog Editor to:

- Create a new catalog from an existing catalog
- Create a new catalog from scratch
- Reorganize a part catalog by renaming chapters and moving parts
- Browse available parts
- Create a new part from an existing part
- Add part sizes
- Add custom part properties
- Copy and paste, or drag and drop, part data between catalogs
- Edit part data in Microsoft® Excel

The Catalog Editor provides the flexibility to create and modify part catalogs to meet your company or project requirements. Because the Catalog Editor is a standalone utility, you can access it from inside or outside AutoCAD MEP.

NOTE To create new parts from scratch, use Content Builder.

About Catalog Editor

The Catalog Editor user interface is divided into 2 resizable panes—a navigation pane and a details pane—and has a menu bar, a toolbar, and a preview image window.
Example of Catalog Editor

Navigation Pane

The navigation pane on the left organizes the open catalog into a structured tree view that you can navigate by expanding and collapsing the different chapters in the tree.

You can add, delete, copy, paste, and save part data in the tree view. As you select items in the tree view, the software updates the details pane on the right accordingly. For more information about the structure of a part catalog, see How Catalog Parts are Stored and Referenced on page 80.

Details Pane

The right pane of Catalog Editor displays a table view of the part data for the part selected in the navigation pane. The table view displays the data in its most primitive, or “uncompiled,” form. Each column represents a specific parameter that is used to define the part. Each row represents an attribute description or unique value of the parameter. For clarity, different background colors differentiate the various types of part data.

Parameter attributes determine how the parameter values are used in defining the part. For example, parameter attributes define the type of parameter and the dimensional units of the parameter’s values.

Preview Image Window

The preview image window in the lower-left corner of the Catalog Editor displays the part as a rendered 3-dimensional (3D) image. Parameters that define the part are referenced as dimensions.

Menu Bar and Toolbar

The menu bar and toolbar at the top of the Catalog Editor provide quick access to commands. If you position your pointing device over a toolbar icon, the software displays a tooltip that describes the command associated with the icon.
## Key Catalog Terms

Use this table to become familiar with the key terms related to part catalogs and the Catalog Editor.

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>APC file</td>
<td>Defines an Autodesk product catalog used in AutoCAD MEP, along with a folder hierarchy that includes each part’s definition files (DWG, BMP, and XML files).</td>
</tr>
<tr>
<td>BMP file</td>
<td>A part definition file that stores the preview bitmap image of the part; used to help identify the part during part selection.</td>
</tr>
<tr>
<td>catalog part</td>
<td>A part defined by the associated files (DWG, XML, and BMP files) that store the part data.</td>
</tr>
<tr>
<td>chapter</td>
<td>A group of related chapters or part families that makes up a part catalog structure.</td>
</tr>
<tr>
<td>common parameter</td>
<td>A specific type of part data that is defined once in a part family and shared by all part sizes, such as domain, type, and subtype.</td>
</tr>
<tr>
<td>custom data</td>
<td>A unique, user-defined part parameter. Custom data can be constant for a part family or different for each part size.</td>
</tr>
<tr>
<td>DWG file</td>
<td>A part definition file that stores model geometry, which defines the appearance and enables the display of the part.</td>
</tr>
<tr>
<td>parameter</td>
<td>A specific type of part data that can have one or more values.</td>
</tr>
<tr>
<td>part catalog</td>
<td>A collection of parts typically organized into chapter folders that group related parts. The hierarchy of a part catalog is user-definable.</td>
</tr>
<tr>
<td>part data</td>
<td>A collection of parameters whose values define a part; part data is stored in an XML file.</td>
</tr>
<tr>
<td>part family</td>
<td>A collection of related part sizes.</td>
</tr>
<tr>
<td>part size table</td>
<td>The part data for the XML file that is compiled into a single table of part sizes, enabling easy navigation of part sizes during part selection.</td>
</tr>
<tr>
<td>part size</td>
<td>A unique part defined by a set of specific parameters, or part data.</td>
</tr>
<tr>
<td>part</td>
<td>1. A part family when referenced in Catalog Editor or with regard to content. 2. A specific part size when referenced in AutoCAD MEP.</td>
</tr>
<tr>
<td>size parameter</td>
<td>A specific type of part data used to define one or more part sizes, depending on how the size parameter is stored in the part family.</td>
</tr>
<tr>
<td>storage type</td>
<td>A collection of related parameters with unique characteristics that determine how the part data defines the part. There are 4 storage types: basic table, constant lists, constants, and calculations.</td>
</tr>
<tr>
<td>XML file</td>
<td>A part definition file that stores the data for a part family, including the common and size parameters. The part data is stored using extensible mark-up language (XML).</td>
</tr>
</tbody>
</table>
Opening Catalog Editor

You can open the Catalog Editor from inside or outside of AutoCAD MEP.

RELATED For more information on Catalog Editor, see About Catalog Editor on page 771.

To open the Catalog Editor from inside AutoCAD MEP

➤ Click Manage tab ➤ MEP Content panel ➤ Catalog Editor .

To open the Catalog Editor outside of AutoCAD MEP

1 On your desktop, open My Computer.
2 Navigate to the \Program Files\AutoCAD MEP 2010 folder.
3 Double-click AecbCatalogEditor.exe.

NOTE To close Catalog Editor, click File menu ➤ Exit, or click the “X” on the right side of the title bar.

Opening a Part Catalog in Catalog Editor

1 Open the Catalog Editor.
2 In the Catalog Editor, click . Alternatively, click File menu ➤ Open.
3 Navigate to the \ProgramData\Autodesk\MEP 2010\Tool Catalogs folder, double-click a catalog folder, and then double-click the Autodesk product catalog (APC) file to open it.

Customizing Catalogs in Catalog Editor

Catalog Editor enables you to work with part data in a spreadsheet fashion within the tree view and the table view.

IMPORTANT If you make changes and then change your mind, you can click Edit menu ➤ Undo to remove your changes and restore the original data.

You can access commands by right-clicking catalogs, chapters, and part families in the tree view; or rows, columns, and cells in the table view. You can also access commands from the Edit menu, and you can cut, copy, and paste using the standard keyboard shortcuts:

- CTRL+X for cut
- CTRL+C for copy
- CTRL+V for paste

In addition, you can drag and drop to move or copy a chapter or part family between chapters or catalogs.

NOTE You can copy and paste, or drag and drop, chapters or part families between catalogs when multiple sessions of Catalog Editor are open.

Working with Part Data in the Tree View

When you work with part data in the tree view of Catalog Editor, the functionality available to you depends upon the type of part data that you select.
You can cut, copy, paste, rename, and move chapters and part families. You can also insert new chapters, and copy and paste part data between catalogs. When you copy and paste a chapter, Catalog Editor copies and pastes the entire chapter including its part families. You can rename the chapter or part family when you paste it into another catalog or accept the predefined (default) name.

**Catalog**

When selecting a part catalog in the tree view, you can:

- Insert a chapter.
- Rename the part catalog description.

**Chapter**

When selecting a chapter in the tree view, you can:

- Insert a chapter.
- Rename the chapter.
- Cut, copy, and paste the chapter.
- Delete the chapter.

**Part Family**

When selecting a part family in the tree view, you can:

- Cut, copy, and paste the part family.
- Rename the part family.
- Delete the part family.

**Part Sizes**

When selecting a part type in the tree view, you can edit part size values displayed in the Content tab on the right pane:

- Cut, copy, and paste part size values.
- Edit part size values.
- Add and delete part size values.

**Storage Type**

When selecting a storage type (Basic Table, Constant Lists, Constants, Calculations) in the tree view, you can:

- Insert a custom data column.
- Insert a value row for a component part in a basic table.

---

**Working with Part Data in the Table View**

When you work with part data in the table view of Catalog Editor, the functionality available to you depends on the part type and storage type in which the part data is stored.
You can cut, copy, and paste part data between parameters and insert and delete parameter columns. You can also edit and delete parameter value rows and edit a limited number of parameter attribute cells. For more information about storage types, see Part Sizes on page 82.

**Basic Table**

For part data stored in a basic table, you can:

- Edit the name, description, units, data type, and visible attribute cells for custom data columns.
- Copy, paste, and edit value cells.
- Copy, paste, and delete value rows.
- Insert value rows from scratch and from copied data.
- Insert custom data columns from scratch and from copied data.
- Cut, copy, and delete custom data columns.

**Constant Lists**

For part data stored in constant lists, you can:

- Edit the name, description, units, data type, and visible attribute cells for custom data columns.
- Copy, paste, and edit value cells.
- Insert custom data columns from scratch and from copied data.
- Cut, copy, and delete custom data columns.

**Constants**

For part data stored as constants, you can:

- Edit the name, description, units, data type, and visible attribute cells for custom data columns.
- Copy, paste, and edit value cells.
- Copy the value row.
- Insert custom data columns from scratch and from copied data.
- Cut, copy, and delete custom data columns.

**Calculations**

For part data stored as calculations, you can:

- Edit the name, description, units, data type, and visible attribute cells for custom data columns.
- Copy, paste, and edit value cells.
- Copy the value row.
- Insert custom data columns from scratch and from copied data.
- Cut, copy, and delete custom data columns.
IMPORTANT Be careful when working with calculation formulas. Valid formulas depend on correct formula syntax and the existence of parameters used in the formula. Formulas are calculated in the order the parameters are presented in the table view from left to right. This enables the resulting value of a calculation to be used in a formula calculated later.

Creating Parts in Catalog Editor

You can create a new part using Catalog Editor only by copying an existing part and modifying its parameters. To create a new part from scratch, use Content Builder.

To create a part in Catalog Editor

1. If necessary, open the Catalog Editor, and then open the part catalog.
2. In the tree view, navigate to and select a part family name that is similar to the part you want to create, right-click, and click Copy.
3. Select the chapter in which to add the new part, right-click, and click Paste.
   The software adds a copy of the selected part family.

   NOTE You can also drag and drop the part between chapters.

4. To rename the new part family, right-click the copied part family name, click Rename, enter a name and a unique text description for that name, and press Enter.
5. In the table view, add or modify size parameter values, or add custom data, if needed. For more information, see Adding Part Sizes in Catalog Editor on page 777 or Adding Custom Data to Parts in Catalog Editor on page 778.

6. In the Catalog Editor, click . Alternatively, click File menu ➤ Save.
   The software validates the new part and regenerates the catalog.

   NOTE To access the new part during part selection, be sure to load the modified part catalog in your drawing. For more information, see Specifying Part Catalogs and Style-Based Content Locations on page 70.

Adding Part Sizes in Catalog Editor

Use this procedure to add a size to a component, such as a duct, pipe, cable tray, or conduit segment. You can add size parameter values to a basic table or constant lists. For more information about storage types, see Part Sizes on page 82.

IMPORTANT To add a size to an MvPart, such as equipment, use the Parametric Part Wizard or Content Builder. You can also use Content Builder to add a size to a fitting. For more information, see Customizing Catalog-Based Content on page 641.

To add a size to a part in Catalog Editor

1. If necessary, open the Catalog Editor, and then open the part catalog.
2. In the tree view, navigate to the non-MvPart part you want to edit, and expand the part family to show the storage types.
3. Select the storage type of the part parameter to which to add a size.
4 In the table view, add a new parameter value:

<table>
<thead>
<tr>
<th>If you want to add a size to a...</th>
<th>then right-click a...</th>
</tr>
</thead>
<tbody>
<tr>
<td>basic table parameter</td>
<td>value row, and click Insert ➤ Row. A new value row is added above the selected value row.</td>
</tr>
<tr>
<td>constant lists parameter</td>
<td>value cell in the desired parameter column, and click Insert ➤ Cell. A new value cell is added above the selected value cell.</td>
</tr>
</tbody>
</table>

**NOTE** You can also modify any size parameter value, including calculation formulas. To change a constant value or calculation, click the parameter value cell in the table view and edit the value.

If you add a size and then change your mind, you can click Edit menu ➤ Undo to remove the new size.

5 Click the new parameter value cell and enter a size.

6 In the Catalog Editor, click ✏️. Alternatively, click File menu ➤ Save. The software validates the new part and regenerates the catalog. The software validates the part and regenerates the catalog.

**NOTE** To access the new part size during part selection, be sure to load the modified part catalog in your drawing. For more information, see Specifying Part Catalogs and Style-Based Content Locations on page 70.

### Adding Custom Data to Parts in Catalog Editor

Custom data is a unique, user-defined parameter that you use to customize your parts. Custom data can be helpful if you want to expand scheduling data for a part, or access additional values to use in engineering calculations.

Before adding custom data, you must determine the storage type in which to store the custom data, depending on the uniqueness of the data.

<table>
<thead>
<tr>
<th>If the custom data...</th>
<th>then add the custom data to the...</th>
</tr>
</thead>
<tbody>
<tr>
<td>is a value that varies with other part size parameters, such as the material</td>
<td>basic table storage type.</td>
</tr>
<tr>
<td>is a list of values for the part, such as size dimensions</td>
<td>constant lists storage type.</td>
</tr>
<tr>
<td>is a single value that remains constant for all part sizes, such as the manufacturer</td>
<td>constants storage type.</td>
</tr>
<tr>
<td>is a calculated value for all part sizes, such as size dimensions dependent on other constant dimensions</td>
<td>calculations storage type.</td>
</tr>
</tbody>
</table>

For more information about storage types, see Part Sizes on page 82.

**To add custom data to a part in Catalog Editor**

1 If necessary, open the Catalog Editor, and then open the part catalog.
2 In the tree view, navigate to the part to which to add custom data, and expand the part family to show the storage types.

3 Select the storage type for the custom data parameter.

4 In the table view, right-click a cell, and then click Insert ➤ Column.
The software inserts a new custom data column to the left of the selected cell.

**NOTE** If you add a custom data column and then change your mind, click Edit menu ➤ Undo to remove the custom data parameter.

5 Enter values for Name and Description, and select a value for Units, Data Type, and Visible to define the attribute rows of the parameter.

6 Enter values for one or more value rows to define the custom data, depending on the storage type of the parameter.

7 In the Catalog Editor, click ✒. Alternatively, click File menu ➤ Save.
The software validates the new part and regenerates the catalog.
The software validates the part and regenerates the catalog.

---

**Creating Part Catalogs in Catalog Editor**

You can create custom part catalogs in Catalog Editor. Custom part catalogs can serve as company-specific or project-specific catalogs. They can also be used to limit the number of available parts during part selection. It is recommended that custom part catalogs be created by a CAD manager or other user who is experienced with Catalog Editor.

To simplify catalog creation and to ensure that you create valid parts, create new parts by copying parts from an existing catalog into your new catalog and then modifying the part data.

**IMPORTANT** To facilitate the process of upgrading to a new version of AutoCAD MEP, your custom catalogs should contain all of your custom parts; do not add custom parts to the catalogs provided with the software. When you upgrade, this allows you to easily move all of your custom catalog content as a whole to the catalog folders for the new version (where new versions of the catalogs provided with the software are also located). You can use both types of catalogs during layout if you specify multiple catalogs for a domain, as described in Specifying Part Catalogs and Style-Based Content Locations on page 70.

**To create a catalog in Catalog Editor**

1 If necessary, open the Catalog Editor.

2 In the Catalog Editor, click ✒ (New Catalog) on the toolbar. Alternatively, click File menu ➤ New.

3 In the New Catalog dialog, define the new part catalog:

<table>
<thead>
<tr>
<th>To define the...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>domain type of the catalog</td>
<td>select a domain for Domain Name.</td>
</tr>
<tr>
<td>name of the catalog</td>
<td>enter a value for Catalog Name. The catalog name you specify is the name of the Autodesk product catalog (APC) file that you access through the MEP Catalogs tab in the Options dialog when you load the catalog into your drawing.</td>
</tr>
<tr>
<td>description of the catalog</td>
<td>enter a value for Catalog Description.</td>
</tr>
</tbody>
</table>
To define the directory location of the catalog, then browse to and select a directory location for Catalog Root Directory.

4 Click OK.

5 Customize the catalog:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then in the tree view…</th>
</tr>
</thead>
<tbody>
<tr>
<td>add a chapter</td>
<td>right-click the catalog or chapter, click Insert ➤ Chapter, enter a name, and press Enter.</td>
</tr>
<tr>
<td>copy a chapter or part</td>
<td>right-click the chapter or part, click Copy, and then right-click another chapter and click Paste. You can also copy and paste chapters and parts between part catalogs when multiple sessions of Catalog Editor are open. When you copy and paste a chapter, the Catalog Editor copies and pastes the entire chapter, including its part families.</td>
</tr>
<tr>
<td>move a chapter or part</td>
<td>right-click the chapter or part, click Cut, and then right-click another chapter and click Paste. You can also cut and paste chapters and parts between part catalogs when multiple sessions of Catalog Editor are open.</td>
</tr>
<tr>
<td>delete a chapter</td>
<td>right-click a chapter, and click Delete.</td>
</tr>
<tr>
<td>delete a part</td>
<td>right-click a part family, and click Delete.</td>
</tr>
<tr>
<td>rename a chapter or part</td>
<td>right-click the chapter or part family, click Rename, enter the new name, and press Enter.</td>
</tr>
</tbody>
</table>

6 In the Catalog Editor, click ➤ . Alternatively, click File menu ➤ Save. The software validates the new part and regenerates the catalog.

When you save the catalog, the software validates all parts in the entire catalog structure and then regenerates the catalog by updating the APC file. You can only use a part catalog in AutoCAD MEP if it has been regenerated successfully.

**Working with Part Data in Excel**

You can copy and paste part data between Catalog Editor and Microsoft® Excel. Right-click a cell in Catalog Editor, click Cut or Copy, and then paste the part data into Excel for further manipulation, for use in part schedules, or for performing engineering calculations. You can also cut or copy part data from Excel and paste it into Catalog Editor. Part data can be selected by rows, columns, or individual cells by dragging the cursor over your selection.

When copying part data from Catalog Editor into Excel, you select one or more parameter values to copy, and the rows are pasted into the Excel spreadsheet in order. When copying part data from Excel into Catalog Editor, you select values from the spreadsheet, and they are pasted into the appropriate cells based on data type.
Validating and Regenerating Part Catalogs

It is important to validate the parts in your part catalogs to ensure the parts work correctly in AutoCAD MEP and that you are using the most updated catalog data in your engineering designs. When you make changes to a part catalog, you should validate and regenerate the part catalogs to ensure they are current. You can only use part catalogs that have been regenerated. Similarly, during part selection, you can only access parts that have been validated.

The content tools—Content Builder on page 646 and Catalog Editor on page 771—validate and regenerate the part catalog that is being accessed when a part or part catalog is saved. However, you might want to validate and regenerate part catalogs that you have received from other users or that you are migrating from previous versions of AutoCAD MEP.

Validating the Parts in a Catalog

You validate parts that you have changed or added to a part catalog. Only validated parts are available during part selection.

To validate the parts in a catalog

1. Verify that the catalog you modified is one of the catalogs specified on the MEP Catalogs tab of the Options dialog.
   
   Only the catalogs specified on this tab are loaded into the drawing and, therefore, can be validated. For more information, see Specifying Part Catalogs and Style-Based Content Locations on page 70.

2. In AutoCAD MEP, click Manage tab ➤ MEP Content panel ➤ ➤ Test Catalog.

3. Specify the catalogs to validate:

   If you want to validate ... Then ...

   all of the catalogs enter a (All), and press Enter.

   the catalogs specified for a single domain, such as Duct or MvPart enter the appropriate letter, and press Enter. (For example, to validate the catalogs specified for Duct, enter d.)

   During the validation process, the software steps through the catalog structure and validates part sizes by verifying that necessary part size information exists for each part size. For example, it checks that parameters for AoD (angle of deflection on page 267), CEL (connection engagement length on page 267), and ND (nominal diameter) are present.

   When the catalog test is complete, a dialog containing the results is displayed. As noted in the dialog, you can view the full test results in Validate\Catalog_Validation_Summary.htm; the Validate directory is located in the same directory as the Autodesk part catalog (APC file).

4. Click OK, and press Enter to end the command.
Regenerating a Part Catalog

You should regenerate a part catalog that you have modified. Regenerating a part catalog updates the Autodesk part catalog (APC) file. A part catalog can be used in AutoCAD MEP only if it is updated (regenerated).

**To regenerate a part catalog**

1. Verify that the catalog you modified is one of the part catalogs specified on the MEP Catalogs tab of the Options dialog.
   
   Only the catalogs specified on this tab are loaded into the drawing and, therefore, can be regenerated. For more information, see Specifying Part Catalogs and Style-Based Content Locations on page 70.

2. In AutoCAD MEP, click Manage tab ➤ MEP Content panel ➤ ➤ Regenerate Catalog .

3. Specify the catalogs to regenerate:

   - **If you want to regenerate ... then ...**
     
     all of the catalogs: enter (All), and press Enter.
     
     the catalogs specified for a single domain, such as Duct or MvPart: enter the appropriate letter, and press Enter. (For example, to regenerate the catalogs specified for Duct, enter d.)

   During the regeneration process, the software updates the catalogs to reflect new or deleted part sizes.

   **NOTE** If multiple catalogs are specified for a domain in the Options dialog, the software regenerates all of them in the order listed in the dialog.

   When the catalog regeneration is complete, a dialog containing the results is displayed. As noted in the dialog, you can view the full regeneration results in Validate\Catalog_Regen_Summary.txt; the Validate directory is located in the same directory as the Autodesk part catalog (APC file). Examining the text file is helpful when you need to verify that a specific part has been added to or removed from the catalog.

4. Click OK, and press Enter to end the command.

If part sizes are missing or have not been removed, you can make the necessary modifications in the Catalog Editor. For more information, see Customizing Catalogs in Catalog Editor on page 774.

Migrating Part Catalogs

You can migrate part catalogs in a particular domain. In effect, this functionality lets you upgrade version and parameter information for existing part catalogs, ensuring that you are using the most updated catalog data.

1. In AutoCAD MEP, click Manage tab ➤ MEP Content panel ➤ ➤ Migrate Catalog .

   **NOTE** You can also enter CatalogMigrate on the command line.
2 Note the prompt on the AutoCAD MEP command line: Catalog Migrate
   [Mvpart/Pipe/Duct/Conduit/Cabletray/All]

3 Specify the catalogs to migrate, as follows:

<table>
<thead>
<tr>
<th>If you want to migrate ...</th>
<th>then ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>all of the catalogs</td>
<td>type a (All), and press Enter.</td>
</tr>
<tr>
<td>the catalogs specified for a single domain (such as Pipe, Duct, MvPart)</td>
<td>type the appropriate letter, and press Enter. (For example, to regenerate the catalogs specified for Pipe, type p.)</td>
</tr>
</tbody>
</table>

A progress bar displays the part number, total parts, and the affected catalog being upgraded. This command updates the version number and also integrates changes to connectors in the selected domain, such as connection engagement length, angle of deflection, and nominal diameter.

When the upgrade is completed, a report summarizes the results, including the number of errors, a list of the affected parts, and a link to the results file. The report also includes a link to a file that contains these details.

4 Click OK, and press Enter to end the command.

NOTE You can use the Redefine From Catalog command to update an existing drawing with the most current pipe fittings and MvParts. For more information, see Redefining the Catalog Parts in a Drawing on page 783.

Redefining the Catalog Parts in a Drawing

You use the Redefine from Catalog command to scan the pipe fittings and MvParts in a drawing and swap the parts from the catalog to replace those in the drawing. This command will only swap a part if it is already in the drawing and if the part in the catalog matches the part parameters (part ID and part name) for the specified domain.

1 In AutoCAD MEP, click Manage tab ➤ MEP Content panel ➤ Redefine From Catalog.

NOTE You can also enter RedefineFromCatalog on the command line.

2 Note the prompt on the AutoCAD MEP command line: Redefine the parts of the type [Mvpart/Pipe]:

3 Specify the parts to redefine by typing m (MvParts) or p (Pipe), and then press Enter.

   While the command is running, AutoCAD MEP checks each part for a part ID and part name match in the appropriate domain catalogs in the drawing. If a suitable match cannot be made, the affected part remains unchanged.

   A progress bar displays the number of parts validated and the number remaining. When the redefinition task is completed, a report summarizes the results, including the number of parts reviewed, and the number of parts successfully updated. The report also includes a link to a file that contains these details.
This section provides information on advanced customization tasks that are typically performed by CAD Managers or other experienced users of AutoCAD MEP.

Creating Drawing Environment Configurations for Users

You can create profiles and workspaces to customize the drawing environments of users to meet company or project requirements.

Creating Profiles

Profiles store drawing environment settings, such as the following:

- Default search and project file paths
- Template file locations
- Initial folder specified in file navigation dialogs
- Default linetype and hatch pattern files
- Printer defaults

Profile information is typically set on the Files tab of the Options dialog and stored in the system registry. Each time you make a change to an option, setting, or other value, the software updates the current profile.

You create and manage profiles on the Profiles tab of the Options dialog. You can create profiles for different users or projects, and you can share profiles by importing and exporting them as ARG files. AutoCAD MEP includes several profiles for working with metric and imperial units. The name of the current profile is displayed at the top of the Options dialog.

To access the Options dialog, click ➤ Options. For more information about working with profiles, see “Save and Restore Interface Settings (Profiles)” and “Profiles Tab (Options Dialog Box)” in the AutoCAD Help.
Creating Workspaces

Workspaces are sets of ribbon tabs and palettes that are grouped and organized so you can work in a custom,
task-oriented drawing environment. The software includes sample workspaces that are tailored for different
disciplines and tasks.

While profiles save environment settings including many of your user options, drafting settings, paths, and
other values, workspaces control the display of ribbons and palettes in the drawing area. You create and
manage workspaces using the Workspace Settings dialog, and the Customize User Interface (CUI) dialog.

Users can create their own workspaces, or, in design situations where more control over the drawing
environment of users is required, CAD managers can create read-only workspaces that are shared by many
users. This can be helpful for maintaining company or project standards.

For more information on working with workspaces, see “Create Task-Based Workspaces” and “Create an
Enterprise CUI File” in the AutoCAD Help.

NOTE: The software automatically adds object-specific shortcut commands to the context ribbon of an object.
For example, the context ribbon of a duct object includes commands for working with ducts, such as commands
for calculating duct system sizes and for specifying duct lengths by breaking or merging segments.

Styles and Support Files

Support files are located in the following locations:

<table>
<thead>
<tr>
<th>Files</th>
<th>Location Windows XP</th>
<th>Location Windows Vista</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plotter Configurations</td>
<td>\ProgramData\Autodesk\MEP 2010\enu\Plotters</td>
<td>\ProgramData\Autodesk\MEP 2010\enu\Plotters</td>
</tr>
<tr>
<td>Plot Styles</td>
<td>\ProgramData\Autodesk\MEP 2010\enu\Plotters\Plot Styles</td>
<td>\ProgramData\Autodesk\MEP 2010\enu\Plot Styles</td>
</tr>
<tr>
<td>DesignCenter Content</td>
<td>\ProgramData\Autodesk\MEP 2010\enu\AEC Content</td>
<td>\ProgramData\Autodesk\MEP 2010\enu\AEC Content</td>
</tr>
<tr>
<td>Layer Standards drawing</td>
<td>\ProgramData\Autodesk\MEP 2010\enu\Layers</td>
<td>\ProgramData\Autodesk\MEP 2010\enu\Layers</td>
</tr>
<tr>
<td>Styles drawings</td>
<td>\ProgramData\Autodesk\MEP 2010\enu\Styles</td>
<td>\ProgramData\Autodesk\MEP 2010\enu\Styles</td>
</tr>
<tr>
<td>Drawing templates</td>
<td>\ProgramData\Autodesk\MEP 2010\enu\Template</td>
<td>\ProgramData\Autodesk\MEP 2010\enu\Template</td>
</tr>
<tr>
<td>Area Evaluation templates</td>
<td>\ProgramData\Autodesk\MEP 2010\enu\Template\Evaluation Templates</td>
<td>\ProgramData\Autodesk\MEP 2010\enu\Template\Evaluation Templates</td>
</tr>
<tr>
<td>Default Used User Interface Catalog</td>
<td>\Documents and Settings&lt;Username&gt;\Application Data\Autodesk\MEP 2010\enu\Support\WorkspaceCatalog (Imperial/Metric)</td>
<td>\Users$Username$\AppData\Roaming\Autodesk\MEP 2010\enu\Support\WorkspaceCatalog (Imperial/Metric)</td>
</tr>
<tr>
<td>Stock Tool Catalog</td>
<td>\Program Files\AutoCAD MEP 2010\Catalogs\MEPStockToolCatalogs\MEPStock Tool Catalog.atc</td>
<td>\Program Files\AutoCAD MEP 2010\Catalogs\MEP-StockToolCatalogs</td>
</tr>
<tr>
<td>Structural Member Catalog</td>
<td>\Program Files\AutoCAD MEP 2010\Catalogs\Structural</td>
<td>\Program Files\AutoCAD MEP 2010\Catalogs\Structural</td>
</tr>
</tbody>
</table>
Customizing Tool Palettes

You can create custom tool palettes to suit company or project requirements. Typically, you create tool palettes according to tool type or design phase. For example, you could place your piping tools on a tool palette called “Piping,” or your schematic tools on a tool palette called “Schematic.”

Because the tool palette set is the collection of tool palettes specified for the current user profile, you can have only one tool palette set active at a time during an AutoCAD MEP session. However, you can create different tool palette sets for different user profiles and customize the tool palette sets. For example, you can add, remove, and rearrange the palettes in the tool palette set. You can also rename the tool palette set.

Creating a Tool Palette

1. In the title bar of the tool palette set, click \(\text{▼} \), and then click New Palette.
2. Enter a name for the new tool palette, and press \(\text{ENTER} \).
   The software creates an empty tool palette.
3. Add tools to the tool palette. For more information, see Customizing Tools on page 789.

NOTE The MEP Sample Palette catalogs include a number of tool palettes that you can use or customize. You can access the Sample Palette catalogs from the Content Browser. Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content Browser \(\text{▼} \).

You can create tool palettes directly in the Content Browser, and drag and drop palettes from the library to your tool palette set. When you add a palette to your tool palette set in this manner, you can link it to the Content Browser so that the software refreshes the palette automatically whenever it detects changes to the palette in the Content Browser. Alternatively, you can refresh the palette manually. For more information, see Adding a Tool Palette from a Tool Catalog in the Content Browser in the AutoCAD Architecture Help.

Creating a Tool Palette Set

Use this procedure to create a new tool palette set for a new profile. For information on modifying the tool palette set for the current profile, see Specifying Different Tool Palettes for the Tool Palette Set on page 789.

To create a new tool palette set for a new profile

1. To access the Options dialog, click \(\text{▼} \) Options.
2. Click the Profiles tab, and then click Add to List.
3. In the Add Profile dialog, enter a name and description for the profile, and click Apply & Close.

   NOTE By default, the tool palette set for the new profile includes the tool palettes for the current profile.

4. In the list of available profiles, select the new profile, and click Set Current.
5 Click the Files tab, and expand Tool Palettes File Locations.

6 Specify the tool palettes in the tool palette set for the new profile, which is now current:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>modify the set of tool palettes for the current profile</td>
<td>click Browse or Add to change or add tool palettes (ATC files). If desired, you can create copies of the tool palettes provided with the software, modify the copies, and then specify the file locations for the copies.</td>
</tr>
<tr>
<td>create an empty tool palette set</td>
<td>specify the file location of an empty folder. Once you click OK in the next step, this results in a blank tool palette set, to which you can add palettes and tools. For more information, see Creating a Tool Palette on page 787 and Customizing Tools on page 789.</td>
</tr>
</tbody>
</table>

Empty tool palette set

7 Click OK.

8 Rename the tool palette set.

Customizing a Tool Palette Set

The tool palette set has several user-definable display options. For example, you can dock the tool palette set to a specific side of the drawing window, minimize it when it is not in use, or configure it to display tool icons only, tool icons and names, or tool icons and names in a list format. You can set these display options according to your preferences. For information on modifying these user-definable settings, see Modifying the Appearance of Tools on page 90.

This section provides information on more advanced customizations to a tool palette set, such as renaming the tool palette set to a company or project name, or changing the collection of tool palettes in the set.
Specifying Different Tool Palettes for the Tool Palette Set

Use this procedure to switch between different palette combinations in the tool palette set. You can do this in one of two ways:

- modify the set of tool palettes for the current profile
- change to a different profile that uses a different set of palettes

For information on working with profiles, see Creating Drawing Environment Configurations for Users on page 785.

To specify different tool palettes for the tool palette set

1. To access the Options dialog, click ➤ Options.
2. Specify a different set of tool palettes:
   - If you want to modify the set of tool palettes for the current profile: click the Files tab, expand Tool Palettes File Locations, and click Browse or Add to change or add tool palettes (ATC files).
   - If you want to change to a different profile that uses a different set of palettes: click the Profiles tab, select the desired profile, and click Set Current.
3. Click OK.

Renaming the Tool Palette Set

Use this procedure to rename the tool palette set. For example, you might want to name it with a project or company name.

To rename the tool palette set

1. In the title bar of the tool palette set, click Rename, and then click Rename Palette Set.
2. Enter a name for the tool palette set, and press ENTER.

Customizing Tools

There are 2 types of tools: object tools and command tools.

Object Tools

An object tool inserts an object, such as a duct or a pipe, into a drawing. When you add an object with a specific object tool, the object has the settings that are defined in the tool, which facilitates the design process and enhances consistency across your project drawings.
Command Tools

A command tool is a graphical representation of an object-related command. For example, the Analyze ribbon and the Analysis tool palette in the HVAC tool palette group contain a Duct System Size Calculator tool. The tool opens the Duct System Size Calculator dialog, in which you can size a duct system that you have designed.

You can create tools for the commands in AutoCAD MEP.

Content Browser

The Content Browser is a library of tool catalogs containing tools and tool palettes. You can browse the catalogs in the Content Browser, and drag and drop tools onto tool palettes. You can also publish catalogs in the Content Browser to make them available for use by multiple users on a network. For more information, see Content Browser in the AutoCAD Architecture Help.

Customizing Tools

For all tools, you can define the tool name and description. For many tools, you can define additional properties, such as the layer key and layer key overrides of objects inserted with the tool, and the object style.

NOTE The tool description you enter for a tool is used as the tooltip. It is also used as the description when the tool is copied to a tool catalog in the Content Browser.

Creating Tools for Style-Based Content

You can quickly create object tools for the following objects:

- Schematic lines and symbols
- Plumbing lines and fittings
- Devices
- Panels
- Wires
To do so, drag an object from a saved drawing onto a tool palette, and then configure the tool properties. The initial values for the tool properties are determined by the object that you drag and drop onto the palette.

While you can create and configure object tools for other building systems objects using AutoLISP programming, only tools for the aforementioned objects allow you to configure all relevant object properties directly on the Tool Properties worksheet as shown below.

**NOTE** In the Tool Properties worksheet, *indicates a property is available only when you are adding objects, not when you are modifying them.

For general information on configuring tool properties, see:
- Changing Tool Properties on page 795
- Changing Tool Icons on page 795

For information on configuring properties that are specific to an object type, see:
- Adding Schematic Lines in Orthographic Mode on page 525 and Adding Schematic Lines in Isometric Mode on page 528
- Adding Schematic Symbols in Orthographic Mode on page 527 and Adding Schematic Symbols in Isometric Mode on page 531
- Adding Devices on page 391
- Adding Panels on page 403
- Adding Wires on page 412

**TIP** To facilitate annotation and scheduling, you can use the properties of device tools to specify property sets and tags, so they are automatically attached to devices when they are added to drawings. A property set is a user-defined group of related properties, such as a part number or a manufacturer’s name. A tag is a symbol that can display the data in a property set attached to an object. For more information on annotation and scheduling, see Creating Construction Documents on page 547.
Creating Tools from Routing Preferences

You can transfer a pipe routing preference from the Pipe Part Routing Preferences to the Pipe Tool palette. The new Pipe tool uses the name and other characteristics of the original routing preference.

**NOTE** This functionality is only available in the Piping domain.

To drag a pipe tool from the Routing Preferences to the Pipe Tool palette

1. If necessary, **activate the Piping workspace**.
2. Open the desired tool palette.
3. Click Manage tab ➤ Style & Display panel ➤ Style Manager drop-down ➤ Routing Preference Definitions.
4. In the left pane of Style Manager, click the desired routing preference.
5. Drag the routing preference onto the Pipe Tool palette, either to the Parallel Pipe tab or the Gravity Pipe tab. For more information about these tabs, see Adding Pipe Using the Tool Palette on page 291.

The new tool appears in the Tool palette with the same name as the corresponding routing preference. For example, if you transfer Glued to the Pipe Tool palette, the new tool is also named Pipe Tool.

6. Select the new tool, right-click, and click Properties.

In the Tool Properties dialog, the Routing Preference, Routing Preference Location, and Name properties for the new tool reflect values from the original routing preference. The remaining properties in the Tool Properties dialog show “--”. This means that a default value has not been set. The properties will reflect the last value that was used when the Pipe Add command was invoked on the corresponding routing preference.

Creating Tools from AEC Content in DesignCenter

Architectural, engineering and construction (AEC) content consists of drawings, symbols, object styles, and annotation routines that you add to drawings to design and document your project. You can create a tool on a tool palette using the predefined AEC content accessed in DesignCenter. You can also create tools from blocks in DesignCenter, but they have slightly different tool options.

**NOTE** AutoCAD MEP also provides the Stock Tool Catalog and the Documentation Tool Catalog, which you can access in the Content Browser. These catalogs already have tools set up for predefined AEC Content and sample object styles, and they are available for both metric and imperial units. To open Content Browser, click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content Browser.

For more information, see AEC Content and DesignCenter in the AutoCAD Architecture Help.

To create a tool from AEC Content in DesignCenter

1. Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Tools.
2. Open the tool palette where you will create the new tool.
3. Click Insert tab ➤ Content panel ➤ Content drop-down ➤ Design Center.
4 In the DesignCenter, click the AEC Content tab, and navigate to the AEC Content item where you can choose the tool to create.

5 Drag the item to the tool palette.
The software inserts a new tool on the tool palette.

6 Define additional properties for the new tool, if necessary.
For information on changing tool properties, see Changing Tool Properties on page 795. For information on changing the icon of the new tool, see Changing Tool Icons on page 795.

Creating Command Tools
Tools usually represent objects or AEC content items. However, you can also create a tool for a command.

To create a command tool
1 Create the command tool by copying an existing one:

<table>
<thead>
<tr>
<th>If you want to…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>copy an existing command tool from a tool palette</td>
<td>navigate to the tool palette, right-click the command tool, and click Copy. Then navigate to the tool palette on which to insert the new command tool, right-click, and click Paste.</td>
</tr>
<tr>
<td>copy the general purpose Command Tool in the Stock Tool catalog in the Content Browser</td>
<td>Click Home tab ➤ Build panel ➤ Tools drop-down ➤ Content Browser ➤ MEP Stock Tool Catalog. Click a domain (for example, Electrical). Move your pointing device over i-drop icon next to the Command Tool, click, and drag the Command Tool to the tool palette on which to create the new command tool.</td>
</tr>
</tbody>
</table>
2 Right-click the new command tool, and click Properties.

3 For Name, enter a name for the new command tool.
4 For Description, enter a description of the tool function.
5 For Command, enter the command to execute when the tool is selected.

**TIP** For a list of AutoCAD MEP commands, enter `arx` on the command line, and then enter `c` (commands).

6 Click OK.

For information on changing tool properties, see Changing Tool Properties on page 795. For information on changing the icon of the new tool, see Changing Tool Icons on page 795.

### Creating Property-Based Tools

You can create a property-based tool from an existing object in a drawing. This capability is available in the following domains: Piping, Plumbing, Schematic, and Electrical (except for cable tray and conduit). These instructions describe the procedure in the Piping domain.

1 To insert a pipe fitting in the drawing, click Home tab ➤ Build panel ➤ Pipe Fitting.
2 Save the drawing.
3 Zoom into the drawing, and then select the pipe fitting object.
4 Drag the selected pipe fitting part onto the Pipe fitting tool palette.
5 Click the object, right-click, and click Properties.
6 Edit tool properties, as described in Changing Tool Properties on page 795.
Changing Tool Properties

For all tools, you can define the properties of a tool in a tool palette, such as name and description. For many tools, you can also define additional properties, such as the layer key and layer key overrides of objects inserted with the tool, and the object style.

To change the properties of a tool

1. Open the tool palette that contains the tool you want to modify.
2. Right-click the tool, and click Properties.
3. In the Tool Properties dialog, enter a name for the tool.
4. Click and enter a tool description in the Description worksheet (optional).

**NOTE** The software uses the tool description as the tooltip and also as the description when the tool is copied to a tool catalog in the *Content Builder* on page 646.

To select a part for property-based tools

5. For property-based tools created on page 794 from within the drawing, click the part image on the Tool Properties to open the Select a Part dialog.
6. In the Select a Part dialog, choose a part from the catalog and optionally make other part and filtering selections.

**TIP** Select the Use unspecified part type to disable the part selections in this dialog. This selection creates a tool on the tool palette that does not include specified properties. You can use this new tool to start the Pipe Fitting Add command as you lay out the pipe run.

To specify other properties

7. (Optional) On the Properties palette, specify other values for additional properties, as follows:

<table>
<thead>
<tr>
<th>If you want to specify…</th>
<th>then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>a layer key</td>
<td>click the Layer key worksheet, select the layer key in the Select Layer Key dialog, and click OK.</td>
</tr>
<tr>
<td>layer key overrides</td>
<td>click the Layer overrides worksheet, specify the overrides in the Select Layer Overrides worksheet, and click OK.</td>
</tr>
</tbody>
</table>

**NOTE** If you do not specify a layer key or layer key overrides, the layer assignments specified in the layer key style in the drawing are used.

8. Specify other properties that appear depending on the type of tool, such as System, Current size, Elevation, and Insulation thickness.

Changing Tool Icons

When you create a tool, the tool is added to a tool palette with the icon of the tool from which it was copied or with a default icon. You can change the tool icon by selecting a new icon saved as an image file or by selecting an object in the drawing. You cannot create icons from custom blocks. If you need to create an icon based on a custom block, save the block as an image file in any of the formats in the following list.
When you change a tool icon by selecting an icon saved as an image file, you can use any of the following image file formats:

- PNG
- GIF
- JPG
- BMP
- TIFF

**NOTE** PNG is the recommended image format for tool icons because it supports lossless compression and background transparency. All of the other formats leave a background to the tool image.

Icons in tool palettes can have a maximum size of 64 x 64 pixels. Larger images are scaled when inserted.

**To replace the tool icon using an image file**

1. Open the tool palette that contains the tool you want to modify.
2. Right-click the tool, and click Properties.
3. In the Tool Properties dialog, right-click the existing icon, and click Specify Image.
4. In the Select Image dialog, select the image you want to use as a tool icon, and click Open.
5. Click OK.

**To replace the tool icon using an object in a drawing**

1. Open the tool palette that contains the tool you want to modify.
2. Right-click the tool, and click Set Image from Selection.
3. In the drawing, select the object to use as the tool icon, and press ENTER.
4. Click OK.

**NOTE** For information on changing the display size of the tools on a palette, see Modifying the Appearance of Tools on page 90.

### Deleting Tools

When you delete a tool from a tool palette, objects in your drawing that were inserted with the tool are not deleted.

**To delete a tool**

1. Open the tool palette that contains the tool.
2. Right-click the tool, and click Delete.
AutoCAD MEP includes a U.K. profile containing content based on the British Standards Institute (BSI) standards and other standards for metric design. The profile includes content and tools that support the design requirements of the U.K. and German markets, such as

- Predefined hanger styles
- Object tools for adding hangers to drawings
- Command tools for adding hanger schedules to construction documents

The U.K. profile also is configured to load a set of related features and commands when you make it the current profile. These features include but are not limited to

- Support for creating hanger styles in Style Manager
- Commands for working with hangers
- Commands for rotating cable trays and connected objects

This chapter provides information on using this set of related features and commands.

**NOTE** If you are not using the U.K profile, see Using Other Profiles on page 797.

### Using Other Profiles

If you are not using the U.K. profile, you can still use the features and commands discussed in this chapter, but, in some cases, you might need to create supporting content beforehand.

If you make the Global profile (included in the Global content pack) the current profile, the features and commands are loaded by default. If you make a different profile current, you can access them by doing either of the following:

- Enter any command discussed in this chapter when you need it. This action loads the required module on demand.
- Enter `loadmetriccmds` to permanently configure the profile to always load the module at startup.
NOTE  For information on switching profiles, see “Save and Restore Interface Settings (Profiles)” in the AutoCAD Help.

**Working with Hangers**

You can add hangers to ducts, pipes, cable trays, and conduits.

Hangers are a type of style-based content, which means you create and modify the styles that represent them in Style Manager. For an introduction to style-based content, see Working with Style-Based Content on page 85.

**Configuring Hanger Styles**

A hanger style specifies two structural member styles that define

- The type of drop rod to use
- The type of channel to use

You need to create these structural member styles before creating a hanger style.

**TIP**  To create a structural member style, switch to the Architecture workspace, click Manage tab ➤ Style & Display panel ➤ Structural Member Wizard , and create a style using the Structural Member Style Wizard.

**To create a hanger style**

1. Click Manage tab ➤ Style & Display panel ➤ Style Manager .
2. In the left pane, expand Multi-Purpose Objects, and select the Hanger Styles category.
   If the Hanger Styles node is not listed under Multi-Purpose Objects, enter the hangeradd command and follow the prompts to add a hanger to your drawing.
3. Create the style, and configure its general properties as described in Creating a Style on page 601.
4. Click the Hangers tab.

5. For Channel Style, select the structural member style to represent the channel.

**IMPORTANT**  You can select from the structural member styles in the current drawing that include both of the following words in their names or descriptions: hanger and channel.
Adding Hangers

You can add hangers to ducts, pipes, cable trays, and conduits. You cannot add hangers to fittings.

When you add a hanger, the midpoint of the hanger top is positioned relative to the midpoint of the bottom of the building system object to which it is anchored. Because the hanger is anchored to the object, when the object moves, the hanger moves with it. When the object is deleted, the hanger is also deleted.

To add hangers

1 Start the add command by doing one of the following:
   ■ Open the Tools palette, and click the Add Hanger Support tool, if available.
   ■ On the command line, enter `hangeradd`.

2 For Hanger Style, select the hanger style to use.
   You can select from the hanger styles defined in the current drawing.
3 For Left Channel Offset, enter the distance between the left side of the building systems object and the edge of the channel.

NOTE The left and right sides of the building systems object are determined by its start point and endpoint.

4 For Right Channel Offset, enter the distance between the right side of the building systems object and the edge of the channel.

5 For Support Height, enter the height of the drop rods.

6 Specify how you want the hangers to provide support:

<table>
<thead>
<tr>
<th>If you want the hangers to provide support ...</th>
<th>Then ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>from above the run</td>
<td>select Support From Above</td>
</tr>
<tr>
<td>from below the run</td>
<td>clear Support From Above</td>
</tr>
</tbody>
</table>

7 Under Insertion Options, specify the number of hangers to insert and how to space them:

<table>
<thead>
<tr>
<th>If you want to add...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>a single hanger</td>
<td>for Insertion, select Single.</td>
</tr>
<tr>
<td>hangers at a specific distance interval</td>
<td>do the following:</td>
</tr>
<tr>
<td></td>
<td>■ For Insertion, select Along Run.</td>
</tr>
<tr>
<td></td>
<td>■ For Distance between, enter the distance between the centers of the hangers.</td>
</tr>
<tr>
<td>a specific number of hangers at a specific distance interval</td>
<td>do the following:</td>
</tr>
<tr>
<td></td>
<td>■ For Insertion, select Along Run (Fixed Number).</td>
</tr>
<tr>
<td></td>
<td>■ For Distance between, enter the distance between the centers of the hangers.</td>
</tr>
<tr>
<td></td>
<td>■ For Quantity, enter the number of hangers to insert.</td>
</tr>
</tbody>
</table>

8 Click OK.

9 In the drawing, select the building systems object to which to add the hangers.

10 Click to specify the location of the first hanger.

11 If, for Insertion, you selected Along Run or Along Run (Fixed Number), click in the direction you want to place the remaining hangers.
Modifying Hangers

You can modify a hanger using several methods:

- **Location grips**: To move a hanger, select it, click the Location grip, and specify a different location on the building systems object.

- **Lengthen grips**: To lengthen the channel or drop rods, select the hanger, right-click, and click Edit Parameters. Then select a Lengthen grip, and drag it to a new location.

- **Commands on the context menu**: Use the commands on the Support Orientation submenu to rotate the hanger around the building systems object, or to change the direction of support (Support From Above or Support From Below).

- **AutoCAD commands**: Use these commands to modify a hanger in other ways. You can access several AutoCAD commands, such as COPY, from the Basic Modify Tools submenu on the context menu.

Rotating Cable Trays

**NOTE** To rotate cable tray runs in model views, make sure the current display configuration uses a Cable Tray Model display representation for both cable trays and fittings. Only these display representations show an open side to cable trays and fittings, as is necessary to visually represent their rotation. If you are using the U.K. profile or the Global profile, the drawing templates are configured to use these display representations by default. If you are using another profile, you must configure the current drawing to do so, and you might also need to run LOADMETRICCMDS beforehand to make the display representations available in Display Manager. For information on loading the module, see Using Other Profiles on page 797.

**To rotate a cable tray run**

1. Select an isometric view direction, such as SW Isometric.
2. Select a cable tray, right-click, and click Rotate Cable Tray Direction. This action rotates the segment or fitting 90 degrees.
3. Repeat the previous step as required.
4. Select the same segment or fitting, right-click, and click Regenerate Cable Tray System.
5. Specify how you want to rotate connected objects:

   - **If you want to apply the same rotation angle to all connected in-line objects**
     - **Then...**
     - **in the system**
       - Enter `n` (no).
     - **to next transition in both directions**
       - Enter `y` (yes).
Glossary

Glossary Terms

3D orbit viewing You can use the dynamic features of the 3DORBIT command to manipulate the viewpoint for an object or an entire model. See also orbit.

access panel An opening for access to concealed parts or other equipment without disturbing the wall or building systems component.

acid neutralizer A system, either mechanical or chemical, that balances the pH level in water.

actual velocity The flow velocity for the pipe that you have selected. Once the pipe diameter and friction loss are calculated, you can calculate the actual velocity.

adjust slope To modify the slope (rise or run) of a pipe segment that results in modifying the slope ratio. See also slope.

AEC Object Enabler A distributable utility that allows users without Autodesk AEC applications to use Autodesk AEC objects in AutoCAD®, Volo View Express, AutoCAD Map, and other Autodesk applications.

AEC objects Objects created through AutoCAD Architecture, such as doors, walls, and windows.

air eliminator A device used to remove air from water, steam, or refrigerant.

air handling unit A single part composed of multiple pieces of equipment that together move heated or cooled air throughout ductwork in a building.

air inlet An opening that air is drawn into or flows into, typically through a fan.

air outlet An opening that air is pushed through or flows from, typically through a register or vent.

airflow The distribution or movement of air.

alternating current (AC) An electrical current that moves first in one direction and then in the other (positive to negative, then negative to positive).

ambient air The air outside a building or device.

amp (ampere) A unit of measurement for the flow of electrical current in a circuit.

amperage The total amount of current (amperes) flowing in a circuit.

anchor (1) A feature that creates a relationship between 2 objects.

anchor (2) To fasten, or anchor, an object to another object, a layout curve, or grid. The anchored object’s movement and/or size is constrained by the object to which it is anchored.

angle A pipe bend at 90 degrees that is used to connect pipe segments. Angles are used because 90-degree elbows are typically not used in plumbing.
angle of deflection The maximum allowable angle specified in the content indicating that male and female connectors are still considered connected. Angle of deflection (AoD) appears as Use fitting tolerance on the Piping Properties palette on page 286.

annotation Text, dimensions, symbols, or reference marks added to drawings for clarification.

annotation scale flag Elevation annotation used in place of linear measurements to show the height of pipes and fittings.

annotation symbols Annotation used to clarify parts of a drawing, such as leaders, break marks, title marks, and revision clouds. See also annotation.

APC For Autodesk Part Catalog. Standard file format for part catalogs within AutoCAD MEP.

architectural elements Architectural objects such as doors, walls, and windows. See also AEC objects.

ASHRAE fitting A duct fitting identified and described in the Duct Fitting Database of the American Society of Heating, Refrigerating, and Air-Conditioning Engineers (ASHRAE).

attribute An AutoCAD object that is included in a block definition to store alphanumeric data. Attribute values can be predefined or specified when the block is inserted. Attribute data can be extracted from a drawing and inserted into external files.

ballast An electrical device used in fluorescent and HID fixtures. It furnishes the necessary starting and operating characteristics to the lamp for proper performance.

base curve A curve used to define particular drawing objects, such as lines, polylines, and arcs. Many objects do not have a base curve and must be used with the curve anchor or layout curve command. See also curve anchor and layout curve.

baseline An established but imaginary line on which objects can rest.

bay In grid layouts, a regularly repeated spatial element defined by grid lines.

bell/hub A joining method where the pipe or fitting has an enlarged end to accept the male end of a pipe or fitting. The depth of the connection is defined by the connection engagement length value. See also connection engagement length (CEL).

bitmap The digital representation of an image having bits referenced to pixels. In color graphics, a different value represents each red, green, and blue component of a pixel.

block A generic term for one or more AutoCAD objects combined to create a single object.

branch circuits The circuits that carry power from the service panel to electrical devices.

brazed (1) Made of brass.

brazed (2) To unite metal with solder that contains copper, zinc, and other materials with high melting points.

break marks (1) Annotation used to specify a shortened view of an elongated object or group of objects.

break marks (2) To signify that an object has been broken or has had a piece removed.

breaker An electrical device that connects or disconnects power to a circuit.

BTU For British Thermal Unit. The amount of heat required to raise the temperature of one pound of water one degree Fahrenheit.

building model A 2-dimensional (2D) or 3-dimensional (3D) representation of one or more building objects, such as architectural, structural, or building systems objects.

butt weld A joint type where pipe is welded to other pipe, to fittings, or to equipment. No special joint fixture is required. The pipe end is prepared by grinding, and the pipe end is prepared by grinding, and then the pipe is directly welded.
butt welded 2 pieces of metal that are butted together, with the abutted ends thickened, shortened, and fused using heat.

cable Electrical wires protected by plastic tubing, metal sheathing, or another protective covering.

cable tray An assembly of segments and fittings forming a rigid structural system, used to securely fasten or support cables, wires, and raceways.

calculated size Size determined by the resulting value of a mathematical equation (calculation).

capacity The quantity of electricity that can be delivered from a unit, such as the output from a generator.

Catalog Editor A tool used to modify the content of the catalogs in some way, such as adding tracking information to a new part. See also content.

ceiling grid A rectangular arrangement of parallel lines forming a pattern for laying out ceiling tile and fixtures in a building.

cell anchor A feature that fastens, or anchors, an object to the cell position of a 2D or 3D layout object. The anchored object’s movement and size are constrained by the cell.

centerline A line used to indicate the axes of symmetrical objects, the center of a segment or fitting, and paths of motion.

chase A vertical passage in a wall where ducts, pipes, and wires can be run through a building.

Circuit (1) A continuous loop of current from a power source, with “hot” wire to the device and “neutral” wire back to the source.

Circuit (2) An object used to connect devices and MvParts to panels. See also closed circuit and open circuit.

Circuit breaker A common type of protection for over current. A circuit breaker is used to break contact in an overload condition, resulting in an open circuit. See also over current.

Circuit length A rough estimate of the total length of all the wires in a single circuit. Circuit length is calculated by adding the XY distances between electrical devices to the rise/drop distances between the wire and device elevations.

Circuit load Circuit load is the voltage on a circuit that contains the system type Power and Lighting. All devices connected to the circuit must have a voltage in the range of the voltage definition. See also voltage.

Circuit voltage The voltage of all the devices in a single circuit.

clean up Joining appropriate parts of 2 different components by lengthening, shortening, or breaking lines that represent boundaries of the components. For example, when adding an elbow to a run, the segments are trimmed back to allow room for the elbow.

closed circuit An electrical circuit in which there is no interruption of current flow. See also circuit.

command line A text area on screen reserved for keyboard input, prompts, and messages.

compass A tool used to navigate your way through a building as you lay out building systems components.

component (1) A fundamental element of an object, such as the centerline of a segment.

component (2) A single piece or part of a building systems design.

conceptual design phase Initial design phase of a building project. Also referred to as schematic or preliminary design.

condensate line A pipe that drains excess water from an air conditioning unit. The water results from vapor condensing on the cool surfaces inside the unit.

conduit A tubular material used to encase and protect electrical wiring: typically plastic or metal.
connection type A property of ducts, pipes, conduits, and cable trays that describes how the segments are mounted together. Normally, connector types must match to form a valid connection. These connector rules are defined in connector styles.

connector An AutoCAD MEP element that is placed on an object and that holds information. A connector joins other objects (i.e., pipe segments) to each other.

connector block A block with terminals used to connect wires or cables.

connector engagement length (CEL) The length of pipe that is inserted into a coupling either as a threaded section or socket weld segment for joining the pipe. CEL constitutes part of the overall length of a pipe segment and is the minimum length required for a proper connection.

constrained layout Drawing pipe between 2 existing pipe objects (pipes or fittings)

constraint In Content Builder, an entity that controls the shape of a feature by establishing relationships between features in the model

construction documents The working drawings, schedules, and specifications required to construct a building. Also referred to as CDs.

containment Cable transport mechanisms, such as trays, trunking, ladders, and baskets.

content User-definable, pre-configured elements provided to aid you in getting started on a project. Examples of supplied content are templates, styles, and symbols. See also design content.

Content Builder A utility tool that enables you to create custom parts, such as fittings and equipment, that can be used in your building systems layouts.

context menu The menu displayed at the cursor location when you right-click your pointing device. The context menu and the options it provides depend on the cursor location and other conditions, such as whether an object is selected or a command is in progress.

continuous load An electrical load where the maximum current is expected to continue for 3 hours or more.

coupling A joint type used to join 2 pipes together. Couplings are typically used for threaded, socket weld, grooved, or glued type piping. The depth of the connection is defined by the CEL value. See also connection engagement length (CEL).

current The flow of electricity in a circuit.

curve The centerline of the geometry along which objects are built.

curve anchor A feature that fastens, or anchors, an object to the base curve of another object. The movement of the anchored object is constrained by the object to which it is anchored.

cut height Elevation for cut plane in the floor plan; breaking level for the Low and High display components

cut plane The height at which an object is cut to produce the plan representation; settings for defining elevations for a floor plan (Display Above Range, Cut Height and Display Below Range)

cutout (1) A cut in a panel or beam used to insert a fixture.

cutout (2) A switch used to cut off the flow of electricity to a circuit.

damper An adjustable plate used to control air flow.

DDXML For Duct Design Extensible Markup Language. An XML format designed to store and transfer design specifications for ductwork.

default A predefined value for program input or parameters. Default values and options for commands are denoted by angle brackets (<>).
**definition** symbol conversion script  A Custom Content File (CCF) file that contains the settings for schematic symbol styles. For more information, see Converting Schematic Symbol Styles to Blocks on page 630.

**degree of freedom**  In part modeling, determines how a geometric object such as a line, arc, or circle can change shape or size. For example, a circle has 2 degrees of freedom: center and radius. When these values are known, degrees of freedom are said to be eliminated.

**demand factor**  For an electrical system or feeder circuit, this is a ratio of the amount of connected load (in kva or amperes) that will operate simultaneously to the total connected load on the circuit. An 80% demand factor, for instance, indicates that only 80% of the connected load on a circuit will ever be operating at the same time.

**design content**  AutoCAD MEP objects that represent real-world parts used to create complete building systems layouts. Examples include duct, pipe, fittings, and equipment.

**design criteria**  Includes information such as the type of design, maximum velocity or load, space requirements, or material specifications.

**design development phase**  The phase during which the conceptual design is developed into the complete building model.

**designation ID**  An optional number or string of characters that you assign to a schematic line. The designation can also be used to group schematic lines for scheduling purposes.

**DesignCenter™**  A display window, similar to the standard Windows® Explorer, in which you use selection aids to find, manipulate, and sort drawings and drawing components. DesignCenter contains hierarchical tree, palette, preview, and description panes. Content can be dragged from the palette into an open drawing.

**detail marks**  Annotation that references another drawing, which contains a detail of the original drawing.

**developed length**  The length of your longest pipe run, including the equivalent length of the fittings.

**device conversion script**  A Custom Content File (CCF) file that contains the settings for devices styles. For more information, see Converting Device Styles to Blocks on page 620.

**diameter**  The length of a straight line through the center of a part.

**diaphragm**  A thin partition or dividing membrane.

**dimension (1)**  Annotation of the size description of an object or group of objects. Typically specifies the associated linear distances, angles, or size-related notes.

**dimension (2)**  In Content Builder, an entity that controls the size of a feature. When changed, the feature is resized. Might be expressed as a constant value, a value as part of a table, a calculated value, or a list of values.

**direct current (DC)**  An electrical current that flows in one direction only.

**direction dependent**  A condition where the display of an object is dependent on the view direction.

**display above range**  Elevation for top of the floor plan; breaking level for the High and Above display components.

**display below range**  Elevation for bottom of the floor plan; breaking level for the Low and Below display components.

**display by elevation**  A feature that allows users to configure the display of objects based on their elevation; uses cut plane height settings to determine if an object is above or below the display range.

**display configuration**  The arrangement of objects in individual viewports. Display configurations can be fixed view or direction-dependent view. Each display configuration has one or more display representation sets associated with it.

**Display Manager**  A central location for all display information in a drawing.
**display properties** Display properties affect the way an object appears in the drawing. You can override the default properties for the current display configuration by changing visibility, layer, color, linetype, hatching, and cut plane height for an object.

**display range** Range of elevation above and below the cut plane

**display representation** A level of display control in which the user can specify settings such as layer, color, linetype, and visibility for individual components of objects.

**display set** A saved set of display representations, which can be associated with a display configuration. See also display configuration and display representation.

**documentation** Any output records of a building project, consisting of working drawings, specifications, schedules, and other information pertaining to the building.

**documentation phase** The phase of a project in which annotation is added to drawings to clarify and record design specifications as well as to reference together the complete set of construction documents. See also annotation.

**documentation symbols** See annotation.

**domain** In Content Builder a family defined by a set of common characteristics within a specified engineering industry. A fixed list of part groups, where each group is based on one type of building systems component, such as duct, pipe, cable tray, conduit, plumbing, or MvPart. Each group has a unique behavior in AutoCAD MEP according to component type.

**downstream fixture units** The calculated value of all connected fixtures.

**drag point** The point that an AutoCAD block rotates around. Also referred to as the block’s insertion point.

**draw** The amount of current required to operate an electrical device. See also amperage.

**drawing area** The area on screen in which your drawings are displayed and modified. The size of the drawing area varies, depending on the size of the AutoCAD window and on the number of toolbars and other elements that are displayed.

**drawing environment settings** The variables and settings for new drawings as defined by the default template drawing. See also template.

**drop (voltage)** The net difference in electromotive force when measured on both sides of impedance.

**duct** A pipe or closed conduit, made of sheet metal, fiberglass board, or other suitable material, used for distributing air to and from a supply source, such as an air handling unit.

**duct and pipe length** The actual length of a duct and pipe segment. You can break segments or an entire run into several segments.

**duct fan** A piece of equipment mounted in a section of duct to move conditioned air.

**duplex receptacle** A commonly used receptacle (outlet) that has 2 plug-in sockets; typical wall outlet.

**DWG** Standard file format for saving vector graphics from within AutoCAD.

**DWT** Standard file format for AutoCAD template files. See also template.

**edge offset** The distance from the face of a component to a specific baseline.

**elbow** An angled fitting that changes the direction of a run. Typical angles are from 22 ½ degrees to 90 degrees.

**elbow angle** The radius to use when laying out ducts, pipes, conduits, and cable trays using the Routing layout method.

**elevation (1)** The default Z value above or below the XY plane of the current user coordinate system; used for entering coordinates and specifying locations.
**elevation** (2) The vertical distance between the level where fluid enters a pipe and the level where it leaves.

**elevation** (3) An orthographic projection of a building model. See also model.

**elevation difference** The difference between the selected pipe and the highest fixture, also known as the limiting fixture.

**elevation labels** Annotation used to dimension height values in plan and section views. See also annotation symbols.

**elevation marks** Annotation used to designate where source objects are being cut to generate an elevation view.

**end-of-line symbol** An AutoCAD block that typically appears at the start or end of a schematic line and is not anchored to the schematic line.

**engineering data** Design specifications assigned to spaces, zones, and ductwork.

**engineering properties** Energy requirements assigned to spaces and zones. These calculations are derived from analysis by an external tool, and then imported into the drawing and assigned to the appropriate zones.

**entity reference (entref)** An object that makes a reference to another object and updates dynamically if the referenced object is altered. Entity references are similar to blocks, except that their definitions must remain as objects in the drawing editor.

**explode** The conversion of a complex object, such as a block, into its basic objects, such as lines and circles.

**external reference (xref)** A drawing that is linked to another drawing.

**fabrication** The process of manufacturing duct fittings or assembling pipe spool sections.

**feature** In Content Builder a building block of a parametric part model. You combine features to create parametric models.

**feeder** A circuit, such as conductors in conduit or a busway run, that typically provides a high current carrying capacity (larger than branch circuits).

**fitting** Any type of connector used to join 2 or more individual segments, for example, a tee and an elbow.

**fixture** (1) Any electrical device that consumes power.

**fixture** (2) A device (sink, tub, toilet) that either provides or disposes of a supply of water.

**fixture tag** A type of annotation that links property set information to schedule tables for fixtures, such as toilets and sinks.

**fixture unit** The design factor used to determine the load-producing value of various plumbing fixtures.

**flange** A plate or flat ring bolted to the projecting collar at the end of a segment of pipe to close the end or connect it to another segment. A joint type that mates with another flange to connect pipes, fittings, or equipment.

**flange face** The mating surface of a flange that makes contact with the mating flange to complete a connection.

**flat riser diagram** Orthographic riser diagrams are also referred to as flat riser diagrams. See also orthographic riser diagram.

**flexible** A flexible segment used, for example, to connect a segment to a part. Different patterns can be applied to display the flexible segments.

**float** A ball, connected to the ballcock in a tank, that rises or falls when the water level in the tank changes, and actuates or shuts off the ballcock.

**Floating Viewer** A separate window on screen that displays objects with orbit commands. See also orbit.
floating viewports Boundaries created in paper space that display views. See also paper space.

floor drain A pipe or channel to remove water from under a floor in contact with soil.

flow arrow Annotation used to graphically show the direction that fluid, such as water, travels through a pipe or series of pipes. Typically indicated by an arrowhead in the line representing the pipe(s).

flow diagram A symbolic drawing, typically a 2D plan, that shows the logic and operation of a building system.

flow direction The direction in which a volume of fluid moves.

flow pressure The pressure within the water supply pipe by the faucet or water outlet while water is flowing.

flow rate The volume of fluid that passes through a pipe in a specified period of time.

flush valve A valve used for flushing toilets.

forced-air system A type of heating system in which heated air is blown by a fan through ducts to rooms.

free-standing symbol An AutoCAD block that is inserted into a drawing without connecting it to other objects or anchoring it to a schematic line.

fuses Replaceable safety devices used to protect an electric circuit from excessive current.

gas meter An instrument for measuring and recording the amount of gas flowing through a pipe.

gathering The tapered section of flue duct or air duct that forms a transition between the duct passage and the flue.

gauge The thickness of the material of a part.

gbXML For Green Building Extensible Markup Language. This XML format is designed to store and transfer building information in CAD drawings. gbXML is used to store space and zone data, and can be used in external analysis tools to determine energy requirements.

GFCI (GFI) For Ground Fault Circuit Interrupter. A type of circuit breaker or receptacle device (commonly required in kitchens and bathrooms) that helps to safeguard against shocks.

glued connection A type of permanent pipe connection used to join individual pipe segments; involves applying a watertight adhesive to the pipe segments.

governor A device that gives automatic control of temperature or pressure.

grids AEC objects on which you can anchor other objects, such as columns, to constrain their locations.

grips Control points used to modify objects such as spaces, schematic symbols, and duct segments.

grooved connection A type of detachable pipe connection used to join individual pipe segments. The pipe segments have male or female grooved ends to create a watertight joint.

ground (1) The endpoint for a current.

ground (2) A large conducting body (as the earth) used as a common return for an electrical circuit in order to prevent the buildup of voltages that may result in hazards to connected equipment or to persons.

grounded conductor Also referred to as the neutral conductor. The return path for current in a normal (non-faulted) electrical system.

grounding conductor Also referred to as the safety ground or equipment ground. Removes the potential for electrical shock of persons in contact with energized metal parts due to a ground fault.

hand wheel A wheel, such as a valve wheel, that is turned by hand.

handle A unique alphanumeric tag for an object in the AutoCAD database.
**hidden line** Portions of an AutoCAD MEP object that can be displayed with a user-definable linetype when obscured by an object at a higher elevation. For example, a hidden line can be shown as dashed.

**home run** The wire segment connecting the end of a circuit to the associated electrical panel. Typically, an arrow is used to represent the direction of the panel’s location on an electrical drawing.

**hose bib (1)** A water faucet to which a hose may be attached.

**hose bib (2)** A valve with an external threaded outlet for accepting a hose fitting.

**hot wire** A common type of circuit wire. Hot wire brings the power from the source to a panel or device.

**HVAC** For Heating, Ventilation, Air Conditioning.

**I.D.** For inside diameter.

**ID** For identification. A number or string of characters that you can assign to symbols. The ID can also be used to group symbols for scheduling.

**in-line symbol** An AutoCAD block that can be anchored anywhere along a schematic line.

**instant sizing** A tool used to calculate an object size as you draw it. There are instant sizing tools for ductwork and wiring.

**insulation thickness** The thickness of insulation added to the outside of a part.

**invert** The part of the interior of a drain or a sewer pipe where the liquid is deepest.

**invert elevation** The elevation of the lowest point along the inner diameter of the end of a pipe.

**invert elevation calculation** The invert elevation determined by the resulting value of a mathematical equation. Typically, the invert elevation of one end of a pipe (A), the slope (B), and the horizontal length (C) are known, and a mathematical equation is used to determine the invert elevation of the other end of the pipe (D). For example, if A is higher in elevation than D, the following equation is used: A2(B3C)5D.

**isometric** A drawing or view in which the X, Y, and Z axes are spaced 120 degrees apart and the Z axis is projected vertically.

**isometric line** A line that represents pressure or temperature changes under conditions of constant volume.

**isometric riser** The vertical segments included in an isometric drawing or view. See also isometric.

**isometric riser diagram** The most common riser diagram for plumbing; provides a 3D representation of the plumbing system in a 2D drawing. Generally not drawn to scale, but shown to be correctly proportioned. In other words, a long run of piping in the plumbing plan is shown as a long run of piping in the riser diagram. Includes symbols for the piping and fittings.

**isometric snap** An AutoCAD drafting option that aligns the cursor with 2 of the 3 isometric axes and displays grid points, making isometric drawings easier to create.

**isometric symbol style** Default symbol properties, such as appearance or connection cleanup type, that are assigned to a specific symbol or a group of symbols in an isometric drawing or view. See also isometric.

**isometric symbols** Symbols used to represent components or equipment within a plumbing system included in an isometric drawing or view. See also isometric.

**isoplane** AutoCAD Architecture command that specifies the current isometric plane (left, top, right).

**joint** A method for attaching pipe segments to each other, to fittings, or to equipment such as flanges, couplings, or butt welds.

**junction box** A plastic or metal box used to protect wire connections. Typically, the boxes are fastened to the structural framing, and devices such as receptacles and switches are attached to the boxes.

**justification** The drag point for AutoCAD symbols. See also drag point and justification/offset.
justification/offset A value used to determine the orientation of a segment relative to its centerline for layout.

kickpipe A short pipe that guards an electrical wire or cable.

kilowatt (kW) A standard unit of electrical power equal to 1,000 watts. A kilowatt hour (kWh) is the amount of energy used in one hour of operation for a piece of equipment that has a continuous power usage of 1kW. A kilowatt-hour is equivalent to 3,412 BTU.

kilowatt hour (kWh) The amount of energy used in one hour of operation for a piece of equipment that has a continuous power usage of 1kW. A kilowatt hour is equivalent to 3,412 BTU.

label curve An imaginary curve on which text characters appear to rest.

labels Annotation used to display object or part information in a drawing, such as text, block definition, and dimensions.

lateral A pipe branching away from the central, primary part of the system, especially in a gas distribution or transmission system.

layer A logical grouping of data equivalent to transparent overlays in manual drafting. Layers can be viewed individually or in combination.

layer key style A set of layer keys with their associated layer names. See also layer keying.

layer keying A method of placing objects in a specific layer as they are drawn. A particular layer key can be assigned to any predefined layer name.

layer management tools Tools to help organize, sort, and group layers, as well as to save and coordinate layering schemes.

Layer Manager The central location for all layer information in a drawing.

layer standard A predefined list of layer names or layer group names, and a set of rules for determining how new layer names are created.

layout curve A linear grid that attaches node points to an object with a base curve, for example, polylines.

layout mode A setting by which the nodes in a grid can be spaced evenly, repeatedly, or manually.

layout tabs A tool to switch between model space, where you spend most of your time creating and editing drawings, and other pre-configured page setups.

lead A short length of wire that hangs free in a box or service panel.

leader A line that visually connects annotations to a drawing object.

length A unit of measurement for distance.

lever (1) A rigid bar that transmits and changes force or motion when force is applied at 2 points and it turns about a third point.

lever (2) A projecting piece by which a mechanism is adjusted.

lighting circuit A 15-amp or 20-amp circuit that powers the lighting in a designated area.

line annotation Line annotation (1 or 2 line annotation) is the type of graphic representation used to represent cable trays. You can select from a list of predefined graphical types.

line cleanup (design rules) Refers to the process of trimming or extending pipe segments or components in order to show connected objects. Design rules define the automatic process that takes place when objects are added together.

lining thickness The thickness of lining added to the inside of a part.

load The amount of electrical power used by equipment or a circuit as it performs its function.
load diagram A symbolic drawing, typically a 2D plan, that shows the layout of an electrical system.

main run See also trunk.

match lines Annotation referencing another drawing that contains additional sections of a model. For example, a plan view of a building with the east side of the building in one drawing and the west side in another drawing would have a match line on each drawing to show where the building was split.

material The substance that a part is made of, such as plastic, metal, or steel.

model (1) A 2D or 3D representation of one or more objects.

model (2) In Content Builder the parametric shape representing all possible sizes, and defined by parameters, geometry, dimensions, and geometric constraints.

model space One of 2 primary spaces in which objects reside. Typically, a building model is placed in a 3D coordinate space called model space. A final layout of specific views and annotations of this model is placed in paper space. See also paper space.

module An assembly of self-contained, interconnected components that constitutes an identifiable device, instrument, or piece of equipment.

MvBlock For multi-view block. A type of block that can contain multiple AutoCAD blocks set to display differently in different views.

MvPart For multi-view part. An MvPart is a multi-view block with smart connectors. They include parts such as access doors, coils, fans, filters, and pumps. See also MvBlock.

N.D. For nominal diameter.

name A character string used to identify a part. The name is predefined for parts from the catalog and content, such as schematic symbols, and is user-defined for custom parts you create, such as MvParts.

network A group of interconnected building system runs.

neutral wire A common type of circuit wire. The neutral wire returns power from a panel or device to the source. The neutral wire is connected at the main service panel. See also grounded conductor.

node anchor A feature that fastens, or anchors, an object to the node position of an object. The movement of an anchored object is constrained by the other object. See also cell anchor.

nodes (1) An object snap specification to locate points, dimension definition points, and dimension text origins.

nodes (2) Points to which an AEC object can be attached, controlling the position and rotation of the object.

nominal size Approximate dimensions of a part for ease of identification. For example, a pipe or conduit may be referred to as 1/4 inch, although the actual dimension on the drawing is 0.2495 inch. Therefore, the nominal size is 1/4 inch.

north arrow A graphical symbol used to designate the north direction in space on a site plan or other plan view drawing.

O.D. For outside diameter.

object A collection of one or more graphical elements, such as lines, circles, polylines, text, or dimensions, treated as a single element for creation, manipulation, and modification.

object anchor See also anchor.

Object Enabler See also AEC Object Enabler.

object snaps Methods for selecting commonly needed points on an object while you create or edit AutoCAD drawing. See also snaps.
object type  See type.

Object Viewer  A separate window that can display any drawing objects. You can manipulate and view the objects with orbit commands. See also orbit.

off center  A setting that provides the ability to connect takeoffs at any location within a duct segment.

off-the-shelf parts  Regularly manufactured parts typically found in stock and commonly used in the building industry.

offset  See justification/offset.

ohm  A unit of measurement of electrical impedance; one ohm equals one volt per ampere.

open circuit  Any break or lack of contact in an electrical circuit, either intentional (switch) or unintentional (bad connection). See also circuit.

opening symbol  Annotation used to designate the need for an opening in a structural component, such as an opening in a load bearing wall for duct work. See also annotation.

orbit  To navigate an object in a graphics display window, such as the Floating Viewer or Object Viewer, with user-selected view geometry rotating around a center axis. Using 3D orbit, the user can inspect the object in real time. See also 3D orbit viewing, Floating Viewer, and Object Viewer.

orthogonal  Having perpendicular slopes or tangents at the point of intersection.

orthographic projection  The flat-projected 2D representation of a 3D object or model. Typically consists of the top, front, and side views of an object or model.

orthographic riser diagram  Also called flat riser diagram. Less often used in construction drawings, it shows the plumbing system in elevation. Used for buildings of 2 or more stories that may require more than one orthographic riser diagram to clearly describe the entire plumbing system.

over current  Any current in excess of the rated current of equipment or circuit. It may result from overload, short circuit, or ground fault.

overload  Load greater than the load for which the system or mechanism was intended. A fault, such as a short circuit or ground fault, is not an overload.

package unit  A year-round heating and air conditioning system that has all the components encased in one unit, typically outside the building.

panel (1)  A cabinet, typically wall-mounted, that serves as a switchboard or control board, including elements such as automatic overcurrent devices, switches for light, heat or power control, and buses.

panel (2)  The name used to identify a panel when creating circuits.

panel rating  The ampere rating of an electrical panel.

panelboard  A single panel or group of panel units designed for assembly in the form of a single panel. See also panel.

paper space  One of 2 primary spaces in which objects reside. Paper space is used for creating a finished layout for printing or plotting, as opposed to doing drafting or design work. Model space is used for creating your model. See also model space.

parameters  Specific part properties, such as height and width, that are required to generate a part.

parametric  In Content Builder a solution method that uses the values of part parameters to determine the geometric configuration of the part.

part catalog  A collection of common industry-specific, real-world parts that you can select to integrate into your building systems designs.

part properties  Specific details or traits of an individual building systems part.
part size In Content Builder a specific set of values applied to the parametric model to define a single size.

part size name The default name of a part stored in the part catalog and used when selecting parts during layout.

path angle In Content Builder, defines the sweep (angle direction) that the software uses to ensure that the 3D part is built correctly. Path Angle is a default setting that appears as PathA1, PathA2, etc.

perspectives 3-dimensional views of a model that apply the principle that objects appear smaller when they are farther away, resulting in a true-to-life representation of the model. Perspective views are generated using the AEC camera commands.

phase type The type of electrical power, 1-phase or 3-phase.

pigtail A short piece of wire used to extend or connect wires in a junction box.

plan view A view of a drawing from above, looking down the Z axis and perpendicular to the XY plane of the current UCS.

plenum The area where the ductwork connects to a furnace unit. Often containing the evaporator coil—the main indoor component of the air conditioning system.

plumbing fitting A plumbing component, such as an elbow, tee, union, or coupling, for connecting individual pipe segments.

pneumatic Operated by air or by the pressure of air.

pressure A type of stress that is exerted uniformly in all directions; its measure is the force exerted per unit area.

pressure drop The pressure drop displays the loss of pressure between the limiting fixture and the source.

pressure-reduction valve Used at the point where water comes into the house, in order to eliminate or reduce the pressure that causes water hammer.

primitive A limited version of a part model that is designed for repeated use in part creation. A primitive can represent a basic shape, such as a box, or a connection on a part, such as a flanged pipe connector.

prompt A message on the command line that asks for information or requests an action by the user.

quick select A sorting filter used to separate selected objects by property (such as layer) or by object type.

quick slice A plane generated from 2 selected points and an entity used to slice through an AEC object. The resulting profile becomes a polyline that is added to the current layer. See also slice.

raceway A routing system used to run electrical wires around a building.

radius of curvature The radius of a bend.

reducer A fitting that connects different size segments together.

regenerate (2) To step through a part catalog structure and validate all parts.

regenerate (regen) (1) To update the screen display of a drawing by recomputing the screen coordinates from the database.

register An assembly of parts, typically a grille and damper, that covers an air opening or end of an air duct.

representation sets See display representation set.

return air Air drawn into an air handling unit after having been circulated through an air system, such as a heating or cooling system.

return duct The duct run through which air is drawn after having been circulated through a building or room.
reverse flow The changing of direction of the fluid, such as water, that travels through a pipe or series of pipes.

revision clouds A cloud-like boundary used to designate changes made to the final construction drawings.

rise/run The pitch of an inclined segment, usually expressed as the ratio of the vertical rise to the horizontal run. Rise is the vertical difference in elevation from end to end of the segment. Run is the horizontal distance covered by the segment. Also referred to as slope.

riser (1) A vertical assembly of pipe segments and fittings that distributes a fluid such as water in an upward direction, typically between floors.

riser (2) A vertical assembly of piping that connects a faucet to the water supply stop valve. See also component.

riser diagram See isometric riser diagram and orthographic riser diagram.

riser objects The common symbols used in a riser diagram: drop, riser, tee up, tee down, drop and run, drop and turn, tee off top, tee off bottom, cross and riser, plan elbow, and plan tee.

routing Minimizes the number of steps when completing a layout. It calculates the position of the elbow while drawing the next segment with a specific angle.

run (1) An assembly of building system components that is used to carry air or water from one point, such as an air terminal or a pump, to another point, such as the junction of another run. See also component.

run (2) A portion of a pipe or fitting lying in a straight line in the same direction of flow as the pipe to which it is connected.

sampling circuit A circuit whose output is a sampling of the values of the input at a series of points in time.

sand filter A filter consisting of graded layers of sand and aggregate for purifying domestic water.

sanitary A gravity drain system that requires piping to slope at a specific angle so that fluid drains properly. The US standard for angles is typically a specific distance over one foot, i.e., 1/4 inch/1 foot.

schedule A tabulation of data extracted from objects in the drawing. Used to create bill of materials, panel loads, and related tabulations.

schedule table The tabular representation of schedule data extracted from the drawing, formatted according to rules set in a schedule table style.

schedule tag A unique annotation tag linked to a drawing object by a schedule anchor for the purpose of extracting schedule data and displaying it in the drawing.

scheduling The process of producing graphical tables showing details of the materials required to purchase and build the system. For example, a panel schedule is a table listing all the circuits and components associated with a specific panel in a building structure.

schematic A not-to-scale 2D drawing or view, used to show the logic or flow of a plumbing system. Schematic design is the initial design phase of a building project and usually includes the general arrangement of equipment and basic system layout.

schematic design phase Initial design phase of a building project. Also referred to as conceptual or preliminary design.

section (1) A representation of an object as it would appear if cut by an imaginary plane, showing the internal structure.

section (2) A representation of a building, or portion thereof, drawn as if it were cut vertically to show the interior.

section (3) An orthographic projection of a model.
section marks Annotation used to designate where source objects are being cut to generate a section view.

segment An individual piece of ductwork or piping connected together by fittings to create a run. Typically, a straight piece of duct or pipe cut to a standard length determined by the design and/or manufacturer.

segment mode The layout method for flex duct or flex pipe. You can specify Line mode, Arc mode, or Spline mode.

service disconnect A switch that enables a person to shut off power to the building (normally used for maintenance or in emergency situations).

service drop Run of cables from the power company’s aerial power lines to the point of connection in the building.

service entrance The location where the incoming power supply enters the building.

service equipment The necessary equipment, usually consisting of a circuit breaker or switch and fuses and their accessories, located near the service entrance to a building and intended to act as the main control and cutoff means for the power supply to the building.

service lateral The underground service lines between the street main, including any risers at a pole or other structure or from transformers, and the first point of connection to the service-entrance lines into a building.

service panel The main electrical panel where all the circuits tie into the incoming power supply.

service/supply leads The incoming electrical lines that supply power to the service panel.

sewage pump A machine used to exhaust waste matter.

shape The actual shape, such as rectangular, oval, or round, of a segment or fitting. Shape defines which part catalog to use during layout.

single pole A switch that controls a device from one location.

single-line drawing A plan view drawing that uses a single line to show the plumbing system and describes the basic function of the system. The centerline of the pipe, regardless of pipe size, is drawn as a single line to which valve, equipment, and fixture symbols are added. The size of the symbols is left to the discretion of the drafter.

size The actual dimensions of a part, including length, width, height, and diameter.

slice An object representing a horizontal section, or slice, through any collection of AEC objects. See also quick slice.

slope The pitch of an inclined segment, usually expressed as a ratio of the vertical rise to the horizontal run of a pipe segment. Slope is commonly expressed in a fractional format, 1/4 inch/1 foot or 1/10.

slope arrow labels Arrows used as annotation to specify the slope of a pipe segment. See also slope.

slots The spaces to install circuit breakers in an electrical panel (also referred to as “poles”).

snap angle The angle around which the snap grid is rotated. See also snap grid and snap mode.

snap grid An invisible grid that locks the cursor into a specific alignment and snap increment when Snap mode is enabled. Snap grid does not necessarily correspond to the visible grid, which is controlled separately by the GRID command. See also snap angle and snap mode.

snap mode A drawing mode where the cursor is locked into alignment with an invisible grid, forcing the cursor to snap to the nearest point on the grid. See also snap angle and snap grid.

snaps Object methods for selecting commonly needed points on an object while you create or edit a building systems layout. Snaps in AutoCAD MEP are accurate snap points of connection for building systems components. See also object snaps.
socket weld A joining method where a pipe is inserted into a socket of a coupling, fitting, or equipment nozzle. The pipe is then welded in the socket. This method is similar to that of a solder joint for tubing. The depth of the connector is defined by the connection engagement length value. See also connection engagement length (CEL).

socket welded Threaded metal pieces twisted together and then fused at the socket.

solution tip A tooltip that displays when you hover the cursor over a solution tip icon, and describes a potential problem and suggested solution for an invalid connection between two objects.

space A tool used to model the interior space and heat transfer elements in a room. The space also stores engineering data, such as design temperatures and air flow requirements. The information for spaces is analyzed to determine energy requirements for a building.

spatial interferences When 2 parts intersect or collide in an undesirable way. Hard interferences refer to interferences created by parts that collide with each other, creating a physically impossible design situation, such as a pipe running through a duct. Soft interferences refer to interferences that impact design considerations, such as space allocations, type of material, amount of insulation, and access methods.

spigot/plain end A mating pipe or fitting that is inserted into a female coupling

spline A blended piecewise polynomial curve passing near a given set of control points. A flex duct can be drawn as a spline.

Style Manager Style Manager provides a central location where you can work with styles from multiple drawings and templates.

style name A name used to identify part styles. See also styles.

styles A group of preset characteristics assigned to an object that determine appearance and function.

subtype Additional characteristics of a part's type.

supply air Air produced from an air handling unit that is used to heat or cool a building or room.

supply duct The duct run that air flows through to distribute air to a building or room.

switch A device used to control the distribution of power.

switch-leg The part of a circuit run from a lighting outlet box where a fixture is installed to an outlet box containing the wall switch that turns the light or other load on or off; control leg of the branch circuit.

symbol library A collection of block definitions stored in a single AutoCAD drawing file.

system An optional property used to group parts based on real-world building systems.

system abbreviation A string of characters used to represent the system name. The system abbreviation is used for labeling and scheduling.

system group The name of the group associated with a part's system definition. System groups are used to associate or group together multiple systems.

system label Annotation used for managing system type abbreviations for labeling.

tangent The angle of a curve.

tankless water heater A system by which water is heated as it flows through heating elements or a heat exchanger, not first stored in a tank.

tee A T-shaped fitting that is used to create branch runs.

template A prototype drawing with predefined settings, borders, and layout tabs that can be used as the basis for creating a new drawing.
terminal A device, typically located in a branch duct, that dispenses or removes air from the duct system to control the temperature and/or quality of the air.

therm A unit of measurement for heat. One therm equals 100,000 BTU.

thickness gauge See gauge.

threaded A joining method where a pipe is prepared with a male threaded end. The pipe is then inserted and screwed into a female threaded coupling, fitting, or equipment nozzle.

title marks Annotation that identifies a drawing.

ton A unit of measurement for capacity. Heat pumps and air conditioners are generally sized in tons. Each ton equals 12,000 BTU. It is important to note that actual capacity is not constant; it changes according to outdoor or indoor temperatures.

tooltips Tooltips display a description when you hover the cursor over items such as toolbars and icons.

transition fitting See reducer.

trip lever The handle that is rotated to initiate the toilet flush cycle.

trunk The primary duct from which secondary runs branch; typically, the largest duct of the system.

type A part’s object type, such as duct or pipe, each with unique characteristics and behaviors.

unconstrained layout Drawing pipe between an object to a point in space

UV filter system A system in which water is sterilized in an ultraviolet chamber, where UV rays purify the water by killing micro-organisms.

VA (volt-ampere) A unit of measurement for the product of voltage and amperage delivered to a device (VA=V*A).

vanes (1) Stationary plates inside a duct used to control air flow.

vanes (2) In building systems, vanes indicate whether an individual duct fitting contains turning vanes. Turning vanes are mounted into fittings to reduce pressure loss. To display the turning vanes in plan view, they must be added to the fittings style using the Add Vane command.

vertex A vertex is a location where spline segments meet. It is also the location of the grip points in a spline.

vertex X The X coordinate location of a pipe segment or component on an XY axis.

vertex Y The Y coordinate location of a pipe segment or component on an XY axis.

view A graphical representation of a model from a specific location in space.

viewport A bounded area that displays some portion of the model space of a drawing. The TILEMODE system variable determines the type of viewport created.

■ When TILEMODE is off (0), viewports are objects that can be moved and resized.

■ When TILEMODE is on (1), the entire drawing area is divided into non-overlapping viewports.

volt A unit of measurement for the amount of electromotive force that causes current to flow.

voltage The number of volts present at a specific point in an electrical system.

water filter A system that provides water purification.

water hammer A pounding or knocking sound in water pipes, resulting from a sudden change in the pressure when a faucet is turned off.

water hammer arrestor A piece that absorbs the extra pressure that causes water hammer in domestic use when the problem involves only a few fixtures.
**water meter** An instrument for measuring the amount of water passing a specified point in a piping system.

**water softener** A system that replaces calcium and magnesium ions in hard water with sodium ions.

**watt** A unit of measurement for the amount of real electrical power consumed by a device. A watt is the mathematical product of amperes, volts, and power factor \((W=\text{A*V*PF})\). For example, \(1/2\) amp of current at 120 volts and a power factor of 1 will power a 60-watt bulb.

**WCS** For World Coordinate System. The coordinate system used as the basis for defining all objects and other coordinate systems.

**width and height** The horizontal and vertical measurements taken at right angles to the length. Width and height determine the actual dimensions of a part.

**wire** One or more long, slender strands of drawn conductive metal, either bare or covered with insulation.

**work plane** An infinite plane related to one or more features of the model. Work planes provide a defined place in space from which to build the model.

**workflow** The general flow process of designing a building system or other design project. Typically includes multiple phases.

**wye** A Y-shaped fitting used to create branch runs.

**xref** See external reference.

**XY angle** The actual angle of the segment that is a result of the rise/run values. See also rise/run and slope.

**zone** The occupied space or group of spaces within a building that has its heating and/or cooling controlled by a single thermostat.

In the software, a zone is a group of spaces that model an actual heating and cooling zone in a building. The data associated with a zone is exported in gbXML format, and analyzed to determine energy requirements.
Appendix - Reference Information

Definitions of Part Properties

The following definitions of part properties are listed alphabetically and include a brief description of how the properties are used in designing building systems.

Adjacent Surface A physical wall shared by 2 engineering space surfaces. Specifying adjacent surfaces helps ensure accurate load calculations.

Calculated Size The actual size of a pipe based on a calculated value that is the result of pipe sizing calculations for a plumbing system.

Capacity The air flow used to calculate duct sizes using the instant sizing tool. Capacity is automatically calculated for systems with defined outlet devices, and it can also be manually specified.

Circuit A collection of electrically connected devices or components. Circuits are used to show how electrical equipment is connected to upstream panels.

Circuit Breaker Rating This value provides information found in a panel schedule. It is a property for Power and Lighting circuits only and is not to be confused with the rating associated with the panel.

Circuit Description Circuit description gives distinguishing information about a circuit on a panel schedule. It is a property common to all system types. This property can be modified in Circuit Manager.

Circuit Length Circuit length is a rough estimate of the total length of the circuit based on where the devices are placed in the drawing. Circuit length is a read-only property and it changes as devices are added or moved on each circuit.

Circuit Name Circuit name identifies the circuit based on the circuit naming strategy specified in electrical preferences. It is a property common to all system types. This property can be modified in Circuit Manager.

Circuit Voltage Circuit voltage is the voltage on a circuit that contains the system type Power and Lighting. The voltage is defined as a Voltage Definition. All devices connected to the circuit must have a voltage in the range of the voltage definition. See also Voltage.

Connection Type Connection type is a property on ducts, pipes, conduits, and cable trays that describes how the segments are mounted together. Normally, the connection type must match to form a valid connection between segments. This is defined in connector styles.

Cooling Loads The amount of conditioned air required to cool a room or a zone based on engineering space analysis. The cooling load is displayed in the Engineering Properties dialog.

Default Surface Height Overall height for an engineering space, including ceiling thickness and any space above the ceiling.
Demand Factor Demand factor is a value used for calculating the estimated demand load of a circuit or device. The value is defined with a style name, and the name is what displays in Circuit Manager and on Power and Lighting connectors. It is a property for Power and Lighting system types only. The value of the definition can be modified using the demand factor style. A demand factor specified on a connector always overrides the circuit demand factor. See also Estimated Demand Load.

Description You can specify a unique description for a part that gives distinguishing information about that part.

Designation ID The designation is an optional number or string of characters that you assign to the schematic line. The designation can also be used to group schematic lines for scheduling purposes.

Diameter You can specify a diameter for parts or select a diameter from the list of available sizes from the part catalogs. Diameter determines the actual size of the part to use during layout. Use an undefined diameter for conceptual layouts when no part or design details are known. You can change the diameter for specific segments or an entire building systems network.

Elbow Angle The elbow angle allows you to specify which radius to use when laying out ducts, pipes, conduits, and cable trays using the layout method “Routing.”

Elevation Elevations ensure that you insert a series of parts at the same height. The elevation of a part is used to determine its position in model view, including rises and drops. In plan view, parts are always inserted using the current drawing elevation. You can lay out rises or drops in plan view by entering a new elevation. You can also choose to rise or drop the segment with a specific angle. You can specify an elevation for a building systems network or select one from the list of predefined elevations in the drawing. For fittings, the elevation is assigned by the connecting part segments. For MvParts, the elevation is used to determine the default system connection points. For wire, the elevation is used for calculating circuit lengths for panel scheduling. For plumbing lines, the elevation is used for calculating pipe size.

Engineering Data Design specifications for engineering spaces that are used to calculate energy requirements for rooms and zones. Engineering data consists of air flow requirements and calculations, heating and cooling design temperatures, and heat gain and loss contributors.

Engineering Properties Engineering properties for an engineering space contain calculated values for heating loads, cooling loads, and air flow requirements. Engineering properties are assigned to an engineering space using the Import gbXML command.

Estimated Demand Load Estimated demand load displays the calculated load based on the demand factor definition used for a circuit or device. It is a property for Power and Lighting circuits only. This property changes if the demand factor of the circuit is modified or if the circuit load is modified. See Demand Factor.

Gauge You can specify a gauge for piping by selecting one from the list of available pipe schedules. The pipe schedule defines which AutoCAD MEP catalog to use during layout. You can change the gauge for specific pipe segments or an entire piping network.

Heating Load The amount of heating units required to heat a room or zone based on engineering space analysis. The heating load is displayed in the Engineering Properties dialog.

Home Run You can add a home run arrow to the end of a circuit run, in the direction of the associated panel. Home run is a read-only property that indicates whether a home run has been specified for the wire by a yes or no value.

ID ID is an optional number or string of characters that you can assign to schematic symbols, devices, and panels. The ID can also be used to group schematic symbols, devices, or panels for scheduling purposes.

Insulation Thickness You can specify the thickness of insulation added to a single segment or fitting, a group of segments or fittings, or an entire building systems network.

Justification The justification property determines the drag point for schematic symbols, devices, and panels. The drag point is the point around which the block rotates. The default justification is the standard AutoCAD® block insertion point. For most layout situations, this should work well. However, if you want to change
this setting, you can also set it to 1 of 9 other predefined points, which are based on the bounding box that surrounds the block:

- Top left, center, right
- Middle left, center, right
- Bottom left, center, right

**Justification/Offset** The justification and offset property determines the orientation of a duct, pipe, cable tray, or conduit segment relative to the centerline for layout. The default justification is the centerline, with no horizontal or vertical offsets. For most layouts, this should work well. However, if you want to change this setting, you can set it to 1 of 9 other predefined points, which are based on the bounding box that surrounds the segment:

- Top left, center, right
- Middle left, center, right
- Bottom left, center, right

You can also use points outside the bounding box by entering a distance for both the horizontal and vertical offset.

**Layout Method** Layout method enables you to select how to lay out ducts or pipes. You can specify a default rise/run angle or use routing to minimize the number of steps to complete a layout. Using the routing method provides optional positions for the elbow based on the location of the connecting segment.

**Length** Duct, pipe, cable tray, or conduit length is the actual length of the segment. You can break segments or an entire run into several segments as well as merge them together. Duct, pipe, cable tray, or conduit length can be useful when determining the number of individual segments a manufacturer needs to supply.

**Line Annotation** Line annotation (1 or 2 line annotation) is the type of graphic representation used to represent cable trays. You can select from a list of predefined graphical types.

**Lining Thickness** You can specify the thickness of lining added to a single duct segment or fitting, a group of duct segments or fittings, or an entire network of ductwork.

**Load** Circuit load is the total burden placed on the circuit, measured in volt-amperes. Circuit load is a read-only property that is defined dynamically based on the device loads on the circuit. Having an accurate load setting for each device ensures an accurate total load for the circuit as well as the panel. You can specify the load during insertion or modify the device property later to change the load. You can also set the load to a predefined value in external content files if you want the load to be a consistent value for a specific type of device. When you change the load of a circuited device, the load total for that circuit and its assigned panel are updated with the new load. The load value is used when calculating total loads and demand loads for circuits and panels. See Total Load.

**Location** The location is a part's actual X, Y, Z coordinate location in a drawing. The insertion point and angle of rotation are also stored as part of the location property.

**Location Type** A building location type assigned to the surface of an engineering space. Wall surfaces can be designated as interior walls, or different exterior wall types. Ceilings and floors can also be designated as interior, exterior, or below-grade surfaces.

**Material** You can specify a material for piping by selecting from the list of available materials. The pipe material is used to sort the mechanical module catalogs for selecting valid parts during layout. You can change the material for specific segments or an entire network of piping.

**Mode** Mode determines the type of drafting mode—orthographic or isometric—when creating a schematic diagram using schematic lines and schematic symbols.
**Name** The name is a read-only property that is used to identify parts. The name is predefined for parts from the catalog and content, such as schematic symbols, and is user-defined for custom parts you create, such as MvParts. Each part is required to have a unique name.

**Nominal Size** You can specify a nominal size for pipe or select a nominal size from the list of available sizes from the AutoCAD MEP catalogs. Nominal size determines the nominal dimensions of the piping. Use an undefined nominal size for conceptual layouts when no part or design details are known. You can change the nominal size of the piping for specific segments or an entire network.

**Number of Devices** Number of devices displays the total number of connected devices in the drawing and on the circuit. It is a property common to all system types. This property changes as devices on the circuit are added and deleted.

**Number of Poles** Number of poles is a property for Power and Lighting circuits and connectors only. The number of poles is one of the rules used to determine if a connector can be connected to a circuit. The number of poles (# of Poles) setting can be changed in Circuit Manager for circuits or on the connector properties list for Power and Lighting connectors. The Number of Poles property can be changed on a circuit only if there are no devices attached to the circuit. The Number of Poles property can be modified on a connector only if the connector is not connected to a circuit.

**Offset** The offset property determines the orientation of a pipe segment relative to the centerline for layout. The default offset is zero for both horizontal and vertical offsets. For most layouts, this should work well.

**Panel Name** Panel is the name used to select the panel when you create circuits. Each panel is required to be a unique name within the drawing. You can specify which panel the wire is connected to by selecting from the list of panels defined in the drawing.

**Panel Rating** You can specify a rating for a panel or select one from the list of ratings that have already been assigned to other panels in the drawing. Rating is the Mains Rating specified for the Panelboard.

**Part Size Name (Part)** The part size name is the default name of the part stored in the part catalogs. The part size name is a read-only property that is used when selecting parts during layout. Each part from the catalog has a unique part size name.

**Phase Type** You can specify either a 1-phase or a 3-phase panel.

**Rise/Run** You can specify the pitch of an inclined segment, usually expressed as the ratio of the vertical rise to the horizontal run. The ratio of rise divided by run equals the slope of the segment.

**Rotation** Rotation specifies the rotation of an object inserted into the drawing, such as a schematic symbol. The rotation controls the X and Y angles of the object in the current UCS.

**Scale** The scale is the factor used to physically size the panel object in a drawing. For example, a scale factor of 2 would double the size of the panel object in the drawing. You can increase or decrease the scale of a panel.

**Segment** The segment determines the layout method of wire. You can specify Line, Arc, Snake, Polyline, and Chamfer as the type of segment to use when drawing wire.

**Segment Mode** You can specify the graphical representation of flexible ducts by selecting a segment mode. The segment modes provided include Line, Arc, Snake, Polyline, and Chamfer. When Line mode is selected, you can define the justification and offset for the orientation of flex parts relative to the centerline for layout. You can specify the height and offset to define the shape of the segment for arc, snake, and polyline modes.

**Shape** Shape determines the actual shape of the ductwork and defines which part family to use during layout. You can define the shape of ductwork as oval, rectangular, round, or undefined. Use undefined shape for conceptual layouts when no part or design details are known. You can change the shape for specific duct segments or an entire duct network. Shape also determines the actual shape of a custom fitting. You can define a different shape for each segment of the custom fitting by assigning a shape for each segment’s start point and endpoint.
Size  Size is the actual size of a part, for example, 6-inch for a 6-inch conduit or pipe. Size is a read-only property and is dynamically updated when the part is modified.

Slope  Slope is the incline of a plumbing line. Slope is calculated by the rise of the segment divided by the length, or run, of the segment. You can specify the rise and run and have the slope calculated automatically, or you can specify a slope and have the rise and run calculated automatically.

Slots  The spaces to install circuit breakers in an electrical panel (also referred to as “poles”).

Style Name  The style name is a read-only property that is used to identify part styles. The name is predefined for standard styles, such as schematic line styles, and is user-defined for custom styles that you create. A unique name is required for each style. You can specify the style of the schematic line by selecting a style from the list of defined schematic line styles. The schematic line style determines the display representation of the schematic line. You define schematic line styles in Style Manager.

Subtype  Every part is classified with a subtype. Subtype is a read-only property defined by a part’s type and characteristics. For example, a pipe segment’s subtype might be smooth or rigid. If a part’s type is undefined, no subtype is defined for the part.

System Abbreviation  The system abbreviation is a string of characters used to represent the system name. The system abbreviation is used for labeling and scheduling and is typically defined when a system definition is created.

System Group  The system group is the name of the group associated with a part’s system definition. System groups are used to associate or group together multiple systems.

System Label  The system label property for schematic layouts is used for managing system type abbreviations for labeling. The system abbreviation for a schematic symbol is set to the system abbreviation of the first schematic line or symbol inserted in the layout.

System Name  A system is an optional means of grouping parts. The system properties of a part are set to the properties of the first part inserted in the system. All subsequent parts must be assigned the same system in order for valid connections between parts to occur, unless connection of dissimilar systems is allowed.

System Type  In the electrical and plumbing modules, every system is classified with a type. Type is defined by the system’s object type, such as cable tray or conduit. The system type can be undefined if a part’s characteristics are unknown.

In the electrical module, the system type is also used on circuits and device connectors. The system type determines which additional properties the circuit or connector should have.

Total Load  Total Load displays the total electrical load of the devices connected on a circuit. It is a property for Power and Lighting circuits only. This property changes if the voltage of devices on the circuit are modified. See Load.

Type  Every part is classified with a type. Type is a read-only property defined by a part’s object type, such as duct, pipe, cable tray, conduit, or fixture. The type can undefined if a part’s characteristics are unknown.

Vanes  Vanes indicate whether an individual duct fitting contains turning vanes. Turning vanes are mounted into fittings to reduce pressure loss. To display the turning vanes in plan view, they must be added to the fitting style using the Add Vane command.

Voltage  All Power and Lighting circuits have a voltage value that is used for calculating current. The voltage value on the circuits is entered as a voltage definition. Devices with a Power and Lighting connector may have a voltage value; if so, this value is used to check whether a device can connect to the circuit. The voltage value on the device must be in the range for the voltage definition on the circuit.

Width and Height  You can specify a width and height for duct and cable tray, or select dimensions from the list of available sizes from the part catalogs. Width and height determine the actual dimensions of the duct or cable tray. You can change the size of specific segments or an entire building systems network.
**Wire Type** You can specify the drafting method used to lay out wiring by selecting a type. The types provided include line, arc, snake, polyline, and chamfer. You can specify the height and offset to define the shape of the segment for arc, snake, and polyline methods.

**Wired Circuits** The wired circuits property shows what circuits are contained in a specific wiring run.

**XY Angle** XY angle is a read-only property that is dependent on the rise and run property settings. The XY angle defines the actual angle between 2 segments that is a result of the rise and run values.

### Using Object Match

An AutoCAD MEP part is assigned a variety of properties that define the part. You can use the Match command to create a new object with the same properties as an existing object. However, different building systems objects contain different properties. Therefore, it is important to understand what specific properties are matched.

The following alphabetical list of AutoCAD MEP object types identifies the properties that you can copy when using the Match command.

---

**NOTE** Property set information is not matched.

- **Cable Tray**
  - System
  - Elevation
  - Part
  - Size
  - Connection type
  - Annotation (available during Add command only)

- **Cable Tray Fitting**
  - System
  - Elevation
  - Part
  - Size
  - Annotation (available during Add command only)

- **Conduit**
  - System
  - Elevation
  - Part
  - Size
  - Connection type

- **Conduit Fitting**
  - System
  - Elevation
■ Part
■ Size

Device
■ System
■ Elevation
■ Style
■ ID
■ Rotation (available during Add command only)

Duct
■ System
■ Elevation
■ Insulation (available during Add command only)
■ Lining (available during Add command only)
■ Part
■ Shape
■ Size
■ Connection type

Duct Fitting
■ System
■ Elevation
■ Insulation (available during Add command only)
■ Lining (available during Add command only)
■ Part (available during Add command only)
■ Shape
■ Size

Duct Fitting, Custom
■ System
■ Insulation (available during Add command only)
■ Lining (available during Add command only)
■ Shape
■ Size

Engineering Space
■ Style
■ Length
- Width
- Height

**Flex Duct**
- System
- Elevation
- Insulation (available during Add command only)
- Lining (available during Add command only)
- Part
- Size
- Connection type
- Annotation (available during Add command only)

**Flex Pipe**
- System
- Elevation
- Gauge
- Insulation (available during Add command only)
- Material (available during Add command only)
- Part
- Size
- Connection type
- Annotation (available during Add command only)

**MvPart**
- Elevation
- Part

**Panel**
- System
- Elevation
- Style
- Name
- Voltage
- Rating
- Slots
- Phases
- Scale (available during Add command only)
- Rotation (available during Add command only)

**Pipe**
- System
- Elevation
- Gauge
- Insulation
- Material
- Part
- Size
- Connection type

**Pipe Fitting**
- System
- Elevation
- Gauge (available during Add command only)
- Insulation (available during Add command only)
- Material
- Part (available during Add command only)
- Size

**Pipe Fitting, Custom**
- System
- Insulation (available during Add command only)
- Size

**Plumbing Fitting**
- System
- Elevation
- ID
- Rotation (hidden when Specify rotation on screen is selected, and available during Add command only)
- Style

**Plumbing Line**
- System
- Elevation
- Style
- Size
- Slope
Schematic Line
- System
- Style
- ID

Schematic Symbol
- Style
- System
- ID
- Mode (available during Add command only)
- Rotation (hidden when Specify rotation on screen is selected, and available during Add command only)

Wire
- System
- Elevation
- Style
Index

1 line
display representation 137
duct, drawing 201
graphical display 258
pipe display 258, 282
screened display representation 137
2 line
display representation 137
pipe display 258, 282
screened display representation 137
3D models, creating for block-based parts 754
3D orbit
previewing pipe routing solutions 254
viewing, definition 803
A
abbreviations 97
access panel, definition 803
acid neutralizer, definition 803
actual velocity, definition 803
add grips
for duct 200
for pipe 272
for plumbing 487
add pipes command 291, 298
adding
block-based parts 753
connectors to parametric fittings 682
dimensions to parametric fittings 687
dimensions to parametric MvParts 724, 726, 728
elevation labels 578
HVAC parts 195
labels 559
parallel pipe runs 313
parametric parts 650
part number tags 564
part sizes to parametric fittings 689
part sizes to parametric MvParts 729–731
radiators to drawing 341
radiators using calculated data 338
radiators using calculation program 337
schematic symbols for block-based parts 756
adding duct 200
adding a takeoff 211
adding inline equipment 195
adding sloped 208
connecting through xrefs 209
connecting to MvParts 200
converting polylines to flexible 213
creating from lines 213
described 196
drawing 1-line 201
drawing a run 196
drawing a vertical run 201
fittings 205
flexible 206
grips 200
locking elevation 208
offsetting from geometry 208
parallel runs 207
part size not found 217
using instant sizing 196
adding pipe 286
connecting to MvParts 300
creating systems 285
design properties 286
drawing flexible pipe 311
fittings 306
grips 272
inline equipment 286
joints 306
locking elevation 270
MvParts 285
offsetting from geometry 314
parallel run 313
pipe tool palette 291, 298
placeholders 261
preferences override, described 305
specifying parts manually 303
starting add pipes command 291, 298
takeoffs 315
using routing solutions 254
vertical segments 301
adding plumbing runs using grips 487
adjust slope, definition 803
AEC content, defined 792
AEC Model drawing template 156
AEC objects
definition 803
enabler, definition 803
AEC Sheet drawing template 156
AECBANCHORFLIPX command 110
AECBANCHORFLIPY command 110
AECBANCHORFLIPZ command 110
AECBANCHORRELEASE command 111
AECBCOMPASS command 112
AECBCOMPASSBAR command 112
AECBLAYERSTD command 133

831 | Index
air handling unit, definition 803
inlet, definition 803
outlet, definition 803
air eliminator, definition 803
air terminals
configuring for analysis 196
flow annotation 165
modifying flow values 232
airflow, definition 803
ALIGN command 20
aligning
devices 391
faces with constraints 711
graphy with work planes 654
view blocks with model blocks 745
alignment grips 345, 409, 431
alternating current (AC), definition 803
ambient air, definition 803
ambient temperature 413
amp (ampere), definition 803
amperage, definition 803
analyze tab 45
analyzing
importing duct data 244
resizing duct systems 244
anchor method for inserting parts 748
Anchor Part property 672
anchoring
release 111
with a curve anchor 109
with a reference anchor 110
with a system anchor 110
anchors
AutoCAD MEP 108–111
curve 109
properties 111
reference 110
releasing 111
schematic symbols 531
system 110
working with 108, 111
ANCHORTOBSCURVE command 109
ANCHORTOBSCURVEATTACH command 109
ANCHORTOBSCURVESETCURVE command 109
ANCHORTOBSCURVESETEND command 109
ANCHORTOBSCURVESETPOSITIONX command 109
ANCHORTOBSCURVESETROTATION command 110
ANCHORTOBSCURVESETROTATIONX command 110
ANCHORTOBSCURVESETROTATIONY command 110
ANCHORTOBSMEMBER command 109
angle 658
definition 803
angle of deflection 267, 289
definition 804
angles, rise/run 475
ANNOALLVISIBLE system variable 553
ANNOAUTOSCALE system variable 554
annotate tab 45
annotating duct 218
adding flow arrows 218
adding hatching patterns 219
adding labels 218
modifying annotation, described 239
annotating pipe
adding flow arrows 317
adding labels 317
annotation
adding to duct 218
adding to parametric schematic symbols 741
air terminal flow 165
configuring for pipe 295
definition 804
elevation labels 578
for pipes, described 317
labels 559–579
preferences, cable trays 379
preferences, conduits 379
scale representations, adding 554
scale representations, modifying 554
scaling 549
specifying the annotation scale 552
style properties for plumbing lines 481
style properties for schematic line 523
style properties for wires 374
symbols, definition 804
using symbols from DesignCenter 560
annotation scale
annotative objects 549
flag, definition 804
specifying 552
annotative objects
AutoCAD Architecture objects 549
AutoCAD MEP objects 549
AutoCAD objects 549
defined 549
displaying 553
hiding 553
AoD 267
APC files, defined 773
APC, definition 804
application menu 33, 48
accessing 49
changing recent files count 51
displaying recent documents 50–51
finding commands 42
locating commands 49
application status bar 56
modify 58
architectural elements, definition 804
ARRAY command 20
ARX command 793
ASHRAE
fitting, definition 804
specifying duct fittings 242
associative movement
for duct, described 219
for pipe, described 248
for plumbing, described 466, 535
attribute, definition 804
AutoCAD
  exporting drawings to 554
AutoCAD commands 20
AutoCAD MEP
  anchors 108, 111
  objects 28
  overview 27
  overview, user interface 33
  regenerating model 120
  snaps. See snaps
tooltips 74
  updating 33
AutoCAD MEP snaps
duct, described 172
electrical 361
  parallel pipe runs 313
  pipe 270
  wire ways 361
Autodesk seek 35
Autodesk subscription program 33, 592
Autodesk, contacting 30
autolayout
  for duct, described 168
  for piping, described 252
  overriding default parts for pipe 305
  using piping routing solutions 254
AutoLayout flag 672

B
ballast, definition 804
base curve, definition 804
baseline, definition 804
basic tables
  parameters, adding sizes 778
  storing part data 776
bay, definition 804
behavior
  rules for connectors 652
behaviors
  changing for block-based parts 765
  defining for block-based parts 757
bell/hub, definition 804
bend angle 287
bends. See plumbing fittings
bitmap, definition 804
BLDSYS_PURGE commands 590
brazed, definition 804
BREAK command 21
Break Into Part property 672
break marks, definition 804
break/overlap paper width 481
Break/Overlap Paper Width property 374, 523
breaker, definition 804
breaking
  cable trays and conduits 378, 449
  configuring for duct 176
  duct manually 234
  pipe manually 329
  plumbing lines 490
British Standards Institute standards 797
BTU, definition 804
building model, definition 804
butt weld, definition 804
butt welded, definition 805

C
cable tray
  definition 805
displaying by elevation 144–145
  fittings, matching part properties 826
  matching part properties 826
Cable Tray connector style 616
Cable Tray Model display representation 801
cable trays and conduits
  adding branches 423
  adding fittings manually 424
  adding runs 421
  breaking 378, 449
connector styles 616
default parts for layout 379
display preferences 379
merging 449
modifying 444
modifying elevation 445
modifying fittings 450
modifying layouts 444
modifying lengths 446
modifying sizes 446
modifying systems 445
rotating cable trays 801
rotating fittings 450
cable trays. See cable trays and conduits 360
cable, definition 805
CABLETRAY command 360
CABLETRAYADD command 424
CABLETRAYADDSELECTED command 424
CABLETRAYBREAK command 449
CABLETRAYFITTING command 360
CABLETRAYFITTINGADD command 424
CABLETRAYFITTINGADDSELECTED command 424
CABLETRAYFITTINGMODIFY command 450
CABLETRAYFITTINGPROPS command 125
CABLETRAYLENGTH command 446
CABLETRAYMERGE command 449
CABLETRAYMODIFY command 444
CABLETRAYPREFERENCES command 376
CABLETRAYPROPS command 125
CABLETRAYRISEDROPSTYLE command 614
CABLETRAYSTYLEEDIT command 603
CAD standards. See projects
calculated size, definition 805
calculating
duct sizes with external tools 241
duct system sizes 203
calculations, part data 776
calculator for duct sizes 171
CANNOSCALE system variable 552
capacity, definition 805
catalog
upgrade catalog data 782
Catalog Editor
accessing commands 774
basic tables 776
calculations 776
catalogs, creating 779
catalogs, selecting 775
chapters, modifying 780
chapters, selecting 775
constant lists 776
constants 776
definition 805
details pane 772
key terms 773
menu bar 772
migrate catalogs 782
navigation pane 772
opening 774
opening part catalogs 774
overview of features 771
overview of the user interface 771
part data, modifying 775
part families, selecting 775
part sizes, selecting 775
parts, adding custom data 778
parts, adding sizes 777
parts, creating 777
preview image window 772
storage types, selecting 775
table view 772, 775
toolbar 772
tree view 772, 774
using 771
working with Excel 780
catalog-based content
creating, electrical 362
creating, plumbing 477
CATALOGREGEN command 782
catalogs 79, 83
adding sizes for parts 777
APC files 773
AutoCAD MEP 79
BMP part definition files 773
chapters 773
creating 779
creating parts in Catalog Editor 777
custom data 773
customizing 774–781
defaults 70
defined 773
DWG part definition files 773
file locations 774
key terms 773
migrate part catalogs 782
modifying chapters 780
modifying part properties in Catalog Editor 778
opening in Catalog Editor 774
parameters 773
parameters, common 773
part data 773
part families 773
part size tables 773
part sizes 773
parts 773
saving 780
selecting in Catalog Editor 775
selecting parts from 81
size parameters 773
storage types 773
structure 80
validating 780
XML files 773
CATALOGTEST command 781
categories
part 747
CCF files 623, 633
CCT files 623, 633
ceiling grids, definition 805
CEL for pipe, described 267
cell anchors, definition 805
centerlines  
definition 805  
displaying on ducts 152  
straight centerline display 261, 284
CHAMFER command 21
changing  
behaviors 765  
UCS planes 113
channel style 798
chapters  
defined 773  
radiator MvParts 337  
selecting in Catalog Editor 775
chase, definition 805
checking. See troubleshooting
Choose a Part dialog, for pipe 303
circuit  
closed, definition 805  
definition 805  
length, definition 805  
load, definition 805  
open, definition 814  
voltage, definition 805

circuit breaker, definition 805

circuit information  
accessing 426  
tools
Circuit Manager 356  
configuring a circuit 387  
creating circuits 385  
opening 388
See also circuits
circuit reports, creating 427
circuit settings 403
CIRCUITCONFIGPROJ command 367
CIRCUITINFO command 426
CIRCUITMANAGER command 356
CIRCUITRELOADPROJ command 383
CIRCUITREPORT command 427

circuits 356–357  
changing properties of 429  
checking loads 426  
checking wire sizes 425  
configuring 387  
connecting across drawings 384  
creating using Circuit Manager 385  
creating when adding panels 403  
creating with wires 413  
deleting 430  
managing for a project 390  
modifying 429–430  
moving 429  
naming 366  
overload notifications 426  
overview 356  
reports, creating 427

show circuited devices 427  
system types 385  
using an electrical project database 380  
viewing 388  
voltage definitions 365  
working with 380
clean up, definition 805  
collision detection 579, 582  
COLLISIONDETECTION command 582  
command line, definition 805  
command prompts 115  
command tools, creating 789  
command window 55  
common parameters, defined 773  
communication center 60  
Communication Center 33  
COMMUNICATIONMODIFY command 434  
comparing drawings 592  
compass 114  
color 112  
customizing 114  
definition 805  
settings 112–114  
nap increment 112  
component, definition 805  
conceptual design phase, definition 805  
condensate line, definition 805  
ConditionType property 187  
conduit  
definition 805  
displaying by elevation 144–145  
fittings, matching part properties 826  
maching part properties 826  
straight centerline display 284
CONDUIT command 360  
Conduit connector style 616  
CONDUITADD command 424  
CONDUITADDSELECTED command 424  
CONDUITBREAK command 449  
CONDUITFITTING command 360  
CONDUITFITTINGADD command 424  
CONDUITFITTINGADDSELECTED command 424  
CONDUITFITTINGMODIFY command 450  
CONDUITFITTINGPROPS command 125  
CONDUITFITTINGSTYLEEDIT command 603  
CONDUITLENGTH command 446  
CONDUITMERGE command 449  
CONDUITMODIFY command 444  
CONDUITPREFERENCES command 376  
CONDUITPROPS command 125  
CONDUITRISEDROPSTYLE command 614  
CONDUITSSTYLEEDIT command 603  
configurations  
parametric fittings 676  
parametric MvParts 653, 698, 700  
configuring duct  
breaking at even intervals 176  
connections 180  
creating system definitions 181
flow arrows 177
insertion justification 174
insulation 176
labels 177
layout preferences 174
lining 176
settings 174
slope 175
configuring pipe
adding flow arrows 295
adding insulation 317
adding labels 295
creating system definition 281
deleting routing preferences 281
insertion justification 297
routing preferences 250
settings 279
CONNECTEDOBJECTS command 581
connecting dissimilar systems 95
connection type
definition 806
selection 682
connections
changing pipe 328
checking for duct 239
checking for pipe 332
checking validity of 579
clean up 603
configuring for duct 180
details 289
male-female 267
pipe, described 264
pipe, maintaining 329
rules 71
same connection 266, 653
system assignments for 122
type 266, 653
validation 107
See also connecting and connectors
connector block, definition 806
connector engagement length, definition 806
connector engagement length. See CEL
connector styles 97, 616
connectors
adding to parametric fittings 682
adding to parametric MvParts 720–723
behavior 652
block-based parts 751, 760, 766
configuring, device styles 368
configuring, devices 395
configuring, panel styles 372
connector styles 616
definition 806
modifying, devices 437
non-standard planes 752
orientation on fittings 666
parametric parts 666
pipe, described 264
piping types 651
plumbing fitting styles 483
properties 682
specifying domains 751
specifying location 752
specifying shape 752
style properties 107, 608
style properties, plumbing 483
style property rules 107, 580
style-based content 608
testing 769
types of 651, 751
working with 107
constant lists
parameters, adding sizes 778
storing part data 776
constants, part data stored as 776
constrained layout
definition 806
slope value displayed 257
sloped piping 255
constraints
adding to parametric MvParts 711
definition 806
parametric parts 658
types of 659
construction documents
creating 548
creating sheets 576
creating views 568
definition 806
schedules 566
workflow 547
containment, definition 806
content
definition 806
See also style-based content
Content Browser 787, 789, 793
Content Builder
connector properties 682
definition 806
dimension, definition 807
gometry types 656
getting started 647
getting started dialog 643
model, definition 813
modifying block-based parts 764
modifying parametric parts 741
overview
parametric MvParts 698
starting for block-based MvParts 757
starting for parametric fittings 676
testing parts 768
types of content 641
workflow for creating with block-based parts 753
workflow for creating with parametric MvParts 696
workflow for creating with parametric parts 674
working environments 643
content packs
Global 797
content tools for creating parts 79
context help 60
context menu
  searching 42
context menus 52
  definition 806
contextual ribbon tabs 47
continuous load, definition 806
conversion scripts
  creating for device styles 623
  creating for schematic symbol styles 633
  defined 623, 633
  for device styles, definition 807
  modifying for device styles 625
  modifying for schematic symbol styles 635
conversion templates
  creating for device styles 623
  creating for schematic symbol styles 633
  defined 623
convert to MvPart 743
CONVERTDEVICECONTENT command 622
converting
  lines to duct 213
  polylines to flexible duct 213
CONVERTSYMBOLCONTENT command 631
CONVERTTODEVICE command 618
COPY command 21
coupling, definition 806
creating
  3D models for block-based parts 754
  block-based parts 753–754
  block-based parts, tips for 745
  connectors for parametric fittings 682
  construction documents 548
  custom duct fittings 215
  duct system definitions 181
  duct systems 194
  parametric fittings 675
  parametric parts 650, 696
  parametric parts, tips for 650
  pipe part routing preferences 279
  radiator parts 336
  rules for parametric fittings 651
  schematic symbols
    schematic symbols for block-based parts 756
creating face geometry for parametric MvParts 710
crossed lines
  plumbing 481
  schematic 523
crossed wires 374
current, definition 806
curve anchors, definition 806
curve, definition 806
Custom Content File 623, 633
Custom Content Template 623, 633
custom data
  adding 778
  defined 773
  storage types 778
custom display 66
  using 67
custom duct fitting 215
custom parameter groups
  creating 766
  defined 766
  inserting into parts 768
custom part sizes
  parametric parts 671
  preferences 73
custom parts. See parts
custom pipe fitting 307
custom pipe fittings. See pipe fittings
Custom Sizing flag 672
customizable style-based content 600
cut height
  definition 806
  setting 145
cut length 267–268
cut plane 145
  definition 806
  global, overriding 150
  modifier 662
cutout, definition 806
D
damper, definition 806
DDPTYPE command 676
DDXML 241
  definition 806
  exporting systems in 242
  importing system data in 244
DECOMPOSEDEVICECONTENT command 620
DECOMPOSESYMBOLCONTENT command 630
default fittings for plumbing systems 478
default, definition 806
defining
  custom equipment 753, 760, 766
  property sets 588
  systems 100
  work planes for parametric fittings 677
degree of freedom, definition 807
demand factor, definition 807
demand load, managing 429
design content, definition 807
design criteria, definition 807
design development phase, definition 807
design rules, specifying for styles 603
Design Tool catalog 792
design workflow
  for plumbing 463
designation IDs 522
  assigning 525, 528, 534
  definition 807
  modifying 536
DesignCenter 792
  annotation symbols 560
detail marks, definition 807
detail view drawing 569
developed length, definition 807
DEVICE command 357
device conversion scripts. See conversion scripts
device styles
classifications 369
connectors 368
converting to blocks 620
creating 599
creating from blocks 618, 622
creating from parts 618
design rules 367
wire cleanup 367
device type classification definition 369
DEVICEADD command 391
DEVICEADDSELECTED command 391
DEVICEMODIFY command 434
DEVICEPROPS command 125
devices
adding 391
adding and aligning 391
adding tags manually 391
adding, example 398–399, 401, 403
configuring electrical connectors 395
connecting with wires 413
copying 409
copying, example 411
creating 599
creating from blocks 618
creating from parts 618
display representations 357
matching part properties 827
modifying electrical connectors 437
modifying properties 434
moving 431
moving, example 432
overview 357
property sets, attaching manually 358
property sets, specifying in tools 358
show circuited 427
styles, specifying wire cleanup 603
tags, attaching manually 358
tags, specifying in tools 358
tools 790
DEVICESTYLE command 367
DEVICESTYLEEDIT command 367
diameter, definition 807
diaphragm, definition 807
diffusers
configuring for analyses 196
modifying flow values 232
dimensions
adding to parametric fittings 687
definition 807
for parts 657
order of placement 657
parametric MvParts, adding 724, 726, 728
tips for creating 650
types of 657
direct current (DC), definition 807
direction dependent, definition 807
direction vectors for block-based parts 752
discussion groups 33
display
1-line for pipe 258
2-line for pipe 258
activate display range in model view 149
compass 114
object 610
style properties 604, 610
systems 99
display above range
definition 807
setting 145
display below range
setting 145
display below range, definition 807
display by elevation
configuring 149
definition 807
display tab 149
overriding global cut plane 150
setting cut plane and display range 148–151
workflow 146
display components
centerlines 152
elevation-based
configuring 144
elevation-based, configuring 149
elevation-based, display tab 149
elevation-based, overriding global cut plane 150
elevation-based, setting cut plane and display range 148–151
display configurations
1-line for pipe 258
changing for xrefs 161
cut plane 145
defaults 139
definition 807
described 135, 139
display tab 149
for pipe 258
Display Manager 136
definition 807
display options, saving configurations 785
display properties, definition 808
display range, definition 808
display representations
adding custom graphics 155
Cable Tray Model 801
defaults 137
definition 808
described 135, 137
devices 357
panels 358
testing for parts 768
display sets
definition 808
described 135, 139
using classifications 154
display settings
applying style-level overrides 143
applying system-level overrides 143
DUCTCUSTOMFITTINGPROPS command 215
DUCTCUSTOMFITTINGSTYLE command 215
DUCTCUSTOMFITTINGSTYLEEDIT command 215
DUCTFITTING command 205
DUCTFITTINGADD command 205
DUCTFITTINGADDNEW command 205
DUCTFITTINGADDSELECTED command 205
DUCTFITTINGMODIFY command 235
DUCTFITTINGOVERRIDE command 218
DUCTFITTINGPROPS command 235
DUCTFITTINGSTYLEEDIT command 235
DUCTFITTING command 235
DUCTFITTINGADD command 206
DUCTFITTINGADDSELECTED command 196
DUCTFITTINGMODIFY command 236
DUCTFITTINGPROPS command 236
DUCTFITTINGSTYLEEDIT command 236
DUCTFITTINGLENGTH command 225
DUCTFITTINGMODIFY command 232
DUCTFITTINGOVERRIDE command 218
DUCTFITTINGPREFERENCES command 174
DUCTFITTING command 125
DUCTTRISEREDROPSTYLE command 614
ducts
displaying by elevation 144–145
displaying centerlines by shape 152
flanges, display 178
DUCTSTYLEEDIT command 603
DUCTSYSTEMDEF command 181
DUCTSYSTEMDEFEDIT command 181
DUCTSYSTEMSIZECALC command 203
DUCTVANES command 168
DUCTVANESADD command 214
DUCTVANESREMOVE command 214
DUCTXMLIMPORT command 244
duplex receptacle, definition 808
DWF
publishing sheet sets 578
DWG
definition 808
part definition file 773
DWT, definition 808
dynamic input
command prompts 115
components 115
disabling 115
enabling 115
overview 114
setting 115
elevation
defining 73
definition 808–809
difference, definition 809
labels, definition 809
marks, definition 809
preferences 73
display by elevation 144
display components
configuring 149
cut plane and display range 145
elevations
defining 73
definition 808–809
difference, definition 809
labels, definition 809
marks, definition 809
preferences 73
end-of-line schematic symbols 519
end-of-line symbol, definition 809
engineering data
adding to spaces 187
definition 809
engineering properties, definition 809
engineering space, definition 818
engineering tools 30
entity reference (entref), definition 809
equation assistant 688, 729
equipment
  adding HVAC 194
  adding inline to duct 195
  adding inline to pipe 286
  adding piping 285
  as block-based parts 643
  changing size or elevation 324
  connecting to duct 200
  connecting to pipe 300
custom, defining connectors for 760
defining 753, 760, 766
defining catalogs for custom 748, 757
defining connectors for custom 760, 766
defining sizes for custom 759–760
defining views for custom 759–760, 766
duct, modifying 231
duct, modifying elevation 222
mechanical, described 76
modifying custom 764, 766
pipe, matching 324
piping, described 76
plumbing, adding 485
plumbing, described 76
plumbing, modifying 494
See also MvParts
EquipmentLoad property 187
ERASE command 21
Excel, working with part data 780
exit show all insertion points grip 431
expansion loops 491
EXPLODE command 22
  problems with using on custom parts 647
explode, definition 809
exporting
  schedules as spreadsheets 568
to AutoCAD 554
to IFC 596
EXTEND command 22
external reference (xref), definition 809
external references. See xrefs
external tools for duct sizing 241
extrusion modifier 678
  blind 661
  from-to 660
  midplane 660
  plane 660
F
F1 help 60
fabrication
  definition 809
  schedules 563
  vendor 563
fabrication schedules 564
features, definition 809
feedback 31
feeder, definition 809
FILLET command 22
fire protection, modifying K-factor 324
FIRESAFETYMODIFY command 434
fitting tolerance 267, 289
fittings
  See plumbing fittings
  branch 289
  connector orientation 666
definition 809
  See cable trays and conduits
  settings 289
tolerance 267
  See parametric fittings
Fixture Unit Table tab 485
fixture unit tables 501
  defining 479
  modifying fixtures 494
  specifying for parts 485, 494
fixture units
  definition 809
  properties 475
fixtures
  adding 485
  definition 809
  described 76
  modifying 494
tag, definition 809
type 485, 494
FIXTUREUNITTABLESTYLE command 479
flanges
  configuring display 178
definition 809
  face, definition 809
FLEXDUCTCENTERLINE command 152
flexible duct
  adding 206
  annotation patterns 179
  creating from polylines 213
default layout method 179
described 167
  matching part properties 828
  modifying layout 236
  spline 167
  spline, modify layout 236
flexible pipe
  annotation patterns 311
  converting polylines to 318
default layout method 311
drawing 311
  matching part properties 828
  modifying layout 331
flexible, definition 809
float, definition 809
floating viewer panel 44
floating viewer 137
definition 809
floating viewports, definition 810
floor drain, definition 810
flow arrows
adding to duct 218
adding to pipe 317
air terminals 165
configuring for duct 177
configuring for pipe 295
definition 810
for duct 118
for pipe, setting direction 118
graphics 549
modifying for pipe 332
preferences for plumbing 484
See also flow direction
flow coefficient 324
flow diagram, definition 810
flow direction
adding flow arrows 218
definition 810
flow arrows 118
setting for duct 118
setting for pipe 118
flow markers, turning on or off 118
flow pressure, definition 810
flow rate, definition 810
flow, modifying for air terminals 232
flush valve, definition 810
forced-air system, definition 810
free-standing symbol, definition 810
from-to extrusion modifier 660
fuses, definition 810

G
gas meter, definition 810
gathering, definition 810
gauge, definition 810
gbXML
definition 810
exporting data in 30
file for radiators 337
GBXMLEXPORT command 190
GBXMLIMPORT command 192
general circuit system type 385
general display representation 137
general screened display representation 137
general view drawing 568
generating 3D parts from 2D models 749
geometry
aligning with work planes 654
creating faces 710
parametric parts 656
GFI (GFCI), definition 810
Global content pack 797
global cut plane, overriding 150
Global profile 797, 801
glued connection, definition 810
governor, definition 810
graphical 1-line. See 1 line
gravity pipe 250–251, 256

grids, definition 810
grips
adding duct 200
adding pipe 272
adding plumbing runs 487
alignment 345, 409, 431
constraints 116
definition 810
duct, described 172
editing modes 117
exit show all insertion points 431
for duct, elevation 222
for duct, lengthen 225
for duct, modifying 220
for pipe, elevation 274
for pipe, lengthen 276
for pipe, rotate 275
for plumbing lines, lengthen 472
for plumbing, rotate 471
for schematic lines, lengthen 541
lengthen 446
location 441, 554
location, moving pipe 273
location, moving plumbing lines 470
modifying pipe 273
modifying plumbing lines and fittings 470
moving duct 221
overview 114
pipe, described 271
rotate 450
rotating duct parts 228
show all insertion points 431
tooltips 116
trigger grips 116
grooved connection, definition 810
ground, definition 810
grounded conductor, definition 810
grounding conductor, definition 810
guides 31

H
hand wheel, definition 810
handle, definition 810
HANGER command 798
hanger styles, configuring 798
HANGERADD command 799
HANGERANCHOR command 801
HANGERCOPYSTYLEANDASSIGN command 801
HANGERGRIPS command 801
HANGERPROPS command 801
HANGERROTATE command 801
hangers 798
adding 799
displaying by elevation 144–145
modifying 801
HANGERSTYLE command 798
HANGERSTYLEEDIT command 798
HANGERSUPPORTABOVE command 801
HANGERSUPPORTBELOW command 801
hatching, adding patterns to duct 219
Hazen-Williams C-factor 477, 504
height, definition 820
help
access 34
context help 60
F1 help 60
menu 60
help resources 31
discussion groups 33
guides 31
other 33
tutorials 32
hidden lines
definition 811
displaying
Options dialog 152
See also preferences, crossing display
Hide Part flag 672
hiding parametric parts 671
hierarchy of display control, described 141
home runs
adding 418
definition 811
home tab 42–43
hose bib, definition 811
hot wire, definition 811
hub 804
HVAC connector style 616
HVAC parts
adding 195
adding inline to duct 195
adding, described 194
changing elevation 222
changing systems 232
configuring for analysis 196
connecting duct to 200
matching 232
modifying 231
modifying flow values 232
modifying location 230
rotating 228
HVAC systems, definition 811

I
I.D., definition 811
ID, definition 811
IFC classification 593
IfcShareBldgElements (MEP).dwg 593
images, preview 690
import file formats
BDH file (.dat) 337–338
importing
BDH file formats (.dat) 336
duct system data 244
label styles 555
radiators 338

schedule tables 590
in-line schematic symbols 519
in-line symbol, definition 811
Industry Foundation Classes (IFC) 593
InfoCenter 59
(initialization preferences
AutoCAD MEP snaps 75
catalogs 70
connection rules 71
content 70
elevations 73
layout rules 71
part selection 73
tooltip preferences 74
insert tab 44
insertion behaviors 664
for block-based parts 748
for parametric parts 671, 733
parametric fittings 690
installation guides 31
instant sizing
adding duct by 196
definition 811
for duct, described 171
for duct, specifying a method 182
for wiring 360
insulation
adding to pipe 317
configuring for duct 176
modifying 332
modifying duct 238
insulation thickness, definition 811
intelligent objects, described 28
interference detection 579, 582
invert elevation
calculation, definition 811
definition 811
invert, definition 811
isometric
definition 811
line, definition 811
previewing pipe routing solutions 254
riser, definition 811
snap, definition 811
views, of style-based content 86
isometric mode 520
planes 520
schematic lines, adding 528
schematic symbols, adding 531
isometric plane grips 542
isometric planes 520
isometric symbol
definition 811
style, definition 811
isoplane, definition 811

J
JOIN command 23
joints  
definition 811  
pipe 268  
junction box, definition 811  
JUNCTIONBOXMODIFY command 434  
justification  
configuring for duct 174  
definition 811  
for pipes 297  
offset, definition 812  
offsetting pipe 314  

K  
K-factor, modifying for sprinklers 324  
kickpipe, definition 812  
kilowatt (kW), definition 812  

L  
label curve properties  
dimension 560  
modifying  
style 559  
label curve, definition 812  
label preferences 484  
label style properties  
annotation 556  
general 555  
offset options 558  
label styles  
importing 555  
modifying 555  
specifying as annotative 549  
labels 559, 579  
adding 559  
adding duct 218  
adding to pipe 317  
configuring for duct 177  
configuring for pipe 295  
definition 812  
modifying 559  
modifying duct 239  
modifying for pipe 332  
preferences, cable trays 379  
preferences, conduits 379  
rotating nodes 559  
style properties  
styles  
LABELSTYLEEDIT command 555  
lateral, definition 812  
layer key 97  
Layer Key property 672  
layer key styles  
definition 812  
described 132  
selecting 647  
specifying for drawings 133  
layer keying 133  
definition 812  
layer keys  
assigning to parts 748  
described 132  
parametric parts 671  
layer management tools, definition 812  
Layer Manager 132  
definition 812  
layer standards  
definition 812  
described 132  
selecting 647  
specifying for drawings 133  
layers  
assigned to systems 97  
definition 812  
layout  
curve, definition 812  
mode, definition 812  
preferences 69  
radiator MvPart 342  
radiators using calculated data 338  
tabs, definition 812  
layout preferences  
cable tray 376  
conduit 376  
duct 174  
layout rules 71  
lead, definition 812  
leaders, definition 812  
length. See cut length  
length, definition 812  
LENGTHEN command 23  
lengthen grips 446  
for duct 225  
for pipe 276  
for plumbing 472  
Lengthen grips  
for schematic 541  
lever, definition 812  
libraries  
for style-based content 85  
location of 70  
lighting circuit, definition 812  
LightingLoad property 187  
LIGHTINGMODIFY command 434  
line  
annotation, definition 812  
cleanup, definition 812  
LINE command 488  
lines, converting to duct 213  
lining  
configuring for duct 176  
modifying for duct 238  
thickness, definition 812  
load  
calculations, specifying data for 187  
definition 812  
diagram, definition 813
LOADCATEGORYDEFINITIONS command 364
LOADMETRICCMDS command 797
location grips 441
  for moving duct 221
  for moving pipe 273
  for moving plumbing lines 470
  labels 554
locking
duct elevation 208
duct size 235
fitting size 235
pipe elevation 270

M
main run, definition 813
manage tab 46
managing demand load 429
mass element to MvPart 743
match lines, definition 813
matching MvParts for piping 324
matching part properties 826
cable tray 826
cable tray fitting 826
conduit 826
conduit fitting 826
devices 827
duct 827
duct fitting 827
flex duct 828
flex pipe 828
MvPart 828
panels 828
pipe 829
pipe fitting 829
plumbing fittings 829
plumbing lines 829
schematic lines 830
schematic symbols 830
wires 830
MATCHPROP command 24
material, definition 813
mechanical - duct - 1 line display configuration 139
mechanical - duct - 2 line display configuration 139
mechanical - pipe by size display configuration 139
mechanical display configuration 139
mechanical parts 76
MEMBERSTYLEWIZARD command 798
MEP Basic 2-Line display configuration 139
MEP Catalogs tab 70
MEP Design display configuration 139
MEP Elevations tab 73
MEP Layout Rules tab 71, 73
MEP Presentation display configuration 139
MEP Schematic Equipment display configuration 139
merging
cable trays and conduits 449
duct 234
pipe manually 329
metric profile 797
Microsoft Excel, working with part data 780
midplane extrusion modifier 660
migrate catalogs 782
MIRROR command 24
model
definition 813
dimensions 657
parameters 665
model blocks
  block-based parts 745
  layer assignments 746
model display representation 137
Model drawing template 156
model screened display representation 137
model space
  creating views 568
definition 813
  using 66
model tab 66
modeling
  block-based parts 745
  parametric fittings 677
  parametric MvParts 700, 720
  parametric parts 654
  parametric tee fittings 678
taps 719
tips for parametric parts 650
modifiers
  applying to parametric MvParts 713
  extrusion 678
  parametric parts 660
types of 660
modifying
  block-based parts 764
  custom equipment 764–766
  label spacing 560
  label styles 555
  labels 559
  object property sets 562
  parametric parts 741
  selecting pipe 318
  selecting schematic lines 535
modifying duct
  associative movement, described 219
  breaking segments 234
  changing length with grips 225
  changing systems 235
  checking connectivity 239
  custom fittings 237
  described 219, 232
  fittings 235
  flexible duct layout 236
grips 220
  insulation 238
  labels 239
  lining 238
  locking size 235
  merging segments 234
  moving off-center takeoffs 237
moving with grips 221  
rotating with grips 228  
selecting components 219  
size or shape 233  
specifying ASHRAE fittings 242  
turning vanes 238  
using AutoCAD commands 234  
with elevation grips 222  
modifying pipe 
breaking 329  
changing flow direction 118  
changing systems 331  
checking connectivity 332  
described 318, 324  
design properties 325  
elevation 274  
fittings 331  
flow arrows 332  
grips 273  
labels 332  
length 276  
locking size 330  
maintain connection 329  
merging 329  
modifying insulation 332  
moving with grips 273  
MvParts 322  
nominal size 328  
part routing preferences 280  
rotating components 275  
selecting components 318  
modifying plumbing fittings 
changing location 500  
grips 470  
rotating components 471  
selecting components 492  
modifying plumbing lines 
changing location 500  
changing size 500  
grips 470  
length 472  
moving with grips 470  
selecting components 492  
modifying radiators 343  
aligning to connector 343, 345  
modifying radiator valve 344  
moving 343  
moving radiator valve 344–345  
using connectors to align MvParts 345  
modifying schematic fittings 
selecting components 535  
modifying schematic lines 
length 541  
selecting components 535  
module, definition 813  
MOVE command 24  
M$LTSCALE system variable 552  
MULTISHAPEFITTINGCENTERLINE command 152  
MvBlock, definition 813  
MvPart Builder. See Content Builder  
MVPARTADD command 194, 419, 485  
MVPARTCONVERT 743  
MVPARTMODIFY command 231, 322, 444, 494  
MvParts 76  
adding HVAC 195  
adding inline to duct 195  
adding inline to pipe 286  
adding piping 285  
adding radiator 341  
changing size or elevation 324  
changing systems 232  
configuring for analysis 196  
connecting duct to 200  
connecting to pipe 300  
defining 760, 766  
defining catalogs for 757  
defining connectors for 760, 766  
defining sizes for 759–760  
defining views for 759–760, 766  
definition 813  
displaying by elevation 144–145  
duct add grips 200  
duct, changing elevation 222  
duct, matching 232  
duct, modifying 231  
duct, modifying location 230  
HVAC, adding, described 194  
matching in piping 324  
matching part properties 828  
mechanical, described 76  
modifying air flow values 232  
modifying custom 764, 766  
modifying in piping 322  
modifying location 322  
modifying pipe systems 324  
modifying sprinkler flow 324  
piping, described 76  
piping, modifying elevation 274  
plumbing fittings, rotating 471  
plumbing, adding 485  
plumbing, described 76  
plumbing, modifying 494  
rotating piping components 275  
See also electrical equipment  
N  
N.D., definition 813  
name, definition 813  
network 
definition 813  
plumbing 464  
neutral wire, definition 813  
nodes 
anchor, definition 813  
definition 813  
label, rotating 559  
nominal size, definition 813  
north arrow, definition 813
O.D., definition 813
object display
  by classification 154
  See also display system
object enablers 591
  definition 813
  using 590
object match. See matching part properties
object properties window 121
object snaps
  comparison to AutoCAD MEP snaps 75
  definition 813
object tools 789
objects 103–168
  anchor, definition 813
  anchoring 108, 111
  annotative, defined 549
  connectors, working with 107
  definition 813
  properties of 121, 168
  purging 590
  type, definition 814
  types of 104, 106
  viewer, definition 814
Occupancy property 187
occupancy type 485, 494
off center, definition 814
off-the-shelf parts, definition 814
offset
  definition 814
  work planes 655
OFFSET command 25
offsetting
  duct from geometry 208
  pipe from geometry 314
ohm, definition 814
Open drawing menu 136
opening symbol, definition 814
operations. See modifiers
Options dialog 69–70, 76
options for parametric parts 671
orbit, definition 814
orthogonal
  definition 814
  projection, definition 814
orthographic grips 542
orthographic mode 519
  schematic lines, adding 525, 534
  schematic symbols, adding 527
orthographic views of style-based content 86
other circuit system type 385
OTHERPOWERMODIFY command 434
outlines of parts 659
OutsideAirFlow property 187
OVALDUCTCENTERLINE command 152
over current, definition 814
overloads
  checking circuits 426
definition 814
override default plumbing fittings 489
overriding default parts during layout 305
overriding preferences 305
P
package unit, definition 814
PANEL command 358
panel rating, definition 814
panel schedules
  generating 453
panel styles
  connectors 372
  creating 599
  design rules 372
  wire cleanup 372
PANELADD command 403
PANELADDSELECTED command 403
panelboard, definition 814
PANELMODIFY command 431
PANELPROPS command 439
panels
  adding 403
  adding, example 409
  connecting across drawings 384
  connecting with wires 418
  connector style properties 372
  copying 409
  copying, example 412
  creating 599
  definition 814
  display representations 358
  matching part properties 828
  modifying properties 439
  moving 431
  moving, example 433
  overview 358
  styles, specifying wire cleanup 603
  tools 790
PANELSTYLE command 371
PANELSTYLEEDIT command 371
paper space
  definition 814
  using 66
parallel runs
  duct, adding 207
  pipe, adding 313
parameters
  definition 814
  model 665
parametric fittings
  connectors, adding 682
  creating 675
  defining work planes for 677
  dimensions, adding 687
  insertion behaviors 690
  modeling 677
  modeling parametric tee fittings 678
displaying by elevation 144–145
gravity 250–251, 256, 291, 298
grips, described 271
joints 268
lengths, described 268
matching part properties 827, 829
overriding default parts 305
part catalog, described 262
part types 262
pressure 250–251, 291, 298
routing preferences, described 250
settings for flexible pipe 311
settings, described 279
straight centerline display 261, 284
system definitions 282
systems 247
tool palette
  pressure 291, 298
tool palette, gravity 291, 298
using flow direction 118
waste 256
See also adding pipe
See also configuring pipe
pipe CEL, described 267
PIPE command 247
pipe connection types 266
Pipe connector style 616
pipe fitting
displaying by elevation 144–145
pipe fittings
  adding 306
  create custom 307
  locking size 330
  matching part properties 829
  modifying 331
  modifying elevation 274
  modifying insulation 332
  rotating 275
pipe joints
  adding 306
pipe layout preferences 289
  adding annotation 295
  adding insulation 317
  configuring justification 297
pipe part routing preferences
described 250
  See also routing preferences
pipe parts catalog 262
pipe settings 279
pipe snaps
described 270
pipe systems
  1-line placeholders 261
  checking connectivity 332
described 247
pipe, connection type (same) 266, 653
pipe, connection types 651
 PIPEADD command 286
PIPEADDSELECTED command 286
PIPECONVERT command 286
PIPECUSTOMFITTING command 307
PIPECUSTOMFITTINGPROPS command 307
PIPECUSTOMFITTINGSTYLE command 307
PIPECUSTOMFITTINGSTYLEEDIT command 307
PIPEFITTING command 306
PIPEFITTINGADD command 306
PIPEFITTINGADDNEW command 306
PIPEFITTINGADDSELECTED command 306
PIPEFITTINGMODIFY command 331
PIPEFITTINGOVERRIDE command 218
PIPEFITTINGPROPS command 331
PIPEFITTINGSTYLEEDIT command 331
PIPEFLEX command 311
PIPEFLEXADD command 311
PIPEFLEXADDSELECTED command 286
PIPEFLEXCONVERT command 318
PIPEFLEXMODIFY command 331
PIPEFLEXPROPS command 331
PIPEFLEXSTYLEEDIT command 331
PIPELENGTH command 329
PIPEMODIFY command 324
PIPEOVERRIDE command 218
PIPEPARALLEL command 348
PIPEPREFDEF command 279
PIPEPROPS command 125
PIPERISEDROPSTYLE command 614
PIPESLOPEDISPLAY command 257
PIPSYSTEMDEF command 281
PIPSYSTEMDEFEDIT command 281
PIPSYLEDIT command 603
piping. See pipe
placeholders for pipe 261
placement point
  parametric fittings 690
  parametric parts 665
plain end, see spigot/plain end 818
plan
  display representation 137
  high detail display representation 137
  low detail display representation 137
  presentation display representation 137
  screened display representation 137
  view, definition 815
plane extrusion modifier 660
planes. See UCS planes and work planes
plenum, definition 815
PLINE command 488
plotting
  configurations 592
  plot preview 592
  plot styles 592
plumbing
  adding expansion loops 491
  calculating sanitary plumbing line sizes 508–515
  calculating supply line sizes 501–508
  content, creating 477
design workflow 463
display configuration 139
equipment, adding 485
equipment, described 76
equipment, modifying 494
fixture unit table definitions 479
fixtures, adding 485
fixtures, described 76
fixtures, modifying 494
plumbing line sizing tables 475, 480
plumbing line, calculating slope 495
preferences 484
systems, configuring label and flow arrows
systems, configuring settings
systems, creating 484–491
systems, modifying 492–501
plumbing fitting styles
described 481
subtype 482
type 482
plumbing fittings
adding manually 490
definition 815
described 465
matching part properties 829
modifying location 500
modifying style 501
modifying system 498
overriding default fittings 489
rotating 471
styles, described 481
styles, specifying line cleanup 603
plumbing line sizing calculation results 475
plumbing line sizing tables 475, 480
plumbing line styles
annotation properties 481
described 481
standard sizes 482
plumbing lines
adding expansion loops 491
adding fittings manually 490
annotation properties for styles 481
break/overlap paper width 481
breaking 490
cleaning up 603
connecting lines at different elevations 489
creating from polylines 488
described 464
drawing from equipment 486
drawing from fixtures 486
drawing run 488
elevation mismatch 489
matching part properties 829
modifying elevation 499
modifying location 500
modifying size 500
modifying style 501
modifying system 498
overriding default fittings 489
plumbing preferences 484
reversing flow 499
sanitary systems, sizing 508–515
standard sizes for styles 482
styles, described 481
subtypes 482
supply systems, sizing 501–508
types 482
plumbing system definitions
black water 478
creating 478
described 465
gray water 478
specifying default fittings 478
PLUMBINGFITTING command 465
PLUMBINGFITTINGADD command 490
PLUMBINGFITTINGADDSELECTED command 490
PLUMBINGFITTINGBREAKPIPE command 490
PLUMBINGFITTINGMODIFY command 498
PLUMBINGFITTINGPROPS command 125
PLUMBINGFITTINGSTYLE command 501
PLUMBINGFITTINGSTYLEEDIT command 501
PLUMBINGLINE command 464
PLUMBINGLINEADD command 464
PLUMBINGLINEADDSELECTED command 464
PLUMBINGLINECONVERT command 488
PLUMBINGLINEINVERTELEVATION command 499
PLUMBINGLINEMODIFY command 470, 498
PLUMBINGLINEPROPS command 125
PLUMBINGLINESVERSEFLOW command 499
PLUMBINGLINESIZE command 501, 511
PLUMBINGLINESIZESANITARY command 511
PLUMBINGLINESIZE_SUPPLY command 501
PLUMBINGLINESYSTEM command 481
PLUMBINGLINESYSTEMEDIT command 481
PLUMBINGPREFERENCES command 484
PLUMBINGRISEDROPSTYLE command 98
PLUMBINGSYSTEMDEF command 478
PLUMBINGSYSTEMDEFEDIT command 478
pneumatic, definition 815
point style 676
polylines
converting to flex pipe 318
converting to flexible duct 213
converting to plumbing lines 488
converting to schematic lines 534
power and lighting circuit system type 385
power totals, calculating 428
POWERTOTALS command 428
preferences
annotation, cable trays 379
annotation, conduits 379
AutoCAD MEP snaps 75
catalogs 70
circuit names 366
configuring duct layout 174
configuring pipe part routing 250
connection rules 71
content 70
creating pipe part routing 279
default parts 83
drawing 69
drawing environment 69–76
electrical elevations 73
flexible duct 179
flexible pipe 311
flow arrows 484
initialization
initialization, defined 69
labels 484
layout
layout rules 71
layout, defined 69
modifying pipe part routing preferences 280
part selection 73
pipe, overriding 305
pipe, routing 250
plumbing lines 484
styles
tooltips 74
voltages 365
pressure
definition 815
drop, definition 815
pressure pipe 250–251
pressure-reduction valve, definition 815
preview images
bitmap resolution 751
block-based parts 750, 760
changing for block-based parts 766
parametric fittings 690
parametric parts 671, 732
primitives
creating 707
defined 663
definition 815
using for part models 702
product feedback 31
profiles
creating 785
Global 797, 801
metric 797
parametric parts 659
radiators (D A CH) 336
types of 659
U.K. 801
Project Browser 30
project database
referencing 384
See electrical project database
project management tools 30
Project Navigator 30, 58
project setup, modifying display settings 141
Project Standards feature 131
projects
Drawing Management feature 129
establishing standards 130
Project Standards feature 131
standards, displays 135
standards, layers 132
standards, templates 130
standards, xrefs 158
prompt, definition 815
properties
accessing 121–168
dialog box 121, 168
label curve
part 121–168
style-based content 600
See also part properties
properties palette 53
Properties palette
Design tab (add) 286
Design tab (modify) 325
Display tab 92
docking 92
hiding 92
modifying appearance 92
opening 91
transparency 92
using 91
property set information, adding to parts 763
property sets
block-based parts 752
definitions 588
modifying for an object 562
proxy graphics 591
PSLTSCALE system variable 552
publishing sheet sets to DWF 578
purge
AutoCAD MEP objects 590
systems 101
PURGE command 25
Q
querying
catalogs 79
part properties 121
quick access toolbar 51
Quick Select
definition 815
for pipe 318
for plumbing lines 492
for schematic lines 535
quick slice, definition 815
R
raceway, definition 815
radiators
adding radiators to drawing 341
adding valve to radiator 343
connecting multiple radiators to parallel pipes 350
connecting target radiators to parallel pipes 351
correcting radiator connection failure 351
creating custom parts 339
creating parallel pipes 347
exporting drawing information 340
routing parallel to baseline pipe 348
rules for existing radiators 339
updating using calculated data 339
using connectors to align MvParts 345
radius of curvature, definition 815
RECEPTACLEMODIFY command 434
RECTANGULARDUCTCENTERLINE command 152
reducer, definition 815
reference work planes 655
REFERENCEANCHORRELEASE command 111
REFERENCEANCHORSETREF command 110
referenced drawings. See xrefs
referencing style-based content 85
reflected display representation 137
regenerate
AutoCAD MEP model 120
definition 815
Regenerate Catalog command 782
register, definition 815
relationships of geometric features. See constraints
reloading project database 383
representation sets, definition 815
reseller information 31
return air, definition 815
return duct, definition 815
ReturnAirFlow property 187
reverse flow
definition 816
plumbing lines 499
REVERSESEGMENT command 118
revision clouds, definition 816
ribbon 33, 39
contextual tabs 47
displaying 39
locating commands 41
resources 43
static tabs 43
using 39
rise angles 475
rise/drop
specifying for a system 98
styles 614
See also styles and systems
rise/run, definition 816
riser
add from fixture to plumbing line 489
add to connecting plumbing line 489
definition 816
diagram, definition 816
objects, definition 816
riser diagram, definition 811
rod style 798
ROTATE command 25
rotate grips 450
for duct 228
for pipe 275
for plumbing fittings 471
ROTATE3D command 25
rotating label nodes 559
ROUNDDUCTCENTERLINE command 152
routing preferences
changing 328
configuring for pipe 250, 280
creating 279
deleting from drawing 281
described 250
gravity pipe 250–251
overriding parts 305
parallel pipe 349
pressure pipe 250–251
sloped piping support 250–251
routing solutions for pipe 254
3D orbit 254
isometric 254
routing, definition 816
rules
creator behavior 652
creating parametric fittings content 651
run angles 475
runs
checking connection validity of 427, 579, 581
definition 816
plumbing, defined 464
See also cable trays and conduits

S
sales information 31
same connection 266, 653
Sample Palette catalogs 787
sampling circuit, definition 816
sand filter, definition 816
sanitary plumbing line sizing tables 475, 480
sanitary plumbing lines
plumbing line sizing table definitions 475, 480
plumbing line sizing tables 501
sizing 508–515
sizing by branch 509
sizing by offset 510
sizing by stack 511
sizing for multiple floors 512
sanitary, definition 816
SANPIPESIZINGTABLEDEF command 475, 480
saving
parametric fittings 693
parametric MvParts 733
style-based content 85
SCALE command 26
scale representations
adding 554
modifying 554
scaling annotation 549
scaling symbols
by reference 545
by scale factor 544
using grips 545
schedule tables
creating property sets for 588
defining schedule data for 588
definition 816
importing 590
schedule tag, definition 816
schedules 566
adding to a drawing 566
circuit reports, creating 427
creating 587
defining data 588
definition 816
exporting as spreadsheet 568
for external drawings 567
updating 567
scheduling, definition 816
Schematic connector style 616
schematic content, creating 521
schematic design phase, definition 816
schematic diagrams
creating
described 517
isometric mode 520
modifying 534–546
orthographic mode 519
schematic display representation 137
schematic line styles
annotation properties 523
configuring 522
described 522
designation IDs 522
schematic lines
adding, isometric mode 528
adding, orthographic mode 525, 534
Break/Overlap Paper Width property 523
cleaning up 603
connecting to symbols 518–519
converting from polylines 534
designation IDs, assigning 525, 528, 534
designation IDs, modifying 536
location, modifying 538
matching part properties 830
modifying 536
styles, assigning 525, 528, 534
systems, assigning 518, 525, 534
systems, modifying 536
schematic screened display representation 137
schematic symbols 519
adding, isometric mode 531
adding, orthographic mode 527
AutoCAD-based, creating from blocks 739
AutoCAD-based, creating from scratch 738
AutoCAD-based, creating from symbols 739
block-based parts 746
connecting to lines 518
creating 599
creating for block-based parts 756
end-of-line 519
for parametric parts 673
geometry types 746
grips, isometric plane 542
grips, location 542
grips, orthographic 542
grips, rotation 542
ID labels, assigning 527–528
ID labels, modifying 537
in-line 519
location, modifying 540
matching part properties 830
modifying 537
parametric, annotating 741
parametric, creating 735
repositioning using grips 542
resizing, modifying 544
rotating, modifying 542
scaling by reference 545
scaling by scale factor 544
scaling with grips 545
styles, assigning 527, 531
styles, creating from blocks 630–631
styles, specifying line cleanup 603
systems, assigning 518, 527, 531
systems, modifying 537
types 674
types for parametric parts 735
using in 1-line display representations 672
using in 2-line display representations 672
schematic system definitions, creating 521
schematic systems. See schematic diagrams
schematic, definition 816
section
definition 816
mark, definition 817
section view drawings
creating 570
updating 575
SECURITYMODIFY command 434
see bell/hub 804
segment
definition 817
mode, definition 817
select classification 596
select connected branches
using with pipe 318
using with plumbing lines 492
using with schematic lines 535
select device 391
select panel 403
select similar 119–120
using with pipe 318
using with plumbing lines 492
using with schematic lines 535
select style 597
selecting
duct components 219
pipe components 318
plumbing components 492
schematic components 535
selecting layer key styles 647
selecting layer standards 647
service
disconnect, definition 817
drop, definition 817
entrance, definition 817
equipment, definition 817
lateral, definition 817
panel, definition 817
service/supply leads, definition 817
SETACTIVERP command 279
SETFLOW command 118
settings, pipe 279
sewage pump, definition 817
shape, definition 817
Sheet drawing template 156
sheet list tables, adding to sheets 577
sheet tabs 66
sheets
    creating 576
    creating a cover 577
    ordering in sheet set 578
    publishing to DWF 578
show all insertion points grip 431
SHOWCIRCUITS command 427
SHOWFLOW command 118
SHOWOBJECTSLIMITINGRUN command 503
single line drawing, definition 817
single line graphics 282–283
single pole, definition 817
Size Parameters dialog 667
size parameters, defined 773
size ranges
    for pipe routing preferences 252
sizes
    adding to parametric MvParts 724
    copying and pasting 669
    definition 817
    of parametric parts 641, 667
    specifying for connectors 669
    specifying for pipe connectors 670
sizing duct with external tools 241
sizing methods for duct 170
sizing tools for duct 171
slice, definition 817
SLINE command 525
SLINEADD command 525, 534
SLINEADDSELECTED command 525
SLINEPROPS command 536
SLINESTYLE command 522
SLINESTYLEEDIT command 522
slope 475
    adjust for pipe segment, definition 803
    angle displayed in drawing 257
    arrow labels, definition 817
    configuring for duct 175
    definition 817
    duct, adding 208
    format (pipe) 287
    pipe, adding 287
    plumbing line 489
slots, definition 817
snap angle, definition 817
snap grid, definition 817
snap mode, definition 817
snaps
    definition 817
    described 75
duct, described 172
electrical 361
entering 75
for pipe 270
wire ways 361
socket weld, definition 818
socket welded, definition 818
SOLAR COMPUTEr Desktop 336–339
solid to MvPart 743
solution tips 64
    applying 579
    definition 818
    marker size 579
    radiator connection failure 351
SOLUTIONTIPICONSIZE command 579
SOLUTIONTIPS command 579
SOLUTIONTIPSTOGGLE command 579
space boundaries for radiators 338
SpaceEngineeringObjects property set 187
spaces, adding engineering data to 187
spatial interferences
    definition 818
    See also interference detection
specifying pipe parts manually 303
spigot/plain end, definition 818
spine
    flexible duct 167
    flexible duct, modify 236
spine, definition 818
spreadsheets
    exporting schedules as 568
    working with part data 780
sprinklers, modifying K-factor 324
SSYSTEMDEF command 521
SSYSTEMDEFEDIT command 521
standard display configuration 139
standard sizes for plumbing line styles 482
standards
    fixture unit table definitions 479
    plumbing line sizing tables 475, 480
    See also projects
static ribbon tabs 43
Stock Tool catalog 793
storage types
    custom data 778
    defined 773
    selecting in Catalog Editor 775
storing style-based content 85
straight centerline display 261
STRETCH command 26
style definitions 85
Style Manager
    definition 818
    IFC classification 595
    style name, definition 818
    style properties
        connector rules 580
        connectors 107, 372, 608
        connectors, plumbing 483
        design rules 603
Index | 855
symbol library, definition 818
SYMBOLADD command 525
SYMBOLADDSELECTED command 525
SYMBOLPROPS command 537
system abbreviation, definition 818
system definitions
  changing for duct 235
  changing for HVAC parts 232
  configuring for duct 181
  creating for pipe 281
  creating, electrical 363
  creating, schematic 521
  duct, creating 181
  for pipe 257
  for piping MvParts 324
  See also plumbing system definitions
system groups
  definition 818
  overview 94
  specifying 97
system label, definition 818
system types
  for circuits 385
  for systems 97
system-level overrides, applying 143
  for systems 97
systems
  assigning layers 97
  assignments for connections 122
  connecting 95
  copying 100
  defining 95–100
  definition 818
  display properties 99
  mechanical default parts 83
  notes and files 100
  predefined 93
  purging 101
  specifying rise/drop styles for 98
  system types, electrical 97
  system types, plumbing 97
  working with 93–101
  See also plumbing system definitions
systems definitions
  for pipe 282

T

tabs
  contextual ribbon 47
  model 66
  sheets 66
  static ribbon 43
  work 66
tags
  adding 562
  described 561
  part number 563
TAKEOFFCENTERLINE command 152
takeoffs
  adding 211
  adding to pipe 315
  configuring for duct 180
  off-center, moving 237
  position 169

tangent, definition 818

tankless water heater, definition 818
taps
  modeling 719
  See also takeoffs
technical support 31
tees
  configuring for duct 180
  definition 818
  modeling parametric 678
templates 130, 156
  creating from drawings 157
  creating from other templates 157
  creating from scratch 158
  defaults 156
  definition 818
terminals, definition 819
Test Catalog command 781
testing
  connectors 769
  display representations of parts 768
  parts 768
  view blocks 769
  See also troubleshooting
text styles 549
therm, definition 819
thickness gauge, definition 819
threaded, definition 819
tick marks
  flipping 443
  moving 443
tips for creating block-based parts 745
title marks, definition 819
TOGGLEFLOW command 118
ton, definition 819
tool palette groups
  changing 88
tool palettes 53
  creating 787
  creating a tool palette set 787
  customizing 787–789
  modifying appearance 90
  renaming the tool palette set 788
  specifying for a profile 87
  using 87
  See also tool palettes set
Tool Palettes File Locations setting 87
tool palettes sets
  adjusting transparency 89
  changing palette group 88
  creating 787
  described 87
  docking 89
  hiding 89
  modifying appearance 89
  modifying included palettes 789
  opening 88
  renaming 788–789
  switching 789
tools
  changing images for icons 795
  changing properties 795
  creating for commands 793
  creating for devices 790
  creating for panels 790
  creating for wires 790
  creating from AEC Content 792
  customizing 789–796
  deleting 796
  described 789
  for analysis 30
  for project management 30
  modifying appearance 90
  types 789
  unspecified part 795
tools for creating 599
tooltips 60
  command tooltips 60
  dialog tooltips 61
  extended tooltips 60
  object grip tooltips 65
  object rollover tooltips 62
  palette tooltips 61
  property tooltips 62
  solution tips 64
  thumbnail previews 63
  turning on and off 61
  tool tips, definition 819
transition fittings, definition 819
transition modifier 661
transparency 89, 92
TRAYDATA command 801
TRAYDATAREGENSYSTEM command 801
TRAYDATAROTATE command 801
trigger grips 116
TRIM command 26
trim lengths
  parametric fittings 690
  parametric parts 664
trip lever, definition 819
troubleshooting
  connection 579
  drawings 579
  interference 579
trunk, definition 819
turning vanes. See vanes
tutorials 32, 43
type, definition 819

U

U.K. profile 801
UCS planes, changing 113
UCS, problems with 650
unconstrained layout, definition 819
unspecified part 795
updating views 575
user guides 31
user profiles, creating 785
UV filter system, definition 819

V
VA (volt-ampere), definition 819
valid connection. See connection
validating
  parametric fittings 693
  parametric MvParts 733
vanes
  adding to duct 214
  configuring display 178
  definition 819
  modifying 238
vertex
  definition 819
  flexible duct (spline) 236
  x, definition 819
  y, definition 819
vertical duct, drawing 201
vertical pipe
  adding 301
  connecting to 270
view blocks
  assigning to display representations 750
  assigning to MvParts 759
  block-based parts 749
  default assignments 750
  insertion point 749
  testing 769
viewports, definition 819
views
  adding a detail view 569
  adding a general view 568
  adding a section view 570
  adding an elevation view 573
  definition 819
  for construction documents 568
  style properties 604
  style-based content 86
  See also display system
volt, definition 819
voltage
  configuring 365
  definition 819

W
water filter, definition 819
water hammer
  arrestsor, definition 819
  definition 819
water meter, definition 820
water softener, definition 820
watt, definition 820
WCS, definition 820
where is my command? tool 41
width and height, definition 820
width, definition 820
wire cleanup
  device styles 367
  panel styles 372
WIRE command 359
wire segment types
  arc 413
  chamfer 413
  line 413
  polyline 413
  snake 413
  spline 413
wire style properties
  annotation 374
  specifications 373
wire ways snaps 361
WIREDNAV command 412–413
WIRED DSELECTED command 412
WIRED CONVERT command 419
WIRED PROPS command 125
wires
  adding home runs 413, 418
  adding manually 413
  adding, example 417
  annotation 374
  break/overlap paper width 374
  checking sizes for circuits 425
  cleaning up 603
  converting from arcs 419
  converting from lines 419
  converting from polylines 419
  definition 820
  generating 413
  instant sizing 360
  matching part properties 830
  modifying layouts 441
  modifying properties 441
  See also wire segment types
  tick marks, flipping 443
  tick marks, moving 443
  tools 790
  wire sizes, modifying 441
  wire sizes, specifying 413
WIRED STYLE command 373
WIRED STYLEEDIT command 373
wizard, for creating parametric parts 694
work planes 654
  adding preset 654
  defining for parametric fittings 677
  offset 655
  parametric MvParts 700
  reference 655
  restrictions 654
work planes, definition 820
work tab 66
workflow
  AutoCAD MEP 28
  construction documents 547
  creating radiator pipework 346
  creating radiator systems overview 335
  definition 820
  placing radiators in drawing 337
working with
  anchors 108, 111
  objects 103, 168
  systems 93
workspaces
  application menu 48
  application status bar 56
  command window 55
  communication center 60
  components 38
  context menus 52
  creating 37
  defaults 36
  drawing window status bar 53
  fundamentals 35
  InfoCenter 59
  overview 34
  Project Navigator palette 58
  Properties palette 53
  quick access toolbar 51
  ribbon 39
  switching 37
  tool palettes 53
tooltips 60
  command tooltips 60
  dialog tooltips 61
  extended tooltips 60
  object grip tooltips 65
  object rollover tooltips 62
  palette tooltips 61
  property tooltips 62
  solution tips 64
  thumbnail previews 63
  turning on and off 61
wye, definition 820

X

XCLIP command 160
XML part definition file 773
xrefs
  attaching 159
  changing display configurations 161
  clipping 160
  connecting ducts with 209
  definition 820
  described 158
  overlaying 159
  reloading 160
  types, described 159
XY angle, definition 820

Z

zone, definition 820