# Contents

**Overview** ................................................................. 1

**Chapter 1**  
**About AutoCAD Mechanical** ........................................... 3  
AutoCAD Mechanical Software Package ................................... 3  
Leveraging Legacy Data ...................................................... 3  
Starting AutoCAD Mechanical ............................................. 4  
AutoCAD Mechanical Help ................................................... 4  
Product Support and Training Resources ................................... 5  
Design Features in AutoCAD Mechanical ................................. 5
  Mechanical Structure ....................................................... 5
  Associative Design and Detailing ......................................... 6
  External References for Mechanical Structure ....................... 7
  Associative 2D Hide ........................................................ 7
  Autodesk Inventor link ...................................................... 8
  2D Design Productivity .................................................... 8
  Engineering Calculations .................................................. 9
  Machinery Systems Generators .......................................... 9
  Intelligent Production Drawing and Detailing ......................... 10
  Detailing Productivity ..................................................... 10
  Annotations ................................................................. 11
  Standard Mechanical Content .......................................... 11
  Standard Parts Tools ...................................................... 11
  Collaboration .................................................................... 12
Using Libraries to Insert Parts .............................................. 103
Configuring Snap Settings .................................................. 104
Creating Construction Lines (C-Lines) ................................. 105
Creating additional C-Lines .................................................. 108
Creating Contours and Applying Fillets ................................. 110
Trimming Projecting Edges on Contours ............................... 113
Applying Hatch Patterns to Contours ................................... 116
Dimensioning Contours ...................................................... 117
Creating and Dimensioning Detail Views .............................. 119

Chapter 6 Working with Model Space and Layouts ................. 125
Key Terms ................................................................. 125
Working with Model Space and Layouts ............................... 126
Getting Started ............................................................ 126
Creating Scale Areas ....................................................... 127
Creating Detail Views ....................................................... 129
Generating New Viewports ............................................... 131
Inserting Holes Within Viewports ....................................... 133
Creating Subassemblies in New Layouts.............................. 138

Chapter 7 Dimensioning ..................................................... 143
Key Terms ................................................................. 143
Adding Dimensions to Drawings ........................................ 144
Adding Multiple Dimensions Simultaneously ....................... 145
Editing Dimensions with Power Commands ......................... 149
Breaking Dimension Lines ............................................... 153
Inserting Drawing Borders ............................................... 154
Inserting Fits Lists ........................................................ 156

Chapter 8 Working with 2D Hide and 2D Steel Shapes .......... 159
Key Terms ................................................................. 159
Working with 2D Hide and 2D Steel Shapes ......................... 160
Opening the initial drawing ............................................... 160
Defining 2D Hide Situations ............................................. 161
Inserting 2D Steel Shapes ............................................... 164
Modifying Steel Shapes Using Power Commands .................. 167
Editing 2D Hide Situations ............................................... 168
Copying and Moving 2D Hide Situations .............................. 171

Chapter 9 Working with Standard Parts ............................... 175
Key Terms ................................................................. 175
Working with Standard Parts ............................................ 176
Inserting Screw Connections ............................................ 178
Copying Screw Connections with Power Copy ....................... 184

Contents | v
Chapter 10 Working with BOMs and Parts Lists

Key Terms

Working with Parts Lists
Inserting Part References
Editing Part References
Placing Balloons
Creating Parts Lists
Merging and Splitting Items In Parts Lists
Collecting Balloons
Sorting and Renumbering Items In Parts Lists
Using Filters

Chapter 11 Creating Shafts with Standard Parts

Key Terms

Creating Shafts
Configuring Snap Options
Configuring Shaft Generators
Creating Cylindrical Shaft Sections and Gears
Inserting Spline Profiles
Inserting Chamfers and Fillets
Inserting Shaft Breaks
Creating Side Views of Shafts
Inserting Threads on Shafts
Editing Shafts and Inserting Sections
Replacing Shaft Sections
Inserting Bearings

Engineering Calculations

Chapter 12 Calculating Shafts

Key Terms

Calculating Shafts
Creating Shaft Contours
Specifying Material
Overview

Part I provides information for getting started with your AutoCAD® Mechanical software. It includes an overview of the product capabilities, a summary of commands with their toolbuttons and descriptions, and a summary of new and revised commands in this release of AutoCAD Mechanical.

In addition, Part I includes information about methods to access commands, AutoCAD Mechanical Help, and product support and training resources.
About AutoCAD Mechanical

This chapter provides information about the AutoCAD® Mechanical software application. It describes the software package, the basic design features in the software, and the methods for accessing commands.

A brief overview of the Help, along with information about where to find resources for product learning, training, and support are included.

AutoCAD Mechanical Software Package

AutoCAD Mechanical is a 2D mechanical design and drafting solution for engineers, designers, and detailers. Its intelligent production drawing and detailing features decrease the time required to create and change 2D production designs. AutoCAD Mechanical introduces many 3D concepts in a familiar 2D environment. It is powered by AutoCAD®, with its easy-to-use palette interface and time-saving xref functionality.

The AutoCAD Mechanical design software package includes both AutoCAD Mechanical and AutoCAD. You can use one Options dialog box to customize settings for both AutoCAD Mechanical and AutoCAD.

Leveraging Legacy Data

The tools for migrating legacy data are installed automatically when you install the AutoCAD Mechanical software. A separate utility tool is available for adding structure to legacy files after they are migrated.
The integrated Autodesk® IGES Translator for transferring and sharing of CAD data between CAD/CAM/CAE systems is installed along with the AutoCAD Mechanical product.

Newly generated files in AutoCAD Mechanical can be saved to a previous version so that you can run multiple versions of AutoCAD Mechanical within the same environment.

**Starting AutoCAD Mechanical**

You can start AutoCAD Mechanical by using one of the following procedures:

- Click Start on the task bar, and then choose Programs. Select Autodesk ➤ AutoCAD Mechanical 2010.

- On the desktop, double-click the AutoCAD Mechanical icon:

**AutoCAD Mechanical Help**

The Help in AutoCAD Mechanical provides information about AutoCAD Mechanical with the power pack.

The Help is formatted for easy navigation, and includes:

- Content organized by the major functional areas of AutoCAD Mechanical, with Concept, Reference, and Procedure pages for each functional area. Procedure pages provide step by step instructions on how to execute a given task. The linked Concept page provides background information about the procedure. The linked Reference pages contain information about all the commands and dialog boxes visited while performing the procedure.

- Specific information about each of the features in the program.

- Concepts and procedures for the new features in this release.

- A keyword index and search function.

- Guides to system variables and accelerator keys.

- Access to Support Assistance with integrated links to solutions.
For access to Help, you can choose from the following methods:

- From the Help menu, select Mechanical Help Topics.
- Select the Help button in the standard toolbar.
- Press F1.
- Click the Help button within a dialog box.

**Product Support and Training Resources**

Be more productive with Autodesk software. Get trained at an Autodesk Authorized Training Center (ATC®) with hands-on, instructor-led classes to help you get the most from your Autodesk products. Enhance your productivity with proven training from over 1,400 ATC sites in more than 75 countries. For more information about Autodesk Authorized Training Centers, contact atc.program@autodesk.com or visit the online ATC locator at www.autodesk.com/atc.

Sources for product support are listed on the AutoCAD Mechanical Product Information Web page. From the AutoCAD Mechanical Web site at http://www.autodesk.com/autocadmech, navigate to the Support Knowledge Base. You can also navigate to the Community page, which contains links to various communities, including the AutoCAD Mechanical Discussion Group.

**Design Features in AutoCAD Mechanical**

This section provides an overview of the functionality in the AutoCAD Mechanical software, including numerous innovative 2D design features.

**Mechanical Structure**

Mechanical structure comprises a suite of 2D structure tools for organizing drawings and for reusing associative data. The capabilities of reuse in blocks and accessibility in layer groups are combined in mechanical structure. When you start the AutoCAD Mechanical application, the Mechanical structure environment is enabled by default. You can also work with it disabled.
The mechanical structure tools include:

- A browser interface for structured 2D mechanical design, where parts, assemblies, views, and folders containing associated data are organized, structured, and managed. Standard parts are automatically organized and managed in the browser. All components are accessible through the browser for many functions, and filters can be set to control the type and level of detail of information displayed.

- Folders in the browser are used for capturing elements of design for reuse. These elements provide all of the associative instancing benefits of components, but do not register as items in the live BOM database. They can contain geometry.

- All geometry remains selectable and editable at all times using familiar commands in open workflows. Workflows for structure can be bottom-up (recommended), middle-out (the most flexible and common workflow), and top-down (not the primary workflow).

**Associative Design and Detailing**

The browser is used to manage and reuse data in both the design and detailing drafting stages. Many functions can be performed in the browser, including the following:

- You can instance components and assemblies multiple times. The live BOM database in AutoCAD Mechanical keeps track of the quantity of each part or assembly used.

- Changes made to an associative instance of a part or assembly, associative component, assembly detailing view, or a standard part or feature are automatically reflected in the other instances.

- Folders, components, and individual views of components can be reused as needed. They maintain full associativity with each other.

- Annotation views can be created for components and assemblies to fully document the design. Changes made to geometry result in associative dimensions being updated to reflect the change.
External References for Mechanical Structure

External References for mechanical structure provides for the components of a drawing to be inserted as an external reference to multiple drawings. Conversely, multiple drawings can be attached as external references to a single drawing.

The following are the key benefits of external references for mechanical structure:

- Increased efficiency by allowing insertion of structure components from many drawings as external reference associatively for concurrent design.
- Reuse of parts from existing assembly drawings very quickly.
- Those involved in multiple design projects that reference the same drawing are able to obtain the most updated design from the externally reference component.
- Ability to set up design specific reference directories as libraries for different applications.

Associative 2D Hide

The 2D hide situation tool in AutoCAD Mechanical automates the process to accurately represent parts and features which are partially or completely hidden in drawing views. The following are some of the 2D hide benefits:

- Associative hide situations are managed in the browser.
- The underlying geometry is not altered when you create an associative hide situation.
- When geometry is hidden, AutoCAD Mechanical knows it is a component in the mechanical structure, and provides a tooltip with the name and view of the component.
**Autodesk Inventor link**

Autodesk Inventor® link redefines the meaning of 3D to 2D interoperability. Use the functionality to link to Autodesk Inventor parts and assemblies to:

- Access and associatively document native 3D part models without the presence of Autodesk Inventor.
- Visualize part models, examine and use part properties such as material, name, and number.
- Associatively document part models using precision hidden-line removed projections, dimensions, and annotations.
- Link to the native Autodesk Inventor part models automatically notifies you of changes and enables updating of views and annotations to keep your drawing up-to-date.

**2D Design Productivity**

These features increase productivity and reduce the number of steps needed to complete mechanical designs:

- AutoCAD Mechanical provides an intelligent, customizable layer management system that puts objects on the appropriate layers automatically.
- Entities that are not on the current layer group, or entities that are on a locked layer group can be displayed in a different color to reduce screen clutter.
- 2D hidden-line calculations are based on defined foreground and background objects. You can choose hidden line representation types.
- Auto detailing creates detailed drawings of individual components from an assembly drawing.
- One set of power commands is used to create, update, and edit objects.
- Mechanical line objects are available for creating centerlines and center crosses, construction lines, symmetrical lines, section lines, break lines, and others.
- Linear/symmetric stretch is used to modify dimensioned geometry by changing the dimension value.
Predefined hatch patterns are applicable in two picks from toolbars and menus.

**Engineering Calculations**

The automatic engineering calculations available in AutoCAD Mechanical ensure proper function in mechanical designs.

- The 2D FEA feature determines the resistance capability of an object put under a static load and analyzes design integrity under various loads.
- A number of moment of inertia and beam deflection calculations are available.
- Engineering calculations are available for shafts, bearings, and screws.

**Machinery Systems Generators**

Machinery systems in AutoCAD Mechanical generate the design and calculation of shafts, springs, belts and chains, and cams. These tools ensure that you get the design right the first time:

- With the shaft generator, you can create drawing views of solid and hollow shafts. Common shaft features supported include center holes, chamfers, cones, fillets, grooves, profiles, threads, undercuts, and wrench fittings. Common standard parts supported include bearings, gears, retaining rings, and seals.

- With the spring generator, you select, calculate, and insert compression, extension, and torsion springs, and Belleville spring washers in a design. You control the representation type of the spring, and create a spec form to incorporate in the drawing.

- The belt and chain generator function provides features to create chain and sprocket systems, belt and pulley systems, calculate optimal lengths for chains and belts, and insert these assemblies in your design. Chains and belts can be selected from standard libraries.

- The cam generator creates cam plates and cylindrical cams given input border conditions. You can calculate and display velocity, acceleration, and the cam curve path. You can couple driven elements to the cam and create NC data through the curve on the path.
Intelligent Production Drawing and Detailing

A number of commands are available in AutoCAD Mechanical that automate the process to create balloons and bills of material.

- You can create formatted balloons and bills of material, as well as detailed views of portions of designs.
- Multiple parts lists per drawing are supported. Grouping of a parts list provides lists of like items. Selected items can be combined to calculate total length required for stock ordering. The parts lists recognize standard parts. You can format item numbers on parts lists.
- Standard-sized drawing borders and customizable title blocks are available.
- Intelligent and associative hole tables show a total count of each type of hole along with a description of them. A second chart lists the coordinates for each of the holes selected. Any update to the holes is reflected in the charts.
- A language converter translates text on a drawing into one of seventeen different languages.
- Revision control tables in drawings track revisions and display comments.
- Fits lists chart all fits used in a drawing.

Detailing Productivity

- Smart dimensions automatically maintain the proper arrangement with each other.
- Power dimension commands provide a single command to create and edit all dimensions, apply specified formats, and add fits or tolerances.
- Dimensions are automatic for 2D geometry with either ordinate or baseline dimensions.
- One command quickly cleans up and arranges dimensions in 2D drawings. One system setting controls the scale for drawing symbols in all views.
- Commands are available for align, break, insert, and join to easily dimension a drawing.
Annotations

- Hole notes can be inserted for standard holes.
- Commands are available to create standards-based surface texture symbols, geometric dimensioning and tolerances, targets, and weld symbols.
- Fits description command creates fits descriptions for standard holes.
- Leader command creates intelligent balloons and other leaders common in mechanical drawings.

Standard Mechanical Content

Standard content includes parametrically generated, intelligent geometry that you can use to generate an object from scratch. The following are available:

- About 600,000 standard parts, including screws, nuts, washers, pins, rivets, bushings, rings, seals, bearings, keys, and others, can be quickly incorporated into any design.
- About 8,000 standard features, including center holes, undercuts, keyways, and thread ends can be quickly incorporated into any design.
- More than 20,000 standard holes, including through, blind, counterbored, countersunk, oblong, and others, can be quickly incorporated into any design.
- Thousands of structural steel shapes, including U-shape, I-shape, T-shape, L-shape, Z-shape, rectangular tube, round tube, rectangular full beam, rectangular round beam, and others, can be quickly incorporated into any design.
- An editing environment to create and publish your own content libraries.

Standard Parts Tools

Standard part tools provide for the elements that go with standard parts, such as a hole to accompany a screw. These tools include:

- Screw connection feature for selecting entire fastener assemblies at one time.
Changeable representation of a standard part between a normal, simplified, or symbolic representation.

Power view to automatically generate a different view of a standard part, such as a top view from a front view.

**Collaboration**

Enjoy the benefits of design collaboration for your 2D output through Autodesk Streamline® support. Autodesk Streamline is a hosted Web service for sharing personalized design data across the entire extended manufacturing enterprise.

Autodesk Streamline functionality includes the following:

- Members can view and interact with the 3D data set published on Autodesk Streamline, without waiting for the data to download.

- Using Streamline, many people can share design information and collaborate online. Functionality includes instant messages, email notifications, polling/voting, discussion threads, database creation, and more.

- AutoCAD Mechanical data can be written to the AutoCAD DWF file format, which is one of the file types that Autodesk Streamline leverages.

- You can export 3D CAD data in ZGL format (a compressed form of a standard Open GL file format called XGL). ZGL readily captures 3D data that can be rendered by the Open GL library. ZGL files can then be uploaded to Autodesk Streamline.
This chapter provides a list of the commands available in AutoCAD® Mechanical, along with a brief description of the function of each command and the associated tool button.

**Command Summary**

The following is a list of the AutoCAD Mechanical commands, a brief description of each, and the associated icon. The icon is used in the ribbon as well as toolbars. Some commands do not have an associated icon. This list does not contain AutoCAD® commands.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Command Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="AM2DHIDE Icon" /></td>
<td>AM2DHIDE</td>
<td>Draws hidden lines to represent hidden edges, when you specify what objects lie in front and what objects lie behind.</td>
</tr>
<tr>
<td><img src="image" alt="AM2DHIDEDIT Icon" /></td>
<td>AM2DHIDEDIT</td>
<td>Edits or updates hide situations created with the AM2DHIDE command.</td>
</tr>
<tr>
<td><img src="image" alt="AMABOUT Icon" /></td>
<td>AMABOUT</td>
<td>Displays a screen containing licensing and copyright information.</td>
</tr>
<tr>
<td><img src="image" alt="AMADJRINGS2D Icon" /></td>
<td>AMADJRINGS2D</td>
<td>Inserts an adjusting ring on a shaft.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>AMANALYSEDWG</td>
<td>Analyzes the current drawing and writes layer information to an ALZ file.</td>
</tr>
<tr>
<td></td>
<td>AMANOTE</td>
<td>Creates a textual annotation that can be attached to an object in a drawing view.</td>
</tr>
<tr>
<td></td>
<td>AMASSOHATCH</td>
<td>Creates a hatch that updates when you modify its boundaries.</td>
</tr>
<tr>
<td></td>
<td>AMAUTOCLINES</td>
<td>Creates vertical and horizontal construction lines on all endpoints of selected objects.</td>
</tr>
<tr>
<td></td>
<td>AMAUTODETAIL</td>
<td>Moves the selected objects to an external drawing file and creates an xref to it within the current drawing.</td>
</tr>
<tr>
<td></td>
<td>AMAUTODIM</td>
<td>Creates multiple dimensions from a selected point to all the vertices on the contour of selected objects.</td>
</tr>
<tr>
<td></td>
<td>AMBALLOON</td>
<td>Creates and places balloons in the drawing area.</td>
</tr>
<tr>
<td></td>
<td>AMBEARCALC</td>
<td>Determines the limiting value, dynamic and static load rating, dynamic and static equivalent load, and fatigue life of a bearing.</td>
</tr>
<tr>
<td></td>
<td>AMBELL2D</td>
<td>Performs a spring calculation and inserts a Bellville washer spring in the drawing area.</td>
</tr>
<tr>
<td></td>
<td>AMBHOLE2D</td>
<td>Inserts a blind hole from the content library.</td>
</tr>
<tr>
<td></td>
<td>AMBOM</td>
<td>Creates, edits, or deletes Bills of Materials (BOMs).</td>
</tr>
<tr>
<td></td>
<td>AMBOMEXTTEMP</td>
<td>Creates an extraction template to be used by BOM Migration Utility.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image1.png" alt="Icon" /></td>
<td>AMBOMMIGRATE</td>
<td>Migrates non-AutoCAD Mechanical drawings to the latest AutoCAD Mechanical drawing format. Legacy BOM data within the drawings will be migrated to intelligent BOM and Parts list data.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Icon" /></td>
<td>AMBREAKATPT</td>
<td>Breaks a line, polyline, or a spline at a specified point.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Icon" /></td>
<td>AMBROUTLINE</td>
<td>Draws a special spline to show breakout borders.</td>
</tr>
<tr>
<td><img src="image4.png" alt="Icon" /></td>
<td>AMBROWSER</td>
<td>Displays, hides, and moves the mechanical browser.</td>
</tr>
<tr>
<td><img src="image5.png" alt="Icon" /></td>
<td>AMBSLOT2D</td>
<td>Inserts a blind slot from the content library.</td>
</tr>
<tr>
<td>AMC_Break_Line</td>
<td>Draws break out lines, as in hatched loop breaks or freehand breaks in shafts.</td>
<td></td>
</tr>
<tr>
<td>(Layer Name)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AMC_Centerline</td>
<td>Draws centerline.</td>
<td></td>
</tr>
<tr>
<td>(Layer Name)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AMC_Construction</td>
<td>Draws construction lines to display with the content.</td>
<td></td>
</tr>
<tr>
<td>(Layer Name)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AMC_Construction_Invisible</td>
<td>Draws construction lines that do not display with the content.</td>
<td></td>
</tr>
<tr>
<td>(Layer Name)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AMC_Contour</td>
<td>Draws contour edges.</td>
<td></td>
</tr>
<tr>
<td>(Layer Name)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AMC_Contour_BHII</td>
<td>Draws contours that make underlying and overlapping objects invisible in a hide situation.</td>
<td></td>
</tr>
<tr>
<td>(Layer Name)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AMC_Contour_BHII_Invisible</td>
<td>Draws contours that do not display with the content, and make underlying and overlapping objects invisible in a hide situation.</td>
<td></td>
</tr>
<tr>
<td>(Layer Name)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image" alt="AMC_Contour_BHIU" /></td>
<td>AMC_Contour_BHIU (Layer Name)</td>
<td>Draws contours that make underlying objects invisible, and leave overlapping objects unchanged in a hide situation.</td>
</tr>
<tr>
<td><img src="image" alt="AMC_Contour_BHIU_Invisible" /></td>
<td>AMC_Contour_BHIU_Invisible (Layer Name)</td>
<td>Draws contours that do not display with the content, make underlying objects invisible, and leave overlapping objects unchanged in a hide situation.</td>
</tr>
<tr>
<td><img src="image" alt="AMC_Dimension" /></td>
<td>AMC_Dimension (Layer Name)</td>
<td>Draws dimensions to display with the content.</td>
</tr>
<tr>
<td><img src="image" alt="AMC_Dimension_Invisible" /></td>
<td>AMC_Dimension_Invisible (Layer Name)</td>
<td>Draws dimensions that do not display with the content.</td>
</tr>
<tr>
<td><img src="image" alt="AMC_Hidden" /></td>
<td>AMC_Hidden (Layer Name)</td>
<td>Draws hidden edges.</td>
</tr>
<tr>
<td><img src="image" alt="AMC_Text_Medium" /></td>
<td>AMC_Text_Medium (Layer Name)</td>
<td>Draws text that derives its color from the Text Medium object. However, this object does not control the height of the text you draw.</td>
</tr>
<tr>
<td><img src="image" alt="AMC__THREAD" /></td>
<td>AMC_Thread (Layer Name)</td>
<td>Draws thread lines.</td>
</tr>
<tr>
<td><img src="image" alt="AMCAM" /></td>
<td>AMCAM</td>
<td>Displays a wizard for the design of linear, circular, or cylindrical cams.</td>
</tr>
<tr>
<td><img src="image" alt="AMCARRAY" /></td>
<td>AMCARRAY</td>
<td>Creates multiple copies of content objects in a pattern.</td>
</tr>
<tr>
<td><img src="image" alt="AMCARRAYEDIT" /></td>
<td>AMCARRAYEDIT</td>
<td>Edits an existing content array object.</td>
</tr>
<tr>
<td><img src="image" alt="AMCENCRCORNER" /></td>
<td>AMCENCRCORNER</td>
<td>Places a hole at a specified distance from two contour lines.</td>
</tr>
<tr>
<td><img src="image" alt="AMCENCRCRANGLE" /></td>
<td>AMCENCRCRANGLE</td>
<td>Creates concentric pitch circles and places holes on it at specified angles.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMCENCRFULLCIRCLE</td>
<td>Creates concentric pitch circles and places a specified number of holes on them, distributed uniformly.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMCENCRHOLE</td>
<td>Places a hole at a specified point.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMCENCRINHOLE</td>
<td>Places a centerline cross on a circle.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMCENCROSS</td>
<td>Places a centerline cross at a specified point.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMCENCRCRPLATE</td>
<td>Places holes at the corners of a closed contour that represents a plate.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMCENINBET</td>
<td>Draws a centerline in between two lines to mark them as symmetrical.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMCENTERHOLE2D</td>
<td>Inserts a centerhole from the content library.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMCENTLINE</td>
<td>Draws a centerline at a specified place in the drawing area.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMCHAINDRAW</td>
<td>Draws a chain or belt links along a polyline.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMCHAINLENGTHCAL</td>
<td>Calculates the required length of a chain or belt when you trace the path of the chain or belt.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMCHAM2D</td>
<td>Connects two non-parallel objects by extending or trimming them to intersect or to join with a beveled line.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td><img src="image1.png" alt="Icon" /></td>
<td>AMCHAM2D_DIM</td>
<td>Creates dimensions for chamfers.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Icon" /></td>
<td>AMCHATCH</td>
<td>Defines content hatch objects in templates for part or feature views.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Icon" /></td>
<td>AMCHATCHEDIT</td>
<td>Edits an existing content hatch object.</td>
</tr>
<tr>
<td><img src="image4.png" alt="Icon" /></td>
<td>AMCHECKDIM</td>
<td>Highlights or edits dimensions with dimension text overrides.</td>
</tr>
<tr>
<td><img src="image5.png" alt="Icon" /></td>
<td>AMCLAYER</td>
<td>Displays the Content Editor Layers dialog box.</td>
</tr>
<tr>
<td><img src="image6.png" alt="Icon" /></td>
<td>AMCLEVISPIN2D</td>
<td>Inserts a clevis pin from the content library.</td>
</tr>
<tr>
<td><img src="image7.png" alt="Icon" /></td>
<td>AMCLINEL</td>
<td>Locks or unlocks construction line layers.</td>
</tr>
<tr>
<td><img src="image8.png" alt="Icon" /></td>
<td>AMCLINEL</td>
<td>Locks or unlocks the construction line layer.</td>
</tr>
<tr>
<td><img src="image9.png" alt="Icon" /></td>
<td>AMC.LINEO</td>
<td>Freezes or thaws construction line layers.</td>
</tr>
<tr>
<td><img src="image10.png" alt="Icon" /></td>
<td>AMCLOSE</td>
<td>Closes the Content Editor.</td>
</tr>
<tr>
<td><img src="image11.png" alt="Icon" /></td>
<td>AMCOMP2D</td>
<td>Performs a spring calculation and inserts a compression spring in the drawing area.</td>
</tr>
<tr>
<td><img src="image12.png" alt="Icon" /></td>
<td>AMCONST_CIRCLE</td>
<td>Draws a construction line circle.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image1" alt="AMCONSTC2 Icon" /></td>
<td>AMCONSTC2</td>
<td>Draws a construction line circle that uses a specified line as a tangent.</td>
</tr>
<tr>
<td><img src="image2" alt="AMCONSTCC Icon" /></td>
<td>AMCONSTCC</td>
<td>Draws a construction line circle that is concentric to a specified circle.</td>
</tr>
<tr>
<td><img src="image3" alt="AMCONSTCCREA Icon" /></td>
<td>AMCONSTCCREA</td>
<td>Draws a construction line circle to represent a top view of a shaft or hole.</td>
</tr>
<tr>
<td><img src="image4" alt="AMCONSTCIRCLI Icon" /></td>
<td>AMCONSTCIRCLI</td>
<td>Draws a construction line rectangle around a circle.</td>
</tr>
<tr>
<td><img src="image5" alt="AMCONSTCRS Icon" /></td>
<td>AMCONSTCRS</td>
<td>Draws a construction line cross.</td>
</tr>
<tr>
<td><img src="image6" alt="AMCONSTHB Icon" /></td>
<td>AMCONSTHB</td>
<td>Draws a construction line when you specify two points or a point and an angle.</td>
</tr>
<tr>
<td><img src="image7" alt="AMCONSTHM Icon" /></td>
<td>AMCONSTHM</td>
<td>Draws a construction line that bisects an angle.</td>
</tr>
<tr>
<td><img src="image8" alt="AMCONSTHOR Icon" /></td>
<td>AMCONSTHOR</td>
<td>Draws a horizontal construction line.</td>
</tr>
<tr>
<td><img src="image9" alt="AMCONSTHW Icon" /></td>
<td>AMCONSTHW</td>
<td>Draws a construction line through a point, by specifying an angle relative to an apparent line that goes through that point.</td>
</tr>
<tr>
<td><img src="image10" alt="AMCONSTKR Icon" /></td>
<td>AMCONSTKR</td>
<td>Draws a construction line that is tangential to two specified circles.</td>
</tr>
<tr>
<td><img src="image11" alt="AMCONSTLINES Icon" /></td>
<td>AMCONSTLINES</td>
<td>Draws construction lines.</td>
</tr>
<tr>
<td><img src="image12" alt="AMCONSTLOT Icon" /></td>
<td>AMCONSTLOT</td>
<td>Draws a construction line that is perpendicular to a specified line.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image" alt="AMCONSTLOT2" /></td>
<td>AMCONSTLOT2</td>
<td>Draws a construction line through a specified point that is a perpendicular to the direction specified by another point or angle.</td>
</tr>
<tr>
<td><img src="image" alt="AMCONSTPAR" /></td>
<td>AMCONSTPAR</td>
<td>Draws a construction line parallel to an existing line at a specified distance.</td>
</tr>
<tr>
<td><img src="image" alt="AMCONSTPAR2" /></td>
<td>AMCONSTPAR2</td>
<td>Draws a construction line parallel to an existing line and bisects the distance between the selected line and a specified point or a specified distance.</td>
</tr>
<tr>
<td><img src="image" alt="AMCONSTSWI" /></td>
<td>AMCONSTSWI</td>
<td>Switches between construction lines that extend to infinity in both directions or lines that extend in one direction only.</td>
</tr>
<tr>
<td><img src="image" alt="AMCONSTTAN" /></td>
<td>AMCONSTTAN</td>
<td>Draws two parallel construction lines that are tangential to a specified circle.</td>
</tr>
<tr>
<td><img src="image" alt="AMCONSTTC" /></td>
<td>AMCONSTTC</td>
<td>Draws two construction lines that are tangential to two specified circles.</td>
</tr>
<tr>
<td><img src="image" alt="AMCONSTVER" /></td>
<td>AMCONSTVER</td>
<td>Draws a vertical construction line.</td>
</tr>
<tr>
<td><img src="image" alt="AMCONSTXLINE" /></td>
<td>AMCONSTXLINE</td>
<td>Draws a construction line through a point, which extends to infinity in both directions.</td>
</tr>
<tr>
<td><img src="image" alt="AMCONSTXRAY" /></td>
<td>AMCONSTXRAY</td>
<td>Draws a construction line starting from a point and extends to infinity in one direction.</td>
</tr>
<tr>
<td><img src="image" alt="AMCONSTZ" /></td>
<td>AMCONSTZ</td>
<td>Draws a construction line along the z axis.</td>
</tr>
<tr>
<td><img src="image" alt="AMCONTENTADD" /></td>
<td>AMCONTENTADD</td>
<td>Creates new content from scratch, the current drawing, or by selecting a block definition in the current drawing.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>AMCONTENTEDIT</td>
<td>Edits the template of the selected view when a Content Library part or feature on a drawing is selected.</td>
</tr>
<tr>
<td></td>
<td>AMCONTENTLIB</td>
<td>Displays the Content Libraries.</td>
</tr>
<tr>
<td></td>
<td>AMCONTENTLIB</td>
<td>Opens the Content Libraries for selection and insertion of content.</td>
</tr>
<tr>
<td></td>
<td>AMCONTENTLIB-MIGRATE</td>
<td>Migrates Vario libraries to the current release of AutoCAD Mechanical.</td>
</tr>
<tr>
<td></td>
<td>AMCONTENTMANAGER</td>
<td>Displays the Content Manager.</td>
</tr>
<tr>
<td></td>
<td>AMCONTENTMIGRATE</td>
<td>Migrates legacy Vario parts and features to the current AutoCAD Mechanical format.</td>
</tr>
<tr>
<td></td>
<td>AMCONTRACM</td>
<td>Creates a closed polyline that traces the inner contour of an enclosed area.</td>
</tr>
<tr>
<td></td>
<td>AMCONOUT</td>
<td>Creates a closed polyline that traces the outer contour of an enclosed area.</td>
</tr>
<tr>
<td></td>
<td>AMCONTRACM</td>
<td>Creates a closed contour that traces the contour of an area by letting you specify the boundaries segment by segment.</td>
</tr>
<tr>
<td></td>
<td>AMCONVDWG</td>
<td>Changes layers properties (layer name, color, linetype, lineweight) to that specified in a Conversion Control file (CCF file).</td>
</tr>
<tr>
<td></td>
<td>AMCOPILG</td>
<td>Copies objects on one or more layer groups to a new layer group.</td>
</tr>
<tr>
<td></td>
<td>AMCOPYRM</td>
<td>Performs copy, rotate, and move operations on specified objects, in sequence</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image1.png" alt="Icon" /></td>
<td>AMCOPYRM_MR</td>
<td>Copies, then moves, and then rotates the specified objects.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Icon" /></td>
<td>AMCOPYRM_R</td>
<td>Copies, then rotates specified objects.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Icon" /></td>
<td>AMCOPYRM_RM</td>
<td>Copies, then rotates, and then moves specified objects.</td>
</tr>
<tr>
<td><img src="image4.png" alt="Icon" /></td>
<td>AMCOPYVIEW</td>
<td>Copies a drawing view to the same layout or to a different layout.</td>
</tr>
<tr>
<td><img src="image5.png" alt="Icon" /></td>
<td>AMCOTTERPIN2D</td>
<td>Inserts a cotter pin from the content library.</td>
</tr>
<tr>
<td><img src="image6.png" alt="Icon" /></td>
<td>AMCOUNTB2D</td>
<td>Inserts a counterbore from the content library.</td>
</tr>
<tr>
<td><img src="image7.png" alt="Icon" /></td>
<td>AMCOUNTS2D</td>
<td>Inserts a countersink from the content library.</td>
</tr>
<tr>
<td><img src="image8.png" alt="Icon" /></td>
<td>AMCPARTREF</td>
<td>Places one content part reference in a view.</td>
</tr>
<tr>
<td><img src="image9.png" alt="Icon" /></td>
<td>AMCRIVET2D</td>
<td>Inserts a countersunk rivet from the content library.</td>
</tr>
<tr>
<td><img src="image10.png" alt="Icon" /></td>
<td>AMCSAVE</td>
<td>Saves the current view.</td>
</tr>
<tr>
<td><img src="image11.png" alt="Icon" /></td>
<td>AMCSAVEAS</td>
<td>Saves the current view in Content Editor to a different name.</td>
</tr>
<tr>
<td><img src="image12.png" alt="Icon" /></td>
<td>AMCSETTINGS</td>
<td>Displays the Content Settings dialog box.</td>
</tr>
<tr>
<td><img src="image13.png" alt="Icon" /></td>
<td>AMCSWITCHVIEW</td>
<td>Navigates between views.</td>
</tr>
<tr>
<td><img src="image14.png" alt="Icon" /></td>
<td>AMCTABLE</td>
<td>Displays the Family Table.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>---------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>AMCTABLECLOSE</td>
<td>Closes the Family Table.</td>
</tr>
<tr>
<td></td>
<td>AMCTABLETOGGLE</td>
<td>Creates content families by attaching a Family Table to parts or features.</td>
</tr>
<tr>
<td></td>
<td>AMCTESTCONTENT</td>
<td>Tests the view of the part or feature being authored in its current state.</td>
</tr>
<tr>
<td></td>
<td>AMCYLPIN2D</td>
<td>Inserts a cylindrical pin from the content library.</td>
</tr>
<tr>
<td></td>
<td>AMDATUMID</td>
<td>Creates a datum identification symbol and, attaches it to an object in the drawing area.</td>
</tr>
<tr>
<td></td>
<td>AMDATUMTGT</td>
<td>Creates a datum target symbol and, attaches it to an object in the drawing area.</td>
</tr>
<tr>
<td></td>
<td>AMDEADJOINT</td>
<td>Creates a dead joint symbol.</td>
</tr>
<tr>
<td></td>
<td>AMDEFLINE</td>
<td>Calculates and draws the deflection line or moment line of a beam that is subject to various forces.</td>
</tr>
<tr>
<td></td>
<td>AMDELVIEW</td>
<td>Deletes a drawing view.</td>
</tr>
<tr>
<td></td>
<td>AMDETAIL</td>
<td>Create a scaled circular, rectangular, or free defined detail view of selected geometry.</td>
</tr>
<tr>
<td></td>
<td>AMDIMALIGN</td>
<td>Lines up linear, ordinate, or angular dimensions, with a dimension you select as the baseline.</td>
</tr>
<tr>
<td></td>
<td>AMDIMARRANGE</td>
<td>Rearranges linear and ordinate dimensions, placing them at an appropriate distance from the outer contour of an object you select.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td>![Icon1]</td>
<td>AMDIMBREAK</td>
<td>Creates breaks in dimensions at specific points or at points where the dimensions cross other objects.</td>
</tr>
<tr>
<td>![Icon2]</td>
<td>AMDIMINSERT</td>
<td>Splits a linear or angular dimension into two individual dimensions.</td>
</tr>
<tr>
<td>![Icon3]</td>
<td>AMDIMJOIN</td>
<td>Combines two individual dimensions (of the same type) into a single dimension.</td>
</tr>
<tr>
<td>![Icon4]</td>
<td>AMDIMMEDIT</td>
<td>Edits multiple dimensions simultaneously.</td>
</tr>
<tr>
<td>![Icon5]</td>
<td>AMDIMSTRETCH</td>
<td>Resizes objects by stretching or shrinking a linear or symmetric dimension.</td>
</tr>
<tr>
<td>![Icon6]</td>
<td>AMDRBUSH2D</td>
<td>Inserts a drill bushing from the content library.</td>
</tr>
<tr>
<td>![Icon7]</td>
<td>AMDRBUSHHOLE2D</td>
<td>Inserts a drill bushing and the corresponding hole, from the content library.</td>
</tr>
<tr>
<td>![Icon8]</td>
<td>AMDWGVIEW</td>
<td>Creates a drawing view for an Inventor linked drawing.</td>
</tr>
<tr>
<td>![Icon9]</td>
<td>AMEDGESYM</td>
<td>Creates an edge symbol and, attaches it to an object in the drawing area.</td>
</tr>
<tr>
<td>![Icon10]</td>
<td>AMEDITVIEW</td>
<td>Provides the ability to modify attributes of a drawing view.</td>
</tr>
<tr>
<td>![Icon11]</td>
<td>AMERASEALLCL</td>
<td>Erases all construction lines.</td>
</tr>
<tr>
<td>![Icon12]</td>
<td>AMERASECL</td>
<td>Erases selected construction lines.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image1.png" alt="AMEXPLODE" /></td>
<td>AMEXPLODE</td>
<td>Converts mechanical structure objects to non-mechanical structure objects. When used on non-mechanical structure objects, breaks a compound object into its component objects.</td>
</tr>
<tr>
<td><img src="image2.png" alt="AMEXT2D" /></td>
<td>AMEXT2D</td>
<td>Performs a spring calculation and inserts a compression spring in the drawing area.</td>
</tr>
<tr>
<td><img src="image3.png" alt="AMEXTHREAD2D" /></td>
<td>AMEXTHREAD2D</td>
<td>Inserts an external thread from the content library.</td>
</tr>
<tr>
<td><img src="image4.png" alt="AMFCFRAME" /></td>
<td>AMFCFRAME</td>
<td>Creates a feature control frame symbol and, attaches it to an object in the drawing.</td>
</tr>
<tr>
<td><img src="image5.png" alt="AMFEA2D" /></td>
<td>AMFEA2D</td>
<td>Performs a Finite Element Analysis on a two-dimensional object that is subject to a static load.</td>
</tr>
<tr>
<td><img src="image6.png" alt="AMFEATID" /></td>
<td>AMFEATID</td>
<td>Creates a feature identification symbol and attaches it to an object in the drawing area.</td>
</tr>
<tr>
<td><img src="image7.png" alt="AMFILLET2D" /></td>
<td>AMFILLET2D</td>
<td>Rounds and fillets the edges of objects with an arc of a specified radius.</td>
</tr>
<tr>
<td><img src="image8.png" alt="AMFITSLIST" /></td>
<td>AMFITSLIST</td>
<td>Generates a fits list from the dimensions in the drawing area and enables you to place at a location of your choice.</td>
</tr>
<tr>
<td><img src="image9.png" alt="AMGROOVE2D" /></td>
<td>AMGROOVE2D</td>
<td>Inserts a circlips and draws the corresponding groove on a shaft.</td>
</tr>
<tr>
<td><img src="image10.png" alt="AMGROOVESTUD2D" /></td>
<td>AMGROOVESTUD2D</td>
<td>Inserts a grooved drive stud from the content library.</td>
</tr>
<tr>
<td><img src="image11.png" alt="AMHATCH_135_11" /></td>
<td>AMHATCH_135_11</td>
<td>Fills an enclosed area with a 135-degree, 11 mm/0.4” hatch.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>---------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td><img src="image" alt="AMHATCH_135_2" /></td>
<td>AMHATCH_135_2</td>
<td>Fills an enclosed area with a 135-degree, 2.7 mm/0.12&quot; hatch.</td>
</tr>
<tr>
<td><img src="image" alt="AMHATCH_135_4" /></td>
<td>AMHATCH_135_4</td>
<td>Fills an enclosed area with a 135-degree, 4.7 mm/0.19&quot; hatch.</td>
</tr>
<tr>
<td><img src="image" alt="AMHATCH_45_13" /></td>
<td>AMHATCH_45_13</td>
<td>Fills an enclosed area with a 45-degree, 13 mm/0.5&quot; hatch.</td>
</tr>
<tr>
<td><img src="image" alt="AMHATCH_45_2" /></td>
<td>AMHATCH_45_2</td>
<td>Fills an enclosed area with a 45-degree, 2.5 mm/0.1&quot; hatch.</td>
</tr>
<tr>
<td><img src="image" alt="AMHATCH_45_5" /></td>
<td>AMHATCH_45_5</td>
<td>Fills an enclosed area with a 45-degree, 5 mm/0.22&quot; hatch.</td>
</tr>
<tr>
<td><img src="image" alt="AMHATCH_DBL" /></td>
<td>AMHATCH_DBL</td>
<td>Fills an enclosed area with a 45 and 135 degree, 2.3 mm/0.09 cross hatch.</td>
</tr>
<tr>
<td><img src="image" alt="AMHELP" /></td>
<td>AMHELP</td>
<td>Displays AutoCAD Mechanical online help.</td>
</tr>
<tr>
<td><img src="image" alt="AMHOLECHART" /></td>
<td>AMHOLECHART</td>
<td>Creates coordinate dimensions for holes in a work piece, dimensions the size of those holes, and generates a hole chart for that work piece.</td>
</tr>
<tr>
<td><img src="image" alt="AMINERTIA" /></td>
<td>AMINERTIA</td>
<td>Calculates the moment of inertial of a closed contour.</td>
</tr>
<tr>
<td><img src="image" alt="AMINERTIAPROF" /></td>
<td>AMINERTIAPROF</td>
<td>Calculates the moment of inertia for cross sections of cylinders, hollow cylinders, rectangular prisms, or hollow rectangular prisms.</td>
</tr>
<tr>
<td><img src="image" alt="AMIVCOMPONLY" /></td>
<td>AMIVCOMPONLY</td>
<td>Creates an Autodesk Inventor linked file.</td>
</tr>
<tr>
<td><img src="image" alt="AMJOIN" /></td>
<td>AMJOIN</td>
<td>Connects non parallel lines, polylines, arcs, and circles.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>----------------</td>
<td>-----------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>AMLANGCONV</td>
<td>Translates text in the drawing to another language.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>AMLANGTEXT</td>
<td>Display a list of text strings for which translations are available and enables you to insert them into your drawing.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>AMLAUNCHPAD</td>
<td>Displays the AutoCAD Mechanical Launchpad.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>AMLAYER</td>
<td>Displays the Mechanical Layer Manager, which enables you to manage layers and mechanical layer definitions.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>AMLAYERGROUP</td>
<td>Displays the Layergroup Manager, which allows you to manage layergroups, layers, and their properties.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>AMLAYINVO</td>
<td>Toggles the visibility of the layer assigned to invisible lines (AM_INV).</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>AMLAYMOVE</td>
<td>Moves objects from one layer to another.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>AMLAYMOVEPL</td>
<td>Move objects that lie on standard parts layers (layers AM_0N to AM_12, by default) to the corresponding working layers (layers AM_0 to AM_12, by default).</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>AMLAYMOVEWL</td>
<td>Move objects that lie on working layers (layers AM_0 to AM_12, by default) to the corresponding standard part layers (layers AM_0N to AM_12N, by default).</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>AMLAYPARTO</td>
<td>Toggles the visibility of the standard part layers (AM_0N to AM_12N, by default).</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>AMLAYPARTREFO</td>
<td>Toggles the visibility of the layer assigned to part references (AM_PAREF, by default).</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image1" alt="AMLAYRESET" /></td>
<td>AMLAYRESET</td>
<td>Resets properties of all mechanical layers to be identical to the corresponding layer definition.</td>
</tr>
<tr>
<td><img src="image2" alt="AMLAYTIBLO" /></td>
<td>AMLAYTIBLO</td>
<td>Toggles the visibility of the layer assigned to title blocks and drawing borders (AM_BOR, by default).</td>
</tr>
<tr>
<td><img src="image3" alt="AMLAYVISENH" /></td>
<td>AMLAYVISENH</td>
<td>Displays the Visibility Enhancements dialog box, which allows you to visually differentiate between the active layergroup and inactive ones.</td>
</tr>
<tr>
<td><img src="image4" alt="AMLAYVPO" /></td>
<td>AMLAYVPO</td>
<td>Toggles the visibility of the layer assigned to viewport borders (AM_VIEWS, by default).</td>
</tr>
<tr>
<td><img src="image5" alt="AMLGMOVE" /></td>
<td>AMLGMOVE</td>
<td>Moves the selected objects to a specified layergroup.</td>
</tr>
<tr>
<td><img src="image6" alt="AMLIBRARY" /></td>
<td>AM LIBRARY</td>
<td>Displays the Library dialog box, which enables you to organize drawing files to retrieve and reuse them more efficiently.</td>
</tr>
<tr>
<td><img src="image7" alt="AMLISTVIEW" /></td>
<td>AM LISTVIEW</td>
<td>Lists information about a selected view.</td>
</tr>
<tr>
<td><img src="image8" alt="AMLUBRI2D" /></td>
<td>AMLUBRI2D</td>
<td>Inserts a lubricator from the content library.</td>
</tr>
<tr>
<td><img src="image9" alt="AMMANIPULATE" /></td>
<td>AMMANIPULATE</td>
<td>Displays the Power Manipulator, a tool that enables you to rotate move and copy objects by dragging.</td>
</tr>
<tr>
<td><img src="image10" alt="AMMARKSTAMP" /></td>
<td>AMMARKSTAMP</td>
<td>Creates a marking symbol and attaches it to an object in the drawing area.</td>
</tr>
<tr>
<td><img src="image11" alt="AMMCONTV" /></td>
<td>AMMCONTV</td>
<td>Makes contours that are hidden by construction lines visible.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>AMMODE</td>
<td>Switches between model space and paper space.</td>
</tr>
<tr>
<td><img src="image1.png" alt="Image" /></td>
<td>AMMOVEDIM</td>
<td>Moves dimensions within a view or between views, while maintaining their association to the drawing view geometry.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Image" /></td>
<td>AMMOVEVIEW</td>
<td>Moves a drawing view to another location within the same layout or to another layout.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Image" /></td>
<td>AMNOTE</td>
<td>Creates a leader note and, attaches it to an object in the drawing area.</td>
</tr>
<tr>
<td><img src="image4.png" alt="Image" /></td>
<td>AMNUT2D</td>
<td>Inserts a nut from the content library.</td>
</tr>
<tr>
<td><img src="image5.png" alt="Image" /></td>
<td>AMOFFSET</td>
<td>Creates concentric circles, parallel lines, and parallel curves.</td>
</tr>
<tr>
<td><img src="image6.png" alt="Image" /></td>
<td>AMPARTLIST</td>
<td>Creates a parts list and enables you to place it in the drawing area.</td>
</tr>
<tr>
<td><img src="image7.png" alt="Image" /></td>
<td>AMPARTREF</td>
<td>Creates a part reference and places it in the drawing area.</td>
</tr>
<tr>
<td><img src="image8.png" alt="Image" /></td>
<td>AMPARTREFEDIT</td>
<td>Edits a part reference.</td>
</tr>
<tr>
<td><img src="image9.png" alt="Image" /></td>
<td>AMPLBEAR2D</td>
<td>Inserts a plain bearing on a shaft.</td>
</tr>
<tr>
<td><img src="image10.png" alt="Image" /></td>
<td>AMPLOTDATE</td>
<td>Inserts the current date in the lower right corner of all title blocks in the drawing.</td>
</tr>
<tr>
<td><img src="image11.png" alt="Image" /></td>
<td>AMPLRIVET2D</td>
<td>Inserts a plain rivet from the content library.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><img src="image.png" alt="Amplug2D Icon" /></td>
<td>AMPLUG2D</td>
<td>Inserts a plug from the content library.</td>
</tr>
<tr>
<td><img src="image.png" alt="Ampowercopy Icon" /></td>
<td>AMPOWERCOPY</td>
<td>Produces an identical copy of a specified object.</td>
</tr>
<tr>
<td><img src="image.png" alt="Ampowerdim Icon" /></td>
<td>AMPOWERDIM</td>
<td>Creates multiple types of dimensions within a single command session and provides the ability to specify tolerances or fits as appropriate.</td>
</tr>
<tr>
<td><img src="image.png" alt="Ampowerdim ali Icon" /></td>
<td>AMPOWERDIM_ALI</td>
<td>Creates aligned linear dimensions.</td>
</tr>
<tr>
<td><img src="image.png" alt="Ampowerdim ang Icon" /></td>
<td>AMPOWERDIM_ANG</td>
<td>Creates angular dimensions.</td>
</tr>
<tr>
<td><img src="image.png" alt="Ampowerdim arclen Icon" /></td>
<td>AMPOWERDIM_ARCLEN</td>
<td>Creates arc length dimensions for arcs and arc segments on a polyline.</td>
</tr>
<tr>
<td><img src="image.png" alt="Ampowerdim bas Icon" /></td>
<td>AMPOWERDIM_BAS</td>
<td>Creates a linear or angular dimension from the first extension line of a selected dimension.</td>
</tr>
<tr>
<td><img src="image.png" alt="Ampowerdim chain Icon" /></td>
<td>AMPOWERDIM_CHAIN</td>
<td>Creates a linear, angular, or arc length dimension from the second extension line of a selected dimension.</td>
</tr>
<tr>
<td><img src="image.png" alt="Ampowerdim dia Icon" /></td>
<td>AMPOWERDIM_DIA</td>
<td>Creates diameter dimensions for arcs and circles.</td>
</tr>
<tr>
<td><img src="image.png" alt="Ampowerdim hor Icon" /></td>
<td>AMPOWERDIM_HOR</td>
<td>Creates horizontal linear dimensions.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>![AMPOWERDIM_JOG Icon]</td>
<td>AMPOWERDIM_JOG</td>
<td>Create a radius dimension with the origin of the dimension at any location you wish and a jog at a convenient location along the dimension line.</td>
</tr>
<tr>
<td>![AMPOWERDIM_RAD Icon]</td>
<td>AMPOWERDIM_RAD</td>
<td>Creates radius dimensions for arcs and circles.</td>
</tr>
<tr>
<td>![AMPOWERDIM_ROT Icon]</td>
<td>AMPOWERDIM_ROT</td>
<td>Creates rotated linear dimensions.</td>
</tr>
<tr>
<td>![AMPOWERDIM_VER Icon]</td>
<td>AMPOWERDIM_VER</td>
<td>Creates vertical linear dimensions.</td>
</tr>
<tr>
<td>![AMPOWEREDIT Icon]</td>
<td>AMPOWEREDIT</td>
<td>Recognizes any object you select and invokes the most appropriate command to edit it.</td>
</tr>
<tr>
<td>![AMPOWERERASE Icon]</td>
<td>AMPOWERERASE</td>
<td>Erases AutoCAD Mechanical objects cleanly and heals the surrounding area.</td>
</tr>
<tr>
<td>![AMPOWERRECALL Icon]</td>
<td>AMPOWERRECALL</td>
<td>Recognizes the object you select and invokes the command that it was created with.</td>
</tr>
<tr>
<td>![AMPOWERSNAP Icon]</td>
<td>AMPOWERSNAP</td>
<td>Displays the Power Snap Settings dialog box, to enable you to set the running object snap modes.</td>
</tr>
<tr>
<td>![AMPOWERVIEW Icon]</td>
<td>AMPOWERVIEW</td>
<td>Creates a top view from a side view of a standard part and vice versa.</td>
</tr>
<tr>
<td>![AMPROJO Icon]</td>
<td>AMPROJO</td>
<td>Creates projection lines to assist you create orthographic views.</td>
</tr>
</tbody>
</table>

Command Summary | 31
<table>
<thead>
<tr>
<th>Icon</th>
<th>Command Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="AMPSNAP1" /></td>
<td>AMPSNAP1</td>
<td>Sets the running object snap modes to the settings saved as Power Snap Configuration Setting 1.</td>
</tr>
<tr>
<td><img src="image" alt="AMPSNAP2" /></td>
<td>AMPSNAP2</td>
<td>Sets the running object snap modes to the settings saved as Power Snap Configuration Setting 2.</td>
</tr>
<tr>
<td><img src="image" alt="AMPSNAP3" /></td>
<td>AMPSNAP3</td>
<td>Sets the running object snap modes to the settings saved as Power Snap Configuration Setting 3.</td>
</tr>
<tr>
<td><img src="image" alt="AMPSNAP4" /></td>
<td>AMPSNAP4</td>
<td>Sets the running object snap modes to the settings saved as Power Snap Configuration Setting 4.</td>
</tr>
<tr>
<td><img src="image" alt="AMPSNAPCEN" /></td>
<td>AMPSNAPCEN</td>
<td>Snaps to the center of a rectangle, when invoked from within another command.</td>
</tr>
<tr>
<td><img src="image" alt="AMPSNAPFILTERO" /></td>
<td>AMPSNAPFILTERO</td>
<td>Switches entity filters on or off.</td>
</tr>
<tr>
<td><img src="image" alt="AMPSNAPMID" /></td>
<td>AMPSNAPMID</td>
<td>Snaps to a point on the apparent line between two specified points, when invoked from within another command.</td>
</tr>
<tr>
<td><img src="image" alt="AMPSNAPREL" /></td>
<td>AMPSNAPREL</td>
<td>Snaps to a point relative to a specified point, when invoked from within another command.</td>
</tr>
<tr>
<td><img src="image" alt="AMPSNAPVINT" /></td>
<td>AMPSNAPVINT</td>
<td>Snaps to the apparent intersection of two non-parallel lines, when invoked from within another command.</td>
</tr>
<tr>
<td><img src="image" alt="AMPSNAPZO" /></td>
<td>AMPSNAPZO</td>
<td>Toggles snapping to Z axis coordinates on or off.</td>
</tr>
<tr>
<td><img src="image" alt="AMRECTANG" /></td>
<td>AMRECTANG</td>
<td>Draws rectangle using a closed polyline.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image1.png" alt="AMRECTBWH Icon" /></td>
<td>AMRECTBWH</td>
<td>Creates a rectangle by using the middle of the base as the start point, and by specifying the full base and full height.</td>
</tr>
<tr>
<td><img src="image2.png" alt="AMRECTBWH2 Icon" /></td>
<td>AMRECTBWH2</td>
<td>Creates a rectangle by using the middle of the base as the start point, and by specifying the full base and half of the height.</td>
</tr>
<tr>
<td><img src="image3.png" alt="AMRECTBY Icon" /></td>
<td>AMRECTBY</td>
<td>Creates a rectangle by using the middle of the base as the start point, and specifying a corner point.</td>
</tr>
<tr>
<td><img src="image4.png" alt="AMRECTCW2H Icon" /></td>
<td>AMRECTCW2H</td>
<td>Creates a rectangle by selecting the center as start point, and by defining half base and full height.</td>
</tr>
<tr>
<td><img src="image5.png" alt="AMRECTCW2H2 Icon" /></td>
<td>AMRECTCW2H2</td>
<td>Creates a rectangle by using the center of the rectangle as the start point, and specifying half of the base and half of the height.</td>
</tr>
<tr>
<td><img src="image6.png" alt="AMRECTCWH Icon" /></td>
<td>AMRECTCWH</td>
<td>Creates a rectangle by using the center of the rectangle as the start point, and specifying the full base and half of the height.</td>
</tr>
<tr>
<td><img src="image7.png" alt="AMRECTCWH2 Icon" /></td>
<td>AMRECTCWH2</td>
<td>Creates a rectangle by using the center of the rectangle as the start point, and specifying the full base and half of the height.</td>
</tr>
<tr>
<td><img src="image8.png" alt="AMRECTCY Icon" /></td>
<td>AMRECTCY</td>
<td>Creates a rectangle by using the center of the rectangle as the start point, and specifying a corner.</td>
</tr>
<tr>
<td><img src="image9.png" alt="AMRECTLWH Icon" /></td>
<td>AMRECTLWH</td>
<td>Creates a rectangle by using the midpoint of the height as the start point, and specifying the full base and full height.</td>
</tr>
<tr>
<td><img src="image10.png" alt="AMRECTLWH2 Icon" /></td>
<td>AMRECTLWH2</td>
<td>Creates a rectangle by selecting the height middle as start point, and by defining full base and half height.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image" alt="AMRECTLY Icon" /></td>
<td>AMRECTLY</td>
<td>Creates a rectangle by using the middle of the height as the start point, and specifying the opposite corner.</td>
</tr>
<tr>
<td><img src="image" alt="AMRECTQBT Icon" /></td>
<td>AMRECTQBT</td>
<td>Creates a square by selecting the base middle as starting point, and by defining full base.</td>
</tr>
<tr>
<td><img src="image" alt="AMRECTQBY Icon" /></td>
<td>AMRECTQBY</td>
<td>Creates a square by selecting the base middle as starting point, and by defining half base.</td>
</tr>
<tr>
<td><img src="image" alt="AMRECTQCR Icon" /></td>
<td>AMRECTQCR</td>
<td>Creates a square by selecting the center as starting point, and by defining half base.</td>
</tr>
<tr>
<td><img src="image" alt="AMRECTQCW Icon" /></td>
<td>AMRECTQCW</td>
<td>Creates a square by selecting the center as starting point, and by defining full base.</td>
</tr>
<tr>
<td><img src="image" alt="AMRECTQLR Icon" /></td>
<td>AMRECTQLR</td>
<td>Creates a square by selecting the height middle as starting point, and by defining full base.</td>
</tr>
<tr>
<td><img src="image" alt="AMRECTQLY Icon" /></td>
<td>AMRECTQLY</td>
<td>Creates a square by selecting the height middle as starting point, and by defining half base.</td>
</tr>
<tr>
<td><img src="image" alt="AMRECTQXY Icon" /></td>
<td>AMRECTQXY</td>
<td>Creates a square by selecting the starting point, and by defining full base.</td>
</tr>
<tr>
<td><img src="image" alt="AMRECTXWH Icon" /></td>
<td>AMRECTXWH</td>
<td>Creates a rectangle by using a corner of the rectangle as the start point, and specifying the full base and full height.</td>
</tr>
<tr>
<td><img src="image" alt="AMREV Icon" /></td>
<td>AMREV</td>
<td>Turns revisions on or off.</td>
</tr>
<tr>
<td><img src="image" alt="AMREVLINE Icon" /></td>
<td>AMREVLINE</td>
<td>Adds a revision line to a revisions list.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>---------------------</td>
<td>-------------------------------------------------------</td>
</tr>
<tr>
<td><img src="image1.png" alt="Icon" /></td>
<td>AMREVUPDATE</td>
<td>Updates the revision block.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Icon" /></td>
<td>AMROLBEAR2D</td>
<td>Inserts a roller bearing on a shaft.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Icon" /></td>
<td>AMSACTIVATE</td>
<td>Makes the specified component view or folder the active edit target.</td>
</tr>
<tr>
<td><img src="image4.png" alt="Icon" /></td>
<td>AMSBASE</td>
<td>Changes the basepoint of a component view or folder.</td>
</tr>
<tr>
<td><img src="image5.png" alt="Icon" /></td>
<td>AMSCALEXY</td>
<td>Sets scale of X and Y axes independently of each other.</td>
</tr>
<tr>
<td><img src="image6.png" alt="Icon" /></td>
<td>AMSCAREA</td>
<td>Creates a scale area in model space.</td>
</tr>
<tr>
<td><img src="image7.png" alt="Icon" /></td>
<td>AMSCATALOG</td>
<td>Displays the Structure Catalog.</td>
</tr>
<tr>
<td><img src="image8.png" alt="Icon" /></td>
<td>AMSCMONITOR</td>
<td>Displays the scale of a scale area or viewport.</td>
</tr>
<tr>
<td><img src="image9.png" alt="Icon" /></td>
<td>AMSCOPYDEF</td>
<td>Saves a copy of the definition of the selected structure object to another name.</td>
</tr>
<tr>
<td><img src="image10.png" alt="Icon" /></td>
<td>AMSCREATE</td>
<td>Creates a new component, component view, folder or annotation view.</td>
</tr>
<tr>
<td><img src="image11.png" alt="Icon" /></td>
<td>AMSCREW2D</td>
<td>Inserts a screw or bolt from the content library.</td>
</tr>
<tr>
<td><img src="image12.png" alt="Icon" /></td>
<td>AMSCREEWCALC</td>
<td>Calculates factors of safety for parts of a screw connection.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMSCREWCON2D</td>
<td>Inserts an entire fastening assembly using items from the content library.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMSCREWMACRO2D</td>
<td>Inserts an entire fastener assembly using items predefined on a template.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMSCRIPT</td>
<td>Generates Scripts to apply a specified operation on selected drawings or entire folders.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMSEALRING2D</td>
<td>Inserts a sealing ring from the content library.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMSEALS2D</td>
<td>Inserts a seal or O-ring and draws the corresponding groove on a shaft.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMSECTIONLINE</td>
<td>Draws a section line inserts the corresponding section view label in the drawing area.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMEDIT</td>
<td>Adds, removes, or copies geometry to the currently activated folder or component view.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMSETUPDWG</td>
<td>Imports the drafting standards and the dependant settings from a template file.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMSHAFT2D</td>
<td>Starts the Shaft Generator utility.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMSHAFTCALC</td>
<td>Calculate deflection lines, bending moments, torsion moments, and factors of safety for shafts and axles put under static loads.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMSHAFTEND</td>
<td>Draws a break line on a shaft to indicate a shaft end.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>AMSHAFTKEY2D</td>
<td>Inserts a parallel or woodruff key on a shaft.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td><img src="image.png" alt="Icon" /></td>
<td>AMSHAFTLNUT2D</td>
<td>Inserts a shaft lock nut and a lock washer on a threaded segment of a shaft.</td>
</tr>
<tr>
<td><img src="image.png" alt="Icon" /></td>
<td>AMSHIDE</td>
<td>Draws hidden lines to represent hidden edges, when you specify what objects lie in front and what objects lie behind.</td>
</tr>
<tr>
<td><img src="image.png" alt="Icon" /></td>
<td>AMSHIDEEDIT</td>
<td>Edits a hide situation created with the AMSHIDE command.</td>
</tr>
<tr>
<td><img src="image.png" alt="Icon" /></td>
<td>AMSHIMRING2D</td>
<td>Inserts a shim ring on a shaft.</td>
</tr>
<tr>
<td><img src="image.png" alt="Icon" /></td>
<td>AMSIMPLEWELD</td>
<td>Draws seam and fillet welds on ellipses, circles, arcs, lines and polylines.</td>
</tr>
<tr>
<td><img src="image.png" alt="Icon" /></td>
<td>AMSINSERT</td>
<td>Inserts an instance of a component, component view or folder, that is already defined in the drawing.</td>
</tr>
<tr>
<td><img src="image.png" alt="Icon" /></td>
<td>AMSNAVMODE</td>
<td>Turns the Design Navigation Mode on or off.</td>
</tr>
<tr>
<td><img src="image.png" alt="Icon" /></td>
<td>AMSNEW</td>
<td>Creates a new mechanical structure definition from selected objects.</td>
</tr>
<tr>
<td><img src="image.png" alt="Icon" /></td>
<td>AMSPROCKET</td>
<td>Inserts the front view of a sprocket or pulley from the content library.</td>
</tr>
<tr>
<td><img src="image.png" alt="Icon" /></td>
<td>AMSPURGE</td>
<td>Removes unused definitions of mechanical structure objects from the drawing.</td>
</tr>
<tr>
<td><img src="image.png" alt="Icon" /></td>
<td>AMSREPLACEDEF</td>
<td>Replaces the definition of selected instances of a component view or folder, with another definition.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td>AMSSMODE</td>
<td>Switches between the top-down and bottom-up geometry selection modes.</td>
</tr>
</tbody>
</table>
|      | AMSTDPLIBEDIT| Displays the Content Manager.  
**NOTE** This command is superseded by the AMCONTENTMANAGER command. |
<p>| ![TT] | AMSTDPREP    | Defines how selected parts and features from the content library are represented in the drawing. |
| ![T]  | AMSTLSHAP2D  | Inserts a steel shape from the content library. |
| ![A]  | AMSTYLEI    | Imports dimension styles from another drawing. |
| ![A]  | AMSTYLEITAL  | Changes the text style to italics. |
| ![A]  | AMSTYLEITAL  | Changes the text style to italics. |
| ![A]  | AMSTYLESIMP  | Sets the current text style to SIMPLEX. |
| ![A]  | AMSTYLESIMP  | Sets the current text style to SIMPLEX. |
| ![A]  | AMSTYLESTAND | Sets the current text style to STANDARD. |
| ![A]  | AMSTYLETEXT  | Sets the current text style to USER1. |
| ![√]  | AMSURFSYM    | Creates a surface texture symbol and attaches it to an object in the drawing area. |</p>
<table>
<thead>
<tr>
<th>Icon</th>
<th>Command Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Icon" /></td>
<td>AMSYMLEADER</td>
<td>Adds or removes leaders and leader segments to/from a symbol.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Icon" /></td>
<td>AMSYMLINE</td>
<td>Draws symmetrical polylines.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Icon" /></td>
<td>AMTAPBHOLE2D</td>
<td>Inserts a tapped blind hole from the content library.</td>
</tr>
<tr>
<td><img src="image4.png" alt="Icon" /></td>
<td>AMTAPERPIN2D</td>
<td>Inserts a taper pin from the content library.</td>
</tr>
<tr>
<td><img src="image5.png" alt="Icon" /></td>
<td>AMTAPERSYM</td>
<td>Creates a taper or slope symbol.</td>
</tr>
<tr>
<td><img src="image6.png" alt="Icon" /></td>
<td>AMTAPETHREAD2D</td>
<td>Inserts a tapered hole that contains external threads.</td>
</tr>
<tr>
<td><img src="image7.png" alt="Icon" /></td>
<td>AMTAPITHREAD2D</td>
<td>Inserts a tapered hole that contains internal threads.</td>
</tr>
<tr>
<td><img src="image8.png" alt="Icon" /></td>
<td>AMTAPTHOLE2D</td>
<td>Inserts a tapped through hole from the content library.</td>
</tr>
<tr>
<td><img src="image9.png" alt="Icon" /></td>
<td>AMTESTCONTENTCLOSE</td>
<td>Closes the Test Content Window and returns you to the Content Editor.</td>
</tr>
<tr>
<td><img src="image10.png" alt="Icon" /></td>
<td>AMTESTCONTENTINSERT</td>
<td>Inserts the content being tested.</td>
</tr>
<tr>
<td><img src="image11.png" alt="Icon" /></td>
<td>AMTEXT3</td>
<td>Creates a multiline text object of 3.5 mm height.</td>
</tr>
<tr>
<td><img src="image12.png" alt="Icon" /></td>
<td>AMTEXT5</td>
<td>Creates a multiline text object of 5 mm height.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image1" alt="AMTEXT7" /></td>
<td>AMTEXT7</td>
<td>Creates a multiline text object of 7 mm height.</td>
</tr>
<tr>
<td><img src="image2" alt="AMTEXTCENT" /></td>
<td>AMTEXTCENT</td>
<td>Creates a multiline text object that is centered horizontally and vertically.</td>
</tr>
<tr>
<td><img src="image3" alt="AMTEXTHORIZ" /></td>
<td>AMTEXTHORIZ</td>
<td>Creates a center justified multiline text object that is aligned to the bottom of the specified area.</td>
</tr>
<tr>
<td><img src="image4" alt="AMTEXTRIGHT" /></td>
<td>AMTEXTRIGHT</td>
<td>Creates a right justified multiline text object that is aligned to the bottom of the specified area.</td>
</tr>
<tr>
<td><img src="image5" alt="AMTHOLE2D" /></td>
<td>AMTHOLE2D</td>
<td>Inserts a through hole from the content library.</td>
</tr>
<tr>
<td><img src="image6" alt="AMTHREADEND2D" /></td>
<td>AMTHREADEND2D</td>
<td>Inserts a thread end from the content library.</td>
</tr>
<tr>
<td><img src="image7" alt="AMTITLE" /></td>
<td>AMTITLE</td>
<td>Inserts a drawing border with a title block.</td>
</tr>
<tr>
<td><img src="image8" alt="AMTOR2D" /></td>
<td>AMTOR2D</td>
<td>Performs a spring calculation and inserts a torsion spring in the drawing area.</td>
</tr>
<tr>
<td><img src="image9" alt="AMTRCONT" /></td>
<td>AMTRCONT</td>
<td>Traces contours on construction lines or construction line circles.</td>
</tr>
<tr>
<td><img src="image10" alt="AMTSLOT2D" /></td>
<td>AMTSLOT2D</td>
<td>Inserts a through slot from the content library.</td>
</tr>
<tr>
<td><img src="image11" alt="AMUNDERCUT2D" /></td>
<td>AMUNDERCUT2D</td>
<td>Inserts an undercut on a shaft.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image1.png" alt="Icon" /></td>
<td>AMUPDATE</td>
<td>Updates the specified drawing view to reflect the modifications made to the model.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Icon" /></td>
<td>AMUSERHATCH</td>
<td>Fills an enclosed area with a user-defined hatch pattern.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Icon" /></td>
<td>AMVALMIGRATE</td>
<td>Migrates the schema of the selected VAL file format to the current AutoCAD Mechanical format.</td>
</tr>
<tr>
<td><img src="image4.png" alt="Icon" /></td>
<td>AMVIEWALL</td>
<td>Creates the named view AM_VIEW6 and loads it.</td>
</tr>
<tr>
<td><img src="image5.png" alt="Icon" /></td>
<td>AMVIEWCEN</td>
<td>Creates the named view AM_VIEW5 and loads it.</td>
</tr>
<tr>
<td><img src="image6.png" alt="Icon" /></td>
<td>AMVIEWLL</td>
<td>Creates the named view AM_VIEW3 and loads it.</td>
</tr>
<tr>
<td><img src="image7.png" alt="Icon" /></td>
<td>AMVIEWLR</td>
<td>Creates the named view AM_VIEW4 and loads it.</td>
</tr>
<tr>
<td><img src="image8.png" alt="Icon" /></td>
<td>AMVIEWOUT</td>
<td>Exports drawing views to an AutoCAD drawing file.</td>
</tr>
<tr>
<td><img src="image9.png" alt="Icon" /></td>
<td>AMVIEWUL</td>
<td>Creates the named view AM_VIEW1 and loads it.</td>
</tr>
<tr>
<td><img src="image10.png" alt="Icon" /></td>
<td>AMVIEWUR</td>
<td>Creates the named view AM_VIEW2 and loads it.</td>
</tr>
<tr>
<td><img src="image11.png" alt="Icon" /></td>
<td>AMVISIBLE</td>
<td>Displays the Desktop Visibility dialog box to enable you to selectively display/hide objects.</td>
</tr>
<tr>
<td><img src="image12.png" alt="Icon" /></td>
<td>AMVPORTAUTO</td>
<td>Creates viewports for all scale areas that are not associated with a viewport.</td>
</tr>
<tr>
<td><img src="image13.png" alt="Icon" /></td>
<td>AMVPZOOMALL</td>
<td>Resets all viewports to their default scale factors.</td>
</tr>
<tr>
<td>Icon</td>
<td>Command Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>----------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><img src="amwasher2d_icon.png" alt="Image" /></td>
<td>AMWASHER2D</td>
<td>Inserts a washer from the content library.</td>
</tr>
<tr>
<td><img src="amweldsym_icon.png" alt="Image" /></td>
<td>AMWELDSYM</td>
<td>Creates a welding symbol and attaches it to the weld point.</td>
</tr>
<tr>
<td><img src="amxrefset_icon.png" alt="Image" /></td>
<td>AMXREFSET</td>
<td>Displays the Xref Processing dialog box to enable you to specify how xref entities are displayed.</td>
</tr>
<tr>
<td><img src="amzigzagline_icon.png" alt="Image" /></td>
<td>AMZIGZAGLINE</td>
<td>Draws a zigzag line.</td>
</tr>
<tr>
<td><img src="amzoomvp_icon.png" alt="Image" /></td>
<td>AMZOOMVP</td>
<td>Zooms an area in a viewport.</td>
</tr>
</tbody>
</table>
Design and Annotation
Tools

The tutorials in this section teach you how to use the tools in AutoCAD® Mechanical for design, annotation, and productivity. The lessons include step-by-step instructions and helpful illustrations. You learn how to work with templates and layers, mechanical structure, model space and layouts, dimensions, steel shapes, bills of material (BOMs) and parts lists. Instructions on how to prepare your designs for final documentation are also included.
Working with Templates

In this tutorial, you learn about the predefined templates and how to create your own user-defined templates in AutoCAD® Mechanical.

Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>base layer</td>
<td>A layer made up of working layers and standard parts layers. Base layers are repeated in every layer group.</td>
</tr>
<tr>
<td>layer group</td>
<td>A group of associated or related items in a drawing. A major advantage of working with layer groups is that you can deactivate a specific layer group and a complete component. The drawing and its overview are enhanced with a reduction in regeneration time.</td>
</tr>
<tr>
<td>part layers</td>
<td>A layer where the standard parts are put. All standard parts layers have the suffix AM_*N.</td>
</tr>
<tr>
<td>template</td>
<td>A file with predefined settings to use for new drawings. However, any drawing can be used as a template.</td>
</tr>
<tr>
<td>working layer</td>
<td>The layer where you are currently working.</td>
</tr>
</tbody>
</table>

Working with Templates

In AutoCAD Mechanical, you can use templates (*.dwt files) to create drawings. Predefined templates, which contain settings for various drawings, such as am_iso.dwt or am_ansi.dwt, are supplied with AutoCAD Mechanical. You can
create your own templates, or use any drawing as a template. When you use a drawing as a template, the settings in that drawing are used in the new drawing.

Although you can save any drawing as a template, prepare templates to include settings and drawing elements that are consistent with your company or project standards, such as the following items:

- unit type and precision
- drawing limits
- snap, grid, and ortho settings
- layer organization
- title blocks, borders, and logos
- dimension and text styles
- linetypes and lineweights

If you start a drawing from scratch, AutoCAD Mechanical reads the system defaults from the registry. The system defaults have a predefined standard.

If you create a drawing based on an existing template and make changes to the drawing, those changes do not affect the template.

To begin working with templates immediately, you can use the predefined template files.

However, for this tutorial you create your own template.

### Setting Mechanical Options

In the Options dialog box, you can specify general settings for AutoCAD Mechanical, Autodesk® Mechanical Desktop®, and AutoCAD®. Tabs that affect settings for either Mechanical Desktop or AutoCAD Mechanical, or both, have an AM prefix. Use the arrows at the right end of the tab bar to move left and right through all of the available tabs.

**To set mechanical options**

1. Start the Mechanical Options command.
   - **Ribbon**: None.
   - **Menu**: Assist ➤ Options.
Command OPTIONS or AMOPTIONS

2 On the AM:Standards tab, specify:

Standard: ISO
Measurement: Metric
Model Scale: 1:1

Click OK.

**NOTE** All settings in this dialog that are stored in the drawing (template) are marked with this icon: ![Icon](image). The current standard and all related settings are listed in the right section.

**Specifying Drawing Limits**

Specify the drawing limits according to size A0 (840 x 1188 mm). This limits your drawing space to the specified size.
To specify the drawing limits

1  Start the Drawing Limits command.
   Ribbon  None
   Menu    Format ➤ Drawing Limits
   Command LIMITS

2  Respond to the prompts as follows:
   Specify lower left corner or [ON/OFF] <0.00,0.00>: Press ENTER
   Specify upper right corner <420.00,297.00>:
   Enter 841, 1189, press ENTER
   The limits are expanded to A0 format.

Saving Templates

Save the previously changed drawing as a template.

To save a template

1  Start the Save As command.
   Ribbon
   ➤ Save as ➤ AutoCAD Mechanical
   Drawing Template ➤
   Menu    File ➤ Save As
   Command SAVEAS

2  In the Save Drawing As dialog box, specify:
   Files of type:  AutoCAD Mechanical Drawing Template (*.dwt)
   File name:  my_own_template
3 In the Template Description dialog box, specify:

Description: Tutorial Template
Measurement: Metric

Click OK.

4 Close the drawing.

Ribbon

Menu
Using Templates

Use the previously created template to start a new drawing.

To open a template

1 Start the New command.

Ribbon

➤ New ➤ Drawing ➤

Menu

File ➤ New

Command

NEW

2 In the Select template dialog box, select *my_own_template.dwt*, and then choose Open.

Start the new drawing using the settings of the previously saved template.
Setting Default Standards Templates

Specify your template as the default template.

To set a default template

1. Start the Mechanical Options command.
   - Ribbon: None.
   - Menu: Tools ➤ Options
   - Command: AMOPTIONS

2. In the Options dialog box, AM:Standards tab, choose Browse.

3. In the Open dialog box, select my_own_template.dwt, and then choose Open.

4. In the Options dialog box, Click OK.
   The template my_own_template is used as the default standards template until you specify a different default template.
NOTE The default standards template is used if a drawing does not contain any AutoCAD Mechanical configuration. If a drawing already contains AutoCAD Mechanical configuration data, or a new drawing has been created using an AutoCAD Mechanical template, the default template does not affect the drawing.

This is the end of this tutorial chapter.
Using Mechanical Structure

In this tutorial, you learn how to use mechanical structure in AutoCAD® Mechanical. You learn how to work with folders, components and component views. You also review the bill of materials, restructure components and resolve ghost components. You learn how to insert components from external files, edit in-place, localize external components and externalize local components.

Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>annotation view</td>
<td>A folder that contains one or more component views dedicated to annotating and detailing parts and subassemblies.</td>
</tr>
<tr>
<td>associative</td>
<td>In mechanical structure, the implication that a change to one instance of a definition is reflected in all other instances of that definition, including the definition itself.</td>
</tr>
<tr>
<td>mechanical browser</td>
<td>A browser that contains the hierarchy of components, component views, annotation views, and folders of a given mechanical structure.</td>
</tr>
<tr>
<td>component</td>
<td>A browser placeholder and identification for the component type. A component is analogous to the manufacturing units of parts and assemblies.</td>
</tr>
<tr>
<td>component view folder</td>
<td>A folder nested under a component that contains the geometry for a particular view of that component.</td>
</tr>
</tbody>
</table>
### Working with Mechanical Structure

Mechanical structure is a set of tools used to organize data for reuse. Structure is graphically represented by a tree called the Mechanical Browser.
The Mechanical Browser and structure tools are not displayed by default. To display them, you must switch to the structure workspace. First, you must create a new drawing and enable mechanical structure.

**To display the Mechanical Browser**

1. On the command line, enter `WORKSPACE` and press ENTER.
2. Respond to the prompts as shown:
   ```
   Enter workspace option
   [setCurrent/SAVEas/Edit/Rename/Delete/SETTINGS/?]:
   Enter C and press ENTER
   Enter name of workspace to make current [?] <Current Workspace>:
   Enter Structure and press ENTER
   ```

Even though you switch to the Structure Workspace, mechanical structure is not switched on automatically.

**To enable mechanical structure**

- Click the STRUCT status bar button and ensure that it lights up.
Folders

The basic element of mechanical structure is the folder. A folder is similar to a block in that it has a definition that can be instanced multiple times. Like a block, the definition is stored away in the non graphical area of the drawing. Similar to blocks, any change you make to the folder definition is reflected in all instances of that folder.

Creating Folders

1. Use the Circle tool to create a circle. The size and proportions are not important.
2. Use the Rectangle tool to draw a rectangle around the circle.
3. Right-click anywhere in the browser, and select New ➤ Folder.
4. Respond to the prompts as shown:
   Enter folder name <Folder1>: Press ENTER
   Select objects for new folder: Select the circle and then the rectangle and press ENTER
   Specify base point: Pick the lower left corner of the rectangle

Modifying Folders

While folders are similar to blocks, there are significant differences. The most significant, is that the contents of a folder remain editable without the need for a special editing mode such as REFEDIT.
To grip edit the circle

1. Continue clicking the circle until you see the word CIRCLE in the tooltip window.
2. Select a grip, drag and then click.

If the contents of a folder are selectable, how do you select the folder? This is where the tooltip comes in. You select folders (and other elements of structure) by cycling through a selection, and the tooltip tells you what you are selecting. In the next exercise, you copy the folder to demonstrate structure selection.

To copy the folder

1. Press ESC to clear any preselection.
2. On the command line, enter COPY and press ENTER.
3. Continue clicking the circle until you see the word Folder1:1 in the tooltip window.
4. Press ENTER to complete selection, then pick points to finish the copy.
5. Press ESC to finish.
The Mechanical Browser shows a second instance of the folder (Folder1:2), implying that you copied the folder, not just the contents.

In the next exercise you modify the contents of a folder to demonstrate that modifying one instance of a folder updates both.

To edit an instance

1. Continue clicking a circle until you see the word CIRCLE in the tooltip window.
2. Press DELETE. Note how the circle is deleted from both instances.

Next, you add new geometry to a folder. Before you add geometry you must activate the folder to make it the active edit target. This ensures that geometry is added to the folder and not to model space.

To activate and add geometry

1. In the browser, right-click Folder1:1 and select Activate. The geometry that does not belong to this folder is dimmed out.
2. Use LINE to draw two diagonal lines from corner to corner on the rectangle. Note that the lines appear in the other instance as soon as the command is completed.
3 Double-click a vacant area in the browser to reset activation.

Nesting Folders

Like blocks, folders can be nested. However, a folder cannot be nested within itself, which is about the only restriction on folder nesting.

1 Draw a small circle in the lower triangle in the second instance of the folder.

2 Draw a line from the center of the circle to the 3 o’clock quadrant of the circle.

3 In the browser, right-click Folder1:2 and select New Folder.

4 Respond to the prompts as shown:
   Enter folder name <Folder2>: Press ENTER
   Select objects for new folder:
Select the circle and then the line, press ENTER
Specify base point: Select the center of the circle.

5. Expand Folder1:1 and Folder 1:2 and verify that a nested folder was created.

6. In the browser, right-click Folder1:2 again and select Insert Folder.

7. Respond to the prompts as below:
   Enter folder name to insert or [?] <>: Enter Folder2, press ENTER
   Specify the insertion point or [change Base point/Rotate 90]:
   Click in the triangle on the right, in the second instance of Folder1
   Specify rotation angle <0>: Enter 45, press ENTER
Notice that when you added the nested folders, both instances updated, as when you added the lines. Folder2:1 was created as a child of Folder1:2 because we chose New Folder from its context menu, and Folder2:2 was inserted into Folder1:2 for the same reason. Note that as with blocks, you were able to rotate the folder instance on insertion.

**Instance vs. Occurrence**

To finish with folders, you inspect a few browser functions such as visibility and property overrides. While performing these exercises you learn the difference between instances and occurrences.

**To override properties**

1. In the browser, right-click Folder1:1 and select Property Overrides.
2. In the Property Overrides dialog box, select the Override Properties check box.
3. Select the Color check box, The default color changes to red.
4. Click OK.

   Note how the entire instance, inclusive of the nested folders is now red. Also note how the color change did not have an effect on Folder1:2.

5. In the browser, right-click Folder1:1 again, and select Property Overrides.
6. In the Property Overrides dialog box, clear the Enable overrides check box, and click OK.
7. In the browser, right click Folder1:1 ➤ Folder2:1 and select property overrides.
8. Apply a color override of red to the folder.
The subfolder you selected is now red, but the other subfolder is not. Notice that the same subfolder under Folder1:2 has changed color to red. This is because property overrides are instance-based. When you look at visibility you will understand why this matters.

To apply visibility overrides

1. In the browser, right-click Folder1:1 and select Visible. The entire folder is now invisible.
2. In the browser, right-click Folder1:1 and select Visible. The folder is visible again.
3. In the browser, right-click Folder1:1\Folder2:2 and select Visible. Notice that unlike the property overrides, both instances of Folder2 are visible in Folder1:2. That’s because visibility is occurrence-based.

Selection Modes

There are three status bar buttons that control the different selection modes. These buttons are not visible by default and you must display them first.

To display the selection mode status bar buttons

1. Click the Drawing Status Bar Menu arrow at the right end of the drawing status bar.
2 Turn on the Status Toggles ➤ S-LOCK, Status Toggles ➤ R-LOCK and Status Toggles ➤ Top Down/Bottom up options.

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>BTM-UP/TOP-DN</td>
<td>Switches the structure selection order between bottom-up and top-down.</td>
</tr>
<tr>
<td>R-LOCK</td>
<td>Switches the Reference Lock on and off. When the Reference Lock is on, you cannot select entities in an external folder or view (more on this later).</td>
</tr>
<tr>
<td>S-LOCK</td>
<td>Switches the Selection Lock on and off. When the Selection Lock is on, selection is restricted to the active edit target and below.</td>
</tr>
</tbody>
</table>

The next two exercises demonstrate the behavior of the BTM-UP/TOP-DN and S-LOCK selection modes.

**To select items when the selection mode is set to top-down**

1 Press ESC to clear any preselection.

2 Click the BTM-UP/TOP-DN button and ensure that the text on the button reads TOP-DN.

3 Click one of the circles in Folder1:1. Note the tooltip indicates that you selected the folder, Folder1:1, and not the circle.

4 Click the circle again. Note the tooltip indicates that you selected the nested folder.

5 Click the circle again. Note the tooltip indicates that you have finally managed to select the circle.

6 Click the circle again. Selection cycles to Folder1:1 again.

When the selection mode is set to top-down, the selection sequence begins at the topmost level and ends with the elemental geometry. When the selection mode is set to bottom-up the selection begins with the elemental geometry.

You may want to set the selection mode and repeat the exercise to verify the behavior of the selection modes under the bottom-up.

**To select items when S-LOCK is on**

1 Press ESC to clear any preselection.
2 In the browser, double-click Folder1:1 to activate it.
3 Click the S-LOCK button and latch it down to turn on the selection lock.
4 Click one of the circles in Folder1:2. Note that the circle is no longer selectable.
5 Click one of the circles in Folder1:1. Grips appear, indicating that selection is possible.
6 Double-click the root of the Mechanical Browser tree to reset activation.
7 Close the drawing. You can save the drawing, if required.

Components and Component Views

You may notice that folders provide some useful features, but they're probably not different enough from blocks to convince you to change over to the structure paradigm. The true potential of mechanical structure becomes visible only when you start dealing with components and component views.

Component Views are basically folders with some extra rules that make them more suitable for mechanical design. You typically need more than one view to fully describe a part or assembly. Folders (and blocks before them) don't offer any mechanism other than naming to associate multiple views of the same part. Components and views solve this by allowing you to collect multiple folders (component views) under a single Component.

A component can be a part or assembly, based on its contents (if a component contains another component, it's an assembly). The component also gives you a place to store attributes like description and material. Components don't actually contain geometry; they group the views that contain the geometry. This will begin to make more sense when you create some components and component views.

Creating Part Components

1 Start a new drawing and draw a long thin rectangle (the edge view of a plate).
2 Draw a second rectangle, above the first, having the same width (the top view).
3 Right-click anywhere in the browser, and select New ➤ Component.
Respond to the prompts as shown:

Enter new component name <COMP1>: Press ENTER
Enter new view name <Top>: Press ENTER
Select objects for new component view:

Select the larger rectangle and press ENTER
Specify base point: Pick the lower left corner of the rectangle

Note that the Mechanical Browser now displays the component COMP1:1 and that it contains the component view; Top, below it.

To add a new view to a component

1. In the browser, right-click COMP1:1 and select New ➤ Component View.
2. Accept the default name for the component view.
3. Select the smaller rectangle and press ENTER.
4. To specify a base point, click the lower left corner of the rectangle. Note that the new component view, Front, was added to the component COMP1:1.
Creating Assembly Components

You now have two component views; Front and Top, and they are grouped together in the browser by COMP1:1. In the next exercise, you insert another instance of COMP1 and assemble the two components (parts) in an “L” shape.

To insert a new instance of a component

1. In the browser, right-click a vacant area, and select Insert ➤ Component.

2. Respond to the prompts as shown:
   
   Enter component name or [?] <COMP1>: Enter COMP1 and press ENTER
   
   Enter component view name or [?] <Top>: Enter Front and press ENTER
   
   Specify the insertion point or [change Base point/Rotate 90/select next View]:
   
   Pick point 1, the top left corner of the larger rectangle
   
   Specify rotation angle <0>: Press ENTER
3 In the browser, right-click COMP1:2 and select Insert ➤ Component View ➤ Top.

4 Respond to the prompts as shown:

Specify the insertion point or [change Base point/Rotate 90/select next View]:

*Pick point 2, the lower left corner of the front view of COMP1:1*

Specify rotation angle <0>: Press ENTER.

To assemble components

1 Right-click anywhere In the browser, and select New ➤ Component.
2 Respond to the prompts as shown:
Enter new component name <COMP2>: Enter ASSY and press ENTER
Enter new view name <Top>: Enter Front and press ENTER
Select objects for new component view:
Select COMP1:1 (Front) and COMP1:2 (Top) and press ENTER
To select a component view instead of the geometry, continue clicking the geometry until you see the component view name in the tooltip window. If you accidentally select the wrong view, you can cancel the selection by selecting the view again with the SHIFT key pressed.
Specify base point: Pick the lower left corner of the combined view.
The Component Restructure dialog box is displayed.

3 In the Destination Components list, right-click a vacant area, and select Create New View.

4 Respond to the prompts as shown:
Enter new view name <Top>: Press ENTER
Select objects for new component view:
Select COMP1:1 (Top) and COMP1:2 (Front), press ENTER
Specify base point: Pick the lower left corner of the combined view
Modifying Assembly Components

As you work, you can continue to add views as needed. To demonstrate this, in the next exercise, you add a side view of this assembly.

To add a component view

1. Draw a rectangle representing the side view of the first instance of COMP1.
2. In the browser, right-click ASSY:1 and select New ➤ Component View.
3. Respond to the prompts as follows:
   - Enter new view name <Right>: Enter Side and press ENTER
   - Select objects for new component view: Don’t pick anything, press ENTER
   - Specify base point: Pick the lower left corner of the rectangle
4. In the browser, right-click COMP1:1 and select New ➤ Component View.
5. Respond to the prompts as shown:
   - Enter new view name <Right>: Enter Side, press ENTER
   - Specify parent view or [?] <Front>: Enter Side, press ENTER
   - Select objects for new component view: Pick the rectangle and press ENTER
Specify base point: *Pick the lower left corner of the rectangle*

6 In the browser, right-click COMP1:2 and select Insert ➤ Component View ➤ Side.

7 Respond to the prompts as shown:

   Specify parent view or [?] <Front>: *Enter Side, press ENTER*

   Specify the insertion point or [change Base point/Rotate 90/select next View]:

   *Enter R, press ENTER*

   Specify the insertion point or [change Base point/Rotate 90/select next View]:

   *Pick a place close to the other view*

   Specify rotation angle <90>: *Press ENTER*

8 Move the view into the correct position.
In the next exercise, you add a component to the assembly to demonstrate the ability to add a component after the assembly is created.

To add a component

1. Draw a circle on the top view of the assembly.
2. In the browser, right-click ASSY:1(Top) and select New ➤ Component.
3. Respond to the prompts as shown:
   - Enter new component name <COMP2>: Press ENTER
   - Enter new view name <Top>: Press ENTER
   - Select objects for new component view: Select the circle, press ENTER
   - Specify base point: Click the center of the circle
4 Draw a rectangle representing the projected view in the front view of the assembly.

5 Right-click COMP2:1 and select New ➤ Component View.

6 Respond to the prompts as shown:

   Enter new view name <Front>: Enter Side, press ENTER

   Specify parent view or [?] <Front>: Press ENTER

   Select objects for new component view:

   Select the rectangle, press ENTER

   Specify base point: Pick the midpoint of the lower edge of the rectangle
7 In the browser, right-click COMP2:1 and select Insert ➤ Component View ➤ Side.

8 Respond to the prompts as shown:

Specify parent view or [?] <Front>: Enter Side, press ENTER

Select objects for new component view:

Select the rectangle, press ENTER

Specify the insertion point or [change Base point/Rotate 90/select next View]: Pick the midpoint of the lower rectangle in the Side view of ASSY1

Using Folders with Component Views

When folders are used in conjunction with component views, you can do several useful things. This section shows two examples.

You can use folders to contain drawing items that would otherwise not be accounted for with a default component view folder.

In the following example, a folder, Groove:1, was created to contain the upper groove and arrayed to create the others. Because the groove is implemented as a folder, it does not have an impact on the BOM. Modifying one of the grooves results in all grooves being updated.
In the following example, a folder, Profile:1, was created to contain the upper-wheel profile. Profile:2 is another instance of this folder, created by mirroring Profile:1. Changing one profile automatically updates the other. The wheel component was created after the Profile folders. The design intent is captured and organized with these folders.

**Mechanical Browser Display Options**

The Mechanical Browser shows the hierarchical organization of components within a drawing. In this section, you use browser options to show data in different ways to get a better understanding of components and component views.

The default view of the Mechanical Browser shows the hierarchical organization of components as well as indicates which component owns a given component view.
To show the View Tree and Component Tree

1. Right-click the root node of the Mechanical Browser and select Browser Options.

2. In the View Tree section, select the Display Tree check box.

3. In the Component Tree section, clear the Component Views check box.

4. Click OK.

5. Right-click a vacant area in the Mechanical Browser and select Expand All.

In this view, the hierarchy of components as well as views are shown.
To show both default and expandable assembly views

1. Right-click the root node of the Mechanical Browser and select Browser Options.

2. In the Component Tree section, select the Component Views check box.

3. Click OK.

In this view, the Mechanical Browser shows the hierarchy of components, component views as well as indicates which component owns a given component view. In practice, you can work with the view settings that makes most sense to you.

**Mechanical Browser and BOMs**

Components not only group component views, they hold bills of material (BOM) attributes as well. In the next exercise, you insert a parts list and in the process, explore the BOM of the simple assembly you created.
To insert a parts list

1. On the command line, enter AMBOM.
2. Respond to the prompts as shown:
   
   Specify BOM to create or set current [Main/?] <MAIN>:
   
   Press ENTER

3. In the BOM dialog box, click the plus sign (+) in the first column to expand ASSY.
4. Click the Insert Parts list button on the toolbar of the BOM dialog box.
5. In the Parts List dialog box, click OK and click inside the drawing to indicate where to insert the parts list.
6. In the BOM dialog box, click OK.
By associating views through a single component, the BOM is managed accurately and semi-automatically. You can manage component attributes through the BOM editor or directly on the component from the Mechanical Browser.

**Browser Restructure and Ghost Components**

In the next exercise you restructure COMP1:1 and COMP2:1 to be parts of an assembly named SUB-ASSY. To do this, you must create SUB-ASSY first.

**To create a component**

1. Right-click a vacant area in the Mechanical Browser and choose New ➤ Component.

2. Respond to the prompts as follows:
   
   Enter new component name <COMP3>: *Enter SUB-ASSY, press ENTER*

   Enter new view name <Top>: *Press ENTER*
Select objects for new component view:

*Select COMP1:1 (Top) and COMP2:1 (Top), press ENTER*

To select a component view instead of the geometry, continue clicking the geometry until you see the component view name in the tooltip window. If you accidentally select the wrong view, you can cancel the selection by selecting the view again with the SHIFT key pressed.

Specify base point: *Pick the lower left corner of the combined view*

The Component Restructure dialog box is displayed.

3. Observe the Mechanical Browser.
Note that the component SUB-ASSY is already created (1) and COMP1:1 and COMP2:1 are components of it. Also, the COMP1:1 and COMP2:1 continue to exist as components of ASSY1 (2), but the icon changed. This icon indicates that the component is a Ghost Component. Ghost components are containers of the views of components that are in an intermediate state of restructure.

To learn how to resolve ghost components, you must stop creating SUB-ASSY at this point.

4 Click OK. You now have two ghost components in the Mechanical Browser.

Before you start resolving ghost components, you must add two component views to the component SUB-ASSY.

5 In the Mechanical Browser, right-click SUB-ASSY:1 and select New ➤ Component View.

6 Respond to the prompts as follows:

Enter new view name <Front>: Press ENTER
Select objects for new component view:

*Don’t pick anything, press ENTER*

Specify base point:

*Pick the lower left corner of the large rectangle in the lower left of the drawing*

7 In the Mechanical Browser, right-click SUB-ASSY:1 and select New ➤ Component View again.

8 Respond to the prompts as shown:

- Enter new view name <Right>: *Enter Side, press ENTER*

Select objects for new component view:

*Don’t pick anything, press ENTER*

Specify base point:

*Pick the lower left corner of the assembly displayed in the lower right of the drawing*
To resolve ghost components

1. In the Mechanical Browser, click the ghost component COMP1:1, press the CTRL key and click COMP2:1. Both components are selected.

2. Drag to SUB-ASSY1. The Component Restructure dialog box is displayed.

3. In the Source Component Views list, with the CTRL key pressed select COMP1:1(Front) and COMP2:1(Side).

4. Drag to SUB-ASSY1(Front). The views move from the Source Component Views list to the Destination Component Views list.

5. Drag the remaining views in the Source Component Views list to SUB-ASSY1:(Side) in the Destination Component Views list.

6. Click OK.
The ghost components disappear and COMP1:1 and COMP2:1 are now parts of SUB-ASSY1.

In the final exercise of browser restructure, you restructure SUB-ASSY1 to be a subassembly of ASSY1.

To restructure components

1. In the Mechanical Browser, drag SUB-ASSY:1 ➤ Front to ASSY:1 ➤ Front. The Restructure components dialog box is displayed.

2. Drag SUB-ASSY:1 (Top) to ASSY:1 (Top) and SUB-ASSY:1 (Side) to ASSY:1 (Side).

3. Click OK. SUB-ASSY1 is restructured as a subassembly of ASSY:1
External Reference Components

In AutoCAD Mechanical, you can save individual parts and subassemblies in external files and share them between designs. When a part is modified, the changes are propagated to all instances, ensuring that assembly drawings are always synchronized with their related part drawings.

Inserting External Components

In this exercise, you insert a Gripper on to a Gripper Plate drawing.
1. Open the file Tut_Gripper_Plate.dwg in the tutorials folder.
   
   **Ribbon**
   None.

   **Menu**
   File ➤ Open...

   **Command**
   OPEN

   **NOTE**
   The path to the tutorials folder is;
   - Windows Vista®: C:\Users\Public\Public Documents\Autodesk\ACADM 2010\Acadm\Tutorial
   - Windows® XP: C:\Documents and Settings\All Users\Shared Documents\Autodesk\ACADM 2010\Acadm\Tutorial

   The drawing contains two views of a gripper plate and contains two construction lines.

2. To keep the original file intact, save the file as Gripper.dwg

3. Display the Structure Catalog.
   
   **Ribbon**
   None.

   **Menu**
   Tools ➤ Palettes ➤ Structure Catalog
   Structure ➤ Structure Catalog...

   **Command**
   AMSCATALOG

4. In the External Drawings tab, navigate to the tutorials folder and select Tut_Gripper.dwg.

   **NOTE**
   In the Structure Catalog, navigate to the following folders:
   - Windows Vista: C:\Users\Public\Documents\Autodesk\ACADM 2010\Acadm\Tutorial
   - Windows® XP: C:\Documents and Settings\All Users\Documents\Autodesk\ACADM 2010\Acadm\Tutorial

   The Mechanical Structure panel shows the mechanical structure components in the drawing and the Preview panel shows a preview of the drawing.

5. In the structure panel, double click GRIPPER to reveal the components list.

6. Click and drag GRIPPER ➤ Front to model space.
7 Respond to the prompts as shown:
Specify the insertion point or [change Base point/Rotate
90/select next View]:

*Pick the upper left corner of the smaller rectangle*

Specify rotation angle <0>: *Press ENTER*

Note the Mechanical Browser. The external reference (xref) component
is indicated by a blue colored marker.

---

Once one view of an xref component is inserted, the other views can be
inserted as normal.

**To insert another view of the xref component**

1 In the Mechanical Browser, right-click GRIPPER1 and select Insert from
Xref Drawing ➤ Component View ➤ Top.

2 Respond to the prompts as shown:
Specify the insertion point or [change Base point/Rotate
90/Select nextView]:

*Pick the upper left corner of the larger rectangle*

Specify rotation angle <0>: *Press ENTER*
To insert more instances of the xref component

1. On the command line enter `MIRROR` and press ENTER.
2. Respond to the prompts as shown:
   - Select objects:
     "Ensure that the selection mode is set to TOP-DN and in model space, click both xref views you inserted, press ENTER"
   - Specify first point of mirror line:
     "Click anywhere on the vertical construction line"
   - Specify second point of mirror line:
     "Click elsewhere on the vertical construction line"
   - Erase source objects? [Yes/No] <N>: Enter N and press ENTER
3. In the last column of the Component View Instance Created dialog box, select New.
   - A new instance of the component, GRIPPER:2 is created. You will now mirror the top views of GRIPPER:1 and GRIPPER:2 to draw two more grippers on the top view of the plate.
4. On the command line enter `MIRROR` and press ENTER.
5. Respond to the prompts as follows:
   - Select objects:
     "Ensure that the selection mode is set to TOP-DN and in model space, click the top views of the two grippers, press ENTER"
   - Specify first point of mirror line:
     "Click anywhere on the horizontal construction line"
   - Specify second point of mirror line:
Click elsewhere on the horizontal construction line

Erase source objects? [Yes/No] <N>: Enter N and press ENTER

Next, you assemble the components under an assembly, named GRIPPER ASSEMBLY.

To assemble components

1. Right-click a vacant area in the Mechanical Browser, and select New ➤ Component.

2. Respond to the prompts as shown:
   - Enter new view name <Top>: Enter Front and press ENTER
   - Select objects for new component view:
     - Ensure that the selection mode is set to TOP-DN and window select the smaller rectangle and the two grippers connected to it and press ENTER
     - Specify base point:
       - Pick the intersection of the construction line with the upper edge of the rectangle

The Component Restructure dialog box is displayed.
3 In the Destination Components list, right-click a vacant area, and select Create New View.

4 Respond to the prompts as shown:

   Enter new view name <Top>: Press ENTER

   Select objects for new component view:

   Ensure that the selection mode is set to TOP-DN and window select the larger rectangle and the four grippers connected to it and press ENTER

   Specify base point: Pick the intersection of the two construction lines

5 Save the file as Gripper Assembly.dwg.

Editing External Components In-place

In AutoCAD Mechanical, you can edit xref components in-place. Although this is very convenient, if you accidentally modify a component, the mistake affects all drawings that use this xref component. As a precaution, you must do one of the following before you edit an xref component:

■ Release the R-LOCK status bar button.
■ Activate the xref component view or folder to be edited.

In the next exercise, you modify the gripper lever using the activate method.
To edit an xref component in place

1. In the Mechanical Browser, double-click Gripper ➤ Front to activate it.
   Notice that locks appear on all instances of the gripper in the Mechanical Browser. This indicates that the source file containing the gripper is now locked and no one else can modify it.

2. Start the Chamfer command.
   **Ribbon**
   Content Edit tab ➤ Modify panel ➤ Chamfer.

   **Menu**
   Modify ➤ Chamfer

   **Command**
   AMCHAM2D

3. Respond to the prompts as shown:
   Select first object or [Polyline/Setup/Dimension]: <Setup>
   Press ENTER

4. In the Chamfer dialog box, select 10 as the first and second chamfer lengths, and click OK

5. Respond to the prompts as shown:
   Select first object or [Polyline/Setup/Dimension]: <Setup>
   Select the left vertical line of the gripper lever (1)
   Select second object or <Return for polyline>: 
   Select the lower horizontal line of the gripper lever (2)
   Select object to create original length: Press ESC

6. In the Mechanical Browser, double-click a vacant area to reset activation.
   Note that although the xref component view is no longer the active edit target, the gripper continues to be locked.
7 In the Mechanical Browser, right-click a vacant area, and select Purge All Locks.

8 In the Purge Locks message box, click OK.

To verify if the changes were written back to the source file

- In the Mechanical Browser, right-click GRIPPER1 and select Open to Edit. The Gripper source file opens.

Note that the component view Open Position has also been modified. How did this happen?

Expand the component Lever1. Notice that it has two instances of the component view Front. Another example of how mechanical structure can eliminate repetitive tasks.

Localizing and Externalizing

To modify a part without effecting other drawings that use the part, you can localize the xref component. By localizing you copy the definition of the xref component to the current drawing and the link with the xref file is severed.

To localize an xref component

1 From the Window menu, switch to the Gripper Assembly drawing.

2 In the Mechanical Browser, right-click the GRIPPER assembly node and select Localize.

3 In the Xref Info message box, click Yes.

The Gripper is no longer an xref component.

To detail a part without loosing associativity between the detail and assembly, you can externalize the part to a file and detail it in that file. In the next exercise you externalize the cylinder component.

To externalize a component

1 In the Mechanical Browser, expand one of the Gripper components and right click CYLINDER:1.

2 Select Externalize.

3 In the New External File dialog box, accept the defaults and click Save.
Note that CYLINDER:1 is an xref component in all instances of the GRIPPER component.

Annotation Views

In some cases, externalizing to detail may be considered excessive. Mechanical Structure provides for creating Annotation Views, an associative view of a component purely for the purpose of detailing. Annotation views have no effect on the BOM.

In the next exercise, you create an annotation view for the LEVER component.

To create an annotation view

1. In the Mechanical Browser, expand one of the Gripper components and right-click LEVER:1
2. Select New ➤ Annotation View.
3. Respond to the prompts as follows:
   - Enter annotation view name <LEVER(AV1)>: Press ENTER
   - Select placement location
     - [Modelspace/existing Layout/ New layout] <existing Layout>: Press ENTER
   - Enter existing layout name <Layout1>: Press ENTER
   - Enter scale or [Calculate] <1:2>: Press ENTER
     --- Switch to Paperspace ---
   - Restoring cached viewports - Regenerating layout.
   - Create labels for all subviews [Yes/No] <No>: Press ENTER
   - Specify base point:
     Select a point at the center of the A3 paper for the annotation views
   - Specify the insertion point or [change Base point/Rotate 90/select next View/Done] <Done>:
     Select a point below and to the right of the point you clicked on previously
   - Specify rotation angle <0>: Press ENTER
     Specify the insertion point or [change Base point/Rotate 90/select next View/Done] <Done>: 

92 | Chapter 4  Using Mechanical Structure
Use object tracking mode for alignment, select a point directly below the point you clicked on previously.

Specify rotation angle <0>: Press ENTER

Specify the insertion point or [change Base point/Rotate 90/select next View/Done] <Done>: Press ENTER

NOTE You can type AMSNEW at the command line to display the New dialog box to create annotation views.

To annotate the geometry in the annotation view

1 Start the Automatic Dimension command.

   **Ribbon** Home tab ➤ Dimension panel ➤ Power Dimension drop-down ➤ Multiple Dimension. Annotate tab ➤ Dimension panel ➤ Multiple Dimension.

   **Menu** Annotate ➤ Multiple Dimensioning

   **Command** AMAUTODIM

The Automatic Dimensioning dialog box is displayed.

2 In the Type drop-down list, select Chain and click OK.

3 Respond to the prompts as follows:

   Select objects [Block]:

   Window-select the larger of the two views in the annotation view

   Select objects [Block]: Press ENTER
First extension line origin: Pick the upper left corner of the geometry
Specify dimension line location or [Options/Pickobj]:
Select a point to the left of the geometry
Starting point for next extension line: Press ENTER

4 Note the dimension of the chamfer section.

To modify the chamfer in the assembly

1 Switch to model space. In the Mechanical Browser, expand GRIPPER:1, right-click LEVER:1 ➤ Front and select Zoom to.

2 Start the Power Edit command.
   Ribbon None.
   Menu Default Menu ➤ Power Edit
   Edit Menu ➤ Power Edit
   Modify ➤ Power Edit
   Command AMPOWEREDIT

3 Respond to the prompts as shown:
   Select object: Select the Chamfer

4 In the Chamfer dialog box, select 2.5 as the First Chamfer Length and 5 as the Second Chamfer Length, and click OK.

5 Switch to layout1. In the Mechanical Browser, right click LEVER(AV1:1) and select Zoom to.
   Note that the Lever shape is changed and the dimensions are updated.
Associative Hide

Mechanical structure is all about reuse, especially reuse of components in an assembly to show multiple instances of a component and reuse of component views in the assembly and in the part detail. Component view instances are often obscured in the assembly, sometimes the same view is even obscured differently in different instances. This requires a mechanism to make a folder or component view instance partially or fully hidden without effecting other view instances. Use Associative hide (AMSHIDE) to do that.

Basics of AMSHIDE

In the next exercise, you create a hide situation between two folders.

To create a hide situation

1. Open the file Tut_AMSHIDE.dwg in the tutorials folder.

Ribbon

- Home tab ➤ Draw Tools panel ➤ Hide Situation drop-down ➤ Create.
- Structure tab ➤ Hide panel ➤ Create Associative Hide Situation.

Menu

- Modify ➤ Associative Hide ➤ Create Associative Hide Situation

Command

- AMSHIDE

NOTE The path to the tutorials folder is;
- Windows Vista: C:\Users\Public\Public Documents\Autodesk\ACADM 2010\Acadm\Tutorial
- Windows XP: C:\Documents and Settings\All Users\Shared Documents\Autodesk\ACADM 2010\Acadm\Tutorial

The drawing contains three instances of a folder, where two overlap each other.
2 Start the Associative Hide command.

**Ribbon**

- Home tab ➤ Draw Tools panel ➤ Hide Situation
  - drop-down ➤ Create.
- Structure tab ➤ Hide panel ➤ Create Associative Hide Situation.

**Menu**

- Modify ➤ Associative Hide ➤ Create Associative Hide Situation

**Command**

AMSHIDE

3 Respond to the prompts as follows:

Select foreground objects:

*Ensure that the selection mode is set to TOP-DN and click the upper rectangle (1)*

Select foreground objects: Press ENTER

4 In the Hide Situation dialog box, expand Level1 and Level2. Note how Folder1 is selected for the foreground (Level1) and Folder2 is selected for the background.
5 If the dialog box is collapsed, as shown in the image above, click to expand it.

6 Click the Hide node on the tree in the dialog box.

7 Clear the Display hidden lines check box.
   The hidden lines are set to invisible. The change is immediately reflected in model space.

8 In the Name box, enter *Test Hide*. 

9 To swap the foreground and background, select Level1 on the tree and click the Send to Back button on the toolbar of the dialog box. Note that the position of Level1 changes in the tree and model space reflects the change immediately.

10 Click OK.
   In the next exercise, you edit the hide situation and add the third folder to the hide situation.

To edit a hide situation

1 In the Mechanical Browser, if a node named Hide Situations is not visible:
   a Right-click TUT_AMSHIDE on the Mechanical Browser. The Browser Options dialog box is displayed.
   b In the Hide Situations section, select the Display hide situations check box.
c  Click OK.

2 Select Test Hide, from below the Hide Situations node on the Mechanical Browser. Note that the entities involved in the hide are highlighted in model space.

3 Double-click Test Hide.
   The Hide situations dialog box is displayed.

4 In the Toolbar of the Hide Situation dialog box, click the button.
   Level3 is added to the top of the tree.

5 Click to select objects for Level3.

6 Respond to the prompts as follows:
   Select objects:
   Set selection mode to TOP-DN and click the rectangle on the extreme right
   Select objects: Press ENTER

7 Click OK.

8 Use the MOVE command to move the contents of Folder 1:3 on top of Folder1:2 and Folder 1:3.
Using AMSHIDE in Assemblies

In this section, you create a hide situation on an assembly and save it to the appropriate position in the mechanical structure.

To open the sample files

- Open the file Tut_Robot_Arm.dwg in the tutorials folder.
  
  **Ribbon** None.
  
  **Menu** File ➤ Open...
  
  **Command** OPEN

**NOTE** The path to the tutorials folder is;

- **Windows Vista**: C:\Users\Public\Public Documents\Autodesk\ACADM 2010\Acadm\Tutorial

- **Windows XP**: C:\Documents and Settings\All Users\Shared Documents\Autodesk\ACADM 2010\Acadm\Tutorial

The drawing contains an assembly of a robotic arm, and has external references to the gripper assembly you created during the exercise for external references.

To create a hide situation between the gripper and the axis of the robotic arm

1. Start the Associative Hide command.
   
   **Ribbon** Home tab ➤ Draw Tools panel ➤ Hide Situation drop-down ➤ Create.
2 Respond to the prompts as shown:
   Select foreground objects:
   *Continue clicking (1) until you see GRIPPER:2 (Front) in the tooltip*
   Select foreground objects: *Press ENTER*

3 Click Level2 in the tree view and select the button.

4 Respond to the prompts as shown:
   Select objects:
   *Continue clicking (2) until you see AXIS:1 (Front) in the tooltip*
   Select objects: *Press ENTER*

5 In the tree view of the Create Hide Situations dialog box, click the Hide node.
   In the next step, you select where in the Mechanical Browser the hide situation is stored. The most logical place to store the hide situation is on the Front view of the ROBOT:1 assembly.

6 In the Store Hide Situation on list, select ROBOT:1 (Front).

7 Click OK. The Hide Situation is created and stored under ROBOT:1 (Front) in the Mechanical Browser.
   This is the end of the tutorial.
In this tutorial, you start with a lever inserted from the parts library, and then you refine the design using many of the design options available in AutoCAD® Mechanical. You also create a drawing detail and add dimensions to it.

### Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>construction lines</td>
<td>Lines, which are infinite in both directions or rays, which are infinite starting at a point that can be inserted into the drawing area. You use construction lines to transfer important points (for example, center points of holes) into other views or drawing areas.</td>
</tr>
<tr>
<td>construction geometry</td>
<td>A line or an arc created with construction lines. Using construction geometry in 2D drawings helps define the shape of a contour.</td>
</tr>
<tr>
<td>detail</td>
<td>A portion of a design drawing that cannot be clearly displayed or dimensioned in the overall representation but can be enlarged to show the details.</td>
</tr>
<tr>
<td>distance snap</td>
<td>To give the dimensions in a drawing a uniform appearance, Power Dimensioning and Automatic Dimensioning enable automatic insertion of the dimension line at a defined distance from the object being dimensioned. While dragging the dimension line dynamically, you will find that it remains “fixed” and is highlighted in red as soon as the required distance to the object being dimensioned is reached.</td>
</tr>
</tbody>
</table>
Definition

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>library</td>
<td>A feature that makes it possible to store parts such as blocks and drawings in a library. For every inserted part, an icon can be created. The icon is put in the display section on the right side of the dialog box along with an assigned name.</td>
</tr>
<tr>
<td>Power Dimensioning</td>
<td>Power Dimensioning is a very useful tool for generating linear, radial and diameter dimensions, which minimizes the number of the individual actions required while generating a dimension. Power Dimensioning selects the type of linear dimension (horizontal, vertical, or aligned), based on the selected point, and the dimensions of the drawing can have a uniform style using the distance snap.</td>
</tr>
</tbody>
</table>

**Extending Designs**

First, you start a new drawing template with ISO standard. Then you load the initial drawing using the Library.

**To open a template**

1. Open a new drawing.
   - **Ribbon**
     - New ➤ Drawing
   - **Menu**
     - File ➤ New
   - **Command**
     - NEW
   - The Select template dialog box opens.

2. In the Select template dialog box, select the template *am_iso.dwt*.
   - This opens a new drawing template. Now you insert the drawing from the library.
Using Libraries to Insert Parts

Insert the required part from the library.

To insert a drawing from the library

1. Start the Library.
   
<table>
<thead>
<tr>
<th>Ribbon</th>
<th>None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu</td>
<td>Tools ➤ Library...</td>
</tr>
<tr>
<td>Command</td>
<td>AMLIBRARY</td>
</tr>
</tbody>
</table>

2. Double-click the *tut_lever.dwg* file in the Library.

3. Respond to the prompt as follows:
   Specify insertion point: *Specify any point in the drawing*

4. Start the Zoom Window command.
   
<table>
<thead>
<tr>
<th>Ribbon</th>
<th>View tab ➤ Navigate panel ➤ Zoom drop-down ➤ Window.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu</td>
<td>View ➤ Zoom ➤ Window</td>
</tr>
<tr>
<td>Command</td>
<td>ZOOM</td>
</tr>
</tbody>
</table>

Respond to the prompts as follows:
Before starting the design, define the object snaps that you will use in later operations.

**Configuring Snap Settings**

In addition to the AutoCAD® snap, mechanical snap options like arc radial, arc tangent, and so forth are available. You also have four different snap settings, which can be configured separately for a quick switch to a different snap setting. For example, you can use different snap settings for detailing or general design.

**NOTE** The snap defaults can be set in the Options dialog box on the AM:Preferences tab.
To configure Power Snap settings

1. Start the Power Snap settings.
   - Ribbon: None.
   - Menu: Object Snap Cursor Menu ➤ Power Snap Settings
   - Command: AMPOWERSNAP

2. In the Power Snap Settings dialog box:
   - Settings 1: Endpoint, Intersection
   - Settings 2: Endpoint, Center, Quadrant, Intersection, Parallel
   - Settings 3: Perpendicular

3. After configuring the settings, activate Setting 1, by selecting Settings 1 from the Power Snap Configuration drop-down list and then click OK.

   Save your file.

   **NOTE** Within a command, the various object snap functions are also accessible. Hold down the SHIFT key, and right-click.

**Creating Construction Lines (C-Lines)**

Construction lines are very useful when you start your design process. With their help, you draw a design grid with your defined values for distance and angles. After generating the design grid, you simply trace your contour with the contour layer.
Now insert the construction lines, which will help you draw the contour lines.

**To create construction lines**

1. Start the Draw Construction Lines command.

   **Ribbon**
   - Home tab ➤ Draw Tools panel ➤ Construction
   - Draw ➤ Construction Lines ➤ Draw Construction Lines...

   **Menu**
   - Draw ➤ Construction Lines ➤ Draw Construction Lines...

   **Command**
   - AMCONSTLINES

   The Construction Lines dialog box opens.

2. In the Construction Lines dialog box, choose the option next to the icon shown below and click OK.

3. Respond to the prompts as follows:
   - Specify insertion point: *Specify the intersection of line b and line c (1)*
   - Specify insertion point: Press ENTER

4. Next, draw two lines parallel to the vertical and horizontal lines of the construction line cross.

5. Start the Draw Construction Lines command.
Ribbon

Home tab ▶ Draw Tools panel ▶ Construction Lines

Menu

Draw ▶ Construction Lines ▶ Draw Construction Lines...

Command

AMCONSTLINES

The Construction Lines dialog box is displayed.

6 In the Construction Lines dialog box, choose the option next to Parallel construction line with full distance icon shown below and click OK.

7 Respond to the prompts as follows:

Select line, ray or xline: Select line c (1)

Specify insertion point or Distance (xx|xx|xx..) <10|20|30>:

Enter 3|9, press ENTER

Specify point on side to offset: Specify a point to the left of line c (2)

8 Insert the second set of parallel lines, and respond to the prompts as follows:

Select line, ray or xline: Select line b

Specify insertion point or Distance (xx|xx|xx..) <3|9>:

Enter 4.5|9.5, press ENTER

Specify point on side to offset: Specify a point below line b (2)
Creating additional C-Lines

AutoCAD Mechanical offers a large choice of C-line options.

To create additional construction lines

1. Activate snap setting 2.
   - Ribbon: None.
   - Menu: Object Snap Cursor Menu ➤ Power Snap Settings 1-4 ... ➤ Power Snap Configuration 2
   - Tools ➤ Drafting Settings ➤ Power Snap Configuration 2
   - Command: AMSNAP2

2. Start the Draw Construction Lines command.
   - Ribbon: Home tab ➤ Draw Tools panel ➤ Construction Lines.
   - Menu: Draw ➤ Construction Lines ➤ Draw Construction Lines...
   - Command: AMCONSTLINES
   - The Construction Lines dialog box is displayed.

3. In the Construction Lines dialog box, choose the option next to the Construction line by defining two points or an angle icon shown below, and click OK.

4. Respond to the prompts as follows:
   - Specify first point: Select the first point (1)
   - Specify second point or Angle (xx|xx|xx..) <30|45|60>: 

9. Press ENTER.
   - Save your file.
Move the cursor over line a and back to the rectangle until the Parallel symbol appears, click (2)

5 Press ENTER to finish the command.
Now, you draw tangential circles between the diagonal C-line and the right vertical line and lower horizontal line of the rectangle.

6 Start the Draw Construction Lines command.
   **Ribbon**  Home tab ➤ Draw Tools panel ➤ Construction Lines
   **Menu**  Draw ➤ Construction Lines ➤ Draw Construction Lines...
   **Command**  AMCONSTLINES
The Construction Lines dialog box is displayed.

7 In the Construction Lines dialog box, choose the option next to the Construction line circle tangent to 2 lines icon, shown below and click OK.

8 Draw the two circles by responding to the prompts as follows:
   Select first tangent: *Select tangent point (1)*
   Select second tangent: *Select tangent point (2)*
   Specify diameter: *Enter 2, press ENTER*
   Select first tangent: *Select tangent point (3)*
Select second tangent: **Select tangent point (4)**

Specify diameter <2>: **Enter 2, press ENTER**

9 Press ENTER to end the command.

All construction lines have been inserted, and the contour can be generated.

Save your file.

---

**Creating Contours and Applying Fillets**

Now, you connect the two tangential circles with the right part of the rectangle, to build a filleted triangle.

**To create and edit a contour**

1 Start the Polyline command.

   **Ribbon**
   
   Home tab ➤ Draw panel ➤ Polyline.

   **Menu**
   
   Draw ➤ Polyline

   **Command**
   
   PLINE

2 Create the contour by responding to the prompts as follows:

   Specify start point: **Specify the intersection point (1)**

   Specify next point or [Arc/Halfwidth/Length/Undo/Width]:

   **Specify next point (2)**

   Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]:

   **Enter A, press ENTER**
Specify endpoint of arc or [Angle/CEnter/Close/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width]: Specify next point (3)

Specify endpoint of arc or [Angle/CEnter/Close/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width]: Enter L, press ENTER

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]:

Specify next point (4)

Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: Enter A, press ENTER

Specify endpoint of arc or [Angle/CEnter/Close/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width]: Specify next point (5)

Specify endpoint of arc or [Angle/CEnter/Close/Direction/Halfwidth/Line/Radius/Second pt/Undo/Width]: Enter CL, press ENTER

Now, erase the C-Lines. You can erase all C-lines by calling one command.

3 Erase all C-Lines.

Ribbon

Home tab ➤ Draw Tools panel ➤ Erase Construction Lines drop-down ➤ All.

Menu

Modify ➤ Erase ➤ Erase all Construction Lines

Command

AMERASEALLCL

NOTE You can switch construction lines on and off temporarily by choosing Assist ➤ Layer/Layergroup ➤ Construction Line On/Off.
4 Apply a fillet to the corner of the triangle.

Ribbon

Home tab ➤ Modify panel ➤ Fillet.

Menu Modify ➤ Fillet

Command AMFILLET2D

5 Respond to the prompts as follows:

(Dimension mode:OFF) (Trim mode) Current fillet radius = 2.5
Select first object or [Polyline/Setup/Dimension] <Setup>:
Press ENTER. The Fillet dialog box is displayed.

6 In the Fillet size list, select 1.

7 Select the Trim Geometry check box:

Click OK.

8 Respond to the prompts as follows:

(Dimension mode:OFF) (Trim mode) Current fillet radius = 1
Select first object or [Polyline/Setup/Dimension] <Setup>:
Enter P, press ENTER
Select polyline: Select a point on the polyline near the corner
9 Press ESC to cancel the command.
The triangular contour is complete.
Save your file.

**Trimming Projecting Edges on Contours**

Now, you create another part of the contour and trim projecting edges.

**To edit a contour**

1. Activate Power Snap Setting 3 command.
   - **Ribbon** None.
   - **Menu** Object Snap Cursor Menu ➤ Power Snap Settings 1-4 ➤ Power Snap Configuration 3
   - **Tools** ➤ Drafting Settings ➤ Power Snap Configuration 3
   - **Command** AMPSNAP3

   Next, insert the next contour.

2. Start the Line command.
   - **Ribbon**
   - **Menu** Draw ➤ Line
   - **Command** LINE

3. Respond to the prompts as follows:
   - **Specify first point:**
     - *Hold down the SHIFT key, right-click, and choose Intersection from the menu*
_int of: Select line a (1)
and: Select intersection on line b (2)
Specify next point or [Undo]:

Hold down the SHIFT key, right-click, and choose Perpendicular from the menu
per to: Select line e
Specify next point or [Undo]:

Drag the cursor to the right, crossing over line c, and select intersection point
(4)
Specify next point or [Close/Undo]: Press ENTER

Now, trim the projecting edges at the upper edge of the lever.

4 Start the Trim command.
Ribbon
Home tab ➤ Modify panel ➤
Menu Modify ➤ Trim
Command TRIM

5 Respond to the prompts as follows:
Current settings: Projection = UCS, Edge = None
Select cutting edges:
Select Objects: Select cutting edge (1)
Select Objects: Select cutting edge (2)
Select Objects: Press ENTER
Select object to trim or shift-select to extend or
[Project/Edge/Undo]: Select object to trim (3)
Select object to trim or shift-select to extend or [Project/Edge/Undo]: Select object to trim (4)

Select object to trim or shift-select to extend or [Project/Edge/Undo]: Press ENTER

6  Zoom to the extents of the lever.

The contour is complete and looks like this. Save your file.
Applying Hatch Patterns to Contours

There are a number of predefined hatch patterns available in AutoCAD Mechanical. Choose one of the predefined hatching styles, and then specify a point within a contour to apply the hatching.

To apply hatching to a contour

1. Start the Hatch command, using an angle of 45 degrees and 2.5 mm / 0.1 inch spacing.
   - **Ribbon**: Home tab ➤ Draw Tools panel ➤ Hatch drop-down ➤ 45 deg. 2.5 mm/0.1 inch.
   - **Menu**: Draw ➤ Hatch ➤ Hatch 45 deg. 2.5 mm/0.1 inch
   - **Command**: AMHATCH_45_2

2. Respond to the prompt as follows:
   - Select additional boundary or point in area to be hatched or [Select objects]: **Click a point inside the contour (outside the cutouts)**
   - The lever is hatched. It looks like this:

   ![Hatched Lever](image)

Save your file.
Dimensioning Contours

Now, dimension the lever, using the Power Dimensioning command.

To dimension a contour

1. Start the Power Snap Setting 1 command.
   - **Ribbon**: None.
   - **Menu**: Object Snap Cursor Menu ➤ Power Snap Settings 1-4 ➤ Power Snap Configuration 1
   - **Tools ➤ Drafting Settings ➤ Power Snap Configuration 1
   - **Command**: AMPSNAP1

2. Start the Power Dimensioning command.
   - **Ribbon**
     - Home tab ➤ Dimension panel ➤ Power Dimension.
     - Annotate tab ➤ Dimension panel ➤ Power Dimension.
   - **Menu**: Annotate ➤ Power Dimensioning
   - **Command**: AMPOWERSDIM

3. Respond to the prompts as follows:
   - Specify first extension line origin or [Linear/Angular/Radial/Baseline/Chain/Options/Update] <select object>:
     - *Select the first corner point of the lever opening (1)*
   - Specify second extension line origin:
     - *Select the second corner point (2)*
   - Specify dimension line location or [Horizontal/Vertical/Aligned/Rotated/Placement options]:
     - *Drag the dimension line to the left until it is highlighted in red, click (3)*
4 In the Power Dimensioning dialog box, click the Add Tolerance button and specify:

- Deviation: Upper: 0.1
- Deviation: Lower: 0
- Precision: Primary: 1

Click OK.

5 Press ENTER twice to finish the command.

The lever looks like this:
Creating and Dimensioning Detail Views

Now, define a detail of the upper part of the lever.

To create a detail

1. Start the Detail command.
   - **Ribbon**: Home tab ➤ Draw Tools panel ➤ Detail View.
   - **Menu**: Draw ➤ Detail...
   - **Command**: AMDETAIL

2. Respond to the prompts as follows:
   - Center of circle or [Rectangle/Object]:
     *Click a point in the center of the area to be detailed (1)*
   - Specify radius or [Diameter]:
     *Drag the radius to the appropriate size, click (2)*

Save your file.
3 In the Detail dialog box, specify:

Detail View: Detail in Current Space

![Detail dialog box image]

4 Click OK, and respond to the prompts as follows:

Place the detail view: Select a location to the right of the lever

**NOTE** Some entities such as dimensions and symbols are automatically filtered out in the detail function.
Now, add a dimension to the detail.

5 Start the Power Dimensioning command.
   - **Ribbon**: Home tab ➤ Dimension panel ➤ Power Dimension.
   - **Annotate tab**: Dimension panel ➤ Power Dimension.
   - **Menu**: Annotate ➤ Power Dimensioning
   - **Command**: AMPOWERDIM

6 Respond to the prompts as follows:

   Specify first extension line origin or
   [Linear/Angular/Radial/Baseline/Chain/Options/Update] <select object>: Press ENTER

   Select arc, line, circle or dimension: *Select the radius (1)*
7 Select an appropriate position for the dimension.

8 In the Power Dimensioning dialog box, click the tolerances button to deactivate the tolerances.

Click OK.

9 Press ENTER twice to finish the command.

Now, your lever looks like this:
The Power Dimensioning command recognizes the different scale area. If you dimensioned the radius in the original drawing, the dimension value would be the same. The text height is also the same, as per the selected drafting standard.

This is the end of this tutorial chapter.

Save your file.
In this tutorial, you work with layouts in AutoCAD® Mechanical, to create scale areas, viewports, and detail views in model space. You learn how to freeze objects in viewports without affecting the model and other layouts.

### Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>base layer</td>
<td>A layer made up of working layers and standard parts layers. Base layers are repeated in every layer group.</td>
</tr>
<tr>
<td>detail</td>
<td>Enlargement of a portion of the design drawing that cannot be clearly displayed or dimensioned. The overall representation (surface texture symbols, etc.) can be enlarged.</td>
</tr>
<tr>
<td>drawing</td>
<td>A layout of drawing views in model space or layout.</td>
</tr>
<tr>
<td>layer group</td>
<td>A group of associated or related items in a drawing. A major advantage of working with layer groups is that you can deactivate a specific layer group and a complete component. The drawing and its overview are enhanced by reduction in regeneration time.</td>
</tr>
<tr>
<td>layout</td>
<td>The tabbed environment in which you create and design floating viewports to be plotted. Multiple layouts can be created for each drawing.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Power Dimensioning</td>
<td>A command useful for generating linear, radial, and diameter dimensions, which minimizes the number of the individual actions while generating a dimension. Power Dimensioning automatically selects the type of the linear dimension (horizontal, vertical, aligned), based on the selected point.</td>
</tr>
</tbody>
</table>

**scale area**
Defines the scale for an area of the drawing.

**scale monitor**
A function to view and control the scale for any scale area.

**viewport**
A scaled view of the model defined in a layout.

**view scale**
The scale of a base drawing relative to the model scale. Also, the scale of dependent views relative to the base view.

**working layer**
The layer where you are currently working.

---

**Working with Model Space and Layouts**

Using model space and layouts, you can create different views with different scales from the same model. The main advantage of working with layouts is that views are associative. If you make changes in one viewport, those changes are made in all other viewports as well, since each viewport is another view of the same model. You can also freeze objects in a new viewport without affecting objects in other views.

**Getting Started**

In this tutorial, you work with viewports. You generate an associative detail and create a subassembly drawing.

**To open a file**

- Open the file *tut_engine.dwg* in the tutorials folder.

Ribbon

- Open ➤ Drawing

Menu

- File ➤ Open

---

126 Chapter 6 Working with Model Space and Layouts
NOTE The path to the folder containing tutorial files is:

- **Windows Vista**: C:\Users\Public\Public Documents\Autodesk\ACADM 2010\Acadm\Tutorial
- **Windows XP**: C:\Documents and Settings\All Users\Shared Documents\Autodesk\ACADM 2010\Acadm\Tutorial

The drawing contains parts of a four-stroke engine. Save your file under a different name or to a different directory to preserve the original tutorial file.

**Creating Scale Areas**

To generate correct views with correct zoom factors in a layout, you must define a scale area in model space.

Create the scale area.

**To create a scale area**

1. Start the Viewport/Scale Area command.
   - **Ribbon** View tab ➤ Viewports panel ➤ Viewport/Scale Area.
   - **Menu** View ➤ Viewports ➤ Viewport/Scale Area
   - **Command** AMSCAREA

2. Respond to the prompts as follows:
   - Define the border....
   - Specify first point or [Circle/Object]: Specify the first corner point
     (1)
   - Specify second point: Specify the second corner point (2)
3 In the Scale Area dialog box, specify:

**Scale: 1:1**

Click OK.

Since you now have a defined scale area, you can automatically create a viewport.
To create a viewport automatically

1. Start the Viewport Auto Create command.
   - **Ribbon**: None.
   - **Menu**: View ➤ Viewports ➤ Viewport Auto Create
   - **Command**: AMVPORTAUTO

2. Respond to the prompts as follows:
   - **Enter layout name** (<Return> for “Layout1”): Press ENTER
   - **Select target position** (<Return> for current position):
     - Place the viewport on the left, inside the drawing border

Save your file.

Creating Detail Views

There are two types of detail views; associative and non associative. In this exercise, you create an associative detail, because you use a viewport.

Create an associative detail of the valve.

To create a detail

1. Start the Detail command.
Ribbon
Home tab ➤ Draw Tools panel ➤ Detail View.

Menu
Draw ➤ Detail...

Command
AMDETAIL

The viewport is activated automatically.

2 Respond to the prompts as follows:
Define the enlargement area for the detail ...
Center of circle or [Rectangle/Object]: Select the center of the detail (3)
Specify radius or [Diameter]: Drag the radius to the desired size (4)

3 In the Detail dialog box, specify the settings shown in the illustration.

Click OK.

4 Respond to the prompt as follows:
Select target position (<Return> for current position):
Place the detail to the right of the current viewport
Generating New Viewports

Now, you create a viewport inside a layout.

To create a viewport in the layout

1. Start the Viewport/Scale Area command.
   - Ribbon: None.
   - Menu: None.
   - Command: AMVPORT

2. Respond to the prompts as follows:
   - Specify first point or [Circle/Border/Object]:
     Select point 5 in the drawing
   - Specify second point: Select point 6 in the drawing

3. In the View dialog box, specify:
   - Scale: 5:1
   - Choose Midpoint.

Save your file.
The drawing is changed to model space so that you can define the midpoint.

4 Respond to the prompt:

   Select view center: Select the endpoint of the centerline

5 In the View dialog box, Click OK.
   Your drawing looks like this:
Save your file.

Inserting Holes Within Viewports

To demonstrate the main advantage of working with layouts, insert a hole in the housing. When you make this change, it is immediately displayed in every view.

Insert a user through hole in the previously created viewport.

**To insert a through hole**

1. Activate the previously created viewport.
   - **Ribbon**: None
   - **Menu**: None
   - **Command**: MSPACE
   
   The viewport has a thick (highlighted) frame.

2. Start the Through Hole command.
In the Select a Through Hole dialog box, scroll to and select User Through Holes, and then click Front View.

4 Respond to the prompts as follows:

Specify insertion point:

*Hold down the `SHIFT` key and right-click, and then choose Midpoint*

5 Specify insertion point: _mid of Select the midpoint of the housing (1)_

Specify hole length: Select the endpoint of the hole (2)
In the User Through Holes - Nominal Diameter dialog box, specify:

Nominal Diameter: 8

Choose Finish.

The user through hole is inserted into your drawing.

The drawing looks like this:
Because of the associativity, the through hole created in the viewport also appears in the original view.

In the next step, you dimension the through hole diameter in the viewport. Since the dimension is to appear only in the detail view, you generate the dimension directly in the layout without having a viewport active.

**To apply a dimension in the layout**

1. Change to the layout.
   - **Ribbon**
     - None ➤ None ➤
   - **Menu**
     - Does not exist in the Menu.
   - **Command**
     - PSPACE

2. Start the Power Dimensioning command.
   - **Ribbon**
     - Home tab ➤ Dimension panel ➤ Power Dimension.
     - Annotate tab ➤ Dimension panel ➤ Power Dimension.
   - **Menu**
     - Annotate ➤ Power Dimensioning
   - **Command**
     - AMPOWERDIM

3. Respond to the prompts as follows:
Specify first extension line origin or [Linear/Angular/Radial/Baseline/Chain/Options/Update] <select object>:

Select the first edge of the hole (1)

Specify second extension line origin:

Select the second edge of the hole (2)

Specify dimension line location or [Horizontal/Vertical/Aligned/Rotated/Placement options]:

Drag the dimension line toward point 3 until it turns red, and then click

4 In the Power Dimensioning dialog box, Click OK.

5 Continue to respond to the prompts as follows:

Specify first extension line origin or [Linear/Angular/Radial/Baseline/Chain/Options/Update] <select object>: Press ENTER

Select arc, line, circle or dimension: Press ENTER

The viewport looks like this:
NOTE You can also dimension the hole in model space and turn off the layer of one specific viewport. In that case, the dimension text is correct only in the 1:1 viewport, and not in the detail view. Therefore, it is best that you dimension directly on the layout.

Save your file.

Creating Subassemblies in New Layouts

If you use layer groups in your assembly drawing, you can create detail and subassembly drawings in layouts. You can switch off selected layer groups in a viewport so that only the detail or subassembly is visible.

Before you create a subassembly in a new layout, freeze the model and other views. Then when you create a new viewport in Layout 2, only the specified subassembly is displayed, and objects are not hidden in the model and other views.

To freeze the model and other layouts

1  Select the Layout 2 tab on the bottom of your drawing area. Layout 2 is displayed.

2  Start the Layer Group Control.
   Ribbon                 None.
   Menu                   Tools ➤ Layergroup ➤ Layergroup Manager
   Command                AMLAYER
3 In the Layergroup Manager, Layergroups list, click the icon in the Base Layer Group row, New VP Freeze column to freeze it.

![Layergroup Manager](image)

Click OK.

Create an associative view of a subassembly in layout 2.

**To create an associative view of a subassembly**

1 Select the Layout 2 tab on the bottom of your drawing area. Layout 2 is displayed.

2 Start the Viewport/Scale Area command.
   - **Ribbon** None.
   - **Menu** None.
   - **Command** AMVPORT

3 Respond to the prompts as follows:
   - **Specify first point or [Circle/Border/Object]:**
   - **Select point 7 in the drawing**
   - Specify second point: **Select point 8 in the drawing**

4 In the View dialog box, specify:
   - **Scale:** 5:1
Choose Midpoint.

![View dialog box]

The drawing is changed to model space.

5 Specify the point, as shown in the following drawing:

![Diagram showing specified point]

6 In the View dialog box, Click OK.
   In the new viewport, only the subassembly you specified is visible.
   AutoCAD Mechanical freezes the Base Layer Group.
   Your drawing looks like this:
Finish your detail drawing with text, remarks, annotations, and so on.

**NOTE** When you plot the drawing, the red viewport frame is turned off automatically. If you have a plotter or printer driver installed, use the plot command, and preview the drawing.

This is the end of this tutorial chapter.

Save your file.
Dimensioning

In this tutorial, you learn how to add dimensions to your drawing with the automatic dimensioning in AutoCAD® Mechanical, change the dimensions with Power Commands, and insert a drawing border.

Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>baseline dimension</td>
<td>A dimension that is aligned to extension lines and read from the bottom or right side of the drawing.</td>
</tr>
<tr>
<td>centerline</td>
<td>Line in the center of a symmetrical object.</td>
</tr>
<tr>
<td>drawing border</td>
<td>A standardized frame that is used for technical drawings.</td>
</tr>
<tr>
<td>fit</td>
<td>Range of tightness or looseness in mating parts (for example shafts or holes). Tolerances in these dimensions are expressed in standard form.</td>
</tr>
<tr>
<td>fit name</td>
<td>Name of the selected fit (for example, H7).</td>
</tr>
<tr>
<td>multi edit</td>
<td>An option where you determine a selection set of dimensions and edit them together.</td>
</tr>
</tbody>
</table>

Power Dimensioning

Power Dimensioning is a tool for generating linear, radial, angular, and diameter dimensions, which minimizes the number of the individual actions required while generating a dimension. Power Dimensioning selects the type of linear dimension (horizontal, vertical, or aligned), based on the selected point, and
<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power Erase</td>
<td>Command for deleting. Use Power Erase when you delete part reference numbers or dimensions that were created with Power Dimensioning and Automatic Dimensioning.</td>
</tr>
<tr>
<td>title block</td>
<td>A title block contains a series of attributes. Some already have values. The pre-assigned values can be modified, and the vacant attributes can be completed with new values.</td>
</tr>
<tr>
<td>tolerance</td>
<td>The total amount by which a given dimension (nominal size) may vary (for example, 20 ± 0.1).</td>
</tr>
</tbody>
</table>

### Adding Dimensions to Drawings

AutoCAD Mechanical offers various dimensioning tools. Use automatic dimensioning to add dimensions to a bushing, and then change these dimensions.

**To open a file**

- Open the file `tut_bushing.dwg` in the tutorials folder.

**Ribbon**

![Open Ribbon Icon]

**Menu**

File ➤ Open...

**Command**

OPEN

**NOTE** The path to the folder containing tutorial files is:

- **Windows Vista®**: C:\Users\Public\Public Documents\Autodesk\ACADM 2010\Acadm\Tutorial
- **Windows® XP**: C:\Documents and Settings\All Users\Shared Documents\Autodesk\ACADM 2010\Acadm\Tutorial

The file contains a drawing of a bushing.
Adding Multiple Dimensions Simultaneously

Dimension the bushing using automatic dimensioning.

To dimension a contour

1. Start the Automatic Dimensioning command.
   
   **Ribbon**
   Home tab ➤ Dimension panel ➤ Power Dimension drop-down ➤ Multiple Dimension.
   Annotate tab ➤ Dimension panel ➤ Multiple Dimension.

   **Menu**
   Annotate ➤ Multiple Dimensioning

   **Command**
   AMAUTODIM

2. In the Automatic Dimensioning dialog box, Parallel tab, specify:
   
   **Type**: Baseline

Save your file under a different name or to a different directory to preserve the original tutorial file.
Click OK.

3 Respond to the prompts as follows:

Select objects [Block]:

Select the complete bushing by creating a window around it

Select objects [Block]: Press ENTER

First extension line origin:

Select the lower left most corner of the bushing (1)

Specify dimension line location or
[Horizontal/Vertical/Rotated/Placement options]:

Drag the dimensioning downwards until it snaps in (highlighted red), and then click
To dimension a shaft

1. Start the Automatic Dimensioning command.
   - **Ribbon**: Home tab ➤ Dimension panel ➤ Power Dimension drop-down ➤ Multiple Dimension.
   - **Annotate tab**: Dimension panel ➤ Multiple Dimensioning.
   - **Menu**: Annotate ➤ Multiple Dimensioning
   - **Command**: AMAUTODIM

2. In the Automatic Dimensioning dialog box, Shaft/Symmetric tab, specify:
   - Type: Shaft (Front View)
   - Click OK.
3 Respond to the prompts as follows:

Select objects [Block]:

Select the complete bushing by creating a window around it

Select objects [Block]: Press ENTER

Select Centerline or new starting point:

Select the centerline of the bushing (1)

Specify dimension line location or [Placement options]:

Drag the dimensioning to the right until it snaps in (highlighted red), and then click

4 Continue responding to the prompt:

Starting point for next extension line:
Press ENTER to end the command

Your drawing looks like this.

Save your file.

**Editing Dimensions with Power Commands**

Some dimensions in the drawing are not necessary. In the next step, you delete the dimensions that you don't need.

**To delete dimensions**

1. Start the Power Erase command.
   - **Ribbon:**
     - Home tab ➤ Modify panel ➤ Erase.
   - **Menu:** Modify ➤ Power Erase
   - **Command:** AMPOWERERASE

2. Respond to the prompt as follows:

   Select baseline dimensions 2 and 61, and diameter dimensions 12, 14, and 36, press ENTER

   The dimensions are deleted, and the remaining dimensions are rearranged. Your drawing looks like this:
Add a single dimension with a fit using Power Dimensioning.

**To add a dimension with a fit**

1. Start the Power Dimensioning command.
   - **Ribbon**
     - Home tab ➤ Dimension panel ➤ Power Dimension.
   - Annotate tab ➤ Dimension panel ➤ Power Dimension.
   - **Menu**
     - Annotate ➤ Power Dimensioning
   - **Command**
     - AMPOWERDIM

2. Respond to the prompts as follows:
   - Specify first extension line origin or [Linear/Angular/Radial/Baseline/Chain/Options/Update] <select object>:
     - Select the first point (1)
   - Specify second extension line origin: Select second point (2)
   - Specify dimension line location or [Horizontal/Vertical/Aligned/Rotated/Placement options] :
     - Drag the dimensioning to the left until it is highlighted red, and then click
3 In the Power Dimensioning dialog box, click \( H^7 \), and then specify:
   - **Fit:** Symbol: \( H^7 \)

4 Under Text, click \( \varnothing \), and then select the diameter symbol (upper left).

![Power Dimensioning dialog box](image)

Click OK.

Apply angular dimensioning.

**To apply an angular dimension**

1 Respond to the prompts as follows:
   - Specify first extension line origin or [Linear/Angular/Radial/Baseline/Chain/Options/Update] <select object>:
   - Enter **A**, press ENTER
186x657 (Single) Select arc, circle, line or [Baseline/Chain/eXit] <specify vertex>:

Select the line (1)
Select second line: Select the second line (2)
Specify dimension arc line location:

Drag the dimension to a suitable position, and then click

2 Press ENTER twice to finish the command.
Add a fit to the shaft dimensions using Multi Edit.

To add a fit using Multi Edit

1 Start the Multi Edit command.
   Ribbon Annotate tab ➤ Dimension panel drop-down ➤ Multi Edit
   Menu Annotate ➤ Edit Dimensions ➤ Multi Edit
   Command AMDIMMEDIT

2 Respond to the prompts as follows:
   Select dimensions: Select the dimensions 18 and 30
   Select dimensions: Press ENTER

3 In the Power Dimensioning dialog box, choose the Add Fit button
   , and then specify:
   Fit: Symbol: h7
Click OK.
The fit description h7 is added to the dimensions.
Save your file.

**Breaking Dimension Lines**

The automatic dimensioning process created intersecting dimension lines. The drawing appearance can be improved by breaking these lines.

**To break dimension lines**

1. Start the Break Dimension command.
   - **Ribbon**: Annotate tab ➤ Dimension panel drop-down ➤ Break Dimension.
   - **Menu**: Annotate ➤ Edit Dimensions ➤ Break Dimension
   - **Command**: AMDIMBREAK

2. Respond to the prompt as follows:

   **Press ENTER**

   Select dimensions:

   *Select baseline dimension 10 and 13, and diameter dimensions 18, 30, and 40, press ENTER*
Select Objects [Restore] <Automatic>: Press ENTER

The selected dimensions are broken automatically and your drawing looks like this:

Save your file.

**Inserting Drawing Borders**

Insert a drawing border.

**To insert a drawing border**

1. Start the Drawing Title/Borders command.
   - **Ribbon**: Annotate tab ➤ Layout panel ➤ Title Border.
   - **Menu**: Annotate ➤ Drawing Title and Revision ➤ Drawing Title/Borders...
   - **Command**: AMTITLE

2. In the Drawing Borders with Title Block dialog box, specify:
   - **Paper Format**: A4 (297x210mm)
   - **Title Block**: ISO Title Block A
   - **Scale**: 1:1
Click OK.

3 Respond to the prompt as follows:
   Specify insertion point: Enter -150,0, press ENTER

4 In the Change Title Block Entry dialog box, specify:
   Drawing Title: Bushing

Click OK.

5 Respond to the prompts as follows:
Select Objects: Select the complete bushing including dimensions
Select Objects: Press ENTER
New location for objects: Click View ➤ Zoom ➤ Extents.

Place the bushing in the middle of the drawing border
Your drawing looks like this:

Save your file.

Inserting Fits Lists

Insert a fits list. Fits lists describe all fits existing in a drawing.

To insert a fits list

1. Start the Fits List command.
Ribbon

Annotate tab ➤ Table panel ➤ Fits List.

Menu
Annotate ➤ Fits List

Command
AMFITSLIST

2 Respond to the prompts as follows:

Fits lists [Update all/Order/New] <New>: Press ENTER

Specify insertion point: Specify the upper right corner of the title block

The fits list is inserted above the title block, and looks like this.

<table>
<thead>
<tr>
<th>ø3 1</th>
<th>h7</th>
<th>f</th>
<th>11 l12</th>
<th>31.46</th>
<th>1.120</th>
</tr>
</thead>
<tbody>
<tr>
<td>ø18</td>
<td>h7</td>
<td>f</td>
<td>11 l118</td>
<td>46.039</td>
<td>1.920</td>
</tr>
<tr>
<td>ø12</td>
<td>H7</td>
<td>f</td>
<td>11 l110</td>
<td>61.25</td>
<td>1.52</td>
</tr>
</tbody>
</table>

Edit a dimension with a fit. The fits list is updated.

To edit a dimension

1 In the drawing, double-click the diameter dimension (not the dimension line) 18 h7.

2 In the Power Dimensioning dialog box, specify:

Fit symbol: g6
Click OK.

3 In the AutoCAD Question dialog box, choose Yes.

The fits list is updated, too. Save your file.
This is the end of this tutorial chapter.
Working with 2D Hide and 2D Steel Shapes

In this tutorial, you learn how to work with 2D steel shapes. The features in AutoCAD® Mechanical for defining 2D hide situations have already been covered in Basics of AMSHIDE on page 95. However, the tutorial is intended for new users who may have to work with AM2DHIDE supported legacy drawings.

Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>background</td>
<td>A contour that is covered by another contour or by objects that are</td>
</tr>
<tr>
<td></td>
<td>lying behind another contour, in the 3D sense. A background may be</td>
</tr>
<tr>
<td></td>
<td>a foreground for an additional contour.</td>
</tr>
<tr>
<td>foreground</td>
<td>Objects which are lying in front of another contour, in the 3D sense.</td>
</tr>
<tr>
<td></td>
<td>A foreground may also be a background for an additional contour.</td>
</tr>
<tr>
<td>hidden line</td>
<td>Line that is not visible in a specified view. For example, in a front view,</td>
</tr>
<tr>
<td></td>
<td>lines behind the front plane are not visible.</td>
</tr>
<tr>
<td>steel shapes</td>
<td>Steel shapes are standardized steel geometries and profiles that are</td>
</tr>
<tr>
<td></td>
<td>used for steel and plant construction.</td>
</tr>
</tbody>
</table>
1. Open the file `Tut_Gripper_Plate.dwg` in the tutorials folder.

   - **Ribbon**: None.
   - **Menu**: File ➤ Open...
   - **Command**: OPEN

   **NOTE** The path to the tutorials folder is:
   - **Windows Vista**: \Users\Public\Public Documents\Autodesk\ACADM 2010\Acadm\Tutorial
   - **Windows XP**: \Documents and Settings\All Users\Shared Documents\Autodesk\ACADM 2010\Acadm\Tutorial

   The drawing contains two views of a gripper plate and contains two construction lines.

2. To keep the original file intact, save the file as `Gripper.dwg`.

3. Display the Structure Catalog.

   - **Ribbon**: None.
   - **Menu**: Tools ➤ Palettes ➤ Structure Catalog
   - **Command**: AMSCATALOG

4. In the External Drawings tab, navigate to the tutorials folder and select `Tut_Gripper.dwg`.

   **NOTE** In the Structure Catalog, navigate to the following folders:
   - **Windows Vista**: \Users\Public\Documents\Autodesk\ACADM 2010\Acadm\Tutorial
   - **Windows XP**: \Documents and Settings\All Users\Documents\Autodesk\ACADM 2010\Acadm\Tutorial

   The Mechanical Structure panel shows the mechanical structure components in the drawing and the Preview panel shows a preview of the drawing.

5. In the structure panel, double click GRIPPER to reveal the components list.

6. Click and drag GRIPPER ➤ Front to model space.
Defining 2D Hide Situations

Define a 2D hide situation. You can define foreground and background contours and the settings for the representation of the hidden objects.

To define a 2D hide situation

1. Start the Hide Invisible Edges command.
   - Ribbon: None.
   - Menu: Modify ➤ 2D Hide ➤ Hide Invisible Edges
   - Command: AM2DHIDE

2. Respond to the prompts as follows:
   - Select objects for foreground: Select the chain
   - Select objects for foreground: Press ENTER

3. In the Create Hide Situation dialog box, Background tab, specify:
   - Representation of Hidden Objects: Dashed
   - Choose Preview.
NOTE As you can see, the parts of the sprockets that should be visible appear as hidden lines. This shows that the complete area inside the outer chain contour is defined as foreground.

Define the 2D hide situation in a way that the chain has an inner contour.

4 Respond to the prompt as follows:
   Accept preview and exit command [Yes/No] <Yes>:
   Enter N, press ENTER

5 In the Create Hide Situation dialog box, Foreground tab, click Select Inner Contours.
6 Respond to the prompt as follows:
Select point inside a hole or select a loop to remove:
Select a point inside the chain (1)
The inner contour of the chain is displayed green.

7 Respond to the prompt as follows:
Select point inside a hole or select a loop to remove: Press ESC

8 In the Create Hide Situation dialog, choose Preview.
The sprocket is no longer displayed as a hidden line and the chain drive is displayed correctly.
9  Respond to the prompt as follows:

Accept preview and exit command [Yes/No] <Yes>: Press ENTER

The 2D hide situation is defined correctly, and you can proceed with your drawing.

Save your file under a different name or to a different directory to preserve the original tutorial file.

**Inserting 2D Steel Shapes**

Steel Shapes can easily be inserted through a selection dialog box, where you can define the standard, profile, size, and length of the steel shape.

Insert a steel shape with a square hollow section on the left edge of the I-shaped girder.

**To insert a 2D steel shape**

1  Start the Zoom All command.

Ribbon  View tab ➤ Navigate panel ➤ Zoom drop-down

➤ Window.

Menu  View ➤ Zoom ➤ Window
Command ZOOM

2 Start the Steel Shape command.
   Ribbon
      Content tab ➤ Misc panel ➤ Steel Shapes.
   Menu
      Content ➤ Steel Shapes...
   Command AMSTLSHAP2D

3 In the Select a Steel Shape dialog box, select Steel Shapes ➤ Square/Rectangular Hollow Section, and then select ISO 657/14-1982 (Rectangular) and Top View.

4 Respond to the prompts as follows:
   Specify insertion point: Select point P1
   Specify rotation angle <0>: Press ENTER

5 In the ISO 657/14 - 1982 (Rectangular) - Size Selection dialog box, specify:
   Select a Size: 90x90x4.0

Inserting 2D Steel Shapes | 165
Choose Finish.

6 Respond to the prompt as follows:

Drag Size: Select point P2

The steel shape is inserted. Your drawing looks like this:

Save the file.

Modify the steel shapes using the Power Commands.
Modifying Steel Shapes Using Power Commands

With the Power Commands, you can create different views of the steel shapes. You can copy, multiply, or edit the steel shapes.

Insert the steel shapes in the top view of the assembly using Power View and Power Copy.

To modify a steel shape using a Power Command

1. Start the Power View command.
   - Ribbon: None.
   - Menu: Modify ➤ Power View
   - Command: AMPOWERVIEW

2. Select the previously inserted steel shape.

3. In the Select new view dialog box, select the Front View.

4. Respond to the prompts as follows:
   - Specify insertion point: Select point P3
   - Specify rotation angle <0>: 0, press ENTER

   The steel shape is inserted in the top view of the assembly. Your drawing looks like this:

   Copy the previously inserted view to the other edge of the girder.

5. Start the Power Copy command.
   - Ribbon: Home tab ➤ Modify panel ➤ Copy.
Content Edit tab ➤ Modify panel ➤ Power Copy.

Menu
Default Menu ➤ Power Copy
Edit Menu ➤ Power Copy
Modify ➤ Power Copy

Command
AMPOWERCOPY

6 Respond to the prompts as follows:
Select object: Select the previously inserted steel shape at point P3
Enter an option [Next/Accept]<Accept>: Press ENTER
Specify insertion point: Select point P4
Specify rotation angle <0>: Press ENTER
The steel shape is copied. Your drawing looks like this:

Save your file.

Editing 2D Hide Situations

The insertion of the steel shapes in the top view of the assembly created a 2D hide situation automatically. This 2D hide situation is not correct. Use the command AM2DHIDEDIT when mechanical structure is disabled.

Edit the 2D hide situation.

To edit a 2D hide situation

1 Start the Edit Hidden Edges command.
Ribbon None.
Menu Modify ➤ 2D Hide ➤ Edit Hidden Edges
Command AM2DHIDEDIT

2 Respond to the prompts as follows:
Edit the behind situation [modify/Move/Restore/Genius12]

<Update>: Enter Y, press ENTER

Select objects: Select the square hollow section on the left
Select objects: Press ENTER

3 In the Modify Hide Situation dialog box, Foreground tab, choose Select View.

![Modify Hide Situation dialog box](image)

4 Respond to the prompts as follows:

Select objects for foreground: Select the I-shaped girder

Select objects for foreground: Press SHIFT while you click the square hollow section on the left to deselect it
Select objects for foreground: Press ENTER

5 In the Modify Hide Situation dialog box, Background tab, choose Select View.
6 Respond to the prompts as follows:
   Select objects for background:
   Select the square hollow section on the left
   Select objects for background:
   Select the square hollow section on the right
   Select objects for background: Press ENTER

7 In the Modify Hide Situation dialog box, click Preview.
   Your drawing looks like this:

8 Respond to the prompts:
   Accept preview and exit command [Yes/No] <Yes>: Press ENTER
   Edit the behind situation [modify/Move/Restore/Genius12] <Update>: Press ENTER
   Select objects: Press ENTER
   The 2D hide situation is corrected.

Save your file.
Copying and Moving 2D Hide Situations

If you copy or move assemblies that contain 2D hide situations, the 2D hide information is not lost.

Copy the girder assembly.

To copy a 2D hide situation

1. Select the I-shaped girder and the two square hollow sections.
2. Right-click the graphics area background, and then choose Copy with Base Point.
   Respond to the prompt as follows:
   Specify base point: Select point P3
3. Right-click, and then choose Paste.
   Respond to the prompt as follows:
   Specify insertion point: Select point P5

The girder assembly is copied to the new location. Your drawing looks like this.

Save your file.

Move the chain drive from the beginning of the chapter to the top view of the assembly.
To move a 2D hide situation

1. Start the Move command.
   - **Ribbon**
     
     Home tab ➤ Modify panel ➤ Move.
     
     Content Edit tab ➤ Modify panel ➤ Move.
   
   - **Menu**
     
     Edit Menu ➤ Move
     
     Modify ➤ Move
   
   - **Command**
     
     MOVE

2. Respond to the prompts as follows:
   
   Select objects: *Select the complete chain drive using a window*
   
   Select objects: *Press ENTER*
   
   Specify base point or displacement: *Select point P6*
   
   Specify second point of displacement or <use first point as displacement>: *Select point P7*

   The complete chain drive is moved to the top view of the assembly. Your drawing looks like this:

   Define the 2D hide situation for the girder assembly and the chain drive.
To define a 2D hide situation

1. Start the Hide Invisible Edges command.
   - **Ribbon**: None.
   - **Menu**: Modify ➤ 2D Hide ➤ Hide Invisible Edges
   - **Command**: AM2DHIDE

2. Respond to the prompts as follows:
   - Select objects for foreground: Select the complete chain drive
   - Select objects for foreground: Press ENTER

3. In the Create Hide Situation dialog box, Click OK.

![Create Hide Situation dialog box](image)

Now, the girder assembly is hidden by the chain drive. Your drawing looks like this:
Save your file. This is the end of this exercise.
In this tutorial, you learn to work with standard parts in AutoCAD® Mechanical. You insert a screw connection, a hole, and a pin. You also edit the standard parts with power commands.

### Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>background</td>
<td>A contour that is covered by another contour or by objects that are lying behind another contour, in the 3D sense. A background may be a foreground for an additional contour.</td>
</tr>
<tr>
<td>C-line (construction line)</td>
<td>A line that is infinite in both directions or infinite starting at a point which can be inserted into the drawing area. You use C-lines to transfer important points (for example, center points of holes) into other views or drawing areas.</td>
</tr>
<tr>
<td>countersink</td>
<td>A chamfered hole that allows bolt and screw heads to be flush or below the part surface.</td>
</tr>
<tr>
<td>dynamic dragging</td>
<td>The act of determining the size of a standard part with the cursor while inserting it into a side view. The standard part is displayed dynamically on the screen and can be dragged to the next possible size or length. The values (sizes) are taken from the Standard parts database.</td>
</tr>
</tbody>
</table>
### Definition Term

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power Copy</td>
<td>A command that copies a drawing object to another position in the drawing. Power Copy produces an identical copy of the original object.</td>
</tr>
<tr>
<td>Power Edit</td>
<td>An edit command for all objects in your drawing.</td>
</tr>
<tr>
<td>Power Erase</td>
<td>A command for intelligent deleting. Use Power Erase when you delete part reference numbers or when you delete dimensions that have been created with Power Dimensioning and Automatic Dimensioning.</td>
</tr>
<tr>
<td>Power Recall</td>
<td>A command that lets you click an existing drawing object and places you in the correct command for creating that object.</td>
</tr>
<tr>
<td>Power View</td>
<td>A command where you can quickly and easily create a standard part top view or bottom view of a side view and vice versa.</td>
</tr>
<tr>
<td>Representation</td>
<td>Standard parts representation in a drawing in normal, simplified, or symbolic mode.</td>
</tr>
</tbody>
</table>

---

### Working with Standard Parts

AutoCAD Mechanical provides a large selection of standard parts to work with, including regular and fine threads, many types of holes, fasteners, and other standard parts. You can insert complete screw connections (screws with holes and nuts) in one step. Some intelligence is built into this process. For example, if you select a screw with a metric thread, you get only metric threads when you add any additional parts such as tapped holes or nuts.

**NOTE** It is required that the ISO standard parts be installed for this tutorial exercise.

Open the initial drawing.

**To open a drawing**

1. Open the file `tut_std_pts.dwg` in the Tutorial folder.

---

176 | Chapter 9   Working with Standard Parts
NOTE The path to the folder containing tutorial files is:

■ Windows Vista®: C:\Users\Public\Public Documents\Autodesk\ACADM 2010\Acadm\Tutorial

■ Windows®XP: C:\Documents and Settings\All Users\Shared Documents\Autodesk\ACADM 2010\Acadm\Tutorial

The drawing contains a motor with a gearbox. Some construction lines are inserted to help you work through the tutorial exercise. The gearbox is not completed yet. We want to add standard components and show how easy it is to edit standard parts with an automatic update of the background objects.

Before you proceed, you must enable mechanical structure. If you proceed without mechanical structure enabled, some command line prompts will differ from the prompts in the exercise.

2 Zoom in to the area of interest.

Ribbon View tab ➤ Navigate panel ➤ Zoom drop-down

➤ Window.

Menu View ➤ Zoom ➤ Window

Command ZOOM

3 Respond to the prompts as follows:

[All/Center/Dynamic/Extents/Previous/Scale/Window/Object] <real time>: Enter W, press ENTER

Specify first corner: Specify the first corner point (1)

Specify opposite corner: Specify the second corner point (2)
Inserting Screw Connections

Insert a screw connection in the differential gear housing.

To insert a screw connection

1. Start the Screw Connection command.
   
   **Ribbon**
   
   Content tab ➤ Fasteners panel ➤ Screw Connection.
   
   **Menu**
   
   Content ➤ Screw Connection...
   
   **Command**
   
   AMSCREWCON2D

2. In the Screw Connection dialog box, click Screws.

Save your file under a different name or to a different directory to preserve the original tutorial file.
3 In the Select a Screw dialog box, select Socket Head Types.
4 Select ISO 4762 and Front View.
You are returned to the Screw Connection - Front View dialog box.

5 In the Screw Connection - Front View dialog box, click the upper Holes button. Then select Through Cylindrical, and ISO 273 normal.

6 In the Screw Connection - Front View dialog box, click the lower Holes button. Then select Tapped Holes, Blind, and ISO 262 (Regular Thread).

**NOTE** The screw types available and the order depend on the standard selected to be active in AMOPTIONS, AM:Standard Parts.

7 In the Screw Connection dialog box, specify the size M4.
Click Next.

8 Respond to the prompts as follows:

Specify insertion point of first hole: Specify first point (1)

Specify endpoint of first hole [Gap between holes]:

Specify second point (2)
9 In the Screw Assembly Representation - Front View dialog box, click Next.

10 In the Screw Assembly Grip Representation - Front View dialog box, click Finish.
11 Respond to the prompts as follows:

Drag Size:

*Drag the screw connection dynamically to size M4 x 16, and then click*

Drag Size: *Enter 12*, press ENTER

The screw connection is inserted with a specified a screw length of 16 mm and a blind hole depth of 12 mm.

**NOTE** During dragging, the size of the screw is shown as a tooltip and in the status bar, where the coordinates are usually displayed.

The background is automatically hidden, and your drawing looks like this:

![Image of screw connection]

Save your file.

**Copying Screw Connections with Power Copy**

With Power Copy, you can copy complete objects, including the information attached to those objects. In the case of a screw connection, you copy the whole screw connection to another location. The background is automatically updated.

Copy the new screw connection using the Power Copy command.
To copy a screw connection

1. Start the Power Copy command.
   - Ribbon: Home tab ➤ Modify panel ➤ Copy.
   - Content Edit tab ➤ Modify panel ➤ Copy.
   - Menu: Modify ➤ Power Copy
   - Command: AMPOWERCOPY

2. Respond to the prompts as follows:
   - Select object: Select the previously inserted screw
   - Specify insertion point: Specify a point (1)
   - Specify direction: Press ENTER

The screw is copied to the specified location. Your drawing looks like this:
Creating Screw Templates

Create a screw template and store it for repeated use. This makes the insertion of identical or similar screw connections much faster.

Before you create and insert the screw template, zoom to the cover plate.

To zoom to a window

1. Zoom to the extents of the drawing.
   
   | Ribbon | View tab ➤ Navigate panel ➤ Zoom drop-down ➤ Extents. |
   | Menu   | View ➤ Zoom ➤ Extents |
   | Command| ZOOM |

2. Respond to the prompts as follows:
   
   [All/Center/Dynamic/Extents/Previous/Scale/Window/Object] <real time>: Enter E, press ENTER.

3. Zoom in to the coverplate.
4. Respond to the prompts as follows:

[All/Center/Dynamic/Extents/Previous/Scale/Window/Object] <real

Tip>: Enter W, press ENTER

Specify first corner: Specify first corner point (1)

Specify opposite corner: Specify second corner point (2)

Start the screw connection and create a screw template.

To create a screw template

1. Start the Screw Connection command.

Ribbon: Content tab ➤ Fasteners panel ➤ Screw Connection.

Menu: Content ➤ Screw Connection...
Command: AMSCREWCON2D

2. In the Screw Connection dialog box, click the Screws button.

3. In the Select a Screw dialog box, select Countersink Head Type.
4 Select ISO 10642, and Front View.
5 In the Screw Connection - Front View dialog box, click the upper Holes button. Then select Countersinks, and ISO 7721.

6 In the Screw Connection - Front View dialog box, click the lower Holes button. Then select Tapped Holes, Blind, and ISO 262.

7 In the Screw Connection - Front View dialog box, click Back to store the screw template.
8 In the Screw Assembly Templates dialog box, click the Save icon. Your screw connection is stored as a template and is added to the list.

Click Next.
NOTE The screw template contains the combination of the used standard parts. It contains no sizes, like diameters or lengths.

9 In the Screw Connection dialog box, click the Pre-calculation icon.

10 In the Screw Diameter Estimation dialog box, specify:
   - Material Class: 10.9
   - Applied Force: 1500
   - Nature of Load: Static and Centric applied Axial Force (upper-left icon)
   - Method for Tightening Screw: Mechanical Screw Driver
The Result field displays a nominal diameter size of M4. Click OK.

11 In the Screw Connection - Front View dialog box, the pre calculation routine has marked M4.

Click Next.
12 Respond to the prompts as follows:
Specify insertion point of first hole: Specify first point (1)
Specify endpoint of first hole [Gap between holes]:
Specify second point (2)

13 In the Screw Assembly Location - Front View dialog box, click Next.

14 In the Screw Assembly Grip Representation - Front View dialog box, click Finish.

15 Respond to the prompts as follows:
Drag Size:
Drag screw connection dynamically to size M4 x 12, and then click
Drag Size: Enter 8, press ENTER

The screw connection is inserted with a screw length of 12 mm and a blind hole depth of 8 mm.
Your drawing looks like this:
Save your file.

**Editing Screw Connections with Power Edit**

Rather than use different editing commands for different objects, you can use only one command, Power Edit, for editing all objects in a drawing with built-in intelligence. When you use Power Edit on a screw connection, the whole assembly can be edited and is updated in your drawing with an automatic background update.

Change the screw connections to the appropriate length.

**To edit a screw connection that is not yet structured**

1. Start the Power Edit command.
   - **Ribbon**: None.
   - **Menu**: Default Menu ➤ Power Edit
     - Edit Menu ➤ Power Edit
     - Modify ➤ Power Edit
   - **Command**: AMPOWEREDIT

2. Respond to the prompts as follows:
   - **Select object**: *Select the lower screw of the coverplate*
Enter an option [Next/Accept] <Accept>:  Press ENTER

NOTE You can also start Power Edit by double-clicking the desired part.

3. In the Screw Connection New Part Front View - Front View dialog box, click Back.

4. On the Templates page, double-click the ISO 10642 screw template in the list, or select it and click the Load the template icon.

The Screw Connection New Part Front View - Front View dialog box contains the screw connection as it has been stored in the template.

5. Select the size M4, and then click Next.
6 Respond to the prompts as follows:
   Specify insertion point of first hole: Press ENTER
   Specify endpoint of first hole [Gap between holes]: Press ENTER

7 In the Screw Connection New Part Front View - Front View dialog box, Location representation, click Next.

8 In the Screw Connection New Part Front View - Front View dialog box, Grip representation, click Finish.

Drag Size:
   Drag the screw connection dynamically to the size M4 x 12, and then click

Drag Size: Enter 8, press ENTER

The screw connection is edited to a screw length of 12 mm and a blind hole depth of 8 mm.

Your drawing looks like this:

Your drawing looks like this:
Working with Power View

With Power View, you can quickly generate a top or bottom view of a side view of a standard part and vice versa.

Before you complete the top view of the coverplate, you have to zoom into it.

To zoom to the cover plate

1. Zoom to the extents of the drawing.
   - **Ribbon**: View tab ➔ Navigate panel ➔ Zoom drop-down ➔ Extents.
   - **Menu**: View ➔ Zoom ➔ Extents
   - **Command**: ZOOM
2 Respond to the prompts as follows:

[All/Center/Dynamic/Extents/Previous/Scale/Window/Object] <real time>: Enter E, press ENTER

3 Zoom in to the coverplate.

Ribbon

View tab ➤ Navigate panel ➤ Zoom drop-down

➤ Window.

Menu

View ➤ Zoom ➤ Window

Command

ZOOM

4 Respond to the prompts as follows:

[All/Center/Dynamic/Extents/Previous/Scale/Window/Object] <real time>: Enter W, press ENTER

Specify first corner: Specify first corner point (1)

Specify opposite corner: Specify second corner point (2)

Use Power View to insert the screws into the top view of the coverplate.
To insert a standard part using Power View

1. Start the Power View command.
   - **Ribbon**: None.
   - **Menu**: Modify ➤ Power View
   - **Command**: AMPOWERVIEW

2. Respond to the prompt as follows:
   - **Select object**: Select the screw at cover plate (1)
   - The AutoCAD Mechanical message box is displayed.

3. Click Top, and respond to the prompt as follows:
   - **Specify insertion point**: Specify the centerline cross at top view (2)

The top view of the screw connection is inserted into the top view of the coverplate. Your drawing should look like this:
4 Repeat steps 1 and 2 to insert the top view of the screw at the other three centerline crosses of the top view of the coverplate.

The coverplate should look like this:

Save your file.

**Deleting with Power Erase**

Power Erase is an intelligent erase command. It detects the object information of a part. If you delete a screw connection with Power Erase, the representation of the background is automatically corrected.

Before you delete the standard part, you have to zoom into it.
To zoom to the standard part to delete

1. **Zoom to the extents of the drawing.**
   - **Ribbon:** View tab ➤ Navigate panel ➤ Zoom drop-down ➤ Extents.
   - **Menu:** View ➤ Zoom ➤ Extents
   - **Command:** ZOOM

2. Respond to the prompts as follows:
   - [All/Center/Dynamic/Extents/Previous/Scale/Window/Object] <real time>: Enter E, press ENTER

3. **Zoom in to the area of interest.**
   - **Ribbon:** View tab ➤ Navigate panel ➤ Zoom drop-down ➤ Window.
   - **Menu:** View ➤ Zoom ➤ Window
   - **Command:** ZOOM

4. Respond to the prompts as follows:
   - [All/Center/Dynamic/Extents/Previous/Scale/Window/Object] <real time>: Enter W, press ENTER
   - Specify first corner: Specify first corner point (1)
   - Specify opposite corner: Specify second corner point (2)
Delete a screw using the Power Erase command.

To delete a standard part

1. Start the Power Erase command.
   - **Ribbon**: Home tab ➤ Modify panel ➤ Erase.
   - **Menu**: Modify ➤ Power Erase
   - **Command**: AMPOWERERASE

2. Respond to the prompts as follows:
   - **Select object**: *Select the screw (1)*
   - **Select object**: Press ENTER
The screw connection is deleted and the lines and hatch are restored.

Save your file.

**Inserting Holes**

Replace the previously deleted screw connection with a pin. First you insert a blind hole for the pin.
To insert a hole

1. Start the Blind Hole command.
   - **Ribbon**: Content tab ➤ Holes panel ➤ Blind Hole.
   - **Menu**: Content ➤ Holes ➤ Blind Holes...
   - **Command**: AMBHOLE2D

2. In the Select a Blind Hole dialog box, select Acc. to ISO 273, and Front View.

3. Respond to the prompts as follows:
   - Specify insertion point: Specify insertion point (1)
   - Specify rotation angle <0>: Specify a point to define insertion angle (2)
4 In the Acc. to ISO 273 - Nominal Diameter dialog box, select a size of 5, and then click Finish.

5 Continue to respond to the prompts as follows:

Drag Size: Enter 20, press ENTER

The blind hole is inserted.

Your drawing should look like this:
Inserting Pins

Insert a pin into the blind hole.

**To insert a pin**

1. Start the Cylindrical Pins command.
   - **Ribbon**: Content tab ➤ Fasteners panel ➤ Pins drop-down ➤ Cylindrical Pin.
   - **Menu**: Content ➤ Fasteners ➤ Cylindrical Pins...
   - **Command**: AMCYLPIN2D

2. In the Select a Cylindrical Pin dialog box, select ISO 2338 and Front View.
3. Respond to the prompts as follows:
   Specify insertion point: Specify insertion point (1)
   Specify rotation angle <0>: Specify a point to define insertion angle (2)

4. In the ISO 2338 - Nominal Diameter dialog box, select a size of 5.
5 Click Finish, and then continue to respond to the prompt as follows:

**Drag Size:** Drag the pin to size 5 h8 x 16 - B, and then click

**NOTE** Turn the object snap (OSNAP) option off to snap to the correct pin size.

6 In the Select Part Size dialog box, select 5 h8 x 16 - B, and then Click OK.

You inserted the blind hole first, and then the pin. This results in overlapping centerlines. In order to have a correct plot, turn one centerline off.

**To turn off a centerline**

1 Select the previously inserted cylindrical pin.
2 Right-click, and on the shortcut menu deactivate Centerlines on/off. 
With the centerline of the pin turned off, only the centerline of the blind 
hole is displayed. 
Save your file.

**Turning Off Centerlines in Configurations**

If your drawing already contains holes with centerlines, and you want to add standard parts, it is recommended to turn off the centerlines for standard parts in the configuration. This avoids removing overlapped centerlines.

**To turn off centerlines in the configuration**

1. Open the Options dialog box.
   - Ribbon: None.
   - Menu: Tools ➤ Options...
   - Command: AMOPTIONS

2. On the AM:Standard Parts tab, clear the Draw Centerlines check box. 
   Click Apply, and then Click OK.

**Hiding Construction Lines**

For a better overview, you can hide the construction lines by turning them off temporarily.

Zoom to the extents of the drawing.

**To zoom to the extents**

1. Zoom to the extents of the drawing.
   - Ribbon: View tab ➤ Navigate panel ➤ Zoom drop-down ➤ Extents.
   - Menu: View ➤ Zoom ➤ Extents
   - Command: ZOOM

2. Respond to the prompts as follows:
To turn off C-lines

- Start the Construction Line On/Off command.


Menu: Format ➤ Layer Tools ➤ Construction Line On/Off

Command: AMCLINEO

All construction lines are turned off.

Save your file.

Simplifying Representations of Standard Parts

In some cases, such as in complex assemblies, it is helpful to have a simplified representation of the standard parts for a better overview. With AutoCAD Mechanical, you can switch between different representation types without losing object or part information.

Change the representation of the differential gear screws.

To change the representation of a standard part

1. Start the Change Representation command.

   Ribbon: Content tab ➤ Library panel drop-down ➤ Change Representation.

   Menu: Content ➤ Change Representation...

   Command: AMSTDPREP

2. Respond to the prompts as follows:

   Select objects: Select the differential gear with a window (1, 2)

   Select objects: Press ENTER
3 In the Switch Representation of Standard Parts dialog box, select Symbolic.

Click OK.

The representation of the selected standard parts is symbolic. Your drawing should look like this:
All of the standard parts you inserted in this exercise are listed in the mechanical browser.

Save your file. This is the end of this tutorial chapter.
In AutoCAD® Mechanical, you can create parts lists and bills of material (BOMs), and modify part references and balloons. In this chapter, you insert and edit a parts list, and work with the bill of material (BOM) database.

**Key Terms**

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>balloon</td>
<td>Circular annotation tag that identifies a bill of material item in a drawing. The number in the balloon corresponds with the number of the part in the bill of material.</td>
</tr>
<tr>
<td>bill of material</td>
<td>A dynamic database containing a list of all the parts in an assembly. Used to generate parts lists that contain associated attributes such as part number, manufacturer, and quantity.</td>
</tr>
<tr>
<td>BOM attribute</td>
<td>An entity that contains attributes by default (the attribute is invisible) that can add information to and describe details of a part in the drawing. The values of these attributes are transformed into the parts list attributes when converting BOM attributes and creating a parts list.</td>
</tr>
<tr>
<td>part reference</td>
<td>Part information for a bill of material, which is attached to the part in the drawing.</td>
</tr>
</tbody>
</table>
Working with Parts Lists

The drawing used for this exercise is not structured. In structured drawings, BOMs and parts list are generated automatically, and it is not necessary to insert part references manually.

Open the initial drawing.

To open a drawing

1. Open the file tut_pts_list.dwg in the Tutorial folder.

2. Zoom in to the area of interest.

The drawing contains a shaft with a housing.
Respond to the prompts as follows:

[All/Center/Dynamic/Extents/Previous/Scale/Window/Object] <real time>: Enter W, press ENTER

Specify first corner: Specify the first corner point figure (1)
Specify opposite corner: Specify the second corner point (2)

Save your file under a different name or to a different directory to preserve the original tutorial file.

**Inserting Part References**

Part references contain the part information required for a bill of material. The information in a part reference is available in the BOM database for creating a parts list.

Use the part reference command to enter part information for your part.

**To insert a part reference**

1. Start the Part Reference command.
   - **Ribbon**: Annotate tab ➤ BOM panel ➤ Part Reference drop-down ➤ Create.
   - **Menu**: Annotate ➤ Part Reference
   - **Command**: AMPARTREF

2. Respond to the prompts as follows:
   - Select point or [Block/Copy/Reference]:
   - Specifying a point on the part (1).
3 In the Part Reference dialog box, specify:
   Description: Housing Partition
   Standard: Size 130x125x55
   Material: EN-GJL-200

Click OK.
The Part Reference is inserted into the drawing. In the next step, you create a part reference by reference.
To insert a part reference by reference

1. Start the Part reference command again.
   - **Ribbon**: Annotate tab ➤ BOM panel ➤ Part Reference drop-down ➤ Create.
   - **Menu**: Annotate ➤ Part Reference
   - **Command**: AMPARTREF

2. Respond to the prompts as follows:
   
   Select point or [Block/Copy/Reference]:
   
   *Enter R at the command prompt to select Reference.*

3. In the drawing, select the previously inserted part reference to create a reference.
   
   **NOTE**: You can use the option Copy to create a new part with similar text information.

4. Respond to the prompts as follows:
   
   Enter an option [Next/Accept]<Accept>:  *Press ENTER*

5. Select point or: *Specify the insertion point at the circular edge (2)*

6. In the Part Reference dialog box, click OK.
   
   **NOTE**: This part reference looks different, because it has been attached to an object (the circular edge) of the part.

   Subsequently, when you generate the parts list, it shows a quantity of 2 for this item.

   Save your file.
Editing Part References

In this exercise, you edit an existing part reference.

To edit a Part Reference

1. Start the Part Reference Edit command.
   
   **Ribbon**
   
   Annotate tab ➤ BOM panel ➤ Part Reference drop-down ➤ Edit.

   **Menu**
   
   Annotate ➤ Part Reference Edit

   **Command**
   
   AMPARTREFEDIT

2. Respond to the prompts as follows:

   Select part reference or <Assembly properties>: Specify the part reference of the left bolt (3)

   Enter an option [Next/Accept]<Accept>: Press ENTER

3. In the Part Reference dialog box, Reference Quantity field, enter 3, and then click OK.
Zoom to the extents to display the entire drawing.

**Ribbon**
- View tab ➤ Navigate panel ➤ Zoom drop-down ➤ Window.

**Menu**
- View ➤ Zoom ➤ Window

**Command**
- ZOOM

Save your file.

---

**Placing Balloons**

Create balloons from the part references in the drawing.

**To place a balloon**

1. Start the Balloon command.

**Ribbon**
- Annotate tab ➤ Balloon panel ➤ Balloons.
Menu
Annotate ➤ Balloons
Command
AMBALLOON

2 Respond to the prompt as follows:

Select part/assembly or [auTo/autoAll/set Bom/Collect/arrow
Inset/Manual/One/Renumber/rEorganize/annotation View]: Enter B

NOTE At this stage the drawing doesn’t contain a BOM database. As with
the AMPARTLIST command, the AMBALLOON command creates a BOM
database automatically. All part references are added to the database and
item numbers are created inside the database. However, unless specifically
instructed the commands create only the main BOM database. For the
purpose of this tutorial, you must create a BOM database to contain part
references held within the border; a border BOM. This is why you are
instructed to enter B, to trigger the set BOM option of the AMBALLOON
command.

NOTE To create and edit a database manually, use the AMBOM command

Specify BOM to create or set current [Main/?] <BORDER1>: Press
ENTER

Select part/assembly or:

Select part/assembly or [auTo/autoAll/set Bom/Collect/arrow
Inset/Manual/One/Renumber/rEorganize/annotation View]: Enter A

Select part reference or: Use a window to select all objects, press ENTER

NOTE Press ENTER to change the type of arrangement (horizontal, vertical,
angle or stand-alone).

3 Place the balloons horizontally, above the assembly.
Because the balloons are numbered automatically, depending on where you located the part references, the appearance of your drawing can be different.

In the next step, you must renumber the balloons.

To renumber balloons

1. Start the Balloon command again.
   - **Ribbon**: Annotate tab ➤ Balloon panel ➤ Balloons.
   - **Menu**: Annotate ➤ Balloons
   - **Command**: AMBALLOON

2. Respond to the prompt as follows:
   - Select part/assembly or [auTo/autoAll/set Bom/Collect/arrow Inset/Manual/One/Renumber/rEorganize/annotation View]: Enter R
   - Enter starting item number: <1>: Press ENTER
   - Enter increment: <1>: Press ENTER
   - Select balloon: Select the balloons in numerical order from 1 to 7
   - Select balloon: Press ENTER

   ![](image.png)

**NOTE** Since the right most balloon contains the same number as another balloon you already selected, there is no need to explicitly select it.

Your drawing must look like the following image for you to continue:
To rearrange balloons.

1. Start the Balloon command again.
   - Ribbon: Annotate tab ➤ Balloon panel ➤ Balloons.
   - Menu: Annotate ➤ Balloons
   - Command: AMBALLOON

2. Respond to the prompt as follows:
   - Select part/assembly or [auTo/autoAll/set Bom/Collect/arrow Inset/Manual/One/ReNumber/reorganize/annotation View]: Enter E
   - Select balloon: Select the six balloons on the right
   - Select balloon: Press ENTER
   - Align [Angle/Standalone/Horizontal/Vertical]<Vertical>: Enter h, press ENTER

3. Move the cursor through the center of balloon 1 to get the horizontal tracking line.
   - NOTE Make sure that the OTRACK function is active.

4. Move the cursor to the right, and snap along the tracking line until you reach a distance of 120, and then click.
Create a part reference and a balloon in one step with the manual option.

To create a part reference and a balloon using the manual option

1. Start the Balloon command again.
   - **Ribbon**: Annotate tab ➤ Balloon panel ➤ Balloons.
   - **Menu**: Annotate ➤ Balloons
   - **Command**: AMBALLOON

2. Respond to the prompt as follows:
   
   Select part/assembly or [auTo/autoAll/set Bom/Collect/arrow
   Inset/Manual/One/ReNumber/reOrganize/annotation View]:

   Enter M, press ENTER

   The result must look like the following image:
Select point or [Block/Copy/Reference]: *Select a point on the shaft*

**NOTE** Instead of selecting a point to create a part reference, you can use Copy or Reference from the Manual option to get the information from an existing balloon or part reference.

3 In the Part Reference dialog box, specify:

- **Description:** Shaft
- **Standard:** Size Dia 50x150
- **Material:** C45

![Part Reference dialog box](image)

Click OK.
4 Press ENTER to start the leader line of the balloon in the center of the part reference.

5 Move the cursor through the center of balloon 1 to get the tracking line and the snap distance, and then click the insertion point.

   **NOTE** Instead of entering the insertion point, you can select another point to create an extended leader line.

   ![Diagram](image)

6 Press ENTER.

   Save your file.

---

**Creating Parts Lists**

Generate a parts list from the part reference information.

**To create a parts list**

1 Start the Parts List command.
   - **Ribbon**
     - Annotate tab ➤ Table panel ➤ Parts List.
   - **Menu**
     - Annotate ➤ Parts List
   - **Command**
     - AMPARTLIST

2 Respond to the prompt as follows:

   Select border/annotation view or specify BOM to create/use [Main/?] <MAIN>:

   *Move the cursor over the border until tooltip ISO_A2 is displayed, click the highlighted border*

   The Parts List dialog box is displayed.
Click OK.

The parts list appears dynamically on the cursor.

3 Move the cursor to position the parts lists above the title block, and then click to insert the parts list.

The parts list looks like the following:

![Parts List](image)

228 | Chapter 10  Working with BOMs and Parts Lists
Because the balloons were originally numbered automatically, depending on where you located the part references, the order that parts are listed can be different in your drawing.

If a drawing contains more than one border, the borders are listed in the BOM dialog box. From there you can select a particular border and view the associated parts list.

In the next exercise, you edit balloon and parts list information using several methods.

To edit parts list information

1. Start the Edit Part List/Balloon command.
   - **Ribbon**: None.
   - **Menu**: Modify ➤ Power Edit
   - **Command**: AMPowerEdit

2. Respond to the prompt as follows:
   - **Select object**: Select balloon 2

3. In the Balloon dialog box, Material column, enter 8.8.
Click OK.

The parts list reflects the material value you added.

<table>
<thead>
<tr>
<th>Item</th>
<th>Qty</th>
<th>Name/Description</th>
<th>Standard/Size</th>
<th>Material</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td>1</td>
<td>Shaft</td>
<td></td>
<td>C45</td>
</tr>
<tr>
<td>4</td>
<td>3</td>
<td>Hex Nut</td>
<td>ISO 4034 - M6</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>Needle Roller Bearing</td>
<td>ISO 1216 - MS - 4x10 x 62 x 22</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>2</td>
<td>Housing Partition</td>
<td>Size 130 x 15 x 55</td>
<td>EN-GJL-200</td>
</tr>
<tr>
<td>2</td>
<td>3</td>
<td>Hex-Head Bolt</td>
<td>ISO 4017 - M6 x 25</td>
<td>8.8</td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>Hex-Head Bolt</td>
<td>ISO 4017 - M6 x 25</td>
<td>8.8</td>
</tr>
<tr>
<td>5</td>
<td>3</td>
<td>Hex Nut</td>
<td>ISO 4034 - M6</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>1</td>
<td>Needle Roller Bearing</td>
<td>ISO 1216 - MS - 4x10 x 62 x 22</td>
<td></td>
</tr>
</tbody>
</table>

**NOTE** Choose Apply to see the results in the drawing immediately without leaving the dialog box. All changes made in the dialog box are associative and change the data in the drawing immediately.

4 Double-click the parts list.
The Parts List dialog box is displayed.
You can edit your data in this dialog box. Some examples are shown next.

5 Select the Hex Nut entry, and then choose the Set values icon.
6 In the Set Value dialog box, specify:

- **Column:** Material
- **Value:** 8
Click OK.

The material value is added to the Parts List.

7 Now, change the material of the second bolt and nut accordingly.

NOTE Use the shortcut menu inside a field to cut, copy, and paste.

Merging and Splitting Items In Parts Lists

Use the Parts List function to merge like items that are listed repeatedly.

To merge items in a parts list

1 In the Parts List dialog box, select the repeated items - Needle Roller Bearing. Click the row heading (the button in the left most column) of item 1 and with the CTRL key pressed click the row heading of item 6.
2 Click the Merge Items toolbar button.

The two rows are merged. In the Parts List dialog box, Item 6 now has a quantity of 2, and item 1 is missing.

You can select several rows to merge or split items. To merge rows, the part data in the selected rows must be the same.

3 Click Apply to display the changes in the drawing. Note how the balloon changes to reflect the same item number.
If you click the Split item button with the Needle Roller Bearing row selected, the previously merged items can be split to become two separate items once again. We, however, will not do it now, because in the next exercise we replace the two separate balloons with a single balloon that points to both Needle Roller Bearings.

Click OK to exit the Parts List dialog box.

To delete a balloon

1. Use Power Erase, and select the left balloon with the item number 1 (or 6, as the case may be).
2. Press ENTER to delete the balloon.
NOTE Deleting a balloon in the drawing doesn’t delete any data. Data is lost only if you delete a part reference. You can add more than one balloon to a part reference. For example, you can create a balloon with the same item number for the same part in another view.

To add an additional leader

1. Select the remaining balloon 1.
2. Right-click to display the shortcut menu. Select Add Leader and respond to the prompts as follows:
   - Select object to attach: Select the left bearing
   - Next point (or F for first point): Select a point inside the balloon 1
   The leader is added and your drawing should look like the following:

   ![Leader added](image)

   Save your file.

Collecting Balloons

You can collect balloons to place balloons of related parts to one leader line. For example, you can place the balloons of a screw and a nut to one common leader line.

Use Zoom Window to zoom in the top view of the drawing.

- **Ribbon**
  - View tab ➤ Navigate panel ➤ Zoom drop-down ➤ Window.
- **Menu**
  - View ➤ Zoom ➤ Window
- **Command**
  - ZOOM

To collect balloons

1. Start the AMBALLOON command.
2 Respond to the prompt as follows:

Select part/assembly or [auTo/autoAll/set Bom/Collect/arrow
Inset/Manual/One/Re-number/reOrganize/annotation View]:

Enter C, press ENTER

3 Continue to respond to the prompts as follows:

Select pick object or balloon: Select the part reference of the left nut

4 Continue to respond to the prompts as follows:

Select pick object or balloon: Press ENTER
Select balloon: Select balloon 2
Pick orientation: Select a vertical orientation

5 Repeat the collect balloon command for the screw and nut on the right side.
The result should look like this:
Sorting and Renumbering Items In Parts Lists

You can sort a parts list for manufacturing and sort standard parts with updated item numbers.

**To sort a parts list**

1. Zoom to the extents of the drawing.
   
   **Ribbon**: View tab ➤ Navigate panel ➤ Zoom drop-down ➤ Window.  
   
   **Menu**: View ➤ Zoom ➤ Window
   
   **Command**: ZOOM

2. Double-click the parts list to display the Parts List dialog box.

3. Choose the Sort icon.
The Sort dialog box opens.

**NOTE** You can sort within a selection set, otherwise you are sorting all items.

4 In the Sort dialog box, specify as shown in the following image.

Click OK.

The result should look like this:

Sorting and Renumbering Items In Parts Lists | 239
In the next step, you renumber the items.

**To renumber parts list items**

1. Click the column heading for the Item column.
2 Click the Set values button.

3 In the Set Value dialog box, specify:
   
   **Column:** Item
   **Start value:** 10
   **Step:** 10
4 Click OK to return to the Parts List dialog box.

5 Choose Apply to see the results.
The result should look like the following.

6 Choose OK to return to the drawing.
Save your file.

Using Filters

You can create and use one or more filters for every parts list you have inserted in the drawing.

To use filters in a parts list

1. Double-click the parts list to display the Parts List dialog box.
2. Right-click the blank list in the Filters and groups section.
3. Select Add Filter to display the List of Filters dialog box.
4. Select Custom and click OK.
The details for this filter are displayed in the Filter and groups section of the Parts List dialog box.

5 Set the following values to define the filter.

6 Activate the filter with the Custom check box.

7 Select the check box next to Custom and click Apply.
The Standards that contain ISO are displayed.

The filtered parts list is displayed in the drawing. The defined filters are saved with the parts list and can be used again later.

To print only the filtered list, choose the Print icon.

8 Deactivate the custom filter, and then click OK to close the dialog box.
The filter is used in this drawing.
The result looks like the following:
Save your file. This is the end of this tutorial chapter.
Creating Shafts with Standard Parts

In this tutorial, you work with the automated shaft generator and standard parts in AutoCAD® Mechanical to create and edit a shaft, and insert bearings. The standard parts you use are automatically structured in the mechanical browser.

Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>bearing calculation</td>
<td>Calculates limiting value, dynamic and static load rating, dynamic and static equivalent load, and fatigue life in revolutions and hours.</td>
</tr>
<tr>
<td>chamfer</td>
<td>A beveled surface between two faces or surfaces.</td>
</tr>
<tr>
<td>dynamic calculation</td>
<td>Calculation required for a revolving bearing. The result is the Adjusted Rating Life. This is the life associated with 90% reliability with</td>
</tr>
<tr>
<td></td>
<td>contemporary, commonly used material, and under conventional operating conditions. With the number of revolutions you get the life in working hours.</td>
</tr>
<tr>
<td>dynamic dragging</td>
<td>The act of determining the size of a standard part with the cursor while inserting it into a side view. The standard part is displayed</td>
</tr>
<tr>
<td></td>
<td>dynamically on the screen and can be dragged to the next possible size and length. The values (sizes) are taken from the Standard parts database.</td>
</tr>
<tr>
<td>fillet</td>
<td>A curved transition from one part face or surface to another. The transition cuts off the outside edge or fills in the inside edge.</td>
</tr>
</tbody>
</table>
Creating Shafts

In this section, you use the shaft generator to create a shaft with standard parts. You also perform a bearing calculation.

**To open a template**

1. Create a new drawing.
   - **Ribbon**
     - File ➤ New ➤ Drawing
   - **Menu**
     - File ➤ New
   - **Command**
     - NEW

2. In the Select template dialog box, click the template *am_iso.dwt*, and then click Open.
This creates a new drawing based on the am_iso template. Use Save As to save the drawing file with an appropriate name.

**NOTE** The ISO standard part standard has to be installed for this tutorial exercise.

Ensure that mechanical structure is enabled

**To enable mechanical structure**

1. Click the STRUCT status bar button and latch it down to enable mechanical structure.
2. If the mechanical browser is not visible, on the command line, enter `AMBROWSER`.
3. When prompted, enter `ON`.

**Configuring Snap Options**

Configure the snap options.
To configure the snap options

1. Start the Power Snap Settings command.
   - **Ribbon**: None.
   - **Menu**: Object Snap Cursor Menu ➤ Power Snap Settings
   - **Command**: AMPOWERSNAP

2. In the Power Snap Settings dialog box, in the Power Snap Configuration list, select Settings 4 and specify:
   - **Snap Modes**: Endpoint, Midpoint, Intersection

   ![Power Snap Settings dialog box](image)

   Click OK

   Save your file.

### Configuring Shaft Generators

In the next steps, you start and configure the shaft generator.

**NOTE** Turn off Dynamic Input

Click on the Dynamic Input status bar icon and ensure that it is not lighted up.

**To start and configure the shaft generator**

1. Start the Shaft Generator command.
Ribbon Content tab ➤ Shaft panel ➤ Shaft Generator.

Menu Content ➤ Shaft Generator...

Command AMSHAFT2D

2 Respond to the prompts as follows:

Enter shaft component name <Shaft1>: Press ENTER
Specify starting point or select center line:

Enter 150,150, press ENTER
Specify centerline endpoint: Enter 240,150, press ENTER

**NOTE** The start and endpoints of the centerline are only important in determining the direction. The length of the centerline is automatically adapted to the length of the shaft.

3 In the Shaft Generator dialog box, click Options.

4 In the Shaft Generator - Configuration dialog box, specify:

For Segment inserted: Insert
Stationary Shaft End: Left
Adjust Centerline: Yes
Front View: Radius Reflection Line, Check contour
Side and Sectional Views: Sectional with Background, Always update
View of Interrupt: Hatch
If shaft is in background, hide standard part too: Yes

Configuring Shaft Generators | 251
Creating Cylindrical Shaft Sections and Gears

The shaft generator is configured. Now you want to generate the first shaft segments. Verify that the Outer Contour tab is selected.

To create shaft segments

1. Click the lower cylinder button to define a cylinder section, and respond to the prompts as follows:
   - Specify length <50>: Enter 12, press ENTER
   - Specify diameter <40>: Enter 20, press ENTER

2. Click the gear button, and then enter the values for module, number of teeth, and length as shown in the following figure:
NOTE Here, the DIN standard requires that you indicate the module. The ANSI standard requires the Diametral Pitch 1/module. You can switch between these two representations using the DIN and ANSI options.

3 Close the Shaft Generator dialog box.
In the mechanical structure browser, the shaft is added as a component. Add an assembly to structure the shaft components you create in this exercise.

To add an assembly to the mechanical browser

1 In the mechanical browser, right click the file name node (the root node) and click New ➤ Component.

2 Respond to the prompts:
Enter new component name <COMP1>: Enter shaftassembly, press ENTER
Enter new view name <Top>: Enter front, press ENTER
Select objects for new component view: Select the shaft with a window
Select objects for new component view: Press ENTER
Specify base point: Specify a point at the upper left of the shaft
The shaft assembly is listed at the top of the browser, and the existing shaft components are listed within the assembly. As you add more
components to the shaft, they are automatically structured in the assembly.

<table>
<thead>
<tr>
<th>Mechanical Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Model</strong></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

Return to the shaft generator.
Double-click the left shaft segment in the drawing and then press ESC.

3. Click the lower cylinder button to define a further cylinder section and respond to the prompts as follows:
   - Specify length <10>: Enter 5, press ENTER
   - Specify diameter <20>: Enter 20, press ENTER

4. Click the gear button, and then enter the values for module, number of teeth, and length as shown in the following figure:
Click the lower cylinder button to define another cylinder section, and then respond to the prompts as follows:

Specify length \(<10>\): Enter 4, press ENTER

Specify diameter \(<20>\): Enter 24, press ENTER

Click the lower cylinder button to define another cylinder section, and then respond to the prompts as follows:

Specify length \(<4>\): Enter 33, press ENTER

Specify diameter \(<24>\): Enter 20, press ENTER

The first five sections of the shaft are created, as represented in the following figure:
Inserting Spline Profiles

Add a spline profile to the shaft.

To create a profiled segment

1. Click the Profile button.
2. In the Profile dialog box, click ISO 14 in the Details panel.
3. In the Splined Shaft ISO 14 dialog box, select the standard size 6 x 13 x 16 and enter a length of 26.

Click OK.

You created another section of the shaft, as shown in the following figure:
**Inserting Chamfers and Fillets**

Apply a chamfer and a fillet to the shaft.

**To apply a chamfer and a fillet**

1. Click the Chamfer button to apply a chamfer to a shaft section, and then respond to the prompts as follows:
   - Select object: *Select the left most cylinder section (1)*
   - Specify length (max. 12) <2.5>: *Enter 2, press ENTER*
   - Specify angle (0-79) or [Distance] <45>: *Enter 45, press ENTER*

2. Click the Fillet button to apply a fillet to a shaft section, and then respond to the prompts as follows:
   - Select object: *Select the cylinder section between the two gears near the second gear (1)*
   - Enter radius (max. 10.00) <2.50>: *Enter 2, press ENTER*
NOTE The fillet is applied to the edge of the selected section that is closer to the selected point.

The shaft looks like the following figure:

![Shaft Diagram]

## Inserting Shaft Breaks

Insert a shaft break in the drawing.

### To insert a shaft break

- Click the Break button to insert a shaft break, and then respond to the prompts as follows:
  - Specify point: *Select the midpoint of the cylindrical section (1)*
  - Specify length (min. 4.00) <6>: Enter 10, press ENTER

![Shaft Break Diagram]

NOTE You can insert the break to the left if you enter a negative value.

The shaft break is inserted.
Creating Side Views of Shafts

Insert a side view of the shaft.

To insert a side view

1. Click the Side view button.
2. In the Side view from dialog box, select Right. Click OK.
3. Respond to the prompt as follows:
   
   Specify insertion point: Press ENTER

   The right side view is inserted at the proposed position.

In the mechanical browser, the new right side view is listed within the shaft component along with the existing front view. The right side view includes its hide situations.

Inserting Threads on Shafts

Add a thread to the shaft.
To insert a thread on a shaft

1. Click the Thread button to insert a thread, and then select ISO 261 External from the Details panel.

2. In the ISO 261 ExternalThreads (Regular Thread) dialog box, select M10 and enter a length of 20. Click OK.

The thread is added to the shaft, which looks like this:

```
NOTE
If Always Update is unchecked in Options, AM:Shaft tab, you are
prompted to update associated views when you close the Shaft Generator.
```

**Editing Shafts and Inserting Sections**

Edit an existing shaft section and insert a new section. You use the Edit button in the shaft generator to turn on AMPowerEDIT.

**To edit and insert a shaft section**

1. Click the Edit button, and then respond to the prompts as follows:
Select object: Select the first cylindrical section (1)
Specify length <12>: Press ENTER
Specify diameter <20>: Enter 18, press ENTER

The diameter is changed to 18 while the length remains 12.

2 Click the Insert button, and then respond to the prompt as follows:
Specify point: Select a point after the second gear (1)

3 Click the Slope button, and then respond to the prompts as follows:
Specify length or [Dialog] <20>: Enter 4, press ENTER
Specify diameter at starting point <24>: Enter 28, press ENTER
Specify diameter at endpoint or [Slope/Angle] <20>: Enter 22, press ENTER
Replacing Shaft Sections

The previously inserted slope needs to be deleted again.

To replace a shaft section

1. Click the Undo button.
   The previous slope insertion is undone.
   Replace an existing shaft section. To do this, change the settings in the configuration.

2. Click the Options button to start the shaft generator configuration, and then specify:
   For Segment inserted: Overdraw
Click OK.

3. Click the Slope button, and then respond to the prompt as follows:
   Specify length or [Dialog] <4>: Enter D, press ENTER

4. In the Shaft Generator - Cone dialog box, specify the following settings.

Click OK.

The slope replaces the cylindrical shaft section.
Inserting Bearings

Insert a bearing and perform a bearing calculation.

To insert a bearing

1. Click the Standard Parts button, and then select Roller Bearings ➤ Radial ➤ ISO 355. Respond to the prompts as follows:
   - Specify insertion point on shaft contour: Specify insertion point (1)
   - Direction to [Left]: Select a point to the right (2)

2. In the ISO 355 dialog box, click Next.
3 Specify the loads, and activate Work Hours as shown in the following.

Click Next.

4 In the ISO 355 dialog box, select the bearing 2BD - 20 x 37 x 12, and then click Finish.
You can drag the cursor to see all available bearing sizes.

5 Drag to the size 2BD - 20 x 37 x 12, and then press ENTER.

6 In the Create Hide Situation dialog box, click OK. The bearing is inserted.

7 Close the Shaft Generator dialog box.
   In the mechanical structure browser, the roller bearing component is added to the assembly.
   Save your file. This is the end of this tutorial chapter.
Engineering Calculations

The tutorials in this section teach you how to calculate moments of inertia and deflection lines, create and calculate chains, springs and cams. The drawing files for each lesson can be found in the `Acadm/tutorial/` folder of the AutoCAD® Mechanical installation folder. These drawing files provide design elements that help you understand several AutoCAD Mechanical concepts.
Calculating Shafts

In this tutorial, you use the shaft generator in AutoCAD® Mechanical to perform a calculation on an existing shaft, and apply various loads to a supported shaft. Then you insert the results into a drawing.

Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>deflection line</td>
<td>A curve representing the vertical displacement of different points along the member subjected to a load.</td>
</tr>
<tr>
<td>bending mo-</td>
<td>The moment of all forces that act on the member to the left of a section (a point along the member where bending moment needs to be calculated) taken about the horizontal axis of the section.</td>
</tr>
<tr>
<td>moment</td>
<td></td>
</tr>
<tr>
<td>fatigue factor</td>
<td>Safety to endurance or fracture under repetitive cycles of loads.</td>
</tr>
<tr>
<td>fixed support</td>
<td>A support that prevents translation as well as rotation about all axes.</td>
</tr>
<tr>
<td>gear</td>
<td>Any of several arrangements in a machine, especially toothed wheels, that allow power to be passed from one part to another to control the power, speed, or the direction of movement.</td>
</tr>
<tr>
<td>load</td>
<td>The forces and moments that act on a part.</td>
</tr>
<tr>
<td>movable support</td>
<td>A support that prevents translation as well as rotation about all axes.</td>
</tr>
<tr>
<td>notch</td>
<td>A change of cross section, such as an undercut, groove, hole or shoulder. A notch leads to higher stress in the part. The flux of the stress is interrupted or redirected.</td>
</tr>
</tbody>
</table>
### Term | Definition
--- | ---
point force | A force that is concentrated on a point.
strength | A summary term for all forces and moments, thus loads and stress, which act on a part.
stress | Force or pressure on a part. Stress is the force per unit area.
yield point | Safety to the stress beyond which the material exhibits permanent deformation.

### Calculating Shafts

With AutoCAD Mechanical, you can perform a shaft calculation using a contour created with the Shaft Generator, or any other symmetric shaft contour. The function provides a static calculation, which is important for the design of the shaft and the bearing load.

In this tutorial, you calculate a gearbox shaft. The general way to calculate an existing shaft is to define the contour and insert forces and supports. The routine calculates all necessary values and draws the respective graphs for moment and deflection.

Mechanical structure does not impact this engineering structure routine. You can calculate shafts with mechanical structure enabled or disabled.

Load the initial drawing.

**To open a file**

1. Open the file `tut_shafts.dwg` in the Tutorial folder.

   **Ribbon**
   - File ➤ Open ➤ Drawing

   **Menu**
   - File ➤ Open

   **Command**
   - OPEN
NOTE The path to the folder containing tutorial files is:

- **Windows Vista®**: `C:\Users\Public\Public Documents\Autodesk\ACADM 2010\Acadm\Tutorial`
- **Windows® XP**: `C:\Documents and Settings\All Users\Shared Documents\Autodesk\ACADM 2010\Acadm\Tutorial`

The drawing contains a shaft in front and side view.

2. Zoom in to the shaft.
   
   **Ribbon**  
   View tab ➤ Navigate panel ➤ Zoom drop-down ➤ Window.

   **Menu**  
   View ➤ Zoom ➤ Window

   **Command**  
   ZOOM

3. Respond to the prompts as follows:
   
   Specify corner of window, enter a scale factor (nX or nXP), or [All/Center/Dynamic/Extents/Previous/Scale/Window/Object] <real time>:
   
   Enter W, press ENTER

   Specify first corner: **Specify the first corner point (1)**

   Specify opposite corner: **Specify the second corner point (2)**

Save your file under a different name or to a different directory to preserve the original tutorial file.
Creating Shaft Contours

Before you can perform any calculations on a shaft, you have to create the shaft contour.

**To create a shaft contour**

1. Start the Shaft Calculator.

2. **Ribbon**
   - Content tab ➤ Calculation panel drop-down ➤ Shaft Calculation.
   - **Menu**
     - Content ➤ Calculations ➤ Shaft Calculation...
   - **Command**
     - AMSHAFTCALC

3. Respond to the prompts as follows:
   - Select contour or [Create contour/Strength] <Create>:
     - Enter C, press ENTER
   - Select objects: Select the complete shaft
   - Select objects: Press ENTER

4. In the AutoCAD Question dialog box, click Yes.

5. Respond to the prompts as follows:
   - Specify contour position: Press ENTER

---

**NOTE** The calculation routine recognizes hollow shafts and uses the contour for the calculation.

After you create the shaft contour, the Shaft Calculation dialog box is displayed so that you can select the boundary conditions, the material, and the representation of the calculation results.
Specifying Material

You specify the material by selecting it from a table containing the most commonly used materials. You can also enter the characteristics for other materials using the option Edit.

**To specify a material**

1. In Material, click Edit.
   
   The Material Properties dialog box is displayed.

   **TIP** There are two Edit buttons in the dialog box. Ensure that you click the Edit button in the Materials section.

2. In the Material Properties dialog box, click Table.

3. In the Details panel of the Material Dialog box, click ANSI Material.

4. In the Material dialog box, select the material Steel SAE 1045 from the table.
Click OK.

**NOTE** If the ANSI standard is not installed on your system, you can select a different standard, but the results may differ from the results in this tutorial. For example, if you select DIN, you can select a similar material, like E335, to achieve similar results.

**NOTE** Some material properties are not complete. In this case, you have to complete them to obtain calculation results.

In the Material Properties dialog box, complete the ANSI material properties, if necessary.

Click OK.
Placing Shaft Supports

Specify the shaft supports.

To place a support

1. In the Shaft Calculation dialog box, select the Movable Support icon, and then respond to the prompt as follows:
   **Specify insertion point:** Select the midpoint of the left most shaft section

2. Select the Fixed Support icon, and then respond to the prompt as follows:
   **Specify insertion point:** Select the midpoint of the third cylindrical shaft section

The shaft supports are specified, and the result looks like this:

![Shaft Supports Diagram]

Specifying Loads on Shafts

Specify the effective loads. AutoCAD Mechanical uses geometry from the drawing for load calculations.

The loads depend on the Calculated Part setting. There are three possibilities: Rotating Shaft, Rotating Axle, and Not rotating Axle. Shafts transfer torque and rotating axles results in different stress values than static axles results.

To specify a load

1. From the Calculated Part drop-down list, click Rotating Shaft.
2 Click the Gear icon, and then respond to the prompt as follows:

Specify insertion point:
Select the midpoint of the second gear from the left

3 In the Gear dialog box, Inputs tab, specify:

Gear Load: Constant Motive Power, Driven
Torque: 15

![Gear dialog box with inputs](image)

Click OK.

**NOTE** The Components tab displays the force components. Changes in one tab are automatically reflected in the other tab.

4 Click the Point Load icon, and then respond to the prompts as follows:

Specify insertion point: Select the midpoint of the profile section
Specify rotation angle: Press ENTER

5 In the Point Load dialog box, Resultant tab, specify:
Point Load: 2500

Click OK.

6 Click the Torque icon, and then respond to the prompt as follows:

Specify insertion point: Select the midpoint of the profile section

7 In the Torque dialog box, specify:

Torque: Mt= 15

Click OK.

The loads are specified, and the result looks like this:
Calculating and Inserting Results

Perform a calculation of the moments and deformations, and insert the results in your drawing.

To perform a shaft calculation

1. In the Shaft Calculation dialog box, click the Moments and Deformations button.

2. In the Select Graph dialog box, specify:
   - **Bend**: Bending Moment in Y - Axis, Deflection in Y - Axis
   - **Torsion**: Torsion Moment in X - Direction
   - **Stresses**: Result Bending Stress
   - **Table Title**: Shaft Calculation Exercise

3. Click OK, and then respond to the prompts as follows:
   - Specify insertion point:
     - Select an appropriate point to the right of the shaft
   - The result block and the deflection and torsion moment graphs are inserted.

4. Close the Shaft Calculation dialog box.
   - Your drawing looks like this:
The result block provides the most important information about your calculated shaft, such as the maximum stress deflection and moment values.
5 Close the Shaft Calculation dialog box.
   Save your file.

### Calculating Strengths of Shafts

Check the strength at a critical place of the shaft, such as at a notch.

**To calculate the strength at a notch**

1. Restart the Shaft Calculation.
   - **Ribbon**
     - Content tab ➤ Calculation panel drop-down ➤
       - Shaft Calculation.
   - **Menu**
     - Content ➤ Calculations ➤ Shaft Calculation...
   - **Command**
     - AMSHAFTCALC

2. Respond to the prompt as follows:
Select contour or [Create contour/Strength] <Create>:

Select the shaft contour

The Shaft Calculation dialog box opens. Continue with calculations on the previously specified shaft.

3 In the Shaft Calculation dialog box, click the Strength button, and then respond to the prompt as follows:

Specify calculation position on shaft or [Graph]:

Specify the notch at the end of the conical section (1) (do not select the endpoint of the cylindrical shaft section)

NOTE This notch was selected because the calculation established that the highest bending stress is close to this place.

The Strength Calculation dialog box opens.

Use the Strength Calculation dialog box to specify the properties of the notch in more detail and display the strength values and factors.
Click OK.

4 Respond to the prompts as follows:

Specify next point <Symbol>: Specify a point below the shaft
Specify next point <Symbol>: Press ENTER
The result block is inserted in the drawing.
The safety factors are greater than 1.0, so the shaft does not need to be redesigned at this notch.

5 Close the Shaft Calculation dialog box.

Save your file. This is the end of this tutorial chapter.
Calculating Moments of Inertia and Deflection Lines

Many engineering calculations are automated in AutoCAD® Mechanical. This tutorial illustrates how you calculate the moment of inertia for a profile section, and calculate the deflection line on a beam based on the profile calculation.

Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>bending moment</td>
<td>The moment of all forces that act on the member to the left of a section (a point along the member where bending moment needs to be calculated) taken about the horizontal axis of the section.</td>
</tr>
<tr>
<td>deflection line</td>
<td>A curve representing the vertical displacement of different points along the member subjected to a load.</td>
</tr>
<tr>
<td>distributed load</td>
<td>A load or force that is exerted over a certain length.</td>
</tr>
<tr>
<td>fixed support</td>
<td>A support that prevents translation as well as rotation about all axes.</td>
</tr>
<tr>
<td>load</td>
<td>Force or moment acting on a member or body.</td>
</tr>
<tr>
<td>moment of inertia</td>
<td>An important property of areas and solid bodies. Standard formulas are derived by multiplying elementary particles of area and mass by the squares of their distances from reference axes.</td>
</tr>
</tbody>
</table>
Performing Calculations

The measurement unit for the moment of inertia is mm^4 or inches^4. These are geometric values, which appear in deflection, torsion, and buckling calculation. AutoCAD Mechanical uses the result of the moment of inertia calculation for the deflection line calculation.

Moment of inertia calculations are performed on cross sections of beams or on other objects that can be represented as closed contours. Calculations can be performed on a cross section of any shape, as long as the geometry of the cross section forms a closed contour.

AutoCAD Mechanical determines the center of gravity for a cross section, draws the main axes, and calculates the moment of inertia about each of those axes. You can also select a load direction for a cross section; AutoCAD Mechanical calculates the moment of inertia and angle of deflection for that load.

**NOTE** Before you perform this exercise, verify that the ISO standard part standard is installed.

Load the initial drawing.

- Open the file *tut_calc* in the Tutorial folder.

  **Ribbon**
  
  ➤ Open ➤ Drawing

  **Menu**
  
  File ➤ Open

  **Command**
  
  OPEN
NOTE The path to the folder containing tutorial files is:

- **Windows Vista®**: C:\Users\Public\Public Documents\Autodesk\ACADM 2010\Acadm\Tutorial
- **Windows® XP**: C:\Documents and Settings\All Users\Shared Documents\Autodesk\ACADM 2010\Acadm\Tutorial

The drawing contains this profile:

![Profile Image]

Save your file under a different name or directory to preserve the original tutorial file.

**Calculating Moments of Inertia**

In order to perform any calculations on a profile, you need to know its moment of inertia.

**To calculate the moment of inertia**

1. Start the calculation for the moment of inertia.
   - **Ribbon**: Content tab ➤ Calculation panel ➤ Moment of Inertia
   - **Menu**: Content ➤ Calculations ➤ Moment of Inertia
   - **Command**: AMINERTIA

2. Respond to the prompts as follows:
   - Specify interior point: *Click a point inside the profile*
Specify interior point: Press ENTER

Is the area filled correctly? (Yes/No)? <Yes>: Press ENTER

The coordinates of the centroid and the moment of inertia along the principle axes are displayed on the command line, as follows:

Coordinates of centroid (in user coordinates):
X coordinate: 228.071933 Y coordinate: 150.027674

Moments of inertia along principal axes:
I1: 2.359e+004 I2: 1.4095e+004

Axis angle for major moment (I1): 5.3

Define the direction of the loads. They must be in one plane.

3 Respond to the prompts as follows:
Specify direction of load forces (must all lie in one plane):
Enter 270, press ENTER

The data for this load direction is displayed on the command line, as follows:

Effective moment of inertia for this load direction: 2.341e+004
Angle of deflection: 266.5

Maximum distances neutral line – border:
Extension side: 16.690 Compression side: 14.444

Enter a description for the calculated profile and locate the block with the calculation data in the drawing.

4 Respond to the prompts as follows:
Enter description: Enter Frame Profile, press ENTER
Specify insertion point: Place the calculation block next to the profile

Your drawing looks like this:
NOTE The main axes, 1 and 2, are the axes with the most and least deflection. The F arrow displays the direction of the force, the s arrow displays the resultant deflection. The moment of inertia block shows the moments related to the main axis, the maximum distances from the edges, and the calculated area. For more detailed information, see Help.

A side view of the profile has been created for the deflection line.

5  Zoom to the extents of the drawing.

Calculating Deflection Lines

The calculation of the deflection line requires the calculation result from the moment of inertia calculation.

Calculate the deflection line under a specific load situation.

To calculate the deflection line

1  Start the deflection line calculation.

<table>
<thead>
<tr>
<th>Frame Profile</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>( I_1 ) [\text{mm}^4]</td>
<td>23590</td>
</tr>
<tr>
<td>( I_2 ) [\text{mm}^4]</td>
<td>14095</td>
</tr>
<tr>
<td>( S_6 ) [\text{mm}]</td>
<td>14.44</td>
</tr>
<tr>
<td>( S_7 ) [\text{mm}]</td>
<td>16.69</td>
</tr>
<tr>
<td>( A ) [\text{mm}^2]</td>
<td>277.7</td>
</tr>
</tbody>
</table>
Ribbon

Content tab ➤ Calculation panel ➤ Deflection Line.

Menu

Content ➤ Calculations ➤ Deflection Line...

Command

AMDEFLINE

2 Respond to the prompts as follows:

Select moment of inertia block: Select the calculation block (1)

Specify starting point or [Existing beam]:

Select the left end of the beam (2)

Specify endpoint: Select the right end of the beam (3)

3 In the Beam Calculation dialog box, click Table.

4 In the Select Standard for Material dialog box, select ANSI Material.

5 In the Material Type dialog box, select ANSI standard and the material Al. Bronze Cast.

290 | Chapter 13  Calculating Moments of Inertia and Deflection Lines
NOTE If you have not installed ANSI standard, selecting a different standard according to your preference is also possible, but the results will differ from the results in this tutorial exercise. For example, if you select DIN, you can select a similar material, like AlMgSi0.5F22, to achieve similar results.

Click OK.

Define the supports and the loads.

6. Click the Fixed Support icon, and then respond to the prompt as follows:

   Specify insertion point:  *Select the left edge of the beam (1)*

   ![Beam with Fixed Support](image)

   **NOTE** The support can only be placed along the beam.

7. Click the Movable Support icon, and then respond to the prompt as follows:

   Specify insertion point:  *Select the right edge of the beam (2)*

   ![Beam with Movable Support](image)
8 Click the Uniform Load icon, and then respond to the prompts as follows:

Specify insertion point: Select the left edge of the beam (3)
Specify endpoint: Select the midpoint of the beam using midpoint snap (4)
Line Load [N/mm]<50>: Enter 10, press ENTER

9 Click the Moment icon, and then respond to the prompts as follows:

Specify insertion point:
Select a point in the center of the uniform load (5)
Bending moment (Nm)<10>: Enter 3, press ENTER

10 In the Beam Calculation dialog box, click Moments and Deflection.

11 In the Select Graph dialog box, select the options as shown in the following figure, and then Click OK.
12 Respond to the prompts as follows:

Enter scale for bending moment line (drawing unit:Nm)<1:1.3913>:

Press ENTER

Enter scale for deflection (drawing unit:mm)<37.208:1>:

Press ENTER

Specify insertion point:  Select a point in the drawing

The result looks like this:

The calculation result block displays all important data on your calculation:
| Moment of Inertia | I1 | in^4 | 22596 |
| Moment of Inertia | I2 | in^4 | 10.899 |
| Moment of Inertia | I3 | in^4 | 2941.8 |
| Max. Bending Dist. | L1 | in | 16.69 |
| Safety Factor | | | 1.5873 |
| Yield Point | N/mm² | 712 |
| E-Modulus | N/mm² | 108.42 |
| Material | | | Al. Bronze Cast |
| Max. Deflection | S1 | in | 0.003768 |
| Max. Bending Moment | M1 | ft·in | 16.13 |
| Max. Deflection | S2 | in | 0.000656 |
| Max. Bending Moment | M2 | ft·in | 176.16 |
| Max. Stress | Rea. | N/mm² | 123.98 |
| Max. Deflection | Sres | in | 0.007425 |
| Max. Bending Moment | Memax | ft·in | 128.98 |
| Scale for Left Line | | | 27.711 |
| Scale for Bending Mom. Line | | | 11.34 |

Save your file. This is the end of this tutorial chapter.
Calculating Chains

In this AutoCAD® Mechanical tutorial, you calculate a chain length, and insert sprockets and chain links into a drawing.

Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>partition</td>
<td>Distance in mm or inches between centers of adjacent joint members. Other dimensions are proportional to the pitch. Also known as pitch.</td>
</tr>
<tr>
<td>pitch diameter</td>
<td>The diameter of the pitch circle that passes through the centers of the link pins as the chain is wrapped on the sprocket.</td>
</tr>
<tr>
<td>roller chain</td>
<td>A roller chain is made up of two kinds of links: roller links and pin links alternately and evenly spaced throughout the length of the chain.</td>
</tr>
<tr>
<td>sprocket</td>
<td>A toothed wheel that transfers the power from the chain to the shaft or the other way round.</td>
</tr>
</tbody>
</table>

Chain Calculations

NOTE Before you begin this tutorial exercise, be sure the ISO standard parts are installed on your screen.
Before you begin this tutorial...

This tutorial requires the mechanical browser. If the mechanical browser is not visible:

1. Enter `AMBROWSER` on the command line and press ENTER.
2. When prompted, enter `ON` and press ENTER.

To load the tutorial drawing

1. Open the file `tut_chain.dwg` in the Tutorial folder.

   **Ribbon**
   - Open ➤ Drawing
   **Menu**
   - File ➤ Open
   **Command**
   - OPEN

   **NOTE** The path to the folder containing tutorial files is:
   - **Windows Vista**: C:\Users\Public\Public Documents\Autodesk\ACADM 2010\Acadm\Tutorial
   - **Windows® XP**: C:\Documents and Settings\All Users\Shared Documents\Autodesk\ACADM 2010\Acadm\Tutorial

2. Save your file under a different name to preserve the original tutorial file.

3. Use a window to Zoom in to the chain housing.

   **Ribbon**
   - View tab ➤ Navigate panel ➤ Extents drop-down
   **Menu**
   - View ➤ Zoom ➤ Zoom, Window
   **Command**
   - ZOOM

4. Respond to the prompts as follows:

   `[All/Center/Dynamic/Extents/Previous/Scale/Window/Object] <real time>:
   Enter W, press ENTER
   Specify first corner: Specify first corner point (1)
Performing Length Calculations

To calculate the required length of the chain

1. Start the Length Calculation command.
   - **Ribbon**: Content tab ➤ Tools panel ➤ Chains/Belts dropdown ➤ Length Calculation.
   - **Menu**: Content ➤ Chains / Belts ➤ Length Calculation...
   - **Command**: AMCHAINLENGTHCAL

2. In the Belt and Chain Length Calculation dialog box, click Library.
3 In the Select a Chain dialog box, in the Details panel, select ISO 606 metric.

4 In the Select Part Size dialog box, specify:
   Standard: ISO 606 - 05B - 1
   Click OK.

5 In the Belt and Chain Length Calculation dialog box, Click OK, and then respond to the prompts as follows:
   Specify 1st point for tangent or [Undo] <exit>: Select circle a (1)
Specify 2nd point for tangent:  
Select circle c (2)  
Specify 1st point for tangent or [Undo] <exit>:  
Select circle c (3)  
Specify 2nd point for tangent:  
Select circle b (4)  
Specify 1st point for tangent or [Undo] <exit>:  
Select circle b (5)  
Specify 2nd point for tangent:  
Select circle a (6)  
Specify 1st point for tangent or [Undo] <exit>:  
Press ENTER

The tangent definition is finished, and the length of the chain is calculated. Because the length is divided into whole numbers of links, one sprocket has to be moved to achieve such a length.

6  Continue responding to the prompts as follows:
Select pulleys or sprockets to be moved. Select objects:  
Select circle b  
Select objects:  Press ENTER  
Specify base point of displacement:  
Select the center of circle b  
Specify second point of displacement:  
Select the center of the cross (8)  
Select pulleys or sprockets to be moved.  
Select objects:  Press ENTER  
AutoCAD Mechanical calculated the new length, which is still not a multiple of the chain division:
Number of links in chain: 121 Distance to next link: 6.88567 mm
Length: 974.8857
The chain arrangement has to be optimized to a length that is a multiple of the chain division.

Save your file.

Optimizing Chain Lengths

To optimize the chain length

1. Start the Length Calculation command.
   - Ribbon: Content tab ➤ Tools panel ➤ Chains/Belts drop-down ➤ Length Calculation.
   - Menu: Content ➤ Chains / Belts ➤ Length Calculation...
   - Command: AMCHAINLENGTHCAL

2. In the Belt and Chain Length Calculation dialog box, select Auto Optimization and Move, and then specify:
   - Required Number of Links: 122
Click OK.

3  Respond to the prompts as follows:
Select pulleys or sprockets to be moved.
Select objects:  Select the relocated circle b
Select objects:  Press ENTER
Specify direction angle to move:  Enter 90, press ENTER
Sprocket b is moved until a chain length of 122 links is achieved.

4  In the Belt and Chain Length Calculation dialog box, Click OK.
Close the dialog box by clicking Cancel.
Your drawing looks like this:

Optimizing Chain Lengths | 301
Inserting Sprockets

To insert the sprocket

1. Start the Draw Sprocket/Pulley command.
   - **Ribbon**: Content tab ➤ Tools panel ➤ Chains/Belts drop-down ➤ Sprocket/Pulley.
   - **Menu**: Content ➤ Chains / Belts ➤ Draw Sprocket/Pulley...
   - **Command**: AMSPROCKET

2. In the Select Pulley and Sprocket dialog box, Details panel, click Sprockets ➤ Front view.
   Respond to the prompts:
   - Specify insertion point: *Select the center of circle a*
   - Specify rotation angle < 0 >: *Enter 360, press ENTER*

3. In the Sprockets - Size Selection dialog box, select ISO 606 05B-1, and then click Next.

4. In the Sprockets - Geometry dialog box, specify:
   - Geometry of Sprocket:
   - Number of teeth: 21
Number of Visible Teeth: 21
Shaft Diameter: 10

Click Finish.
The sprocket is inserted into the drawing, and the Create Hide Situation dialog box is displayed.

5 In the Hide Situation dialog box, click OK.
A hide situation is created.
Insert the next two sprockets.

6 Start the Draw Sprocket/Pulley command again.

   Ribbon  Content tab ➤ Tools panel ➤ Chains/Belts drop-down ➤ Sprocket/Pulley.
   Menu  Content ➤ Chains / Belts ➤ Draw Sprocket/Pulley...
   Command  AMSPROCKET

7 In the Select Pulley and Sprocket dialog box, Buttons tab, click Sprockets %Ф Front view.
Respond to the prompts:
Specify insertion point: Select the center of circle b
Specify rotation angle < 0 >: Enter 360, press ENTER
In the Sprockets - Size Selection dialog box, select ISO 606 05B-1, and then click Next.

In the Sprockets - Geometry dialog box, specify:

Geometry of Sprocket:
Number of teeth: 13
Number of Visible Teeth: 13
Shaft Diameter: 10

Click Finish.

In the Create Hide Situation dialog box, click OK.
A hide situation is created, and is listed in the mechanical browser.
The sprocket is inserted into the drawing.
Create the next sprocket.

Start the Draw Sprocket/Pulley command again.

Ribbon
Content tab ➤ Tools panel ➤ Chains/Belts drop-down ➤ Sprocket/Pulley.

Menu
Content ➤ Chains / Belts ➤ Draw Sprocket/Pulley...

Command
AMSPROCKET

In the Select Pulley and Sprocket dialog box, Details panel, click Sprockets ➤ Front view.
Respond to the prompts:
Specify insertion point:  Select the center of circle c
Specify rotation angle < 0 >: Enter 360, press ENTER

13 In the Sprockets - Size Selection dialog box, select ISO 606 05B-1, and then click Next.

14 In the Sprockets - Geometry dialog box, specify:
Geometry of Sprocket:
Number of teeth: 51
Number of Visible Teeth: 3
Shaft Diameter: 10

Click Finish.

15 In the Create Hide Situation dialog box, click OK.
A hide situation is created, and is listed in the mechanical browser.
The last sprocket is inserted as a simplified representation with only three teeth, as specified in the dialog box. Your drawing looks like this:
Save your file.

Inserting Chains

To insert a chain

1. Start the Draw Chain/Belt Links command.
   - **Ribbon:** Content tab ➤ Tools panel ➤ Chains/Belts dropdown ➤ Chain/Belt Links.
   - **Menu:** Content ➤ Chains / Belts ➤ Draw Chain/Belt Links...
   - **Command:** AMCHAINDRAW

2. In the Select Belt and Chain dialog box, Details panel, click Chains.
   - Respond to the prompts:
     - Select polyline: *Select the polyline near point 9*
     - Select starting point on polyline: *Select a point on the polyline*

3. In the Select a Chain dialog box, select ISO 606 Metric.

4. In the Chains - Size Selection dialog box, select ISO 606 05B - 1, and then click Next.

5. In the Chains - Geometry selection dialog box, specify:
   - **Number of Links:** 121
Click Finish.

6 Respond to the prompts:
   Specify direction of Links [Flip/Accept] <Accept>: **Press ENTER**
   Specify orientation of Links [Flip/Accept] <Accept>: **Enter F, press ENTER**
   Specify orientation of Links [Flip/Accept] <Accept>: **Press ENTER**

7 In the Hide Situation dialog box, click OK.
The chain is inserted into the drawing, and a hide situation is created.
Your drawing looks like this:

![Image of a chain inserted into a drawing]

The mechanical browser reflects the standard components you created in the drawing.
Save your file. This is the end of this tutorial chapter.
Calculating Springs

In this tutorial, you calculate a spring for existing boundary conditions and insert the spring into a drawing. You copy and edit the spring using the Power Copy and Power Edit commands in AutoCAD® Mechanical.

Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Belleville spring washer</td>
<td>A washer-type spring that can sustain relatively large loads with small deflections. The loads and deflections can be increased by stacking the springs.</td>
</tr>
<tr>
<td>compression spring</td>
<td>A spring type that can be compressed and can absorb pressure forces.</td>
</tr>
<tr>
<td>dynamic dragging</td>
<td>The act of determining the size of a standard part with the cursor while inserting the part into a side view. The standard part is displayed dynamically on the screen and can be dragged to the next possible size and length. The values (sizes) are taken from the Standard parts database.</td>
</tr>
<tr>
<td>extension spring</td>
<td>A spring type that can absorb tension forces.</td>
</tr>
<tr>
<td>Power Copy</td>
<td>A command that copies a drawing object to another position in the drawing. Power Copy produces an identical copy of the copied object.</td>
</tr>
<tr>
<td>Power Edit</td>
<td>A single edit command for all objects in a drawing.</td>
</tr>
<tr>
<td>torsion spring</td>
<td>A spring type that can absorb torque forces.</td>
</tr>
</tbody>
</table>
Calculating Springs

With the AutoCAD Mechanical spring function, you can insert compression, extension, and torsion springs, as well as Belleville spring washers. The calculation is carried out in accordance with DIN 2098 or ANSI. The standard sizes of the springs can be selected from various standard catalogs.

**NOTE** The ISO standard parts have to be installed for this tutorial exercise.

In this tutorial, you create a compression spring in two different compression situations. You calculate and insert the springs in the existing drawing. Perform this tutorial with mechanical structure disabled.

**To open a drawing**

1. Open the file *tut_spring.dwg* in the tutorials folder at:
   
   **Ribbon**
   
   ![Open Drawing](image)
   
   **Menu** File ➤ Open
   
   **Command** OPEN

   **NOTE** The path to the folder containing tutorial files is;
   
   - **Windows Vista®:** C:\Users\Public\Public Documents\Autodesk\ACADM 2010\Acadm\Tutorial
   
   - **Windows® XP:** C:\Documents and Settings\All Users\Shared Documents\Autodesk\ACADM 2010\Acadm\Tutorial

2. Zoom in to the area of the spring housings.
   
   **Ribbon** View tab ➤ Navigate panel ➤ Zoom drop-down
   
   ![Zoom](image)
   
   **Menu** View ➤ Zoom ➤ Window
   
   **Command** ZOOM

3. Respond to the prompts as follows:
Starting Spring Calculations

Specify the spring and the location.

To specify a spring

1. Start the Compression Spring command.

The drawing shows two views (A and B) of the lever and spring housing, to reflect two different states of compression.

Save your file under a different name or to a different directory to preserve the original tutorial file.
2. In the Select Compression Spring dialog box, click Standards ➤ SPEC® Catalog A ➤ Front View.

3. Respond to the prompts as follows:
   - Specify starting point: Specify the starting point (1)
   - Specify direction: Specify endpoint (2)
Specifying Spring Restrictions

Specify the spring restrictions. Use the Compression Springs dialog box to restrict the spring selection in various ways.

To specify the spring restrictions

1. In the Compression Springs - Select from Table SPEC® Catalog A [mm] dialog box, specify:
   - Specification: 2 Loads, 2 Lengths
   - Absolute Set: Lengths
   - Click the Da button.
A row for specifying the outer diameter $D_a$ is added to the restrictions table.

2 Click the value field for the diameter $D_a$. You can pick a point on the inner spring housing to specify the diameter, or enter a value. In this instance, enter the value 15.

Define the initial spring length.

3 In the Compression Springs - Select from Tables SPEC® Catalog A [mm] dialog box, click the value field for the length $L_1$, and then choose the pick icon.
4 Respond to the prompts as follows:

Specify point for spring length L1:

Select a point on the spring pressure plate (1)

Use view B of the lever and spring housing to define the compressed spring length.

5 In the Compression Springs dialog box, click the value field for the length L2, and then choose the pick icon.
6 Respond to the prompts as follows:

Specify point for spring length L2:

Select a point on the spring pressure plate in view B (1)

The geometric boundary conditions are defined, and you can proceed with the calculation.

**Calculating and Selecting Springs**

Make the calculation settings and calculate the possible springs.
To calculate and select a spring

1 In the Compression Springs - Select from Tables SPEC® Catalog A [mm] dialog box, choose the Additional Calculation Settings button.

2 In the Compression Springs - Additional Calculation [ANSI] dialog, select the left buckling case, and then Click OK.

3 In the Compression Springs - Select from Tables SPEC® Catalog A [mm] dialog box, choose Next.
The possible springs are calculated and the results are displayed in the Compression Springs - Select from Tables SPEC® Catalog A [mm] dialog box.

4 Choose Select All to select all possible springs for the dynamic dragging process.
Choose Finish.

Inserting Springs

Drag the cursor dynamically to switch between the selected possible springs. The outline of the spring is displayed in the drawing and the spring description is displayed in the tooltip.

To insert a spring

1 Drag the cursor until the tooltip reads SPEC - 1.6 x 14.1 x 36, and then click.

2 Respond to the prompts as follows:

   Topical Length (14.28 - 36) [Force/Deflection] <32.01>:

   Select a point on the spring pressure plate (1)

3 Continue to respond to the prompts as follows:

   Select rod (only closed contours) <Enter=continue>: Press ENTER

   The spring is inserted as shown below.
Creating Views of Springs with Power View

In order to adjust the length of the spring in view B, the springs in the two views need to be different components rather than instances of the same component.

Use the previously inserted spring in view A to create a spring for view B, using the Power View command.

To create a view of a spring with Power View

1. Start the Power View command.

   **Ribbon**
   - Tools ➤ Content ➤ Modify ➤ Power View
   - Menu ➤ Modify ➤ Power View
   - Command ➤ AMPowerView

2. Respond to the prompts as follows:
   - **Select objects:** Select the spring in view A

3. In the Select New View dialog box, select Front View.
4 Respond to the prompts:

Specify starting point: *Select point (1) in view B*

Specify direction: *Select point (2) in view B*

Topical Length (14.28 - 36)(Force/Deflection)<32.01>: 

*Select the lower contact point of the compressed spring*

Select rod (only closed contours) <Enter=continue>: *Press ENTER*

The spring is copied into view B in its compressed length.

Save your file. This is the end of this tutorial chapter.
Calculating Screw Connections

In this tutorial, you calculate a screw connection using the stand-alone screw calculation function in AutoCAD® Mechanical.

Key Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>axial force</td>
<td>A force parallel to the screw axis.</td>
</tr>
<tr>
<td>contact area</td>
<td>The touching surfaces of the plates, which are effective for the calculation.</td>
</tr>
<tr>
<td>safety factor</td>
<td>The safety factor is the ratio of effective load and safe load.</td>
</tr>
<tr>
<td>shear force</td>
<td>A force perpendicular to the screw axis.</td>
</tr>
<tr>
<td>stress</td>
<td>The force acting on a member or body per unit area.</td>
</tr>
</tbody>
</table>

Methods for Calculating Screws

The Screw Calculation provides two different ways to calculate a screw connection:

- Stand-alone calculation: All data and properties are specified by the user.
Calculation of an existing screw connection: The user selects an existing screw connection to be calculated. All geometric and standard-related data is taken from the screw connection and cannot be edited.

In this exercise, you use the stand-alone Screw Calculation. With the standalone calculation, you can calculate a screw connection without any prerequisites. You can specify the screw connection in detail (material, geometry, load, settlement and tightening properties). In this exercise, you are provided with the drawing of a screw calculation. Some values are selected from tables, some are entered manually, and some are taken directly from the drawing.

To open the initial drawing

1. Open the file tut_screw.dwg in the tutorials folder.

NOTE The path to the folder containing tutorial files is:

- Windows Vista®: C:\Users\Public\Public Documents\Autodesk\ACADM 2010\Acadm\Tutorial
- Windows® XP: C:\Documents and Settings\All Users\Shared Documents\Autodesk\ACADM 2010\Acadm\Tutorial

The drawing contains the representation of a screw connection.
2 Save your file under a different name or to a different directory to preserve the original tutorial file.

**Problem for this exercise**

- Two hollow shafts made of Cq 45 with forged coupling flanges are to be connected by 13 hex-head bolts ISO 4017 M12 x 45 - 10.9, which are arranged at a pitch diameter of 130 mm.
- The through holes are according to ISO 273 close.
- The bolts are safeguarded against loosening by gluing the threads \((\mu = 0.14)\). The tightening takes place manually using a torque wrench \((k = 1.8)\).
- The flanged connection is to be designed for a alternating torque of \(T = 2405\) Nm and non-skid (seal safety of plates \(\geq 1\)).

**Using Stand Alone Screw Calculations**

**To start the Screw Calculation**

1. Start the Screw Calculation command.
   
   **Ribbon**
   
   Content tab ➤ Calculation panel drop-down ➤ Screw Calculation.

   **Menu**
   
   Content ➤ Calculations ➤ Screw Calculation...

   **Command**
   
   AMSCREWCALC

2. Respond to the prompts as follows:
   
   Select screw connection <Stand alone calculation>: Press ENTER

   The Screw Calculation dialog box opens.

   Specify the screw connection.
Selecting and Specifying Screws

In the Definition of SCREW section of the screw calculation, you can select the screw standard and size and the material properties. You can also enter the geometric properties of a user-defined screw, for example in detail.

To specify a screw

1. On the Screw: Geometry tab, click Table of Screws.

2. In the Select a Screw dialog box, in the Details panel, click Hex Head Types, and then click ISO 4017 (Regular Thread).

3. In the Select a Row dialog box, choose the standard M12x45.
Click OK.

The geometric values of the standard screw ISO 4017 M12x45 are entered. Specify the property class.

4 Click the Material tab and then specify:

**Property class:** DIN 10.9

The screw is specified completely. Specify the nut.
5 Click Next or the Definition of NUT icon in the top row to proceed.

Selecting and Specifying Nuts

In the Definition of NUT section of the screw calculation, you can select a nut standard and size.

To specify a nut

1 On the Nut tab, click Table of Nuts.

2 In the Select a Nut dialog box, in the Details pane, click Hex Nuts and then, ISO 4032 (Regular Thread).
   You do not need to specify a size, because the size is determined by the screw size.
   Specify the washers.

3 Click Next.
Selecting and Specifying Washers

In the Definition of WASHERS section of the screw calculation, you can select the washer standard and size and the positions of the washers.

To specify a washer

1. On the Washer under: Head 1 tab, clear the Washer check box.

2. Click the Nut 1 tab, and then click the Table of Washers button.

3. In the Select a Washer dialog box, choose ISO 7091.

4. Click Next.

Specifying Plate Geometry and Properties

In the Definition of PLATES section of the screw calculation, you can select plate materials and their geometric properties.
To specify the plates

1. On the Plates tab, specify:
   - Hole: dh: 13
   - Number of Plates: 2
   - Height of plate 1 h1: 10
   - Height of plate 2 h2: 10

2. Click any of the Table buttons.

3. In the Please Select a Part dialog box, in the Details panel, click DIN material.

4. Choose the material Cq 45, and then Click OK.

5. Repeat steps 3 and 4 for the other Table button.

Specify the contact area.

6. On the Gaps and Chamfers tab, click the pick button of the value gr.

7. Respond to the prompts as follows:
   - Specify first point: Select the point (1)
   - Second point: Select the point (2)
The value for gr is changed to 17, as shown in the illustration.

8 Click Next.
Specifying Contact Areas

In the Definition of CONTACT AREA section of the screw calculation, you can specify the geometric properties of the contact area.

To specify the contact area

1. On the Contact Area tab, click the Type button.
2. In the Select the Type of Contact Area dialog box, click the third button from the left.
3. Select the User Changes check box.
4. In the entry field, specify:  
   \[ \text{ang: } 22.5 \]
5 For the outer radius $r_o$, click the pick button next to the entry field and respond to the prompts as follows:
   Specify first point: Select the point (1)
   Second point: Select the point (2)

6 For the inner radius $r_i$, click the pick button next to the entry field and respond to the prompts as follows:
   Specify first point: Select the point (1)
   Second point: Select the point (3)

Specify the loads and moments.

7 Click Next.

**Specifying Loads and Moments**

In the Definition of LOADS section of the screw calculation, you can specify the loads and moments and their points of application.

**To specify loads and moments**

1 On the Axial Loads tab, clear the Dynamic check box and specify:
   Axial force: $F_B$: 0
2 Click the Shear Loads tab and specify:

Torsion Moment \( T = 185 \text{[Nm]} \)

Radius \( R = 65 \)

Coefficient of Friction: \( m_t = 0.14 \)

**NOTE** The torsion moment of 185 Nm results from the total torsion moment of 2405 Nm as given in the terms of reference divided by the 13 bolts.
Specify the settlement.

3  Click Next.

**Specifying Settlement Properties**

In the Definition of SETTLEMENT section of the screw calculation, you can specify settlement properties.

**To specify the settlement**

1  Click Calculate from Roughness and $\geq 1.6$ micro m.
Specify the tightening.

2 Click Next.

**Specifying Tightening Properties**

In the Definition of TIGHTEN section of the screw calculation, you can specify the tightening method and properties.

**To specify the tightening**

1 Specify as follows:
   - Tightening Factor: $k_A = 1.5$
   - Coefficient of Friction: in Thread $m_{\nu G} = 0.12$
2 Click Next.

**Creating and Inserting Result Blocks**

In the Results section of the screw calculation, you can take a look at the results.

You have a complete overview of the results of the screw calculation.
Insert the result block.

To insert a result block

- Click Finish and respond to the prompts as follows:
  Specify start point: **Specify a point right of the screw connection**
  Specify next point <Symbol>: **Press ENTER**

The result block is inserted at the specified location.

Save your file. This is the end of this tutorial chapter.
In this tutorial, you calculate the stresses in a lever using the finite element analysis (FEA) in AutoCAD® Mechanical. You use the results to improve the design of the lever.

**Key Terms**

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>distributed load</td>
<td>A load or force that is exerted over a certain length.</td>
</tr>
<tr>
<td>FEA</td>
<td>Finite Element Analysis. A calculation routine based on analyzing a rigid body subject to loads and restraints for stress, strain, and deformation.</td>
</tr>
<tr>
<td>fixed support</td>
<td>A support that prevents translation as well as rotation about all axes.</td>
</tr>
<tr>
<td>load</td>
<td>Force or moment acting on a member or body.</td>
</tr>
<tr>
<td>movable support</td>
<td>A support that prevents rotation in all axes, but allows translation along one axis.</td>
</tr>
<tr>
<td>Power Edit</td>
<td>A single edit command for the objects in your drawing.</td>
</tr>
<tr>
<td>stress</td>
<td>The force acting on a member or body per unit area.</td>
</tr>
</tbody>
</table>
2D FEA

To determine the stability and durability of a given structure under various loading situations, you need to observe the stress and deformation in the components while they are being loaded. A structure is considered to be durable if the maximum stress is less than what the material permits.

There are various computational methods for calculating deformation and stress conditions. One of these methods is called the Finite Element Analysis.

The knowledge gained from this stress rating may lead to changing the structure in certain areas, which in turn necessitates changes to the design.

The FEA routine uses its own layer group for input and output.

Note that FEA is not designed for solving all special FEA tasks. Its purpose is to provide you with a quick idea of the stress and deformation distributions.

**NOTE** The ISO standard parts have to be installed for this tutorial exercise.

For this exercise, work with mechanical structure disabled.

**To open the initial drawing**

1. Open the file `tut_fea.dwg` in the tutorials folder at:
   - Windows Vista®: `C:\Users\Public\Public Documents\Autodesk\ACADM 2010\Acadm\Tutorial`
   - Windows®XP: `C:\Documents and Settings\All Users\Shared Documents\Autodesk\ACADM 2010\Acadm\Tutorial`

   **Ribbon**
   - File ➤ Open ➤ Drawing
   
   **Menu**
   - File ➤ Open
   
   **Command**
   - OPEN

   The drawing contains a lever, which is the basis for your calculations.

2. Zoom in to the lever.

   **Ribbon**
   - View tab ➤ Navigate panel ➤ Zoom drop-down ➤ Window.
Menu View ➤ Zoom ➤ Window
Command ZOOM
The complete lever is displayed on your screen.

Save your file under a different name or to a different directory to preserve the original tutorial file.

Regenerate the drawing.
- Ribbon None.
- Menu View ➤ Regen All
- Command REGENALL
The drawing is regenerated.

Calculating Stress In Parts
Before you calculate the stress in a part, specify the border conditions.
To specify the border conditions

1. Activate the FEA calculation.
   **Ribbon**
   Content tab ➤ Calculation panel ➤ FEA...
   **Menu**
   Content ➤ Calculations ➤ FEA ...
   **Command**
   AMFEA2D

2. Respond to the prompts as follows:
   **Specify interior point:** Specify a point inside the contour
   The FEA 2D Calculation dialog box opens so that you can define border conditions and perform calculations.

Select the thickness and the material of the lever.

3. In the Default section, specify a thickness of 10.

4. In the Material section, click Table.

5. In the Select Standard for Material dialog box, in the Details panel, click ANSI Material, and from the Select Material Type dialog box, select Al. Alloys Diecast.

6. Click the Config button, and in the FEA Configuration dialog box, and specify:
Click OK to return to the FEA 2D - Calculation dialog box.

Defining Loads and Supports

To perform calculations, you need to define the loads and supports.

To specify loads and supports

1. Click the fixed line support button, and respond to the prompts as follows:
   - Specify insertion point <Enter=Dialogbox>: Specify point (1)
   - Specify endpoint: Specify point (2)
   - Specify side from endpoint: Specify a point above the contour

2. Click the movable line support button, and respond to the prompts as follows:
   - Specify insertion point <Enter=Dialogbox>:
   - Hold down SHIFT, right-click and click Quadrant, specify point (3)
   - Specify endpoint: Press ENTER to define the starting point as the endpoint
3 Click the line force button, and respond to the prompts as follows:
Specify insertion point <Enter=Dialogbox>: Specify point (5)
Specify endpoint: Specify point (4)
Specify side from endpoint:
Specify a point to the right of the specified points
Enter a new value <1000 N/mm>: Enter 500, press ENTER

4 Click the line force button again, and respond to the prompts as follows:
Specify insertion point <Enter=Dialogbox>: Specify point (6)
Specify endpoint: Specify point (7)
Specify side from endpoint:
Specify a point to the right of the specified points
Enter a new value <1000 N/mm>: Enter 500, press ENTER
Calculating Results

Before you calculate the results, generate a mesh.

**NOTE** If you calculate results without creating a mesh in advance, the mesh will be created automatically.

To calculate the results

1. In the Mesh section, click the mesh button, and then press ENTER to return to the dialog box.

2. In the Results section, click the isolines (isoareas) button.

3. In the FEA 2D Isolines (Isoareas) dialog box, select the Graphic Representation button on the right.

Click OK.

4. Respond to the prompts as follows:
Specify base point <Return – in boundary>:

Press ENTER to place the isoareas in the boundary

Insertion point: Select a point to place the table to the left of the part

<Return>: Press ENTER to return to the dialog box

The result looks like this:

After calculation, the support forces are displayed near the support symbol.

Evaluating and Refining Mesh

The stress table allocation relative to the lever shows heavy concentration of local stress near drawing points 8 and 9. Refine the mesh near these points to obtain more exact calculation results for the points of interest.

To refine the mesh

1. In the Refining section, click the left refining button, and respond to the prompts as follows:
Specify center point 1 <Return=Continue>:
Specify a point near point 8
Specify center point 2 <Return=Continue>:
Specify a point near point 9
Specify center point 3 <Return=Continue>:
Press ENTER to continue meshing
<Return>: Press ENTER to return to the dialog box

The mesh is refined at the specified points.
Recalculate the stress representation.

2 Click the isolines (isoareas) button.
3 In the FEA 2D Isolines (Isoareas) dialog box, click the Graphic Representation button on the right.

Click OK
4 Respond to the prompts as follows:
Refining Designs

The results show a critical area around point 8 that can be improved by applying a larger radius. Before changing the geometry, the results and solutions have to be deleted.

To edit the geometry

1. Click the Delete Solution button.
2. In the AutoCAD Question dialog box, click Yes to delete the solutions and results.
3. In the AutoCAD Question dialog box, click No to keep the loads and supports.
4. To change the radius, start the Power Edit command:
   - Ribbon: None.
   - Menu: Modify ➤ Power Edit
   - Command: AMPOWEREDIT

   Respond to the prompt as follows:
   - Select object: Select the arc segment at point 8

5. In the Fillet dialog box, specify:
   - Fillet Size: 10
Click OK.

7 Respond to the prompt:

Select objects: Press ENTER to exit the command

The radius of the fillet is changed to 10.

8 Zoom to the extents of the drawing.

Ribbon View tab ➤ Navigate panel ➤ Zoom drop-down ➤ Extents.

Menu View ➤ Zoom ➤ Extents

Command ZOOM

Save your file.

Recalculating Stress

Before recalculating the stress division of the lever, calculate and display the deformation.

To calculate the stress

1 Restart the FEA routine.

Ribbon

Content tab ➤ Calculation panel ➤ FEA.

Menu Content ➤ Calculations ➤ FEA...

Command AMFEA2D
2 Respond to the prompts as follows:
   Specify interior point: Specify a point inside the contour
   Select the thickness and the material of the lever again, as you did it before.

3 In the Default section, enter a thickness of 10.

4 Click Table, and select the material from your preferred standard table. Select Al. Alloys Diecast if you prefer to use ANSI materials.

5 Click the deformation button in the Results field.

6 In the FEA 2D - Displacements dialog box, Click OK.

7 Respond to the prompts as follows:
   Specify base point <Return = in boundary>: Press ENTER
   Insertion point: To the right of the part, select a location for the table
   <Return>: Press ENTER to return to the dialog box
   The result looks like this:
Recalculate the stress division of the lever.

1. Click the isolines (isoareas) button.

2. In the FEA 2D Isolines (Isoareas) dialog box, click the Graphic Representation button on the right.

   ![FEA 2D - Isolines (Isoareas) dialog box]

   Click OK.

3. Respond to the prompts as follows:
Specify base point <Return – in boundary>: Press ENTER

Specify insertion point:

To the left of the part, select a location for the table

<Return>: Press ENTER to return to the dialog box

4 Click Close to leave the FEA 2D - Calculation.

The final result looks like this:

NOTE You can return to the FEA 2D - Calculation using Power Edit.

Save your file. This is the end of this tutorial chapter.
In this tutorial you use the automated cam design and calculation functionality in AutoCAD® Mechanical to create a cam, perform calculations, and generate data for NC production.

**Key Terms**

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>acceleration</td>
<td>Rate of change in velocity.</td>
</tr>
<tr>
<td>cam</td>
<td>Types of gears for obtaining unusual and irregular motions that would be difficult to produce otherwise.</td>
</tr>
<tr>
<td>curve path</td>
<td>Geometric shape of the cam.</td>
</tr>
<tr>
<td>motion diagram</td>
<td>Diagram illustrating the lift or rotation of the follower for each degree of rotation or translation of the cam plate.</td>
</tr>
<tr>
<td>motion section</td>
<td>Part of the motion diagram. Some sections are defined by design. For example, the maximum lift of 15 mm is reached at an angle of 90 degrees.</td>
</tr>
<tr>
<td>NC</td>
<td>Numerical Control. Used in manufacturing to represent the control on machine tool motion through numeric data for 2 to 5 axis machining.</td>
</tr>
<tr>
<td>resolution</td>
<td>Controls the precision of curves. A low value increases computing time. Use a higher value for initial design.</td>
</tr>
</tbody>
</table>
Designing and Calculating Cams

With the cam design and calculation functionality in AutoCAD Mechanical, you can implement all motions required in the scope of process control with a minimum number of gear elements. The basis for systematic design procedures is offered using standardized laws of movement in the development of new cam gears.

With the automated cam features, you can create cams (linear, circular, and cylindrical cams) based on sections drawn in a motion diagram. You can also calculate velocity and acceleration of an existing section of the motion diagram. The cam curve path can be determined with the calculated cam sections. An existing curve path can be scanned and transferred in the motion diagram. A driven element can be coupled to the cam. NC data can be created using the curve path.

In the following exercise, you generate a circular cam and a swinging follower with a single roller. You also calculate the spring of the follower. The cam and the follower are inserted into the drawing together with the motion diagrams. At the end you generate the NC data for the cam production.

Start with an ISO drawing template.

To open a template

1. Start a new drawing.
   - Ribbon
     ➤ New ➤ Drawing
   - Menu
     File ➤ New
   - Command
     NEW

2. The Select template dialog box opens. Select the template am_iso.dwt and click Open. This creates a new drawing based on the am_iso template. Use Save As to save the drawing file with an appropriate name.
Starting Cam Designs and Calculations

To start a cam design and calculation

1. Open the cam design and calculation tool.
   Ribbon ➤ Content tab ➤ Calculation panel drop-down ➤
   Cam Design and Calculation.
   Menu ➤ Content ➤ Cams...
   Command ➤ AMCAM

   Specify the cam type.

2. In the Cam Design and Calculation dialog box, on the Cam tab, specify:
   Type: Circular
   In the Type of Cam dialog box, click the center Circular icon and specify:
   Revolutions [1/min]: 100
   Drawn: Select the check box
   Diameter of Body [mm]: 50

3. Click the Follower button.

   NOTE: You can also step through the dialog using the Next button.

4. On the Follower tab, Movement section, click the Translating button.
In the Type of Follower dialog box, click the Swinging button. You are returned to the CAM Design and Calculation dialog box.

Specify the following settings.
6 Click the Profile button, and define the profile.
You can select between a power-contact profile (inner or outer) or a form-contact profile (both outer). Specify an inner profile, which requires a spring to keep contact.
Specify the following settings.

7 Click the Location button.
The dialog box is hidden so you can specify a location for the cam and the follower in the drawing.

8 Respond to the prompts as follows:
Specify center of cam: 100,100, press ENTER
Specify center of follower swing [Undo]: @100,0, press ENTER
Specify start of movement [Undo]: @90<157.36, press ENTER
Specify origin of movement diagram [Undo/Window] <Window>: Specify a point next to the cam
Specify length of movement diagram [Undo]: @360,0, press ENTER

The cam and the follower are inserted into the drawing with the motion diagram. Your drawing looks like this:
The Cam Design and Calculation dialog box is opened again.

**Defining Motion Sections**

Define five motion sections to describe the cam.

**To specify motions**

1. In the Cam Design and Calculation dialog box, click the Motions button, and then click the New button.
In the Select Method to Add New Segment dialog box, you can either insert or append a new motion section.

2 Click Append.

Define the first motion section.

3 In the Motion - New mode dialog box, specify the following settings.
   - Position [deg] <from - to> 0 -: 90
   - Elevation [deg] 0 -: 0
Click OK.
The motion is inserted into the drawing and you are reverted back to the Cam Design and Calculation dialog.

Define the next motions to describe the cam.

1. In the Cam Design and Calculation dialog box, Motion tab, click New.

2. In the Select Method to Add New Segment dialog box, click Append.

3. In the Motion - New mode dialog box, specify the following settings.

   Position [deg] <from - to> 90 -: 150
   Elevation [deg] 0 -: 5
4 Click the Context of Follower movement button.

5 Click Dwell - Constant Velocity (second button from left).

6 In the Motion - New mode dialog box, specify the following settings.
   Curve: 5th polynomial
   Velocity [rad/s] 0 -: 2
The next motion section has to be ‘Constant Velocity,’ since the motion section before is ‘Dwell - Constant Velocity’.

1. In the Cam Design and Calculation dialog box, Motion tab, click New.
2. In the Select Method to Add New Segment dialog box, click Append.
3. In the Motion - New mode dialog, specify the following settings.
   - Position [deg] <from - to> 150 -: 180
   - Elevation [deg] 5 -: 8
4. Click the Context of Follower movement button.
Click Constant Velocity (left most button).

The routine recalculates the elevation and inserts the correct value, 10.73, in the Elevation box of the Motion New mode dialog box.

Click OK.

Define the next motion section.

1. In the Cam Design and Calculation dialog box, Motion tab, click New.
2. In the Select Method to Add New Segment dialog box, click Append.
3. In the Motion - New mode dialog box, specify the following settings:
   - Position [deg] <from - to> 180 -: 220
   - Elevation [deg] 10.73 -: 16
4. Click the Context of Follower movement button, and then click Constant Velocity - Reverse (fourth button from left).
5. In the Motion - New mode dialog box, specify the following settings:
   - Acceleration [rad/s^2] 0 -: 60
Define the last motion section to complete the 360 degrees.

1. In the Cam Design and Calculation dialog box, Motion tab, click New.
2. In the Select Method to Add New Section dialog box, click Append.
3. In the Motion - New mode dialog, specify the following settings.
   - **Position [deg] <from - to>:** 220 - 360
   - **Elevation [deg]:** 16 - 0
4. Click the Context of Follower movement button.
   The routine calculates the correct values for the end position.
5. In the Motion - New mode dialog box, specify the following settings.
   - **Curve:** Harmonic Combination
Click OK.

The definition of the motion section is complete, and all motion sections are displayed in the list.

The definition of the geometry is finished.

**Calculating Strength for Springs**

To calculate the strength for the spring

1. In the Cam Design and Calculation dialog box, select the Strength check box, and then click the Strength button.
2 In the Cam Design and Calculation dialog box, Loads tab, specify:

- External Force [N] $Fe = 20$
- Reduced Mass of the Follower [kg] $mf = 0.1$
- Reduced Inert Mass [kg] $mi = 0.07$

3 On the Spring tab, specify:

- Preload [N] $F_0 = 10$
- Mass of Spring [kg] $ms = 0.08$
- Spring Location [mm] $ls = 45$
- Spring Rate: Select the User Change check box, enter 30
4 On the Material tab, you can specify the material for cam and roller. In this case, use the default material.

5 On the Arm tab, specify:

   Dimensions of Arm [mm] d = 8

   NOTE You can choose other types of cross sections for the arms.

6 Click Results, and then click Calculation.

   All calculation results are displayed on the respective tabs:
The Calculation button gives you the results of your design. To optimize your design, you can choose to generate the correct size of the cam based on the pressure angle and the radius of curvature.

To generate a cam design based on pressure angle and radius of curvature

1 Click the Calculation button.
   To optimize the size of the cam, the pressure angle from your design must be less than or equal to a certain value (automatically calculated and displayed at the bottom of the cam Design and Calculation dialog box) while the radius of curvature must be greater than or equal to a certain value (automatically calculated and displayed at the bottom of the cam Design and Calculation dialog box).

2 Click the Results button.

3 In the Geometry tab, click the Center of Cam button.
   Two hatched open triangles are displayed on the screen.

4 Respond to the prompts as follows:
   Press ESC or ENTER to exit, or [Change center of cam]:
   Enter C, press ENTER
   Specify center of cam <100,100>: Press ENTER

5 Snap to the apex of the triangle that produces a maximal pressure angle less than or equal to the recommended value and a minimal radius of curvature greater than or equal to the recommended value.

Exporting Cam Data and Viewing Results

To export TXT cam data for an NC machine

1 In the Cam Design and Calculation dialog box, click Export.
   On the File tab, specify:
   Export Curves: Inner
   Precision [mm]: 0.01
   Data Type: File: TXT
   Data Type: Coordinates: Polar
Click Generate File.

2 In the Save As dialog box, specify a descriptive file name and a location. Click Save.

The cam is completely designed and calculated.

3 To view the results, click Finish, and then respond to the prompt as follows:

Specify insertion point of result table:

Specify a location for the result table

The table of results is inserted into the drawing.
Save your file. This is the end of the tutorial chapter.
Autodesk Inventor Link

The tutorial in this section teaches you how to import an Autodesk Inventor® file and generate drawing views from them for documentation. The Autodesk Inventor assembly and part drawings required for this tutorial are available in the Acadm/tutorial/tut_bracket folder of the AutoCAD® Mechanical installation folder.
Using Autodesk Inventor Link Support

In this chapter, you learn how to enable AutoCAD® Mechanical to create views and documentation for Autodesk Inventor® assemblies and parts.

**Key Terms**

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>parametric dimensions</td>
<td>A type of dimension associated with an Autodesk Inventor model. Parametric dimensions control the size and positions of geometry. If the dimension value is changed, the size and position of the geometry adjusts to reflect the new value. Parametric dimensions can be changed only from Autodesk Inventor.</td>
</tr>
<tr>
<td>power dimensioning</td>
<td>A command useful for generating linear, radial, and diameter dimensions, which minimizes the number of individual actions while generating a dimension. Power dimensioning automatically selects the type of linear dimension (horizontal, vertical, or aligned), based on the selected point.</td>
</tr>
<tr>
<td>reference dimensions</td>
<td>A type of dimension that indicates the size and position of geometry. Reference dimensions do not control the geometry size or position, but follow them instead. The type of dimensions created with power dimensioning commands are reference dimensions.</td>
</tr>
</tbody>
</table>
### Linking Autodesk Inventor Part Files

With Autodesk Inventor link support, you can create views of Autodesk Inventor part files while maintaining full model to drawing associativity. Note: You can perform the exercises in this chapter only if AutoCAD Mechanical is installed with the Install Autodesk Inventor link option enabled. Also, before you begin the exercises, download and install Visual Basic for Applications (VBA) at http://autodesk.com/vba-download.

#### To link an Autodesk Inventor part file

1. Open the Inventor part file.
   
   **Ribbon**
   
   ![Ribbon](image)
   
   ➤ New ➤ Inventor Link
   
   **Menu**
   
   File ➤ New Inventor Link
   
   **Command**
   
   NEW
   
2. In the Select template dialog box, select the template *am Ansi.dwt*, then click Open.
3 In the Link Autodesk Inventor File dialog box, locate the
Tut_Bracket\Bracket Components folder, within the folder containing
tutorial files at:

■ Windows Vista®: C:\Users\Public\Public Documents\Autodesk\ACADM
2010\Acadm\Tutorial

■ Windows® XP: C:\Documents and Settings\All Users\Shared
Documents\Autodesk\ACADM 2010\Acadm\Tutorial

4 Click Holder Bracket.ipt, then click Open.

Shading and Rotating Geometry

The commands to shade and rotate geometry are on the Mechanical Browser’s
right-click menu. If the Mechanical Browser is not visible:

➤ On the command line, enter AMBROWSER and respond to the prompts as follows.

\textbf{Desktop browser? [ON/OFF] <ON>:}

\textit{Enter ON, press ENTER}
To shade a part

- Right-click the root node of the Mechanical Browser and click Shade. Use the 3D Orbit tool to rotate the part.

To rotate a part

1. Right-click the root node of the Mechanical Browser and click 3D orbit.
2. Right-click in the drawing area again and select Other Navigation Modes ➤ Free Orbit.
3. Place the cursor in the appropriate location inside or on the Arcball.
4. Click and hold the left mouse button, then rotate the part to a position that resembles the following illustration.
5. Right-click, then click Exit from the menu.

Inserting Drawing Borders

To insert a drawing border

1. Click the Drawing tab in the Mechanical Browser.
2. Start the Drawing Title/Borders command.

Ribbon

- Annotate tab ➤ Layout panel ➤

Menu

- Annotate ➤ Drawing Title and Revision ➤ Drawing Title/Borders...
Command AMTITLE

3 In the Drawing Borders with Title Block dialog box, specify:
- Paper Format: C (17.0x22.0 inch)
- Title Block: US Title Block
- Scale: 1:1

4 Choose OK.

5 In the Page Setup Manager dialog box, select Layout1, then click Modify.
6 In the Page Setup - Layout1 dialog box, specify the following value:

Paper size: ANSI C (22.00 x 17.00 Inches)
7 Click OK to exit the Page Setup Manager.
8 Click Close.
9 Respond to the prompt as follows:
   Specify insertion point: Enter -0.25,-0.75, press ENTER
10 In the Change Title Block Entry dialog box, click Next.
11 In the next page specify:
   File Name: InventorPart
Choose OK.

In the Save Title Block Filename dialog box, verify the following settings:
- **File Name:** InventorPart.dwg
- **File of Type:** Drawing (*.dwg)

Choose Save.

### Creating Drawing Views

You can create a variety of drawing view for a part. Any changes made to the part in Autodesk Inventor are automatically updated in the drawing views, when the .dwg file is updated.

When you create a drawing view, the link reads parametric dimensions from the model and adds them to the view.

To enable creation of parametric dimensions

1. Open the Options dialog box.
   - **Ribbon:** None ➤ None ➤
   - **Menu:** Tools ➤ Options
   - **Command:** OPTIONS or AMOPTIONS

2. Select the AM:Drawing tab.
3 Under Parametric Dimension Display, select the Active Part Views check box.

4 Choose OK.

To create a base view

1 Create a new drawing view
   Ribbon None
   Menu Drawing Default ➤ New View
   Browser Right-click a Layout icon in the Drawing tab, then choose New View.
   Command AMDWGVIEW

2 In the Create Drawing View dialog box, specify:
   View Type: Base
   Data Set: Select
   Layout: Layout1
   Orientation: Back
3 Choose OK.

4 Respond to the prompts as follows:

Specify location for base view:

Click in the lower left corner of the graphics area, press ENTER
The base view is placed in the lower-left corner of the drawing. Parametric dimensions extracted from the Inventor Part file are displayed.
Create an orthogonal view from the base view.

To create an orthogonal view type

1. Create a new drawing view.
   Ribbon None
   Menu Drawing Default ➤ New View
   Browser Right-click the Base icon in the Drawing tab, then choose New View.
   Context Menu Right-click in the graphics area, then choose New View.
   Command AMDWGVIEW

2. In the Create Drawing View dialog box, specify:
   View Type: Ortho
3 Choose OK.

4 Respond to the prompts as follows:
   Select parent view: Select the base view
   Specify location for orthogonal view:
      Drag to a location above the base view, click to select location
      Specify location for orthogonal view: Press ENTER
The view is placed in the upper-left corner of the drawing. Parametric dimensions read from the Autodesk Inventor part are displayed.

**Working with Dimensions**

Some of the dimensions need rearranging, while a few may be redundant. You may also need to create dimensions for some entities. Dimensions you add yourself are called reference dimensions. If the part is modified in Autodesk Inventor, these dimensions automatically display the correct part size.

**To delete a parametric dimension**

- In the orthogonal view, click the dimension that reads .0450 and press DELETE. The dimension is deleted.
NOTE The dimension you deleted may have been entered as a sketch dimension originally, and extruded later resulting in the redundancy of dimensions.

To move dimensions

1 Click the diameter dimension of 0.8800.

Three grip points are displayed on the dimension.

2 Drag the middle grip outside the bracket, and click. The dimension should be displayed as shown in the following image.
3 You may want to rearrange all the dimensions to tidy up the drawing view.

To add a hole note

1 Start the Leader note command.
   Ribbon

   Annotate tab ➤ Symbol panel ➤

388 | Chapter 19 Using Autodesk Inventor Link Support
2 Respond to the prompts as follows:

Select object to attach [rEorganize]:

_In the orthogonal view, click the center of the hole in the middle (1), drag to a placement point (2), click and press ENTER_

The Note Symbol ANSI dialog box is displayed.

3 Click OK. The Hole Note is added.

NOTE The note text is automatically generated with details extracted from the part file.

To create a vertical reference dimension

1 Start the power dimensioning command.

Ribbon

Annotate ➤ Dimension panel ➤ Working with Dimensions |

Menu Annotate ➤ Power Dimension

Command AMPOWERDIM

2 Respond to the prompts as follows:

Specify first extension line origin or [Linear/Angular/Radial/Baseline/ Chain/Options/Update] <select object>:

_In the orthogonal view, click the end points of the line, (1) and (2)_

Specify dimension arc line location:
Drag the dimension line to the right until it is highlighted in red and click (3)

3 In the Power Dimensioning dialog box, click OK.

4 Press ENTER twice to exit the command.

**NOTE** Parametric dimensions and reference dimensions are shown in different colors.

To create a radial reference dimension

1 Start the power dimensioning command.
   - **Ribbon**
     - Annotate tab ➤ Dimension panel ➤
   - **Menu**
     - Annotate ➤ Power Dimension
   - **Command**
     - AMPOWERDIM

2 Respond to the prompts as follows:
   - Specify first extension line origin or
     - [Linear/Angular/Radial/Baseline/ Chain/Options/Update] <select object>: Press ENTER
   - Select arc, circle, line or dimension:
In the base view, click the circle indicating the hole (1), drag the dimension to a placement point (2) and click.

3 In the Power Dimensioning dialog box, click OK.

4 Press ENTER twice to exit the command.

Exporting Drawing Views to AutoCAD

It is possible to export a drawing view of a linked drawing such that it can be viewed in AutoCAD® or AutoCAD® LT.

To export a drawing view

1 Start the Export Views command.

   | Ribbon | None |
   | Menu   | Does not exist in the Menu. |
   | Browser | Right-click the Base icon in the Drawing tab, then choose Export. |
   | Command | AMVIEWOUT |

2 In the Export Drawing Views dialog box, from the Source drop-down list, select Select Views/Entities, then click Select.
The dialog box hides.

3 Respond to the prompts:
   Select objects to export <all views>: Select the base view
   Select objects to export <all views>: Press ENTER
   You are returned to the Export Drawing Views dialog box.

4 In the File Name box, enter the name of a drawing file to export to.
5 Click OK.
6 Save the file.
7 Close AutoCAD Mechanical, start AutoCAD and open the file that you created in step 5.

**Linking Autodesk Inventor Assembly Files**

To link an Autodesk Inventor assembly file
   1 Open the assembly file.
2 In the Select template dialog box, select the template \textit{am\_ansi.dwt}, then click Open.

3 Locate and select \textit{Bracket.iam}, then click Open.

To shade and rotate the assembly

1 Right-click the assembly name in the Mechanical Browser and select Shade.

2 Right-click the assembly name in the Mechanical Browser and select 3D orbit.

3 Place the cursor in the appropriate location inside or on the Arcball.

4 Click and hold the left mouse button, then rotate the part to a position that resembles the following illustration.
**Accessing Parts from the Browser**

To select a part from the browser

1. Click a part in the Mechanical Browser. The part is highlighted in model space.
2. Right-click a part and select Zoom-to. The display zooms to the part.

**Accessing iProperties**

When the assembly file is linked, Attached Mechanical is able to access iProperties through its Bill of Materials (BOM).

To access iProperties

1. Start the BOM Database command.
   - **Ribbon**: Annotate tab ➤ BOM panel ➤
   - **Menu**: Annotate ➤ BOM Database
   - **Command**: AMBOM

2. Respond to the prompts as follows:
   - Specify BOM to create or set current [Main/?] <MAIN>: Press ENTER
   - The BOM dialog box is displayed.
3 Click the + sign in the first column to expand the row.

4 Click Settings. The BOM Settings dialog box is displayed.
5 Click the More button to display More Properties dialog box.

6 Select Part Number and click OK. You are returned to the BOM dialog box. Notice the additional row at the bottom of the Available component properties list.
Click OK. The BOM Settings dialog box closes and the BOM dialog box becomes accessible again.

In the BOM dialog box, use the horizontal scroll bar to inspect the columns in the extreme right.
Note how the iProperty Part Number is listed and automatically filled with data from the Inventor assembly file.

Save the file as **Inventor Assembly.dwg**.

**Inserting Drawing Borders**

**To insert a drawing border**

1. Click the Drawing tab in the Mechanical Browser.
2. Start the Drawing Title/Borders command.

**Ribbon**

- Annotate tab ➤ Layout panel ➤ 

**Menu**

- Annotate ➤ Drawing Title and Revision ➤ Drawing Title/Borders...
Command AMTITLE

3 In the Drawing Borders with Title Block dialog box, specify:
   Paper Format: C (17.0x22.0 inch)
   Title Block: US Title Block
   Scale: 1:1
   Retrieve from Assembly Properties: Select

4 Click OK.

5 In the Page Setup Manager dialog box, select Layout1, then click Modify.

6 In the Page Setup - Layout1 dialog box, specify the following value:
   Paper size: ANSI C (22.00 x 17.00 Inches)

7 Choose OK to exit the Page Setup Manager.

8 Click Close.

9 Respond to the prompt as follows:
   Specify insertion point: Enter -0.25,-0.75, press ENTER

10 In the Change Title Block Entry dialog box click Next.

11 In the Drawing Title box, type Adjustable Bracket.

12 Click OK.

398 | Chapter 19  Using Autodesk Inventor Link Support
Creating Parts Lists and Balloons

You can create a variety of drawing view types for a part, but you must create a base view first. Subsequent changes made to the assembly file in Autodesk Inventor are automatically updated in the drawing views when the drawing file is updated.

To create a base view

1. Create a new drawing view.
   - **Ribbon**: None
   - **Menu**: Drawing Default ➤ New View
   - **Browser**: Right-click a Layout icon in the Drawing tab, then choose New View.
   - **Command**: AMDWGVIEW

2. In the Create Drawing View dialog box, specify:
   - **View Type**: Base
   - **Data Set**: Select
   - **Layout**: Layout1
   - **Orientation**: Top
   - **Scale**: 2.0000

3. Click OK.

4. Respond to the prompts as follows:
   - Specify location for base view:
     - *Click in the lower left corner of the graphics area, press ENTER*
To create the parts list

1. Start the Parts List command.
   
   **Ribbon**
   
   Annotate tab ➔ Table panel ➔

   **Menu**
   
   Annotate ➔ Parts List

   **Command**
   
   AMPARTLIST

   The Part List ANSI dialog box is displayed.

2. Click OK.

3. Move the cursor to position the parts lists above the title block, then click to insert the parts list.
To create balloons

1. Start the Balloons command..

Ribbon

Annotate tab ➤ Balloon panel ➤

Menu

Annotate ➤ Balloons

Command

AMBALLOON

2. Respond to the prompt as follows:

Select part/assembly or
.auTo/autoAll/Collect/Manual/One/Renumber/rEorganize]: Enter A

Select pick object: Window select the entire assembly

Select pick object: Press ENTER

3. Place the balloons horizontally above the assembly.
Creating Breakout Section Views

A breakout section view shows hidden details by cutting away portions that block their visibility. In this exercise, you indicate the section to remove by creating a cut line on one view and marking the depth of the cut on another view. Once the breakout section view is generated, you create an isometric view for it.

To create the base view and orthogonal view:

1. Click the Drawing tab in the browser and double-click Layout 2.
2. Start the Drawing Title/Borders command.

   **Ribbon**
   - Annotate tab ➤ Layout panel ➤

   **Menu**
   - Annotate ➤ Drawing Title and Revision ➤ Drawing Title/Borders...

   **Command**
   - AMTITLE

The Drawing Borders with Title Block dialog box is displayed.
3 Create a new drawing border for Layout2, following the procedure outlined in Inserting Drawing Borders on page 376.

To create a base view and orthogonal view

1 Create a new drawing view.
   Ribbon None
   Menu Drawing Default ➤ New View
   Browser Right-click the Layout2 icon in the Drawing tab, then choose New View.
   Command AMDWGVVIEW

2 In the Create Drawing View dialog box, specify:
   View Type: Multiple
   Data Set: Select
   Layout: Layout2
   Scale: 1.5
   Display Hidden Lines: Clear the check box

3 Choose OK.

4 Respond to the prompt as follows:
   Select planar face, work plane or
   [sTandard view/Ucs/View/worldXy/worldYz/worldZx]: Enter X
   Select work axis, straight edge or [worldX/worldY/worldZ]: Enter X
   Adjust orientation [Flip/Rotate] <Accept>: Press ENTER
   Specify location of base view:
   Position the view in the lower left corner of the graphics area and click
   Specify location of base view or [Done] <next view>: Press ENTER
   Specify location of projected view or [New parent view]:
   Drag to a location above the base view, click to select location
   Specify location of projected view or [Done] <next view>: Press ENTER
   Specify location of projected view or [New parent view]: Press ENTER
To create the cut line:

1. Start the polyline command.
   - **Ribbon:** Home tab ➤ Draw panel ➤ Polyline
   - **Menu:** Draw ➤ Polyline
   - **Command:** PLINE

2. Respond to the prompts as follows:
   - Specify start point: **Click point (1)**
   - Specify next point or [Arc/Halfwidth/Length/Undo/Width]: **Click point (2)**
   - Specify next point or [Arc/Halfwidth/Length/Undo/Width]: **Click point (3)**
   - Specify next point or [Arc/Halfwidth/Length/Undo/Width]:
   - **Enter close, press ENTER**
   - A closed polyline is created.
To create a breakout section view

1. Create a base view type.
   - **Ribbon**: None
   - **Menu**: Drawing Default ➤ New View
   - **Browser**: Right-click the Ortho icon in the Drawing tab, then choose New View.
   - **Context Menu**: Right-click in the graphics area, then choose New View.
   - **Command**: AMDWGVIEW

2. In the Create Drawing View dialog box, specify:
   - **View Type**: Base

3. On the Section Tab, specify
   - **Type**: Breakout
   - **Hatch**: Selected

4. Click OK.
5 Respond to the prompts:

Select first parent view for breakout view:

Select the orthogonal view

Specify location of base view:

Drag just above the base view, click to select the location, press ENTER

Select polyline to use as cutline:

Click the polyline you created in the previous exercise (1)

Select second parent view for depth selection:

Select the base view (2)

Select point for depth of section: Select point (3)

The breakout section view is created.
To create an isometric view of the breakout section view:

1. Create an isometric view type.
   - **Ribbon**: None
   - **Menu**: Drawing Default ➤ New View
   - **Browser**: Right-click the Section icon in the Drawing tab, then choose New View.
   - **Context Menu**: Right-click in the graphics area, then choose New View.
   - **Command**: AMDWGVIEW

2. In the Create Drawing View dialog box, specify:
   - **View Type**: Iso

3. Choose OK.

4. Respond to the prompts:
   - **Select parent view**: Select the breakout section view
   - **Specify location of base view**
Drag to the left of the orthogonal view, click, and press ENTER

NOTE The details shown in the view that is generated depend on where you place the view. When you drag to the left, the isometric view that is generated reveals a hole and a screw. They would not be visible if you placed the view elsewhere.

The isometric view is created.

5 Move the isometric view to the right of the orthogonal view.
   Ribbon None
   Menu Drawing Default ➤ Move View
   Browser In the Drawing tab, right-click the Iso icon, then choose Move.
   Context Menu Right-click in the graphics area, then choose Move View.
   Command AMMOVEVIEW

6 Respond to the prompts:
   Select view to move: Select the isometric view
Specify new view location:

Drag to the right of the orthogonal view, click, and press ENTER

---

Modifying Breakout Section Views

The cut line used to generate the breakout section view can be modified and breakout section view regenerated. Under normal circumstances, the cut line is not visible. To modify the cut line, you must display it first.

To display the cutline:

   - **Browser**: Right-click the Section icon in the Drawing tab, then choose Re-Select Cutline.
   - **Command**: AMEDITPSCUTLINE

2. Respond to the prompts:
   - **Select broken-out section view**: Click the breakout section view
Enter an option for paperspace cutline [Display/Select] <Display>:

Press ENTER
The cut line is displayed.

3 Modify the cutline to any shape you want it to be.

4 Start the Edit Paper Space Cut Line command.
   Browser Right-click the Section icon in the Drawing tab, and then choose Re-Select Cutline.
   Command AMEDITPSCUTLINE

5 Respond to the prompts.
   Select broken-out section view: Click the breakout section view
   Enter an option for paperspace cutline [Display/Select] <Display>:
   **Enter S**
   Select polyline to use as cutline: Click the edited polyline
   The breakout section view and the isometric view update.
Removing Views

You can remove views, even though that view may have been used to derive other views.

To delete the base view:

1. Right-click the base view icon in the browser and select Delete. The Delete dependent views dialog box is displayed.
2. Click No. The base view is deleted.
3. Save the file and close AutoCAD Mechanical.

Updating Autodesk Inventor Parts

If you have access to Autodesk Inventor (version 8 or above), you can modify the part file using Autodesk Inventor, then update the part in AutoCAD Mechanical to reflect the change.
To edit a dimension using Autodesk Inventor

1. Open Holder Bracket.ipt in Autodesk Inventor.
2. Edit a feature.
3. Save the modified part file.

When the part file has been modified outside AutoCAD Mechanical, on the browser, the affected views are highlighted in yellow. Additionally, a balloon is displayed on the status bar informing you that a newer version is now available. To bring in the modifications, you must update the part file.

To update the part file

1. Use AutoCAD Mechanical to open the Assembly file or Part file that was used in this exercise.
2. Observe how the browser indicates the parts and views affected by the part modification.
3. Start the update command.
   **Browser** Right-click the yellow part node, then choose Update.
   **Command** AMIVUPDATE
4. Verify that your part has been modified.
   You are notified of the number of drawing views that have been updated.
   Save your file. This is the end of this tutorial chapter.
Index

A
acceleration 353
angular dimensions 151
annotation views 53, 92
associative
hide 95
views 139
Autodesk Inventor link option 374
Autodesk Inventor linked models
base views 381, 399
breakout section views 402, 405
isometric views 407
multiple views 402
orthogonal views 384
shade and rotate 376, 393
update 412
Automatic Dimensioning dialog box 145
automatic dimensions 145

B
balloons 215, 221, 401
base layers 45, 125
base views
for assembly files 399
for part files 381
baseline dimensions 143
Beam Calculation dialog box 290
bearing calculations 247, 264
Belleville spring washers 309
Belt and Chain Length Calculation dialog box 297
bending moments 269, 285
bills of material 215
blind holes 204
BOM databases 215, 222
border conditions in stress calculations 342
break dimensions 153
breakout section views, assembly files 402, 405
breaks in shafts 258
browser
mechanical 53

calculations on bearings 264
Cam Design and Calculation dialog box 355, 358, 365, 368
cams 353
centerlines 143, 209
centroids 288
chains 306
calculations 295
length calculations 297
partitions 295
pitch diameters 295
roller 295
sprockets 295
chamfers 247, 257
Change Title Block Entry dialog box 379, 398
command summary 13
components
external reference 84, 89, 91
externalize local 91
ghost 82
insert views of external 86
mechanical structure 53
mechanical structure folders 53
restructure 83
view 64
compression springs 309
construction lines 101, 105, 175, 210
Construction Lines dialog box 106
contact areas in screw calculations 332
contours
backgrounds and foregrounds 159, 175
hatch patterns 116
lines 106
countersinks 175
Create Drawing View dialog box 381, 384, 399, 403, 405, 407
cross-hatches 116
curve paths on cams 353
custom filters for parts lists 245
cutlines 404
cylinders in shafts 252

D
deflection lines 269, 285, 289
detail views 101, 119, 125, 129
deviations to dimensions 118
dialog boxes
 Automatic Dimensioning 145
Beam Calculation 290
Belt and Chain Length Calculation 297
Cam Design and Calculation 355
Change Title Block Entry 379, 398
Construction Lines 106
Create Drawing View 381
Create Drawing View 384, 399, 403, 405, 407
Detail 120
Drawing Borders with Title Block 154, 398
Drawing Borders with Title Block 377
Edit Attributes 155
Export Drawing Views 391
FEA 2D Calculation 342
FEA 2D Isolines (Isoarears) 345
FEA Configuration 342
Fillet Radius 112
Gear 276
Layer Control 139
List of Filters 243
Material 273
Material Properties 274
Material Type 290
Nominal Diameter 135
Options 46, 380
Page Setup Manager 377, 398
Page Setup-Layout 378, 398
Part Ref Attributes 218, 220, 226
Parts List 230
Point Load 276
Power Dimensioning 118, 122, 137, 143
Power Snap Settings 105, 250
Pulleys and Sprockets 302
Save Drawing As 48
Save Title Block Filename 380
Scale Area 128
Screw Assembly Grip Representation - Front View 183
Screw Assembly Templates 191
Screw Calculation 325
Screw Connection New Part Front View 196
Screw Diameter Estimation 192
Select a Blind Hole 205
Select a Cylindrical Pin 207
Select a Nut 328
Select a Row 326
Select a Screw 179, 326
Select Graph 278, 292
Select Part Size 209, 298
Select Template 102, 248, 374, 393
Set Value 232, 241
Shaft Calculation 272
Shaft Generator 251
Sort 239
Switch Representation of Standard Parts 212
Template Description 49
Torque 277
Type of Follower 356
View 131, 139
dimensions
angular 151
automatic 145
baseline 143
breaks 153
contours 117
deviations 118
multi edit 143, 152
parametric 380, 386
radial 390
reference 389
distance snaps 101
distributed loads 285, 339
drawing borders 154, 376, 397
Drawing Borders with Title Block dialog box 154, 377, 398
drawing views 380, 399
  export to AutoCAD 391
  insert drawing borders 376, 397
drawings
  borders 143
  default templates 51
  layers 46
  limits 46–47
  new 50
  templates 45, 48
durability calculations 340
dynamic calculations 247
dynamic dragging 175, 247, 309

E
Edit Attributes dialog box 155
Export Drawing Views dialog box 391
export drawing views to AutoCAD 391
extension springs 309
external reference components 84, 89, 91

F
fatigue factors 269
FEA (Finite Element Analysis) 339
FEA 2D Calculation dialog box 342
FEA 2D Isolines (Isoareas) dialog box 345
FEA Configuration dialog box 342
Fillet Radius dialog box 112
fillets 112, 247
filters for parts lists 243, 245
finite element analysis (FEA) 339
fits 143, 152
fits lists 156
fixed supports 269, 285, 339, 343
fixed supports on shafts 275
folders
  instances of 58
  mechanical structure 53, 73
  modify 56

G
Gear dialog box 276
gears 248, 269
general structures 54
ghost components 82

H
hatch patterns 116
hidden lines 159
hide situations
  associative 95
  in mechanical structure 95
holes
  add notes 388
  blind 204
  countersunk 175

I
instances
  compared to occurrences 61
  in mechanical structure 54
  isoareas in calculations 345
  isolines in stress calculations 345

L
Layer Control dialog box 139
layer groups 45, 125
layouts 125–126
leaders 227, 236
length calculations for chains 297
libraries for storage 102
lines
  deflection 269, 289
List of Filters dialog box 243
load calculations 269, 285, 333, 339
M
Material dialog box 273
Material Properties dialog box 274
material properties for screws 326
Material Type dialog box 290
mechanical browser 53, 74
restructure 78
usage with Bill of Materials 76
mechanical options 46
mechanical structure 53–54
enable 55, 249
folders 53, 56
hide situations 95
mesh in stress calculations 345–346
model space 126, 132
module values in shafts 253
moments of inertia 285
motion diagrams for cams 353
movable supports 269, 286, 339, 343
movable supports on shafts 275
multi edit dimensions 143, 152

N
NC (numerical control) 353
Nominal Diameter dialog box 135
notches and stress calculations 269
numerical control (NC) 353

O
object snaps 104
objects
  mechanical structure 54
occurrences
  compared with instances 61
  in mechanical structure 54
Options dialog box 46
orthogonal views for part files 384

P
Page Setup - Layout dialog box 378, 398
Page Setup Manager dialog box 377, 398
part information 217
Part Ref Attributes dialog box 218, 220, 226
part references 215, 217
partitions in chains 295
parts layers 45
Parts List dialog box 230
parts lists 227
  defined 216
  filters 243
  merge rows 233
  sort 238
  split rows 234
pins 207
pitch diameters in chains 295
point forces 270, 286
Point Load dialog box 276
polylines 110
power commands 102, 167
Power Copy 176, 184, 309
Power Dimensioning 102, 126, 143
Power Dimensioning dialog box 118,
  122, 137
Power Edit 176, 195, 309, 339, 348
Power Erase 144, 176, 201, 235
Power Recall 176
Power Snap Settings dialog box 105, 250
Power View 176, 198, 320
precision in dimensions 118
profiles in shafts 256
property class for screws 327
Pulleys and Sprockets dialog box 302
radial dimensions 390
radius reflection lines 248
reference dimensions 389
representations of standard parts 176,
  211
resolution in cam calculations 353
restructure components 83
result blocks in screw calculations 338
roller chains 295
rotate tool 376, 393
S

Save Drawing As dialog box 48
Save Title Block Filename dialog box 380
Scale Area dialog box 128
scale areas 126–127
scale monitors 126
Screw Assembly Grip Representation - Front View dialog box 183
Screw Assembly Templates dialog box 191
Screw Calculation dialog box 325
Screw Connection dialog box 178, 188, 192
Screw Connection New Part Front View dialog box 196
Screw Diameter Estimation dialog box 192
screws
  calculations 323
  connections 323
  contact areas 332
  loads and bending moments 333
  material properties 326
  precalculations 192
  property class 327
  result blocks 338
  settlement properties 335
  stand-alone calculations 324
  templates 186
  tightening properties 336
  washers 329
Select a Blind Hole dialog box 205
Select a Cylindrical Pin dialog box 207
Select a Nut dialog box 328
Select a Row dialog box 326
Select a Screw dialog box 179, 326
Select Graph dialog box 278, 292
Select Part Size dialog box 209, 298
Select Template dialog box 102, 248, 374, 393
Set Value dialog box 232, 241
settlement properties in screw calculations 335
Shaft Calculation dialog box 272
Shaft Generator dialog box 251
shafts
  breaks 248, 258
  calculations 270, 278
  cylinders 252
  generator 248, 270
  module values 253
  profiles 256
  side views 259
  slopes 261
  threads 259
  slopes on shafts 261
  snap distance for balloons 227
  snap settings 104–105
  Sort dialog box 239
  sort parts lists 238
springs
  Belleville 309
  calculations 309–310, 313
  compression 309
  extension 309
  layouts 313
  torsion 309
  sprockets 295, 302
  stability calculations 340
  standard parts 176
  steel shapes 159, 164, 167
  step width in cam calculations 354
  Strength Calculation dialog box 281
  strength calculations for shafts 270, 280
  stress calculations 270, 339
  stress divisions 349
  stress representations 347
  stress tables 346
  stress yield points 270
  supports 269
  Switch Representation of Standard Parts dialog box 212
T
tangent definitions for chains 299
Template Description dialog box 49
templates, drawings 45, 48, 51
threads on shafts 259
tightening properties in screw calculations 336
title blocks  144
tolerances  118, 144
Torque dialog box  277
torsion springs  309
tracking lines  227
trims  114
Type of Follower dialog box  356

V
view components  64
View dialog box  131, 139
viewports  126, 129
views
  annotation  92
  associative  139
  base  399
  breakout section  402
detail  101, 129
drawing  380, 399

W
isometric  407
multiple for assembly files  402
orthogonal  384
scales  126
sides of shafts  259

W
washers  329
working layers  45, 126

X
xref components  84, 89, 91

Y
yield points of stress  270