Autodesk® Vault Professional® SolidWorks Integration

SolidWorks Advanced Property Mapping

In SolidWorks basic property basic mapping we looked at how to map a SolidWorks file property to a Vault
property for the purpose of viewing thumbnails and assigning items to files.

In advanced property mapping we will now look at how to write Vault properties back to the CAD file and display
these.

Displaying Revision on Drawing
One of the most typical requirements in any implementation is the ability to manage document release and
revisions. As part of this, displaying the system managed revision on design documents is fundamental.

In the following example users should make these adjustments to their SolidWorks template files for consistent
behavior.

Create Custom Revision Property
From the CAD file, we need to add a custom property

. From the File menu select properties
e In the Summary Information tab select “Custom” and add a new property
e Select Revision from the drop down menu, set the type as Text

-
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e Enter an initial value for the property (“A”, “1” or “-)

Summary Information EI
Summary | Custom
BOM gquantity:
Delete - Edit List
Property Name Type Value | Text Expression Evaluated Value

1 |SWFormatSize Text |=|| 16.54n*23.35in 16.54in*23. 35in

2 | Revision Text x| A A

k] ATarmm = s e

e If you are using a standard SolidWorks drawing title block should now display your initial value in the

Revision field
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Map Vault Revision Property
Return to Vault Explorer and open the property definitions dialog from Tools > Administration > Vault Settings

e Go to the Behaviors tab and select Properties

Properties

| ] Edit and Manage Properties

—
—r

Properties... ]

[
| DataCard.. |
l

Revision Table... ]

e From the property list highlight the “Revision” property and select “Edit”.

l Property Definitions
iﬂm =] Ed'ﬂ... |3 EEIEtE | get Usage Counts
"@ Property Name /| Data Type State Usage i
% Released Revision Boolean (True or False) "@
| Rev Number Text T Enabled
\% Review Status Boolean (True or False)

% Revision Scheme

=N -~ e . e o, | I—

e On the edit dialog select the mapping tab and “Add” mapping



AUTODESK VAULT PROFESSIONAL SOLIDWORKS INTEGRATION PROPERTY MAPPING ADVANCED

o Select “File” as entity and for the property provider SolidWorksPropertyProvider

ﬁ Usage =

MName: Revision
Type: | Text - |
Associations: |File, Trem -]

Settings | Mapping

a

Create

Provider File Property Type Classification ~ Mapping
éOther H [ W o

Inventor DWG (*.dwg)
Office 97-2003 Documents (*.doc;*.dot; * xs;* .dt; *.ppt; *.pot)

Office Documents (*.dooy;*.docm; *.dobe;™.dotm; ™ xdbg = .xltm; * xds * . xlsm; * xisb; *.pobe; . ppby; *. pptm; *. potm)
Revit (*.rfa;*.rvt; *.rte; *.adsk)
Sheet Set Data (*.dss; *.dsu;*.dsh)
SoIidWorksProp*'r_yF'rovider (*.sldprt;*.sldasm; *.slddrw)
Other Files (*.*)

[

m

e From file properties select “Import from Vault” or “Import from file” — if you have not yet loaded the
SolidWorks drawing into your Vault select “Import from file” for this first step.

e You will now be prompted to search your local drive for a supported SolidWorks file type

e Picking the modified drawing file you should now see the SolidWorks custom property “Revision”

. Edit (System) - Revision =]

Mame: Revision

Type: |Te:d: hd |

Associations: |File, Trem [~]

=
™

Entity Provider File Property Type Classification ~ Mapping Create

Mre  sohdwor.

Pr ies -+

Property / Data Type Classification Source

AUTHOR Text None Adsk-00000...
COMMENT | Text None Adsk-00000...
KEYWORDS | Text None Adsk-00000...

» F:ewon Standard Adsk-00000...
SAVEDBY |Text Mone Adsk-00000...
SUBJECT |Text Mone Adsk-00000...
SWForm... |Text Standard Adsk-00000...
TITLE Text None Adsk-00000...
UNIT_OF... |Text Standard Adsk-00000...

oKk || Cancel |
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e Select OK to save and complete the property mapping

g Edit (System) - Revision
Name: Revizion

Type: Text

Associations: | File, Trem

Entity Provider File Property

SolidWor... Revision

Classification  Mapping

Standard = ] H No

Create

Note that this system property is restricted to a one directional relationship from Vault to the File as Vault will

now control the revision.

e Your SolidWorks file should now display the Vault Revision.

Change Document Revision

Highlight a drawing file (slddrw) in Vault Explorer and from Vault the Vault Explorer menu bar select “Revise”

¢ Inthe revise dialog make sure the document is selected and from the Revision pull down menu select
“Primary” — the revision will now bump to the next value.

F-

¥ Revise - 'Adsk-000000.slddrw’

Adsk-000000.... B

e Select OK to close the dialog.

Revise from: Latest (Mon-Released Biased)
Select next revision: |§Primarj.r |"| ’ ]
Name Revision Revision Definition

Standard Alphabetic F...

e Looking at the Vault properties for the file we can see that there is now a “Non-Compliance” on Revision

T 3742

Fdise
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& Equivalence Error

Not equivalent with 'Revision’
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Work in Progress
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e To update the file property we can either sync properties from Vault Explorer or Update properties from
inside Solidworks

e To update from Vault Explorer, highlight the file and select “Synchronize Properties” from the Actions
Menu

e To update from SolidWorks, return to SolidWorks and open the slddrw file from Vault

[E=8|E=E =<
Landing Gear Q-
Folders Filename 4 Revision State Check in date Com

=-E Project Explorer (8)

B Adsk-DDD000.slddrw B Work in Progress  Administrator

-] Contert Certer Files
E‘E Designs % landing_gear sldasm Work in Progress | Administrator | 4/2/2014 546:42PM AL
@-E] Gipper 1, | wrsway_Ink sldprt B Work in Progress | Administrator | 3/26/2014 10:52:59 AM | A...

e After opening select “Update Properties” from the Vault tab

= vr\”_ng - B & E- Adsk-000000 - Sheetl

Ef Undo Chedk Out o ] vﬁt
heck [& Show Details Change Get Revise Manage Go to
Jut g Pri fies | State  Revision COwenershi Worl ce
Vault Options Pt . kspa -
Vaut aaNg®d -
¥ Get Latest Properties - Adsk-000000.slddrw o[ B[]
MName Rewvision State i
=1}
E-[¥] 7] Designs
2-[7]F] Landing Gear
Adsk-000000... B Work in Progress
% landing_gear.sl... B Work in Progress =
: ﬂ?cl upprsway In._. B Work in Progress

e The file will be checked out and updated and you should now see the new Revison value in the title

block
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Bidirectional Custom Property Mapping

As well as mapping system properties it is common for user to create User Defined Properties which can be
mapped to Vault allowing users to populate the field from a CAD document and then edit in Vault and write back
to the CAD file.

There are many examples of these but they often include properties such as Part Number, Title, Description,
Project, Department etc.

For more information on User Defined Properties and Property Mapping please see Vault help.

Create Custom Properties in SolidWorks file
As we did in the last example, open a SolidWorks file and from the File menu select “Properties”

e  From the summary tab create your new custom SolidWorks properties

Summary Information EI @
EEE Custom | Configuration Specific
BOM quantity:
Delete -none - - Edit List
Property Name Type Value [ Text Expression Evaluated Value

1 |Partho Text || EXT-1100000-5C EXT-1100000-5C

2 |Description Text = || External Retaining Plate External Retaining Plate

3 |Project Text | || Redesign Roll Assembly Redesign Roll Assembly

4 | <Type a new property > = ﬂ

Make sure you provide an initial value for the properties

e Return to Vault Explorer, from the Tools menu select Administration and “Vault Settings”.

e On the behaviors tab select the properties section.

e Here we can either select to map our SolidWorks custom properties to an existing UDP or create a new
one

e To create a new User Defined Property select “New” from the menu at the top

. Property Definitions @

=i New... g Edit... | # Delete | Get Usage Counts

5 Property Name Data Type State Usage
| Checked Out Date T
il Charkad Mot B Tawvt i =

¢ The new property dialog will appear — enter a name and type, select to make this a file property

. New (Property) @

MNarme: Project

Type: [Tex‘t hd l

Aszociations: | | "|

Settings Mappmg
Property values: Cateqory values: |
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e Under the association select the categories you require

¥ New (Property) 553
Narme: Project
Type: ’Tmrt v]
Associations:  |File | v|
—I:Settings = M Change Drer &
[Clcustom Object
Property valu| :-["|Base alues:
MName Fillél Value Ove... *
- Base
p State ) ) Category: Engineering
- [¥|Engineering
Basic Sez [ office rce List ... |False E
Initial Va [Fstandard = ||juires value |False
List Value V15w ASM Sensitivity| None E
Enforce L| [¥]SwX DRW mum Len...
Requires []sw PRT imum Le.
Case Ser| []Folder Cataanrus SWY AGM

Note, for more details on categories and property association, please see Vault help

e Under settings configure your property behavior (Minimum and maximum lengths, required or not, case

sensitive and even predefined lists or default values)

Property values:

Category values:

Value

Name

Name

= File Category: E

Value

ngineering

»

Basic Search f—k Searched »  |Enforce List ... |False E

Initial Value Requires Value | False

List Values Case Sensitivity| None £
Enforce List Of Va... | False Minimum Len...

Requires Value False Maximum Le...

Case Sensitivity | None = File Category: SWX ASM

Mini.mum Length Enforce List ... |False I
Maximum Length Requires Value | False

Case Sensitivity

Mone

Minimum Len...

Maximum Le...

= File Category: SWX DRW
Enforce List ... |False |

Note that property behavior can be set for all category types or overridden. For more information on property
setting and property compliance please see Vault help.

e Onthe Mapping tab — select once again file mapping, the content source provider as
SolidWorksPropertyProvider

e Select to Import properties from file and select the file with the newly added Custom Properties
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e  From the list now select the correct Custom Property for mapping

[ M New Proper) [&=]
l\.lam\;.h Project
Type: ’Tﬂ‘l V]
Associations: |File |~

Settings | Mapping

Entity Provider File Property Type Classification ~ Mapping Create

 ENCTT S S N

-

Property / Data Type Classification Source

Description | Text Standard Adsk-0000...
KEYWOR... | Text Mone Adsk-0000...
PartMo Text Standard Adsk-0000...
: Standard  Adsk-0000...
SaveDate |Date Mone Adsk-0000...
SAVEDBY |Text Mone Adsk-0000... | =
SUBJECT |Text Mone Adsk-0000...
TITLE Text Mone Adsk-0000...
UNIT_O... |Text Standard Adsk-0000... | |
oK || cancel |

e Select the mapping option — here we are selecting bi-directional so we can edit the property in Vault or

CAD
Name: Project
Type: [Teu‘l v]
Associations: |File |~

Provider File Property Classification ~ Mapping Create
Solidwor...  Project Standard EI | H No

e Select OK to save your new property with its settings and CAD mapping.
e Return to SolidWorks and Add your file to Vault using Check In
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e You will now see the newly created User Defined Property with the Correct SWX Custom Property

ElI User Defined =
Author
Company
Part Number

Project

Edit a User Define Property
Once the property is mapped and the file added to Vault we are able to edit this directly inside Vault Explorer

e From Vault Explorer, select one or more files and from the Edit menu click on “Edit File Properties”
e The edit file properties dialog comes up with a property set ready to edit for the selected files, users can
add or remove properties from this grid that they wish to modify

W ropetyece

Add - [ "L Remove | [l Select Properties... ab
D Mame Project Author
b 7, Adsk-000003.sldprt Redesign Roll Assembly |

e  Enter the new property values

(W eoperyecc

Add ~ [ 'L Remove | ] Select Properties... gt
D Mame Project Author
I l’i&| Adsk-000003.sldprt Standard Assembly Components i

e You will now see the property edit results

Property Success Original Value New Value Reason
» = Name: Adsk-000003.sldprt
Project Redesign Roll Assembly Standard Assembly Comp... | Successfully updated
) s = . Successfully updated from
File Property: Project Redesign Roll Assembly Standard Assembly Comp... vault property "Project’

Note that the results of the edit properties can be output to a report or saved to Vault
e Hit close to continue and you will see the User Defined property is updated

=l User Defined
Author
Company
Fart Mumber
Project :Standard Assembly Components

m
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e  Open your file again from SolidWorks and you will see the Custom Property has updated

Summary Information EIIEI
Custom | Corfiguration Specific
BOM quantity:
Delete by none | - Edit List
Property Name Type Value [ Text Expression Evaluated Value
1 |Partio Text ||| EXT-1100000-5C EXT-1100000-5C
2 | Description Text | = || External Retaining Plate External Retaining Plate
3 |Project Text | = || Standard Assembly Components Standard Assembly Component|
4 | <Type a new property> B4

See the Vault help for more information on creating user defined properties, mapping and editing properties.
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