
Assembly Bill of Materials, R10

In This Exercise
This Skill Builder demonstrates how to create and 
manage the structure of bill of materials in an 
assembly.

BOM Structure
BOM is an assembly database containing 
component properties and information used to 
generate reports for EDM and Parts Lists.

BOM structure introduced in Inventor R10 
controls the bill of materials visibility in the BOM 
concept and provides an idea of the intent of a 
component in the design process. It provides 
management of component properties in several 
types of assemblies.

BOM structure addresses several key areas:

■ Component identification (Normal, Phantom, Purchase, Reference, Inseparable)
■ Virtual components 
■ Component equivalency
■ Quantity overrides & changes to quantity formatting
■ BOM property override

BOM Structure Parameters
The BOM structure attribute is used to communicate the property for a component. Each component has a 
predefined property assigned in the design intent. BOM structure in Inventor is defined into five different 
characteristics: Normal, Inseparable, Purchased, Phantom and Reference.

If you have Autodesk Inventor R10, you can find the Test Station assembly in the sample folder.
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The Test Station assembly below demonstrates the use of the assembly BOM structure functionality.

1. Set the current project to samples.

2. Browse to Assemblies >Test Station, and then open Test Station.iam.

3. From the drop-down menu, click Tools > Bill of Materials to display the Bill of Materials dialog box.     
Review the different BOM structure properties.
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4. Switch between the Display Model Structure and Display BOM Structure modes to view the model 
structure and BOM structure. To edit the quantity for the components, you switch to Display Model 
Structure.

5. To reorder the structure of parts and assemblies, you select a single or multiple components, drag and 
drop the selected items to the required position. 

6. You can renumber the reordered items by clicking the Renumber Items tool in the BOM editor. The 
selected items are renumbered to a sequential order begins by 1 in the list.

TIP Items renumbering can only be carried out in the Display BOM Structure mode when the Structured 
or Parts-only view is visible.
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7.    Click once on the Item heading to sort all items in ascending order. Click once again to sort in 
descending order.

8. Click the BOM Structure heading to sort the components with identical BOM Structure settings.

TIP You can also reposition the title headings by dragging the cell and drop it to the appropriate location.
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This assembly makes use of Normal, Reference, Purchased, Phantom and Inseparable components.

Normal components
Normal is the default BOM Structure for the components. Normal components have the following 
characteristics:

■ The parent assembly determines their placement in the BOM. 
■ They are numbered and included in quantity calculations.
■ They have no direct influence on their child components participation in the BOM.

Notice the assemblies M178-1000, M178-2000 and M178-3000 are normal. In the browser, right click to 
open the assembly M178-1000:1, and then select the Bill of Materials tool in the assembly panel.
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Inseparable components
Inseparable components are assemblies of multiple components that must be physically damaged to 
separate the parts. They are generally fabricated, not purchased.

Inseparable assemblies are treated like parts in the Parts-Only view. The assembly’s children are not 
included in the BOM.

Examples of inseparable assemblies are:

■ Weldments in assemblies that are glued or bonded.
■ Riveted components fastened together with semi-permanent fasteners that must be destroyed to 

separate the components.
■ Assemblies where components have been pressed fit together, such as dowel pins pressed into a 

part.

Click Display BOM Structure in the Bill of Materials dialog box, notice M178-4000 is an Inseparable 
assembly consists of six Normal parts in different quantities and sixty-eight purchased rivets.
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Purchased components
They are components that are not fabricated. Examples of Purchased Assemblies include:

■ Cylinders, pistons, or shock absorbers. 
■ Swing arms for LCD monitors. 
■ Hinges.
■ Screws, nuts and rivets.

Purchased components have the following characteristics:

■ The component is considered a single BOM line item; regardless if it is a part or an assembly (for 
example, an assembly marked as purchased is listed as a part in Parts-Only parts list).

■ If the purchased component is an assembly, its children are not included in a Parts-Only view.
Children are also excluded from quantity calculations in the BOM. 

■ Normal child components of a purchased assembly are included in structured parts list, and 
numbered, but are hidden in Parts-Only parts lists.

In the Test Station.iam, the Swing Arm is a purchased assembly.
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Phantom components
Phantom components are not physical parts of the manufactured product in the design. They are used to 
simplify the design process. Therefore, components with the BOM Structure - Phantom will not be displayed 
in the Bill of Materials. 

Phantom components have the following characteristics:

■ They are ignored by the BOM. 
■ They are not numbered, and are not directly included in quantity calculations. 
■ They influence their children's participation in the BOM by promoting them in the Structured BOM 

views.
■  The children of a Phantom component are treated as siblings to the phantom component siblings.
■ The quantity of their children is multiplied by the quantity of the phantom component.

The illustration below shows how the BOM promotes the children (Normal) of the parent (Phantom) in BOM 
Structure to a higher level.
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Reference components
Reference Components are construction geometries used to add context to a design. BOM ignores all 
reference components and their children/instances. Therefore, reference parts and assemblies, including 
children, are not included in the BOM views and Quantity calculations.

Examples of Reference Components are:

■ Construction elements such as skeleton parts or assemblies in the modeling design.

Visual enhancements such as a tote filled with parts sitting on a desk, where the tote is added for technical 
drawing/publication purposes but is not a part of the actual design. 
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Manage BOM attributes using the BOM Attribute Editor
The Bill of Materials (BOM) Editor is a tool for maintaining assembly bill of materials. It is used to: 

■ Edit BOM Structure for components. 
■ Edit iProperties and BOM properties.
■ Set quantity overrides for components. 
■ Create a consistent item order for components for the generation of Parts Lists and other associative 

lists from the BOM.
 

You can access BOM editor from the assembly panel, tool menu or right click on a subassembly to select 
Bill of Materials tool.

To change the component property, 

1. From the assembly panel, click the Bill of Materials tool.

2. Click on the Item heading to sort all items in ascending order. Scroll down to item 6 and 7.
Notice both belong to the test station software. Change the BOM Structure property from Normal to 
Purchased by clicking the drop-down arrow and selecting Purchased from the list.
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3. Expand all children for the assembly M178-1000.

4. Change the BOM structure property from Normal to Phantom.

5. Notice the M178-1000 assembly is no longer visible, and its components have been promoted one level.

6. Click the Parts-Only View Options button, and then select Enable Parts-Only BOM View.

7. Click the Parts-Only tab to view the structure of the BOM with all of the parts promoted from their 
subassemblies. BOM structure is ignored in Parts-Only view.
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8. Click the Structured tab. Click the Description field for the part number: 21-091 and 21-092, and then 
rename to WHEEL CASTER, STANDARD and WHEEL CASTER, LOCKING respectively.

9. In the browser, expand M178-1000:1, and then expand 21-092 Caster Phantom:1. Right-click 21-092 
Caster: 1 and click Properties. In the Properties dialog box, click the Project tab to view the Description 
that you entered in the Bill of Materials dialog box. Click OK.

Create virtual components
Virtual components are non-modeled components with no file reference. They are components that do not 
need to be modeled though they will show up in model browser. They have properties such as quantity, 
BOM Structure and Part Number. For example, oil, grease and paint.

You notice the software used for the test station are virtual components. To add a virtual component to the 
test station,

1.  From the Assembly panel, click Create Component tool.

2.  In the Create-In-Place Component dialog box, click the Virtual Component check box and change the 
Default BOM Structure to Purchased.

3.  In the New Component Name field, enter Oil. Click OK.
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Virtual components support BOM structure and quantity. They can have material style, volume and mass.

4.  Right click Oil:1 at the browser, and then select Component Settings.

5.  In the Oil Component Settings dialog box, click the Edit Parameter button.

6.  Click the Add button in the Parameters dialog box, and then type Volume for the Parameter Name. Select 
Volume > Liter (l) for the Unit Type, and then type 17 for the Equation. Click Done.
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7.  Click the drop-down arrow for the Base Quantity, and the select Volume in the User Parameters. Click 
OK to close the drop-down list. Click OK to close the Oil Component Settings dialog box.

8.  Click the Bill of Materials, scroll to the last item in the BOM Structure, and then type Oil in the part number 
column for the newly added virtual component. Its quantity displayed 17 l (liters).
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Component Equivalence
In the BOM structure, equivalent components are components with the same part number. When two or 
more equivalent components are at the same level in an assembly, a roll-up will be performed, which 
merges the components into a single line item. BOM will sum up the equivalent components according to 
the rules below.

■ Equivalent components have the same part number.
■ Components with blank part number fields are not considered as equivalent.
■ Components with parent/child relationship are also not considered as equivalent.
■ When both assembly and part are equivalent, the assembly is rolled up into a single line item.
■ When both assembly and assembly are equivalent, the first assembly is rolled up into a single line 

item.

Note: During the roll-up, the Properties (iProperties and/or BOM Properties) that do not match are reported 
as *Varies*.
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Disable automatic merging of parts with matching Part 
Numbers in Inventor 10 BOM for legacy drawings
For your exisitng legacy drawings, to avoid the automatically roll-up and sum-up equivalent components, 
use the hot fix ID: TS1052403 “Rows merge automatically due to part number matching.” from the Autodesk 
support website: http://www.autodesk.com/support.

Static vs. Calculated Quantity
Quantity in the bill of materials is calculated as Each, Length, Volume or Mass. When quantity is anything 
other than Each, then a model parameter exists.

In the bill of materials, quantity is defined by three properties: Item Quantity, Unit Quantity and Total Quantity. 
Total Quantity is the unit quantity multiplied by the item quantity.

You can click on the quantity cell to create and edit a static quantity manually. You can also right click to 
change from Static to Calculated Quantity and vice versa. When you switch the Calculated Quantity of a 
component to Static Quantity, you loose the calculated adding of unit/item to its quantity. 

In the iProperties, static values display with font properties of blue and bold to distinguish these from values 
received from the BOM. When cells are manually edited, the property is automatically applied.

1.  Open M178-4000 Phantom.iam assembly.

2.  Click Tools > Bill of Materials to display the BOM editor.

3.  Notice item 7 -the quantity of rivets displayed in blue and bold indicates it is static.

For more detail information on quantity property in the BOM, refer to Autodesk Inventor HELP.

TIP To find the number of components in an assembly, create an assembly BOM of all components, and 
then export the part list to XLS Excel format.
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