In This Exercise

In Autodesk Inventor® Professional R9 or earlier versions, the Tube & Pipe Publishing wizard was the tool to prepare your custom conduit parts and fittings in Tube & Pipe library.

Now, the unified Content Center library of Autodesk Inventor® replaces the previous Tube & Pipe library and stores standard conduit parts and fittings for tube and pipe design. The task of authoring and publishing is performed using two tools subsequently:

- Tube & Pipe Authoring tool provided in Autodesk Inventor Professional Tube & Pipe.
- Publish Part tool provided in Autodesk Inventor.

In addition, normal (non-iPart) conduit parts and fittings are now available to author and publish to the Content Center library.

Before starting the following exercises, you must complete the exercises in Part 1.

Author iParts and Parts

To author a conduit iPart, a fitting iPart, or a fitting part, use the Tube & Pipe Authoring tool to specify the part type, end treatment, parameter mapping, connection, and engagement.

**NOTE:** ISOGEN properties are not enabled when authoring conduit parts; they are enabled and optional only when authoring fittings.

Parts can only be authored as fittings, for example, you can author the pipe part, pipe_normal.ipt you previously created as a coupling or any other fitting type, but cannot author it as a conduit part.

The Tube & Pipe Authoring tool predefines a list of available part types to author, such as Tubes, Pipes, Hoses, Couplings, Elbows, and Tees. When no category is appropriate for the fitting part being authored, select Other.
1. Open the pipe iPart, `pipe_iPart.ipt`.

2. On the Part Features panel bar, click the Tube & Pipe Authoring tool.

3. In the Tube & Pipe Authoring dialog box, specify the following:

   **Type:** Pipes
   **Connections:** 2. Note that the number of connections for Pipes is grayed out.

4. Click the connection number button 1 and specify the following parameters.

   **End Treatment:** Welded. It indicates the way in which the pipe part connects to adjacent fittings.

   **Parameter and Table Mapping:** Click the red required field and complete the mapping as shown in the following image.

   The Parameter list represents the attributes for the published part and it determines the controlling parameters for styles. The Table Mapping list represents the attributes for the pipe iPart. Parameter and table mapping are always selected as a pair.

   **Connection Point and Connection Axis:** Use the Connection Point and Connection Axis tools to set them as shown in the following image.
FEMALE: Leave as is because the welded end treatment does not require gender.

Click Flip Connection if the connection axis points toward the inside of the pipe. The connection direction must point toward the engaging fitting, so it often points outward.

**NOTE:** You can click a valid circular edge to define the connection point and connection axis as you do in this exercise, as well as using existing work points and work axes. For detailed instructions on the latter case, see the Autodesk Inventor Professional Tube and Pipe Help ➤ Authoring and Publishing ➤ Authoring Tube and Pipe Parts ➤ Author iParts ➤ Elbow iPart.

**Engagement:** It is enabled until both Connection Point and Connection Axis are set. The engagement parameters specify the minimum engagement position and maximum engagement position that determine how far a pipe is inserted into the specified fitting. The available engagement distance for the fitting is the difference between Max and Min.

**FIXED:** selected
Max: 0
Min % of Max: 0

**NOTE:** For pipe parts, when connecting to the adjacent fittings, the connection only applies to the engagement definition of the adjacent fittings by default. Because any engagement parameters specified for a pipe iPart are ignored by default for the connection to the adjacent fittings, it is recommended that you set a fixed value of 0 in such cases.

5. Click connection number button 2 and repeat Step 4 for the other end of the pipe, using the following connection point and connection axis. Note that the parameters are already mapped. Be sure to set the end treatment.

6. Verify that each connection number button changes from red to black so all required connection criteria are set.

7. Click OK to complete the authoring.
8. In the Authoring Result message box, click OK.

9. Save the part.
90-Degree Elbow iPart

1. Open 90Elbow_iPart.ipt.

2. Click File ➤ Tube & Pipe Authoring.

3. In the Tube & Pipe Authoring dialog box, specify the following parameters:
   - **Type**: Elbows
   - **Connections**: 2

4. Click the connection number button 1 and specify the following parameters:
   - **End Treatment**: Welded
   - **Parameter and Table Mapping**: See the following image.
   - **Connection Point and Connection Axis**: See the following images.
   - **FEMALE**: Leave as is because the welded end treatment does not require gender.

**Engagement:**
- **FIXED**: not selected
- Max % of NS: 80
- Min % of Max: 50

**NOTE:** The engagement must be greater than the Increment Size on the Tube & Pipe Styles dialog box. If it is not, the available pipe lengths may not fall within the minimum and maximum engagement range, causing a case where Autodesk Inventor Professional cannot create the routes. As pipe size decreases, the engagement range typically decreases accordingly. With a smaller engagement range, it is more likely that an increment value like the default .1 will cause routes to fail.
For example, in the illustration you can see that it is 4.7 inches from the previous connection point to the minimum engagement and 5.2 inches to the maximum engagement. Acceptable pipe lengths are greater than or equal to 4.7 inches, but less than or equal to 5.2 inches. With an increment value of .5, possible pipe lengths include 4.5, 5, and 5.5. Only the 5 pipe is in the acceptable range. Decreasing the increment value would provide more valid pipe lengths.

5. Click the connection number button 2 and repeat Step 4 for Connection 2 using the following connection point and connection axis. Note that the parameters are already mapped.

Be sure to set the end treatment because it is not automatically set to the same end treatment as the preceding connection number.

6. Optionally, specify ISOGEN Properties only if you plan to generate the elbow part in the ISOGEN output.

Type: **ELBOW**
Skey: **ELBW Elbow - Butt Weld (90 degree and 45 degree)**

7. Verify that each connection number button changes from red to black so all required connection criteria are set.

8. Click OK to complete the authoring.

9. In the Authoring Result message box, click OK.

10. Save the part.
In this section, you use the skills you just learned to:

- Author the 90-degree elbow part 90Elbow_normal.ipt as Elbows.
- Author the pipe part pipe_normal.ipt as Couplings or any other fitting type you need.

During authoring, you can try to modify the default number of connections for the selected fitting type. To complete the authoring successfully, you must set all required parameters for each connection number.

**Author the 90-degree elbow part as Elbows**

1. Open 90Elbow_normal.ipt.
2. Click the Tube & Pipe Authoring tool.
3. Repeat the steps used for the 90-degree elbow iPart. Specify the same parameters, with the exception of a fixed nominal size of 1/4 in.

4. Click OK to complete the authoring.
5. Save the part.
Author the pipe part as Couplings

1. Open pipe_normal.ipt.

2. Click the Tube & Pipe Authoring tool.

3. Specify the fitting type as Couplings.

4. Specify all other needed parameters, such as the number of connections, end treatment, the value of Nominal Size, connection point and connection axis, gender, engagement, and optionally, ISOGEN properties. Verify that all required parameters are set.

5. Click OK to complete the authoring.

Publish to Content Center Library

To take advantage of the Content Center library functionality, such as queries and dropping conduit parts and fittings, you must publish custom tube and pipe iParts and parts to the Content Center library. Custom parts in the Content Center library can also be shared in multiple projects so you do not need to save the same custom parts for each project workspace.

You must publish parts to a library to which you have read/write permissions. Before publishing authored parts, verify that you have permissions of editing and publishing in the Content Center library. Reinstall Autodesk Inventor to change permissions if needed.

Publishing parts automatically points to the default category in the active library in which they must be published. If you click into another category, click the default category in the library tree again to continue the publishing.

In the following exercises, you add a custom library, publish the authored pipe iPart, elbow iPart, and the other parts to that custom library.

Configure a Custom Content Center Library

Custom parts cannot be published into the system-supplied read-only libraries. In the Configure Libraries dialog box, the Libraries table indicates the access permission you have to each library. With permissions to edit and publish in the Content Center, Autodesk Inventor automatically creates an empty custom library named MyLibrary.

There are two ways to configure custom libraries:

- Use the Configure Libraries tool in the Content Center dialog box.
- Exit Autodesk Inventor and go to Start ➤ Programs ➤ Autodesk ➤ Autodesk Inventor (version) ➤ Tools ➤ Content Center Library Manager.

In this exercise, you use the Configure Libraries tool to add a custom Read/Write library.
Create a custom library

1. Open an Autodesk Inventor part or assembly file.

2. Click Tools ➤ Content Center tool.

3. In the Content Center dialog box, click the Configure Libraries tool.

4. In the Configure Libraries dialog box, make sure no library is selected. Click the New Library tool.

5. In the Create New Library dialog box, select **Single User Library (Local)**, and then enter the library name, **CustomLibrary**.

   **NOTE:** The library name must not contain blank spaces.

6. Click OK.

   The Libraries table displays the new library to which you have Read/Write permission.

   **NOTE:** Autodesk Inventor prompts you if a duplicate library name exists. If the library with the same name is not displayed in the Libraries table, exit Autodesk Inventor and then run the Content Center Library Manager tool to check and delete the library permanently if it is no longer used.

7. Click OK.
Pipe iPart

In this exercise, you publish the authored pipe iPart to CustomLibrary.

Publish the authored pipe iPart

1. Open pipe_iPart.ipt you authored previously.

2. Click Tools ➤ Publish Part.

   In the Publish dialog box, the Tube & Pipe ➤ Pipes category is selected by default.

3. In the Libraries panel or list, select CustomLibrary.

4. Optionally, click the New Category tool on the toolbar of the Publish dialog box, and then name the new category Custom.

5. Click Tools ➤ Family Properties.

6. In the Family Properties dialog box, specify the following information on the General tab:

   **Naming:**
   Family Name: SamplePipe
   Description: Custom Welded Pipe

   **Standard:**
   Standards Organization: SampleStandardsOrganization
   Manufacturer: SamplePipeCompany
   Standard: SampleStandard
   Standard Revision: 1

   **NOTE:** Multiple styles can be used in a single tube and pipe run and different styles may use different standards, so the Standards Organization and Standard information is required if you plan to use a differing standard part in a style.

On the Parameters tab, you do not need to do anything for tube and pipe parts publishing because the mapping between category parameters and part parameters has been done during authoring.

On the Preview tab, you can preview the published pipe image, verify the publish language, family name, description, and category path to publish, and go back to the Family Properties tab to make appropriate changes as needed. The preview image shows the base part in the appropriate material. When an iPart factory contains more than one member in the iPart Author table, the preview image shows the default row.

For example, you can set the fifth row in the pipe iPart Author table of which the nominal size has a larger value and the material style is Custom Welded Steel Mild. When publishing the pipe iPart, you can see that the preview image reflects the NS and material from this row.
7. Click OK. The Family Properties dialog box is closed and the Publish dialog box displays the specified part family.

8. In the Publish dialog box, click Publish.

9. When the Publish Result message box informs you of the successful publish, click OK.

10. Close the Publish dialog box.

Once published, the Standard information is available in the lists in the Tube & Pipe Styles dialog box. The part materials are available when the appropriate standard specification is selected. You can define tube and pipe styles or use the i-drop functionality to drag the part from the Content Center library into the assembly of your choice.

Elbow iPart

In this exercise, use the skills you just learned to publish the authored 90-degree elbow iPart to CustomLibrary.

Publish the authored 90-degree elbow iPart

1. Repeat the previous steps to set the category in CustomLibrary. Use Tube & Pipe ➤ Fittings ➤ Elbows ➤ Custom as the category path.

2. In the Family Properties dialog box, General tab, specify:

   **Naming:**
   - Family Name: Sample90DegreeElbow
   - Description: Custom Welded 90-degree Elbow

   **Standard:**
   - Standards Organization: SampleStandardsOrganization
   - Manufacturer: SamplePipeCompany
   - Standard: SampleStandard
   - Standard Revision: 1

3. On the Preview tab, you can preview the published pipe image, verify the publish language, family name, description, and category path to publish, and go back to the Family Properties tab to make appropriate changes as needed.

4. Click OK to complete setting the family properties.

5. In the Publish dialog box, click Publish.

6. When the Publish Result dialog box informs you of the successful publishing, click OK.

7. Close the Publish dialog box.
Parts

After completing the publishing exercises, practice publishing the authored pipe part and 90-degree elbow part to the Content Center library with a unique part family name.

Once published, the part family contains only one member. You can navigate to the category in the Content Center library and review the part information.

Review Published Parts and Republish

All content from each library is merged in the Content Center. If you want to view which library a part comes from, open the part family, do either of the following on the Content Member Selection panel:

- Click the Family Information tab.
- On the Select tab, click Details.

Each part family in the Content Center library has a file name schema. Customizing the file name schema works differently:

- For conduit parts, when they are i-dropped on to a tube and pipe assembly, the Content Center file name schema is used. When they are used to populate routes, the system always uses the Tube & Pipe-specific naming convention of `pipe.<13-digit number>` where **13-digit number** is automatically assigned based on the current time of your computer.
- For fittings, when i-dropped or used to populate routes, the Content Center file name schema is always respected.

**TIP:** To verify the file name in the pipe run environment, right-click a conduit part or fitting and select Properties. The General tab of the Properties dialog box displays the file name.

If you want to provide your own naming conventions to read/write library parts, open a part family, click the part file name on the bottom of the Select tab, and then make appropriate changes. The next instance of this part uses the new schema. For detailed instructions on how to customize file name schema of library parts, see the index entry **Content Center, file name** in the Autodesk Inventor Help.

In this exercise, you modify the stock number definition of the published pipe part and republish it.

**Customize the stock number of read/write library parts**

1. In the part or assembly environment, start the Content Center tool.
2. Open the part family, **Tube & Pipe ➤ Pipes ➤ Custom ➤ SamplePipe**.
3. On the Content Member Selection panel, Table View tab, right-click the Stock Number [Project] column and select Properties.

   The Column Properties dialog box is displayed.
4. In the Map to Inventor Properties list, select **Design Tracking Properties.Stock Number**.

5. Optionally, you can change the column caption and determine an expression to define the stock number for each part family member interactively. Typically, use the expression of **your part family name - {Nominal Size} - Schedule {Schedule Number}**, and you can also include other properties, such as raw materials, as needed.

**IMPORTANT:**

- If you shift to use the expression or modify the existing definition, all previous stock number properties are replaced once republished.
- One essential functionality of tube and pipe drawings is to understand the net length needed for given-type conduit parts. Do not use **{DESIGNATION} or {PL}** in the stock number expression; otherwise, the parts list will not group conduit parts accurately. Note that **{DESIGNATION}** has the pipe length property appended to the end.

6. Click OK to close the Column Properties dialog box.

   In this exercise, the published pipe part has a stock number property of **SamplePipe - 1/4 Schedule 40**.

   - **SamplePipe** indicates the part family name with which you are to publish the part.
   - **1/4** indicates the primary key (NS).
   - **40** indicates the secondary key (SN).

7. In the Content Center dialog box, click Publish.

8. When the Publish Result message box prompts, click OK.
You have now learned to:

- Author iParts and parts.
- Create a custom Content Center library.
- Publish the authored iParts and parts.
- Review published parts in the Content Center library, such as looking up the source library.
- Modify library parts in the Content Center and republish the part.

If you are interested in a full range of Content Center functionality and tube and pipe authoring, refer to the following documentation:

- Autodesk Inventor Help
- Managing Your Data book
- Autodesk Inventor Professional Routed Systems Getting Started book
- Autodesk Inventor Professional Tube and Pipe Help