This set of Skill Builders includes 3 parts:

- Part 1: Prepare an iPart factory for a conduit part and a fitting.
- Part 2: Author iParts and parts and publish to the Content Center library.
- Part 3: Create a custom tube and pipe style using published parts, and then create a pipe route.

In This Exercise

Following the iPart guidelines, you will learn how to prepare an iPart factory for a conduit part and a fitting.

Prepare Parts and iParts

The first step in creating a custom style is to create the parts that the style must include. By creating your own parts, you can ensure that you have the parts in the sizes, materials, and other parameters you need. Once you create the parts, you can optionally transform them into iPart factories, and then author and publish them to the Content Center library.

The Content Center library stores standard conduit parts and fittings for tube and pipe design. The task of authoring and publishing is performed using two tools: the Tube & Pipe Authoring tool provided in Autodesk Inventor® Professional and the Publish Part tool provided in Autodesk Inventor®.

Both normal (non-iPart) parts and iParts can be authored and published to the Content Center library. The only difference between a part and an iPart is that a part can only be authored and published as a fitting and it has only one member in the part family.

The following exercises provide guidelines on how to prepare parts as well as conduit iParts and fitting iParts. For basics about how to create an iPart factory, see the index entry *iParts, create factory* in the Autodesk Inventor Help.

**NOTE:** If the base part related to an iPart factory must be modified in any way, you must change the base part, and then re-author and republish it to the Content Center library.
Required iPart Parameters

The number of parameters required for authoring a tube and pipe iPart or a part depends on the type of part you are publishing.

For conduit iParts, the following parameters are required:

- Nominal Size (NS)
- Schedule Number (SN)
- Outside Diameter (OD)
- Inside Diameter (ID)
- Pipe Length (PL): It is only required on the first connection number. You do not need to map the iPart column to Pipe Length for other connection numbers.

For fitting iParts, only NS is required. For other parts, a fixed nominal size is required.

TIP: If you cannot remember the required parameters for authoring a specific part, click the Tube & Pipe Authoring tool and review the required parameters.

In addition to required iPart parameters, you can add other parameters, such as existing iMates, work features, and threads, to the iPart factory to fully define the part. For example, you can manually specify a material style for an appropriate part member.

Unit Formats for iParts

During authoring, the nominal size must use one of the three unit formats supported:

- Integer or fractional number for inch, such as 1/2, 1 1/2
- M40 for metric
- 1/2-20 UNF for special threaded fittings

Materials for Conduit Parts and Fittings

When needed materials in a tube and pipe style are not available in the Styles library, routes and runs using this style cannot be properly populated. To add new materials to the Styles library, you must enable the Styles library for your project. For detailed instructions on how to enable the Styles library, see the index entry styles, enable styles editor in the Autodesk Inventor Professional Tube and Pipe Help.

In this exercise, you add a custom material style Custom Welded Steel Mild to the Styles library and set the system-shipped Steel, Mild as the active material style. Later, you will see how they work with a part, its iPart factory, the published part family in the Content Center library, and tube and pipe styles.
Add or Modify Materials to Styles Library

In the part environment, you can add and modify material styles. Changes must be saved to the Styles library so they can be used to prepare an iPart factory or configure tube and pipe styles.

For example, when configuring tube and pipe styles, you cannot find the desired material style in the Material list in the Tube & Pipe Styles dialog box but the part family in the Content Center library owns this material. In this case, the material style is probably not added to the Styles library yet.

1. Verify the Use Styles Library option is set to Yes for your active project.
2. Open an Autodesk Inventor part file.
3. Click Format ➤ Styles Editor.
4. In the Styles and Standards Editor dialog box, left pane, expand Materials. Click Welded Steel Mild to review the material details on the right pane.
5. Click New and enter Custom Welded Steel Mild in the New Style Name prompt box.
6. On the right pane, ensure the Use as Weldment Material check box is selected. Make needed changes for the new material style.
7. On the left pane, right-click the material style, and select Save to Styles Library.
8. Click Done.

You can now add the material style to the iPart Author table when creating iParts.

Define an Active Material Style

The active material style is the default material used to create new parts and iPart factories. To change the active material style, click Format ➤ Active Standard or the Styles Editor tool.

1. In the part environment, start the Styles Editor tool.
2. In the Styles and Standards Editor dialog box, left pane, double-click Steel, Mild to make it active.
3. On the right pane, select the Use as Weldment Material check box.
4. Save changes to the Styles library.
5. Click Done.

All new parts will be created using the active material style.
Pipe Part and iPart Factory

In the following exercises, you create a pipe part and then use the part as the base to create an iPart factory.

**TIP:** When creating a pipe part, it is recommended that you use as many model parameter equations as you can to preserve the model ratio.

Create a pipe part

1. Create a pipe part, pipe_normal.ipt.

Set the dimension of the inside circle to 0.364 inch and the dimension of the outside circle to 0.540 inch when sketching the base part.

Extrude the sketch using a distance of 1.500 inch.

2. On the Part Features panel bar, click the Parameters tool.
Click Add to enter the following 3 user parameters:

- ID: 0.364 in
- OD: 0.540 in
- PL: 1.500 in

Set the model parameter equations using ID, OD, and PL, and then click Done.

3. Add a chamfer with an equation of OD/50 ul at both outer circular edges of the part, or use the equation, OD/50.

4. In addition, you can add more features, such as threads, to the pipe. For more information, refer to the Autodesk Inventor Help.

5. Click the Parameters tool again, and then verify that the chamfer parameters are added into the Model Parameters table.

6. Save pipe_normal.ipt.

At this point, we’ve created the pipe part. Next, we’ll use this part as the base to create an iPart factory.
Create an iPart factory from the base pipe part

1. Save a copy of the pipe part, pipe_normal.ipt as pipe_iPart.ipt.

2. Open pipe_iPart.ipt.

3. Click Tools ➤ Create iPart.

4. In the iPart Author dialog box, verify that the ID, OD, and PL user parameters are already in the first row.

5. On the Other tab, click the first row in the upper-right field and add NS with a value of 1/4. The NS parameter is automatically selected into the parameter table. Enter 1/4 in the NS value field.

6. Click the second row in the upper-right field, and then add SN with a value of 40.

7. On the Properties tab, expand Project and click Stock Number. Click the Add arrow tool and enter the desired stock number in the parameter table.

**IMPORTANT:**

- When a part family contains more than one type of the material, you must have the stock number property to distinguish each material. In drawing documents, the parts list groups conduit parts based on the stock number property.
- When completing the publishing, you must go to the part family in the Content Center library to verify whether or not the stock number is mapped to the Autodesk Inventor property of Design Tracking Properties.Stock Number. If not mapped, you will get a blank stock number for all instances of this conduit part in tube and pipe drawings.
Alternatively, you can ignore this step. After this publishing process is completed, you can directly add a stock number column in the Content Center library using an interactive expression, and then republish the conduit part. In this way, you get the correct results of the bill of material table and parts lists in tube and pipe drawings.

To verify the mapping and make appropriate changes to the stock number definition, see the Skill Builder titled Authoring, Publishing, and Styles - Part 2. See the Publish to Content Center Library ➤ Review Published Parts and Republish section.

8. Do the following to add the material information to the iPart Author table.

- On the Properties tab, expand Physical, and then double-click Material to add it to the parameter table. By default, the Material column has a value of the active style Steel, Mild. You can manually change it to any other material style available in the Styles library.
- On the Other tab, add a new column. Right-click the column in the parameter table, and then select Material Column. It is not important what column name you use. You must enter a material style that already exists in the Styles library.

In this exercise, use Steel, Mild for the row where NS equals to 1/4 inch.

Click OK to close the iPart Author dialog box.

**NOTE:** If the material property is not selected in the parameter table, the active material style is used after it is authored and published to the Content Center library.
9. Add four more members to the pipe iPart factory. In this case, right-click Table in the Model browser and select Edit via Spread Sheet. With the spreadsheet you can quickly add the nominal diameters: 3/8, 1/2 (0.5), 3/4, and 1 as shown in the following table.

<table>
<thead>
<tr>
<th>ID</th>
<th>ID</th>
<th>OD</th>
<th>PL</th>
<th>NS</th>
<th>SN</th>
<th>Stock Number</th>
<th>Material</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>0.364 in</td>
<td>0.540 in</td>
<td>1.500 in</td>
<td>1/4</td>
<td>40</td>
<td><strong>SamplePipe - 1/4 Schedule 40</strong></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>0.540 in</td>
<td>0.675 in</td>
<td>1.500 in</td>
<td>3/8</td>
<td>40</td>
<td><strong>SamplePipe - 3/8 Schedule 40</strong></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>0.622 in</td>
<td>0.840 in</td>
<td>1.500 in</td>
<td>1/2</td>
<td>40</td>
<td><strong>SamplePipe - 1/2 Schedule 40</strong></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>0.824 in</td>
<td>1.050 in</td>
<td>1.500 in</td>
<td>3/4</td>
<td>40</td>
<td><strong>SamplePipe - 3/4 Schedule 40</strong></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>1.049 in</td>
<td>1.315 in</td>
<td>1.500 in</td>
<td>1</td>
<td>40</td>
<td><strong>SamplePipe - 1 Schedule 40 Custom Welded Steel Mild</strong></td>
</tr>
</tbody>
</table>

Close the worksheet.

Finally, double-click Table in the Model browser and verify that the iPart Author parameter table displays the same result as shown in the previous table.

The first row is highlighted by default. The default row determines the library part that displays when you open a part family in the Content Center library. To change the default row, right-click the appropriate row number, such as 5, and select **Set As Default Row**. The pipe part in the graphics window automatically updates and you should have the same image as shown.

In this exercise, verify that the first row is set as the default.

10. Do the following to set the keys for future use in the Content Center library. Pipe parts typically have three hierarchical keys: nominal size, schedule number, and pipe length.

- Right-click the NS column in the parameter table, and then select Key > 1 to set NS as the primary key. You can also set the parameter key in the upper-right field.
- Set SN as the secondary key, 2.
- Set PL as the tertiary key, 3.
The following image shows the relationship between the default row and keys in the iPart Author table and the corresponding part thumbnail page in the Content Center library.

<table>
<thead>
<tr>
<th>ID</th>
<th>OD</th>
<th>PL</th>
<th>NS</th>
<th>SN</th>
<th>Stock Number</th>
<th>Material</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.541 x 0.540 x 1.5 in</td>
<td>1/4</td>
<td>40</td>
<td>pipe 1/4</td>
<td>0.54 - pipe 1/4</td>
<td>Default</td>
</tr>
<tr>
<td>2</td>
<td>0.600 x 0.600 x 1.5 in</td>
<td>1/2</td>
<td>40</td>
<td>pipe 1/2</td>
<td>0.84 - pipe 1/2</td>
<td>Default</td>
</tr>
<tr>
<td>3</td>
<td>0.750 x 0.750 x 1.5 in</td>
<td>1/2</td>
<td>40</td>
<td>pipe 1/2</td>
<td>0.84 - pipe 1/2</td>
<td>Default</td>
</tr>
<tr>
<td>4</td>
<td>1.000 x 1.000 x 1.5 in</td>
<td>3/4</td>
<td>40</td>
<td>pipe 3/4</td>
<td>1.05 - pipe 3/4</td>
<td>Default</td>
</tr>
<tr>
<td>5</td>
<td>1.250 x 1.250 x 1.5 in</td>
<td>1</td>
<td>40</td>
<td>pipe 1.25</td>
<td>1.315 - pipe 1.25</td>
<td>Steel, HD, Welded</td>
</tr>
</tbody>
</table>

**Note:** After authoring and publishing, the sequential combination of hierarchical keys form the value of the pre-defined property {DESIGNATION} in the Content Center library. In this case, {DESIGNATION} is pipe {NS} {SN} {PL}, in which pipe indicates the conduit part type. For more information, refer to the Tube & Pipe skill builder Authoring, Publishing, and Styles Part 3, Publish to Content Center library, Review Published Parts and Republish section.

11. Save pipe_iPart.ipt.

90-Degree Elbow Part and iPart Factory

In the following exercises, you create a 90-degree elbow part, and then use the part as the base to create another iPart factory.
Create a 90-degree elbow

1. Create a 90-degree elbow part, 90Elbow_normal.ipt.

   Set the dimension of the inside circle to 0.540 inch and the dimension of the outside circle to 0.622 inch when sketching the base part. Set the arc for the sweep path to 0.500 inch.

   Sweep the circular profile along the arc.

2. Click the Parameters tool to create and map user parameters to model parameters.
Click Add to enter the following three user parameters:

- **ID**: 0.540 in
- **OD**: 0.622 in
- **G**: 0.500 in

Set the model parameter equations using **ID**, **OD**, and **G**, and then click Done.

3. Add an extrusion with an equation of \( \text{ID}/3 \) ul at both ends of the part, or simply use the equation of \( \text{ID}/3 \).

4. Add a chamfer with an equation of \( \text{OD}/50 \) ul at both outer circular edges of the part, or simply use the equation of \( \text{OD}/50 \).

5. In addition, you can add more features to the elbow, such as the Revolve feature at both ends. For basics on how to create more part features, refer to the Autodesk Inventor Help.
6. Click the Parameters tool and verify that the extrusion and chamfer parameters are added to the Model Parameters table.

7. Save 90Elbow_normal.ipt.

The elbow part is now created. Next, you create an iPart factory based on this part.

Create an iPart factory from the base 90-degree elbow part

1. Save a copy of the 90-degree elbow part, 90Elbow_normal.ipt as 90Elbow_iPart.ipt.

2. Open 90Elbow_iPart.ipt.

3. On the Tools menu, click the Create iPart tool.

4. In the iPart Author dialog box, verify that ID, OD, and G are in the first row.
5. On the Other tab, add NS with a value of $\frac{1}{4}$.

6. Add four more members to this elbow iPart factory as shown.

<table>
<thead>
<tr>
<th></th>
<th>ID</th>
<th>OD</th>
<th>G</th>
<th>NS</th>
<th>Material</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.540 in</td>
<td>0.622 in</td>
<td>0.500 in</td>
<td>$\frac{1}{4}$</td>
<td>Steel, Mild</td>
</tr>
<tr>
<td>2</td>
<td>0.675 in</td>
<td>0.824 in</td>
<td>0.750 in</td>
<td>$\frac{3}{8}$</td>
<td>Steel, Mild</td>
</tr>
<tr>
<td>3</td>
<td>0.840 in</td>
<td>1.049 in</td>
<td>1.000 in</td>
<td>$\frac{1}{2}$</td>
<td>Steel, Mild</td>
</tr>
<tr>
<td>4</td>
<td>1.050 in</td>
<td>1.380 in</td>
<td>1.500 in</td>
<td>$\frac{3}{4}$</td>
<td>Steel, Mild</td>
</tr>
<tr>
<td>5</td>
<td>1.315 in</td>
<td>1.660 in</td>
<td>2.000 in</td>
<td>1</td>
<td>Custom Welded</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Steel Mild</td>
</tr>
</tbody>
</table>

7. Set NS as the primary key.

8. Save 90Elbow_iPart.ipt.
You have now learned to:

- Add new materials to the Styles library and configure the active material style.
- Create a conduit iPart factory and a fitting iPart factory.

This workflow is prerequisite to understand the complete authoring and publishing workflow and to ensure successful completion of the exercises in Part 2 and Part 3 of the accompanying skill builders. To learn more about tools involved in this exercise, such as parts, iPart factories, and iPart guidelines specific to conduit parts and fittings, see the following documentation:

- Autodesk Inventor Help
- Autodesk Inventor Professional R10 Routed Systems Getting Started book
- Autodesk Inventor Professional Tube and Pipe Help and Skill Builders.