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Media & Entertainment
2012 Products
Installation FAQ

Overview
The following diagram shows the major parts of the installation process:

Further details are provided in the following sections.

Prepare for Installation

Before starting to install, check the following details:
■ Confirm that your computer meets the minimum system requirements. If

in doubt, click System Requirements at the bottom of the installer screen.

■ Review product documentation to clarify details such as the type of
installation to do (stand-alone or network) and which products to install.
Documentation is accessible from links on the lower left corner of the
installer:
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■ Ensure that your user name has Administrator permissions to install
applications on the computer or network.

■ Obtain serial numbers and product keys for all products you want to install.
These are on the product package or provided at the time you download
the software.

■ Close all running applications.

Select Install Type

Here is some basic information to help you choose the right path.
■ Install is recommended for individual users or small groups. The key

point is that you will repeat the installation process on each computer.
This is the only valid installation type for a stand-alone license, but it can
also be used with a multi-seat stand-alone or network license.

■ Create Deployment is recommended for network administrators, using
either a multi-seat stand-alone or network license. In the deployment
process, the installation is configured once, stored on the network, and
then distributed efficiently to users' computers.

For more information on deployments, see Create Deployment (page 5)
or the Network Administrator's Guide.

■ Install Tools & Utilities is used to install tools and utilities related to
your suite or product. If you have a network license for your Autodesk
product, you will need to use this option to install the Network License
Manager before any users can run the product. Consult the documentation
for your suite or product to identify the available tools and utilities of
interest.

Select Installer Language

On the first screen of the installer, you can select the language for the installer
screens, using this control on the upper right:

2 | Chapter 1   Media & Entertainment 2012 Products Installation FAQ



For some Autodesk products, later in the install process you can select the
language for installed products. For more information, see Change Product
Language (page 5).

Specify License

The following notes provide a general overview. For more detailed information,
see the Licensing Guide for your product.

License Types

You can install most Autodesk products for a trial period of 30 days to evaluate
the product. If you purchase a license, it is configured as either stand-alone
or network, and for a specific number of users. These license types are briefly
described as follows:
■ A stand-alone license is intended for use by one person. The licensed

products can be installed on two computers, as long as both instances are
not running concurrently.

■ A multi-seat stand-alone license is intended to support a specified
maximum number of users, but it can be installed on a larger number of
computers for convenient access.

■ A network license supports a specified number of users who are
connected to a network. The Network License Manager is installed on one
or more servers on the network to manage the distribution of licenses to
users.

Network License Server Models

If you are using a network license, choose the server configuration for the
Network License Manager that was specified at the time of license purchase:
■ Single License Server

One server manages all licenses on the network.

■ Distributed License Server

Licenses are distributed across a pool of multiple servers in the network.
You enter the name of each server in the pool.

■ Redundant License Server

Three servers are available to authenticate each license. You enter the
names of the three servers.
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Configure and Install

Installation Path

This path specifies where the product folder will be installed.

Configuration

Most products have a number of configuration settings. On the Install >
Configure Installation page, for any product you have selected to install, you
see a triangular control for access to a configuration panel:

Click anywhere in the product box to open the configuration panel. For many
products, you can select an installation type, either Typical to accept the
default configuration settings, or Custom to review the settings and decide
whether to modify them. More information on the configuration settings for
your product may exist in an appendix to this guide. After you have configured
the settings as required, click the triangle to close the configuration panel.

Activate Products

When you run an Autodesk product for the first time, you will be asked to
activate the product. If it is connected to the Internet, your computer can
communicate directly with Autodesk to complete the activation process.

If your computer is disconnected from the Internet, you can activate later
when you are connected. Some products also permit you to activate offline
by sending the serial number, request code, and registration data to Autodesk
over the Web or by email. For more information on activation, go to Autodesk
Licensing and select the FAQ link.
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Create Deployment

Administrative Image

This is a customized set of installation files created by the deployment process.
It is used to install a consistent configuration of programs on each computer.
Other settings:
■ Administrative image path. Specify a shared network location where

you have Full Control permissions. Users will go to this path to install the
programs.

■ Target platform. Select either 32-bit or 64-bit to match the operating
system of the computers that will use the deployment.

■ Include only products required by this deployment
configuration. If selected, the deployment cannot be modified in the
future to include additional products. If unselected, the administrative
image will include all possible products, and the deployment can be
modified in the future in any way.

Installation Settings

■ Silent mode runs the installation in background, without user input.

IMPORTANT In silent mode, the user's computer can restart automatically
and without warning when the installation is complete.

■ A log file records installation data for each computer.

■ A network log file keeps a central record of installation data for all
computers that run the deployment. It has the same name as your
deployment, and must reside in a shared folder where users have Change
permissions, so that their computers can write to the log file.

Change Product Language

This topic does not apply to Autodesk products that provide each language
version on separate media. For these products, you must specify the product
language when purchasing, and cannot change it.

For some Autodesk products, you can select the product language at the time
of installation, using this drop-down menu on the installer:
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If the language you want is not available from this control, and if you see the
Add Language option on the menu, you can add a language pack.

NOTE The Add Language Pack option is available only to subscription customers.

For deployments, language packs can be included in an administrative image
when you initially create a deployment, or when you create a new deployment
configuration, but not when you modify a deployment.

To Download a Language Pack

You can obtain language packs from the Subscription Center website, as follows:

1 On the Select the Products to Install page, click the language drop-down
arrow and select Add Language Pack.

2 In the Language Pack dialog box, click the Browse button and select the
language pack downloaded from the subscription center.

The following rules apply to language selection:

■ Only one language can be chosen per installation session. For example,
you cannot chose English for one product and German for another product
during the same installation.

■ Deployments must be in a single language. One administrative image can
support deployments for different languages, but each deployment is for
one language.

■ If you are modifying a deployment, or creating a new deployment using
an existing deployment as a template, you cannot change the language of
the deployment.

■ If you select a language that is not supported by some products, a default
language is chosen.

Frequently Asked Questions
For advice and assistance with topics not covered here, go to Autodesk Support,
click your product name, and search in the Knowledgebase for your product.
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What if I have lost my serial number or
product key?

Check your product packaging or purchase records, if available, or contact
Autodesk Customer Service for assistance.

Why do I need to activate a product after
installation?

Activation verifies for Autodesk and for you as a license holder that your
Autodesk product is installed on an eligible computer. The activation process
improves license security and management. For example, it ensures that a
multi-seat license is not in use by more than the authorized number of users.

How does a trial license work in a product
suite or bundle?

A single trial period, usually 30 days, applies to all Autodesk products in the
suite or bundle. When the first product is started, the trial period countdown
begins for all products. If the user does not activate one of the products before
the trial period ends, access to all of the products is denied. After the trial
period ends, the user can restore access to the products by entering an
activation code.

How do I switch my license from stand-alone
to network or network to stand-alone?

If you simply entered the wrong license type by mistake, and are still running
the installer, use the Back button to return to the Product Information dialog,
and change the license type.

If you want to change the license type for an installed product, contact your
Autodesk reseller or license supplier to obtain the new license and serial
number. Then uninstall your product and run a new install to change the
license type and enter the new serial number.

Frequently Asked Questions  | 7
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Where can I find product license
information after installation?

Select Help menu ➤ About, or About [Product Name]. If your product uses
InfoCenter, that is where you can find the Help menu.

After installation, how can I change product
configuration, repair, or uninstall the
product?

1 Go to the Windows control panel:
■ Windows XP: On the Start menu, click Settings ➤ Control

Panel ➤ Add or Remove Programs.

■ Windows Vista or 7: On the Start menu, click Settings ➤ Control
Panel ➤ Programs/Uninstall a Program.

2 In Windows control panel, click the product name, and then click
Change/Remove (Windows XP) or Uninstall/Change (Windows Vista
and 7).

The Installer opens in maintenance mode, and directs you through the
process.
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Installation Information
Specific to Autodesk
3ds Max

Certain items are unique to the Autodesk
®
 3ds Max

®
 / Autodesk

®
 3ds Max

®
 Design

install process (in contrast with other Autodesk products). In this chapter learn about
the process for switching to the local version of the help and the sub-components
and tools and utilities that ship with 3ds Max (also includes 3ds Max Design unless
otherwise noted). Also learn how to install the 32-bit version of 3ds Max on a 64-bit
machine.

Switch from Online (Default) to Local Help
By default the Help in 3ds Max is internet-based. If you do not have a dedicated
internet connection, you can download a local version of your help. To override
the default behavior you then need to change the corresponding preference.

1 Download and run the Help installer from
www.autodesk.com/3dsmax-helpdownload-enu.

2 Once installed, in 3ds Max / 3ds Max Design go to Customize > Preferences
> Help Tab and select Local Computer / Network.

NOTE If you are using the default path this is all you need to do. Change the path
if you have not used the default location. To revert to the default location (which
matches the Help installer's default), click Reset. You an switch back to the online
version of the Help at any time, which is the most up-to-date version of the Help
available.

2
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Sub-Components Installed with 3ds Max
The sub-components installed with Autodesk 3ds Max 2012 include 3ds Max
Composite 2012, the various Autodesk Material Libraries, and Autodesk
Backburner 2012. The only optional sub-component is 3ds Max Composite.

3ds Max Composite 2012

When installing 3ds Max, 3ds Max Composite is checked for install by default.
3ds Max Composite 2012 includes:
■ Raster and Vector Paint

■ Image Processing

■ Color Correction

■ Keying and Rotoscoping

■ Stereoscopic Production Support

■ Motion Blur

■ Advanced 2D Tracking

■ Camera Mapping

■ Depth of Field

■ Node and Layer-based Compositing Options

■ Spline-Based Warping

■ Enhanced Render Passes

■ Data Managing and Collaborating

Autodesk Material Libraries

The Autodesk Material Libraries are shared libraries installed with Autodesk
products such as Inventor, AutoCAD, Revit and 3ds Max. These three items
are selected for install by default when you install 3ds Max. They might be
installed already, if one of these applications is already installed.

NOTE If you uninstall or remove a library, the library is no longer available for any
products. Uninstalling also means you will be unable to view or display scenes that
have Autodesk Materials currently in them.
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The Autodesk Material Library consists of three sub-libraries:
■ Autodesk Material Library 2012: Contains the material appearances used

for Realistic Appearance in color styles. This component is installed by
default, and it is required for 3ds Max to have full visual style and color
style functionality. It is recommended you do not uninstall this component
unless you are also uninstalling all Autodesk products that require this
library.

■ Autodesk Material Library 2012 Base Image Library: Contains low-resolution
(approximately 512 x 512) images for use with Autodesk Materials. This is
also installed by default.

■ Autodesk Material Library 2012 Medium Image Library: Contains
medium-resolution (approximately 1024 x 1024) images for rendering
materials in medium detail. This library is used for close-ups, and for
rendering objects at a larger scale. This library is an installation option
available on the Select Products to Install page in the installation wizard.

NOTE To reinstall the material libraries, run the corresponding MSI:
■ Autodesk Material Library 2012 -

\Content\ADSKMaterials\2012\CM\MaterialLibrary2012.msi

■ Autodesk Material Library 2012 Base Image Library -
\Content\ADSKMaterials\2012\ILB\BaseImageLibrary.msi

■ Autodesk Material Library 2012 Medium Image Library -
\Content\ADSKMaterials\2012\ILM\MediumImageLibrary.msi

Autodesk Backburner 2012

Autodesk
©
 Backburner

™
is the 3ds Max network-rendering management

software, also used by products such as Autodesk
©
 Flame

©
, and Autodesk

©

Smoke
©
. Backburner is a required install and is installed by default when you

install Autodesk 3ds Max 2012 / Autodesk 3ds Max Design 2012. You must
uninstall older versions of Backburner before installing Backburner 2012.
Backburner 2012 is backward compatible but settings do no migrate from
earlier versions. For information about using Backburner from inside 3ds Max,
refer to the "Network Rendering" section in the "Rendering" chapter of the 3ds
Max Help. For further information about installing and using Backburner see
the Help menu in the Backburner Manager.
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Backburner for Managing and Monitoring Only

You can install Autodesk Backburner on a machine without 3ds Max or 3ds
Max Design. However, such an installation of Autodesk Backburner cannot
be used for rendering. You can use this machine only to manage or monitor
jobs. Although the Autodesk Backburner server can be installed on a single
machine, it will not do anything; it will work only if it detects a supported
program such as Autodesk 3ds Max, Autodesk 3ds Max Design, Autodesk
Flame, or Autodesk Smoke. This means that you must have Autodesk
Backburner installed with at least one additional Autodesk product for a
machine in your configuration to be capable of rendering.

Tools and Utilities
The following table summarizes the optional installs available from the 3ds
Max / 3ds Max Design Tools and Utilities section in the installer.

Website:Description:Tool or Utility:

www.autodesk.com/devel-
op3dsmax

Use the SDK to create new
Autodesk 3ds Max features
and tools by writing your
own plug-ins.

Autodesk 3ds Max 2012
SDK

NOTE The SDK is not
shipped with Autodesk 3ds
Max Design.

www.autodesk.com/me-licens-
ing-2012-enu

You must install the Net-
work License Manager if
you are using network licens-
ing.

Network License Manager

www.allegorithmic.com/Install the Allegorithmic -
Substance Bonus Pack (Extra

Allegorithmic - Substance
Bonus Pack (Designer and
Player) Content) for additional sub-

stances that work with the
Substance Designer trial,
that is also included.
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Website:Description:Tool or Utility:

www.archvision.com/Manage the content ac-
quired using RPC

™
 Plug-ins

ArchVision
™

 Dashboard

with the ArchVision Dash-
board.

Add photorealistic objects
(such as cars, people, and

ArchVision
™

 RPC
™

 Plug-In

so on) with the RPC Plug-
Ins.

See the Civil View menu in
3ds Max Design for Help
and Tutorial information.

NOTE The first time you
access Civil View you will
need to initialize it and set
some basic settings. After
that you have access to the
complete Civil View menu
where you can find the Help
and Tutorials.

Convert 3D civil engineer-
ing data into 3D visualiza-
tions. Autodesk Civil View is
integrated into Autodesk
3ds Max Design and is ac-
cessed from the Civil View
menu.

NOTE Autodesk Civil View
is only included with
Autodesk 3ds Max Design.

Autodesk Civil View

www.bionatics.com/EASYnat/Drop virtual seeds from the
included samples and

EASYnat
®
 2.5 for 3ds Max

2012 (Demo)
“grow” them in your model
to add life-like plants. This
includes 2D, 3D, and hybrid
models with branch and leaf
detail.

www.craftanimations.comUse the Craft Director Stu-
dio Plug-in Bundle to per-

Craft Director Studio
™

 Plug-

in Bundle
form advanced, in-the-box,
rigging and physics simula-
tions. These features help
you animate cameras and
vehicles more quickly and
realistically.
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Website:Description:Tool or Utility:

www.okino.com/A demo version of PolyTrans
and NuGraf, from Okino

Okino Plug-ins (Demo)

Okino PolyTrans
™

 and Nu-

Graf
™

 Demos

Computer Graphics, lets
you evaluate dozens of
CAD, DCC, and VisSim data
converters directly within
3ds Max or 3ds Max
Design.

Installing a 32-bit Product on a 64-bit
Operating System

Manually override the installer's default behavior, which automatically installs
the 64-bit product on a 64-bit computer. For a stand-alone installation, navigate
to the root directory of the install media, and launch the 32-bit installer, which
has a file name of Setup_32.exe or something similar. For a deployment, you
can select the 64-bit target platform, and specify the 32-bit version of a product.
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Installation Information
Specific to Autodesk
Maya

Installation Information Specific to Autodesk
Maya 2012

Certain items are unique to the Autodesk® Maya® install process (in contrast
with other Autodesk products). In this chapter, learn how to install the 32-bit
version of Maya on a 64-bit machine, and how to install a local copy of the
Maya Help.

This chapter also includes information on installing and uninstalling Autodesk
Maya for Mac OS X and Linux.

Installing a 32-bit Product on a 64-bit Operating
System

You can manually override the installer's default behavior, which automatically
installs the 64-bit product on a 64-bit computer. For a stand-alone installation,
navigate to the root directory of the install media, and launch the 32-bit installer,
which has a file name of Setup_32.exe or similar. For a deployment, you can
select the 64-bit target platform, and specify the 32-bit version of a product.

3
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Install Maya on Mac OS X
To install Maya on Mac OS X

1 Do one of the following to launch the installer:
■ If you are installing from a DVD, insert the DVD into your drive,

then double-click the Maya DVD icon that appears on your desktop.

Navigate to the Maya/MacOSX folder on the DVD drive.

■ If you are installing from a download package, double-click the Maya
.dmg.

2 In the Finder window, double-click the Install Maya 2012 program.

The Maya Installer starts.

3 Follow the instructions in the Maya Installer to install the product.

For example, in the License Configuration window, do the following:

■ Enter your 11-digit serial number.

■ Enter your Product key.

■ Select your License type: Standalone or Network.

If you select the Network license type, enter your license server name
in the Server name field that appears. Contact your network
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administrator to find your license server name. If you have access to
the license server machine, you can also find its name by opening a
Terminal window (Applications > Utilities > Terminal) and
typing:

hostname <enter>

■ Click Continue.

4 In the final window that confirms a successful installation, click Done.
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By default, Maya is installed in the following directory:
/Applications/Autodesk/Maya2012/.

NOTE As indicated in the final installer screen, the Maya Help is
Internet-based. When you press F1 or select Help > Maya Help, the Help
launches from an Autodesk web server. If you do not have reliable Internet
access, you can download a copy of the Help from
www.autodesk.com/maya-helpdownload-enu.

Install Maya on Linux
This section provides detailed information on installing Maya on Linux.
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Install Maya on Linux using the installation
wizard

To install Maya on Linux

1 Do one of the following to start the Maya install:
■ If you are installing from a DVD, insert the DVD into your drive.

■ If you are installing from a download package, extract the Maya
packages from the compressed file.

2 Open a shell as a super user (using su -) and navigate to the directory
where you extracted the packages.

NOTE Recent Linux distributions may require a full super user environment
to run the installer as root. You can use su - to obtain the proper level.
(Note the trailing dash.)

3 Type ./setup and press Enter.

This starts the Maya Installer.

4 Follow the instructions in the Maya Installer to install the product.
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For example, in the License information window, do the following:

■ Enter your 11-digit serial number.

■ Enter your Product key.

■ Select your License type: Standalone or Network.

If you select the Network license type, enter your license server name
in the Server name field that appears. Contact your network
administrator to find your license server name.

■ Click Continue.

5 In the final window that confirms a successful installation, click Done.

By default, Maya is installed in the following directory:
/usr/autodesk/maya2012-x64.

NOTE The Maya Help is now Internet-based. When you press F1 or select
Help > Maya Help, the Help launches from an Autodesk web server. If you
do not have reliable Internet access, you can download a copy of the Help
from www.autodesk.com/maya-helpdownload-enu.
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Install Maya on Linux using the rpm utility

With the rpm command line utility, you can use either the -i flag or the -ivh
flag to install the programs. The -ivh flag provides you with more information
during the installation.

To install Maya on Linux using the rpm utility

1 Open a shell as a super user (using su -).

2 Do one of the following:
■ Insert the Maya DVD into your drive and mount the DVD drive. For

example, type: mount -r /dev/dvd /mnt/dvd.

■ Extract the Maya packages from the compressed file you downloaded,
then change to the directory where you extracted the Maya packages.

3 Use the ls command to list the packages.

The packages you see will be similar to the following, where # indicates
the specific package numbers.

RequiredDescriptionPackage name

YesMaya for LinuxMaya2012_0_64-2012.0-
#.x86_64.rpm

YesAutodesk licensingadlmapps4-
4.#.x86_64.rpm

Only for stand-alone li-
censing (Not required if

Autodesk stand-alone li-
censing

adlmflexnetclient-
4.#.x86_64.rpm

you use network licens-
ing)

NoLicense server tools (for
network licensing)

adlmflexnetserver-
4.#.x86_64.rpm

NoCompositeComposite_2012-2012.0-
#.x86_64.rpm

NoAutodesk Backburnerbackburner.sw.base-2012-
#.i386.rpm
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RequiredDescriptionPackage name

NoAutodesk Backburner
web monitor

backburner_webmonit-
or.sw.base-2012-
#.i386.rpm

NoAutodesk Backburner
monitor

autodesk.backburner.mon-
itor-2012.0.0-#.i386.rpm

NoMatchMoverMatchMover2012_0_64-
2012.0-#.x86_64.rpm

4 To install the required software, enter either of the following commands
(where # indicates the specific package numbers), depending on whether
you are installing Maya on a computer with Mudbox already installed:
■ To install Maya alone, enter:

rpm -ivh Maya2012_0_64-2012.0-#.x86_64.rpm
adlmapps4-4.#.x86_64.rpm
adlmflexnetclient-4.#.x86_64.rpm

■ To install Maya with Mudbox, enter:

rpm -ivh --force Maya2012_0_64-2012.0-#.x86_64.rpm
adlmapps4-4.#.x86_64.rpm
adlmflexnetclient-4.#.x86_64.rpm

Maya 2012 adds the required libXm.so.3 library to the Maya lib directory
as part of its standard install, so installing the openMotif runtime rpm
is not required.

5 Look for a file named libGL.so in the /usr/lib/ or /usr/X11R6/lib
directory to verify that OpenGL is installed.

NOTE /usr/lib is normally 32-bit on Red Hat, Fedora, and SuSE
distributions, but may be 64-bit for Ubuntu and Debian distributions. Some
distributions include the system OpenGL driver mesa-GL, which is not ideal
for running Maya. Maya is a 64-bit application and requires a 64-bit OpenGL
3D-accelerated driver for best performance.
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TIP To easily check which OpenGL driver is installed, use the glxinfo
program to list the top portion of the output, then look for the driver and
renderer strings. For example:

glxinfo | less

6 (Optional) For information on installing the Maya documentation
package, see Install the Maya Help (page 30).

By default, the Maya Help is Internet-based, so launching the Help within
Maya calls an Autodesk web server to display the documentation.

7 Run the following command to set whether you are using a network or
a stand-alone license:

/usr/autodesk/maya2012-x64/bin/licensechooser
/usr/autodesk/maya2012-x64/ <licensetype> unlimited

where you specify standalone or network for <licenseType>.

This updates the license.env file (used by the Autodesk licensing software)
with your license type information.

8 Add /opt/Autodesk/Adlm/R4/lib64/to LD_LIBRARY_PATH to set your
shared libraries for this session.

For example, you can run the following command in a BASH shell:

export LD_LIBRARY_PATH=/opt/Autodesk/Adlm/R4/lib64/

9 Run the following commands to register Maya with the Autodesk
licensing software, where <productKey1> and <productKey2> are your product
keys, and <serialNum> is your serial number:

■ (Stand-alone licensing)

/usr/autodesk/maya2012-x64/bin/adlmreg -i S
<productKey1> <productKey2> 2012.0.0.F <serialNum>
/var/opt/Autodesk/Adlm/Maya2012/MayaConfig.pit

■ (Network licensing)

/usr/autodesk/maya2012-x64/bin/adlmreg -i N
<productKey1> <productKey2> 2012.0.0.F <serialNum>
/var/opt/Autodesk/Adlm/Maya2012/MayaConfig.pit

NOTE If you purchased Maya alone and received only one product key, you
can enter the same product key for both <productKey1> and <productKey2>.

For example:
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/usr/autodesk/maya2012-x64/bin/adlmreg -i S 657D1 657D1

2012.0.0.F 000-00000000
/var/opt/Autodesk/Adlm/Maya2012/MayaConfig.pit

This step updates the product information .pit file, which you can copy
to other machines that have the same configuration if you are installing
many instances of Maya.

These commands return a Registration succeeded message, and you
can now run Maya using your stand-alone or network license.

Additional Linux notes

This section provides information for configuring Maya to run on Linux,
describes differences between Maya for Linux and other versions of Maya, and
provides other information specific to using Maya on the Linux operating
system. For complete information on limitations and possible workarounds,
also refer to the Maya Release Notes, available at
www.autodesk.com/maya-readme-2012-enu.

Compiling plug-ins and standalone programs

To compile plug-ins and standalone applications for Maya 2012 on Linux,
use the released gcc 4.1.2 compiler. Maya has been compiled with this compiler
under RHEL 5.1 WS.

In addition, Maya uses some component libraries that may already exist on
your system (for example, Qt, Python, OpenAL, Intel TBB, MKL, Cg). These
libraries are installed in the /lib directory under your Maya installation
directory, and should not interfere with the normal operation of your Linux
system. In some cases, your system may include newer versions of these
libraries, which may or may not be compatible with Maya.

NOTE Maya requires its own versions of the Qt libraries to run properly.

For more information, see the API Guide at
www.autodesk.com/maya-sdkdoc-2012-enu.

Installing additional required packages and fonts

On Linux, especially on Fedora systems, not all system libraries required to
run Maya are included in the default installation of the operating system. You
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can use yum to find any additional system-dependent library packages and get
the required runtime libraries.

For example, to install some of the following dependent libraries, you can
execute the following commands:
■ yum install mesa-libGLw

■ yum install libXp

■ yum install gamin audiofile audiofile-devel e2fsprogs-libs

Dependent OpenGL libraries (vendor Nvidia/AMD supplied)

■ libGL.so from Nvidia/AMD 3rd party library

■ libGLw.so.1 from mesa-libGLw

Dependent X Windows libraries

■ libXp.so.6 from package libXp

■ libXmu.so.6 from package libXmu

■ libXpm.so.4 from package libXp

■ libXt.so.6 from package libXt

■ libXi.so.6 from package libXi

■ libXext.so.6 from package libXext

■ libX11.so.6 from package libX11

■ libXinerama.so.1 from package libinerama

■ libXau.so.6 from package libXau

■ libxcb.so.1 from package libxcb

Dependent System libraries

■ libfam.so.0 from package gamin

■ libaudiofile.so.0 from package audiofile

■ libaudiofile.so from package audiofile-devel

■ libuuid.so.1 from package e2fsprogs-libs

■ ibpthread.so.0

■ llibc.so.6

■ libdl.so.2

■ libz.so.1
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■ librt.so.1

■ libSM.so.6

■ libICE.so.6

■ libutil.so.1

■ libssl.so.6

■ libcrypto.so.6

IMPORTANT Note the following additional information on libssl.so.6 and
libcrypto.so.6.

libssl.so.x and libcrypto.so.x are versions of the OpenSSL library that ship with
RHEL. The version number for the required system libraries depends on your
Linux distribution. For example, Fedora 14 uses libcrypto.so.10 and libssl.so.10.

The Maya installer checks to see if there are existing system library versions,
and if so, automatically creates the symbolic links in the Maya lib directory.
In some cases, for example if you are running Maya from a network server,
this process cannot be done automatically.

If there are no system libssl.so.x libcrypto.so.x libraries, you can manually
create local symbolic links. The files are located in
/usr/autodesk/maya2012-x64/support/openssl/.

As root, create the symlinks in the Maya lib directory to isolate them from
the rest of your system. If the installer does not detect a libssl.so.6 library, it
should attempt the following.

su
cd /usr/autodesk/maya2012-x64/lib
ln –s /usr/lib64/libssl.so.8 libssl.so.6
ln –s /usr/lib64/libcrypto.so.8 libcrypto.so.6

Dependent applications

■ tcsh

This is a command language interpreter application. Run the command
yum install tcsh to install.

Dependent 32-bit Backburner monitor libraries

■ php

■ elfutils-libelf

■ glibc
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■ libgcc

■ libstdc++

■ httpd

To ensure that you install the required 32-bit version of these libraries, run
the following commands to install:

(Fedora 14)

yum install elfutils-libelf.i586 glibc.i686
libstdc++.i586 httpd php

(Red Hat Enterprise Linux WS 5.4)

yum install elfutils-libelf.i386 glibc.i686
libstdc++.i386 httpd php

Fonts

Maya also uses some fonts that may not be installed by default. Execute the
following to install these fonts:

yum install liberation-mono-fonts liberation-fonts-common
liberation-sans-fonts liberation-serif-fonts

Differences in operation

When installed on a Linux system, Maya works in much the same way as
when installed on Windows.

Unsupported Maya features

■ Some of the features in the Windows version are not currently supported.
These include output to AVI or SGI movie formats. Please refer to refer to
the Maya Release Notes, available at
www.autodesk.com/maya-readme-2012-enu for more information.

■ You can install most Autodesk products for a trial period of 30 days to
evaluate the product. The 30 day trial for Maya is not available for the
Linux platform.

Linux desktop configuration

To use Maya on Linux, certain default keyboard and mouse bindings must be
changed from the factory settings. These default bindings prevent commands
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from being received by Maya, such as the ones that let you tumble or pan a
view in a panel.

Different Linux window managers have different key bindings and different
procedures for setting them. Linux systems are highly customizable, and many
combinations of Linux system components are possible for use with
Maya—more than can be described (or tested) by Autodesk.

The following instructions give the procedures necessary for changing the
most common configurations.

KDE and Gnome desktop configuration

For Maya to work properly with KDE and Gnome, some modifications should
be made to the mouse control. The default bindings of the Alt key and mouse
buttons do not work well with Maya. Maya 2012 adds support to use the Meta
(Windows) key to act as the Alt key for tumbling. If you want to use the
Alt+mouse buttons for scene tumbling, ensure the bindings do not conflict.

Different versions of KDE and Gnome may have different methods of selecting
the key bindings. See the KDE and Gnome documentation for instructions if
the following steps don’t work for your particular window manager.

KDE under Red Hat

1 Open the KDE Control Center.

2 Select Desktop and then select Window Behavior.

3 Do one of the following:
■ (Red Hat Enterprise Linux WS 5.4) Open the Actions tab.

■ (Fedora 14) Open the Window Actions tab.

4 In the following section:
■ (Red Hat Enterprise Linux WS 5.4) Inner Window, Titlebar & Frame

■ (Fedora 14) Interactive Inner Window, Inner Window, Titlebar &

Frame

For modifier key Meta, set all mouse action combinations to Nothing.

5 Click Apply and close the Control Center.

Gnome under Red Hat

1 Open the Gnome Panel.
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2 Do one of the following:
■ (Red Hat Enterprise Linux WS 5.4) Select Applications, then

Preferences and then select Windows.

■ (Fedora 14) Select System, then Preferences and then select Windows.

3 In the Window Preferences dialog box, set the “To move a window...”
key to Super.

(Setting either Control or Alt here can cause problems when using Maya.)

4 Click Close.

Uninstall Maya on Mac OS X or Linux
To uninstall Maya on Mac OS X

1 Navigate to the Maya directory (by default,
/Applications/Autodesk/Maya2012/).

2 Drag the Maya2012 application to the trash.

3 Open a Terminal window and execute both of the following commands,
where <productKey> is your product key:

adlmreg –u S <productKey> 2012.0.0.F
adlmreg –u N <productKey> 2012.0.0.F

This ensures that product information is properly removed from the
ProductInformation.pit file.

To uninstall Maya on Linux

To uninstall Maya on Linux you can use the rpm utility.

1 Open a shell as a super user.

2 Add /opt/Autodesk/Adlm/R4/lib64/ to LD_LIBRARY_PATH to set your
shared libraries for this session.

For example, by running the following command: export
LD_LIBRARY_PATH=/opt/Autodesk/Adlm/R4/lib64/

3 Run both of the following commands, where <productKey> is your product
key:

/usr/autodesk/Maya2012-x64/bin/adlmreg -u S
<productKey> 2012.0.0.F
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/usr/autodesk/Maya2012-x64/bin/adlmreg -u N
<productKey> 2012.0.0.F

4 List the installed package names by entering:

rpm -qa |egrep 'adlm|Maya'

5 Identify each package name you want to uninstall. For example, the
Maya2012_# package (where # is the package number).

6 Uninstall each package using the following command:

rpm -e PackageName

Install the Maya Help
By default, your installed version of Maya 2012 launches the Help from the
Autodesk.com Web site. You can download and install a copy of the Maya
2012 Help using the following instructions.

Prepare to Install the Maya Help

Before you install the Maya Help, ensure that you have done the following:
■ Install Maya 2012.

■ Download the Autodesk Maya 2012 English Documentation installer for
your platform from www.autodesk.com/maya-helpdownload-enu.

This file installs Maya Help for 32-bit and 64-bit systems.

Install Maya Help on Windows

This section describes how to install a local version of the Maya Help on your
system. You can also install the Maya Help on a shared location such as an
internal network or web server. See Install the Maya Help on a shared location
(page 32).

1 Double-click the Autodesk Maya 2012 English Documentation executable
file.

The installation wizard appears.

2 Extract the Help files to a temporary directory, then click Next.

These files are automatically removed from your system after the
installation completes.

3 Follow the instructions in the installation wizard.
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By default, the Maya Help is installed in the following directory:

■ C:\Program Files\Autodesk\Maya2012\docs\Maya2012\en_US on
Windows 32-bit systems.

■ C:\Program Files(x86)\Autodesk\Maya2012\docs\Maya2012\en_US
on Windows 64-bit systems.

You can change the install location of the docs directory during the
installation if necessary.

4 Start Maya.

5 In Maya, open the Help preferences window by selecting Window >
Settings/Preferences > Preferences.

The Preferences window appears.

6 Under Categories, click Help.

7 In the Help Location section, select Installed Local Help.

8 Click Save and exit the Preferences window.

The Maya 2012 Help is now available from the Help, F1, and context
sensitive help menus.

Install Maya Help on Mac OS X

1 Double-click the Autodesk Maya 2012 English Documentation executable
file.

The Maya Help package appears in a Finder window.

2 Double-click the package (.pkg) file.

The installation wizard appears.

3 Follow the instructions in the installation wizard.

By default, the Maya Help is installed in the following directory:

/Applications/Autodesk/maya2012/docs/Maya2012/en_US.

You cannot change the install location of the docs directory.

4 Start Maya.

5 In Maya, open the Help preferences window by selecting Window >
Settings/Preferences > Preferences.

The Preferences window appears.

6 Under Categories, click Help.

7 In the Help Location section, select Installed Local Help.

8 Click Save and exit the Preferences window.
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The Maya 2012 Help is now available from the Help, F1, and context
sensitive help menus.

Install Maya Help on Linux

This section describes how to install a local version of the Maya Help on your
system. You can also install the Maya Help on a shared location such as an
internal network or web server. See Install the Maya Help on a shared location
(page 32).

1 Extract the Maya Help package from the compressed files you
downloaded.

2 Open a shell as a super user (using su -) and navigate to the directory
where you extracted the packages.

3 Type ./setup and press Enter.

The installation wizard appears.

4 Follow the instructions in the installation wizard.

By default, the Maya Help is installed in the following directory:

/usr/autodesk/maya2012-x64/docs/Maya2012/en_US.

You can change the install location of the docs directory during the
installation if necessary.

5 Start Maya.

6 In Maya, open the Help preferences window by selecting Window >
Settings/Preferences > Preferences.

The Preferences window appears.

7 Under Categories, click Help.

8 In the Help Location section, select Installed Local Help.

9 Click Save and exit the Preferences window.

The Maya 2012 Help is now available from the Help, F1, and context
sensitive help menus.

Install Maya Help on a shared location

On Windows and Linux platforms, you can install the Maya Help to a shared
location, such as internal network or web server, so that it can be accessed by
multiple users. You can then set the Maya Help preferences on individual
systems to access Help from this location.
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NOTE On the Mac OS X systems, you can only install the Maya Help to the default
directory. To use the Maya Help from a shared location, you must copy the docs
directory to a shared location. Individual systems can then set their Help preferences
so they access Help from this location.

When choosing a shared location, ensure that the directory path to the Maya
Help does the following:
■ Points directly to the Help location. For example,

\\CompanyServer\SharedLocation\MayaHelp\docs\Maya2012\en_US.

Do not use an alias path.

■ Points to the directory containing the index.html file. For example, the
path pointing to the English Maya Help ends at the \en_US directory.

■ Uses either http or https protocol for a web server location.

To install Maya Help to a shared location

1 Extract the Maya Help files for your platform and start the installation
wizard as described in steps 1 and 2 of the Maya Help installation
instructions.

See Install the Maya Help on Windows (page 30) and Install the Maya
Help on Linux (page 32).

2 During the installation when asked to confirm the destination folder for
the Help install, depending on your platform, click Change (Windows)
or Browse (Linux), then specify a shared location for the Help.

Individual systems can then set their Help preferences so they access
Help from this location.

To set Help preferences for a shared location

1 Start Maya.

2 In Maya, open the Help preferences window by selecting Window >
Settings/Preferences > Preferences.

The Preferences window appears.

3 Under Categories, click Help.

4 In the Help Location section, select Custom, and then click the 
icon to browse to the shared location of the Maya Help, or type the
directory of http path directly in the Custom field.

5 Click Save and exit the Preferences window.

The Maya 2012 Help is now available from the shared location.
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Install MatchMover, Composite, Backburner,
and DirectConnect

The Maya installer gives you the option of installing Maya Composite,
Autodesk® MatchMover™ camera tracker, Autodesk® Backburner™ network
render queue manager, and Autodesk® DirectConnect. You do not need a
separate license to install and run these applications.

NOTE You must install Maya if you want to install and run MatchMover or
Composite. You can install and run Backburner without Maya.

Install and load the Craft Animations™ plug-in

The following sections describe how to install the Craft Animations plug-in
on Windows, Mac OS X and Linux platforms. It also describes how to load
the plug-in using the Maya Plug-in Manager.
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Install the Craft Animations plug-in

Install the Craft Animations plug-in on Windows

1 Navigate to the 3rdParty folder of your Maya installation DVD or
downloaded package.

2 Navigate to the CraftAnimations folder and double-click the
craftdirectorstudio .exe file.

This starts the Craft Animations plug-in installation.

Install the Craft Animations plug-in on Mac OS X

1 Do one of the following to launch the installer:
■ If you are installing from a DVD, insert the DVD into your drive,

then double-click the Maya DVD icon that appears on your desktop.

Navigate to the Maya/MacOSX folder on the DVD drive.

■ If you are installing from a download package, double-click the Maya
.dmg.

2 In the Finder window that opens, control-click the Install Maya 2012
program, then select Show Package Contents from the pop-up menu.

3 In the Finder window that opens navigate to
Contents/Resources/Maya/AdditionalItems.

4 Double-click the Craft Animations .dmg.

5 In the Finder window that opens, double-click Install.

This launches the Craft Animations plug-in installation.

Install the Craft Animations plug-in on Linux

1 Do one of the following to start the plug-in install:
■ If you are installing from a DVD, insert the DVD into your drive.

■ If you are installing from a download package, extract the Maya
packages from the compressed file.

2 Open a shell and navigate to the location of the extracted files.

3 Extract the craftdirectorstudio .tar.gz file.

4 As a super user (using su -), navigate to the
craftdirectorstudio_11.1.1_installer_maya2012promo directory.

5 Type ./install.bash.

This starts the Craft Animations plug-in installation.
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Load the Craft Animations plug-in

Before using the Craft Animations plug-in for the first time, you need to load
the plug-In using the Plug-in Manager.

To load Craft Animations Director Studio plug-in

1 Start Maya.

2 Select Window > Settings/Preferences > Plug-in Manager. The
Plug-in Manager opens.

3 Locate craftdirectorstudioadaptor_maya2012.mll and turn on Loaded.

To load the plug-in automatically every time you start Maya, turn on
Auto load.

4 Click Close.

You can access the Craft Animations plug-in from the shelf by clicking

the DirectorStudio tab, then clicking the  icon.

Install and load the PhysX® for Maya plug-in

Install the PhysX for Maya plug-in

1 Run the Maya installation wizard.

2 Open the Maya configuration options by clicking Click to open and
configure.
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3 Under Sub-Components, select PhysX.

The PhysX for Maya plug-in will be installed during the Maya 2012
installation.

Load the PhysX for Maya plug-in

Before using the PhysX for Maya plug-in for the first time, you need to load
the plug-In using the Plug-in Manager.

To load PhysX for Maya plug-in

1 Start Maya.

2 Select Window > Settings/Preferences > Plug-in Manager.

The Plug-in Manager opens.

3 Locate physx.mll and turn on Loaded.

To load PhysX automatically every time you start Maya, turn on Auto
load.

4 Click Close.

In Maya, a PhysX  menu is added to the Maya main menu bar and a PhysX
item is added to the shelf. Use these shelf items to access the plug-in.

Install and load the DMM plug-in for Maya
The following sections describe how to install the DMM™ plug-in for Maya
on Windows, Mac OS X, and Linux platforms. It also describes how to load
the plug-in using the Maya Plug-in Manager.

Install the DMM plug-in on Windows

1 Run the Maya installation wizard.

2 Open the Maya configuration options by clicking Click to open and
configure.
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3 Under Sub-Components, select DMM.

The DMM plug-in for Maya is installed during the Maya 2012 installation.

Install DMM plug-in on Mac OS X

1 Run the Maya installation wizard.

2 In the list of components to be installed, ensure that DMM is selected.

The DMM plug-in for Maya is installed during the Maya 2012 installation.

Install the DMM plug-in on Linux

1 Extract the Maya packages from the compressed file you downloaded.

2 Open a shell as a super user (using su -)and navigate to the directory
where you extracted the packages.

3 Type ./setup and press Enter.

This starts the Autodesk Product Configuration wizard.

4 In the list of components you want to install, under Maya, select DMM.

The DMM plug-in for Maya is installed after the Maya 2012 installation
completes.

Load the DMM plug-in

Before using the DMM plug-in for the first time, you need to load the plug-In's
associated files using the Plug-in Manager. To use you all of the plug-in's
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features, you need to ensure that dmm_cinematic.mll and DmmPlugin.py
are both loaded.

To load the DMM plug-in

1 Start Maya.

2 Select Window > Settings/Preferences > Plug-in Manager.

The Plug-in Manager opens.

3 Locate dmm_cinematic.mll and DmmPlugin.py, and then turn on
Loaded for each file.

To load these files automatically every time you start Maya, turn on
Auto load.

4 Click Close.

In Maya, a DMM item is added to the shelf. Use these shelf items to access
the plug-in.

Install mental ray for Maya satellite

Overview of mental ray (satellite)

mental ray for Maya supports a different form of network rendering: mental
ray satellite rendering. The new network rendering capability, based on mental
ray satellite technology, allows you to install a version of mental ray (satellite)
on any networked computer. This special version of mental ray resides on
that machine and waits for rendering tasks from Maya. It supplements the
mental ray rendering capabilities in Maya with the additional rendering power
provided by the networked computers’ CPUs.

A mental ray distributed rendering can speed up all of the following tasks:
■ interactive rendering (through the Maya interface)

■ IPR rendering with mental ray for Maya

■ interactive batch rendering (a batch render started by Maya)

■ command-line rendering
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The rendering process is typically initiated from the master machine (the
machine running Maya or where the command-line render starts from). The
slave machines (satellite rendering computers) process rendering tasks they
receive over the network from the master and send back results. The master
machine handles task distribution, load balancing, and the collection of
received rendering tasks which make up the rendered image.

For more information about mental ray satellite, including how to set up the
rayhosts file to get and receive data from Maya, see the Maya Help. In the
Maya Help, navigate toUser Guide > Rendering and Render Setup >
Rendering > mental ray for Maya rendering > Network rendering
using mental ray for Maya.

Setting up the rayhosts file is required for mental ray for Maya satellite
rendering to work.

Slave machine installation

The special version of mental ray standalone with satellite rendering
technology must be installed on all slave machines. The satellite-enabled
versions of mental ray for Windows, Mac OS X, and Linux are included with
this release of Maya on the Maya DVD.

(Windows) To install mental ray standalone with satellite licensing

1 On each slave machine, begin the installation process by inserting the
Maya DVD, opening the mental ray satellite folder and the
platform-specific Windows folder, and double-clicking the mental ray
standalone installer.

The installer appears.

2 Follow the installation steps.

During the installation, you can click Custom to change the installation
directory. The default installation directory is:

C:\Program
Files\Autodesk\mrsat3.9.1-maya2012

(Mac OS X) To install mental ray standalone with satellite licensing

1 On each slave machine, begin the installation process by inserting the
Maya DVD, opening the mental ray satellite folder and double-clicking
the mental ray standalone installer.
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2 Follow the installation steps.

During the installation, you can change the installation directory. The
default installation directory is:

/Applications/Autodesk/mrsat3.9.1-maya2012

(Linux) To install mental ray standalone with satellite licensing using rpm

1 Log in as root.

2 On each slave machine, begin the installation process by inserting the
Maya DVD.

3 Mount the DVD drive, if necessary. For example, type:

mount
-r /dev/dvd /mnt/dvd

4 Open the mental ray satellite directory, go to the Linux directory, and
enter the following command (where # is the specific package number):

rpm –ivh mentalraySatellite3.9.1_maya2012-3.9-#.x86_64.rpm

NOTE 64-bit Windows releases of mental ray for Maya satellite use the same
port and service name as the 32-bit version. You will run into problems if
you install both the 32-bit and the 64-bit versions on a 64-bit system. There
is only one service entry/xinetd config, so installing a 64-bit package after
the 32-bit (or the other way around) leaves only the last installed version
working.

Slave machine additional setup

Once this version of mental ray is installed and running, a service on the
machine (the Ray Sat server) waits for rendering tasks from mental ray for
Maya on the master machine. The satellite-enabled version of mental ray does
not require its own licensing; it is activated through Maya’s licensing.

On the slave machine, the Ray Sat server (service name: mental ray Satellite
3.9.1 for Maya 2012) must be running. To verify that it is running on Windows,
follow this procedure.

To verify that Ray Sat server is running (Windows)

1 Open a Windows command prompt.
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2 Navigate to the bin directory of the mental ray satellite standalone. By
default this is C:\Program Files\Autodesk\mrsat3.9.1-maya2012\bin\.

3 Type the following:

raysat2012server
/query

A message should be returned that the RaySat2012 Server service is
running.

If you do not get this message, make sure that RaySat2012 Server has
been installed as a service, and start it from the Services Control Panel
(Settings > Control Panel > Administrative Options > Services)
or type the following:

raysat2012server
/start

Slave machine port setup

On the slave machine, port number 7412 is set by default. This works well in
the majority of cases and you won’t need to change the port number.

If you want to change the port number that mental ray satellite uses to a value
other than 7412, you must edit the services file. The port value would be
determined by your network administrator (a free TCP/IP port).

To change the port number (Windows, Linux)

1 Edit the services file with a text editor.

The services file is located at:

■ (Windows XP) C:\Windows\system32\drivers\etc\services

■ (Linux) /etc/services

2 Change the number in the following line (here, 7412) to the desired port
number:

mi-raysat2012
7412/tcp

To change the port number (Mac OS X 10.4, Tiger)

1 Log in as superuser (sudo -s).
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2 Open the file /etc/services using your preferred text editor.

3 Edit the line: mi-raysat2012 7412/tcp.

4 Save the file.

5 From the Finder menu, select Go > Applications and then double-click
the Utilities folder.

6 Double-click the NetInfo Manager icon.

7 Under the Services directory of the NetInfo database, find and select the
appropriate service (mental ray Satellite 3.9.1 for Maya 2012).

8 Click the lock icon at the bottom of the panel and then enter your
administrator user name and password. This allows you to unlock the
NetInfo database and make changes.

9 Select the port field and change its value to the desired port number.

10 Click the lock icon again when you’re done.

11 From the Finder menu, select Domain > Save Changes to commit
your changes to the NetInfo database.

12 Reboot your machine.

To change the port number (Mac OS X 10.5, Leopard)

1 Log in as superuser (sudo -s).

2 Open the file /etc/services using your preferred text editor.

3 Edit the line: mi-raysat2012 7412/tcp.

4 Save the file.

5 Open a Terminal window and do the following:

sudo
/usr/bin/dscl . -change /Services/mi-raysat2012port
<currentportnumber>
<newportnumber>

For example:

sudo
/usr/bin/dscl . -change /Services/mi-raysat2012 port
7109 7412

NOTE To determine the port you’re currently using, in a Terminal window,
type: /bin/dscl . -read /Services/mi-raysat2012

6 Reboot your machine.
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Licensing of satellite rendering

For standalone licenses, the use of mental ray for Maya with satellite can only
be initiated from the specified host for which your received your Maya key.
The workstation can distribute mental ray for Maya rendering to up to eight
slave CPUs.

For networked licenses, use of the functionality is slightly more flexible. For
networked license setups, the license running Maya and the license running
mental ray for Maya can be logged out separately, allowing certain rendering
tasks to be initiated remotely.

There are two possible cases when using mental ray for Maya with networked
licenses:
■ (Interactive) With Maya running interactively on a workstation, initiate a

mental ray for Maya render (either a single frame in the Render View, Batch
render or command line render) on the workstation. The networked mental
ray for Maya portion of your license is logged out. This allows the mental
ray satellite slaves indicated in your rayhost file to participate in the render.

■ (Offline) If you launch a command line mental ray for Maya render, the
computer you launched the command from then becomes the master
machine for mental ray for Maya satellite rendering.

NOTE If you have launched Maya but have not yet rendered with mental ray
for Maya since the start of your interactive session, no mental ray for Maya line
item from your networked license is checked out. You may therefore start a
command line mental ray for Maya render from another host. This checks out
the mental ray for Maya portion of the license, making it unavailable for any
other workstation, including the workstation of the user who launched Maya.

For more details on mental ray rendering, see the Rendering sections of the
Maya Help, as well as the mental ray reference included with the Maya
Help.
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Installation Information
Specific to Autodesk
MotionBuilder 2012

Certain items are unique to the Autodesk® MotionBuilder® install process (in contrast
with other Autodesk products). In this chapter learn about the default installation
paths, installing the 32-bit version of MotionBuilder on a 64-bit machine, switching
to the local version of the Help, and accessing the Japanese Help.

Installation and Registration

Install and register MotionBuilder 2012 by following the on-screen installation instructions.

The default installation paths are as follows:

1 For Microsoft® Windows® XP x32 Edition:

C:\Program Files\Autodesk\MotionBuilder 2012 (32-bit).

2 For Microsoft® Windows® XP x64 Edition:

C:\Program Files\Autodesk\MotionBuilder 2012 (64-bit).

3 For Microsoft® Windows® Vista® Enterprise x64 Edition:

C:\Program Files\Autodesk\MotionBuilder 2012 (64-bit).

4 For Microsoft® Windows® 7® Enterprise x64 Edition:

C:\Program Files\Autodesk\MotionBuilder 2012 (64-bit).

If you choose to install the 32-bit version of MotionBuilder on a 64-bit machine, the default
installation paths are as follows:

1 For Microsoft® Windows® XP x64 Edition:

C:\Program Files (x86)\Autodesk\MotionBuilder 2012 (32-bit).

2 For Microsoft® Windows® Vista® Enterprise x64 Edition:

C:\Program Files (x86)\Autodesk\MotionBuilder 2012 (32-bit).
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3 For Microsoft® Windows® 7® Enterprise x64 Edition:

C:\Program Files (x86)\Autodesk\MotionBuilder 2012 (32-bit).

Installing a 32-bit Product on a 64-bit Operating System

You can manually override the installer's default behavior, which automatically installs the
64-bit product on a 64-bit computer. For a stand-alone installation, navigate to the root
directory of the install media, and launch the 32-bit installer, which has a file name of
Setup_32.exe or similar. For a deployment, you can select the 64-bit target platform, and
specify the 32-bit version of a product.

Switch from Online (Default) to Local Help

By default the Help in MotionBuilder is Internet-based. If you do not have reliable Internet
access, you can download the MotionBuilder Help from the Autodesk Web site and install
it locally as follows.

1 Download and run the Help installer from
http://www.autodesk.com/motionbuilder-helpdownload-enu .

2 Once installed, select Settings > Preferences, then expand the Help section in the
Preferences window.

3 Do one of the following, depending on whether you installed the Help to the default
location:
■ If you installed the Help to the default location, set Help Location to Local

Computer/Network.

■ If you installed the Help to an alternative location, click Browse to locate the
custom local or network location of the MotionBuilder help. You can also click
Reset, which prompts MotionBuilder to automatically find the location you
specified for the documentation.

4 Click Ok to close the Preferences window.

5 Click Ok when the Configuration file update confirmation dialog box appears
on your screen.

The locally installed MotionBuilder Help is now available from the Help, F1, and
context-sensitive Help buttons.
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Accessing the Japanese Help

By default the Japanese Help in MotionBuilder is internet-based. You can access this Help
from your F1 key by making the following adjustments to the Help Preferences:

1 Select Settings > Preferences, then expand the Help section in the Preferences
window.

2 Set Help Location to Local Computer/Network.

3 Enter  http://download.autodesk.com/global/docs/motionbuilder2012/ja_JP as the location
for the documentation.

4 Click Ok to close the Preferences window.

5 Click Ok when the Configuration file update confirmation dialog box appears
on your screen.

The Japanese Help is now available from the Help, F1, and context-sensitive Help
buttons.
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Installation Information
Specific to Autodesk
Mudbox

Certain items are unique to the Autodesk® Mudbox® install process (in contrast
with other Autodesk products). In this chapter learn about the process for switching
to the local version of the help and how to install the 32-bit version of Mudbox on
a 64-bit machine. Refer to the following sections:
■ Install the Mudbox Help locally (page 50)

■ Install a 32-bit Product on a 64-bit Operating System (page 15)

If you are installing Mudbox on Mac OS X or Linux, refer to the Mudbox Installation
Overview and FAQ at www.autodesk.com/mudbox-faq-2012-enu .

For late-breaking information, you can also review the Mudbox Release Notes
available at www.autodesk.com/mudbox-readme-2012-enu.

Additional Mudbox resources

You can find the following additional Mudbox resources online:
■ The complete Autodesk Mudbox 2012 Installation Overview and FAQ at

www.autodesk.com/mudbox-faq-2012-enu.

■ The Autodesk Mudbox 2012 documentation at  www.autodesk.com/mudbox-help-2012-enu.

■ A listing of the most current qualified hardware and operating systems at
www.autodesk.com/mudbox-systemreq-2012-enu.

■ Mudbox licensing information at  www.autodesk.com/me-licensing-2012-enu.
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Install the Mudbox Help locally
By default, Mudbox calls an Autodesk web server to display the Mudbox Help.
You must have Internet access to view the Help. This ensures you have the
most up-to-date version of the Help and allows Autodesk to make updates to
the Help between software releases.

If you do not have reliable Internet access, you can download the Mudbox
Help from the Autodesk Web site and install it locally as follows.

Prepare to install the Mudbox Help

Before you install the Mudbox Help, ensure that you do the following:
■ Install Mudbox

■ Download the Autodesk Mudbox 2012 English Documentation executable
file for your platform from www.autodesk.com/mudbox-helpdownload-enu.
This file installs Mudbox Help for 32-bit and 64-bit systems.

Install the Mudbox Help

(Windows)

1 Download and run the Help installer from
www.autodesk.com/mudbox-helpdownload-enu, following the instructions
in the installer.

By default, the Mudbox Help is installed in the following directory:
Program Files\Autodesk\Help\mudbox2012\.

2 Start Mudbox.

3 Select Windows > Preferences to open the Preferences window.

4 Expand the Help section and set Help Location to Installed Local
Help.

5 Click Ok to exit the Preferences window.

Once installed, the local Mudbox 2012 Help is available when you select
Help > Mudbox Help, press F1, or click the Help button in various
Mudbox windows.

(Mac OS X)

1 Double-click the Autodesk Mudbox 2012 English Documentation
executable file you download from
www.autodesk.com/mudbox-helpdownload-enu.
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The Mudbox Help package appears in a Finder window.

2 Double-click the package (.pkg) file.

3 Follow the instructions in the Help installer that appears.

By default, the Mudbox Help is installed in the following directory:
/Applications/Autodesk/Mudbox2012/docs/mudbox2012/en_US.

4 Start Mudbox.

5 Select Mudbox > Preferences  to open the Preferences window.

6 Expand the Help section and set Help Location to Installed Local
Help.

7 Click Ok to exit the Preferences window.

Once installed, the local Mudbox 2012 Help is available when you select
Help > Mudbox Help, press F1, or click the Help button in various
Mudbox windows.

(Linux)

1 Extract the Mudbox Help package from the compressed files you
download from www.autodesk.com/mudbox-helpdownload-enu.

2 Open a shell as a super user (using su -) and navigate to the directory
where you extracted the packages.

3 Type ./setup and press Enter.

4 Follow the instructions in the Help installer that appears.

By default, the Mudbox Help is installed in the following directory:
/usr/Autodesk/Mudbox2012-x64/docs/mudbox2012/en_US.

5 Start Mudbox.

6 Select Windows > Preferences to open the Preferences window.

7 Expand the Help section and set Help Location to Installed Local
Help.

8 Click Ok to exit the Preferences window.

Once installed, the local Mudbox 2012 Help is available when you select
Help > Mudbox Help, press F1, or click the Help button in various
Mudbox windows.

NOTE You can also set the Help Location preference to Custom if you have
manually copied the Mudbox Help files to your computer, or if you want to access
the Help from a location not on your own machine (for example, to point to a
common location on your network). Refer to the instructions in the following
section, Install the Mudbox Help in a shared location.
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Install the Mudbox Help in a shared location

You can install the Mudbox Help on a shared location, such as internal network
or web server, so that it can be accessed by multiple users. You can then set
the Mudbox Help preferences on individual systems to access the Help from
the shared location.

When designating a directory path to the shared location of the Mudbox Help,
ensure that:
■ The path points directly to the Help location. For example,

\\CompanySever\SharedLocation\MudboxHelp\docs\Mudbox2012\en_US.

Do not use an alias path.

■ The path points to the directory containing the index.html file. For
example, the path pointing to the English Mudbox Help ends at the \en_US
directory.

■ Either http or https protocol is used for a web server location.

To install Mudbox Help to a shared location

1 Download and run the Help installer from
www.autodesk.com/mudbox-helpdownload-enu, following the instructions
in the installer.

2 When asked where to install the Mudbox Help files, click Change
(Windows) or Browse (Linux) and specify a shared location for the
Help.

NOTE

On Mac OS X, you can only install the Help to the default location. To
install the Mudbox Help in a shared location, you must first install to
the default location (
/Applications/Autodesk/Mudbox2012/docs/mudbox2012/en_US), then
manually copy the docs directory to your desired location.

Individual users can then set their Help preferences to access the Mudbox
Help from this shared location.

To access Mudbox Help from a shared location

1 Start Mudbox.

2 (Windows and Linux) Select Windows > Preferences to open the
Preferences window.
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(Mac OS X) Select Mudbox > Preferences  to open the Preferences
window.

3 Expand the Help section and set Help Location to Custom, then
enter the shared location of the Mudbox Help in the Help Path field.

4 Click Ok to exit the Preferences window.

The Mudbox Help is now accessed from the shared location.

Installing a 32-bit Product on a 64-bit
Operating System

You can manually override the installer's default behavior, which automatically
installs the 64-bit product on a 64-bit computer. For a stand-alone installation,
navigate to the root directory of the install media, and launch the 32-bit
installer, which has a file name of Setup_32.exe or similar. For a deployment,
you can select the 64-bit target platform, and specify the 32-bit version of a
product.
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Installation Information
Specific to Autodesk
Showcase

This topic describes important information on installing and setting up Autodesk
Showcase, including how to:
■ Install Showcase Professional (page 55)

■ Switch from Online (Default) to Local Help (page 56)

■ Run Showcase in Kiosk Mode (page 58)

For last-minute news and information on Showcase installation and other important
issues, see the Showcase Readme at http://autodesk.com/showcase-readme-2012-enu.

Install Showcase Professional

NOTE Showcase Professional is not included in any Autodesk suite offering.

The process to install and use a Showcase Professional license varies depending
on your circumstance, as described here. You may need to first install Showcase
using a standard (that is, not Professional) license. In some cases, you may need
to download and run the Showcase Professional Licensing Utility. The Showcase
Professional Licensing Utility can be downloaded from
http://www.autodesk.com/showcaseprolicensing.

If you have a standalone Showcase license that came with the Showcase DVD,
and you have a license server that hosts Professional licenses:

1 Run the Showcase installation DVD and enter the standard Showcase
product key when prompted.
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2 Run the Showcase Professional Licensing Utility and enter the Showcase
Professional network product key when prompted.

If you do not have a license from a Showcase DVD, and your license server
hosts both Professional and standard Showcase licenses:

1 Run the Showcase installer and enter the network Showcase standard
product key when prompted.

2 Run the Showcase Professional Licensing Utility and enter the network
Showcase Professional product key when prompted.

If you do not have a license from a Showcase DVD, and if your license server
hosts Showcase Professional licenses but not standard Showcase licenses:

■ Run the Showcase installer and enter the network Showcase Professional
product key when prompted.

NOTE Check with your license server administrator to make sure the server does
not host standard Showcase licenses.

If you have both standard and Professional standalone Showcase DVD licenses
(no license servers):

1 Run the Showcase installation DVD and enter the standard Showcase
product key when prompted.

2 Run the Showcase Professional Licensing Utility and enter the Showcase
Professional standalone product key when prompted.

If you have a Showcase Professional license from a DVD, and you have a
license server that hosts standard Showcase licenses:

1 Run the Showcase installation DVD and enter the network Showcase
standard product key when prompted.

2 Run the Showcase Professional Licensing Utility and enter the Showcase
Professional standalone product key when prompted.

Switch from Online (Default) to Local Help
By default Autodesk Showcase Help is internet-based. If you do not have a
dedicated internet connection, you can install the help to your local hard
disk. Do this in one of two ways.
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Install Showcase help at the end of application installation:

1 On the last screen of the Showcase installation wizard, a list of installed
components appears, and beside the Showcase component, a blue
information icon is displayed.

Hover the mouse pointer over the blue icon to see a link.

2 Click the link and follow the instructions to install the help.

Install Showcase help at any time:

1 Go to http://www.autodesk.com/showcase-helpdownload-enu.

2 Follow the instructions to install the help.

Once help is installed locally, Showcase will detect it and use it from that
point onward. If you want Showcase to resume pointing to the internet-based
help, you must uninstall the local copy of the help.

To uninstall the local copy of Showcase help:

■ In Windows Control Panel, open Uninstall / Add or Remove Programs.

■ Select "Autodesk Showcase 2012 Language Documentation" and click
Uninstall / Remove.

The next time you start Showcase, the internet-based help will be used.
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NOTE Showcase Customization Help is only available in English at this time.

Run Showcase in Kiosk Mode
As of the 2012 release, the "Presenter" version of Showcase is no longer
available. However, you can get all the features of Showcase Presenter by
running Showcase 2012 in "Kiosk" mode. First, you need to create a shortcut
that will start Showcase in this mode, using the "-kiosk" parameter.

To create a shortcut that starts Showcase in Kiosk mode:

1 In Windows Explorer, right-click inside the folder where you want to
place the shortcut.

2 Select New > Shortcut.

3 In the location box, enter the following:

Showcase_application_path_in_quotes -kiosk

So for example, your shortcut could look like this:

"C:\Program Files\Autodesk\Showcase 2012\bin\Showcase.exe"
-kiosk

You could also add in the "-borderless" parameter, so that there are no main
window borders and no heads-up display messages, as well as the "-fullscreen"
parameter:

"C:\Program Files\Autodesk\Showcase 2012\bin\Showcase.exe"
-kiosk -borderless -fullscreen

Finally, if you want to specify an initial scene to open in Kiosk mode, use the
file parameter:

-file file_path_and_name_in_quotes

So, your shortcut could look like this:

"C:\Program Files\Autodesk\Showcase 2012\bin\Showcase.exe"
-kiosk -borderless -fullscreen -file
"C:\Users\myaccount\Documents\mycomputer\MyScenes\My_Demo.a3s"

Once your shortcut is created, double-click it to run Showcase in Kiosk mode.

Remember that in Kiosk mode, Showcase only responds to Web server inputs.
You will not be able to interact with Showcase without Web server inputs,
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and the only way to load a different scene during your Kiosk session is through
the Web server.

TIP To close the Kiosk mode of Showcase without using a Web server, right-click
it in the Windows task bar and select the Close command for your version of
Windows.

For a complete list of available parameters and their descriptions, run Showcase
from a Windows command prompt using the "-help" parameter; for example:

"C:\Program Files\Autodesk\Showcase 2012\bin\Showcase.exe"
-help
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Installation Information
Specific to Autodesk
Softimage

The answers to many of your Softimage-specific installation and licensing questions
can be found on the Softimage Support site where you can quickly access the top
support issues or search the Support knowledge base.

Late-breaking information and troubleshooting tips are always available from the
Softimage Support Blog and in the Softimage Release Notes on the wiki.

Important Information Links

■ Softimage Product Center: www.autodesk.com/softimage

■ Softimage Support: www.autodesk.com/softimage-support

■ Softimage Support Blog: xsisupport.wordpress.com

■ Softimage Wiki: www.autodesk.com/softimage-wiki

■ Softimage Release Notes: www.autodesk.com/softimage-whatisnew
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