








7 After specifying the License Server System or the Network License file,
the 3ds Max will start and continue to run in Network license mode.

NOTE If you wish to switch from a Network to a Standalone license, you need to
perform a full uninstall/reinstall with the Strandalone License mode selected during
reinstallation.

Installation Information Specific to Autodesk
Maya

Installation Information Specific to Autodesk
Maya 2013

Certain items are unique to the Autodesk® Maya® install process (in contrast
with other Autodesk products). In this chapter, learn how to install the 32-bit
version of Maya on a 64-bit machine, and how to install a local copy of the
Maya Help.

This chapter also includes information on installing and uninstalling Autodesk
Maya for Mac OS X and Linux.

Installing a 32-bit Product on a 64-bit Operating
System

You can manually override the installer's default behavior, which automatically
installs the 64-bit product on a 64-bit computer. For a stand-alone installation,
navigate to the root directory of the install media, and launch the 32-bit
installer, which has a file name of Setup_32.exe or similar. For a deployment,
you can select the 64-bit target platform, and specify the 32-bit version of a
product.
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Install Maya on Mac OS X

To install Maya on Mac OS X

1 Do one of the following to launch the installer:
■ If you are installing from a DVD, insert the DVD into your drive,

then double-click the Maya DVD icon that appears on your desktop.

Navigate to the Maya/Mac OS X folder on the DVD drive.

■ If you are installing from a download package, double-click the Maya
.dmg.

2 In the Finder window, double-click the Install Maya 2013 program.

The Maya Installer starts.

3 Follow the instructions in the Maya Installer to install the product.

For example, in the License window, do the following:

■ Enter your 11-digit serial number.

■ Enter your Product Key.

■ Select your License type: Standalone or Network.

If you select the Network license type, click Use existing license
server and enter your license server name in the Server Name field.
Contact your network administrator to find your license server name.
If you have access to the license server machine, you can also find
its name by opening a Terminal window (Applications > Utilities
> Terminal) and typing:
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hostname <enter>

■ Click Continue.

4 In the final window that confirms a successful installation, click Done.

By default, Maya is installed in the following directory:
/Applications/Autodesk/maya2013/.
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NOTE As indicated in the final installer screen, the Maya Help is
Internet-based. When you press F1 or select Help > Maya Help, the Help
launches from an Autodesk web server. If you do not have reliable Internet
access, you can download a copy of the Help from www.autodesk.com/maya-
helpdownload-enu.

Install Maya on Linux

This section provides detailed information on installing Maya on Linux.

Install Maya on Linux using the installation wizard

To install Maya on Linux

1 Do one of the following to start the Maya install:
■ If you are installing from a DVD or USB, insert the install media into

your drive.

■ If you are installing from a download package, extract the Maya
packages from the compressed file.

2 Open a shell as a super user (using su -) and navigate to the directory
where you extracted the packages.

NOTE Recent Linux distributions may require a full super user environment
to run the installer as root. You can use su - to obtain the proper level.
(Note the trailing dash.)

3 Type ./setup and press Enter.

This starts the Maya Installer.
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4 Follow the instructions in the Maya Installer to install the product.

For example, in the License information window, do the following:

■ Enter your 11-digit serial number.

■ Enter your Product key.

■ Select your License type: Standalone or Network.

If you select the Network license type, enter your license server name
in the Server name field that appears. Contact your network
administrator to find your license server name.

■ Click Continue.
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5 In the final window that confirms a successful installation, click Done.

By default, Maya is installed in the following directory:
/usr/autodesk/maya2013-x64.

NOTE The Maya Help is now Internet-based. When you press F1 or select
Help > Maya Help, the Help launches from an Autodesk web server. If you
do not have reliable Internet access, you can download a copy of the Help
from www.autodesk.com/maya-helpdownload-enu.

Install Maya on Linux using the rpm utility

With the rpm command line utility, you can use either the -i flag or the -ivh
flag to install the programs. The -ivh flag provides you with more information
during the installation.

To install Maya on Linux using the rpm utility

1 Open a shell as a super user (using su -).

2 Do one of the following:
■ Insert the install media (DVD or USB) and mount the drive. For

example, type: mount -r /dev/dvd /mnt/dvd.
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■ Extract the Maya packages from the compressed file you downloaded,
then change to the directory where you extracted the Maya packages.

3 Use the ls command to list the packages.

The packages you see will be similar to the following, where # indicates
the specific package numbers.

RequiredDescriptionPackage name

YesMaya for LinuxMaya2013_0_64-2013.0-
#.x86_64.rpm

YesAutodesk licensingadlmapps5-
5.#.x86_64.rpm

Only for stand-alone li-
censing (Not required if

Autodesk stand-alone li-
censing

adlmflexnetclient-
5.#.x86_64.rpm

you use network licens-
ing)

NoLicense server tools (for
network licensing)

adlmflexnetserver-
5.#.x86_64.rpm

NoCompositeComposite_2013-2013.0-
#.x86_64.rpm

NoAutodesk Backburnerbackburner.sw.base-2013-
#.i386.rpm

NoAutodesk Backburner
web monitor

backburner_webmonit-
or.sw.base-2013-
#.i386.rpm

NoAutodesk Backburner
monitor

autodesk.backburner.mon-
itor-2013.0.0-#.i386.rpm

NoMatchMoverMatchMover2013_0_64-
2013.0-#.x86_64.rpm
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4 To install the required software, enter either of the following commands
(where # indicates the specific package numbers), depending on whether
you are installing Maya on a computer with Mudbox already installed:
■ To install Maya alone, enter:

rpm -ivh Maya2013_0_64-2013.0-#.x86_64.rpm
adlmapps5-5.#.x86_64.rpm
adlmflexnetclient-5.#.x86_64.rpm

■ To install Maya with Mudbox, enter:

rpm -ivh --force Maya2013_0_64-2013.0-#.x86_64.rpm
adlmapps5-5.#.x86_64.rpm
adlmflexnetclient-5.#.x86_64.rpm

Maya 2013 adds the required libXm.so.3 library to the Maya lib directory
as part of its standard install, so installing the openMotif runtime rpm
is not required.

5 Look for a file named libGL.so in the /usr/lib/ or /usr/X11R6/lib
directory to verify that OpenGL is installed.

NOTE /usr/lib is normally 32-bit on Red Hat, Fedora, and SuSE
distributions, but may be 64-bit for Ubuntu and Debian distributions. Some
distributions include the system OpenGL driver mesa-GL, which is not ideal
for running Maya. Maya is a 64-bit application and requires a 64-bit OpenGL
3D-accelerated driver for best performance.

TIP To easily check which OpenGL driver is installed, use the glxinfo
program to list the top portion of the output, then look for the driver and
renderer strings. For example:

glxinfo | less

6 (Optional) For information on installing the Maya documentation
package, see Install the Maya Help (page 39).

By default, the Maya Help is Internet-based, so launching the Help within
Maya calls an Autodesk web server to display the documentation.

7 Run the following command to set whether you are using a network or
a stand-alone license:

/usr/autodesk/maya2013-x64/bin/licensechooser
/usr/autodesk/maya2013-x64/ <licensetype> unlimited

where you specify standalone or network for <licenseType>.
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This updates the license.env file (used by the Autodesk licensing software)
with your license type information.

8 Add /opt/Autodesk/Adlm/R5/lib64/to LD_LIBRARY_PATH to set your
shared libraries for this session.

For example, you can run the following command in a BASH shell:

export LD_LIBRARY_PATH=/opt/Autodesk/Adlm/R5/lib64/

9 Run the following commands to register Maya with the Autodesk
licensing software, where <productKey1> and <productKey2> are your product
keys, and <serialNum> is your serial number.

NOTE

If you purchased Maya as part of a suite, enter your Maya product key
as productKey1, and your suite product key as productKey2.
If you purchased Maya alone and received only one product key, you can
enter the Maya product key for both <productKey1> and <productKey2>.

■ (Stand-alone licensing)

/usr/autodesk/maya2013-x64/bin/adlmreg -i S
<productKey1> <productKey2> 2013.0.0.F <serialNum>
/var/opt/Autodesk/Adlm/Maya2013/MayaConfig.pit

■ (Network licensing)

/usr/autodesk/maya2013-x64/bin/adlmreg -i N
<productKey1> <productKey2> 2013.0.0.F <serialNum>
/var/opt/Autodesk/Adlm/Maya2013/MayaConfig.pit

For example:

/usr/autodesk/maya2013-x64/bin/adlmreg -i S 657E1 657E1

2013.0.0.F 000-00000000
/var/opt/Autodesk/Adlm/Maya2013/MayaConfig.pit

This step updates the product information .pit file, which you can copy
to other machines that have the same configuration if you are installing
many instances of Maya.

These commands return a Registration succeeded message, and you
can now run Maya using your stand-alone or network license.
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Additional Linux notes

This section provides information for configuring Maya to run on Linux,
describes differences between Maya for Linux and other versions of Maya, and
provides other information specific to using Maya on the Linux operating
system. For complete information on limitations and possible workarounds,
also refer to the Maya Release Notes, available at www.autodesk.com/maya-
readme-2013-enu.

Compiling plug-ins and standalone programs

To compile plug-ins and standalone applications for Maya 2013 on Linux,
use the released gcc 4.1.2 compiler. Maya has been compiled with this compiler
under CentOS 6.0 WS.

In addition, Maya uses some component libraries that may already exist on
your system (for example, Qt, Python, OpenAL, Intel TBB, MKL, Cg). These
libraries are installed in the /lib directory under your Maya installation
directory, and should not interfere with the normal operation of your Linux
system. In some cases, your system may include newer versions of these
libraries, which may or may not be compatible with Maya.

NOTE Maya requires its own versions of the Qt libraries to run properly.

For more information, see the API Guide at www.autodesk.com/maya-sdkdoc-
2013-enu.

Installing additional required packages and fonts

On Linux, especially on Fedora systems, not all system libraries required to
run Maya are included in the default installation of the operating system. You
can use yum to find any additional system-dependent library packages and get
the required runtime libraries.

For example, to install some of the following dependent libraries, you can
execute the following commands:
■ yum install mesa-libGLw

■ yum install libXp

■ yum install gamin audiofile audiofile-devel e2fsprogs-libs

Dependent OpenGL libraries (vendor Nvidia/AMD supplied)

■ libGL.so from Nvidia/AMD 3rd party library
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■ libGLw.so.1 from mesa-libGLw

Dependent X Windows libraries

■ libXp.so.6 from package libXp

■ libXmu.so.6 from package libXmu

■ libXpm.so.4 from package libXp

■ libXt.so.6 from package libXt

■ libXi.so.6 from package libXi

■ libXext.so.6 from package libXext

■ libX11.so.6 from package libX11

■ libXinerama.so.1 from package libinerama

■ libXau.so.6 from package libXau

■ libxcb.so.1 from package libxcb

Dependent System libraries

■ libfam.so.0 from package gamin

■ libaudiofile.so.0 from package audiofile

■ libaudiofile.so from package audiofile-devel

■ libuuid.so.1 from package e2fsprogs-libs

■ ibpthread.so.0

■ llibc.so.6

■ libdl.so.2

■ libz.so.1

■ librt.so.1

■ libSM.so.6

■ libICE.so.6

■ libutil.so.1

■ libssl.so.6

■ libcrypto.so.6

IMPORTANT Note the following additional information on libssl.so.6 and
libcrypto.so.6.
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libssl.so.x and libcrypto.so.x are versions of the OpenSSL library that ship with
RHEL. The version number for the required system libraries depends on your
Linux distribution. For example, Fedora 14 uses libcrypto.so.10 and libssl.so.10.

RHEL 6 and CentOS 6 provide a compatibility package for libssl.so.6 and
libcyrpto.so.6. Install this package before installing Maya.

yum install openssl098e-0.9.8e

The Maya installer checks to see if there are existing system library versions,
and if so, automatically creates the symbolic links in the Maya lib directory.
In some cases, for example if you are running Maya from a network server,
this process cannot be done automatically.

If the system versions of the library exist, use them.

su
cd /usr/autodesk/maya2013-x64/lib
ln –s /usr/lib64/libssl.so.10 libssl.so.6
ln –s /lib64/libcrypto.so.10 libcrypto.so.6

If there are no versions of libssl.so and libcrypto.so on the system, as a last
resort you can use the files located in
/usr/autodesk/maya2013-x64/support/openssl/.

If you need to use the files found in the support directory, copy the files to
the Maya lib directory with the following names:

su
cd /usr/autodesk/maya2013-x64/lib
cp ./support/openssl/libssl.so.6 libssl.so.6
cp ../support/openssl/libcrypto.so.6 libcrypto.so.6
cp ../support/openssl/libcrypto.so.6 libcrypto.so.0.9.8

Dependent applications

■ tcsh

This is a command language interpreter application. Run the command
yum install tcsh to install.

Dependent 32-bit Backburner monitor libraries

■ php

■ elfutils-libelf

■ glibc

■ libgcc
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■ libstdc++

■ httpd

To ensure that you install the required 32-bit version of these libraries, run
the following commands to install:

(RHEL 6.x/CentOS 6.0/Fedora 14)

yum install elfutils-libelf.i586 glibc.i686
libstdc++.i586 httpd php

Fonts

Maya also uses some fonts that may not be installed by default. Execute the
following to install these fonts:

yum install xorg-x11-fonts-ISO8859-1-100dpi
yum install xorg-x11-fonts-ISO8859-1-75dpi
yum install liberation-mono-fonts liberation-fonts-common
liberation-sans-fonts liberation-serif-fonts

Differences in operation

When installed on a Linux system, Maya works in much the same way as
when installed on Windows.

Unsupported Maya features

■ Some of the features in the Windows version are not currently supported.
These include output to AVI or SGI movie formats. Please refer to refer to
the Maya Release Notes, available at www.autodesk.com/maya-readme-2013-
enu  for more information.

■ You can install most Autodesk products for a trial period of 30 days to
evaluate the product. The 30 day trial for Maya is not available for the
Linux platform.

Linux desktop configuration

To use Maya on Linux, certain default keyboard and mouse bindings must be
changed from the factory settings. These default bindings prevent commands
from being received by Maya, such as the ones that let you tumble or pan a
view in a panel.

Different Linux window managers have different key bindings and different
procedures for setting them. Linux systems are highly customizable, and many
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combinations of Linux system components are possible for use with
Maya—more than can be described (or tested) by Autodesk.

The following instructions give the procedures necessary for changing the
most common configurations.

KDE and Gnome desktop configuration

For Maya to work properly with KDE and Gnome, some modifications should
be made to the mouse control. The default bindings of the Alt key and mouse
buttons do not work well with Maya. Maya 2013 adds support to use the Meta
(Windows) key to act as the Alt key for tumbling. If you want to use the
Alt+mouse buttons for scene tumbling, ensure the bindings do not conflict.

Different versions of KDE and Gnome may have different methods of selecting
the key bindings. See the KDE and Gnome documentation for instructions if
the following steps don’t work for your particular window manager.

KDE under Red Hat

1 Open the KDE Control Center.

2 Select Desktop and then select Window Behavior.

3 Do one of the following:
■ (Red Hat Enterprise Linux WS 6.x) Open the Actions tab.

■ (Fedora 14) Open the Window Actions tab.

4 In the following section:
■ (Red Hat Enterprise Linux WS 6.x) Inner Window, Titlebar & Frame

■ (Fedora 14) Interactive Inner Window, Inner Window, Titlebar &

Frame

For modifier key Meta, set all mouse action combinations to Nothing.

5 Click Apply and close the Control Center.

Gnome under Red Hat

1 Open the Gnome Panel.

2 Do one of the following:
■ (Red Hat Enterprise Linux WS 6.x) Select Applications, then

Preferences and then select Windows.

■ (Fedora 14) Select System, then Preferences and then select Windows.
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3 In the Window Preferences dialog box, set the “To move a window...”
key to Super.

(Setting either Control or Alt here can cause problems when using Maya.)

4 Click Close.

Optimize the Maya Hotbox and marking menus on
Linux

Modifications to operating system and window manager settings are
recommended to optimize the performance of Maya’s hotbox and marking
menus on Linux systems.

There are three display methods that the hotbox and marking menus can use:
RGB Overlay, X Compositing, and Internal Software Compositing.

In general, you should try using RGB Overlay and X Compositing to see which
method works best in practice. The Internal Software Compositing method
is the slowest method and should be avoided if possible.

Certain limiting factors may determine which method you can use:
■ RGB Overlay

Use this method if you intend to use the Stereo feature in Maya. Do not
use this method with AMD graphics cards.

■ X Compositing

Use this method with AMD graphics cards (the Linux drivers with AMD
graphics do not support RGB Overlay).

■ Internal Software Compositing

Only use this method if both RGB Overlay and X Compositing Mode are
unsuitable. This is the Maya default.

Using RGB Overlay

The RGB Overlay method uses the hardware RGB overlay to display the hotbox
and marking menu. This method removes flickering that occurs with Internal
Software Compositing.

To turn on RGB Overlay

1 Open the /etc/X11/xorg.conf file.

2 Replace the "CIOverlay" option (Color Index Overlay) as follows:
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Section "Device"
Option "Overlay" "on"

EndSection

OR
Section "Screen"

Option "Overlay" "on"
EndSection

3 Turn off X Compositing as follows:

Section "Extensions"
Option "Composite" "false"

EndSection

4 Save the xorg.conf file.

Using X Compositing

To use the X Compositing method, the X Composite Extension must be
enabled, and your window manager must have compositing enabled. This
method removes flickering that occurs with Internal Software Compositing.

To turn on X Compositing

NOTE X Compositing is turned on by default on Red Hat 6 and Fedora 14 systems,
so you do not have to modify the xorg.conf file.

1 Open the /etc/X11/xorg.conf file.

2 Turn on X Compositing as follows:

Section "Extensions"
Option "Composite" "true"

EndSection

3 Save the xorg.conf file.
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To turn on window manager compositing

The following table outlines how to turn on window manager compositing.

To turn on compositing…Window Manager

Select System Settings > Desktop Ef-
fects, and under Activation, turn on En-
able desktop effects at startup.

KDE

Open the Configuration Editor, then go
to Metacity > General, and turn on
compositing_manager.

Metacity

Consult the window manager’s Help for in-
formation.

Others

Using Internal Software Compositing

Internal Software Compositing takes a screen shot and draws the hotbox and
marking menus on top of that image to simulate the transparency.

This is a fallback method and should only be used if RGB Overlay and X
Compositing methods are not suitable. You may find this method is slow and
is likely to cause flickering when the hotbox or marking menu disappears
from the screen.

Other Recommended Settings

Focus Settings

To further improve interaction with the hotbox and marking menus in Maya,
use the following focus policy settings for the window manager you are using.

Recommended settingWindow Manager

KDE ■ Use the Focus follows the Mouse
Pointer policy.

■ Turn off Click raises active window.

■ For Inactive Inner Window, set Activate
& Pass Click for LMB, MMB and RMB.
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Recommended settingWindow Manager

Metacity (with Gnome) ■ Set focus_mode to sloppy.

■ Set raise_on_click to false.

Environment Variables

The following adjustments to Maya environment variables are also
recommended to improve interaction with the hotbox.

In your Maya.env file, set the following:
■ MAYA_SET_PARENT_HINT=0

Controls the automatic parenting of windows, where setting it to 0 disables
the default parenting. (The behavior is similar to Maya 2010 on Linux
systems.)

■ MAYA_HBFreeFocus=1

When set to 1, does not force the focus back to the window that had focus
prior to the hotbox appearing on screen. (This is an additional control
when MAYA_SET_PARENT_HINT=0 is set on Linux systems.)

■ MAYA_HBFreeRaise=1

When set to 1, does not force the previously focused window to be raised
when the hotbox disappears from screen. (This is an additional control
when MAYA_SET_PARENT_HINT=0 is set on Linux systems.)

Uninstall Maya on Mac OS X or Linux

To uninstall Maya on Mac OS X

1 Navigate to the Maya directory (by default,
/Applications/Autodesk/Maya2013/).

2 Drag the Maya2013 application to the trash.

3 Open a Terminal window and execute both of the following commands,
where <productKey> is your product key:

adlmreg –u S <productKey> 2013.0.0.F
adlmreg –u N <productKey> 2013.0.0.F

This ensures that product information is properly removed from the
ProductInformation.pit file.
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To uninstall Maya on Linux

To uninstall Maya on Linux you can use the rpm utility.

1 Open a shell as a super user.

2 Add /opt/Autodesk/Adlm/R4/lib64/ to LD_LIBRARY_PATH to set your
shared libraries for this session.

For example, by running the following command: export
LD_LIBRARY_PATH=/opt/Autodesk/Adlm/R4/lib64/

3 Run both of the following commands, where <productKey> is your product
key:

/usr/autodesk/Maya2013-x64/bin/adlmreg -u S
<productKey> 2013.0.0.F

/usr/autodesk/Maya2013-x64/bin/adlmreg -u N
<productKey> 2013.0.0.F

4 List the installed package names by entering:

rpm -qa |egrep 'adlm|Maya'

5 Identify each package name you want to uninstall. For example, the
Maya2013_# package (where # is the package number).

6 Uninstall each package using the following command:

rpm -e PackageName

Install the Maya Help

By default, your installed version of Maya 2013 launches the Help from the
Autodesk.com Web site. You can download and install a copy of the Maya
2013 Help using the following instructions.

Prepare to install the Maya Help

Before you install the Maya Help, ensure that you have done the following:
■ Install Maya 2013.

■ Download the Autodesk Maya 2013 English Documentation installer for
your platform from www.autodesk.com/maya-helpdownload-enu.

This file installs Maya Help for 32-bit and 64-bit systems.
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Install Maya Help on Windows

This section describes how to install a local version of the Maya Help on your
system. You can also install the Maya Help on a shared location such as an
internal network or web server. See Install the Maya Help on a shared location
(page 42).

1 Double-click the Autodesk Maya 2013 English Documentation executable
file.

The installation wizard appears.

2 Extract the Help files to a temporary directory, then click Next.

These files are automatically removed from your system after the
installation completes.

3 Follow the instructions in the installation wizard.

By default, the Maya Help is installed in the following directory:

■ C:\Program Files\Autodesk\Maya2013\docs\Maya2013\en_US on
Windows 32-bit systems.

■ C:\Program Files(x86)\Autodesk\Maya2013\docs\Maya2013\en_US
on Windows 64-bit systems.

You can change the install location of the docs directory during the
installation if necessary.

4 Start Maya.

5 In Maya, open the Help preferences window by selecting Window >
Settings/Preferences > Preferences.

The Preferences window appears.

6 Under Categories, click Help.

7 In the Help Location section, select Installed Local Help.

8 Click Save and exit the Preferences window.

The Maya 2013 Help is now available from the Help, F1, and context
sensitive help menus.

Install Maya Help on Mac OS X

1 Double-click the Autodesk Maya 2013 English Documentation .dmg.

The Maya English Documentation disk image mounts on the desktop.

2 Double-click the disk image.

A Finder window opens.
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3 Double-click the Install Maya 2013 Documentation icon.

The installation wizard appears.

4 Follow the instructions in the installation wizard.

By default, the Maya Help is installed in the following directory:

/Applications/Autodesk/maya2013/docs/Maya2013/en_US.

You cannot change the install location of the docs directory.

5 Start Maya.

6 In Maya, open the Help preferences window by selecting Window >
Settings/Preferences > Preferences.

The Preferences window appears.

7 Under Categories, click Help.

8 In the Help Location section, select Installed Local Help.

9 Click Save and exit the Preferences window.

The Maya 2013 Help is now available from the Help, F1, and context
sensitive help menus.

Install Maya Help on Linux

This section describes how to install a local version of the Maya Help on your
system. You can also install the Maya Help on a shared location such as an
internal network or web server. See Install the Maya Help on a shared location
(page 42).

1 Extract the Maya Help package from the compressed files you
downloaded.

2 Open a shell as a super user (using su -) and navigate to the directory
where you extracted the packages.

3 Type ./setup and press Enter.

The installation wizard appears.

4 Follow the instructions in the installation wizard.

By default, the Maya Help is installed in the following directory:

/usr/autodesk/maya2013-x64/docs/Maya2013/en_US.

You can change the install location of the docs directory during the
installation if necessary.

5 Start Maya.

6 In Maya, open the Help preferences window by selecting Window >
Settings/Preferences > Preferences.
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The Preferences window appears.

7 Under Categories, click Help.

8 In the Help Location section, select Installed Local Help.

9 Click Save and exit the Preferences window.

The Maya 2013 Help is now available from the Help, F1, and context
sensitive help menus.

Install Maya Help on a shared location

On Windows and Linux platforms, you can install the Maya Help to a shared
location, such as internal network or web server, so that it can be accessed by
multiple users. You can then set the Maya Help preferences on individual
systems to access Help from this location.

NOTE On the Mac OS X systems, you can only install the Maya Help to the default
directory. To use the Maya Help from a shared location, you must copy the docs
directory to a shared location. Individual systems can then set their Help preferences
so they access Help from this location.

When choosing a shared location, ensure that the directory path to the Maya
Help does the following:
■ Points directly to the Help location. For example,

\\CompanyServer\SharedLocation\MayaHelp\docs\Maya2013\en_US.

Do not use an alias path.

■ Points to the directory containing the index.html file. For example, the
path pointing to the English Maya Help ends at the \en_US directory.

■ Uses either http or https protocol for a web server location.

To install Maya Help to a shared location

1 Extract the Maya Help files for your platform and start the installation
wizard as described in steps 1 and 2 of the Maya Help installation
instructions.

See Install the Maya Help on Windows (page 40) and Install the Maya
Help on Linux (page 41).

2 During the installation when asked to confirm the destination folder for
the Help install, depending on your platform, click Change (Windows)
or Browse (Linux), then specify a shared location for the Help.

Individual systems can then set their Help preferences so they access
Help from this location.
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To set Help preferences for a shared location

1 Start Maya.

2 In Maya, open the Help preferences window by selecting Window >
Settings/Preferences > Preferences.

The Preferences window appears.

3 Under Categories, click Help.

4 In the Help Location section, select Custom, and then click the 
icon to browse to the shared location of the Maya Help, or type the
directory of http path directly in the Custom field.

5 Click Save and exit the Preferences window.

The Maya 2013 Help is now available from the shared location.

Install MatchMover, Composite, Backburner,
and DirectConnect

The Maya installer gives you the option of installing Maya Composite,
Autodesk® MatchMover™ camera tracker, Autodesk® Backburner™ network
render queue manager, and Autodesk® DirectConnect. You do not need a
separate license to install and run these applications.

NOTE You must install Maya if you want to install and run MatchMover or
Composite. You can install and run Backburner without Maya.
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Install mental ray for Maya satellite

Overview of mental ray (satellite)

mental ray for Maya supports a different form of network rendering: mental
ray satellite rendering. The new network rendering capability, based on mental
ray satellite technology, allows you to install a version of mental ray (satellite)
on any networked computer. This special version of mental ray resides on
that machine and waits for rendering tasks from Maya. It supplements the
mental ray rendering capabilities in Maya with the additional rendering power
provided by the networked computers’ CPUs.

A mental ray distributed rendering can speed up all of the following tasks:
■ interactive rendering (through the Maya interface)

■ IPR rendering with mental ray for Maya

■ interactive batch rendering (a batch render started by Maya)

44 | Chapter 4   Configure Autodesk Products in your Entertainment Creation Suite



■ command-line rendering

The rendering process is typically initiated from the master machine (the
machine running Maya or where the command-line render starts from). The
slave machines (satellite rendering computers) process rendering tasks they
receive over the network from the master and send back results. The master
machine handles task distribution, load balancing, and the collection of
received rendering tasks which make up the rendered image.

For more information about mental ray satellite, including how to set up the
rayhosts file to get and receive data from Maya, see the Maya Help. In the
Maya Help, navigate to User Guide > Rendering and Render Setup >
mental ray Rendering > mental ray for Maya Rendering > Network
rendering using mental ray for Maya.

Setting up the rayhosts file is required for mental ray for Maya satellite
rendering to work.

Slave machine installation

The special version of mental ray standalone with satellite rendering
technology must be installed on all slave machines. The satellite-enabled
versions of mental ray for Windows, Mac OS X, and Linux are included with
this release of Maya on the Maya DVD.

(Windows) To install mental ray standalone with satellite licensing

1 On each slave machine, begin the installation process by inserting the
Maya DVD, opening the mental ray satellite folder and the
platform-specific Windows folder, and double-clicking the mental ray
standalone installer.

The installer appears.

2 Follow the installation steps.

During the installation, you can click Custom to change the installation
directory. The default installation directory is:

C:\Program
Files\Autodesk\mrsat3.10.1-maya2013
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(Mac OS X) To install mental ray standalone with satellite licensing

1 On each slave machine, begin the installation process by inserting the
Maya DVD, opening the mental ray satellite folder and double-clicking
the mental ray standalone installer.

2 Follow the installation steps.

During the installation, you can change the installation directory. The
default installation directory is:

/Applications/Autodesk/mrsat3.10.1-maya2013

(Linux) To install mental ray standalone with satellite licensing using rpm

1 Log in as root.

2 On each slave machine, begin the installation process by inserting the
Maya DVD.

3 Mount the DVD drive, if necessary. For example, type:

mount
-r /dev/dvd /mnt/dvd

4 Open the mental ray satellite directory, go to the Linux directory, and
enter the following command (where # is the specific package number):

rpm –ivh mentalraySatellite3.10.1_maya2013-3.10-#.x86_64.rpm

NOTE 64-bit Windows releases of mental ray for Maya satellite use the same
port and service name as the 32-bit version. You will run into problems if
you install both the 32-bit and the 64-bit versions on a 64-bit system. There
is only one service entry/xinetd config, so installing a 64-bit package after
the 32-bit (or the other way around) leaves only the last installed version
working.

Slave machine additional setup

Once this version of mental ray is installed and running, a service on the
machine (the Ray Sat server) waits for rendering tasks from mental ray for
Maya on the master machine. The satellite-enabled version of mental ray does
not require its own licensing; it is activated through Maya’s licensing.

On the slave machine, the Ray Sat server (service name: mental ray Satellite
3.10.1 for Maya 2013) must be running. To verify that it is running on
Windows, follow this procedure.
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To verify that Ray Sat server is running (Windows)

1 Open a Windows command prompt.

2 Navigate to the bin directory of the mental ray satellite standalone. By
default this is C:\Program Files\Autodesk\mrsat3.10.1-maya2013\bin\.

3 Type the following:

raysat2013server
/query

A message should be returned that the RaySat2013 Server service is
running.

If you do not get this message, make sure that RaySat2013 Server has
been installed as a service, and start it from the Services Control Panel
(Settings > Control Panel > Administrative Options > Services)
or type the following:

raysat2013server
/start

Slave machine port setup

On the slave machine, port number 7413 is set by default. This works well in
the majority of cases and you won’t need to change the port number.

If you want to change the port number that mental ray satellite uses to a value
other than 7413, you must edit the services file. The port value would be
determined by your network administrator (a free TCP/IP port).

To change the port number (Windows, Linux)

1 Edit the services file with a text editor.

The services file is located at:

■ (Windows XP) C:\Windows\system32\drivers\etc\services

■ (Linux) /etc/services

2 Change the number in the following line (here, 7413) to the desired port
number:

mi-raysat2013
7413/tcp
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To change the port number (Mac OS X 10.4, Tiger)

1 Log in as superuser (sudo -s).

2 Open the file /etc/services using your preferred text editor.

3 Edit the line: mi-raysat2013 7413/tcp.

4 Save the file.

5 From the Finder menu, select Go > Applications and then double-click
the Utilities folder.

6 Double-click the NetInfo Manager icon.

7 Under the Services directory of the NetInfo database, find and select the
appropriate service (mental ray Satellite 3.10.1 for Maya 2013).

8 Click the lock icon at the bottom of the panel and then enter your
administrator user name and password. This allows you to unlock the
NetInfo database and make changes.

9 Select the port field and change its value to the desired port number.

10 Click the lock icon again when you’re done.

11 From the Finder menu, select Domain > Save Changes to commit
your changes to the NetInfo database.

12 Reboot your machine.

To change the port number (Mac OS X 10.5, Leopard)

1 Log in as superuser (sudo -s).

2 Open the file /etc/services using your preferred text editor.

3 Edit the line: mi-raysat2013 7413/tcp.

4 Save the file.

5 Open a Terminal window and do the following:

sudo
/usr/bin/dscl . -change /Services/mi-raysat2013port
<currentportnumber>
<newportnumber>

For example:

sudo
/usr/bin/dscl . -change /Services/mi-raysat2013 port
7109 7413

48 | Chapter 4   Configure Autodesk Products in your Entertainment Creation Suite



NOTE To determine the port you’re currently using, in a Terminal window,
type: /bin/dscl . -read /Services/mi-raysat2013

6 Reboot your machine.

Licensing of satellite rendering

For standalone licenses, the use of mental ray for Maya with satellite can only
be initiated from the specified host for which your received your Maya key.
The workstation can distribute mental ray for Maya rendering to up to four
slave CPUs.

For networked licenses, use of the functionality is slightly more flexible. For
networked license setups, the license running Maya and the license running
mental ray for Maya can be logged out separately, allowing certain rendering
tasks to be initiated remotely.

There are two possible cases when using mental ray for Maya with networked
licenses:
■ (Interactive) With Maya running interactively on a workstation, initiate a

mental ray for Maya render (either a single frame in the Render View, Batch
render or command line render) on the workstation. The networked mental
ray for Maya portion of your license is logged out. This allows the mental
ray satellite slaves indicated in your rayhost file to participate in the render.

■ (Offline) If you launch a command line mental ray for Maya render, the
computer you launched the command from then becomes the master
machine for mental ray for Maya satellite rendering.

NOTE If you have launched Maya but have not yet rendered with mental ray
for Maya since the start of your interactive session, no mental ray for Maya line
item from your networked license is checked out. You may therefore start a
command line mental ray for Maya render from another host. This checks out
the mental ray for Maya portion of the license, making it unavailable for any
other workstation, including the workstation of the user who launched Maya.

For more details on mental ray rendering, see the Rendering sections of the
Maya Help (for example, Rendering), as well as the mental ray reference
included with the Maya Help.
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Installation Information Specific to Autodesk
MotionBuilder 2013

This chapter covers the default installation paths of the 32-bit and 64-bit
MotionBuilder software products, the installation of the ClipArt sample files,
and the procedures for switching from the default online Help to the local
Help or the Japanese local Help.

Installation and Registration

Install and register the MotionBuilder software product by following the
on-screen installation instructions.

MotionBuilder 32-bit Version Default Installation

The default installation path for the 32-bit version of the MotionBuilder
software product is C:\Program Files\Autodesk\MotionBuilder 2013 on the
following Operating System (OS):
■ Microsoft® Windows® XP Professional

The default installation path for the 32-bit version of the MotionBuilder
software product is C:\Program Files (x86)\Autodesk\Autodesk MotionBuilder
2013 on the following OS:
■ Microsoft Windows XP Professional x64 Edition

■ Microsoft Windows 7 Professional x64 Edition

MotionBuilder 64-bit Version Default Installation

The default installation path for the 64-bit version of the MotionBuilder
software product is C:\Program Files\Autodesk\MotionBuilder 2013 on the
following OS:
■ Microsoft Windows XP Professional x64 Edition

■ Microsoft Windows 7 Professional x64 Edition

The MotionBuilder installer installs by default the 64-bit version of the software
on a 64-bit OS. You can override this default stand-alone installation by
navigating to the root directory of the install media and launching the 32-bit
installer (Setup32.exe). For a deployment, you can select the 64-bit target
platform, and specify the 32-bit version of the product.
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ClipArt Sample Files Default Installation

The default installation path for the ClipArt sample files folder is:
C:\Autodesk\MotionBuilder 2013 32bit\Content for the 32-bit MotionBuilder
version and C:\Autodesk\MotionBuilder 2013 64bit\Content for the 64-bit
MotionBuilder version.

NOTE If you are installing the MotionBuilder software product from the (DVD or
USB) media, the ClipArt sample files do not get installed by default. You need to
copy the ClipArt sample files folder from the media (located under the Content
folder) to your system.

Switching from Default Online Help to Local Help

The MotionBuilder Help is Internet-based by default. If you prefer to have the
MotionBuilder Help available on your system, proceed with the following
procedure.

To change the Help preferences from online Help to local Help:

1 Download the MotionBuilder Help executable from ht-
tp://www.autodesk.com/motionbuilder-helpdownload-enu.

2 Run the installer by following the on-screen installation instructions.

NOTE Although the default Help installation path is C:\Program Files
(x86)\Autodesk\Help\motionbuilder2013, you can specify another installation
location.

3 Once installed, launch MotionBuilder.

4 In the MotionBuilder menu bar, select Settings > Preferences.

5 In the Preferences window, click Help.

6 Click Local Computer/Network.

7 Click Browse, locate, and select the MotionBuilder Help folder, then
click OK.

The Help is now accessible via the MotionBuilder Help menu and the
MotionBuilder F1 keyboard shortcut.

NOTE The Help launches in your system's default browser.
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Accessing the Japanese Help via MotionBuilder

The Japanese MotionBuilder Help is internet-based by default. If you prefer
to have the Japanese MotionBuilder Help available on your system, proceed
with the following procedure.

To access the Japanese MotionBuilder Help via MotionBuilder:

1 Download the MotionBuilder .zip file from http://www.autodesk.com/mo-
tionbuilder-helpdownload-enu to your system.

2 Extract the contents of the Japanese Help .zip file to the desired location.

3 Launch MotionBuilder.

4 In the MotionBuilder menu bar, select Settings > Preferences.

5 In the Preferences window, click Help.

6 Click Local Computer/Network.

7 Click Reset.

8 Click Browse, locate, and select the Japanese MotionBuilder Help folder,
then click OK.

The Help is now accessible via the MotionBuilder Help menu and the
MotionBuilder F1 keyboard shortcut.

NOTE The Help launches in your system's default browser.

Installation Information Specific to Autodesk
Mudbox

Certain items are unique to the Autodesk® Mudbox® install process (in contrast
with other Autodesk products). In this chapter learn about the process for
switching to the local version of the Help and how to install the 32-bit version
of Mudbox on a 64-bit machine. Refer to the following sections:
■ Install the Mudbox Help locally (page 53)

■ Install a 32-bit Product on a 64-bit Operating System (page 21)

If you are installing Mudbox on Mac OS X or Linux, refer to the Autodesk
Mudbox 2013 Installation Help at  www.autodesk.com/mudbox-install-2013-enu
.
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For late-breaking information, you can also review the Mudbox release notes
available at www.autodesk.com/mudbox-readme-2013-enu.

Additional Mudbox resources

You can find the following additional Mudbox resources online:
■ The Autodesk Mudbox 2013 Help at  www.autodesk.com/mudbox-help-2013-

enu.

■ A listing of the most current qualified hardware and operating systems at
www.autodesk.com/mudbox-systemreq-2013-enu.

■ The full Mudbox Installation Help at  www.autodesk.com/mudbox-install-
2013-enu.

■ Mudbox licensing information at  www.autodesk.com/me-licensing-2013-
enu.

Install the Mudbox Help locally

By default, Mudbox calls an Autodesk web server to display the Mudbox Help.
You must have Internet access to view the Help. This ensures you have the
most up-to-date version of the Help and allows Autodesk to make updates to
the Help between software releases.

If you do not have reliable Internet access, you can download the Mudbox
Help from the Autodesk Web site and install it locally as follows.

Prepare to install the Mudbox Help

Before you install the Mudbox Help, ensure that you do the following:
■ Install Mudbox

■ Download the Autodesk Mudbox English Documentation executable file
for your version and platform from www.autodesk.com/mudbox-helpdownload-
enu. This file installs Mudbox Help for 32-bit and 64-bit systems.

Install the Mudbox Help

(Windows)

1 Download and run the Help installer from www.autodesk.com/mudbox-
helpdownload-enu, following the instructions in the installer.
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By default, the Mudbox Help is installed in the following directory:
Program Files\Autodesk\Help\mudbox<version>\.

2 Start Mudbox.

3 Select Windows > Preferences to open the Preferences window.

4 Expand the Help section and set Help Location to Installed Local
Help.

5 Click Ok to exit the Preferences window.

Once installed, the local Mudbox Help is available when you select Help
> Mudbox Help, press F1, or click the Help button in various Mudbox
windows.

(Mac OS X)

1 Double-click the Autodesk Mudbox English Documentation executable
file you download from www.autodesk.com/mudbox-helpdownload-enu.

The Mudbox Help package appears in a Finder window.

2 Double-click the package (.pkg) file.

3 Follow the instructions in the Help installer that appears.

By default, the Mudbox Help is installed in the following directory:
/Applications/Autodesk/Mudbox<version>/docs/mudbox<version>/en_US.

4 Start Mudbox.

5 Select Mudbox > Preferences to open the Preferences window.

6 Expand the Help section and set Help Location to Installed Local
Help.

7 Click Ok to exit the Preferences window.

Once installed, the local Mudbox Help is available when you select Help
> Mudbox Help, press F1, or click the Help button in various Mudbox
windows.

(Linux)

1 Extract the Mudbox Help package from the compressed files you
download from www.autodesk.com/mudbox-helpdownload-enu.

2 Open a shell as a super user (using su -) and navigate to the directory
where you extracted the packages.

3 Type ./setup and press Enter.

4 Follow the instructions in the Help installer that appears.
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By default, the Mudbox Help is installed in the following directory:
/usr/Autodesk/Mudbox<version>-x64/docs/mudbox<version>/en_US.

5 Start Mudbox.

6 Select Windows > Preferences to open the Preferences window.

7 Expand the Help section and set Help Location to Installed Local
Help.

8 Click Ok to exit the Preferences window.

Once installed, the local Mudbox Help is available when you select Help
> Mudbox Help, press F1, or click the Help button in various Mudbox
windows.

NOTE You can also set the Help Location preference to Custom if you have
manually copied the Mudbox Help files to your computer, or if you want to access
the Help from a location not on your own machine (for example, to point to a
common location on your network). Refer to the instructions in the following
section, Install the Mudbox Help in a shared location.

Install the Mudbox Help in a shared location

You can install the Mudbox Help on a shared location, such as internal network
or web server, so that it can be accessed by multiple users. You can then set
the Mudbox Help preferences on individual systems to access the Help from
the shared location.

When designating a directory path to the shared location of the Mudbox Help,
ensure that:
■ The path points directly to the Help location. For example,

\\CompanySever\SharedLocation\MudboxHelp\docs\Mudbox<version>\en_US.

Do not use an alias path.

■ The path points to the directory containing the index.html file. For
example, the path pointing to the English Mudbox Help ends at the \en_US
directory.

■ Either http or https protocol is used for a web server location.

To install Mudbox Help to a shared location

1 Download and run the Help installer from www.autodesk.com/mudbox-
helpdownload-enu, following the instructions in the installer.

Installation Information Specific to Autodesk Mudbox | 55

http://www.autodesk.com/mudbox-helpdownload-enu
http://www.autodesk.com/mudbox-helpdownload-enu


2 When asked where to install the Mudbox Help files, click Change
(Windows) or Browse (Linux) and specify a shared location for the
Help.

NOTE

On Mac OS X, you can only install the Help to the default location. To
install the Mudbox Help in a shared location, you must first install to
the default location (
/Applications/Autodesk/Mudbox<version>/docs/mudbox<version>/en_US),
then manually copy the docs directory to your desired location.

Individual users can then set their Help preferences to access the Mudbox
Help from this shared location.

To access Mudbox Help from a shared location

1 Start Mudbox.

2 (Windows and Linux) Select Windows > Preferences to open the
Preferences window.

(Mac OS X) Select Mudbox > Preferences to open the Preferences
window.

3 Expand the Help section and set Help Location to Custom, then
enter the shared location of the Mudbox Help in the Help Path field.

4 Click Ok to exit the Preferences window.

The Mudbox Help is now accessed from the shared location.

Installing a 32-bit Product on a 64-bit Operating
System

You can manually override the installer's default behavior, which automatically
installs the 64-bit product on a 64-bit computer. For a stand-alone installation,
navigate to the root directory of the install media, and launch the 32-bit
installer, which has a file name of Setup_32.exe or similar. For a deployment,
you can select the 64-bit target platform, and specify the 32-bit version of a
product.
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Installation Information Specific to Autodesk
Softimage

The answers to many of your Softimage-specific installation and licensing
questions can be found on the Softimage Support site where you can quickly
access the top support issues or search the Support knowledge base.

Late-breaking information and troubleshooting tips are always available from
the Softimage Support Blog and in the Softimage Release Notes on the wiki.

Important Information Links

■ Softimage Product Center: www.autodesk.com/softimage

■ Softimage Support: www.autodesk.com/softimage-support

■ Softimage Support Blog: xsisupport.wordpress.com

■ Softimage Wiki: www.autodesk.com/softimage-wiki

■ Softimage Release Notes: www.autodesk.com/softimage-whatisnew
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