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What’s New in Alias 2015

We are pleased to provide you with the latest version of Autodesk® Alias™ software. This
guide leads you through the new and changed features of Alias 2015.
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General improvements

Describes general changes and new features.

General disclaimer

If you are using existing user preferences from an older version of Alias, you may not notice
when the default values of options change.

User preferences for Windows 7 and 8 are located in
C:\Users\<username>\AppData\Roaming\Autodesk\Alias\UserPrefs2015.

User preferences for Mac OS are located in
/Users/<username>/Library/Preferences/Autodesk/Alias/UserPrefs2015.

If the folder does not exist, it is created the first time Alias 2015 launches. The following dialog
appears:

Choose Defaults to accept the new default preferences.

Spaceball support on Mac OS X

Alias now supports the use of a spaceball on Mac OS X.

2

3



ToolClips

Learn about tools in Alias using ToolClips. ToolClips provide rapid access to learning content
from within Alias via short video clips and Help links.

To view a ToolClip, hover over any tool in the Alias palette, Diagnostic Shade window, or
shelves. Click More to open the ToolClip window.

To disable ToolClips, choose Preferences > General Preferences > Help and select
either Tool Tips to display only the tool name, or None to display nothing when you
hover over a tool.

You can customize ToolClips to include additional movies, images or linked content.

Customize ToolClips

ToolClips indicate the name and purpose of a tool and provide access to additional learning
content. You can customize ToolClips to include additional movies, images, or linked
content.

To edit an existing ToolClip

1 Copy the ToolClips.xml file from the builtin.toolclips\Control directory to
your custom.toolclips\Control directory. See ToolClip directories, next.

You must copy the XML file to the custom.toolclips directory, because any edits
you make in the builtin.toolclips directory will be overwritten by software patches
and upgrades.

2 In a text or XML editor of your choice, open the copied ToolClips.xml file.
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NOTE If you plan on adding characters with double-byte encoding, it is recommended
that you use an editor that supports UTF-8 formatting. Ensure that the file is saved with
this encoding specified.

3 Edit the file to customize the existing ToolClip. See Parts of the ToolClip XML file.

For example, you can edit videos, images, and links to point to your custom content.

TIP Each ToolClip is defined using <toolclip> elements. Remove any <toolclip>
elements that yo udo not want to modify so that original ToolClip data is used.

4 Save the XML file.

5 Add any new resources you specified in your XML file to the
custom.toolclips\Resources directory.

6 Set the location of the custom ToolClips in the Shared Tool Clips location box in
Preferences > General Preferences > Help.

7 Launch Alias to view your ToolClip.

ToolClip directories

By default, ToolClips shipped with Alias are located in the builtin.toolclips directory.
Any custom ToolClip content must be added to a custom.toolclips directory.

builtin.toolclips

The builtin.toolclips directory is located as follows:
■ Windows

\Program Files\Autodesk\Alias2015\ToolClips\builtin.toolclips

■ Mac OS X

/Applications/Autodesk/Alias2015/Alias.app/Contents/ToolClips/builtin.toolclips

The following sub-directories contain the ToolClip content that is shipped with Alias:
■ Control – Contains the default ToolClips.xml file. This file specifies the content that

appears in the ToolClip window including tool titles, tool summaries, keyboard shortcuts,
movies, images, and help links.

■ Resources – Contains the movie and image files specified in the ToolClips.xml file.
Movies must be in WebM format and images must be in PNG or JPEG format.

■ ui – Contains resources that are used in the ToolClip window including icons. This
subdirectory also contains files that define the formatting and layout of the window in
a QML format.
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NOTE Do not modify XML files and subdirectories within builtin.toolclips. This may
adversely affect the operation of ToolClips.

Custom directory

You can create a custom directory for your ToolClip content and share it with other users.
If you create a custom directory, note the following:
■ The custom directory name must use the .toolclips extension.

■ The custom directory must contain the Control and Resources subdirectories.

Control – Place the ToolClips.xml file in this directory.

Resources – Place custom ToolClip content (movies, images) in this directory.

■ To view the ToolClips in Alias, set the Shared Tool Clips location in Preferences
> General Preferences > Help.

Parts of the ToolClips XML file

The ToolClips.xml file is stored in the following locations:
■ Windows

\Program Files\Autodesk\Alias2015\ToolClips\builtin.toolclips

■ Mac OS X

/Applications/Autodesk/Alias2015/Alias.app/Contents/ToolClips/builtin.toolclips

Main elements

The main body of the XML file is defined by a single <toolclips> element.

The <toolclips> element has the following attributes:
■ <ui> – Specifies the location of the QML description. This file describes the layout of the

default ToolClip window. By default, the ToolClipUI.qml file is located in the
builtin.toolclips\ui directory.

■ <simple> – Specifies the location of the simplified QML UI description. This file describes
the way ToolClips appear when Tool Tips is enabled in Preferences > General
Preferences > Help. By default, the SimpleTooltip.qml file is located in the
builtin.toolclips\ui directory.

■ <locale> – Specifies the language locale of ToolClips included in the ToolClips.xml file.
The default attribute value is en_US (English).

TIP If you are localizing ToolClips to Japanese or Simplified Chinese, you can use ja_JP or
zh_CN as the attribute value.
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Example code:

xml version="1.0" encoding="utf-8"
<toolclips ui="ui/ToolClipUI.qml" simple="ui/SimpleTooltip.qml"
locale="en_US”>
... </toolclips>

Level 1 ToolClip

Level 1 ToolClip

The following attributes define parts of a level 1 ToolClip.
■ <toolclip> – Encloses all level 1 and level 2 ToolClip elements.

■ <key> – The key name used to request the ToolClip.

NOTE

If a key name exists in two ToolClip.xml files within the ToolClip search path, Alias
uses the key name that is encountered first.

■ <help> – (Optional) Specifies the location of the help link that is included in the ToolClip
window when a level 2 ToolClip does not exist. The location can be a URL or an internal
help string (as shown in the example code below).

■ <title> – The tool title that displays in the ToolClip window.

■ <text> – The summary text that displays in the ToolClip window.

Example code:

<toolclip key="SetFace" title="Set Planar Tool"
help="files/SurfacesPlanarsurfacesSetplanar.htm">

<text>Creates a trimmed NURBS surface from a set of planar
boundary curves.</text>

</toolclip>
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Level 2 ToolClip

Level 2 ToolClips are optional and are used when additional learning content exists. When
a level 2 ToolClip exists, the More button appears in the level 1 ToolClip window.

Level 2 ToolClip with level 2 data

The following attributes define parts of a level 2 ToolClip.
■ <expanded> – Encloses all level 2 ToolClip data. If a ToolClip contains an expanded

section, the More button appears in the level 1 ToolClip window.

■ <default-resource> – (Optional) Specifies that a particular video or image resource
within the ToolClip's resource list can be loaded into the viewer/player when the level
2 ToolClip is opened. The <index> attribute determines which resource list item is loaded
in the viewer or player. For example, set the value to 2 to display the second item in the
list. By default, the <index> attribute is set to 1.

■ <resourcelist> – Specifies the list of resources to be displayed in the level 2 ToolClip
window. You can include videos, images, and/or links to external resources.

■ <video> – Adds a video to the resource list. Use the <location> attribute to indicate the
name of the file and the title that appears in the ToolClip window. When creating custom
ToolClips, all videos must be in WebM format and located in the
users.toolclips\Resources or <customdirectory>\Resources subdirectory. The video
resolution should be 304 x 228 (4:3 aspect ratio).

■ <image> – Adds an image to the resource list. Use the <location> attribute to indicate
the name of the file and the title that appears in the ToolClip window. When creating
custom ToolClips, all images must be in JPEG or PNG format and located in the
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users.toolclips\Resources or <customdirectory>\Resources subdirectory. The image
resolution should be 304 x 228.

■ <link> – Adds an external link to the resource list. Use the location attribute to indicate
the location of the link and the title that appears in the ToolClip window. The location
can be a fully qualified URL or an internal help string (as shown in the example code
below).

Example code:

<expanded>
<resourcelist>

<video location="Align.webm">Align objects</video>

<link
location="files/Workflows_for_the_Align_tool.htm">Workflows for the
Align tool</link>

</resourcelist>
</expanded>

Simplified printing

We've simplified the entire printing experience in Alias.
■ Print to a PDF file or printer, or generate a PDF file and send it by email.

■ Print raster or vector images.

■ Select Alias windows to print (Camera, Left, Top, Back, Bottom, Front, Right).

■ For orthographic windows, scale and position images on the page.

■ Specify which view elements to print (Grid, Background, Model).

To print other view elements, select them in the Alias window.

Print Options

Destination

Select the destination for your print output.

Print

Send your print job to the printer selected under Print Options.

File Convert the page to a PDF or postcript file.
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Page Size

If File is selected as the destination, select the page size for your PDF file output.

Print Options

If Print is selected as the destination, set the following options for your printer output.

Printer  Select the printer from the list of available printers.

Size  Select the page size for the print output.

When Size is Custom Paper Size, set the size in Print Properties

Print Properties  Opens the properties window for the selected printer, where you can
choose options such as paper source and print quality.

Copies  Use the arrows to change the number of copies to be printed, or type the number
of copies in the box.

Layout

Choose the orientation of the content on the page.

Portrait  Print the content of the view vertically on the page.

Landscape Print the content of the view horizontally on the page.

Style

Choose the image format of the content to be printed.

Raster  Print the content of the view as a bitmap image. Shapes are defined by pixels. Printing
a raster image is quicker, but the line quality is not as good as printing vectors.

Vector  Print the content of the view as vectors. With Vector selected, shapes are defined
by mathematical equations, resulting in sharper printed results.

View

Choose which window view to print: Camera, Top, Right, Front, Left, Back, Bottom.
Any new windows you create, also appear on the list. The content of the view appears in
the Preview area.

Fit To Page  Resizes the view to fit the paper. Large views are scaled down to fit. Smaller
views are scaled up.

Select Maintain Aspect Ratio to resize the view proportionally.
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Scale  For orthographic views (Top, Right, Front, Left, Back, Bottom), select the ratio
between modeling units and units on the page (for example 1:8). For actual size, select 1:1.
For a scale not listed, select Custom and either enter the ratio, or a percentage.

View Options

Select the window elements to include in the printed page: Grid, Background, Model.

To print or hide other elements (such as the wireframe, guidelines, textures), show or hide
them in the window before printing.

Margins

Left, Right, Top, Bottom  Set the amount of margin space surrounding the view on the
page.

Margin Units  Select the margin units: Inches or Millimeters.

Alignment

For orthographic views that are scaled, place the model on the page relative to the center
of the page.

Placement  Select where to place the window on the page.

X – Align it to Left edge of the page, Center it horizontally on the page, or align it to the
Right of the page.

Y – Align it to the Top edge of the page, Center it vertically on the page, or align it to the
Bottom of the page.

Offset Offsets the window from the placed position.

Send PDF

Create a PDF file of the contents of the view and attach it to a new email using your default
email application.

Print

If the Destination is Print, send the contents of the view to the printer

Save

If the Destination is File, create a PDF file of the view and save it.
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Enhancements to Msave

■ When Alias terminates unexpectedly, Alias attempts to save your model in your current
project folder. You are now prompted to choose whether you want to save the file, cancel
the msave and go to the next stage, or reopen the stage in another session of Alias.

Construction Plane tool buttons restored

We restored the five Construction Plane tool buttons that appeared at the bottom of the
view window and were removed in Alias 2013.

The buttons correspond with options in the Construction Plane Options window
(Construction > Plane

). Each button allows you to create a different type of construction plane. With the buttons
restored, you can select the tool with a hotkey and use the tool without opening the
Construction Plane Options window. The Construction Plane tool continues to be shelvable.

The on-screen buttons are optional. You can ignore them by clicking in the display—the
selection from the option window will be used instead.

New support for Desktop Analytics

We added support for Desktop Analytics.

Desktop Analytics collects the following information about product usage:
■ Unique user ID - creates a record for each use of a product license, not associated with

a specific person or user profile, as a means of linking the related usage data, as follows.
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■ Product ID and license type - specifies which products are used, and how they are
licensed.

■ Product launch and close time - indicates when each product is used, and the length
of each work session.

■ Geographic location - identifies only the country where the product is used.

This information will not be used to identify or contact customers.

Desktop Analytics complies with the Autodesk Privacy Statement.

Would you like to provide more input on product usage to assist the Autodesk® development
team? If so, read about the  Customer Involvement Program.

To opt out of the program

1 Choose Help > Desktop Analytics Program.

2 Deselect Yes I would like to contribute to this program.

New screen management feature

■ You can Shift-click a tab on the palette to open or close all tabs in the palette. In this
release, we added the ability to open a tab and close all others by Alt-clicking on the tab.

■ Now when you open or close any window in a family windows, all windows in the
family open or close. In previous releases, opening or closing a child window opened or
closed that window only.

Assign random colors to layers

You can now randomly assign colors to layers without color by selecting Layers > Random
Colors . Layers that already have colors assigned will retain their original color.
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Visualization

This version of Alias presents improvements to rendering.

New shader in Multi-Lister creates a grey shader

Selecting New Shader in the Multi-lister now creates a grey shader (the default
DefaultShader). It no longer creates a copy of the DefaultShader.
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Evaluation

Describes changes to Evaluation tools

New diagnostic shaders

We added four new diagnostic shaders to Alias: Light Tunnel, Clay with Ambient
OcclusionIsophote Highlight, and VRED NURBS Analysis.

Light Tunnel

Creates linear reflections on the model by surrounding it in a cylindrical tunnel of long lights.
This is the same functionality found in the Hardware Shade Environment.
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Show Tunnel Displays the tunnel, representing the lights as green bands.

Color Choose a color for the reflections. Move the slider to change the color value.

Transparency Sets the transparency of the shaded surfaces from opaque (0) to almost totally
transparent (0.9).

Intensity Controls the relative brightness of the reflections. Values greater than one are
equivalent to setting a light to the same intensity.

Number of Bands Controls the number of light bands used to form the tunnel.

Band Width Controls the width of the light bands.

Band Fringe Controls the edge transition of lights, ranging from a hard, sharp transition
to a smooth, soft transition.

Center Tunnel Centers the tunnel at the origin.

Show Manip Displays a manipulator for placing and scaling the light tunnel.

■ Click the center move handle, then use curve snapping to snap the manipulator to the
curve.

■ Drag the arrows to move the light tunnel.

■ Drag a cube to resize the tunnel: the red cube changes the length of the tunnel, the green
cube changes the diameter, the cyan cube changes both the length and the diameter.

■ Click a square plane to reorient the tunnel along another axis.

■ Drag a dotted rotation arc to rotate the light tunnel.

■ Drag a sphere to rotate the tunnel around an axis.
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Clay with Ambient Occlusion

Gives the model the look of clay by shading it with a low specularity clay color. The clay
shader supports the display of ambient occlusion (you must first calculate ambient occlusion
to see the effect).

Color Choose a color for the clay. Move the slider to change the color value.

Show Occlusion If ambient occlusion has been calculated, displays the resulting shadow
textures on the shaded model.

Concentration Increase this value to cause the occlusion shadow to be more concentrated
in the areas where it is darkest.

Contrast Set how dark an area with ambient occlusion is. When the value is 1, areas with
maximum ambient occlusion are rendered as if there is no ambient light.

Isophote

Displays thin, sharp lines to indicate spots of the same brightness (isophotes). This shader
is useful for detecting discontinuities across surfaces.
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Base Color Choose a color for the model. Move the slider to change the color value.

Stripe Color Choose a color for the isophote lines.

Transparency Sets the transparency of the shaded surfaces from opaque (0) to almost totally
transparent (0.9).

Count Controls the number of isophote lines used.

Thickness Controls the thickness of the isophote lines.

Sharpness Controls the sharpness of the isophote lines. increasing the value blurs the line
edges.

Use Camera View Vector Uses the current camera view vector for the light direction so the
lines move over the model as you tumble.

When this option is not selected, the lines remained fixed.

X, Y, Z Sets the position of the light when Use Camera View is not selected. Click X, Y,
or Z to set the direction to X (1, 0, 0), Y (0, 1, 0), or Z (0, 0, 1), respectively.

VRED NURBS Analysis

We added a new diagnostic shader that sends the selected surfaces to VRED NURBS Analysis
to perform ray tracing directly on the NURBs surfaces.

You can display different types of virtual lines on the objects in the scene to examine the
continuity of surfaces.

20 | Chapter 4   Evaluation



To analyze surfaces in VRED NURBS Analysis

1 Select the surfaces you want to analyze.

2 In the Diagnostic Shade window, click the VRED NURBS Analysis diagnostic shader.
VRED NURBS Analysis opens.

3 Select an Analysis Mode and set options.

4 To center the all geometry in the scene in the view (look at), press Shift+F

To center selected geometry in the view, select the geometry ( Shift-click) and press F.

To toggle anti-aliasing, press the spacebar.

VRED NURBS Analysis Options

Analysis Mode

Activate Surface Analysis Projects lines on the objects in the scene for analyzing the quality
of surfaces.

Analysis Mode Select the type of lines to display for analysis:

Isophotes – Displays isophotes (lines of equal brightness on the surface). With isophotes
you can determine whether a surface is continuous in position, tangency, or curvature. The
surface is assumed to be perfectly diffuse reflecting. It is lit from both sides by a directional
light emitting parallel light beams. You can set the direction of the light source. The isophote
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lines are view-independent meaning that the lines do not change when moving the camera
(except when using the option Use Camera View Vector).

Highlight Lines – Displays locations on the surface where the extended surface normals
intersect the light lines. Highlight lines are view independent.

Reflection Lines – Displays reflections of light lines on the surface. Reflection lines are
view independent.
Both Highlight Lines and Reflection Lines need light lines to be defined as a kind of virtual
light source. You can choose between two different shapes on which the light lines appear.

Longitudinal Lines on a Sphere – The lines are meridians on a sphere (lines from pole
to pole) which encloses the scene and is of infinite size. You can set the axis of the sphere.

Parallel Linear Lines on a Plane – The lines are parallel and straight on a plane. You
can set their position and rotation.
Curvature (NURBS only) – Color-codes the curvature of the surfaces.

Define Light Source

Not applicable to Curvature (NURBS only) analysis mode.

For Isophotes

Show Light Direction Displays the light direction as an orange arrow in the render view.
You can change the light direction by Shift-dragging the rotation manipulator or by entering
precise X, Y, Z direction values. The translation manipulator does not change the direction
of the light and therefore does not affect the isophotes.

Direction Change the direction of the light by setting X, Y, and Z coordinates.

Normalize Scales the direction vector to a length of 1.0.

Set to Axis Sets the direction to X (1, 0, 0), Y (0, 1, 0), or Z (0, 0, 1).

Pick Surface Normal Enters a mode where you can pick a surface normal as the light
direction, sphere axis, or plane normal, depending on which analysis mode is selected.
■ Shift + left mouse button to pick a surface normal.

■ To exit the mode, click the button again.

Use Camera View Vector Uses the current camera view vector for the direction of the light.
To select a different light direction, click the button again.
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For Highlight/Reflection Lines with Longitudinal Lines on a Sphere

Show Sphere with Light Lines Displays the light sphere with its light lines in the render
window.

The sphere used for mapping the lines on the surfaces is of infinite size.

You can change the axis of the sphere by Shift-dragging the rotation manipulator.

Sphere Rotation Change the direction of the light by setting X, Y, and Z coordinates.

Set to Axis Sets the direction to X (1, 0, 0), Y (0, 1, 0), or Z (0, 0, 1).

Pick Surface Normal Enters a mode where you can pick a surface normal as the light
direction, sphere axis, or plane normal, depending on which analysis mode is selected.
■ Shift + left mouse button to pick a surface normal.

■ To exit the mode, click the button again.

For Highlight/Reflection Lines with Parallel Linear Lines on a Plane

Show Plane with Light Lines Displays the light sphere with its light lines in the render
window.

The sphere used for mapping the lines on the surfaces is of infinite size.

You can change the axis of the sphere using the rotation manipulator.

Light Plane Origin Set coordinates of the origin of the light plane.

Light Plane Rotation Specify the number of degrees to rotate the plane around the X, Y,
and Z axes.

Lines Spacing Specify the spacing between the lines on the plane. The default is 10.00.

Limited Lines Length Limits the length of the lines to the number you specify. The default
is 1000.00.

Pick Surface Normal Enters a mode where you can pick a surface normal as the light
direction, sphere axis, or plane normal, depending on which analysis mode is selected.
■ Shift + left mouse button to pick a surface normal.

■ To exit the mode, click the button again.

Lines / Stripes

Not applicable to Curvature (NURBS only) analysis mode.

Type Select the style of analysis line to display:
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Thin Lines – Displays thin sharp lines.

Stripes – Displays stripes. You can modify the Sharpness and Thickness of the stripes.

Zebra – Uses a classical zebra pattern.

Count The number of isoline highlight bands on the surface.

Color The color of the highlight bands. Click to open the Choose a Color dialog box and
select a color.

Surface

Not applicable to Curvature (NURBS only) analysis mode.

Lighting Select the surface lighting to render the surface:

Ambient – The surfaces are displayed single-colored. The color is defined by Base Color.

Diffuse – The surfaces are assumed to be diffuse. Set the diffuse reflection color using Base
Color.

Phong – The surfaces are lit with the phong lighting model. You can use Base Color to
set the diffuse reflection color, the glossy reflection color using Glossy Color, and
Roughness.

NURBS UV – Show the parameterization of NURBS surfaces. Triangle meshes are displayed
in Ambient mode.

Base Color The color of the surface. Click to open the Choose a Color dialog box and
select a color.

Curvature

Applicable only to Curvature (NURBS only) analysis mode.

Type The method of calculating curvature on the surface. Mean averages the two principal
curvatures at each point on the surface.

Color Scale  Scales the radius ramp to show finer details of curvature variation.

Radius Ramp Select this option to show the range of colors that will be applied to the
curvature map (and their corresponding curvature radius values).

If the +/- band is set to 0.0, the curvature map is relative, and the ramp colors, from left to
right, represent increasing curvature values. (The colors are not associated with specific
values.)

If you adjust the Color Scale, the radius ramp updates interactively.
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Rendering

Downscale Select this option to turn off anti-aliasing. Press the spacebar to toggle anti-aliasing
on and off.

Simplified Iso Angle evaluation

Now you only need the Iso Angle diagnostic shader to evaluate continuity across surfaces
using iso angles. We moved the Iso Angle tool options to the Iso Angle diagnostic shader
and removed the Iso Angle tool from the Evaluation tab in the palette.

Additionally, we:
■ Added the Double map type, which displays a wide iso angle line.

■ Added the Rainbow map type, which displays bands corresponding with each color
of the rainbow.

■ Added three buttons to align the light source vector with the X, Y and Z axes.

■ Added Update From Section button to set the direction of the light source to be that
of an already selected vector or plane. In the case of a plane, the direction perpendicular
to the plane is used.

The X, Y, Z fields are automatically set to the coordinates of the picked vector.
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■ Moved the Show Manipulator button that appeared in the view when the Iso Angle
tool was selected to the diagnostic shader window.

■ Added Show Curves Only option to disable the shading and show the iso angle lines
as curves only.

■ Added Create and Delete buttons to create and delete iso angle curves.

Simplified Surface Evaluation

Now you only need the Surface Evaluation  diagnostic shader to create curves-on-surface
along draft lines. We moved the Parting Line tool options to the Surface Evaluation
diagnostic shader and removed the Parting Line tool from the Evaluation tab in the
palette.
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Additionally, we:
■ Changed the default pull direction of the vector from Rotation to Vector.
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■ Added a Show Manipulator button that displays a modified vector manipulator. There
is no longer a Go button.

■ Added three buttons to align the pull vector with the X, Y and Z axes.

■ Added Show Curves Only option to disable the shading and show the draft lines as
curves only.

■ Added Create and Delete buttons to create and delete draft curves.

Curvature Evaluation diagnostic shader improved

The curvature ramp for the Curvature Evaluation diagnostic shader is now interactive.
You can add, remove, and move ramp entries and set the scale value by adding curvature
values at set locations.
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■ To add an entry, double-click on the ramp.

■ To move an entry, drag the circular handle.

To change the color, double-click the circular handle. The Ramp Color window opens,
where you can select the color you want.

■ To remove an entry, Shift-click the x handle.

■ To change the curvature radius values, double-click the value, type the new value and
press Enter. When the value is at, or near 0.5, the value is indicated as "Flat".
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Modeling

Profile Tool enhancements

We added some new options that will give you the ability to rotate or slide a profile to touch
a curve or surface. These options are under Profile orientation.

We moved Parallel and Radial from the Profile orientation option to a new Frame
Travel option.

Profile Orientation

Natural – The orientation of the profile frame is determined only by the Frame Travel.

Natural Orientation, Parallel Frame Travel

Natural Orientation, Radial Frame Travel

Rotate to Target – The profile rotates about the rail curve until it touches a selected Profile
Target.
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Rotate to Target Orientation, Surface Target, Radial Frame Travel

Rotate to Target Orientation, Curve Target, Radial Frame Travel

Slide to Target – The profile slides along an attached surface until it touches the selected
Profile Target. The profile rotates so that the profile frame remains tangent to the sliding
surface.

Slide to Target Orientation, Surface Target, Radial Travel
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Slide to Target Orientation, Curve Target, Radial Travel

Guide Curve – The orientation of the profile frame is determined by the normal direction
of an adjacent curve.

Guide Curve Orientation, Proportional Scaling, Parallel Travel

Surface Normal – The orientation of the profile frame is determined by the normal
direction of an adjacent surface at the closest point between the rail curve and the surface.

2nd Rail – The orientation of the profile is determined by connecting the profile curve to
two rail curves.

Profile Target
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Surface Target – If Rotate to Target is selected, the profile rotates around the point
where it meets the rail curve until it touches the target surface . If Slide to Target is
selected, the profile "slides" along an attached surface until it touches the target surface.

If Use Profile Point is also selected, the profile rotates or slides until the selected point
on the profile touches the surface.
Curve Target – If Rotate to Target is selected, the profile rotates around the point where
it meets the rail curve until it touches a selected curve. If Slide to Target is selected, the
profile "slides" along an attached surface until it touches the target curve.

If Use Profile Point is also selected, the profile rotates or slides until the selected point
on the profile touches the curve.

Use Profile Point

If Use Profile Point is also selected, the profile rotates or slides until the selected point
on the profile touches the surface or curve.
If Rotate to Target or Slide to Target are selected, enables you to select the point on
the profile that will touch the target.

Profile Scaling

Scales the profile with the influence of the target curve.

No Scaling – Does not scale the profile.

Non-proportional Scaling – Scales the profile non-proportionally in one dimension.

Proportional Scaling – Scales the profile proportionally in two dimensions of the local
coordinate system.

New Curve Fillet tool

We created a new Curve Fillet tool (Curve Edit > Create > Curve Fillet ). With it you
can:
■ create chamfers that are degree 1-3; G1 fillets, degree 3-6; and G2 fillets, degree 5-7

■ create fillets with curves, curves-on-surface, and edges

■ fillet between non-planar inputs

■ create fillets that are G1 tangent or greater with form factor capability
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Curve Fillet options

Construction Type

Radius – Produces a fillet where you control the radius value at the center of the fillet (but
not the width of the fillet).

Chord – Produces a fillet where you control the distance between the two ends of the fillet
(but not the radius). Use the Chordal Length or Tangent Length option to set the
distance to maintain.

Section Type

G0 Chamfer – Creates a chamfer edge between the two curves. This type maintains only
position continuity with the curves at both ends of the fillet.

G1 Circular – Creates a circular fillet. This type maintains tangent continuity with the
curves at both ends of the fillet.

G1 Tangent – Maintains tangent continuity with the curves at both ends of the fillet

G2 Curvature – Maintains curvature continuity (G2) with both curves. G2 continuity
means that the curvature (which is the inverse of the radius of curvature) is the same on
both sides across the fillet's boundaries.

G3 Curvature – Maintains G3 continuity with both curves. G3 continuity means that the
curvature's rate of change is the same on both sides across the fillet's boundaries.
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Curvature Side For G2 and G3 Curvature section types only.

Specify

For Radius construction type, with G1 Tangent, G2 Curvature, or G3 Curvature
section types, select which values to specify to define the fillet: Tangent Offset, Center
Radius, or Both. Both lets you specify both the Tangent Offset and Center Radius
of the fillet but not the Form Factor. The form factor is calculated automatically from
these two values and varies along the fillet.

Tangent Offset Radius of a circle that is tangent to both input curves at the endpoints (that
is, contact points).

Center Radius Radius at the center of the fillet (as measured along the arc length).

Radius For Radius construction type, with a G1 Circular section type. Radius at the center
of the fillet (as measured along the arc length).

Form Factor

Adjusts the shape of the fillet. It specifies the ratio between the lengths of the innermost
and outermost CV arms of the fillet hull. Values range from 0.1 to 2.0. The smaller the value,
the sharper the bend in the fillet.

Chordal Type For Chord construction type, select which values to specify to define the
fillet, Tangent Length or Chordal Length.

Tangent Length – The length of the tangent segment.

Chordal Length – The distance between the two sides of the fillet.

Fillet Plane

Automatic – Uses a fillet plane that is automatically determined.

Specify – Lets you specify the fillet plane using the Fillet Plane Options, or the fillet plane
manipulator.

Explicit Control Gives you control of the curve degree of the new fillet curve.

Fillet Plane Options

These options are available only when Fillet Plane is set to Specify.

Explicit Control Options

These options are only available when Explicit Control is selected.
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Control Options

Trim Type Automatic – Automatically trims the original curves back to the contact line.

Off – Does not trim the original curves.

Auto Update Automatically updates the fillet curve as you change options.

If you turn this option off, you can click the Update button when you want to update the
curve.

Curvature Comb Displays a curvature comb plot across the resulting fillet curve.

Create History

Save the fillet curve history for later editing. If you select Create History, when you edit the
original curves, the fillet updates automatically.

New Surface Array tool

With the new Surface Array tool (Transform > Arrays > Surface Array), you can
create arrays across surfaces in multiple directions.
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To create a Surface Array

1 Choose Transform > Arrays > Surface Array

2 Select the object to duplicate. Click Accept

3 Select surface edge or curve on surface for the primary direction. The surface array is
built.

NOTE If Number is 1 for the primary and secondary direction, you will only see the original
object

4 Adjust the options in the control window. If Auto Update is checked, the surface
array updates automatically. Otherwise click the Update button.

Surface Array options

Position Offset in the N, U, and V directions along the duplicates local axes.

Rotation Rotation around the local, X, Y, and Z axes of the duplicates.

Primary

Specify Choose to duplicate by Spacing or Number.

Spacing Choose distance between duplicates.

Number Choose number of duplicates.

Start / End Specifies where the duplicates Start and End in the primary direction of the
surface. These can be adjusted in the control window or with in-canvas range manipulators.

Scale This is a relative scale factor applied to the original object to produce the last duplicate
in each row . The size of the intermediate duplicates is interpolated.

Offset Offsets each row in the array by this distance from the previous row.

Stagger Offsets each row half of the spacing value, creating a "stagger" effect.

Rotation When checked, displays fields to change the Incremental Rotation of the
duplicates in the X, Y and Z.

Range Fit Expands the array to fit within the start and end range.
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Secondary

Direction If U is selected, the objects will be laid out along U isoparms. If V is selected, they
will be laid out along V isoparms. If the target is a U or V isoparm, the U or V direction will
be selected by default and is dependent on the primary direction.

Perpendicular creates the secondary direction perpendicular to the primary direction.

Side Creates the secondary direction of the array on the Positive, Negative or Both sides
of the primary input.

Specify Choose distance between duplicates.

Spacing Choose distance between duplicates.

Number Choose number of duplicates.

Positive End / Negative End Specifies the start and end of the secondary direction duplicates
on the positive and negative side of the primary input.

Scale This is a relative scale factor applied to the original object to produce the last duplicate
in each row . The size of the intermediate duplicates is interpolated.

Offset Offsets each row in the array by this distance from the previous row.

Stagger Offsets each row half of the spacing value, creating a "stagger" effect.

Rotation When checked, displays fields to change the Incremental Rotation of the
duplicates in the X, Y and Z

Range Fit Expands the array to fit within the positive and negative end range.

Control Options

Auto Update When this box is checked, duplicates update automatically when values in
the control window are changed.

Chain Select When checked, selecting a surface also selects all other curves that are tangent
continuous with it.

Create History When checked, the duplicates have construction history. Modifying the
stitch objects or target curves causes the duplicates to update accordingly.

Orient Normals Check this box to align the local X axis of each duplicate with the tangent
of the target curve at the position of the duplicate. If the target curve is a curve-on-surface,
each duplicate is oriented so that its local Z axis matches the normal direction of the surface
where the curve-on-surface lies.
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Proportional Crown manipulators

The Freeform Blend and Skin tools now have a manipulator to update the Proportional
Crown settings directly on the model.
■ Drag the circle to change the Crown Value. The value adjusts in 0.005 increments.

Use the left mouse button for adjustments, the middle mouse button for fine adjustments.

■ Click the arrow to Flip the crown direction.

Revolve tool improvements

■ We added a radius manipulator to the Revolve tool.

■ Barrel and Helix are grouped under a new Side Glass surface type.
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■ In Barrel or Helix mode, we added an Edit Points button to the view so that you
can go back into point editing mode after moving the axis.

■ In Freeform mode, we added a Per Segment option to specify the sweep angle per
segment instead of for the entire revolution.

■ You can build helix surfaces in Freeform mode using the Pitch option.

■ You can create a vector within the tool to use as a revolve axis.

42 | Chapter 5   Modeling



Modeling | 43



Align tool improvements

■ We changed the Continuity types from menu selection to radio button selection for
more efficient use of the tool.

■ In Project mode:
■ We added a Shrink to Fit option that ensures the projection happens when the

slave surface overlaps the master surface. When Shrink to Fit is selected, the position
row is compressed to fit onto the master surface.

■ We added a No COS option that does a projection align without creating a
curve-on-surface. Continuity Check is disabled without a curve-on-surface.

■ When G1 or greater continuity is selected, the manipulator arrows that appear on
interior CVs now behave like the Transform CV tool in SLIDE mode.
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■ We added a Diagnostic Feedback option. When selected, the minimum and maximum
Position, Tangent, Curvature, and Torsion values display, and the start and end
Angle values display.

Surface Fillet improvements

■ The quality of surface rails on G0 Chamfer surfaces has been improved.

■ Chordal surface fillets have been improved:
■ They now work with Chordal Length.

■ They match better with neighboring circular fillets.

■ They are more circular in shape and less like freeform blends.

■ They are more consistent across internal multi-surface boundaries.

■ Fillet quality has been improved for situations where the underlying surfaces do not
intersect. It is no longer necessary to extend a surface so the surfaces intersect.

■ To give you better control over the number of spans for each fillet surface, we changed
the Uniform Spans option to include three options: Maximum, Explicit, and Off.

Maximum uses the specified number of spans or less, if it achieves continuity.

Explicit uses the exact number of specified spans, regardless of whether continuity is
achieved with a lesser number of spans.

Freeform Blend improvements

Form Factor has been added to the Freeform Blend tool.

Select Form Factor from the Blend Control drop-down menu to control the shape of
the blend when Continuity is set to G1, G2 or G3 Curvature. This is the same math
used in the Surface Fillet, Symmetric Fillet, Fillet Flange, Tube Flange, and Panel
Gap tools.
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Form factor math will work only on surfaces that would blend to create a "shoulder" (both
edges would need to be extended for the surfaces to intersect).

Skin tool improvements

■ The quality of Bezier surfaces created with the Skin tool has been improved, particularly
in cases where rail curves are segmented.

■ Picking has been improved to work more like the Skin 2012 tool.
■ Pick two curves to build a skin. Pick the third curve to start a new skin operation.

■ To build a skin from three curves, hold the Shift key when you pick the third curve.
If Auto Update is not selected, you can pick as many curves as you want before you
click Build to create the skin. Curves can be added or removed by holding Shift
and clicking.

■ If you have already built a skin, box selecting additional curves without holding
Shift starts a new skin.

■ In-canvas manipulators were added for controlling Proportional Crown. Click on
the manipulator arrow to flip direction and drag the blue dot to increase or decrease
crown.

■ The patch layout of the skin surface has been improved.

Array tool improvements

■ We added a Center Original option to the Radial mode of the Array tool.

When the option is selected, the tool works as before. The selected object is at the center
and copies are created radially around it.
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When not selected, the tool creates duplicates around a point beside the original based
on the spacing value. The middle object is not created.
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■ We added a Mirror option to the Linear mode of the Array tool so you can easily
create linear patterns from the center of an array.

Trim and Trim Convert tool improvements

■ You can now extend a curve that does not project entirely on the patch, either
automatically or manually, and continue the trim operation without leaving the Trim
or Trim Convert tools.

Auto – When the trim fails, any curves-on-surface that are within the set Tolerance
of another curve-on-surface or boundary are extended and the trim is attempted again.

Selected – A trim extend arrow appears on the curve that needs extending. Clicking
the arrow snaps the end of the curve to the patch edge.
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■ You can create a vector within the Trim and Trim Convert tools.

■ We added a Divide button to the Trim Convert tool that trims and divides the input
surface and then attempts to convert all the resulting faces into untrimmed surfaces.
Only four-sided faces will successfully convert.

Multi-Surface Draft tool improvements

You can now create a draft vector while in the Multi-Surface Draft tool.
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Offset tool improvements

The CV layout of offset surfaces has been improved. Tangent continuity between offset
surfaces is now maintained when Normal Mode is set to NUV.

Transform CV and Prop Mod tool improvements

■ You can now use the Transform CV and Prop Mod tools across multiple connected
curves with tangent continuity.

■ The direction of movement across multiple surfaces is now unified in the NUV mode of
the Prop Mod tool. All CVs move in the same direction regardless of the UV layout of
the object.

Circle tool enhancements

The Circle tool now has a Segments option that specifies the number of curve segments
that will form the circle.

It is no longer the case that the sum of the Degree and number of Spans for a non-periodic
circle cannot exceed 16.

Vector creation within tools

You can now create vectors while in the following tools:
■ Revolve tool – revolve axis.

■ Multi-Surface Draft and Fillet Flange tools – draft pull direction vector

■ Trim, Trim Convert, and Project tools – projection vector

■ Tube Flange tool – parting line pull direction vector

Rotate around a vector

We added the ability to rotate around a vector.

1 Choose Transform > Rotate

and select Vector.

2 Create the vector by clicking in the view where you want the vector to start or typing
the start position in the prompt line.
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3 Adjust the manipulator to position the vector and click Accept.

4 Enter a sweep angle on the prompt line.

Construction Plane improvements

When you create a Geom type construction plane, the plane is now oriented parallel to
the view plane.

Dynamic Section improvements

You can now set the visual clip in the Dynamic Section tool to be persistent. When you
exit the Dynamic Section tool with Persistent Visual Clip selected, the visual clipping
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planes do not disappear, so you can now print the section display, measure the section, do
anything to the section outside the tool.

Dynamic Section now supports Query Edit when Persistent Sections is checked.

Place tool improvements

Picked construction planes are now locked by default when you select them in the
Transform > Place tool. To transform a picked construction plane, first click the Unlock
Plane button.

Proxy display in Transform CV tool

Proxy display is now available in the Transform CV tool. Select it to display a green
proxy of the original hull after the transformation. The proxy helps you visualize how much
the surface has changed during the transformation.
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Keep Originals added to the Smooth tool

You can now keep the original surface when you smooth it using Object Edit > Smooth.

Fit Curve tool enhancement

We added a Create History option to the Fit Curve tool. When the option is not selected,
template curves are not kept when fitting to cross sections, so you do not have to delete
them after leaving the tool.

Modeling | 53



54 | Chapter 5   Modeling



Data Transfer

Describes changes and new features in data transfer.

Alias data to Autodesk SketchBook

If you have Autodesk SketchBook Pro installed, you can now export your view to SketchBook
Pro. Choose File > Send to SketchBook.

Alias data to Autodesk VRED

If you have Autodesk VRED installed, you can now export your data from Alias to VRED for
rendering. Choose File > Send to VRED.

Send to VRED options

Geometry Output Send either All geometry or Selected geometry to VRED.

Open New Scene Opens a new scene and inserts the Alias geometry into it.

If this option is not selected the Alias geometry is imported into the current scene.

VRED Base CAD Options

Keep Surface Data Keep NURBS data.

Merge Geometries Merge the geometry to be imported to VRED.

Chord Deviation

Set the distance from the midpoint of a tessellated edge to the geometry.

Normal Tolerance

Set the allowed normal deviation between the normals on the ends of a tessellated edge.

Max Chord Length

Set the maximum length of a tessellated edge.
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Enable Stitching Enable the stitching of adjacent edges.

Stitching Tolerance

Set the tolerance where two adjacent edges are considered to be touching and where they
should be stitched together.

Import and Export ACIS files

You can now open Standard ACIS Text (SAT) files in Alias.

You can also save Alias files as SAT files or Standard ACIS Binary (SAB) files.

To import an SAT file

1 Choose File > Import

or File > Open

.

2 Set SAT import options and click Import File or Open File.

3 Choose the file.

To export an SAT file

1 Choose File > Export > Active As

or File > Save As

.

2 Choose SAT as the File Format.

3 Set SAT export options and click Save.

SAT import options

Logfile Output Creates a log file of the results (<filename>.alias2sat).

SAT export options

Logfile Output Creates a log file of the results (<filename>.sat2alias).

Export Binary Saves the file as Standard ACIS Binary (SAB).
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New CATIA V5 export option to export curves-on-surface

Curves-on-surface are converted to curves on export to CATIA V5. We added the Export
Curve on Surface option to the CATIA V5 export options to include these files in the
CATIA V5 file.

For the AlToC5 command, the equivalent option is -x.
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Fixed Limitations

Lists important customer issues that have been addressed in this release.

General Issues

■ If you set your My Documents folder to a network drive, when you selected File > Open,
Alias interpreted it as a relative path and added a drive letter to it. This has been fixed.
Alias no longer fails to recognize a network path as an absolute path.

■ When you opened a file that referenced several .wref files, none of the of the reference
data loaded if you were missing just one file, or if one of the files had been modified. This
has been fixed.

■ Clicking outside a window did not dismiss an active cell. This has been fixed.

■ When importing files in the Reference Manager, you can now filter by .wref files.

■ When using two monitors with Alias on the first monitor, selecting Layout > Full Screen
no longer moves the Alias window to the second monitor.

Evaluation Issues

■ The curvature comb on a trimmed edge is now more accurate.

■ The diagnostic shaders no longer share the same transparency value. Each shader now
has its own transparency value so that changing transparency for one shader no longer
changes it for all shaders.

Modeling Issues

■ The Surface Fillet tool sometimes created T-connections. This has been fixed.

■ The Symmetric Fillet tool failed to build in some highly-curved cases. This has been
fixed.

■ You can now detach a periodic surface at the seam.

■ Chain select now works on objects in layers with symmetry on.
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■ When you have multiple CVs selected and choose the Proportional Mod or
Transform CV tool, the CVs are no longer unselected. A single CV close to the center
of the selected CVs remains selected.

■ Skin tool fixes:

Chain select now works.

The surface is now correct when you edit a skinned surface using the range manipulators.

Skin now uses the original parameterization of curves when building multiple surfaces
(with Explicit Control off). The result is that the output skin patch matches the input
curve.

The skin is now closed when Proportional Crown is on.

The skin history is no longer lost when there are more than nine V spans.

Selecting Continuity Check no longer hangs the tool.

Proportional Crown now gives a consistent crown across the entire surface.

When you increase the Proportional Crown value, G1 Continuity is no longer
broken.

Changes made to surface flow control using the manipulator handles are now reflected
in the Skin Control window.

■ In the Surface Fillet tool, cylinders were not trimming when Trim Type was set to
Automatic. This has been fixed.

■ Extend tool fixes:

You can now snap-extend a surface.

The surface is no longer duplicated when you extend it with Chain Select selected.

■ With Double Sided on and Single Surface off, the surface structure of two sided
surfaces created with the Multi-Surface Draft tool did not match. This has been fixed.
The surfaces now match.

■ The toggle label for the Interior Flow Control in the Surface Fillet and Symmetric
Fillet tools now only appears when there is an interior boundary to align to. Otherwise,
only the Start and End labels appear.

■ When using the Move Locator tool, you can now edit multiple deviation locators at
the same time.

■ The Layer Symmetry Plane manipulator now continues to display until you select Layer
> Set Plane again.
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What’s Where...

New tools

The tools listed in this section are new in this release of Alias.
■ Transform > Arrays > Surface Array

■ Curve Edit > Create > Curve Fillet

■ File > Send to VRED

■ File > Send to SketchBook

■ Layers > Random Colors

■ Help > Desktop Analytics Program

Obsolete tools

The following tools have been removed, either because they were redundant, or no longer
served any useful purpose.
■ Evaluate > Iso Angle

■ Evaluate > Parting Line
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