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General information

To be able to follow the instructions of this manual, you 
need the files of the VRED Tutorial. Download files.

The structure is as follows:
1. IGES-data: This directory contains the necessary CAD files for 
import. 

Filename: *.igs.

2. Textures_and_environment: This directory contains all needed 
textures, HDRI’s, and the environment geometry. Filenames:

•	 Environment.vpb (Environment geometry)
•	 perfectStudio.hdr (Studio HDRI)
•	 forest.mtd (Forest HDRI)
•	 nummerntafel_8.gif (number plate texture)
•	 tire_marking_bump.jpg (Tire texture 1)
•	 tire_profile_bump.jpg (Tire texture 2)

3. VRED data: This directory contains the starting point file (if you 
want to import the CAD files, the IGES files are located in the IGES-data 
folder) and the final data, which shows what the final scene should look 
like after going through this tutorial. Filenames: 

•	 microracer_start.vpb (Starting point file after CAD import)
•	 microracer_final.vpb (Final file)

http://download.autodesk.com/us/vred/2015help/docs_autodesk_vred_2015_handson_files.zip
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Using VRED: Interface

This chapter provides general information regarding 
interface, navigation, selection, manipulating objects, 
and setting up preferences. 
This tutorial is designed to work with the standard user 
interface. Make sure the Simple UI icon is not selected.

1.  Menu bar: The Menu bar provides features for creating and editing 
content.

2. Icons tab: The Icons tab provides shortcuts to access commonly 
used features, such as render options or the wireframe function.
		
3. Scenegraph: The Scenegraph contains a tree of all objects used in a 
scene and enables you to directly select and modify them.	

4. Renderview: The renderview displays the whole scene and enables 
you change views and to directly select and modify objects.

5. Quick Access bar: The Quick Access bar provides easy and fast 
access to main functions such as the Material Editor, the Clip Maker, or 
the Variants. 

6. Statusline: The Statusline provides information about memory 
usage. It allows users to change the up vector, the near and far
Clip Planes and the field of view. The Statusline is integrated with the 
Terminal.	

parksu
Inserted Text
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Optimize scene

Autodesk® VRED is an interactive 3D visualization 
software. Before starting to prepare a VRED render file, 
CAD data must be loaded or imported. 

•	 The CAD file still has to be optimized. First, the import options have 
to be set.

•	 Select File > Open in the Menu bar. Select all Microracer IGES files 
and press Open.

•	 Choose a Tessellation quality (if you want to render your NURBS data 
directly, uncheck Tessellation).

After importing data, the scene needs to be optimized.
•	 Select all imported groups. They are indicated in a green font.
•	 Right-click on any group node and select Edit > Show Optimize 

Module.
•	 Click the default button in the Optimize module.
•	 Check both Flush Transformation Nodes check boxes. This ensures 

that all transformations will be set to 0 and all scale operations will 
be set to 1.

•	 Check the Cleanup Group Nodes check box. This function removes all 
groups containing fewer than two child nodes.

•	 Press Optimize to execute the optimization process.
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Now execute the Material Editor optimization
•	 This step is only necessary if you chose to open the IGES files. The 

microracer_start file materials have already been optimized.
•	 In the Material Editor click Edit.
•	 In the dialog box menu select Edit > Optimize Materials.
•	 Multiple identical materials will be replaced by a single material.

The imported data is split into separate patches, which still 
need to be merged to a connected part on an object basis. The       
optimization process merges all meshes with identical materials 
that are located in the same group, to a single object.

After importing data, the scene needs to be optimized.
•	 Select File > Optimize Scene in the Menu bar.	
•	 Select Optimize Geometries in the drop-down box.
•	 Execute by clicking OK.

Optimize scene
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Rearranging the Scenegraph

To obtain a better overview of the objects in the scene, 
we recommend that you prepare and restructure the 
Scenegraph.

•	 Right-click on any node in the Scenegraph and select Create > Group 
to create a group node. Any new group node will be created as a 
child of the selected node.

•	 Right-click on the root node and create a new group. Enter the name 
Microracer.

•	 Right-click on the Microracer group and create two other groups as 
children. Name them Interior and Exterior.

•	 Create another group called Chassis as child of the group Exterior.
•	 Move the Kasko.igs group node into the Chassis group, either by 

doing a cut and paste operation in the Scenegraph, or simply by 
using the drag and drop functionality.

•	 To use the cut and paste function, select the group node to be 
repositioned and press CTRL+X. Then select the designated parent 
group node and press CTRL+V.

•	 To use the drag and drop function, select the group to be 
repositioned, click and hold the left mouse button, drag it to the 
designated parent group, and drop. The moved group will be placed 
between the gray indicator lines that appear between two nodes. If 
the node turns blue, the group will be placed into the framed node.

Create further groups and reposition all nodes to 
achieve a logical Scenegraph structure. 

•	 Right-click on the rim_blends.igs group node in the Scenegraph and 
create two new group nodes called rim_blend_front and rim_blend_ 
back.

•	 Select Front Shells in the Scenegraph and move them into the “rim_
blend_front” Group.

•	 Select Back Shells in the Scenegraph and move them into the “rim_
blend_back” Group.
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Creating geometry switches

A geometry switch node offers the possibility of     
making one of a series of objects visible. There are 
two front bumper versions in this file. Add both front    
bumpers to a geometry switch node.

•	 In the Scenegraph, select Create > Switch. Drag the Switch below 
Bumper_back.

•	 Cut and paste both front bumper group nodes into the switch node.
•	 Both geometries are invisible because the initial state of a switch 

node is set to “None” by default, which means that no child is shown.
•	 Open Scene in the Menu Bar and click Variants.
•	 Right Click in the Variants module and “Create All”.
•	 Now the created Switch can be seen.
•	 Select the Switch and set the State from “!None” to “!Next” and 

assign a hotkey to it.
•	 Now you can switch between the two bumpers by clicking the 

hotkey.

This is what the Scenegraph should look like with the 
bumper switch:

•	 Continue rearranging the Scenegraph by moving the door and 
bumper nodes to the Chassis group.
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Duplicate & mirror

After rearranging the Scenegraph, it becomes apparent 
that some parts are only partially modeled. In this case, 
they can simply be duplicated and mirrored (i.e., for the 
co-driver’s side).

•	 Right click on the group node Bumper_front_b.igs and select Edit > 
Duplicate > Mirror X.

•	 A new node named Bumper_front_b_mirrored has been created and 
is at the bottom of the scenegraph.

•	 Drag and drop Bumper_front_b_mirrored into Bumper_front_b.igs.
•	 Now you have created the missing part of the bumper.

Duplicate and mirror all missing parts, rename 
them, and place them adequately in the 
Scenegraph:

•	 Headlight interior parts
•	 Rims and tires
•	 Rear light interior parts
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Surface direction and normals

The surface normals define the direction, a surface 
is pointing. To see the surface directions, switch to      
Vertex/Face normal rendering render mode.

•	 Press F5 or in the Visualization menu turn on Vertex/Face Normal 
Rendering.

•	 Each surface has a green and a blue drawn side. To receive proper 
shading and ambient occlusion rendering results, all surfaces viewed 
from the outside should appear green. Green means the vertex and 
surface normals point towards the camera. Blue means the vertex 
and surface normals point away from the camera.

•	 To adjust the surface normals open the Scene > Geometry Editor > 
Normals module.

•	 Select any geometry part appearing blue. Press the Face and Vertex 
button in the Normals tab. All normals of the selected object will be 
flipped.

Sometimes only part of the selected object’s normals 
have to be flipped:

•	 Press and hold ALT + click right mouse button on the blue parts 
of the surface. Only the adjacent blue faces will be flipped. The 
adjacency crease angle can be set in the Scene >  Geometry Editor > 
Normals.

•	 Adjust the normals direction for the car’s frame, brakes, headlight 
interiors, rear window, and others.

•	 Press F3 to change the render mode to “Realistic High Quality” 
rendering.
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Material: Shadow Material

Use and assign materials.
The Shadow Material is a special material for ground surfaces. It 
is a transparent material that is opaque only where ambient 
occlusion is calculated or where shadows cast by light sources or 
EnvironmenSphereMaterials (only raytracing mode) hit the ground.
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Create a Unicolor Paint Material for the car’s chassis. 
•	 Right-click in the Materials tab and select Create Material > Unicolor 

Carpaint.
•	 Rename the Unicolor Carpaint material to CarPaint_01.
•	 Set the car paint base color to orange using the color chooser.
•	 Set the car paint clearcoat color to white.
•	 Assign CarPaint_01 to all body parts of the car.
•	 Select all body parts in the Renderview with SHIFT+CTRL+left-click.
•	 In the Materials tab, right-click on the CarPaint_01 material and 

select Apply to Selected Nodes.

Material: Carpaint Material & Plastic Material

Create a Plastic Material for the car’s plastic parts.
•	 Right-click in the Materials tab and select Create Material > Plastic.
•	 Rename Plastic Material1 to “BlackPlasticGrill”.
•	 Assign the BlackPlasticGrill material to the two front grills. This 

time, assign the material by dragging it from the Material Editor and 
dropping it on the grill in the Renderview.

•	 Set the BlackPlasticGrill material’s Diffuse Color to black.
•	 Set the Glossy Color to mid-gray.
•	 Set the Roughness to 2.
•	 Enable the Use Structure check box in the Bump Texture menu.
•	 Set the Bump Intensity value to 2.
•	 Set the Structure Size to 0.3.
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Create a Glass Material for the car’s headlight glasses.
•	 Right-click in the Materials tab and select Create Material > Glass.
•	 Rename the Glass material to HeadlightGlass and assign it to the 

headlight glass parts.

Create a GlassMaterial for the car’s indicators.
•	 Right-click in the Materials tab and select Create Material > Glass.
•	 Rename Glass material to IndicatorGlass and assign it to the indicator 

glass parts.
•	 Set the Exterior Transparency color to a strong orange color.

Material: Glass Material

Create a Glass Material for the car’s frontglass.
•	 Right-click in the Materials tab and select Create Material > Glass.
•	 Rename the Glass material to FrontGlass and assign it to the headlight 

glass parts.
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Material: Chrome & brushed metal

Create a Chrome Material for the car’s chrome parts.
•	 Right-click in the Materials tab and select Create Material > Chrome.
•	 Assign the Chrome material to the chrome parts in the headlights.

Create a Brushed Metal Material for the car’s brushed 
aluminum parts. 

•	 Right-click in Materials tab and select Create > Brushed Metal.
•	 Rename the Brushed Metal material to “Aluminium”.
•	 Assign the Aluminium material to the brushed_aluminum parts of the 

headlights.
•	 Set the Glossy Color to a light gray color with a value of 0.8.
•	 Set the Roughness U value to 0.5 and the Roughness V value to 1.
•	 Set the Metal Type to Aluminium.
•	 Brush Orientation > Set the Brush Mapping to planar YZ.
•	 Set the Size U value to 5 and the Size V value to 0.3
•	 Bump Texture > Use structure.
•	 Set the Bump Intensity to 1.1.
•	 Set the Specular Weight to 0.75.
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Material: Brushed metal 

Create a BrushedMetalMaterial for the rims.
•	 Right-click in Materials tab and select Create > Brushed Metal.
•	 Rename the Brushed Metal to Rim Material.
•	 Assign the Rim Material material to the front left and front right rim.
•	 Set the metal type to Aluminium.
•	 In the Brush Orientation section, set the Brush Mapping orientation 

to Radial YZ.
•	 Set the Size U and V value to 0.3.
•	 Select the front left rim and press Get Center in the material’s Radial
•	 Mapping section.
•	 Enable the Use Structure check box in the Bump Texture section.
•	 Set the Bump Intensity value to 1.

Duplicate the Rim Material and assign the duplicated 
material to the rear rims.

•	 Right-click on the Rim Material in the Material Editor > Material tab.
Select Edit > Duplicate.

•	 Rename the duplicated material to Rim Material_back.
•	 Assign the Rim Material_back material to the rear rims.
•	 Select the left rear rim and press the Get Center button in the 

material’s Radial Mapping section.
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Material: Tire Material

Create a Tire Material for the car’s tires.
•	 Right-click in the Materials tab and select Create Material > Tire.
•	 Rename the Tire to tire_front_left.
•	 Assign the tire_front_left material to the left front tire.
•	 Set the Diffuse Color to black.
•	 Set the Glossy Color to white.
•	 Set the Roughness value to 1.5.
•	 Load the file tire_marking_bump.jpg as the Diffuse marking texture.
•	 Load the tire_profile_bump.jpg as the Diffuse profile texture.
•	 Load the file tire_marking_bump.jpg as the Bump marking texture.
•	 Load the tire_profile_bump.jpg as the Bump profile texture.
•	 Set the Bump Intensity to 10.
•	 Set the Parallax Intensity to 0.8
•	 Select the front tire and press the Get Values from Object button      

in the Texture Settings section located in the materials attributes.
•	 Set the texture Repeat Profile U value to 11 and the Repeat Profile V 

value to 5. These values define the repeat behavior of the profile area 
of the tire.

•	 Set the Scale Markings value to 1.7. This value defines position and 
size of the markings.

Duplicate the tire_front_left material and rename the 
new material to tire_front_right. 

•	 Assign the tire_front_right material to the front right tire. Caution: 
The profile will not be placed correctly.

•	 To update the profile placement, select the front right tire and press 
the “Get Value from Object” button in the Texture Settings section 
located in the material attributes of the tire_front_right material.

•	 Repeat the same procedure for the two rear tires.
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Material: Carbon Material

Create a Carbon Material for the car’s back door.
•	 Right-click in the Materials tab and select Create Material > Carbon.
•	 Rename the Carbon material to rear door.
•	 Assign the rear door material to the rear door.
•	 Set the Carbon Pattern Type in the Carbon Pattern section to 3x1 

Staircase.
•	 Set the Pattern Size to 2.
•	 Enable the Use Structure check box in the Bump section.
•	 Set the Bump Intensity to 1.5.
•	 Set the Structure Size to 2.5.

Now go through the following steps:
•	 Create a black Reflective Plastic material for the door handles and 

name it door_handle.
•	 Create a black Plastic material for the car’s chassis blackout and name 

it black.
•	 Create a Chrome material for the car’s exhaust and call it exhaust.
•	 Create a Chrome material for all Logos and types named Logo.
•	 Create another Chrome material called cover for the gas cover and 

increase the Roughness value.
•	 Create a red Glass material for the rearlights called rear_glass.
•	 Adjust the windshield’s glass material transparency. Set the Exterior 

Transparency color to black.
•	 Assign the IndicatorGlass material to the side blinker`s internal light 

geometry.
•	 Create a Brushed Metal Material and name it dark_metal using the 

metal type Tungsten.
•	 Assign it to the brake calipers, lug nuts, ventiles and the center caps.
•	 Create a Brushed Metal material called brake disc and apply to the 

brake discs.
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Ambient Occlusion

Precalculated Ambient Occlusion is a Render mode. In 
raytracing mode, ambient occlusion settings take effect 
only on surfaces that have TruelightShaders assigned 
and when selecting a Pre-computed Illumination render 
mode. In Raytracing GI rendering mode the 
pre-calculated ambient occlusion will be ignored. All 
information will be rendered at runtimes.
To calculate the ambient occlusion, you must to create a ground 
plane, which visualizes the occlusion information at the car’s 
bottom side. This was completed in the Material: Shadow 
Material section. 

Select the Microracer group node in the Scenegraph. 
Hold the CTRL key and select the ShadowPlane 
contained in the Environment node in the Scenegraph.

•	 Scene > Ambient Occlusion.
•	 Set the Shadow Quality to Medium Quality.
•	 Press Calculate All. Ambient Occlusion is a complex calculation and 

may take considerable time to complete.
•	 Press F7 to switch to Ambient Occlusion Rendering render mode.

The ambient occlusion calculation is vertex-based. To achieve a 
completely smooth result, it may be necessary to recalculate some parts, 
which do not have a mesh fine enough to offer smooth transitions
from dark to bright. VRED adds further subdivisions to these parts if 
necessary. Subdivisions will be added to all.
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Ambient Occlusion

The surface normals define the direction at which      
surface is pointing. To see the surface directions switch 
to “Vertex/Face normal rendering” render mode.

•	 Select the Ground Plane and all glass objects.
•	 In the Ambient Occlusion Module, enable the subdivision checkbox.
•	 Set the Subdivision Quality to High Quality.
•	 Set the Minimum Edge Length to 1 and press Calculate All.
•	 All selected parts will be rerendered, taking into account all visible 

parts.

Sometimes only part of the selected object’s normals 
have to be flipped:

•	 Select the headlight glass. Right-click on the headlight glass node in 
the Scenegraph and hide it.

•	 Geometries behind the glass are black because the headlight 
glass was not recognized as a transparent object during occlusion 
rendering. To define objects as transparent for ambient occlusion 
rendering, assign a transparent material.

•	 Unhide the headlight glass.

•	 Press F3 to switch to Realistic High Quality render mode.
•	 In the MaterialEditor > Materials tab: Right-click on the material 

assigned to the glass objects and select Convert > ToTruelightMaterial 
> Glass.

•	 Switch back to ambient occlusion render mode (F7) and recalculate 
the whole car and the ground.

•	 Set the shadow quality to Medium Quality.
•	 Deactivate the Subdivision check box in the Ambient Occlusion 

module before recalculating and press Calculate.
•	 Press F3 to switch to Realistic High Quality render mode.
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Material: Intermediary result

This is how your picture should look now:
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Creating environments

HDR images can be used as spherical environments. 
They surround all objects of the scene. An HDR image 
can also be used to define the lighting of a scene. VRED 
provides a default HDR image that is connected to all 
TruelightMaterials and is used to light the scene.

•	 At the bottom of each material’s attributes list (except for the 
ShadowMaterial) is an Environment section under the Common tab.

•	 The environment value is set to SkyDomeEnv, which indicates that the 
default HDR image is in use.

•	 To use an individual HDR image as environment, a 
SphereEnvironmentMaterial is needed.

•	 In Material editor right click in the Materials pane. Select Create 
Environment > Sphere Environment.

•	 Navigate to the forest.mtd image and select.
•	 The envirognment will be loaded and named.

Assign the new environment to all TrueLightMaterials.
•	 Drag&Drop the “forest” Material on the Dome Geometry
•	 Right Mouse click on forest and select “Apply Environment to All 

Materials”.
•	 The previous lighting information will be replaced by the lighting of 

the new forest material.
•	 In the forest material’s attributes, set the Reflected Saturation value 

to 0.65.
•	 Save the project file.
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Projected textures

Create projected textures.
Create a Reflective Plastic Material for the numberplate.

•	 Right-click in the Materials tab and select: Create Material > Reflective 
Plastic and assign to the License plate geometry.

•	 Rename the Reflective Plastic Material to licenseplate.
•	 Set the material’s environment value to forest in the Common section 

of the numberplate material.
•	 In the Diffuse Texture section, assign the licenseplate material to the 

license plate.
•	 Enable the Use Texture check box and select the texture 

nummerntafel_8.gif.
•	 With the licenseplate geometry node selected, select Scene > 

Textures Editor.
•	 Select Edit Texture Projection.
•	 Move the Visibility slider to max.
•	 In the Place Texture 2D section, rotate the texture by 180 degrees.
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Material switches

Create material switches.
A Switch Material is a material node that enables the assignment 
of different materials. In other words, it can be used to switch 
between the different color variations. Create a Switch Material 
as a bucket for different car paints.

•	 Right-click in the Materials tab and select Create Material > Switch.
•	 Rename the Switch to carpaint.
•	 Right mouse click on the CarPaint_01 material in the Material Editor 

Scenegraph and select Select nodes. All objects with the CarPaint_01 
material assigned will be selected.

•	 Right-click on the Switch Material carpaintSwitch and select Apply to 
selected nodes.

All chassis parts will turn black, since there is still no 
shading added to the carpaintSwitch node yet.

•	 Right-click the CarPaint_01 material and select Edit > Copy.
•	 Select the carpaintSwitch node and Edit > Paste the CarPaint_01 

material into the context box of the carpaintSwitch node.
•	 Edit > Duplicate the CarPaint_01 material. Rename the new CarPaint_
•	 material to CarPaint_02.
•	 Add the CarPaint_02 material to the carpaintSwitch node. 
•	 Set the CarPaint_02 material’s color to gray.
•	 Create a Metallic Carpaint Material.
•	 Right-click in the Materials tab and select Create > Metallic Carpaint
•	 Rename the MetallicPaintMaterial to CarPaint_03.
•	 Set the CarPaint_03 material’s Environment parameter to forest in the 

Common section.
•	 Add the new material to the carpaintSwitch material node.
•	 Now the Chassis color can be quickly changed by choosing different 

materials in the carpaint switch.
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Environment Material switch

Create environment material switches.
An Environment Switch Material is a material node that enables 
instant assignment of different HDR surroundings to all shaders. 
The lighting situation can be switched immediately, based on the 
used HDR image.

•	 Right-click in the Materials tab and select Create Environment > 
Environment Switch.

•	 Rename the Environment Switch Material to EnvSwitch.
•	 Right-click in the EnvSwitch content box and select Add Environment 

> forest.
•	 Create a new Sphere Environment Material called EnvStudio.
•	 Load the HDR image called perfectStudio.mtd.
•	 Add the EnvStudio material to the EnvSwitch. 
•	 Add the SkyDomeEnv material to the EnvSwitch.
•	 Apply the EnvSwitch material to the Dome geometry node.
•	 Right-click on the EnvSwitch material and select Apply Environment 

to All Materials. Leave the dialog box empty. All Truelight Material’s 
forest values in the environment parameter will be replaced by the 
EnvSwitch value.

•	 Select the desired HDR Image in the EnvSwitch Choice parameter.
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Object animations

Position the pivot and create object animations.
Animations can be created in the Curve Editor module. VRED 
supports the creation of keyframe animations. Keyframe 
animations can be rearranged and retimed in the Clip Maker 
module.

How to create a back door animation:
•	 Select the rear_door group node in the VRED Scenegraph. Activate 

the Transform Tool in the Icons tab.
•	 Press Shift + Q to activate the Pivot-Transform Tool.
•	 Hold shift to position the pivot (yellow arrows) at the top edge of the 

backdoor.
•	 Press Shift + E to activate the Rotate Tool.
•	 An object can be rotated by holding Shift + left clicking on the circles
•	 Open Animation > CurveEditor module.
•	 The rear_door transform parameters will be listed in the CurveEditor’s 

Scenegraph. Press the Key All Channels button in the CurveEditor 
to key the initial rear_door position at frame 0. Keyed parameters 
appear colored.

•	 Go to Animation > Timeline to display the timeline at the bottom of 
the Renderview and move to frame 24. Rotate the x-axis of the Back_
door geometry 95 degrees. Press the Key All Channels button  again.

•	 Press “f” to frame all created keyframes in the CurveEditor´s Graph.
•	 Hold SHIFT + click left mouse button and drag to create a frame 

selection around all keyframes. Press the “Flat tangents” button to 
define a flat tangent in all keyframes.

•	 Scrub through the timeline to view the animation. To store the 
animation, press the Create an animation block element button in 
the CurveEditor. An animation Block called “rear_door_Block”will 
be created and added to the CurveEditor’s Scenegraph. It lists all 
animated parameters. When selecting the rear_door_Block parameter, 
the stored animation can be accessed and played.

•	 Go to Animation > Clip Maker and create a clip by clicking on the plus 
sign icon and selecting Clip.

•	 Drag&Drop the rear_door_Block onto the new clip.
•	 Right click on the rear_door_Block parameter in the Clipmaker and 

select “Duplicate flipped”.
•	 Left mouse button drag the duplicate to the end of rear_door block.
•	 Now press the Play Button, in the Clip Maker, and view the reverse 

animation.
•	 In the Curve Editor the Back_door parameters are now free for 

further keyframe animations. An unlimited number of Animation 
Blocks can be created.
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Camera animations

Camera animations can also be created using the 
CurveEditor module.

•	 Select the Microracer group node in the VRED Scenegraph and press 
right view on the Navigation Cube in the Renderview.

•	 Open the Animation > Curve Editor module.
•	 In the Time Line set the end frame value to 100 and move to frame 0.
•	 In the Scenegraph, select Perspective Camera in the root node. 
•	 Press the Key all channels button in the Curve Editor.
•	 Move to frame 50 in the Time Line.
•	 Select the Microracer group node in the VRED Scenegraph and press 

front view on the Navigation Cube in the Renderview.
•	 In the Scenegraph, select Perspective Camera in the root node. 
•	 Press the Key all channels button in the Curve Editor.
•	 Move to frame 100 and in the Time Line.
•	 Select the Microracer group node in the VRED Scenegraph and press 

left view on the Navigation Cube in the Renderview.
•	 In the Scenegraph, select Perspective Camera in the root node. 
•	 Press the Key all channels button in the Curve Editor.
•	 Select Create an animation block element, in the Curve Editor, to 

store the animation. A camera block will be created.
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Rendering

VRED supports two different rendering modes: OpenGL 
rendering and raytraced rendering-. 

•	 Switching between both render modes does not require particular 
preparation. To activate raytracing rendering press the Raytracing 
button in the Icons bar.

•	 To improve the interactive performance in the Renderview press 
“Downscale” in the Icons Bar. Press and hold the left Mouse button on 
the Downscale button. Four modes are available.

•	 In case no antialiasing calculations take place select Antialias in the 
Icons bar. Alternatively, press the spacebar.

•	 Caution: In OpenGL Mode all reflections are approximated. A 
correct result will only be received in raytracing mode, as this mode 
calculates light beams physically. Nevertheless, all color variations, 
geometry switches, environment switches, and animations are 
available in both modes in the same way.
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Raytracing rendering

Creating area lights in raytracing rendering
•	 In the Material Editor, switch to the default environment and change 

the carpaint switch to metallic carpaint.
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Raytracing rendering

Direct light sources can be converted to area light 
sources.

•	 Activate Downscale and Raytracing in the Menu bar.
•	 Create a PlasticMaterial. Rename it ground_plastic and assign it to 

the Shadowplane. 
•	 Change the EnvSwitch material to SkyDomeEnv.
•	 Go to Scene > Light Editor.
•	 Right click in the Light Editor Scenegraph and select Create > Disk 

Light.
•	 Set the light intensity to 2. 
•	 Enable the Visible in Reflections check box.
•	 Select Transform from the Icons Bar, to move and scale the Disk Light.
•	 Shift drag the move manipulator and place the Disk Light above the 

Microracer.
•	 Shift R to change to the scale manipulator.
•	 Shift drag the yellow cube to scale uniformly. Scale toapproximately 

400.
•	 Adjust the height of the Disk Light if necessary (shift W). 
•	 Activate Antialias in the Menu bar.

Create area lights in raytracing rendering.
•	 The whole scene is still being lit by the HDR image and the DiskLight.

To use only the DiskLight’s lighting, set the SkyDomeEnv Exposure 
value to 0.
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Global illumination

Raytracing rendering mode supports full global 
illumination. When you activate this function, more 
than one light reflection bounce will be calculated. All 
shadows will be calculated on the fly.

•	 Adjust the ground_plastic material.
•	 Set the Roughness value to 0.02.
•	 Set the Reflectivity value to 0.5.
•	 Open Rendering > Render Settings. In the Raytracing Quality set the 

Illumination Mode in Still Frame to Full Global Illumination.
•	 In the Reflection/Refraction Sampling Quality tab, change the Still 

Frame value to 3.
•	 In the Trace Depth tab, change the value for Still Frame to 32.
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Interface: Iconstab

The Icons tab provides shortcuts to access commonly 
used features, such as the render options or the 
wireframe function.

File Open: File > Open

Add File: File > Add

Save File: File > Save

Antialiasing: Turns on / off antialiasing.

Raytracing: Activates raytracing. When deactivated OpenGL 
mode.

Downscale: Activates/ deactivates downscaling. Offers a total 
of four downscaling options to accelerate the work process. 

Region: Defines a render region.

Isolate: Shows only the selected nodes in the Renderview.

Backplate: Sets the backplate to visible / invisible. 

Wireframe: Renders the geometry in wireframe.

Bounding Box: Draws the maximum cubic extension of 
selected object.

Headlight: Activates the Headlight. Its position is identical to 
the camera’s position. It points in the same direction as the 
camera’s view. 

Statistics: Activates the scene’s statistics. They are drawn at 
the top left corner of the Renderview.

Full Screen: Activates Full Screen render mode. Pressing 
Escape deactivates Full Screen render mode.

Presentation: Disables all VRED internal hotkeys except user 
defined hotkeys from the Variants module.

Show all: Shows all objects in the scene.

Zoom: Frames selected objects. 

Grid: Shows the Grid. In default mode it is the XY Grid.

Ruler: Activates the Ruler check box. The ruler axis adapts 
according to the view axis.

Transform: Activates the Transform tool to interactively 
transform objects in Renderview.

•	Press any arrow to move selected object along the selected 
transform axis.

•	 Press any cube to scale selected object along the selected 
scale axis.

•	Press any sphere to rotate selected object along the 
selected rotation axis.

	 red > X-axis

	 green > Y-axis

	 blue > Z-axis

•	Press the yellow cube to scale the selected object along all 
scale axes uniformly.

•	Press the green, red, or blue plane to move selected object 
along selected plane axis.

Texturing: The new Texture editing mode allows the user to 
interactively place and modify textures without opening the 
Material Editor.

Simple UI: Enables a user to create image content very 
quickly. Reduces functionality to a minimum viable amount.

Connect: Using the connector, VRED instances can be 
synchronized for navigation, even on independent computers. 
This mode can be useful to compare variants, for example. 
Besides navigation, python commands are synchronized.

Cluster: Opens the Cluster module. The Cluster module 
provides access to all settings for setting up the different 
clustering modes VRED offers.

Tracking: The tracking module is responsible for connecting 
an external tracking system to VRED by communicating to one 
or more VRPN (Virtual Reality Peripheral Network) servers.
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Learn more or purchase
Access specialists worldwide who can provide product expertise, a deep understanding 
of your industry, and value that extends beyond your software. To license Autodesk 
VRED software, contact an Autodesk Authorized Reseller. Locate a reseller near you 
at www.autodesk.com/reseller.

Autodesk Education
Autodesk offers students and educators a variety of resources to help ensure 
students are prepared for successful design careers, including access to free* 
software, curricula, training materials, and other resources. Anyone can get expert 
guidance at an Autodesk Authorized Training Center (ATC®) site, and validate skills 
with Autodesk Certification. Learn more at www.autodesk.com/education. 

Autodesk Subscription
Autodesk® Subscription gives you a greater advantage with powerful cloud-based 
services, access to the latest software, online technical support, and flexible 
licensing privileges.** Learn more at www.autodesk.com/subscription.

Autodesk 360
The Autodesk® 360 cloud-based framework provides tools and services to extend 
design beyond the desktop. Streamline your workflows, effectively collaborate, and 
quickly access and share your work anytime, from anywhere. Learn more at  
www.autodesk.com/autodesk360. 

*Free Autodesk software licenses and/or cloud-based services are subject to acceptance of and compliance with the 
terms and conditions of the license agreement or terms of service, as applicable, that accompany such software or 
cloud-based services.

**All Subscription benefits are not available for all products in all geographies. Please consult your Autodesk reseller 
or sales representative for more information.

Autodesk, the Autodesk logo, ATC and VRED  are registered trademarks or trademarks of Autodesk, Inc., and/or its 
subsidiaries and/or affiliates in the USA and/or other countries. All other brand names, product names, or trademarks 
belong to their respective holders. Autodesk reserves the right to alter product and services offerings, and specifica-
tions and pricing at any time without notice, and is not responsible for typographical or graphical errors that may 
appear in this document.
© 2013 Autodesk, Inc. All rights reserved. 

Autodesk is a world-leading supplier of engineering software, 
providing companies with tools to experience their ideas be-
fore they are real. By offering powerful visualization
technology to the automotive industry, Autodesk helps car 
manufacturers and their suppliers move from physical to
virtual processes and create more productive workflows. The 
Autodesk automotive approach is unique in that it is scalable, 
attainable, and cost-effective, which allows a broader group 
of manufacturers to realize the benefits of high-end
visualization and virtual prototyping. It provides the most 
straightforward path to creating and maintaining visual
reference in a multidisciplinary engineering environment.


