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Sharing complex design information has never been 

easy. Since design files are large, sending sheet sets and 

3D models to printers, or sharing work with extended 

team members, has taken a lot of time and effort, not to 

mention bandwidth. DWF™ technology changes all that. 

DWF-based designs are compact, secure, and easy-to-

use. In fact, because sharing rich 2D and 3D design  

information is a snap with DWF, completely digital 

workflows become possible—streamlining the flow of 

information across the entire project team.

This handy pocket guide of DWF Tips and Tricks provides 

individual users and entire project teams with the infor-

mation needed to get the most from DWF. To learn more 

about DWF visit www.autodesk.com/dwf. 

Publish 
The ability to publish DWF files is built 
into every Autodesk® design applica-
tion and available free* of charge when 
using third-party applications with the 
Autodesk® DWF™ Writer. 

• Information on how to publish  
DWF files from Autodesk products is 
available in the product documentation. 
Information is also available online at  
www.autodesk.com/dwf-publishing. 

*This product is subject to the terms and conditions 
of the end-user license agreement that accompanies 
download of this software.

Publish 3D DWF Files from  
AutoCAD-Based Products
Create and publish DWF files of 3D mod-
els with the 3D DWF PUBLISH command, 
available only if you have installed the 3D 
DWF Publishing feature with AutoCAD® 
2006–based products.

1.  On the command line, enter  
3ddwfpublish. 

2. In the 3D DWF Publish dialog box,  
under DWF File Name, change the 
name and location of the DWF file  
to be saved, or use the [...] button  
to navigate to a new location for the 
3D DWF file. 

3. Under Objects to Publish, click one of 
the following: 

• All Model Space Objects. All model 
space objects are published to the  
3D DWF file. 

• Selected Model Space Objects.  
Create a selection set of model space 
objects, which are published to the 
3D DWF file. 



4. If the drawing contains xrefs, the 
Group By Xref Hierarchy option is 
selected by default. Clear the check 
box if you do not want to display the 
objects grouped by xref hierarchy in 
the published DWF file. 

5. Under Group Individual Objects By, 
select one of the following options to 
group individual objects in the DWF 
file for viewing. Click OK. 

• Layer. Group individual objects  
by layer. 

• Object Type. Group individual  
objects by object type (for example, 
by block). 

Add Object Properties from  
AutoCAD Blocks
Enable team members to access  
AutoCAD block properties in the DWF 
file by setting DWF publishing options. 

1. From the File menu, choose Publish. 

2. In the Publish dialog box, under Pub-
lish To, click DWF File, and then click 
Publish Options. 

3. In the Publish Options dialog box, 
under DWF Data Options, Block 
Information, select Include from the 
drop-down list. 

Note: By default, Block Information is 
set to Don’t Include. If you change the 
setting to include block information, you 
can use the viewer to view or print block 
property and attribute information in 
the DWF file.

4. Click OK. 

5. In the Publish dialog box, either con-
tinue with publishing tasks or close the 
dialog box. 

Increase the Precision of  
the DWF File
Specify the pixel resolution for vector 
and raster graphics when creating DWF 
files. The higher the resolution, the 
greater the precision but the larger the 
file size.

1.  From the File menu, choose Plot to 
display the Plot dialog box.

2. Ensure that DWF 6 ePlot.pc3 is  
selected. Click Properties to display  
a tree control.

3. Select Graphics from the tree, and 
expand it. Select Custom Properties 
in the tree control, and then click the 
Custom Properties button.

4. Set Vector Resolution to the desired 
value. You can leave the other DPI 
values (Gradient Resolution, Color 
and Grayscale Resolution, and Black 
and White Resolution) as they are. 
Valid values from the pull-down menu 
are between 150 and 4800. Use the 
keyboard to enter a custom value, such 
as 30270.
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Pass It On: Publish DWF and Email 
Easily email a DWF file when using  
Autodesk DWF Writer.

1. Select the file to be published, and 
choose Publish DWF and Email. 

• The default email application opens, 
automatically creating a new email 
message. 

• The subject displays the name of  
the published DWF file.

• The DWF file is automatically  
attached to the file.

• The URL to download the free  
Autodesk DWF Viewer is provided  
to streamline the process.

Publish from Microsoft Office  
Documents 
With Autodesk DWF Writer installed, 
users can publish DWF files from  
Microsoft® applications (PowerPoint®, 
Word, Excel®, Visio®, Outlook, and  
Internet Explorer) and share them as  
part of the project set.

1.  Click the Publish DWF button on the 
Microsoft application toolbar, or from 
the File menu, choose Print and then 
select Autodesk DWF Writer in the list 
of available printers.

2. Specify a file name and location for 
the published DWF file.

3. Choose Print.

Publish from SolidWorks® 2005 or 
Pro/ENGINEER® Wildfire 2.0
Install Autodesk DWF Writer 3 to publish 
3D models and design data from Solid-
Works® 2005 or Pro/ENGINEER® Wildfire 
2.0 software. 

1. From the file menu, select Publish 
DWF to automatically turn your 2D 
drawing or 3D model into DWF.

• Learn about publishing from  
other applications, by visiting  
www.autodesk.com/dwf-publishing.
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View & Print
In the past, viewing rich design data 
required the purchase of CAD software. 
Now, the free*, downloadable Autodesk® 
DWF™ Viewer means that everyone on 
the team can navigate sheet sets, access 
design information, and print whatever 
they need.

Download the free Autodesk DWF 
Viewer at www.autodesk.com/ 
dwfviewer-download.

*This product is subject to the terms and conditions 
of the end-user license agreement that accompanies 
download of this software.

Pull Apart a 3D Model 
Autodesk DWF Viewer users can navi-
gate 3D models published from Autodesk 
applications or with the free Autodesk 
DWF Writer. Follow these steps to rotate 
and pull apart individual pieces of a 
model:

1. From the Tools menu, choose Move 
and click Rotate.

2. In the Model palette  or view area, 
click the parts that you want to move 
or rotate.

Remove a Part from the Selection 
Press and hold the Ctrl key and click  
the part again (Ctrl+click). In the  
Model palette, use Shift+click to select 
consecutive parts by clicking the first 
and last parts in the series.

Move Along an Axis 
On the axis along which you want to 
move the part, click that axis near the 
origin. Drag in either direction along the 
axis. Alternatively, press the Up Arrow 
key to move away from the origin or the 
Down Arrow to move toward the origin.

Move Within a Plane 
Roll the cursor over a plane defined by 
two axes until a plane icon with arrows 
appears, and click. Drag the part in any 
direction. 

Move Parallel to the Screen 
Click the origin, and drag the part in any 
direction. Or use the keyboard arrows to 
move left, right, up, or down.

Rotate 
On the axis around which you want to 
rotate the part, click near the end of the 
axis and drag the part around the axis. 
Or press the Down Arrow key to rotate 
1 degree clockwise or the Up Arrow key 
to rotate 1 degree counterclockwise. To 
rotate the part in 45 degree increments, 
press and hold the Shift key while using 
the keyboard arrows.

 Result

Begin Move
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Cut 3D Cross Sections

Cut through a model with a section 
plane and manipulate the view in various 
ways by moving and rotating the section 
plane and flipping the view.

1. Open a model and from the Tools 
menu, choose Cross Section> 
XY Section, YZ Section, or XZ Section. 

2. A transparent purple sheet (the sec-
tion plane) and a tripod drop into the 
center of the model, cutting through 
the model to reveal a cross section. 
Move or rotate the section plane to 
reveal a different cross section each 
time.

3. The three legs, or axes, of the tripod 
meet at a central point called the 
origin. To change the cross section 
revealed, move or rotate the section 
plane by moving the cursor over 
the tripod. Hot spots appear, each 
enabling the user to move the section 
plane in a different way. 

Before

After

Use Flexible Printing Options
Preview the job before sending it to the 
printer. Partnerships with printer manu-
facturers like HP and Océ help assure 
fast, high-quality output.

Print to Spec 
Customize the settings that affect 
output from standard to large format. 
Choose from among the following op-
tions: 

1. Full Page or the Current View

2. Paper Size or select Use DWF  
Paper Size

• Landscape or Portrait

• Fit to Page or Print to Scale

• Tile across multiple pages

Move Along an Axis 
On the axis along which you want to 
move the section plane, click the axis 
near the origin. Drag in either direction 
along the axis. Click the Up Arrow key to 
move away from the origin or the Down 
Arrow key to move toward the origin.

Move Within a Plane 
Roll the cursor over a plane defined by 
two axes until a plane icon with arrows 
appears, and click. Drag the section 
plane in any direction.

Move Parallel to Screen 
Click the origin. Drag the section plane in 
any direction. 

Rotate 
On the axis around which you want to 
rotate, click near the end of the axis. 
Drag the section plane around the axis. 
If you press and hold the Shift key while 
using the keyboard arrows to rotate, 
the section plane rotates in 45 degree 
increments.
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Preview What You Print

1. From the File menu, choose Print to 
open the Print dialog box.

2. Choose the settings that affect your 
preview, like paper size or landscape 
view. 

3. Click the Show Print Preview button. 

Print Instantly to HP Printers

1. Click the HP Instant Printing  
button. 

 Note: The button automatically  
appears if you are connected to a  
supported HP® Designjet™ printer.

• The optimal print settings are chosen 
automatically based on the properties  
of the DWF file.

Access Design Intelligence
Publish detailed design information from 
Autodesk® Architectural Desktop 2004 
and later versions, AutoCAD® 2006–
based products, and Autodesk Inventor® 
software, for viewing in Autodesk DWF 
Viewer or Autodesk® DWF™ Composer.

View and Sort Object Properties 
Click the Properties window.

Access Block Information 
In the Content Browser, select the Prop-
erties window, and then choose Object 
Properties from the drop-down menu.

Click the selector button, and  
then click the block to display  
the block data.

Search for Design Data 
In Microsoft® Windows® Explorer, select 
Search, and enter your search string to 
find data within the DWF file such as 
doors, bolts, and more.

Navigate Sheets or Views Using  
Hyperlinks 
From the main menu, choose 
View>Show>Hyperlinks (Ctrl+H) to  
display hyperlinks in blue. To follow a  
hyperlink, hold down the Ctrl key and 
click the hyperlink (Ctrl+click). The  
drawing, file, or web page to which it  
was linked opens.

Present in Microsoft Office  
Applications
Share the full design intent in Microsoft 
PowerPoint, Excel, or Word whether it’s a 
client presentation, product documenta-
tion, or bill of materials.

1. Drag the file from Windows Explorer 
into the document.

2. Alternatively, from the Insert menu, 
choose Object and Autodesk DWF 
Viewer Control, then right-click and 
select Autodesk DWF Viewer Control 
Object and then Properties to embed 
an interactive DWF.

Note: To view the document, the user must 
have Autodesk DWF Viewer installed.
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Bonus Autodesk DWF Viewer Tips
1. Use the mouse wheel button to zoom 

in and out. To pan, hold the button 
down and move the mouse. 

2. Select Options in the Content Browser 
to show thumbnails, list views, or 
bookmarks of the original DWF data.

3. When rotating 3D objects, keep the 
triad at least slightly oblique to the 
screen to move or rotate. You cannot 
move or rotate the axis that points 
directly toward you.

Review & Mark Up
No more looking through faxes and 
emails to incorporate feedback by 
hand. With Autodesk DWF Composer 
software, team members can review, 
measure, and mark up designs, and then 
round-trip redlines and changes back 
to the original design application. All 
changes are automatically tracked and 
kept in the context of the design.

Post Files to Autodesk Buzzsaw
Autodesk DWF Viewer and Autodesk 
DWF Composer are fully integrated into 
the Autodesk® Buzzsaw® collaborative 
project management solution. 

Follow these steps to efficiently share 
your designs:

1. Drag DWF files into the project folder.

2. Notify the project team using the 
Buzzsaw notification system. Updates 
and versions are automatically tracked.
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Color Code Reviews 
Use different markup colors to indicate 
different users.

1. Select from the 48 predefined colors 
or one of your own. 

2. Change the Text Color and Line Color 
on the main menu, and then click your 
chosen color.

Work with Advanced Redlines  
and Markups
Autodesk DWF Composer includes easy-
to-use shapes, text, freehand, stamp, and  
custom symbol tools in addition to 
markup tools.

Control Markup Shape 
Hold down the Shift key to constrain the 
range of movement when marking up 
drawings. 

1. To start again, press the Esc key and 
try again. 

2. To delete a markup, use the Selection 
tool and press Delete.
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Measure Accurately
The dimension tools with the AutoSnap™ 
feature help project team members  
determine lengths, polylines, and areas.

Snap to Endpoints 
Set the measure tools to snap to end-
points, midpoints, and lines for precision 
measurement of design elements in the 
DWF file. Click the Tools command, and 
turn on the Snap to Geometry feature.

Zoom In for Greater Accuracy 
To achieve greater accuracy, zoom in to 
the section of the drawing to which you 
are applying the starting and ending 
points of the dimension.

Save a New Markup View 
When you create a markup, the current 
view of the page is stored with that mark-
up. To change and automatically store a 
new view, pan and zoom to the desired 
view, and then move the markup slightly 
or modify it in some way. 



Drag and Drop 
Combine DWF files, raster images, and 
other project information into a single 
DWF file or send it out for review:

1. Drag and drop, or use File>Open to 
view and mark up many different types 
of image files, such as JPEG or GIF 
files. 

2. Drag a page or pages into an email  
or onto the desktop to create a new 
DWF file. 

 

Use Custom Symbols and Stamps
Use symbols to annotate and mark up 
information in the office or in the field.

Create Custom Symbol Catalog  
Publish the 2D drawings, images, or text 
to a DWF file using the Autodesk DWF 
Writer. In Autodesk DWF Composer, 
import this file into the symbol catalog.

1. From the toolbar, click the  
Stamps and Symbols button.

2. Select Import DWF as Symbol  
Catalog.

3. Browse for and select the DWF file 
that contains your symbols, and click 
Open or press Enter. 

Create Your Own Stamp 
Create custom annotations and stamps 
by double-clicking a stamp and typing to 
insert text, or highlight the text you want 
to change. 

Manage Your Project Information  
in One Place
Work with multiple document types in 
one multisheet DWF sheet set, combin-
ing images, sketches, project timelines, 
specifications, bills of materials, and 
other project information.

Capture Information with  
Snapshot Tool 
Add a snapshot to an existing DWF file, 
or create a new DWF file by adding one 
or more snapshots to a blank file. 

1. Click the Snapshot  
button.

2. Set up the subject of your screen shot.

3. Click the Capture button on  
the Snapshot window title bar.
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Advanced Tips
Take advantage of these advanced DWF 
tips from the experts.

Install Across Your Company
Install Autodesk DWF Viewer or  
Autodesk DWF Composer across your 
company easily, using command-line 
scripting and the Tarma installation 
software. 

Note: Detailed information about the 
Tarma installation software is available 
at www.tarma.com/support/index.htm#/
support/cmdline.htm.

1. DwfViewerSetup.exe /q: Perform a 
silent (quiet, unattended) installation. 
During silent installations, the Setup 
wizard is suppressed and the entire 
installation, registration, or uninstalla-
tion process is performed without user 
intervention. This feature is intended 
for unattended installations and 
removals.

2. DwfViewerSetup.exe /q2: Perform 
an invisible installation. In this mode, 
the entire installation, registration, or 
uninstallation process is performed 
without user intervention and with 
a completely hidden user interface. 
(Note, though, that the Setup process 
still appears in the Windows Task 
Manager’s list of running processes.)

Embed Autodesk DWF Viewer  
in HTML Documents
Autodesk DWF Viewer is available as an 
ActiveX® control that is embedded in 
Microsoft® Internet Explorer, providing a 
smooth installation of the free Autodesk 
DWF Viewer in web pages. 

1. Embed DWF files directly in web pages 
by using the <object> element tag.

2. Access an HTML sample that demon-
strates how to embed a DWF file at 
www.autodesk.com/dwf-developers 
and click on Code Samples.

Note: Microsoft Internet Explorer 5.01 or 
later is required.

Additional Resources

Visit the DWF Center

www.autodesk.com/dwf

Participate in the Discussion Groups
www.autodesk.com/dwfviewer-discussion 
www.autodesk.com/dwfcomposer-discussion 
www.autodesk.com/dwf-discussion

Get Free Downloads
www.autodesk.com/dwfviewer-download 
www.autodesk.com/dwfcomposer-trial  
www.autodesk.com/dwfwriter 

Purchase Autodesk DWF Composer 
www.autodesk.com/store 

Find Product Information
www.autodesk.com/dwfcomposer 
www.autodesk.com/dwfviewer 
www.autodesk.com/dwf-publishing

Find Developer Tools and Information
www.autodesk.com/dwf-developers 
www.autodesk.com/dwftoolkit 

Save DWF Files That You View
Follow these steps to save a local copy  
of a DWF file published to a website:

1. Right-click the DWF file and choose 
Save As. Alternatively, click the Save 
As button on the toolbar.  

2. To save a local copy of the DWF file 
you are viewing, specify a file name.

Use API to Customize and Extend 
Functionality
Use the Autodesk DWF Viewer and 
Autodesk DWF Composer application 
programming interface (API) documenta-
tion to integrate DWF Viewer or DWF 
Composer within websites or third- 
party applications. The documentation 
provides instruction on features such 
as navigation to a specific page or view, 
control over layer visibility, the ability to 
show and hide the toolbar and context 
menus, as well as control of the viewer 
behavior. Visit www.autodesk.com/
dwf-developers to download the API 
documentation.
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“ DWF is an intelligent design format,  
meaning that engineering data is not lost 
when drawings are converted from DWG. 
DWF allows us to zoom in on drawings with 
vector precision and view all the intelligence 
built into the files. DWF out-performs all the 
other available formats so drastically that 
there’s hardly a comparison between them.”

— Chas Thompson, Senior AutoCAD Support Engineer, 
Siemens Logistics and Assembly Systems Inc.

A
dv

an
ce

d 
Ti

ps
V

ie
w

 &
 P

ri
nt


