In This Exercise

This Skill Builder demonstrates how to create a tube and pipe iPart, publish it into a custom Tube & Pipe Library, create a style using published parts, and then create a pipe route.

This process consists of four distinct, yet closely related tasks. The success of each task is highly dependent on the successful completion of the previous one. For example, creating and publishing the iPart correctly is key to successfully searching for the parts you need in your custom style.

Create iParts for Publishing

The first step in creating a custom style is to create the parts that you need the style to include. By creating your own parts, you can, of course, ensure that you have the parts in the sizes and materials you need. Once you create the parts, you transform them into iPart factories, and then publish them into the Tube & Pipe Library.

The two types of iParts you can publish into the library are pipe iParts and fitting iParts. Pipe iParts include rigid pipe, bent tube, and flexible hose. Fitting iParts are any part types other than a pipe segment, such as elbows, couplings, and flanges.

Required Parameters for iPart Author

The number of parameters required for authoring an iPart depends on the type of the part you are publishing.

For pipe iParts, five parameters are required:

- Nominal Size (NS)
- Schedule Number (SN)
- Outside Diameter (OD)
- Inside Diameter (ID)
- Pipe Length (PL)

For fitting iParts, only Nominal Size (NS) is required, but other parameters are needed to fully define the part.
In the iPart Author parameter table, one parameter (usually NS) must be mapped to Nominal Size on the Tube & Pipe Publishing wizard. This parameter must use one of the three unit formats supported for Nominal Size:

- Integer or fractional number for inch iParts, such as “1/2,” “1,” “1 1/2”
- M40 for metric iParts
- 1/2-20 UNF for special threaded fittings

**Tip:** If you cannot remember the required parameters for authoring a specific iPart, click Tube & Pipe Publishing wizard on the Part Features panel bar, select Pipe or clear the check box, and then review the required parameters in the Parameter list that correspond to that part type on the Connections step.

**Pipe iPart**

This exercise provides guidelines on how to create 2 parts, and then transform parts into iPart factories that contain the parameters required for publishing. It is not intended to teach you everything about creating parts or iPart factories. For detailed instructions on how to create an iPart, refer to the Index entry “iParts, create factory” in Autodesk Inventor® Help.

1. To begin, create a base pipe part `pipe.ipt`.

   ![Pipe Sketch](image)

   Set the dimension of the inside circle to **0.364 inch** and the dimension of the outside circle to **0.540 inch** when sketching the base part.

   Extrude the sketch. The extrusion distance is not important. In this exercise, use a distance of **1.500 inch**.

2. Click Parameters on the Part Features Panel Bar to create User Parameters and map them to the appropriate Model Parameters.
Click Add, and then enter **ID (0.364 inch)**, **OD (0.540 inch)**, and **PL (1.500 inch)**.

Set the model parameter equations using **ID**, **OD**, and **PL**, and then click Done.

3. Add a chamfer with a distance of **OD/50 ul** at both outer circular edges of the part, or simply use the equation of **OD/50**.

4. Click Parameters on the Part Features Panel Bar, and then verify that the chamfer parameter is added into the Model Parameters table.
At this point, we’ve created the base part. The model parameter equations we have set will preserve the model ratio when different instances are selected. Next, we’ll transform the pipe to an iPart factory.

5. Click Tools > Create iPart to transform the pipe to an iPart.

6. In the iPart Author dialog box, verify that the ID, OD, and PL user parameters are already in the first row.

7. Click the Other tab, and then click the first row in the upper-right field. Add NS in the Name field, and then add (1/4) in the NS value field. The NS parameter is automatically selected into the parameter table.

8. Click the second row in the upper-right field, and then add SN with a value of (40).

9. Add parameters for four more instances of the pipe. In this case, right-click Table on the Model Browser, and then select Edit via Spread Sheet. With the spreadsheet we can quickly add the nominal diameters: 3/8, 1/2, 3/4, and 1.

<table>
<thead>
<tr>
<th>ID</th>
<th>OD</th>
<th>PL</th>
<th>NS</th>
<th>SN</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.364 in</td>
<td>0.540 in</td>
<td>1.500 in</td>
<td>1/4</td>
</tr>
<tr>
<td>2</td>
<td>0.540 in</td>
<td>0.675 in</td>
<td>1.500 in</td>
<td>3/8</td>
</tr>
<tr>
<td>3</td>
<td>0.622 in</td>
<td>0.840 in</td>
<td>1.500 in</td>
<td>1/2</td>
</tr>
<tr>
<td>4</td>
<td>0.824 in</td>
<td>1.050 in</td>
<td>1.500 in</td>
<td>3/4</td>
</tr>
<tr>
<td>5</td>
<td>1.049 in</td>
<td>1.315 in</td>
<td>1.500 in</td>
<td>1</td>
</tr>
</tbody>
</table>
Close **Worksheet in pipe.ipt**. The iPart Author parameter table should now be the same as shown.

<table>
<thead>
<tr>
<th>ID</th>
<th>OD</th>
<th>PL</th>
<th>NS</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.344 in</td>
<td>0.549 in</td>
<td>1,500 in</td>
</tr>
<tr>
<td>2</td>
<td>0.344 in</td>
<td>0.549 in</td>
<td>1,500 in</td>
</tr>
<tr>
<td>3</td>
<td>0.344 in</td>
<td>0.549 in</td>
<td>1,500 in</td>
</tr>
<tr>
<td>4</td>
<td>0.344 in</td>
<td>0.549 in</td>
<td>1,500 in</td>
</tr>
<tr>
<td>5</td>
<td>0.344 in</td>
<td>0.549 in</td>
<td>1,500 in</td>
</tr>
</tbody>
</table>

The first row is highlighted as the default. The default row determines the library part that displays when you open a part page in the Tube & Pipe Library. To change the default row, right-click the appropriate row number, such as 2, and then select **Set As Default Row**. For this exercise, make sure that the first row is the default row.

**Note:** You can also directly add parameters in the iPart Author dialog box. Right-click one row, and then select Insert Row.

10. Right-click **NS** in the parameter table, and then select **Key > 1** to set NS as the primary key.

11. Set **OD** as the secondary key.

**Note:** You can also set the parameter keys in the upper-right field.

The following illustration shows the relationship between the default row and keys in the iPart Author table and the corresponding part page in the Tube & Pipe Library.

12. Select File > Save or press Ctrl + S to save your changes.
Next we’ll create a single elbow part and transform it to an iPart. Because the style we will create later only uses 90-degree elbows, a 45-degree elbow is not required.

1. Create a base 90-degree elbow part **90LongElbow.ipt**.

   Set the dimension of the inside circle to **0.540 inch** and the dimension of the outside circle to **0.662 inch** when sketching the base part.

   Sweep the section along an arc. The radius of the arc is not important. For this exercise, use a radius of **0.500 inch**.

2. Click Parameters and map the User Parameters and Model Parameters.
Click Add, and then enter **ID (0.540 inch)**, **OD (0.622 inch)**, and **G (0.500 inch)**.

Set the model parameter equations using **ID**, **OD**, and **G**, and then click Done.

3. Add an extrusion with a distance of **ID/3 ul** at both ends of the part, or use the equation of **ID/3**.

4. Add a chamfer with a distance of **OD/50 ul** at both outer circular edges of the part, or simply use the equation of **OD/50**.

5. Click Parameters on the Part Features Panel Bar, and then verify that the extrusion and chamfer parameters are added into the Model Parameters table.
The elbow base part is now created with parameter equations that will preserve the model ratio when different instances are selected. Now we will transform the elbow to an iPart.

6. Click Tools > Create iPart.

7. In the iPart Author dialog box, verify that the ID, OD, and G are already in the first row:

8. On the Other tab, add NS with a value of (1/4).
9. Add parameters for four more instances of the elbow with nominal diameters: 3/8, 1/2, 3/4, and 1.

<table>
<thead>
<tr>
<th>ID</th>
<th>OD</th>
<th>G</th>
<th>NS</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.540 in</td>
<td>0.622 in</td>
<td>0.500 in</td>
</tr>
<tr>
<td>2</td>
<td>0.675 in</td>
<td>0.824 in</td>
<td>0.750 in</td>
</tr>
<tr>
<td>3</td>
<td>0.840 in</td>
<td>1.049 in</td>
<td>1.000 in</td>
</tr>
<tr>
<td>4</td>
<td>1.050 in</td>
<td>1.380 in</td>
<td>1.500 in</td>
</tr>
<tr>
<td>5</td>
<td>1.315 in</td>
<td>1.660 in</td>
<td>2.000 in</td>
</tr>
</tbody>
</table>

10. Close Worksheet in 90LongElbow.ipt. The iPart Author parameter table should now be the same as shown.

<table>
<thead>
<tr>
<th>ID</th>
<th>OD</th>
<th>G</th>
<th>NS</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.540 in</td>
<td>0.622 in</td>
<td>0.500 in</td>
</tr>
<tr>
<td>2</td>
<td>0.675 in</td>
<td>0.824 in</td>
<td>0.750 in</td>
</tr>
<tr>
<td>3</td>
<td>0.840 in</td>
<td>1.049 in</td>
<td>1.000 in</td>
</tr>
<tr>
<td>4</td>
<td>1.050 in</td>
<td>1.380 in</td>
<td>1.500 in</td>
</tr>
<tr>
<td>5</td>
<td>1.315 in</td>
<td>1.660 in</td>
<td>2.000 in</td>
</tr>
</tbody>
</table>

11. Set NS as the primary key and ID as the secondary key.

12. Save your changes.

**Tip:** You can also add existing iMates, work features, and threads as iPart parameters when authoring an iPart.
To take advantage of the Tube & Pipe Library functionality, such as queries and dropping fittings, you must add the iPart to the Tube & Pipe library. Custom iParts cannot be published into the read-only libraries that are supplied by the system, so we must create a custom tube and pipe library. There are two ways to add a custom library: through the Tube & Pipe Library Browser Bar or when publishing an iPart.

In this exercise, we will create a custom Read/Write library using the Tube & Pipe Library Browser Bar.

1. Open a tube and pipe assembly or a top-level assembly that contains tube and pipe runs. Select Tube & Pipe Library from the Browser Bar, and then click Configure.

2. Click Add.

3. Click Browse to open the Select Library File dialog box, and then:

   Navigate to the Content Library directory `Program Files\Autodesk\Inventor Professional <version>\Content`.

   Create a new library folder, for example, Custom ANSI.

   Enter Custom_ANSI in the File name field, and leave Files of type as is. Make sure that Open as read-only is not selected, and then click Open.

   Click Yes to create this new library file when Inventor prompts that this MDB file does not exist.
4. In the Add Library File dialog box, enter **Custom ANSI** in the Name for this library field. This is the name that is displayed on the Tube & Pipe Library browser.

5. Leave the default local storage location as is, and then click Save.

6. In the Configure Library dialog box, click Done.

**Tip:** It is recommended that you save the custom library in the default Content Center instead of your workspace. Custom parts in the Content Center can be shared in multiple projects so you do not need to save the same custom parts for each project workspace.
Publish an iPart

When you publish an iPart, you use the Tube & Pipe Publishing wizard to specify the connection information, define the part information used in manufacturing, and determine where in the library structure to place the part.

Publish a Pipe iPart

In this exercise, we will set the connection geometry and part definition for the pipe iPart, and then publish it into the previously created custom library.

Set the connection type and connection number

In the Start step, specify the number of the connections on the part being published. You can publish parts with up to 10 connections.

1. Open the pipe iPart **pipe.ipt**.
2. Click Tube & Pipe Publishing wizard on the Part Features panel bar.

The Tube & Pipe Publishing wizard is displayed.

3. Select the Pipe check box.

The number of connection points for the pipe iPart defaults to 2.

4. Click Next to go to the Connections step.
Set the connection geometry

In the Connections step, we’ll click a Connection Number and set the appropriate connection geometry for each connection point of the part. The connection number changes from red to black once all required connection criteria are set.

1. Make sure that Connection Number 1 is selected.

2. Select **Welded** from the End Treatment list.

   End Treatment indicates the way in which the pipe part connects to adjacent fittings when it is dropped into the tube and pipe assembly.

3. Map the parameters in the pipe iPart Author table to the Parameter list of the pipe part.

   The Parameter list represents the attributes for the published part and it determines the controlling parameters for styles. The Table Mapping list represents the attributes for the pipe iPart. Five options within the list are the same as the parameters on the Parameters tab of the iPart Author dialog box. If the name of any iPart Author parameter changes, the Table Mapping list automatically updates.

   Parameter and table mapping are always selected as a pair. Select Parameter, and then select Table Mapping. All parameters in the lists must be mapped correctly.

   Select **NS** in the Table Mapping list for **Nominal Size** from the Parameter list.

   Select **SN** for **Schedule Number**.
Select ID for Inside Diameter.
Select OD for Outside Diameter.
Select PL for Pipe Length.

4. Define the connection point and connection axis as follows:

Click the Connection Point tool, pause the cursor over the geometry until the circular edge is highlighted as shown, and then click to set the connection point. The center of the circular edge is the connected point.

Click the Connection Axis tool, pause the cursor over the geometry until the same circular edge is highlighted, and then click to set the connection axis.

The connection direction must point toward the engaging fitting, so it may sometimes point away from the part. For this exercise, click Flip Connection if the axis direction points toward the inside of the pipe.

Clear the Female check box.

5. Specify the Engagement parameters.

Engagement is enabled until both Connection Point and Connection Axis are set. The engagement parameters specify the minimum engagement position and maximum engagement position that determine how far a pipe is inserted into the specified fitting. The available engagement distance for the fitting is the difference between Max and Min.

Note: For pipe parts, when connecting to the adjacent fittings, the connection only applies to the engagement definition of the adjacent fittings by default. Because any engagement parameters specified for a pipe iPart default to be ignored for the connection to the adjacent fittings, it is recommended that you set a fixed value 0 in such cases.

Select Fixed.

Enter 0 in the Max inch field.

Enter 0 in the Min % of Max field.
6. Follow the previous steps to configure Connection Number 2. Verify that the end treatment is correct and the parameters are already mapped.

The connection point and connection axis for Connection Number 2 should be the same as the following illustration. The engagement value is fixed to 0 for the pipe part.

ISOGEN Properties are not enabled when publishing a pipe iPart. They are enabled and optional when publishing a non-pipe iPart, such as an elbow.

7. Verify that the end treatment is correct, and notice how the mapping relationship is inherited from Connection 1. You do not need to remap the parameters unless they are different from connection 1.

8. Follow the previous step to configure Connection Number 2.

9. Click Next to go to the Part Definition step.

**Set the part definition**

In the Part Definition step, we will set the family name, description, and standard for the pipe iPart, and then specify a custom library in which the pipe iPart is published.

1. In the Part Definition step, set the Naming parameters.

Enter **ASTM A 53/A 53M_MalePipe** in the Family Name field.
Enter **Custom Welded Male Pipe** in the Description field.

2. Set the Standard parameters.

Multiple styles can be used in a single tube and pipe run and different styles may use different standards, so the standard you select is important if you plan to use a differing standard part in a style.

In particular, it is the standard specification that is most important. If you publish a pipe using the specification **ASTM A 53/A 53M** and want to use the part for defining a new style, you need to set Pipe Standard to **ASTM A 53/A 53M** in the Tube & Pipe Styles dialog box; otherwise, the system cannot filter for the part.

Select **ANSI** from the Standard Organization list. Enter a new standard organization if it does not exist in the list.

Enter **XYZ** in the Manufacturer field.

Select **ASTM A 53/A 53M** from the Specification list. Enter the information if it does not exist in the list.

Leave Spec. Revision as it is.

**Note:** Once published, the standard specification is available in the lists in the Tube & Pipe Styles dialog box when configuring tube and pipe styles. The part materials are available when the appropriate standard specification is selected.

3. Select the custom content library and specify a category for the pipe part. In this exercise, we will select the **Custom ANSI** library we created earlier from the Content Library list.

**Note:** You can also create custom libraries by clicking Configure under Content Library and providing the required information.

4. Right-click the library name in the Type field, select New Category, and then enter **Pipe** in the Name field.

Select **Pipe** to determine where to publish the pipe part. The new category is checked by default.
5. Select **Designation** from the Content Library > Type > Parameter list, and then select **NS** from the Table Mapping list.

6. Specify additional parameters and map them to the Table Mapping list as appropriate.

7. Click Next to go to the Publish step.

**Save the part file**

It is recommended that you save the iPart file in your workspace before publishing it. By saving the iPart file, you do not have to enter all the iPart data again if you need to edit and republish the part at a later time. Once saved, you can also insert the part into an open assembly using Place Component on the Assembly Panel Bar.

In the Publish step, we will review the image and summary information and save the part as recommended before publishing it to the library.

1. Review the image and summary information.

2. Click Save.

   Navigate to the appropriate directory in your workspace in the Save As dialog box. For example, create a **Backup** folder under your workspace.

   Leave Options as is.

   Enter **pipe_back**up in the File name field.

3. Click Save.

   The part is saved in your workspace.

   Now that the required connection geometry and the part definition information is specified and verified, and the part is saved, we can publish the pipe part into the custom library.

4. Click Publish.
5. In the Publish Complete dialog box, Click OK.

The published part is now available in the Tube & Pipe Library.

With a tube and pipe assembly open, you can now open the Tube & Pipe Library and browse to Custom ANSI > Pipe > ASTM A 53/A 53M_MalePipe to see the pipe we just published. Next, we'll publish the elbow.

**Publish an Elbow iPart**

1. Open 90LongElbow.ipt.

2. Click Tube & Pipe Publishing Wizard on the Part Features panel bar.

3. Clear the Pipe check box, and specify 2 as the number of connection points.

4. Click Next, and then click Connection Number 1 if not selected.

5. Set the connection geometry.

   Select **Welded** from the End Treatment list.

   Map **NS** in the Table Mapping list to **Nominal Size**, the only required parameter in the Parameter list.

   Set the Connection Point and Connection Axis as shown in the following illustration.

   ![Connection Point and Connection Axis](image)

   Select Female.

   Set the engagement information. Clear the Fixed check box, and enter **80%** and **50%** in the Max % of NS field and Min % of Max fields.

   **Note:** When setting engagement, keep in mind that the engagement must be greater than the Increment Size on the Tube & Pipe Style dialog box. If the engagement value is too small, the pipe end might not be able to adjust to fall within the minimum engagement and maximum engagement. For example, if the Increment Size is 5mm, the engagement distance is 1mm, and a pipe is 999mm that is 1mm short for the adjacent fitting. Incrementing the pipe to 1004mm will over-engage 3mm with the fitting.

   Select ISOGEN Properties only if you plan to generate the elbow part in the ISOGEN output. For example, you could select ELBOW from the Type List and ELBW from the SKEY list.

6. Follow the previous steps to configure Connection Number 2.
7. Click Next, and then set the part library definition.

Enter **ANSI_ASME_B16.1_Female90LongElbow** in the Family Name field.

Enter **Custom Welded Female Elbow** in the Description field.

Select **ANSI** from the Standard Organization list.

Enter **ABC** in the Manufacturer field.

Select **ANSI/ASME B16.1** from the Specification list.

Leave Spec. Revision as is.

Select **Custom ANSI** from the Content Library list, add a new category **Elbow**, and make sure it is selected in the Type list.

Map **Designation** in the Content Library > Type > Parameter... list to **NS** in the Table Mapping list.

8. Click Next.

9. Review the image and summary information.
10. Click Save to save the elbow part file into your workspace > Backup directory. Name the elbow part file 90LongElbow_backup.ipt.

11. Click Publish.

12. In the Publish Complete dialog box, click OK.

Now that the parts are successfully published, we can use the parts to create a custom style.

Republish an iPart

If the base part related to an iPart must be modified in any way, you must change the base part, and then create and publish a relevant iPart into the Tube & Pipe Library.
Create a New Tube and Pipe Style Using Published Parts

When defining a style, you are essentially searching for pipe and fittings that will make up a pipe run. You are also establishing certain rules to be followed while creating routes. Use the Tube & Pipe Styles dialog box to first define the search criteria, and then search for the components based on the criteria.

The number of published parts required by a style depends on the type of style you are creating.

- When creating rigid pipe styles, for example, a minimum of three compatible parts are required: a pipe, a coupling, and an elbow. If you require both 45-degree and 90-degree elbows, four parts are required. The welded tube and pipe style needs a minimum of two part types: a pipe and an elbow.
- For bent tubing styles, at least one pipe part (tube segment) must be published for a tube route.
- For flexible hose styles, it depends on whether or not the start fitting and end fitting are required for the hose, but at least one hose part (hose segment) must be published.

In this exercise, we will set the Tutorial Files folder as your workspace and create a welded Rigid Pipe with Fittings style using the published pipe and elbow parts. Only 2 parts are required by this style, since it is a welded style with 90-degree elbows only. No couplings or 45-degree elbows are needed.

1. Set your workspace as Program Files\Autodesk\Inventor Professional \version\Tube & Pipe\Tutorial Files.

2. Open AirSystemAssy.iam.

3. Click Create Pipe Run on the Assembly Panel Bar leave the default tube and pipe assembly name and file location as they are, and then click OK.
The first pipe run **Pipe Run 1** is created and activated automatically.

4. Click Tube & Pipe Styles on the Assembly Panel Bar.

5. Click New on the Tube & Pipe Styles dialog box.


7. On the General tab, set the following parameters:
   - **Route Type:** Rigid Pipe with Fittings
   - **Pipe Material:** *, Standard: **ASTM A 53/A 53M**
   - **Fitting Material:** *, Standard: **ANSI/ASME B16.1**
   - **Route Direction:** 90°
   
   **Note:** Leave Material as * (asterisk) when you do not know the specific material or plan to search out all the compatible pipes or fittings based on other criteria. The default material is used when the pipe route of interest is populated.

8. On the Size tab, set the following parameters:
   - **Nominal Diameter:** 1/4 in
   - **Schedule:** 40

9. On the Rules tab, set the following parameters:
   - **Segment Length Min:** 1.000 in
   - **Max:** 200.000 in
   - **Inc:** 0.100 in
   
   **Tip:** It is recommended that the minimum segment length is at least 1.5 times Nominal Diameter; otherwise, it is more likely to cause a minimum segment length violation if pipe segments are too small compared to Nominal Diameter.

10. On the Display tab, leave the default settings as they are.

11. On the Fittings tab, do the following:
   - Select **Pipe** from the Fitting Types list, click Browse to open the Library Browser > Custom ANSI > Pipe > ASTM A 53/A 53M_MalePipe.
Double-click the pipe part **ASTM A 53/A 53M_MalePipe 1/4**, and click OK. This is the pipe part we named in the Part Definition step of the Tube & Pipe Publishing Wizard.

Select **Elbow 90** from the Fitting Types list, click Browse to locate the Library Browser > Custom ANSI > Elbow > ANSI_ASME_B16_1_Female90LongElbow > ANSI_ASME_B16_1_Female90LongElbow 1/4.

12. Click Save.

The new style **ASTM A53/A53M-ANSI/ASME B16.1 - Custom Welded Pipe** is created and available for creating new rigid pipe routes.
Create a Rigid Pipe Route Using the New Style

In this exercise, we'll use the new style to create a rigid pipe route in AirSystemAssy.iam.

1. Activate the previously created pipe run Pipe Run 1 in the Tube & Pipe Runs subassembly.

2. Click the Active Style tool on the standard toolbar and verify that ASTM A53/A53M-ANSI/ASME B16.1 - Custom Welded Pipe is selected.

3. Click New Route on the Tube & Pipe Panel Bar.

   The first pipe route Pipe Route 1 is created.

4. Click Route on the Route Panel Bar.

5. In the graphics window, select the following geometry to start the route. Press the spacebar to change the direction of the line extender if needed.

6. Select the second geometry, and then click the green check mark to set the route node.

7. Select the third geometry as shown in the illustration. When clicking the green check mark, you may fail to place the fitting or bend.
Move the lowest horizontal segment upward if needed.

Press Esc, or right-click the graphics window, and then select Done.

Select Move Segment on the Route panel bar, and move the following segment upward as shown in the illustration.

Press Esc, or right-click the graphics window, and then select Done.

8. Right-click the last work point under the pipe route, Work Point7, and select Route.

   The Route tool is active again.

9. Select the same geometry as Step 7, and click the green check mark to set the final route node.

10. Press Esc, or right-click the graphics window, and then select Done.

11. Right-click the graphics window, and then select Finish Edit.
If needed, double-click **Pipe Run 1** in the Model Browser Bar, and then select Rendered Display in the Display Settings list on the standard toolbar.

The custom tube and pipe style was applied to the pipe route as it was being created. It used the pipe and the 90-degree elbow that we published into the Tube & Pipe Library. You can now populate the route to view the route with the actual pipe and elbow components.

At this point, you have:

- defined iParts
- created a custom library
- published the iPart
- defined a custom style
- used the style to create a run

By completing this lengthy process, you now have an understanding of the complete publishing workflow and can see how each step is critical to ensuring the successful outcome of the next.